User’s Guide

Real-Time C Debugger for Intel80386EX
Notice

Hewlett-Packard makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Hewlett-Packard shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Hewlett-Packard assumes no responsibility for the use or reliability of its software on equipment that is not furnished by Hewlett-Packard.


This document contains proprietary information, which is protected by copyright. All rights are reserved. No part of this document may be photocopied, reproduced or translated to another language without the prior written consent of Hewlett-Packard Company. The information contained in this document is subject to change without notice.

Intel386, Intel80386, Intel486, and Intel80486 are U.S. trademarks of Intel Corporation.

MS-DOS(R) is a registered trademark of Microsoft Corporation.

HP-UX 9.* and 10.0 for HP 9000 Series 700 and 800 computers are X/Open Company UNIX 93 branded products.

TrueType(TM) is a U.S. trademark of Apple Computer, Inc.

UNIX(R) is a registered trademark in the United States and other countries, licensed exclusively through X/Open Company Limited.

Windows or MS Windows is a U.S. trademark of Microsoft Corporation.

Hewlett-Packard
P.O. Box 2197
1900 Garden of the Gods Road
Colorado Springs, CO 80901-2197, U.S.A.

RESTRICTED RIGHTS LEGEND Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraph (c) (1)(ii) of the Rights in Technical Data and Computer Software Clause at DFARS 252.227-7013. Hewlett-Packard Company, 3000 Hanover Street, Palo
Printing History

New editions are complete revisions of the manual. The date on the title page changes only when a new edition is published.

A software code may be printed before the date; this indicates the version level of the software product at the time the manual was issued. Many product updates and fixes do not require manual changes, and manual corrections may be done without accompanying product changes. Therefore, do not expect a one-to-one correspondence between product updates and manual revisions.

Edition 1  B3637-97002, November 1995


Safety, Certification and Warranty

Safety and certification and warranty information can be found at the end of this manual on the pages before the back cover.
Real-Time C Debugger — Overview

The Real-Time C Debugger is an MS Windows application that lets you debug C language programs for embedded microprocessor systems.

The debugger controls HP 64700 emulators and analyzers either on the local area network (LAN) or connected to a personal computer with an RS-232C interface or the HP 64037 RS-422 interface. It takes full advantage of the emulator's real-time capabilities to allow effective debug of C programs while running in real time.

The debugger is an MS Windows application
- You can display different types of debugger information in different windows, just as you display other windows in MS Windows applications.
- You can complete a wide variety of debug-related tasks without exiting the debugger. You can, for example, edit files or compile your programs without exiting the debugger.
- You can cut text from the debugger windows to the clipboard, and clipboard contents may be pasted into other windows or dialog boxes.

The debugger communicates at high speeds
- You can use the HP 64700 LAN connection or the RS-422 connection for high-speed data transfer (including program download). These connections give you an efficient debugging environment.

You can debug programs in C context
- You can display C language source files (optionally with intermixed assembly language code).
- You can display program symbols.
- You can display the stack backtrace.
- You can display and edit the contents of program variables.
- You can step through programs, either by source lines or assembly language instructions.
- You can step over functions.
- You can run programs until the current function returns.
- You can run programs up to a particular source line or assembly language instruction.
• You can set breakpoints in the program and define macros (which are
collections of debugger commands) that execute when the breakpoint is
hit. Break macros provide for effective debugging without repeated
command entry.

You can display and modify processor resources
• You can display and edit the contents of memory locations in
hexadecimal or as C variables.
• You can display and edit the contents of microprocessor registers
including on-chip peripheral registers.
• You can display and modify individual bits and fields of bit-oriented
registers.

You can trace program execution
• You can trace control flow at the C function level.
• You can trace the callers of a function.
• You can trace control flow within a function at the C statement level.
• You can trace all C statements that access a variable.
• You can trace before, and break program execution on, a C variable being
set to a specified value.
• You can make custom trace specifications.

You can debug your program while it runs continuously at full speed
• You can configure the debugger to prevent it from automatically
initiating any action that may interrupt user program execution. This
ensures that the user program executes in real time, so you can debug
your design while it runs in a real-world operating mode.
• You can inspect and modify C variables and data structures without
interrupting execution.
• You can set and clear breakpoints without interrupting execution.
• You can perform all logic analysis functions, observing C program and
variable activity, without interrupting program execution.
In This Book

This book documents the Real-Time C Debugger for Intel80386EX. It is organized into five parts whose chapters are described below.

Part 1. Quick Start Guide
   Chapter 1 quickly shows you how to use the debugger.

Part 2. User’s Guide
   Chapter 2 shows you how to use the debugger interface.
   Chapter 3 shows you how to plug the emulator into target systems.
   Chapter 4 shows you how to configure the emulator.
   Chapter 5 shows how to perform the tasks that you can use to debug programs.

Part 3. Reference
   Chapter 6 contains a summary of the debugger commands as they are used in command files and break macros.
   Chapter 7 describes the format for expressions used in commands.
   Chapter 8 describes commands that appear in the menu bar.
   Chapter 9 describes commands that appear in debugger window control menus.
   Chapter 10 describes commands that appear in popup menus.
   Chapter 11 describes commands that are only available in command files and break macros.
   Chapter 12 describes error messages and provides recovery information.

Part 4. Concept Guide
   Chapter 13 contains conceptual (and more detailed) information on various topics.

Part 5. Installation Guide
   Chapter 14 shows you how to install the debugger.
   Chapter 15 shows you how to install or update HP 64700 firmware.
Contents

Part 1 Quick Start Guide

1 Getting Started

Step 1. Start the debugger  5
Step 2. Adjust the fonts and window size  6
Step 3. Map memory for the demo program  7
Step 4. Set address translations for the demo program  9
Step 5. Load the demo program  10
Step 6. Display the source file  11
Step 7. Set a breakpoint  12
Step 8. Run the demo program  13
Step 9. Delete the breakpoint  14
Step 10. Single-step one line  14
Step 11. Single-step 10 lines  15
Step 12. Display a variable  16
Step 13. Edit a variable  17
Step 14. Monitor a variable in the WatchPoint window  18
Step 15. Run until return from current function  19
Step 16. Step over a function  19
Step 17. Run the program to a specified line  20
Step 18. Display register contents  21
Step 19. Trace a function’s callers  23
Step 20. Trace access to a variable  24
Step 21. Exit the debugger  25
Part 2  User’s Guide

2  Using the Debugger Interface

How the Debugger Uses the Clipboard  31
Debugger Function Key Definitions  32
Starting and Exiting the Debugger  33
To start the debugger  33
To exit the debugger  34
To create an icon for a different emulator  34

Working with Debugger Windows  36
To open debugger windows  36
To copy window contents to the list file  37
To change the list file destination  37
To change the debugger window fonts  38
To set tab stops in the Source window  38
To set colors in the Source window  39

Using Command Files  40
To create a command file  40
To execute a command file  41
To create buttons that execute command files  42

3  Plugging the Emulator into Target Systems

Plugging the Emulator into Target Systems  44
Step 1. Turn OFF power  45
Step 2. Unplug the probe from the demo target system  45
Step 3. Plug the probe into the target system  46
Step 4. Connect the reset flying lead to the target system  47
Step 5. Turn ON power  48
4 Configuring the Emulator

Configuring the Emulator  50

Setting the Hardware Options  51
To specify a CLK2 speed faster than 42 MHz  52
To enable or disable target interrupts  53
To enable or disable software breakpoints  54
To enable or disable break on writes to ROM  55
To enable or disable execution trace messages  56
To enable or disable foreground monitor traced as user  57

Selecting the Type of Monitor  58
To select the background monitor  58
To select the foreground monitor  59
To use a custom foreground monitor  60

Mapping Memory  62
To map memory  64

Selecting Address Translations  66
When address translations occur  66
Implications of address translation options  66
Performance of address translation caching  67

Setting Up the BNC Port  68
To output the trigger signal on the BNC port  68
To receive an arm condition input on the BNC port  68

Saving and Loading Configurations  69
To save the current emulator configuration  69
To load an emulator configuration  70

Setting the Real-Time Options  71
To allow or deny monitor intrusion  72
To turn polling ON or OFF  73
5 Debugging Programs

Debugging Programs 76

Loading and Displaying Programs  77
To load user programs  77
To display source code only  78
To display source code mixed with assembly instructions  78
To display source files by their names  79
To specify source file directories  80
To search for function names in the source files  81
To search for addresses in the source files  81
To search for strings in the source files  82

Displaying Symbol Information  83
To display program module information  84
To display function information  84
To display external symbol information  85
To display local symbol information  86
To display global assembler symbol information  87
To display local assembler symbol information  87
To create a user-defined symbol  88
To display user-defined symbol information  89
To delete a user-defined symbol  89
To display the symbols containing the specified string  90

Stepping, Running, and Stopping the Program  91
To step a single line or instruction  91
To step over a function  92
To step multiple lines or instructions  93
To run the program until the specified line  94
To run the program until the current function return  94
To run the program from a specified address  95
To stop program execution  96
To reset the processor  96
Using Breakpoints and Break Macros   97
To set a breakpoint   98
To disable a breakpoint   99
To delete a single breakpoint   99
To list the breakpoints and break macros   100
To set a break macro   100
To delete a single break macro   103
To delete all breakpoints and break macros   103

Displaying and Editing Variables   104
To display a variable   104
To edit a variable   105
To monitor a variable in the WatchPoint window   106

Displaying and Editing Memory   107
To display memory   107
To edit memory   109
To copy memory to a different location   110
To copy target system memory into emulation memory   111
To modify a range of memory with a value   112
To search memory for a value or string   113

Displaying and Editing GDT, LDT, and IDT Windows   114
To display the GDT, LDT, and IDT windows   114
To edit the GDT, LDT, and IDT windows   115

Displaying and Editing I/O Locations   116
To display I/O locations   116
To edit an I/O location   117

Displaying and Editing Registers   118
To display registers   118
To edit registers   120
Tracing Program Execution 121
To trace callers of a specified function 124
To trace execution within a specified function 126
To trace accesses to a specified variable 127
To trace until the command is halted 128
To stop a running trace 128
To repeat the last trace 128
To display bus cycles 129
To display absolute or relative counts 130
To display or suppress unexecuted prefetches 130
To swap instruction bytes in display of data-bus values 131

Setting Up Custom Trace Specifications 132
To set up a "Trigger Store" trace specification 133
To set up a "Find Then Trigger" trace specification 136
To set up a "Sequence" trace specification 141
To edit a trace specification 145
To trace "windows" of program execution 145
To store the current trace specification 147
To load a stored trace specification 148
# Part 3 Reference

## 6 Command File and Macro Command Summary

- Command File and Macro Command Summary 152
- WAIT Command Dialog Box 158

## 7 Expressions in Commands

- Numeric Constants 161
- Symbols 162
- C Operators 165

## 8 Menu Bar Commands

Menu Bar Commands 168
- File→Load Object... (ALT, F, L) 170
- File→Command Log→Log File Name... (ALT, F, C, N) 172
- File→Command Log→Logging ON (ALT, F, C, O) 173
- File→Command Log→Logging OFF (ALT, F, C, F) 174
- File→Run Cmd File... (ALT, F, R) 175
- File→Load Debug... (ALT, F, D) 177
- File→Save Debug... (ALT, F, S) 178
- File→Load Emulator Config... (ALT, F, E) 179
- File→Save Emulator Config... (ALT, F, V) 180
- File→Copy Destination... (ALT, F, P) 181
- File→Exit (ALT, F, X) 182
- File→Exit HW Locked (ALT, F, H) 183
- File Selection Dialog Boxes 184
- Execution→Run (F5), (ALT, E, U) 185
- Execution→Run to Cursor (ALT, E, C) 186
- Execution→Run to Caller (ALT, E, T) 187
- Execution→Run... (ALT, E, R) 188
- Execution→Single Step (F2), (ALT, E, N) 190
- Execution→Step Over (F3), (ALT, E, O) 191
- Execution→Step... (ALT, E, S) 192
- Execution→Break (F4), (ALT, E, B) 196
- Execution→Reset (ALT, E, E) 197
Contents

Breakpoint→Set at Cursor (ALT, B, S) 198
Breakpoint→Delete at Cursor (ALT, B, D) 200
Breakpoint→Set Macro... (ALT, B, M) 201
Breakpoint→Delete Macro (ALT, B, L) 207
Breakpoint→Edit... (ALT, B, E) 208
Variable→Edit... (ALT, V, E) 214
Variable Modify Dialog Box 216
Trace→Function Caller... (ALT, T, C) 217
Trace→Function Statement... (ALT, T, S) 219
Trace→Variable Access... (ALT, T, V) 221
Trace→Edit... (ALT, T, E) 223
Trace→Trigger Store... (ALT, T, T) 224
Trace→Find Then Trigger... (ALT, T, D) 227
Trace→Sequence... (ALT, T, Q) 231
Trace→Until Halt (ALT, T, U) 235
Trace→Halt (ALT, T, H) 236
Trace→Again (F7), (ALT, T, A) 237
Condition Dialog Boxes 238
Trace Pattern Dialog Box 241
Trace Range Dialog Box 243
Sequence Number Dialog Box 245
RealTime→Monitor Intrusion→Disallowed (ALT, R, T, D) 246
RealTime→Monitor Intrusion→Allowed (ALT, R, T, A) 247
RealTime→I/O Polling→ON (ALT, R, I, O) 248
RealTime→I/O Polling→OFF (ALT, R, I, F) 249
RealTime→Watchpoint Polling→ON (ALT, R, W, O) 250
RealTime→Watchpoint Polling→OFF (ALT, R, W, F) 251
RealTime→Memory Polling→ON (ALT, R, M, O) 252
RealTime→Memory Polling→OFF (ALT, R, M, F) 253
Settings→Emulator Config→Hardware... (ALT, S, E, H) 254
Settings→Emulator Config→Memory Map... (ALT, S, E, M) 257
Settings→Emulator Config→Monitor... (ALT, S, E, O) 261
Settings→Emulator Config→Address Translation... (ALT, S, E, A) 264
Settings→Communication... (ALT, S, C) 268
Settings→BNC→Outputs Analyzer Trigger (ALT, S, B, O) 271
Settings→BNC→Input to Analyzer Arm (ALT, S, B, I) 273
Settings→Font... (ALT, S, F) 274
Settings→Tabstops... (ALT, S, T) 275
Settings→Symbols→Case Sensitive→ON (ALT, S, S, C, O) 276
Settings→Symbols→Case Sensitive→OFF (ALT, S, S, C, F) 276
Settings→Extended→Trace Cycles→User (ALT, S, X, T, U) 277
Settings→Extended→Trace Cycles→Monitor (ALT, S, X, T, M) 277
Settings→Extended→Trace Cycles→Both (ALT, S, X, T, B) 278
Settings→Extended→Load Error Abort→ON (ALT, S, X, L, O) 279
Settings→Extended→Load Error Abort→OFF (ALT, S, X, L, F) 279
Settings→Extended→Source Path Query→ON (ALT, S, X, S, O) 280
Settings→Extended→Source Path Query→OFF (ALT, S, X, S, F) 280
Window→Cascade (ALT, W, C) 281
Window→Tile (ALT, W, T) 281
Window→Arrange Icons (ALT, W, A) 281
Window→1-9 (ALT, W, 1-9) 282
Window→More Windows... (ALT, W, M) 283
Help→About Debugger/Emulator... (ALT, H, D) 284
Source Directory Dialog Box 285

9 Window Control Menu Commands

Window Control Menu Commands 288
Common Control Menu Commands 289
Copy→Window (ALT, -, P, W) 289
Copy→Destination... (ALT, -, P, D) 290
Button Window Commands 291
Edit... (ALT, -, E) 291
Expression Window Commands 294
Clear (ALT, -, R) 294
Evaluate... (ALT, -, E) 295
I/O Window Commands 296
Define... (ALT, -, D) 296
Memory Window Commands 298
Display→Linear (ALT, -, D, L) 298
Display→Block (ALT, -, D, B) 299
Contents

Display→Byte (ALT, -, D, Y) 299
Display→16 Bit (ALT, -, D, 1) 299
Display→32 Bit (ALT, -, D, 3) 299
Search... (ALT, -, R) 300
Utilities→Copy... (ALT, -, U, C) 302
Utilities→Fill... (ALT, -, U, F) 303
Utilities→Image... (ALT, -, U, I) 304
Utilities→Load... (ALT, -, U, L) 306
Utilities→Store... (ALT, -, U, S) 307

GDT/LDT/IDT Window Commands 309
Search→Entry... (ALT, -, R, E) 309
Search→Selector... (ALT, -, R, S) 310

Register Windows’ Commands 313
Continuous Update (ALT, -, U) 313
Copy→Registers (ALT, -, P, R) 313
Register Bit Fields Dialog Box 314

Source Window Commands 316
Display→Mixed Mode (ALT, -, D, M) 316
Display→Source Only (ALT, -, D, S) 317
Display→Select Source... (ALT, -, D, L) 318
Search→String... (ALT, -, R, S) 319
Search→Function... (ALT, -, R, F) 320
Search→Address... (ALT, -, R, A) 322
Search→Current PC (ALT, -, R, C) 323
Search Directories Dialog Box 324

Symbol Window Commands 325
Display→Modules (ALT, -, D, M) 325
Display→Functions (ALT, -, D, F) 326
Display→Externals (ALT, -, D, E) 326
Display→Locals... (ALT, -, D, L) 327
Display→Asm Globals (ALT, -, D, G) 328
Display→Asm Locals... (ALT, -, D, A) 328
Display→User defined (ALT, -, D, U) 330
Copy→Window (ALT, -, P, W) 330
Copy→All (ALT, -, P, A) 331
FindString→String... (ALT, -, F, S) 331
User defined→Add... (ALT, -, U, A) 332
User defined→Delete (ALT, -, U, D) 334
User defined→Delete All (ALT, -, U, L) 334

Trace Window Commands 335
Display→Mixed Mode (ALT, -, D, M) 335
Display→Source Only (ALT, -, D, S) 336
Display→Bus Cycle Only (ALT, -, D, C) 336
Display→Count→Absolute (ALT, -, D, C, A) 337
Display→Count→Relative (ALT, -, D, C, R) 337
Trace Display→From State... (ALT, -, D, F) 338
Display→Options→Suppress Prefetch (ALT, -, D, O, S) 339
Display→Options→Swap Instruction Bytes (ALT, -, D, O, I) 340
Copy→Window (ALT, -, P, W) 340
Copy→All (ALT, -, P, A) 341
Search→Trigger (ALT, -, R, T) 341
Search→State... (ALT, -, R, S) 342
Trace Spec Copy→Specification (ALT, -, T, S) 343
Trace Spec Copy→Destination... (ALT, -, T, D) 343

WatchPoint Window Commands 344
Edit... (ALT, -, E) 344

10 Window Pop-Up Commands

BackTrace Window Pop-Up Commands 349
Source at Stack Level 349

Source Window Pop-Up Commands 350
Set Breakpoint 350
Clear Breakpoint 350
Evaluate It 350
Add to Watch 351
Run to Cursor 351
11 Other Command File and Macro Commands

BEEP 355
EXIT 356
FILE CHAINCMD 357
FILE RERUN 358
NOP 359
TERMCOM 360
WAIT 362

12 Error Messages

Error Messages 364
Bad RS-232 port name 365
Bad RS-422 card I/O address 365
Could not open initialization file 365
Could not write Memory 366
Error occurred while processing Object file 367
General RS-232 communications error 368
General RS-422 communications error 368
HP 64700 locked by another user 369
HP 64700 not responding 369
Incorrect DLL version 369
Incorrect LAN Address (HP-ARPA, Windows for Workgroups) 370
Incorrect LAN Address (Novell) 371
Incorrect LAN Address (WINSOCK) 371
Internal error in communications driver 372
Internal error in Windows 372
Interrupt execution (during run to caller) 372
Interrupt execution (during step) 373
Interrupt execution (during step over) 373
Invalid transport name 374
LAN buffer pool exhausted 374
LAN communications error 375
LAN MAXSENDSIZE is too small 375
LAN socket error 375
Logical to physical address translations initially unavailable: Cannot read
descriptor tables into host memory since GDT base and limit are
unavailable 376
Object file format ERROR 376
Out of DOS Memory for LAN buffer 377
Out of Windows timer resources 378
PC is out of RAM memory 378
physical address translation failed 379
Structure Access Warning!!! 380
Timed out during communications 381
Part 4 Concept Guide

13 Concepts

Concepts 386

Debugger Windows 387
The BackTrace Window 388
The Button Window 389
The Expression Window 390
The I/O Window 391
The Memory Window 393
The GDT Window 395
The LDT Window 397
The IDT Window 398
The Register Windows 399
The Source Window 400
The Status Window 403
The Symbol Window 406
The Trace Window 407
The WatchPoint Window 409

Monitor Program Options 410
Background monitor 411
Foreground monitor 411
Foreground monitor advantages and disadvantages 412

Trace Signals and Predefined Status Values 413

Understanding Intel80386EX Analysis 415

Understanding Address, Data, and Status 421

Entering Addresses as Constants 423
Overview of Intel80386EX address types 424
Explanation: why different syntax for different address types 425
Constant-address syntax 426
Contents

Understanding Incompletely Specified LDT Addresses  427

Unexpected Stepping Behavior  428
Faults  428
INT instructions  429
Task gates  429
To step into a task or a fault handler  429
Part 5 Installation Guide

14 Installing the Debugger

Requirements 435

Before Installing the Debugger 436

Step 1. Connect the HP 64700 to the PC 437
To connect via RS-232 437
To connect via LAN 440
To connect via RS-422 444
If you cannot verify RS-232 communication 445
If you cannot verify LAN communication 446

Step 2. Install the debugger software 447

Step 3. Start the debugger 450
If you have RS-232 connection problems 450
If you have LAN connection problems 453
If you have LAN DLL errors 454
If you have RS-422 connection problems 455

Step 4. Check the HP 64700 system firmware version 456

Optimizing PC Performance for the Debugger 457

15 Installing/Updating HP 64700 Firmware

Step 1. Connect the HP 64700 to the PC 461
Step 2. Install the firmware update utility 463
Step 3. Run PROGFLASH to update HP 64700 firmware 466
Step 4. Verify emulator performance 468

Glossary

Index
Part 1

Quick Start Guide

A few task instructions to help you get comfortable.
Part 1
Getting Started
Getting Started

This tutorial helps you get comfortable by showing you how to perform some measurements on a demo program. This tutorial shows you how to:

1. Start the debugger.
2. Adjust the fonts and window size.
3. Map memory for the demo program.
4. Set address translations for the demo program.
5. Load the demo program.
6. Display the source file.
7. Set a breakpoint.
8. Run the demo program.
9. Delete the breakpoint.
10. Single-step one line.
12. Display a variable.
13. Edit a variable.
14. Monitor a variable in the WatchPoint window.
15. Run until return from current function.
16. Step over a function.
17. Run the program to a specified line.
18. Display register contents.
19. Trace a function's callers.
20. Trace access to a variable.
21. Exit the debugger.

Demo Programs

Demo programs are included with the Real-Time C Debugger in the C:\HP\RTC\I386EX\DEMO directory (if C:\HP\RTC\I386EX was the installation path chosen when installing the debugger software).

Subdirectories exist for the SAMPLE demo program, which is a simple C program that does case conversion on a couple strings, and for the ECS demo program, which is a somewhat more complex C program for an environmental control system.

Each of these demo program directories contains a README file that describes the program and batch files that show you how the object files were made.
This tutorial shows you how to perform some measurements on the SAMPLE demo program.

---

**Step 1. Start the debugger**

1. Cycle power on the HP 64700-Series Card Cage to ensure that the emulator will be in its default state when you begin this tutorial. Wait a minute to allow time for the boot-up routine to complete.

2. Open the HP Real-Time C Debugger group box and double-click the I80386EX debugger icon.

   Or:

3. Choose the File→Run (ALT, F, R) command in the Windows Program Manager.

4. Enter the debugger startup command, `C:\HP\RTC\I386EX\B3637B.EXE` (if `C:\HP\RTC\I386EX` was the installation path chosen when installing the debugger software).

5. Choose the OK button.
Step 2. Adjust the fonts and window size

The first time RTC is used, a default window and font size is used. This may not be the best for your display. You may change the font type and size with the Settings→Font... command, and change the window size by using the standard Windows 3.1 methods (moving the mouse to the edge of the window and dragging the mouse to resize the window).

1 Choose the Settings→Font... (ALT, S, F) command.

2 Choose the Font, Font Style, and Size desired in the Font dialog box.

3 Choose the OK button to apply your selections, and close the Font dialog box.

The sizes of the RTC window, as well as the sizes of the windows within RTC, and the fonts used will be saved in the B3637B.INI file and reused when you enter RTC the next time.
Step 3. Map memory for the demo program

By default, the emulator assumes all memory addresses are in RAM space in your target system. If you wish to load some of your target program in emulation memory, or identify some of your memory addresses as ROM or Guarded, those specifications must be entered in the memory map.

The demo sample program occupies address ranges 00h-2fffh and 03ffff00h-03ffffffffh. Map these address ranges in emulation RAM memory.

1 Choose the Settings→Emulator Config→Memory Map... (ALT, S, E, M) command.

2 Enter "0" in the Start text box.

3 Tab the cursor to the End text box and enter "2fff".

4 Select "eram" in the Type option box.

5 Unselect Use target RDY and leave Use dual-ported memory unselected.

6 Choose the Apply button.
7 Enter "03ffff00" in the Start text box, enter "03ffffff" in the End text box. Select "eram" in the Type option box for this range also, and choose the Apply button.

8 Choose the Close button.
Step 4. Set address translations for the demo program

1 Choose the Settings → Emulator Config → Address Translation... (ALT, S, E, A) command.

2 Set up the Address Translation dialog box as shown in the illustration.

3 Choose the OK button.

![Address Translation Dialog Box]

This is the default setup for the Address Translation dialog box. It ensures that the emulator can refer to protected-mode addresses (for setting breakpoints) before running the demo program.
Step 5. Load the demo program

1. Choose the Execution→Break (ALT, E, B) command.

2. Choose the File→Load Object... (ALT, F, L) command.

3. Choose the Browse button and select the sample program object file, C:\HP\RTC\I386EX\DEMO\SAMPLE\SAMPLE (if C:\HP\RTC\I386EX was the installation path chosen when installing the debugger software).

4. Choose the OK button in the Object File Name dialog box.

5. Choose the Load button.
Step 6. Display the source file

To display the sample.c source file starting from the main function:

1. If the Source window is not open, double-click on the Source window icon to open the window. Or, choose the Window→Source command.

2. From the Source window’s control menu, choose Search→Function... (ALT, -, R, F) command.

3. Select "main".

4. Choose the Find button.

5. Choose the Close button.

6. From the Source window’s control menu, choose Display→Source Only (ALT, -, D, S) command.

The window displays sample.c source file, starting from main function.
Step 7. Set a breakpoint

To set a breakpoint on line 34 in sample.c:

1. Cursor-select line 34 (that is, move the mouse pointer over line 34 and click the left mouse button).

2. Choose the Breakpoint→Set at Cursor (ALT, B, S) command.

Notice that line 34 is marked with "BP", which indicates a breakpoint has been set on the line.

Note

This can be done more quickly by using the pop-up menu available with the right mouse button.
Step 8. Run the demo program

To run the demo program from the reset address:

1. Choose the Execution→Run... (ALT, E, R) command.

2. Select the User Reset option.

3. Choose the Run button.

Notice the demo program runs until line 34. The highlighted line indicates the current program counter.
Step 9. Delete the breakpoint

To delete the breakpoint set on line 34:

1. Cursor-select line 34.

2. Choose the Breakpoint→Delete at Cursor (ALT, B, D) command.

The "BP" marker disappears in the Source window.

---

Step 10. Single-step one line

To single-step the demo program from the current program counter:

- Choose the Execution→Single Step (ALT, E, N) command. Or, press the F2 key.

Notice the C statement executed and the program counter is at the "convert" function.
Step 11. Single-step 10 lines

To single-step 10 consecutive executable statements from the current PC line:

1. Choose the Execution→Step... (ALT, E, S) command.

2. Select the Current PC option.

3. Enter "10" in the Count text box.

4. Choose the Step button. Notice that the step count decrements by one as the program executes step by step. The step count stops at 0.

5. Choose the Close button.
Step 12. Display a variable

To display the contents of auto variable "*mes":

1 Drag "*mes" on line 60 in the Source window until it is highlighted.

2 Choose the Variable→Edit... (ALT, V, E) command.

The Variable text box displays "*mes".

Notice the Value list box displays the contents of "*mes".

Note You can only register or display an auto variable as a watchpoint while the program counter is within the function in which the variable name is declared.
Step 13. Edit a variable

To edit the contents of variable "mes":

1. In the Variable Edit dialog box, choose the Modify button.

2. Enter "41" in the Value text box.

3. Choose the OK button.

4. Notice the contents of the variable in the Value list box has changed to "41".
Step 14. Monitor a variable in the WatchPoint window

The WatchPoint window lets you define a set of variables that may be looked at and modified often. For these types of variables, using the WatchPoint window is more convenient than using the Variable→Edit... (ALT, V, E) command.

To monitor the variable "*mes" in the WatchPoint window:

1 In the Variable Edit dialog box, choose the "to WP" button.
2 Choose the Close button.
3 Choose the Window→WatchPoint command.

Notice the variable "*mes" has been registered as a watchpoint.
Step 15. Run until return from current function

To execute the program until "convert_case" (the current PC function) returns to its caller:

- Choose the Execution→Run to Caller (ALT, E, T) command.

The program executes until the line that called "convert_case".

Step 16. Step over a function

To step over "change_status":

- Choose the Execution→Step Over (ALT, E, O) command. Or, press the F3 key.

The "change_status" function executes, and the program counter indicates line 55.
Step 17. Run the program to a specified line

To execute the demo program to the first line of "next_message":

1. Cursor-select line 80.

2. Choose the Execution→Run to Cursor (ALT, E, C) command.

The program executes and stops immediately before line 80.
Step 18. Display register contents

1. Choose the Window→Basic Registers command.

   ![Basic Registers Table]

   The Basic Registers window opens and displays the register contents. The display is updated periodically.

2. To see the effects of preventing monitor intrusion (running in the real-time mode), choose the RealTime→Monitor Intrusion→Disallow (ALT, R, T, D) command.

3. To run the program, choose the Execution→Run (ALT, E, U) command. Or, press the F5 key.
Notice that register contents are replaced with "----" in the display. This shows the debugger cannot update the register display. In order for the emulator to update its register display, the emulation monitor must interrupt target program execution to read the registers.

4 Choose the RealTime→Monitor Intrusion→Allowed (ALT, R, T, A) command to deselect the real-time mode. Notice that the contents of the registers are updated periodically.
Step 19. Trace a function’s callers

To trace the caller of "next_message":

1. Double-click "next_message" on line 78 in the Source window.

2. Choose the Trace → Function Caller... (ALT, T, C) command.

3. Choose the OK button.

The Trace window becomes active and displays the caller as shown below.

This command stores the first statement of a function and prestores statements that occur before the first statement (notice the state type PRE). The prestored statements show the caller of the function. In the above example, "next_message" is called by line 35 of "main".
Step 20. Trace access to a variable

1. Double-click "message_id" in the Trace window or on line 35 in the Source window.

2. Choose the Trace→Variable Access... (ALT, T, V) command.

3. Choose the OK button.

The Trace window becomes active and displays accesses to "message_id" as shown below.

Lines 36 and 34 precede each capture of line 35. These were the last two lines executed before "message_id" was captured. Line 34 actually made each call to message_id.
Step 21. Exit the debugger

1. Choose the File→Exit (ALT, F, X) command.

2. Choose the OK button.

   This will end your Real-Time C Debugger session.
Part 2

User’s Guide

A complete set of task instructions and problem-solving guidelines, with a few basic concepts.
Part 2
Using the Debugger Interface
Using the Debugger Interface

This chapter contains general information about using the debugger interface.

- How the Debugger Uses the Clipboard
- Debugger Function Key Definitions
- Starting and Exiting the Debugger
- Working with Debugger Windows
- Using Command Files
How the Debugger Uses the Clipboard

Whenever something is selected with the standard windows double-click, it is placed on the clipboard. The clipboard can be pasted into selected fields by clicking the right mouse button.

Double-clicks are also used in the Register and Memory windows to make values active for editing. These double-clicks also copy the current value to the clipboard, destroying anything you might have wanted to paste into the window (for example, a symbol into the memory address field). In situations like this, you can press the CTRL key while double-clicking to prevent the selected value from being copied to the clipboard. This allows you to, for example, double-click on a symbol, CTRL+double-click to activate a register value for editing, and click the right mouse button to paste the symbol value into the register.

Many of the Real-Time C Debugger commands and their dialog boxes open with the clipboard contents automatically pasted in the dialog box. This makes entering commands easy. For example, when tracing accesses to a program variable, you can double-click on the variable name in one of the debugger windows, choose the Trace→Variable Access... (ALT, T, V) command, and click the OK button without having to enter or paste the variable name in the dialog box (since it is has automatically been pasted in the dialog box).
## Debugger Function Key Definitions

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Accesses context sensitive help. Context sensitive help is available for windows, dialog boxes, and menu items (with Ctrl+F1).</td>
</tr>
<tr>
<td>F2</td>
<td>Executes a single source line from the current program counter address (or a single instruction if disassembled mnemonics are mixed with source lines in the Source window).</td>
</tr>
<tr>
<td>F3</td>
<td>Same as F2 except when the source line contains a function call (or the assembly instruction makes a subroutine call); in these cases, the entire function (or subroutine) is executed.</td>
</tr>
<tr>
<td>F4</td>
<td>Break emulator execution into the monitor. You can use this to stop a running program or break into the monitor from the processor reset state.</td>
</tr>
<tr>
<td>F5</td>
<td>Runs the program from the current program counter address.</td>
</tr>
<tr>
<td>Shift-F4</td>
<td>Tiles the open debugger windows.</td>
</tr>
<tr>
<td>Shift-F5</td>
<td>Cascades the open debugger windows.</td>
</tr>
<tr>
<td>F7</td>
<td>Repeats the trace command that was entered last.</td>
</tr>
<tr>
<td>Ctrl+F7</td>
<td>Halts the current trace.</td>
</tr>
</tbody>
</table>
Starting and Exiting the Debugger

This section shows you how:

• To start the debugger
• To exit the debugger
• To create an icon for a different emulator

To start the debugger

• Double-click the debugger icon.

Or:

1 Choose the File→Run (ALT, F, R) command in the Windows Program Manager.

2 Enter the debugger filename, C:\HP\RTC\I386EX\B3637B.EXE (if C:\HP\RTC\I386EX was the installation path chosen when installing the debugger software).

3 Choose the OK button.

You can execute a command file when starting the debugger by using the 
"-C<command_file>" command line option.
To exit the debugger

1 Choose the File→Exit (ALT, F, X) command.

2 Choose the OK button.

This will end your Real-Time C Debugger session.

To create an icon for a different emulator

1 Open the "HP Real-Time C Debugger" group box, or make it active by positioning the mouse in the window and clicking the left button.

2 Choose the File→New... (ALT, F, N) command in the Windows Program Manager.

3 Select the Program Item option and choose OK.

4 In the Description text box, enter the icon description.

5 In the Command Line text box, enter the "C:\HP\RTC\I386EX\B3637B.EXE -T<transport> -E<connectname>" command (if C:\HP\RTC\I386EX was the installation path chosen when installing the debugger software). The ",-T" and ",-E" startup options allow you to bypass the transport and connect name definitions in the B3637B.INI file.

<Transport> should be one of the supported transport options (for example, HP-ARPA, RS232C, etc.).

<Connectname> should identify the emulator for the type of transport. For example, if the HP-ARPA transport is used, <connectname> should be the hostname or IP address of the HP 64700; if the RS232C transport is used, <connectname> should be COM1, COM2, etc.
6 In the Working Directory text box, enter the directory that contains the debugger program (for example, C:\HP\RTC\I386EX).

7 Choose the OK button.
Working with Debugger Windows

This section shows you how:

• To open debugger windows
• To copy window contents to the list file
• To change the list file destination
• To change the debugger window fonts
• To set tab stops in the Source window
• To set colors in the Source window

To open debugger windows

• Double-click the icon for the particular window.

• Or, choose the particular window from the Window → menu.

• Or, choose the Window → More Windows... (ALT, W, M) command, select the window to be opened from the dialog box, and choose the OK button.
To copy window contents to the list file

• From the window’s control menu, choose the Copy→Windows (ALT, -, P, W) command.

The information shown in the window is copied to the destination list file.

You can change the name of the destination list file by choosing the Copy→Destination... (ALT, -, P, D) command from the window's control menu or by choosing the File→Copy Destination... (ALT, F, P) command.

To change the list file destination

• Choose the File→Copy Destination... (ALT, F, P) command, and select the name of the new destination list file.

• Or, from the window’s control menu, choose the Copy→Destination... (ALT, -, P, D) command, and select the name of the new destination list file.

Information copied from windows will be copied to the selected destination file until the destination list file name is changed again.

List file names have the "*.LST" extension.
To change the debugger window fonts

1. Choose the Settings→Font (ALT, S, F) command.

2. Select the font, font style, and size. Notice that the Sample box previews the selected font.

3. Choose the OK button.

To set tab stops in the Source window

1. Choose the Settings→Tabstops (ALT, S, T) command.

2. Enter the tab width. This width is also used for source lines in the trace window.

3. Choose the OK button.

The tab width must be between 1 and 20.
To set colors in the Source window

1. Exit the RTC interface and find the initialization file (B3637B.INI). It should be in the directory where you installed the RTC product (C:\HP\RTC\I386EX, by default).

2. Edit the initialization file to find the "color" entry. You will see:

   [Color]
   ColorMode=ON|OFF
   ColorPc=<color>
   ColorSource=<color>
   ColorMne=<color>

   Where: <color> may be any of the following: RED, GREEN, BLUE, YELLOW, PINK, PURPLE, AQUA, ORANGE, SLATE, or WHITE.

   • The <color> entry may be in upper-case or lower-case letters.

   • When ColorMode=ON, these are the default colors:

       • ColorPc=GREEN
       • ColorSource=RED
       • ColorMne=BLUE

   • The default color is black if an option is given a null value.

   • The options under [Color] set colors as follows:

       • ColorPc sets the color of the line of the current program counter.
       • ColorSource sets the color of the line numbers of source lines.
       • ColorMne sets the color of the address of all mnemonic lines.

Note

If you have set ColorMode=ON while using a monochrome display, you may see no line numbers in the Source window. Items that will be presented in color on a color display may not be seen at all on a monochrome display.
Using Command Files

This section shows you how:

• To create a command file
• To execute a command file
• To create buttons that execute command files

A command file is an ASCII text file containing one or more debugger commands. All the commands are written in a simple format, which makes editing easy. The debugger commands used in command files are the same as those used with break macros. For details about the format of each debugger command, refer to the "Reference" information.

To create a command file

1 Choose the File→Command Log→Log File Name... (ALT, F, C, N) command.

2 Enter the command file name.

3 Choose the File→Command Log→Logging ON (ALT, F, C, O) command.

4 Choose the commands to be stored in the command file.

5 Once the commands have been completed, choose the File→Command Log→Logging OFF (ALT, F, C, F) command.

Command files can also be created by saving the emulator configuration.
To execute a command file

1 Choose the File→Run Cmd File... (ALT, F, R) command.

2 Select the command file to be executed.

3 Choose the Execute button.

You can execute command files that have been created by logging commands. Also, emulator configurations can be restored by executing the associated command file.

You can execute a command file when starting the debugger by using the "-C<command_file>" command line option.

Example

Command File Being Executed
To create buttons that execute command files

1. Activate the Button window by clicking on the Button window icon or by choosing the Window→Button command.

2. From the Button window’s control menu, choose the Edit... (ALT, -, E) command.

3. In the Command text box, enter "FILE COMMAND", a space, and the name of the command file to be executed.

4. Enter the button label in the Name text box.

5. Choose the Add button.

6. Choose the Close button.

Once a button has been added, you can click on it to run the command file. You can also set up buttons to execute other debugger commands.
Plugging the Emulator into Target Systems
Plugging the Emulator into Target Systems

This chapter shows you how to:

• Step 1. Turn OFF power
• Step 2. Unplug the probe from the demo target system
• Step 3. Plug the probe into the target system
• Step 4. Connect the reset flying lead to the target system
• Step 5. Turn ON power

CAUTION

Possible Damage to the Emulator Probe. The emulation probe contains devices that are susceptible to damage by static discharge. Take precautionary measures before handling the microprocessor connector attached to the end of the probe cable to avoid damaging the internal components of the probe by static electricity.

HP STRONGLY recommends you use a ground strap when handling the emulator probe. A ground strap is provided with the emulator.

There is a red LED on the probe board. If the LED is on, immediately turn off your target system! The LED turns on when your target system has power but the emulator does not. Permanent damage will occur if target system power is turned on when the emulator is turned off, especially if this condition lasts for more than one minute.
Step 1. Turn OFF power

**CAUTION**
Possible Damage to the Emulator. Make sure target system power is OFF and make sure HP 64700 power is OFF before removing or installing the emulator probe into the target system.

Do not turn HP 64700 power OFF while the emulator is plugged into a target system whose power is ON.

1. If the emulator is currently plugged into a different target system, turn that target system’s power OFF.

2. Turn emulator power OFF.

---

Step 2. Unplug the probe from the demo target system

- If the emulator is currently connected to a different target system, unplug the emulator probe; otherwise, disconnect the emulator probe from the demo target system.
Step 3. Plug the probe into the target system

- Install the emulator probe into the target system socket. Make sure that pin A1 of the connector aligns with pin A1 of the socket. **Damage to the emulator will result if the probe is incorrectly installed.**

You can also use the supplied PGA to PGA adapter or other PQFP adapters. Always make sure that pin 1 and other pins of the adapters and connectors are properly aligned; otherwise, damage to the emulator will result.
Step 4. Connect the reset flying lead to the target system

- The details of how to connect the reset flying lead are shown in the HP 64789B Intel80386EX Emulator Installation/Service/Terminal Interface User’s Guide.

The reset flying lead on the Intel80386EX emulator can be used to reset your target system when the emulator applies reset to the processor. This is useful if you have any hardware in your target system that needs to know when the processor is reset (such as a circuit to generate the self-test request to the processor).

The reset flying lead is an open-collector circuit that will go low when the emulator applies reset (that is, you have used the “reset” command, have reconfigured the emulator, or have given any other command that results in the processor being reset.) It will not go low when your target system applies reset unless the emulator is also applying reset.

You do not need to use this if the only signal your target system derives from RESET is the "CLK" signal; the emulator will preserve the phase of CLK between emulation-only resets.
Step 5. Turn ON power

1. Turn emulator power ON.

2. Turn target system power ON.
Configuring the Emulator
Configuring the Emulator

This chapter contains information about configuring the emulator.

• Setting the Hardware Options
• Selecting the Type of Monitor
• Mapping Memory
• Selecting Address Translations
• Setting Up the BNC Port
• Saving and Loading Configurations
• Setting the Real-Time Options
Setting the Hardware Options

This section shows you how:

- To specify a CLK2 speed faster than 42 MHz
- To enable or disable target interrupts
- To enable or disable software breakpoints
- To enable or disable break on writes to ROM
- To enable or disable execution trace messages
- To enable or disable foreground monitor traced as user
To specify a CLK2 speed faster than 42 MHz

1 Choose the Settings→Emulator Config→Hardware... (ALT, S, E, H) command.

2 Select or deselect the check box beside Processor Clock is Faster Than 42 MHz.

3 Choose the OK button to exit the Emulator Configuration dialog box.

If the 4-Mbyte SIMMs are installed, and the CLK2 speed is greater than 42 MHz, the emulator has to force at least one wait state because the 4-MByte SIMMs are slower than the 256-KByte and 1-Mbyte SIMMs.

CLK2 is the clock input to the Intel80386EX; it is twice the speed of the usually-quoted speed (that is, a "20 MHz Intel80386EX" has a CLK2 speed of 40 MHz).

Note that if you lock emulation memory cycles with target cycles, the target hardware must continue to assert the READY# line until the second wait state.
To enable or disable target interrupts

1 Choose the Settings→Emulator Config→Hardware... (ALT, S, E, H) command.

2 Select or deselect the check box beside Enable Target Interrupts.

3 Choose the OK button to exit the Emulator Configuration dialog box.

When the check box is selected, the emulator responds to interrupts generated by the target system while running in the user program or foreground monitor. All interrupts (INT or NMI) are blocked when execution is within the background monitor.

When the check box is deselected, the emulator ignores all interrupts generated by the target system, all INT interrupts, and the NMI.
To enable or disable software breakpoints

1 Choose the Settings→Emulator Config→Hardware... (ALT, S, E, H) command.

2 Select or deselect the check box beside Enable Software Breakpoints.

3 Choose the OK button to exit the Emulator Configuration dialog box.

If software breakpoints are enabled, the processor will take longer to leave the RESET state than when they are disabled.

The emulator uses the bond-out processor's software breakpoint capability. This requires a special bit to be set to enable recognition of the breakpoint instruction (which is a special opcode, different from the normal execution breakpoint opcode of 0CCH). When the processor is reset, this bit is cleared. To make use of breakpoints, the emulation monitor must set this bit every time the processor leaves the reset state.
To enable or disable break on writes to ROM

1. Choose the Settings → Emulator Config → Hardware... (ALT, S, E, H) command.

2. Select or deselect the check box beside Enable Break on Write to ROM.

3. Choose the OK button to exit the Emulator Configuration dialog box.

When the check box is selected, a running program breaks into the monitor when it writes to a location mapped as ROM.

When the check box is deselected, program writes to locations mapped as ROM do not cause breaks into the monitor.
To enable or disable execution trace messages

1 Choose the Settings→Emulator Config→Hardware... (ALT, S, E, H) command.

2 Select or deselect the check box beside Enable Execution Trace Messages.

3 Choose the OK button to exit the Emulator Configuration dialog box.

When the check box is selected, branch trace messages and task switch messages are enabled. Every time the processor does a branch, it will emit the target address of the branch. Each time a task switch occurs, the emulator will emit a task switch message identifying both the old task and the new task.

When the check box is deselected, no branch trace messages nor task switch messages will be emitted.
To enable or disable foreground monitor traced as user

1 Choose the Settings→Emulator Config→Hardware... (ALT, S, E, H) command.

2 Select or deselect the check box beside Enable Monitor Traced as User.

3 Choose the OK button to exit the Emulator Configuration dialog box.

If the check box is selected when using a foreground monitor, all foreground monitor cycles will be captured in the trace memory by the emulation-bus analyzer. This is useful when you are having problems with an interrupt routine and you want to trace that routine even if it occurs during execution in the foreground monitor.

If the check box is not selected, and you have chosen Settings→Extended→Trace Cycles→User, the analyzer will capture nothing between the time the foreground monitor is entered and the time you begin a run of your user program again. This prevents capture of interrupt routines executed while in the foreground monitor. This is useful when you are trying to conserve trace memory space to capture user program execution.

When using the background monitor, this has no effect.

See "Tracing Program Execution" in the "Debugging Programs" chapter for useful combinations of the "Settings→Extended→Trace Cycles" command and the Enable Foreground Monitor Traced as User selection.
Selecting the Type of Monitor

This section shows you how:

- To select the background monitor
- To select the foreground monitor
- To use a custom foreground monitor

Refer to "Monitor Program Options" in the "Concepts" part for a description of emulation monitors and the advantages and disadvantages of using background or foreground emulation monitors.

Note

Select the type of monitor before mapping memory because changing the monitor type resets the memory map.

To select the background monitor

1. Choose the Settings→Emulator Config→Monitor... (ALT, S, E, O) command.
2. Select the Background option.
3. Choose the OK button.

When you power up the emulator, or when you initialize it, the background monitor program is selected by default.
To select the foreground monitor

1 Choose the Settings→Emulator Config→Monitor... (ALT, S, E, O) command.

2 Select the Foreground option.

3 Enter the base address of the foreground monitor in the Monitor Address text box. The address must reside on a 16-Kbyte boundary (in other words, the address must be a multiple of 4000H) and must be specified in hexadecimal.

4 Enter the GDT descriptor for the foreground monitor code segment. This reserves a GDT entry to define the code segment for the monitor when running in protected mode. The specified value must be a multiple of 8, greater than 0 and less than the limit defined in GDTR.

5 If you wish to synchronize monitor cycles to the target system (that is, interlock the emulation and target system READY# lines on accesses to the monitor memory block), select the Monitor Cycles Use Target RDY option; otherwise, deselect this option.

6 Leave the Load Custom Monitor box unselected. This tells the emulator to use the default foreground monitor present in the emulator firmware.

7 Choose the OK button.

8 Load the user program by choosing the File→Load Object... (ALT, F, L) command and entering the name of the user program object file.

When you select the foreground monitor, the emulator automatically loads the default foreground monitor program, resident in emulator firmware, into emulation memory. The foreground monitor is reloaded every time the emulator breaks into the monitor state from the reset state.

For more information on the foreground monitor, refer to the "Monitor Program Options" section in the "Concepts" information.
To use a custom foreground monitor

1 Edit the foreground monitor program source.

2 Assemble and link the foreground monitor program.

3 Choose the Settings → Emulator Config → Monitor... (ALT, S, E, O) command.

4 Select the Foreground option.

5 Enter the base address of the foreground monitor in the Monitor Address text box. The address must reside on a 16-Kbyte boundary (an address ending in 4000H) and must be specified in hexadecimal.

6 If you wish to synchronize monitor cycles to the target system (that is, interlock the emulation and target system READY# lines on accesses to the monitor memory block), select the Monitor Cycles Use Target RDY option; otherwise, deselect this option.

7 Enter the name of the foreground monitor object file in the Monitor File Name text box.

8 Choose the OK button.

9 Use the Settings → Emulator Config → Memory Map... (ALT, S, E, M) to remap the user program memory areas. Selecting the foreground monitor automatically resets the current memory map and adds a new map term for the monitor.

10 Load the user program by choosing the File → Load Object... (ALT, F, L) command and entering the name of the user program object file.

When customizing the foreground monitor, you must maintain the basic communication protocol between the monitor program and the emulation system controller.
An example foreground monitor is provided with the debugger in the \HP\RTC\I386EX\MONITOR directory (if \HP\RTC\I386EX is the directory where the software was installed). The file is named I386EX.ASM.

The custom foreground monitor was written to be built using a Microtec Research Inc. builder and 386 language tools.

The custom foreground monitor is saved in the emulator (until the monitor type is changed) and reloaded every time the emulator breaks into the monitor state from the reset state.
Mapping Memory

This section shows you how:

- To map memory

By default, the emulator assumes all memory addresses are in RAM space in your target system. If you wish to load some of your target program in emulation memory, or identify some of your memory addresses as ROM or Guarded, enter those specifications in the memory map.

There are two types of emulation memory: SIMMs, and dual-port memory. 256-Kbyte, 1-Mbyte, and 4-Mbyte SIMMs are supported, although the 4-Mbyte SIMMs require an additional wait state if the CLK2 speed in your target system is greater than 42 MHz.

The dual-port memory is 8 Kbytes and is always available. (Actually, 16 Kbytes of dual-port memory are supplied with this emulator, but the other 8 Kbytes are reserved for the monitor and cannot be used for any other purpose.) The differences between dual-port memory and SIMM memory are:

- Dual-port memory is always available, even when no SIMMs are loaded.
- Only one map term (address range) can be used with the dual-port attribute.
- The user interface can access data stored in dual-port RAM without interrupting any programs running on the Intel80386EX. If the processor is executing instructions, the memory is accessed transparently by interleaving accesses from the Intel80386EX with accesses from the emulator. If the processor is RESET, or there is no power to the target system, the dual-port memory can be accessed normally (transparently). If the processor is in the HALT or SHUTDOWN state, however, dual-port memory cannot be accessed transparently. In this case, the monitor will be used. To prevent the monitor from being used, you can choose Realtime→Monitor Intrusion→Disallowed (ALT, R, T, D).

Up to eight ranges of memory can be mapped, and the resolution of mapped ranges is 256 bytes (that is, the memory ranges must begin on 256-byte boundaries and must be at least 256 bytes in length).
Note that if you have a 1-Mbyte SIMM, but you map all eight terms to 256-byte ranges (for a total of 2 Kbytes), the remaining 1022 Kbytes within your SIMM cannot be used.

External direct memory access (DMA) to emulation memory is not permitted.

You should map all memory ranges used by your programs before loading programs into memory.

If you use a foreground monitor, you must map its address space within your target address space, but you will not need to provide memory hardware to contain it. It will be contained in the 8-Kbyte dual-port memory that is reserved for containing the monitor.
To map memory

1 Choose the Settings→Emulator Config→Memory Map... (ALT, S, E, M) command.

2 Specify the starting address in the Start text box.

3 Specify the end address in the End text box.

4 Select or deselect the Use target RDY option.

5 Select or deselect the Use dual-ported memory option.

6 Select the memory type in the Type option box.

7 Choose the Apply button.

8 Repeat steps 2 through 7 for each range to be mapped.

9 Choose the Close button to exit the Memory Map dialog box.

You can specify one of the following memory types for each map term:

- eram Specifies "emulation RAM".
- erom Specifies "emulation ROM".
- tram Specifies "target RAM".
- trom Specifies "target ROM".
- guarded Specifies "guarded memory".

For non-mapped memory areas, select any of the memory types in the Other option box.
Writes to emulation ROM or to target system RAM mapped as ROM will modify memory.

 Writes to ROM will also result in a break to the monitor, if enabled in the emulator configuration. Writes to locations mapped as guarded memory will always result in a break to the monitor.

The Use target RDY option specifies that emulation memory accesses in the range be synchronized to the target system RDY signal.

To delete a map term, first select it in the Map list box; then, choose the Delete button.

Map all memory ranges used by your programs before loading programs into memory.

**Example**

To map addresses 0 through 7fffh as an emulation RAM, specify the mapping term as shown below.

![Define Map Term](image)

Choose the Apply button to register the current map term.

Then, choose the Close button to quit mapping.
Selecting Address Translations

1. Choose the Settings→Emulator Config→Address Translations... (ALT, S, E, A) command.

2. Leave Page translations required unselected unless your target system uses paging.


4. If you selected one of the static methods of determining translations, select the desired Caching Option.

5. Choose the OK button to apply your selections and close the Address Translation dialog box, or choose Apply to apply your selections and leave the dialog box open on screen.

When address translations occur

Translations are necessary whenever a request is made to access target or emulation memory (such as displaying memory or modifying memory), or whenever a trace is set up.

If paging is not being used, it is not necessary to break processor execution in order to translate a real-mode address. If paging is being used, processor execution must be broken (because the real-mode address may be a virtual-8086 address).

Implications of address translation options

The method used to translate addresses determines the accuracy and intrusiveness of the emulator:

Dynamic translations cause a temporary break (from your program into the monitor) to do a translation. This means that the translation is always accurate for the current state of the processor and for the current GDT (if in protected mode).

If your GDT tables change frequently, dynamic translation may be the best option for you; however, you cannot set up the analyzer or modify and display memory using protected-mode addresses when the processor is RESET. You must use physical addresses in that case.
Static translations cache the GDT and LDT tables (either from a program or from the current tables in the processor), and use the cached values of the tables to translate all virtual addresses. Static translations are only accurate if the current GDT matches the cached GDT values. When using Static translations, your program is never interrupted in order to perform a translation. You can use protected-mode addresses while the processor is RESET (or in real mode) to modify and display memory or set up a trace.

If page translations are needed, only the dynamic method (i.e. always request translations from the emulator) is available. This is because page tables are inherently dynamic and cannot be cached.

**Performance of address translation caching**

Selecting the appropriate address translation caching scheme will greatly improve the response of the RTC interface. By allowing logical-to-physical translations to be computed on the PC instead of via requests to the emulator, the interface updates windows much quicker. Computing translations on the host is an order of magnitude quicker than requesting the same service from the emulator.

The Global and Local Descriptor Tables are unique to specific programs and are often static, i.e. they don’t change while the program is running. If you are using static tables, RTC lets you cache the tables on the host PC, thereby reducing the requests sent to the emulator for logical-to-physical translations.

Choose Settings→Emulator Config→Address Translation... (ALT, S, E, A), and select Static (cache translations on OK or Apply) or Static (cache translations after every file load) in the Address Translation dialog box.

The chosen address translation method is saved in the .INI file when you exit the emulator so the next RTC session will use the previously chosen method. This creates a problem if a Static method was chosen along with the option of getting the base/limit values from the loaded absolute file. When the emulator starts up, no absolute file has been loaded so there are no valid GDT base and limit values available. In this case, the screen displays a warning stating that logical-to-physical translations are not initially available. Either a file must be loaded or the method of obtaining a base GDT address changed before translations can occur.
Setting Up the BNC Port

This section shows you how:

- To output the trigger signal on the BNC port
- To receive an arm condition input on the BNC port

To output the trigger signal on the BNC port

- Choose the Settings→BNC→Outputs Analyzer Trigger (ALT, S, B, O) command.

The HP 64700 Series emulators have a BNC port for connection with external devices such as logic analyzers or oscilloscopes.

This command enables the trigger signal from the internal analyzer to be fed to external devices.

To receive an arm condition input on the BNC port

- Choose the Settings→BNC→Input to Analyzer Arm (ALT, S, B, I) command.

The HP 64700 Series emulators have a BNC port for connection with external devices such as logic analyzers or oscilloscopes.

This command allows an external trigger signal to be used as an arm (enable) condition for the internal analyzer.
Saving and Loading Configurations

This section shows you how:

- To save the current emulator configuration
- To load an emulator configuration

To save the current emulator configuration

1 Choose the File→Save Emulator Config... (ALT, F, V) command.

2 In the file selection dialog box, enter the name of the file to which the emulator configuration will be saved.

3 Choose the OK button.

This command saves the current hardware, memory map, and monitor settings to a command file.

Saved emulator configuration files can be loaded later by choosing the File→Load Emulator Config... (ALT, F, E) command or by choosing the File→Run Cmd File... (ALT, F, R) command.

See Also

File→Save Emulator Config... (ALT, F, V) in the "Menu Bar Commands" section of the "Reference" information.
To load an emulator configuration

1. Choose the File→Load Emulator Config... (ALT, F, E) command.

2. Select the name of the emulator configuration command file to load from the file selection dialog box.

3. Choose the OK button.

This command lets you reload emulator configurations that have previously been saved.

Emulator configurations consist of hardware, memory map, and monitor settings.
Setting the Real-Time Options

This section shows you how:

- To allow or deny monitor intrusion
- To turn polling ON or OFF

The monitor program is executed by the emulation microprocessor when target system memory, I/O, and microprocessor registers are displayed or edited. In addition, any address translations will cause the monitor program to execute unless they are configured to be static (see Selecting how Address Translations work). Also, periodic polling to update the Memory, I/O, WatchPoint, and Register windows can cause monitor program execution.

When the user program is running and monitor intrusion is allowed, the user program must be temporarily interrupted in order to display or edit target system memory, display or edit registers, or update window contents.

If it is important that your program execute without these kinds of interruptions, you should deny monitor intrusion. You can still display and edit target system memory and microprocessor registers, but you must specifically break emulator execution from the user program into the monitor.

When monitor intrusion is denied, polling to update window contents is automatically turned OFF.

When monitor intrusion is allowed, you can turn OFF polling for particular windows to lessen the number of interruptions during user program execution.
To allow or deny monitor intrusion

- To deny monitor intrusion, choose the RealTime→Monitor Intrusion→Disallowed (ALT, R, T, D) command.

- To allow monitor intrusion, choose the RealTime→Monitor Intrusion→Allowed (ALT, R, T, A) command.

When you deny monitor intrusion, any debugger command that may interrupt a running user program is prevented. This ensures the user program will execute in real time.

When you allow monitor intrusion, debugger commands that may temporarily interrupt user program execution are allowed.

The current setting is shown by a check mark (√) next to the command.
To turn polling ON or OFF

- To turn I/O window polling ON or OFF, choose the RealTime→I/O Polling→ON (ALT, R, I, O) or RealTime→I/O Polling→OFF (ALT, R, I, F) command.

- To turn WatchPoint window polling ON or OFF, choose the RealTime→Watchpoint Polling→ON (ALT, R, W, O) or RealTime→Watchpoint Polling→OFF (ALT, R, W, F) command.

- To turn Memory window polling ON or OFF, choose the RealTime→Memory Polling→ON (ALT, R, M, O) or RealTime→Memory Polling→OFF (ALT, R, M, F) command.

When the user program is running and monitor intrusion is denied, polling is automatically turned OFF.

When the user program is running and monitor intrusion is allowed, you can turn polling OFF to reduce the number of user program interrupts made in order to update I/O, WatchPoint, and Memory window contents.

The current settings are shown by check marks (√) next to the command.
Debugging Programs
Debugging Programs

This chapter contains information on loading and debugging programs.

- Loading and Displaying Programs
- Displaying Symbol Information
- Stepping, Running, and Stopping the Program
- Using Breakpoints and Break Macros
- Displaying and Editing Variables
- Displaying and Editing Memory
- Displaying and Editing GDT, LDT, and IDT Windows
- Displaying and Editing I/O locations
- Displaying and Editing Registers
- Tracing Program Execution
- Setting Up Custom Trace Specifications
Loading and Displaying Programs

This section shows you how:

- To load user programs
- To display source code only
- To display source code mixed with assembly instructions
- To display source files by their names
- To specify source file directories
- To search for function names in the source files
- To search for addresses in the source files
- To search for strings in the source files

To load user programs

1. Choose the File→Load Object... (ALT, F, L) command.
2. Select the file to be loaded.
3. Choose the Load button to load the program.

With this command, you can load any Intel OMF object file created with Microtec Research Inc. 80386 language tools.
To display source code only

1 Position the cursor on the starting line to be displayed.

2 From the Source window control menu, choose the Display→Source Only (ALT, -, D, S) command.

The Source window may be toggled between the C source only display and the C source/mnemonic mixed display.

The display starts from the line containing the cursor.

The source only display shows line numbers with the source code.

To display source code mixed with assembly instructions

1 Position the cursor on the starting line to be displayed.

2 From the Source window control menu, choose the Display→Mixed Mode (ALT, -, D, M) command.

The mnemonic display contains the address, data, and disassembled instruction mnemonics intermixed with the C source lines.
To display source files by their names

1 Make the Source window the active window, and choose the Display→Select Source... (ALT, -, D, L) command from the Source window's control menu.

2 Select the desired file.

3 Choose the Select button.

4 Choose the Close button.

Note
The contents of assembly language source files cannot be displayed.
To specify source file directories

1 Make the Source window the active window, and choose the Display→Select Source... (ALT, -, D, L) command from the Source window’s control menu.

2 Choose the Directory... button.

3 Enter the directory name in the Directory text box.

4 Choose the Add button.

5 Choose the Close button to close the Search Directories dialog box.

6 Choose the Close button to close the Select Source dialog box.

If the source files associated with the loaded object file are in different directories from the object file, you must identify the directories in which the source files can be found.

You can also specify them source file directories by setting the SRCPATH environment variable in MS-DOS as follows:

```
set SRCPATH=<full path 1>;<full path 2>
```
To search for function names in the source files

1. From the Source window’s control menu, choose the Search→Function... (ALT, -, R, F) command.

2. Select the function to be searched.

3. Choose the Find button.

4. Choose the Close button.

Disassembled instructions are displayed in the Source window for assembly language source files.

To search for addresses in the source files

1. From the Source window’s control menu, choose the Search→Address... (ALT, -, R, A) command.

2. Type or paste the address into the Address text box.

3. Choose the Find button.

4. Choose the Close button.

Disassembled instructions are displayed in the Source window for assembly language source files.
To search for strings in the source files

1 From the Source window’s control menu, choose the Search→String... (ALT, -, R, S) command.

2 Type or paste the string into the String text box.

3 Select whether the search should be case sensitive.

4 Select whether the search should be down (forward) or up (backward).

5 Choose the Find Next button. Repeat this step to search for the next occurrence of the string.

6 Choose the Cancel button to close the dialog box.
Displaying Symbol Information

This section shows you how:

- To display program module information
- To display function information
- To display external symbol information
- To display local symbol information
- To display global assembler symbol information
- To display local assembler symbol information
- To create a user-defined symbol
- To display user-defined symbol information
- To delete a user-defined symbol
- To display the symbols containing the specified string
To display program module information

- From the Symbol window's control menu, choose the Display→Modules (ALT, -, D, M) command.

To display function information

- From the Symbol window's control menu, choose the Display→Functions (ALT, -, D, F) command.

The name, type, and address range for the functions in the program are displayed. Refer to "Constant-address syntax" in the "Concepts" chapter to understand the format of the addresses shown in the display.

Example

Function Information Display

<table>
<thead>
<tr>
<th>Functions</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>_NMSG_WRITE</td>
<td>unknown 0F800:00018D..0F800:00104</td>
</tr>
<tr>
<td>_writeerr</td>
<td>unknown 0F800:00018C..0F800:00018C</td>
</tr>
<tr>
<td>_start</td>
<td>unknown 0F800:00018C..0F800:000151</td>
</tr>
<tr>
<td>change_status</td>
<td>int 0F800:0002FA..0F800:000320</td>
</tr>
<tr>
<td>convert</td>
<td>int 0F800:00023A..0F800:00027F</td>
</tr>
<tr>
<td>convert_case</td>
<td>int 0F800:000290..0F800:0002F9</td>
</tr>
<tr>
<td>init_data</td>
<td>int 0F800:0001F6..0F800:000238</td>
</tr>
<tr>
<td>INT31M_HANDLER</td>
<td>unknown 0F800:000424..0F800:00044B</td>
</tr>
<tr>
<td>INT31M_HANDLER</td>
<td>unknown 0F800:0003F6..0F800:000422</td>
</tr>
<tr>
<td>INT21H_HANDLER</td>
<td>unknown 0F800:0003E4..0F800:0003FC</td>
</tr>
<tr>
<td>main</td>
<td>int 0F800:0001C0..0F800:0001F4</td>
</tr>
<tr>
<td>next_message</td>
<td>int 0F800:000322..0F800:000348</td>
</tr>
<tr>
<td>SetUpIntVectors</td>
<td>unknown 0F800:00014C..0F800:0001A8</td>
</tr>
</tbody>
</table>
To display external symbol information

- From the Symbol window’s control menu, choose the Display→Externals (ALT, -, D, E) command.

The name, type, and address of the global variables in the program are displayed. Refer to "Constant-address syntax" in the "Concepts" chapter to understand the format of the addresses shown in the display.

Example

External Symbol Information Display
To display local symbol information

1 From the Symbol window’s control menu, choose the
   Display→Locals... (ALT, -, D, L) command.

2 Type or paste the function for which the local variable information is
   to displayed.

3 Choose the OK button.

The name, type, and offset from the stack frame of the local variables in the
selected function are displayed.

---

Example

Local Symbol Information Display

```
<table>
<thead>
<tr>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>struc_st_data</td>
<td>00000000</td>
</tr>
<tr>
<td>char_nea</td>
<td>000000ff</td>
</tr>
</tbody>
</table>
```

---
To display global assembler symbol information

- From the Symbol window’s control menu, choose the Display→Asm Globals (ALT, -, D, G) command.

The name and address for the global assembler symbols in the program are displayed.

To display local assembler symbol information

1. From the Symbol window’s control menu, choose the Display→Asm Locals... (ALT, -, D, A) command.

2. Type or paste the module for which the local variable information is displayed.

3. Choose the OK button.

The name and address for the local assembler variables in the selected module are displayed.
To create a user-defined symbol

1. From the Symbol window's control menu, choose the User defined→Add... (ALT, -, U, A) command.

2. Type the symbol name in the Symbol Name text box.

3. Type the address in the Address text box.

4. Choose the OK button.

User-defined symbols, just as standard symbols, can be used as address values when entering commands.

Example

To add the user-defined symbol "jmp_start":

![User Defined Symbol Add dialog box](image)
To display user-defined symbol information

- From the Symbol window’s control menu, choose the Display→User defined (ALT, -, D, U) command.

The command displays the name and address for the user-defined symbols.

Example

User-Defined Symbol Information Display

To delete a user-defined symbol

1. From the Symbol window’s control menu, choose the Display→User defined (ALT, -, D, U) command to display the user-defined symbols.

2. Select the user-defined symbol to be deleted.

3. From the Symbol window’s control menu, choose the User defined→Delete (ALT, -, U, D) command.
To display the symbols containing the specified string

1 From the Symbol window’s control menu, choose the FindString→String... (ALT, -, F, S) command.

2 Type or paste the string in the String text box. The search will be case-sensitive.

3 Choose the OK button.

To restore the original nonselective display, redisplay the symbolic information.
Stepping, Running, and Stopping the Program

This section shows you how:

- To step a single line or instruction
- To step over a function
- To step multiple lines or instructions
- To run the program until the specified line
- To run the program until the current function return
- To run the program from a specified address
- To stop program execution
- To reset the processor

To step a single line or instruction

- Choose the Execution→Single Step (ALT, E, N) command.
- Or, press the F2 key.

In the source display mode, this command executes the C source code line at the current program counter address.

In the source/mnemonic mixed display mode, the command executes the microprocessor instruction at the current program counter address.

Once the source line or instruction has executed, the next program counter address is highlighted.

During a single-step command, multiple instructions can be executed if the instruction being stepped causes an instruction fault or task switch. See "Unexpected Stepping Behavior" in the "Concepts" chapter.
To step over a function

- Choose the Execution→Step Over (ALT, E, O) command.
- Or, press the F3 key.

This command steps a single source line or assembly language instruction except when the source line contains a function call or the assembly instruction makes a subroutine call. In these cases, the entire function or subroutine is executed.

Example

When the current program counter is at line 34, choosing the Execution→Step Over (ALT, E, O) command steps over the "convert" function. Once the function has been stepped over, the program counter indicates line 35.
To step multiple lines or instructions

1. Choose the Execution→Step... (ALT, E, S) command.

2. Select one of the Current PC, Start Address, or Address options. (Enter the starting address when the Address option is selected.)

3. In the Count text box, type the number of lines to be single-stepped.

4. Choose the Execute button.

5. Choose the Close button to close the dialog box.

The Current PC option starts single-stepping from the current PC address. The Start Address option starts single-stepping from the transfer address. The Address option starts single-stepping from the address specified in the text box.

In the source only display mode, the command steps the number of C source lines specified. In the source/mnemonic mixed display mode, the command steps the number of microprocessor instructions specified.

When the step count specified in the Count text box is 2 or greater, the count decrements by one as each line or instruction executes. A count of 1 remains in the Count text box. Also, in the Source window, the highlighted line that indicates the current program counter moves for each step.

To step over functions, select the Over check box.
To run the program until the specified line

1 Position the cursor in the Source window on the line that you want to run to.

2 Choose the Execution→Run to Cursor (ALT, E, C) command.

Execution stops immediately before the cursor-selected line.

Because this command uses breakpoints, you cannot use it if you are already using the four hardware breakpoints on the Intel80386EX and the address you are stepping is in target ROM.

If the specified address is not reached within the number of milliseconds specified by StepTimerLen in the B3637B.INI file, a dialog box appears, asking you to cancel the command by choosing the Stop button. When the Stop button is chosen, the program execution stops, the breakpoint is deleted, and the processor transfers to the RUNNING IN USER PROGRAM status.

Note

This can be done more quickly by using the pop-up menu available with the right mouse button.

To run the program until the current function return

- Choose the Execution→Run to Caller (ALT, E, T) command.

The Execution→Run to Caller (ALT, E, T) command executes the program from the current program counter address up to the return from the current function.
Note

The debugger cannot properly run to the function return when the current program counter is at the first line of the function (immediately after its entry point). Before running to the caller, use the Execution→Single Step (ALT, E, N) command to step past the first line of the function.

To run the program from a specified address

1 Choose the Execution→Run... (ALT, E, R) command.

2 Select one of the Current PC, Start Address, User Reset, or Address options. (Enter the address when the Address option is selected.)

3 Choose the Run button.

The Current PC option executes the program from the current program counter address. The Start Address option executes the program from the transfer address.

The User Reset option initiates program execution from the reset vector. Note that this will cause your target board to reset only if you have attached the "reset flying lead" to the appropriate spot in your target system.

The Address option executes the program from the address specified.

See Also

"Step 4. Connect the reset flying lead to the target system" in the "Plugging the Emulator into Target Systems" chapter.
To stop program execution

- Choose the Execution→Break (ALT, E, B) command, or press the F4 key.

As soon as the Execution→Break (ALT, E, B) command is chosen, the emulator starts running in the monitor.

To reset the processor

- Choose the Execution→Reset (ALT, E, E) command.

Once the command has been completed, the processor remains reset if monitor intrusion is disallowed. If monitor intrusion is allowed, the emulation microprocessor may switch immediately from reset to running in monitor, for example, to update the contents of a register window.

If a foreground monitor is selected, it will automatically be loaded when this command is executed. This is done to make sure the foreground monitor code is intact.
Using Breakpoints and Break Macros

This section shows you how:

- To set a breakpoint
- To disable a breakpoint
- To delete a single breakpoint
- To list the breakpoints and break macros
- To set a break macro
- To delete a single break macro
- To delete all breakpoints and break macros

A breakpoint is an address you identify in the user program where program execution is to stop. Breakpoints let you look at the state of the target system at particular points in the program.

A break macro is a breakpoint followed by any number of macro commands (which are the same as command file commands).

You may have any number of "software breakpoints", which are set by replacing opcodes in the program.

You may have up to four "hardware breakpoints", which are breakpoints for code in target system ROM. Hardware breakpoints are set by requiring the emulator to remember the breakpoint address (because breakpoint opcodes cannot be replaced in target system ROM).

Software and hardware breakpoints can be set on executions, write transactions, and read transactions.

All breakpoints are deleted when RTC is exited.
To set a breakpoint

1. Position the cursor on the line where you wish to set a breakpoint.

2. Choose the Breakpoint→Set at Cursor (ALT, B, S) command.

When you run the program and the breakpoint is hit, execution stops immediately before the breakpoint line. The current program counter location is highlighted.

Example

To set a breakpoint at line 56:

```
0042 char *mess;
0043 for(mess = dat->message; *mess != '\0'; mess++)
0044     if(*mess >= 'a' && *mess <= 'z')
0045         mess = mess - 'a' + 'A';
0046     else if(*mess >= '0' && *mess <= 'Z')
0047         mess = mess - 'A' + 'a';
0048 }
0049 }
0051 }
0052 change_status(int st) /* Change status of the
0053     if(st == ORIGINAL
0054         return(CONVERTED);
0055     else
```
To disable a breakpoint

1. Choose the Breakpoint→Edit... (ALT, B, E) command.

2. Select the breakpoint to be disabled.

3. Choose the Enable/Disable button. Notice that "DI" appears next to the breakpoint in the list.

4. To close the dialog box, choose the Close button.

You can reenable a breakpoint in the same manner by choosing the Breakpoint→Edit... (ALT, B, E) command, selecting a disabled breakpoint from the list, and choosing the Disable/Enable button.

To delete a single breakpoint

- Position the cursor on the line that has the breakpoint to be deleted, and choose the Breakpoint→Delete at Cursor (ALT, B, D) command.

Or:

1. Choose the Breakpoint→Edit... (ALT, B, E) command.

2. Select the breakpoint to be deleted.

3. Choose the Delete button.

4. Choose the Close button.

The Breakpoint→Edit... (ALT, B, E) command allows you to delete all the breakpoints and break macros at once with the Delete All button.
To list the breakpoints and break macros

- Choose the Breakpoint→Edit... (ALT, B, E) command.

The command displays breakpoints followed by break macro commands in parentheses.

The Breakpoint Edit dialog box also allows you to delete breakpoints and break macros.

To set a break macro

1. Position the cursor on the line where you wish to set a break macro.

2. Choose the Breakpoint→Set Macro... (ALT, B, M) command.

3. Select the Add Macro check box in the Breakpoint Edit dialog box.

4. Specify the macro command in the Macro Command text box.

5. Choose the Set button.

6. To add another macro command, repeat steps 4 and 5.

7. To exit the Breakpoint Edit dialog box, choose the Close button.

The debugger automatically executes the specified macro commands when the break macro line is reached.

To add macro commands after an existing macro command, position the cursor on the macro command before choosing Breakpoint→Set Macro... (ALT, B, M).
To add macro commands to the top of an existing break macro, position the cursor on the line that contains the BP marker before choosing Breakpoint→Set Macro... (ALT, B, M).

Example

Position the cursor on line 62; then, choose the Breakpoint→Set Macro... (ALT, B, M) command.

Select the Add Macro check box.

Enter "EVALUATE *mes" in the Macro Command text box.

Choose the Set button.

Enter "RUN" in the Macro Command text box.
Choose the Set button.

Choose the Close button.

The break macro is displayed in the Source window as shown below.
To delete a single break macro

1. Position the cursor on the line that contains the break macro to be deleted.

2. Choose the Breakpoint $\rightarrow$ Delete Macro (ALT, B, L) command.

To delete a single macro command that is part of a break macro, position the cursor on the macro command before choosing Breakpoint $\rightarrow$ Delete Macro (ALT, B, L).

The Breakpoint $\rightarrow$ Edit... (ALT, B, E) dialog box allows you to delete all the breakpoints and break macros at once by choosing the Delete All button. Also, by selecting the Global Disable and Delete All check box, you can delete all breakpoints and break macros and prevent creation of new breakpoints and break macros.

To delete all breakpoints and break macros

1. Choose the Breakpoint $\rightarrow$ Edit... (ALT, B, E) command.

2. Choose the Delete All button.

3. Select the Global Disable and Delete All check box.

4. Choose the Close button.

The Breakpoint $\rightarrow$ Edit... (ALT, B, E) command allows you to delete all the breakpoints and break macros at once with the Delete All button. Also, you can delete all breakpoints and break macros and prevent creation of new breakpoints and break macros by selecting the Global Disable and Delete All check box.
Displaying and Editing Variables

This section shows you how:

- To display a variable
- To edit a variable
- To monitor a variable in the WatchPoint window

To display a variable

1. Position the mouse pointer over the variable in the Source window and double-click the left mouse button.

2. Choose the Variable→Edit... (ALT, V, E) command.

3. Choose the Update button to read the contents of the variable and display the value in the dialog box.

4. To exit the Variable dialog box, choose the Close button.

Note that you can update the contents of an auto variable only while the program executes within the scope of the function.
To edit a variable

1 Position the mouse pointer over the variable in the Source window and double-click the left mouse button.

2 Choose the Variable→Edit... (ALT, V, E) command.

3 Choose the Modify button. This opens the Variable Modify dialog box.

4 Type the desired value in the Value text box. The value must be of the type specified in the Type field.

5 Choose the OK button.

6 Choose the Close button.

Note that you can change the contents of an auto variable only while the program executes within the scope of the function.
To monitor a variable in the WatchPoint window

1 Highlight the variable in the Source window by either double-clicking the left mouse button or by holding the left mouse button down and dragging the mouse pointer over the variable.

2 Choose the Variable→Edit... (ALT, V, E) command.

3 Choose the "to WP" button.

4 Choose the Close button.

5 To open the WatchPoint window, choose the Window→WatchPoint command.

Note that you can only monitor an auto variable in the WatchPoint window when the program executes within the scope of the function.
Displaying and Editing Memory

This section shows you how:

- To display memory
- To edit memory
- To copy memory to a different location
- To copy target system memory into emulation memory
- To modify a range of memory with a value
- To search memory for a value or string

To display memory

1. Choose the RealTime→Memory Polling→ON (ALT, R, M, O) command.

2. Choose the Window→Memory command.

3. Double-click one of the addresses.

4. Use the keyboard to enter the address of the memory locations to be displayed.

5. Press the Enter key.

An address may be entered as a value or symbol. You can also select the desired address by using the scroll bar.

To change the size of the data displayed, access the Memory window's control menu; then, choose the Display→Byte (ALT, -, D, Y), Display→16 Bits (ALT, -, D, 1), or Display→32 Bits (ALT, -, D, 3) command. When the
Display→Byte (ALT, -, D, Y) command is chosen, ASCII values are also displayed.

To specify whether memory is displayed in a single-column or multicolumn format, access the Memory window’s control menu; then, choose the Display→Linear (ALT, -, D, L) or Display→Block (ALT, -, D, B) command. When the Display→Linear (ALT, -, D, L) command is chosen, symbolic information associated with an address is also displayed.

The Memory window display is updated periodically. When the window displays the contents of target system memory, user program execution is temporarily suspended as the display is updated. To prevent program execution from being temporarily suspended (and the Memory window from being updated), choose the RealTime→Monitor Intrusion→Disallowed (ALT, R, T, D) command to activate the real-time mode.

Example
Memory Displayed in Byte Format

<table>
<thead>
<tr>
<th>Address</th>
<th>Memory</th>
</tr>
</thead>
<tbody>
<tr>
<td>00037:001f4</td>
<td>01 00 54 68 69 73 20 69 ..This is a sample</td>
</tr>
<tr>
<td>00037:001fc</td>
<td>73 20 61 20 73 61 6D 70 6E progr</td>
</tr>
<tr>
<td>00037:00204</td>
<td>6C 65 20 72 6F 67 72 le program</td>
</tr>
<tr>
<td>00037:0028c</td>
<td>61 6D 00 00 00 00 00 00 and_loader</td>
</tr>
<tr>
<td>00037:00214</td>
<td>00 00 00 00 00 00 00 00 ........</td>
</tr>
<tr>
<td>00037:0081c</td>
<td>00 00 00 01 00 55 75 20 65 ........Udppe</td>
</tr>
<tr>
<td>00037:00224</td>
<td>72 20 61 6E 64 20 4C 6F r and wer</td>
</tr>
<tr>
<td>00037:0022c</td>
<td>77 6E 72 20 43 61 73 65 75 ver Case</td>
</tr>
<tr>
<td>00037:00234</td>
<td>20 43 6F 6E 7B 65 72 73 73 Convers</td>
</tr>
<tr>
<td>00037:0023c</td>
<td>6D 6F 00 00 00 00 00 00 00 ion .....</td>
</tr>
<tr>
<td>00037:00244</td>
<td>00 00 00 00 00 00 10 00 98 ........</td>
</tr>
</tbody>
</table>
| 00037:0024c | 00 C8 00 00 77 4D 00 00 ...........
| 00037:00254 | 04 B1 21 DF 00 00 00 02 ........ |
| 00037:0025c | 00 80 00 C2 25 7D 61 5D ........ |
| 00037:00264 | 6E EF 03 9B 00 58 00 61 ........X |
| 00037:0026c | 00 52 00 61 00 CF 80 FF .R.a... |
To edit memory

Assuming the location you wish to edit has already been displayed (and Memory window polling is turned ON):

1 Double-click the location you wish to edit.

2 Use the keyboard to enter a new value.

3 Press the Enter key. Notice that the next location is highlighted.

4 Repeat steps 2 and 3 to edit successive locations.

Editing the contents of target system memory causes user program execution to be temporarily interrupted. You cannot modify the contents of target memory when the emulator is running the user program and monitor intrusion is disallowed.
To copy memory to a different location

1. From the Memory window’s control menu, choose the Utilities→Copy... (ALT, -, U, C) command.

2. Enter the starting address of the range to be copied in the Start text box.

3. Enter the end address of the range to be copied in the End text box.

4. Enter the address of the destination in the Destination text box.

5. Choose the Execute button.

6. To close the Memory Copy dialog box, choose the Close button.
To copy target system memory into emulation memory

1 Map the address range to be copied as emulation memory.

2 Because the processor cannot read target system memory when it is in the EMULATION RESET state, choose the Execution→Break (ALT, E, B) command, or press the F4 key, to break execution into the monitor.

3 From the Memory window’s control menu, choose the Utilities→Image... (ALT, -, U, I) command.

4 Enter the starting address in the Start text box.

5 Enter the end address in the End text box.

6 Choose the Execute button.

7 To exit the Memory Image Copy dialog box, choose the Close button.

This command is used to gain access to features that are only available with emulation memory (like breakpoints).

If you want to use more than four breakpoints in target system ROM, you may use the Utilities→Image... command to copy the content of target system ROM into emulation RAM. In the memory map, identify the code as being in emulation RAM. Once the code is in emulation RAM, you can use any number of software breakpoints in it instead of the four hardware breakpoints.

Note that the following commands use breakpoints:

- Breakpoint→Set at Cursor (ALT, B, S)
- Breakpoint→Delete at Cursor (ALT, B, D)
- Breakpoint→Set Macro... (ALT, B, M)
- Breakpoint→Delete Macro (ALT, B, L)


**Example**

To copy the contents of addresses 0 through 0fffh from target system memory to the corresponding emulation memory address range:

![Memory Image]

To modify a range of memory with a value:

1. From the Memory window’s control menu, choose the Utilities→Fill... (ALT, -, U, F) command.

2. Enter the desired value in the Value text box.

3. Enter the starting address of the memory range in the Start text box.

4. Enter the end address in the End text box.

5. Select one of the Size options.

6. Choose the Execute button.

The Byte, 16 Bit, or 32 Bit size option specifies the size of the values that are used to fill memory.
To search memory for a value or string

1. From the Memory window’s control menu, choose the Search... (ALT, -, R) command.

2. Enter in the Value or String text box the value or string to search for.

3. Enter the starting address in the Start text box.

4. Enter the end address in the End text box.

5. Choose the Execute button.

6. Choose the Close button.

When the specified data is found, the location at which the value or string was found is displayed in the Memory window.

Example

To search addresses 6000h through 0ffffh, for the string "This":

<table>
<thead>
<tr>
<th>Search Memory</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Value:</strong></td>
</tr>
<tr>
<td><strong>String:</strong> This</td>
</tr>
<tr>
<td><strong>Start:</strong> 6000</td>
</tr>
<tr>
<td><strong>End:</strong> 0fff</td>
</tr>
<tr>
<td><strong>Size:</strong> 8 byte</td>
</tr>
</tbody>
</table>

---

113
Displaying and Editing GDT, LDT, and IDT Windows

This section shows you how:

• To display the GDT, LDT, and IDT windows
• To edit the GDT, LDT, and IDT windows

To display the GDT, LDT, and IDT windows

• Choose the Window→GDT, Window→LDT, or the Window→IDT, command.

The Window→GDT, Window→LDT, and Window→IDT commands display the contents of the specified window.

The debugger periodically reads the GDT, LDT, and IDT locations and displays the latest content in the selected window.
To edit the GDT, LDT, and IDT windows

1. Choose the Window→GDT, Window→LDT, or Window→IDT command.

2. Find the physical address associated with the value to be changed.

3. Display the Memory window with the Window→Memory command.

4. Find the same physical address in the Memory window that you found in the GDT, LDT, or IDT window.

5. Use the keyboard to modify the content associated with the physical address, as desired.

6. Press the Enter key. Notice that the next location is highlighted.

As long as the cursor remains in the Memory window, the GDT, LDT, or IDT window will not show your new value. Move the cursor out of the Memory window to see the GDT, LDT, or IDT window update to the new value.
Displaying and Editing I/O Locations

This section shows you how:

- To display I/O locations
- To edit an I/O location

To display I/O locations

1. Choose the Window→I/O command.
2. From the I/O window’s control menu, choose the Define... (ALT, -, D) command.
3. Enter the address in the Address text box.
4. Select whether the size of the I/O location is a Byte, 16 Bits, or 32 Bits.
5. Select whether the I/O location is in Memory or I/O space.
6. Choose the Set button.
7. Choose the Close button.

The Window→I/O command displays the contents of the specified I/O locations.

The debugger periodically reads the I/O locations and displays the latest status in the I/O window. To prevent the debugger from reading the I/O locations (and updating the I/O window), choose the RealTime→I/O Polling→OFF (ALT, R, I, F) command.
Example

To display the contents of address 2000:

1. Display the I/O value to be changed with the Window→I/O command.
2. Double-click the value to be changed.
3. Use the keyboard to enter a new value.
4. Press the Enter key.

To confirm the modified values, press the Enter key for every changed value.

Editing the I/O locations temporarily halts user program execution. You cannot modify I/O locations while the user program executes in the real-time mode or when I/O polling is turned OFF.
Displaying and Editing Registers

This section shows you how:

- To display registers
- To edit registers

To display registers

- Choose the Window→Basic Registers command.

The register values displayed in the window are periodically updated to show you how the values change during program execution. The Status Flags register can be displayed and modified as decoded bits by double-clicking on its value.

When the register windows are updated, user program execution is temporarily interrupted. To prevent the user program from being interrupted (and the register windows from being updated), choose the RealTime→Monitor Intrusion→Disallowed (ALT, R, T, D) command to activate the real-time mode.
### Example

Register Contents Displayed in the Basic Registers Window

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>eip</td>
<td>0000019F</td>
<td>Instruction Pointer</td>
</tr>
<tr>
<td>eflags</td>
<td>FFPCE26E</td>
<td>Condition/Control Flags</td>
</tr>
<tr>
<td>eax</td>
<td>00000001</td>
<td>General Register A</td>
</tr>
<tr>
<td>ebx</td>
<td>00000000</td>
<td>General Register B</td>
</tr>
<tr>
<td>ecx</td>
<td>00000000</td>
<td>General Register C</td>
</tr>
<tr>
<td>edx</td>
<td>00000000</td>
<td>General Register D</td>
</tr>
<tr>
<td>esi</td>
<td>FFFFFFF9</td>
<td>Source Index</td>
</tr>
<tr>
<td>edi</td>
<td>FFFFFFFB8</td>
<td>Destination Index</td>
</tr>
<tr>
<td>ebp</td>
<td>0000FFEC</td>
<td>Base Pointer</td>
</tr>
<tr>
<td>esp</td>
<td>0000FFEC</td>
<td>Stack Pointer</td>
</tr>
<tr>
<td>cr0</td>
<td>7FFEFFF9</td>
<td>Machine Control</td>
</tr>
<tr>
<td>cr2</td>
<td>00000000</td>
<td>Page Fault Linear Addr</td>
</tr>
<tr>
<td>cr3</td>
<td>00000000</td>
<td>Page Directory Base Addr</td>
</tr>
<tr>
<td>tr6</td>
<td>00000002</td>
<td>Test Control</td>
</tr>
<tr>
<td>tr7</td>
<td>00000000</td>
<td>Test Data</td>
</tr>
</tbody>
</table>
To edit registers

1 Display the register contents by choosing the Window→Basic Registers command or the Window→System Registers command.

2 Double-click the value to be changed.

3 Use the keyboard to enter a new value.

4 Press the Return key.

Modifying register contents temporarily interrupts program execution. You cannot modify register contents while the user program is running and monitor intrusion is disallowed.

Note that register values are not actually changed until the Return key is pressed.

Double-clicking registers with flags or other bit fields opens the Register Bit Fields dialog box which you can use to set or clear individual bit fields.
Tracing Program Execution

This section shows you how:

• To trace callers of a specified function
• To trace execution within a specified function
• To trace accesses to a specified variable
• To trace until the command is halted
• To stop a running trace
• To repeat the last trace
• To display bus cycles
• To display absolute or relative counts
• To display or suppress unexecuted prefetches
• To swap instruction bytes in display of data-bus values

How the Analyzer Works

When you trace program execution, the analyzer captures microprocessor address bus, data bus, and control signal values at each clock cycle. The values captured for one clock cycle are collectively called a state. A trace is a collection of these states stored in analyzer memory (also called trace memory).

The trigger condition tells the analyzer when to store states in trace memory. The trigger position specifies whether states are stored before, after, or about the state that satisfies the trigger condition.

The store condition limits the kinds of states that are stored in trace memory. When the states stored must satisfy a store-qualifier condition, up to two states which satisfy the prestore condition may be stored when they occur before the states that satisfy the store condition.

After a captured state satisfies the trigger condition, a trace becomes complete when trace memory is filled with states that satisfy the store and prestore conditions.
See "Understanding Intel80386EX Analysis" to understand how the analyzer works with the prefetching of the Intel80386EX, how the disassembler decodes the bus cycles, and how to use Execution Trace Messages to resolve questions about the exact target address of branches.

**Trace Window Contents**

When traces are completed, the Trace window is automatically opened to display the trace results.

Each line in the trace shows the trace buffer state number, the type of state, the module name and line number, the function name, the source file information, and the time the state was captured (relative to the other states, by default).

When bus cycles are included, the address, data, and disassembled instruction or bus cycle status mnemonics are shown.

**Tracing Monitor Cycles**

When the emulator is executing monitor code, cycles are generated, but usually not all cycles are captured by the analyzer. The Intel80386EX emulator allows you to determine the types of monitor cycles to be captured when using the foreground monitor, and the types of monitor cycles to be ignored, as follows:

Default: By default, accesses by the monitor to non-monitor address space are traced. Execution of monitor code is not traced. This means that if the monitor reads memory to update the memory window, the trace list will show memory reads from the accessed addresses. However, the code executed by the monitor to read the addresses will not be shown.

Quiet: You can set up the emulator to prevent capture of states to target addresses while executing in the monitor. This will prevent the capture of monitor read cycles when the monitor updates the memory window, but it may also prevent capture of useful information, too. For example, if you are using the foreground monitor and an interrupt arrives, your interrupt code will execute but the analyzer will not capture its execution in the trace list.

Complete: You can set up the emulator to capture all states generated by the monitor. This will let you see the execution of the monitor in addition to its accesses to non-monitor address space. This is generally used to help debug a custom foreground monitor.
To set up the monitor trace options:

Default:
Settings→Extended→Trace Cycles→User
Settings→Emulator Config→Hardware... then make sure the "Enable Foreground Monitor Traced as User" box is checked.

Quiet:
Settings→Extended→Trace Cycles→User
Settings→Emulator Config→Hardware... then make sure the "Enable Foreground Monitor Traced as User" box is not checked.

Complete:
Settings→Extended→Trace Cycles→Both
Settings→Emulator Config→Hardware... then make sure the "Enable Foreground Monitor Traced as User" box is checked.
To trace callers of a specified function

1 Double-click the function name in one of the debugger windows.

2 Choose the Trace→Function Caller... (ALT, T, C) command.

3 Choose the OK button.

This command stores the first executable statement of the specified function and prestores statements that execute before it. The prestored statements show the caller of the function.

To identify interrupts in program execution, trace the caller of the interrupt process routine using the Trace→Function Caller... (ALT, T, C) command.
To trace the caller of "next_message":

Double-click "next_message".

Choose the Trace→Function Caller... (ALT, T, C) command.

The Trace window becomes active and displays the trace results.

You can see how prefetching affects tracing by choosing the Display→Mixed Mode (ALT, -, D, M) command from the Trace window’s control menu.
To trace execution within a specified function

1. Double-click the function name in the Source window.

2. Choose the Trace→Function Statement... (ALT, T, S) command.

This command traces C functions only. It does not trace execution of assembly language subroutines.

Example

To trace execution within "next_message":

Double-click "next_message."

Choose the Trace→Function Statement... (ALT, T, S) command.

The Trace window becomes active and displays the results. You can see how prefetching affects tracing by choosing the Display→Mixed Mode (ALT, -, D, M) command from the Trace window’s control menu.
To trace accesses to a specified variable

1 Double-click the global variable name in the Source window.

2 Choose the Trace→Variable Access... (ALT, T, V) command.

The command also traces access to the Assembler symbol specified by its name and size.

Example

To trace access to "message_id":

Double-click "message_id."

Choose the Trace→Variable Access... (ALT, T, V) command.

The Trace window becomes active and displays the trace results.
To trace until the command is halted

1 To start the trace, choose the Trace→Until Halt (ALT, T, U) command.

2 When you are ready to stop the trace, choose the Trace→Halt (ALT, T, H) command.

This command is useful, for example, in tracing program execution that leads to a processor halted state or to a break to the monitor.

To stop a running trace

- Choose the Trace→Halt (ALT, T, H) command.

The command is used to:

1 Stop the trace initiated with the Trace→Until Halt (ALT, T, U) command.
2 Force termination of the trace that cannot be completed due to absence of the specified state.
3 Stop a trace before the trace buffer becomes full.

To repeat the last trace

- Choose the Trace→Again (ALT, T, A) command, or press the F7 key.

The Trace→Again (ALT, T, A) command traces program execution using the last trace specification stored in the HP 64700.
To display bus cycles

1. Place the cursor on the line from which you wish to display the bus cycles.

2. From the Trace window’s control menu, choose the Display→Mixed Mode (ALT, -, D, M) command or the Display→Bus Cycle Only (ALT, -, D, C) command.

The Display→Mixed Mode (ALT, -, D, M) command displays each source line followed by the bus cycles associated with it.

The Display→Bus Cycle Only (ALT, -, D, C) command displays the bus cycles without the source lines.

The display starts from the cursor-selected line.

To hide the bus cycles, choose the Display→Source Only (ALT, -, D, S) command from the Trace window’s control menu.

**Example**

Bus Cycles Displayed in Trace with "Mixed Mode" selected:

![Bus Cycles Displayed in Trace](image)
To display absolute or relative counts

- From the Trace window’s control menu, choose the Display→Count→Absolute (ALT, -, D, C, A) or Display→Count→Relative (ALT, -, D, C, R) command.

Choosing the Display→Count→Relative (ALT, -, D, C, R) command selects the relative mode where the state-to-state time intervals are displayed.

Choosing the Display→Count→Absolute (ALT, -, D, C, A) command selects the absolute mode where the trace time is displayed as the total time elapsed since the analyzer has been triggered.

To display or suppress unexecuted prefetches

- From the Trace window’s control menu, choose the Display→Options→Suppress Prefetch (ALT, -, D, O, S) command.

Unexecuted instructions appearing in a trace list can make the trace list difficult to read and understand. Use this feature to confine the content of the trace list to cycles that were executed during the run of the program.

When selected, a check mark will appear beside Suppress Prefetch. The trace list will show only executed cycles.

When unselected (the default), no check mark will appear beside Suppress Prefetch. The trace list will show all traced cycles, whether or not they were executed.

The selection you make with the Display→Options→Suppress Prefetch (ALT, -, D, O, S) command only affects display of unexecuted prefetches in the trace list.

To restore the default display of all traced cycles in the Trace window, again choose the Display→Options→Suppress Prefetch (ALT, -, D, O, S) command from the Trace window’s control menu.
To swap instruction bytes in display of data-bus values

- From the Trace window’s control menu, choose the Display→Options→Swap Instruction Bytes (ALT, -, D, O, I) command.

When you swap instruction bytes, the byte order of the displayed data-bus values is reversed for instruction fetch cycles. This makes it easier to correlate data bytes with the opcode bytes in assembler listings and/or the Source window. A data-bus value of 40302010 swapped will be displayed as 10203040.

If Swap Instruction Bytes is checked, little endian order is selected. Bytes are arranged in the data column in this order: D[7:0], D[15:8], D[23:16], D[31:24].

If Swap Instruction Bytes is not checked (default), big endian order is selected. Bytes are arranged in the data column in this order: D[31:0].

The selection you make with the Display→Options→Swap Instruction Bytes (ALT, -, D, O, I) command only affects data-bus values corresponding to instruction fetches (opcodes).

To restore the default order to data bytes shown for instruction fetches in the Trace window, again choose the Display→Options→Swap Instruction Bytes (ALT, -, D, O, I) command from the Trace window’s control menu.
Setting Up Custom Trace Specifications

This section shows you how:

- To set up a "Trigger Store" trace specification
- To set up a "Find Then Trigger" trace specification
- To set up a "Sequence" trace specification
- To edit a trace specification
- To trace "windows" of program execution
- To store the current trace specification
- To load a stored trace specification

**Note**

Analyzer memory is unloaded two states at a time. If you use a storage qualifier to capture states and state capture proceeds slowly, it's possible that one captured state may be stored but it cannot be displayed because another state must be stored before the pair can be unloaded. When this happens, you can stop the trace measurement to see all stored states. All states can be unloaded when the trace measurement is stopped.

**When Do I Use the Different Types of Trace Specifications?**

When you wish to trigger the analyzer on the occurrence of one state, use the "Trigger Store" dialog box to set up the trace specification.

When you wish to trigger the analyzer on the occurrence of one state followed by another state, or one state followed by another state but only when that state occurs before a third state, use the "Find Then Trigger" dialog box to set up the trace specification.

When you wish to trigger the analyzer on a sequence of more than two states, use the "Sequence" dialog box to set up the trace specification.
To set up a "Trigger Store" trace specification

1 Choose the Trace→Trigger Store... (ALT, T, T) command.

2 Specify the trigger condition using the Address, Data, and/or Status text boxes within the Trigger group box.

3 Specify the trigger position by selecting the trigger start, trigger center, or trigger end option in the Trigger group box.

4 Specify the store condition using the Address, Data, and/or Status text boxes within the Store group box.

5 Choose the OK button to set up the analyzer and start the trace.

The Trace→Trigger Store... (ALT, T, T) command opens the Trigger Store Trace dialog box:

A group of Address, Data, and Status text boxes combine to form a state qualifier. You can specify an address range by entering a value in the End Address box. By selecting the NOT check box, you can specify all states other than those identified by the address, data, and status values.
Example

To trace execution after the "convert_case" function:

Choose the Trace→Trigger Store... (ALT, T, T) command.

Enter "convert_case" in the Address text box in the Trigger group box.

Choose the OK button.

Example

To trace execution before and after the "convert_case" function and store only states with "write" status:
Example

To specify the trigger condition as any address in the range 1000h through 1fffh:
To set up a "Find Then Trigger" trace specification

1. Choose the Trace→Find Then Trigger... (ALT, T, D) command.

2. Specify the sequence, which is made up of the enable, trigger store, trigger, and store conditions.

3. Specify the restart, count, and prestore conditions.

4. Specify the trigger position by selecting the trigger start, trigger center, or trigger end option.

5. If you want emulator execution to break to the monitor when the trigger condition occurs, select the Break On Trigger check box.

6. Choose the OK button to set up the analyzer and start the trace.

The Trace→Find Then Trigger... (ALT, T, D) command opens the Find then Trigger Trace dialog box:

Choosing the enable, trigger, store, count, or prestore buttons opens a Condition dialog box that lets you select "any state," "no state," trace patterns
"a" through "h," "range," or "arm" as the condition. Patterns "a" through "h," "range," and "arm" are grouped into two sets, and resources within a set may be combined using the "or" or "nor" logical operators. Resources from the two sets may be combined using the OR or AND logical operators.

The range and pattern resources are defined by double-clicking on the resource name in the Pattern/Range list box.

If you double-click on a pattern name, the Trace Pattern dialog box is opened to let you specify address, data, and status values. By selecting the NOT check box, you can specify all states other than those identified by the address, data, and status values. The Direct check box lets you specify status values other than those that have been predefined.
If you double-click on the range resource (bottom of the Pattern/Range list box), the Trace Range dialog box is opened to let you select either the Address range or the Data range option and enter the minimum and maximum values in the range.

![Trace Range Dialog Box]

**Example**

To trace execution after the "convert_case" function:

Choose the Trace→Find Then Trigger... (ALT, T, D) command.

Choose the Trigger button (default: any state).

Select "a."

![Trace Condition Dialog Box]

Choose the OK button.
Double-click "a" in the Pattern/Range list box.

Enter "convert_case" in the Address text box in the Trace Pattern dialog box.

Choose the OK button in the Trace Pattern dialog box.

Choose the OK button in the Find then Trigger Trace dialog box.
Example

To trace about the "next_message" function when it follows the "change_status" function and store all states after the "change_status" function:

![Diagram of find the trigger trace interface]

- Sequence:
  - Enable Store: [no state]
  - Enable: [a]
  - Trigger Store: [any state]
  - Trigger: [b]
  - Store: [any state]

- Event:
  - Count: [time]
  - Event: [no state]

- Pattern/Range: (Select with Double-Click)
  - a = A: change_status D: S;
  - b = A: next message D: S;
  - c = A: D: S;
  - d = A: D: S;
  - e = A: D: S;
To set up a "Sequence" trace specification

Sequence trace specifications let you trigger the analyzer on a sequence of several captured states.

There are eight sequence levels. When a trace is started, the first sequence level is active. You select one of the remaining sequence levels as the level that, when entered, will trigger the analyzer. Each level lets you specify two conditions that, when satisfied by a captured state, will cause branches to other levels:

```plaintext
if (state matches primary branch condition)
    then GOTO (level associated with primary branch)
else if (state matches secondary branch condition)
    then GOTO (level associated with secondary branch)
else
    stay at current level
```

Note that if a state matches both the primary and secondary branch conditions, the primary branch is taken.

Each sequence level also has a store condition that lets you specify the states that get stored while at that level.

1. Choose the Trace→Sequence... (ALT, T, Q) command.

2. Specify the primary branch, secondary branch, and store conditions for each sequence level you will use.

3. Specify which sequence level to trigger on. The analyzer triggers on the entry to the specified level. Therefore, the condition that causes a branch to the specified level actually triggers the analyzer.

4. Specify the count and prestore conditions.

5. Specify the trigger position by selecting the trigger start, trigger center, or trigger end option.
If you want emulator execution to break to the monitor when the trigger condition occurs, select the **Break On Trigger** check box.

Choose the OK button to set up the analyzer and start the trace.

The Trace→Sequence... (ALT, T, Q) command calls the Sequence Trace Setting dialog box, where you make the following trace specifications:

Choosing the primary branch, secondary branch, store, count, or prestore buttons opens a Condition dialog box that lets you select "any state," "no state," trace patterns "a" through "h," "range," or "arm" as the condition. Patterns "a" through "h," "range," and "arm" are grouped into two sets, and resources within a set may be combined using the "or" or "nor" logical operators. Resources in the two sets may be combined using the OR or AND logical operators.
The range and pattern resources are defined by double-clicking on the resource name in the Pattern/Range list box.

If you double-click on a pattern name, the Trace Pattern dialog box is opened to let you specify address, data, and status values. By selecting the NOT check box, you can specify all states other than those identified by the address, data, and status values. The Direct check box lets you specify status values other than those that have been predefined.

If you double-click on the range resource at the bottom of the Pattern/Range list box, the Trace Range dialog box is opened to let you select either the Address range option or the Data range option and enter the minimum and maximum values in the range.
Example

To specify address "convert_case" as the trigger condition:

Example

To specify execution of "convert_case" and "next_message" as the trigger sequence:
To edit a trace specification

1 Choose the Trace→Edit... (ALT, T, E) command.

2 Using the Sequence Trace dialog box, edit the trace specification as desired.

3 Choose the OK button.

You can use this command to edit trace specifications, including trace specifications that are automatically set up. For example, you can use this command to edit the trace specification that is set up when the Trace→Function Caller... (ALT, T, C) command is chosen.

You can also use Trace→Trigger Store..., Trace→Find Then Trigger..., and Trace→Sequence..., if desired. Modifications made in these dialog boxes will be transferred directly to the Trace→Edit... dialog box.

To trace "windows" of program execution

1 Because pairs of sequence levels are used to capture window enable and disable states both before and after the trigger, choose the Trace→Sequence... (ALT, T, Q) command.

2 Set up the sequence levels, patterns, and other trace options (as described below) in the Sequence Trace dialog box.

3 Choose the OK button.

When you trace "windows" of program execution, you store states that occur between one state and another state. Storing states that occur between two states is different from the trace specification set up by the Trace→Statement... (ALT, T, S) command, which stores states in a function's range of addresses.
In a typical windowing trace specification, sequence levels are paired. The first sequence level searches for the window enable state, and no states are stored while searching. When the window enable state is found, the second sequence level stores the states you have qualified for storage ("any state" in the example below) while searching for the window disable state.

If you want to store the window of code execution before and after the trigger condition, use two sets of paired sequence levels: one window enable/disable pair of sequence levels before the trigger, and another disable/enable pair after the trigger, as shown below.

Notice that the order of the second sequence level pair is swapped. In sequence level 2, if the analyzer finds the trigger condition while searching for the window disable state, it will branch to sequence level 3 where it continues its search for the window disable state. After this, the analyzer will remain in sequence levels 3 and 4 until the trace memory is filled, completing the trace.
To trace the window of code execution between lines 46 and 51 of the sample program, triggering on any state in the window:

Notice that the analyzer triggers on the entry to sequence level 3. The primary branch condition in level 2 actually specifies the trigger condition.

To store the current trace specification:

1. Choose the Trace→Edit... (ALT, T, E) command.
2. Choose the Save... button.
3. Specify the name of the trace specification file.
4. Choose the OK button.

You can also store trace specifications from the Trigger Store Trace, Find Then Trigger Trace, or Sequence Trace dialog boxes.

The extension for trace specification files defaults to ".TRC".
To load a stored trace specification

1 Choose the Trace→Trigger Store... (ALT, T, T), Trace→Find Then Trigger... (ALT, T, D), Trace→Sequence... (ALT, T, Q), or Trace→Edit... (ALT, T, E) command.

2 Choose the Load... button.

3 Select the desired trace specification file.

4 Choose the OK button.

A "Trigger Store" trace specification file can be loaded into any of the trace setting dialog boxes. A "Find Then Trigger" trace specification file can be loaded into either the Find Then Trigger Trace or Sequence Trace dialog boxes. A "Sequence" trace specification file can only be loaded into the Sequence Trace dialog box.
Part 3

Reference

Descriptions of the product in a dictionary or encyclopedia format.
Command File and Macro Command Summary
Command File and Macro Command Summary

This section lists the Real-Time C Debugger break macro and command file commands, providing syntax and brief description for each of the listed commands. For details on each command, refer to the command descriptions.

The characters in parentheses can be ignored for shortcut entry.

### Run Control Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>BRE(AK)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Breaking execution</td>
</tr>
<tr>
<td>COM(E)</td>
<td>address</td>
<td></td>
<td></td>
<td></td>
<td>Run to cursor-indicated line</td>
</tr>
<tr>
<td>OVE(R)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Stepping over</td>
</tr>
<tr>
<td>OVE(R)</td>
<td>count</td>
<td></td>
<td></td>
<td></td>
<td>Repeated a number of times</td>
</tr>
<tr>
<td>OVE(R)</td>
<td>count</td>
<td>address</td>
<td></td>
<td></td>
<td>From specified address</td>
</tr>
<tr>
<td>OVE(R)</td>
<td>count</td>
<td>STA(RT)</td>
<td></td>
<td></td>
<td>From transfer address</td>
</tr>
<tr>
<td>RES(ET)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Resetting processor</td>
</tr>
<tr>
<td>RET(URN)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Until return</td>
</tr>
<tr>
<td>RUN</td>
<td>address</td>
<td></td>
<td></td>
<td></td>
<td>From specified address</td>
</tr>
<tr>
<td>RUN</td>
<td>STA(RT)</td>
<td></td>
<td></td>
<td></td>
<td>From transfer address</td>
</tr>
<tr>
<td>RUN</td>
<td>RES(ET)</td>
<td></td>
<td></td>
<td></td>
<td>From reset</td>
</tr>
<tr>
<td>STE(P)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Stepping</td>
</tr>
<tr>
<td>STE(P)</td>
<td>count</td>
<td></td>
<td></td>
<td></td>
<td>Repeated a number of times</td>
</tr>
<tr>
<td>STE(P)</td>
<td>count</td>
<td>address</td>
<td></td>
<td></td>
<td>From specified address</td>
</tr>
<tr>
<td>STE(P)</td>
<td>count</td>
<td>STA(RT)</td>
<td></td>
<td></td>
<td>From transfer address</td>
</tr>
</tbody>
</table>

### Variable and Memory Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>VARI(ABLE)</td>
<td>variable</td>
<td>TO</td>
<td>data</td>
<td></td>
<td>Changing value of variable</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>FIL(L)</td>
<td>size</td>
<td>addr-range</td>
<td>value</td>
<td>Filling memory contents</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>COP(Y)</td>
<td>size</td>
<td>addr-range</td>
<td>address</td>
<td>Copying memory contents</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>IMA(GP)</td>
<td>size</td>
<td>addr-range</td>
<td></td>
<td>Copying target memory</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>LOA(D)</td>
<td>MOT(OSREC)</td>
<td>file_name</td>
<td></td>
<td>Loading memory from a Motorola S-record file</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>LOA(D)</td>
<td>INT(ELHEX)</td>
<td>file_name</td>
<td></td>
<td>Loading memory from an Intel Hexadecimal file</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>STO(RE)</td>
<td>MOT(OSREC)</td>
<td>addr-range</td>
<td>file_name</td>
<td>Storing memory to a Motorola S-record file</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>STO(RE)</td>
<td>INT(ELHEX)</td>
<td>addr-range</td>
<td>file_name</td>
<td>Storing memory to an Intel Hexadecimal file</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>BYT(E)</td>
<td></td>
<td></td>
<td></td>
<td>Byte format display</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>WOR(D)</td>
<td></td>
<td></td>
<td></td>
<td>16-Bit format display</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>ABS(GLUTE)</td>
<td></td>
<td></td>
<td></td>
<td>Single-column display</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>BLO(CK)</td>
<td></td>
<td></td>
<td></td>
<td>Multi-column display</td>
</tr>
<tr>
<td>MEM(ORY)</td>
<td>LON(G)</td>
<td></td>
<td></td>
<td></td>
<td>32-Bit format display</td>
</tr>
<tr>
<td>IO</td>
<td>BYTE/WORD/LONG</td>
<td>IOSPACE/MEMORY</td>
<td>address TO data</td>
<td></td>
<td>Editing specified I/O address</td>
</tr>
<tr>
<td>IO</td>
<td>SET</td>
<td>BYTE/WORD/LONG</td>
<td>IOSPACE/MEMORY</td>
<td>address</td>
<td>Registering I/O display</td>
</tr>
<tr>
<td>IO</td>
<td>DEL(ETE)</td>
<td>BYTE/WORD/LONG</td>
<td>IOSPACE/MEMORY</td>
<td>address</td>
<td>Deleting I/O address</td>
</tr>
<tr>
<td>WP</td>
<td>SET</td>
<td>address</td>
<td></td>
<td></td>
<td>Registering watchpoint</td>
</tr>
</tbody>
</table>
WP  DEL(ETE)  address                             Deleting watchpoint
WP  DEL(ETE)  ALL                                 Deleting all watchpoints

Breakpoint Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>MODE</td>
<td>BKP (TBREAK)</td>
<td>ON</td>
<td>OFF</td>
<td></td>
<td>Deletes all/prevents new breakpoints</td>
</tr>
<tr>
<td>BM</td>
<td>SET</td>
<td>address</td>
<td>command</td>
<td></td>
<td>Setting break macro</td>
</tr>
<tr>
<td>BM</td>
<td>SET EXE(C)</td>
<td>breakaddress</td>
<td>command</td>
<td></td>
<td>Setting execution break macro</td>
</tr>
<tr>
<td>BM</td>
<td>SET ACC(Ess)</td>
<td>BYT(E)</td>
<td>breakaddress</td>
<td>command</td>
<td>Setting byte-access break macro</td>
</tr>
<tr>
<td>BM</td>
<td>SET ACC(Ess)</td>
<td>WOR(D)</td>
<td>breakaddress</td>
<td>command</td>
<td>Setting word-access break macro</td>
</tr>
<tr>
<td>BM</td>
<td>SET ACC(Ess)</td>
<td>DWO(RD)</td>
<td>breakaddress</td>
<td>command</td>
<td>Setting doubleword-access break macro</td>
</tr>
<tr>
<td>BM</td>
<td>SET WRI(TE)</td>
<td>BYT(E)</td>
<td>breakaddress</td>
<td>command</td>
<td>Setting byte-write break macro</td>
</tr>
<tr>
<td>BM</td>
<td>SET WRI(TE)</td>
<td>WOR(D)</td>
<td>breakaddress</td>
<td>command</td>
<td>Setting word-write break macro</td>
</tr>
<tr>
<td>BM</td>
<td>SET WRI(TE)</td>
<td>DWO(RD)</td>
<td>breakaddress</td>
<td>command</td>
<td>Setting doubleword-write break macro</td>
</tr>
<tr>
<td>BM</td>
<td>DEL(ETE)</td>
<td>address</td>
<td></td>
<td></td>
<td>Deleting break macro</td>
</tr>
<tr>
<td>BP</td>
<td>SET</td>
<td>address</td>
<td></td>
<td></td>
<td>Setting breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>SET EXE(C)</td>
<td>address</td>
<td></td>
<td></td>
<td>Setting execution breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>SET ACC(Ess)</td>
<td>BYT(E)</td>
<td>address</td>
<td></td>
<td>Setting byte-access breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>SET ACC(Ess)</td>
<td>WOR(D)</td>
<td>address</td>
<td></td>
<td>Setting word-access breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>SET ACC(Ess)</td>
<td>DWO(RD)</td>
<td>address</td>
<td></td>
<td>Setting doubleword-access breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>SET WRI(TE)</td>
<td>BYT(E)</td>
<td>address</td>
<td></td>
<td>Setting byte-write breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>SET WRI(TE)</td>
<td>WOR(D)</td>
<td>address</td>
<td></td>
<td>Setting word-write breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>SET WRI(TE)</td>
<td>DWO(RD)</td>
<td>address</td>
<td></td>
<td>Setting doubleword-write breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>DEL(ETE)</td>
<td>address</td>
<td></td>
<td></td>
<td>Deleting breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>DEL(ETE)</td>
<td>ALL</td>
<td></td>
<td></td>
<td>Deleting breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>DISABLE</td>
<td>address</td>
<td></td>
<td></td>
<td>Disabling a breakpoint</td>
</tr>
<tr>
<td>BP</td>
<td>ENABLE</td>
<td>address</td>
<td></td>
<td></td>
<td>Enabling a breakpoint</td>
</tr>
<tr>
<td>EVA(LUATE)</td>
<td>address</td>
<td></td>
<td></td>
<td></td>
<td>Expression window display</td>
</tr>
<tr>
<td>EVA(LUATE)</td>
<td>&quot;strings&quot;</td>
<td></td>
<td></td>
<td></td>
<td>Printing string</td>
</tr>
<tr>
<td>EVA(LUATE)</td>
<td>CLE(AR)</td>
<td></td>
<td></td>
<td></td>
<td>Clearing Expression window</td>
</tr>
</tbody>
</table>

Window Open/Close Command

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIS(PLAY)</td>
<td>window-name</td>
<td></td>
<td></td>
<td>Opening the named window</td>
<td></td>
</tr>
<tr>
<td>ICO(NIC)</td>
<td>window-name</td>
<td></td>
<td></td>
<td>Closing the named window</td>
<td></td>
</tr>
</tbody>
</table>
## Configuration Command

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>MON(ITOR)</td>
<td>STA(RT)</td>
<td></td>
<td></td>
<td></td>
<td>Starting monitor</td>
</tr>
<tr>
<td>MON(ITOR)</td>
<td>mon-item</td>
<td>mon-ans</td>
<td></td>
<td></td>
<td>Executing monitor</td>
</tr>
<tr>
<td>MON(ITOR)</td>
<td>END</td>
<td></td>
<td></td>
<td></td>
<td>Ending monitor</td>
</tr>
<tr>
<td>CON(FIG)</td>
<td>STA(RT)</td>
<td></td>
<td></td>
<td></td>
<td>Starting configuration</td>
</tr>
<tr>
<td>CON(FIG)</td>
<td>config-item</td>
<td>config-ans</td>
<td></td>
<td></td>
<td>Executing configuration</td>
</tr>
<tr>
<td>CON(FIG)</td>
<td>END</td>
<td></td>
<td></td>
<td></td>
<td>Ending configuration</td>
</tr>
<tr>
<td>MAP</td>
<td>STA(RT)</td>
<td></td>
<td></td>
<td></td>
<td>Starting mapping</td>
</tr>
<tr>
<td>MAP</td>
<td>mem_type</td>
<td>attributes</td>
<td></td>
<td></td>
<td>Executing mapping</td>
</tr>
<tr>
<td>MAP</td>
<td>END</td>
<td></td>
<td></td>
<td></td>
<td>Ending mapping</td>
</tr>
<tr>
<td>MAP</td>
<td>OTHER</td>
<td>mem_type</td>
<td></td>
<td></td>
<td>Mapping OTHER area</td>
</tr>
<tr>
<td>ADDRTRAN</td>
<td>STA(RT)</td>
<td></td>
<td></td>
<td></td>
<td>Starting address translation</td>
</tr>
<tr>
<td>ADDRTRAN</td>
<td>config-item</td>
<td>config-ans</td>
<td></td>
<td></td>
<td>Executing address translation</td>
</tr>
<tr>
<td>ADDRTRAN</td>
<td>END</td>
<td></td>
<td></td>
<td></td>
<td>Ending address translation</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>MNE(MONIC)</td>
<td>ON</td>
<td></td>
<td></td>
<td>Enabling Mnemonic display</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>MNE(MONIC)</td>
<td>OFF</td>
<td></td>
<td></td>
<td>Enabling Source display</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>REA(LTIME)</td>
<td>ON</td>
<td></td>
<td></td>
<td>Enabling real-time mode</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>REA(LTIME)</td>
<td>OFF</td>
<td></td>
<td></td>
<td>Disabling real-time mode</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>IOG(UARD)</td>
<td>ON</td>
<td></td>
<td></td>
<td>Enabling I/O guard</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>IOG(UARD)</td>
<td>OFF</td>
<td></td>
<td></td>
<td>Disabling I/O guard</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>DOW(NLOAD)</td>
<td>NOE(RRABORT)</td>
<td></td>
<td></td>
<td>Load file or memory; ignore errors</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>DOW(NLOAD)</td>
<td>ERR(ABORT)</td>
<td></td>
<td></td>
<td>Load file or memory; abort if error</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>MEM(ORYPOL)</td>
<td>ON</td>
<td></td>
<td></td>
<td>Enabling Memory polling</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>MEM(ORYPOL)</td>
<td>OFF</td>
<td></td>
<td></td>
<td>Disabling Memory polling</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>WAT(CHPOLL)</td>
<td>ON</td>
<td></td>
<td></td>
<td>Enabling WatchPoint polling</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>WAT(CHPOLL)</td>
<td>OFF</td>
<td></td>
<td></td>
<td>Disabling WatchPoint polling</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>LOG</td>
<td>ON</td>
<td></td>
<td></td>
<td>Enabling log file output</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>LOG</td>
<td>OFF</td>
<td></td>
<td></td>
<td>Disabling log file output</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>BNC</td>
<td>INP(UT_ARM)</td>
<td></td>
<td></td>
<td>Setting BNC input</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>BNC</td>
<td>OUT(PUT_TRIGGER)</td>
<td></td>
<td></td>
<td>Setting BNC output</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>SYM(BOLCASE)</td>
<td>ON</td>
<td></td>
<td></td>
<td>Case sensitive symbol search</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>SYM(BOLCASE)</td>
<td>OFF</td>
<td></td>
<td></td>
<td>Case insensitive sym. search</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>TRACECLOCK</td>
<td>BACKGROUND</td>
<td></td>
<td></td>
<td>Trace all processor cycles</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>TRACECLOCK</td>
<td>USER</td>
<td></td>
<td></td>
<td>Trace user program cycles</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>TRACE</td>
<td>DISPLAY</td>
<td>FROM</td>
<td>&lt;state&gt;</td>
<td>Trace disassembly begin from &lt;state&gt;</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>TRACE</td>
<td>DISPLAY</td>
<td>BYTE0/1/2/3</td>
<td></td>
<td>Trace disassembly begin from BYTE&lt;no.&gt;</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>TRACE</td>
<td>DISPLAY</td>
<td>USE16/USE32</td>
<td></td>
<td>Trace disassembly from 16-bit/32-bit segment type</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>TRACE</td>
<td>DISPLAY</td>
<td>SWAPINSTRBYTES</td>
<td>OFF</td>
<td>Trace display swapping order of instruction bytes</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>TRACE</td>
<td>DISPLAY</td>
<td>SUPPRESSPREFETCH</td>
<td>ON</td>
<td>OFF</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>SOU(RCE)</td>
<td>ASK(PATH)</td>
<td></td>
<td></td>
<td>Prompt for source paths</td>
</tr>
<tr>
<td>MOD(E)</td>
<td>SOU(RCE)</td>
<td>NOA(SKPATH)</td>
<td></td>
<td></td>
<td>Don’t prompt for source paths</td>
</tr>
</tbody>
</table>
### File Command

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>FIL(E)</td>
<td>SOU(RCE)</td>
<td>module_name</td>
<td></td>
<td></td>
<td>Displaying source file</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>OBJ(ECT)</td>
<td>file_name</td>
<td></td>
<td></td>
<td>Loading object</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>SYM(BOL)</td>
<td>file_name</td>
<td></td>
<td></td>
<td>Loading symbol</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>BIN(ARY)</td>
<td>file_name</td>
<td></td>
<td></td>
<td>Loading data</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>APPEND</td>
<td>file_name</td>
<td></td>
<td></td>
<td>Appending symbol</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>CHA(INCMD)</td>
<td>file_name</td>
<td></td>
<td>args</td>
<td>Chaining command files</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>COM(MAND)</td>
<td>file_name</td>
<td></td>
<td>args</td>
<td>Executing command file</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>LOG</td>
<td>file_name</td>
<td></td>
<td></td>
<td>Specifying command log file</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>RER(UN)</td>
<td></td>
<td></td>
<td></td>
<td>Re-executes command file</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>CON(FIG)</td>
<td>LOA(D)</td>
<td>file_name</td>
<td></td>
<td>Loads config. from file</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>CON(FIG)</td>
<td>STO(RE)</td>
<td>file_name</td>
<td></td>
<td>Stores configuration to file</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>ENV(IRON)</td>
<td>LOA(D)</td>
<td>file_name</td>
<td></td>
<td>Loads environment from file</td>
</tr>
<tr>
<td>FIL(E)</td>
<td>ENV(IRON)</td>
<td>SAV(E)</td>
<td>file_name</td>
<td></td>
<td>Stores environment to file</td>
</tr>
</tbody>
</table>

### Trace Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRA(CE)</td>
<td>FUN(CTION)</td>
<td>CAL(L)</td>
<td>address</td>
<td></td>
<td>Tracing function call</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>FUN(CTION)</td>
<td>STA(TEMENT)</td>
<td>address</td>
<td></td>
<td>Tracing statement</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>VAR(IABLE)</td>
<td>ACC(ESSION)</td>
<td>address</td>
<td></td>
<td>Tracing access to variable</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>STO(P)</td>
<td></td>
<td></td>
<td></td>
<td>Stopping tracing</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>ALW(AYS)</td>
<td></td>
<td></td>
<td></td>
<td>Tracing until halt</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>AGA(IN)</td>
<td></td>
<td></td>
<td></td>
<td>Restarting tracing</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>SAV(E)</td>
<td>file_name</td>
<td></td>
<td></td>
<td>Storing trace specification</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>LOA(D)</td>
<td>file_name</td>
<td></td>
<td></td>
<td>Loading trace specification</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>CUR(TIMIZE)</td>
<td></td>
<td></td>
<td></td>
<td>Starts trace w/loaded spec.</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>DIS(PLAY)</td>
<td>MIX(ED)</td>
<td></td>
<td></td>
<td>Enabling source+bus display</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>DIS(PLAY)</td>
<td>SOU(RCE)</td>
<td></td>
<td></td>
<td>Enabling source display</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>DIS(PLAY)</td>
<td>BUS</td>
<td></td>
<td></td>
<td>Enabling bus display</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>DIS(PLAY)</td>
<td>ABS(OLUTE)</td>
<td></td>
<td></td>
<td>Displaying absolute time</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>DIS(PLAY)</td>
<td>REL(ATIVE)</td>
<td></td>
<td></td>
<td>Displaying relative time</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>COP(Y)</td>
<td>DISPLAY</td>
<td></td>
<td></td>
<td>Copying trace display</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>COP(Y)</td>
<td>ALL</td>
<td></td>
<td></td>
<td>Copying trace results</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>FIN(D)</td>
<td>TRIG(GER)</td>
<td></td>
<td></td>
<td>Centers trigger in window</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>FIN(D)</td>
<td>STA(T)</td>
<td>state_num</td>
<td></td>
<td>Centers state in window</td>
</tr>
<tr>
<td>TRA(CE)</td>
<td>COP(Y)</td>
<td>SPE(C)</td>
<td></td>
<td></td>
<td>Copying specification</td>
</tr>
</tbody>
</table>

### Symbol Window Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>SYM(BOL)</td>
<td>LIS(T)</td>
<td>MOD(ULE)</td>
<td></td>
<td></td>
<td>Displaying module</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>LIS(T)</td>
<td>FUN(CTION)</td>
<td></td>
<td></td>
<td>Displaying function</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>LIS(T)</td>
<td>EXT(E RIMAL)</td>
<td></td>
<td></td>
<td>Displaying global symbol</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>LIS(T)</td>
<td>INT(E RNAL)</td>
<td>func_name</td>
<td></td>
<td>Displaying local symbol</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>LIS(T)</td>
<td>GLO(BALS)</td>
<td>module</td>
<td></td>
<td>Displaying global asm symbol</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>LIS(T)</td>
<td>LOC(AL)</td>
<td></td>
<td></td>
<td>Displaying local asm symbol</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>LIS(T)</td>
<td>USE(R)</td>
<td></td>
<td></td>
<td>Displaying user-defined symbol</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>ADD</td>
<td>symbol_nam</td>
<td>address</td>
<td></td>
<td>Adding user-defined symbol</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>DEL(ETE)</td>
<td>symbol_nam</td>
<td></td>
<td></td>
<td>Deleting user-defined symbol</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>DEL(ETE)</td>
<td>ALL</td>
<td></td>
<td></td>
<td>Deleting all user symbols</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>MAT(CH)</td>
<td>&quot;strings&quot;</td>
<td></td>
<td></td>
<td>Displaying matched string</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>COP(Y)</td>
<td>DIS(PLAY)</td>
<td></td>
<td></td>
<td>Copying symbol display</td>
</tr>
<tr>
<td>SYM(BOL)</td>
<td>COP(Y)</td>
<td>ALL</td>
<td></td>
<td></td>
<td>Copying all symbols</td>
</tr>
</tbody>
</table>
## Command File Control Command

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>EXIT</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Exiting command file</td>
</tr>
<tr>
<td>EXIT</td>
<td>(VAR)</td>
<td>address</td>
<td>value</td>
<td></td>
<td>Exiting with variable cont.</td>
</tr>
<tr>
<td>EXIT</td>
<td>REG</td>
<td>regname</td>
<td>value</td>
<td></td>
<td>Exiting with register cont.</td>
</tr>
<tr>
<td>EXIT</td>
<td>MEM(ORY)</td>
<td>BYTE/WORD/LONG</td>
<td>address</td>
<td>value</td>
<td>Exiting with memory contents</td>
</tr>
<tr>
<td>EXIT</td>
<td>IO</td>
<td>BYTE/WORD/LONG</td>
<td>address</td>
<td>value</td>
<td>Exiting with I/O contents</td>
</tr>
<tr>
<td>WAIT</td>
<td>MON(ITOR)</td>
<td></td>
<td></td>
<td></td>
<td>Wait until MONITOR status</td>
</tr>
<tr>
<td>WAIT</td>
<td>RUN</td>
<td></td>
<td></td>
<td></td>
<td>Wait until RUN status</td>
</tr>
<tr>
<td>WAIT</td>
<td>UNK(OWN)</td>
<td></td>
<td></td>
<td></td>
<td>Wait until UNKOWN status</td>
</tr>
<tr>
<td>WAIT</td>
<td>SLO(W)</td>
<td></td>
<td></td>
<td></td>
<td>Wait until SLOW CLOCK status</td>
</tr>
<tr>
<td>WAIT</td>
<td>TGT(RESET)</td>
<td></td>
<td></td>
<td></td>
<td>Wait until TARGET RESET</td>
</tr>
<tr>
<td>WAIT</td>
<td>SLE(EP)</td>
<td></td>
<td></td>
<td></td>
<td>Wait until SLEEP status</td>
</tr>
<tr>
<td>WAIT</td>
<td>GRA(NT)</td>
<td></td>
<td></td>
<td></td>
<td>Wait until BUS GRANT status</td>
</tr>
<tr>
<td>WAIT</td>
<td>NOB(US)</td>
<td></td>
<td></td>
<td></td>
<td>Wait until NOBUS status</td>
</tr>
<tr>
<td>WAIT</td>
<td>TCO(M)</td>
<td></td>
<td></td>
<td></td>
<td>Wait until end of trace</td>
</tr>
<tr>
<td>WAIT</td>
<td>TLA(LT)</td>
<td></td>
<td></td>
<td></td>
<td>Wait until halt</td>
</tr>
<tr>
<td>WAIT</td>
<td>TIM(E)</td>
<td>seconds</td>
<td></td>
<td></td>
<td>Wait a number of seconds</td>
</tr>
</tbody>
</table>

## Global/Local/Interrupt Descriptor Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>GDT</td>
<td>SELECTOR</td>
<td>value</td>
<td></td>
<td></td>
<td>Place selector on top line of GDT window.</td>
</tr>
<tr>
<td>LDT</td>
<td>SELECTOR</td>
<td>value</td>
<td></td>
<td></td>
<td>Place selector on top line of LDT window.</td>
</tr>
<tr>
<td>IDT</td>
<td>SELECTOR</td>
<td>value</td>
<td></td>
<td></td>
<td>Place selector on top line of IDT window.</td>
</tr>
<tr>
<td>GDT</td>
<td>ENTRY</td>
<td>value</td>
<td></td>
<td></td>
<td>Place entry on top line of GDT window.</td>
</tr>
<tr>
<td>LDT</td>
<td>ENTRY</td>
<td>value</td>
<td></td>
<td></td>
<td>Place entry on top line of LDT window.</td>
</tr>
<tr>
<td>IDT</td>
<td>ENTRY</td>
<td>value</td>
<td></td>
<td></td>
<td>Place entry on top line of IDT window.</td>
</tr>
</tbody>
</table>

## Miscellaneous Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Param_1</th>
<th>Param_2</th>
<th>Param_3</th>
<th>Param_4</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>BEE(P)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Sounding beep</td>
</tr>
<tr>
<td>BUTTON</td>
<td>label</td>
<td>&quot;command&quot;</td>
<td></td>
<td></td>
<td>Adds button to Button window</td>
</tr>
<tr>
<td>QUI(T)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Exiting debugger</td>
</tr>
<tr>
<td>QUI(T)</td>
<td>LOC(KED)</td>
<td></td>
<td></td>
<td></td>
<td>Exiting debugger while retaining control</td>
</tr>
<tr>
<td>COP(Y)</td>
<td>TO</td>
<td>file_name</td>
<td></td>
<td></td>
<td>Specifying copy destination</td>
</tr>
<tr>
<td>COP(Y)</td>
<td>SOU(RCE)</td>
<td></td>
<td></td>
<td></td>
<td>Copying Source window</td>
</tr>
<tr>
<td>COP(Y)</td>
<td>REG(ISTER)</td>
<td></td>
<td></td>
<td></td>
<td>Copying Register window</td>
</tr>
<tr>
<td>COP(Y)</td>
<td>MEM(ORY)</td>
<td></td>
<td></td>
<td></td>
<td>Copying Memory window</td>
</tr>
<tr>
<td>COP(Y)</td>
<td>WAT(CHPOINT)</td>
<td></td>
<td></td>
<td></td>
<td>Copying WatchPoint window</td>
</tr>
<tr>
<td>COP(Y)</td>
<td>BAC(KTRACE)</td>
<td></td>
<td></td>
<td></td>
<td>Copying BackTrace window</td>
</tr>
<tr>
<td>COP(Y)</td>
<td>I0</td>
<td></td>
<td></td>
<td></td>
<td>Copying I/O window</td>
</tr>
<tr>
<td>COP(Y)</td>
<td>EXP(RESSION)</td>
<td></td>
<td></td>
<td></td>
<td>Copying Expression window</td>
</tr>
<tr>
<td>COP(Y)</td>
<td>BUT(TON)</td>
<td></td>
<td></td>
<td></td>
<td>Copying Button window</td>
</tr>
<tr>
<td>CUR(SOR)</td>
<td>address</td>
<td></td>
<td></td>
<td></td>
<td>Positioning cursor</td>
</tr>
<tr>
<td>CUR(SOR)</td>
<td>PC</td>
<td></td>
<td></td>
<td></td>
<td>Finding current PC</td>
</tr>
<tr>
<td>NOP</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Non-operative</td>
</tr>
<tr>
<td>NOP</td>
<td>comments</td>
<td></td>
<td></td>
<td></td>
<td>Non-operative to prefix comment lines</td>
</tr>
<tr>
<td>SEA(RCH)</td>
<td>STRING</td>
<td>FOR/BACK</td>
<td>ON/OFF</td>
<td>strings</td>
<td>Searching string</td>
</tr>
<tr>
<td>SEA(RCH)</td>
<td>FUNC(TION)</td>
<td>func_name</td>
<td></td>
<td></td>
<td>Selecting function</td>
</tr>
</tbody>
</table>
Chapter 6: Command File and Macro Command Summary

Command File and Macro Command Summary

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>address</td>
<td>Address</td>
<td>See &quot;Reference.&quot;</td>
</tr>
<tr>
<td>addr-range</td>
<td>Address range</td>
<td></td>
</tr>
<tr>
<td>args</td>
<td>Arguments</td>
<td>Replaces placeholders in command file.</td>
</tr>
<tr>
<td>attributes</td>
<td></td>
<td>Can be comma-separated</td>
</tr>
<tr>
<td>breakaddress</td>
<td>linenumber, plinenum, or address.</td>
<td></td>
</tr>
<tr>
<td>case</td>
<td>Case sensing</td>
<td></td>
</tr>
<tr>
<td>command</td>
<td>Macro command</td>
<td>Commands listed in the &quot;Reference.&quot;</td>
</tr>
<tr>
<td>config-ans</td>
<td>Setting</td>
<td>See &quot;Reference.&quot;</td>
</tr>
<tr>
<td>config-item</td>
<td>Configuration</td>
<td>See &quot;Reference.&quot;</td>
</tr>
<tr>
<td>count</td>
<td>Count</td>
<td>Decimal notation</td>
</tr>
<tr>
<td>direction</td>
<td>Search direction</td>
<td></td>
</tr>
<tr>
<td>directoryname</td>
<td>Directory name</td>
<td></td>
</tr>
<tr>
<td>file_name</td>
<td>File name</td>
<td></td>
</tr>
<tr>
<td>format</td>
<td>Memory file format</td>
<td></td>
</tr>
<tr>
<td>func_name</td>
<td>Function name</td>
<td></td>
</tr>
<tr>
<td>label</td>
<td>Button label</td>
<td></td>
</tr>
<tr>
<td>linenumber</td>
<td>Line number</td>
<td></td>
</tr>
<tr>
<td>mem_type</td>
<td>Memory type</td>
<td></td>
</tr>
<tr>
<td>module_name</td>
<td>Module name</td>
<td></td>
</tr>
<tr>
<td>mon-ans</td>
<td>Setting</td>
<td>See &quot;Reference.&quot;</td>
</tr>
<tr>
<td>mon-item</td>
<td>Configuration</td>
<td>See &quot;Reference.&quot;</td>
</tr>
<tr>
<td>plinenum</td>
<td>Macro line number</td>
<td>line number.macro number (ex. 34.1)</td>
</tr>
<tr>
<td>regname</td>
<td>Register name</td>
<td></td>
</tr>
<tr>
<td>seconds</td>
<td>Time in seconds</td>
<td></td>
</tr>
<tr>
<td>size</td>
<td>Data size</td>
<td></td>
</tr>
<tr>
<td>space</td>
<td>Memory or I/O space</td>
<td></td>
</tr>
<tr>
<td>strings</td>
<td>String &quot;string&quot;</td>
<td></td>
</tr>
<tr>
<td>symbol_name</td>
<td>Symbol name</td>
<td></td>
</tr>
<tr>
<td>usersymbol</td>
<td>User-defined symbol</td>
<td>See &quot;Reference.&quot;</td>
</tr>
<tr>
<td>value</td>
<td>Value</td>
<td>See &quot;Reference.&quot;</td>
</tr>
<tr>
<td>window-name</td>
<td>Window Name</td>
<td>See &quot;Reference.&quot;</td>
</tr>
</tbody>
</table>

1st 3 characters
WAIT Command Dialog Box

This dialog box appears when the WAIT command is included in a command file, break macro, or button.

Choosing the STOP button cancels the WAIT command.
Expressions in Commands
Expressions in Commands

When you enter values and addresses in commands, you can use:

- Numeric constants (hexadecimal, decimal, octal, or binary values). You can only use Numeric constants when using the constant-address syntax.
- Symbols (identifiers).
- C operators (pointers, arrays, structures, unions, unary minus operators) and parentheses (specifying the order of operator evaluation).
Numeric Constants

All numeric constants are assumed to be hexadecimal, except when the number refers to a count; count values are assumed to be decimal. By appending a suffix to the numeric value, you can specify its base.

The debugger expressions support the following numeric constants with or without radix:

**Hexadecimal**
- Alphanumeric strings starting with "0x" or "0X" and consisting of any of '0' through '9', 'A' through 'F', or 'a' through 'f' (for example: 0x12345678, 0xFFFF0000).

**Decimal**
- Numeric strings consisting of any of '0' through '9' and ending with 'T' or 't' (for example: 128T, 1000t).

**Octal**
- Numeric strings consisting of any of '0' through '7' and ending with 'O' or 'o' (not zero) (for example: 200o, 377O).

**Binary**
- Numeric strings consisting of '0' or '1' and ending with 'Y' or 'y' (for example: 10000000y, 11001011Y).

**Don't Care**
- Numeric strings containing 'X' or 'x' values. All numeric strings must begin with a numeric value. For example, x1x0y must be entered as 0x1x0y.
Symbols

The debugger expressions support the following symbols (identifiers):

- Symbols defined in C source code.
- Symbols defined in assembly language source code.
- Symbols added with the Symbol window control menu's User defined→Add... (ALT, -, U, A) command.
- Line number symbols.

Symbol expressions may be in the following format (where bracketed parts are optional):

```
[module_name\]symbol_name[,format_spec]
```

Module Name

The module names include C/Assembler module names as follows:

- Assembler module name: (file_path)asm_file_name
- C module name: source_file_name (without extension)

Symbol Name

The symbol names include symbols defined in C/Assembler source codes, user-defined symbols, and line number symbols:

- User-defined symbols: Strings consisting of up to 256 characters including: alphanumeric characters, _ (underscore), and ? (question mark).
- Line number symbols: #source_file_line_number
The symbol names can also include either * or & to explicitly specify the evaluation of the symbol.

Symbol address &symbol_name

Symbol data *symbol_name

**Format Specification**

The format specifications define the variable display format or size for the variable access or break tracing:

- **String**
  - s

- **Decimal**
  - d (current size), d8 (8 bit), d16 (16 bit), d32 (32 bit)

- **Unsigned decimal**
  - u (current size), u8 (8 bit), u16 (16 bit), u32 (32 bit)

- **Hexadecimal**
  - x (current size), x8 (8 bit), x16 (16 bit), x32 (32 bit)

**Examples**

Some example symbol expressions are shown below:

```plaintext
sample\#22,x32
```

Display the address of line number 22 in the module "sample," formatted as a 32-bit hex number. This form (with the format specification) is used in the watchpoint window, expression window, etc.

```plaintext
sample\#22
```

Refer to the address of line number 22 in the module "sample." This form (without the format specification) is used in the trace specification, memory display window, etc.
data[2].message,s

Display the structure element "message" in the third element of the array "data" as a string.

dat→message,s

Display the structure element "message" pointed to by the "dat" pointer as a string.

dat→message,x32

Display the structure element "message" pointed to by the "dat" pointer as a 32-bit hex number.

sample\data[1].status,d32

Display the structure element "status" in the second element of the array "data" that is in the module "sample" as a 32-bit decimal integer.

&data[0]

Refer to the address of the first element of the array "data."

*1000

Does not do anything. (It displays dashes, as an indication of a parsing error.) Note that you cannot use constants as an address.
C Operators

The debugger expressions support the following C operators. The order of operator evaluation can be modified using parentheses '(' and ')'; however, it basically follows C conventions:

- Pointers: `*` and `&`
- Arrays: `[` and `]`
- Structures or unions: `.` and `"\rightarrow"`
- Unary minus: `-`

Chapter 7: Expressions in Commands
C Operators
Menu Bar Commands
Menu Bar Commands

This chapter describes the commands that can be chosen from the menu bar. Command descriptions are in the order they appear in the menu bar (top to bottom, left to right).

- File→Load Object... (ALT, F, L)
- File→Command Log→Log File Name... (ALT, F, C, N)
- File→Command Log→Logging ON (ALT, F, C, O)
- File→Command Log→Logging OFF (ALT, F, C, F)
- File→Run Cmd File... (ALT, F, R)
- File→Load Debug... (ALT, F, D)
- File→Save Debug... (ALT, F, S)
- File→Load Emulator Config... (ALT, F, E)
- File→Save Emulator Config... (ALT, F, V)
- File→Copy Destination... (ALT, F, P)
- File→Exit (ALT, F, X)
- File→Exit HW Locked (ALT, F, H)
- Execution→Run (ALT, E, U)
- Execution→Run to Cursor (ALT, R C)
- Execution→Run to Caller (ALT, E, T)
- Execution→Run... (ALT, E, R)
- Execution→Single Step (ALT, E, N)
- Execution→Step Over (ALT, E, O)
- Execution→Step... (ALT, E, S)
- Execution→Break (ALT, E, B)
- Execution→Reset (ALT, E, E)
- Breakpoint→Set at Cursor (ALT, B, S)
- Breakpoint→Delete at Cursor (ALT, B, D)
- Breakpoint→Set Macro... (ALT, B, M)
- Breakpoint→Delete Macro (ALT, B, L)
- Breakpoint→Edit... (ALT, B, E)
- Variable→Edit... (ALT, V, E)
- Trace→Function Caller... (ALT, T, C)
- Trace→Function Statement... (ALT, T, S)
- Trace→Variable Access... (ALT, T, V)
- Trace→Edit... (ALT, T, E)
- Trace→Trigger Store... (ALT, T, T)
Chapter 8: Menu Bar Commands

- Trace→Find Then Trigger... (ALT, T, D)
- Trace→Sequence... (ALT, T, Q)
- Trace→Until Halt (ALT, T, U)
- Trace→Halt (ALT, T, H)
- Trace→Again (ALT, T, A)
- RealTime→Monitor Intrusion→Disallowed (ALT, R, T, D)
- RealTime→Monitor Intrusion→Allowed (ALT, R, T, A)
- RealTime→I/O Polling→ON (ALT, R, I, O)
- RealTime→I/O Polling→OFF (ALT, R, I, F)
- RealTime→Watchpoint Polling→ON (ALT, R, W, O)
- RealTime→Watchpoint Polling→OFF (ALT, R, W, F)
- RealTime→Memory Polling→ON (ALT, R, M, O)
- RealTime→Memory Polling→OFF (ALT, R, M, F)
- Settings→Emulator Config→Hardware... (ALT, S, E, H)
- Settings→Emulator Config→Memory Map... (ALT, S, E, M)
- Settings→Emulator Config→Monitor... (ALT, S, E, O)
- Settings→Emulator Config→Address Translation... (ALT, S, E, A)
- Settings→Communication... (ALT, S, C)
- Settings→BNC→Outputs Analyzer Trigger (ALT, S, B, O)
- Settings→BNC→Input to Analyzer Arm (ALT, S, B, I)
- Settings→Font... (ALT, S, F)
- Settings→Tabstops... (ALT, S, T)
- Settings→Symbols→Case Sensitive→ON (ALT, S, S, C, O)
- Settings→Symbols→Case Sensitive→OFF (ALT, S, S, C, F)
- Settings→Extended→Trace Cycles→User (ALT, S, X, T, U)
- Settings→Extended→Trace Cycles→Monitor (ALT, S, X, T, M)
- Settings→Extended→Trace Cycles→Both (ALT, S, X, T, B)
- Settings→Extended→Load Error Abort→ON (ALT, S, X, L, O)
- Settings→Extended→Load Error Abort→OFF (ALT, S, X, L, F)
- Settings→Extended→Source Path Query→ON (ALT, S, X, S, O)
- Settings→Extended→Source Path Query→OFF (ALT, S, X, S, F)
- Window→Cascade (ALT, W, C)
- Window→Tile (ALT, W, T)
- Window→Arrange Icons (ALT, W, A)
- Window→1-9 <win_name> (ALT, W, 1-9)
- Window→More Windows... (ALT, W, M)
- Help→About Debugger/Emulator... (ALT, H, D)
File→Load Object... (ALT, F, L)

Loads the specified object file and symbolic information into the debugger.
Program code is loaded into emulation memory or target system RAM.
Object files are typically Intel OMF386 boot-loadable format absolute files.
You can also load Motorola S-Record and Intel Hexadecimal format files; however, no symbolic information from these files will be loaded.

Load Object File Dialog Box
Choosing the File→Load Object... (ALT, F, L) command opens the following dialog box:

Current Shows the currently loaded object file.
File Name Specifies the object file to be loaded.
Bytes Loaded Displays the loaded data in Kbytes.
Symbols Only Loads only the symbolic information. This is used when programs are already in memory (for example, when the debugger is exited and re-entered without turning OFF power to the target system or when code is in target system ROM).
Data Only  Loads program code but not symbols.

Symbols Append  Appends the symbols from the specified object file to the currently loaded symbols. This lets you debug code loaded from multiple object files.

Load  Starts loading the specified object file and closes the dialog box if the load was successful. The dialog box is left open on screen if the load was not successful.

Cancel  Closes the dialog box without loading the object file.

Browse...  Opens a file selection dialog box from which you can select the object file to be loaded.

**Command File Command**

FIL(E) OBJ(ECT) file_name
Loads the specified object file and symbols into the debugger.

FIL(E) SYM(BO) file_name
Loads only the symbolic information from the specified object file.

FIL(E) BIN(ARY) file_name
Loads only the program code from the specified object file.

FIL(E) APP(END) file_name
Appends the symbol information from the specified object file to the currently loaded symbol information.

**See Also**

"To load user programs" in the "Loading and Displaying Programs" section of the "Debugging Programs" chapter.
File→Command Log→Log File Name... (ALT, F, C, N)

Lets you name a new command log file.

The current command log file is closed and the specified command log file is opened. The default command log file name is "log.cmd".

Command log files can be executed with the File→Run Cmd File... (ALT, F, R) command.

The File→Command Log→Logging OFF (ALT, F, C, F) command stops the logging of executed commands.

This command opens a file selection dialog box from which you can select the command log file. Command log files have a "CMD" extension.

**Command File Command**

FIL(E) LOG filename

**See Also**

"To create a command file" in the "Using Command Files" section of the "Using the Debugger Interface" chapter.
File→Command Log→Logging ON (ALT, F, C, O)

Starts command log file output.

The File→Command Log→Log File Name... (ALT, F, C, N) command specifies the destination file.

Command File Command

MOD (E) LOG ON

See Also

"To create a command file" in the "Using Command Files" section of the "Using the Debugger Interface" chapter.
File→Command Log→Logging OFF (ALT, F, C, F)

Stops command log file output.

The File→Command Log→Log File Name... (ALT, F, C, N) command specifies the destination file.

**Command File Command**

MOD (E) LOG OFF

**See Also**

"To create a command file" in the "Using Command Files" section of the "Using the Debugger Interface" chapter.
File→Run Cmd File... (ALT, F, R)

Executes the specified command file.

Command files can be:

- Files created with the File→Command Log→Log File Name... (ALT, F, C, N) command.
- Configuration files having .CMD extension.

Command files are stored as ASCII text files so they can be created or edited with ASCII text editors.

**Command File Execution Dialog Box**

Choosing the File→Run Cmd File... (ALT, F, R) command opens the following dialog box:

![Command File Execution Dialog Box](image)

File Name  Lets you enter the name of the command file to be executed.
Chapter 8: Menu Bar Commands
File→Run Cmd File... (ALT, F, R)

Directory  Shows the current directory and the command files in that directory. You can select the command file name from this list.

Parameters  Lets you specify up to five parameters that replace placeholders $1 through $5 in the command file. Parameters must be separated by blank spaces.

Executing  Shows the command being executed.

Execute  Executes the command file.

Stop  Stops command file execution.

Close  Closes the dialog box.

Browse...  Opens a file selection dialog box from which you can select the command file name.

**Command File Command**
FIL(E) COM(MAND) filename args

**See Also**
"To execute a command file" in the "Using Command Files" section of the "Using the Debugger Interface" chapter.
File→Load Debug... (ALT, F, D)

Loads a debug environment file.

This command opens a file selection dialog box from which you select the debug environment file.

Debug environment files have the extension ".ENV".

Debug environment files contain information about:

- Breakpoints.
- Variables in the WatchPoint window.
- The directory that contains the currently loaded object file.

**Command File Command**

```
FIL(E) ENVIRONMEN(T) LOA(D) filename
```
File→Save Debug... (ALT, F, S)

Saves a debug environment file.

This command opens a file selection dialog box from which you select the debug environment file.

The following information is saved in the debug environment file:

- Breakpoints.
- Variables in the WatchPoint window.
- The directory that contains the currently loaded object file.

**Command File Command**

FIL(E) ENV(IRONMENT) SAV(E) filename
File→Load Emulator Config... (ALT, F, E)

Loads a hardware configuration command file.

This command opens a file selection dialog box from which you select the hardware configuration file.

Emulator configuration command files contain:

- Hardware configuration settings.
- Memory map configuration settings.
- Monitor configuration settings.

**Command File Command**

FIL(E) CON FIGURATION LOA(D) filename

**See Also**

"To load an emulator configuration" in the "Saving and Loading Configurations" section of the "Configuring the Emulator" chapter.
File→Save Emulator Config... (ALT, F, V)

Saves the current hardware configuration to a command file.

The following information is saved in the emulator configuration file:

- Hardware configuration settings.
- Memory map configuration settings.
- Monitor configuration settings.

**Command File Command**

FIL(E) CON(FIGURATION) STO(RE) filename

**See Also**

"To save the current emulator configuration" in the "Saving and Loading Configurations" section of the "Configuring the Emulator" chapter.
File→Copy Destination... (ALT, F, P)

Names the listing file to which debugger information may be copied.

The contents of most of the debugger windows can be copied to the destination listing file by choosing the Copy→Window command from the window's control menu.

The Symbol and Trace windows' control menus provide the Copy→All command for copying all of the symbolic or trace information to the destination listing file.

This command opens a file selection dialog box from which you select the name of the output list file. Output list files have the extension ".LST".

**Command File Command**

COP(Y) TO filename

**See Also**

"To change the list file destination" in the "Working with Debugger Windows" section of the "Using the Debugger Interface" chapter.
File→Exit (ALT, F, X)

Exits the debugger.

**Command File Command**

QUI (T)

**See Also**

"To exit the debugger" in the "Starting and Exiting the Debugger" section of the "Using the Debugger Interface" chapter.

File→Exit HW Locked (ALT, F, H)
File→Exit HW Locked (ALT, F, H)

Exits the debugger and locks the emulator hardware.

When the emulator hardware is locked, your user name and ID are saved in the HP 64700 and other users are prevented from accessing it.

You can restart the debugger and resume your debug session after reloading the symbolic information with the File→Load Object... (ALT, F, L) command.

If you have any breakpoints set when you exit the debugger, you will have to reset the breakpoints when you restart the debugger. All breakpoints are deleted when RTC is exited.

**Command File Command**

QUI(T) LOC(KED)

**See Also**

Settings→Communication... (ALT, S, C)
File Selection Dialog Boxes

File selection dialog boxes are used with several of the debugger commands. An example of a file selection dialog box is shown below.

File Name: You can select the name of the file from the list box and edit it in the text box.

List Files of Type: Lets you choose the filter for files shown in the File Name list box.

Directories: You can select the directory from the list box. The selected directory is shown above the list box.

Drives: Lets you select the drive name whose directories are shown in the Directories list box.

OK: Selects the named file and closes the dialog box.

Cancel: Cancels the command and closes the dialog box.

Help: If this button is available, it opens a help window for viewing the associated help information.
Execution→Run (F5), (ALT, E, U)

Runs the program from the current program counter address.

Command File Command

RUN
Execution→Run to Cursor (ALT, E, C)

Runs from the current program counter address up to the Source window line that contains the cursor.

This command sets a breakpoint at the cursor-selected source line and runs from the current program counter address; therefore, it cannot be used when programs are in target system ROM if you already have four hardware breakpoints.

If the cursor-selected source line is not reached within the number of milliseconds specified by StepTimerLen in the B3637B.INI file, a dialog box appears from which you can cancel the command. When the Stop button is chosen, program execution stops, the breakpoint is deleted, and the processor continues RUNNING IN USER PROGRAM.

Command File Command

COM(E) address

See Also

"To run the program until the specified line" in the "Stepping, Running, and Stopping" section of the "Debugging Programs" chapter.
**Execution→Run to Caller (ALT, E, T)**

Executes the user program until the current function returns to its caller.

Because this command determines the address at which to stop execution based on stack frame data and object file function information, the following restrictions are imposed:

- A function cannot properly return immediately after its entry point because the stack frame for the function has not yet been generated. Use the Step command to single-step the function before using the Execution→Run to Caller (ALT, E, T) command.

- An assembly language routine cannot properly return, even if it follows C function call conventions, because there is no function information in the object file.

- An interrupt function cannot properly return because it uses a stack in a different fashion from standard functions.

**Command File Command**

RET (URN)

**See Also**

"To run the program until the current function return" in the "Stepping, Running, and Stopping" section of the "Debugging Programs" chapter.
Execution→Run... (ALT, E, R)

Executes the user program starting from the specified address.
This command sets the processor status to RUNNING IN USER PROGRAM.

**Note**
If you try to run from an address whose symbol is START, STA, RESET, or RES (or any upper- or lower-case variation), the debugger instead runs from the start address or reset address, respectively, because these are the keywords used with the RUN command. To fix this problem, use START+0, STA+0, RESET+0, or RES+0 to force the symbol to be evaluated as an address.

**Run Dialog Box**

Choosing the Execution→Run... (ALT, E, R) command opens the following dialog box:

```
Run

From
- Current PC
- Start Address
- User Reset
- Address: 1026a

[Run]  [Cancel]  [Help]
```

**Current PC** Specifies that the program run from the current program counter address.

**Start Address** Specifies that the program run from the *transfer address* defined in the object file.
User Reset  The emulator resets the processor (driving the "flying lead" low); then releases reset, causing the processor to begin executing at the reset address (0xfffff0). Note that the reset address is truncated to 26 bits external to the microprocessor.

Address  Lets you enter the address from which to run.

Run  Initiates program execution from the specified address, then close the dialog box.

Cancel  Cancels the command and closes the dialog box.

**Command File Command**

**RUN**
Executes the user program from the current program counter address.

**RUN STA (RT)**
Executes the user program from the transfer address defined in the object file.

**RUN RES (ET)**
Drives the target reset line and begins executing from the contents of exception vector 0.

**RUN address**
Executes the user program from the specified address.

**See Also**

"To run the program from a specified address" in the "Stepping, Running, and Stopping" section of the "Debugging Programs" chapter.
Execution→Single Step (F2), (ALT, E, N)

Executes a single instruction or source line at the current program counter address.

A single source line is executed when in the source only display mode, unless no source is available or an assembly language program is loaded; in these cases, a single assembly language instruction is executed.

When in the mnemonic mixed display mode, a single assembly language instruction is executed.

During a single-step command, multiple instructions may be executed if the instruction being stepped causes an instruction fault or task switch.

**Command File Command**

STE (P)

**See Also**

"To step a single line or instruction" in the "Stepping, Running, and Stopping" section of the "Debugging Programs" chapter.

"Unexpected Stepping Behavior" in the "Concepts" chapter.

Execution→Step Over (ALT, E, O)

Execution→Step... (ALT, E, S)
Execution→Step Over (F3), (ALT, E, O)

Executes a single instruction or source line at the current program counter except when the instruction or source line makes a subroutine or function call, in which case the entire subroutine or function is executed.

This command is the same as the Execution→Single Step (ALT, E, N) command except when the source line contains a function call or the assembly instruction makes a subroutine call. In these cases, the entire function or subroutine is executed.

Note

The Execution→Step Over (ALT, E, O) command may fail in single-stepping the source lines containing such loop statements as "while", "for", or "do while" statements.

Command File Command

OVE (R)

See Also

"To step over a function" in the "Stepping, Running, and Stopping" section of the "Debugging Programs" chapter.
Execution→Step... (ALT, E, S)

Single-steps the specified number of instructions or source lines, starting from the specified address.

Single source lines are executed when in the source only display mode, unless no source is available or an assembly language program is loaded; in these cases, single assembly language instructions are executed.

**Note**

During a single-step command, multiple instructions can be executed if the instruction being stepped causes an instruction fault or task switch. See Unexpected Stepping Behavior in the "Concepts" chapter.

When in the mnemonic mixed display mode, single assembly language instructions are executed.

**Note**

If you try to step from an address whose symbol is START or STA (or any upper- or lower-case variation), the debugger instead steps from the start address because these are the keywords used with the STEP and OVER commands. To fix this problem, use START+0 or STA+0 to force the symbol to be evaluated as an address.
Step Dialog Box

Choosing the Execution→Step... (ALT, E, S) command opens the following dialog box:

Current PC Specifies that stepping start from the current program counter address.

Start Address Specifies that stepping start from the start address or transfer address.

Address Lets you enter the address from which to single-step.

Count Indicates the step count. The count decrements by one for every step and stops at 1.

Over If the source line to be executed contains a function call or the assembly language instruction to be executed contains a subroutine call, this option specifies that the entire function or subroutine be executed.

Follow PC If you check the Follow PC box, stepping will provide more detail because it will follow the PC for each step, and update the Source window after each step. Leaving this box unchecked speeds the stepping process; the steps will be counted, but the content of the Source window will not be updated until stepping is completed.
Step Single-steps the specified number of instructions or source lines, starting from the specified address.

Close Closes the dialog box.

Stop Stops single-stepping.

**Command File Command**

STE(P) count
Single-steps the specified number of instructions or source lines, starting from the current program counter address.

STE(P) count address
Single-steps the specified number of instructions or source lines, starting from the specified address.

STE(P) count STA(RT)
Single-steps the specified number of instructions or source lines, starting from the transfer address defined in the object file.

OVE(R) count
Single-steps the specified number of instructions or source lines, starting from the current program counter address. If an instruction or source line makes a subroutine or function call, the entire subroutine or function is executed.

OVE(R) count address
Single-steps the specified number of instructions or source lines, starting from the specified address. If an instruction or source line makes a subroutine or function call, the entire subroutine or function is executed.

OVE(R) count STA(RT)
Single-steps the specified number of instructions or source lines, starting from the transfer address defined in the object file. If an instruction or source line makes a subroutine or function call, the entire subroutine or function is executed.

**See Also**

"To step multiple lines or instructions" in the "Stepping, Running, and Stopping" section of the "Debugging Programs" chapter.
Chapter 8: Menu Bar Commands

Execution→Single Step (ALT, E, N)
Execution→Step Over (ALT, E, O)
Execution→Break (F4), (ALT, E, B)

Stop user program execution and break into the monitor.

This command can also be used to break into the monitor when the processor is in the EMULATION RESET status.

Once the command has been completed, the processor transfers to the RUNNING IN MONITOR status.

**Command File Command**

BRE (AK)

**See Also**

"To stop program execution" in the "Stepping, Running, and Stopping" section of the "Debugging Programs" chapter.
Execution→Reset (ALT, E, E)

Resets the emulation microprocessor.

If a foreground monitor is being used, it will automatically be loaded when this command is chosen.

While the processor is in the EMULATION RESET state, no display or modification is allowed for the contents of target system memory or registers. Therefore, before you can display or modify target system memory or processor registers, you must use the Execution→Break (ALT, E, B) command to break into the monitor.

Note

If RealTime→Monitor Intrusion→Allowed (ALT, R, T, A) command is chosen, the emulation microprocessor may switch immediately from reset to running in monitor, for example, to update the contents of a register window.

Command File Command

RES (ET)

See Also

"To reset the processor" in the "Stepping, Running, and Stopping" section of the "Debugging Programs" chapter.
Breakpoint → Set at Cursor (ALT, B, S)

Sets a breakpoint at the cursor-selected address in the Source window.

The breakpoint marker "BP" appears on lines at which breakpoints are set.

When a breakpoint is hit, program execution stops immediately before executing the instruction or source code line at which the breakpoint is set.

A set breakpoint remains active until it is deleted.

There are two types of breakpoints available: software and hardware

**Software breakpoints**

Software breakpoints are handled by the Intel80386EX bond-out’s interrupt facility. When you define or enable a software breakpoint, the emulator will replace the opcode at the software breakpoint address with the bond-out’s breakpoint interrupt instruction (which is different from INT 3).

Note that you must only set software breakpoints at memory locations which contain instruction opcodes (not operands or data).

Also, in order to successfully set a software breakpoint, the emulator must be able to write to the memory location specified. Therefore, software breakpoints cannot be set in target ROM. If the emulator discovers an attempt to put a software breakpoint in target ROM, it will automatically attempt to use a hardware breakpoint. If you already have four hardware breakpoints, this will fail. You can, however, copy a target ROM memory image into emulation memory and then use a software breakpoint.

**Hardware breakpoints**

Hardware breakpoints use the Intel80386EX bond-out’s breakpoint facility. It shares the debug 'breakpoint' registers with the breakpoint registers available to the target system, so when hardware breakpoint registers are used by the emulator, they are unavailable for use by the target system’s software. Any attempt by the target system software to use the hardware breakpoint will result in a break to the monitor.

There are four hardware breakpoints for the Intel80386EX.
Hardware breakpoints are used automatically when the emulator attempts to set a breakpoint and detects that the memory value did not change (probably because it is in ROM).

The Breakpoint→Set at Cursor (ALT, B, S) command may cause BP markers to appear at two or more addresses. This happens when a single instruction is associated with two or more source lines. You can select the mnemonic display mode to verify that the breakpoint is set at a single address.

**Command File Command**

BP SET address

**See Also**

"To set a breakpoint" in the "Using Breakpoints and Break Macros" section of the "Debugging Programs" chapter.
Breakpoint→Delete at Cursor (ALT, B, D)

Deletes the breakpoint set at the cursor-selected address in the Source window.

This command is only applicable to lines that contain "BP" markers (which indicate set breakpoints). Once the breakpoint is deleted, the original instruction is replaced.

Command File Command

BP DEL(ETE) address

See Also

"To delete a single breakpoint" in the "Using Breakpoints and Break Macros" section of the "Debugging Programs" chapter.

Breakpoint→Edit... (ALT, B, E)
Breakpoint→Set Macro... (ALT, B, M)

Sets a break macro immediately before the cursor-selected address in the Source window.

Break macro lines are marked with the "BP" breakpoint marker, and the corresponding addresses or line numbers are displayed in decimal format.

When a break macro is hit, program execution stops immediately before executing the instruction or source code line at which the break macro is set. Then, the commands associated with the break macro are executed. When a "RUN" command is set as the last command in the break macro, the system executes the break macro and resumes program execution.

The break macro remains active until it is deleted with the Breakpoint→Delete Macro (ALT, B, L) command or the Breakpoint→Edit... (ALT, B, E) command.

Because break macros use breakpoints, they cannot be set at addresses in target system ROM.

Additional commands can be added to existing break macros as follows:

- When a source code line or disassembled instruction is cursor-selected, the additional command is inserted at the top of the list of commands.
- When a macro command line is cursor-selected, the additional command is inserted immediately following the cursor-selected command.
Chapter 8: Menu Bar Commands

Breakpoint→Set Macro... (ALT, B, M)

**Breakpoint Edit Dialog Box**

Choosing the Breakpoint→Set Macro... (ALT, B, M) command opens the following dialog box:

![Breakpoint Edit Dialog Box](image)

- **Address**: Displays the line number or address followed by a decimal point and the line number for the new break macro.

- **Type**: Allows you to choose the type of break macro breakpoint (Intel80386EX has only four hardware breakpoint registers):
  - **Execution (E)**: A break occurs when the opcode at the address is about to be executed. A software breakpoint is used unless the address is in target ROM. In that case, a hardware breakpoint register is used in the Intel80386EX processor.
Execution Hardware Only (EH). A break occurs when the opcode at the address is about to be executed. Only hardware breakpoints are used (that is, one of the four hardware breakpoint registers in the Intel80386EX is used to implement the breakpoint).

Write Byte (WB). A break occurs when the byte specified by the address is written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Write Word (WW). A break occurs when the word (16 bits) specified by the address is written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Write Dword (WD). A break occurs when the double word (32 bits) specified by the address is written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Read/Write Byte (RB). A break occurs when the byte specified by the address is read from or written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Read/Write Word (RW). A break occurs when the word (16 bits) specified by the address is read from or written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Add Macro
Activates the Macro Command text box.

Macro Command
Lets you specify the macro command to be added to the break macro.

Set
Inserts the specified macro command at the location immediately preceding the specified source line or address, or inserts the macro command at the location immediately following the specified break macro line.
Two or more commands can be associated with a break macro by entering the first command and choosing Set; then entering the second command and choosing Set; and so on. Commands execute in the order of their entry.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Disable and Delete All</td>
<td>Disables and deletes all current breakpoints and break macros.</td>
</tr>
<tr>
<td>Current Breakpoints</td>
<td>Displays the addresses and line numbers of the current breakpoints and break macros. Allows you to select breakpoints or break macros to be enabled, disabled, or deleted.</td>
</tr>
<tr>
<td></td>
<td>If EN precedes the entry, the breakpoint is currently enabled.</td>
</tr>
<tr>
<td></td>
<td>If DI precedes the entry, the breakpoint is disabled. That is, it is not actually inserted into the code (or the hardware register is not enabled. See below).</td>
</tr>
<tr>
<td></td>
<td>If two dashes (--) precede the breakpoint, the status is unknown (probably because you used the &quot;Realtime→Monitor Intrusion→Disallowed&quot; command).</td>
</tr>
<tr>
<td>Disable/Enable</td>
<td>Disables and enables the selected breakpoint and break macro.</td>
</tr>
<tr>
<td></td>
<td>Enabled breakpoints begin with EN in the Current Breakpoints list box and show &quot;BP&quot; at the start of the line in the Source window list.</td>
</tr>
<tr>
<td></td>
<td>Disabled breakpoints begin with DI in the Current Breakpoints list box and show &quot;bp&quot; at the start of the line in the Source window list.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected breakpoints or break macros from the Current Breakpoints list box.</td>
</tr>
<tr>
<td>Delete All</td>
<td>Deletes all breakpoints and break macros from the Current Breakpoints list box.</td>
</tr>
</tbody>
</table>
Close Closes the dialog box.

**Command File Command**

**BM SET breakaddress command**
Sets a break macro at the break address where a breakpoint has already been set.

**BM SET EXE(C) breakaddress command**
Sets a break macro along with a breakpoint at the specified address. The associated breakpoint will be a software breakpoint unless the breakaddress is in target system ROM. In that case, a hardware breakpoint is set using one of the hardware breakpoint registers in the Intel80386EX processor.

**BM SET ACC(ESS) BYT(E) breakaddress command**
Sets a break macro along with a breakpoint at the specified address. The breakpoint and its macro occur when the byte is read from or written to. This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.

**BM SET ACC(ESS) WOR(D) breakaddress command**
Sets a break macro along with a breakpoint at the specified address. The breakpoint and its macro occur when the word is read from or written to. This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.

**BM SET ACC(ESS) DWO(RD) breakaddress command**
Sets a break macro along with a breakpoint at the specified address. The breakpoint and its macro occur when the double word is read from or written to. This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.

**BM SET WRI(TE) BYT(E) breakaddress command**
Sets a break macro along with a breakpoint at the specified address. The breakpoint and its macro occur when the byte is written to. This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.

**BM SET WRI(TE) WOR(D) breakaddress command**
Sets a break macro along with a breakpoint at the specified address. The breakpoint and its macro occur when the word is written to. This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.
BM SET WRI(TE) DWO(RD) breakaddress command
Sets a break macro along with a breakpoint at the specified address. The breakpoint and its macro occur when the double word is written to. This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.

See Also

"To set a break macro" in the "Using Breakpoints and Break Macros" section of the "Debugging Programs" chapter.
Breakpoint→Delete Macro (ALT, B, L)

Removes the break macro set at the cursor-indicated address in the Source window.

This command is only applicable to lines that contain "BP" markers (which indicate set breakpoints) or break macro lines.

When a source code line is cursor-selected, this command removes the breakpoint and all the macros commands set at the line.

When a break macro line is cursor-selected, this command removes the single macro command at the line.

**Command File Command**

BM DEL(ETE) address

**See Also**

"To delete a single break macro" in the "Using Breakpoints and Break Macros" section of the "Debugging Programs" chapter.

Breakpoint→Edit... (ALT, B, E)
Breakpoint→Edit... (ALT, B, E)

This feature lets you set, list, or delete breakpoints and break macros. Breakpoints are always globally enabled on initial entry into the RTC interface.

Breakpoint Edit Dialog Box

Choosing the Breakpoint→Edit... (ALT, B, E) command opens the following dialog box:

![Breakpoint Edit Dialog Box](image)

- **Address**: Lets you specify the address at which to set a breakpoint or a break macro.

- **Type**: Allows you to choose the type of breakpoint to cause a break into the monitor: (Note that the Intel80386EX has only four hardware breakpoint registers.)

  - Execution (E). A break occurs when the opcode at the address is about to be executed. A software breakpoint is used unless the address is in target ROM. In that case, a hardware breakpoint register is used in the Intel80386EX processor.
Execution Hardware Only (EH). A break occurs when the opcode at the address is about to be executed. Only hardware breakpoints are used (that is, one of the four hardware breakpoint registers in the Intel80386EX is used to implement the breakpoint).

Write Byte (WB). A break occurs when the byte specified by the address is written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Write Word (WW). A break occurs when the word (16 bits) specified by the address is written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Write Dword (WD). A break occurs when the double word (32 bits) specified by the address is written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Read/Write Byte (RB). A break occurs when the byte specified by the address is read from or written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Read/Write Word (RW). A break occurs when the word (16 bits) specified by the address is read from or written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Read/Write Dword (RD). A break occurs when the double word (32 bits) specified by the address is read from or written to. This is implemented by using one of the hardware breakpoint registers in the Intel80386EX processor.

Add Macro When selected, this specifies that a break macro should be included with the breakpoint.
<table>
<thead>
<tr>
<th>Macro Command</th>
<th>Let you specify the macro to be included with the breakpoint.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set</td>
<td>Sets a breakpoint with or without a break macro at the specified address.</td>
</tr>
<tr>
<td>Global Disable and Delete All</td>
<td>When selected, all existing breakpoints are deleted (not simply disabled), and no new breakpoints can be added.</td>
</tr>
<tr>
<td>Current Breakpoints</td>
<td>Displays the addresses and line numbers of the current breakpoints and break macros. Allows you to select the breakpoints or break macros to be enabled, disabled, or deleted.</td>
</tr>
<tr>
<td></td>
<td>If EN precedes the entry, the breakpoint is currently enabled.</td>
</tr>
<tr>
<td></td>
<td>If DI precedes the entry, the breakpoint is disabled. That is, it is not actually inserted into the code (or the hardware register is not enabled. See below).</td>
</tr>
<tr>
<td></td>
<td>If two dashes (--) precede the breakpoint, the status is unknown (probably because you used the &quot;Realtime→Monitor Intrusion→Disallowed&quot; command).</td>
</tr>
<tr>
<td>Disable/Enable</td>
<td>Disables or enables the selected breakpoint or breakpoint macro in the Current Breakpoints list box.</td>
</tr>
<tr>
<td></td>
<td>Enabled breakpoints begin with EN in the Current Breakpoints list box and show &quot;BP&quot; at the start of the line in the Source window list.</td>
</tr>
<tr>
<td></td>
<td>Disabled breakpoints begin with DI in the Current Breakpoints list box and show &quot;bp&quot; at the start of the line in the Source window list.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected breakpoints or break macros from the Current Breakpoints list box.</td>
</tr>
</tbody>
</table>
Delete All  Deletes all the breakpoints and break macros from the
Current Breakpoints list box.

Close  Closes the dialog box.

NOTE
Whenever a file is loaded (via the "File→Load Object" command), all
breakpoints will be deleted. If you want to save your breakpoints, use the
"File→Save Debug..." command.

Command File Command

MOD(E) BKP(TBREAK) ON|OFF
Globally enables or disables the breakpoint mode.

BP SET address
Sets a new breakpoint at the specified address.

BP DEL(E)E ALL
Deletes all breakpoints.

BP DEL(E)E address
Deletes the breakpoint at the specified address.

BP ENA(BLE) address
Enables the breakpoint previously specified at the address.

BP DIS(ABLE) address
Disables the breakpoint at the address, but does not delete it.

BP SET EXE(C) address
Sets a software breakpoint at the specified address unless the address is in
target system ROM. In that case, a hardware breakpoint is set using one of
the hardware breakpoint registers in the Intel80386EX processor.

BP SET ACC(ESS) BYT(E) address
Sets a breakpoint at the address. The breakpoint occurs when the byte is read
from or written to. This is implemented using one of the hardware
breakpoint registers in the Intel80386EX processor.
BP SET ACC(ESS) WOR(D) address
 Sets a breakpoint at the address. The breakpoint occurs when the word is
 read from or written to. This is implemented using one of the hardware
 breakpoint registers in the Intel80386EX processor.

BP SET ACC(ESS) DWO(RD) address
 Sets a breakpoint at the address. The breakpoint occurs when the double
 word is read from or written to. This is implemented using one of the
 hardware breakpoint registers in the Intel80386EX processor.

BP SET WRI(TE) BYT(E) address
 Sets a breakpoint at the address. The breakpoint occurs when the byte is
 written to. This is implemented using one of the hardware breakpoint
 registers in the Intel80386EX processor.

BP SET WRI(TE) WOR(D) address
 Sets a breakpoint at the address. The breakpoint occurs when the word is
 written to. This is implemented using one of the hardware breakpoint
 registers in the Intel80386EX processor.

BP SET WRI(TE) DWO(RD) address
 Sets a breakpoint at the address. The breakpoint occurs when the double
 word is written to. This is implemented using one of the hardware
 breakpoint registers in the Intel80386EX processor.

BM SET breakaddress command
 Sets a break macro at the break address where a breakpoint has already been
 set.

BM SET EXE(C) breakaddress command
 Sets a break macro along with a breakpoint at the specified address. The
 associated breakpoint will be a software breakpoint unless the breakaddress
 is in target system ROM. In that case, a hardware breakpoint is set using one
 of the hardware breakpoint registers in the Intel80386EX processor.

BM SET ACC(ESS) BYT(E) breakaddress command
 Sets a break macro along with a breakpoint at the specified address. The
 breakpoint and its macro occur when the byte is read from or written to.
 This is implemented using one of the hardware breakpoint registers in the
 Intel80386EX processor.

BM SET ACC(ESS) WOR(D) breakaddress command
 Sets a break macro along with a breakpoint at the specified address. The
 breakpoint and its macro occur when the word is read from or written to.
This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.

**BM SET ACC(ESS) DWO(RD) breakaddress command**
Sets a break macro along with a breakpoint at the specified address. The breakpoint and its macro occur when the double word is read from or written to. This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.

**BM SET WRI(TE) BYT(E) breakaddress command**
Sets a break macro along with a breakpoint at the specified address. The breakpoint and its macro occur when the byte is written to. This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.

**BM SET WRI(TE) WOR(D) breakaddress command**
Sets a break macro along with a breakpoint at the specified address. The breakpoint and its macro occur when the word is written to. This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.

**BM SET WRI(TE) DWO(RD) breakaddress command**
Sets a break macro along with a breakpoint at the specified address. The breakpoint and its macro occur when the double word is written to. This is implemented using one of the hardware breakpoint registers in the Intel80386EX processor.

**See Also**

"To enable or disable software breakpoints" to understand how to enable breakpoints and the side-effects of doing so, in the "Setting the Hardware Options" section of the "Configuring the Emulator" chapter.

"To disable a breakpoint" and "To list the breakpoints and break macros" in the "Using Breakpoints and Break Macros" section of the "Debugging Programs" chapter.
Variable→Edit... (ALT, V, E)

Displays or modifies the contents of the specified variable or copies it to the WatchPoint window.

A dynamic variable can be registered as a watchpoint when the current program counter is in the function in which the variable is declared. If the program counter is not in this function, the variable name is invalid and an error results.

Variable Edit Dialog Box

Choosing the Variable→Edit... (ALT, V, E) command opens the following dialog box:

Variable:

- **Variable**: Specifies the name of the variable to be displayed or modified. The contents of the clipboard, usually a variable selected from another window, automatically appears in this text box.

- **Type**: Displays the type of the specified variable.

- **Value**: Displays the contents of the specified variable.
Update  
Reads and displays the contents of the variable specified in the Variable text box.

Modify  
Modifies the contents of the specified variable. Choosing this button opens the Variable Modify Dialog Box, which lets you edit the contents of the variable.

to WP  
Adds the specified variable to the WatchPoint window.

Close  
Closes the dialog box.

**Command File Command**

`VARIABLE variable TO data`

Replaces the contents of the specified variable with the specified value.

**See Also**

"To display a variable" and "To monitor a variable in the WatchPoint window" in the "Displaying and Editing Variables" section of the "Debugging Programs" chapter.

"Symbols" in the "Expressions in Commands" chapter.
Variable Modify Dialog Box

Choosing the Modify button in the Variable Edit dialog box opens the following dialog box, where you enter the new value and choose the OK button to confirm the new value.

<table>
<thead>
<tr>
<th>Variable</th>
<th>Value</th>
<th>OK</th>
<th>Cancel</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable</td>
<td>mes</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Type</td>
<td>char</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td>41</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Variable: Shows the variable to be edited.

Type: Indicates the type of the variable displayed in the Variable field.

Value: Lets you enter the new value of the variable.

OK: Replaces the contents of the specified variable with the specified value and closes the dialog box.

Cancel: Cancels the command and closes the dialog box.

See Also

"To edit a variable" in the "Displaying and Editing Variables" section of the "Debugging Programs" chapter.
Trace→Function Caller... (ALT, T, C)

Traces the caller of the specified function.

The function name can be selected from another window (in other words, copied to the clipboard) before choosing the command; it will automatically appear in the dialog box that is opened.

The analyzer stores only the execution of the function entry point and prestores execution states that occur before the function entry point. These prestored states correspond to the function call statements and identify the caller of the function.

When assembly language programs are used, you can specify the assembler symbol for a subroutine instead of a C function name, and the prestored states will show the instructions that called the subroutine.

Function Caller Trace Dialog Box

Choosing the Trace→Function Caller... (ALT, T, C) command opens the following dialog box:

```
Function Caller Trace

Function: next_message

OK

Cancel

Help
```

Function

Lets you enter the function whose callers you want to trace.

OK

Executes the command and closes the dialog box.

Cancel

Cancels the command and closes the dialog box.

Command File Command

TRA(CE) FUNC(TION) CAL(L) address
See Also

"To trace callers of a specified function" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.
Trace→Function Statement... (ALT, T, S)

Traces execution within the specified function.

The function name can be selected from the another window (in other words, copied to the clipboard) before choosing the command; it will automatically appear in the dialog box that is opened.

The analyzer stores execution states in the function's address range.

Because the analyzer is set up based on function information from the object file, this command cannot be used to trace non-C functions.

**Function Statement Trace Dialog Box**

Choosing the Trace→Function Statement... (ALT, T, S) command opens the following dialog box:

![Function Statement Trace Dialog Box](image)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
<td>Lets you enter the function whose execution you want to trace.</td>
</tr>
<tr>
<td>OK</td>
<td>Traces within the specified function and closes the dialog box.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Cancels the command and closes the dialog box.</td>
</tr>
</tbody>
</table>

**Command File Command**

```
TRA(CE) FUNC(TION) STA(TEMENT) address
```
Chapter 8: Menu Bar Commands
Trace → Function Statement... (ALT, T, S)

See Also

"To trace execution within a specified function" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.
Trace→Variable Access... (ALT, T, V)

Traces accesses to the specified variable.

The variable name can be selected from another window (in other words, copied to the clipboard) before choosing the command; it will automatically appear in the dialog box that is opened.

You can specify any of the external or static variables, or the variables having a fixed address throughout the course of program execution.

The analyzer stores only accesses within the range of the variable and prestores execution states that occur before the access. These prestored states correspond to the statements that access the variable.

Variable Access Dialog Box

Choosing the Trace→Variable Access... (ALT, T, V) command opens the following dialog box:

```
<table>
<thead>
<tr>
<th>Variable Access Trace</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable:</td>
</tr>
<tr>
<td>message_id</td>
</tr>
<tr>
<td>OK</td>
</tr>
<tr>
<td>Cancel</td>
</tr>
<tr>
<td>Help</td>
</tr>
</tbody>
</table>
```

Variable Let you enter the variable name.

OK Traces accesses to the specified variable and closes the dialog box.

Cancel Cancels the command and closes the dialog box.

Command File Command

TRA(CE) VAR(IABLE) ACC(ESS) address
Chapter 8: Menu Bar Commands
Trace→Variable Access... (ALT, T, V)

See Also

"To trace accesses to a specified variable" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.
Trace→Edit... (ALT, T, E)

Edits the trace specification of the last trace command.

This command is useful for making modifications to the last entered trace command, even if the analyzer was set up automatically as with the Trace→Function or Trace→Variable commands.

Trace specifications are edited with Sequence Trace Setting dialog box.

**Command File Command**

**TRA(CE) SAV(E) filename**
Stores the current trace specification to a file.

**TRA(CE) LOA(D) filename**
Loads the specified trace setting file.

**TRA(CE) CUS(TOMIZE)**
Traces program execution using the loaded trace setting file.

**See Also**

"To edit a trace specification" in the "Setting Up Custom Trace Specifications" section of the "Debugging Programs" chapter.

Trace→Sequence... (ALT, T, Q)
Trace→Trigger Store... (ALT, T, T)

Traces program execution as specified in the Trigger Store Trace dialog box.

You can enter address, data, and status values that qualify the state(s) that, when captured by the analyzer, will be stored in the trace buffer or will trigger the analyzer. See "Understanding Addresses, Data, and Status" for information and hints on setting up the A:D:S fields.
Trigger Store Trace Dialog Box

Choosing the Trace→Trigger Store... (ALT, T, T) command opens the following dialog box:

- **Trigger**: This box groups the items that make up the trigger condition.
- **NOT**: Specifies any state that does not match the Address, Data, and Status values.
- **Address**: Specifies the address portion of the state qualifier.
- **End Address**: Specifies the end address of an address range.
- **Data**: Specifies the data portion of the state qualifier.
- **Status**: Specifies the status portion of the state qualifier.
- **trigger start**: Specifies that states captured after the trigger condition be stored in the trace buffer.
- **trigger center**: Specifies that states captured before and after the trigger condition be stored in the trace buffer.
- **trigger end**: Specifies that states captured before the trigger condition be stored in the trace buffer.
Chapter 8: Menu Bar Commands
Trace → Trigger Store... (ALT, T, T)

Store
This box groups the items that make up the store condition.

OK
Starts the specified trace and closes the dialog box.

Cancel
Cancels the trace setting and closes the dialog box.

Clear
Restores the dialog box to its default state.

Load...
Opens a file selection dialog box from which you select the name of a trace specification file previously saved from the Trigger Store Trace dialog box. Trace specification files have the extension ".TRC".

Save...
Opens a file selection dialog box from which you select the name of the trace specification file.

Command File Command

TRA(CE) LOA(D) filename
Loads the specified trace setting file.

TRA(CE) CUS(TOMIZE)
Traces program execution using the loaded trace setting file.

See Also
"To set up a "Trigger Store" trace specification" in the "Setting Up Custom Trace Specifications" section of the "Debugging Programs" chapter.
Trace→Find Then Trigger... (ALT, T, D)

Traces program execution as specified in the Find Then Trigger Trace dialog box.

This command lets you set up a two level sequential trace specification that works like this:

1. Once the trace starts, the analyzer stores (in the trace buffer) the states that satisfy the Enable Store condition while searching for a state that satisfies the Enable condition.

2. After the Enable condition has been found, the analyzer stores the states that satisfy the Trigger Store condition while searching for a state that satisfies the Trigger condition.

3. After the Trigger condition has been found, the analyzer stores the states that satisfy the Store condition.

If any state during the sequence satisfies the Restart condition, the sequence starts over.

You can enter address, data, and status values that qualify state(s) by setting up pattern or range resources. These patterns and range resources are used when defining the various conditions.

A trace is complete when the trace buffer is full.
Find Then Trigger Trace Dialog Box

Choosing the Trace→Find Then Trigger... (ALT, T, D) command opens the following dialog box:

![Find Then Trigger Trace Dialog Box]

The Sequence group box specifies a two term sequential trigger condition. It also lets you specify store conditions during the sequence.

Enable Store  Qualifies the states that get stored (in the trace buffer) while searching for a state that satisfies the enable condition.

Enable  Specifies the condition that causes a transfer to the next sequence level.

Trigger Store  Qualifies the states that get stored while the analyzer searches for the trigger condition.

Trigger  Specifies the trigger condition.

Store  Qualifies the states that get stored after the trigger condition is found.

Restart  Specifies the condition that restarts the sequence.
Count Specifies whether time or the occurrences of a particular state are counted; you can also turn counts OFF. See the Condition Dialog Boxes.

Prestore Qualifies the states that may be stored before each normally stored state. Up to two states may be prestored for each normally stored state. Prestored states can be used to show from where a function is called or a variable is accessed.

trigger start The state that satisfies trigger condition is positioned at the start of the trace, and states that satisfy the store condition will be stored after the trigger. In this case, the states that satisfy the Enable Store and Trigger Store conditions will not appear in the trace.

trigger center The state that satisfies the trigger condition is positioned in the center of the trace, and states that satisfy the store conditions will be stored before and after the trigger.

trigger end The state that satisfies the trigger condition is positioned at the end of the trace, and states that satisfy the Enable Store and Trigger Store conditions will be stored before the trigger. In this case, states that satisfy the Store condition will not appear in the trace.

Break on Trigger When selected, this option specifies that execution break into the monitor when the analyzer is triggered.

Pattern/Range Specifies the trace patterns for the state conditions. Double-clicking the desired pattern or range in the Pattern/Range list box opens the Trace Pattern Dialog Box or the Trace Range Dialog Box, where you specify the desired trace pattern or range.

Clicking the Sequence, Restart, Count, or Prestore buttons causes the Condition Dialog Boxes to be opened. This dialog box lets you select or combine patterns or ranges to specify the condition.
OK Starts the specified trace and closes the dialog box.

Cancel Cancels trace setting and closes the dialog box.

Clear Restores the dialog box to its default state.

Load... Opens a file selection dialog box from which you select the name of a trace specification file previously saved from the Trigger Store Trace or Find Then Trigger Trace dialog boxes. Trace specification files have the extension ".TRC".

Save... Opens a file selection dialog box in which you specify a name to identify a file containing the present trace specification.

**Command File Command**

```
TRA(CE) LOA(D) filename
```
Loads the specified trace setting file.

```
TRA(CE) CUS(TOMIZE)
```
Traces program execution using the loaded trace setting file.

**See Also**

"To set up a "Find Then Trigger" trace specification" in the "Setting Up Custom Trace Specifications" section of the "Debugging Programs" chapter.
Trace→Sequence... (ALT, T, Q)

Traces program execution as specified in the Sequence Trace dialog box.

This command lets you set up a multilevel sequential trace specification that works like this:

1. Once the trace starts, the analyzer stays on sequence level 1 until the primary or secondary branch condition is found. (If a state satisfies both primary and secondary branch conditions, the primary branch is taken.) Once the primary or secondary branch condition is found, the analyzer transfers to the sequence level specified by the "to" button.

2. The analyzer stays at the next sequence level until its primary or secondary branch condition is met; then, the analyzer transfers to the sequence level specified by the "to" button.

3. When the analyzer reaches the sequence level specified in Trigger On, the analyzer is triggered.

4. During the above described operation, the analyzer stores the states specified in the Store text box.

The trace is complete when the trace buffer is full.
Sequence Trace Dialog Box

Choosing the Trace→Sequence... (ALT, T, Q) command opens the following dialog box:

The Sequence group box specifies primary and secondary branch conditions for transferring from one sequence level to another. It also specifies store conditions for each of the eight sequence levels.

Primary Branch Specifies the condition for transferring to the sequence level specified in the "to" text box.

Secondary Branch Specifies the condition for transferring to the sequence level specified in the "to" text box. Secondary branches are used to do things like restart the sequence if a particular state is found.

Store Specifies the states to be stored in the trace buffer at each sequence level.

Page Toggles the display between sequence levels 1 through 4 and levels 5 through 8.

Trigger On Specifies the sequence level whose entry triggers the analyzer. See the Sequence Number Dialog Box.
<table>
<thead>
<tr>
<th>Count</th>
<th>Specifies whether time or the occurrences of a particular state are counted; you can also turn counts OFF. See the Condition Dialog Boxes.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prestore</td>
<td>Qualifies the states that may be stored before each normally stored state. Up to two states may be prestored for each normally stored state. Prestored states can be used to show from where a function is called or a variable is accessed.</td>
</tr>
<tr>
<td>trigger start</td>
<td>The state that satisfies trigger condition is positioned at the start of the trace, and states that satisfy the store conditions will be stored after the trigger.</td>
</tr>
<tr>
<td>trigger center</td>
<td>The state that satisfies the trigger condition is positioned in the center of the trace, and states that satisfy the store conditions will be stored before and after the trigger.</td>
</tr>
<tr>
<td>trigger end</td>
<td>The state that satisfies the trigger condition is positioned at the end of the trace, and states that satisfy the store conditions will be stored before the trigger.</td>
</tr>
<tr>
<td>Break on Trigger</td>
<td>When selected, this option specifies that execution break into the monitor when the analyzer is triggered.</td>
</tr>
<tr>
<td>Pattern/Range</td>
<td>Specifies the trace patterns for the state conditions. Double-clicking the desired pattern or range in the Pattern/Range list box opens the Trace Pattern Dialog Box or the Trace Range Dialog Box, where you specify the desired trace pattern or range.</td>
</tr>
<tr>
<td>OK</td>
<td>Starts the specified trace and closes the dialog box.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Cancels trace setting and closes the dialog box.</td>
</tr>
</tbody>
</table>

Chapter 8: Menu Bar Commands
Trace→Sequence... (ALT, T, Q)
Clear
Restores the dialog box to its default state.

Load...
Opens a file selection dialog box from which you select the name of a trace specification file previously saved from any of the trace setting dialog boxes. Trace specification files have the extension ".TRC".

Save...
Opens a file selection dialog box from which you select the name of the trace specification file.

**Command File Command**

```
TRA(CE) LOA(D) filename
```
Loads the specified trace setting file.

```
TRA(CE) CUS(TOMIZE)
```
Traces program execution using the loaded trace setting file.

**See Also**

"To set up a "Sequence" trace specification" in the "Setting Up Custom Trace Specifications" section of the 'Debugging Programs' chapter.
Trace→Until Halt (ALT, T, U)

Traces program execution until the Trace→Halt (ALT, T, H) command is chosen.

This command is useful in tracing execution that leads to a processor halt or a break to the background monitor. Before executing the program, choose the Trace→Until Halt (ALT, T, U) command. Then, run the program. After the processor has halted or broken into the background monitor, choose the Trace→Halt (ALT, T, H) command to stop the trace. The execution that led up to the break or halt will be displayed.

Command File Command
TRA (CE) ALW (AYS)

See Also
"To trace until the command is halted" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.
Trace→Halt (ALT, T, H)

Stops a running trace.

This command stops a currently running trace whether the trace was started with the Trace→Until Halt (ALT, T, U) command or another trace command.

As soon as the analyzer stops the trace, stored states are displayed in the Trace window.

**Command File Command**

TRA (CE)  STO (P)

**See Also**

"To stop a running trace" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.
Trace→Again (F7), (ALT, T, A)

Traces program execution using the last trace specification stored in the HP 64700.

If you haven’t entered a trace command since you started the debugger, the last trace specification stored in the HP 64700 may be a trace specification set up by a different user; in this case, you cannot view or edit the trace specification.

**Command File Command**

TRA (CE) AGA (IN)

**See Also**

"To repeat the last trace" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.
Condition Dialog Boxes

Choosing the buttons associated with enable, trigger, primary branch, secondary branch, store, or prestore conditions opens the following dialog box:

Choosing the button associated with the count condition opens the following dialog box:

- **no state**: No state meets the specified condition.
- **any state**: Any state meets the specified condition.
- **time**: The analyzer counts time for each state stored in the trace.
state
This group box lets you qualify the state that will meet the specified condition. You can qualify the state as one of the patterns "a" through "h," the "range," or the "arm," or you can qualify the state as a combination of the patterns, range, or arm by using the interset or intraset operators.

a b c d e f g h
The patterns that qualify states by identifying the address, data, and/or status values.

The values for a pattern are specified by selecting one of the patterns in the Pattern/Range list box and entering values in the Trace Pattern Dialog Box.

range
Identifies a range of address or data values.

The values for a range are specified by selecting the range in the Pattern/Range list box and entering values in the Trace Range Dialog Box.

not range
Identifies all values not in the specified range.

arm
Identifies the condition that arms (in other words, activates) the analyzer. The analyzer can be armed by an input signal on the BNC port.

or/nor
You can combine patterns within the set1 or set2 group boxes with these logical operators.

You can create the AND and NAND operators by selecting NOT when defining patterns and applying DeMorgan's law (the / character is used to represent a logical NOT):

\[
\begin{align*}
\text{AND} & \quad A \text{ and } B = \lnot (\lnot A \text{ or } \lnot B) \\
\text{NAND} & \quad \lnot (A \text{ and } B) = \lnot A \text{ or } \lnot B \end{align*}
\]

OR/AND
You can combine patterns from the set1 and set2 group boxes with these logical operators.
Count  Appearing in Trace Condition dialog boxes, this value specifies the number of occurrences of the state that will satisfy the condition.

OK  Applies the state qualifier to the specified condition and closes the dialog box.

Cancel  Closes the dialog box.

See Also

"To set up a "Find Then Trigger" trace specification", and "To set up a "Sequence" trace specification" in the "Setting Up Custom Trace Specifications" section of the "Debugging Programs" chapter.

Trace→Find Then Trigger... (ALT, T, D)
Trace→Sequence... (ALT, T, Q)
Trace Pattern Dialog Box

Selecting one of the patterns in the Pattern/Range list box opens the following dialog box:

![Trace Pattern Dialog Box](image)

- **NOT**: Lets you specify all values other than the address, data, and/or status values specified.
- **Address**: Lets you enter the address value for the pattern.
- **Data**: Lets you enter the data value for the pattern.
- **Status**: Lets you select the *status value* for the pattern.
- **Direct**: Lets you enter a status value other than one of the predefined status values.
- **Clear**: Clears the values specified for the pattern.
- **OK**: Applies the values specified for the pattern, and closes the dialog box.
Cancel Closes the dialog box.

See Also

"To set up a "Find Then Trigger" trace specification", and "To set up a "Sequence" trace specification" in the "Setting Up Custom Trace Specifications" section of the "Debugging Programs" chapter.

Trace→Find Then Trigger... (ALT, T, D)
Trace→Sequence... (ALT, T, Q)
Trace Range Dialog Box

Selecting the range at the bottom of the Pattern/Range list box opens the following dialog box:

Address Selects a range of address values.
Data Selects a range of data values.
Minimum Lets you enter the minimum value for the range.
Maximum Lets you enter the maximum value for the range.
OK Applies the values specified for the range, and closes the dialog box.
Cancel Closes the dialog box.
Clear Clears the values specified for the range.
See Also

"To set up a "Find Then Trigger" trace specification", and "To set up a "Sequence" trace specification" in the "Setting Up Custom Trace Specifications" section of the "Debugging Programs" chapter.

Trace→Find Then Trigger... (ALT, T, D)
Trace→Sequence... (ALT, T, Q)
Sequence Number Dialog Box

Choosing the buttons associated with "to" or Trigger On opens the following dialog box:

<p>| | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>OK</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Cancel</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Help</td>
</tr>
</tbody>
</table>

1-8 These options specify the sequence level.

OK Applies the selected sequence level and closes the dialog box.

Cancel Closes the dialog box.

See Also

"To set up a "Sequence" trace specification" in the "Setting Up Custom Trace Specifications" section of the "Debugging Programs" chapter.

Trace→Sequence... (ALT, T, Q)
RealTime→Monitor Intrusion→Disallowed (ALT, R, T, D)

Activates the real-time mode.

When the user program is running in real-time mode, no command that would normally cause temporary suspension of program execution is allowed. Also, the system hides:

- The Register window.
- Target system memory in the Memory window.
- Target system I/O locations in the I/O window.
- Target system memory variables in the WatchPoint window.
- Target system memory in the Source window.

While the processor is in the RUNNING REALTIME IN USER PROGRAM state, no display or modification is allowed for the contents of target system memory or registers. Therefore, before you can display or modify target system memory or processor registers, you must use the Execution→Break (ALT, E, B) command to stop user program execution and break into the monitor.

Command File Command

MOD(E) REA(LTIME) ON

See Also

"To allow or deny monitor intrusion" in the "Setting the Real-Time Options" section of the "Configuring the Emulator" chapter.
RealTime→Monitor Intrusion→Allowed (ALT, R, T, A)

Deactivates the real-time mode.

Commands that cause temporary breaks to the monitor during program execution are allowed.

**Command File Command**

MOD (E) REA (LTIME) OFF

**See Also**

"To allow or deny monitor intrusion" in the "Setting the Real-Time Options" section of the "Configuring the Emulator" chapter.
RealTime→I/O Polling→ON (ALT, R, I, O)

Enables access to I/O.

**Command File Command**

MOD (E)  IOG (UARD)  OFF

**See Also**

"To turn polling ON or OFF" in the "Setting the Real-Time Options" section of the "Configuring the Emulator" chapter.
RealTime→I/O Polling→OFF (ALT, R, I, F)

Disables access to I/O.

When polling is turned OFF, values in the I/O window are updated on entry to the monitor. When monitor intrusion is not allowed during program execution, the I/O window is not updated and contents are replaced by dashes (-).

Command File Command

MOD (E) IOG (UARD) ON

See Also

"To turn polling ON or OFF" in the "Setting the Real-Time Options" section of the "Configuring the Emulator" chapter.
RealTime→Watchpoint Polling→ON (ALT, R, W, O)

Turns ON polling to update values displayed in the WatchPoint window.

When polling is turned ON, temporary breaks in program execution occur when the WatchPoint window is updated.

**Command File Command**

MOD (E) WAT (CHPOLL) ON

**See Also**

"To turn polling ON or OFF" in the "Setting the Real-Time Options" section of the "Configuring the Emulator" chapter.
RealTime→Watchpoint Polling→OFF (ALT, R, W, F)

Turns OFF polling to update values displayed in the WatchPoint window.

When polling is turned OFF, values in the WatchPoint window are updated on entry to the monitor. When monitor intrusion is not allowed during program execution, the WatchPoint window is not updated and contents are replaced by dashes (-).

**Command File Command**

MOD (E) WAT (CHPOLL) OFF

**See Also**

"To turn polling ON or OFF" in the "Setting the Real-Time Options" section of the "Configuring the Emulator" chapter.
RealTime→Memory Polling→ON (ALT, R, M, O)

Turns ON polling to update target memory values displayed in the Memory window.

When polling is turned ON, temporary breaks in program execution occur when target system memory locations in the Memory window are updated. When monitor intrusion is not allowed during program execution, the contents of target memory locations are replaced by dashes (-).

Also, when polling is turned ON, you can modify the addresses displayed or contents of memory locations by double-clicking on the address or value, using the keyboard to type in the new address or value, and pressing the Enter key.

**Command File Command**

MOD (E)  MEM (OPYOLL)  ON

**See Also**

"To turn polling ON or OFF" in the "Setting the Real-Time Options" section of the "Configuring the Emulator" chapter.
Real-Time → Memory Polling → OFF (ALT, R, M, F)

Turns OFF polling to update target memory values displayed in the Memory window.

When polling is turned OFF, values in the Memory window are updated on entry to the monitor.

Also, when polling is turned OFF, you cannot modify the addresses displayed or contents of memory locations by double-clicking on the address or value.

**Command File Command**

MOD (E) MEM (ORYPOLL) OFF

**See Also**

"To turn polling ON or OFF" in the "Setting the Real-Time Options" section of the "Configuring the Emulator" chapter.
Settings → Emulator Config → Hardware... (ALT, S, E, H)

Specifies the emulator configuration.

**Hardware Config Dialog Box**

Choosing the Settings → Emulator Config → Hardware... (ALT, S, E, H) command opens the following dialog box:

<table>
<thead>
<tr>
<th>Emulator Configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CLK2 Frequency &gt; 42 MHz</strong></td>
</tr>
<tr>
<td>Enable Target Interrupts</td>
</tr>
<tr>
<td>Enable Software Breakpoints</td>
</tr>
<tr>
<td>Enable Break on Write to ROM</td>
</tr>
<tr>
<td>Enable Execution Trace Messages</td>
</tr>
<tr>
<td>Enable Foreground Monitor Traced as User</td>
</tr>
</tbody>
</table>

**CLK2 Frequency** Specifies whether one wait state should be added for accesses to memory mapped into 4-Mbyte SIMMs. Note that CLK2 is the oscillator frequency to the Intel80386EX. It is twice the frequency of the usually-quoted value. For example, a "20 MHz Intel80386EX" has a CLK2 of 40 MHz.

**Enable Target Interrupts** Enables or disables target interrupts. If interrupts are disabled, no interrupts (INT or NMI) are passed to the processor. If enabled, interrupts are passed when executing user code or when using the foreground monitor. In any case, when using the background monitor, interrupts will be ignored while in the monitor.

**Enable Software Breakpoints** Enables or disables software breakpoints. If disabled, you cannot set any breakpoints. If enabled, you can set
software breakpoints. If software breakpoints are set, the emulator will take a longer time to leave the RESET state because it must break into the monitor to enable the software breakpoints each time it leaves the RESET state.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Break on Write to ROM</td>
<td>Enables or disables breaks to the monitor when the user program writes to memory mapped as ROM.</td>
</tr>
<tr>
<td>Enable Execution Trace Messages</td>
<td>Enables or disables branch trace messages and task switch messages:</td>
</tr>
<tr>
<td></td>
<td>If enabled, every time the processor does a branch, it will emit the target address of the branch. See Understanding Intel80386EX Analysis for more information about how to use branch trace messages.</td>
</tr>
<tr>
<td></td>
<td>If enabled, any task switch will emit a task switch message telling you what the old task was and what the new task is.</td>
</tr>
<tr>
<td>Enable Foreground Monitor Traced as User</td>
<td>Enables or disables tracing when execution is in the foreground monitor. When using a foreground monitor with this selected, all foreground monitor cycles will be captured in the trace memory by the emulation-bus analyzer. This is useful when you are having problems with an interrupt routine and you want to trace that routine even if it occurs during execution in the foreground monitor.</td>
</tr>
<tr>
<td></td>
<td>If this is not selected, and you have chosen Settings→Extended→Trace Cycles→User, the analyzer will capture nothing between the time the foreground monitor is entered and the time you begin a run of your user program again. This prevents capture of interrupt routines executed while in the foreground monitor. Use this to conserve space in the trace memory for capture of target program execution. When using the background monitor, this has no effect.</td>
</tr>
<tr>
<td>OK</td>
<td>Stores the current modification and closes the dialog box.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Cancels the current modification and closes the dialog box.</td>
</tr>
<tr>
<td>Apply</td>
<td>Loads the configuration settings into the emulator.</td>
</tr>
</tbody>
</table>
Command File Command

CON(FIG) FAS(TCLOCK) ENA(BLE)
CON(FIG) FAS(TCLOCK) DIS(ABLE)
CON(FIG) INT(RS) ENA(BLE)
CON(FIG) INT(RS) DIS(ABLE)
CON(FIG) WRR(OM) ENA(BLE)
CON(FIG) WRR(OM) DIS(ABLE)
CON(FIG) BKP(TS) ENA(BLE)
CON(FIG) BKP(TS) DIS(ABLE)
CON(FIG) EMS(GS) ENA(BLE)
CON(FIG) EMS(GS) DIS(ABLE)
CON(FIG) MON(ACCESSSES) ENA(BLE)
CON(FIG) MON(ACCESSSES) DIS(ABLE)

Any of the above command file commands must be preceded and followed by the respective start and end commands:

CON(FIG) STA(RT)
Starts the configuration option command section.

CON(FIG) END
Ends the configuration option command section.

See Also

"Setting the Hardware Options" in the "Configuring the Emulator" chapter.

"Tracing Program Execution" in the "Debugging Programs" chapter for useful combinations of the Settings→Extended→Trace Cycles command and the Enable Foreground Monitor Traced as User selection.
Chapter 8: Menu Bar Commands
Settings→Emulator Config→Memory Map... (ALT, S, E, M)

Settings→Emulator Config→Memory Map... (ALT, S, E, M)

Maps memory ranges.

Up to eight ranges of memory can be mapped, and the resolution of mapped ranges is 256 bytes (that is, the memory ranges must begin on 256-byte boundaries and must be at least 256 bytes in length).

You can map ranges as emulation RAM, emulation ROM, target system RAM, target system ROM, or as guarded memory.

Guarded memory accesses always cause emulator execution to break into the monitor program.

Write transactions by user code to locations mapped as ROM (whether emulation ROM or target ROM) will cause emulator execution to break into the monitor program if you have selected "Enable Break on Write to ROM" in the Emulator Configuration dialog box.

Writes to emulation ROM will modify memory. Writes to target RAM that has been mapped as ROM will also modify memory.
Memory Map Dialog Box

Choosing the Settings→Emulator Config→Memory Map... (ALT, S, E, M) command opens the following dialog box:

- **Start**: Specifies the starting address of the address range to be mapped.
- **End**: Specifies the end address of the address range to be mapped.
- **Type**: Lets you select the memory type of the specified address range.
- **Use target RDY**: Specifies that emulation memory accesses in the range be synchronized to the target system RDY signal.
Use dual-ported memory: Specifies that this memory range will be placed in the 8K of dual-ported memory. Note that you can only map one address range to this memory. RTC can access this memory without breaking into the monitor when the processor is running and not in the HALT or SHUTDOWN state. If the processor is in the HALT or SHUTDOWN state, however, dual-port memory cannot be accessed. In that case, the emulator will break into the monitor to read the memory. To prevent the break into the monitor in this case, choose Realtime→Monitor Intrusion→Disallowed.

Apply: Maps the address range specified in the Define Map Term group box.

Default Type: Specifies the type of unmapped memory.

Current Map: Lists currently mapped ranges.

Available: Indicates the amount of emulation memory available.

Delete: Deletes the address range selected in the Current Map list box.

Delete All: Deletes all of the address ranges in the Current Map list box.

Close: Closes the dialog box.
Command File Command

MAP addressrange mem_type attributes
Maps the specified address range with the specified memory type. When mapping emulation memory ranges, the attributes can be a comma-separated list including:

dp map the address range to dual-port memory.

trdy memory accesses in the range will be synchronized to the target system READY# signal.

MAP OTHER mem_type
Specifies the type of the specified non-mapped memory area.

Any of the above command file commands must be preceded and followed by the respective start and end commands:

MAP START
Starts the memory mapping command section.

MAP END
Ends the memory mapping command section.

See Also

"Mapping Memory" in the "Configuring the Emulator" chapter.
Settings→Emulator Config→Monitor... (ALT, S, E, O)

Selects the type of monitor program and other monitor options.

**Monitor Config Dialog Box**

Choosing the Settings→Emulator Config→Monitor... (ALT, S, E, O) command opens the following dialog box:

![Monitor Configuration Dialog Box]

- **Monitor Type**
  - Lets you choose between a background monitor and a foreground monitor.

- **Monitor Address**
  - Specifies the starting address of the foreground monitor program. The address must reside on a 16-Kbyte boundary (in other words, a multiple of 4000H) and must be specified in hexadecimal. In order for the foreground monitor to run in real mode, the base address must be limited to 000fc000 hex. Higher addresses can be selected if the target program always runs in protected mode. However, any attempt to break before protected mode is enabled will result in the background monitor being used (target interrupts will be blocked).
Monitor Selector
Selects the GDT descriptor for the foreground monitor code segment. The foreground monitor is interruptable and is designed to run in both real and protected modes based on the current state of the processor. In order to run in protected mode, a GDT entry must be reserved to define the code segment for the monitor. The specified value must be a multiple of 8, greater than 0 and less than the limit defined in GDTR.

Monitor Cycles
Specifies whether monitor cycles should be synchronized to the target system (in other words, whether the emulation and target system READY# should be interlocked on accesses to the monitor memory block).

Use Target RDY

Load Custom Monitor
Specifies whether the default foreground monitor (resident in the emulator firmware) or a custom monitor should be used.

Monitor File Name
When using a customized foreground monitor program, this text box lets you enter the name of the object file. An example foreground monitor is provided with the debugger in the C:\HP\RTC\I386EX\MONITOR directory (if C:\HP\RTC\I386EX was the installation path chosen when installing the debugger software). The file is named I386EX.ASM.

Browse...
Opens a file selection dialog box from which you can select the foreground monitor object file to be loaded.

OK
Modifies the monitor configuration as specified and closes the dialog box.

Cancel
Cancels the monitor configuration and closes the dialog box.

Apply
Loads the configuration settings into the emulator.
Command File Command

MON(ITOR) TYP(E) FOR(EGROUND)
Selects the foreground monitor.

MON(ITOR) TYP(E) BAC(KGROUND)
Selects the background monitor.

MON(ITOR) ADD(RESS) address
Specifies the monitor's base address.

MON(ITOR) SEL(ECTOR) selector
Specifies the monitor's selector.

MON(ITOR) TRD(Y) ENA(BLE)
Enables synchronization of monitor cycles to the target system (that is, interlock the emulation and target system RDY on accesses to the monitor memory block).

MON(ITOR) TRD(Y) DIS(ABLE)
Disables synchronization of monitor cycles to the target system.

MON(ITOR) FIL(ENAME) NON(E)
Specifies using the built-in foreground monitor.

MON(ITOR) FIL(ENAME) file_name
Names the foreground monitor object file.

Any of the above command file commands must be preceded and followed by the respective start and end commands:

MON(ITOR) STA(RT)
Starts the monitor option command section.

MON(ITOR) END
Ends the monitor option command section.

See Also

"Selecting the Type of Monitor" in the "Configuring the Emulator" chapter.
Settings→Emulator Config→Address Translation... (ALT, S, E, A)

Choosing the Settings→Emulator Config→Address Translation... (ALT, S, E, A) command opens the following dialog box:

![Address Translation Dialog Box]

**Page translations required**
Specifies that paging is used by your target system; therefore, any virtual-to-physical translation will need to traverse the page tables.

HP strongly recommends you not use this unless your target system uses paging because your system performance will be improved if the page tables do not need to be traversed every time a translation occurs.
Dynamic (always break to determine translations) Specifies that the emulator will temporarily break from execution of your target program into the monitor to do a translation. With this selection, the translation will always be accurate for the current state of the processor and the current GDT (if in protected mode).

Choose "Dynamic" if your GDT tables change frequently. The only negative aspect of making this choice is that you cannot set up the analyzer or modify and display memory using protected-mode addresses when the processor is RESET or in real mode. You must use physical addresses in these cases.

Static (cache translations on OK or Apply) Specifies that cached translations will be used, and that the source for the cache will be read from the Intel80386EX when the OK or Apply button is pressed. The "Caching Options", below, will be consulted to determine the location of the GDT and page tables.

Static (cache translations after every file load) Specifies that cached translations will be used, and that the source for the cache is from an object file. When a file is loaded, the cache will be updated. The "Caching Options", below, will be consulted to determine the location of the GDT and page tables within the absolute file. Note that when this is chosen, the current translation scheme is used until the next File→Load Object... command is given. For example, if the mode is "dynamic" when this is chosen, address translations will continue to be dynamic until the next successful File→Load Object... command.

Caching Options

Use current processor register values Specifies that the current register values for GDTR, CR0, and CR3 are read, then their values are used to cache GDT and LDT tables as well as page tables.
Use GDT base/limit stored in absolute file
Specifies that the GDT location is stored in the absolute file and is marked as such. Some builders provide this data and some do not. If you try this and fail, use the next option.

Use GDT base/limit specified below
Specifies that the GDT address and size will be taken from the values in the edit boxes below:

- **GDT base address**: Specifies the base address of the GDT. Note that this address must be a linear address (not virtual).
- **GDT limit**: Specifies the limit of the GDT; it must be a multiple of 8 minus 1 (bytes). For example, if there were four entries in the GDT, the value would be 31 (01F); \((8 \times 4) - 1\).

**Command File Command**

**ADD (RTRAN) PAG(ING) ON**
Specify that paging is enabled, so page tables must be traversed in order to translate linear (and virtual) addresses to physical.

**ADD (RTRAN) PAG(ING) OFF**
Specify that paging is disabled.

**ADD (RTRAN) MET(HOD) DYN(AMIC)**
Specify that dynamic address translations should be used.

**ADD (RTRAN) MET(HOD) STATICOKAY**
Specify that static address translations should be used, and cache the GDT and page tables immediately.

**ADD (RTRAN) MET(HOD) STATICFILE**
Specify that static address translations should be used, and cache the GDT and page tables whenever a file is loaded into the emulator.
ADD (TRAN) CAC (HE) CUR (RENT)
Specify that the current register values for GDTR, CR0 and CR3 are read, and then their values are used to cache GDT and LDT tables as well as page tables.

ADD (RTRAN) CAC (HE) FROMOMF
Specify that when caching the GDT, the base and limit of the GDT is to be taken from the OMF386 file loaded into the emulator.

ADD (TRAN) CAC (HE) FROMVAL
Specify that the GDT address and size will be taken from the values specified in "ADDRTRAN GDTBASE base" and "ADDRTRAN GDTLIMIT limit", and in "ADDRTRAN PDBASE base" (if applicable).

ADD (RTRAN) GDTBASE base
Specify that when caching the GDT, the address of the GDT is "base".

ADD (RTRAN) GDTLIMIT limit
Specify that when caching the GDT, the limit of the GDT is "limit".

Any of the above command file commands must be preceded and followed by the respective start and end commands:

ADD (RTRAN) STA (RT)
Starts the address translation command section.

ADD (RTRAN) END
Ends the address translation command section.

See Also

"Selecting how Address Translations work" in the "Configuring the Emulator" chapter.
Settings→Communication... (ALT, S, C)

Choosing this command opens the RTC Emulation Connection Dialog Box which lets you identify and set up the communication channel between the personal computer and the HP 64700.

**RTC Emulation Connection Dialog Box**

Choosing the Settings→Communication... (ALT, S, C) command opens the following dialog box:

![RTC Emulation Connection Dialog Box](image)

**Current Connection Status**

This part of the dialog box shows the current communication settings.

**RTC Core Version Information**

Displays software version information.
New Emulator Connection Setup

Transport Selection
Lets you choose the type of connection to be made to the HP 64700. Double-clicking causes the current connection to be tried with the given transport. Single-clicking selects the transport for use with the Setup button.

User Name
This name tells the HP 64700 and other users who you are. When other users attempt to access the HP 64700 while you are using it or while it is locked, a message tells them you’re using it.

User ID
Another method of identifying yourself to the HP 64700 and other users. This is primarily useful in a mixed UNIX and MS-DOS environment; when a UNIX user tries to unlock an emulator, the user ID is used to look into the /etc/passwd entry on the UNIX host for the user name.

If your HP 64700 is on the LAN, we recommend that you change User Name and User ID so that other users can easily tell if an emulator is in use and by whom. Also, if you don’t change the User Name/ID from the defaults, the File→Exit HW Locked (ALT, F, H) command has no effect because all users are identical.

Setup
Opens a transport-specific dialog box which usually allows you to change the address and unlock the emulator.

In the LAN Setup dialog boxes, enter the IP address or network name of the HP 64700.

In the RS232C Setup dialog box, select the baud rate and the name of the port (for example, COM1, COM2, etc.) to which the HP 64700 is connected.

In the HP-RS422 Setup dialog box, select the baud rate and specify the I/O address you want to use for the HP 64037 card. The I/O address must be a hexadecimal number from 100H through 3F8H, ending in 0 or 8, that does not conflict with other cards in your PC.
The Connect button in any of these Setup dialog boxes starts the debugger with the specified communication settings.

Close
Either closes the Real-Time C Debugger, if the current connection failed, or simply closes the dialog box.

The Real-Time C Debugger does not allow you to change connection or transport information without leaving the debugger and reentering it. However, any changes you make will be put in the .INI file and take effect the next time you enter the debugger (assuming that you do not override the .INI information on the command line).

The command line options for connection and transport (-E and -T) take precedence over the values in the .INI file.
Settings→BNC→Outputs Analyzer Trigger (ALT, S, B, O)

Specifies that the analyzer trigger signal be driven on the BNC port.

Selecting the emulator BNC port for output enables the trigger signals to be fed to external devices (for example, logic analyzers) during tracing.

**CAUTION**

Do not drive the BNC beyond the range of 0 to 5 volts. Doing so may cause permanent damage to the HP 64700.

The BNC's drivers can drive 50 ohm loads. The following is a logical diagram of the BNC connection. The physical implementation and values of resistors are not exact. This diagram is just to help you understand the BNC interface:

![Logical Diagram of BNC Connection](image)

When a trace starts, it stops driving the output (so if nothing else is driving the line, it will fall low due to the 500 ohm pull-down resistor).

When the trigger point is found, the BNC starts driving the output high. It will stay high until the start of the next trace.

**Command File Command**

MOD(E) BNC OUT_PAT_TRIGGER
Chapter 8: Menu Bar Commands
Settings → BNC → Outputs Analyzer Trigger (ALT, S, B, O)

See Also

"To output the trigger signal on the BNC port" in the "Setting Up the BNC Port" section of the "Configuring the Emulator" chapter.
Settings→BNC→Input to Analyzer Arm (ALT, S, B, I)

Allows the analyzer to receive an arm signal from the BNC port.

This command allows an external trigger signal to be used as an arm (enable) condition for the internal analyzer. The internal analyzer will arm (or enable) on a positive edge TTL signal.

**CAUTION**

Do not drive the BNC beyond the range of 0 to 5 volts. Doing so may cause permanent damage to the HP 64700.

You can use the arm condition when setting up custom trace specifications with the Trace→Find Then Trigger... (ALT, T, D) or Trace→Sequence... (ALT, T, Q) commands. For example, you can trigger on the arm condition or enable the storage of states on the arm condition. The "arm" condition may be selected in "set2" of the Trace Condition or Count Condition dialog boxes.

The BNC port is internally terminated with about 500 ohms; if using a 50 ohm driver, use an external 50 ohm termination (such as the HP 10100C 50 Ohm Feedthrough Termination) to reduce bouncing and possible incorrect triggering.

**Command File Command**

MOD(E) BNC INP(UT_ARM)

**See Also**

Settings→BNC→Outputs Analyzer Trigger (ALT, S, B, O) for a logical schematic of the BNC interface.

"To receive an arm condition input on the BNC port" in the "Setting Up the BNC Port" section of the "Configuring the Emulator" chapter.
settings→font... (alt, s, f)

selects the fonts used in the debugger windows.

font dialog box

choosing the settings→font... (alt, s, f) command opens the following dialog box:

font

let you select the font to be used in the real-time c debugger interface. the "t" shaped icon indicates a true type font.

font style

let you select the typeface, for example, regular, bold, italic, etc.

size

let you select the size of the characters.

sample

shows you what the selected font looks like.

ok

sets the font, and closes the dialog box.

cancel

cancels font setting, and closes the dialog box.
See Also
"To change the debugger window fonts" in the "Working with Debugger Windows" section of the "Using the Debugger Interface" chapter.

Settings→Tabstops... (ALT, S, T)

Sets the number of spaces between tab stops.

Source Tab Dialog Box

Choosing the Settings→Tabstops... (ALT, S, T) command opens the following dialog box:

![Source Tab Dialog Box](image)

- **Tab width in source window display**
  - Enter the number of spaces between tab stops. This also affects the tab width for source lines in the Trace window.
  - The number must be between 1 and 20.
- **OK**
  - Sets the tab stops, and closes the dialog box.
- **Cancel**
  - Cancels tab stop setting, and closes the dialog box.

See Also
"To set tab stops in the Source window" in the "Working with Debugger Windows" section of the "Using the Debugger Interface" chapter.
Settings→Symbols→Case Sensitive→ON (ALT, S, S, C, O)

Symbol database search is case sensitive.

**Command File Command**

MOD (E) SYM (BOLCASE) ON

**See Also**

Settings→Symbols→Case Sensitive→OFF (ALT, S, S, C, F)

Settings→Symbols→Case Sensitive→OFF (ALT, S, S, C, F)

Symbol database search is not case sensitive.

If there are case conflicts (for example, FOO and foo), no warning is given, and you cannot predict which symbol will be used. The symbol that is used depends on what type of symbols FOO and foo are and how they were input by the symbol section of the object file.

**Command File Command**

MOD (E) SYM (BOLCASE) OFF

**See Also**

Settings→Symbols→Case Sensitive→ON (ALT, S, S, C, O)
Settings→Extended→Trace Cycles→User (ALT, S, X, T, U)

Traces foreground emulation microprocessor operation.
This is the normal setting.

**Command File Command**

MOD (E) TRA (CECLOCK) USE (R)

**See Also**

Settings→Extended→Trace Cycles→Monitor (ALT, S, X, T, M)
Settings→Extended→Trace Cycles→Both (ALT, S, X, T, B)

Settings→Extended→Trace Cycles→Monitor (ALT, S, X, T, M)

Traces background emulation microprocessor operation.
This is rarely a useful setting when debugging programs.

**Command File Command**

MOD (E) TRA (CECLOCK) BAC (KGROUND)

**See Also**

Settings→Extended→Trace Cycles→User (ALT, S, X, T, U)
Settings→Extended→Trace Cycles→Both (ALT, S, X, T, B)
Settings → Extended → Trace Cycles → Both (ALT, S, X, T, B)

Traces both foreground and background emulation microprocessor operation.

**Command File Command**

MOD (E) TRA (CECLOCK) BOT (H)

**See Also**

Settings → Extended → Trace Cycles → User (ALT, S, X, T, U)
Settings → Extended → Trace Cycles → Monitor (ALT, S, X, T, M)
Settings→Extended→Load Error Abort→ON (ALT, S, X, L, O)

An error during an object file or memory load causes an abort.

Normally, when an error occurs during an object file or memory load, you want the load to stop so that you can fix whatever caused the error.

**Command File Command**

```text
MOD (E) DOW (NLOAD) ERR (ABORT)
```

**See Also**

Settings→Extended→Load Error Abort→OFF (ALT, S, X, L, F)

Settings→Extended→Load Error Abort→OFF (ALT, S, X, L, F)

An error during an object file or memory load does not cause an abort.

If you expect certain errors during an object file or memory load, for example, if part of the file is located at "guarded" memory or "target ROM," you can choose this command to continue loading in spite of the errors.

**Command File Command**

```text
MOD (E) DOW (NLOAD) NOE (RRABORT)
```

**See Also**

Settings→Extended→Load Error Abort→ON (ALT, S, X, L, O)
Settings→Extended→Source Path Query→ON (ALT, S, X, S, O)

You are prompted for source file paths.

When the debugger cannot find source file information for the Source or Trace windows, it may prompt you for source file paths, depending on the MODE SOURCE setting.

**Command File Command**

MOD (E) SOUR (RCE) ASK (PATH)

**See Also**

Settings→Extended→Source Path Query→OFF (ALT, S, X, S, F)

Settings→Extended→Source Path Query→OFF (ALT, S, X, S, F)

You are not prompted for source file paths.

You can turn off source path prompting, for example, to avoid annoying dialog interactions when tracing library functions for which no source files are available.

**Command File Command**

MOD (E) SOUR (RCE) NOA (SPATH)

**See Also**

Settings→Extended→Source Path Query→ON (ALT, S, X, S, O)
Window→Cascade (ALT, W, C)

Arranges, sizes, and overlaps windows.
Windows are sized, evenly, to be as large as possible.

Window→Tile (ALT, W, T)

Arranges and sizes windows so that none are overlapped.
Windows are sized evenly.

Window→Arrange Icons (ALT, W, A)

Rearranges icons in the Real-Time C Debugger window.
Icons are distributed evenly along the lower edge of the Real-Time C Debugger window.
Window→1-9 (ALT, W, 1-9)

Opens the window associated with the number.

The nine most recently opened windows appear in the menu list. If the window you wish to open is not in the list, choose the Window→More Windows... (ALT, W, M) command.

Windows are closed just as are ordinary MS Windows, that is, by opening the control menu and choosing Close or by pressing CTRL+F4.

For details on each of the debugger windows, refer to the "Debugger Windows" section in the "Concepts" chapter.

Command File Command

DIS(PLAY) window-name
Opens the specified window. Use the first three characters of the window name, or, if the window name is "Basic Registers", use "REG".

ICO(NIC) window-name
Closes the specified window. Use the first three characters of the window name, or, if the window name is "Basic Registers", use "REG".

See Also

"To open debugger windows" in the "Working with Debugger Windows" section of the "Using the Debugger Interface" chapter.
Window→More Windows... (ALT, W, M)

Presents a list box from which you can select the window to be opened.

Select Window Dialog Box

Choosing the Window→More Windows... (ALT, W, M) command opens the following dialog box:

![Select Window Dialog Box](image)

OK

Opens the window selected in the list box.

Cancel

Closes the dialog box.

Command File Command

DIS(PLAY) window-name
Opens the specified window. Use the first three characters of the window name, or, if the window name is "Basic Registers," use "REG."

ICO(NIC) window-name
Closes the specified window. Use the first three characters of the window name, or, if the window name is "Basic Registers," use "REG."

See Also

"To open debugger windows" in the "Working with Debugger Windows" section of the "Using the Debugger Interface" chapter.
Help→About Debugger/Emulator... (ALT, H, D)

Provides information on the Real-Time C Debugger.

Choosing the Help→About Debugger/Emulator... (ALT, H, D) command opens a dialog box containing the version information on the current Real-Time C Debugger and emulator.
Source Directory Dialog Box

When the source file associated with a symbol cannot be found in the current directory, the following dialog box is opened:

<table>
<thead>
<tr>
<th>Module</th>
<th>Shows the symbol whose source file could not be found.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Directory</td>
<td>Lets you enter the directory in which the source file associated with the symbol may be found.</td>
</tr>
<tr>
<td>OK</td>
<td>Adds the directory entered in the Directory text box to the source file search path.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Closes the dialog box.</td>
</tr>
</tbody>
</table>

You may not wish to have this dialog box open. There is a way to prevent it from opening. If you select Settings→Extended→Source Path Query→OFF, this dialog box will not open. If you wish to have this dialog box open when the source file associated with a symbol cannot be found, select Settings→Extended→Source Path Query→ON.
Window Control Menu Commands
Window Control Menu Commands

This chapter describes the commands that can be chosen from the control menus in debugger windows.

- Common Control Menu Commands
- Button Window Commands
- Expression Window Commands
- I/O Window Commands
- Memory Window Commands
- GDT/LDT/IDT Window Commands
- Register Windows’ Commands
- Source Window Commands
- Symbol Window Commands
- Trace Window Commands
- WatchPoint Window Commands
Common Control Menu Commands

This section describes commands that appear in the control menus of most of the debugger windows:

- Copy→Window (ALT, -, P, W)
- Copy→Destination... (ALT, -, P, D)

Copy→Window (ALT, -, P, W)

Copies the current window contents to the destination file specified with the File→Copy Destination... (ALT, F, P) command.

Command File Command

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>COP(Y) BAC(KTRACE)</td>
<td></td>
</tr>
<tr>
<td>COP(Y) BUT(TON)</td>
<td></td>
</tr>
<tr>
<td>COP(Y) EXP(RESSION)</td>
<td></td>
</tr>
<tr>
<td>COP(Y) IO</td>
<td></td>
</tr>
<tr>
<td>COP(Y) MEM(ORY)</td>
<td></td>
</tr>
<tr>
<td>COP(Y) REG(ISTER)</td>
<td></td>
</tr>
<tr>
<td>COP(Y) SOU(RCE)</td>
<td></td>
</tr>
<tr>
<td>COP(Y) WAT(CHPOINT)</td>
<td></td>
</tr>
</tbody>
</table>

See Also

"To copy window contents to the list file" in the "Working with Debugger Windows" section of the "Using the Debugger Interface" chapter.
Copy→Destination... (ALT, -, P, D)

Names the listing file to which debugger information may be copied.

This command opens a file selection dialog box from which you can select the listing file. Listing files have the extension ".LST".

**Command File Command**

COP(Y) TO filename

**See Also**

"To change the list file destination" in the "Working with Debugger Windows" section of the "Using the Debugger Interface" chapter.
Button Window Commands

This section describes the following command:

- **Edit... (ALT, -, E)**

## Edit... (ALT, -, E)

Lets you define and label buttons in the Button window.

You can set up buttons to execute commonly used commands or command files.

Note that the Copy→Window command will generate a listing file that contains a header followed by commands needed to recreate the buttons. By removing the header, this file may be used as a command file.

Alternatively, you can log commands to a command file as you edit the buttons (refer to "To create a command file" in the "Using Command Files" section of the "Using the Debugger Interface" chapter). To recreate the buttons, just run the command file that you created while editing the buttons.
Button Edit Dialog Box

Choosing the Edit... (ALT, -, E) command opens the following dialog box:

Command Specifies the command to be associated with the button. Command syntax is described at the bottom of most help topics under the "Command File Command" heading. Also, look in the "Command File and Macro Command Summary" chapter in the "Reference" part.

You can only enter a single command here; if you want a series of commands to be executed when this button is used, put them in a command file and use the command "FILE COMMAND filename," where "filename" is the name of your command file.

Name Specifies the button label to be associated with the command.

Add Adds the button to the button window.

Button Definitions Lists the currently defined buttons. You can select button definitions for deletion by clicking on them.
Delete   Deletes the button definition selected in the Button Definitions list box.

Delete All   Deletes all buttons from the Button window.

Close   Closes the dialog box.

**Command File Command**

BUTTON label "command"

**See Also**

"To create buttons that execute command files" in the "Using Command Files" section of the "Using the Debugger Interface" chapter.
Expression Window Commands

This section describes the following commands:

- Clear (ALT, -, R)
- Evaluate... (ALT, -, E)

Clear (ALT, -, R)

Erases the contents of the Expression window.

Command File Command

EVA (LUATE)  CLE (AR)
**Evaluate...** (ALT, -, E)

Evaluates expressions and displays the results in the Expression window.

**Evaluate Expression Dialog Box**

Choosing the Evaluate... (ALT, -, E) command opens the following dialog box:

![Evaluate Expression Dialog Box](image)

- **Expression**: Lets you enter the expression to be evaluated.
- **Evaluate**: Makes the evaluation and places the results in the Expression window.
- **Close**: Closes the dialog box.

**Command File Command**

EVA(LUATE) address

EVA(LUATE) "strings"

**See Also**

"Symbols" in the "Expressions in Commands" chapter.
I/O Window Commands

This section describes the following command:

- Define... (ALT, -, D)

Define... (ALT, -, D)

Adds or deletes memory mapped I/O locations from the I/O window.

I/O Setting Dialog Box

Choosing the Edit→Definition... command opens the following dialog box:
Address Specifies the address of the I/O location to be defined.

Size Specifies the data format of the I/O location to be defined. You can select the Byte, 16 Bits, or 32 Bits option.

Space Specifies whether the I/O location is in memory or I/O space.

Set Adds the specified I/O location.

I/O set Displays the information on the I/O locations that have been set.

Delete Deletes the I/O locations selected in the I/O set list box.

Close Closes the dialog box.

**Command File Command**

IO BYTE/WORD/LONG IOSPACE/MEMORY address TO data
Replaces the contents of the specified I/O address with the specified value in the specified size.

IO SET BYTE/WORD/LONG IOSPACE/MEMORY address
Registers the I/O address to be displayed in the specified size.

IO DEL(ETE) BYTE/WORD/LONG IOSPACE/MEMORY address
Deletes the I/O specified with its address and size.

**See Also**

"Displaying and Editing I/O Locations" in the "Debugging Programs" chapter.
Memory Window Commands

This section describes the following commands:

• Display→Linear (ALT, -, D, L)
• Display→Block (ALT, -, D, B)
• Display→Byte (ALT, -, D, Y)
• Display→16 Bits (ALT, -, D, 1)
• Display→32 Bits (ALT, -, D, 3)
• Search... (ALT, -, R)
• Utilities→Copy... (ALT, -, U, C)
• Utilities→Fill... (ALT, -, U, F)
• Utilities→Image... (ALT, -, U, I)
• Utilities→Load... (ALT, -, U, L)
• Utilities→Store... (ALT, -, U, S)

Display→Linear (ALT, -, D, L)

Displays memory contents in single column format.

Command File Command

MEM(ORY) ABS(OLUTE)
Display → Block (ALT, -, D, B)
Displays memory contents in multicolumn format.

**Command File Command**
MEM (ORY)  BLO (CK)

Display → Byte (ALT, -, D, Y)
Displays memory contents as bytes.

**Command File Command**
MEM (ORY)  BYTE

Display → 16 Bit (ALT, -, D, 1)
Displays memory contents as 16-bit values.

**Command File Command**
MEM (ORY)  WORD

Display → 32 Bit (ALT, -, D, 3)
Displays memory contents as 32-bit values.

**Command File Command**
MEM (ORY)  LONG
Search... (ALT, -, R)

Searches for a value or string in a range of memory.

When the value or string is found, the location is displayed in the Memory window. Choose the Window→Memory command to open the window.

The value or string can be selected from another window (in other words, copied to the clipboard) before choosing the command; the contents of the clipboard will automatically appear in the dialog box that is opened.

Search Memory Dialog Box

Choosing the Search... (ALT, -, R) command opens the following dialog box:

```
<table>
<thead>
<tr>
<th>Value:</th>
<th>String:</th>
<th>Start:</th>
<th>End:</th>
<th>Size:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>This</td>
<td>6000</td>
<td>0ff0</td>
<td>byte</td>
</tr>
</tbody>
</table>
```

Value

Lets you enter a value.

String

Lets you enter a string.

Start

Lets you enter the starting address of the memory range to search.

End

Lets you enter the end address of the memory range to search.

Size

Selects the data size using the Byte, 16 Bits, or 32 Bits option buttons.

Execute

Searches for the specified value or string.
Close closes the dialog box.

**Command File Command**

```
SEA(RCH) MEM(ORY) BYTE/WORD/LONG addr_range value
```

```
SEA(RCH) MEM(ORY) STR(ING) "string"
```

**See Also**

"To search memory for a value or string" in the "Displaying and Editing Memory" section of the "Debugging Programs" chapter.
Utilities→Copy... (ALT, -, U, C)

Copies the contents of one memory area to another.

**Memory Copy Dialog Box**

Choosing the Utilities→Copy... (ALT, -, U, C) command opens the following dialog box:

<table>
<thead>
<tr>
<th>Memory Copy</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Start:</strong></td>
</tr>
<tr>
<td><strong>End:</strong></td>
</tr>
<tr>
<td><strong>Destination:</strong></td>
</tr>
<tr>
<td><strong>Size:</strong></td>
</tr>
</tbody>
</table>

- **Start**: Lets you enter the starting address of the source memory area.
- **End**: Lets you enter the end address of the source memory area.
- **Destination**: Specifies the starting address of the destination memory area.
- **Size**: Selects the data size using the Byte, 16 Bits, or 32 Bits option buttons.
- **Execute**: Copies the memory contents.
- **Close**: Closes the dialog box.

**Command File Command**

```
MEM(ORY) COP(Y) size address_range address
```
Utilities→Fill... (ALT, -, U, F)

Fills a range of memory with a specified value.

Memory Fill Dialog Box

Choosing the Utilities→Fill... (ALT, -, U, F) command opens the following dialog box:

```
Value  Lets you enter the filling value.
Start  Lets you enter the starting address of the memory area to be filled.
End  Lets you enter the end address of the memory area to be filled.
Size  Selects the size of the filling value. If the value specified is larger than can fit in the size selected, the upper bits of the value are ignored. You can select the size using the Byte, 16 Bits, or 32 Bits option buttons.
Execute  Executes the command.
```
Close  Closes the dialog box.

Command File Command
MEM(ORY) FIL(L) size address_range data

See Also
"To modify a range of memory with a value" in the "Displaying and Editing Memory" section of the "Debugging Programs" chapter.

Utilities→Image... (ALT, -, U, I)

Copies the contents of a target system memory range into the corresponding emulation memory range.

You can copy programs that are in target system ROM to emulation memory. Once the program code is in emulation memory, you can use features like breakpoints, run until, etc.

The address range must be mapped as emulation memory before choosing this command.

Memory Image Dialog Box

Choosing the Utilities→Image... (ALT, -, U, I) command opens the following dialog box:

![Memory Image Dialog Box](image)
Start

Lets you enter the starting address of the memory area.

End

Lets you enter end address of the memory area.

Size

Selects the data size using the Byte, 16 Bits, or 32 Bits option buttons.

Execute

Copies the target system memory into emulation memory.

Close

Closes the dialog box.

Command File Command

MEM(ORY) IMA(GE) size address_range

See Also

"To copy target system memory into emulation memory" in the "Displaying and Editing Memory" section of the "Debugging Programs" chapter.
Utilities→Load... (ALT, -, U, L)

Loads memory contents from a previously stored file.

**Load Binary File Dialog Box**

Choosing the Utilities→Load... (ALT, -, U, L) command opens the following dialog box:

File Name  Lets you enter the name of the file to load memory from.

Bytes Loaded  After you choose the Import button, this box shows the number of bytes that are loaded.

Record Format  Lets you specify the format of the file from which you're loading memory. You can load Motorola S-Record or Intel Hexadecimal format files.

Load  Starts the memory load.

Cancel  Closes the dialog box.

Browse...  Opens a file selection dialog box from which you can select the file name.

**Command File Command**

MEM(ORY) LOA(D) MOT(OSREC) filename

MEM(ORY) LOA(D) INT(ELHEX) filename
Utilities→Store... (ALT, -, U, S)

Stores memory contents to a binary file.

**Store Binary File Dialog Box**

Choosing the Utilities→Store... (ALT, -, U, S) command opens the following dialog box:

- **File Name** lets you enter the name of the file to which memory contents are stored.
- **Bytes Stored** shows the number of bytes that are stored after you choose the Export button.
- **Record Format** lets you specify the format of the file to which you’re storing memory. You can select Motorola S-Record or Intel Hexadecimal formats.
- **Start** lets you enter the starting address of the memory range to be stored.
End               Lets you enter the ending address of the memory range to be stored.

Store             Starts the memory store.

Cancel            Closes the dialog box.

Browse...         Opens a file selection dialog box from which you can select a file name.

**Command File Command**

MEM(ORY) STO(RE) MOT(OSREC) addr-range filename

MEM(ORY) STO(RE) INT(ELHEX) addr-range filename

**See Also**

"To copy target system memory into emulation memory" in the "Displaying and Editing Memory" section of the "Debugging Programs" chapter.

Utilities→Load... (ALT, -, U, L)
GDT/LDT/IDT Window Commands

This section describes the following commands:

- **Search→Entry... (ALT, -, R, E)**
- **Search→Selector... (ALT, -, R, S)**

### Search→Entry... (ALT, -, R, E)

Displays the specified entry in the window.

When the specified entry is found, it is displayed on the top line in the GDT, LDT, or IDT window. Choose the Window→GDT, Window→LDT, or Window→IDT command to open the window.

#### Search GDT/LDT/IDT Entry Dialog Box

Choosing the Search→Entry... (ALT, -, R, E) command opens a dialog box similar to the following:

![Search GDT Entry Dialog Box](image)

The entry specifies the Nth entry in the table. For example, "20" specifies entry 20 shown in the table. The first entry line is entry "0". Because each entry is 8 bytes, the second entry starts at the 16th byte from the start of the table and the third entry starts at the 24th byte from the start of the table.

To search for entry 20 (the 21st line) in the table, type 20 in the Entry field and either press return or the Find button.
Bits 15 through 3 of the selector specify the offset into the table of the start of the entry.

Bit 2 specifies GDT when it is zero, or LDT when it is 1.

Bits 1-0 specify privilege level. For example, if the second entry in the GDT is privilege level 0, its selector is 8. If it had a DPL of 3, it would be B (hex).

Find Searches for the specified entry.

Close Closes the dialog box.

Command File Command

GDT ENTRY value
LDT ENTRY value
IDT ENTRY value

See Also
"The GDT window", "The LDT window", or the "The IDT window" in the "Debugger Windows" section of the "Concepts" chapter.

Search→Selector... (ALT, -, R, S)

Displays the specified selector in the window.

When the specified selector is found, it is displayed on the top line in the GDT, LDT, or IDT window. Choose the Window→GDT, Window→LDT, or Window→IDT command to open the window.
Search GDT/LDT/IDT Selector Dialog Box

Choosing the Search→Selector... (ALT, -, R, S) command opens a dialog box similar to the following:

To search for a selector, choose the Search→Selector... command. Then enter the selector number (in hex) and either press return or the Find button.

- Bits 15 through 3 of the selector specify the offset into the table of the start of the entry.
- Bit 2 specifies GDT when it is zero, or LDT when it is 1.
- Bits 1-0 specify privilege level. For example, if the second entry in the GDT is privilege level 0, its selector is 8. If it had a DPL of 3, it would be B (hex).

The lower three bits of the selector number are ignored on entry. For example, selector number 30 may be used to search for selector 30, 31, 32, or 33.

If the requested selector is within the range of the current table, it will be positioned at the top of the window. If it is out of range, an error box will pop up telling you it is an invalid selector.

Find       Searches for the specified selector.

Close      Closes the dialog box.

Command File Command

GDT SELECTOR value
LDT SELECTOR value
IDT SELECTOR value
See Also

"The GDT window", "The LDT window", or the "The IDT window" in the "Debugger Windows" section of the "Concepts" chapter.
Register Windows’ Commands

This section describes the following commands:

- Continuous Update (ALT, -, U)
- Copy→Registers (ALT, -, P, R)

Continuous Update (ALT, -, U)

Specifies whether the Register window contents should be continuously updated while running programs.

A check mark (√) next to the command shows that continuous update is active.

Copy→Registers (ALT, -, P, R)

Copies the current Register window contents to the destination file specified with the File→Copy Destination... (ALT, P, P) command.

Command File Command

COP(Y) REG(I)STER
Register Bit Fields Dialog Box

When a register has bit-fields, a dialog will pop up and the register value may be edited by changing the whole value or by editing individual bit-fields.

<table>
<thead>
<tr>
<th>Description</th>
<th>Value</th>
<th>Bit(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reserved</td>
<td>3fF</td>
<td>31-48</td>
</tr>
<tr>
<td>Virtual 8086 Mode</td>
<td>17</td>
<td></td>
</tr>
<tr>
<td>Resume Flag</td>
<td>16</td>
<td></td>
</tr>
<tr>
<td>Reserved</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>Nested Task Flag</td>
<td>14</td>
<td></td>
</tr>
<tr>
<td>I/O Privilege Level</td>
<td>13-12</td>
<td></td>
</tr>
<tr>
<td>Overflow</td>
<td>11</td>
<td></td>
</tr>
<tr>
<td>Direction Flag</td>
<td>10</td>
<td></td>
</tr>
</tbody>
</table>

When editing in the dialog box, a carriage-return is the same as choosing the OK button. To end an edit of a field within the dialog box without quitting, use the Tab key.

Edited Value        Shows the register value that corresponds to the selections made below. You can also change the register's value by modifying the value in this text box.

Original Value      Shows the value of the register when the dialog box was opened. If the register could not be read, 'XXXXXXXX' is displayed.
OK  Modifies the register as specified, and closes the dialog box.

Cancel  Closes the dialog box without modifying the register.
Source Window Commands

This section describes the following commands:

- Display→Mixed Mode (ALT, -, D, M)
- Display→Source Only (ALT, -, D, S)
- Display→Select Source... (ALT, -, D, L)
- Search→String... (ALT, -, R, S)
- Search→Function... (ALT, -, R, F)
- Search→Address... (ALT, -, R, A)
- Search→Current PC (ALT, -, R, C)

Display→Mixed Mode (ALT, -, D, M)

Chooses the source/mnemonic mixed display mode.

Command File Command

MOD(E) MNE(MONIC) ON

See Also

"To display source code mixed with assembly instructions" in the "Loading and Displaying Programs" section of the "Debugging Programs" chapter.
Display→Source Only (ALT, -, D, S)

Chooses the source only display mode.

Command File Command

MOD (E) MNE (MONIC) OFF

See Also

"To display source code only" in the "Loading and Displaying Programs" section of the "Debugging Programs" chapter.
Display→Select Source... (ALT, -, D, L)

Displays the contents of the specified C source file in the Source window.

This command is disabled before the object file is loaded or when no source is available for the loaded object file.

**Select Source Dialog Box**

Choosing the Display→Select Source... (ALT, -, D, L) command opens the following dialog box:

![Select Source Dialog Box](image)

- **Source Files** Lists C source files associated with the loaded object file. You can select the source file to be displayed from this list.
- **Select** Switches the Source window contents to the selected source file.
- **Close** Closes the dialog box.
- **Directory** Opens the Search Directories Dialog Box from which you can add directories to the search path.

**Command File Command**

FIL(E) SOU(RCE) module_name
Search→String... (ALT, -, R, S)

Searches for, and displays, a string in the Source window.

The search starts from the current cursor position in the Source window, may be either forward or backward, and may be case sensitive.

The string can be selected from another window (in other words, copied to the clipboard) before choosing the command; it will automatically appear in the dialog box that is opened.

Search String Dialog Box

Choosing the Search→String... (ALT, -, R, S) command opens the following dialog box:

<table>
<thead>
<tr>
<th>Find What</th>
<th>lets you enter the string.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Match Case</td>
<td>selects or deselects case matching.</td>
</tr>
<tr>
<td>Up</td>
<td>Specifies that the search be from the current cursor position backward.</td>
</tr>
<tr>
<td>Down</td>
<td>Specifies that the search be from the current cursor position forward.</td>
</tr>
</tbody>
</table>
Find Next  Searches for the string.

Close  Closes the dialog box.

**Command File Command**

SEA(RCH) STR(ING) FOR/BACK ON/OFF strings

Searches the specified string in the specified direction with the case matching option ON or OFF.

**See Also**

"To search for strings in the source files" in the "Loading and Displaying Programs" section of the "Debugging Programs" chapter.

---

**Search→Function... (ALT, -, R, F)**

Searches for, and displays, a function in the Source window.

The object file and symbols must be loaded before you can choose this command.

**Note**

This command displays the source file based on the function information in the object file. Depending on the structure of the function, the command may fail in displaying the declaration of the function.
Search Function Dialog Box

Choosing the Search→Function... (ALT, -, R, F) command opens the following dialog box:

![Search Function Dialog Box]

- **Function**: Lets you select the function to search for.
- **Find**: Searches the specified function.
- **Close**: Closes the dialog box.

**Command File Command**

```
SEA(RCH) FUNC(TION) func_name
```

**See Also**

"To search for function names in the source files" in the "Loading and Displaying Programs" section of the "Debugging Programs" chapter.
Search→Address... (ALT, -, R, A)

Searches for, and displays, an address in the Source window.

Address expressions such as function names or symbols can be selected from another window (in other words, copied to the clipboard) before choosing the command; the contents of the clipboard will automatically appear in the dialog box that is opened.

Search Address Dialog Box

Choosing the Search→Address... (ALT, -, R, A) command opens the following dialog box:

<table>
<thead>
<tr>
<th>Search Address</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Address:</strong></td>
</tr>
<tr>
<td>Let you enter the address to search for.</td>
</tr>
<tr>
<td><strong>Find</strong></td>
</tr>
<tr>
<td>Searches for the specified address.</td>
</tr>
<tr>
<td><strong>Close</strong></td>
</tr>
<tr>
<td>Closes the dialog box.</td>
</tr>
</tbody>
</table>

Command File Command

CUR(SOR) address
When used before the COME command, this command can be used to run to a particular address.

See Also

"To search for addresses in the source files" in the "Loading and Displaying Programs" section of the "Debugging Programs" chapter.
Search → Current PC (ALT, -, R, C)

Searches for, and displays, the location of the current program counter in the Source window.

**Command File Command**

CUR (SOR) PC

This command can be used to show the current PC in the Source window.
Search Directories Dialog Box

Choosing the Directories... button in the Select Source dialog box opens the following dialog box:

<table>
<thead>
<tr>
<th>Directory</th>
<th>Lets you enter the directory to be added to the source file search path.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Source Directories</td>
<td>Lists the directories in the source file search path.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the directory entered in the Directory text box to the source file search path.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the directory in the Directory text box from the source file search path.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the dialog box.</td>
</tr>
</tbody>
</table>

**See Also**

"To specify source file directories" in the "Loading and Displaying Programs" section of the "Debugging Programs" chapter.
Symbol Window Commands

This section describes the following commands:

- **Display → Modules (ALT, -, D, M)**
- **Display → Functions (ALT, -, D, F)**
- **Display → Externals (ALT, -, D, E)**
- **Display → Locals... (ALT, -, D, L)**
- **Display → Asm Globals (ALT, -, D, G)**
- **Display → Asm Locals... (ALT, -, D, A)**
- **Display → User defined (ALT, -, D, U)**
- **Copy → Window (ALT, -, P, W)**
- **Copy → All (ALT, -, P, A)**
- **FindString → String... (ALT, -, D, M)**
- **User defined → Add... (ALT, -, U, A)**
- **User defined → Delete (ALT, -, U, D)**
- **User defined → Delete All (ALT, -, U, L)**

---

**Display → Modules (ALT, -, D, M)**

Displays the symbolic module information from the loaded object file.

**Command File Command**

```
SYM(BOL) LIS(T) MOD(ULE)
```
See Also

"To display program module information" in the "Displaying Symbol Information" section of the "Debugging Programs" chapter.

---

**Display→Functions (ALT, -, D, F)**

Displays the symbolic function information from the loaded object file.

The Symbol window displays the name, type and address range for C functions.

**Command File Command**

SYM(BOL)  LIS(T)  FUN(CTION)

See Also

"To display function information" in the "Displaying Symbol Information" section of the "Debugging Programs" chapter.

---

**Display→Externals (ALT, -, D, E)**

Displays the global variable information from the loaded object file.

The Symbol window displays the name, type and address for global variables.

**Command File Command**

SYM(BOL)  LIS(T)  EXT(ERNAL)

See Also

"To display external symbol information" in the "Displaying Symbol Information" section of the "Debugging Programs" chapter.
Display→Locals... (ALT, -, D, L)

Displays the local variable information on the specified function.

The function name can be selected from another window (in other words, copied to the clipboard) before choosing the command; the clipboard contents automatically appear in the dialog box that is opened.

The Symbol window displays the name, type and offset from the frame pointer for the local variables for the specified function.

Local Symbol Dialog Box

Choosing the Display→Locals... (ALT, -, D, L) command opens the following dialog box:

```
Local Symbol

Function: convert_case

OK  Cancel

Help
```

Function selects the function for which the local variable information is displayed.

OK Executes the command and closes the dialog box.

Cancel Cancels the command and closes the dialog box.

Command File Command

SYM(BOL) LIS(T) INT(ERNAL) function

See Also

"To display local symbol information" in the "Displaying Symbol Information" section of the "Debugging Programs" chapter.
Display→Asm Globals (ALT, -, D, G)

Displays the global Assembler symbol information from the loaded object file.
The Symbol window displays the name and address for the global assembler symbols.

Command File Command
SYM(BOL) LIS(T) GLO(BALS)

See Also
"To display global assembler symbol information" in the "Displaying Symbol Information" section of the "Debugging Programs" chapter.

Display→Asm Locals... (ALT, -, D, A)

Displays the local symbol information from the specified module.
The module name can be selected from another window (in other words, copied to the clipboard) before choosing the command; the clipboard contents automatically appear in the dialog box that is opened.
The Symbol window displays the name and address for the local symbols for the specified module.
Assembler Symbol Dialog Box

Choosing the Display→Asm Locals... (ALT, -, D, A) command opens the following dialog box:

Module Selects the module for which the local symbols are displayed.
OK Executes the command and closes the dialog box.
Cancel Cancels the command and closes the dialog box.

Command File Command
SYM(BOL) LIS(T) LOC(AL) module

See Also
"To display local assembler symbol information" in the "Displaying Symbol Information" section of the "Debugging Programs" chapter.
Display→User defined (ALT, -, D, U)

Displays the user-defined symbol information.

The Symbol window displays the name and address for the user-defined symbols.

The User defined→Add... (ALT, -, D, U) command adds the user-defined symbols.

**Command File Command**

SYM(BOL) LIS(T) USE(R)

**See Also**

"To display user-defined symbol information" in the "Displaying Symbol Information" section of the "Debugging Programs" chapter.

---

Copy→Window (ALT, -, P, W)

Copies the information currently displayed in the Symbol window to the specified listing file.

The listing file is specified with the File→Copy Destination... (ALT, F, P) command.

**Command File Command**

SYM(BOL) COP(Y) DIS(PLAY)

**See Also**

"To copy window contents to the list file" in the "Working with Debugger Windows" section of the "Using the Debugger Interface" chapter.
Copy→All (ALT, -, P, A)

Copies all the symbol information to the specified listing file.

The listing file is specified with the File→Copy Destination... (ALT, F, P) command.

**Command File Command**

SYM (BOL) COP (Y) ALL

FindString→String... (ALT, -, F, S)

Displays the symbols that contain the specified string.

This command performs a case-sensitive search.

**Symbol Matches Dialog Box**

Choosing the FindString→String... (ALT, -, F, S) command opens the following dialog box:

```
String: [edit]
  String: [edit]

OK       Executes the command and closes the dialog box.
Cancel   Cancels the command and closes the dialog box.
```

String  Specifies the string.
Command File Command

SYM(BOL) MATCH string

See Also

"To display the symbols containing the specified string" in the "Displaying Symbol Information" section of the "Debugging Programs" chapter.

User defined→Add... (ALT, -, U, A)

Adds the specified user-defined symbol.

User-defined symbols may be used in debugger commands just like other program symbols.

The symbol name must satisfy the following requirements:

- The name must begin with an alphabetical, _ (underscore), or ? character.
- The following characters must be any of alphanumerical, _ (underscore), or ? characters.
- The maximum number of characters is 256.
User defined Symbol Dialog Box

Choosing the User defined→Add... (ALT, -, U, A) command opens the following dialog box:

![User Defined Symbol Add]

Symbol Name: Specifies the symbol to be added.
Address: Specifies the address of the symbol.
OK: Executes the command and closes the dialog box.
Cancel: Cancels the command and closes the dialog box.

Command File Command

SYMBOL ADD symbol_name address

See Also

"To create a user-defined symbol" in the "Displaying Symbol Information" section of the "Debugging Programs" chapter.
User defined→Delete (ALT, -, U, D)

Deletes the specified user-defined symbol.

This command deletes the user-defined symbol selected in the Symbol window.

**Command File Command**

```
SYM(BOL) DEL(ETE) symbol_nam
```

**See Also**

"To delete a user-defined symbol" in the "Displaying Symbol Information" section of the "Debugging Programs" chapter.

---

User defined→Delete All (ALT, -, U, L)

Deletes all the user-defined symbols.

**Command File Command**

```
SYM(BOL) DEL(ETE) ALL
```
Trace Window Commands

This section describes the following commands:

- **Display→Mixed Mode (ALT, -, D, M)**
- **Display→Source Only (ALT, -, D, S)**
- **Display→Bus Cycle Only (ALT, -, D, C)**
- **Display→Count→Absolute (ALT, -, D, C, A)**
- **Display→Count→Relative (ALT, -, D, C, R)**
- **Display→From State... (ALT, -, D, F)**
- **Display→Options→Suppress Prefetch (ALT, - D, O, S)**
- **Display→Options→Swap Instruction Bytes (ALT, - D, O, I)**
- **Copy→Window (ALT, -, P, W)**
- **Copy→All (ALT, -, P, A)**
- **Search→Trigger (ALT, -, R, T)**
- **Search→State... (ALT, -, R, S)**
- **Trace Spec Copy→Specification (ALT, -, T, S)**
- **Trace Spec Copy→Destination... (ALT, -, T, D)**

---

**Display→Mixed Mode (ALT, -, D, M)**

Chooses the source/mnemonic mixed display mode.

**Command File Command**

TRA(CE) DIS(PLAY) MIX(ED)
See Also

"To display source code mixed with assembly instructions" in the "Loading and Displaying Programs" section of the "Debugging Programs" chapter.

---

Display→Source Only (ALT, -, D, S)

Selects the source only display mode.

Command File Command

\texttt{TRA(CE) DIS(PLAY) SOU(RCE)}

See Also

"To display bus cycles" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.

---

Display→Bus Cycle Only (ALT, -, D, C)

Selects the bus cycle only display mode.

Command File Command

\texttt{TRA(CE) DIS(PLAY) BUS}

See Also

"To display bus cycles" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.
Display→Count→Absolute (ALT, -, D, C, A)

Selects the absolute mode (the total time elapsed since the trigger) for count information.

**Command File Command**

```
TRA(CE) DIS(PLAY) ABS(OLUTE)
```

**See Also**

"To display absolute or relative counts" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.

---

Display→Count→Relative (ALT, -, D, C, R)

Selects the relative mode (the time interval between the current and previous cycle) for count information.

**Command File Command**

```
TRA(CE) DIS(PLAY) REL(ATIVE)
```

**See Also**

"To display absolute or relative counts" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.
Trace Display→From State... (ALT -, D, F)

Lets you specify a state and/or a byte within a state where you wish to begin disassembly, as well as a segment type (16-bit or 32-bit).

Normally the disassembler begins disassembly with the first byte of the first captured opcode fetch. Sometimes this does not result in correct disassembly because the first byte is a continuation of a previous opcode. When a branch-trace message is found, the disassembler will resynchronize. However, this dialog box allows you to manually set the correct starting byte.

**Trace Disassemble From... Dialog Box**

Choosing the Display→From State... (ALT, -, D, F) command opens the following dialog box:

```
Trace Disassemble From...

State: 17
Byte: 0 1 2 3
Segment Type: USE16
```

- **State**: Lets you enter a state number (as shown in the left-most column in the trace display) where you wish to begin disassembly.
- **Byte**: Lets you specify the byte within the selected state where you wish to begin disassembly.
- **Segment Type**: Lets you specify what type of segment (16-bit or 32-bit) the code is in. You may specify this without specifying a disassembly state.

Note that the state you specify should be a control read (instead of a data read).
Command File Command
MOD(E) TRA(CE) DIS(PLAY) FROM <state>
MOD(E) TRA(CE) DIS(PLAY) BYTE0/BYTE1/BYTE2/BYTE3
MOD(E) TRA(CE) DIS(PLAY) USE16/USE32

Display→Options→Suppress Prefetch (ALT, -, D, O, S)

Allows you to turn off display of unexecuted prefetches in the Trace window. When selected (check mark beside Suppress Prefetch), unexecuted prefetches will not be displayed in the Trace window. When unselected, all traced activity, including unexecuted prefetches, will be displayed in the Trace window.

Command File Command
MOD(E) TRA(CE) DIS(PLAY) SUPPRESSPREFETCH ON|OFF

See Also
"To display or suppress unexecuted prefetches" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.
Display→Options→Swap Instruction Bytes (ALT, -, D, O, I)

Controls order of bytes displayed for data-bus values. When selected (check mark beside "Swap Instruction Bytes"), data-bus values are displayed in little endian byte order in the Trace window (D[0:7], D[15:8], D[23:16], D[31:24]). When unselected (the default), data-bus values are displayed in big endian byte order in the Trace window (D[31:0]).

This option only affects the order of bytes displayed in data-bus values corresponding to instruction fetches (opcodes).

**Command File Command**

MOD(E) TRA(CE) DIS(PLAY) SWA(PINSTRBYTES) ON|OFF

**See Also**

"To swap instruction bytes in display of data-bus values" in the "Tracing Program Execution" section of the "Debugging Programs" chapter.

---

Copy→Window (ALT, -, P, W)

Copies the information currently in the Trace window to the specified listing file.

The listing file is specified with the File→Copy Destination... (ALT, F, P) command.

**Command File Command**

TRA(CE) COP(Y) DIS(PLAY)

**See Also**

"To copy window contents to the list file" in the "Working with Debugger Windows" section of the "Using the Debugger Interface" chapter.
Copy→All (ALT, -, P, A)

Copies all the trace information to the specified listing file.

The listing file is specified with the File→Copy Destination... (ALT, F, P) command.

**Command File Command**

TRA(CE) COP(Y) ALL

Search→Trigger (ALT, -, R, T)

Positions the trigger state at the top of the Trace window.

**Command File Command**

TRA(CE) FIN(D) TRI(GGER)
Search→State... (ALT, -, R, S)

Positions the specified state at the top of the Trace window.

**Search Trace State Dialog Box**

Choosing the Search→State... (ALT, -, R, S) command opens the following dialog box:

<table>
<thead>
<tr>
<th></th>
<th>Search Trace State</th>
</tr>
</thead>
<tbody>
<tr>
<td>State:</td>
<td>Lets you enter the trace state number to search for.</td>
</tr>
<tr>
<td>Find</td>
<td>Searches for the specified trace state.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the dialog box.</td>
</tr>
</tbody>
</table>

**Command File Command**

TRA(CE) FIN(D) STA(TE) state_num
Trace Spec Copy→Specification (ALT, -, T, S)

Copies the current trace specification to the listing file.

**Command File Command**

```
TRA(CE) COP(Y) SPE(C)
```

---

Trace Spec Copy→Destination... (ALT, -, T, D)

Names the listing file to which debugger information may be copied.

This command opens a file selection dialog box from which you can select the listing file. Listing files have the extension ".LST".

**Command File Command**

```
COP(Y) TO filename
```
WatchPoint Window Commands

This section describes the following command:

- Edit...

Edit... (ALT, -, E)

Registers or deletes watchpoints.

Variables can be selected from another window (in other words, copied to the clipboard) before choosing the Edit... (ALT, -, E) command from the WatchPoint window's control menu, and they will automatically appear in the dialog box that is opened.

Dynamic variables can be registered and displayed in the WatchPoint window when the current program counter is in the function in which the variable is declared. If the current program counter is not in the function, the variable name is invalid and results in an error.
WatchPoint Dialog Box

Choosing the Edit... (ALT, -, E) command from the WatchPoint window's control menu opens the following dialog box:

Variable

- Lets you enter the name of the variable to be registered as a watchpoint. The contents of the clipboard, usually a variable selected from another window, automatically appears in this text box.

Watch Points Set

- Lists the current watchpoints and allows you to select the watchpoint to be deleted.
- Copies the specified variable to the WatchPoint window.
- Deletes the variable selected in the Watch Points Set box.
- Deletes all the watchpoints.
- Closes the dialog box.
Command File Command

WP SET address
Registers the specified address as a watchpoint.

WP DEL(ETE) address
Deletes the specified watchpoint.

WP DEL(ETE) ALL
Deletes all the current watchpoints.

See Also

"To monitor a variable in the WatchPoint window" in the "Displaying and Editing Variables" section of the "Debugging Programs" chapter.

"Symbols" in the "Expressions in Commands" chapter.
Window Pop-Up Commands
Window Pop-Up Commands

This chapter describes the commands that can be chosen from the pop-up menus in debugger windows. Pop-up menus are accessed by clicking the right mouse button in the window.

- BackTrace Window Pop-Up Commands
- Source Window Pop-Up Commands
BackTrace Window Pop-Up Commands

- Source at Stack Level

Source at Stack Level

For the cursor-selected function in the BackTrace window, this command displays the function call in the Source window.
Source Window Pop-Up Commands

- Set Breakpoint
- Clear Breakpoint
- Evaluate It
- Add to Watch
- Run to Cursor

Set Breakpoint

Sets a breakpoint on the line containing the cursor. Refer to the Breakpoint→Set at Cursor (ALT, B, S) command.

Clear Breakpoint

Deletes the breakpoint on the line containing the cursor. Refer to the Breakpoint→Delete at Cursor (ALT, B, D) command.

Evaluate It

Evaluates the clipboard contents and places the result in the Expression window. Refer to the Evaluate... (ALT, -, E) command available from the Expression window’s control menu.
Add to Watch

Adds the selected variable (that is, the variable copied to the clipboard) to the WatchPoint window. Refer to the Variable→Edit... (ALT, V, E) command.

Run to Cursor

Executes the program up to the Source window line containing the cursor. Refer to the Execution→Run to Cursor (ALT, R C) command.
Other Command File and Macro Commands
This chapter describes the commands that are only available in command files, break macros, or buttons.

- BEEP
- EXIT
- FILE CHAINCMD
- FILE RERUN
- NOP
- TERMCOM
- WAIT
BEEP

Sounds beep during command file or break macro execution.

Command File Command
BEEP
EXIT

Exits, or conditionally exits, command file execution.

**Command File Command**

EXIT
Exits command file execution.

EXIT VAR(IABLE) address value
Exits command file execution if the variable contains the value.

EXIT REG(ISTER) regname value
Exits command file execution if the register contains the value.

EXIT MEM(ORY) BYTE/WORD/LONG address value
Exits command file execution if the memory location contains the value.

EXIT IO BYTE/WORD address value
Exits command file execution if the I/O location contains the value.
FILE CHAINCMD

Chains command file execution.

This command lets you run one command file from another nonrecursively; in other words, control is not returned to the original command file.

By contrast, the FILE COMMAND command is recursive; if you use the FILE COMMAND command to run one command file from another, control will be returned to the original command file. FILE COMMAND commands can be nested four levels deep.

Command File Command

FILE CHAINCMD filename
FILE RERUN

Starts command file execution over again.

This command is useful for looping stimulus files or running a demo or other command file continuously.

Command File Command

FILE RERUN
NOP

No operation.
This command may be used to prefix comment lines in command files.

Command File Command
NOP
NOP comments
TERMCOM

Sends Terminal Interface commands to the HP 64700.

The HP 64700 Card Cage contains a low-level Terminal Interface, which allows you to control the emulator's functions directly. You can use the TERMCOM command to bypass the RTC Interface and send commands directly to the low-level Terminal Interface.

There is no window in the RTC Interface where you can execute TERMCOM commands directly. The only way to execute them with the RTC Interface is to make them part of a command file and then run the command file from an RTC Interface window.

You may need to start a unique target system that requires emulator intervention that is only available through the Terminal Interface. You can create the command file and then execute it at the appropriate time using a command such as File→Run Cmd File..., and place the name of your command file in the Run Command File dialog box.

The danger in using Terminal Interface commands via the TERMCOM command is that the RTC Interface may not be updated to know the state of the emulator. Some Terminal Interface commands can be executed by using the TERMCOM command, and the RTC Interface will not know that they were executed. Other Terminal Interface commands can be executed and the RTC Interface will be updated immediately. For example:

- If you have a command in your command file that changes the setting of RealTime→Monitor Intrusion→Disallow/Allowed, (such as, TERMCOM "cf rrt=en"), the RTC Interface will not know about this change and will continue to try to operate according to the earlier setting. In this case, the RTC Interface may try to update its displays when the emulator is set to deny monitor access to the registers and memory.

- If you have a command in your command file that writes a value to memory (such as, TERMCOM "00000..00fff=0"), the Memory window will be updated immediately to show the new value, assuming you have chosen RealTime→Monitor Intrusion→Allowed.
Do not use the following Terminal Interface commands with the RTC TERMCOM command:

- **stty, po, xp**: These commands will change the operation of the communications channel, and are likely to hang the RTC Interface.

- **echo, mac**: These commands may confuse the communications protocols in use in the channel.

- **wait**: The pod will enter a wait state, blocking access by the RTC Interface.

- **init, pv**: These will reset the emulator and end your session.

- **t**: This will confuse the functions of trace status polling and unload.

Refer to your "Terminal Interface User's Guide" for more information about Terminal Interface commands.

**Command File Command**

TERMCOM "ti-command"
Chapter 11: Other Command File and Macro Commands

**WAIT**

Inserts wait delays during command file execution.

**Command File Command**

- `WAI (T) MON (ITOR)`
  Waits until MONITOR status.

- `WAI (T) RUN`
  Waits until RUN status.

- `WAI (T) UNK (NOWN)`
  Waits until UNKNOWN status.

- `WAI (T) SLO (W)`
  Waits until SLOW CLOCK status.

- `WAI (T) TGT (RESET)`
  Waits until TARGET RESET status.

- `WAI (T) SLE (EP)`
  Waits until SLEEP status.

- `WAI (T) GRA (NT)`
  Waits until BUS GRANT status.

- `WAI (T) NOB (US)`
  Waits until NOBUS status.

- `WAI (T) TCO (M)`
  Waits until the trace is complete.

- `WAI (T) THA (LT)`
  Wait until the trace is halted.

- `WAI (T) TIM (E) seconds`
  Waits for a number of seconds.
Error Messages

This chapter helps you find details about the following error messages:

- Bad RS-232 port name
- Bad RS-422 card I/O address
- Could not open initialization file
- Could not write Memory
- Error occurred while processing Object file
- General RS-232 communications error
- General RS-422 communications error
- HP 64700 locked by another user
- HP 64700 not responding
- Incorrect DLL version
- Incorrect LAN Address (HP-ARPA, Windows for Workgroups)
- Incorrect LAN Address (Novell)
- Incorrect LAN Address (WINSOCK)
- Internal error in communications driver
- Internal error in Windows
- Interrupt execution (during run to caller)
- Interrupt execution (during step)
- Interrupt execution (during step over)
- Invalid transport name
- LAN buffer pool exhausted
- LAN communications error
- LAN MAXSENDSIZE is too small
- LAN Socket error
- Logical to physical address translations initially unavailable: Cannot read descriptor tables into host memory since GDT base and limit are unavailable
- Object file format ERROR
- Out of DOS Memory for LAN buffer
- Out of Windows timer resources
- PC is out of RAM memory
- physical address translation failed
- Structure Access Warning!!!
- Timed out during communications
Bad RS-232 port name

RS-232 port names must be of the form "COM<number>" where <number> is a decimal number from 1 to the number of communications ports within your PC.

Bad RS-422 card I/O address

The RS-422 card's I/O address must be a hexadecimal number from 100H through 3F8H whose last digit is 0 or 8 (example 100, 108, 110). Select an I/O address that does not conflict with the other cards in your PC.

Could not open initialization file

The initialization file was not found in the same directory where the executable file was found.

For example, if the application file is B3637B.EXE, the initialization file B3637B.INI is expected to be found in the same directory.

To fix this problem, you may be able to find the initialization file and move it to the same directory as the executable file, or you can create a new initialization file from the default initialization file. For example:

COPY B3637DEF.INI Bxxxx.INI

Note that the above command is the DOS COPY command. Do not use the ksh 'cp B3637DEF.INI Bxxxx.INI' command. Use only the DOS 'COPY B3637DEF.INI B3637B.INI' command.

If you cannot find the default initialization file either, you can re-install the debugger software.

For correct operation, make certain the B3637B.INI file has both read and write permission.
Could not write Memory

You may see this error message when trying to load a file or perform any other task that requires use of the monitor. The emulation monitor is used to load files, which requires writing to memory. If you have chosen RealTime→Monitor Intrusion→Disallowed the monitor will not be usable, and Execution→Reset may prevent use of the monitor in some emulators.

Choose RealTime→Monitor Intrusion→Allowed, and Execution→Break to ensure that the emulation monitor is running. The Status window should show Emulator: RUNNING IN MONITOR.

With this setup, the emulator should be able to write to Memory.

If you are still unable to load a file, select "Symbols Only" in the Load Object File dialog box and try to load the file. If Symbols Only will not load, the problem is in your symbols.

Choose "Data Only" in the Load Object File dialog box and try to load the file. If the symbols loaded, but the data fails to load, the problem is in your program code.

Call your local HP representative.
Error occurred while processing Object file

The following is a list of typical reasons why an error might occur while processing an object file. There are many other possible reasons.

- Bad record in the object file.
- File is in wrong format.
- File does not follow OMF Specifications correctly.
- No memory mapped.
- Attempt to write to guarded memory.
- Emulator restricted to real-time runs. Enter the command, "RealTime→Monitor Intrusion→Allowed".
- Emulator not executing the monitor. Enter the command, "Execution→Break".

Another message often occurs along with this message. View the help information for the other message, if available.

Call your local HP representative.
General RS-232 communications error

In general, these messages indicate that the RS-232 communication has intermittent errors. Sometimes you will get this message if you power on the emulator, or when you try to connect to the emulator. In that case, simply retry the connection (by double-clicking on the RS232C driver line in the selection box); if you connect with no problems the second time, you can ignore the original message.

If you get this message other than during connection, you can try to fix the problem by:

- Reducing the length of the RS-232 cable between the PC and the HP 64700.
- Reducing the number of tasks running under Windows.
- Reducing the baud rate (the default is 19200).

For further information, refer to the paragraph titled, "If you have RS-232 connection problems" in the Communications Help screen, or in Chapter 15, "Installing the Debugger" in the Real-Time C Debugger User’s Guide.

General RS-422 communications error

In general, these messages indicate that the RS-422 communication has intermittent errors. Sometimes you will get this message if you power on the emulator, or when you try to connect to the emulator. In that case, simply retry the connection (by double-clicking on the HP-RS422 driver line in the selection box); if you connect with no problems the second time, you can ignore the original message.

If you get this message other than during connection, you can try to fix the problem by:

- Reducing the number of tasks running under Windows.
- Reducing the baud rate (the default is 230400).
HP 64700 locked by another user

Because it is possible to destroy another user's measurement by choosing the Unlock button in the error dialog box, check with the other user before unlocking the HP 64700.

Note that if the other user is actually using an interface to the HP 64700, an Unlock request will fail.

HP 64700 not responding

The HP 64700 has not responded within the timeout period. There are several possible causes of this error. For example, a character could have dropped during RS-232 communications, or some network problem could have disrupted communications.

Usually, you must cycle power to the HP 64700 to fix this problem.

See also: The description for the error message titled, "Timed out during communications."

Incorrect DLL version

The version of the dynamic link libraries (.DLLs) used by the Real-Time C Debugger does not match the version of the main program (.EXE).

If you have two versions of the debugger on your system, you may see this message when you try to execute both of them at the same time, or when you execute one version and then the other without restarting Windows. Once DLLs have been loaded into Windows memory, they stay there until you exit Windows. Therefore, exit windows, restart windows, and try again.

This message will also appear if you have somehow loaded a version of the DLLs that is different from the version of the executable. In this case, you must reload your software.
Incorrect LAN Address (HP-ARPA, Windows for Workgroups)

A LAN address can be one of two types: an IP address, or a host name.

An IP address consists of four digits separated by dots. Example:
15.6.28.0

A hostname is a name that is related (mapped) to an IP address by a database. For example, the file \LANMAN.DOS\ETC\HOSTS (HP-ARPA) or \WINDOWS\HOSTS (Windows for Workgroups) may contain entries of the form:

```
system1 15.6.28.0
```

**Note**
The directory of the "hosts" file may be different on your system.

If "HP Probe" or "DNR" (Domain Name Resolution) is available on your PC, those are consulted first for a mapping between the hostname and the IP address. If the hostname is not found by that method, or if those services are unavailable, the local "hosts" file is consulted for the mapping.

Note that if "Probe" is available on your system but unable to resolve the address, there will be a delay of about 15-seconds while Probe is attempting to find the name on the network.
Incorrect LAN Address (Novell)

A LAN address can be one of two types: an IP address, or a host name.

An IP address consists of four digits separated by dots. Example:

15.6.28.0

A hostname is a name that is related (mapped) to an IP address by a database. For example, the file \NET\TCP\HOSTS may contain entries of the form:

system1 15.6.28.0

Note

The directory of the "hosts" file may be different on your system. Also, all files defined by the PATH TCP_CFG setting under "Protocol TCPIP" in the NETCFG files are searched.

Incorrect LAN Address (WINSOCK)

A LAN address can be one of two types: an IP address, or a host name.

An IP address consists of four digits separated by dots. Example:

15.6.28.0

A hostname is a name that is related (mapped) to an IP address by a database. For example, the hosts file may contain entries of the form:

system1 15.6.28.0

Note

Because WINSOCK is a standard interface to many LAN software vendors, you need to read your LAN vendor's documentation before specifying the LAN address.
Internal error in communications driver

These types of errors typically occur because other applications have used up a limited amount of some kind of global resource (such as memory or sockets).

You usually have to reboot the PC to free the global resources used by the communications driver.

Internal error in Windows

These types of errors typically occur because other applications have used up a limited supply of some kind of global resource (such as memory, sockets, tasks, or handles).

You usually have to reboot the PC to free the global resources used by Windows.

Interrupt execution (during run to caller)

The Return dialog box appears when running to the caller of a function and the caller is not found within the number of milliseconds specified by StepTimerLen in the .INI file of the debugger application.

You can cancel the run to caller command by choosing the STOP button, which causes program execution to stop, the breakpoint to be deleted, and the processor to transfer to the RUNNING IN USER PROGRAM status.
Interrupt execution (during step)

The Step dialog box appears when stepping a source line or assembly instruction and the source line or instruction does not execute within the number of milliseconds specified by StepTimerLen in the .INI file of the debugger application.

You can cancel the step command by choosing the STOP button, which causes program execution to stop, the breakpoint to be deleted, and the processor to transfer to the RUNNING IN USER PROGRAM status.

Interrupt execution (during step over)

The Step dialog box appears when stepping over a function or subroutine and the function or subroutine does not execute within the number of milliseconds specified by StepTimerLen in the .INI file of the debugger application.

You can cancel the step-over command by choosing the STOP button, which causes program execution to stop, the breakpoint to be deleted, and the processor to transfer to the RUNNING IN USER PROGRAM status.
Invalid transport name

The transport name chosen does not match any of the possible transport names (RS232C, HP-ARPA, Novell-WP, WINSOCK1.1, W4WG-TCP, or HP-RS422).

The transport name can be specified either on the command line with the -t option or in the .INI file:

[Port]
Transport=<transport name>

Choosing an appropriate transport in the dialog box that follows this error message will correct the entry in the .INI file, but if the error is in the command line option, you must modify the command line (by using the "Properties..." command in the Program Manager).

LAN buffer pool exhausted

The LAN buffer pool is used as a temporary buffer between the time the debugger sends data and the time the LAN actually sends it. When this pool is exhausted, the debugger cannot send any data across the LAN.

The size of the sockets buffer pool is configured in the network installation procedure. The size and number of LAN buffer pools can be changed by editing your network configuration file.
LAN communications error

This message may appear after any kind of LAN error.

Refer to the documentation for your LAN software for descriptions of the types of problems that can cause LAN errors.

LAN MAXSENDSIZE is too small

This message indicates you have configured your LAN with a value or MAXSENDSIZE that is less than 100 bytes. Note that the default is 1024 bytes.

The Real-Time C Debugger requires at least 100 bytes for this parameter.

To fix this, change the following entry in your PROTOCOL.INI file and reboot your PC:

[SOCKETS]
MAXSENDSIZE

LAN socket error

A TCP-level error has occurred on the network. See your network administrator.
Logical to physical address translations initially unavailable: Cannot read descriptor tables into host memory since GDT base and limit are unavailable

A static method of performing address translation has been chosen along with the option of getting the base and limit values from the loaded absolute file and no absolute file is currently loaded or the currently loaded absolute file has no GDT base and limit specified.

Either load an absolute file or choose Settings→Emulator Config→Address Translation...(ALT, S, E, A) and select a different method of obtaining a GDT base and limit in the Address Translation dialog box.

**See Also**

"Performance of address translation caching" in the "Configuring the Emulator" chapter.

Object file format ERROR

This message is typically caused by one of two conditions:

- **Bad format file.** Perhaps there is a bad record within the file. If you have a file format verifier, submit your file to it to determine whether or not all records are in the correct format.

- **Unknown construct.** Perhaps the construct of your file is unfamiliar to the reader.

To respond to this error message, verify the file format, and ensure that the reader can understand the file format in use.

If these steps do not solve the problem, call your local HP representative.
Out of DOS Memory for LAN buffer

This means that there is not enough memory in the lower 1 Mbyte of address space (that is, conventional memory) for the LAN driver to allocate a buffer to communicate with the LAN TSR.

When you are in windows, and execute the DOS command "mem", you cannot see the memory that is in the lower 1 Mbyte that is used by the windows program. If you have the Microsoft program "heapwalker", you can use it to see what programs have allocated space in the address range 0 through FFFFF.

To fix this, you can:

- Reduce the number of TSRs running on your PC (before Windows starts) that use conventional memory.

- Reconfigure your network to have fewer sockets or modules loaded, or to be configured for fewer total connections.

- Use a different memory manager to reduce your network memory usage, such as QEMM.
Out of Windows timer resources

The debugger is not able to acquire the timer resources it needs.

There are a limited number of timer resources in Windows. You may be able to free timer resources by closing other applications.

PC is out of RAM memory

The debugger is not able to acquire the memory it needs because other applications are using it, or because of fragmented memory.

You may be able to free memory by closing other applications, or you might have to reboot the PC to cause memory to be unfragmented.
physical address translation failed

This message occurs when you enter a symbol or address that is a virtual address (gdt::offset, gdt:ldt:offset, or ldt::offset) and the emulator is not able to translate it to a linear or physical address. Any of the following conditions may cause this error:

- Dynamic address translations are being used, but the emulator is not able to break into the monitor to read the tables. This will occur if you run the emulator restricted to real time, or if the processor is reset. Try using static translations.
- Dynamic address translations are being used, but the processor is in real mode and the request was made for a protected-mode translation. Try using static translations.
- The GDT number is larger than the gdtr.limit (for dynamic translations), or larger than the table in the static translation table. Check your symbol, or try reloading the static translations.
- gdt:ldt:offset was entered, but the entry number "gdt" in the GDT table was not a pointer to an LDT.
- gdt:ldt:offset was entered, but the "ldt" was larger than the limit of the referenced local descriptor table.
- ldt::offset was entered, but LDTR is not valid (0).
- ldt::offset was entered, but LDTR does not point to the correct local descriptor table.

See also:

"Understanding Incompletely Specified LDT Addresses" in the "Concepts" chapter.
Structure Access Warning!!!

No field offset information found in OMF file
so field offsets computed by adding previous sizes
Structures with 'padding' may display incorrect data!

This message occurs when loading OMF386 files containing structure types. The emulator cannot detect offset information in an OMF386 file. If you will be accessing fields in structures and there is padding between those fields, the debugger will read memory as if there is no padding, producing invalid results.

This warning alerts you to possibilities of invalid displays of fields within structures when you have compiled your file with padding enabled, or if your structure has contents with odd byte sizes. (You will have no problems if all of your structure contents don’t require padding.)
Timed out during communications

The HP 64700 has not responded within the timeout period. There are various causes for this error. For example, a character could have been dropped during RS-232 communications or some network problem could have disrupted communications.

The timeout period for reading and writing to the HP 64700 is defined by TimeoutSeconds in either the [RS232C], [HP-ARPA], [Novell-WP], or [HP-RS422] section of the B3637B.INI file. For example, if you are using the RS-232C transport:

[RS232C]
TimeoutSeconds=<seconds>

The number of seconds can be between 1 and 32767. The default is 20 seconds.

If you are using RS-232C or RS-422 transport ... The TimeoutSeconds value is also used for connecting to the HP 64700 (as well as for reading and writing).

If you are using HP-ARPA or Novell-WP transport ... If there are several gateways or bridges between the PC and the emulator, larger values of TimeoutSeconds may be reasonable.

The timeout period for connecting to the HP 64700 is defined in the PROTOCOL.INI file.

[TCP/IP_XFR]
TCPCONNTIMEOUT=<seconds>

The default connection timeout is 30 seconds.

The remainder of this discussion shows you how to overcome the problem of "connection timed out" during large memory fill operations.

The RTC interface sends the memory fill operation to the emulator as a single command. While the command is executing in the emulator, the emulator cannot respond to inquiries from the interface about its status. If the memory fill takes long enough, the connection will time out.
Emulators for some microprocessors take up to one minute per megabyte to perform a memory fill operation. Timeout default values for RTC interfaces shipped from HP are typically 45 seconds.

First Workaround. Modify the TimeoutSeconds field (discussed above) to increase the TimeoutSeconds value. Then exit the interface and restart it (to ensure that the new value of TimeoutSeconds is read). You may experiment with several values of TimeoutSeconds to find the value that allows you to do a memory fill. The problem with this workaround is that all timeouts will take this new longer time, and you may find this annoying when you are not doing memory fill operations.

Second Workaround. Create a command file that contains TERMCOM commands to write to small portions of the overall memory to be filled. For example, suppose the following Memory window command causes the emulator to time out, "Memory→Utilities→Fill→0 to ffff".

You might make a command file named memfill.cmd, and place the following commands in it:

```
TERMCOM "m 00000..00fff=0"
TERMCOM "m 01000..01fff=0"
TERMCOM "m 02000..02fff=0"
TERMCOM "m 03000..03fff=0"
TERMCOM "m 04000..04fff=0"
TERMCOM "m 05000..05fff=0"
TERMCOM "m 06000..06fff=0"
TERMCOM "m 07000..07fff=0"
TERMCOM "m 08000..08fff=0"
TERMCOM "m 09000..09fff=0"
TERMCOM "m 0a000..0afff=0"
TERMCOM "m 0b000..0bfff=0"
TERMCOM "m 0c000..0cfff=0"
TERMCOM "m 0d000..0dfff=0"
TERMCOM "m 0e000..0efff=0"
TERMCOM "m 0f000..0ffff=0"
```

When you choose File→Run Cmd File→... and select your memfill.cmd file, it will not exceed the timeout value. This is because the emulator will be able to respond to inquiries from the interface between execution of each of the TERMCOM commands in your command file.
Part 4

Concept Guide

Topics that explain concepts and apply them to advanced tasks.
Concepts
Concepts

This chapter describes the following topics.

- Debugger Windows
- Monitor Program Options
- Trace Signals and Predefined Status Values
- Understanding Intel80386EX Analysis
- Understanding Address, Data, and Status
- Entering Addresses as Constants
- Understanding Incompletely Specified LDT Addresses
- Unexpected Stepping Behavior
Debugger Windows

This section describes the following debugger windows:

- BackTrace
- Button
- Expression
- I/O
- Memory
- GDT
- LDT
- IDT
- Register
- Source
- Status
- Symbol
- Trace
- WatchPoint
The BackTrace Window

The BackTrace window displays the function associated with the current program counter value and this function's caller functions in backward order. Applicable addresses are prefixed with module#linenum information. The current arguments of these functions are also displayed.

The BackTrace window is updated when program execution stops at an occurrence of a breakpoint, break, or Step command.

Note that the return address can occur any number of bytes from the base pointer of the stack. The OMF386 symbol file contains information used to locate return addresses. If symbols are not available (typically for assembly-language routines), the backtrace is shown as far as it can decode the addresses, and then display of the backtrace stops.

The BackTrace window lets you copy text strings to the clipboard by double-clicking words or by holding down the left mouse button and dragging the mouse pointer.

By clicking the right mouse button in the BackTrace window, you can access the Source at Stack Level pop-up menu command. Cursor-select a function in the BackTrace window and choose this command to display (in the Source window) the code that called the function. The top line of the source display shows the source code that called the function.

See Also

"BackTrace Window Pop-Up Commands" in the "Window Pop-Up Commands" chapter.
The Button Window

The Button window contains user-defined buttons that, when chosen, execute debugger commands or command files.

The Button window’s control menu provides the Edit... (ALT, -, E) command which lets you add and delete buttons from the window.

See Also

"Using Command Files" in the "Using the Debugger Interface" chapter.

"Button Window Commands" in the "Window Control Menu Commands" chapter.
The Expression Window

The Expression window displays the results of the EVALUATE commands in command files or break macros.

<table>
<thead>
<tr>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>*mes: 101 65</td>
</tr>
<tr>
<td>*mes: 32 20</td>
</tr>
<tr>
<td>*mes: 112 70</td>
</tr>
<tr>
<td>*mes: 111 66</td>
</tr>
<tr>
<td>*mes: 114 72</td>
</tr>
<tr>
<td>*mes: 97 61</td>
</tr>
<tr>
<td>*mes: 109 66</td>
</tr>
<tr>
<td>*mes: 85 55</td>
</tr>
<tr>
<td>*mes: 112 70</td>
</tr>
</tbody>
</table>

When a variable name is specified with the EVALUATE command, the Expression window displays the evaluation of the variable. When a quoted string of ASCII characters is specified with the EVALUATE command, the Expression window displays the string.

The Expression window's control menu provides the Evaluate... (ALT, -, E) command which lets you evaluate expressions and see the results in the window.

See Also

"Expression Window Commands" in the "Window Control Menu Commands" chapter.
The I/O Window

The I/O window displays the contents of the I/O locations.

You can modify the contents of I/O locations by double-clicking on the value, using the keyboard to type in the new value, and pressing the Enter key.

The I/O window contents are updated periodically when the processor is running the user program.

If a location is in target system memory, a temporary break from the user program into the monitor program must occur in order for the debugger to update or modify that location's contents. If it's important that the user program execute without these types of interruptions, you should disallow monitor intrusion. Even when monitor intrusion is allowed, you can stop temporary breaks during the window update by turning polling OFF.
Note that if any address in the displayed range is not readable (for example, it is beyond the segment limit in protected mode), all memory will be displayed as dashes (--). In this case, resize the memory window to only display the address ranges needed.

Also, do not use the memory window for reading memory-mapped I/O devices; use the I/O window (to ensure that only the bytes necessary to read the specific address are read).

**See Also**

"Displaying and Editing I/O Locations" in the "Debugging Programs" chapter.

"I/O Window Commands" in the "Window Control Menu Commands" chapter.
The Memory Window

The Memory window displays memory contents.

The Memory window has control menu commands that let you change the format of the memory display and the size of the locations displayed or modified. When the absolute (single-column) format is chosen, symbols corresponding to addresses are displayed. When data is displayed in byte format, ASCII characters for the byte values are also displayed.

When Memory window polling is turned ON, you can modify the addresses displayed or contents of memory locations by double-clicking on the address or value, using the keyboard to type in the new address or value, and pressing the Enter key.

The Memory window contents are updated periodically when the processor is running the user program.

If a location is in target system memory, a temporary break from the user program into the monitor program must occur in order for the debugger to update or modify that location’s contents. If it’s important that the user program execute without these types of interruptions, you should disallow monitor intrusion. Even when monitor intrusion is allowed, you can stop temporary breaks during the window update by turning polling OFF.
In contrast to the memory window, the I/O window only reads the number of bytes specified in the Size field when it displays the data. The memory window reads a buffer which may contain many more bytes than are displayed. Therefore, if a memory address is surrounded by addresses you do not want to read, use the I/O window to avoid reading the surrounding addresses. Typically, you will want to use the I/O window when displaying memory-mapped I/O.

**See Also**

"Displaying and Editing Memory" in the "Debugging Programs" chapter.

"Memory Window Commands" in the "Window Control Menu Commands" chapter.
The GDT Window

The GDT window displays the contents of the current Global Descriptor Table. The current GDT can be found by looking at the current value of the gdtr.b (GDT base) and gdtr.l (GDT limit) registers in the System Registers window.

You cannot display the GDT window (or gdtr.l and gdtr.b) if the emulator is running your target program and monitor intrusion is disallowed unless the GDT is in dual-port memory.

If you are in real-mode (prior to entering protected mode), you cannot display a valid GDT window until the LGDT opcode has been executed, or you have modified the gdtr.b register.

<table>
<thead>
<tr>
<th>Sel</th>
<th>Location Type</th>
<th>Address/Range</th>
<th>Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>NULL Selector</td>
<td>0 00000004..0000008b</td>
<td>16-bit wri</td>
</tr>
<tr>
<td>0008</td>
<td>Data Segment</td>
<td>0 00000004..00000048</td>
<td>16-bit wri</td>
</tr>
<tr>
<td>0010</td>
<td>Code Segment</td>
<td>0 00000400..000004df</td>
<td>16-bit rax</td>
</tr>
<tr>
<td>0020</td>
<td>Data Segment</td>
<td>0 00000000..00000084</td>
<td>16-bit wri</td>
</tr>
<tr>
<td>0020</td>
<td>Code Segment</td>
<td>0 000000e0..000000ad</td>
<td>32-bit rax</td>
</tr>
<tr>
<td>0030</td>
<td>Task Gate</td>
<td>3 0070r:00000000</td>
<td>word count</td>
</tr>
<tr>
<td>0040</td>
<td>Code Segment</td>
<td>3 0000004c..0000002d</td>
<td>32-bit rax</td>
</tr>
<tr>
<td>0040</td>
<td>Segment</td>
<td>0 00000014..0000001a</td>
<td>16-bit rax</td>
</tr>
<tr>
<td>0050</td>
<td>Data Segment</td>
<td>0 0000084a..000008ad</td>
<td>16-bit wri</td>
</tr>
<tr>
<td>0058</td>
<td>Invalid</td>
<td>3 00000000..000000ff</td>
<td>16-bit wri</td>
</tr>
<tr>
<td>0060</td>
<td>Data Segment</td>
<td>3 00000004..00000006</td>
<td>16-bit wri</td>
</tr>
<tr>
<td>0070</td>
<td>TSS</td>
<td>3 00000084..0000008a</td>
<td>16-bit wri</td>
</tr>
</tbody>
</table>

Note that selector 0 is always the NULL selector. Referencing it in an Intel80386EX program will always cause the Intel80386EX to generate a General Protection Fault.

Each display line has six fields:

- **Sel.** The selector of the segment. This is the value loaded into a segment descriptor (CS, DS, etc). The last two bits of the selector are the DPL of the segment.
• Location. This is the physical address of this entry. This is useful when looking at trace lists.

• Type. This decodes the type of the segment. Types include LDT (this entry points to a Local Descriptor Table), Code segments, Data segments, TSS blocks, and various gates. "80286 call gates/TSS/etc" are decoded simply as the type, but the attribute will include "16-bit". "80386 gates/TSS/etc" are decoded simply as the type, but the attribute will be "32-bit".

• DPL. This is the Descriptor Privilege level of the entry.

• Address/Range. This is either a starting and ending address for the entry or a selector (depending on the type of entry). For expand-down segments, the address range is the real address range (that is, the wrapping is taken into account). For example, if the mapping file shows the range as 'start=00001EE4H limit=3FFFFFFH Expand-down', the Address/Range column will show the range as 'ee4..1ee3', which is the linear address range that will be used.

• Attributes. This decodes the attributes according to the type of entry.

The GDT window shows the descriptor table in memory, not the shadow registers in the CPU. In order to change the shadow registers in the CPU, you must change the GDT table in memory (using the memory window). Break into the monitor, modify the desired segment register, and then exit the monitor.

See Also

"Search→Entry... (ALT, -, R, E)", and "Search→Selector... (ALT, -, R, S)" in the "GDT/LDT/IDT Window Command" section of the "Window Control Menu Commands" chapter.
The LDT Window

The LDT window displays the contents of the current Local Descriptor Table. (The current LDT can be found by looking at the current value of the ldtr register in the System Registers window.) It refers to an entry in the GDT, which in turn points to the linear address of the table.

You cannot display the LDT window if the emulator is running your target program with monitor intrusion disallowed unless the LDT is in dual-port memory.

If you are in real-mode (prior to entering protected mode), you cannot display valid LDT window content until the LLDT opcode has been executed, or you have modified the ldtr register.

The selector numbers have bit 2 set (that is, the first selector is 4, not 0). That is how the processor differentiates between a selector in the GDT and the same selector in the LDT. Selector 4 (entry 0) is legal, but some builders leave it empty.

See the GDT window for descriptions of each of the six fields in the display lines.

The LDT window shows the descriptor table in memory, not the shadow registers in the CPU. In order to change the shadow registers in the CPU, you must change the LDT table in memory (using the memory window). Break into the monitor, modify the desired segment register, and then exit the monitor.

See Also

"Search→Entry... (ALT, -, R, E)", and "Search→Selector... (ALT, -, R, S)" in the "GDT/LDT/IDT Window Commands" section of the "Window Control Menu Commands" chapter.
The IDT Window

The IDT window displays the contents of the current Interrupt Descriptor Table. The current IDT can be found by looking at the current value of the idtr.b and idtr.l (IDT base and limit) registers in the System Registers window.

You cannot display the IDT window if the emulator is running your target program and monitor intrusion is disallowed unless the IDT is in dual-port memory.

The IDT window display is only useful in protected mode.

<table>
<thead>
<tr>
<th>Sel</th>
<th>Location</th>
<th>Type</th>
<th>Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>0000</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Divisor Error</td>
</tr>
<tr>
<td>0001</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Debug Exception</td>
</tr>
<tr>
<td>0010</td>
<td>0000003f</td>
<td>Invalid</td>
<td>NMI Interrupt</td>
</tr>
<tr>
<td>0011</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Breakpoint</td>
</tr>
<tr>
<td>0020</td>
<td>0000003f</td>
<td>Invalid</td>
<td>INTC-Detected OverFlow</td>
</tr>
<tr>
<td>0021</td>
<td>0000003f</td>
<td>Invalid</td>
<td>D Safe Range Executed</td>
</tr>
<tr>
<td>0030</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Invalid Gs</td>
</tr>
<tr>
<td>0038</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Coprocessor Not Available</td>
</tr>
<tr>
<td>0040</td>
<td>0000003f</td>
<td>Interrupt Gate 0</td>
<td>0028:00000000 Double Fault.22-Bit,1w</td>
</tr>
<tr>
<td>0048</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Coprocessor Segment 0</td>
</tr>
<tr>
<td>0050</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Invalid Task State 0</td>
</tr>
<tr>
<td>0058</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Segment Not Present</td>
</tr>
<tr>
<td>0060</td>
<td>0000003f</td>
<td>Interrupt Gate 0</td>
<td>0028:00000000 Stack Fault.22-Bit,1w</td>
</tr>
<tr>
<td>0068</td>
<td>0000003f</td>
<td>Interrupt Gate 0</td>
<td>0028:0000000d General Protection Fp</td>
</tr>
<tr>
<td>0070</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Page Fault</td>
</tr>
<tr>
<td>0078</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Reserved</td>
</tr>
<tr>
<td>0080</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Coprocessor Error</td>
</tr>
<tr>
<td>0088</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Reserved</td>
</tr>
<tr>
<td>0090</td>
<td>0000003f</td>
<td>Invalid</td>
<td>Reserved</td>
</tr>
</tbody>
</table>

Each line has six fields:

- Sel. The selector of the descriptor.
- Location. This is the physical address of the entry. This is useful when looking at trace lists.
- Type. This decodes the type of the selector. Only interrupt gates, trap gates, and task gates may be in the IDT.
- DPL. This is the Descriptor Privilege level of the entry.
- Address/Range. This is the address of the interrupt routine or task TSS.
- Attributes. This decodes the attributes according to the type of entry.
The name of the interrupt is displayed for the first 32 entries.

See Also

"Search→Entry... (ALT, -, R, E)", and "Search→Selector... (ALT, -, R, S)" in
the "GDT/LDT/IDT Window Commands" section of the "Window Control
Menu Commands" chapter.

The Register Windows

The Register windows display the contents of registers. There is a separate
window for each class of registers. For example, the Basic Registers are in
one class of registers.

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>sip</td>
<td>0000019F</td>
<td>Instruction Pointer</td>
</tr>
<tr>
<td>aflga</td>
<td>FFEC326E</td>
<td>Condition/Control Flags</td>
</tr>
<tr>
<td>eax</td>
<td>00000001</td>
<td>General Register A</td>
</tr>
<tr>
<td>ebx</td>
<td>00000000</td>
<td>General Register B</td>
</tr>
<tr>
<td>ecx</td>
<td>00000000</td>
<td>General Register C</td>
</tr>
<tr>
<td>edx</td>
<td>00000000</td>
<td>General Register D</td>
</tr>
<tr>
<td>esi</td>
<td>FFFFFFF9</td>
<td>Source Index</td>
</tr>
<tr>
<td>edi</td>
<td>FFFFFFF8</td>
<td>Destination Index</td>
</tr>
<tr>
<td>ebp</td>
<td>00000FEC</td>
<td>Base Pointer</td>
</tr>
<tr>
<td>esp</td>
<td>00000FEC</td>
<td>Stack Pointer</td>
</tr>
<tr>
<td>cr0</td>
<td>73FEEFF9</td>
<td>Machine Control</td>
</tr>
<tr>
<td>cr2</td>
<td>00000000</td>
<td>Page Fault Linear Address</td>
</tr>
<tr>
<td>cr3</td>
<td>00000000</td>
<td>Page Directory Base Addr</td>
</tr>
<tr>
<td>tr6</td>
<td>00000002</td>
<td>Test Control</td>
</tr>
<tr>
<td>tr7</td>
<td>00000000</td>
<td>Test Data</td>
</tr>
</tbody>
</table>

Each register is represented by a row which holds a mnemonic name, a
current value, and a description of the register contents.

The registers may be edited by either single clicking or double-clicking on the
value. A single click puts you in a mode where the left or right arrow keys
may be used for placement of the cursor. Double-clicking puts you in one of
two modes; either a Register Bit Fields dialog pops up or the value is
highlighted. When the value is highlighted, the backspace key will erase the
value and a completely new value may be entered. This mode is applicable to registers where the value is considered a single number and is not divided by any bit-fields.

The Register window contents are updated periodically when the processor is running the user program and monitor intrusion is allowed.

A temporary break from the user program into the monitor program must occur in order for the debugger to update or modify register contents. If it is important that the user program execute without these types of interruptions, you should disallow monitor intrusion.

**See Also**

"Displaying and Editing Registers" in the "Debugging Programs" chapter.

"Register Window Commands" in the "Window Control Menu Commands" chapter.

---

**The Source Window**

The Source window displays source files, optionally with disassembled instructions intermixed.

The Source window contains a cursor whose position is used when setting or deleting breakpoints or break macros or when running the program up to a certain line.

The Source window lets you copy strings, usually variable or function names to be used in commands, to the clipboard by double-clicking words or by holding down the left mouse button and dragging the mouse pointer.

The Source window also provides commands in the *control menu* that let you select whether disassembled instruction mnemonics should appear intermixed with the C source code.
By clicking the right mouse button in the Source window, you can also access pop-up menu commands.

Filename
The name of the displayed source file appears at the top of the window.

Source Lines
C source code is displayed when available. Source lines are preceded by the corresponding line numbers.

When programs are written in assembly language or when no C source code is available, disassembled instruction mnemonics are displayed.

The interface will only support display in either trace or source windows of source lines numbered less than 32,000.

Disassembled Instructions
In the Mnemonic Display mode, disassembled instruction mnemonics are intermixed with the source lines. Disassembled lines contain address, data, and mnemonic information.

When symbolic information is available for the address, the corresponding symbol line precedes the disassembled instruction, displayed in the module_name\symbol_name format.
Current PC  The line associated with the current program counter is highlighted.

Scroll Bars  For C source files, the display scrolls within the source files. For assembly language programs or programs for which no source code is available, the display scrolls for all the memory space.

"BP" Marker  The breakpoint marker, BP, appears at the beginning of the breakpoint lines or break macro lines.

Break Macro Lines  Decimal points following line numbers or addresses indicate break macro lines.

**Note**  When programs are stored in target system memory and the emulator is running in real-time, source code cannot be displayed.

**See Also**

"Loading and Displaying Programs", "Stepping, Running, and Stopping the Program", and "Using Breakpoints and Break Macros" in the "Debugging Programs" chapter.

"Source Window Commands" in the "Window Control Menu Commands" chapter.

"Source Window Pop-Up Commands" in the "Window Pop-Up Commands" chapter.

"To set colors in the Source window" in the "Working with Debugger Windows" section of the "Using the Debugger Interface" chapter.
The Status Window

The Status window shows:

- Emulator status.
- Trace status.
- Scope of the current program counter value.
- Progress of symbols being loaded from a file.
- Last five asynchronous messages from the emulator.

Emulation Processor Status Messages

EMULATION RESET
The emulation processor is being held in the reset state by the emulator.

RUNNING IN MONITOR
The emulation processor is executing the monitor program.

RUNNING IN USER PROGRAM
The emulation processor is executing the user program.

RUNNING REALTIME IN USER PROGRAM
The emulation processor is executing the user program in the real-time mode where:
Any command that would temporarily interrupt user program execution is disabled.

Any on-screen information that would be periodically updated by temporarily interrupting user program execution (target system memory or register contents, for example) is disabled.

**WAITING FOR TARGET RESET**
The emulation processor is waiting for a RESET signal from the target system. User program execution starts on reception of the RESET signal.

**SLOW CLOCK**
No proper clock pulse is supplied from the external clock.

**EMULATION RESET BY TARGET**
The emulation processor is being held in a reset state by a RESET signal from the target system.

**BUS GRANT TO TARGET SYSTEM DEVICE**
The bus is granted to some device in the target system.

**NO BUS CYCLE**
The bus cycle is too slow or no bus cycle is provided.

**HALTED**
The emulation processor has halted.

**UNKNOWN STATE**
The emulation processor is in an unknown state.

**Other Emulator Status Messages**
The Status window may also contain status messages other than the emulation processor status messages described above:

**BREAK POINT HIT AT module_name#line_number**
The breakpoint specified in the source code line was hit and program execution stopped at "line_number" in "module".

**BREAKPOINT HIT AT address**
The breakpoint specified in the assembled line was hit and program execution stopped at "address".
UNDEFINED BREAKPOINT at address
The breakpoint instruction occurred at "address", but it was not inserted by a breakpoint set command.

WRITE TO ROM BREAK
Program execution has stopped due to a write to location mapped as ROM. These types of breaks must be enabled in the emulator configuration.

ACCESS TO GUARD BREAK
Program execution has stopped due to a write to a location mapped as guarded memory.

TRACE TRIGGER BREAK
The analyzer trigger caused program execution to break into the monitor (as specified by selecting the Break On Trigger option in the trace setting dialog box).

Trace Status Messages

TRACE RUNNING
The trace has been started and trace memory has yet to be filled; this could be because the trigger condition has not occurred or, if the trigger condition has occurred, there have not been enough states matching the store condition to fill trace memory. Contents of the trace buffer cannot be displayed during the TRACE RUNNING status; you must halt the trace before you can display the contents of the trace buffer.

TRACE HALTED
The trace was halted before the trace buffer was filled. The status indicates that the trace was halted immediately after the emulator powerup, or that the trace was force-terminated by the user. In the TRACE HALTED status, the analyzer displays the contents of the trace buffer before the halt in the Trace window.

TRACE COMPLETE
The trace completed because the trace buffer is full. The results are displayed in the Trace window.
The Symbol Window

The Symbol window displays information on the following types of symbols:

- Modules
- Functions
- Global symbols
- Local symbols
- Global Assembler symbols
- Local Assembler symbols
- User-defined symbols

The Symbol window has control menu commands that let you display various types of symbols, add or delete user-defined symbols, copy Symbol window information, or search for symbols that contain a particular string.

The Symbol window lets you copy symbols to the clipboard by clicking the left mouse button. The symbol information can then be pasted from the clipboard in other commands.

Symbols are displayed with "type" and "address" values where appropriate.

See Also

"Displaying Symbol Information" in the "Debugging Programs" chapter.

"Symbol Window Commands" in the "Window Control Menu Commands" chapter.
The Trace Window

The Trace window displays trace results and shows source code lines that correspond to the execution captured by the analyzer. Optionally, bus cycle states can be displayed along with the source code lines.

The Trace window has control menu commands that let you display bus cycles, specify whether count information should be shown absolute or relative, or copy information from the window.

The Trace window opens automatically when a trace is complete.

For each line in the Trace window, the trace buffer state number, the type of state, the module name and source file line number, the function name, the source line, and the time count information are displayed.

The << and >> buttons let you move between the multiple frames of trace data that are available with newer analyzers for the HP 64700.

The type of state can be a sequence level branch (SEQ), a state that satisfies the prestore condition (PRE), or a normal state that matches the store conditions (in which case the type field is empty).

Bus cycle states show the address and data values that have been captured as well as the disassembled instruction or status mnemonics.

On startup, the system defaults to the source only display mode, where only source code lines are displayed. The source/bus cycle mixed display mode can be selected by using the Trace window control menu’s Display→Mixed.
Mode (ALT, -, D, M) command. In the source/bus cycle mixed display mode, each source code line is immediately followed by the corresponding bus cycles.

The trace buffer stores bus cycles only. The system displays source lines in the Trace window based on execution bus cycles.

**See Also**

"Tracing Program Execution" and "Setting Up Custom Trace Specifications" in the "Debugging Programs" chapter.

"Trace Window Commands" in the "Window Control Menu Commands" chapter.
The WatchPoint Window

The WatchPoint window displays the contents of variables that have been registered with the Variable→Edit... (ALT, V, E) command or with the Edit... (ALT, -, E) command in the WatchPoint window’s control menu.

The contents of dynamic variables are displayed only when the current program counter is in the function in which the variable is declared.

You can modify the contents of variables by double-clicking on the value, using the keyboard to type in the new value, and pressing the Enter key.

The WatchPoint window lets you copy text strings, to the clipboard by double-clicking words or by holding down the left mouse button and dragging the mouse pointer.

See Also

"Displaying and Editing Variables" in the "Debugging Programs" chapter.

"WatchPoint Window Commands" in the "Window Control Menu Commands" chapter.
Monitor Program Options

- Background monitor
- Foreground monitor
- Foreground monitor advantages and disadvantages

The emulation monitor program is a program that the emulation microprocessor executes as directed by the HP 64700 system controller. The emulation monitor program gives the system controller access to the target system.

For example, when you modify target system memory, the system controller writes a command code to a communications area and switches (breaks) emulation processor execution into the monitor program. The monitor program reads the command code (and any associated parameters) from the communications area and executes the appropriate machine instructions to modify the target system memory. After the monitor has performed its task, emulation processor execution returns to the area where it was executing before the break.

The emulation monitor program executes out of a separate, internal memory system known as background memory, which is dual ported. A monitor program executing out of background memory is known as a background monitor program.

The foreground emulation monitor program also executes out of dual-port memory, which is not the same 8K, dual-port memory available to your programs. However, the foreground monitor does consume memory address space (that is, you must reserve physical addresses to contain the foreground monitor), and addresses consumed by the foreground monitor are not available to use within your target system.

Emulator firmware includes both background and foreground monitor programs and lets you select either one. You can also load and use a customized foreground monitor program, if desired.
Background monitor

The default emulator configuration selects the background monitor.

Interrupts from the target system are disabled during background monitor execution. If your programs have strict real-time requirements for servicing target system interrupts, you must use a foreground monitor.

DMA cycles are allowed while in the background monitor (that is, the HOLD line will be acknowledged with the HLDA signal even while executing the background monitor.)

Foreground monitor

A foreground monitor source file is provided with the emulator. It can be assembled, linked, and loaded into the debugger. It is linked and loaded separately from your program. However, you must provide:

• A physical address space of 16K that is not used for any other purpose within your target hardware.

• An unused entry in your GDT. You do not need to put any data in this entry. It will be filled in by the emulator prior to entering the monitor.

• If you are using paging, the foreground monitor must be located in address space where each virtual address is the same as each physical address (virtual address = physical address). You must have a valid page table for the virtual address range (although the specific entries for the foreground monitor will be filled in by the emulator prior to entering the monitor).
Forefront monitor advantages and disadvantages

**Advantages**

- A foreground monitor executes as part of the user program. This allows you to enable target system interrupts during monitor program execution for applications that have strict real-time processing requirements.

- A foreground monitor can be customized.

**Disadvantages**

- A foreground monitor consumes target system address space.

- In order for interrupts to be received while execution is in the monitor, they must either have a DPL of 0 (because the monitor runs at DPL 0), or be a task gate.

- A foreground monitor does not require target system stack space. However, because the foreground monitor runs at DPL 0, you must provide a privilege level 0 stack in case interrupts are serviced while the foreground monitor is executing.
Trace Signals and Predefined Status Values

This section describes how emulation-bus analyzer trace signals are assigned to microprocessor address bus, data bus, and control signals.

See also "Understanding Address, Data, and Status", and "Understanding Intel80386EX Analysis" for more information.

### Emulation-Bus Analyzer Trace Signals

<table>
<thead>
<tr>
<th>Trace Signals</th>
<th>Signal Name</th>
<th>Signal Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>6-31</td>
<td>A0-A25</td>
<td>Address Lines A1-A25, plus address A0 derived from BLE# and BHE#</td>
</tr>
<tr>
<td>32-47</td>
<td>D0-D15</td>
<td>Data lines 0-15</td>
</tr>
<tr>
<td>64</td>
<td>Monitor/User</td>
<td>0 = Monitor, 1 = User program execution</td>
</tr>
<tr>
<td>65</td>
<td>W/R#</td>
<td>1 = write, 0 = read</td>
</tr>
<tr>
<td>66</td>
<td>D/C#</td>
<td>1 = data, 0 = control</td>
</tr>
<tr>
<td>67</td>
<td>M/IO#</td>
<td>1 = memory, 0 = I/O</td>
</tr>
<tr>
<td>68</td>
<td>BLE#</td>
<td>0 = byte low enable (data bits 0-7)</td>
</tr>
<tr>
<td>69</td>
<td>BHE#</td>
<td>0 = byte high enable (data bits 8-15)</td>
</tr>
<tr>
<td>70</td>
<td>UCS#</td>
<td>0 = Addr of mem or io cycle within prog addr rgn</td>
</tr>
<tr>
<td>71</td>
<td>LBA#</td>
<td>0 = proc provides internal READY# for bus trans</td>
</tr>
<tr>
<td>72</td>
<td>BS8#</td>
<td>0 = Bus Size 8 is asserted.</td>
</tr>
<tr>
<td>73</td>
<td>NA#</td>
<td>0 = Next Address (pipelining) requested</td>
</tr>
<tr>
<td>74</td>
<td>LOCK#</td>
<td>0 = lock asserted (HOLD will not be acknowledged)</td>
</tr>
<tr>
<td>75</td>
<td>SMIACT#</td>
<td>0 = processor is in System Management Mode</td>
</tr>
<tr>
<td>76</td>
<td>HLDA</td>
<td>1 = Hold Acknowledge in previous cycle</td>
</tr>
<tr>
<td>77</td>
<td>MSG</td>
<td>1 = branch or task trace message from processor</td>
</tr>
<tr>
<td>78</td>
<td>NMI</td>
<td>1 = nonmaskable interrupt request</td>
</tr>
<tr>
<td>79</td>
<td>REFRESH#</td>
<td>1 = Refresh bus cycle in progress</td>
</tr>
</tbody>
</table>
## Predefined Status Values

<table>
<thead>
<tr>
<th>Qualifier</th>
<th>Status Bits (31-16)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ble</td>
<td>xxxx xxxx xxxx0 xxxx</td>
<td>BLE# (Byte Low Enable) active</td>
</tr>
<tr>
<td>bhe</td>
<td>xxxx xxxx xx0x xxxx</td>
<td>BHE# (Byte High Enable) active</td>
</tr>
<tr>
<td>bs8</td>
<td>xxxx xxxx0 xxxx xxxx</td>
<td>BS8# (Bus Size 8) active</td>
</tr>
<tr>
<td>bmsg</td>
<td>xxlx xlx xxxx xxxx 001x</td>
<td>Branch Trace message</td>
</tr>
<tr>
<td>code</td>
<td>xxxx xxxx xxxx x0xx</td>
<td>A control access (op-code fetch, for example)</td>
</tr>
<tr>
<td>data</td>
<td>xxxx xxxx xxxx xlx xx</td>
<td>A data access (memory read, for example)</td>
</tr>
<tr>
<td>halt</td>
<td>xxxx xxxx xx11 101x</td>
<td>The ‘hlt’ instruction was executed</td>
</tr>
<tr>
<td>hlda</td>
<td>xxx1 xxxx xxxx xxxx</td>
<td>HLDA (hold acknowledge) was active just prior to captured state</td>
</tr>
<tr>
<td>inta</td>
<td>xxxx x0xx xx10 000x</td>
<td>An interrupt acknowledge cycle</td>
</tr>
<tr>
<td>io</td>
<td>xxxx xxxx xxxx 01xx</td>
<td>An I/O access ('out', for example)</td>
</tr>
<tr>
<td>iord</td>
<td>xxxx xxxx xxxx 011x</td>
<td>An I/O read cycle</td>
</tr>
<tr>
<td>iowr</td>
<td>xxxx xxxx xxxx 01lx</td>
<td>An I/O write cycle</td>
</tr>
<tr>
<td>lba</td>
<td>xxxx xxxx 0xxxx xxxx</td>
<td>Processor provides internal READY# for bus transactions</td>
</tr>
<tr>
<td>lock</td>
<td>xxxx x0xx xxxx xxxx</td>
<td>Lock asserted (HOLD will not be acknowledged)</td>
</tr>
<tr>
<td>mem</td>
<td>xxxx xxxx xxxx 1xxx</td>
<td>A memory access ('read', for example)</td>
</tr>
<tr>
<td>memif</td>
<td>xxxx xxxx xxxx 100x</td>
<td>A memory instruction fetch (op-code fetch)</td>
</tr>
<tr>
<td>memrd</td>
<td>xxxx xxxx xxxx 1x0x</td>
<td>A memory read</td>
</tr>
<tr>
<td>memwr</td>
<td>xxxx xxxx xxxx 111x</td>
<td>A memory write</td>
</tr>
<tr>
<td>mon</td>
<td>xxxx xxxx xxxx xxxx0</td>
<td>A background monitor cycle</td>
</tr>
<tr>
<td>msg</td>
<td>xxlx xxxx xxxx xxxx</td>
<td>Message</td>
</tr>
<tr>
<td>na</td>
<td>xxxx xxxx0x xxxx xxxx</td>
<td>NA# (pipelining) request active</td>
</tr>
<tr>
<td>nmi</td>
<td>xxlx xxxx xxxx xxxx</td>
<td>Nonmaskable interrupt active</td>
</tr>
<tr>
<td>read</td>
<td>xxxx xxxx xxxx xx0x</td>
<td>A read cycle (memory or I/O)</td>
</tr>
<tr>
<td>refresh</td>
<td>1xxx xxxx xxxx xxxx</td>
<td>Refresh cycle active</td>
</tr>
<tr>
<td>shut</td>
<td>xxxx xxxx xx10 101x</td>
<td>Processor shutdown</td>
</tr>
<tr>
<td>smiact</td>
<td>xxxx 0x0x xxxx xxxx</td>
<td>System Management Mode active</td>
</tr>
<tr>
<td>ttmsg</td>
<td>xxlx xx1xx xxxx xxxx 000x</td>
<td>Task Trace message</td>
</tr>
<tr>
<td>ucs</td>
<td>xxxx xxxx x0xx xxxx</td>
<td>Address of cycle is in programmed address range</td>
</tr>
<tr>
<td>write</td>
<td>xxxx xxxx xxxx xx1x</td>
<td>A write cycle (memory or I/O)</td>
</tr>
</tbody>
</table>
Understanding Intel80386EX Analysis

The external address, data, and control signals of the Intel80386EX can be difficult to understand. This section will help you understand how the Intel80386EX works, how to interpret the trace information, and how to ask for more precise trace information.

Instruction reads are always two bytes

The Intel80386EX always reads two bytes at a time when reading instructions. This can be confusing when the target of a branch is at an address that is not a multiple of two. This can also cause problems when you want to trigger on a specific function. See Understanding Address, Data, and Status for information on how the emulator helps you do this.

Prefetching

The Intel80386EX may read up to 12 bytes of data before it starts to execute the first byte of data (it may fetch less, depending on the number of wait states and the instructions being executed). Eleven of these twelve bytes of data are "prefetched" (that is, fetched from memory before they are needed). One implication of these prefetches is that the processor runs faster. Another is that the order of the external bus cycles can be confusing when you see them in a trace list.

Consider the following assembly code:

```
readloop:
    mov ax, control
    cmp ax, 0
    je readloop

try1:
    cmp ax, 1
    jne try2 ; command 1: call into ld15romseg
```
When traced by a logic analyzer, with 0000h as the address of 'control', these are the bus cycles the Intel80386EX generates:

<table>
<thead>
<tr>
<th>Line</th>
<th>addr,H</th>
<th>80386 Mnemonic</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>000103e</td>
<td>a190H</td>
<td>code read</td>
</tr>
<tr>
<td>1</td>
<td>0001040</td>
<td>0000H</td>
<td>code read</td>
</tr>
<tr>
<td>2</td>
<td>0001042</td>
<td>003dH</td>
<td>code read</td>
</tr>
<tr>
<td>3</td>
<td>0001044</td>
<td>7400H</td>
<td>code read</td>
</tr>
<tr>
<td>4</td>
<td>0001046</td>
<td>3df8H</td>
<td>code read</td>
</tr>
<tr>
<td>5</td>
<td>0000000</td>
<td>0000H</td>
<td>read mem</td>
</tr>
<tr>
<td>6</td>
<td>0001048</td>
<td>0001H</td>
<td>code read</td>
</tr>
<tr>
<td>7</td>
<td>000104a</td>
<td>1875H</td>
<td>code read</td>
</tr>
<tr>
<td>8</td>
<td>000103e</td>
<td>a190H</td>
<td>code read</td>
</tr>
<tr>
<td>9</td>
<td>0001040</td>
<td>0000H</td>
<td>code read</td>
</tr>
<tr>
<td>10</td>
<td>0001042</td>
<td>003dH</td>
<td>code read</td>
</tr>
<tr>
<td>11</td>
<td>0001044</td>
<td>7400H</td>
<td>code read</td>
</tr>
<tr>
<td>12</td>
<td>0001046</td>
<td>3df8H</td>
<td>code read</td>
</tr>
<tr>
<td>13</td>
<td>0000000</td>
<td>0000H</td>
<td>read mem</td>
</tr>
<tr>
<td>14</td>
<td>0001048</td>
<td>0001H</td>
<td>code read</td>
</tr>
</tbody>
</table>

The above trace list shows several features of the Intel80386EX bus activity:

- Even though readloop begins at address 103f, the processor had to fetch instructions starting at address 103e each time it jumped to readloop. The Intel80386EX always reads two bytes when reading instructions.
- The processor prefetched some instructions (addresses 1042 through 1047) before executing the 'mov ax,control' instruction at address 103f. You can see this by seeing that the read of 'control' (address 0) occurs at state 5, not after state 1 where the entire opcode had been read.
- Even after 'control' was read, the processor continued to prefetch, reading address 104a at state 7 in the trace before recognizing it had to jump back to address 103f.
Disassembly helps

Fortunately, the disassembler which is part of RTC helps you decode the order of execution. Here is the output of the 'trace' command, displaying disassembled bus cycles:

<table>
<thead>
<tr>
<th>Line</th>
<th>addr, H</th>
<th>80386 Mnemonic</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>000103e</td>
<td>NOP</td>
</tr>
<tr>
<td></td>
<td>-000103f</td>
<td>MOV AX,0000H code read</td>
</tr>
<tr>
<td>1</td>
<td>0001040</td>
<td>0000H code read</td>
</tr>
<tr>
<td>2</td>
<td>0001042</td>
<td>CMP AX,#0000H</td>
</tr>
<tr>
<td>3</td>
<td>-0001045</td>
<td>JZ 0000103FH</td>
</tr>
<tr>
<td>4</td>
<td>-0001047</td>
<td>CMP AX,#0001H</td>
</tr>
<tr>
<td>5</td>
<td>0000000</td>
<td>0000H read mem</td>
</tr>
<tr>
<td>6</td>
<td>0001048</td>
<td>- 0001H code read</td>
</tr>
<tr>
<td>7</td>
<td>0001049</td>
<td>-JNZ 00001064H</td>
</tr>
<tr>
<td>8</td>
<td>000103e</td>
<td>-NOP</td>
</tr>
<tr>
<td></td>
<td>-000103f</td>
<td>MOV AX,0000H</td>
</tr>
<tr>
<td>9</td>
<td>0001040</td>
<td>0000H code read</td>
</tr>
<tr>
<td>10</td>
<td>0001042</td>
<td>CMP AX,#0000H</td>
</tr>
<tr>
<td>11</td>
<td>-0001045</td>
<td>JZ 0000103FH</td>
</tr>
<tr>
<td>12</td>
<td>-0001047</td>
<td>CMP AX,#0001H</td>
</tr>
<tr>
<td>13</td>
<td>0000000</td>
<td>0000H read mem</td>
</tr>
<tr>
<td>14</td>
<td>0001048</td>
<td>- 0001H code read</td>
</tr>
</tbody>
</table>

- The lines preceded by equals signs (=) did not appear as bus cycles. Instead, they were emitted by the disassembler. They were obtained as part of the preceding fetch.
- When a dash (-) is shown preceding a mnemonic, it indicates that the associated opcode was not executed. Instead, it was obtained in an unexecuted prefetch.
- When a multiple-byte opcode is decoded, the next address in the address column shows the starting byte of the next opcode, not the address that appeared on the address bus. This is convenient when using an assembly listing to match up addresses, but you cannot trigger a trace on this address. Only use addresses that are multiples of two when specifying a trigger for the analyzer.
Execution Trace Messages help even more

In many cases, the disassembler cannot correctly determine which bytes are unused prefetches and which are executed. The "execution trace message" facility in this emulator helps you make the determination.

When the "Enable Execution Trace Messages" box in the Settings→Emulator Config→Hardware... dialog box is checked, the processor emits the target of any branches to the analyzer (use of "Enable Execution Trace Messages" has little or no effect on the performance of your target system.)

Consider the following code which jumps into a table based on the value in the ax register:

```
0140 40 53 inc ax
0141 BA4801 54 mov dx,offset table_start
0144 01C2 55 add dx,ax
0146 FFE2 56 jmp dx
0148 40 57 table_start: inc ax
0149 42 58 entry2: inc dx
014A 41 59 entry3: inc cx
```

These are the bus cycles when the above code is executed:

<table>
<thead>
<tr>
<th>Line</th>
<th>addr,H</th>
<th>80386 Mnemonic</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0000140</td>
<td>ba40H code read</td>
</tr>
<tr>
<td>1</td>
<td>0000142</td>
<td>0148H code read</td>
</tr>
<tr>
<td>2</td>
<td>0000144</td>
<td>c201H code read</td>
</tr>
<tr>
<td>3</td>
<td>0000146</td>
<td>e2ffH code read</td>
</tr>
<tr>
<td>4</td>
<td>0000148</td>
<td>4240H code read</td>
</tr>
<tr>
<td>5</td>
<td>000014a</td>
<td>eb41H code read</td>
</tr>
<tr>
<td>6</td>
<td>000014c</td>
<td>00feH code read</td>
</tr>
<tr>
<td>7</td>
<td>0000148</td>
<td>4240H code read</td>
</tr>
<tr>
<td>8</td>
<td>000014a</td>
<td>eb41H code read</td>
</tr>
<tr>
<td>9</td>
<td>000014c</td>
<td>00feH code read</td>
</tr>
<tr>
<td>10</td>
<td>000014e</td>
<td>1700H code read</td>
</tr>
<tr>
<td>11</td>
<td>0000150</td>
<td>ff00H code read</td>
</tr>
<tr>
<td>12</td>
<td>0000152</td>
<td>00ffH code read</td>
</tr>
<tr>
<td>13</td>
<td>000015a</td>
<td>eb41H code read</td>
</tr>
</tbody>
</table>

The RTC disassembler helps, but it cannot identify the exact destination of the indirect jump, which could be the opcode at address 148, 149, 14a, or even 14b (because they were all fetched together). There is no way to tell without knowing the value of register AX at the start of the trace, and there is no hint as to its starting value.
<table>
<thead>
<tr>
<th>Line</th>
<th>addr,H</th>
<th>80386 Mnemonic</th>
<th>stat,H</th>
<th>count,R</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0000140</td>
<td>INC AX</td>
<td>1f09fff</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0000141</td>
<td>MOV DX,#0148H</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>0000142</td>
<td>0148H code read</td>
<td>1f09fff</td>
<td>2.84uS</td>
</tr>
<tr>
<td>2</td>
<td>0000144</td>
<td>ADD DX,AX</td>
<td>1f09fff</td>
<td>2.84uS</td>
</tr>
<tr>
<td>3</td>
<td>0000146</td>
<td>JMP NEAR PTR DX</td>
<td>1f09fff</td>
<td>2.82uS</td>
</tr>
<tr>
<td>4</td>
<td>0000148</td>
<td>-INC AX</td>
<td>1f09fff</td>
<td>2.84uS</td>
</tr>
<tr>
<td></td>
<td>0000149</td>
<td>-INC DX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>000014a</td>
<td>INC AX</td>
<td>1f09fff</td>
<td>2.84uS</td>
</tr>
<tr>
<td></td>
<td>000014b</td>
<td>INC CX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>000014c</td>
<td>INC CX</td>
<td>1f09fff</td>
<td>2.82uS</td>
</tr>
<tr>
<td></td>
<td>000014d</td>
<td>JMP 000014bH</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>000014e</td>
<td>ADD DH,CH</td>
<td>1f09fff</td>
<td>2.84uS</td>
</tr>
<tr>
<td>8</td>
<td>000014f</td>
<td>-ADD [BX][SI],AL</td>
<td>1f09fff</td>
<td>2.84uS</td>
</tr>
<tr>
<td>9</td>
<td>0000150</td>
<td>-ADD no operand</td>
<td>1f09fff</td>
<td>2.82uS</td>
</tr>
<tr>
<td>10</td>
<td>0000151</td>
<td>-INC CX</td>
<td>1f09fff</td>
<td>2.84uS</td>
</tr>
</tbody>
</table>

Note that the disassembler had no choice but to assume that the jump was to address 148 in the above trace (the first byte fetched). By enabling Execution Trace Messages, the disassembler can produce the following trace list:

<table>
<thead>
<tr>
<th>Line</th>
<th>addr,H</th>
<th>80386 Mnemonic</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0000140</td>
<td>INC AX</td>
</tr>
<tr>
<td></td>
<td>0000141</td>
<td>MOV DX,#0148H</td>
</tr>
<tr>
<td>1</td>
<td>0000140</td>
<td>branch trace msg, dest=000000140H</td>
</tr>
<tr>
<td>2</td>
<td>0000142</td>
<td>0148H code read</td>
</tr>
<tr>
<td>3</td>
<td>0000144</td>
<td>ADD DX,AX</td>
</tr>
<tr>
<td>4</td>
<td>0000146</td>
<td>JMP NEAR PTR DX</td>
</tr>
<tr>
<td>5</td>
<td>0000148</td>
<td>-INC AX</td>
</tr>
<tr>
<td></td>
<td>0000149</td>
<td>-INC DX</td>
</tr>
<tr>
<td>6</td>
<td>000014a</td>
<td>INC AX</td>
</tr>
<tr>
<td></td>
<td>000014b</td>
<td>-JMP 0000014bH</td>
</tr>
<tr>
<td>7</td>
<td>000014d</td>
<td>-ADD [BX][SI],AL</td>
</tr>
<tr>
<td>8</td>
<td>000014f</td>
<td>-INC AX</td>
</tr>
<tr>
<td>9</td>
<td>000014g</td>
<td>branch trace msg, dest=000000149H</td>
</tr>
<tr>
<td>10</td>
<td>000014a</td>
<td>INC CX</td>
</tr>
</tbody>
</table>

In this listing, the "branch trace message" shows that the indirect jump went to address 149. Note that the instruction at address 148 is an unused prefetch, accurately marked by the leading dash. (By reading this trace list, you can see that register AX must have been equal to '0' on entry to this routine.)
Using Execution Trace Messages to observe program flow

If you enable Execution Trace Messages, and then store only cycles with the 'btmsg' status, you can obtain a concise trace showing the exact "flow" of your program. Only branches that are taken will appear, so you can observe calls to your functions, returns from them, "if" statements executed, and the number of times loops are executed. Since only the branches are stored, you can keep a record of program activity for a very long time before filling all of your analysis memory.
Understanding Address, Data, and Status

The Intel80386EX has a 16-bit data bus but allows the program to access data contents in 8-bit and 16-bit physical accesses. It can be difficult to know how to define a specification for the external bus on the Intel80386EX when you want to perform a trace. The following information will help you decide what to put in the A:D:S: fields of the analyzer in order to trigger, store, or sequence the analyzer to capture desired information.

Code fetches

If your hardware asserts BS8# low, or the chip-select unit has programmed a range to be BS8, the processor will do two fetches. For example, if an instruction was at address 4000, the processor would normally do a 16-bit read from address 4000. When BS8# is asserted, it will do an 8-bit read from address 4000, and another 8-bit read from address 4001. This makes it difficult to specify an address for instruction fetches. In fact, bit 0 of any instruction address must be "don’t care". This must be specified in binary. Otherwise, all four lower bits will be "don’t cares".

There are two cases where the emulator has been designed to know you want to "don’t care" bit 0:

- When you specify an address and use the status "memif", the analyzer will "don’t care" address bit 0.
- When you specify an address with a symbol, and that symbol is in a code segment, the address will be "don’t cared" correctly. If you do not wish this to happen, use "<symbol>+0".

Example:

If address 5 contains an opcode, the analyzer must trigger on 010x binary. If this was entered as "A: 5 S: memif", the correct trigger specification will be entered automatically. If address 5 was the symbol "START", simply using the symbol will also automatically generate the address pattern 010x instead of 0101. If this was entered as "START+0", the trigger address pattern will be 0101.
Data read/write

Data values are 16-bit values (because the data bus is 16 bits wide). To identify byte values on the data bus, use "don't cares" (x) as shown below:

- Data at multiple of 2 (e.g. 0, 2, 4): 0xx12
- Data at multiple of 2 + 1 (e.g. 1, 3, 5): 034xx

For example, to specify a write to address byte 4031 with value 23:

Address: 4031 Data: 023xx Status: write

Status values identify the types of Intel®80386EX bus cycles. Status values may be ANDed together by selecting two or more in the Trace Pattern Dialog Box, accessible via the Trace→Edit... dialog box and the Trace→Sequence... dialog box. For example, to trigger on the occurrence of a data read immediately following a HOLD cycle, select hlda, memrd, and data together.

If you need a combination of status values not available in the predefined list, you may compose a binary value on bits 31 - 16 from the following information:

<table>
<thead>
<tr>
<th>Status Bits 31 - 16</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>xxxx xxxx xxxx xxxx0</td>
<td>0 = monitor cycle. See Note 1 below.</td>
</tr>
<tr>
<td>xxxx xxxx xxxx xx1x</td>
<td>1 = write. 0 = read.</td>
</tr>
<tr>
<td>xxxx xxxx xxxx x1xx</td>
<td>1 = data. 0 = code.</td>
</tr>
<tr>
<td>xxxx xxxx xxxx 1xxx</td>
<td>1 = memory. 0 = data.</td>
</tr>
<tr>
<td>xxxx xxxx xxxx xx0x</td>
<td>0 = Byte Low Enable (bits 7..0) active.</td>
</tr>
<tr>
<td>xxxx xxxx xxxx x0xx</td>
<td>0 = Byte High Enable (bits 15..8) active.</td>
</tr>
<tr>
<td>xxxx xxxx x0xx xxxx</td>
<td>0 = UCS pin active.</td>
</tr>
<tr>
<td>xxxx xxxx 0xxx xxxx</td>
<td>0 = READY pin active.</td>
</tr>
<tr>
<td>xxxx xxxx0 xxxx xxxx</td>
<td>0 = Bus Size 8-pin active.</td>
</tr>
<tr>
<td>xxxx xx0x xxxx xxxx</td>
<td>0 = NA pin (pipelining) active.</td>
</tr>
<tr>
<td>xxxx x0xx xxxx xxxx</td>
<td>0 = Interrupt acknowledge active.</td>
</tr>
<tr>
<td>xxxx 1xxx xxxx xxxx</td>
<td>1 = SMIACT pin active.</td>
</tr>
<tr>
<td>xx0x xxxx xxxx xxxx</td>
<td>0 = HLDA pin active.</td>
</tr>
<tr>
<td>xx0x xxxx xxxx xxxx</td>
<td>0 = branch or task trace message active.</td>
</tr>
<tr>
<td>x1xx xxxx xxxx xxxx</td>
<td>1 = NMI pin active.</td>
</tr>
<tr>
<td>1xxx xxxx xxxx xxxx</td>
<td>1 = refresh cycle active.</td>
</tr>
</tbody>
</table>

Note 1: Also controls cycle type in the Settings→Extended→Trace menu.
Entering Addresses as Constants

This chapter contains information about entering addresses as constants (instead of using symbols or clicking on source lines in the source display):

- Overview of Intel80386EX address types
- Explanation: why different syntax for different address types
- Constant-Address Syntax
Overview of Intel80386EX address types

The Intel80386EX uses several different types of addresses. This section gives a brief definition of each type. For more information, see your Intel80386EX programmer’s handbook.

Physical addresses
These are the addresses actually available on the address pins of the Intel80386EX. They are used by the memory and I/O subsystems on an 80386-based system. They have 32 bits on the Intel80386DX, 26 bits on the Intel80386EX, and 24 bits on the Intel80386CX.

Linear addresses
These are the addresses used by the hardware breakpoints on the Intel80386EX, and are inputs into the paging hardware on the Intel80386EX. They have 32 bits.

Virtual addresses
These are the addresses as seen by the programmer. There are three types of virtual addresses: real-mode, protected-mode, and virtual 8086-mode.

Real-mode These addresses have a 16-bit segment and a 16-bit offset. The linear address is calculated as: (segment * 16) + offset. After RESET, the processor is in ‘real mode’. In this mode, physical addresses are the same as linear addresses.

Protected-mode These addresses have a 32-bit selector and a 16-bit or 32-bit offset. The linear address is calculated by using 13 bits of the selector as an index into the GDT (Global Descriptor Table), reading a base address from that entry in the GDT, and adding the offset.

Virtual 8086-mode These addresses have a 16-bit segment and a 16-bit offset. The linear address is calculated as: (segment * 16) + offset. In this mode, paging can be used so the physical address is not necessarily the same as the linear address.
Explanation: why different syntax for different address types

There are several reasons why this emulator differentiates between real-mode addresses and protected-mode addresses:

- To reduce the use of the monitor when doing dynamic translations. Real-mode addresses do not need to traverse any tables, but protected-mode addresses do.

- To allow the use of protected-mode addresses while the processor is still in real mode (e.g. it is reset). This is generally used to set up breakpoints or to set up a trace.

- To allow clear display of real-mode addresses versus protected-mode addresses.
Constant-address syntax

**Physical addresses**

offset  
offset is a 32-bit value.

**Real-mode addresses**

segment:offset  
Segment is a 16-bit value, and offset is a 16-bit value. The linear address is calculated as: (64 * segment) + offset

**Protected-mode addresses, GDT only**

selector::offset  
Offset is 16 or 32 bits; selector is an entry into the GDT (current or cached)

**Protected-mode addresses, GDT and LDT specified**

selector:ldt:offset  
Offset is 16 or 32 bits; selector is an entry into the GDT (current or cached) which points to an LDT; ldt is the entry in that LDT.

All 16 and 32-bit values are entered as numeric constants.

**Protected-mode addresses, LDT only specified**

selector::offset  
Offset is 16 or 32 bits; selector is an entry into an LDT (bit 2 is set). If this form is used, the current LDTR is assumed to point into the correct LDT; ldt is the entry in that LDT.

**See Also**

"Understanding Incompletely Specified LDT Addresses," next in this chapter.

"Selecting how Address Translations work" in the "Configuring the Emulator" chapter.
Understanding Incompletely Specified LDT Addresses

Some generators of OMF format files do not provide enough debug information in the file to completely locate symbols that are in a Local Descriptor Table (LDT).

To completely locate a symbol’s address, the OMF generator must supply the Global Descriptor Table (GDT) entry of the LDT, the offset of the selector in the LDT, and the offset of the symbol from the selector’s base. Many OMF generators provide only the LDT and the offset.

When the emulator’s RTC interface sees an incompletely specified LDT address, it uses the current LDT. If the current LDT is the correct LDT for the symbol, there is no problem. If, however, the current LDT is not the one related to the symbol, you may have severe problems because the physical address is not related to the symbol at all.

In the symbol window, you can identify the symbols that have incompletely specified LDT addresses. They look like this:

<symbol> <LDT>::<OFFSET>

Be very careful when using such symbols.

Remember that an LDT has bit 2 set, whereas the GDT has bit 2 cleared. Therefore, in the following example, the symbol named HELLO is a fully-qualified LDT symbol, GOODBYTE is a fully-qualified GDT symbol, and YOUSAY is an LDT symbol where the current LDT will be assumed:

HELLO 28:14:30
GOODBYTE 30:5
YOUSAY 14:5
Unexpected Stepping Behavior

The emulator uses the single-step trap feature of the i83086 processor to single step instructions. A single-step trap happens when:

- The TF flag in the EFLAGS register is set.
- An instruction is executed with the TF flag set.

Faults

If an instruction causes a fault, the flags register is saved on the stack and the TF flag is cleared before the fault handler is executed. Unless the fault handler restores the value of the TF flag saved on the stack, the entire fault handler will be executed without generating a single-step trap.

For example, if a floating-point instruction is executed on a system that does not have an i80387 floating-point coprocessor, an instruction fault will be generated. This type of fault is typically fielded by a floating-point emulation library which processes the exception stack frame, decodes and emulates the floating-point instruction, modifies the return address on the stack to point to the next instruction, and returns from the fault handler. However, because no instructions were executed with the trap flag set, the processor does not generate a single-step trap. The processor will continue to execute floating-point instructions until the first normal instruction is executed.

This does not occur when floating-point instructions are executed on an i80387 coprocessor. Floating-point emulation libraries could be implemented to generate a single-step trap upon return by restoring the TF flag from the stack immediately prior to executing the IRET/IRETD instruction.
INT instructions

Like an instruction fault, the TF flag is saved on the stack and then cleared prior to execution of the first instruction in the interrupt handler. Therefore, on returning from the INT instruction, the processor will execute the next instruction, and then generate the single-step fault (assuming the next instruction is not another INT, fault, etc.).

Task gates

If the instruction is a task gate, the EFLAGS register is saved in the old TSS and the TF flag is restored from the new TSS prior to execution of the first instruction of the new task. Therefore, the entire task will be executed before the single-step trap occurs.

To step into a task or a fault handler

First, set a breakpoint in the routine you want to step into. Then do a "run" command. If you do a step as you go into the INT routine or the fault handler, the TF flag will be restored when you return from the INT routine or fault handler routine. This means that if you do a RUN while in the routine, you will enter the monitor on the instruction after the routine returns.
Part 5

Installation Guide

Instructions for installing the product.
Installing the Debugger
Installing the Debugger

This chapter shows you how to install the Real-Time C Debugger.

- Requirements
- Before Installing the Debugger
- Step 1. Connect the HP 64700 to the PC
- Step 2. Install the debugger software
- Step 3. Start the debugger
- Step 4. Check the HP 64700 system firmware version
- Optimizing PC Performance for the Debugger
Requirements

- IBM compatible or NEC PC with an 80486 microprocessor and 8 megabytes of memory.
- MS Windows 3.1, set up with 20 megabytes of swap space.
- VGA Display.
- 3 Megabytes available disk space.
- Serial port, HP 64037 RS-422 port, or Novell LAN with Lan Workplace for DOS or Microsoft Lan Manager with HP ARPA Services.
- Revision A.04.00 or greater of HP 64700 system firmware. The last step in this chapter shows you how to check the firmware version number.
Before Installing the Debugger

- Install MS Windows according to its installation manual. The Real-Time C Debugger must run under MS Windows in the 386 enhanced mode.

  To ensure your PC is running in the 386 Enhanced Mode, double-click the PIF Editor in the Main or Accessories window. Choose the Mode pulldown in the PIF Editor menu bar. A check mark should be beside "386 Enhanced" in the Mode pulldown.

- If the HP 64700 is to communicate with the PC via LAN:

  Make sure the HP 64700 LAN interface is installed (see the "HP 64700 Series Installation/Service" manual).

  Install the LAN card into the PC, and install the required PC networking software.

  Obtain the Internet Address, the Gateway Address, and the Subnet Mask to be used for the HP 64700 from your Network Administrator. These three addresses are entered in integer dot notation (for example, 192.35.12.6).

- If the HP 64700 is to communicate with the PC via RS-422:

  Install the HP 64037 RS-422 interface card into the PC. The Real-Time C Debugger includes software that configures the RS-422 interface.
Step 1. Connect the HP 64700 to the PC

You can connect the HP 64700 to an RS-232 serial port on the PC, the Local Area Network that the PC is on, or an HP 64037 RS-422 interface that has been installed in the PC.

- To connect via RS-232
- To connect via LAN
- To connect via RS-422

To connect via RS-232

1. Set the HP 64700 configuration switches for RS-232C communication. Locate the COMM CONFIG switches on the HP 64700 rear panel, and set them as shown below.

![COMM CONFIG Switches](image)

Notice that switches 1 through 3 are set to 001, respectively. This sets the baud rate to 19200.

Notice also that switches 12 and 13 are set to 1 and 0, respectively. This sets the RTS/CTS hardware handshake which is needed to make sure all characters are processed.
2 Connect an RS-232C modem cable from the PC to the HP 64700 (for example, an HP 24542M 9-pin to 25-pin cable or an HP 13242N 25-pin to 25-pin cable).

If you want to build your own RS-232 cable, follow one of the pin-outs for HP cables shown in the following figure.

You can also use an RS-232C printer cable, but you must set HP 64700 configuration switch 4 to 1.

3 Turn ON power to the HP 64700.

The power switch is located on the lower left-hand corner of the front panel. The power lamp at the lower right-hand corner of the front panel will light.
4 Start MS Windows in the 386 enhanced mode.

5 Verify RS-232 communication by using the Terminal program that is found in the Windows "Accessories" group box.

Double-click on the "Terminal" icon to open the Terminal window. Then, choose the Settings→Communications... (ALT, S, C) command, and select: 19200 Baud Rate, 8 Data Bits, 1 Stop Bit, Parity None, Hardware Flow Control, and the PC's RS-232 interface connector. Choose the OK button.

You should now be able to press the Enter key in the Terminal window to see the HP 64700's Terminal Interface prompt (for example, "R>", "M>", or "U>"). The "->" prompt indicates the present firmware does not match the emulator probe, or there is no probe connected. If you see the prompt, you have verified RS-232 communication. If you do not see the prompt, refer to "If you cannot verify RS-232 communication".

If you will be using the RS-232 connection for the debugger, exit the Terminal program and go to "Step 2. Install the debugger software".

If you will be using the LAN connection, go to "To connect via LAN".
To connect via LAN

1 Set the HP 64700 LAN parameters.

If you're setting the HP 64700 LAN parameters for the first time, you must connect the HP 64700 to the PC via RS-232 before you can access the HP 64700 Terminal Interface. Follow the steps in "To connect via RS-232" and then return here.

If you're changing the LAN parameters of an HP 64700 that is already on the LAN, you can use the "telnet <HP 64700 IP address>" command to access the HP 64700 Terminal Interface.

Once the HP 64700 Terminal Interface has been accessed, display the current LAN parameters by entering the "lan" command:

R> lan
lan -i 15.6.25.117
lan -g 15.6.24.1
lan -s 255.255.248.0 <-- HP 64700A ONLY
lan -p 6470
Ethernet Address : 08000909BBC1

The "lan -i" line shows the Internet Address (or IP address). The Internet Address must be obtained from your Network Administrator. The value is entered in integer dot notation. For example, 192.35.12.6 is an Internet Address. You can change the Internet Address with the "lan -i <new IP>" command.

The "lan -g" line shows the Gateway Address which is also an Internet address and is entered in integer dot notation. This entry is optional and will default to 0.0.0.0, meaning all connections are to be made on the local network or subnet. If connections are to be made to workstations on other networks or subnets, this address must be set to the address of the gateway machine. The gateway address must be obtained from your Network Administrator. You can change the Gateway Address with the "lan -g <new gateway address>" command.

The "lan -s" line will be shown if you are using the HP 64700A, and will not be shown if you are using the HP 64700B. If this line is not shown, the Subnet Mask is automatically configured. If this line is shown, it shows the Subnet Mask in integer dot notation. This entry is optional and will default to 0.0.0.0. The default is valid only on networks that are not subnetted. (A network is
subnetted if the host portion of the Internet address is further partitioned into a subnet portion and a host portion.) If the network is subnetted, a subnet mask is required in order for the emulator to work correctly. The subnet mask should be set to all "1"s in the bits that correspond to the network and subnet portions of the Internet address and all "0"s for the host portion. The subnet mask must be obtained from your Network Administrator. You can change the Subnet Mask with the "lan -s <new subnet mask>" command.

Both the PC’s subnet mask and the emulator’s subnet mask must be identical unless they communicate via a gateway or a bridge. Unless your Network Administrator states otherwise, make them the same. You can check the PC’s subnet mask with the "lminst" command if you are using HP-ARPA. If you are using Novell LAN WorkPlace, make sure the file \NET.CFG has the entry "ip_netmask <subnet mask>" in the section "Protocol TCPIP".

The "lan -p" line shows the base TCP service port number. The host computer interfaces communicate with the HP 64700 through two TCP service ports. The default base port number is 6470. The second port has the next higher number (default 6471). If the service port is not 6470, you must change it with the "lan -p 6470" command.

The Internet Address and any other LAN parameters you change are stored in nonvolatile memory and will take effect the next time the HP 64700 is powered off and back on again.

2 Exit the Terminal or telnet program.

3 Turn OFF power to the HP 64700.

4 Connect the HP 64700 to the LAN. This connection can be made using either the 15-pin AUI connector or the BNC connector.

DO NOT use both connectors. The LAN interface will not work with both connected at the same time.
5 Set the HP 64700 configuration switches for LAN communication.

Switch 16 must be set to one (1) indicating that a LAN connection is being made.

Switch 15 should be zero (0) if you are connecting to the BNC connector or set to one (1) if a 15 pin AUI connection is made.

Switch 14 should be zero (0).

Set all other switches to zero (0).
6 Turn ON power to HP 64700.

7 Verify LAN communication by using a "telnet <HP 64700 IP address>" command. This connection will give you access to the HP 64700 Terminal Interface.

You should now be able to press the Enter key in the telnet window to see the HP 64700's Terminal Interface prompt (for example, "R>", "M>", "U>", etc.). If you see the prompt, you have verified LAN communication. If you cannot connect to the HP 64700's IP address, refer to "If you cannot verify LAN communication".
To connect via RS-422

Before you can connect the HP 64700 to the PC via RS-422, the HP 64037 RS-422 Interface must have already been installed into the PC.

1 Set the HP 64700 configuration switches for RS-422 communication. Locate the COMM CONFIG switches on the HP 64700 rear panel, and set them as shown below.

Notice that switches 1 through 3 are set to 111, respectively. This sets the baud rate to 230400.

Notice that switch 5 is set to 1. This configures the 25-pin port for RS-422 communication.

Notice also that switches 12 and 13 are set to 1 and 0, respectively. This sets the RTS/CTS hardware handshake which is needed to make sure all characters are processed.

2 Connect the 17355M cable (which comes with the HP 64037 interface) from the PC to the HP 64700.

3 Turn ON power to the HP 64700.

The power switch is located on the lower left-hand corner of the front panel. The power lamp at the lower right-hand corner of the front panel will light.
If you cannot verify RS-232 communication

If the HP 64700 Terminal Interface prompt does not appear in the Terminal window:

- Make sure that you have connected the emulator to the proper power source and that the power light is lit.

- Make sure that you have properly configured the data communications switches on the emulator and the data communications parameters on your controlling device. You should also verify that you are using the correct cable.

The most common type of data communications configuration problem involves the configuration of the HP 64700 as a DCE or DTE device and the selection of the RS-232 cable. If you are using the wrong type of cable for the device selected, no prompt will be displayed.

When the RS-232 port is configured as a DCE device (S4 is set to 0), a modem cable should be used to connect the HP 64700 to the host computer of terminal. Pins 2 and 3 at one end of a modem cable are tied to pins 2 and 3 at the other end of the cable.

When the RS-232 port is configured as a DTE device (S4 is set to 1), a printer cable should be used to connect the HP 64700 to the host computer of terminal. Pins 2 and 3 at one end of a printer cable are swapped and tied to pins 3 and 2, respectively, at the other end of the cable.

If you suspect that you may have the wrong type of cable, try changing the S4 setting and turning power to the HP 64700 OFF and then ON again.
If you cannot verify LAN communication

Use the "telnet" command on the host computer to verify LAN communication. After powering up the HP 64700, it takes a minute before the HP 64700 can be recognized on the network. After a minute, try the "telnet <internet address>" command.

- If "telnet" does not make the connection:
  
  - Make sure that you have connected the emulator to the proper power source and that the power light is lit.
  
  - Make sure that the LAN cable is connected. Refer to your LAN documentation for testing connectivity.
  
  - Make sure the HP 64700 rear panel communication configuration switches are set correctly. Switch settings are only used to set communication parameters in the HP 64700 when power is turned OFF and then ON.
  
  - Make sure that the HP 64700's Internet Address is set up correctly. You must use the RS-232 port to verify this that the Internet Address is set up correctly. While accessing the emulator via the RS-232 port, run performance verification on the HP 64700's LAN interface with the "lanpv" command.

- If "telnet" makes the connection, but no Terminal Interface prompt (for example, R>, M>, U>, etc.) is supplied:
  
  - It's possible that the HP 64000 software is in the process of running a command (for example, if a repetitive command was initiated from telnet in another window). You can use CTRL+c to interrupt the repetitive command and get the Terminal Interface prompt.
  
  - It's also possible for there to be a problem with the HP 64700 firmware while the LAN interface is still up and running. In this case, you must turn OFF power to the HP 64700 and turn it ON again.
Step 2. Install the debugger software

1 If you are updating or re-installing the debugger software, you may want to save your B3637B.INI file because it will be overwritten by the installation process.

2 Start MS Windows in the 386 enhanced mode.

3 Insert the Intel80386EX REAL-TIME C DEBUGGER Disk 1 of 2 into floppy disk drive A or B.

4 Choose the File→Run... (ALT, F, R) command in the Windows Program Manager. Enter "a:\setup" (or "b:\setup" if you installed the floppy disk into drive B) in the Command Line text box.

Then, choose the OK button. Follow the instructions on the screen.
You will be asked to enter the installation path. The default installation path is `C:\HPRTC\I386EX`. The default installation path is shown wherever files are discussed in this manual.

![Installation Path for HP Real-Time C](image)

You will be asked to enter your user ID. This information is important if the HP 64700 is on the LAN and may be accessed by other users. It tells other users who is currently using, or who has locked, the HP 64700. This information can be modified while using the Real-Time C Debugger by choosing the Settings→Communication... (ALT, S, C) command.

![User Identification](image)
You will be asked to select the type of connection to be made to the HP 64700. This information can be modified while using the Real-Time C Debugger by choosing the Settings→Communication... (ALT, S, C) command.

When using the HP-RS422 transport, the connection name is the I/O address you want to use for the HP 64037 card. Enter a hexadecimal number from 100H through 3F8H, ending in 0 or 8, that does not conflict with other cards in your PC.

After you have specified the type of connection, files will be copied to your hard disk. (The B3637B.TMP and B3637B.HLP files are larger than most of the other files and take longer to copy.) Fill out your registration information while waiting for the files to be copied.

If the Setup program detects that one or more of the files it needs to install are currently in use by Windows, a dialog box informs you that Windows must be restarted. You can either choose to restart Windows or not. If you don't choose to restart Windows, you can either run the _MSSETUP.BAT batch file (in the same directory that the debugger software is installed in) after you have exited Windows or reinstall the debugger software later when you are able to restart Windows.
Step 3. Start the debugger

1. If the "HP Real-Time C Debugger" group box is not opened, open it by double-clicking in the icon.

2. Double-click the "I80386EX Real-Time C Debugger" icon.

   If you have problems connecting to the HP 64700, refer to:
   - If you have RS-232 connection problems
   - If you have LAN connection problems
   - If you have RS-422 connection problems

If you have RS-232 connection problems

☐ Remember that Windows 3.1 only allows two active RS-232 connections at a time. To be warned when you violate this restriction, choose Always Warn in the Device Contention group box under 386 Enhanced in the Control Panel.

☐ Use the "Terminal" program (usually found in the Accessories windows program group) and set up the "Communications..." settings as follows:

   Baud Rate: 19200 (or whatever you have chosen for the emulator)
   Data Bits: 8
   Parity: None
   Flow Control: Hardware
   Stop Bits: 1
When you are connected, hit the Enter key. You should get a prompt back.
If nothing echos back, check the switch settings on the back of the emulator.

Switches 1 thru 3 set the baud rate as follows:

<table>
<thead>
<tr>
<th>S1</th>
<th>S2</th>
<th>S3</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>9600</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>1</td>
<td>19200</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>0</td>
<td>2400</td>
</tr>
</tbody>
</table>

Switches 12 and 13 must be set to 1 and 0, respectively. This sets the RTS/CTS hardware handshake, which is needed to make sure all characters are processed.

All other switches should be in the "0" position, especially switch 16 on the HP 64700 (which selects LAN/Serial interface).

Remember that if you change any of the switch positions, you must turn OFF power to the HP 64700 and turn it ON again before the changes will take effect.

- If the switches are in the correct position and you still do not get a prompt when you press return, check the following:
  - Turn off power to the HP 64700 and then turn it on again. Press return to see if you get a prompt.
  - Check to make sure the RS-232 cable is connected to the correct port on your PC, and that the cable is appropriate for connecting the PC to a DCE device. If the cable is intended to connect the PC to a DTE device, set switch 4 to "1" (which makes the emulator a DTE device), turn OFF power to the HP 64700, turn power ON, and try again.
  - Check to make sure your RS-232 cable has the RTS, CTS, DSR, DCD, and DTR pins supported. If your PC RS-232 connection is a 9-pin male connection, HP cable number 24542M will work (set switch 4 to 0 if you use this cable). If your PC has a 25-pin RS-232 connector, HP cable number 13242N will work (set switch 4 to 0).
• If you wish to build your own RS-232 cable, refer to "To connect via RS-232" in the paragraph titled, "Step 1. Connect the HP 64000 to the PC" earlier in this chapter.

• When using certain RS-232 cards, connecting to an RS-232 port where the HP 64700 is turned OFF (or not connected) will halt operation of the PC. The only way to restore operation is to reboot the PC. Therefore, HP recommends you always turn ON the HP 64700 before attempting to connect via RS-232.

• If RTC reports overrun errors or simply times out, RTC may be overrunning the serial interface. In this case, try the following:

  □ Stop all unnecessary TSR's and other applications to allow the processor to service the serial interface more often.

  □ Overrun errors may occur when the serial interface card is not sufficiently buffered. Check to make sure your serial interface card uses the 16550AF UART, or better. Use the DOS command, "MSD", and when the window opens, select "COM Ports..." to see the UART chip used in your serial interface card.
If you have LAN connection problems

☐ Try to "ping" the emulator:

    ping <hostname or IP address>

☐ If the emulator does not respond:

- Check that switch 16 on the emulator is "1" (emulator is attached to LAN, not RS-232 or RS-422).
- Check that switch 15 on the emulator is in the correct position for your LAN interface (either the AUI or the BNC).

Remember, if you change any switch settings on the emulator, the changes do not take effect until you turn OFF emulator power and turn it ON again.

☐ If the emulator still does not respond to a "ping," you need to verify the IP address and subnet mask of the HP 64700. To do this, connect the HP 64700 to a terminal (or to the Terminal application on the PC), change the emulator's switch settings so it is connected to RS-232, and enter the "lan" command. The output looks something like this:

    lan -i 15.6.25.117
    lan -g 15.6.24.1
    lan -s 255.255.248.0
    lan -p 6470
    Ethernet Address : 08000909BBC1

The important outputs (as far as connecting) are:

"lan -i"; this shows the internet address is 15.6.25.117 in this case. If the Internet address (IP) is not what you expect, you can change it with the 'lan -i <new IP>' command.

"lan -s"; shows the subnet mask is 255.255.248 (the upper 21 bits -- 255.255.248.0 == FF.FF.F8.0). If the subnet mask is not what you expect, you can change it with the 'lan -s <new subnet mask>' command.

"lan -p"; shows the port is 6470. If the port is not 6470, you must change it with the "lan -p 6470" command.

Both the PC's subnet mask and the emulator's subnet mask must be identical unless they communicate via a gateway or a bridge. Unless your Network...
Administrator states otherwise, make them the same. If you are using HP-ARPA, you can check the PC's subnet mask with the "lminst" command in a DOS window. If you are using Novell LAN WorkPlace, make sure the file \NET.CFG has the entry "ip_netmask <subnet mask>" in the section "Protocol TCP/IP." If you are using Windows for Workgroups, you can check the PC's subnet mask by looking in the [TCPIP] section of the PROTOCOL.INI file or by looking in the Microsoft TCP/IP Configuration dialog box. If you are using WINSOCK, refer to your LAN software documentation for subnet mask information.

Occasionally the emulator or the PC will "lock up" the LAN due to excessive network traffic. If this happens, all you can do is turn OFF power to the HP 64700 or PC and turn it back ON, again. If this happens two frequently, you can try placing a gateway between the emulator/PC and the rest of your network.

---

If you have LAN DLL errors

The various LAN transport selections require the following DLLs:

- HP-ARPA: WSOCKETS.DLL
- Novell-WP: WLIBSOCK.DLL
- W4WG-TCP: WSOCKETS.DLL (Windows for Workgroups)
- WINSOCK1.1: WINSOCK.DLL

These DLLs are included with LAN software. The required DLL must be in your search path. This will be the case if your network software is installed.
If you have RS-422 connection problems

- Make sure the HP 64700 switch settings match the baud rate chosen when attempting the connection.

Switches 1 thru 3 set the baud rate as follows:

<table>
<thead>
<tr>
<th>S1</th>
<th>S2</th>
<th>S3</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>230400</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>115200</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>38400</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>0</td>
<td>57600</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1200</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>0</td>
<td>2400</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>1</td>
<td>19200</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>9600</td>
</tr>
</tbody>
</table>

Switch 5 must be set to 1 to configure the HP 64700 for RS-422 communication.

Switches 12 and 13 must be set to 1 and 0, respectively. This sets the RTS/CTS hardware handshake, which is needed to make sure all characters are processed.

All other switches should be in the "0" position, especially the switch that determines LAN/Serial interface (switch 16 on HP 64700).

Remember that if you change any of the switch positions, you must turn OFF power to the HP 64700 and turn it ON again before the changes will take effect.

- If the switches are in the correct position and you still do not get a prompt when you hit return, try turning OFF the power to the HP 64700 and tuning it ON again.

- If you still don't get a prompt, make sure the HP 17355M RS-422 cable is connected to the correct port on your PC.
Step 4. Check the HP 64700 system firmware version

- Choose the Help→About Debugger/Emulator... (ALT, H, D) command.

The version information under HP 64700 Series Emulation System must show A.04.00 or greater. If the version number is less than A.04.00, you must update your HP 64700 system firmware as described in the Installing/Updating HP 64700 Firmware chapter.
Optimizing PC Performance for the Debugger

The Real-Time C Debugger is a memory and I/O intensive Windows program. Slow user interface performance may be caused by many things:

- Underpowered PC -- The Real-Time C Debugger requires an IBM compatible or NEC PC with an 80486 class microprocessor, 8 megabytes of memory, and 20 megabytes of MS Windows swap space. Because RAM is faster than swap, performance is best when there is enough RAM to accommodate all of the Real-Time C Debugger's memory usage (which is directly related to the size of your programs and the amount of debug information in them).

- Improperly configured PC -- Windows configuration may have a very significant effect on performance. The Windows swap file settings are very important (see the Virtual Memory dialog box under 386 Enhanced in the Control Panel). The larger the swap file, the better the performance. Permanent swap has superior performance.

- Disk performance (due to Windows swap file access and Windows dialog and string resource accesses from the debugger "EXE" file) -- The disk speed has a direct impact on performance of the Real-Time C Debugger. Use of SMARTDrive or other RAM disk or caching software will improve the performance.

Various PC performance measurement and tuning tools are commercially available. Optimizing your PC performance will improve debugger interface performance and, of course, all your other PC applications will benefit as well.
Installing/Updating HP 64700 Firmware
Installing/Updating HP 64700 Firmware

This chapter shows you how to install or update HP 64700 firmware.

**Note**

If you are using an HP 64700A, it must contain the optional Flash EPROM memory card before you can install or update HP 64700 system firmware. Flash EPROM memory is standard in the HP 64700B card cage.

The firmware, and the program that downloads it into the HP 64700, are included with the debugger on floppy disks labeled HP 64700 EMUL/ANLY FIRMWARE.

The steps to install or update HP 64700 firmware are:

- Step 1. Connect the HP 64700 to your PC
- Step 2. Install the firmware update utility
- Step 3. Run PROGFLASH to update HP 64700 firmware
- Step 4. Verify emulator performance
Step 1. Connect the HP 64700 to the PC

1 Set the COMM CONFIG switches for RS-232C communication. To do this, locate the DIP switches on the HP 64700 rear panel, and set them as shown below.

![Comm Config Switches](image)

Notice that switches 12 and 13 are set to 1 and 0, respectively. This sets the RTS/CTS hardware handshake, which is needed to make sure all characters are processed. Switches 1, 2, and 3 are set to 0. This sets the baud rate to 9600. Switch settings are read during the HP 64700 power up routine.

2 Connect an RS-232C modem cable from the PC to the HP 64700 (for example, an HP 24542M 9-pin to 25-pin cable or an HP 13242N 25-pin to 25-pin cable).

You can also use an RS-232C printer cable, but if you do, you MUST set COMM CONFIG switch 4 to 1.

3 Turn ON power to the HP 64700.

The power switch is located on the lower left-hand corner of the front panel. The power lamp at the lower right-hand corner of the front panel will light.
4 Start MS Windows in the 386 enhanced mode.

To ensure your PC is running in the 386 Enhanced Mode, double-click the PIF Editor in the Main or Accessories window. Choose the Mode pulldown in the PIF Editor menu bar. A check mark should be beside "386 Enhanced" in the Mode pulldown.

5 Verify RS-232 communication by using the Terminal program that is found in the Windows "Accessories" group box.

Double-click on the "Terminal" icon to open the Terminal window. Then, choose the Settings→Communications... (ALT, S, C) command, and select: 9600 Baud Rate, 8 Data Bits, 1 Stop Bit, Parity None, Hardware Flow Control, and the PC's RS-232 interface connector to which the RS-232 cable is attached (example: COM1). Choose the OK button.

You should now be able to press the Enter key in the Terminal window to see the HP 64700's Terminal Interface prompt (for example, p>, R>, M>, and U>). A -> prompt indicates the present firmware does not match the emulator probe, or there is no probe connected). If you see the prompt, you have verified RS-232 communication. If you do not see the prompt, refer to "If you cannot verify RS-232 communication" in Chapter 14.

6 Exit the Terminal window.
Step 2. Install the firmware update utility

The firmware update utility and emulation and analysis firmware require about 1.5 Mbytes of disk space.

1 Start MS Windows in the 386 enhanced mode.

2 Insert the HP 64700 EMUL/ANLY FIRMWARE Disk 1 of 2 into floppy disk drive A or B.

3 Choose the File→Run... (ALT, F, R) command in the Windows Program Manager. Enter "a:\setup" (or "b:\setup" if you installed the floppy disk into drive B) in the Command Line text box.

Then, choose the OK button. Follow the instructions on the screen.

You will be asked to enter the installation path. The default installation path is C:\HP64700.
Wait until the Setup Exit Message dialog box appears. This indicates installation of the firmware update utility is complete.

4 After completing the installation, use the editor of your choice and edit the C:\CONFIG.SYS file to include these lines:

```
BREAK=ON
FILES=20
```

BREAK=ON allows the system to check for two break conditions: CTRL+Break, and CTRL+c.

FILES=20 allows 20 files to be accessed concurrently. This number must be at LEAST 20 to allow the firmware update utility to operate properly.

5 If you installed the files in a path other than the default (C:\HP64700), edit the C:\AUTOEXEC.BAT and C:\HP64700\BIN\FLASH.BAT files as follows:

- Edit AUTOEXEC.BAT to set the HP64700 and HPTABLES environment variables. For example:

  ```
  SET HP64700=C:\<installation_path>
  SET HPTABLES=C:\<installation_path>\TABLES
  ```

- Edit FLASH.BAT to identify the location of PROGFLAS.EXE. For example:

  ```
  C:\<installation_path>\PROGFLAS.EXE
  ```

6 Edit the <installation_path>\TABLES\64700TAB file to indicate the communications connection you will use, as follows:

The default <installation_path>\TABLES\64700TAB file contains entries to establish the communications connection for COM1 and COM2. The content of this file is:

```
EMUL_COM1 unknown COM1 OFF 9600 NONE ON 1 8
EMUL_COM2 unknown COM2 OFF 9600 NONE ON 1 8
```
If you are using COM3 or COM4 port to update your firmware, you need to edit the \<installation_path>\TABLES\64700TAB file. Either add another line or modify one of the existing lines. For example:

```
EMUL_COM3 my_emul COM3 OFF 9600 NONE ON 1 8
EMUL_COM4 unknown COM4 OFF 9600 NONE ON 1 8
```

7 Ensure the Interrupt Request Line for the selected COMx port is set to its default value. To check the default value:

1. Choose Control Panel in the Main window.
2. Choose Ports in the Control Panel window.
3. Choose the COMx port you are using and click Settings....
4. Click Advanced... in the Settings for COMx dialog box.
5. Select the default value for the Interrupt Request Line in the Advanced Settings for COMx dialog box. The default settings are:

   - COM1 and COM3 = IRQ 4
   - COM2 and COM4 = IRQ 3

8 Exit Windows and reboot your PC to activate the changes made to the CONFIG.SYS and AUTOEXEC.BAT files (CTRL+ALT+DEL). Installation of the firmware update utility is now complete.
Step 3. Run PROGFLASH to update HP 64700 firmware

1 Start MS Windows in the 386 enhanced mode.

2 If the "HP 64700 Firmware Utility" group box is not opened, open it by double-clicking the icon.

3 Double-click the "PROGFLASH" icon. (You can abort the PROGFLASH command by pressing CTRL+c.)

4 Enter the number that identifies the emulator you want to update. For example, enter "1" if you want to update the emulator identified by the line, "1 emul_com1 my_emul."

5 Enter the number that identifies the product whose firmware you want to update. For example, if this product is listed as number 12, enter "12":

```
Product
  1  64782
  2  E3490
  647??
```

6 Enter "y" to enable status messages.
The PROGFLASH command downloads code from files on the host computer into Flash EPROM memory in the HP 64700. During this download, you will see messages similar to the following:

Rebooting HP64700...with init -r

Downloading flash programming code:
'/hp64700/lib/npf.X'
Checking Hardware id code...
Erasing Flash ROM
Downloading ROM code: '/hp64700/update/647???.X'
  Code start 280000H
  Code size 29ABAH
Finishing up...

Rebooting HP64700...
Flash programming SUCCEEDED

You can display firmware version information and verify the update by choosing the Help→About Debugger/Emulator... (ALT, H, D) command in the Real-Time C Debugger.
Step 4. Verify emulator performance

- Do the performance verification procedure shown in the Installation/Service/Terminal Interface User's Guide.
Glossary

Defines terms that are used in the debugger help information.

**analyzer**  An instrument that captures data on signals of interest at discreet periods. The emulation bus analyzer captures emulator bus cycle information synchronously with the processor's clock signal.

**arm condition**  A condition that enables the analyzer. The analyzer is always armed unless you set the analyzer up to be armed by a signal received on the BNC port; when you do this, you can identify the arm condition in the trace specification by selecting arm in the Condition dialog boxes.

**background memory**  A separate memory system, internal to the emulator, out of which the background monitor executes.

**background monitor program**  An emulation monitor program that executes out of background memory.

**break on trigger**  Causes emulator execution to break into the monitor when the trigger condition is found. This is known as a hardware breakpoint, and it lets you break on a wider variety of conditions than a software breakpoint (which replaces an opcode with a break instruction); however, depending on the speed of the processor, the actual break point may be several cycles after the one that caused the trigger.

**breakpoint**  An address you identify in the user program where program execution is to stop. Breakpoints let you look at the state of the target system at particular points in the program.

**break macro**  A breakpoint followed by any number of macro commands (which are the same as command file commands).

**control menu**  The menu that is accessed by clicking the control menu box in the upper left corner of a window. You can also access control menus by pressing the "ALT" and "." keys.
**count condition** Specifies whether time or the occurrences of a particular state are counted for each state in the trace buffer.

**embedded microprocessor system** The microprocessor system that the emulator plugs into.

**emulation memory** Memory provided by the emulator that can be used in place of memory in the target system.

**emulation monitor** A program, executed by the emulation microprocessor (as directed by the emulation system controller), that gives the emulator access to target system memory, microprocessor registers, and other target system resources.

**emulator** An instrument that performs just like the microprocessor it replaces, but at the same time, it gives you information about the operation of the processor. An emulator gives you control over target system execution and allows you to view or modify the contents of processor registers, target system memory, and I/O resources.

**enable condition** Specifies the first condition in a two-step sequential trigger condition.

**enable store condition** Specifies which states get stored in the trace buffer while the analyzer searches for the enable condition.

**foreground memory** The memory system out of which user programs execute. Foreground memory is made up of emulation memory and target system memory.

**foreground monitor program** An emulation monitor program that executes out of the same memory system as user programs. This memory system is known as foreground memory and is made up of emulation memory and target system memory. The emulator only allows foreground monitor programs in emulation memory.

**guarded memory** Memory locations that should not be accessed by user programs. These locations are specified when mapping memory. If the user program accesses a location mapped as guarded memory, emulator execution breaks into the monitor.
**macro**  Refers to a break macro, which is a breakpoint followed by any number of macro commands (which are the same as command file commands).

**monitor**  A program, executed by the emulation microprocessor (as directed by the emulation system controller), that gives the emulator access to target system memory, microprocessor registers, and other target system resources.

**object file**  An Intel OMF format absolute file that can be loaded into emulation or target system memory and executed by the debugger.

**pop-up menu**  A menu that is accessed by clicking the right mouse button in a window.

**prestore condition**  Specifies the states that may be stored before each normally stored state. Up to two states may be prestored for each normally stored state.

**primary branch condition**  Specifies a condition that causes the analyzer to begin searching at another level.

**restart condition**  Specifies the condition that restarts the two-step sequential trigger. In other words, if the restart condition occurs while the analyzer is searching for the trigger condition, the analyzer starts looking for the enable condition again.

**secondary branch condition**  Specifies a condition that causes the analyzer to begin searching at another level. If a state satisfies both the primary and secondary branch conditions, the primary branch will be taken.

**sequence levels**  Levels in the analyzer that let you specify a complex sequential trigger condition. For each level, the analyzer searches for primary and secondary branch conditions. You can specify a different store condition for each level. The Page button toggles the display between sequence levels 1 through 4 and sequence levels 5 through 8.

**state qualifier**  A combination of address, data, and status values that identifies particular states captured by the analyzer.

**status values**  Values that identify the types of microprocessor bus cycles recognized by the analyzer. You can include status values (along with
address and data values) when specifying trigger and store conditions. The status values defined for the Intel80386EX emulator are listed under "Predefined Status Values" at the end of Chapter 13, "Concepts."

**store condition** Specifies which states get stored in the trace buffer.

In the "Find Then Trigger" trace set up, the store condition specifies the states that get stored after the trigger.

In the "Sequence" trace set up, each sequence level has a store condition that specifies the states that get stored while looking for the primary or secondary branch conditions.

**target system** The microprocessor system that the emulator plugs into.

**trace state** The information captured by the analyzer on a particular microprocessor bus cycle.

**transfer address** The program's starting address defined by the software development tools and included with the symbolic information in the object file.

**trigger** The captured analyzer state about which other captured states are stored. The trigger state specifies when the trace measurement is taken.

**trigger condition** Specifies the condition that causes states to be stored in the trace buffer.

**trigger position** Specifies whether the state that triggered the analyzer appear at the start, center, or end of the trace buffer. In other words, the trigger position specifies whether states are stored after, about, or before the trigger.

**trigger store condition** Specifies which states get stored in the trace buffer while the analyzer searches for the trigger condition.

**watchpoint** A variable that has been placed in the WatchPoint window where its contents can be readily displayed and modified.
Index

A

A:D:S, 421-422
abort, during object file or memory load, 279
absolute count information, displaying, 130, 337
Add to Watch command, 351
address specification for tracing, 421-422
address syntax: why different for different types, 425
address translations, 264-267
  caching and performance using caching, 67
  how they work, 66-67
  mapping for demo program, 9
addresses
  incompletely specified for LDT, 427
  searching, 81, 322
  when they are translated, 66-67
analysis of Intel80386EX bus cycles, 415-420
analyzer, 469-472
  editing the trace specification, 145, 223
  halting, 128, 236
  repeating last trace, 128, 237
  setting up with "Find Then Trigger", 136, 227-230
  setting up with "Sequence", 141, 231-234
  setting up with "Trigger Store", 133, 224-226
  setup, 421-422
  trace signals, 413-414
  tracing until halt, 128, 235
arguments, function, 388
arm condition, 68, 136, 141, 238-240, 273, 469-472
arrays (C operators), 165
ASCII values in Memory window, 107, 393
assembly language instructions
  stepping multiple, 93, 192-195
  stepping single, 91, 190
Index

auto variables, 104-106
AUTOEXEC.BAT file, 463-465

B
background memory, 469-472
background monitor, 410-412
  program, 469-472
  selecting, 58, 261-263
background operation, tracing, 277-278
BackTrace window, 388
  displaying source files, 349
Bad RS-232 port name, 365
Bad RS-422 card I/O address, 365
beep, sounding from command file, 355
big endian order, 131, 340
binary values, how to enter, 161
BNC port
  driving the trigger signal, 271-272
  output trigger signal, 68
  receiving an arm condition from, 273
  receiving an arm condition input, 68
  setting up, 68
BP marker, 12, 14, 100, 198-207, 400
branch trace messages, 415-420
  enabling, 254-256
break into monitor, 96, 196
break macros, 469-472
  command summary, 152-158
  deleting, 103, 207
  listing, 100, 208-213
  preventing new, 103
  setting, 100, 201-206
break on writes to ROM, enabling or disabling, 55
Breakpoint→Delete at Cursor (ALT, B, D) command, 200
Breakpoint→Delete Macro (ALT, B, L) command, 207
Breakpoint→Edit... (ALT, B, E) command, 208-213
Breakpoint→Set at Cursor (ALT, B, S) command, 198-199
Breakpoint→Set Macro... (ALT, B, M) command, 201-206
breakpoints, 469-472
  enable, 254-256
  deleting, 14, 99, 103, 200
  disabling and enabling, 99
  enable or disable, 54
  listing, 100, 208-213
  preventing new breakpoints, 103
  setting, 12, 98, 198-199
bus cycles, 415-420
  displaying, 129
  displaying only, 336
Button window, 389
  editing, 42, 291
buttons that execute command files, creating, 42

C
C operators, 165
  caching address translation, performance of, 67
  callers (of a function), tracing, 23, 124, 217-218
chain command files, 357
Clear Breakpoint command, 350
clipboard, 31
CLK2 speeds greater than 60 MHz, 52
clock speeds greater than 60 MHz, 52
colors in the Source window, setting, 39
command files
  chain, 357
  command summary, 152-158
  comments, 359
  creating, 40, 172
  executing, 41, 175-176
  executing at startup, 33, 41
  execution, exiting, 356
  inserting wait delays, 362
  locating cursor, 322
  nesting, 357
  parameters, 175-176
  rerun, 358
  sounding beep, 355
  turning logging on or off, 173-174
  which include Terminal Interface commands, 360-361
Index

command line options, 33-34, 41
commands
  menu bar, 168
  summary, 152-158
comments in command files, 359
communications (emulator), setting up, 268-270
CONFIG.SYS file, 463-465
configurations
  emulator, 254-256
  saving and loading, 69-70
connection problems
  LAN, 453
  RS-232, 450
  RS-422, 455
Constant-Address Syntax, 423-426
Continuous Update (ALT, -, U) command, 313
control menu, 469-472
Copy→Destination... (ALT, -, P, D) command, 290
Copy→Registers (ALT, -, P, R) command, 313
Copy→Window (ALT, -, P, W) command, 289
Could not open initialization file, 365
Could not write Memory, 366
count conditions, 238-240, 469-472
count information
  displaying absolute, 130, 337
  displaying relative, 130, 337
CTRL key and double-clicks, 31
current PC in Source window, 323
cursor, locating cursor from command file, 322
cut and paste, 31

D

data column of trace list
  swap instruction bytes, 131, 340
data specification for tracing, 421-422
DCE or DTE selection and RS-232 cable, 445
debugger
  arranging icons in window, 281
  cascaded windows, 281
  exiting, 25, 34, 182
  exiting locked, 183
  installing software, 447-449
  opening windows, 282-283
debugger (continued)
  starting, 5, 33, 450-455
  startup options, 34
  tiled windows, 281
  windows, opening, 36
decimal values, how to enter, 161
deleting all breakpoints, 103
demo programs, 4
  loading, 10
  mapping memory, 7-8
  running, 13
  setting address translations, 9
DeMorgan's law, 238-240
dialog boxes
  breakpoints, 208-213
  file selection, 184
directories
  search path, 324
  source, 285
disassembler, 415-420
display fonts, changing, 6
display mode
  mixed, 78
  source only, 78
  toggling, 316-317, 335
Display→From State... (ALT -, D, F), 338
Display→Select Source... (ALT, -, D, L) command, 318
displaying state from specific byte within a state, 338
displaying trace from specified state, 338
displays of wrong LDT address space, 427
DLL errors, 454
don't care values, how to enter, 161
double-clicks and the CTRL key, 31
dynamic variables, 214-215, 344, 409
E  edit breakpoints, 208-213
  embedded microprocessor system, 469-472
  emulation memory, 469-472
    copying target system memory into, 111, 304
  emulation microprocessor, resetting, 96, 197
  emulation monitor, 469-472
  programs, 410-412
emulator, 469-472
   hardware options, setting, 51
   limitations, external DMA support, 64
emulator configuration, 50-57, 254-256
   loading, 70, 179
   saving, 69, 180
emulator probe
   plugging into the target system, 46
   unplugging from demo target system, 45
enable
   breakpoints, 254-256
   condition, 469-472
   or disable software breakpoints, 54
   store condition, 469-472
   target interrupts, 254-256
endian order, big and little, 131, 340
entering addresses as constants, 423-426
entries, searching GDT/LDT/IDT for, 309
environment variables, 80
   HP64700 , 463-465
   HPTABLES, 463-465
   PATH, 463-465
environment
   loading, 177
   saving, 178
error messages, 364
   Bad RS-232 port name, 365
   Bad RS-422 card I/O address, 365
   Could not open initialization file, 365
   Could not write Memory, 366
   Error occurred while processing Object file, 367
   general RS-232 communications error, 368
   general RS-422 communications error, 368
   HP 64700 locked by another user, 369
   HP 64700 not responding, 369
   Incorrect DLL version, 369
   Incorrect LAN Address (HP-ARPA, Windows for Workgroups), 370
   Incorrect LAN Address (Novell), 371
   Incorrect LAN Address (WINSOCK), 371
   Internal error in communications driver, 372
   Internal error in Windows, 372
error messages (continued)
  Interrupt execution (during run to caller), 372
  Interrupt execution (during step over), 373
  Interrupt execution (during step), 373
  Invalid transport name, 374
  LAN buffer pool exhausted, 374
  LAN communications error, 375
  LAN MAXSENGSIZE is too small, 375
  LAN socket error, 375
  Logical to physical address translations initially unavailable: Cannot ...., 376
  Object file format ERROR, 376
  Out of DOS Memory for LAN buffer, 377
  Out of DOS Windows timer resources, 378
  PC is out of RAM memory, 378
  physical address translation failed, 379
  Structure Access Warning!!!, 380
  Timed out during communications, 381-382
ethernet address, 440
Evaluate It command, 350
oxecution trace messages, 415-420
  enabling or disabling, 56
execution trace messages, enabling, 254-256
execution unexpected during single stepping, 428-429
Execution→Break (F4), (ALT, E, B) command, 196
Execution→Reset (ALT, E, E) command, 197
Execution→Run (F5), (ALT, E, U) command, 185
Execution→Run to Caller (ALT, E, T) command, 187
Execution→Run to Cursor (ALT, E, C) command, 186
Execution→Run... (ALT, E, R) command, 188-189
Execution→Single Step (F2), (ALT, E, N) command, 190
Execution→Step Over (F3), (ALT, E, O) command, 191
Execution→Step... (ALT, E, S) command, 192-195
exiting command file execution, 356
Expression window, 390
  clearing, 294
  displaying expressions, 295
expressions, 160
  displaying, 295
externals, displaying symbol information, 85, 326
F
fetches, instruction, 415-420
file selection dialog boxes, 184
File→Command Log→Log File Name... (ALT, F, C, N) command, 172
File→Command Log→Logging OFF (ALT, F, C, F) command, 174
File→Command Log→Logging ON (ALT, F, C, O) command, 173
File→Copy Destination... (ALT, F, P) command, 181
File→Exit (ALT, F, X) command, 182
File→Exit HW Locked (ALT, F, H) command, 183
File→Load Debug... (ALT, F, D) command, 177
File→Load Emulator Config... (ALT, F, E) command, 179
File→Load Object... (ALT, F, L) command, 170-171
File→Run Cmd File... (ALT, F, R) command, 175-176
File→Save Debug... (ALT, F, S) command, 178
File→Save Emulator Config... (ALT, F, V) command, 180
firmware update
   connecting the HP 64700 to the PC, 461-462
   installing utility, 463-465
firmware version information, 284
firmware
   ensuring performance after update, 468
   using PROGFLASH to update, 466-467
font
   changing, 38
   settings, 274
   sizing, 6
foreground memory, 469-472
foreground monitor, 410-412
   advantages and disadvantages, 410-412
   program, 469-472
   selecting, 59-60, 261-263
   traced as user, enabling or disabling, 57
foreground operation, tracing, 277-278
function arguments, 388
function keys, 32
functions
   displaying symbol information, 84, 326
   running until return, 19, 94, 187
   searching, 81, 320
   stepping over, 19, 92, 191
functions (continued)
   tracing callers, 23, 124, 217-218
   tracing execution within, 126, 219-220

G  gateway, 453
   gateway address, 440
   GDT editing, 115
   GDT to physical address translation, 66-67, 264-267
   GDT window, 395
       displaying, 114
   general RS-232 communications error, 368
   general RS-422 communications error, 368
   getting started, 4
   global assembler symbols, displaying, 87, 328
   Global Descriptor Table window, 395
   global symbols, displaying, 85, 326
   global variables, 85, 127, 326
   glossary, 469-472
   ground strap, 44
   guarded memory, 64, 257-260, 403, 469-472

H  hardware breakpoints, 198-199, 208-213
   hardware options, setting, 51
   hardware requirements, 435
   hardware, locking on exit, 183
   help for error messages, 364
   Help→About Debugger/Emulator... (ALT, H, D) command, 284
   hexadecimal values, how to enter, 161
   hostname, 268-270
   HP 64700
       connecting to the PC, 437-446
       connecting via LAN, 440
       connecting via RS-232, 437
       connecting via RS-422, 444
   HP 64700 firmware
       ensuring performance after update, 468
       using PROGFLASH to update, 466-467
   HP 64700 firmware update
       connecting the HP 64700 to the PC, 461-462
       installing utility, 463-465
   HP 64700 LAN port number, 453
   HP 64700 locked by another user, 369
Index

HP 64700 not responding, 369
HP 64700 switch settings
  LAN, 453
  RS-232, 450
  RS-422, 455
HP-ARPA LAN transport DLL, 454
HP64700 environment variable, 463-465
HPTABLES environment variable, 463-465

I

I/O locations
  displaying, 116
  editing, 117
  guarding, 248-249
  specifying, 296
I/O window, 391
  turning polling ON or OFF, 73
icons
  arranging in debugger window, 281
  for a different emulator, 34
IDT editing, 115
IDT window, 398
  displaying, 114
incompletely specified LDT addresses, 427
Incorrect DLL version, 369
Incorrect LAN Address (HP-ARPA, Windows for Workgroups), 370
Incorrect LAN Address (Novell), 371
Incorrect LAN Address (WINSOCK), 371
installation path, 447-449
instruction bytes swapped in data column, 131, 340
instruction fetches, 415-420
Internal error in communications driver, 372
Internal error in Windows, 372
internals, displaying symbol information, 86, 327
Internet Address, 268-270, 440, 446
Interrupt Descriptor Table window, 398
Interrupt execution (during run to caller), 372
Interrupt execution (during step over), 373
Interrupt execution (during step), 373
intercepts
   enabling, 254-256
   enabling or disabling from target system, 53
   target system, 410-412
intererset operators, 238-240
intraset operators, 238-240
intrusion, monitor, 72, 246-247
Invalid transport name, 374
inverse assembly with 16- or 32-bit segments assumed, 338
IP address, 453
labels, 162-164
LAN buffer pool exhausted, 374
LAN cards, 435-436
LAN communication, 268-270, 450-455
LAN communications error, 375
LAN connection problems, 453
LAN MAXSENDSIZE is too small, 375
LAN socket error, 375
LAN, connecting HP 64700, 440
LBG flying lead, connecting, 47
LDT addresses incompletely specified, 427
LDT editing, 115
LDT to physical address translations, 66-67, 264-267
LDT window, 397
   displaying, 114
levels, trace sequence, 141, 145, 231-234, 245
limitations, Symbol window, 406
line (source file), running until, 20, 94, 186
line numbers missing in Source window, 39
linear address: definition, 424
link level address, 440
link level address, 440
list file
   changing the destination, 37
   copying window contents to, 37
listing files, specifying, 181, 290
little endian order, 131, 340
loading file error, 366
local assembler symbols, displaying, 87, 328
Local Descriptor Table window, 397
local symbols, displaying, 86, 327
local variables, 86-87, 327
Index

lock hardware on exit, 183
log (command) files, 40, 172-176
logical operators, 136, 141, 238-240
logical to physical address translations, 264-267
Logical to physical translations initially unavailable: Cannot ... unavailable, 376

M
macro, 469-472
memory
  abort during load, 279
  copying, 110, 302
  displaying, 107
  editing, 109
  loading from stored file, 306
  mapper, resolution, 64
  mapping, 62-65, 257-260
  mapping for demo program, 7-8
  modifying a range, 112, 303
  searching for a value or string in, 113
  storing to a binary file, 307
  target system, copying into emulation memory, 111, 304
  type, 64, 257-260
Memory window, 393
  displaying 16-bit values, 299
  displaying 32-bit values, 299
  displaying bytes, 299
  displaying multicolumn format, 299
  displaying single-column format, 298
  turning polling ON or OFF, 73
Menu Bar Commands, 168
messages, error, 364
microprocessor, resetting, 96, 197
mixed display mode, 78, 316, 335
monitor, 469-472
  enabling trace of foreground monitor, 57
  monitor intrusion, 72, 96, 246-247
monitor
  programs, 410-412
  selecting the type, 58-61
multiple instructions execute in single step, 428-429
N  nesting command files, 357
   no-operation command, 359
   noabort, during object file or memory load, 279
   Novell LAN transport DLL, 454
   numeric constants, 161

O  Object file format ERROR, 376
   object files, 469-472
      abort during load, 279
      loading, 77, 170-171
      loading the foreground monitor, 59-60
   operators
      C, 165
      interset, 238-240
      intraset, 238-240
      logical, 136, 141, 238-240
   options, command line, 34
   Out of DOS Memory for LAN buffer, 377
   Out of Windows timer resources, 378
   output line
      LBG, 47
      RESET, 47
   overview of Intel80386EX address types, 424

P  parameters, command file, 175-176
   paste, cut and, 31
   PATH environment variable, 463-465
   path for source file search, 80, 324
   paths for source files, prompting, 280
   patterns, trace, 136, 141, 227-234, 238-242
   PC is out of RAM memory, 378
   PC
      connecting HP 64700, 437-446
      locating in Source window, 323
   performance (PC), optimizing for the debugger, 457
   performance verification after firmware update, 468
   physical address translation failed, 379
   physical address: definition, 424
   ping command, 453
   platform requirements, 435
   pointers (C operators), 165
   polling for debugger windows, turning ON or OFF, 73
Index

pop-up menus, 469-472
  accessing, 348
port
  BNC, 68, 238-240, 271-273
  communication, 268-270
power
  turning OFF, 45
  turning ON, 48
prefetching, 415-420
  turning off in trace, 130, 339
prestore condition, 136, 141, 227-234, 407, 469-472
primary branch condition, 141, 231-234, 469-472
probe (emulator)
  plugging into the target system, 46
  unplugging from demo target system, 45
processor, resetting, 96, 197
PROGFLASH firmware update utility, 466-467
program counter, 91, 95, 185, 188-189, 192-195, 399-400
program modules, displaying symbol information, 84, 325
programs
  demo, 4
  loading, 77, 170-171
  running, 95, 185, 188-189
  stopping execution, 96
Q qualifier, state, 133, 224-226
R real-time mode
  disabling, 72, 247
  enabling, 72, 246
real-time options, setting, 71-73
RealTime→I/O Polling→OFF (ALT, R, I, F) command, 249
RealTime→I/O Polling→ON (ALT, R, I, O) command, 248
RealTime→Memory Polling→OFF (ALT, R, M, F) command, 253
RealTime→Memory Polling→ON (ALT, R, M, O) command, 252
RealTime→Monitor Intrusion→Allowed (ALT, R, T, A) command, 247
RealTime→Monitor Intrusion→Disallowed (ALT, R, T, D) command, 246
RealTime→Watchpoint Polling→OFF (ALT, R, W, F) command, 251
RealTime→Watchpoint Polling→ON (ALT, R, W, O) command, 250
register bit fields dialog box, 314
Register windows, 399
  continuous update, 313
  copying information from, 313
registers
  displaying, 21-22, 118
  editing, 120
relative count information, displaying, 130, 337
requirements
  hardware, 435
  platform, 435
rerun command files, 358
reset address, 13
RESET
  flying lead, connecting, 47
  output line, 47
  slow to leave when using software breakpoints, 54
reset
  emulator, 96, 197
  emulator status, 403
  running from target system, 95, 188-189
resolution, memory mapper, 64
restart condition, 136, 227-230, 469-472
restriction on number of RS-232 connections, 450
return (function), running until, 19, 94, 187
ROM, enabling or disabling breaks on writes to, 55
RS-232
  cable and DCE or DTE selection, 445
  connection problems, 450
  connections restriction, 450
  connecting HP 64700, 437
RS-422
  connection problems, 455
  connecting HP 64700, 444
Run to Cursor command, 351
S
  screen fonts, changing, 6
search path, 454
search path for source files, 80, 324
Search→Address... (ALT, -, R, A) command, 322
Search→Current PC (ALT, -, R, C) command, 323
Search→Entry... (ALT, -, R, E) command, 309
Index

Search→Function... (ALT, -, R, F) command, 320
Search→Selector... (ALT, -, R, S) command, 310
Search→String... (ALT, -, R, S) command, 319
Search... (ALT, -, R) command, 300
searching GDT/LDT/IDT for entries, 309
searching GDT/LDT/IDT for selector, 310
secondary branch condition, 141, 231-234, 469-472
selecting how address translations work, 66-67
selector, searching GDT/LDT/IDT for, 310
sequence levels, 245, 469-472
service ports, TCP, 440
Set Breakpoint command, 350
Settings→BNC→Input to Analyzer Arm (ALT, S, B, I) command, 273
Settings→BNC→Outputs Analyzer Trigger (ALT, S, B, O) command, 271-272
Settings→Communication... (ALT, S, C) command, 268-270
Settings→Emulator Config→Address Translation... (ALT, S, E, A) command, 264-267
Settings→Emulator Config→Hardware... (ALT, S, E, H) command, 254-256
Settings→Emulator Config→Memory Map... (ALT, S, E, M) command, 257-260
Settings→Emulator Config→Monitor... (ALT, S, E, O) command, 261-263
Settings→Extended→Load Error Abort→OFF (ALT, S, X, L, F) command, 279
Settings→Extended→Load Error Abort→ON (ALT, S, X, L, O) command, 279
Settings→Extended→Source Path Query→OFF (ALT, S, X, S, F) command, 280
Settings→Extended→Source Path Query→ON (ALT, S, X, S, O) command, 280
Settings→Extended→Trace Cycles→Both (ALT, S, X, T, B) command, 278
Settings→Extended→Trace Cycles→Monitor (ALT, S, X, T, M) command, 277
Settings→Extended→Trace Cycles→User (ALT, S, X, T, U) command, 277
Settings→Font... (ALT, S, F) command, 274
Settings→Symbols→Case Sensitive→OFF (ALT, S, S, C, F) command, 276
Settings→Symbols→Case Sensitive→ON (ALT, S, S, C, O) command, 276
Settings→Tabstops... (ALT, S, T) command, 275
side effects of software breakpoints, 54
single-step one line, 14
single-stepping, unexpected behavior, 428-429
software breakpoints, 198-199, 208-213
   enable or disable, 54
software, installing debugger, 447-449
Source at Stack Level command, 349
source directory, 285
source display mode, toggling, 316-317
source file line, running until, 20, 94, 186
source files
   displaying, 11, 79, 318
   displaying from BackTrace window, 349
   prompting for paths, 280
   searching for addresses, 81, 322
   searching for function names, 81, 320
   searching for strings, 82, 319
   specifying search directories, 80
source lines
   stepping multiple, 93, 192-195
   stepping single, 91, 190
source only
   displaying, 78, 336
   displaying in Memory window, 316-317
Source window, 400
   line numbers missing, 39
   locating current PC, 323
   setting colors, 39
   setting tabstops, 38
   toggling the display mode, 316-317
SRCPATH environment variable, 80
startup options, 34
state qualifier, 133, 224-226, 469-472
static discharge, protecting the emulator against, 44
status register, editing, 314
status specification for tracing, 421-422
status values, 469-472
   for making custom mnemonics, 422
   predefined, 413-414
Status window, 403
step
   multiple lines, 15
   one line, 14
   unexpected behavior, 428-429
store, 133
store conditions, 238-240, 469-472
strings
  - displaying symbols containing, 90, 331
  - searching memory for, 113, 300
  - searching source files, 82, 319
Structure Access Warning!!!, 380
structures (C operators), 165
subnet mask, 440, 453
subroutines, stepping over, 191
swap instruction bytes, 131, 340
Symbol window, 406
  - copying information, 330-331
  - searching for strings, 331
symbolic addresses based on LDT specification, 427
symbols, 162-164
syntax of addresses entered as constants, 426
system setup, 436
T
  - tab stop settings, 275
  - tabstops in the Source window, setting, 38
target system, 469-472
target system interrupts, 410-412
  - enabling or disabling, 53
target system memory, copying into emulation memory, 111, 304
task switch messages, enabling, 254-256
TCP service ports, 440
telnet, 440, 446
TERMCOM command, 360-361
Terminal Interface commands, 360-361
text, selecting, 31
Timed out during communications, 381-382
TimeoutSeconds, 381-382
too many instructions execute in single step, 428-429
top of screen commands, 168
trace display mode, toggling, 335
trace foreground monitor
  - enabling or disabling, 57
trace foreground/background operation, 277-278
trace list, swap instruction bytes in data column, 131, 340
trace messages
  enabling or disabling, 56
trace patterns, 136, 141, 227-234, 238-242
trace prefetch, turning OFF, 130, 339
trace range, 243-244
trace settings, 238-240
trace signals, 413-414
trace specifications, 421-422
  copying, 343
  editing, 145, 223
  loading, 148
  specifying the destination, 343
  storing, 147
trace state, 469-472
  searching for in Trace Window, 342
Trace window, 407
  copying information, 340-341
  displaying absolute count information, 337
  displaying bus cycles only, 336
  displaying relative count information, 337
  displaying source only, 336
  toggling the display mode, 335
trace, setting up a sequence, 141
Trace→Again (F7), (ALT, T, A) command, 237
Trace→Edit... (ALT, T, E) command, 223
Trace→Find Then Trigger... (ALT, T, D) command, 227-230
Trace→Function Caller... (ALT, T, C) command, 217-218
Trace→Function Statement... (ALT, T, S) command, 219-220
Trace→Halt (ALT, T, H) command, 236
Trace→Sequence... (ALT, T, Q) command, 231-234
Trace→Trigger Store... (ALT, T, T) command, 224-226
Trace→Until Halt (ALT, T, U) command, 235
Trace→Variable Access... (ALT, T, V) command, 221-222
transfer address, 93, 95, 188-189, 192-195, 469-472
translating addresses, 264-267
  implications, 66-67
  performance when using the cache, 67
  virtual to physical failed, 379
Index

trigger, 133, 469-472
    condition, 133, 469-472
    position, 133, 469-472
    state, searching for in Trace window, 341
    store condition, 133, 469-472
turning off prefetches in trace list, 130, 339
tutorial, 4
type of memory, 64, 257-260

U
    unary minus operator, 165
    unions (C operators), 165
    unused prefetches, 415-420
    user ID, 447-449
    user programs, loading, 77
    user-defined symbols
        creating, 88, 332
        deleting, 89, 334
        displaying, 89, 330
Utilities→Copy... (ALT, -, U, C) command, 302
Utilities→Fill... (ALT, -, U, F) command, 303
Utilities→Image... (ALT, -, U, I) command, 304
Utilities→Load... (ALT, -, U, L) command, 306
Utilities→Store... (ALT, -, U, S) command, 307

V
    values
        searching memory for, 113, 300
        status, 413-414
Variable→Edit... (ALT, V, E) command, 214-215
variables
    auto, 104-106
    displaying, 16, 104
    dynamic, 214-215, 344, 409
    editing, 17, 105, 214-216
    environment, 80
    global, 85, 127, 326
    local, 86-87, 327
        monitoring in the WatchPoint window, 18, 106
        tracing accesses, 24, 127, 221-222
verification of emulator performance, 468
version information, 284, 456
virtual address: definition, 424
**W**

WAIT command, 158
wait delays, inserting in command files, 362
watchpoint, 469-472
WatchPoint window, 409
  monitoring variables in, 18, 106
  turning polling ON or OFF, 73
watchpoints, editing, 344
window contents, copying to the list file, 37
Window→1-9 (ALT, W, 1-9) command, 282
Window→Arrange Icons (ALT, W, A) command, 281
Window→Cascade (ALT, W, C) command, 281
Window→More Windows... (ALT, W, M) command, 283
Window→Tile (ALT, W, T) command, 281
windows (debugger), opening, 282-283
Windows for Workgroups LAN transport DLL, 454
windows of program execution, tracing, 145
WINSOCK LAN transport DLL, 454
WINSOCK.DLL, 454
WLIBSOCK.DLL, 454
writes to ROM, enabling or disabling breaks on, 55
wrong displays of LDT-based addresses, 427
WSOCKETS.DLL, 454
Certification and Warranty

Certification

Hewlett-Packard Company certifies that this product met its published specifications at the time of shipment from the factory. Hewlett-Packard further certifies that its calibration measurements are traceable to the United States National Bureau of Standards, to the extent allowed by the Bureau’s calibration facility, and to the calibration facilities of other International Standards Organization members.

Warranty

This Hewlett-Packard system product is warranted against defects in materials and workmanship for a period of 90 days from date of installation. During the warranty period, HP will, at its option, either repair or replace products which prove to be defective.

Warranty service of this product will be performed at Buyer’s facility at no charge within HP service travel areas. Outside HP service travel areas, warranty service will be performed at Buyer’s facility only upon HP’s prior agreement and Buyer shall pay HP’s round trip travel expenses. In all other cases, products must be returned to a service facility designated by HP.

For products returned to HP for warranty service, Buyer shall prepay shipping charges to HP and HP shall pay shipping charges to return the product to Buyer. However, Buyer shall pay all shipping charges, duties, and taxes for products returned to HP from another country. HP warrants that its software and firmware designated by HP for use with an instrument will execute its programming instructions when properly installed on that instrument. HP does not warrant that the operation of the instrument, or software, or firmware will be uninterrupted or error free.
Limitation of Warranty

The foregoing warranty shall not apply to defects resulting from improper or inadequate maintenance by Buyer, Buyer-supplied software or interfacing, unauthorized modification or misuse, operation outside of the environment specifications for the product, or improper site preparation or maintenance.

No other warranty is expressed or implied. HP specifically disclaims the implied warranties of merchantability and fitness for a particular purpose.

Exclusive Remedies

The remedies provided herein are buyer’s sole and exclusive remedies. HP shall not be liable for any direct, indirect, special, incidental, or consequential damages, whether based on contract, tort, or any other legal theory.

Product maintenance agreements and other customer assistance agreements are available for Hewlett-Packard products.

For any assistance, contact your nearest Hewlett-Packard Sales and Service Office.
Safety

Summary of Safe Procedures

The following general safety precautions must be observed during all phases of operation, service, and repair of this instrument. Failure to comply with these precautions or with specific warnings elsewhere in this manual violates safety standards of design, manufacture, and intended use of the instrument. Hewlett-Packard Company assumes no liability for the customer’s failure to comply with these requirements.

Ground The Instrument

To minimize shock hazard, the instrument chassis and cabinet must be connected to an electrical ground. The instrument is equipped with a three-conductor ac power cable. The power cable must either be plugged into an approved three-contact electrical outlet or used with a three-contact to two-contact adapter with the grounding wire (green) firmly connected to an electrical ground (safety ground) at the power outlet. The power jack and mating plug of the power cable meet International Electrotechnical Commission (IEC) safety standards.

Do Not Operate In An Explosive Atmosphere

Do not operate the instrument in the presence of flammable gases or fumes. Operation of any electrical instrument in such an environment constitutes a definite safety hazard.

Keep Away From Live Circuits

Operating personnel must not remove instrument covers. Component replacement and internal adjustments must be made by qualified maintenance personnel. Do not replace components with the power cable connected. Under certain conditions, dangerous voltages may exist even with the power cable removed. To avoid injuries, always disconnect power and discharge circuits before touching them.
Do Not Service Or Adjust Alone

Do not attempt internal service or adjustment unless another person, capable of rendering first aid and resuscitation, is present.

Do Not Substitute Parts Or Modify Instrument

Because of the danger of introducing additional hazards, do not install substitute parts or perform any unauthorized modification of the instrument. Return the instrument to a Hewlett-Packard Sales and Service Office for service and repair to ensure that safety features are maintained.

Dangerous Procedure Warnings

Warnings, such as the example below, precede potentially dangerous procedures throughout this manual. Instructions contained in the warnings must be followed.

**WARNING**

Dangerous voltages, capable of causing death, are present in this instrument. Use extreme caution when handling, testing, and adjusting.
Safety Symbols Used In Manuals

The following is a list of general definitions of safety symbols used on equipment or in manuals:

Instruction manual symbol: the product is marked with this symbol when it is necessary for the user to refer to the instruction manual in order to protect against damage to the instrument.

Indicates dangerous voltage (terminals fed from the interior by voltage exceeding 1000 volts must be marked with this symbol).

Protective conductor terminal. For protection against electrical shock in case of a fault. Used with field wiring terminals to indicate the terminal which must be connected to ground before operating the equipment.

Low-noise or noiseless, clean ground (earth) terminal. Used for a signal common, as well as providing protection against electrical shock in case of a fault. A terminal marked with this symbol must be connected to ground in the manner described in the installation (operating) manual before operating the equipment.

Frame or chassis terminal. A connection to the frame (chassis) of the equipment which normally includes all exposed metal structures.

Alternating current (power line).

Direct current (power line).

Alternating or direct current (power line).
Caution

The Caution sign denotes a hazard. It calls your attention to an operating procedure, practice, condition, or similar situation, which, if not correctly performed or adhered to, could result in damage to or destruction of part or all of the product.

Warning

The Warning sign denotes a hazard. It calls your attention to a procedure, practice, condition or the like, which, if not correctly performed, could result in injury or death to personnel.