VTrak Setup Task List

Task 1: Unpacking the VTrak (below)
Task 2: Mounting VTrak in a Rack (page 3)
Task 3: Making Management and Data Connections (page 5)
Task 4: Powering On the System (page 8)
Task 5: Initial Setup (page 9)
Task 6: Configuring the VTrak (page 12)

For complete information about your VTrak E610f and J610s subsystems, see their respective VTrak Product (user) Manuals on the Software CDs.

Task 1: Unpacking the VTrak

The VTrak box contains the following items:

- VTrak Unit
- Quick Start Guide
- Left and right center-mount brackets
- Left and right mounting rails
- RJ11-to-DB9 serial data cable
- 1.5m (4.9 ft) Power cords (2)
- CD with SNMP files, Product (user) Manual and Quick Start Guide

Warning

The electronic components within the VTrak disk array are sensitive to damage from Electro-Static Discharge (ESD). Observe appropriate precautions at all times when handling the VTrak or its subassemblies.

Caution

At least two persons are required to safely lift the VTrak subsystem from the box and place it into a rack.

Important

Use the following categories of network cables with VTrak:
- Cat 6, preferred
- Cat 5E, minimum
Task 2: Mounting VTrak in a Rack

The E610f/s subsystem installs to the rack using the supplied mounting rails. You can also use your existing rails.

Figure 1. VTrak mounted in a rack with the supplied rails

Cautions

- At least two persons are required to safely lift, place, and attach the VTrak subsystem into a rack.
- Do not lift or move the VTrak subsystem by the handles, power supplies or the controller units. Hold the subsystem itself.
- Do not install the VTrak subsystem into a rack without rails to support the subsystem.
- Only a qualified electrician who is familiar with the installation procedure should mount and install the VTrak subsystem.
- Be sure all switches are OFF before installing the VTrak subsystem or exchanging components.

To install the VTrak subsystem into a rack with the supplied mounting rails:

1. Check the fit of the mounting rails in your rack system.
2. Adjust the length of the mounting rails as needed.
3. Attach the mounting rail assemblies to the outside of the rack posts, using the attaching screws from your rack system. See Figure 2.

Be sure the support is on the bottom facing inward.
4. Square the rail assemblies in the rack.
5. Tighten the adjustment screws and the attaching screws.
6. Place the VTrak subsystem onto the rails.
7. Secure the VTrak subsystem to the rack through each handle, using the attaching screws from your rack system.

**Figure 2. Rack mount assembly diagram**

8. Remove the drive carriers from their packing and install them into the drive bays of the VTrak enclosure. See Figure 1.
9. Plug in the power supply cords.
Task 3: Making Management and Data Connections

VTrak models have two RAID controllers. Each controller has an Ethernet (RJ45) Management Port connector that enables you to monitor the VTrak over your network using the WebPAM PROe Software. VTrak supports HTTP, HTTPS, and Telnet protocols.

The VTrak RAID controllers have two 4-Gb Fibre Channel (FC) connections for the data ports. See Figure 3.

You can configure your VTrak for:

- Storage Area Network (SAN)
- Direct Attached Storage (DAS)
- JBOD Expansion using a SAS data connection

Figure 3. VTrak RAID controller connectors
Configuring a Storage Area Network

A storage area network (SAN) requires:

• A Fibre Channel switch
• A Fibre Channel HBA card in the Mac Pro
• A network switch

To establish the data path:
Connect one of the Fibre Channel data ports on the VTrak controller to your Fibre Channel switch.

To establish the management path:
1. Connect the Management port on the VTrak controller to your network switch. Figure 4.
2. Connect each Mac Pro’s NIC to your network switch.

*Figure 4. SAN data and management connections*
Configuring Direct Attached Storage

Direct attached storage (DAS) requires:

- Two Fibre Channel HBA cards in the Host PC or Server
- A network switch

To establish the data path:

Connect one of the Fibre Channel data ports on the VTrak controller to your Fibre Channel switch.

To establish the management path:

1. Connect the Management port on the VTrak controller to your network switch. See Figure 5.
2. Connect the Mac Pro’s NIC to your network switch.

**Figure 5. DAS data and management connections**
**Task 4: Powering On the System**

There is a specific sequence to follow when you power on your VTrak and Mac Pro system.

*Figure 6. VTrak and Mac Pro power on sequence*

Power on your system components in the following sequence:

1. VTrak J610s subsystems
2. VTrak E610f subsystem
3. Mac Pro
**Task 5: Initial Setup**

**VTrak Default Network Settings**

<table>
<thead>
<tr>
<th>Component</th>
<th>Default Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Virtual Management Port IP address</td>
<td>10.0.0.1</td>
</tr>
<tr>
<td>RAID Controller 1 IP address</td>
<td>10.0.0.2</td>
</tr>
<tr>
<td>RAID Controller 2 IP address</td>
<td>10.0.0.3</td>
</tr>
<tr>
<td>Subnet Mask</td>
<td>255.0.0.0</td>
</tr>
</tbody>
</table>

You must change these network settings so the VTrak works on your network. The setting change requires a serial connection from your computer to the VTrak. Your computer activates the Command Line Interface (CLI) on the VTrak to make the required changes.

**Setting up a Serial Connection**

There are two methods to make the initial network settings:

- **Xserve Server** – Requires ZTerm software
- **Mac Pro** – Requires ZTerm software and USB-to-DB9 adapter

**Xserve Server**

Before you begin:

   Install ZTerm onto your Xserve server.
2. Find the RJ11-to-DB9 serial cable that ships with the VTrak.
   Attach the RJ11 end of the serial cable to the RJ11 serial connector on one of the VTrak controller modules. See Figure 3.
   Attach the DB9 end of the serial cable to the serial connector on the Xserve.

*Figure 7. Xserve Server serial connector*
To set up a serial connection with VTrak:

1. On your Xserve, double-click the ZTerm desktop icon (right).
   The Local window opens on the desktop.
2. From the ZTerm dropdown menus, choose Settings > Connection.
   Set the Data Rate to 115200 and click the OK button.
3. Press Enter once to launch the CLI.
   The CLI opens in the Local window. The prompt should look like this:
   administrator@cli>
   If you see a Login prompt, type administrator and press Enter.
   Then at the Password prompt, type password and press Enter.
4. Go to “Making Settings on VTrak” on page 11.

**Mac Pro**

Before you begin:

   Install ZTerm onto your Mac Pro.
2. Obtain a USB-to-DB9 adapter.
   Install the software for the USB-to-DB9 adapter onto your Mac Pro.

*Figure 8. An example of a USB-to-DB9 adapter*

3. Find the RJ11-to-DB9 serial cable ships with the VTrak.
   Attach the RJ11 end of the serial cable to the RJ11 serial connector on one of the VTrak controller modules. See Figure 3.
Task 5: Initial Setup

Attach the DB9 end of the serial cable to the DB9 connector on the USB-to-DB9 adapter. See Figure 8.

Attach the USB end of the USB-to-DB9 adapter to a USB port on the Mac Pro.

To set up a serial connection with VTrak:
1. On your Mac Pro, double-click the ZTerm desktop icon (right). The Local window opens on the desktop.
2. From the ZTerm dropdown menus, choose Settings > Connection. Set the Data Rate to 115200 and click the OK button.
3. Press Enter once to launch the CLI. The CLI opens in the Local window. The prompt should look like this:
   administrator@cli>

   If you see a Login prompt, type administrator and press Enter. Then at the Password prompt, type password and press Enter.
4. Go to “Making Settings on VTrak,” below.

Making Settings on VTrak

1. Type the following string to set the system date and time, then press Enter.
   administrator@cli> date -a mod -d 2008/07/25 -t 14:50:05
   In the above example, the date and time are included as examples only. Use yyyy/mm/dd for the date and a 24-hour clock for the time.
2. Type the following string to set the Virtual Management Port IP address and other settings, then press Enter.
   administrator@cli> net -a mod -t mgmt -s "dhcp=enable"
3. To verify the settings, type net and press Enter.
   administrator@cli> net

   ============================================
   ClId Port Type   IP          Mask   Gateway   Link
   ============================================
   1    1  Mgmt  192.168.10.85  255.255.255.0 192.168.10.1  Up

   Note that the IP address described above belongs to the VTrak subsystem, not to one of the RAID controllers.
   The IP address and subnet mask shown here are examples only.
4. Type the following string to set the RAID Controller IP addresses and other settings, then press Enter. You must set each Controller separately.

   administrator@cli> net -a mod -t mgmt -m -c 1 -s "dhcp=enable"
   administrator@cli> net -a mod -t mgmt -m -c 2 -s "dhcp=enable"

5. To verify the maintenance mode settings, type `net -m` and press Enter.

   administrator@cli> net -m

   CtrlId: 1  Port: 1
   Type: Management Ethernet  IPType: IPv4
   IP: 192.168.10.101  IPMask: 255.255.255.0
   MAC: 00:01:55:AE:02:AE  DNS: 0.0.0.0
   Gateway: 192.168.10.1  DHCP: Disabled

   The IP address and subnet mask shown here are examples only.

   To exit ZTerm, press Command–Q.

**Task 6: Configuring the VTrak**

You can configure your VTrak system automatically by means of a script available on the Apple website.

**Preparing Your Script**

To prepare your configuration script:

1. Double-click this link [http://support.apple.com/kb/HT1200](http://support.apple.com/kb/HT1200). The scripts are listed under **Configure via script**.

2. Carefully read the descriptions and choose the script that matches your application. Click the script name to choose it.

3. Highlight the entire script from `#Begin Copy` through `#End Copy`, then press Command-C to copy it.

4. Open **TextEdit** and press Command-V to paste the script into a new file.

5. From the dropdown menu, choose **Format > Make Plain Text**. Be sure you convert the configuration script to a plain text file.
6. Choose File > Save As, name the script file, and click the Save button. Your configuration script is ready to import into WebPAM PROe.

Logging into WebPAM PROe

To log into WebPAM PROe:

1. Open Safari.

2. In the address field, type in the IP address of the VTrak Management port. See step 3 under “Making Settings on VTrak” on page 11.
   - WebPAM PROe uses an HTTP connection. . . . . . . . . . . . . . . . . .http://
   - Enter the VTrak’s Management Port IP address . . . . 192.168.10.85
   Together, your entry looks like this example:
     http://192.168.10.85

7. When the log-in screen (Figure 9) appears:
   - Type administrator in the User Name field.
   - Type password in the Password field.
   - Click the Login button.
   The User Name and Password are case sensitive.

8. Click the Login button.

Figure 9. WebPAM PROe log-in screen
Checking Your Physical Drives

The configuration script only works when all of your physical drives are unconfigured. If you are setting up your VTrak system for the first time, all of your drives will be unconfigured.

To check your physical drives:

1. In Tree View, click the VTrak icon, Enclosures icon, Enclosure icon, and Physical Drives icon.
2. Under the Information tab, check Operational Status and Configuration. If Operational Status is OK and Configuration is Unconfigured, your physical drives are ready to run the configuration script.

**Figure 10. Physical drive information**

If you have created any disk arrays, logical drives, or spare drives, you must delete them before you run the script. Be sure you back-up your important data first, then delete the disk arrays and logical drives. See the VTrak Product (User) Manual on the Software CD for instructions.
Importing and Running Your Script

To import and run your configuration script:

1. In Tree View, click the Administrative Tools icon, then click the Import link.

*Figure 11. The Import link under Administrative Tools*

2. In the Import File dialog box, choose Configuration Script from the Type dropdown menu.

*Figure 12. Importing a Configuration Script*

3. In the Import File dialog box, click the Choose File button and navigate to the folder where you saved the configuration file. Click the configuration file and click the Choose button.
4. In the Import File dialog box, click the **Submit** button.

*Figure 14. Clicking the Submit button*

5. In the Import File dialog box, click the **Next** button.

*Figure 15. Clicking the Next button*

6. In the Warning box, click the **OK** button.
The configuration script takes about 30 to 45 seconds to upload and run. When the script is done, new disk arrays and logical drives appear in Tree View.

The exact appearance of Tree View depends upon how you set up your system and which script you chose. Your VTrak system is now configured and ready to use.