Hot Destinations South of the Border

AERO TOURS

Owner’s Manual
COPYRIGHT

Software Copyright © 1991 GeoWorks. All rights reserved. You are licensed to use the software under the terms set forth in the End User License Agreement printed on the diskette envelope which contains the software. You may not copy, rent, lease, decompile, disassemble, or create derivative works of the software or documentation, but may transfer this entire package to another person under the terms of the License Agreement. If you do not agree to the End User License, you may return all the materials for a full refund as set forth in the License Agreement.

Manual Copyright © 1992 GeoWorks. All rights reserved. No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language in any form by any means without the written permission of GeoWorks.

Images Copyright © 1991 GeoWorks, except certain clip art (as noted by file information) which is copyrighted work of T/Maker Company. All rights reserved.

Under Title 17, United States Code, Section 106, GeoWorks, the owner of the copyright in the pictorial and graphic work (called “Image(s)”) included in this Software package, has the sole right to reproduce these copyrighted Images, to prepare derivative copies based upon these Images and to distribute copies of them. GeoWorks, the owner of the copyright, grants Buyer a Sublicense to use the Images solely for the purpose of incorporating these copyrighted Images into Buyer's original published materials. Buyer may not reproduce any of the Images, in any form, for the purpose of selling, leasing, transferring or assigning the unaltered artwork in substantially the same form as the Images appear in this Software package.

The Sublicense to use the Images is conditioned upon Buyer including the copyright notice appearing adjacent to each Image when Buyer uses the Image or any portion of it. Title 17, United States Code, Section 506, provides for criminal penalties for removal of a copyright notice.

The software contains Nimbus Q from Digital Typeface Corporation and typefaces from URW, GmbH.

TRADEMARKS

GeoWorks Pro™, GeoWorks™, GeoManager™, File Cabinet™, GeoBanner™, GeoDraw™, GeoWrite™, and GeoPlanner™ are trademarks of GeoWorks. GEOS®, PC/GEOS®, GeoComm®, and GeoDex® are registered trademarks of GeoWorks.

America Online® is a registered trademark of Quantum Computer Services, Inc. URW Roman™, URW Sans™, URW Mono™, and URW Symbol™ are trademarks of URW, GmbH.

Tetris © 1987 V/O Electronorgtechnica (Elorg). All rights reserved. Tetris™ is a trademark of Elorg. Tetris copyright and trademark licensed to Sphere, Inc. and sublicensed to GeoWorks. Original concept by Alexey Pajitnov. GeoWorks version © 1991 GeoWorks.


AutoCAD® is a registered trademark of Autodesk, Incorporated. Adobe Type Manager® and ATM® are trademarks of Adobe Systems Incorporated, registered in the USA and other countries.

DESQ® is a registered trademark of Quarterdeck Office Systems. DESQview™ is a trademark of Quarterdeck Office Systems. Digital Research™, TaskMax™, and DR-DOS™ are trademarks or registered trademarks of Digital Research, Inc. Lotus®, 1-2-3®, and Symphony® are registered trademarks of Lotus Development Corporation. Microsoft®, MS®, and MS-DOS® are registered trademarks of Microsoft Corporation. Windows™ is a trademark of Microsoft Corporation. Ami® is a registered trademark of Samna Corporation, a wholly-owned subsidiary of Lotus Development Corporation. Q&A®, Norton Commander®, and Norton Utilities® are registered trademarks of Symantec Corporation. Norton Backup™ is a trademark of Symantec Corporation. Quattro® is a registered trademark of Borland International. WordPerfect® is a registered trademark of WordPerfect Corporation. GeoWorks and any other associated entities are not directly affiliated with, endorsed by, or sponsored by any of the companies listed in this paragraph.

All other brand and product names are trademarks or registered marks of their respective holders.

DISCLAIMER

GeoWorks reserves the right to make changes to this manual and the software described herein without notice. GeoWorks has made all reasonable efforts to insure that the information in this manual is accurate and complete. However, GeoWorks shall not be liable for any technical or editorial errors or omissions made herein or for incidental, special, or consequential damage of whatsoever nature resulting from the furnishing of this manual, or operation and performance of software in connection with this manual.

Words in the American Heritage Electronic Dictionary that are believed to be registered trademarks have been checked with authoritative sources. No investigation has been made of common-law trademark rights in any word. Words that are known to have current registration are shown with an initial capital and are also identified as trademarks. The inclusion or exclusion of any word, or its capitalization, in this Dictionary is not, however, an expression of the Publisher's opinion as to whether or not it is subject to proprietary rights, nor is it to be regarded as affecting the validity of any trademark.

PRINTED IN THE UNITED STATES OF AMERICA

1st Printing, February 1992
1. OVERVIEW
A little about the GeoWorks Pro environment, using this manual, the Beginner, Intermediate, and Advanced workspaces, the DOS Programs screen, and a note about document templates.

GETTING TO KNOW GEOWORKS PRO

2. GETTING STARTED
Installing your software and a step-by-step tutorial.

3. BASIC TOOLS AND SKILLS
All the little things you should know to explore GeoWorks Pro—everything from using your mouse to printing your documents.

A DETAILED REFERENCE

4. THE APPLIANCES
Six easy-to-use tools, including Notepad (a simple line editor) Calculator (exactly that) Address Book (a place to keep names and addresses) Planner (a way to plan your time) Solitaire (the card game) Banner (for making real long signs).

5. THE CALCULATOR
An on-screen calculator with a few more features than its appliance cousin.

6. THE DOS PROGRAMS SCREEN
A place to launch regular DOS programs at the click of a button. We've also included icons for many popular programs so you can create buttons for your favorites.

7. EXTRAS
Some "freebie" applications, including one that lets you take pictures of GeoWorks Pro screens, another that lets you convert Nimbus fonts to GeoWorks Pro fonts, and one that lets you monitor the performance of your system.
8. THE FILE CABINET
All about using the File Cabinet, the centerpiece of the Intermediate Workspace. Creating, coping, moving, and renaming files and directories without using a single cryptic DOS command. Opening directories, and the files in them.

9. GEOCOMM
Using GeoComm and your modem to communicate with other computers over the telephone lines. Sending and Receiving files with your modem. Your computer as a dumb terminal. How scripts can help you log on to computer services.

10. GEODEX
Adding names and addresses to your GeoDex address books. Searching for a name and making changes. Having GeoDex dial a phone number for you. Linking GeoDex to GeoPlanner.

11. GEODRAW
Using GeoDraw: a powerful and easy-to-use drawing application that lets you produce full-color graphics with integrated text.

12. GEOMANAGER
Using GeoManager in the Advanced Workspace to manage your files and directories—with no mysterious DOS commands. Using the built-in directory tree. Starting applications, opening documents, and running DOS programs.

13. GEOPLANNER
Planning your days with GeoPlanner—a calendar, planner, and alarm clock rolled into one.

14. GEOWRITE
How GeoWrite can help you create professional looking documents. Using different fonts and styles, creating tables, headers and footers, multi-column documents, and adding graphics. Importing and exporting text files. Adding color. Using the built-in spelling checker.

15. THE NOTEPAD
A simple text editor for working with DOS text files (files without formatting).

16. PREFERENCES
Using the Preferences application to tell GeoWorks Pro when you add or change hardware on your system. Tailoring GeoWorks Pro to work the way you do.
17. THE QUATTRO PRO VIEWER
Using the Viewer to look at spreadsheets and charts in a GeoWorks Pro window. Copying Quattro Pro spreadsheets and charts to GeoWrite, GeoDraw, and the Scrapbook. Having the Viewer launch Quattro Pro SE and open a spreadsheet for you.

18. THE SCRAPBOOK
Storing images and text you use often as scraps in a scrapbook. Importing graphics from other DOS programs. Using the Scrapbook to scale graphics.

19. SOLITAIRE
Taking a break from your work.

20. TETRIS
Taking a longer break.

21. GEOWORKS PRO IN THE REAL WORLD
Using GeoWorks Pro with a network. Task switching with MS-DOS 5.0, and DR DOS 6.0 TaskMax. Running under Windows 3.0

THE APPENDIX AND INDEX

A. SPECIAL CHARACTERS
How to type all sorts characters you never had on your typewriter.

INDEX
Welcome! We think you’re going to enjoy using GeoWorks Pro. This chapter gives you a general idea of what you can do with GeoWorks Pro and explains how to get the most out of this manual. If you haven’t yet installed GeoWorks Pro, you should do so now by following the instructions in the “Getting Started” section of this book.
Computers. They’re supposed to make life easier. But the time it takes to learn a new program—all the commands you must remember, all the trial and error you must go through—these things can take the fun out of using a computer.

So we created GeoWorks Pro, which includes both an exciting new environment to work in and a family of applications (including GeoWrite and GeoDraw) that make full use of its power. GeoWorks Pro is designed to give you powerful tools for doing your work, and to bring a little fun back into it, too.

GeoWorks Pro is easy to use because it’s visual and intuitive. Instead of using hard-to-remember commands, the screen shows you pictures of things, like buttons and icons. Everything you can do in GeoWorks Pro is represented somewhere on the screen, whether it’s in a menu, in a list, or on a button. You spend less time trying to remember how to do things and more time actually doing them. Simply move an arrow-shaped pointer around on the screen with your mouse until it points at a visual representation of what you want to do, then press and release the mouse button.

With the graphic abilities of GeoWorks Pro, things appear on the screen as they will on the printer. Whether it’s a business letter you’re writing or some artwork you’re creating, what you see is what you get (WYSIWYG). And if you have a PostScript-compatible color printer, you can print in color, too.

These are just a few of the reasons that GeoWorks Pro is easy and fun to use. Go ahead and explore... Find a few reasons of your own.

### OVERVIEW

#### USING THIS MANUAL

**LEARNING THE BASICS** If you haven’t yet installed the software, flip to the “Getting Started” chapter to see how. There you’ll also find a step-by-step tutorial that touches on just about every aspect of GeoWorks Pro—from installing the software to creating your own document. However, any basic concepts that aren’t covered in the “Getting Started” chapter (and even some things that are) you’ll find in “Basic Tools and Skills”—a chapter geared toward those who aren’t necessarily new to computers, but may be new to graphical operating environments like GeoWorks Pro.

**DEALING WITH THE DETAILS** Once you’re comfortable with the basics, if you ever have a specific question about an application (such as how to make a table in GeoWrite) turn to the Reference section. Whereas the Getting Started chapter is designed to be read from front to back, the “Reference” section is designed to be read more like an encyclopedia—it’s meant to be skimmed for specific topics.

Pick a topic your interested in—say, making a table in GeoWrite—and turn right to the section about creating tables in the “GeoWrite” chapter. There, as you would expect, you’ll find important details about making tables. Keep in mind, though, that you won’t find instructions on how to select text or drag an item (things you also need to know to make a table)—these are basic skills that the “Reference” section assumes that you have already learned from the “Getting Started” and “Basic Tools and Skills” chapters.
EXPLORING When you do have the basics down, you're ready to get to work using GeoWorks Pro for your own projects. Don't worry if there are still things you don't understand—the best way to learn about GeoWorks Pro is to try it. As you try things out, and become more comfortable experimenting, GeoWorks Pro becomes easier to use. And, if you're worried about accidentally damaging something important, remember this: GeoWorks Pro asks you for permission before it updates or removes anything important.

ABOUT THE SPECIAL SYMBOLS USED IN THIS BOOK
The special symbols in this manual—like , , and —represent keys on your keyboard. The may not match the keys on your keyboard. For example, not all “Control” keys are marked ; sometimes they're marked with the full word “Control” instead. Also, the key appears as a key on some keyboards. You get the idea. Refer to your computer owner's manual for more information about your particular keyboard and its layout.

When you see a group of keys separated by a + sign, it means to hold down the first set of keys while pressing the second. For example, if you see , it means to hold down both the and keys while pressing the key.

THE WELCOME SCREEN

When you first start GeoWorks Pro, the Welcome screen greets you. The Welcome screen provides a friendly and simple starting place. Everything is large and clearly labeled. This is your gateway to GeoWorks Pro. It's from here that you can enter any of the three workspaces (Beginner, Intermediate, or Advanced) and go to the DOS Programs screen—a place where you can run your regular DOS programs.
ENTERING AND EXITING THE WORKSPACES When you click one of the buttons on the Welcome screen (see “Basic Tools and Skills” for more about clicking buttons) you immediately enter one of the three workspaces, or the DOS Programs screen. (Once in one of the workspaces or the DOS programs screen, you can always return to the Welcome screen by pressing the F2 key on your keyboard.)

THE BEGINNER WORKSPACE

Anybody in your household who can use a familiar home appliance—a washing machine, phone answering machine, or a blender—can also use the GeoWorks Pro appliances in the Beginner Workspace. These appliances are designed to be especially easy to learn. All you have to know is how to point and click.

The Beginner Workspace comes with six appliances:

- An Address Book for looking up names and addresses
- A Planner for showing important upcoming events
- A Calculator for quick calculations
- A Notepad for making notes
- A Solitaire game that’s just like the game you play on the living room rug
- A Banner-maker for creating long banners

For more information, turn to the “Appliances” chapter in the “Reference” section of this manual.
THE INTERMEDIATE WORKSPACE

Like its name implies, the Intermediate Workspace fits conceptually between the ultra-simple goof-proof Beginner Workspace, and the high-powered Advanced Workspace. Like the latter workspace, you can use all of the GeoWorks applications, but you use them in a simpler way—each application fills the screen completely, and DOS file management is greatly simplified.

Like you do with the other areas of GeoWorks Pro, you enter the Intermediate Workspace via the Welcome screen. The File Cabinet document manager is the first thing you see. From there you can open documents—yours and ours—as well as manage your files, directories, and disks.

You do most of your work in the Intermediate Workspace using ready-made documents called templates.

Templates make your work easy: the formatting in them has already been done for you. So to create a great looking document all you have to do is open a template and add your own text—and even graphics, if you'd like.

Best of all, whenever you leave the Intermediate Workspace, GeoWorks Pro remembers exactly what you were doing, so you can come back to the workspace and have all your work waiting for you, just as you left it.

For more information, turn to the “file Cabinet” chapter in the “Reference” section of this manual.
THE ADVANCED WORKSPACE

Whereas the Intermediate Workspace boils file management down to a few basic tasks, limits what DOS directories you can get into, and only lets you look at one application window at a time, the Advanced workspace sets you free. There, you can resize windows and strew them around the screen as you see fit. That way, on the screen, you can have a GeoWrite document and right next to it a GeoDraw document.

Central to the Advanced Workspace is GeoManager, File Cabinet's “big brother.” Like the File Cabinet, it represents your files as icons within the window. You also use these icons to open documents and manage your files and directories. But that's where the similarity stops. GeoManager offers a wealth of additional features—you can look at many directories at once, view your disk structure as a tree, and view any directory on any disk that your computer has access to.

And, like the Intermediate Workspace, you can stop working at any time—you don't need to finish what you are doing before you shut down your computer and go home. Everything in the Advanced Workspace stays exactly as you left it, ready for you when you start working again, no matter how long you are gone, and no matter what you do in the meantime (you can even turn off your computer). Nothing is ever lost, misplaced, or rearranged.

For more information, turn to the “GeoManager” chapter in the “Reference” section of this manual.

A typical picture of the Advanced Workspace, which—unlike the Intermediate Workspace—can have different applications sharing the screen at the same time. Here, both GeoDraw and GeoWrite are open, making it simple to transfer artwork from the former to the latter.
THE DOS PROGRAMS SCREEN

The DOS Programs screen offers a quick way to run DOS programs and batch files at the press of a button. Create a button for each DOS program and batch file you use, giving each button its own picture and title. Then simply click the button to shut down GeoWorks Pro and run the corresponding DOS program.

At first this screen has only one button, labeled “Enter DOS.” Click it to temporarily shut down GeoWorks Pro and enter DOS, where you can invoke normal DOS commands. When you’re finished in DOS, type “exit” and press Enter to return to GeoWorks Pro and the DOS Programs screen.

DOCUMENT TEMPLATES

In your Document directory, you’ll find folders containing handy templates—ready-made documents that can save you a lot of time because all the layout work is already done. For instance, if you plan to create a newsletter, open the NEWSLTTTR folder and one of the template documents you find there. When in the document, select the preformatted text and replace it with your own. To add a quick graphic, look through the scrapbooks in the CLIPART folder (also in the DOCUMENT directory) for ready-to-use clip art.
GETTING TO KNOW GEOWORKS PRO
We’d like to introduce you to GeoWorks Pro, show you how to use it right away to do simple tasks, and give you the basic skills you can build on later. This chapter works to get you up and running with GeoWorks Pro fast—telling you how to install the software on your computer, how to start it once it’s installed, and how to do some common things with key applications. So sit back and prepare to be pleasantly surprised at how friendly your computer’s become!
INSTALLING GEOWORKS PRO

Before you can use GeoWorks Pro you must install it on your hard disk. With our automated Setup utility, it's easy. The Setup utility takes you through all the installation steps and even starts GeoWorks Pro for you automatically when finished.

When you finish installing the software, you should take a moment to fill out and mail in the registration card, packed separately in the box. This will make you a registered owner. We'll keep you informed about new versions of GeoWorks Pro and other new products. (Better yet, we usually give special discounts to registered owners ordering software upgrades.)

1. Start your computer in the normal manner (see the DOS reference manual that came with your computer for more information about using DOS).
2. Place the disk labeled “Disk 1” in the proper drive (usually drive A, the floppy disk drive—or the top drive, if you've got two).
3. At the DOS prompt, type a:setup (or b:setup if you've placed the disk in the second floppy drive) and press [Return]. The Setup program explains everything else you need to do.

You'll need to use your mouse to complete the installation. If you've never used a mouse before, turn to page 2.5 (“Using the Mouse”) for some simple instructions.

If for any reason the installation did not go smoothly and successfully, don't despair. At the dos prompt, type c:\geoworks\geohelp and press [Return]. This activates a special help program that will help you to successfully install GeoWorks Pro. Just follow the directions that appear on the screen.

GETTING STARTED
STARTING GEOWORKS PRO

The Setup utility automatically starts GeoWorks Pro for you, so you won't need to follow these steps until you run GeoWorks Pro the second time. During installation you're asked if you would like to be able to start GeoWorks Pro no matter what DOS directory you're in; if you answer yes, then skip straight to step 3.

1. Switch to the disk drive where you installed GeoWorks Pro. Normally, this is drive C, unless you changed this during installation. Type
   
   c:
   
   and press [Return]. (Remember, you always have to press [Return] after you enter a DOS command.)

2. Switch into the proper directory. The Setup program loads everything into the GEOWORKS directory unless you told it otherwise; if you did, in fact, tell it otherwise, then type the directory name you specified instead of GEOWORKS.
   
   Type the following,
   
   cd \geoworks
   
   and press [Return], of course.

3. Start PC/GEOS by typing
   
   geos
   
   and pressing [Return].
   
   The first thing you see is the Welcome screen, which is your gateway to the different parts of GeoWorks Pro.
PERUSING THE WELCOME SCREEN

The Welcome screen is the first thing you see when you enter GeoWorks Pro. Here are some of the things you see:

- Your personal serial number. Use this number if you call customer support and also in your correspondence with GeoWorks.
- There’s a button that gives you on-line help if you need it. (i)
- There’s a button that sends you back to DOS. Click the Exit button to leave GeoWorks Pro. Don’t click it now. (i)
- One button takes you to the Beginner Workspace. If you’ve never used a computer or mouse before, then this is a handy place to start. Here you find software *appliances*—programs as simple to use as the toaster in your kitchen. All you have to know how to do is click the mouse. (i)
- The next button takes you to the Intermediate Workspace, a simplified version of the Advanced Workspace. The same applications are available to you, but your interaction with them is kept very simple and straightforward. (i) This is the workspace that we’ll explore in this tutorial.
- And there’s a button that takes you to the Advanced Workspace. Here you have access to all the power and functionality of GeoWorks Pro applications. (i)
- The DOS Programs button brings you to the DOS programs screen. There you can set up buttons to launch DOS based programs. (i)

If you’ve used a mouse before, go ahead and click the Intermediate button. If you’re new to using a mouse, read on to learn some basic mouse techniques.
USING THE MOUSE

The mouse, pointer, and buttons are to GeoWorks Pro what a hammer and nails are to a carpenter—indispensable. But, like any new tool, using a mouse takes a little practice, and sometimes a little patience.

1. Put the mouse down on the table top, with its rolling ball underneath.
2. Hold it in your hand with your fingers resting lightly on the buttons.
3. Now move it around. As you move the mouse, an arrow-like pointer moves around the screen, following the movement of your mouse. Move the mouse left, and the pointer moves left. Move it right, and the pointer moves right.
4. As the pointer moves across the screen, it changes shape depending on what’s underneath it. When it’s over a place where you can type text, it changes into an I-beam. And when the computer’s busy doing something and you have to wait, the pointer turns into an hourglass.
CLICKING A BUTTON

When you press buttons on a microwave or an answering machine, you make something happen. If it’s the on/off button, you turn the machine’s power on or off. If it’s the rewind button on your answering machine, you rewind the tape. You also use GeoWorks Pro buttons to make things happen.

1. Move the mouse to position the tip of the pointer over the Intermediate button.
2. Being careful not to jiggle the mouse out of position, press down on the left mouse button. The button on the screen turns black to show that it’s being clicked.
3. Release the mouse button. On the screen, the button returns to normal, and whatever action clicking the button causes to happen actually happens.
4. If you haven’t already, click the Intermediate button. This brings up the File Cabinet Window. File Cabinet and any other applications you use in GeoWorks Pro appear in what’s called the workspace. The workspace is like your desktop—it’s where you put everything you’re working on (and possibly a few things you’re not).
**STARTING THE FILE CABINET**

When you enter the Intermediate area, the File Cabinet *window* appears. Like the papers on your desk, windows are the medium you use to do work. Everything that you do, you do inside a window of some sort, and each kind of window has a specific purpose. You manage documents inside the File Cabinet window, or write letters inside the GeoWrite window.

• If you haven’t already done so, in the Welcome screen, click the Intermediate button. The File Cabinet window appears. (1)
• Notice that that there are different types of icons (pictures) in the window. (2)
• Each icon that looks like three pieces of paper in a pile represents a GeoWorks Pro document. (When you open one of these documents, its window covers up the File Cabinet window.) (3)
• Each icon that looks like a manila folder represents a directory. (4)
OPENING A FOLDER

A directory is the computer equivalent of a file folder. A file folder usually contains documents and—with difficulty—other file folders. Similarly, computer directories also contain documents, but, unlike their real-world counterparts, they can just as easily contain other directories. These other directories can, in turn, contain directories too. And so on. Directories that contain other directories are called parent directories.

Unlike DOS, documents in the File Cabinet not only have names (and long ones at that) but also little pictures to represent them. These pictures are known as icons. You'll find little pictures such as these all over GeoWorks Pro, although not all of them represent documents.

To perform some action on a document or directory—or just about anything for that matter—you must first select it. Selecting is your way of telling the computer that your next command should affect the selected file.

For example, let's say that you want to open up a directory to see what's inside.

1. Using the mouse, move the pointer so that its point is over the LETTERS directory icon.
2. Click. The LETTERS icon darkens, indicating that it is selected.
3. Click the Open Directory button (it's labeled “Open Dir”). The LETTERS directory window appears. You are now looking at the contents of the LETTERS directory (which is contained within the DOCUMENT directory).
4. If you're ever confused about which directory you're in, look at the path at the top of the File Cabinet window. It shows, from left to right, all the directories you went through to reach the directory you're now viewing. Reading a path is a little like looking at one branch of a family tree: each directory is the parent of the directory to its right, where the rightmost directory is the one currently shown in the window.
OPENING A TEMPLATE

Whereas directory icons look like file folders, document icons look like, well, little documents. When you open a document, it automatically starts a corresponding application, the computer program that you use to create and edit the contents of the document. For example, if you wanted to write a letter, you would need to open a GeoWrite document (one created with the GeoWrite application). GeoWrite gives you the writing tools you need to create letters, reports, newsletters, or whatever. Likewise, to pull some clip art out of a scrapbook, you'd need to open a Scrapbook document (one created with the Scrapbook application). Different types of documents have different looks to their icons, so that you can readily tell the kind of application associated with the document.

(If all this talk of applications confuses you, don't worry. After you've used GeoWorks Pro for a while, it will probably make more sense to you.)

Let's open a document that was created with GeoWrite.

1. Click the icon that says "Blank Letter" under it to select the document. Many of the File Cabinet buttons light up when you select the document—this lets you know that they are now available for use. Before you selected the document, the buttons were dimmed, meaning that their actions were not available to you at that moment. (1a)

2. Click the Open button. The GeoWrite application starts and a dialog box appears, telling you that the document you've just opened is a template, so you'll need to give it a name of your own when you're finished.

3. Click the OK button. This gets rid of the dialog box. (Clicking OK is, in a sense, your part of the "dialogue." By clicking it, you're saying that yes, you've read the message and you want to get on with your work.)
ADDING TEXT TO YOUR DOCUMENT

You should now be looking at a blank GeoWrite document. The next step is to fill that blank document with words (we’ll add some illustrations later). In this section you’ll use GeoWrite to type words into your document and in the next section you learn how to edit what you type. In fact, the text skills you learn here apply any time you ever need to enter text any place within GeoWorks Pro.

1. Move the pointer around the white space in the center of the screen. (This is called the body area.) Notice how the pointer now looks like an I-beam, meaning that you can type here.

2. With the I-beam pointer still somewhere in the body area, click. A thin blinking line appears at the upper left corner of the body area. This is the text cursor—showing you where the text will go.

3. Type in the letter below. The cursor rides along at the end of the text you’re typing, indicating where the next character will go. Note the order—first you click to place the text cursor, then you type. (Of course, if the text cursor is already where you want to type something, you don’t need to place it there again.) Be sure to press (Return) when indicated.

Murtnik Travel (Return)
211 Mulberry Avenue (Return)
Mudville, Maine 012783 (Return)
(Return)
Dear Frequent Traveler, (Return)
First of all, I’d like to thank you for allowing Murtnik Travel to assist you in your travel plans. We hope our service has proved helpful. (Return)
Because you are a frequent traveler (our records show that you’ve booked over 50,000 flight miles with us) we’d like to offer you a special gift, one you can use in all your travels. Bring this letter with you the next time you visit our offices, and we’ll give you your gift. You don’t even need to be planning a trip! (Return)
(Return)
Sincerely, (Return)
(Return)
John Murtnik (Return)
Travel Consultant
Notice that when you type enough text to go beyond the right margin of the page, the cursor automatically moves down to the next line. Unlike using a typewriter, you do not need to manually return the carriage when you reach the end of a line. This is called text *wrapping*. If the last word hangs out past the right margin, the entire word is moved down to the next line.

Here are four easy-to-remember rules that give your document a professional look:

1. Don’t press `Return` at the end of *every* line—just those where you want to start a new paragraph. The application automatically jumps to the next line for you.
2. Press `Return` at the end of each paragraph.
3. Press `Backspace` to delete the character to the left of the cursor, or `Delete` to delete the one to the right.
4. Type only one space after punctuation, including periods. (Trust us on this one.)
EDITING TEXT

Things you type in are not chiseled in stone—you can edit them at any time. This is the beauty of an electronic word processor: no matter where you type text, you can immediately change it.

INSERTING TEXT
1. Position the I-beam pointer at the spot in the text where you want to insert something. Click. You'll see the text cursor appear at this point. Anything you type is inserted there. If you missed, simply move the I-beam pointer to the correct space and click again.
2. Type.

CHANGING TEXT
3. Position the I-beam pointer to the left of the S in the word “Sincerely” at the bottom of the document. Press and hold down the left mouse button and drag the pointer to the right until you’ve highlighted all of the word “Sincerely.”

This new mouse action—pointing, holding down the mouse button, and moving the mouse—is called dragging. You'll use dragging a lot as you work. (Dragging is something you use often to select text in GeoWrite. You can also use dragging in the File Cabinet to move documents around.)
4. Type the words “Thank you.” The highlighted text is completely removed and replaced by whatever you type. (Instead of typing something, you could also press [Delete] to erase the highlighted text without actually inserting anything new in its place.)
CHANGING FONT, FONT SIZE, AND STYLE

In this section you learn how to use double-clicking to select words in your text. You’ll also learn and how to use menu commands to change the font, size, and style of those words. A menu is simply a collection of commands or choices listed together under a common heading at the top of a window. When you choose one of the commands or choices from a menu, you perform an action or a select item.

1. Move the I-beam pointer so that it’s on the word “Murtnik” in “Murtnik Travel.”
2. Quickly click the left mouse button twice (being careful not to jiggle the mouse so that it inadvertently moves). This technique is called double-clicking, and generally speaking, you can double-click anything that you normally click (single-click, that is). The whole word “Murtnik” becomes highlighted to show you that it’s been selected. You can use this method to select words in lieu of the click-and-drag method you used earlier.

Similarly, if you double-click on a word, then drag, each word you drag over is selected. This is useful when you want to replace, copy, or move a group of words.

3. Move the pointer to the word “Fonts” in GeoWrite’s menu bar (near the top of the window). Notice that the I-beam pointer changes back to an arrow pointer.
4. Click on the word Fonts. A list of different fonts appears.
5. Click Cooperstown. The word “Murtnik” changes from its old font (URW Roman) to the new font (Cooperstown). Generally, when you choose a command from a menu, it effects only what is currently selected. In this case, you had selected the word “Murtnik,” then you chose Cooperstown from the Fonts menu. Therefore only the word Murtnik changed.
6. To try another menu command, choose 18 Point from the Sizes menu. Now you’ve increased the size of the word from 12 points to 18 points.

Try a few more fonts and sizes while you have “Murtnik” selected. Also try choosing different styles from the Style menu—make the word bold, italic, or both. Notice that you don’t need to re-select the word “Murtnik” each time you make a change—a great time saver when you’re trying a lot of different fonts and styles to find something you like.

Note: “Points” are units used to measure type in the publish world. A point is about 1/72 of an inch, so text that’s 72 points tall is one inch tall; 36 point text is half an inch tall, and so on. Generally speaking, text used in the body of a letter or story should be 10 or 12 points tall.
SELECTING PARAGRAPHS WITH THE MOUSE

Whereas you can select words by double-clicking, you can select lines of text by triple-clicking, paragraphs by quadruple-clicking, and even a whole page by quintuple-clicking. Try using a quadruple-click and a drag to select two paragraphs of text.

1. Move the I-beam cursor so that it is somewhere—anywhere—in the first paragraph of the letter.
2. Click the left mouse button four times in rapid succession, and on the fourth click, bold down the mouse button. That's click, release, click, release, click, release, click and hold. (It's a little tricky the first time you try, but as you practice it becomes as natural as writing with a pencil.) The paragraph should become highlighted. If it doesn't, or just a word or line becomes highlighted, wait a second and try again.
3. Still holding the mouse button, drag the I-beam pointer to the next paragraph. It highlights, too.
CHANGING THE RULER

Now that you've selected a couple of paragraphs, you can change their styles using the ruler. The ruler is the bar along the top of the GeoWrite window that looks like—not surprisingly—a ruler. The top half of the ruler, with the tick marks, measures the width of the document and the bottom half, with all the little icons, controls the style of the current paragraph. (The current paragraph is the one with the text cursor in it, or in the current example, the selected paragraphs.)

1. Move the I-beam pointer so that it's in the ruler bar. (The I-beam turns back into an arrow pointer.) Click on the first line indentation marker—the top half of the little triangle on the left side of the ruler—and hold down the mouse button. This “picks up” the indentation marker, and the arrow pointer itself turns into a little triangle.

2. Still holding the mouse button down, drag the triangle pointer a quarter inch to the right (to get the measurement correct, use the ruler ticks as a guide).

3. Release the mouse button. The pointer turns back into an arrow pointer and the indentation triangle is “dropped” at its new position. Look at the paragraphs. They're now indented a quarter of an inch.

4. Now change the justification of your paragraphs. Move the pointer so that it's over the full justification icon. Click. Your paragraphs become fully justified—that is, stretched to fit exactly within the margins.
SAVING YOUR WORK

It's very important for you to understand the concept of "saving" your work. You may think that the letter you've been working on is "in" the computer—and therefore available to you tomorrow, the next day, or a year from now—but in fact what you're currently working on is only temporary. Turn off your computer right now, and the letter is lost forever. You have to explicitly instruct the computer to store your letter away for later work. This instruction is referred to as saving the document, and you should get in the habit of saving your work often. (Imagine how you'd feel if you'd spent hours working on a document and then accidentally turned off your computer before you saved it. Ouch!)

Let's save your GeoWrite document.

1. Choose Save As from the File menu. A file selector dialog box appears. Remember, a dialog box is any box that GeoWorks Pro brings up to tell you something or ask you for information—often both. A file selector is just a specific kind of dialog box. We'll show you more about using file selectors in the next section.
2. Click in the box that says Name. A text cursor appears (if it doesn't, try clicking again in the Name box).
3. Type a name for your document, like "My Letter." You can edit this text the same way you edited text in GeoWrite. (DOS lovers, take note: your document names can be up to 32 characters long, and can contain upper and lower case letters, spaces, even special characters!)
4. Click Save when you're ready to save the document—but not yet! First read the next section to learn some of the subtle points about File Selectors.
USING A FILE SELECTOR

On your screen you should see, from the previous section, the Save As file selector. GeoWorks Pro usually uses a file selector to ask you where you want to put a document or where it can find a document. In this case, GeoWorks Pro is asking you where (in which directory) you want to save your GeoWrite document. Let's use the file selector to tell GeoWrite to save your document in the DOCUMENT directory.

Before you begin, look at the current directory path, next to the Parent Directory button. It should say \GEOWORKS\DOCUMENT\LETTERS, indicating that, if you saved the file right now, it would be saved in the directory containing the original GeoWrite template (the LETTERS directory). Your path may be different depending how you've set up your system.

1. Move up one level to the DOCUMENT directory by clicking the Parent Directory button. The second line of the path changes to read \GEOWORKS\DOCUMENT. Also, the directory contents list changes to show the contents of the DOCUMENT directory.
2. Actually, that's all you need to do. But just for practice, return to the LETTERS directory by double-clicking its name in the directory contents list (you'll have to scroll the list until the name appears—see "Moving Through the Scrapbook," below, to learn how to scroll a window). To open any directory in the list, just double-click it.
3. Click the parent directory button again to go back to the DOCUMENT directory, and click Save to save your document there.

You'll see file selectors all over GeoWorks Pro—not just in GeoWrite. And, while each one is a little bit different, you'll see that they all work basically the same way.
SWITCHING BACK TO THE FILE CABINET

GeoWorks Pro allows you to use several applications at the same time. Right now, if you’ve been following the steps so far, the File Cabinet application and the GeoWrite application are both running. If you look at the screen, though, you only see the GeoWrite window. That’s because GeoWrite’s window is in front of the File Cabinet window (like those papers on your desk—you only see the ones at the top of the pile).

It’s easy to switch back and forth between applications—all you need is the Express menu. (Remember that a menu is a collection of commands listed together under a common heading at the top of the window.)

Let’s use the Express menu to switch back to File Cabinet.

1. Click the Express button at the upper left corner of the window. The Express menu appears. It lists any open applications (you should see GeoWrite and File Cabinet listed), as well as two commands: the Printer Control Panel, and Exit to DOS.

Notice the Diamond-shaped buttons next to each application’s name. These are radio buttons. Radio buttons work together like the buttons on an old-fashioned car radio—if you push one in, the other pops out, so only one can be in at a time. In the same way, only one radio button can be “on” at any given time. You see radio buttons when you can only choose one option from many. (1a)

2. Click the radio button next to where it says “File Cabinet.” The File Cabinet window pops up to the front. Although now you only see the File Cabinet window, GeoWrite is still there, with your document still open, behind the File Cabinet window. The two windows have changed places.
OPENING A SCRAPBOOK DOCUMENT

The Scrapbook application allows you to store a collection of pictures and text in one location—a scrapbook document—so you can retrieve them quickly and add them to your GeoWrite documents. In this section, you’ll open a Scrapbook document that’s already filled with images. But first, you need to go back to the DOCUMENT directory.

MOVING UP DIRECTORIES To move back to a directory’s parent directory (remember, the parent directory contains the directory that you currently see in the window) you must close the current directory.

1. Click the Close Dir button. The DOCUMENT directory reappears in the window.

OPENING GEOWORKS CLIPART Instead of opening a directory or document by selecting it and clicking Open, you can open it by double-clicking its icon.

2. Place the pointer on the CLIPART folder and double-click the left mouse button—using the same double-clicking action you used to select words in GeoWrite. The CLIPART directory window appears.

3. Now double-click the Clipart document icon.

4. You’ll see the “read-only” dialog box again—only this time it’s for the Clipart document. Click OK.
MOVING THROUGH THE SCRAPBOOK

The Clipart scrapbook is filled with images that you can easily add to your GeoWrite documents. In this section, you learn how to move through the scrapbook to find an image, how to see the whole image using scroll bars, and how to copy that image to the clipboard. The clipboard is an invisible holding place for text or pictures that you want to paste (place) into a document.

1. Click the Next button until you come to the picture of the ship—it's number 7. (The word “Ship” should be in the Name box, below the picture.) If you go too far, click the Previous button.

2. Choose Enlarged to 200% from the View menu. This doubles the size of the image, so now a larger version of the ship appears in the window. Notice that to the right of and below the image of the ship are two long thin bars with arrows at the end. These are scroll bars. Scroll bars appear in any window that can't show its entire contents. Click the arrow that points down a few times. The ship seems to “move” up, but it's better to think of it as your view of the ship moving down, in the direction of the arrow. (2a) Now click the arrow that points up. Your view of the ship moves back down. (2b)

3. Choose Reduced to 50% from the View menu so that the ship is now half of its original size.

4. Choose Copy at View % from the Edit menu. The image is copied (at half its original size) to the clipboard (where it will remain until you copy or cut something else). You can now paste this image into other applications like GeoWrite or GeoDraw.

Note: Enlarging the view to 200% or reducing it to 50% doesn't actually change the size of the image. It only changes how big it appears in the window, like you were looking through a magnifying glass. When you choose Copy at View % to place it in the clipboard, you're copying it at its adjusted size. If you had wanted to copy the original version, you would have chosen Copy instead.
PUTTING IMAGES INTO GEODRAW

Now that you have something on the clipboard, you're almost ready to paste it into your letter. But first let's paste it into a GeoDraw document, so we can modify it slightly.

1. Choose File Cabinet from the Express menu. This brings File Cabinet back to the front of the screen, making it the active window. You should be looking at the CLIPART directory. Click the Close Dir button to go back up to the DOCUMENT directory.

2. Open the document labeled "New drawing" by double-clicking its icon. Again, click OK when you get the read-only dialog box. GeoDraw starts and opens a new blank document. In the center of the window, like in GeoWrite, is the space—called the drawing area—where you do your work.

3. Choose Paste from the Edit menu. The illustration of the ship appears in the center of the drawing area. Where did it come from? From the clipboard, where you copied it in the last section. The ship is now a GeoDraw object—that is, something that you can manipulate with GeoDraw tools.

   Notice the little black squares around the ship's perimeter and the black diamond in its center. These are called handles, which you drag with the pointer to move, rotate, and stretch the object.
**ADDING TEXT TO YOUR PICTURE**

GeoDraw comes with a collection of drawing tools, which you can use to change the samples that we've supplied or even create your own drawings. These tools are located in the *Toolbox*. To use a tool simply click its icon in the Toolbox. The pointer changes to reflect the tool you've selected, and stays that way until you select another tool. Let's use the text tool to add text to the picture of the ship.

1. Click the Text Tool icon (the one that looks like a the letter “T”) in the Toolbox. The icon turns black to indicate that it's been selected. Then move the pointer into the drawing area—notice how the pointer changes to an I-beam pointer like the one you used in GeoWrite.

2. Click somewhere in the drawing area. A box with a dotted-line border appears. This box is called the *text box*, and it shows where your text will be placed. You should recognize the thin blinking line that appears—the text *cursor*. Just as in GeoWrite, it shows you where text you type will go.

3. Type “Murtnik Travel”. The text you type shows up in the text box.
ROTATING THE TEXT

Like the Text Tool, most of GeoDraw's tools are used to *add* text or objects in your drawing. But GeoDraw has two tools that actually create nothing—they are only used to manipulate objects that you've already drawn or typed. The rotation pointer is an example of one of these tools (the other is the simple pointer tool). The rotation pointer is so named because it's used to rotate objects, text blocks, or both.

1. Click the rotation pointer icon (the one that looks like a curved pointer) in the Toolbox. Now move the pointer into the white *drawing space*. Notice how the arrow pointer is now curved—it looks like the icon in the Toolbox.

2. Click anywhere on the text you just typed. The handles for the text box appear. You know an object (text objects included) is selected when you can see its handles.

3. Position the pointer on the upper-right handle. Click and hold down the left mouse button. As you hold the button, move the mouse (*drag* it) up and to the left. An outline of the text box rotates around its center in the direction you move. (3a)

4. Release the mouse button when the outline is rotated 90 degrees. The text, handles and all, rotates to match the outline. It should now be reading vertically. If the text is not quite 90 degrees from its original position, grab the handle and try again. (Rotating takes some practice so don't dismay if you have a little trouble getting it right the first time.)
MOVING YOUR SHAPE WITH THE POINTER

Once you create an object, you can move it anywhere in the drawing area. Let's move the ship next to the text you just rotated.

1. Move the rotation pointer to the ship and click. The ship's handles appear to show you that it's selected.

2. Click and *drag* the diamond-shaped handle in the center of the illustration (on the bow of the ship). An outline of the polygon moves in the direction you drag. Remember, to drag anything, you must click the left mouse button and *hold it down*.

3. Drag the outline of the ship so that it's right next to the words “Murtnik Travel.”

4. Release the mouse button. The ship moves to its new location.
PUTTING YOUR MODIFIED IMAGE ON THE CLIPBOARD

Now that you have modified the image, you can put it on the clipboard so that you can transfer it to your letter document.

1 Choose Select All in the Edit menu. Handles appear around your image and around the text you just typed. Each object can be selected individually or together as we’ve done here.

2 Choose Copy from the Edit menu. This copies the modified image to the clipboard. Remember, anything you copy to the clipboard only remains there until you copy (or cut) something else. If you were to copy another item, the new item would replace this one on the clipboard.
PASTING IMAGES INTO YOUR DOCUMENT

With the modified image on the clipboard, you’re almost ready to paste it into your letter. But first, you must switch back to GeoWrite (that is, bring its window to the front).

1. Choose GeoWrite from the Express menu. This brings GeoWrite back to the front of the screen, making it the active window (the windows out of sight behind it are, of course, inactive).
2. Move the I-beam so it’s just to the left of the M in the words “Murtnik Travel.” Click to place text cursor there. This is where your picture will be placed.
3. Choose Paste from the Edit menu. The ship logo appears in your document where the text cursor was, and the text cursor moves to the right. For all practical purposes, this picture is just like any bit of text in the document—you can cut it, move it, and delete it quite like you would regular text.
4. Press Return to move the words “Murtnik Travel” down a line.

Dear Frequent Traveller,

First of all, I’d like to thank you for allowing Murtnik Travel to assist you in your travel plans. We hope our service has proved helpful.

Because you are a frequent traveller (our records show that you’ve booked over 50,000 flight miles with us) we’d like to offer you a special gift, one you can use in all your travels. Bring this letter with you the next time you visit our office, and we’ll give you your gift. You don’t even need to be planning a trip!

Thank You,

John Murtnik
Travel Consultant

Murtnik Travel
211 Mulberry Avenue
Mudville, Maine 012783
PRINTING YOUR WORK

If you installed a printer when you installed GeoWorks Pro, you can now print your document. The print command is found in the File menu. For practice, though, instead of using the mouse to pull down the File menu and select Print, let's use the keyboard only.

1. On your keyboard, hold down the \texttt{Alt} key and press \texttt{F}. The File menu pops down. The \texttt{F} corresponds to the underlined \texttt{F} in the word "File." You can pull down any menu by pressing \texttt{Alt} and the menu's underlined letter.

2. Now press \texttt{P} (\texttt{P} is the underlined letter in the Print command in the File menu). Note that you only need to hold the \texttt{Alt} key when you want to pull down the menu. Once the menu is down, you can release it and simply press the letter of the command you want from the menu.

3. The Print dialog box appears, letting you change the way the document is printed. You could choose to make a crude, quick printing, were your document only a rough draft and you didn't need very sharp results. However, for the moment simply click Print. If you've set up your printer correctly, your document should print out like it looks on the screen.
SAVING YOUR FINAL VERSION AND EXITING GEOWRITE

Although you’ve already saved your letter once, that saved version doesn’t contain any of the changes you’ve made since then. If you were to leave GeoWrite now, you would lose all your recent work. So before exiting GeoWrite, let’s save the changed letter one more time.

1. Choose Save from the File menu. All the changes that you’ve made are now automatically saved in the file “My Letter.”

   Note that when you use the Save command (instead of the Save As command) GeoWrite does not ask you to name a new file. When you use the Save command, GeoWrite assumes you only want to update the original file—the one you’ve already named—not create a new one.

   When you are finished with a document, you should close it. That’s your way of telling GeoWorks Pro that you no longer need the document in front of you (and it frees up valuable computer resources). Likewise, if you’re also finished with the application, you should exit it too. The terminology for documents and applications is a little different—you close one and exit the other—but the result is essentially the same: the document or application window disappears from the screen. Let’s close the document “My Letter” and then exit GeoWrite.

2. Choose Close from the file menu. The document “My File” closes and its window disappears, leaving a large black area in the GeoWrite window. Note that the GeoWrite window is still open. Although you closed the document you were working on (My Letter), you did not exit the application you working in (GeoWrite).

3. Choose Exit from the File menu. The GeoWrite window disappears.
EXITING GEODRAW AND SCRAPBOOK

Now that you've closed GeoWrite, GeoDraw should be in the front. Let's close GeoDraw also, but by using a different method.

Some menu commands have *keyboard accelerators*. A keyboard accelerator is a single keystroke you can use to choose a particular menu item or command. If an item has a keyboard accelerator, the accelerator appears at the right edge of the menu. Not every command has a keyboard accelerator, but the Exit command does. Let's use it to exit GeoDraw.

1. Press `F3` to exit GeoDraw, which is the same as selecting Exit from the File menu. When it exits, GeoDraw automatically closes any documents you were working on.

2. Since you've never saved this GeoDraw document, GeoDraw asks you if you want to save the changes before you exit. If you want to save the ship logo, click Yes and use the ensuing file selector to give the file a name. If you do not want to save the file, click No. GeoDraw will close without saving the file. While in this case you should probably answer "no," generally speaking you should answer "yes" and save your work.

3. Now the Scrapbook window should be in front. If it isn't and File Cabinet is, use the Express menu to return to the Scrapbook application.

4. Double-click the Control button (at the extreme upper-left corner of the window, next to the Express menu). Your Scrapbook closes and its window disappears. The File Cabinet window should now be in front.

Double-clicking the Control button is identical to pressing `F3`, which in turn is identical to choosing Exit from the File menu. Use whatever method you like best.
SHUTTING DOWN GEOWORKS PRO

Now that you've created, saved, and printed a document using GeoWorks Pro, you are ready to tackle your own projects. Remember the tools you encountered in this tutorial, and know that there are many more you'll encounter as you explore. For now, shut down GeoWorks Pro and return to DOS. You should always do this before you turn your computer off.

1. In the File Cabinet window, click the Exit to DOS button. A dialog box appears, asking you if you're sure that you want to return to DOS.
2. Click Yes. You'll see the File Cabinet shutting down, and in a few moments you'll be back at the familiar DOS prompt.
3. It's OK to turn your computer off now.
BASIC TOOLS AND SKILLS

If you’re not new to computers, but you are new to GeoWorks Pro, this is the section for you. Like “Getting Started,” this section lays the foundation for your work with all the GeoWorks Pro applications. But here you’ll find in-depth discussions about the basic concepts fundamental to everything you do in GeoWorks Pro. Be sure to browse. Skip around. As a general rule, the chapter builds from the simplest concepts to the most advanced, with each section building on the one before.
THE MOUSE

The mouse is your pointer; in some ways, it's an extension of your fingers. Use it to press buttons on your screen (the way you use your fingers to press buttons in real life). Or use it to pick up a document and move it someplace else. The mouse and its attached on-screen pointer play an important part in working with different things in GeoWorks Pro.

Moving the mouse around on a flat surface moves a little picture of an arrow—the pointer—around in a similar fashion on the screen. Move the mouse a little to the right, and the pointer moves right also. Move it left and the pointer moves left. The pointer also occasionally changes shape to remind you what you're doing. For example, when your computer needs to take a moment to finish an operation, the pointer turns into an hourglass, indicating that you should wait a moment.

THE POINTER AND SOME OF ITS MANY SHAPES

Here are some common forms that the pointer takes on as you move it around.

**Arrow pointer** This is the standard pointer. You usually use it to click buttons and select things.

**Hourglass pointer** The hourglass (or busy) pointer indicates that the system is working hard to finish some operation—you shouldn't perform another task until this first one is completed.

**Circle/Slash pointer** When the pointer is outside of the *active area* of the screen (often, a dialog box that demands an answer before you can continue), it becomes a circle with a slash through it. This means hands off—you can't do anything outside of the active area—but you can still do things within the active area.

**I-beam pointer** When the pointer is over text or in a text box it turns into an I-beam pointer. You use the I-beam pointer to edit text.
THE MOUSE BUTTONS While you use the mouse itself to point, you use its buttons to actually take action.

You can control GeoWorks Pro with either a two-button or three-button mouse. If you have a two-button mouse, the buttons are referred to as “left” and “right.” If you have a three-button mouse, the buttons are referred to as—not surprisingly—“left,” “middle,” and “right.”

**Left button** The left button performs most operations in GeoWorks Pro. If the instructions don’t specify a particular mouse button to use, use the left one.

**Middle button** The middle button is rarely used in GeoWorks Pro because some mice don’t have one. (So don’t feel left out if yours only has two buttons.)

**Right button** The right button is for moving items around the screen. This is called *direct manipulation*. Not all direct manipulations require you to use the right mouse button, so this book will make it clear when you should.

HOLDING THE MOUSE Put the mouse on a flat surface, like a table top or a mouse pad, with its rolling ball underneath. The mouse’s tail (its cable) should be facing the computer. Not the way you’d hold a real mouse, in all probability, but this orientation is important so that the mouse works correctly. Hold it by the sides with your index finger resting lightly on the buttons.

MOVING THE POINTER AND CLICKING

To control GeoWorks Pro, you move the pointer around the screen until it’s over an item you want to use—such as a button, a menu item, or an icon—and then press and release the mouse button. Moving the pointer over an item is called *pointing* to the item. Pressing and releasing the mouse button quickly is called *clicking* (or, more specifically, *single-clicking*).

To move the pointer on the screen...

1. Place the mouse on a flat surface. The cord should face away from you.
2. Move the mouse in any direction. The pointer movement corresponds to the movement of the mouse.

If you ever want to move the mouse without moving the pointer, lift the mouse off of its surface and place it down somewhere else. The pointer stays where it is.

To click an item on the screen...

1. Position the pointer so that its tip is over the item you want to click.
2. Press and release the mouse button—usually the left one—one time.
ICONS

Icons are small pictures on the screen that represent things you can work with. A file icon in the GeoManager window represents a file on your disk drive. Different files have different icons, to identify the kind of files they are.

A folder icon in the GeoManager window represents a directory on your disk drive. Because directories appear as folders in the GeoManager window, “directory” and “folder” are often used interchangeably.

For instance, dragging a file icon to the Wastebasket deletes the file. (Be careful. Whatever you put in the Wastebasket is removed permanently from the disk and cannot be retrieved.)

BUTTONS

When you press buttons on a microwave or an answering machine something happens. If it’s the on/off button, you turn the machine’s power on or off. If it’s the rewind button on your answering machine, you rewind the tape. You also use GeoWorks Pro buttons to make things happen. An example: Click the Intermediate button on the Welcome screen and you enter the Intermediate Workspace.

On color or grayscale screens, buttons have 3-D styling that makes them look like slightly raised parts of the screen. On monochrome or CGA monitors, on the other hand, buttons are merely outlined. In GeoWorks Pro, buttons are usually distinguished from one another by an icon or a written title—sometimes both.

The first buttons you see when you start GeoWorks Pro are the four buttons on the Welcome screen: the Beginner, Intermediate, Advanced, and DOS Programs buttons.

The Welcome screen with the Beginner, Intermediate, Advanced, and DOS Programs buttons.
CLICKING BUTTONS You activate buttons by clicking them.

To click a button (or just about anything)...
1. Position the pointer so that its tip is over the button.
2. Being very careful not to jiggle the mouse out of position, press down the left mouse button.
3. When the button turns black to show that it’s being clicked, release the mouse button. On the screen, the button returns to normal. At this point, whatever action clicking the button causes actually happens.

   If you inadvertently moved the pointer off the button before you released the mouse button, the button would also return to normal, only the action wouldn’t happen. It’s important that the pointer still be on the button when you release the mouse button.

DOUBLE-CLICKING

A double-click often provides a shortcut way of doing something you would normally do with several single-clicks, such as starting an application with Geo-Manager. Double-clicking is done with two quick clicks of the mouse button.

To double-click an item on the screen...
1. Position the pointer over the item you wish to double-click.

The trick to double-clicking is steadiness and speed: Don’t jiggle the mouse as you press and release quickly. You might need some practice to get it just right.

TRIPLE-CLICKING, QUADRUPLE-CLICKING, QUINTUPLE-CLICKING, AND MORE.

Above and beyond double-clicks, there are triple-clicks (three clicks), quadruple-clicks (four clicks), and even quintuple-clicks (five clicks). Multiple clicks are useful in a variety of situations, such as selecting text. In a word processor, for example, each successive click selects a larger unit of text—a double-click selects a word, a triple-click selects a line, a quadruple-click selects a paragraph, and a quintuple-click selects an entire page.

PRESSING

Pressing means positioning the pointer over something and then pressing and holding down the mouse button. Pressing an item on the screen is like pressing and holding a key on your keyboard—the keystroke repeats automatically, and keeps repeating until you take your finger off. In the same way, some buttons keep doing something while you keep holding down the mouse button. For example, pressing on a down arrow—such as those used to scroll through lists—causes the list to scroll continuously.

To press an item on the screen...
1. Position the pointer over the item you want to press.
2. Press and hold down the mouse button, being careful not to move it out of position. The continuous action (if there is one—not everything works this way) begins.
3. Release the mouse button. The continuous action stops.
**DRAGGING**

Dragging means pressing and holding down the mouse button while moving the mouse. Dragging is one way to browse through menus and choose commands. It is also convenient for moving and resizing windows, and for selecting text.

You can also use dragging to pick up items and move them around the screen (direct manipulation).

**To drag an item on the screen...**

1. Position the pointer where you want to begin dragging.
2. Press and hold down the mouse button. Depending on what you're trying to do, it can be the right or left button.
3. Move the pointer in any direction.
4. Release the mouse button.

**APPLICATIONS AND DOCUMENTS**

Programs you run in GeoWorks Pro are called *applications*. You use applications to create and edit *documents*. A document can be a one-page letter, a ten-page report, an architectural drawing, or even a complete address book with names and addresses. Documents are stored as files on your disks. They are similar to the files you create and save with DOS programs.

Each application in GeoWorks Pro uses a unique type of document. A graphics application uses graphics documents, a word processor application uses word processor documents, and an address book application uses address book documents. You can't open a word processor document with a graphics application, or vice versa, because the documents are of different types—but you *can* share information between the two documents by cutting and pasting. More on this later.

**NAMING DOCUMENTS, DOS FILES, AND DIRECTORIES**

**GEOWORKS PRO DOCUMENTS** The names of GeoWorks Pro applications and documents can be up to 32 characters long, including spaces and punctuation.

Some good file names:

- Travel Report:
  - Trip to Maine 01/12
  - Letter To Mom
  - Cubism Study #1

**DOS FILES AND DIRECTORIES** The names of directories and DOS files must conform to the standard DOS format. The filename can be from one to eight characters long. You can use both numbers and letters in the filename, but no spaces or punctuation. An optional *filename extension* follows the filename and begins with a period.

Legal DOS file and directory names:

- MYFILE1.TXT
- RUN_THIS.BAT
- OVERTHEH.ILL

Names that won't work:

- BAD NEWS (no spaces)
- LONGFILENAME (Too long)
**Windows**

Windows are the rectangular areas of the screen where information appears. Windows may be moved and stacked like sheets of paper on a desktop, and, like a bunch of papers, they may overlap one another. The metaphor doesn't stop there—you may also flip back and forth from one window to another just as easily as if you were flipping from one sheet of paper to another. All you have to do is move the pointer over the window you want to see, and click; the window pops to the top of the pile.

**Title bar** The title bar names the contents of the window—or, more often, the application that corresponds to the window. Move a window by dragging its title bar.

**Menu bar** If an application has menus, the menu names appear on the menu bar, right below the title bar. Not all windows have menus.

**Menu name** Clicking a menu name brings down the pull-down menu.

**Control button** Double-clicking the Control button closes the window. Single-clicking the Control button displays a special menu, the Control menu.

**Express button** Clicking the Express button displays the Express menu. The Express menu contains options for switching between running applications, starting new applications, returning to the Welcome screen, checking on documents being printed, setting your system preferences, and exiting directly to DOS. Very handy.

**Maximize/Restore button** Clicking the Maximize button enlarges the window to completely fill the screen. The window loses its resize borders and can no longer be moved or resized, and the Maximize button is replaced by the Restore button. Click the Restore button to return the window to its previous size.

A typical window in GeoWorks Pro. The different parts of the window are:
- Title bar (○)
- Menu bar (△)
- Menu name ( ○)
- Control Button (□)
- Express button (□)
- Maximize/Restore button (□)
- Minimize button (□)
- Resize borders (□)
- Scroll bar (□)
Minimize button Clicking the Minimize button collapses the window into an icon, moving it out of your way temporarily. Minimizing an application’s window does not exit the application or stop it from running, but merely makes it small enough so that it’s not in your way. Double-clicking the icon restores the window (and application) to its original size.

Resize borders Dragging a resize border in any direction resizes the window.

Scroll bar When the contents of a window are larger than the window itself, scroll bars appear at the right and bottom edges of the window. Scroll bars let you scroll the contents of the window to see different parts.

ACTIVATING WINDOWS The active window is the window you are currently working in. It’s also the window in front of all the others—no part of the active window is underneath another. You can also tell which window is active by looking at the title bar. If it’s dark, the window is active; if it’s gray, the window isn’t.

To activate a window...
Click in the window you wish to activate. The best place to click is the title bar (since you don’t run the risk of accidentally clicking some button within the window at the same time), although you can click anywhere inside the window. The window moves to the top of the pile and its title bar is highlighted.

If you’ve run more than one application, you can switch between them by activating their respective windows. If the window you want to activate is completely obscured by other windows, you should move or close the windows on top.

MOVING AND RESIZING WINDOWS By moving and resizing windows you can rearrange the workspace to suit your needs, the way you might arrange your desk by putting some papers here and others over there. You move a window by dragging its title bar. You resize a window by dragging its resize borders.

To move a window...
1. Position the pointer over the title bar of the window you wish to move.
2. Press and hold down the mouse button. The pointer changes and a rectangular outline of the window appears.
3. Drag the outline in any direction.
4. Release the mouse button. The window redraws at the location of the outline.

The easiest way to switch to another application is to click on that application’s window.
To resize a window...
(1) Position the pointer over one of the resize borders on the window. The pointer changes shape to show you which edge or edges you are resizing.
(2) Press and hold down the mouse button. An outline of the window appears.
(3) Drag in any direction. The outline shrinks or grows as you move the pointer.
   If you drag a horizontal or vertical border, the outline shrinks or grows horizontally or vertically only. If you drag a corner border, the outline shrinks or grows in both dimensions, horizontally and vertically.
(4) Release the mouse button. The window redraws to the size of the outline. Some windows have a minimum size, beyond which you cannot shrink it. If you try, the window will automatically bounce back to its minimum size.
   Windows without resize borders (like dialog boxes, or maximized windows) can’t be resized.

To minimize a window...
   Click the Minimize button. Or, choose Minimize from the Control menu.

To maximize a window...
   Click the Maximize button. Or, choose Maximize from the Control menu. Or, double-click the window’s title-bar.

To restore a minimized window...
   Double-click the window’s icon.

To restore a maximized window...
   Click the Restore button, which has now replaced the Maximize button at the upper right corner of the window. Or, choose Restore from the Control menu. Or simply double-click the window’s title bar.

THE CONTROL BUTTON AND MENU The Control menu is a special menu that specifically gives you control over windows. To see the Control menu, click the Control button in the upper-left corner of most windows. If you double-click the Control button the current window closes.

Here are the items on the Control menu:
Restore is only available when a window is maximized. It returns the window to its previous size so you can move and resize it as usual.

MINIMIZING AND MAXIMIZING WINDOWS Windows are normally resizeable. Sometimes, though, you want a window to be as big as possible, so that you can fit the most information in it. Or you want it to be as small as possible, so that it’s out of the way. With the Maximize and Minimize buttons, you can quickly reach these extremes without having to painstakingly resize the window.

- Minimizing collapses a window to an icon. (Minimizing an application does not exit the application or stop it from running, but merely shrinks it to an icon.)
- Maximizing enlarges the window to fill the whole screen. When maximized, a window has no resize borders. If you want to resize the window, restore it first.
Move This item is always dimmed and unavailable.
Size This item is always dimmed.
Minimize collapses the window to an icon.
Maximize enlarges the window to fill the entire screen.
Close closes the window, and if it’s an application window, also exits the application.

SCROLLING WINDOWS
When the contents of a window cannot fit completely within the window itself, scroll bars appear. Scroll bars let you scroll the window to view more of its contents. You can scroll a window to the right, for example, to see parts of a document located beyond the right edge of the window. Or you can scroll a window up, to see portions of a document located off the bottom edge. Scroll bars have several controls that allow you to move the contents of a window in different ways:

Scroll arrows Clicking a scroll arrow scrolls the window a single step in a particular direction. For example, clicking a down-facing arrow shifts the contents of the window up to reveal more of the document at the bottom. If clicking the down arrow to move the window up doesn’t sound completely logical, think of it as letting you see farther down the document. And the other way around with the up arrow (and left and right arrows), of course.

Slider The entire length of the scroll bar represents the total length of the document, while the length of the slider within it represents that part of the document that is currently visible within the window. The longer the slider, the more of the document that’s showing. A short slider could mean that your document is much larger than the window, or that the window’s unusually small, or both. If the slider covers the complete length of the scroll bar, the whole document is showing.

In addition to indicating how much of the document is showing, the slider tells you what part of the document appears in the window. If the slider is at the bottom of the scroll bar, the bottom of the document is showing in the window.

The slider allows you to move freely through the document. You can drag the slider across the whole scroll bar, or move it just a little. Your view of the document changes proportionally.

Paging areas The paging areas on either side of the slider represent the portion of the document hidden from view. Clicking in a paging area scrolls the document one window-full at a time.

To scroll a window in small steps...
Click the scroll arrow. The window scrolls a small step (usually one line) in the opposite direction of the arrow (click the down arrow to move the document up and reveal another line at the bottom of the window).

To scroll continuously, press (that is, click and hold down the mouse button) on the scroll arrow.

To scroll a full window at a time...
Click one of the paging areas to scroll the window a window-full at a time. The window scrolls in the direction of the nearest scroll arrow. In other words, if you click the paging area below the slider, the document scrolls up to reveal more of the document below. And the other way around if you click the paging area above the slider.

To scroll continuously a full window at a time, press (hold down) the mouse button with the pointer over a paging area.
To scroll directly to a particular position...

1. Position the pointer over the slider in a scroll bar.
2. Press and drag the slider to a new position.
3. Release. The window scrolls to match the position of the slider.

**WINDOWS WITHIN WINDOWS** Windows can contain almost anything you see in GeoWorks Pro, including other windows. For instance, in GeoManager you can display directories in overlapping windows so that each directory is represented by a window inside the GeoManager window. You can resize, maximize, and move these windows, but you can’t minimize them.

**CLOSING WINDOWS** Closing a window removes the window from the screen, and often exits the application that corresponds to the window as well.

**To close a window...**
- Double-click the Control button of the window. The window closes.
- You can also close a window by choosing Close from the window’s Control menu.

**MENUS**

A GeoWorks Pro menu, like its real world counterpart, is a list of items—items you can point to and say, “I want that.” In GeoWorks Pro that’s exactly what you do. You use your mouse to first pull down a menu and then choose an item by pointing to it and clicking with the mouse button. The difference is that instead of choosing Chicken Dijon or Meatloaf Flambé, you choose commands or options. It’s with these commands and options that you control GeoWorks Pro applications.

By choosing a command, you initiate some sort of action. For instance, choose the Save command from the File menu and the document you’re working with is saved. Or choose Print to produce a copy of your document on the printer. Aside from commands, you also find options, which can be either on or off. One option in GeoManager, for example, is to have it ask you for confirmation when you delete a file. When the option is on (that is, currently in effect), choosing it from the menu turns it off. And when it’s off, choosing it turns it on.

Every GeoWorks Pro menu has its own name which appears on the application’s menu bar. Beneath each menu name, out of sight until you need it, is the menu itself. Since many different GeoWorks applications work in roughly the same manner, you’ll notice that most applications have similar collections of menus. For example, every application has a File menu, and almost every one of these File menus has the Exit command on it. This kind of consistency makes it easy for you to learn how to operate applications in GeoWorks Pro, since once you know how to work the menus in one of them, you know how to work the same menus in all the others, too.
Two special menus are the Control menu and the Express menu. You might not be able to immediately identify them, since they’re represented by icons instead of names, and they’re located on the title bar, not the menu bar like other menus. You pull down these two menus by clicking their icons, and even though they’re not on the menu bar, you use them the same way you use regular menus.

**CHOOSING FROM MENUS** There are two different ways to choose from menus. You can use the clicking method—click once to display a menu and then click again to choose an item—or the dragging method—click the menu name, and, without letting up the mouse button, drag to the item you want and release the mouse button to choose the item.

Sometimes items on a menu appear dimmed (gray and indistinct) which means they aren’t yet available for use. When you click these dimmed items, nothing happens. Usually the items are dimmed because conditions aren’t right for them. (For example, the Close command in the File menu is dimmed until you actually open something, since until you do so there’s nothing to close.)

**To choose from a menu by clicking...**
1. On the menu bar, click the name of a menu. The menu appears. (If you don’t find the item you want, simply click the name of another menu, and another, until you find the item you’re looking for.)
2. With a menu displayed, click the item you want. As long as the item isn’t dimmed, this selects the item, and the menu closes. If you are just browsing, you can close the menu without making a choice by clicking anywhere off the menu or clicking on the menu name again.

**To choose from a menu by dragging...**
1. Position the pointer over the name of a menu on the menu bar.
2. Press and hold down the mouse button. The menu appears. If you drag...
the pointer across the different menus on the menu bar, as you pass over different menu names the corresponding menus appear.

3 Stop at the menu with the item you want.

4 With a menu displayed, drag the pointer down the menu without releasing the mouse button. Available items highlight as the pointer passes over them. (Remember, you can't choose dimmed items.)

5 When the pointer is over the item you wish to choose, release the mouse button. The item is selected, and the menu closes.

If you are just browsing, you can close the menu without making a choice by dragging the pointer off the menu and then releasing the mouse button.

CASCADE MENUS Some menu items have a right-facing arrow next to them. Choosing one of these items reveals another menu with additional choices. This secondary menu is called a cascade menu.

You choose items from a cascade menu in much the same way as you choose from other menus.

To choose from a cascade menu by clicking...

1 Click to open a menu in the normal fashion.

2 Click the cascade menu item (the item with the right-facing arrow). The cascade menu appears.

3 On the cascade menu, click the item you want to choose. The item is selected, and the cascade menu closes.

To choose from a cascade menu by dragging...

1 Drag open a menu in the normal fashion.

2 Drag the pointer down the menu to highlight the cascade menu item (the item with the right-facing arrow).

3 With the pointer on the cascade menu item, drag to the right so that the pointer is over the right-facing arrow. The cascade menu appears.

4 Drag the pointer off of the main menu and onto the cascade menu. As you do this, be sure not to accidentally drag onto another cascade menu, or off the menu entirely.

5 Drag the pointer down the cascade menu to the item you want to choose and release the mouse button. The item is selected, and both menus close.

If you don't want to make a choice from the cascade menu, drag the pointer back to the first menu or off both menus completely.

PINNING MENUS Menus don't always have to disappear each time you make a selection. If you want to make a series of selections from a menu without having to pull it down each time, you can keep it hanging around, ready for
each choice you make. That is, you can “pin” a menu to the workspace (the way you’d pin a piece of paper to a wall) so that it stays open and ready all the time.

Once you pin a menu, you can move it around the workspace and place it wherever you need it most. When you’re finished with it, close the pinned menu so it no longer takes up space on the screen.

To pin a menu...
Choose the push-pin item at the top of a menu you want to keep open. If there’s no push-pin, you can’t pin the menu open. (The Express menu, for example, doesn’t have one.)

The menu stays open. A title bar (for moving the menu) and Control button (for closing it) appear on the menu. In fact, the menu now resembles—and behaves like—a very small window.

To move a pinned menu...
Move a pinned menu as you would move a window, by dragging its title bar. An outline of the menu moves as you drag. When you release the mouse button, the menu moves to its new position.

To close (unpin) a menu...
Close a pinned menu in the same way you would close a window: Double-click the Control button in the upper-left corner. The menu unpins and closes.

KEYBOARD ACCELERATORS To speed up your work, some menu items have keyboard accelerators. A keyboard accelerator is a single keystroke you can use to choose a particular menu item or command. Using the keyboard accelerator is identical to actually pulling down the menu and choosing the item. If an item has a keyboard accelerator, the accelerator appears at the right edge of the menu. (For example, in the menu at left the accelerator for “Bold” is \[Ctrl + B\].)

Most keyboard accelerators require you to hold down the [Ctrl] key while pressing another key, but sometimes you need to hold down the [Shift] key, too. There is a simple notation that indicates which keys you should press: When a plus (+) sign separates two groups of keys, it means hold down the first set of keys while pressing the second. For instance, Ctrl+P means hold down the [Ctrl] key while pressing [P] to choose the command.

To choose from a menu by using a keyboard accelerator...
Press the accelerator key combination indicated on the menu. The menu item is selected exactly as if you had chosen it using the mouse.
Navigating Menus with the Keyboard

While you’d normally use the mouse to navigate menus, you can also use the keyboard.

Knowing how to navigate menus with the keyboard can save you time, especially when you’re doing a lot of typing—you don’t need to take your hands off the keyboard to reach for the mouse.

Navigate through menus using the ◄ ► keys or by using mnemonics. A mnemonic is a single letter, or number, that represents a menu name or item. First, use the mnemonic for the menu name to pull down the menu; then use the item’s mnemonic to choose it from the menu.

To choose from a menu using the arrow keys...
1. Press and release the [Alt] key. The name of the first menu on the menu bar is highlighted.
2. If this highlighted menu isn’t the one you want, press the ◄ and ► keys to move left and right from menu to menu, highlighting each name as you go, until the right one is selected. If you keep going past the edge of the menu bar, you’ll select the Control and Express buttons. Remember, these also have menus that you can pull down.
3. Press the ◄, [Spacebar], or [Return] keys to display the menu for the currently highlighted name. If you decide that the command you want is not in this menu, and you want to try another, use the ◄ and ► keys to move through the menu names again.
4. Use the ◄ and ► keys to move up and down the menu, highlighting items as you go, until you reach the one you want.

If an item has a right-facing arrow and leads to a cascade menu, you can open the cascade menu by pressing the ◄ key. With the cascade menu open, press the ◄ and ► keys again to move up and down the cascade menu. Press the ◄ key to close the cascade menu and move back to the first menu.

5. When the item you want to choose is highlighted, press [Spacebar]. The item is selected and the menu closes.

If you are just browsing, you can press the [Esc] key to close the menu without making a choice.

To choose from menus using mnemonics...
1. While holding down the [Alt] key, press the key corresponding to the underlined letter (the mnemonic) in the menu name. For example, hold down the [Alt] key and press the [F] key to display the File menu. (You’ll notice that the menus are designed so that each one has a unique—though not necessarily obvious—mnemonic.)
2. With a menu open, press the mnemonic of the item you wish to choose, without pressing the [Alt] key. For example, press the [S] key to choose the Save item from the already opened File menu. This selects the item and closes the menu.
THE EXPRESS MENU

The Express menu is another special menu that lets you quickly start an application, switch between running applications, change your system preferences, check your printing, return to the Welcome screen, or exit directly to DOS. The Express menu works just like any other menu in GeoWorks Pro. But to see it, instead of clicking a menu name, you click the Express button. The Express button appears only in the active window (don’t worry, since there’s always one active window, the Express menu is always available).

Here are the items you have to choose from in the Express menu:

**Welcome** returns you to the Welcome screen.

**Running Applications** Any applications that are currently running appear in the Express menu. Choose one to bring the application’s window to the front.

**Startup** brings up a cascade menu from which you can start any GeoWorks Pro application.

**Printer Control Panel** opens the Printer Control Panel dialog box where you can see what documents you have currently printing or waiting to print. You can also cancel the printing of any document.

**System Preferences** starts the Preferences application, where you can change the look and feel of your system, as well as let GeoWorks Pro know when you add or change any hardware. (See the “Preferences” chapter in this book for more information about this useful application.)

**Exit to DOS** shuts down GeoWorks Pro and returns you to the DOS prompt.

---

To return to the Welcome screen...

1. Click the Express button in the active window. The Express menu appears.
2. On the Express menu, click Welcome. The Welcome screen immediately reappears.

You may also press the F2 key to return to the Welcome screen without using the Express menu.

To exit directly to DOS...

1. Click the Express button in the active window. The Express menu appears.
2. Choose Exit to DOS. GeoWorks Pro shuts down.

Exiting directly to DOS is a shortcut way to exit, without returning to the Welcome screen. As when returning to the Welcome screen, nothing is lost when you exit directly to DOS.

To switch between running applications...

Choose the application’s name from the Express menu. The application’s windows immediately pop to the top (just as though you had clicked them).

To start an application...

1. Choose Startup from the Express menu. A cascade menu appears with a list of available applications (basically, the same applications that are in the WORLD directory).
Choose the application from the cascade menu. The cascade menu disappears and the application starts up.

To monitor your printing...
Choose Printer Control Panel from the Express menu. The Printer Control Panel appears. Use it to monitor your printing and cancel documents that are waiting to print. See "The Printer Control Panel," later in this chapter, for more information.

To change your system preferences...
Choose System Preferences from the Express menu. The Preferences application starts. (For more about the Preferences application see the "Preferences" chapter in this manual.)

DIALOG BOXES

Whenever GeoWorks Pro needs more information from you, or needs to alert you to a problem, a small window known as a dialog box appears.

Some dialog boxes are like windows—they have a title bar for moving and a Control button for closing. You can keep these boxes open and switch between them and other windows if you want.

Other dialog boxes require a response before you can continue. Such boxes do not have a title bar or a Control button, and the image of the pointer changes to a circle-and-slash symbol when you move outside of the box.

Some boxes even use symbols indicating their purpose.

ELEMENTS OF A DIALOG BOX Dialog boxes are assembled from standard elements, such as text fields, radio buttons, and scrolling lists.

Button Every dialog box has buttons. Clicking a button causes an action to occur. If the label on a button is followed by an ellipsis (...), then that button leads to another dialog box.

Two examples of dialog boxes containing some common elements:
- Default button
- Text field
- Scrolling list
- Radio buttons
- Check boxes
- Up and down arrows
Some common buttons include those marked OK and Cancel. You will see others, too, such as Yes, No, Apply, Reset, and Close. The function of a button is usually self-explanatory.

- **Apply** Applies the current settings but leaves the dialog box open so you can continue to adjust them.
- **Reset** Resets the box to its previous settings, undoing any changes you may have made.
- **Close** Closes the box without applying the current settings. You can do the same thing by double-clicking the Control button, if the dialog box has one.
- **OK** Applies the current settings and closes the dialog box.
- **Cancel** Closes the box without applying the current settings.
- **Yes** Answers “yes” to the question presented and closes the dialog box.
- **No** Answers “no” to the question presented and closes the dialog box.
- **Stop** Ends the task in progress at the next possible stopping point.

**Default button** If a button is surrounded by a thick border, then that button is the default button. The default button represents the safest or most common choice in the dialog box. Pressing the Enter key selects the default button.

**Radio buttons** Radio buttons always come in groups of two or more. Like the preset buttons in an old car radio, only one of the buttons in a group can be on at a time. Clicking a radio button turns that item on and turns off any others in the group. Radio buttons appear as small diamond buttons on EGA and VGA monitors and small round buttons on monochrome monitors.

**Check boxes** A check box can be either on or off. When the box is highlighted (black) the item is on; otherwise, it is off. Like flipping a light switch, clicking a check box switches the box from on to off, or from off to on. Unlike radio buttons, a check box can be turned on or off independently from the other check boxes in the group.

**Up and down arrows** Many items have up and down arrows for cycling through options or for increasing and decreasing a number. Clicking the up arrow cycles to the next item or increases the number. Clicking the down arrow cycles to the previous item or decreases the number. Clicking and holding down the mouse button on an arrow (rather than simply clicking)
cycles the item continuously. (Items with these arrows are often called “spinners,” since clicking the arrows is a bit like twisting a knob on a piece of equipment.) You can also choose to simply type (or edit) the item directly. See “Entering and Editing Text,” later in this chapter for more information about editing text.

**Scrolling list** When there is a list of options to choose from, these choices are provided in a scrolling list. A scrolling list is like a miniature window, complete with a scroll bar along the right edge.

**Text field** Text fields appear in a dialog box when you need to enter text. You can edit the text in a text field just as you edit text anywhere else (see “Entering and Editing Text,” later in this chapter).

**RESPONDING TO A DIALOG BOX** To respond to a dialog box you set the different options and fill in the text fields provided. Then, you click one of the buttons at the bottom of the dialog box to apply the settings and continue.

---

**UNITS OF MEASURE**

<table>
<thead>
<tr>
<th>Units</th>
<th>Abbreviation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>inches</td>
<td>in or &quot;</td>
<td>1&quot;</td>
</tr>
<tr>
<td>picas</td>
<td>pi</td>
<td>6 pi</td>
</tr>
<tr>
<td>points</td>
<td>pt</td>
<td>72 pt (1 inch)</td>
</tr>
<tr>
<td>centimeters</td>
<td>cm</td>
<td>2.54 cm</td>
</tr>
<tr>
<td>millimeters</td>
<td>mm</td>
<td>254 mm</td>
</tr>
<tr>
<td>Ciceros</td>
<td>ci</td>
<td>5.63 ci</td>
</tr>
<tr>
<td>European points</td>
<td>ep</td>
<td>67.57 ep</td>
</tr>
</tbody>
</table>

---

**To respond to a dialog box...**

1. Set any options in the dialog box by clicking to turn them on or off.
2. To select an item from a list, click the item you wish to select. To change your selection, simply click another item. You may need to scroll the list to see more choices. Refer to “Windows” earlier in this chapter for more information on scrolling.
3. To enter and edit text in a text field, click in the text field you want to edit. The text cursor appears where you click. Now type your text. Characters appear at the text cursor. Press the Backspace key to delete characters if you make a mistake. Refer to “Entering and Editing Text” in this chapter for more information on text editing techniques.
4. Click one of the buttons at the bottom of the box to proceed.

Most dialog boxes have a default button, identified by a thick border. Pressing the Enter key is the same as clicking this button. If the dialog box has a Cancel button, pressing the Esc key is the same as clicking this button.

**ENTERING MEASUREMENTS** In some dialog boxes you can enter units of measure. The default is usually inches, but you can use any of the following units as long as you type the correct abbreviation. (See the chart above.)

**RESPONDING TO A DIALOG BOX WITH THE KEYBOARD**

You can also use the keyboard to select options in a dialog box. When responding with the keyboard, you move a dotted selection cursor to highlight different items and turn them on or off.
The elements of a file selector:
- **List window** (O)
- Name of current disk (O)
- Current pathname (O)
- Change disk button (O)
- Parent directory button (O)

**FILE SELECTORS**

GeoWorks Pro usually uses a file selector to ask you where you want to put a document or where it can find a document. The file selector helps you negotiate through a sometimes confusing maze of directories and subdirectories to find a specific directory or file. Once you find it, you click a button to open the file—or copy it, or save it, or whatever.

**ELEMENTS OF A FILE SELECTOR** All file selectors have these elements in common:
- **List window** Files and directories available for selection appear in this
- Name of current disk
- Current pathname
- Change disk button
- Parent directory button

**To respond to a dialog box using the keyboard...**

0 Use the following techniques to move the selection cursor and set options in the dialog box:

- If a dialog box has more than one group of options, press the Tab or Shift + Tab keys to move forward and backward between the groups. Once the selection cursor is in a group, press the Arrow keys to move from item to item.
- To jump quickly within a dialog box, press the mnemonic for one of the items. (As in menus, a mnemonic is a single character or number marked by an underline. To jump directly to an item titled Style, for example, you’d simply press the T key). If you are currently in a text field (where pressing T would just type a “T” in the field) you need to hold down the Alt key while pressing the mnemonic.
- To switch an item from on to off or from off to on, move the selection cursor to the item and press the Spacebar key.

2 When you finish setting options, select one of the buttons at the bottom of the box to proceed. Use the following techniques:

- Most dialog boxes have a default button, which is identified by a thick border. To select this button press the Enter key.
- You can press the Tab or Shift + Tab keys until the selection cursor surrounds the proper button, and then press the Enter or Spacebar key.
- You can press the mnemonic of the button you want to select. If you are editing in a text field, you need to hold down the Alt key while pressing the mnemonic.
- If the dialog box has a Cancel button, pressing the Esc key is the same as clicking this button.
Important Note: Files only appear in the list window when the file selector is being used to open, load, or otherwise bring some file into an application. If you're using it to save a file out to a disk (Save, Save As, Export, etc.) only directories will appear in the list.

Name of current disk The volume name of the disk whose directories are being shown appears at the top of the file list. If the disk doesn't have a volume name—many floppy disks don't—its name is shown as "[Untitled]."

Current pathname The pathname of the current directory appears above the list window.

Change Disk button Click the Change Disk button to switch to another disk drive. You'll see all the available disk drive letters in the list window. Double-click the one you want.

Parent Directory button Click the Parent Directory button to close the current directory and display the contents of the directory that contains it—the "parent" directory—one level up. This button dims when you reach the root directory, since this has no parent directory.

MOVING THROUGH DIRECTORIES

To open a directory in a file list...
Double-click the name of the directory you wish to open. (Small folder icons appear next to directory names in the file list.)

To close the current directory...
Click the Parent Directory button. The current directory closes and the contents of its parent directory (the directory which contains this one within it) appear in the file list window.

To display the contents of a different disk...
1. Click the Change Disk button located above the file list. A list of available disk drives appears in the list window.
   Disk drives are listed by drive letter. Floppy drives are A and B on most computers. Your hard disk, hard disk partitions, and other disk devices appear as other letters, typically starting at C and proceeding through the alphabet.
2. To display the contents of a floppy disk, make sure that it's in the correct floppy disk drive.
3. Double-click the letter of the drive you wish to use. The contents of the disk display in the file list window.

TAKING ACTION Once you find the directory or file you're looking for, click one of the buttons on the bottom of the file selector. If you're saving a file, use the file selector to find and open the directory you want to save the file into, then click Save. (Don't be put off if the list window doesn't show any files within the directory—for a Save, it only shows directories, not files.) If you're opening a file, use the file selector to find the proper directory and file. Then, click to select the name of the file and click Open (or, alternatively, double-click on the name of the file in the list window).

Keep in mind, though, that when you save a file it will be saved into the directory indicated next to the parent directory button, not the directory that is high-

3.21  BASIC TOOLS AND SKILLS
lighted in the file selector. It's always a good idea to pay close attention to where your files are being saved, so you can retrieve them easily later.

SELECTING ITEMS (IN FILE CABINET, GEOMANAGER, AND GEODRAW)

Many actions require that you first select an item in a window and then choose a command to act upon it. The act of selecting doesn't in itself change the item; it's merely how you identify which item you want to work with.

For example, to duplicate a file in GeoManager (or the File Cabinet), first select the file or files you wish to duplicate and then choose the Duplicate command from the File menu.

Another example: To change the pattern or color of a shape in GeoDraw, first select the shape you want to change and then choose the pattern and color you want. The selected shape changes to reflect your choices.

Note the order of events: First you select the item, then you choose the command. Select, then do.

When you select an item, it becomes highlighted on the screen. Different applications have different ways of highlighting items. The most common method is to reverse the colors so that white becomes black, and vice versa. Some applications, such as those for drawing and painting, have other methods of highlighting. When an item is selected in GeoDraw, for instance, its handles appear. No matter what, though, selected items and unselected items are visually distinct.

You can select a single item or you can select a group of items—selecting a group of items lets you change many items with one command. You can also select text, but you need to use different techniques to do so. See "Entering and Editing Text" later in this chapter for more information on selecting text.

SELECTING A SINGLE ITEM

Most of the time you only need to work with one item at a time, and so you only need to select a single item.

To select a single item...

Click the item in the window. The item is highlighted to indicate the selection. If you accidentally select the wrong item, click another item to change the selection. (If the item you click won't highlight, it may not be selectable.)

To deselect a single item...

Do one of the following:
- Click a different item. The new item is selected and the original item is deselected.
- Click an area of the window where no item appears. The original item is deselected.

SELECTING A GROUP OF ITEMS

By selecting a group of items you can work on many items at once. If you select a group of items and then choose a command, the command affects all items in the group.

For example, if you're using GeoManager and you want to duplicate more than one file, you can select all...
the files as a group and then choose the Duplicate command from the File menu. GeoManager duplicates each file in the group.

There are many ways to select a group of items. You can select the items one at a time or you can select them by specifying a range. Once you have a group of items selected, you can adjust or extend the selection to include items that are not yet selected. Or you can de-select certain ones to remove them from the group selection.

To select a group of items one at a time...

1. Click the first item. The item is highlighted to indicate the selection.
2. Hold down the Ctrl key and click additional items you wish to add to the group. The items highlight as you add them to the group selection. If you make a mistake selecting an item and wish to deselect it, simply click the item again without releasing the Ctrl key.
3. When finished selecting items, release the Ctrl key.

To select a group of items by dragging...

1. Position the pointer near—but not on—the first item you want to select.
2. Press and hold down the left mouse button while dragging the mouse. The outline of a box follows the pointer, changing size as you drag the mouse. Drag the outline so that it encloses the items you want to select.
3. When the outline of the box surrounds the items you want to select, release the mouse button. All items contained in the box are highlighted to indicate the selection.

To select a group of items between two points...

1. Click the first item. The item is highlighted to indicate the selection. This is the first point.
2. Hold down the Shift key and click another item. This is the second point. All items between the two points become selected. If you make a mistake selecting the item for the second point, click another item while holding down the Shift key. This changes the second point, thus selecting an entirely new group.
3. To start over, release the Shift key and begin a new selection.

To add additional items to a group...

1. With the Ctrl key held down, select items in the normal manner: Click an item to add it to the group, or drag to add a range of items. Items highlight to show they're selected.
2. When you finish selecting, release the Ctrl key.

You may repeat this process to add as many items to the group as you desire. Just make sure that you hold down the Ctrl key as you select the first item.

To subtract items from a group...

1. With the Ctrl key held down, do one of the following:
   • Click a selected item to subtract it from the group. The item is deselected.
   • Drag over a range of selected items to remove the range of items from the group. The items in the range are deselected.
Once items are deselected, they are no longer part of the group.

2 When you finish, release the Ctrl key.

You may repeat this process to remove as many items from the group as you desire.

To select multiple ranges...
1 Select the first range of items in the normal manner, either by dragging or using some other method.
2 With the Ctrl key held down, select another range. Repeat this step as many times as you like to select additional ranges.
3 Release the Ctrl key.

To deselect a group of items...
Click in any area of the window where no item appears. You should not hold down any keys while doing this. The group of items is deselected.

You can also click to select a single item (don’t hold down the Ctrl or Shift key). The single item is selected, deselecting all the other items in the process.

ENTERING AND EDITING TEXT

Nearly every GeoWorks Pro application allows (if not requires) you to enter and edit text at some point. For some, like GeoWrite, this is their raison d'etre.

The techniques for entering and editing text are the same in all applications. So once you learn to edit text in GeoWrite, you'll be able to edit text in GeoDraw, GeoDex, and GeoPlanner, too.

THE TEXT CURSOR When you click in a text box to enter and edit text you'll notice a flashing text cursor. This little flashing line marks your insertion point—the place where new characters appear as you type on the keyboard.

To position the text cursor...
Click anywhere in the text. The text cursor moves to where you click. (The cursor will always sit between characters, though.)

To enter characters...
Type on the keyboard. Characters appear at the location of the text cursor.

• Press the Backspace key to delete characters to the left of the text cursor, one at a time.
• Press the Del key to delete characters to the right of the text cursor, one at a time.
• Click to reposition the text cursor.

You can also reposition the text cursor using the ± keys to move it one character or line (depending on the direction) at a time.

SELECTING TEXT Selecting text is a way of specifying a particular range of text you want to change as a whole. When you select a range of text, selected characters temporarily reverse their colors: Black becomes white, and white becomes black.

The simplest way to select a range of text is to drag over the characters you want to select. But there are other ways of selecting text, including ways to quickly select words, lines, paragraphs, sometimes even whole pages at a time.

To select a range of text by dragging...
1 Position the pointer in front of the first character you want to select.
2 Press and hold down the mouse button while dragging across the text you want to select. Text is highlighted
as you drag the pointer. Drag right, left, up, or down—no matter where you drag, the only text highlighted is that between your starting point and your current position.

3 When the range you want to select is highlighted, release the mouse button. The text remains selected.

To select a range between two points...
1 Click to place the text cursor to the left of the first character you want to select. (Or to the right of the last character you want to select.)
2 Hold down the Shift key and click at the point where you want to extend the range. Text between the text cursor and your current position is selected. If you make a mistake in selecting the range, hold down the [Shift] key and click somewhere else. The selection adjusts to this new position.

To select words quickly...
Double-click a word to select it.
To select a range of words, start a double-click, but don’t release after the second click. (That’s click, release, click, and hold.) Instead, keep the mouse button pressed and drag in any direction. As you drag, whole words (instead of just single characters like before) are highlighted. You can also hold down the Shift key and click to extend the range of the word selection.

To select lines quickly...
Triple-click anywhere over a line to select that line.
To select a range of lines, start a triple-click, but don’t release after the third click. Instead, keep the mouse button pressed and drag up or down. Entire lines are highlighted as you drag. You can also hold down the Shift key and click to extend the range of the line selection.

To select larger units...
In the same way that you double-click to select words and triple-click to select lines, you can quadruple-click (four times) and quintuple-click (five times) to select paragraphs and entire pages, respectively. Each successive click selects a larger unit of text.
As with words and lines, you can extend the selection by dragging instead of releasing after the last click. Also, you can hold down the Shift key and click to extend the selection in the larger units.

To adjust a range...
Once you have selected a range of text, you can adjust the range to include more or less text.
To adjust the range, hold down the Shift key and click to where you want the range to end. The selection changes.
If you hold down the [Shift] key and press the ▼ ▲ □ △ keys, you can...
adjust the range a character or line at a time using the keyboard. See “Keyboard Editing” later in this chapter for more information.

DELETING AND REPLACING TEXT

To delete a range of text...
1. Select the range of text you wish to delete.
2. Press the Del or Backspace key. The selected range is erased.

To replace a range of text...
1. Select the range of text you wish to replace.
2. Type your new text. The selected range is completely replaced by the characters you type.

KEYBOARD EDITING As you become more proficient editing text, you'll probably want to start editing mostly with the keyboard so you don't have to reach for the mouse.

EDITING WITH THE KEYBOARD

Moving the text cursor
A character/line in any direction

<table>
<thead>
<tr>
<th>Direction</th>
<th>Key(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up</td>
<td>↑</td>
</tr>
<tr>
<td>Down</td>
<td>↓</td>
</tr>
<tr>
<td>Left</td>
<td>←</td>
</tr>
<tr>
<td>Right</td>
<td>→</td>
</tr>
</tbody>
</table>

One word backward
Ctrl + ↑

One word forward
Ctrl + ↓

One paragraph backward
Ctrl + ←

One paragraph forward
Ctrl + →

To beginning of line
Home

To end of line
End

To beginning of text
Ctrl + Home

To end of text
Ctrl + End

Selecting Text
Select left, right, up, down
Shift + ← → ↑ ↓

Select to beginning of word
Shift Ctrl + ↑

Select to end of word
Shift Ctrl + ↓

Select whole word
Ctrl + Spacebar

Select to beginning of line
Shift + Home

Select to end of line
Shift + End

Select whole line
Home, then Shift + End

Select to beginning of paragraph
Shift Ctrl + ↑

Select to end of paragraph
Shift Ctrl + ↓

Select whole paragraph
Ctrl + ↑, then Shift Ctrl + ↓

Select to beginning of column/page
Shift Ctrl + Home
OVERTYPING AND INSERTING Normally when you type, characters appear at the position of the text cursor and existing characters move to the right to make room. This is called insert mode because new characters are inserted at the cursor position.

There is another mode, called over-type mode, where characters you type run right over characters to the right, like a typewriter, rather than pushing them over. In insert mode the cursor is a thin blinking line that appears between characters, whereas in over-type mode it's thicker and it selects the letter that you'll overtype.

To switch between insert and over-type mode...

Press the Ins key. Text editing switches from insert mode to overtype mode or vice versa. The text cursor changes to indicate which mode you're in.

If nothing happens when you press the insert key, insert mode may be disabled in the Look & Feel option of Preferences. (See the “Preferences” chapter in this manual.)

SPECIAL CHARACTERS One way to give your document a professionally typeset look is to use the special characters available to you with GeoWorks Pro. As examples, use bullets (•) to set off important paragraphs, put a copyright on your work (©), or even add accented characters to your résumé. For a complete list of special symbols and how to type them, flip to the Appendix in this guide.
CUTTING AND PASTING

Cutting and pasting with GeoWorks Pro is like cutting and pasting with scissors and glue, just not as messy. In GeoWorks Pro, both text and graphics can be cut from one place and pasted in another, in effect moving them. You can move items in the same document, across documents, even across applications. And anything you can cut you can also copy—that is, leave the original item intact and in place while you paste a copy of it in its new place.

THE CLIPBOARD When you cut or copy something, it's placed on the clipboard (a temporary holding place) ready for you to paste where you please. That destination can be the same document or another document—or even a document created in a completely different application. The clipboard can only hold one thing at a time, but it can hold it for a long time; items placed on the clipboard will stay there (and can be pasted into a document more than once) until you cut or copy something else.

THE EDIT MENU Most cutting, copying, and pasting is done through the Edit menu and these commands:

Cut The Cut command removes the selected text or graphics from the current document and places it onto the clipboard.

Copy The Copy command places a copy of the selected text or graphics onto the clipboard, leaving the original selection intact.

Paste The Paste command copies the contents of the clipboard into the current document. If you are pasting into text, the contents are inserted at the text cursor.

To move text or graphics using the clipboard...

1. Select the text or graphics you want to move.
2. Choose Cut from the Edit menu. The selected scrap is removed from the document and placed on the clipboard.
3. Pick an insertion point where the scrap will be placed. This could be at another point in the same document, or in a different document, even in an entirely different application (you could, for example, cut a bit of text from GeoWrite and paste it to GeoDraw).
4. Choose Paste from the Edit menu. The scrap is pasted at the insertion point. If you like, choose Paste repeatedly to paste additional copies.

To copy text or graphics between two documents...

1. Select the text or graphics you want to copy.
2. Choose Copy from the Edit menu. The selected scrap is copied from the document to the clipboard.
3. Pick an insertion point where the scrap will be placed. This could be at another point in the same document, or in a different document, even in an entirely different application (you could, for example, copy some text from GeoWrite and paste it to GeoDraw).
Choose Paste from the Edit menu. The scrap is pasted at the insertion point. If you like, choose Paste repeatedly to paste additional copies.

**QUICK MOVE AND QUICK COPY WITH TEXT** If you want to swiftly move or copy text between two documents (or even within the same document), use the Quick Move and Quick Copy features. Neither Quick Move nor Quick Copy use the clipboard, so the scrap on the clipboard remain intact.

**To Quick Copy text...**
1. Select the text you want to Quick Copy.
2. Position the pointer over the selected text.
3. Press and hold down the right mouse button. The pointer changes to a Quick Copy pointer.
4. With the right mouse button still held down, position the pointer where you want to copy the text.
5. Release the right mouse button. A copy of the selected text appears at the position of the pointer. If the text doesn’t copy, then you positioned the pointer over an area of the screen that won’t accept Quick Copied text.

To cancel a Quick Copy, position the pointer back over the original selection and release the right mouse button.

**To Quick Move text...**
1. Select the text you want to Quick Move.
2. Position the pointer over the selected text.
3. Hold down the **Alt** key while pressing and holding down the right mouse button. The pointer changes to a Quick Move pointer.
4. With the **Alt** key and the right mouse button still held down, position the pointer where you want to move the text.
5. Release the right mouse button first, then the **Alt** key. The selected text moves to the position of the pointer. If the text doesn’t move, then you positioned the pointer over an area of the screen that won’t accept Quick Move text.

To cancel a Quick Move, position the pointer over the original selection, then release the right mouse button and the **Alt** key.

**WORKING WITH APPLICATIONS**

Before you can do anything with an application, you first need to start it—in much the same way that you can’t drive a car until you start it. Starting an application loads it into memory and opens its window. Once the application is started, you can work with its documents. When you are finished using an application, exit it, which closes its window and removes it from memory.

You can start as many applications as you want (there is a limit, but it’s pretty high and you’re not liable to run into it during the course of normal operation), and you can easily switch between them. However, because every application you start takes up some precious memory in your computer, it’s a good idea to only start applications you think you’re going to use immediately. If you start too many applications, and your computer seems sluggish, you should exit a few of them to free up some memory.
STARTING AN APPLICATION
You can start an application from the GeoManager window by opening the actual application file or by opening one of its document files. Since, in the File Cabinet, you never actually see an application's file, you can only start an application by opening one of its documents. (In the Advanced Workspace, you can also start an application from the Express menu.)

To start an application by opening its file (Advanced Workspace)...
In GeoManager, double-click the application icon (usually found in the WORLD directory) to select and open the application in one quick step.

To start an application by opening one of its documents...
In GeoManager or the File Cabinet, double-click the document icon. The corresponding application starts and automatically opens the document (i.e., GeoWrite starts when you double-click a GeoWrite document).

To start an application using the Express menu (Advanced Workspace only)...
1. Choose Startup from the Express menu. A cascade menu appears, showing all the available applications.
2. On the cascade menu, click the name of the application you wish to open. The application loads from disk and its window opens.

SWITCHING BETWEEN APPLICATIONS
You can start as many applications as you want in the Professional Workspace. When you start a new application, its window appears on the screen and its name is added to the Express menu. You can then switch between running applications by clicking their respective windows or by choosing a name from the Express menu.

To switch between running applications...
Do one of the following:
• Click the window of the application you wish to use.
• Choose an application from those listed at the top of the Express menu. The application's window comes to the front, making it the active window.

To switch between running applications, simply click the window of the application you wish to use, and it will become active.
EXITING AN APPLICATION

You exit an application when you finish working with it. Exiting an application removes the application from memory and closes its window.

To exit an application...

Do one of the following:
• Choose Exit from the File menu of the application.
• Double-click the Control button in the upper left corner of the application’s window.

The application closes its window and removes itself from memory. If you’ve made changes to any open documents, the application first asks you if you wish to save the changes before exiting.

OPENING AND CLOSING DOCUMENTS

To work with a document, you must first open it. There are two ways to do this: You can either start the document’s application and use its File menu, or you can open the document directly (from GeoManager or the File Cabinet), which automatically starts the application.

Either way, two things happen: the application is started, and the document is opened. When you work with multiple documents (discussed later) you usually open them from within the application. On the other hand, in the File Cabinet you usually open a document directly by double-clicking its icon.

As important as opening a document is closing it when you’re done. This gets it off the screen and out of your way and frees up valuable computer memory for other work you want to do. Perhaps most importantly, it forces you to save the work you’ve done, before it can be inadvertently erased.

To create a new, untitled document...

With the application started, choose New from the File menu. A new, untitled document appears.

Since many applications automatically open a new, untitled document when you start them, it may be easiest to just start the application when you want to create a new document.

Note: This shortcut does not work in the File Cabinet where you see no applications. In this case, just open one of the “blank” documents provided (the ones actually named something like “Blank Document”). Some applications, such as GeoDex and GeoPlanner, open default documents when started in this manner, instead of creating new ones.

To open a document from within an application...

1. Choose Open from the File menu. A file selector appears, listing the documents you can open with the current application.
2. If you wish to open a document that is in a different directory or on a different disk drive, use the file selector to change directories or disk drives first.
When you see the document you wish to open, click to select its name in the list window of the file selector.

Click Open. The dialog box goes away and the selected document opens.

You may also double-click the name of the document in the file list to select and open the document in a single step.

To open a document from within GeoManager or the File Cabinet...

1. With the GeoManager or File Cabinet windows displayed, find the document you wish to open. (For more about moving through directories in GeoManager or the File Cabinet, see their respective chapters in this manual.)
2. Double-click the document. The corresponding application starts and automatically opens the selected document.

To work on a copy of a document...

1. Open a document in the normal manner.
2. Choose Save As from the File menu. The Save As dialog box appears.
3. Type a name for the new copy of the document.
4. Click Save or press the Return key. An exact copy of the document is created and appears ready for editing. The original document is left unchanged.

Another way to create a copy of the document is to use the Duplicate command in either the File Cabinet or GeoManager.

To close a document when you are finished working with it...

Choose Close from the File menu. The document closes.

If you've made changes to the document, a dialog box first appears asking if you wish to save your changes. Follow the directions in the dialog box if necessary. If you don't save your changes when you close the document, the changes are lost forever—so think carefully before answering No!

Another way to close a document is by exiting the application. If you have any unsaved changes, the application automatically asks you if you would like to save the changes before exiting.

WORKING WITH MULTIPLE DOCUMENTS

Some applications let you work with more than one document at a time, making it easy to move text and graphics between documents. Every document appears in its own little window within the application window. If you opened three documents within GeoWrite, for instance, the GeoWrite window would have three little windows (that look and behave almost exactly like regular windows) within it.

Normally applications only show one document window at a time—even if many documents are in fact open at the moment. This is called full-sized window mode, although a better name for it might be invisible window mode, since you can't tell by looking at the GeoWrite window that there's actually a separate little document window inside it; it just looks like a regular GeoWrite window with a document open.
Even if you can't see them, though, the individual document windows are still there, as you can see by pulling down the Window menu. (You'll see each document identified by name). The only way to switch between windows in full-sized mode is via the Window menu.

The Window menu is also useful for switching to overlapping view, in which each document is plainly visible as a little window within the application window. These little document windows are both resizeable and moveable—you can shift windows around to see others underneath, or size them to fit neatly side by side. One example of this is when you switch to overlapping view in GeoManager. Each directory becomes a little window inside the larger GeoManager window. You can then position two windows side by side and move files between them.

**To open multiple documents...**

While in the application, use the Open command on the File menu to open each document you want to work with, without closing the documents already open. (If the Open command is dimmed, then the application simply cannot open any more documents.)

Remember, since applications normally operate in full-sized mode, you'll only see one window at a time. Choose Overlapping from the Window menu to see all the document windows at once.

Also note that you must open the document with the Open command—if you double-click the document's icon in the GeoManager window, something very different happens: A second application starts. So, if you double-clicked a second GeoWrite document, say, a second GeoWrite would start. (And if you looked in the Express menu, you'd see two entries for GeoWrite.)

**To work with documents as overlapping windows...**

Choose Overlapping from the Window menu. All the open documents become overlapping windows inside the application window.

When working with documents as overlapping windows, they behave much like any other kind of window—they can be moved, resized, and activated in the same way as application windows. The only difference is that document windows cannot be moved beyond the borders of the application window.

**To switch back to full-sized document windows...**

Use one of the following methods:
- Choose Full-Sized from the Window menu.
- Click the Maximize button on any one of the overlapping windows.
To switch between open documents...
If you are in full-sized mode, choose the name of the document from the Window menu.
If you are in overlapping mode, either click in the window of the document you want to use or choose the name of the document from the Window menu.

To close a document window...
When working in either full-sized or overlapping mode, activate the window of the document you wish to close, and choose Close from the File menu. The window closes.
When working with overlapping windows, however, you can also double-click the Control button on the document window. Or single-click the Control button, then choose Close from the Control menu that appears.

The Window menu
Most applications have a window menu, which allows you to move between pages, documents, or directories (depending on the application). For instance, in GeoWrite you can use the Window menu to move through pages of a document and even between different documents. In GeoManager, you can hop between open directories.

The Window menu also allows you to change between overlapping and full-sized windows. While each application has a unique set of commands in its Window menu, there are some traits that are common to all:
Overlapping changes to overlapping windows. The little windows can then be resized and moved to be side by side.
Full-sized changes to full-sized windows. The top window grows to completely fill the application window—which means that, by definition, you can only see one document window at a time.
Also, each Window menu lists, at the bottom, each open window, even if the window isn't currently visible (as is the case when you're working in full-sized mode).

Saving a document
Until saved, the work that you do is only temporary. If the electricity were to suddenly go out, the computer would forget all the work you've done. (The same would happen if you turned your computer off, too.) An important part of your work routine, then, is saving your work. When you save your work, you copy it on to your hard disk, where it remains intact even after the power has been turned off. In other words, the saved information is permanent. (This saved information becomes a document.)
That doesn't mean you need to save your work after every little change, though. GeoWorks Pro has a special safeguard feature that periodically copies your work to disk and keeps it safe in case of a power outage or other mishap. Additionally, if you've made some
changes you don't want to keep, you can get rid of them and go back to the last saved version of a document by using the Revert command on the File menu. But remember, you lose all changes you've made since your last save.

All commands relating to saving a document are found on the File menu:

**SAVE** The Save command tells GeoWorks Pro to save the document under its current name.

**To save a document and make its changes permanent...**

Choose Save from the File menu. The document is saved onto the disk. No dialog boxes appear; your only indication that the document is being saved is a bit of noise from your disk drive.

**To save a document for the very first time...**

1. Choose Save from the File menu. A file selector appears.
2. Name the document and identify which directory will contain it. The name can be up to 32 characters long.
3. Click Save or press the (Return) key. The newly created document is saved under the name you gave. When you switch to GeoManager, you'll see the document.

**SAVE AS** Use Save As when you want to save your changed document under a different name. That is, if you're putting a document through several editing cycles, you may want to keep earlier versions of the document intact. For example, say a newsletter named the *Murtnik Monthly* goes through several changes before it's sent to print. The first version may saved under the name “Murtnik’s Monthly: Draft,” the next version under “Murtnik’s Monthly: Second Try,” and finally “Murtnik’s Monthly: Print it!”

**To save a copy of a document under a different name...**

1. Choose Save As from the File menu. A file selector appears.
2. Type a new name for the document, up to 32 characters in length. The name you type appears in the text box, replacing the original name of the document.
3. If you wish to save the document in a different place, use the file selector to change directories or disk drives.
4. Click Save or press the (Return) key. The document is saved onto the disk under its new name, and the original document is left unchanged.

When you save a document, remember that it will be saved into the directory indicated next to the parent directory, not the directory that is highlighted in the file selector.
**REVERT** Use the Revert command to undo changes you wish you hadn’t made. Revert restores the document to its *last saved version*, erasing any changes you’ve made recently. Use Revert *only* if you’re sure you want to discard your changes. If you’re not absolutely sure, take the safe route and use Save As to save the changed document (for instance, “Murtnik’s Monthly: Possible Additions”). Then reopen the last saved version.

**To revert to the last saved version of a document...**
1. Choose Revert from the File menu. A dialog box appears, asking if you are sure you wish to revert.
2. Click Yes. The document is restored to its last saved version. If you have made changes since the last time you saved the document, those changes are permanently lost.

**SUMMARY OF THE FILE MENU**

Most applications have a File menu with at least the following commands:
- **Open** The Open command opens a document you have already created.
- **New** The New command creates a new, untitled document.
- **Close** The Close command closes the current document. If you have made changes, you are asked if you wish to save your changes.
- **Save** The Save command saves the current document.
- **Save As** The Save As command saves the current document under a different name. The original document remains as it was when you last saved it and you are left editing the new document with the different name.

**PRINTING**

When you first install GeoWorks Pro, you have the opportunity to identify the printer attached to your computer. If you ever want to change your printer, or if you get a second printer, you can use the Preferences desk tool to tell GeoWorks Pro about it.

You print from within most applications by choosing the Print command from the File menu, bringing up a Print dialog box. The Print dialog box is more or less the same for most applications, and generally includes these options:

- **Printer Options** The Printer Options area displays the name of the current printer. Click the Change Options button to switch printers (if you have more than one plugged into your com-
puter) and change other settings, like paper size and paper tray.

**Print Quality** With most printers you have a choice of printing in either high or low quality. The High setting offers the best results, producing documents that almost look like they were printed on a laser printer, but with the drawback that it takes a long time to print even a single page. The Low setting offers much faster printing, but produces very rough looking documents. (Some printers have an additional Medium setting.)

**Text Mode Only** Turning on this option prints a quick text-only draft of your document. The text-only draft uses your printer’s internal fonts, so it probably won’t look like the document you see on your screen. It does not print in different fonts or styles, nor does it print graphics.

**Print Pages** You can choose to print your entire document, or only some of the pages.

**Number of Copies** and **Collate** You can print more than one copy of the document. If the document has more than one page, you can also choose to collate the copies. (Printing with the Collate option on can be slower than printing with it off.)

To print with the standard settings...
1. Choose Print from the File menu. The Print dialog box appears.
2. Click OK. The document prints with the standard settings.

To change the print quality...
1. Choose Print from the File menu. The Print dialog box appears.
2. Next to Print Quality, choose the setting you want. Generally speaking, the higher the quality, the longer it takes your document to print.
3. If you want to get a text-only draft, turn on the Text Mode Only option. This option prints using your printer’s internal fonts and does not print graphics, but it does print very quickly.
4. Set any other options as desired.
5. Click OK. The document prints using the settings you have chosen.

To print a range of pages...
1. Choose Print from the File menu. The Print dialog box appears.
2. Next to Print Pages, click to select From. If your document only has one page, this option is disabled.
3. Change the From and To fields to the range of pages you want to print. Change these fields by clicking the

---

The Print dialog box.
arrows or by typing new numbers. To print all the pages in your document, click All.
4 Set any other options as desired.
5 Click OK. The pages you have selected are printed using the settings you have made.

To print more than one copy...
1 Choose Print from the File menu. The Print dialog box appears.
2 Change the Number of Copies by clicking the arrows or typing a new number.
3 If you want to print the document so that each copy is printed and sorted independently, turn on the Collate option. (If you are only printing one page, the Collate option is disabled.)
4 Set any other options as desired.
5 Click OK. The pages you have selected are printed using the settings you have made.

CHANGING YOUR PRINTER AND PAPER OPTIONS The Change Options button in the Print dialog box leads to the Change Options dialog box, which you use to set the printer and paper options, such as:

Printer The printers you have identified as being attached to your computer are listed under this setting. The one currently being used for printing is selected; select a different printer from the list if you want. To add printers to the list, use the Preferences application.

Paper Size You can select the size of the paper in your printer from those listed in the scrolling list. If your paper size isn't listed, you can change the Width and Height fields to make a custom size.

Paper Source Some printers have several paper sources, such as different paper trays. Depending on your printer, you may be offered up to three tractor feed and three tray sources. Additionally, there may be a Manual Feed option, which pauses the printout between pages to let you insert sheets by hand.

To change printer and paper options...
1 In the Print dialog box, click Options. The Options dialog box appears.
2 Click to select the printer you want to use.
3 Click to select the paper size. If you can't find the paper size you want, enter the dimensions in the Width and Height fields.
4 If your printer has more than one tractor feed, paper bin, or paper tray,
change the Paper Source option. If you want to pause printing between pages so you can insert paper by hand, select the Manual Feed option.

3 Click OK. The new options are set and the Print dialog box reappears.

**THE PRINTER CONTROL PANEL**

Printing takes time. If you print a lot of documents in succession you probably don't have the time to sit around waiting for your printer to finish printing one document before you tell it to print another. Rather than making you wait, GeoWorks Pro gives you a way to "stack up" a list of documents that you want to print. The printer grabs the document at the top of the stack and starts printing, and as soon as it finishes that document, it starts printing the next one. And so on.

You can see the list of documents currently printing (or waiting to print) via the Printer Control Panel. You can also change your mind and cancel the printing of any of the documents shown, including the one that's currently printing.

To see the list of documents waiting to print...

1 Choose Printer Control Panel from the Express menu. The Printer Control Panel appears.

2 The documents printing or waiting to print appear in the list in the middle of the Panel. You can scroll the list to see all of these documents. The ones at the top of the list print before the ones at the bottom—the one at the very top is the one currently printing.

3 If you have more than one printer attached to your system, click Other Printers to see any documents waiting to print on another printer.

4 Click Close to make the Printer Control Panel go away.

To cancel the printing of a document in the list...

1 Choose Printer Control Panel from the Express menu. The Printer Control Panel appears.

2 Click to the name of the document in the list that you no longer want to print.

3 Click Cancel Document.

4 Cancel printing other documents if you want and click Close when you're finished.

If the document is currently printing, it may continue for a little while before it stops.
In many GeoWorks Pro applications, you can select text and then choose between different fonts, font sizes, and special styles (such as bold, italic, and underline). In some applications, you can also color text, lighten it with a halftone, or adjust the character spacing for titles or headlines.

**What is a font?** Font refers to the design of the individual characters. In one font, the letter “A” might be straight and simple, while in others the same letter might be very ornate and decorative. Some common fonts are:

- Sans
- Roman
- Mono
- Συμβολ (Symbol)

In GeoWorks Pro, the fonts appear on the screen exactly as they will appear on the printed page. You change the font by selecting text and

- Choosing a font from the Fonts menu, or
- Choosing the More Fonts command and selecting a font from the More Fonts dialog box

The Fonts menu lists only some of the most frequently used fonts, while the More Fonts dialog box lists all the fonts currently installed on your system. When you select a font from the More Fonts dialog box, you’re given a preview of the font so you can verify it.

Not every GeoWorks Pro application lets you change fonts (the Notepad doesn’t, for example).

**To choose a new font...**

1. Select the text.

2. In GeoDraw, choose Fonts from the Text menu, then choose a font from the ensuing cascade menu. In other applications, like GeoWrite, simply choose a new font from the Fonts menu. The text changes to the new font.

3. Select a font from the list in the More Fonts dialog box. An example of the font you select is shown at the bottom of the dialog box.

4. Click Apply to see the new font. If you like, select and apply other fonts while the More Fonts dialog box is still open.

5. Click Close when you finish.

**Changing the text size** A point is a measurement of the height of a character. One point is 1/72 of an inch, so a 72-point character is one inch tall, and a 36-point character is half an inch.

GeoWorks Pro allows a broad range of text size—from 4 to 792 points. At the maximum point size (792), you can fit roughly one character on a page.

The Sizes menu (Sizes cascade menu in GeoDraw) contains the standard font sizes from 10 to 72 points. In addition, the Smaller and Larger commands let you make a gradual changes in the
size. You also have a Custom Size command that lets you enter a specific point size.

To change text size...
1. Select the text.
2. Choose one of the standard sizes from the Sizes menu. Or, to vary the size incrementally, choose the Larger or Smaller commands.

To change text to a custom size...
1. Select the text, and choose Custom Size from the Size menu. The Custom Size dialog box appears.
2. Type a new size, or click the arrow buttons to change the one shown, then click Apply. In your document, you'll see the text change size.
3. Click Close when finished.

To change the text style...
1. Select the text.
2. Choose a style from the Styles menu. Repeat the process if you want to apply additional styles to the selected text.

ZOOMING IN AND OUT

Zooming in and out refers to the ability to magnify or reduce the image on the screen. The View menu lets you zoom in and out of the page you're looking at. If the text you're using in GeoWrite is so small that you're having trouble reading it, you can zoom into the page (make it larger). Note that the zoom has no effect on printing—the page prints at the regular size regardless of whether you're zoomed in or out.

Experiment by choosing different magnification levels from the View menu to find the one that's most appropriate for the work at hand. For example, when you want to precisely align two objects, it's easier if you zoom in. When you want to get an overview of the entire layout of a newsletter, a reduced view is better.

CHANGING THE TEXT STYLE
With many GeoWorks Pro applications, you can also change the text's style to any one (or a combination) of seven styles:
- Plain
- Bold
- Italic
- Underline
- Strike Thru
- Superscript
- Subscript

You can apply more than one style to text at a time, such as bold and italic. Choosing Plain Text cancels any of the other styles.
To magnify the view (zoom in or out)...
Choose the level of magnification or reduction you want from the View menu.

To return the document to its original size...
Choose Actual Size from the View menu.

CORRECTING THE ASPECT RATIO
Some monitors, such as those that display Hercules and CGA graphics, have rectangular pixels rather than perfectly square ones. (Remember, pixels are the small dots in your screen that form the image.) These monitors have a rectangular aspect ratio which tends to distort the image, making it look stretched or squashed.

If you're using GeoWrite or GeoDraw with one of these monitors, you can turn on the Correct for Aspect Ratio option. With this option on, your documents appear in their proper proportions and more closely resemble their printed result. It takes a bit longer to draw the image on your screen, though, and the image is also a little harder to read, so you might want to use it only for previewing your document.

To turn the Correct for Aspect option on or off...
Choose Correct for Aspect Ratio from the View menu. The option turns on and the document appears as if your monitor had square pixels. (If the Correct for Aspect ratio is dimmed, it is because your monitor already has square pixels and no correction is necessary.)

To turn the option off, simply choose it from the View menu again.

February 5, 1992

Dear Celia,

I am very pleased with the quality of your work for the Game of Service exposition. In fact, Chris Dixon mentioned...
GETTING HELP

Getting help is easy with GeoWorks Pro. If a screen has a Help button, click it to get a window with information and instructions:

To display the Help Window...
Click the Help button. The Help window appears.

To view different Help pages...
Click the paging buttons:
• Click the Page Down button to view the next page of help.
• Click the Page Up button to view the previous page of help.

If one of the paging buttons appears dimmed (light gray), then you can go no further in that direction. If both buttons are dimmed, then there is only one page of help and it's currently displayed. Clicking a dimmed button has no effect.

To make the Help window go away...
Click the Close button. The Help window goes away.
A Detailed Reference (In Alphabetical Order)

Elegant accommodations, fine dining, and affordable prices have combined with the increasing strength of the dollar to make Mexico far and away our most popular vacation spot. It's steady rise was apparent...
The Appliances

Anybody who can use a familiar home appliance—a washing machine, telephone answering machine, remote-control television—can also use Beginner Workspace’s software appliances. These appliances are designed to be especially easy to learn and foolproof in operation. GeoWorks Pro comes standard with six appliances: Address Book, Planner, Calculator, Notepad, Solitaire, and Banner.
TURNING APPLIANCES ON AND OFF

To use an appliance, you must first turn it on. Turning on an appliance is as simple as clicking a button. And, when you are finished using the appliance, another button turns it off.

To turn on an appliance...
1. On the Welcome screen, click the large Beginner Workspace button. The Choose an Appliance screen appears.
2. Click the button of the appliance you wish to use—for example, click the Calculator button. The appliance turns on and fills the screen.

If you need help using an appliance, click the Help button in the upper-right corner of the screen.

To turn off an appliance...
1. Click the Exit button in the upper-left corner of the appliance. The appliance turns off and the Choose an Appliance screen reappears.
2. Click a button to use another appliance or click Exit to return to the Welcome screen.

THE NOTEPAD APPLIANCE

The Notepad appliance is a handy place to write quick notes or lists.

The Notepad works like a very simple word processor—just start typing. Use the mouse to edit the text (as described in the “Basic Tools and Skills” chapter). The buttons at the top of the window perform special operations: Click Print to actually print the contents of the Notepad. Select some text, then click Cut or Copy to put it on the clipboard, from which it can be pasted back in when you click Paste. The Text Size options make the text larger or smaller. If you have more text than can fit on the screen, click Page Up or Page Down to see it.
THE CALCULATOR APPLIANCE

The Calculator appliance works like a normal desktop calculator.

The Calculator has more than a passing resemblance to the kind you usually see on a desk. Click the buttons to enter the numbers and perform operations (0). The results appear on the LED display at the top (0).

THE ADDRESS BOOK APPLIANCE

The Address Book appliance works much like a common office card file.

You can flip immediately to any section of the Address Book by clicking one of the index tabs (0). Or click the Next Card and Previous Card buttons to flip forward and backward one card at a time (0). To add a new card to the collection, click New Card (0) and fill in the blanks (0). When you're done entering the information, flip to another card to have the Address Book record your changes. If you have a modem, the Address Book appliance can dial a phone number, too: just click the Dial button (0).
THE PLANNER APPLIANCE

The Planner appliance works like a desk calendar and date book. In the Planner's left window, which shows a monthly calendar, days that have events scheduled on them are marked with little triangles, and the day that you're viewing is marked with a darkened square. The events scheduled on this day appear in the Event window on the right. If there are more events on a given day than can be shown on the screen, the Page Up and Page Down buttons will darken to the other events. To add a new event to the list, click on the desired day on the calendar and then click New Event. To print a monthly calendar or the list of scheduled events, click the Print button.

THE BANNER APPLIANCE

The Banner appliance does one simple thing: It prints large, multipage banners you can hang on a wall, window, or whatever. It's easy to use and quick to master, so you should be creating huge signs with cool fonts and special effects in no time. To begin typing your banner, click the keyboard button in the upper-left corner. Type the text for your banner into the Banner Message box. After a short delay, your message will appear in the sample banner. Click the sample left or right by clicking the four buttons at the bottom of the screen. Change the font or add special effects by clicking the appropriate buttons. When the banner looks good, click the Printer button to print your banner. The Banner appliance always prints with low print quality to keep your printer from overheating—literally.
SOLITAIRE

The Solitaire appliance lets you play the famous Solitaire card game called Klondike. Be careful, it's surprisingly addictive.

To play, drag cards from one stack to the next by placing the pointer over the card you want to move ( ), pressing and holding down the left mouse button to “pick up” the card, and moving it to the appropriate stack. (If the card can’t legally be placed on that stack, it will bounce back to the original stack.) If you need additional instructions on how to play Solitaire, click the Help button in the upper-right corner of the screen.
The Calculator works much like a simple hand-held calculator. You can add, subtract, multiply and divide, calculate percentages, and store results in the calculator’s memory. When you finish, you can paste the results into other applications, like GeoWrite or GeoComm.
THE CALCULATOR WINDOW

The Calculator window resembles a normal hand-held calculator. Parentheses ("(" and ")") Changes the order of operations. When you use parentheses, the quantity inside the parentheses is evaluated before anything else in the calculation. For more information, see “Order of Operations” in this chapter.

Delete button Acts like a backspace key to erase the last digit of the number in the display.
C/CE button Clears the displayed number so that you can re-enter it without affecting a calculation in progress. If clicked twice, this clears everything, including any calculations in progress.

DOING CALCULATIONS

Use the mouse to click the Calculator’s buttons, or press the corresponding keys on the keyboard. You can use keys on the numeric keypad, but first make sure that [Num Lock] is on.

ORDER OF OPERATIONS When you do calculations involving more than two numbers, be aware that the Calculator may not do your calculation in the exact order you entered it. The Calculator follows a specific order of operations: operations in parentheses first, then multiplication and division, then addition and subtraction. Arithmetic functions with the same precedence are performed left to right.

For example, entering 3 + 4 x 6 would yield 27, not 42 as you would expect from the order in which you entered the calculation. The calculation is interpreted as 3 + (4 x 6) instead of (3 + 4) x 6.

OPERATING THE CALCULATOR

<table>
<thead>
<tr>
<th>Function</th>
<th>Click</th>
<th>On Keyboard</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digits</td>
<td>0 through 9</td>
<td>0 through 9</td>
</tr>
<tr>
<td>Decimal point</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>Add</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>Subtract</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Multiply</td>
<td>x or ÷</td>
<td>* or ÷</td>
</tr>
<tr>
<td>Divide</td>
<td>÷</td>
<td>/</td>
</tr>
<tr>
<td>Equals</td>
<td>=</td>
<td>= or Enter</td>
</tr>
<tr>
<td>Change sign</td>
<td>±</td>
<td>±</td>
</tr>
<tr>
<td>Clear</td>
<td>C/CE</td>
<td>C</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
<td>Backspace</td>
</tr>
<tr>
<td>Store in memory</td>
<td>STO</td>
<td>[S]</td>
</tr>
<tr>
<td>Display memory</td>
<td>RCL</td>
<td>[R]</td>
</tr>
<tr>
<td>Add to memory</td>
<td>STO+</td>
<td>[T]</td>
</tr>
<tr>
<td>Percent</td>
<td>%</td>
<td>%</td>
</tr>
<tr>
<td>Parentheses</td>
<td>( )</td>
<td>( )</td>
</tr>
</tbody>
</table>
THE ERROR INDICATOR

When the Calculator cannot handle a calculation, the word “Error” appears. This can happen when the result is greater than 2,147,483,647 or less than -2,147,483,648. This also happens if you divide by zero.

When “Error” is displayed, click C/CE once to clear it.

USING THE MEMORY

With the Calculator’s built-in memory, you can save the result of a calculation. In fact, the memory is a great way to keep a running total of your calculations. The memory can only hold one number, so each number you store erases the one previously stored.

To store the displayed number...

Click STO or press 5. The number on the display is stored in memory.

To recall the number from memory...

When you want to use the stored number in a calculation, click RCL or press 5. The number appears on the display. You can then use this number in a calculation.

To add to the number in memory...

If you want to add the number showing on the display to the number stored in memory, click STO+ or press 7. The sum is then stored in memory.

This is handy for keeping a running total of your calculations.

To clear memory...

1. Enter a zero.
2. Click STO or press 5.

CUTTING AND PASTING

The number on the display can be cut or copied to the Clipboard in the normal way (with the Edit menu) and then pasted into another application. The reverse is also true: you can copy numbers in from other applications, such as the spreadsheet Viewer. (You can use Quick Copy and Quick Move to do these operations, too.)

CHANGING OPTIONS

With the Options menu you can set the number of decimal places you want displayed, or make the Calculator work like a Hewlett Packard Reverse Polish Notation (RPN)-style calculator.

To switch the method of operation to RPN...

Choose RPN from the Options menu. The Standard Calculator is replaced with the RPN Calculator. (See “Using the RPN Calculator,” later in this chapter.)

To switch back to Standard operation, choose Standard from the Options menu.

To set the number of decimal places...

1. Choose Decimal Places from the Options menu. The Decimal Places dialog box appears.
2. Set the number of decimal places. You can choose from 0 to 8 decimal places.
3. Click OK.

When displayed, numbers are rounded to the number of places you specify, but this does not change the actual values being used for calculations. For example, if you set the number of decimal places...
to two, the Calculator shows all your results rounded to two decimal places on the display. This means that 1.275 appears as 1.28, but still has the value of 1.275 when used in a calculation.

**USING THE RPN CALCULATOR**

The calculator can also function like a Hewlett Packard-style calculator, which uses Reverse Polish Notation (RPN). RPN is simply a different way to enter calculations. First you enter both numbers, then you click the arithmetic function. The numbers are kept on a stack, where they can be “popped” and used in operations. (The number of numbers that you can put on the stack is limited only by the amount of available memory.)

The buttons on the RPN Calculator are basically the same as those on the Standard Calculator, with a few differences:

**Enter Button** Click this button to place—or “push”—the number on the display onto the stack. Type the first number, click Enter, type the second number, and then click an arithmetic function.

**Exchange Button** (“x<>y”) Exchange the number in the display with the top number on the stack. This is useful in switching the order of numbers to be subtracted or divided.

**C/CE Button** When clicked once, this button erases the number you’re currently entering—provided you haven’t yet clicked Enter (at which point the number can’t be erased). When clicked twice, it erases all the numbers on the stack, effectively resetting the calculator.

All the RPN Calculator buttons are activated by the same keys on the keyboard as the Standard Calculator. The two additions are the Enter key, which corresponds to the Enter key on the keyboard, and the Exchange Key, which corresponds to the [§] key.

**To do RPN calculations...**

1. Type (or click) the first number, as you would for Standard calculator.
2. Click Enter to “push” the first number onto the stack.
3. Type the second number. *Do not click Enter this time.*
4. Click the arithmetic function you want. The result shows on the display. You can then use this result as the first number in another calculation.

It’s important that you not click Enter after typing the second number, as this will both store the number on the stack and leave it on the display. If you then click an operation, the operation will use the number on the display and the top number on the stack—the same number.
The DOS Programs screen offers a quick way to run DOS programs and batch files at the press of a button. Create a button for each program or batch file you use. Then simply click the button to shut down GeoWorks Pro and run the program. (Before you attempt to set up buttons, though, you should make sure that you’re comfortable working with dialog boxes. If you’re not, check the “Basic Tools and Skills” chapter for more information.)
The DOS Programs screen is one of the four choices on the Welcome screen—simply click the DOS Programs button to get to it. Like the Beginner Workspace screen it has large, friendly Help and Exit buttons, which you use to get help and return to the Welcome screen, respectively. And just as the Beginner Workspace has buttons for starting the appliances, the DOS Programs screen can be set up to have buttons for starting DOS programs and batch files.

Well, not at first. The DOS Programs screen comes standard with only one button, labeled “Enter DOS.” (Clicking this drops you out of GeoWorks Pro to the DOS prompt.) You need to create buttons to run your favorite programs, but don’t worry, it’s easy—see “Creating a Button” a little later.

If you create more buttons than will fit on the screen, paging arrows appear at the bottom of the screen. The paging arrows let you flip from one screenful of buttons to another. (If a paging arrow is greyed out, you’ve already gone as far as you can in that direction.)

To run a DOS program or batch file...

1. Find the button you wish to use. Create one if you have to. If there are additional screens of buttons, click the Next and Prev arrows at the bottom of the screen to see the others.
2. Click the button. (A dialog box may appear so that you can enter command line options; more on this later in the chapter.) The screen clears while GeoWorks Pro shuts down—conveniently freeing up almost all of memory—and the DOS program starts.
3. When you exit the program, GeoWorks Pro is automatically started back up again, and you’re returned to the DOS Programs screen. Everything is exactly the way you left it. (If you get stuck at the DOS prompt you’ll have to type exit to return.)

To exit to DOS temporarily...

1. Click the Enter DOS button. GeoWorks Pro shuts down, leaving you at the DOS prompt.
2. Since GeoWorks Pro is completely shut down and removed from memory,
you can run any program or perform any
command you like without GeoWorks
Pro getting in the way.
③ When you're finished, type exit
and press [Return]. This starts GeoWorks
Pro back up again and returns you to
the DOS Programs screen.

CREATING A BUTTON

It's easy to create a custom button
for any DOS program or batch file.
But, before you begin, you should
make sure you're familiar with the
concepts and techniques presented in
the "Basic Tools and Skills" chapter.

To create a new button...
① Choose Create New Button from the
Options menu. A file selector appears,
asking you to select a DOS file for the
new button. (Only .COM, .EXE, and
.BAT files appear.)

② Select the file and click Use This
File. The file selector goes away and is
replaced by the Button Settings dialog
box.
③ Change the button's settings as
desired.
• No Command Line Options: Runs the program without any command line options.
• Ask for Options Each Time: Each time you run the program you'll be asked to enter some command line options.
• Specify Options Now: Choose this when the options are always the same. Enter them here and be done with it.

4 Click OK. The dialog box closes and the new button appears on the screen.

**CHANGING AND DELETING BUTTONS**

Once you have created a button, you can change its settings or delete it at any time.

**To change a button's settings...**

1. Choose Change Button Settings from the Options menu. A dialog box appears, listing all the buttons by name.

2. In the list, click to select the name of the button you wish to change. Click Change Settings. The Button Settings dialog box appears, showing the settings for the button.

3. Change the button's settings in the dialog box as desired. (See “Creating a Button,” earlier in this chapter, for an explanation of the settings.)

4. Click OK. The dialog box closes and the button appears with its new settings.

**To delete a button...**

1. Choose Delete Button from the Options menu. A dialog box appears, listing all the buttons by name.

2. Click to select the name of the button you want to delete.

3. With the button name selected, click Delete Button. The dialog box closes and the button is gone.

**CREATING AND EDITING BATCH FILES**

A *batch file* is a sequence of DOS commands contained in a text file (check the DOS User’s Reference for information). You can easily create and edit them in the DOS Programs screen.

**To create a new batch file...**

1. Choose Create Batch File from the Options menu. A file selector appears, asking you to name the batch file.
2 Type a name for the batch file, up to eight characters in length. Only characters valid for DOS file names are accepted. Since it's a batch file, a ".BAT" is automatically tacked on at the end of the name.
3 Click Create. The Batch File Text dialog box appears.

The Batch File Text dialog box. Basically the same thing as the Notepad, this is where you enter (and edit) the contents of your new batch file.

4 Use this dialog box to enter the contents of the batch file.
5 When you finish editing, click Save to save your work.

To edit an existing batch file...
1 Chose Edit Batch File from the Options menu. A file selector appears, asking you to select the batch file you want to change. Choose the file and click Edit File. The Batch File Text dialog box appears.
2 Edit the text in the Batch File Text dialog box the same way you'd edit text in, say, the Notepad.
3 When you finish editing, click Save to update the batch file on your disk.
In addition to the regular applications, fonts, and clip art, GeoWorks Pro comes with a collection of "freebie" programs. Some are quite useful and others are just for your amusement. The most useful of them is Screen Dumper, which is handy for taking a "snapshot" of your GeoWorks Pro windows. This utility—and all the other "extra" software—can be found in the World directory, in a directory called "Extras."
SCREEN DUMPER

Screen Dumper is an application you use to take a “picture” of a GeoWorks Pro screen. It captures the image and saves it as a file you can import into another program, such as GeoDraw (or Aldus PageMaker, or any of the other page layout programs available for PC or Macintosh computers—we used this utility to produce this book). Screen Dumper lets you capture one window out of several open windows, if you wish—you don’t have to capture the whole screen. And it can save images in several popular formats: Raw Bitmap, PostScript, Encapsulated PostScript, PC-Paintbrush (“PCX”), and TIFF.

A couple of important points before you begin: Screen Dumper is one of the only GeoWorks Pro programs that’s truly modal. This means that while you’re issuing commands to capture a screen, all other applications are completely frozen (unresponsive). This may be disconcerting the first time you use Screen Dumper, but you’ll soon get used to it.

Also, when capturing PostScript-format (or EPS-format) files, Screen Dumper doesn’t include a screen image along with the PostScript commands. While the image prints normally, most other programs (PageMaker, etc.) will show you a gray box (with a name in it) in lieu of the image.

SETTING UP THE SCREEN DUMPER

The Screen Dumper window does nothing more than allow you to set the Screen Dumper options. The first thing you should do is use the file selector (see “Basic Tools and Skills” for more about file selectors) to tell Screen Dumper where you want it to put the dump files. Change the Base Name if you want each file to be named something more specific than “DUMP.” But leave the percent sign (%) at the end of whatever name you type—Screen Dumper substitutes the dump number for the percent sign, upping the number by one for each dump. (The first capture will be saved as DUMP00, the second as DUMP01, and so on.) Use the annotation feature to keep a log of your screen
captures, or use Append to add entries to the end of the current log.

**BANISHING THE SCREEN DUMPER WINDOW** To make the Screen Dumper window disappear (so that you don’t inadvertently capture it in a screen dump), click Banish. To bring the Screen Dumper window back, press Ctrl + Alt + Tab, then F1.

**DISABLING THE CURSOR** If you are capturing an image that has a blinking cursor (like a dialog box with a text field or a page in a word processing document), you can do two things: let the cursor continue blinking, which means you may or may not get the cursor in your image, depending on how you time the screen dump; or disable the blinking cursor, in which case it stops blinking and appears in the image. To disable the blinking cursor, choose Disable Blinking Cursor from the Options menu. To restore the blinking cursor during screen captures, choose Enable Blinking Cursor Again. GeoWorks Pro automatically restarts when you do either of these.

**SETTING POSTSCRIPT OPTIONS** When you save a screen dump as a PostScript file, you have several options for the size and orientation of the image, the color model, the number of copies of each screen dump you want, and so forth. Choose Postscript from the Options menu and make your choices in the Postscript dialog box.

**Image Name** This name appears on the blank box that represents the PostScript image within desktop publishing programs (such as PageMaker). The name serves only to document the contents of the screen capture file; it has no effect on the image itself, or on the name of the file in which the image is placed.

**Color** Choose the color model best suited for the equipment you will use to print the images. Use RGB if you will be viewing the images on a color monitor, while CMYK is better for color printers. Grayscale is best for black-and-white printers and monitors. 

*Note: Both RGB and CMYK use Postscript color extensions (the “colorimage” operator). If your printer doesn’t support this, choose Grayscale, or you’ll get an error when you try to print the document.*

**Number of Copies** You can have the printer make several copies of each capture. This is much, much faster than printing the image several times, but every time you print the file you’ll get this many copies.

**Orientation** Choose Portrait if you want the image printed normally. Choosing Landscape makes the image print out sideways—useful for printing full screens, as this is closer to the aspect ratio (width to height ratio) of a monitor than the Portrait option.
**Image Width, Image Height** This is the size (in centimeters) of the image. Note that Image Width and Image Height are always relative to the image, not the page orientation. Your image will appear this size when you print, even if it has to be stretched to fit—there being no way to have Screen Dumper automatically size the Image Width and Image Height to match the image.

**Paper Size** This is the size of the paper on which you'll print the image. The image will be centered within this space.

**SETTING TIFF OPTIONS** When you choose the TIFF format to save your screen dumps, you can choose between color or grayscale images. Choose TIFF from the Options menu and make your choices in the TIFF dialog box.

![TIFF Dialog Box](image)

**Dump Color As** When capturing a color screen to a TIFF file, the colors can be placed in the file as-is, or converted to sixteen-level Grayscale. This option has no effect if you're capturing a monochrome screen.

**Image Compression** This option isn't yet supported.

**CAPTURING A SCREEN IMAGE** Often, capturing an image involves going into Screen Dumper's “control mode.” This means that Screen Dumper completely takes control of your computer, and all you can do—until you leave control mode, at any rate—are screen dumping operations. You can still move the pointer around the screen (you'll notice it no longer changes when it moves over different things), but it returns to its original position when you leave control mode.

You enter control mode when you press `Ctrl` + `Shift` + `Tab`. The computer immediately freezes so that you can dump the screen. Press `[Esc]` when you want to exit from control mode and thaw your computer.

**To capture the entire screen...**

1. Make sure that you've set all the proper options—Base Name, Dump Number, Formats, etc.
2. Press `Shift` + `PrtSc`. Or, press `Ctrl` + `Shift` + `Tab`. This freezes everything temporarily and puts you into “control mode.” Press `[F8]` to capture the screen.
3. If Annotation is on, a dialog box appears so that you can enter a description of what you just captured.

![Annotation Dialog Box](image)

**To capture a single window...**

1. Make sure that you’ve set all the proper options—Base Name, Dump Number, Formats, etc.
2. Press `[Ctrl]` + `Shift` + `Tab`. This freezes everything temporarily and puts you into “control mode.”
3. Position the pointer on the title bar of the window you wish to capture.
This is very, very important. When you capture a window, Screen Dumper captures the window that is directly under the pointer. But there’s a catch: In many cases, windows are built up from several little windows that don’t look like windows—they’re essentially invisible. If you put the pointer on one of these, all you get is the little window. Putting the pointer on the big window’s title bar gives you everything inside the window (little windows and all), and therefore avoids the problem.

1. Press [F3] to capture the window without the pointer, or press [F4] to capture both the window and the pointer.
2. If Annotation is on, a dialog box appears so that you can enter a description.

   If your keyboard has the extended function keys, you can simply press [F11] to get the window by itself or [F12] to get the window and pointer, without ever entering control mode (meaning that you also don’t have to press [Esc] to exit control mode).

To capture only a portion of the screen...

   You don’t have to capture an entire window if all you need is a tiny portion of it.
   1. Enter Screen Dumper control mode by pressing [Ctrl] + [Shift] + [Tab].
   2. Position the pointer at the upper-left corner of the portion you wish to capture.
   3. Hold down the left mouse button and drag a selection rectangle. Everything within this rectangle will be captured. (Release the mouse button when done.)

   Press [F6] to capture everything on the screen within the capture rectangle.

   Screen Dumper remembers the current selection rectangle, so you only need to enter control mode and press [F6] when you want to capture the same area again. (Press [F5] to see the current selection rectangle.)

To exit control mode...

   Screen Dumper automatically pops you out of control mode and “thaws” your computer after you capture something (by pressing [F6] or [F8]). If you enter control mode and change your mind, you can escape by pressing [Esc].
NIMBUS FONT CONVERTER

There are many different font formats out there. GeoWorks Pro uses a format based on a specific driver known as "Nimbus Q," which is designed to work with fonts produced by the URW type foundry in Germany. (The term "foundry" stems from long ago when fonts were minted from lead in an actual foundry.)

If you happen to have other URW fonts that you want to use with GeoWorks Pro, you can run them through the Nimbus Font Converter. The font converter translates and copies URW fonts into GeoWorks Pro's internal font directory. It also adds some extra information to the file to improve the font's performance. These fonts will then appear in the Fonts menu, and you'll be able to use them in your documents the same way you'd use any of the regular GeoWorks Pro fonts.

To convert a font...

1. Start the Nimbus Font Converter. A file selector appears.
2. Locate the directory containing the fonts you would like to convert. Double-click to open it. You may have to move through several directories or even look on another disk to find the proper directory.
3. When you've found the directory containing the fonts you'd like to convert, click OK. At this point, you're not actually selecting the font files that you're interested in, but merely selecting the directory that contains them.
4. Another dialog box appears with the fonts listed by their Nimbus font names instead of their DOS filenames. If there are several variations of one font in the directory (for example, a file containing Roman Book, one for Roman Italic, and another for Roman Bold), all the files will be listed under one font name—Roman.
5. Select the font name that you would like to convert.
6. You can type in a new name for the font. This is the name that will appear in the Fonts menu of GeoWrite or GeoDraw. As you type in a new name for the font, the name of the font in the list changes also. This name change is used in GeoWorks Pro only—the name of the font in the original file is not changed.
Click Convert. The font you selected is converted to PC/GEOS format and its new name—if you typed one in—is added to the font menus of GeoDraw and GeoWrite.

Click Done when there are no more fonts that you want to convert. Choose Exit from the File menu to exit the Font Converter.

At this point you're asked to restart GeoWorks Pro so that the new fonts can take effect. Click Yes if you'd like your changes to take effect immediately. (If you're in no hurry to use the fonts you can choose No, in which case the new fonts will appear the next time you start GeoWorks Pro.)

PERF

Perf is kind of like the pressure indicator on a steam pipe in that it tells you how "hot" GeoWorks Pro is getting—how much memory is in use, what percentage of the CPU's processing power is being used, how much is currently swapped out of memory, and other things "techies" might want to know. (If you have no idea what any of this means, relax—Perf is just for satisfying your curiosity, it's not something you ever need to run.) All these statistics are shown in small graphs that reflect changes by the second. For a discussion of what each graph means, click Help at the bottom of the Perf window.

CHOOSING GRAPH OPTIONS

You have control over what statistics to display and how to display them. You can choose only a few statistics of interest, show a single statistic in the corner of the screen, change graph colors, and show graphs with or without captions and values. You can even freeze graphs to preserve their values.
To hide the controls...

Select Hide Controls to hide everything but the graphs. This is a handy to view the graphs without having the whole dialog box open. To view the controls again, simply click on the graphs.

To choose specific graphs to view...

In Performance Statistics, click on the statistics that you do not want to see and click Apply. Those graphs disappear from the window. To see them again, reselect them in Performance Statistics and click Apply.

To see a single graph in the lower-left corner of the screen...

Choose Minimize from the Control menu to view the CPU graph in the lower left corner of the screen. To view another single graph, turn off all the graphs you do not want to see and select Minimize from the Control menu. You can drag the graph anywhere on the screen. To view the Perf dialog box again, double-click the graph.

To customize graph colors...

Click the graph you would like to change and click Graph colors. From the palette, choose the desired color. You can keep the palette open until you have a color you like, then double-click the Control button to close it.

To freeze values...

Click the Off button next to Performance Meters. The graphs stop changing and the values freeze. Click On to resume activity.

To set display options...

Each display consists of the graph, its caption, and a value. These are all visible when you open the Perf dialog box. To hide any of them, click the appropriate setting in Display options and click Apply. To view that part of the display again, select the setting in Display options and click Apply.

3D FONT DEMO AND BOUNCE

The 3D Font Demo shows a piece of text spinning around and around in three dimensional space. The name GeoWorks appears in the text field, but you can type any word you want into it. (Be sure to press Return when done typing.) You can resize the window as you wish.

Bounce shows a bouncing diamond moving around a window. It bounces around and around and around. It’s not very useful, but it is fun to watch.

Its purpose—and that of 3D Font Demo, too—is to let you see GeoWorks Pro’s multitasking in action. Start the ball bouncing and the text spinning, and then notice how you can still do other things (like editing and printing) without seriously affecting their speed.
When you enter the Intermediate Workspace, the File Cabinet document manager is the first thing you see. From there you can open documents—yours and ours—as well as manage your files, directories, and disks. You do all these things with the simple point and click actions that you use elsewhere in GeoWorks Pro—their’s no need to remember any mystifying commands. (It’s much like the Advanced Workspace’s GeoManager in this way.)
WHAT YOU SHOULD ALREADY KNOW

Certain tasks you perform in the File Cabinet are common to all GeoWorks applications. This is the main reason you can go from one GeoWorks Pro application to another and feel immediately comfortable. These common tasks are not discussed in application chapters like this one, but they are described in the “Basic Tools and Skills” chapter. Here are some of these tasks. If you are not familiar with them already, go to the “Basic Tools” chapter and read about them there.

• Opening and closing a document
• Naming Files and directories
• Entering and editing text
• Saving a document
• Using a file selector
• Selecting file and directory icons
• Directories and subdirectories

THE FILE CABINET WINDOW

The File Cabinet window tells you much about the directory you’re in and what it contains. Here are some of the items that give you that information:

Information bar The information bar displays:
• The directory pathname (See “Basic Tools and Skills” for more about pathnames)
• The number of files and directories currently appearing in the File Cabinet window
• The amount of disk space, in bytes (characters, that is), used by the files shown and the amount of free disk space

GeoWorks Pro file icons Each type of GeoWorks Pro document has a unique icon. The different icons help you quickly spot particular types of files. The names of the files appear below the icons.
DOS file icons Though you'll rarely see DOS files listed in a File Cabinet window, they also have their own unique icon.

Directory icons A folder icon in the File Cabinet window represents a directory on your disk drive. Because directories appear as pictures of little folders, the terms “directory” and “folder” are often used interchangeably (in much the same way that “document” and “file” are).

Floppy disk buttons Each floppy disk drive in your computer is represented by a button on the bottom edge of the File Cabinet window. The letters on the buttons indicate which drives the buttons represent. If, for example, you want to see the contents of the floppy disk in drive A, you click the disk button labeled “A.”

GETTING TO WORK

You start work on a document simply by opening it. If you’re creating a document from scratch, you need to open a template document (see “Working With Templates,” later in this chapter).

To open a document...
1. Open the directory that contains your document. (See “Opening Directories,” later, for more information about this.)
2. Click to select the document’s icon. The icon will highlight to show you that it’s selected.
3. With the document selected, click the Open button at the top of the File Cabinet window. The document opens up, and you can get to work.

You can also open the document by double-clicking the document icon (instead of selecting it and clicking Open). It doesn’t matter which method you use.

WORKING WITH TEMPLATES

The documents that you use in the Intermediate Workspace are called template documents—basically, boiler-plate documents. Templates make your work easy because the formatting in them has already been done for you. So, to create a great-looking document, all you have to do is open a template and add your own text—and even graphics, if you’d like.

For example, a newsletter template holds formatting for columns, line spacing, paragraph indents, headings, fonts, and so forth. To create your own newsletter, you simply open a template in the NEWSLTR folder, type in your text, paste in any graphics, then name the newsletter and save it. The template itself remains unchanged, ready to be used again, while your new document appears in the File Cabinet. Other folders (like BANNERS, CARDS, FORMS, SIGNS) also contain useful templates.

To open a template...
1. Click the template’s icon to select it. It will highlight to indicate that you’ve correctly selected it.
2. Click the Open button at the top of the window. A dialog box appears to tell you that the file is marked as Read Only, meaning that you can’t change the template.
Since you’ll be saving the document with a name of your own—thus leaving the template unchanged—click OK. The dialog box goes away and the template opens up.

**OPENING DIRECTORIES**

When you want to perform file management tasks like copying or moving files and directories, you begin by opening the directory that contains the items you want to work with. You can also open a directory to just view its contents. When you open a directory, its contents appear in a new window. The directory you are working with is called the *current* or *active* directory.

**To open the DOCUMENT directory...**

The DOCUMENT directory is where you normally store all your GeoWorks Pro documents. Click the Documents button. This opens the directory and shows its contents in the window.

**To open a directory from its folder icon...**

Double-click the icon of the directory you want to open, or select the icon and click Open Dir at the bottom of the File Cabinet window. The directory opens and its contents display in the window.

**To open the parent directory...**

Switch to the *parent* directory—that is, the directory that contains the current directory—by clicking the Close Dir button.

You can continue clicking the Close Dir button to move up the directory structure (one level at a time) until you reach the DOCUMENT directory. When you get here, the button is dimmed to indicate that you can go no higher. If you want to manage files and directories that are not in the \GEOWORKS\DOCUMENT directory, use GeoManager in the Advanced Workspace.

**To open a directory on another disk...**

If the other disk you want to open is a brand new floppy disk, you may need to format it before you try to open it. See “Formatting a Floppy Disk” later in this chapter.

1. If you want to open a directory on a floppy disk, insert the disk in a floppy disk drive.
2. Click the disk button that corresponds to that drive. If it’s a floppy that you put in the A drive, for example, click the Floppy button labeled “A.” The File Cabinet window displays the root directory of the floppy disk or hard disk.
3. You can now work with the contents of this disk in the normal way.
**CREATING A NEW DIRECTORY**

You can create a new directory within any open directory. The new directory is empty until you move or copy items into it.

**To create a new directory...**

1. Open the directory you want to contain the new directory. (If you need to move back up the directory structure to do this, use the Close Dir button.)

2. Click Create Dir at the bottom of the File Cabinet window. A dialog box appears asking you to name the new directory.

3. Type the name of the new directory. Use standard DOS filename conventions—eight letters, with an optional three letter extension. For instance, MYFOLDER.ONE.

4. Click Create. The new directory appears in the current directory window.

**RENAMEING A FILE OR DIRECTORY**

The name that you give a directory or file is not necessarily permanent. You can change it at any time using the Rename button.

**To rename an item...**

1. Select the item you want to rename. You can select more than one if you like (see “Selecting” in the “Basic Tools and Skills” chapter for more information).

2. Click Rename at the top of the File Cabinet window. A dialog box appears.

3. Enter the new name in the box.

4. Click Rename to apply the new name. If another file already has this name, a dialog box asks you to type a different name. If you’ve selected several items, you get a dialog box for each item. Click Next to leave the name of the current item unchanged and go on to the next. Click Cancel to close the dialog box without renaming the rest of the selected files.

**MOVING AND COPYING FILES AND DIRECTORIES**

The easiest way to move or copy a file or directory is to drag it to its destination (using the right mouse button). Dragging an item to a directory on the same disk moves the item to that directory, while dragging it to another disk copies the item. You can also copy and move by using the Copy and Move buttons.

When you move or copy more than one item, a dialog box appears showing you the progress of the operation. If you want to halt the whole process, click Stop. The operation stops after finishing with the current file.
The directory you copy or move items from is sometimes called the source directory, and the directory you copy or move them to is called the destination directory. If the destination directory already contains an item with the same name, you’re asked if you want to replace the existing item.

**To move an item using the Move button...**
1. Select the item (or items) you want to move.
2. Click the Move button at the top of the File Cabinet window. A file selector appears asking you for the destination directory.
3. In the file selector, find and select the destination directory. Only the directories within the current directory are shown — files in the directory aren’t listed. If the list is empty then there are no folders in the current directory. (For more about file selectors, look in the “Basic Tools and Skills” chapter of this book.)
4. Click Move to move the items. When you move more than one item, a dialog box appears showing you the progress of the operation. If you want to halt the move operation, click Stop (the operation will stop after finishing with the current file).

**To copy an item using the Copy buttons...**
1. Select the item (or items) you want to copy.
2. Click the Copy button at the top of the File Cabinet window. A file selector appears asking you for the destination directory.
3. In the file selector, find and select the destination directory. Only the directories within the current directory are shown — files in the directory are not listed. If the list is empty then there are no folders in the current directory.
4. Click Copy to copy the files into the directory. When you copy more than one item, a dialog box appears showing you the progress of the operation. If you want to halt the copy operation, click Stop (the operation will stop after finishing with the current file).

To move a file, position the pointer over it and click the left mouse button and hold it down. This “picks up” the file. Actually drag the file to the place you want it to be. Your options range from putting it in another directory to copying it to a file, or even dropping it in the wastebasket (to delete it from your disk). It may seem a little odd at first to be dropping files on buttons (you can achieve the same results by clicking the Move and Copy buttons, or the Delete button), but this way is faster and easier.
To move or copy an item by dragging...

1. Select the item or items you want to move or copy.
2. Position the pointer over one of the selected items then press and hold down the right mouse button. The pointer changes to indicate whether you are dragging a single item or several items.
3. Drag the pointer over one of the following elements:
   - A folder icon.
   - The Close Dir button (if available) at the bottom of the File Cabinet window—the items are moved to the parent directory, one level up in the directory hierarchy.
4. Release the right mouse button.

Dragging an item to a directory on the same disk moves the item to that directory, while dragging it to another disk copies the item. You can always force a move operation by holding down the Alt key while dragging, or force a copy operation by holding down the Ctrl key.

**DUPLICATING A FILE OR DIRECTORY**

You can make copies (exact in all but name) of both files and directories. For example, you may want to duplicate a document file before making extensive changes to it, in order to have a backup of the original.

To duplicate an item...

1. Select the item (or items) you want to duplicate.
2. Click the Duplicate button at the top of the File Cabinet window. A dialog box appears.
3. Type in a name for the duplicate—if you like—otherwise the copy is just named “Copy of (file or directory name).” When you duplicate many items, you’re given a chance to change the name of each copy. Clicking Next skips the current item altogether. Clicking Cancel closes the dialog box without duplicating the remaining items.
4. Click Duplicate. A duplicate of the selected item (or items) appears in the same directory as the original. If you’re duplicating more than one item, the name of the next item appears in the dialog box and the whole process repeats.

**DELETING A FILE OR DIRECTORY**

There are times when you need to make room on your hard disk (or floppy disks for that matter) by deleting files or directories you no longer need. Deleting a file removes the file from your disk, so be careful to delete only those files you know you won’t need later. You cannot recover a deleted item using GeoWorks Pro.

To delete an item...

1. Select the item (or items) you want to delete.
2. Click Delete at the bottom of the File Cabinet window. A dialog box...
appears, asking you to confirm the delete operation.

3 Click Yes to delete the item; click No to keep it and move on to the next (if you're deleting several). Click Cancel to close the dialog box without deleting additional items.

If you delete more than one item, a dialog box may appear showing you the progress of the operation. If you want to halt the deletions, click Stop. The delete operation stops after the current file is deleted.

GETTING INFORMATION ABOUT A FILE OR DIRECTORY

Click the Get Info button to see information about a file, including its size and when you last worked on it. When you display information about a GeoWorks Pro application or document, you can also enter your own notes.

To display information about a file or directory...

1 Select the item (or items) you're interested in.
2 Click Get Info at the top of the File Cabinet window. The Get Info dialog box appears.
3 If the item is a GeoWorks Pro application or document, and it isn't Read-Only, you can enter and edit text in the User Notes box. Notes are saved along with the file.

4 Click OK to save the notes and display information about the next item. Click Next to skip the current item and display information about the next item. Click Cancel to close the dialog box.

FORMATTING A FLOPPY DISK

An unformatted disk is like a library with no shelves—there's nowhere to put the books. Before you can store anything on a disk, you must format it. When you format a disk, you're essentially building the shelves (and labeling them) so the computer has an organized framework in which to store files and directories.

To see if a disk has already been formatted, insert it into a floppy disk drive and click the appropriate floppy disk drive button. If a dialog box appears telling you that the disk is unreadable, you know the disk needs formatting.

To format a floppy disk...

1 Insert the floppy disk into one of the disk drives.
2 Click Format at the top of the File Cabinet window. A dialog box appears.
3. Click the radio button that identifies which floppy disk drive has the disk.
4. Click the option for the disk capacity you want. Your formatting options depend on the capacity of your floppy disk drive and the size of the disk you are formatting.
5. Click OK. A dialog box appears requesting a name for the disk.
6. Type a name for the disk, and click Format. The File Cabinet formats the disk according to the options you specified. A message lets you know how the formatting is proceeding and when it is complete.

LEAVING FILE CABINET (AND THE INTERMEDIATE WORKSPACE)

You can leave the File Cabinet (and the Intermediate Workspace) at any time by either returning to the Welcome screen or exiting to DOS. Always exit to DOS before turning off your computer.

GeoWorks Pro also remembers what you were doing when you exited. This way, when you come back, no matter how long you’ve been gone or what you’ve done in the meantime, everything is just as you left it. The current directory is the same. The same documents are open.

To leave File Cabinet and return to the Welcome screen...
1. Click the Express button.
2. On the Express menu, click Welcome. The File Cabinet window goes away and the Welcome screen appears.
Note: You may also press F2 to return to the Welcome screen without using the Express menu.

To leave File Cabinet and return to DOS...
1. Click the Exit button at the top of the File Cabinet window. A dialog box appears asking you to confirm that you want to exit to DOS.
2. Click Yes. File Cabinet exits and the DOS prompt appears. At this point it’s OK to turn your computer off or run a DOS program.
GeoComm makes telecommunication with other computers, information services, and bulletin board systems straightforward and efficient. And it also gives you powerful tools for processing the information you send and receive. You can capture your session in a DOS text file. Compose messages off-line. Send and receive files using the XMODEM protocol. Even create scripts to automate your session.
THE GEOCOMM WINDOW

When you're on-line (connected to another computer), anything you type into the GeoComm window is sent to the other computer. And, likewise, anything sent to you from the other computer appears in the window. It's just like having a regular phone conversation—except that both sides of the conversation appear in a window.

GeoComm's cursor looks and acts differently than the text cursor you see in other GeoWorks applications (like GeoWrite). First of all, GeoComm's cursor looks like a little box instead of a thin vertical bar. When the box is solid, the GeoComm window is active, and whatever you type is sent to the other computer you are communicating with. When the box is hollow, the GeoComm window is inactive. The window will still receive data from another computer, but you cannot type anything until you make the window active (by clicking in the GeoComm window).

To change the size of the window...

In addition to using the resize borders to make the window larger or smaller, you can specifically set the number of lines and columns in the window:

1. Choose Window Size from the View menu. The Window Size dialog box appears, displaying the current number of lines and columns.
2. Adjust the number of Window Lines by clicking the arrow buttons or typing a new number.
3. Adjust the number of Window Columns.
4. Click Apply. The GeoComm window immediately changes to the new size.
5. Click Close.

You can have up to 80 columns and 24 lines. On some computer screens, this size would make the GeoComm window

The GeoComm window has a uniquely-shaped cursor, a square instead of a line. When the window is active, the cursor is black. But when the window is inactive—meaning that you can still receive information but you cannot type—the cursor turns into a hollow white square.
bigger than the entire screen. In these cases, GeoComm allows only the number of lines that will fit on the screen.

**To make the text large or small...**
Choose Large Font or Small Font from the View menu. The window redraws with the appropriate font size. GeoComm automatically changes (if need be) the number of lines and columns so the GeoComm window completely fits on the screen.

**SETTING PARAMETERS**

Before you do anything, adjust your protocol, terminal, and modem settings using the commands in the Options menu. All the settings on your computer must match the other one's exactly, or you may not be able to communicate.

**PROTOCOL SETTINGS** When you first start GeoComm, a dialog box appears asking you to choose the protocol settings for your modem. The settings you first see are default settings—they match those in the modem section of the Preferences application. To change these default protocol settings—and prevent GeoComm from asking for them each time—change the corresponding settings in the modem section of Preferences. Of course, you can still change the protocol settings temporarily using the Protocol dialog box.

- **Modem Port** Should correspond to the serial port where your modem is plugged in.
- **Baud Rate** The baud rate is the speed at which data is transmitted between your computer and the remote system.
- **Data Bits, Parity, and Stop Bits** These settings define exactly how data is formatted for transfer between two computers. Data Bits defines how many bits (in the stream of data) contain meaningful information. Parity is used for error-checking during transmission. Stop Bits are the one or two bits which indicate the end of a character in the stream of data.
- **Handshake** Choosing Software (XON/XOFF) allows GeoComm to monitor the flow of data from the remote system, pausing and restarting the remote computer if necessary. If you turn this option off, you risk losing portions of incoming data.

**To set protocol settings...**
2. Change the options in the window.
3. Click Apply when you finish, and click Close to close the window.
**TERMINAL SETTINGS** GeoComm can *emulate* (act like) many popular models of dumb terminals. (A dumb terminal is essentially a computer with very little computing power—basically just a screen and a keyboard, that can’t run programs the way a PC can.)

![Terminal Settings Dialog Box](image)

**Terminal Type** GeoComm can emulate a variety of terminals: TTY, VT52, VT100, WYSE50, ANSI, IBM3101, and TVI950. Normally you use a standard TTY ("teletype") terminal setting. When you connect to a system that expects a particular type of terminal, select the appropriate entry from the list.

**Duplex** The Duplex setting controls the way data flows between computers. Full duplex is analogous to a two-way street: data can flow in both directions at the same time. Similarly, half duplex is like a one-way street: data can only flow in one direction at a time. There’s an easy way to tell which setting you should choose: type something. If what you type appears twice on the screen, select Full duplex. If they don’t appear at all, try Half duplex.

**Wrap Lines at Edge** This option controls how GeoComm deals with lines of text that are too long to fit in the window. With this option on, a long line is split into several shorter lines that fit within the window. When the option is off, long lines abruptly end at the window’s edge. (If you’re capturing the text to a DOS file, the entire long line is *captured* correctly, even if it doesn’t *display* correctly in the window.)

**Auto Linefeed** This option replaces each incoming carriage return with a carriage return and a linefeed. If each new line displayed on your screen overwrites previous lines, turn on Auto Linefeed; on the other hand, if all the lines are double spaced, turn it off.

**To set terminal settings...**

1. Choose Terminal from the Options menu. The Terminal dialog box appears.
2. Change the options in the dialog box.
3. Click OK when you finish. The dialog box disappears.

**MODEM SETTINGS** In order to communicate with other computer over a phone line, you must have a modem attached to your computer. The Modem settings will only work with Hayes-compatible modems. If your modem is not Hayes compatible, check the modem’s manual for information on adjusting the modem’s operation.

![Modem Settings Dialog Box](image)

**Phone Type** Set the phone type to agree with the type of service (tone or pulse) on your telephone line.

**Modem Speaker** You can use your modem’s built-in speaker to eavesdrop on the telephone line activity. Choose one of the settings:
• **On Until Connect** keeps the speaker on while dialing and waiting for the other modem to answer, but turns it off when a connection is made.

• **On Unless Dialing** turns the speaker on only while waiting for the other modem to answer.

• **Always On** keeps the speaker on at all times.

• **Always Off** keeps the speaker completely off.

**Speaker Volume** This setting controls the volume of your modem’s speaker.

To change the modem settings...
  1. Choose Modem from the Options menu. The Modem dialog box appears.
  2. Change the options in the dialog box.
  3. Click OK when you finish. The dialog box disappears.

---

**STARTING AND ENDING COMMUNICATIONS**

Once you’ve set the GeoComm parameters for your computer, you’re ready to begin communications. Before you can send or receive anything, though, you must establish a connection with another computer by calling it. This is usually just a matter of using GeoComm to dial the phone number of the other computer.

**To dial a number...**
  1. Choose Quick Dial from the Dial menu. The Quick Dial dialog box appears.
  2. Type the phone number you wish to dial.
  3. Click Dial. GeoComm dials the number.

*Note: Place a comma anywhere in the number where you want a brief pause in the dialing sequence. For example, if you need to dial an access code for an outside line, type it as part of the number: 9,555-1212.*

**To hang up the phone...**
  1. If you’re logged onto the other computer, log off of the computer in the normal way.
  2. Choose Hang Up from the Dial menu. A dialog box appears, asking you if you’re sure you want to break the connection. If you click Yes, the modem hangs up the phone line, closing the connection.

**WORKING ON-LINE**

When you are not connected to another computer, you are **off-line**. Similarly, when you have established communications with a computer and are exchanging information, you are **on-line** with that computer. Once online, anything you type in the GeoComm window is sent to the other computer. Likewise, anything the other computer sends to you also appears in the window—it looks like someone else is typing with your keyboard.

**SENDING PREPARED TEXT** Sending prepared text is like having GeoComm automatically type something for you. In fact, if you were to watch from the other computer, it would look like an extremely fast typist was typing your text. Since neither computer checks for transmission errors, though, you run the risk of
losing characters here and there—which is fine if you’re sending short messages, but very bad if you’re sending something important like a database file. To send important files, use XMODEM (discussed later in this chapter).

Here are three different ways to send prepared text:

• If you like working with your messages—composing, revising, re-revising, and so on—before you send them, you can compose them off-line in the Message window. This is especially useful for sending short electronic mail messages. When you’re done, GeoComm automatically types in the message for you.

• Any text you paste from the clipboard is automatically typed into the window. So, you can copy a paragraph or two from GeoWrite to the clipboard, and then paste them into the GeoComm window, thus sending them to the other computer. You can quick copy text into the GeoComm window and have that type out too.

• GeoComm can also type in the contents of DOS text files (like those you create with the Notepad). This method works well for short files without special control characters in them. In other words, it’s a very bad idea to send GeoWorks Pro documents (those produced by GeoWorks applications) this way.

To compose a message off-line...

1. Choose Message from the Edit menu. The Message window appears. This basically looks and works like a little Notepad window.

2. Type the message you wish to send. You can edit the message using basic text editing procedures.

3. Click Send. The message is automatically typed into the GeoComm window—and therefore to the other computer. Compose and send other messages if you want. When you’re finished, click Close.

To send the contents of the clipboard...

1. From the other applications (or GeoComm), cut or copy the text you wish to send.

2. Switch back to GeoComm with the Express menu (unless, of course, you’re already there).

3. Choose Paste from the Edit menu to send the contents of the clipboard to the other computer.

To send a DOS text file...

1. Choose Type From Text File from the File menu. A file selector appears.

2. Locate and select the DOS file you want to send.

3. If the remote computer requires linefeeds after every carriage return, make sure the Strip Linefeeds from Text option is off (most do not).

4. Click Type. A status window appears, showing you the name of the file currently being transmitted. If you want to stop the transfer at any time, click Cancel in the status window.
SCROLLING THROUGH DATA When the GeoComm window fills with text, it scrolls upward. The top line of text goes out the top, and any incoming lines of text come in at the bottom. As the lines of text go out the top of the window they are stored in something called the “scroll-back buffer.” You can view this holding area by scrolling the window down with the vertical scroll bar. There’s room in the buffer for about 175 lines of text, but when it fills up it removes the oldest lines—in other words, it always contains the most recent 175 lines of text.

You can save the scroll-back buffer into a DOS text file if you want to keep it. For more information, see “Capturing Text” later in this chapter.

SAVING INFORMATION

You can save anything that appears in the GeoComm window. If you want to save only a little bit of text, you can select it and copy it to the clipboard. Or, if you want to save what you see on the screen and what’s included in the scroll back buffer (discussed earlier in this section) use the Save Buffer command. Otherwise, if you know that you just want to save everything that appears in the GeoComm window from now on, try the Capture to Text File command.

To copy text to the clipboard...

1. With the mouse, select the text you wish to copy.

2. Choose Copy from the Edit menu. The selected text is copied to the clipboard. You can then paste this scrap into another application—just like you’d paste anything else from the clipboard.

To save the current screen and scroll-back buffer to a file...

1. Choose Save Buffer from the File menu. A file selector appears.
2. Locate the directory where you want to save the file.
3. Enter a name for the file. This name should be in DOS format—one to eight characters, optionally followed by a period and an extension of up to three more characters.
4. Choose Screen Only if you want to save the current screen, or Scroll-Back Buffer if you would like to save only what has scrolled off the top of the screen. Choose Scroll-Back Buffer and Screen if you would like to save both.

5. Click OK to save the screen to the DOS file.
To capture text to a file...
If you know ahead of time that you want to store data as you receive it, you can route it directly into a text file as it comes in.
1. Choose Capture to Text File from the File menu. A file selector appears.
2. Locate the directory in which you want to save the file.
3. Enter a name for the file (in DOS format).
4. Turn on End Lines With CR/LF if you want the file to have linefeeds after every carriage return. You normally leave this option off.
5. Click Capture. The Capture Status window appears. This window stays up in front of the GeoComm window for as long as you're collecting text—but you can still do work in the GeoComm window. Anything that appears in the GeoComm window is recorded on disk.
6. Click Done in the Capture Status window when you want to stop capturing data. The capture file is closed, and the dialog box goes away.

Sending and receiving files using XMODEM

Earlier in this chapter, you learned how to send short messages and even DOS text files by having GeoComm type them in for you. But this method is not a reliable way to send important files—those where every character must be transmitted correctly. This is where XMODEM comes in. XMODEM works differently from the earlier methods—it sends (or receives) the information in small pieces, making sure that each piece is received correctly before sending the next one. If any piece is received with something wrong (perhaps because of a noisy phone line) then the piece is transmitted again. And again, until it is received perfectly. Almost all file transfers via XMODEM are error-free. Both computers must be using XMODEM for the file transfer to work.

To send a file with XMODEM...
1. Prepare the remote system to receive an XMODEM file. You usually do this by manually sending a message to the other computer that says something like, “I’m about to send an XMODEM file.” Be sure to specify whether you are sending a text or a binary file. (If you’re sending GeoWorks documents, use binary.)
2. When the person on the other side gets your message, it’s up to them to prepare their computer to receive the file.
3. Choose Send XMODEM from the File menu. A file selector appears.
4. Locate and select the file you want to send.
Choose 1K Blocks if the remote computer accommodates 1K Blocks and if you've got a pretty good phone connection to the other computer. Otherwise (or if you're not sure) choose 128 Bytes.

Click Send. The Send Status window appears, showing you the number of errors encountered during the send. While it's normal to get a couple of errors during the operation, getting a lot of errors in a little bit of time probably indicates that there's a problem with the line. If you want to stop sending the file at any time, click Cancel.

To receive a file with XMODEM...
You receive files in much the same way as you send them.
1. Let the remote computer know that you're ready to receive a file using XMODEM. GeoComm doesn't do this for you—you must manually type in a message.
2. Choose Receive XMODEM from the File menu. A file selector appears.
3. Locate the directory where you want to save the file.
4. Enter a name for the file, in DOS format.
5. Choose the Text option if you are receiving a DOS text file. Select the Binary option if you are receiving a binary file (such as a GeoWorks document or application file).
6. Choose CRC if the remote system can accommodate CRC (Cyclic Redundancy Check). Choose Checksum if the remote system doesn't allow CRC. CRC is a more sophisticated error-checking protocol than Checksum, although either should result in error-free file transfers. If you're not sure which to use, choose Checksum.
7. Click Receive. The Receive Status window appears, showing the number of errors encountered during the operation. Expect to get a couple of errors, but if you seem to be encountering an awful lot of them (especially if you get them all right away) it may indicate a problem with the line. If you want to stop receiving the file, click Cancel in the Receive Status window (if the button becomes disabled (grey), then the file transfer can't be interrupted at this point).
SHOWING LINE STATUS

Naturally, any sort of connection between two computers is not going to be perfect—transmission errors are bound to occur. The Show Line Status feature of GeoComm allows you to monitor those errors and decide if what you’re sending is making it to the other computer, and vice versa. Usually it’s all right for a few line errors (like 10) to occur. You should start to worry when you see hundreds of errors (and hang up the phone and try again if you see thousands).

To show line status...
Choose Show Line Status from the Options menu. The Show Line Status window appears. This window monitors errors on the serial line, updating its display each time a read, write, frame, or parity error is encountered.

To reset line status counters...
Click Reset Counters in the Show Line Status window. The four error counters reset to zero.

USING SCRIPTS

Through the use of GeoComm scripts, you can automate many aspects of your communications tasks. For example, scripts are great for automatically logging on to an information service. GeoComm comes with several sample scripts that are ready to use. Use these, or create your own using GeoComm’s scripting language.

To run a script...
1 Choose Scripts from the Dial menu. The Scripts dialog box appears.
2 Locate and select the script you would like to run.
3 Click Run. The Script Display window appears, showing the progress of the script. You can stop a script at any time by clicking Stop in the Script Display window.

To create a script...
1 Use the Notepad desk tool or any other DOS text file editor to create a file containing your script. For a description of scripting commands, see “The Scripting Language,” later in this chapter.
2 Save the file with a name that ends with .MAC. “MYSKRIPT.MAC,” for example.
3 Place this script file in the GEOWORKS\GEOCOMM directory. Once it’s there, you can run the new script from the Scripts dialog box.
THE SCRIPTING LANGUAGE

Scripts resemble simple programs—and in fact you can use them to “program” GeoComm to perform common tasks for you, such as logging on to an information service.

In GeoComm’s scripting language, you must enter all the commands in upper case.

In the descriptions that follow, words enclosed in angle brackets (“<>”) are words that you replace with your own (minus the brackets).

:<label>

Any line beginning with a colon is treated as a label (although the colon isn’t actually part of the label). Use the GOTO command to jump to a label line. Labels can be in upper or lower case, but you must be consistent—if you have a label defined as “:GoHere”, you must refer to it exactly the same way in GOTO statements (“GOTO GoHere”). Here’s a sample label line:

:BranchToMe

:ABORT

GeoComm will GOTO this special label if the user clicks Stop in the Script Display window. The word “ABORT” must be all uppercase. If there’s no label, the script simply stops.

:BELL

This command makes a beep sound to alert the user.

:CLEAR

This command clears the Script Display window. For Example:

:COMM <baud-databits-parity-stop-bits-duplex>

This command sets the communication settings. For more detailed information, refer to “Setting Parameters” earlier in this chapter.

With the COMM command you have these settings available to you:

- **baud**: 300, 1200, 2400, 4800, 9600, 19200
- **data bits**: 5, 6, 7, 8
- **parity**: N, O, E, M, S
- **stop bits**: 1, 1.5, 2
- **duplex**: HALF, FULL

For example, if you’re using a 2400 baud line with eight data bits, no parity, and one stop bit, you would put this command in your script (put dashes between settings):

```
COMM 2400-8-N-1-FULL
```

:DIAL <number>

This dials the number given using tone or pulse dialing (see the TONE and PULSE commands later in this section).

To make your script dial a 9 to connect you to an outside line, and then dial 555-1212, you would put the following command in your script:

```
DIAL "9,555-1212"
```

:END

This stops the script, returning control to the user (but doesn’t jump to the :ABORT label).

:GOTO <label>

This causes GeoComm to jump to the line starting with “:<label>”. Be sure to leave off the starting colon.

:GOTO BranchToMe

:MATCH <text> GOTO <label>

The MATCH and PROMPT commands work together to make GeoComm perform some action based on text received from the other computer.

First, the MATCH command makes GeoComm look for <text> in the text that is transmitted by the other com-
puter. You can specify many MATCH commands but after them all, you must include a PROMPT command.

The text for the MATCH commands must be entered in quotes (".

Use the PROMPT command to make sure GeoComm doesn't wait too long for text from the other computer. The PROMPT command causes GeoComm to wait a certain amount of time for the remote computer to satisfy one of MATCH commands. If a match is found within the specified time, GeoComm jumps to the given label. On the other hand, if no match is found in time, GeoComm "falls through" and runs the command following the PROMPT command. The time in the PROMPT command is given in sixtieths of a second. For example, to make GeoComm wait for up to sixty seconds (3600 sixtieths of a second) while waiting for the other computer to either ask for a password or say that no login is possible, you could put the following lines in your script:

```
MATCH "Password?" GOTO DoPass
MATCH "System down" GOTO Down
PROMPT 3600
PRINT "No response"
```

**PAUSE <number>**

Causes GeoComm to pause for a certain amount of time before continuing with the script. The <number> must be in units of sixtieths of a second. If you omit the number, GeoComm pauses for one second. For example, to make GeoComm pause for one minute (60 seconds), you would use this command:

```
PAUSE 3600
```

**PORT <port>**

Makes GeoComm use the given COM port to communicate with the other computer. If your modem is connected to COM port 2, for example, you would use this command:

```
PORT 2
```

**PRINT <text>**

This command displays the <text> in the Script Display window. The text is not sent to the other computer. If you want the next thing you print in the Script Display window to start on the next line, you should end the line with ",CR" (for carriage return). For example, to make your script show the message "Sending password..." when it transmits a password, you would put the following command in your script:

```
PRINT "Sending Password...", CR, CR
```

**TONE**

**PULSE**

These commands cause GeoComm to use tone or pulse dialing when it dials a phone number. Otherwise, GeoComm uses what you've set in your Modem settings:

```
PULSE
```

**SEND <text>**

This command sends the <text> to the remote system. You can add a "CR" to the end if you want a carriage return sent after the text. For example, to send the word "password" followed by a (Return) to the other computer, you would put the following line in the script:

```
SEND "password", CR
```

**TERM <terminal type>**

This command makes GeoComm emulate a certain type of terminal. The <terminal type> must be one of these: TTY, VT52, VT100, Wyse50, ANSI, IBM3101, TVI950. For example, to make GeoComm emulate a standard TTY terminal, you would put this command in your script:

```
TERM TTY
```
GeoDex combines a card file with a phone auto-dialer. It's ideal for keeping track of friends, relatives, and business contacts. Browsing, listing, and free-form search capabilities make finding a name, address, or phone number quick and easy. GeoDex can also print lists of names and phone numbers, or mailing labels if you want. And for those with modems, GeoDex will dial your phone for you.
THE GEODEX WINDOW

GeoDex, on screen, resembles an office card file, and like an office card file you add names, addresses, and phone numbers directly to the cards—one card for each person. Once you’ve filled in your cards, you can view each card individually, or look at all the names in the Browse View.

Move through your cards one at a time with the Next and Previous buttons, or click one of the letter tabs to jump right to the names that start with that letter. Click the dial button and GeoDex automatically dials the phone number that appears on the current address card (provided you have a modem, of course).

ADDING CARDS

You add names and other bits of information to your GeoDex address book by adding cards, just like you would in a real card file—you put the information right on the card.

To add a card...

1. Click New. A blank card appears.
2. In the index field, type the person’s last name, then the first name, separated by a comma—Murtnik, John for example. The cards are sorted by the index field. By entering something other than names in the index field, you can order the cards differently. For example, you can use area codes or zip codes as indexes.
3. When you’re satisfied with the name as it is, press Return. The name is automatically copied down to the address field, but now with the first name first and the last name last. Press Return again to move to the next line.
4. Type the address, pressing Return at the end of each line. You may enter the address in any format you wish. You may also make addresses as many lines as you like; the address area automatically scrolls if you need more room.
5. When you’re finished typing the address, press Tab. The text cursor moves into the telephone number area. Click the two arrow buttons to select the type of telephone number—home, business, fax, or car—or create your own type. To do so, click the down arrow.
until you come to a blank phone type. Click in the type field and enter your own.

6 You may enter more than one telephone number. Just click the arrows again to select another type of number.

Here are some guidelines for entering phone numbers:

• Omit the area code for local numbers.
• For long distance calls, include the 1 and the area code. For example: 1-415-555-1212.
• If the number needs a special dialing sequence—to access a long distance service, for instance—be sure to enter this sequence before the regular number. For example: 10288-1-202-555-1212.
• Place a comma anywhere in the number where you want a brief pause in the dialing sequence. This is actually a modem feature; not all modems support it and different models delay for different amounts of time. Check your modem owner's manual for more information about this feature.

• If there is a special number—such as an access code for an outside line—that you always dial before each number, you can enter it in front of every number. For instance, if you always dial a 9 before dialing the phone number, you could type it as part of the number, like this: 9,555-1212.

Here the access code is separated from the number by a comma. This not only makes the number more readable, but also pauses the dialing briefly to give your phone system time to respond to the access code. You could leave both the access code and the comma off of the phone number and instead enter them in the Prefix box on the Dialing Options window. This is the best choice if you must dial the access code before all your phone numbers. (It's also much easier to change later, since you don't need to change each number.)
• To make the phone numbers easier to read, separate the parts of the number with dashes ("-") or spaces. You can also use parentheses. For example: 1 (415) 555-1212. These extra characters will not affect dialing.

FLIPPING THROUGH CARDS

You flip through cards in the GeoDex address book in much the same way that you flip through cards in an office card file. The cards in GeoDex are ordered alphabetically by their indexes (the top field on the card).

To flip through cards...

Click the Next arrow to flip to the following card or click the Previous arrow to flip to the preceding card. On the keyboard, press [PgUp] to flip to the following card, and press [PgDn] to flip to the previous card. Flipping past the last card takes you to the first, and vice-versa.

To flip directly to a letter...

In Card View, click the index tab with the letter you wish to see. The first card stored under that letter appears. If there are no cards stored under that letter, GeoDex shows a blank card. If you double-click an index tab, GeoDex switches to the Both View before flipping to that letter.
MAKING CHANGES

Changing a card is just a matter of flipping to the card and editing the text. You can also delete a card completely. In either operation, if you change your mind, GeoDex comes with an Undo feature that restores the card to its original form.

To change the information on a card...

1. Flip to the card you wish to change.
2. Change the name and address the way you would change any text—select it with the mouse and replace it with the new text.
3. Change the phone number the same way you normally change text, by selecting the number and retyping it. (You may need to click the phone number arrows to bring up the number you want to change.)

To undo a change...

Choose Undo from the Edit menu. The card reverts back to its original form.

To delete a card...

1. Flip to the card you wish to delete.
2. Choose Delete from the Edit menu. The card is removed from the address book.

To undo a deletion...

Choose Undo from the Edit menu. The card is restored to the address book.

DIALING

For GeoDex to dial your telephone, you must have a Hayes compatible modem on the same line as your phone (see your modem’s documentation) and you also need to use the Preference Desk Tool to set your modem’s parameters (see “Preferences” in this guide).

There are two ways to dial your telephone using GeoDex. The first is to find the person’s card, then click the Dial button on the card. However, if you frequently dial certain numbers, you may prefer using GeoDex’s Quick Dial command. With this method, you don’t have to actually find the person’s card—just click the Quick Dial button. GeoDex then gives you a list of the most frequently dialed numbers and a list of the most recently dialed numbers. Pick a number from one of the lists and click it. GeoDex automatically dials the number.

Before you dial a number from within GeoDex, make sure that your telephone is not off the hook—otherwise your modem may not be able to dial the number correctly.

To dial a number on the current card...

1. Make sure that your telephone is properly hung up.
2. Click the small arrows to scroll to the appropriate phone number.
3. Click Dial. The Dialing dialog box appears, telling you that GeoDex is starting to dial the phone number. If
your modem has a built-in speaker, you'll hear the dial-tone, the number being dialed, and the ringing signal.

4 As soon as the modem finishes dialing the number, pick up the telephone handset and click Talk in the dialog box. This resets the modem before it can give its deafening connect tone. If you don't click Talk quickly enough, the person answering will not be able to hear you speaking, but he will hear your modem.

To Quick Dial a number...
1 Make sure that your telephone is properly hung up.
2 Click the Quick Dial button.
3 A dialog box appears with two sets of numbers, those most often dialed and those most recently dialed. Click the button showing the name and number you wish to dial. The Dialing dialog box appears, and you hear the modem dial the number.
4 As soon as the modem finishes dialing the number, pick up the telephone handset and click Talk in the dialog box. This resets the modem before it can give its loud connect tone.

The two speed-dial lists are continually updated. For example, as you click on a number in the Frequently Called list, the number may move up the list because it is gradually becoming the most frequently called number. It also moves to the top of the Recently Called list, since it is, by definition, the last number called.

SETTING THE DIALING OPTIONS GeoDex can automatically add special numbers to the front of every number dialed. You enter these special numbers in the Dialing Options dialog box.

Prefix If your phone system requires that you prefix all your phone numbers with a special access code, you can have GeoDex automatically dial this prefix for you. For example, assume that your phone system requires that you dial 9 before every phone number, and that you've entered “9,”. If the address card shows 555-1212 as the number, GeoDex actually dials 9,555-1212.
Area Code GeoDex can turn every phone number it dials into a long-distance number, which is handy if take your computer outside of the local area code but still want to dial the local numbers you have on file. For example, suppose you live in the 415 area code and take your computer with you on long trips. If you want to dial all your local numbers but don't want to change every number to have an area code, enter “1-415-” (you should enter the initial 1 as well as the area code) in the Dialing Options dialog box. If the address card shows 555-1212 as the number, GeoDex dials 1-415-555-1212.

Note that GeoDex enters this area code before every number it dials, so turn the option off if you're dialing numbers that already contain an area code.

The Area Code field accepts long-distance codes up to ten characters long, allowing you to use it for international calls.

To set a dialing option...
1. Choose Dialing Options from the Options menu. The Dialing Options dialog box appears.
2. Turn the option on by clicking the check box next to the option.
3. In the box, enter the numbers GeoDex should dial.
4. Close the Dialing Options dialog box by double-clicking the Control button.

To temporarily turn off a dialing option...
Click in the check box to turn the option off. For example, to stop GeoDex from placing a prefix in front of every number, click (to turn off) the check box next to Prefix.

BROWSING

You can view your address book as a list of names, instead of as a collection of cards. This list is called the Browse View, and it shows only names and phone numbers.

To switch between the Card View and the Browse View...
If you're in the Card View, choose Browse View from the View menu. If you're in the Browse View, choose Card View.
To see a person's phone number...
1. Scroll the browse list until you find the person's name.
2. Select the name by clicking it. A phone number appears in the phone number box.
3. Click the up and down arrows to see the different numbers.

To dial a phone number...
Click the Dial button.

SEARCHING

With GeoDex's search feature, you tell GeoDex what text you want to find, and GeoDex finds cards containing that text for you. You can have GeoDex search for part of a word, a whole word, or many words. Whatever you search for, GeoDex looks for the text in all the parts of the card—in the index field, name, address, or the phone number areas. This means that you could search for “Mu,” and GeoDex would find names like Murtnik, Mulling, and Munster, and also people who lived on Mulberry Avenue or in Mudville.

If this is too broad a search, you can limit the search to the index fields. Because these fields normally contain just the person’s name, this is effectively a name-only search. With this type of search, though, GeoDex looks only for precise matches. If you enter “murtnik” in the Search For field, GeoDex won't consider cards containing “Murtnik” to match—it's looking for a “murtnik" beginning with a small “m.”

To search for a particular card...
1. Switch to the Both view by choosing Both from the View menu.
2. In the Search For field, type the text you wish to find.
3. If you wish to limit your search to Index field only, turn on the Confine Search to Index option.
4. Click Lookup. The first card containing the text is shown, and the Lookup button changes to read Find Next.
5. Click Find Next to find the next card that also contains the text.

To clear the search criteria...
Click the Clear button. The Search For field clears and the Confine Search to Index option turns off.

A search starts in the Both view. Type the text you want to find into the Search For area and click Lookup. Not the right card? Click Find Next (which has replaced the Lookup button).
**PRINTING**

GeoDex gives you three different ways to print all the cards on file. There's no way to print
Print All prints the names, addresses, and the phone numbers from all the cards.
Print Phones prints two columns of names and phone numbers.
Print Labels prints names and addresses in a format suitable for mailing labels.
The Label Size option lists the different sizes that you can print.

![Printer Options](image)

**LINKING TO GEOPLANNER**

GeoDex can search the GeoPlanner calendar for scheduled events containing a particular name or bit of text. If, for example, you were looking at the card for John Murtnik, and you wanted to find the time of your next meeting with him, GeoDex could scan the GeoPlanner calendar for events containing the name “John Murtnik.”

GeoDex expects the text for which you're searching to match the text in the GeoPlanner calendar exactly. If you search for “John Murtnik,” you won't get events containing the name “john murtnik.” For this reason, you should be consistent in the way that you enter names into both GeoDex and GeoPlanner (or omit the first letter from the search criteria).

To find a calendar item for the person on the current card...
1. Make sure that GeoPlanner is started.
2. Select the text. This text could be the person's name, part of the address, or just some odd bit of text.
3. Click the GeoPlanner button. The GeoPlanner window comes up, and the first event containing the selected text is shown in the Event window. If you want to find the next event also containing the name, click Find Next in the Search dialog box.
4. Click Cancel in the Search dialog box when you're done searching.
5. When you finish looking at the calendar, return to GeoDex by clicking anywhere inside the GeoDex window, or by choosing GeoDex from the Express menu.

As an example, suppose you're looking at John Murtnik's card and you want to find your next scheduled meeting with him. Select the last name, "Murtnik," and click the GeoPlanner button. The GeoPlanner window comes up, and your next meeting with "Murtnik" is highlighted.

![GeoDex - First Address Book](image)

When you want to search for a name in GeoPlanner, simply select the text you want to find (Q) and click the GeoPlanner button (Q).
GeoDraw lets you draw full-color charts, graphs, and other pictures that you make out of regular shapes—that is, squares, circles, ovals, polygons, even text. Rotate, group, stretch, and color each element. And while GeoDraw isn’t the best choice for painting things like the Mona Lisa (an actual painting program is best for that), you can import a picture of the Mona Lisa created with a painting program—or any clip art, for that matter. And with GeoWorks Pro’s printing power, your drawing prints exactly as it appears on the screen (and in color, too, if you have a PostScript-compatible color printer).
WHAT YOU MUST ALREADY KNOW

Certain tasks you perform in GeoDraw are common to all GeoWorks applications. This is the main reason you can go from one GeoWorks application to another and feel immediately comfortable. Here are some of these tasks. If you are not familiar with them already, go to the “Basic Tools” chapter and read about them there.

- Opening and closing a document
- Entering and editing text
- Formatting text
- Pasting text and graphics from the clipboard
- Saving a document
- Printing
- Correcting the aspect ratio
- Working with multiple documents

THE GEODRAW WINDOW

The GeoDraw window is your electronic easel. It includes a drawing area and a tool box with tools for drawing, moving, and reshaping objects. The dotted margin lines around the edge of the drawing area indicate the printable area of the page (for most printers). If a part of your drawing falls outside of this line, it’ll more than likely be chopped off when you print.

MOVING AND CLOSING THE TOOL BOX You can move or hide the tool box when you want an unobscured view of your drawing. The tool box is a window like any other window in GeoWorks Pro, and you move and close it the same way (see the “Basic Skills and Tools” chapter). To reopen the tool box, choose Show Tool Box from the Options menu. The tool box reappears exactly where it was positioned when you closed it.
ZOOMING IN AND OUT The View menu lets you change the magnification of the page within the window. It does not affect the window itself. As you create your image, experiment by choosing different magnification levels from the View menu to find the one that’s appropriate for what you’re doing. For example, when you want to precisely align two objects, it’s easier if you magnify the view. When you want an overview of the entire layout of the image, a reduced view is better. To return a document to its normal size, choose Actual Size from the View menu.

SETTING THE DOCUMENT SIZE

The size of a new document is automatically set at 8 1/2 x 11 inches, the size of a regular piece of paper. You can use the Page Setup command to change the page size and orientation, which changes the size and shape of the drawing area in the GeoDraw window.

To set the page size and orientation...

2. Click the radio button to change the page orientation. The Portrait setting orients the page vertically; the Landscape setting orients the page horizontally.
3. Choose a Page Size from the list, or adjust the Width and Height to make a custom-sized page.
4. Click OK to apply the settings and close the dialog box.

CREATING OBJECTS

In GeoDraw, an image is composed of one or more objects. An object is simply a piece of text, a shape (such as a rectangle or a polygon), or imported artwork (like clip art or a Quattro Pro chart). To make all but the most basic pictures, you combine a number of objects. Each object can be selected, edited, and manipulated separately from other objects in the picture, although you can fuse objects together so they behave as one (see the section, “Fusing and Defusing Objects,” in this chapter.)

You create objects using the text and drawing tools in the tool box. Two additional tools—the Arrow Pointer and Rotate Pointer—are used for selecting and manipulating objects after they’re drawn. As you draw, don’t worry if an object is not exactly the right shape or a little out of position. You can easily move and reshape it—or even delete it and try again. You can also flip an object (even a text object!) or rotate it to any angle you want. These techniques are described in “Moving and Reshaping Objects,” later in this chapter.

When you create an object, it appears in the currently selected color, pattern, and style. You can change any
of these properties after the object is created. You can also edit text and change its font, size, and style.

After you create an object, four handles appear around the object and one handle, called the move handle, appears in its center. Use the handles to drag, rotate, and reshape the object (see “Moving and Reshaping Objects” later in this chapter).

ABOUT OVERLAPPING OBJECTS If you draw one object on top of another, the object on top may hide part or all of the object underneath. Often this is exactly the effect that you want. The objects are said to be stacked when they overlap like this. You can move an object towards the top or bottom of a stack by using the Arrange menu commands. This is covered in “Arranging Objects Within a Stack,” later in the chapter.

SELECTING A TOOL The Arrow Pointer tool is automatically selected when you first enter GeoDraw. You use it to select, move, and resize objects. When you want to create and manipulate objects, first select the appropriate tool from the tool box by clicking on it (the selected tool highlights).

- If you select one of the drawing tools, the pointer changes to crosshairs when you move it over the drawing area. The center of the crosshairs shows where the shape will begin as you draw.
- If you select the Text tool, the pointer changes to an I-beam when you move it over the drawing area. The I-beam shows where the text cursor will appear when you click the mouse button.
- If you select the Rotate Pointer, the pointer shape changes to a curved pointer. The Rotate Pointer works like the Arrow Pointer, except that you can also use it to rotate objects (though not stretch them).

A tool remains selected after you have finished the object, so that you’re ready if you want to make another one.

DRAWING LINES The tool box has two tools for drawing lines. With the Line tool, you can draw a single continuous line in any direction. With the Connected Line tool, you can draw any number of connected lines to create a simple geometric outline or even, with a bit of patience, a smoother outline that resembles a freehand drawing. The technique for the latter is the same as for the former—the line segments in the smooth outline are just very small. The smaller, the smoother.

When you draw a line, it appears with a standard color, pattern, width, and style (solid or dashed). You can change any of these in the Line Properties dialog box described in “Changing Colors, Patterns, and Lines” in this chapter.

To draw a line...

1. Select the Line tool in the tool box.
2. Position the center of the crosshairs where you want the line to begin.
3. Hold down the mouse button and drag until the crosshairs are centered over the point where you want the line to end. Then release the mouse button. As you drag, a dotted line...
follows the crosshairs. When you release the mouse button, the line is drawn and its handles appear.

**To draw connected lines...**

1. Select the Connected Line tool in the tool box.
2. Position the center of the crosshairs where you want the line to begin, and click to anchor this point.
3. Move the crosshairs to where you want the first segment of the connected line to end (you don't have to hold down the mouse button with this tool). Then click again to anchor the segment.
4. Continue positioning the crosshairs and clicking to create as many segments as you want. When you've drawn as many segments as you want, double-click to finish the connected line, or click on the Connected Line tool. You can also press the Esc key (or the right mouse button) to end the last line.

**DRAWING CIRCLES** The Circle tool draws circles and ovals that initially have the standard fill and outline (which you can change with the Area Properties dialog box described in “Changing Colors, Patterns, and Lines” in this chapter).

**To draw a circle...**

1. Select the Circle tool in the tool box.
2. Position the crosshairs where you want the circle to begin.
3. Hold down the mouse button and drag diagonally in any direction until the circle (or oval) is the size you want. Release the mouse button.

As you drag, a dotted outline indicates the circle's size. You can adjust the size until you release the mouse button. The dotted outline appears as either a circle or a rectangle, depending on whether you choose the Drag as Rectangle or the Drag as Outline option from the Options menu. (For more information, see “Making GeoDraw Work Faster” later in this chapter.)

**DRAWING RECTANGLES** The Rectangle tool draws filled rectangles and squares. A rectangle or square initially comes with the standard fill and outline, but you can change this with the Area Properties dialog box (described in “Changing Colors, Patterns, and Lines” later in this chapter).
To draw a rectangle...
1. Select the Rectangle tool in the tool box.
2. Position the crosshairs where you want the rectangle to begin.
3. Hold down the mouse button and drag in any direction until the rectangle (or square) is the size you want. (As you drag, a dotted outline indicates the rectangle’s size.) Release the mouse button.

DRAWING POLYGONS The Polygon tool allows you to create objects with irregular shapes and three or more sides. With this tool, you draw a series of connected line segments and let GeoDraw close them into a solid shape. The shape is automatically filled with a solid pattern, which you can change with the Area Properties dialog box (described in the “Changing Colors, Patterns, and Styles” section in this chapter.)

To draw a polygon...
1. Select the Polygon tool in the tool box.
2. Position the crosshairs where you want the first line of the polygon to begin, and click to anchor this point.
3. Move the crosshairs to where you want this first segment of the polygon line to end. Then click again to anchor the segment.
4. Continue positioning the crosshairs and clicking to create as many segments as you want. At the end of the next-to-last segment, double-click to finish the polygon. GeoDraw connects this last point to the starting point to complete the shape. The polygon is then filled in and its handles appear.

You can also finish a polygon by pressing the [Esc] key or the right mouse button (or click the Polygon tool again).

TYING TEXT The Text tool lets you create a simple caption or fill the page with many paragraphs of text. In GeoDraw, a block of text acts like any object. It can be moved, reshaped, rotated, and flipped, which lets you create special effects. For example, you can stretch and skew a text block by fusing it with itself—turning it into a “shape”—and then dragging its handles. See “Fusing and Defusing” later in this chapter.

Text appears in the currently selected font, size, style, and justification. You can change these attributes and even add color and halftones to text as described
in “Changing Colors, Patterns, and Styles” in this chapter. Text is fully editable and can be cut, copied, and pasted in the normal manner.

**To type text...**

1. Select the Text tool in the tool box. The pointer changes to an I-beam.
2. Position the I-beam where you want the first character to begin.
3. Define the width of the block of text by dragging the I-beam to the right, as you might drag the Rectangle tool.
4. Release the mouse and begin typing. As you type, the text wraps within the text object, which automatically expands downward to accommodate the new lines. You can create a text object with a standard three-inch width by just clicking.

When you finish typing, the Text tool remains selected. You can create additional text objects or select another tool.

**To create a text box, select the Text tool and drag a box...**

Then, type.

**Once upon a**

As your text reaches the right edge of the text box, the box grows downward to accommodate another line.

**Once upon a time, there was a little line of text that sat inside a little box**

**SELECTING OBJECTS**

After you create an object, you can alter it in many ways. But before you change an object, you must select it using either the Arrow pointer or Rotation pointer tools. You select objects in GeoDraw the same way you select icons in the File Cabinet or GeoManager, by clicking them with the mouse. If you select more than one object and make a change, the change applies to all the selected objects.

**To select an object by clicking...**

1. Select the Arrow pointer or the Rotation pointer.
2. Position the pointer over the object. Any part will do (it doesn’t need to be over the center), as long as the part isn’t overlapped by another object.
3. Click.

**To select objects by dragging...**

1. Select the Arrow pointer or the Rotation pointer.
2. Visualize a box surrounding the group of objects you want to select. Then position the pointer at the “corner” of this imaginary box.
3. Hold down the mouse button and drag diagonally until the dotted “rubber band” rectangle surrounds all the objects you want to select. Release the mouse button. As you select an object, its handles appear. If you missed an object, try again.

**Ovals &Squares**
To add objects to a selection...

Hold down [Ctrl] as you select additional objects. You can also deselect objects in a selected group by holding down [Ctrl] and clicking the selected objects. Other objects in the group remain selected.

To select every object in the document...

Choose Select All from the Edit menu. Every object is instantly selected.

SELECTING CHARACTERS WITHIN A TEXT OBJECT

When you want to edit or modify selected characters within a text object, use the Text tool to select the characters you want to change. The selection appears highlighted. (See the "Basic Tools and Skills" chapter to read more about selecting text.)

To move or reshape a text object or make the same change to all its characters, select the text as an object—that is, use the Arrow or Rotation pointer tools. For example, you would use this technique when you want to change all the characters in a block to the same font.

MOVING OBJECTS

In GeoDraw, you can move objects by dragging them using the right mouse button—the same way you move files in GeoManager. You can also use the left mouse button to move a selected object if you drag the object's "move" handle (the center handle). To speed up moving objects, select the Drag as Outline option on the Options menu. This option is discussed in "Making GeoDraw Work Faster" later in this chapter.

To drag one or more objects using the left mouse button...

1. Select the objects you want to drag.
2. Position the pointer over the center "move" handle of one of the selected objects.
3. Press the left mouse button and drag the object—or objects—to the new position. Release the mouse button.

To drag one or more objects using the right mouse button...

1. Position the pointer on the object (or on any one of the objects if multiple objects are selected). The pointer need not be over the object's center handle.
2. Press the right mouse button and drag the object—or objects—to the new position. Release the mouse button.
**NUDGING OBJECTS**  You can precisely position an object by moving it one pixel at a time with the Nudge command on the Modify menu. Pixels are the small screen dots that form the character image.

**To move an object slightly by nudging...**
1. Select one or more objects.
2. Choose Nudge from the Modify menu. The Nudge cascade menu appears.
3. Choose the direction in which you want to nudge the selection. After the object moves, the Nudge menu disappears—so, if you plan to do more than one nudge, you should pin the menu before choosing one of the directions.

**ROTATING OBJECTS**

The Rotate 45° Right and Rotate 45° Left commands on the Modify menu let you rotate an object precisely 45° clockwise or counter-clockwise. On the other hand, the Rotation pointer lets you rotate an object freehand to any position. An object always rotates around its center point.

Keep in mind that text characters cannot be edited when the text object has been rotated. To edit text characters, first rotate the object back to its original orientation.

Also, if select several objects and rotate them, they won’t rotate as a single unit; that is, each piece will stay in the same place and rotate about its center point. If you want to rotate all the pieces as a single unit, fuse them first.

**To rotate objects 45°...**
1. Select one or more objects.
2. To rotate 45° clockwise, choose Rotate 45° Right from the Modify menu. To rotate 45° counter-clockwise, choose Rotate 45° Left from the Modify menu. Each object in the selection rotates 45° around its own center point.

**To rotate an object freehand...**
1. Select the Rotate pointer in the tool box.
2. Click the object you want to rotate. The object selects and its handles appear.
3. Position the Rotation pointer over one of the corner handles.
4. Hold down the mouse button and drag clockwise or counter-clockwise to rotate the object to the position you want it. As you drag, the outline shows how the object would appear if you released the mouse button.
5. Release the mouse button. The object appears in its rotated position.
FLIPPING OBJECTS

You can flip an object on its horizontal or vertical axis using the Flip Horizontal and Flip Vertical commands on the Modify menu. Text characters cannot be edited when the text object has been flipped (to edit text characters, first flip the object back to its original orientation).

To flip an object on an axis...

1. Select one or more objects.
2. Choose Flip Horizontal from the Modify menu to flip the object along its horizontal axis. Or, to flip it along the vertical axis, choose Flip Vertical.

RESHAPING OBJECTS

You can change the size and shape of an object by stretching it vertically or horizontally—or both directions at the same time. Stretching an object distorts the object's shape.

Note: Reshaping a text object changes the line width, but does not affect the shape of the characters. The line width determines how words wrap within a text object.

To stretch an object...

1. Select the Arrow pointer.
2. Click the object you want to select. The object's handles appear.
3. To stretch an object vertically, position the pointer on one of the handles on the top or bottom edge and drag. To stretch an object horizontally, position the pointer on one of the handles on the left or right edge and drag. To stretch the object both vertically and horizontally, position the pointer on any corner handle and drag. Until you release the mouse button, you can continue adjusting the shape. An outline shows the size as you stretch. When you release the mouse button, the object appears in the stretched shape.

MAKING GEODRAW WORK FASTER

As you move or reshape an object, a dotted outline appears around it showing the size and location of the object as you manipulate it (it appears when you draw the object, also). This outline of the object's shape allows you to place it exactly where you want it—aligned with another object, for example. If you don't need to see the exact boundary of objects for precise placement, however, you can speed up moving and reshaping objects with the Drag as Rectangle option on the Options menu. With this option selected, a rectangle appears around a selected object no matter what its shape.
COPYING AND PASTING

Copying and pasting produces an exact replica of an object and makes it easy to create an image that contains many identical parts. After you paste, you can drag, rotate, or flip the object to position it where you want it. With text, you can also copy selected characters and paste them into another text object, or paste them in as a new object. Objects can be copied and pasted within one document or between different documents. (Copying and Pasting is discussed more thoroughly in the "Basic Tools and Skill" chapter.)

To insert text in an existing text object...
Choose the Text tool from the tool box. Position the I-beam at the point in the text object where you want to insert the text. Click to place the text cursor. Then choose Paste from the Edit menu.

To paste text as a new text object...
Choose the Pointer tool from the tool box (not the Text tool). Then choose Paste from the Edit menu. The pasted text appears in a new text object in the center of the screen. Or, select the Text tool and position the I-beam in an empty part of the screen. Click. This opens up a new, empty text object. Choose Paste from the Edit menu.

CUTTING AND DELETING

There are two ways to remove selected objects or text characters—cutting and deleting. Cutting removes the selection to the clipboard so that you can paste it in another document. Deleting permanently removes the selection without saving it to the clipboard. Do not delete an object you intend to paste somewhere else.

To cut or delete objects, select them and choose the Cut or Delete command from the Edit menu.

CHANGING COLORS, PATTERNS, AND STYLES

GeoDraw has a palette of 16 colors and 16 patterns that you can apply to lines, object outlines, and the area inside filled objects (rectangles, circles, and polygons). You can also apply color and halftones to text as described in "Changing Text Color and Halftone" later in this chapter. To work with colors you must have a color monitor, either EGA or VGA. To print a document in color you need a PostScript compatible color printer and the appropriate printer driver installed. If you are working with a color monitor and a black and white printer, colors will print out as different shades of gray.

You use three properties boxes for changing colors, patterns, and styles—an Area Properties box, a Line Properties box, and a Text Properties box. Open a properties box by choosing its command from the Modify menu. You can leave it open to make repeated changes to an object until you are happy with its appearance, or to change other objects. If the properties box is covering up an
object, move it around the screen by
dragging its title bar. Close a Properties
box by double-clicking on its Control
button. (In other words, property boxes
are little windows, and can be moved
and closed in the normal way.)

CHANGING LINE PROPERTIES The Line Proper-
ties box lets you change the color,
pattern, width and style of both lines
and object outlines (the outline of a
filled object is treated as a line and can
have a different color and pattern than
the object’s interior). If no object is
selected, the changes you make will
affect the next object you create.

To change an object’s line
properties...
1. Select the object (or objects). If you
do not select an object before you
change the line color or pattern settings,
the change will be applied to the next
object you draw.
2. Choose Line Properties from the
Modify menu to open the Line Proper-
ties box.
3. Click the different buttons to
change the settings. Each time you
click a setting, the selected objects
reflect the change.
   If you have a monochrome monitor,
your only color choices are black and
white.

FILLING AN OBJECT WITH A COLOR OR PATTERN The
Area Properties box lets you change the
color or pattern of the area within a
filled object. A filled object is any object
created with the Rectangle, Circle, or
Polygon tools. A closed shape created
with the Line or Connected Line tool
cannot be filled with a color or pattern.

You can set the area color or pattern
for existing objects (or for the next
object you draw) with settings in the
Area Properties dialog box. Patterns
can be either solid or see-through.
With a see-through pattern, the "holes"
in the pattern are actually clear and
allow you to see through to objects in
the background. In a solid pattern, the
"holes" are actually opaque, so that
you can’t see through the object.

To change the fill color or pattern...
1. Select the object (or objects). If you
do not select an object first, any changes
you make in the properties box apply to
the next object you draw.
2. Choose Area Properties from the
Modify menu to open the Area Proper-
ties box.
3. Click to select the Color or Pattern
you want to apply to the object (or
objects) you’ve selected. You can click
both a color and a pattern setting. Each
time you click a setting, the selected
objects reflect the change.

Objects can be filled with
solid color... ...or a see-through pattern.
CHANGING TEXT COLOR AND HALFTONE The Text Properties box lets you change text color and set a dark, medium, or light halftone for text. A halftone is a lighter shade of the color you have selected. GeoDraw creates the illusion of shades by turning off some of the pixels (the small dots that form the character image). For this reason, halftones look best on larger font sizes and boldface characters that have more pixels. You can change the color or halftone of text you’ve already typed (or the next text you type) by clicking the settings you want in the Text Properties box.

Each of the halftone settings is a percentage of the full concentration of the selected color:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Concentration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solid</td>
<td>100%</td>
</tr>
<tr>
<td>Dark</td>
<td>75%</td>
</tr>
<tr>
<td>Medium</td>
<td>50%</td>
</tr>
<tr>
<td>Light</td>
<td>25%</td>
</tr>
</tbody>
</table>

To apply text color or halftones...

1. Select the text you want to change. You can select specific characters or an entire text object. If you do not select text before you change color or halftone settings, the change will be applied to the next characters you type.

2. Choose Text Properties from the Modify menu (or the Text menu) to open the Text Properties box.

3. Click to select the Text Color you want. To change the Halftone setting, click the radio button for the setting you want. Each time you click a setting, the selected objects reflect the change. You can leave the Properties box open to try different settings until you get the effect you want or to change additional objects. Double-click the control button to close the Properties box.

Once upon a time, there was a little line of text that sat inside a little box.

EDITING TEXT

In GeoDraw, text is fully editable. You can copy, paste, or delete text using the same procedures you use to edit draw objects. For instructions on copying, pasting, and deleting, see the relevant sections earlier in this chapter.

In addition to the standard editing techniques, you can modify text by changing the text font, size, and style, as described in the “Basic Tools and Skills” chapter. You can also change justification, as described below.

CHANGING TEXT JUSTIFICATION The Justification command lets you set how the left and right edges of text are aligned with the borders of the text object. You can choose from four justification settings. Left Justification aligns the left text edges and leaves the right edges “ragged”—that is, uneven. Right Justification aligns the right text edges and leaves the left edges ragged. Center Justification centers text between the left and right borders of the text object. Full Justification spreads each line of text out so that both the left
and right text edges are aligned with the borders of the text object (except that last line of the paragraph, which is left justified).

You can change the justification setting for selected paragraphs within a text object, or for the entire text object.

To change text justification...
1. With the text tool, position the cursor in the paragraph, or select the paragraphs you want to change. To change all text in an object, use the pointer tool to select the object (or objects).
2. Choose Justification from the Text menu.
3. Choose the justification setting you want.

Left...
- Once upon a time, there was a little paragraph of text that got inside a little box. It could shift around inside this little box, back and forth.

Right...
- Once upon a time, there was a little paragraph of text that sat inside a little box. It could shift around inside this little box, back and forth.

Center...
- Once upon a time, there was a little paragraph of text that sat inside a little box. It could shift around inside this little box, back and forth.

And Full Justification.
- Once upon a time, there was a little paragraph of text that sat inside a little box. It could shift around inside this little box, back and forth.

ARRANGING OBJECTS WITHIN A STACK

Several overlapping objects are called a stack. Use the Arrange menu commands to move an object to the front or to the back of the stack to get the effect you want.

To bring an object to the front or send it to the back...
1. Select the object.
2. If you want to bring the object to the front, choose Bring to Front from the Arrange menu. To send it to the back, choose Send to Back from the Arrange menu.

To move an object one level at a time...
1. Select the object.
2. If you want to move the object back into the stack, choose Move Backward from the Arrange menu. The selected object moves one level towards the back of the stack.

   If, on the other hand, you want to bring the object forward, choose Move Forward from the Arrange menu. This moves the selected object up one level towards the front of the stack.
3. Repeat these commands again and again until the object is where you want it in the stack.

FUSING AND DEFUSING OBJECTS

Fusing objects makes them a single object—they are, in effect, fused into one. This feature is useful when you have created a drawing (a house, for instance) out of several separate shapes. By fusing them into one, you can copy, reshape, or resize the house as one
object. This is much easier than trying to work with each part of the house separately. The fuse feature also gives you a way to stretch and distort a block of text.

**To fuse objects...**

1. Select all the objects you want to fuse—it’s important that they *all* be selected at the same time. You can either drag a dotted selection rectangle around them, or hold down [Ctrl] and click them each individually.

2. Choose Fuse Objects from the Edit menu. The separate objects fuse into a single object, with a single set of handles.

3. You can drag one of the handles to resize the newly fused object. While the objects are fused, however, you can’t change the line, area, or text properties (you’ll have to defuse the object first).

**To defuse an object...**

1. Select the object. It must be an object that was previously fused.

2. Choose Defuse Object from the Edit menu. The object is split into its component objects. If you’ve sized or rotated the fused object, the component objects will be returned to their original size and orientation.

**To stretch text...**

1. Use the Arrow pointer tool—*not* the Text tool—to select the text block you wish to stretch.

2. Choose Fuse Objects from the Edit menu. The text is fused to itself, meaning that it becomes a “shape,” instead of a text block.

3. Grab any of the side handles and drag. The text distorts as you drag.

You cannot edit the text while it is fused (since it is no longer a text block). Defuse text when you want to edit it. The distorted text will return to being a text block in its original size and form.
IMPORTING IMAGES FROM DOS APPLICATIONS

You can import images stored in other file formats with the Import command on the File menu. An imported image is treated as a single object in GeoDraw and you resize, reshape, cut, copy, and paste it as you would any GeoDraw object. You can import several file formats, including one-bit TIFF, 16-color PCX, and EPS charts from Quattro Pro.

To import an image...

1. Choose Import from the File menu. The Import file selector dialog box shows the files and directories in the current directory.
2. Click TIFF, PCX, or Quattro Pro EPS to see a list of the files of that type contained in the current directory.
3. Select the file you want to import.
4. To preview the image before importing the file, click View. You can use the scroll bars to scroll the image in the dialog box.

5. When you are ready to import a file, click Import. Or, to close the Import dialog box without importing, click Cancel. When you click Import, the Import dialog box closes and the image appears in the document window. If the image is large, it may take several minutes for the image to be imported.
GeoManager lets you perform all your file and disk management tasks without having to remember a single cryptic DOS command. GeoManager shows files as icons (the "computerese" term for those small symbolic pictures that you see all over GeoWorks Pro). Instead of typing commands, you use these icons to open files and perform management tasks. Whenever you want to do something with a file (like opening, moving, or copying it) simply select the icon and choose a command from one of GeoManager's menus. Easy.
WHAT YOU MUST ALREADY KNOW

Certain tasks you perform in GeoManager are common to all GeoWorks applications. This is the main reason you can go from one GeoWorks Pro application to another and feel immediately comfortable. These common tasks are not discussed in chapters such as this, but they are described in the “Basic Tools and Skills” chapter. Here are some of these tasks. If you are not familiar with them already, go to the “Basic Tools” chapter and read about them there.

• Opening and closing a document
• Using windows
• Naming files and directories
• Entering and editing text
• Saving a document
• Using a file selector
• Selecting file and directory icons
• Directories and subdirectories

THE GEOMANAGER WINDOW

The GeoManager window tells you much about the directory you’re in and what it contains. Here are some of the items that give you that information:

**Information bar** The information bar displays:

- The directory pathname (see “Basic Tools and Skills” for more about pathnames).
- The number of files and directories currently appearing in the File Cabinet window.
- The amount of disk space, in bytes (characters), used by the files shown and the amount of free disk space.

**GeoWorks Pro file icons** Each type of GeoWorks Pro document has a unique icon. The different icons help you quickly spot particular types of files. The name of the files appear below the icons.

**DOS file icons** You rarely see DOS file icons in the same directory as GeoWorks Pro file icons. If the DOS file is a program or batch file, you can double-click...
the file icon to run it. (You don’t need to go back to the DOS Programs screen to run it.)

**Directory icons** Folder icons in the File Cabinet window represents directories on your disk drives. Because directories appear as pictures of little folders, the terms “directory” and “folder” are often used interchangeably (in much the same way as “document” and “file” are).

**Disk drive buttons** Every disk drive available on your computer is represented by a button on the bottom edge of the GeoManager window. A floppy disk button appears for each floppy disk drive attached to your computer and a hard disk button appears for each hard disk. Additional buttons appear if you have a RAM disk, ROM disk, or other type of disk device (such as a network device) attached to your computer.

**Launching a DOS Program or Batch File**

You can start a DOS program or batch file directly from GeoManager. The GeoManager window temporarily closes and the DOS program or batch file appears. When you quit the DOS program, or the batch file finishes, the GeoManager window reopens automatically. The window appears exactly as it looked before it closed.

**To start a DOS program or batch file...**

1. Open the directory that contains the DOS program or batch file you want to launch.
2. Double-click the file’s icon, or select the file and choose Open from the File menu.

**Opening Directories**

Directories appear as folder icons in GeoManager. To open a directory, double-click a folder or select the folder and choose Open from the File menu. The directory opens and its contents display in a window. (Its name is also added to the list of directories on the the Window menu.) The directory you are working with is called the current or active directory, and its name is selected on the Window menu. If the directory is already open, but not active, choose its name from the Window menu, or click on its window to make it active (more about overlapping windows in a moment).

**Opening the World and Document Directories**

GeoWorks Pro has two main directories: WORLD and DOCUMENT. The WORLD directory contains applications (programs you can run), and the DOCUMENT directory contains documents (data files created with applications).
To open the WORLD or DOCUMENT directory...
Click either the WORLD directory button or the DOCUMENT directory button at the bottom of the GeoManager window. The WORLD or DOCUMENT directory opens and its contents display in the window.

OPENING A PARENT DIRECTORY You can display successive parent directories by clicking the Parent Directory button on the directory window. A parent directory is a directory containing another directory. The current parent directory, then, is the one containing the files and folders that now appear in GeoManager. When you move up as far as the root directory, the Parent Directory button dims to indicate there are no higher directory levels to view.

To open the parent directory...
Click the Parent Directory button at the upper-left corner of the window. The parent directory appears, becoming the current directory.

OPENING A DIRECTORY ON ANOTHER DISK You can display directories on another disk by clicking the appropriate drive button.

To open a directory on another disk...
1 If the other disk is a floppy disk, insert the floppy in a floppy disk drive. 2 Click the Drive button for the floppy disk, hard disk, or device you want to view.

GeoManager displays the root directory of the disk, which is then the current directory. Use GeoManager in the normal manner to work with the files and directories on the disk.

CHOOSING FULL-SIZED AND OVERLAPPING WINDOWS
Initially, you view directories one at a time in the GeoManager window. Each directory you open fills the window, covering up any directory that previously appeared there. There is a way, however, to view many directories simultaneously as smaller, overlapping windows. You can then move and resize these windows to your liking (much as you can move and resize application windows in the Advanced Workspace). It's also easier to move files when you have overlapping windows. (See "Moving and Copying Files and Directories" later in this chapter.)

To view directories as overlapping windows...
Click the Overlapping button, or choose Overlapping from the Window menu.
To view directories as full-sized windows again...

Click the Full-Sized button or choose Full-Sized from the Window menu. Alternatively, click the Maximize button on any of the overlapping windows.

COMPRESSING THE DIRECTORY DISPLAY If you get tired of scrolling around directories with lots of files and directories in them, turn on the Compress Display option. This moves the file and directory icons closer together, so that more of them can fit in a window.

To turn the Compress Display option on or off...

Choose Compress Display from the View menu.

CREATING A NEW DIRECTORY

You can create a new directory folder in any open directory. The new directory folder is empty until you move or copy items into it.

To create a new directory...

1. Open the directory in which you want to place the new directory. If the directory is already open, make it active.
2. Choose Create Directory from the File menu. A dialog box appears asking you to name the new directory.
3. Type the name for the directory. Use standard DOS filename conventions—eight letters, with an optional three-letter extension. For instance, MYFOLDER.ONE.
4. Click Create. A new directory appears in the current directory.
**RENAME A FILE OR DIRECTORY**

The name that you give a directory or file is not necessarily permanent. You can change it at any time using the Rename button.

**To rename an item...**
1. Select the item (or items) you want to rename.
2. Choose Rename from the File menu. A dialog box appears.
3. Enter the new name in the box.
4. Click Rename to apply the new name. If a file with the same name already exists, a dialog box asks you to type a different name.

If you've selected several items, you get a separate dialog box for each item. Click Next to leave the name of the current item unchanged and go on to the next. Click Cancel to close the dialog box without renaming the remaining selected files.

**MOVING AND COPYING FILES AND DIRECTORIES**

The easiest way to move or copy a file or directory is to drag it to its destination (using the right mouse button). Dragging an item to a directory on the same disk moves the item to that directory, while dragging it to another disk copies the item. But you can always force a move operation by holding down the `Alt` key during the drag operation, or force a copy operation by holding down the `Ctrl` key. You can also copy and move by using the Copy and Move commands on the File menu.

The directory you copy or move items *from* is often called the *source directory*, and the directory you copy or move them *to* is called the *destination directory*. If the destination directory already contains an item with the same name, you're asked if you want to replace the existing item (unless you have turned off the Confirm Replace option in the Options menu). For more information about the confirmation options, see “Changing GeoManager Options,” later in this chapter.

When you move or copy more than one item, a dialog box appears showing you the progress of the operation. If you want to halt the move or copy operation, click Stop. The operation stops after finishing with the current file.

**To move or copy an item by dragging...**
1. Select the item or items you want to move or copy.
2. Position the pointer over one of the selected items and hold down the right mouse button. The pointer changes to indicate whether you are dragging a single item or several items.
Drag the pointer and position it over one of the following (according to where you want to move or copy the items):
- A folder icon in a directory window. The items are placed in that directory.
- Any area of a directory window, but not over a folder icon. The items are placed in the directory corresponding to the window.
- The Parent Directory button on a directory window. The items are moved to the parent directory, one level up in the directory hierarchy.
- Over one of the disk drive buttons at the bottom of the GeoManager window. The items are copied to the root directory of the disk currently in that drive.
- Release the right mouse button.

To move an item using the Move command...
1. Select the item (or items) you want to move.
2. Choose Move from the File menu. A file selector appears. Use it to find and open the destination directory.
3. Click Move to move the files into the directory.

To copy an item using the Copy command...
1. Select the item (or items) you want to copy.
2. Choose Copy from the File menu. A file selector appears. Use it to find the destination directory.
3. Click Copy to copy the files into the directory.

DUPLICATING A FILE OR DIRECTORY

You can make copies (exact in all but name) of both files and directories. For example, you may want to duplicate a document file before making extensive changes to it, in order to have a backup copy of the original.

To duplicate an item...
1. Select the item (or items) you want to duplicate.
2. Choose Duplicate from the File menu. A dialog box appears.
3. Type in a name for the duplicate—if you like—otherwise the copy is just

When you pick up a file or directory, you can drag it to several different places, like:
- The Parent Directory button—moves it to the parent directory (you don’t need to click the button.)
- Another Folder—moves it into the other folder
- Another Window—moves it to the directory represented by that window
- The Disk Drive buttons—copies it to the disk on which you drop the file
- The WORLD and DIRECTORY buttons—moves it to one of these GeoWorks Pro directories
- The Wastebasket—deletes it
named “Copy of (file or directory name).”

When you duplicate many items, you’re given a chance to change the name of each copy. Clicking Next skips the current item altogether. Clicking Cancel closes the dialog box without duplicating the remaining items.

1. Click Duplicate. A duplicate of the selected item (or items) appears in the same directory as the original.
2. If you’re duplicating more than one item, the name of the next item appears in the dialog box and the whole process repeats.

### Deleting a File or Directory

There are times when you need to make room on your hard disk (or floppy disks, for that matter) by deleting files or directories you no longer need. Deleting a file removes the file from your disk, so be careful to delete only those files you know you won’t need later. You cannot recover a deleted item using GeoWorks Pro.

**To delete an item by dragging it to the Wastebasket...**

1. Select the item (or items) you want to delete.
2. Position the pointer over the selected item (or one of the items, if several items are selected). Hold down the right mouse button and drag the item to the wastebasket.

   If the Confirm Delete option is turned on, a dialog box appears asking you to confirm each deletion. Click Yes to delete the item; click No to leave it untouched and move on to the next (if you’re deleting several). Click Cancel to close the dialog box without deleting the additional items.

### Changing DOS File Attributes

There are four DOS file attributes that limit the kinds of operations you can perform on a file or directory: Read-Only (R), Hidden (H), System (S), and Archive (A).

An item can have one or more file attributes. File attributes appear in the directory window when you select the Names and Details option on the View menu. The file attributes appear in the last column of the listing.

The most useful attribute, and the only one you may ever want to change, is the Read-Only attribute. When the Read-Only attribute is set, it adds a level of protection to the file that prevents the file from being changed or deleted easily. For example, if there are certain documents that you wanted to take extra pains to safeguard, setting the Read-Only attribute is a good way to
protect them. (The template documents that came with GeoWorks Pro have the Read-Only attribute set, which is why a dialog box appears when you open them explaining that you can't change the contents of the document.)

The Archive, Hidden, and System attributes are used by DOS and DOS utilities. They are not very useful to GeoWorks Pro applications. Refer to your DOS reference manual for more information on these attributes.

**To change file attributes...**
1. Select the item (or items) whose attributes you want to change.
2. Choose Attributes from the File menu. The Change Attributes dialog box appears. Click to select the attributes you want to assign. Click to deselect any already selected attributes to turn them off.
3. Click Change to apply the attributes you've selected. Click Next to skip the current item and go on to the next one (if you selected more than one item). Click Cancel to close the dialog box without making any further changes.

**GETTING INFORMATION ABOUT A FILE OR DIRECTORY**

Certain information about a file (or directory)—including its size, file attributes, and when you last worked on it—is available to you at a moment's notice. When you display information about a GeoWorks Pro application or document, you can also enter your own notes about the item. These notes are saved along with the item.

**To display information about an item...**
1. Select the item (or items) and choose Get Info from the File menu. The Get Info dialog box appears.
2. If the item is a GeoWorks Pro application or document and isn't Read-Only (the Read-Only attribute is not set) you can enter (and edit) text in the User Notes box. Notes are saved along with the file; use them to describe the file's contents.
3. Click OK to save the notes and display information about the next item. If you selected more than one, click Next to skip this item and see the next.
4. When you're finished, click Cancel to close the dialog box.
VIEWING FILES AND DIRECTORIES AS A LIST

You can choose to view the contents of a directory as an alphabetized word list rather than as icons. Of the three options for switching between icons and lists, the highlighted option is the one currently in effect for the current directory.

To change the current viewing option...

1. Open the directory you want to change.
2. Choose the option you want from the View menu. Your choices are:
   - **Names Only** Shows the contents of the directory as a list of very small icons with the name on the right (instead of below). This view is especially useful if you have a lot of files in a directory and want to see as many as possible without scrolling.

   ![Names Only View](image)

   **Names and Details** Also shows the contents of the directory as a list of small icons but with the name, size, modification date, and attributes to the right of the icons. Each file attribute is represented by a single letter: Read-Only (R), Hidden (H), System (S), and Archive (A). For more information about file attributes, see “Changing DOS File Attributes” earlier in this chapter.

   ![Names and Details View](image)

   The modification date for a directory is simply the date you created the directory.

   - **Icons** The standard option. Shows the contents of the directory as file or directory icons, with the name below the icon.

   ![Icons View](image)

ORDERING ITEMS Within any directory, you can change the sorting criteria used to display the files and subdirectories. Subdirectories always appear before files, though, no matter how you sort the contents of a directory.

To change how files are sorted...

1. Activate the directory you want to change (that is, make it the current directory).
2. Choose Sort By from the View menu. A cascade menu appears.
3. Choose the arrangement you want from the cascade menu. Your options are:
   - **Name** Arranges the contents of the current directory alphabetically by name.
   - **Date and Time** Arranges the contents of the current directory by the date and time the files were last modified, with the most recent first.
   - **Size** Arranges the contents of the current directory by size, beginning with the largest file.

   ![Ordering Items View](image)
USING THE DIRECTORY TREE

One of the best ways to see the directory structure of a disk is to view the organization as an upside down “directory tree.” It’s upside down because the root directory of the disk is at the top of the tree. Directories directly under the root directory form the main branches, their subdirectories branch off from there, and so on.

Using the Tree menu, you can see this structure on your computer screen.

You control how much of the directory tree is displayed by expanding or collapsing the branches (directories) of the tree. Expanding a directory displays its subdirectories; collapsing a directory hides them. A plus sign indicates that a directory can be expanded. A minus sign indicates that a directory is already expanded.

The Tree window does not show the files within a directory. You can, however, view a directory’s files by double-clicking the directory name. You can also perform all directory management tasks (such as creating, copying, or moving directories) from within the Tree window. You can click the directory name to select it, then choose the command you want from the File menu. Or just drag (with the right mouse button) a directory from the Tree window to move or copy it into another directory.

To open the Tree window...

To display the contents of the current drive, choose Show Tree Window from the Tree menu. The tree for the current drive appears.

To expand all directories in the tree...

Choose Expand All from the Tree menu. This shows every directory within every other directory on the current drive.

To expand the next directory level...

• Click the plus (+) sign next to the directory you want to expand. Or ...
• Click to select the name (do not click the plus or minus sign) of the directory you want to expand (do not click the plus or minus sign) and choose Expand One Level from the Tree menu.

To expand all directories within a branch...

1. Click to select the name of the directory you want to expand (do not click the plus or minus sign).
2. Choose Expand Branch from the Tree menu. This shows you every directory within every other directory inside of the selected one.
To collapse all directories within a branch...
• Click the minus sign next to the directory you want to collapse.
  Or ...
• Click the name of the directory you want to collapse (not the plus or minus sign) and choose Collapse Branch from the Tree menu.

To display the directory tree for another disk...
1 Choose Drive from the Tree menu. A cascade menu appears listing the drives connected to your computer.
2 Click the drive you want to display. The Tree window changes to show the contents of the selected drive.

To return to the regular GeoManager window...
• Choose Close from the Window menu. This closes down the Tree window and shows you one of the other open directories. (More specifically, it shows you the directory that is listed underneath the Directory Tree entry on the Window menu.)
• Choose the name of one of the open directories from the Window menu. This makes this directory the current one (effectively hiding the Tree window behind it), but leaves—no pun intended—the Tree window available should you want to return to it. (You’d return to it by selecting Directory Tree from the Window menu.)

SHOWING HIDDEN FILES
Files with their Hidden or System attribute set do not automatically appear in GeoManager. To see these files, and have them included in the file size count at the top of the window, you must first turn on the Show Hidden Files option on. When the Show Hidden Files option is turned off, these files disappear again.

To turn the Show Hidden Files option on or off...
Choose Show Hidden Files from the View menu. The first time you do this, it turns the option on. The second time, it turns the option off. And so on.

MANAGING DISKS
The Disk menu lets you perform the following disk management tasks:
• Copy a disk’s contents onto another disk
• Format a disk so that it can be used
• Rename a disk
• Rescan any drives needed to update the contents of the open directories

The disk name can be from 1 to 11 characters long, in uppercase letters (lowercase letters are converted to uppercase). You can use both numbers and letters in the name, as shown in the following example:
LETTERS 12

FORMATTING A FLOPPY DISK
An unformatted disk is like a library with no shelves—there’s nowhere to put the books. Before you can store anything on a disk, then, you must format it. When you format a
disk, you build the shelves (and even label them, metaphorically speaking) so the computer has an organized framework in which to store information.

To see if a disk has already been formatted, insert it into a floppy disk drive and click the appropriate floppy disk drive button. If a dialog box appears telling you that the disk is unreadable, you know the disk needs formatting.

To format a floppy disk...
1. Insert the floppy disk into one of the disk drives.
2. Choose Format Disk from the Disk menu.
3. Click the drive that contains the floppy disk.
4. Click the option for the disk capacity you want.
5. Click OK. A dialog box appears requesting a name for the disk. Type a name for the disk (1 to 11 characters long), and click Format. GeoManager formats the disk according to the options you specified. A message lets you know how the formatting is proceeding and when it is complete.

COPYING A FLOPPY DISK The Copy Disk command on the Disk menu lets you create an exact duplicate of a floppy disk. The original disk is called the source disk and the duplicate disk is called the destination disk. Because GeoManager makes an exact duplicate of the source disk, the destination disk must be the same size as the source disk. This means you cannot duplicate a 3.5 inch disk onto a 5.25 inch disk, or vice versa. Also note that, during a disk copy, GeoManager writes over all files that are on the destination disk. Be absolutely sure your destination disk contains nothing you want to keep.

To copy a floppy disk...
1. If you haven't done so already, label the source and destination disks so you don't inadvertently confuse them.
2. Choose Copy Disk from the Disk menu. A dialog box appears.
3. Click to select the source drive and the destination drive. If you have only one drive, drive A appears as both the source and destination drive. (You can do it with only one disk drive, though you'll have to constantly pop disks in and out of the floppy disk drive.)
4. Click Copy.
5. GeoManager tells you whenever you need to insert a new disk. Follow the instructions on the screen.

RENAMEING A DISK You can easily change the name of a floppy disk. You named the disk, remember, when you formatted it (see “Formatting a Floppy Disk,” earlier).

To rename a disk...
1. Choose Rename Disk from the Disk menu. A dialog box appears.
2. Click to select the drive that contains the disk you want to rename.
In the "To" area, type a new name for the disk.

Click Rename to rename the disk.

**RESCANNING** It's possible for a directory display to become out of date. This can happen in two different situations:
- You're working with a floppy disk, and you eject it from your floppy disk drive and have a friend add a file to it. When you stick it back in the drive, the GeoManager window doesn't show the new file.
- You're using a network drive (on, say, a Novell network) and somebody else adds or removes files from it. These changes don't appear in the GeoManager window.

In both these situations, GeoManager doesn't know that the contents of the disk in question have changed, so it doesn't update the window. Fortunately, it's easy to remedy the situation: All you need to do is rescan the drive.

**To rescan...**
Choose Rescan Drives from the Disk menu. GeoManager rereads the contents of all displayed disks (that is, disks whose directories appear in the Window menu), updating any directory windows if necessary.

**CLOSING DIRECTORIES**
A directory remains open until you specifically close it. If you open many directories, you should periodically close the ones you aren't using. This frees additional computer memory.

If you close the only open directory, the GeoManager window will then be empty and black. At this point you should click one of the drive buttons (or the WORLD and DOCUMENTS buttons) along the bottom of the window to open a new directory.

**To close the current directory...**
Choose Close from the Window menu. The window of the current directory closes. If you are viewing directories as overlapping windows, you could do this by simply double-clicking the Control button of the overlapping window you wish to close.

**To close all open directories...**
Choose Close All from the Window menu. All the directory windows close, leaving the GeoManager window black.

**CHANGING GEOMANAGER OPTIONS**
Here are some options you can turn on (or off) to customize GeoManager to your liking. Once you're satisfied with your settings, save them so that they will apply the next time you start GeoManager.

When options are turned on, they are selected in the menu. When a confirmation option is deselected (turned
off), no confirmation message appears when you perform the action.

Remember, when you delete or replace a file, you cannot undo the operation if you change your mind. We suggest you leave confirmation options on unless you're very experienced with the system. Most of them warn you of actions that cannot be undone.

Confirm Delete When on, this option displays a confirmation message before you delete a file.
Confirm Read-Only When on, this option displays a confirmation message before you delete a Read-Only file. For more information about Read-Only files, see “Changing DOS File Attributes,” earlier in this chapter. Otherwise, the Read-Only file is deleted without comment.
Confirm Replace When on, this displays a confirmation message before you copy or move a file to a directory that already contains another file with the same name. When this option is off, you risk unknowingly overwriting files in the destination directory.
Minimize on Run When on, this option causes GeoManager to shrink to an icon when you run another GeoWorks Pro application. With this option off, the GeoManager window remains open when you run another GeoWorks Pro application.
Ask Before Returning to PC/GEOS This only applies when you run a DOS program from GeoManager. When this is on, you have to press r when you exit from this DOS program before GeoWorks Pro will start up again. (At this point, you can alternatively choose to return to DOS, instead of starting GeoWorks Pro.)

To turn an option on or off...
Choose the option from the Options menu. If the option is currently on, choosing it turns it off. And vice versa.

To save the current options and make them permanent...
Choose Save Options from the Options menu.

EXITING GEOMANAGER

The Exit command closes GeoManager. Normally you never exit GeoManager, but if you are running several additional applications and notice that your system is running slowly, you can exit GeoManager to free up some memory on your computer.

To close GeoManager...
Choose Exit from the File menu. The GeoManager application closes.
If another GeoWorks Pro application is currently open, you see the open application when you close GeoManager.
If no other GeoWorks Pro applications are open, you are returned to the Welcome screen.

To restart GeoManager...
1 Choose Startup on the Express menu of any application. A cascade menu appears.
2 From the cascade menu, choose GeoManager. The GeoManager application restarts.
GeoPlanner gives you both a yearly calendar and an appointment book in one powerful application. View this year’s calendar and then switch to next year’s—or last year’s—with one click of the mouse button. Schedule appointments or meetings, and have GeoPlanner automatically remind you about the important ones. You can even schedule recurring events, like birthdays or weekly meetings.
THE GEOPLANNER WINDOW

The GeoPlanner window is actually two windows—the Calendar window on the left and the Event window on the right. You use the Calendar window to pick the day you want to work with, while you use the Event window to look at and change the events scheduled on that day.

In GeoPlanner, something you schedule—such as an appointment or a meeting—is called an event. To see what you’ve scheduled, or to schedule an event on a particular day, select a day in the Calendar window by clicking it. Likewise, if you want to see a series of days, select them by dragging. The scheduled events immediately appear in the Event window.

You can also move through the days one at a time. Simply click the Previous Day and Next Day buttons above the Event window.

CHANGING DAYS WITH THE CALENDAR WINDOW

The Calendar window, as you might expect, shows the calendar for a given year. It normally shows one month at a time, although you can make it show several months at once if you desire.

Today’s date is always marked with a heavy outline. Any days you select are also highlighted with their own color. The little triangles denote days that have events scheduled on them.

To see a particular month while in Single Month view...

Click the scroll bars on the Calendar view window until you reach the desired month.

To view different years...

Change the Year field at the top of the GeoPlanner window, either by clicking the up or down arrows or by
typing a new year. You can enter any year from 1900 to 9999 (AD, of course). The Calendar window immediately changes to show the calendar for that year. Note that doing this doesn't change the selected day. You may not be able to see that day in the window any more, but it's still selected.

You can tell by looking at the date above the Event window, which still shows the selected day—as does the Event window itself. The date and Event window will both change when you actually click a new day.

**To see several months at a time in the Calendar window...**

Choose Full Year from the View menu. The Calendar window immediately changes to show as many months as will fit. Use the scroll bars to see the remaining months.

When you want to see one month at a time again, choose Single Month from the View menu. (This is the normal view.)

---

**WORKING WITH EVENTS**

You can use GeoPlanner as an electronic date book for tracking events in your daily schedule. You can also use it to automatically remind you when it's time for important appointments.

A very useful feature of GeoPlanner is its ability to schedule events that happen at regular intervals, like weekly meetings or anniversaries. This feature is described in "Working With Repeating Events," later in this chapter.

---

**SCHEDULING EVENTS** Scheduling events is simply a matter of selecting the appropriate day, entering the time of the event and then typing a brief description.

In the description portion of an event, you can paste text that's been copied from other applications. The reverse is also true: you can copy text from GeoPlanner to paste into other applications, such as GeoWrite.

**To schedule an event...**

1. In the Calendar window, click the square of the desired day. The day's events appear in the Event window. Check the date above the Event window to make sure that you clicked the correct day.
2. Choose New Event from the Edit menu. A blank event appears in the Event window, with its time selected.
3. Don't de-select the time (by, say, clicking somewhere else in the event).
4. Type the time of the appointment or event (replacing the selected time). For example, type 10:43 am. If the event has no particular starting time, press `Backspace` to delete the existing time and leave the time area blank.

   **Note:** If you omit the "am" or "pm" when you type the time, GeoPlanner tries to guess which one you mean. If it doesn't guess correctly, change the time manually.

5. Press `Tab`. GeoPlanner quickly verifies that you typed the time correctly and the cursor moves into the description portion of the event line.
Type a description of the event. You may fill as many lines as you like.

That's it. GeoPlanner automatically records the event as soon as you do something else—such as selecting a different day or starting a new event.

To change an event...
Change the event the way that you'd change any regular text, by selecting text with the mouse and re-typing.

If you make a mistake while changing an event, choose Undo from the Edit menu to restore the event to its original form. (Note that you cannot undo after you change or delete another event or after you change the day displayed in the Event window.)

To remove an event...
1 Click anywhere in the text of the event to select it. GeoPlanner draws a box around the event to show that it has been selected.
2 Choose Delete Event from the Edit menu. The event is removed from the window.

You can change your mind and restore a deleted event by choosing Undo from the Edit menu. Act quickly, though: you cannot restore the event after you change the day displayed in the Event window, or after you change or delete another event.

VIEWING EVENTS
The Event window shows the events scheduled for a particular day or group of days. GeoPlanner provides several shortcuts for quickly viewing the scheduled events of one day, the entire week, or the entire month.

To view a day's event...
In the Calendar window, simply click the day. The day's events appear in the Event window.

To view the next or previous day's events...
Click the Next Day button to view the day following the currently selected day. The Event window changes to show the day. Or, click the Previous Day button. The events scheduled for that day appear in the Event window.

To view events for a range of days...
In the Calendar window, drag the mouse to select the days you wish to view. The events scheduled for those days appear in the Event window.

The Next Day and Previous Day buttons move you forward and backward by the same number of days that you've selected. For example, if you select four days and click Next Day, GeoPlanner selects the following four days.

To quickly view today's events (or this week's, or this weekend's)...
Choose Today from the Quick menu. The Event window shows the events scheduled for today. Similarly, you can use the Quick menu to view the events for this week, this weekend, or this month.
**SETTING THE ALARM**

GeoPlanner has an alarm you can set to remind you that it’s time for an important appointment. When the alarm goes off, your computer beeps and a dialogue box appears, showing the description for the event. And best of all, like a bedside clock the GeoPlanner alarm comes with a snooze button.

Alarms normally go off at the time of the event, but you can set them to go off a few minutes early to give you some time to prepare.

**To turn an alarm on or off...**

If there is nothing in the description portion of an event, type something there—the event can’t be blank. Click the bell icon next to the particular event. The bell darkens, indicating that the alarm is set. To turn the alarm off, simply click the bell again.

Another way to turn it on or off is with the Alarm Settings dialog box, which you can bring up by choosing Alarm Settings from the Edit menu.

**To stop the alarm once it’s gone off...**

Click Off in the dialog box to turn off the alarm and make the box go away. Or, click Snooze to turn the alarm off temporarily—like pressing the Snooze button on a bedside alarm clock. After five minutes the alarm goes off again.

**To make the alarm go off earlier...**

1. Choose Alarm Settings from the Edit menu. The alarm settings box appears.
2. Change the Time. This is normally set to the time of the event. Enter the time that you wish the alarm to go off. For example, if you were setting the alarm for a 10:00 am appointment and you wanted five minutes to get ready, you’d enter 9:55 am.

3. Click OK. The dialog box goes away. You can set all alarms to go off early as part of their standard operation. See “Customizing GeoPlanner” later in this chapter, for more information about this.

**WORKING WITH REPEATING EVENTS**

With GeoPlanner, you don’t need to record regularly repeating events on each date they occur—you need only enter it once. For instance, if have you have a staff meeting every Tuesday at 9:30 am, or you need to pick up your children from school early on the first Thursday of each month, you’d enter the events once and GeoPlanner would automatically repeat the events on future dates.

GeoPlanner can only handle those events that repeat at regular intervals. It couldn’t handle, say, a meeting that happens in January, September, and November. On the other hand, here are some examples of repeating events it *could* handle:

- Every January 5th until 1995
- Every Monday and Wednesday this year
- Every second Friday of the month
Such events are marked with a large R in the Event window to indicate that they repeat. The Repeating Events dialog box shows them all together.

Here’s what the different parts of the dialog box do:

**Frequency** This is the event’s cycle, how often it repeats. The event can happen each week, once a month, or once a year.

**Specify by** Monthly and yearly events can be listed one of two ways: by date—*January 7th*—or by the day of the week—*the second Friday*. The choices you make here and in Frequency determine which of the following fields you can change.

**Select Days** For a weekly event, use these settings to choose the days of the week that the event occurs. Note that you can choose more than one day if you like.

**Month** For a yearly event, use this setting to choose the month in which the event occurs.

**Day of Month** For monthly or yearly events scheduled by date, use this setting to choose the day of the month on which the event occurs. If it always occurs on the last day of the month, click Last.

**Time** Time of day that the event happens. Leave it blank if the event has no scheduled time, as would be the case if this event were part of a “to do” list.

**Description of event** This is the same as the description portion of a regular event.

**Range of dates:** This shows the date of the first occurrence of the event and the date of the last. If the event continues on indefinitely, click Forever.

**SCHEDULING REPEATING EVENTS** You use the Repeating Events command to create, edit, and remove all repeating events.
To schedule a repeating event...

1. Choose Repeating Events from the Utilities menu. The Repeating Events dialog box appears.
2. Click New. A dialog box with a variety of settings appears.
3. Set the different options. See “Setting Some Common Events,” later in this chapter, for several examples of scheduling different repeating events.
4. Click OK to schedule the new event.
5. Click Close to make the Repeating Events dialog box go away.

To change a repeating event...

1. Choose Repeating Events from the Utilities menu. The Repeating Events dialog box appears.
2. Click to select the event you want to change and then click Change. The settings dialog box appears.
3. Change the information in the dialog box.
4. Click OK when you finish.
5. Choose another event to change, or click Close.

There’s another way to change a repeating event, but it has a major side-effect: as we said earlier, the repeating event shows up in the Event window like any other event when you view the designated day. And, like any other normal event, you can change it there. If you do this, though, it becomes a normal—that is, non-repeating—event; it’s completely cut off from the original repeating event.

This means that if you change the original event later on (the proper way, with the Repeating Event dialogue box) this particular event won’t change. You’ll have to change it manually.

To remove a repeating event entirely from the calendar...

1. Choose Repeating Events from the Utilities menu. The Repeating Events dialog box appears.
2. Select the particular event you want to remove.
3. Click Delete. The event is removed from the window.

EXAMPLES OF SOME COMMON EVENTS Here are a couple examples of how to schedule some repeating events.

To schedule an event that occurs weekly...

Suppose that you meet with your employees every Wednesday at 3:30 pm.

1. Begin a new repeating event by choosing Repeating Events from the Utilities menu.
2. Click the Weekly button in the Repeating Event dialog box.
3. Where it says Select Days, click the day or days when the event occurs. In this case, click Wednesday, since your meeting is every Wednesday afternoon.
4. In the Time of Event box, enter the time of the event:
   3:30 pm
5. In the Event box, type a brief description of the event:
   meeting with employees
6. If the event starts on a particular date and continues through to another date, enter those two dates into the Repeat From and To boxes. On the other hand, if the event goes on indefinitely, click Forever. Since the latter is
the case with your employee meetings, you click Forever.

7. Click OK to enter the event.

To schedule an event that occurs on a certain date each month...

Suppose that you always pay your rent on the 5th of the month.
1. Begin a new repeating event by choosing Repeating Events from the Utilities menu.
2. Click the Monthly button.
3. Because you always pay on a certain date, instead of a certain day of the week, click Date in the Specify By field.
4. Choose the particular date by changing the Date in the Day of Month field. In this case, change the Date to 5, since you pay on the 5th of the month.
5. In the Time box, enter the time of the event. For this example, leave the Time box empty.
6. In the Event box, type a brief description of the event:

Pay rent

7. If the event starts on a particular date and continues through to another date, enter those two dates into the Repeat From and To boxes. If the event goes on indefinitely, click Forever. Since you pay rent indefinitely, you click Forever.
8. Click OK to enter the event.

To schedule an event that occurs on a particular day each year...

Suppose you want to mark Thanksgiving—which always happens on the fourth Thursday of November—in GeoPlanner.
1. Begin a new repeating event by choosing Repeating Events from the Utilities menu.
2. Click the Yearly button.
3. Because Thanksgiving always falls on a Thursday, click Day of Week in the Specify By field.
4. Change the Month field to November.
5. Choose the particular day by changing the Day of Week. In this case, change it to Fourth and Thursday, since Thanksgiving always falls on the fourth Thursday of the month.
6. Leave the Time box empty.
7. In the Event box, type a brief description of the event. For this event, enter Thanksgiving.
8. If the event starts on a particular date and continues through to another date, enter those two dates into the Repeat From and To boxes. On the other hand, if the event goes on indefinitely, click Forever. For this example, you click Forever.
9. Click OK to enter the event.
SEARCHING

GeoPlanner lets you search for events that contain a certain bit of text; for example, you could find all the events containing the word “Murtnik.” GeoPlanner looks for the text in the event description. You can search for part of a word, a whole word, or many words. This means that you could search for “Mu,” and GeoPlanner would find appointments with Murtnik, Mullin, and Munster.

However, GeoPlanner is case-sensitive. If you search for “murtnik” (lower-case “m”), GeoPlanner won’t consider events containing “Murtnik” (uppercase “M”) to match—it expects both of the words to match exactly.

To search for an event containing some text...
1. Choose Search from the Utilities menu. The Search dialog box appears.
2. In the Search For field, type the text you want to find.
3. Click Start Search. The first event containing the text appears selected in the event window.
4. Click Find Next to find the next event that also contains the text.

GeoPlanner starts the search with the selected day and continues on through the list of future events. If it can’t find the text in any of those events, it asks you if you want to search through past events, too. When there are no more past or future events that contain the Search For text, a dialog box appears telling you that the search is complete.

PRINTING

You can use GeoPlanner to print your scheduled events or to print monthly or yearly calendars.

GeoPlanner prints according to the selected days in the calendar window. For example, to print a calendar for February, first select a day in February from the Calendar window. It’s not enough just to have the month showing in the Calendar window—you must actually select a specific day in the month. Then choose Print from the File menu and choose Month. The Will Print box says “February.”

In addition to the usual printing options, GeoPlanner has some options of its own:

Event Window Prints what’s in the event window—the events on the selected day, in other words.
Month Prints a calendar for the month.
Year Prints a calendar for the entire selected year. No events are printed.
Include Events For a monthly calendar, this prints the events as well.
Will Print Shows what day, days, month, or year will be printed. Use this to double-check that you’ve selected the right day.
CHANGING VIEWS

You control the Calendar and Event windows with the View menu.

To select a view...

Choose the desired view from the View menu. There are three different views:

**Calendar Only** This view closes everything but the Calendar window. Because the Event window is closed, you cannot view the events themselves, nor can you change them or add to them. The reminder feature, however, continues to work for events that are already recorded.

**Events Only** This view closes everything but the Event window. You can still view, change, and delete events, but without the Calendar window you can only change the day shown via the Next Day and Previous Day buttons.

**Both** This is the standard view. It shows both the Calendar window and the Event window together.

CUSTOMIZING GEOPLANNER

You can customize some of the different features of GeoPlanner, including the way that it presents events in the Event window and the number of minutes that alarms go off ahead of the actual event. Once you've chosen new options, you should save your preferences so that they still apply the next time you start GeoPlanner.

To set your preferences...

1. Choose Change Preferences from the Options menu. The preferences dialog box appears.
2. Set the different options:

   **Day Template** When you turn on Day Template, the Event window provides a template of regular events (usually spaced at half-hour intervals), even if no events are actually scheduled. When Day Template is off, only scheduled events show; the window is otherwise blank.

   **Show Empty Days** When you select a range of days in the Calendar window, the Event window shows all the events scheduled on all of the days. Normally it lists only those days that actually have events scheduled. With this option turned on, the Event window

![Image of the GeoDex Preferences window.](image-url)
lists every day in the range, even those days containing no scheduled events.

**Start Time, End Time, and Interval**

These three options control the Day Template. Start Time and End Time determine the range of the template—normally 8 AM to 6 PM. The Interval controls the amount of time between template entries, and is set to half an hour by default. This means that the day is marked off into half-hour blocks—8:00, 8:30, 9:00, 9:30, and so on. You can change this interval to anything from five minutes to sixty minutes.

**Reminder Precedes Event**

These settings change how far ahead of the events the alarms normally go off. While the settings are initially set to zero—meaning that alarms go off at the time of the events—you can alter them to make the alarms go off minutes, hours, and even days before. The new settings take effect for all events you enter from then on. Note that this is only the default alarm time. You can set the actual time of the alarm when you turn it on.

**Startup As**

You can control which of the two windows are open when you first start GeoPlanner. You can choose to have just the Calendar window open, just the Events window, or both.

**Automatically Show Today’s Date on Start-Up**

When this option is on, GeoPlanner will show you today’s events when you start it. Alternatively, when the option is off it shows you the day you were looking at when you last used GeoDex.

**At Midnight, Automatically Switch to New Day**

Normally on, this option determines what happens if you leave GeoPlanner running overnight. “On” means that it will change days automatically at midnight, while “off” means that you have to adjust the calendar window manually. (This option only matters if you leave GeoPlanner running overnight.)

 WHEN you’re satisfied with your settings, click OK.

**To save your preferences...**

Choose Save Preferences from the Options menu.

GeoPlanner doesn’t associate the preferences settings with any particular document. When you save your preferences, they stay in effect even if you work with a different GeoPlanner document.

**Linking to GeoDex**

GeoPlanner can search the GeoDex address book for cards containing a particular name or bit of text. For example, say you are scheduled to meet with John Murtnik and you want to call him to confirm the meeting. You can have GeoPlanner search GeoDex for the card with the name “Murtnik” on it. When you find it, you can use the phone numbers on it to call him.

GeoPlanner expects the text that you’re searching for to match the text in the GeoDex address book *exactly*. If you search for “John Murtnik,” you won’t get cards containing the name “john murtnik,” or even “Murtnik, John.” For this reason, you should be consistent in the way that you enter names into both GeoPlanner and GeoDex.
To find the address card for a name in the Events window...

1. Make sure that the GeoDex application is started.
2. Select the person's last name, or some other bit of text that you wish to locate.
3. Choose GeoDex Lookup from the Utilities menu. The GeoDex window appears and shows the first card containing the selected text.

   If you want to find the next GeoDex card also containing the text, switch to GeoDex's Search view (choose Both View from the View menu) and click Find Next.
4. When you finish looking at the address book, return to GeoPlanner by choosing GeoPlanner from the Express menu or by clicking anywhere inside the GeoPlanner window.

   As an example, take the earlier case where you are scheduled to meet with John Murtnik and you want to call him to confirm the meeting. Select the last name, "Murtnik," and choose GeoDex Lookup from the Utilities menu. The GeoDex window appears with the card for Murtnik displayed. All you need to do is scroll to the correct phone number and click the Dial button.
GeoWrite can do letters, sales reports, papers, and lots of other things. So can a lot of other word processors, but GeoWrite does them in style. It gives you the full benefit of the outline fonts built into GeoWorks Pro, which means that your text is smooth and easy to read—both on the screen and on paper. And you can include pictures that you copy from GeoDraw or the Scrapbook. With GeoWrite’s advanced features, it’s even easy to create a three-column newsletter!
WHAT IS A WORD PROCESSOR?

First drafts are rarely perfect. You'll always want to change them. In a letter, you may find a misspelled word here and there, or just a couple of typos. A lengthy report, however, may require a complete reorganization. Either way, with a typewriter, this means retyping the whole thing—a tremendous waste of time. But word processors make changes like this easy.

With a word processor you actually type your text on a video screen (and not directly onto the page) where you can easily change it again and again (and again and again) before a single word is committed to paper. Want to change "feline" to "cat"? Just delete "feline" and type "cat," or "dog," or whatever you want. A word processor automatically shifts the following text to fill the empty space, or to give you room for new text. Pick up a whole paragraph to move it somewhere else, and the rest of the page shifts up to fill the vacancy. You need not settle for flawed documents, as it's so easy to fix them. When you're satisfied with the document you see on the screen, print it.

You can also save your work—so that you can retrieve your text tomorrow, or even a year later and continue working on it. Open an old document, update it, and save your changes as a new document. You now have two slightly different versions of the same document, both of which you can open and edit at any time. Save as many versions of a document as you like.

Most importantly, a word processor like GeoWrite is designed to make the process of writing easier. But like any tool, you'll need to get used to using it. To that end, read through the "Getting Started" section of this manual if you're new to the world of word processing, paying close attention to the bit about GeoWrite. There's also some important information in the "Basic Tools and Skills" chapter—and of course, this chapter.

HINTS FOR WORKING WITH A WORD PROCESSOR

• Do not press [Return] at the end of every line—word wrapping automatically shifts text to the next line for you. Press [Return] only at the end of a paragraph, or when you absolutely have to have certain text start on a new line, say for a heading.

• Remember, only one space after a sentence, not two. With typewriters, you always needed two, since the monospaced typeface—Courier—created very even, regular columns of text, and the only way to create the extra break at the end of a sentence was to add two spaces. While GeoWrite comes with URW Mono, a variation of Courier, most of the other fonts are proportional, meaning that the different letters have different widths ("m" is much wider than "i," and so forth). Since the lines of text don't form even columns, you only need a single space after a sentence to create a separation.
• Use tabs instead of spaces to create tables. In a monospaced font, like on a typewriter, the word “bill” followed by ten spaces takes the same amount of room that the word “when” (and ten spaces) does. Not true for proportional fonts. The letter “b” is slightly slimmer than the letter “w,” “i” slimmer than “e,” and so on. Therefore, “bill” followed by ten spaces takes less room than “when” and ten spaces. The rule, then: tables made with spaces won’t line up; those made with tabs will. (See “Creating a Table” in this chapter.)

• Don’t use spaces to align text in the center or on the right edge of the page. Use the center tab (or center the whole paragraph) and the right align tab. (See “Setting Tabs” in this chapter.)

• Avoid using spaces to indent the first line of a paragraph. Use a tab. Or, better yet, use the indentation mark on the ruler—that way, GeoWrite will automatically indent your paragraphs for you. (See “Changing Margins” in this chapter.)

• In the days of the typewriter, you had only two ways to emphasize a particular word: You underlined it or you made it all capital letters. Fine for typewritten pages, but why use capitals and underlines when you can choose boldface, italics, or even entirely different fonts to make a word stand out? Unless you’re typing a manuscript for submission to an editor, try to avoid underlines and words in capital letters.

• Words with all capitals, however, are useful for logos, titles, and headings. But for these, you often use large font sizes which need their own special treatment. If the letters are big, make sure you adjust the spacing between characters, so the line doesn’t look “spacey.” (See “Changing the Character Spacing.”)

• With GeoWrite, you can use special characters that you rarely, if ever, see on a typewriter. For a break in a sentence, use an em dash (—) instead of a pair of hyphens (—). Hyphens are usually used only to break up a word. Or, use bullet points (•) to set apart items in a list. To see how to type these and other special characters, turn to the Appendix.

WHAT YOU SHOULD ALREADY KNOW

Certain tasks you perform in GeoWrite are common to all GeoWorks applications. This is the main reason you can go from one GeoWorks application to another and feel immediately comfortable. These common tasks are not discussed in application chapters like this one, but they are described in the “Basic Tools and Skills” chapter. Here are some of these tasks. If you are not familiar with them already, go to the “Basic Tools” chapter and read about them there.
• Opening and closing a document
• Entering and editing text
• Formatting text: Fonts, Sizes, Styles
• Cutting and pasting text or graphics
• Saving a document
• Printing
• Using the View menu to zoom in and out
• Correcting the aspect ratio
• Using the Window menu to work with multiple documents
• Reverting
THE GEOWRITE WINDOW

The GeoWrite window gives you an accurate, page-by-page view of your document.

THE RULER The ruler is the centerpiece of GeoWrite’s window. It indicates the width of the text area and allows you to set the position of tabs, margins, and indents. It contains justification and line spacing settings, page buttons, and movable margin and tab markers. Normally, these show you the margins, tabs, justification, etc. for the current paragraph—that is, the one with the text cursor in it. When you select a range of text, however, the ruler turns gray and shows only those settings that are common to all the selected paragraphs.

THE HEADER, BODY, AND FOOTER Each page of the document contains three areas where you can place text: the header, body, and footer. The text in the body of the document appears on only one page, but text in the header and footer areas is repeated on all the pages. This lets you have page numbers and graphics (like a logo or other design element) appear on each page.

The header area is visible at the top of the page, though normally the window is adjusted so that you can’t see it. You can see it by simply scrolling the window to the top. Similarly, to see the footer area at the bottom of the page, scroll the window down to the bottom. For the complete story on head-
ers and footers, see “Adding a Header and Footer.”

MOVING BETWEEN THE PAGES OF A DOCUMENT You can move through the pages of your document in several ways. To move backward or forward one page at a time, use the Page arrows on the ruler. To jump to a specific page, however, it’s easier to choose Go To from the Window menu. Pages you have already worked on appear in the Window menu. To go to one of these, just choose the page in the menu.

FORMATTING TEXT

One powerful feature of GeoWrite is that it allows you to experiment with many different styles of text. When you want to try something, first select the text, then choose different fonts, font sizes, or special styles (such as bold, italic, and underline). You can also color text, lighten it with a halftone (or a pattern of very small dots—but more on this elsewhere), or adjust the character spacing for titles or headlines. Make changes until you find a look you like.

You do most of your text formatting with the Fonts, Sizes, and Styles menus. But those menus, because they’re common to many GeoWorks Pro applications, are only discussed at length in the “Basic Tools and Skills” chapter of this book. There is, however, a formatting trick that is only discussed here: namely character spacing, which is often known as kerning.

CHANGING THE CHARACTER SPACING (KERNING)

When you change the character spacing of a word, you change the amount of space between the characters—particularly useful for titles, headings, logos, and fine print. For example, if you used the word “World” in a title, you’d notice that the “W” and the following “o” seem a little farther apart than, say, the “l” and the “d.” This happens because of the shapes of the two letters. By changing the characters’ spacing, you could bring the “o” in closer to the “W,” and achieve a better result.

What’s altered, like in other formatting commands, depends on what you select. Change the spacing of two characters, or a whole page. The default spacing is zero, but you can set spacing from -150 up to 500. This number isn’t an absolute measurement; rather, it is a degree of spacing that is based on the width of the character—so, a “w” with spacing of 150 moves farther than an “i” with the same spacing. A negative number compresses text and causes the characters to overlap.

Washington Bar
Washington Bar
Washington Bar

Three different examples of character spacing. At top, each letter is spaced at +50. In the middle, the spacing is zero, or standard. In the bottom example, each letter (especially the first “a” in Washington) is kerned to fit well with the one next to it.
To change character spacing...

1. Select the text you want to change. If you select one character, the spacing before the character is changed, while the space after remains unchanged.
2. Choose Character Spacing from the Sizes menu. The Character Spacing dialog box appears.
3. Click the up or down arrows to change the spacing, or type a new number. Increasing the number moves the characters apart, while decreasing number brings them closer together.

4. Click Apply to see the effect of your changes.
5. When you're satisfied, click Close to make the dialog box go away (though you can leave it open if you prefer—just click in the GeoWrite window to continue working).

To set and clear tabs...

1. If necessary, choose Show Ruler Bottom from the Options menu so that the tab markers are visible.
2. Position the text cursor in the paragraph for which you are setting tabs, or select multiple paragraphs.
3. Drag a tab marker to the location you want on the ruler. Release the mouse button to set the tab. To move a tab, drag it to a new position on the ruler. To clear a tab, drag it off the ruler in any direction.
4. Continue dragging tabs from the tab well to set as many tabs as you want.

To copy a tab...

1. Create the first tab.
2. Hold down the Ctrl key and drag the tab to a new position on the ruler. The original tab stays in place. The copy is the same type of tab and contains the same formatting as the original tab.

Changing the default tabs When you haven't set any tab stops on the ruler, GeoWrite sets default tab stops every inch. These default tab stops are marked by tiny vertical arrows on the ruler.

To change the default tabs...

1. Choose Default Tabs from the Paragraph menu.
2. Click one of the four standard distances on the cascade menu: Centimeter, Half Inch, One Inch, or None.

Setting tabs

You set tabs by dragging the type of tab you want from the collection of sample tabs (called the tab well) and positioning it on the ruler. You clear tabs by dragging them off the ruler in any direction. You have a choice of four types of tab: Left tabs align text on the left. Right tab aligns text on the right. Center tab centers text at the tab location. Decimal tab aligns text around a decimal point.
FORMATTING TABS

In addition to setting and clearing tabs from the ruler, you can format tabs. Your tab formatting options include using different types of leaders and applying vertical lines. You can format any tab you add from the tab well, but not GeoWrite’s default tabs.

USING TAB LEADERS Tab leaders automatically insert a line or a row of dots between the text and the leader tab. For example, leading dots are often used to fill in the space between a table of contents entry and its page number, as the following example shows. You cannot add a leader to one of GeoWrite’s default tabs.

To set tab leaders...
1. Click the tab on the upper half of the ruler. A small arrow appears beside it indicating that it is selected.
2. Choose Tab Attributes from the Paragraph menu (or simply double-click the tab on the upper half of the ruler).
3. Select either Dot or Line from the Tab Leader option. (The options are dimmed when no tab is selected.) The leader is associated with the currently selected tab.
4. Change the Tab Type if necessary.
5. Click Apply.

You can keep the Tab Attributes dialog box open and move between the GeoWrite document and the dialog box until you like the tab leaders. You can also keep the dialog box open and click different tabs on the ruler.

DRAWING VERTICAL LINES WITH A TAB With tab lines, you can use tabs to draw vertical lines—called rules—to make tables and columns. You cannot add a vertical line to one of GeoWrite’s default tabs.

To draw tab lines...
1. Click to select a tab on the ruler. The arrow indicates which tab you are formatting.
2. Choose Tab Attributes from the Paragraph menu.
3. Click the Tab Lines option and click Apply. A line appears next to the tab on the ruler to show that a line will be drawn at the position of this tab, and the Tab Lines options become available.
4. Click the arrows next to Tab Line Width to set the width of the lines (from 1 to 3 points).
5. Click the arrows to change the Tab Line Spacing value from 1 to 3 points. This moves the tab line to the left, to create a bit of space between the line and the text at the tab.
6. Click Apply to see the tab line in your document. The tab is now formatted to insert a vertical line in your document. Using this tab on several continuous lines creates a long solid vertical line.
CHANGING MARGINS

Use the margin markers on the ruler to increase the left and right margins. Notice that the left margin marker is split into upper and lower halves. The top half allows you to indent the first line of a paragraph without affecting the paragraph's other lines. By moving the upper half, you can create either a normal paragraph indent or a special hanging indent—where the first line of a paragraph starts to the left of the rest of the paragraph. See “To create a hanging indent...” in this section. By contrast, the lower half of the margin marker determines the left edge of the paragraph—the left margin.

To change paragraph margins...

The simplest way to change the margins for the entire document is to choose Page Setup from the File menu (where you can enter the size of both margins). There, you can also have GeoWrite alternate left and right margins—where the left margin setting is actually the left margin setting on left (even) pages, but it's the right margin setting on right (odd) pages (think about it). To change individual paragraph margins, though, adjust the margin markers on the ruler.

1. Select the desired paragraph by clicking in it to place the text cursor, or select multiple paragraphs that you want to change.
2. Hold down Shift and drag the left marker to a new position on the ruler (by holding down the Shift key, you drag both the upper and lower halves of the marker together). Or, to set the right margin, simply drag the right margin marker.

To indent the first line only...

1. Click to position the text cursor in the paragraph to be indented. Or, select multiple paragraphs.
2. Drag the left indent marker (the upper half) to the correct position on the ruler. Be sure not to hold down Shift as you do this, since this will move both the upper and lower halves.

To create a hanging indent...

1. Select the paragraph(s) you want to align with a hanging indent.
2. Drag the left margin marker (lower half) to the right. Leave the first line indent marker (the upper half) in place.

CENTERING AND JUSTIFYING TEXT

In GeoWrite, lines of text can be justified (aligned) any of four ways: flush to the left margin (left justified), flush to the right margin (right justified), evenly centered between the margins (centered), and flush to both the left and the right margins (fully justified). The alignment you choose affects the entire paragraph.
To center or justify text...
1 If necessary, choose Show Ruler Bottom on the Options menu to display the lower portion of the ruler.
2 Position the text cursor in the paragraph you want to justify, or select multiple paragraphs.
3 Click a justification icon on the ruler.

CHANGING LINE SPACING (AUTOMATIC LEADING) The simplest way to change the space between lines is to adjust line spacing from the ruler. This is best if you are typing a letter or memo and do not need the precise control that custom leading gives you. Choose a setting—single, double, or one-and-a-half spacing—by clicking the appropriate spacing symbol on the ruler.

To change the line spacing with the ruler...
1 If necessary, choose Show Ruler Bottom on the Options menu to see the line spacing options.
2 Click the text cursor in the paragraph to be spaced or select multiple paragraphs.
3 Click one of the three line-spacing icons on the ruler. For more information see “Setting Paragraph Spacing.”

To set custom line spacing...
1 Position the text cursor in the paragraph you want to change, or select multiple paragraphs.
2 Choose Paragraph Spacing from the Paragraph menu. Note that under Leading you have two choices: Automatic and Manual.
3 Select Automatic Leading.
4 Click the arrows or type a value. A number like 3 in the Line Spacing box gives you triple-spacing. The normal line spacing (as determined by the largest character size on the line) is multiplied by this number; so, 1 is single-spacing, 2 is double-spacing, and so forth. You can also enter a fractional value.
5 Click Apply to see the result of your change.
6 Click Close.

SETTING PARAGRAPH SPACING

In typesetting terms, the white space between lines is called leading (pronounced “ledding,” not “leading,” since the term dates back to the days when printers used strips of lead to space lines of text on the press). GeoWrite lets you change the leading separately for above, below, and within a paragraph. You also have a choice of using automatic or manual leading. Automatic makes the line height a multiple of the size of the largest character on the line. You enter the multiple—2 for double-spacing, 3 for triple-spacing, and so forth. With manual leading you have more control—you enter a specific leading measurement, usually in points. Precise manual leading adjustments are handy when laying out a newsletter or pamphlet, where aesthetics and copyfitting are important. However, if you are just typing a letter or memo, it may be best to use the simpler automatic line spacing (see “Changing Line Spacing” in this section).

GeoWrite displays measurements in most dialog boxes in inches by default. But in the Paragraph Spacing dialog box, the default measurement is points. You can also enter values in other units by using the correct abbreviation: in (inch), pi (pica), cm (centimeter), mm (millimeter), ci (Cicero), or ep (European point).
CHANGING LEADING MANUALLY

For precise control over line spacing, use manual leading.

To manually set the leading...

1. Place the text cursor in the paragraph you want to change or select multiple paragraphs.
3. Click the arrows or type a new value in the Manual Leading box.
4. Click Apply to see the result of your change.
5. Click Close.

CHANGING THE SPACING BEFORE AND AFTER A PARAGRAPH

Often, to set a paragraph (like a heading) off from the text around it, you’ll want to add some white space above and below. You could simply add extra lines before and after the paragraph, but unfortunately these lines have a set height (the height of the text) thus giving you little control over exactly how much space you get. Here’s a better way. With the Paragraph Spacing dialog box, you can add a specific amount of space before (and after) the paragraph, to separate it from the others around it.

To change the spacing above or below a paragraph...

1. With your paragraphs selected, choose Paragraph Spacing from the Paragraph menu. The Paragraph Spacing dialog box appears.
2. Click the arrows or type a value for Space on Top, or Space On Bottom.
3. Click Apply to see the results of your changes. Make more adjustments or click Close to close the dialog box.

USING STYLES

You will often spend a good deal of time getting a paragraph to look just the way you want. Elaborate formatting, like choosing point sizes and styles, setting custom leading, creating special indents, setting tabs, and so forth, can be time-consuming for one paragraph—never mind the time it takes to repeat the process for other paragraphs. In GeoWrite, however, you can apply the formatting from one paragraph to another in a couple of easy strokes. This is accomplished with a GeoWrite style. A style is all the character and ruler settings such as font, size, style, and indentation, that you have applied to text. To use a style, you store the style for one paragraph and apply it (by recalling the style) to another.

To store a style...

1. Format text with the font, size, style, and ruler settings that you want.
2. With the text cursor anywhere in the paragraph, choose Store Style from the Edit menu.

To recall a style...

1. Click to position the text cursor in the paragraph to which you want apply the style (or select several paragraphs).
Choose Recall Style from the Edit menu. GeoWrite applies the settings of the last style you stored to the current paragraph. It's just as though you manually set the font, size, and character styles.

**CREATING BORDERS FOR TEXT**

GeoWrite lets you add borders to paragraphs for emphasis and design. For a quick border, you have three choices: one line, two line, and shadow (with an adjustable imaginary light source). For more control though, GeoWrite's Custom Border command allows you to change the three basic border types. Borders can also be colored and halftoned, and when combined with paragraph color, you have a seemingly endless range of design possibilities.

**To add a standard border to text...**
1. Position the text cursor in the paragraph you want to border, or select many paragraphs.
2. Choose Border from the Paragraph menu. A cascade menu appears.
3. Choose a border from the cascade menu: One Line, Two Line, or Shadow Top Left.

---

The mating pattern of the native "flinge-held" bird is one of obscure ritual and many loud noises, particularly by the male when he finds a suitable female.

---

**To remove a border...**
1. Position the text cursor in the paragraph from which you want to remove all the borders, or select several paragraphs.
2. Choose Border from the Paragraph menu.
3. Choose None.

**CUSTOMIZING BORDERS** Choosing Custom Borders lets you refine the three standard borders. For example, you may want a thick line that appears only above and below the text, not on all four sides. Or, if you have a double-line border, you may want to change the spacing between the lines.

To apply a color or halftone to the border, see "Using Color in GeoWrite."

**To customize a border...**
1. Choose Border from the Paragraph menu. Then choose Custom Border from the cascade menu that appears.
2. In the Custom Border dialog box, choose a Border type: Normal, Shadow, or Double Line.
3. Turn on the Draw Inner Lines option if you want a line drawn between bordered paragraphs. (Normally, a group of paragraphs that have exactly the same borders aren't separated by lines—instead they're enclosed in one big box.)
4. Click to deselect any sides that you do not want bordered.
5. Click the arrows if you want to adjust Border Width, Border Spacing, Shadow Width, or the Width Between Lines of a paragraph.
two-line border. If you select the Shadow border, choose the corner from which the shadow is cast (the Shadow Anchor).

6 Click Apply to see the results.
7 Make final adjustments to the border settings and click Close when you finish.

**CREATING A TABLE**

You can use tab lines in conjunction with a border to build tables in your documents.

**To create a table...**

1 Set tabs on the ruler where you want each column of text to begin. Use decimal tabs where appropriate for numeric data.

2 Add a tab anywhere you want a vertical line drawn between columns of data.

3 Double-click the tab to open the Tab Attributes dialog box and turn Tab Lines on. Set Tab Line Width and Tab Line Spacing as desired and click Apply.

4 Click Close when you have tab lines you are happy with.

5 Enter data in the columns of the table. Be sure to use the Tab key (not Spacebar) to create columns on a new line. Tabs you formatted with tab lines make vertical lines between columns. To change the width of a column, simply adjust the appropriate tabs (be sure to select all the lines in the table before adjusting the tab, so that all the lines are adjusted the same way).

6 Select the entire table and choose Border from the Paragraph menu. Choose a border from the cascade menu that appears, or create a custom border for the table.

![A sample table, showing the use of decimal tabs, tab lines, and paragraph borders.](image)

**USING COLOR IN GEOWRITE**

GeoWrite offers you the ability to add color to your documents. You can choose from a palette of 16 colors and apply the colors to text, paragraph backgrounds, or borders. You can view these colors on an EGA or VGA monitor, although you must have a color Postscript-compatible printer to actually print in color. (If you don’t have such a printer, you’ll still see shades of grey, much like watching a color television program on a black and white television set.)

**ABOUT COLOR ON A MONOCHROME SYSTEM** On a monochrome monitor the colors on the color palette appear as patterns. Use them to apply shades of gray to text, paragraph backgrounds, or borders. If you have a Postscript-compatible color...
printer, the actual color (corresponding to the pattern on a monochrome monitor) prints, even though it’s grey on your screen. With regular single-color printers you just get the shades of gray.

The Halftone controls simply change the color intensity (of text, paragraph backgrounds, and borders) on both color and monochrome monitors. Halftones print on both color and black-and-white printers. See “About Halftones” later in this section.

**COLORING TEXT, PARAGRAPHS, AND BORDERS**

Whether you choose a color for text, a paragraph background, or a border, a dialog box presents the color controls in the same way.

**To use color...**

1. Select text or position the text cursor in the paragraph containing the border or background you want to color, then choose the appropriate color command.
   - **Text** Choose Text Color from the Styles menu
   - **Paragraph background** Choose Paragraph Color from the Paragraph menu
   - **A border** Choose Border from the Paragraph menu, then choose Border Color from the cascade menu. Tab lines within a border are also colored when you color the surrounding border

In addition to the preset 16 colors, you can vary the concentration of red, green, and blue to create custom colors.

1. Click to select the color of your choice.
2. To create a custom color, use the arrows to vary the amount of Red, Green, or Blue from 0 to 255.
3. To lighten the concentration of color, change the Halftone setting to Light (15%), Medium (25%), or Dark (50%). (See “About Halftones,” later.)
4. Click Apply to see the change.
5. When satisfied, click Close.

**CREATING WHITE-ON-BLACK TEXT** You can add the sharp look of white type against a black background with the Paragraph Color option.

**To create white-on-black text...**

1. Select the text you want to change.
2. Choose Text Color from the Styles menu.
3. Click White on the color palette and click Apply. The selected text “disappears” (becomes white on white) until you add color to the paragraph background.
4. Choose Paragraph Color from the Paragraph menu.
5. Click the black square (or other color square) on the color palette.
6. Click Apply. The white type that you selected or any that you now type becomes visible against the dark background.
ABOUT HALFTONES GeoWrite provides four halftone settings that you can apply to text, borders, and backgrounds. Halftones change the concentration of a color by reducing the number of pixels—dots on the screen—that display the color, forming a pattern of very tiny dots. Newspapers use halftones when they reproduce photographs; if you look at a photo with a magnifying glass, you'll see that the "colors" (well, shades of grey) are actually made from patterns of little black dots. It's the same way with GeoWrite. On the printed page, the ink is screened according to these percentages (with solid color being 100%, and white—no color—being 0%):

<table>
<thead>
<tr>
<th>Setting</th>
<th>Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solid</td>
<td>100%</td>
</tr>
<tr>
<td>Dark</td>
<td>75%</td>
</tr>
<tr>
<td>Medium</td>
<td>50%</td>
</tr>
<tr>
<td>Light</td>
<td>25%</td>
</tr>
</tbody>
</table>

Halftones work with both color and monochrome systems.

To apply halftones...

1. Select the text, or merely click to place the text cursor in a paragraph if you want to apply a halftone to its border or background.

2. Choose
   - Text Color from the Styles menu (for text).
   - Paragraph Color from the Paragraph menu (for the background color of the paragraph).
   - Border from the Paragraph menu and then Border Color (to color the paragraph's border).

3. Choose a color from the dialog box that appears.

4. Select a Halftone setting: Solid, Light, Medium, or Dark.

5. Click Apply to see the change.

6. When you're finished, click Close.

INSERTING GRAPHICS

Graphic elements that you create in GeoDraw (or scraps collected in a scrapbook) can be copied to the clipboard, then pasted directly into your GeoWrite documents. The graphic appears in your document at the current insertion point, and the line leading automatically increases to accommodate the graphic, unless you have chosen manual leading (in which case the leading stays the same and the graphic spills over to other lines). These graphics then behave much like text. Move it forward on a line by inserting spaces in front of it (using the Spacebar), or move it to the next line by inserting a line before it (by pressing Return). You can double-click to
select it as you would a word, and use the Cut, Copy, and Paste commands to relocate or duplicate it.

**HIDING GRAPHICS** Complex graphics take a long time to draw on the screen and consume a lot of your computer's valuable memory. If your document contains detailed graphics, you can make scrolling and screen drawing go faster and conserve memory by turning off the Draw Graphics option (in the Options menu). This replaces each graphic with a simple rectangular placeholder. To see the actual graphic again, turn the Draw Graphics option back on.

**ADDING A HEADER AND FOOTER**

GeoWrite automatically creates areas for headers and footers on every page of your document. Choose a page—any page—and type text or place graphics in the footer or header area (or both). Whatever you place there appears on all pages of the document. Well, there are a couple of exceptions. If you turn the Title Page option on (see "Creating a Title Page" later in this chapter) the header and footer are suppressed on the first page of your document—useful for cover pages. The other exception arises if you've selected Alternate Left and Right Margins in Page Setup. In this case, the document has alternating headers and footers (one for the odd-numbered pages and one for the even-numbered pages). Therefore, you must make changes on both an even- and odd-numbered page to have the changes appear on both left and right pages.

Headers and footers physically occupy the area between the margin of the document and the *printing* edge of the paper (this is usually 1/4 inch or 18 points in from the real edge of the paper). With a standard margin of one inch and a printing margin of 1/4 inch, the default header or footer is 3/4 of an inch high. Since you cannot easily adjust the printing edge of the paper (this is often permanently set), you adjust the height of the header or footer by changing the Top or Bottom Margin settings in the Page Setup dialog box.

Edit a header or footer just as you would text in the body of the document.

All of the ruler and text controls are available and operate in the same way in the header and footer areas as they do in the body area of the page. For example, you can center text in a header by selecting the text and clicking the center justification icon on the ruler.

**To resize a header or footer...**

2. To make the header area larger, increase the top margin. The header automatically expands to fill the area between the top margin and the printing edge of the paper. To make the header area smaller, decrease the top margin. In the same way, increase and decrease the size of the bottom margin to change the size of the footer.
To remove a header or footer...

2. To remove the header area, decrease the top margin to the lowest possible setting—0.25 inch (18 pt)—which leaves no room for the header area. Similarly, to remove the footer area, decrease the bottom margin to the lowest possible setting (0.25 inch or 18 pt).
3. Click OK. If the header or footer area contains text, the text reappears when you open the header or footer area back up.

Creating a Title Page

You can add a special page to your document that does not have any header or footer information. This is useful if you are printing a report with a header and footer but you don’t want them to appear on the cover page. With the Title Page option on, GeoWrite starts the header and footer (and page numbering) on the second page of the document.

To create a title page...

1. Choose Page Setup from the File menu.
2. Select Yes for Title Page and click OK. The first page of your document becomes the title page, while the second page becomes page one. The header and footer areas disappear from the title page and the page indicator on the ruler reads “Page: TP”—indicating that you are now on the title page.

To go to the title page...

Click the left arrow beside the page indicator on the ruler until the page indicator reads “Page: TP” and you see the title page. Or, choose Go To Beginning from the Window menu.

To remove a title page...

1. Choose Page Setup from the File menu and select No for the Title Page option.
2. Click OK.

Inserting the Page Number

Like everything else in the header or footer, Page numbers placed there appear on every page of the document. GeoWrite keeps track of all the pages in your document, renumbering when you remove pages, and automatically numbering new ones. If you have a title page, page numbering skips the title page and starts on page one.

To insert automatic page numbers...

1. Click the text cursor in either the header or footer.
2. Choose the font, size, and style that you want from the appropriate menus. If you want to center the page number, click the center justification icon on the ruler. Or, if there is other text in the header or footer, use a center tab to place the number rather than centering the whole line.
3. Type a prefix if you wish, such as a dash or the word “Page” followed by a space.
4. Choose Insert Page Number from the Edit menu. The page number appears at the text cursor and updates automatically on each page.
ADDING PAGE BREAKS

As you add text and graphics to a document, GeoWrite automatically creates new pages (or columns) to accommodate your text. Because GeoWrite gives you a page-by-page view of a document, you can easily see where these pages and columns begin. When you see a break that does not naturally occur in the right place (like before a new chapter) you can add a page (or column) break by choosing the Insert Page Break command from the Edit menu.

To insert a page break...
1. Position the text cursor where you want the page or column break to occur.
2. Choose Insert Page Break from the Edit menu.
   You can also press [Ctrl] [Return] to insert a page break.

To delete a page break...
1. Position the text cursor at the top of the page or column that you started with a hard page break.
2. Press [Backspace] to delete the inserted page break. Text reflows automatically between the columns or pages.

For example, if you insert a page break so that a paragraph starts at the top of the next page, then later change your mind, position the text cursor before the first word of that paragraph and press [Backspace] to back up and delete the page break.

WORKING WITH COLUMNS

GeoWrite allows you to create newsletter, book, or brochure layouts by arranging text in two, three, or four evenly spaced columns per page. On the screen, the area of each column is outlined with a dotted line, and empty columns are colored grey. Through the Page Setup dialog box, you can add vertical rules of varying widths to separate them, and you can control the width of columns by changing the spacing between columns.

To create multiple columns...
1. Choose Page Setup from the File menu.
2. Select one of the Columns choices: 2, 3, or 4 columns. When you choose to have more than one column, the Spacing and Rule Width controls become selectable.
3. Change the spacing between the columns by adjusting the Spacing control. Click the arrows or type a new value from 0.175 inch to 1 inch.

A GeoWrite document with three columns. Only the first one has text in it, so the other two are grayed out.
4 Adjust the Rule Widths setting to add a vertical rule between the columns. The width can vary from 1 point to 9 points (0.175 of an inch). To delete the rule, set the Rule Width to zero.
5 Click OK to apply the changes to your document.

To add column breaks...
1 To start text at the top of a new column, position the text cursor where you want the text to break.
2 Choose Insert Page Break from the Edit menu (or press Ctrl (Return)). The text cursor moves to the top of the next column.

To delete column breaks...
1 Position the text cursor at the top of the column following the inserted column break. For example, if you have a column break before a heading and change your mind, position the text cursor before the first word of the heading.
2 Press Backspace to back up and delete the column break. The heading and text automatically flow back into the available space in the previous column.

CUSTOMIZING GEOWRITE

The Options menu gives you several commands that let you tailor GeoWrite to your liking. They are:

- **Draw Graphics**
  Turn this Option off to have GeoWrite replace complicated graphics with temporary rectangular placeholders—for faster scrolling and minimal memory use. Turn it on to actually see your graphics.

- **Align Ruler With Page**
  When this option is on, it aligns the ruler to the edge of the paper. Otherwise, when off, the ruler aligns to the left margin.

- **Snap to Ruler Marks**
  Use this option to make tab alignment easier. When on, any tab you move or add will snap exactly to one of the 1/8 inch marks on the ruler. When off, you can move or add tabs to spots in between the 1/8 inch marks—giving you finer placement, but less accuracy.

- **Show Ruler Top**
  When on, the top portion of the ruler—showing the “tick” marks that give the ruler its name, as well as the tab stops—is visible in the GeoWrite window. When off, the top of the ruler is hidden.

- **Show Ruler Bottom**
  When on, the bottom portion of the ruler is visible, showing you the Page indicator, the tab well, and the justification and line spacing indicators. When off, the bottom of the ruler is hidden.

- **Show Horizontal Scroll Bar**
  Shows or hides the horizontal scroll bar.
Show Vertical Scroll Bar Shows or hides the vertical scroll bar.

Show All Choose this to turn on all of the above four items (Show Ruler Top, Show Ruler Bottom, Show Horizontal Scroll Bar, and Show Vertical Scroll Bar).

Hide All Choose this to turn off the four items (Show Ruler Top, Ruler Bottom, Show Horizontal Scroll Bar, and Show Vertical Scroll Bar).

Measurement Units Gives you a cascade menu from which you can choose the units that appear on the ruler: English, Metric, or the System Default.

Spell Checker Options See “Checking the Spelling in Your Documents.”

Save Options Choose this to save the current settings in the Options menu. That way, the next time you start GeoWrite (no matter what document you may be opening) these settings will automatically take effect.

CHECKING THE SPELLING IN YOUR DOCUMENTS

The GeoWrite spelling checker checks the spelling of words in your document by looking them up in two electronic dictionaries. The first, the system dictionary, is a permanent, 100,000-word American English dictionary. The second, the user dictionary, is empty until you add your own special words. When the spelling checker finds a word in your document that’s not in either of these dictionaries, it flags the word as “unknown” and stops to allow you to correct it.

A spelling check begins when you select Check Spelling from the Edit menu. This brings up the Check Spelling dialog box, the “control room” for the spelling checker. It’s from here that you steer the spelling checker through your document, correct unknown words as they pop up, and edit your user dictionary. When the spelling checker stops for a word not in a dictionary, you can either add it to the user dictionary or skip it. If you add it to the user dictionary, it is ignored in future spelling checks. Personal names like Murtnik and Munster, if used frequently, are good candidates for the user dictionary.

A spelling checker has two important limitations. It can’t tell if you’re using a correctly spelled word incorrectly—for example, “your” when “you’re” is actually right for the sentence. Nor can it identify a word that is misspelled if the misspelling is also a word. It won’t catch a case where you mistype “found” as “fund,” since the latter is indeed a word.

CHOOSING A STARTING POINT Before you check your document, you must tell the spelling checker where to start and how far in the document to go. The spelling checker allows you to check three different portions of your document:

Note: You can change your starting point even after you’ve started a spelling check. Just click at a new place in your document, and then click one of the three start buttons again.

To check a single word or section of text...

1. Double-click a word, triple-click a paragraph, or drag the pointer to select a range of text. (Don’t worry about only selecting part of a word—the spelling checker still checks the entire word.)
2. Choose Check Spelling from the Edit menu or press [F5].
3. Click Check Selection in the Check Spelling dialog box. The spelling
checker checks only the word you’ve selected.

**To check from the text cursor to the end of the document...**

This option is great for continuing a check after you’ve stopped to do some major repairs in the middle of your document.

1. Click somewhere in the document to position the text cursor, but don’t actually select anything.
2. Choose Check Spelling from the Edit menu or press [F5].
3. Click Check to End of Document.

**To check the whole document...**

1. Make sure that no text is selected.
2. Choose Check Spelling from the Edit menu or press [F5].
3. Click Check Entire Document.

**TAKING CARE OF UNKNOWN WORDS** When the spelling checker finds a word in your document that’s not in either of the dictionaries, it does several things. It highlights the word in the document (you may need to move the Check Spelling dialog box to see the word); it places the word in the box labeled “Unknown Word”; and it gives you several ways to fix the word:

- To ignore the word and move on, click Skip. This tells the spelling checker that the word is spelled correctly but you don’t want it added to the user dictionary. The next time it finds this word, the spelling checker stops again. Click Skip All to ignore other occurrences of the word until the Check Spelling dialog box closes (usually when the check is complete). Turn off the “Reset Skipped Words List When Spelling Check Complete” option to have the spelling checker continue to ignore this word in other documents.

- To replace the word with another word, type the correct word in the Replacement Text box. Click Replace to replace this instance only, or Replace All to replace every occurrence of the misspelled word in the document.

![Image](https://example.com/image.png)

The Check Spelling dialog box, the “control room” for the spelling checker. On the bottom row, click any of the three “start” buttons to begin checking your document. The Unknown Word box shows the flagged word. Next to it is the Replacement Text box, where you type in the corrected word. The Suggestions List on the right lists words that are similar to the Unknown Word.
Shortcut: Select the Unknown Word and Quick Copy it to the Replacement Text box.

• To have the spelling checker suggest a replacement, click Suggest Spellings. The spelling checker then searches its dictionaries to find words similar to the unknown word. The spelling checker displays its findings in the Spelling Suggestions box. Use the scroll bar to move through the list. If the correct word isn't listed, you can click Suggest from User Dictionary to have the spelling checker look for possible replacements in the user dictionary.

If you find the correct word in the list, select it. The word appears in the Replacement Text box, where you can change it if you like. When you are satisfied with the Replacement Word, click Replace (or click Replace All if you want to replace all occurrences of the misspelled word).

Shortcut: Double-click a word in the Suggestions list to have it automatically replace the unknown word.

• To add the word to the user dictionary, click (not surprisingly) Add to User Dictionary. With the word recorded in the user dictionary, the spelling checker does not stop if it encounters the word again, in this or any other documents.

EDITING THE USER DICTIONARY The system dictionary supplied with GeoWrite contains over 100,000 words, a lot when you consider the number of unique words in the typical business letter or report, but a relative drop in the bucket compared to the number of words in the English language itself. The Oxford English Dictionary, by comparison, lists over half a million.

This is where the user dictionary comes in. When the spelling checker flags words that you think should be in a dictionary, but aren't, simply click the button labeled “Add to User Dictionary” and the word is added. From that point on, the spelling checker will not flag the word again, even if it's used in other GeoWrite documents.

You can add and remove specific words from the user dictionary at any time by clicking the Edit User Dictionary button.

To add a word to the User Dictionary...

1. Making sure that no text is selected, choose Check Spelling from the Edit menu or press $F5$.
2. Click Edit User Dictionary.
3. Type the word in the New Word field and make sure it's spelled correctly.
4. Click Add New Word. Since it's now part of the dictionary, the spelling checker won't stop for it in subsequent spell checks.

To remove a word from the User Dictionary...

1. Choose Check Spelling from the Edit menu or press $F5$.
2. Click Edit User Dictionary.
3. Select the word in the Words in User Dictionary list and click Delete.
Selected Word. The word is removed from the dictionary, and the spelling checker stops for it in subsequent spell checks.

CUSTOMIZING THE SPELLING CHECKER The spelling checker is not entirely set in its ways—you have some say in how it goes about its business of checking your documents. For instance, when it finds an unknown word, it usually waits for you to click Suggest Spellings before it looks up possible replacements. By changing one of the options, you can avoid a step by having the spelling checker look up replacement words automatically—without waiting for you to click the Suggest Spelling button.

To change the Spelling Checker options...
1. Choose Spell Checker Options from the Options menu. A cascade menu with three check boxes appears. Turn the settings on or off as you like:

   ![Spell Check Options](image)

   **Automatically Suggest Spellings** With this option on, the spelling checker automatically looks for suggested spellings when it finds an unknown word. With the option off, you must click Suggest Spellings to see suggestions. Note that when on, this option can slow you down significantly if you’re working on a slow computer.

   **Automatically Start Checking Selections** Normally this option is on. When you select some text and choose Check Spelling, the spelling checker automatically begins checking the selection rather than waiting for you to click the Check Selection button. But when you turn this option off, you must click the button before it will check.

   **Reset Skipped Words List When Spell Check Complete** When you click Skip All, the spelling checker skips every occurrence of the misspelled word. With this option on, the spelling checker only skips the word until the spell check is complete. After that, the word is once again fair game, and the checker flags the word when it finds it.

   With the option off, the spelling checker keeps on skipping the word until you close GeoWrite or shut down GeoWorks Pro. It also skips the word when you check the spelling of other documents (that is, if the documents are open within the same GeoWrite).

2. When finished, click anywhere outside the cascade menu to close it.

TRANSFERRING FILES BETWEEN GEOWRITE AND OTHER WORD PROCESSORS

Although most word processors seem pretty much the same, the internal formatting of their documents is not. This means you can’t take a document created with one word processor and simply open it in another. GeoWrite can’t open documents created by other word processors, and they in turn can’t open documents created by GeoWrite.

But, if you want to transfer the text in one document from another word processor to GeoWrite, or vice versa, there is a way. Most word processors, page layout programs, and even some spreadsheets can save a document as a simple DOS text file, and load information from such files. Text files (also known as ASCII—American Standard Code for
Information Interchange—files) contain all the letters, numbers, and some of the special characters of a document, but not the formatting information. They contain no italics, boldface, extra fonts, paragraph spacing, colors, or any of the other things that add pizzazz to GeoWrite documents.

**To bring a text file into GeoWrite...**

Remember that when you import a text file into GeoWrite, it comes in with almost no formatting at all. You can, however, add italics, boldface, and other flashy things to your document once it’s been imported.

1. Open a GeoWrite file, or select New from the File menu to create a new document.
2. Click to place the text cursor where you’d like to insert the imported text, or select text you would like the imported text to replace. Keep in mind that the imported text takes on the same style as the text at the insertion point.
3. Select Insert From Text File from the File menu. A file selector dialog box appears.
4. Find the file you want to import, changing directories if necessary, and double-click the name of the file. The contents of the file are placed in your document at the current insertion point.

**To save a GeoWrite documents as a text file...**

You can save any GeoWrite document as a text file. Again, this text file won’t look the same as the original, since it’ll lose most of its formatting (one exception: tabs are kept, although the tab stops are not). But you will be able to import this text file into other word processors.

Also note that the file won’t be saved with carriage returns at the end of each line. You’ll only find carriage returns in the text file where you specifically pressed Return in the GeoWrite document—that is, at the end of paragraphs.

1. Open a GeoWrite document.
2. Select Save as Text File. A file selector appears.
3. Type in a DOS filename. Since your document is being saved as a regular DOS text file—not as a GeoWorks document—you must give the document a legitimate DOS filename (for the definitive word on DOS file names, see your DOS manual).
4. Click Save. GeoWrite saves a separate text version of your document, leaving your actual document unaffected.

![The Save as Text File dialog box. Choose a directory and enter the name for the text file. Note that the name needs to be a standard DOS file name.](image)
The Notepad is a simple text editor, which makes it ideal for quickly jotting down notes that don’t require the full font and formatting power of GeoWrite. And, since it works specifically with DOS text (ASCII) files, it’s also great for creating and editing DOS files, like AUTOEXEC.BAT.
THE NOTEPAD WINDOW

While at first glance the Notepad window may resemble GeoWrite's, it's really much more sparse. There is no ruler underneath the menu bar, since the kind of formatting control—justification, adjustable tabs, line spacing, etc.—found on the ruler isn't found in the Notepad. In fact, there's simply a large area where you can type, and the menu bar.

When you start the Notepad, it automatically opens the file NOTES.TXT. If the file doesn't exist in the DOCUMENT directory, the Notepad creates it there for you.

USING THE NOTEPAD

The Notepad is easy to use. You create, type in, edit, and save Notepad files the same way you do in any other GeoWorks application. See the “Basic Tools and Skills” chapter for information on both working with files and editing text.

Although the Notepad may seem a lot like GeoWrite, keep in mind that there are differences between the two, as shown in the table below.

CHANGING THE TEXT SIZE

Although the Notepad doesn't give you the kind of text size control that you find in GeoWrite—where you can make one word larger or smaller than the surrounding words—the Notepad does let you make all the text in the window larger (and easier to see) or smaller (so that more fits on the screen).

To change the text size...

Choose the size you want from the Sizes menu. You'll see all the text in the window change to the size you chose. Keep in mind, though, that this only changes the text in the window. The text size information isn't saved as part of the file, and the file prints at 10

THE NOTEPAD VS. GEOWRITE

<table>
<thead>
<tr>
<th></th>
<th>Notepad</th>
<th>GeoWrite</th>
</tr>
</thead>
<tbody>
<tr>
<td>Can open</td>
<td>DOS files</td>
<td>GeoWrite files</td>
</tr>
<tr>
<td>Files open at once</td>
<td>ONLY ONE</td>
<td>MANY</td>
</tr>
<tr>
<td>Document safeguarding</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>Indents, spacing, etc.</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>Fonts and text sizing</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>Pagination</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>Maximum File Size</td>
<td>10,000 chars</td>
<td>UNLIMITED</td>
</tr>
</tbody>
</table>
point no matter what size the text is on the screen. Also, the size setting stays in effect even when you close the current file and open a new one.

OPENING, CLOSING, AND SAVING NOTEPAD FILES

With the Notepad, you can only have one file open at a time. So, you must close the current file before you can open a new one. (Or, you can start Notepad a second time.)

Follow the DOS naming conventions (eight characters, optionally followed by a period and three more characters) when you save a Notepad file, as it is a standard DOS text file and not a GeoWorks document. Also, since it only works with DOS files, the Notepad does not support document safeguarding. This means that you need to be sure to save the file whenever you make important changes.
The Preferences application helps you tailor GeoWorks Pro to work with your particular computer system. Use it to adjust various hardware options like printer and modem settings, and software options like size of the font used in menus and dialog boxes.
THE PREFERENCES WINDOW

When you start the Preferences application, the Preferences window appears. The window is filled with buttons that you click to change different groups of options. Here's a list of the Preferences buttons and what they do.

**Look and Feel** Changes the size of the text in menus and dialog boxes, and how often GeoWorks Pro automatically safeguards open documents.

**Date and Time** Changes the computer's internal date and time settings.

**Background** Changes the picture that fills the workspace background.

**Sound** Changes the GeoWorks Pro sound setting. (Keep in mind that when the sound is off, GeoPlanner's alarms are silenced.)

**Printer** Changes the brand of printer you're using and the port to which it's connected.

**Computer** Changes the type of additional memory present in your computer and other hardware options.

**Video** Changes the type of video monitor you're using and the screen saving interval.

**International** Changes the standard currency symbol, decimal point, quotation mark, long date, short date, and time formats.

**Keyboard** Changes the type of keyboard you're using, or the way that the GeoWork Pro responds to your keyboard.

**Mouse** Changes the brand of mouse you're using, its responsiveness, and how quickly you have to click to do a double-click.

**Modem** Changes the port, speed, and protocol options for your modem.

**PC/GEOS** Internal GeoWorks Pro options (not normally changed).
CHANGING THE LOOK AND FEEL

You can increase the size of the system text to make it easier to read. System text appears in menus, menu bars, window title bars, and dialog boxes. You can also change how often applications safeguard open documents by saving temporary copies of them. (If your computer shuts down when your in the middle of something, your last safeguarded version of the document will come up when you restart.) GeoWorks Pro must restart for the changes to go into effect.

To change the size of the system text...
1. In the Preferences window, click Look & Feel. The Look & Feel dialog box appears.
2. Choose small, medium, or large GeoWorks Pro system text. Underneath the settings is some sample system text, so you can see how each of the choices look. Your new setting, though, won’t take effect until GeoWorks Pro shuts down and starts up again.
3. Click OK, or click Reset to leave the options unchanged.

To change document safeguarding...
1. In the Preferences window, click Look & Feel. The Look & Feel dialog box appears.
2. Turn the Document Safeguard feature on or off by clicking On or Off.
3. Set the interval between safeguards by entering a new Time in minutes.
4. Click OK, or click Reset to leave the options unchanged.

To bypass the Welcome Screen...
1. Click Look & Feel. The Look & Feel dialog box appears.
2. Choose where you’d like to end up when you start GeoWorks Pro: the DOS Programs screen, the Intermediate Workspace, the Advanced Workspace, or the Welcome screen (the standard setting).
3. Click OK.

To control overstrike mode...
Choose Via insert key if you want to be able to toggle between overstrike and insert mode while in GeoWorks Pro. Click Always disabled if you want to always use insert mode (standard).

CHANGING DATE AND TIME

Your computer has a built-in clock that tracks both the date and time, which you can change with the Date & Time dialog box. New date and time settings take effect immediately.

To change the date and time...
1. Click Date & Time. The dialog box appears.
2. Change the date. You may enter the date in one of two ways: 5/25/90, or 10/29/1990.
3 Change the time. Enter the new time in 12-hour format, and enter am or pm along with the time: 10:25 am
4 Click OK to update the built-in clock, or click Reset to leave the date and time unchanged.

If you change the format of the date and time in the International section of Preferences, you must enter dates and times in those formats.

CHANGING THE WORKSPACE BACKGROUND

You can fill the Advanced Workspace background—the grey area behind all the windows—with a picture. GeoWorks Pro comes with several different background pictures, or you can create your own. Any change to the background takes effect immediately.

To change the workspace background...

1 In the Preferences window, click Background. The Background dialog box appears.
2 Select the name of the background picture that you want from the Backgrounds Available list.
3 Select the way you want to place the background on the screen:
   • Place graphic in upper-left of screen The left edge of the picture is placed against the upper left edge of the screen.
   • Place graphic in center of screen The picture is centered on the screen. If it is smaller than the screen, then the surrounding area is filled with the regular solid background.
   • Tile graphic to fill screen The picture is repeated across and down the screen, covering the entire screen the way tiles cover a wall.
4 Click Apply to make the current picture your workspace background. The background immediately changes. (To see the results, it helps to first minimize all the application windows, including GeoManager.)
5 If you don't like the background picture, choose another and click Apply.
6 Click Close when you finish.

ADDITION TO BACKGROUND IMAGES You can add some color to your black-and-white background images by clicking one of the color squares.

To change the color of your background...

1 In the Preferences window, click Background. The Background dialog box appears.
2 Click one of the Background Color buttons to select the desired color for the background. This option will not
appear if you have a black and white monitor.

3 Click Apply. The background changes color.

This setting only affects black-and-white background images (or the standard solid background). The color black is replaced with the chosen color, giving you, for example, a red-and-white image. Or a blue-and-white image.

CREATING A BACKGROUND IN GEODRAW Anything that you can create in GeoDraw can become an Advanced Workspace background image. And we mean anything. You can include text, colored shapes, TIFF (Tag Interchange File Format) and PCX (PC Paintbrush) images—anything that you can do in GeoDraw.

To create a background picture using GeoDraw...

1 Create a picture in GeoDraw.
2 Select all of the objects in the picture. You can drag to select the objects, or hold down the Control key and select them individually, or—easiest of all—choose Select All from the Edit menu.
3 Choose Copy from the Edit menu. This copies the picture to the clipboard.
4 Switch to Preferences and click Background. The Background dialog box appears.
5 Click Get Background From Clipboard. A dialog box appears asking you to enter a file name.

6 Enter a name and click OK. This copies the picture from the clipboard to the new file, and also immediately displays it as the background. The file name appears in the Backgrounds Available list, so you can select this picture again at a later date.

CONTROLLING THE SOUND

You can turn GeoWorks Pro's sounds on or off by clicking Sound. The setting here affects sounds throughout GeoWorks Pro, and this can lead to some unexpected consequences—for instance, turning off the sound also silences GeoPlanner's alarms. Your new sound setting takes effect immediately.

Using GeoDraw to create a background...

1
2
3
4
5
6

To turn all GeoWorks Pro sound on or off...

1 Click Sound in the Preferences window. The Sound dialog box appears.
2 Click On or Off.
3 Click OK.
CHANGING PRINTERS

Before you can print anything, you need to tell GeoWorks Pro what printer you have and what communication port it’s connected to. Of course, you must install at least one printer before you can print anything. After that, though, you can install as many as you like. Any changes you make take effect immediately upon closing the Printer dialog box. You can test your printer by clicking Test.

To install a new printer...
1 In the Preferences window, click Printer. The Printer dialog box appears.
2 Click Install New. A second dialog box appears. (See picture below.)
3 From the Printer list, click to select the brand name of the printer you wish to install. Scroll the list to see all the choices. (A quick way to find a printer is to type the first letter of the printer name.)
4 From the Port list, click to select the communication port you’ve connected the printer to. Each port corresponds to a socket at the back of the computer—although not all computers have a port for every port in the Port list.
   As a rule of thumb, most parallel printers plug into LPT1, while most serial printers plug into COM1. (No guarantees, though.)

5 If you’ve chosen one of the serial ports from the Port list (COM1, COM2, COM3, or COM4), click Serial Port Options to configure the serial port to match the settings of your printer. Unfortunately, they have to match exactly. If you’re not sure what the settings should be, consult your printer’s documentation.

6 Normally the Printer Name box contains the brand name of the printer and the port it’s connected to. This is the text that shows up when you use the Print command of an application. You can change this text to anything you like.
   For example, you could change the Printer Name to a more descriptive one like “Speed of Light Laser Printer” or “Creaky Old Dot Matrix Printer.”
7 Click OK. The dialog box closes, leaving you at the Printer dialog box again.
8 Click Close to close this dialog box.
To change a printer's configuration...
Even after installing a printer, you can change the brand of printer, the communication port it's connected to, and the assigned Printer Name.
1 In the Preferences window, click Printer. The Printer dialog box appears.
2 From the Printers Installed list, click the name of the printer you wish to configure and then click Edit. A second dialog box appears. (See the picture at the bottom of the previous page.)
3 Change one or more of the three items in the dialog box—the brand of printer, the communication port, and the assigned Printer Name.
4 Click OK when you're finished. The dialog box closes and the Printer dialog box shows again. If you've changed the Printer Name, the new name shows in the Installed Printer list.
5 Click Close to close the Printer dialog box.

To delete a printer from the list of printers...
1 In the Preferences window, click Printer. The Printer dialog box appears.
2 From the Printers Installed list, click the name of the printer you wish to delete from the list.
3 Click Delete. A dialog box appears asking you if you want to delete the printer. If you still want to, click OK to actually delete it.
4 The printer is removed from the list of Installed Printers.
5 Click Close to close the Printer dialog box.

To print a test page on a printer...
1 In the Preferences window, click Printer. The Printer dialog box appears.
2 From the Printers Installed list, click to select the name of the printer on which you want to print the test page.
3 Click Test. The selected printer should immediately begin printing a test page. If nothing happens or gibberish prints out, you should check the printer's switches and perhaps change its configuration (see above). For persistent problems, check the Customer Service/Troubleshooting Guide.
4 Click Close to close the Printer dialog box when you're done.

CHANGING COMPUTER OPTIONS

Computer options let you tell GeoWorks Pro what memory configuration your system has. Use this preference when you change the kind or amount of memory in your computer. You can also correct the settings you entered during setup if they are wrong. If you know what you are doing, you can change the interrupt levels of the serial and parallel ports, as well. GeoWorks Pro must restart for the changes to go into effect.

To change your memory settings...
1 Click Computer in the Preferences window. The Computer dialog box appears.
2 Choose the types of additional memory that you have installed in your computer:
• **None**  No memory beyond 640K is installed.

• **Expanded memory (LIM EMS)**  If you added memory to an original PC or XT, you probably added expanded memory.

• **XMS/HIMEM.SYS**  If you have a file called HIMEM.SYS, QEMM.SYS, or EMM 386.SYS, you have managed extended memory.

• **Extended**  If you have an AT (286), 386, or 486 machine, you probably have extended memory. (Of course, you may also have expanded memory.) You may select more than one of the options. If you don't know which types you have, you can select all three.

  1. Click OK when you finish, or click Reset to leave the options unchanged.

**To change the interrupt levels of the serial and parallel ports...**

  1. Click Computer in the Preferences window. The Computer dialog box appears.
  2. Change the interrupt levels of the various serial and parallel ports. You shouldn't change these settings unless you're very familiar with the inside workings of the PC.
  3. Click OK when you finish, or click Reset to leave the options unchanged.

**CHANGING VIDEO OPTIONS**

Use the Video preferences to tell GeoWorks what video adapter you are using, when you change adapters. You could use setup newvideo to do this, but it's generally easier to use Preferences—though it can turn into a "catch 22" situation in some cases. To wit: your new adapter must be installed before you change your video settings, but if you do, it's possible that you won't be able to start GeoWorks Pro, since the as-yet unchanged video settings don't match. Fortunately, you're only likely to encounter this problem if you're changing from a more powerful adapter (say, VGA) to a less powerful one (EGA). In these cases, use Setup.

The video setting also controls the "screen blanking." When you leave an image at the same place on your screen for a long time, there's a possibility the image may become permanently burned into the screen—that is, you see a ghost outline of the picture even when the video screen is completely turned off. You have GeoWorks Pro blank the screen automatically when the computer is idle. When you move the mouse or press a key, it turns the picture back on. In addition to turning this feature on and off, you can set how long GeoWorks Pro waits before blanking the picture.

**To configure GeoWorks Pro for a new video adapter...**

  1. Click Video in the Preferences window. The Video dialog box appears.
  2. Click Change.
  3. Select the appropriate adapter from the Change Video Type list. Click OK when you finish.
  4. Click OK. The dialog box disappears.

GeoWorks Pro must be restarted for the changes to take effect. For this
reason, you should install the new video adapter before changing the Video preferences (see the note at the beginning of this section). If GeoWorks Pro fails to work after you’ve installed the new adapter, use setup newvideo to change your video settings.

To turn automatic screen blanking on or off...

1. Click Video in the Preferences window. The Video dialog box appears.
2. Turn the Screen Blanking setting On to have GeoWorks Pro automatically blank the screen after you leave your computer alone for a period of time. Turn Screen Blanking Off to keep GeoWorks Pro from blanking the screen.
3. In the Time box, enter the length of time in minutes your computer must be idle before GeoWorks Pro blanks the screen.
4. Click OK when you’re finished, or Reset to leave the options unchanged.

The screen blanking option takes effect immediately.

CUSTOMIZING GEOWORKS PRO FOR OTHER COUNTRIES

You can change the standard currency symbol, decimal point, quotation mark, long date, short date, and time formats to conform to those used outside the USA. Any changes you make in the International dialog box are reflected in the Example field. GeoWorks Pro must restart for changes to go into effect.

CURRENCY FORMAT

With GeoWorks Pro’s Currency formatting options, you can change the appearance of currency values for international currencies.

To change currency formatting...

1. Click International. The International dialog box appears.
2. Double-click Currency, or click Currency and then click Edit. The dialog box for currency formatting appears.
3. Change the format by clicking the arrows. You have these options:

The International dialog box.
Choose one of the categories on the left and click Edit. A second dialog box will appear that lets you change that particular format.
• Symbol & Negative Placement
Changes the placement of the currency symbol and negative sign.

• Space around symbol
Sets the distance between the symbol and value.

• Symbol
Sets a different currency symbol. Type in any symbol.

• Leading zero
Turns leading zeroes on and off.

• Decimal Digits
Sets the standard number of decimal places.

When you finish changing your settings, click OK. The dialog box disappears.

NUMBER FORMAT AND MEASUREMENT UNITS
You have control over the way numbers are presented, as well as the standard measurement system (English or Metric) used in GeoWrite.

To change number formatting...
1. Click International. The International dialog box appears.
2. Double-click Number, or click Number and then click Edit. The dialog box for number formatting appears.
3. Change the format until the example on the lower left shows the formatting you want. You have these choices:
   • 1000 separator
   Changes the character used to separate thousands. The default is a comma (as in “1,000,000”).
   • Decimal separator
   Changes the decimal character. For example, some countries use a comma instead of a period for the decimal point (3,14 instead of 3.14).
   • Decimal digits
   Changes the default precision (number of decimal places). Setting this to five yields a number like “3.14159,” whereas setting it to two yields “3.14.” (This setting has no effect on the Calculator desk tool, which has its own setting.)
   • Leading zero
   Turns the leading zeroes on or off. Turning them on yields numbers like “0.25,” while turning them off gives you “.25” instead.
   • List separator
   Type in a new list separator. This is the character that shows up as the delimiter in a series of numbers (for example, “1,2,3,” where commas are the list separator).
   • Measurement system
   Use the arrow buttons to change the default measurement system to Metric or English.
4. Click OK. The dialog box disappears.

QUOTATION MARKS
Documents have more of a professionally typeset look when you use “typographer’s” quotation marks instead of straight up-and-down “typewriter style” quotes (the " mark and ’ mark). Typewriter quotes are more often used to indicate measurements in feet and inches (he’s 6’ 3” tall) or minutes and seconds of arc (as in N 38° 4’ 10”).
To use typographer's quotes...
① Click International. The International dialog box appears.
② Double-click Quotation marks, or click Quotation marks and then click Edit. The dialog box for quotation marks appears.
③ Edit the choices shown.
④ Click OK. The dialog box disappears.

LONG DATE FORMAT The Long date format shows the weekday (Sunday, for instance) in addition to the month, year, and day. As you alter the format, the example date shown changes to reflect the settings.

To change the long date format...
① Click International. The International dialog box appears.
② Double-click Long date, or click Long date and then click Edit. The dialog box for long dates appears.
③ Change the weekday, month, day, and year formats by clicking the arrows.

The second and third fields can both contain either the year, month, or day. This is so you can choose to have the day first followed by the month (as is common in Europe), or vice versa. You can also type new separator characters in the small fields between the weekday, month, day, and year fields.

SHORT DATE FORMAT The Short Date shows just the month, day, and year, and is used in windows where space is limited. As you alter the format, the sample date shown changes to reflect the settings.

To change the short date format...
① Click International. The International dialog box appears.
② Double-click Short date, or click Short date and then click Edit. The dialog box for short dates appears.
③ Change the month, day, and year formats by clicking the arrows. Type new separator characters in the small fields between the month, day, and year fields.
④ Click OK.
**TIME FORMAT** You can choose both twelve and twenty-four hour formats. As you alter the format, the sample time shown changes to reflect the new settings.

**To change time formatting...**
1. Click International. The International dialog box appears.
2. Double-click Time, or click Time and then click Edit. The dialog box for time appears.
3. Change the time formats using the arrow buttons. Type new separator characters in the small fields between the hour, minute, and second fields.
4. Click close.

**CUSTOMIZING YOUR KEYBOARD**

GeoWorks Pro provides you with several options to adapt the keyboard to how you work. In addition, you can configure GeoWorks Pro to work with different foreign keyboards. GeoWorks Pro must restart for changes to go into effect.

**To change the way the keyboard works...**
1. Click Keyboard. The Keyboard dialog box appears.
2. Choose your options. They are:
   - **Keyboard Delay** Changes how long you must hold down a key before it starts repeating.
   - **Keyboard Repeat Rate** Sets the speed at which the key repeats.
   - **Right Alt key functions like Ctrl + Alt** Makes pressing the right [Alt] key the equivalent of pressing [Ctrl] + [Alt] together. This could save you some keystrokes, depending on what you are doing. For example, to place a bullet in your document, you normally hold down [Ctrl] and [Alt] and type “8.” With this option on, you could get the same character by holding down only the right [Alt] and typing the “8.” (But be careful—you could also do a [Ctrl] + [Alt] + [Del] reset by pressing only right [Alt] and [Del].)
   - **Pressing Shift releases Caps Lock** Turns off the Caps Lock every time you press Shift. If you learned to type on a typewriter and are new to using computers, this setting may make the transition easier for you. On the other hand, if you’re accustomed to the way Caps Lock functions in DOS—that is, it stays on until you press [Caps Lock] again to turn it off—you may not want to turn this option on.
   - **Exchange Ctrl and Caps lock keys** Makes your [Ctrl] key behave like the [Caps Lock] key, and vice versa. This is handy because half the keyboard manufacturers seem to put [Caps Lock] above the [Shift] key and [Ctrl] below it, while the other half seem equally determined to put them in exactly the opposite arrangement—[Ctrl] above and [Caps Lock] below. Turn this on if your keyboard has keys that are opposite from the arrangement you like.
3. Click OK when you have made your choices, or Reset to leave settings unchanged.
To change the keyboard you are using...

1 Click Keyboard. The Keyboard dialog box appears.
2 Scroll through the Keyboard list and click on the keyboard you are using with GeoWorks Pro. If you are using a U.S. keyboard, click U.S. Keyboard; if you're using a UK extended keyboard, click UK Extended Keyboard. And so on.
3 Click OK when you have made your choice, or Reset to leave the setting unchanged.

CHANGING THE MOUSE

You can change the speed at which the pointer moves across the screen and how fast you must click to do a double-click. You can also change the brand and model of mouse that you use with GeoWorks Pro, and set interrupt levels, if necessary. The new mouse responsiveness setting takes effect immediately, but the other changes require you to restart GeoWorks Pro.

Choose a Double-Click Time, which controls how quickly you must click the mouse to do a double-click. Fast means you must click twice very quickly for GeoWorks Pro to recognize a double-click; Medium and Slow allow you to click more slowly. Double-click the Test button to try out the setting; it flashes and beeps when you've clicked fast enough.

Choose a Mouse Acceleration. This changes how far the pointer moves when you quickly move the mouse.

At the Slow setting, the pointer always moves the same distance as the mouse. At the Fast setting, however, the pointer moves much farther when you move the mouse quickly (although when you move it slowly, the pointer moves only the same distance as the mouse). Therefore, at the Fast setting, short, quick mouse movements can take the pointer all the way across the screen.

Click OK when you finish, or click Reset to leave the options unchanged. After changing Mouse Acceleration, move the mouse around to see how it feels.

To change the mouse configuration...

When you replace your mouse with a different brand or model, you need to change the Mouse Configuration settings as well.

1 In the Preferences window, click the button labeled Mouse. The Mouse dialog box appears.
2 In the Mouse Configuration section, click Change. Another dialog box appears.
3 Choose one of the brands from the list of brands.
4 If you're using a serial mouse, choose the Serial Mouse Port to which it is connected. If it's connected to COM3
or COM4, use the arrows to set the interrupt level. (See also “Setting the Mouse Interrupt Level” in this section.)

3 Click OK when you’re finished. The dialog box closes, leaving you at the Mouse dialog box again.
4 In the Mouse dialog box, click OK. You are then given some screens to test your mouse.

CHANGING MODEM OPTIONS

Before you can use your modem, you need to identify the communication port the modem is connected to and set the port’s Speed and Format options (see your modem manual for these). The settings you make here are used as standard settings by GeoComm, GeoDex, and other GeoWorks Pro applications that use a modem. New modem settings go into effect immediately.

Also, if you can’t use tone dialing with your phone line, you can have the modem do pulse dialing instead.

To change modem options...
1 Click Modem. The Modem dialog box appears.

2 Choose which serial port has the modem plugged into it—usually COM1, unless you have a serial mouse, in which case it’s usually COM2. Make sure it isn’t the same one you plugged a serial mouse into.
3 Click the Speed and Format Options button to change the transmission speed (Baud rate), parity, stop bits, and protocol. A second dialog box appears.
4 Change the options for your modem. Click OK when you’re finished. The dialog box closes, leaving you at the Modem dialog box again.

SETTING THE MOUSE INTERRUPT LEVEL

The Mouse Configuration dialog box has an Interrupt Level option. This option only applies to a few types of mouse devices, those that require a specific interrupt level. If you don’t have one of these mice, don’t worry about it—the Interrupt Level option is grayed out. If you do have one of these mice, you should check the documentation that came with your mouse to make sure that the interrupt level setting is correct.

To set your mouse’s interrupt level...
1 Click Mouse. The Mouse dialog box appears.
2 In the Type of Mouse area, Click Change. The Change Mouse dialog box appears.
3 Set the correct Interrupt Level. Your mouse’s documentation should have more information regarding the correct interrupt level.
4 Click OK.
If your phone can’t handle tone dialing, set the Dial Type to Pulse. Click OK, or click Reset to leave the options unchanged.

CHANGING INTERNAL OPTIONS

The PC/GEOS button lets you change internal options. You should not change any GeoWorks Pro internal options unless directed to do so by an authorized customer service technician. Incorrectly changing any of these options can seriously degrade the performance of GeoWorks Pro and possibly even prevent it from working at all.
The Viewer lets you look at (but not change) Quattro Pro SE and Lotus 1-2-3 spreadsheets without ever leaving GeoWorks Pro. Just double-click a spreadsheet file in GeoManager, and the spreadsheet shows up in a regular window. From there, you can copy it out to the clipboard, and paste it into reports or presentations created in GeoWrite (or any GeoWorks application). The same is true for charts and graphs created in Quattro Pro SE.
WHAT THE VIEWER DOES

The idea behind the Viewer is very simple: It gives you an easy way to integrate Quattro Pro spreadsheets and charts into your GeoWorks Pro documents. To this end, it acts like a window—you can look at your spreadsheets and charts, but you can’t edit them. (You need to use Quattro Pro to actually change them.) You can, however, copy whatever you’re looking at onto the clipboard, and from there paste them into GeoWorks applications.

The Viewer can show you a maximum of (approximately) 26 columns by 60 rows of the spreadsheet, the actual maximum depending on both the complexity of the formatting and your page size. Practically speaking, 26 by 60 is a fairly good-sized spreadsheet, so you shouldn’t have a problem viewing most spreadsheets in their entirety (but if you do have a problem, see “A Few Ways to Deal With Large Spreadsheets,” later.)

In addition to viewing spreadsheets, you can also view Quattro Pro’s Encapsulated PostScript (EPS) chart files. Be careful, though: Quattro Pro doesn’t automatically save charts in EPS format. You must “print” the chart to an EPS file, a simple procedure that ensures that all your chart information—data, labels, and annotation—is retained in the file. (See “Charts and the Viewer” later in this chapter.)

INSTALLING QUATTRO PRO SE

Before you use the Viewer, you should (if you haven’t already done so) install Quattro Pro SE on your hard disk. To make using Quattro Pro SE easier, install Quattro Pro in the QPRO directory on the same drive as the GEOWORKS directory, make sure that you answer “yes” when the Quattro Pro installation utility asks you if you want to add Quattro Pro to your DOS search path. This makes it easy for the Viewer to find and run Quattro Pro. If you install Quattro Pro in a different directory, or on a different disk, you’ll have to tell the Viewer where to find it the first time you try to open a spreadsheet. (See the beginning of the section “Changing or Creating Spreadsheets.”)

To install Quattro Pro, use the Quattro Pro SE Install program and follow the instructions it gives you (see the “Getting Started” chapter of this manual for more about installing Quattro Pro SE). The recommended answers to some of the questions that the Quattro Pro SE installation program will ask are

<table>
<thead>
<tr>
<th>Question</th>
<th>Answer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Drive</td>
<td>As appropriate</td>
</tr>
<tr>
<td>Quattro Pro Directory</td>
<td>C:\QPRO</td>
</tr>
<tr>
<td>Monitor Type</td>
<td>As appropriate</td>
</tr>
<tr>
<td>Edit AUTOEXEC.BAT</td>
<td>Yes</td>
</tr>
<tr>
<td>Printer Manufacturer</td>
<td>As appropriate</td>
</tr>
<tr>
<td>Printer Model</td>
<td>As appropriate</td>
</tr>
<tr>
<td>Graph Quality</td>
<td>Draft</td>
</tr>
<tr>
<td>Bitstream Character Set</td>
<td>As appropriate</td>
</tr>
<tr>
<td>Fonts to Build</td>
<td>None</td>
</tr>
</tbody>
</table>

‘We recommend that you let the INSTALL program add Quattro Pro SE’s directory to your path statement. This lets GeoWorks’ Viewer easily locate the Quattro Pro SE program for launching.'
shown in the table on the previous page.

**INSTALLING THE MOUSE FOR QUATTRO PRO** As you use GeoWorks applications like GeoWrite and GeoDraw, you’ll become accustomed to using a mouse for much of your work. You can also use a mouse in Quattro Pro for many of its commands, but the mouse is not automatically available to you there the way it is in GeoWorks Pro. If you want to use a mouse, and you start Quattro Pro SE and find that your mouse is not available (in other words, nothing happens when you move it) see “Installing Your Mouse” in Appendix A of the Quattro Pro SE manual.

**VIEWING A SPREADSHEET OR CHART**

Viewing spreadsheets and charts is what the Viewer is all about. It lets you open several Quattro Pro and Lotus 1-2-3 file types:

- .WQ1—Quattro Pro SE or 2.0 spreadsheet files
- .EPS—Quattro Pro SE or 2.0 chart files (in EPS or slide EPS format)
- .WK1—Lotus 1-2-3 files

**To view a spreadsheet or chart by starting the Viewer application...**

1. Start the Viewer application by double-clicking its icon in the WORLD directory. The Viewer window appears and a file selector pops up asking you to choose a spreadsheet or chart.

2. From the Document Formats box, click to select the kind of file you want to open. Only files of that type will show in the file list. (If no files appear, then there aren’t any of those types of files in the current directory.)

3. From the file list, select the actual file you want to view (change disk drives and directories as needed).

4. Click Open. A document window opens showing the spreadsheet (or chart).

When you start the Viewer application by double-clicking the Viewer icon in GeoManager (and not by double-clicking, say, a spreadsheet document), the Viewer first asks you to identify the type of document—as well as the document itself—that you want to open.
To view a spreadsheet from within the Viewer...
1. While in the Viewer, choose View from the File menu. A file selector appears.
2. Select the kind of file from the Document Formats box.
3. Click to select the file you want to view from the file list, changing disks or directories if necessary.
4. Click Open.

To view a spreadsheet or chart by opening its file in GeoManager...
1. In GeoManager, open the directory that contains the spreadsheet or chart file you want to open. Take a look at the file's three-letter extension and make sure that it's one of the supported file types listed at the start of this section.
2. Double-click the file's icon. The Viewer starts and automatically opens the file for viewing.

VIEWING ANOTHER PART OF A SPREADSHEET The Viewer is limited in the number of rows and columns it can show you—approximately 26 columns by 60 rows. These numbers depend both on the complexity of the formatting and your page size. Fortunately, you can pick which 26 by 60 region of the spreadsheet you wish to view. You do this by letting the Viewer know the starting cell. This then becomes the upper-left corner of the 26 by 60 viewing area.

Note: There is a way to view spreadsheets with an unlimited number of columns (though not a way to view one with a lot of rows). See "A Few Ways to Deal with Large Spreadsheets" in this chapter.

To set the starting cell...
1. Choose Spreadsheet Range from the Options menu.
2. Click the option “Display as much as possible, given the current page size.”
3. Type the starting cell for the 26 by 60 page. This cell becomes the upper-left corner of the spreadsheet in the Viewer window. For example, if you want to have the Viewer start at column C and row 30, type in C30. The Viewer would then show the 60 rows below this cell and the 26 cells to the right. (Remember, the 26 by 60 figure is approximate—the actual size is determined by the complexity of the spreadsheet.)

To specify a specific range of cells...
You can further limit the number of cells that the Viewer shows by calling out not only the upper-left cell, but also the lower-right cell as well.
1. Choose Spreadsheet Range from the Options menu.
2. Click “Display a block of cells.”
3. Type the upper-left and lower-right limits of the range of cells (for example, C30 and L60). The Viewer displays only the cells that are contained in that block of cells. Keep in mind, though, that the 26 column by 60 row maximum size still applies.

With this dialog box, you can change the part of the spreadsheet that you view.
VIEWING MULTIPLE SPREADSHEETS
You can view multiple spreadsheets and charts in the same way that you work with multiple documents in other GeoWorks applications, like GeoWrite. To view a second document, simply open it for viewing without closing the first one. (Choose View from the File menu, as described earlier.)

CHANGING OR CREATING SPREADSHEETS
The Viewer is for viewing your spreadsheets, not working on them. If you want to work on one—say, to change some formulas—you must launch Quattro Pro SE. The Viewer gives you several ways to do this. The method you choose depends on whether you want Quattro Pro to create a new file or open an existing one.

If you do not add Quattro Pro to your DOS search path, the first time you launch it the Viewer asks you to locate the Quattro Pro program. You'll only have to do this once, as the Viewer remembers where the Quattro program is.

To create a new spreadsheet...
1. In the Viewer, choose New from the File menu. A file selector appears.
2. Use the file selector to choose the directory where you want Quattro Pro to save the spreadsheet when you're done with it.
3. Type in a name for your new file and click Create.
4. A dialog box appears asking you if you really want to launch Quattro Pro.

Note: If you don't want to see this dialog box when you launch Quattro Pro from the Viewer, use the Advanced Options command in the Options menu to turn it off (see "Customizing the Viewer" later in this chapter.)

5. Click OK. GeoWorks Pro shuts down and Quattro Pro SE launches, opening a new empty spreadsheet with the given name. When you exit Quattro Pro SE later, you return to the Viewer. Choose View from the File menu to take a look at the file you just worked with.

To edit the spreadsheet you're currently viewing...
1. Choose Edit Spreadsheet from the Window menu. A dialog box appears asking you if you want to launch Quattro Pro SE.

Note: If you don't want to see this dialog box when you launch Quattro Pro from the Viewer, use the Advanced Options command in the Options menu to turn it off.
2. Click OK. GeoWorks Pro shuts down and Quattro Pro SE launches, automatically opening the same spreadsheet you were viewing. When you exit Quattro Pro SE later, you're returned to the Viewer. Notice that you are still viewing the spreadsheet, and that it has automatically changed to reflect the work you did in Quattro Pro.

To launch Quattro Pro and open an existing spreadsheet without first viewing it...
1. In the Viewer, choose Open from the File menu. A file selector appears.
2. From the Document Formats box, click to select the kind of file you want to open.
to open. Only files of that type will show up in the file list. (If no files appear, then there aren't any files of that type in the current directory.)

3 Select the file you want and click Open. Quattro Pro SE then launches and opens the selected spreadsheet.

When you exit Quattro Pro SE, you return to the Viewer. You can then use the View menu to take a look at the spreadsheet.

**COPYING SPREADSHEETS TO OTHER APPLICATIONS**

Anything in the Viewer window can be copied to the clipboard and subsequently pasted into other GeoWorks applications.

**SELECTING AND COPYING** Before you can copy something to the clipboard, you must select it. This is as true in the Viewer as it is in GeoWrite, GeoDraw, or any other GeoWorks application.

**To select the entire view...**

Choose Select All from the Edit menu or click the Select All button in the upper-left corner of the document window. The entire view is selected. Keep in mind that if the spreadsheet is large, the Viewer will only show a 26 column by 60 row portion of it—and it is this portion that you are selecting.

**To select a line of a spreadsheet...**

Triple-click anywhere in the line of text you want to select, or—even easier—click its row number on the left. To select several lines, triple-click on the first line you want to select and drag to select the others.

**To copy selected text to the clipboard...**

With the text selected, choose Copy from the Edit menu.

**PLACING A SPREADSHEET INTO GEODRAW OR GEOWRITE** When you copy spreadsheet text to the clipboard, it's copied with tabs separating the columns. If you then paste the text into GeoWrite, the tabs automatically show up on the ruler. At that point you can change the tab stops and edit the text to your liking. If, however, you paste the text into GeoDraw, it becomes a text object that you can edit, rotate, stretch, and resize—but you can't adjust the tabs. This can only be done from GeoWrite.

*Note:* If you have borders in your spreadsheet and intend to copy it into a GeoWrite or GeoDraw document, always set the page size (see "A Few Ways to Deal With Large Spreadsheets") to match that of your GeoWrite or GeoDraw document.
A FEW WAYS TO DEAL WITH LARGE SPREADSHEETS

The Viewer's column limit is related to the number of tabs stops it can define. Each column of the spreadsheet requires one tab stop. So, three columns, three tab stops. GeoWorks Pro limits the number of tab stops in a block of text to 25, hence the 26 column limitation (the leftmost column plus 25 other columns gives you 26 columns, Q.E.D.). Because each vertical border in the spreadsheet requires an extra tab stop, turning off the spreadsheet's borders is an easy way to make more room for a large spreadsheet.

There is also a way to view an unlimited number of columns in a spreadsheet: Make all the columns the same width, thus completely eliminating the need for tab stops. But you can't have any borders or varying column widths if you choose this format. (Keep in mind that just because you can view an unlimited amount of columns, it doesn't mean that you can view an unlimited amount of spreadsheet—the number of rows is still limited.)

To remove the borders from the spreadsheet view...
1. Choose Cell Borders from the Options menu. A cascade menu with two options appears.
2. Choose None. The borders in the spreadsheet disappear. You can bring them back by choosing As In File (also under Cell Borders in the Options menu). These changes affect only your view of the file, not the actual Quattro Pro spreadsheet file.

To change to fixed-width columns...
1. Choose Column Widths from the Options menu. A dialog box appears.
2. Click Fixed Column Widths.
3. Click one of the Default Tab Spacing choices. Remember, all the columns in the spreadsheet will become this width. If a column contains text that does not fit within the new width, the end of the text is cut off. And if a cell contains a number that doesn't fit, the Viewer replaces the number with asterisks (*).
4. Click Ok.

To change the page size...
The Viewer only shows you, at most, the number of spreadsheet cells that fit on a single Viewer page. So, one way to see more of a spreadsheet is to simply choose a larger page size.
Change the page size by choosing Page Size from the Options menu, then choose the desired size. If you intend to paste your spreadsheet into a GeoWrite or GeoDraw document, always set the Viewer's Page Size to match that of the final document.

To change the font size for the entire spreadsheet...
Another way to fit more cells into the Viewer page is to make the spreadsheet font size smaller. The smaller the text is, the more you can fit on the page. Choose one of the font sizes from the Sizes menu, or, to set a special size, choose Custom Sizes instead. (You can also set a custom size by clicking the Font Size button in the tool box.)

Any change you make affects the font size of the entire document. The Viewer automatically adjusts everything—font, column width, and row height—to
match. If you want to change the size of individual letters or words, copy and paste the spreadsheet into GeoDraw or GeoWrite and make the changes there.

**To change the font for the entire spreadsheet...**

Choose a font from the Fonts menu, or choose More Fonts if you've installed additional fonts.

---

**SOME IMPORTANT NOTES ABOUT SPREADSHEET BORDERS**

The Viewer uses a combination of tab lines and paragraph borders to match the borders in the original spreadsheet. But there are some differences. Here are some hints for producing the best borders:

- All border lines (including thick, thin, double lines, etc.) in a Quattro Pro file appear as single width lines in the Viewer. However, you can change the border styles once you copy the spreadsheet into GeoWrite.
- The Viewer uses a paragraph border (similar to GeoWrite's paragraph borders) to create horizontal lines. Because a paragraph border applies to a whole row, not individual cells, horizontal lines in the Viewer *always* stretch the entire length of the row, whether or not they originally did in your spreadsheet.
- The Viewer uses a combination of tab lines and paragraph borders to create vertical lines. Because the Viewer is limited by the number of tabs it can show, you can turn the borders off to see more of a spreadsheet. (See “A Few Ways to Deal With Large Spreadsheets” earlier in this chapter.)

---

**CHARTS AND THE VIEWER**

The Viewer can open up Quattro chart files, providing you created them in Encapsulated PostScript (EPS) format. You do this by printing the chart to a PostScript printer, but capturing the result in a file before it can be printed. Not only isn't it as complex as it sounds, but you don't even have to actually have a PostScript printer to do this. (Though you *do* have to make sure that Quattro Pro thinks you have one; see “If All Your Charts Turn Blue” later in this section.)

*Note: The Viewer is designed to only view EPS chart files produced by Quattro Pro, not EPS files produced by other graphics programs.*

**To print a chart to an EPS file...**

1. In Quattro Pro, create a chart from your spreadsheet data. See Chapter 12 and 13 of the Quattro Pro SE manual for more about creating charts (graphs).
2. Choose Graph Print from the Print menu. A cascade menu appears.
3. Choose Write Graph File from the cascade menu. Another cascade menu appears.
4. Choose EPS file (don't worry if you don't have a PostScript printer—you don't really need one). A dialog box appears. Click on the path name (which probably reads C:\GEOWORKS\DOCUMENTS\*.EPS, or something similar). The path name reappears in a dialog box without the *.EPS part.
5. Type a name for the chart using standard DOS file-naming conventions. Leave off the “.EPS” part; Quattro automatically adds it to the end. So, if you enter “mychart” it would create a file named MYCHART.EPS.

*Note: If your chart has the same name as the spreadsheet (except for the .EPS part) you can use the Viewer’s View Matching Spreadsheet and View Matching Chart commands. For example, if your spreadsheet is named MYDATA.WQ1, name your chart MYDATA.EPS.*
Once you've typed a name, press [Return]. A dialog box appears that says “Now Printing.”

SIZING A CHART Charts are not resizeable within the Viewer. Instead, you should copy the chart to either GeoDraw (see “Pasting a Chart into GeoDraw or GeoWrite,” later) or a scrapbook document. There is an advantage to copying a chart to a scrapbook: you can **proportionally scale** it using the View at % feature. Proportional scaling keeps the chart’s horizontal and vertical dimensions the same in relationship to each other—one is not stretched more than the other. This prevents the chart from becoming distorted as you make it larger or smaller.

FITTING A CHART IN THE VIEWER WINDOW If you want to view an entire chart within a window, choose the Fit in Window command from the Options menu. This shrinks or magnifies the chart, so that it exactly fills the window. Note that the chart is still the same size—it just appears bigger or smaller within the window. To see the chart at its actual size, choose Fit in Window a second time to turn the option off.

PASTING A CHART INTO GEODRAW OR GEOWRITE When you copy a chart to the clipboard, the entire chart is copied as a single GeoDraw object. You can then paste this object into both GeoWrite and GeoDraw. In GeoWrite, it behaves just like any other picture you might paste in—it becomes part of the text. In GeoDraw, it is pasted as a single object, meaning that you can’t then defuse it and change the component pieces (although you can rotate it and size it the way you do other objects).

If you plan to eventually print the chart on a PostScript printer (from GeoWrite or GeoDraw), choose the PostScript Printer option from the Options menu. If you’re going to print the chart on a dot-matrix printer, choose Non-PostScript Printer.

To copy a chart to the clipboard...

Make sure that the chart’s window is active (that is, not behind another window). Choose Copy from the Edit menu.

IF ALL YOUR CHARTS TURN BLUE You may find that your colorful charts turn black and blue when you look at them in the Viewer. The problem is that, unless you’ve made Quattro Pro’s default printer a PostScript printer, it doesn’t correctly identify all of the chart’s colors when it creates the EPS file. Fortunately, you don’t need to actually have a PostScript printer in order to make one your default.

(In the following steps, we assume you’re using the mouse to choose menu items. If, however, you want to use the keyboard, you’ll need to do things a little differently. See “Using the Keyboard” in Chapter 1 of the Quattro Pro SE manual for more about using the keyboard.)
To cure the (black and) blues...

1. Choose Hardware from the Options menu (in Quattro Pro SE), and then choose Printers.
2. Choose 2nd Printer.
3. Choose Type of Printer.
5. Choose Normal.
6. Look up a little bit and Click Printers (the same Printers you clicked earlier).
7. Choose Default Printer.
8. Choose 2nd Printer.
9. Click on the Options menu again.
10. Click Update. You're done.

USING THE TOOL BOX

The floating tool box gives you a quick way to give common commands—its buttons correspond to commands in the Viewer's menus. Clicking one of them is exactly the same as pulling down one of the menus and selecting the corresponding command.

If the tool box gets in your way, close it by double-clicking its control button. Bring the tool box back by choosing Tool Box from the Options menus.

There are six commands on the tool box:

**Edit Spreadsheet** Click this button to launch Quattro Pro and open the spreadsheet that corresponds to the chart. (See “View Matching Spreadsheet.”)

**View Matching Spreadsheet** This button is dimmed unless you're viewing a chart. Click it to see the spreadsheet that corresponds to the chart. For instance, if you're viewing a chart named FORECAST.EPS and you click this button, the Viewer looks for the file FORECAST.WQ1 and opens it for viewing. Both files must be in the same directory for this to work. This button corresponds to the View Matching Spreadsheet command in the Window menu.

**View Matching Chart** This is much like the View Spreadsheet button except that it works in reverse: The Viewer looks for the chart associated with a spreadsheet. Again, the spreadsheet and the chart need to be in the same directory. This button corresponds to the View Matching Chart command in the Window menu.

**Set Spreadsheet Range** Click this button to set the starting cell or range of cells in the view. See “Viewing Another Part of a Spreadsheet” in this chapter for more about the starting cell and range.

**Set Font** This brings up the More Fonts dialog box. Choose a font and click Apply—the font changes to the new font throughout the entire spreadsheet.

**Set Font Size** Click this button to bring up the Custom Size dialog box. This changes the font size for the entire spreadsheet. The Viewer adjusts the column widths and row heights to accommodate the new font size.
CUSTOMIZING THE VIEWER

The Viewer allows you to customize some of the things it usually does automatically. For instance, to save time you can tell the Viewer to not display certain warnings. You can also change the program that the Viewer launches when you choose either the Edit Spreadsheet, New, or Open commands. Be careful, though—unless you really know what you’re doing, it’s best to leave these options alone.

TURNING THE VIEWER’S WARNINGS ON AND OFF
The Viewer often warns you when it’s going to do something that you may not expect. Great if you’re new to the Viewer—warnings can save you from unexpected results—but after a while you may not want to see them anymore. Normally, all of the Viewer’s warnings are on. Here’s how to turn them off (and back on, if you change your mind).

To turn the Viewer’s warnings on and off...
1. Choose Advanced Options from the Options menu. The Advanced Options dialog box appears.
2. Turn the “Confirm before” options on or off by clicking the appropriate check boxes. These options control the confirmation dialog boxes that appear when you do the actions shown. Turning the options off suppresses the dialog boxes.
3. Also click the “Warn when spreadsheet” options to turn them on and off. Like the “Confirm before” options, these control the warning dialog boxes that appear whenever something happens that affects accuracy of the view—for example, a warning appears if you change the font size to 72 points, causing part of your spreadsheet to be temporarily lost from the view. If you turn an option off, the associated warning never appears.
4. Click OK to accept the changes and close the Advanced Options dialog box. To reject your changes, click Cancel.

The Advanced Options dialog box. By setting the different options here, you can keep the Viewer from issuing certain warning messages. You can also change the kind of files it creates, and the program that it runs.
CHANGING YOUR QUATTRO PRO CONFIGURATION
This option is for power users only. If you have another spreadsheet program you want the Viewer to launch, or you want to launch Quattro Pro SE with specific options every time, this is how you do it.

Note: If you choose to use a spreadsheet program other than Quattro Pro, keep in mind that the Viewer only imports spreadsheets and charts saved in the formats shown in the Supported File Types list earlier in this chapter.

To launch a program other than Quattro Pro SE...
1. Choose Advanced Options from the Options menu. The Advanced Options dialog box appears.
2. In the Program text box, type the complete pathname for the program, including the drive letter and name of the program file (the file extension is optional). For instance, say you installed Lotus 1-2-3 in the LOTUS directory of drive C. To have the viewer launch Lotus 1-2-3 instead of Quattro Pro SE, you’d type C:\LOTUS\123.EXE in the program field. Then, whenever you choose New, Open, etc., the Viewer launches Lotus 1-2-3 instead of Quattro Pro.
3. Click OK to accept your changes or Cancel to reject them.

To launch the spreadsheet program with specific options...
Some DOS programs allow you to add command line options when you launch them so that the program does something more than just launch. For instance, by typing a document name after the program’s name (at the DOS prompt) many DOS programs will launch the program and automatically open the document. The Viewer can automatically tack on extra options to the end of its usual command line when it launches the spreadsheet program.

1. Choose Advanced Options from the Options menu.
2. Type the options in the Arguments box. (To find out about specific options, see your program’s documentation.)
3. Click OK to accept your changes or Cancel to reject them.

To change the file extension that the Viewer looks for when you View the Matching Spreadsheet...
If you mainly use the Viewer to look at Lotus 1-2-3 files, and you’d like to use the View Matching Spreadsheet command, you can have the Viewer look for the filename extension “.WK1” instead of the usual “.WQ1” (used for Quattro Pro SE files).

1. Choose Advanced Options from the Options menu.
2. Change the three letter document extension. If you mainly use the Viewer to look at Lotus 1-2-3 files, change the Document filename extension to “.WK1”, which is how Lotus 1-2-3 names its spreadsheets. Otherwise, for Quattro Pro SE files, leave it as “.WQ1”.
3. Click OK to accept your changes or Cancel to reject them.

SAVING YOUR OPTIONS You can have the Viewer remember your custom options so that they apply the next time you start the Viewer. Choose Save Advanced Options from the Options menu.
The Scrapbook application, like its real world counterpart, is a place to store scraps—bits of images and information, stuff you want to keep together in one convenient place. Use it to store logos, letterheads, or anything you use again and again—things you want to collect in one place so you can get at them quickly. Scraps are stored in documents called (not surprisingly) scrapbooks. When you want to use something you’ve stored, simply open the scrapbook, flip to the page, and copy the item out.
THE SCRAPBOOK WINDOW

The contents of the current scrapbook page appear in the viewing window. (When you open an empty scrapbook, the viewing window is empty.) To flip to other scrapbook pages, use the Next and Previous buttons—they move you forward and backward one page at a time. Or use the Go to Page button to jump straight to a specific page.

WORKING WITH SCRAPS

To add a page to the Scrapbook, simply cut or copy text or graphics from one document and paste them into the Scrapbook; whatever you paste becomes a new page in the Scrapbook document. When you want to use something you've saved, open the Scrapbook, flip to a page, and cut or copy whatever you want to another document.

See the "Basic Tools and Skills" chapter for more about cutting and pasting.

To flip through pages of a scrapbook...

Click the Next button to flip forward a page, and click the Previous button to flip backward. If you're on the last page, clicking Next flips you around to the first. Likewise, if you're on the first page, clicking Previous flips you to the last.

To flip to a specific scrapbook page...

1. Click the Go to Page button. The Go to Page dialog box appears. Inside the dialog box is a list of all the pages in the Scrapbook.
2. Find the page you want and click to select it.
3. With the page selected, click View Page. The Scrapbook window flips to that page.

You can also double-click a page in the list to select and view that page in one step. If you want, leave the dialog box open while you work in the Scrapbook—just move it so it doesn't cover the viewing window. Or click Close to make the dialog box go away.
To add something to a scrapbook...
1. Within an application, copy (or cut) something—anything—to the clipboard in the normal manner.
2. Switch to the Scrapbook application. If Scrapbook is not already running, start it now.
3. If you want to place the contents of the clipboard on a particular page, flip to that page and choose Paste from the Edit menu. A new page is inserted in front of the current page, and the contents of the clipboard are pasted into it.
4. If, on the other hand, you want to place the contents of the clipboard on a new page at the end of the Scrapbook, choose Paste at End from the Edit menu.
5. In the Name field, type a descriptive name for what you've placed on the scrapbook page. This makes it much easier to find the scrap later, as this name appears in the list of pages when you click the Go to Page button.

To cut or copy from a scrapbook to another application...
1. Flip to the scrapbook page with the scrap you wish to cut or copy.
2. Choose Cut or Copy from the Edit menu. The Copy command copies the contents of the page to the clipboard, leaving the scrapbook page intact. The Cut command also puts a copy of the scrap on the clipboard, but completely removes the scrapbook page in the process.
3. Switch to the application (GeoWrite or GeoDraw, for instance).
4. If you're inserting the clipboard's contents into a GeoWrite document (or GeoDraw text block) click to put the insertion point at the place you wish to paste the scrap. You normally don't need to do this when pasting graphics into GeoDraw, since the scrap is automatically pasted in the center of the screen.
5. Choose Paste from the Edit menu to actually paste in the scrap.

To remove a page...
1. Flip to the page you want to delete.
2. Choose Delete from the Edit menu. The page and its scrap are removed from the Scrapbook document. The Delete command works much like the Cut command, except for one important difference: when you delete a page, its contents are not placed on the clipboard.

If you accidentally remove a page you wanted to keep, you can get it back by choosing Revert from the File menu. Use the Revert command with care though; it undoes all work you've done since you last saved the document.

If you don't name your scrap, then it will be called "Unnamed Graphic" (above) which isn't very helpful when you want to find your scrap a year from now. Type a more descriptive name into the "name" field. (below)
To name or rename the contents of a page...

0 First, flip to the page with the scrap you want to name.
2 In the Name field, type text that describes the contents of the page. You may type up to 32 characters, including spaces and punctuation. If there is already a name for the page, and you'd like to change it, edit it like you would any other text in GeoWorks Pro.

SCALING IMAGES WITH THE SCRAPBOOK

Scaling means sizing an image so that its horizontal and vertical proportions are maintained—useful with logos and artwork that you don't want distorted when you size them. With the scrapbook you can view a scrap at various scaling percentages, much like you'd view something under a magnifying glass—the object looks bigger, but it doesn't actually become bigger. Then, if you want to copy the scaled image, use the Copy at View % command. If, however, you want to copy the image to the clipboard at its normal size, use the Copy command.

To view a scaled image...

0 First, flip to the scrapbook page containing the scrap. Use the Go To button, or the Next and Previous buttons.
2 Select a percentage from the View menu, or choose Custom View if you want to specify your own. The Scrapbook limits your images to sizes under 11 inches square.

0 If you want to view other scraps at this scale, just flip to the other pages. The Scrapbook application shows you every image at that scale (until you change it, of course).

To copy a scaled image to the clipboard...

0 First, flip to the image you want copy, and change the image's scale with the View menu as described earlier.
2 Choose Copy at View % from the Edit menu. The image is copied to the clipboard at the size you were viewing it. That is, if you're viewing an image at 50 percent, and you use the Copy at View % command to copy it, the copy (on the clipboard) is half as big as the original.
SCRAPBOOK TRICKS

Here are some more advanced things you can do with the Scrapbook application:

**To make another document the Default Scrapbook...**
1. Exit Scrapbook.
2. Switch to GeoManager.
3. In the DOCUMENT directory, rename the Default Scrapbook to something else.
4. Also in the DOCUMENT directory, find the Scrapbook document you want to be the default and rename it to “Default Scrapbook” (spell and capitalize the name exactly as it is here). The next time you start the Scrapbook application, this new Default Scrapbook automatically opens.

**To keep more than one Scrapbook open at a time...**

While the Scrapbook application only lets you have one document open at a time, there’s nothing to prevent you from having several Scrapbook applications running at the same time—each with a different scrapbook open. Just open each scrapbook document by double-clicking its file icon.

To cut or copy between two Scrapbooks...
1. Open the two scrapbooks by double-clicking their file icons.
2. In one of the Scrapbooks, flip to a page you want to cut or copy, and cut or copy the contents of the page to the clipboard as usual.
3. In the other Scrapbook, flip to where you want to paste the contents, then paste as usual.

**IMPORTING IMAGES FROM OTHER DOS APPLICATIONS**

The Scrapbook application can import—that is, bring into a scrapbook—TIFF, PCX, or Quattro Pro EPS images.

**To import an image into a scrapbook...**
1. Open the scrapbook in which you want to place the image, and flip to the page where you want the image placed. Remember, the scrap is placed...
on a new page in front of the current page.

2 Choose Import from the File menu. A file selector appears.
3 Click on the type of file (TIFF, PCX, or Quattro Pro EPS) you intend to import. The file selector only shows you files of that type.
4 Find the file you want to import—changing disks and directories if you need to—and click on its name.
5 If you want to glimpse the file before you import it, click the View button. The image appears in the View window.
6 With the file selected, click Import. The image is imported and placed on the current page. (You may need to wait a few seconds while this happens.)
This computer version of Solitaire plays just like the game you know and love. But in this version you move the cards on the screen, instead of on your kitchen table, and the computer does all the shuffling and dealing for you. Be careful though, it's surprisingly addictive.
PLAYING THE GAME

You drag cards to move them from stack to stack, and you click on face-down cards to flip them over. (If you're a little unsure about how to drag and click, turn to the "Basic Tools and Skills" chapter in this manual.)

To move a card...
Click on the card and drag it to its new location.

To flip over a face-down card...
Click the card. If it's in one of the seven lower stacks, a single card will flip. If you click the deck, either one or three cards will flip—depending how you set your options. See "Changing the Number of Cards Drawn" later.

To start playing...
Begin playing by dragging a card or clicking a card to turn it over. The game starts as soon as you move or flip your first card.

To start a new game...
Choose Re-Deal from the Game menu.

To cheat...
If you make a move and then change your mind, choose Undo from the Game menu.

SETTING A DIFFICULTY LEVEL

Solitaire lets you choose from three levels of play: Beginner, Intermediate, and Advanced.

Beginner At the Beginner level, when you click a card, Solitaire helps you decide where to place it by highlighting possible destinations (unless the Full Card Dragging option is on). At this level, it's also legal to move cards from the four top stacks to the seven lower stacks. You can also split sequences—move, say, only the last three face-up cards in a stack of six.
Intermediate You lose both the destination help and the ability to move cards from the top four stacks to the lower seven—once cards are in the top four stacks, they stay there. But you can still split sequences.

Advanced No help. No moving cards off the top four stacks. No splitting of sequences.

To change the level of difficulty...
1. From the Options menu select Level of Play.
2. From the ensuing cascade menu, choose Beginner, Intermediate, or Advanced.

CHANGING THE SCORING

Solitaire can be scored in different ways. Choose from Standard, Vegas, and No Scoring.

STANDARD SCORING With standard scoring, you lose points for time you spend deciding to take action, and when you start through the discard deck again. You gain points for each successful move.

VEGAS SCORING In Vegas scoring, your game starts when you re-deal. You start out 52 points in the hole, and for each re-deal you pay with another 52 points. You then get five (positive) points for each card that you move to one of the four upper stacks. Your goal is to work your way to a positive score. Points are cumulative from game to game. In addition, you’re limited in how many times you can go through the discard deck: once, when you play one-card draw; three times, with three-card draw.

To change scoring...
From the Options menu select Scoring. Three choices appear, Standard, Vegas, and No Scoring. Choose one.

CHANGING THE NUMBER OF CARDS DRAWN

You can draw either one or three cards at a time from the discard stack. The choice you make affects how many passes through the discard deck you get when playing with Vegas scoring (see “Changing Scoring Options” earlier).

To change the number of cards drawn...
Choose Draw How Many Cards? from the Options menu. From the ensuing cascade menu, choose one or three.

STANDARD SCORING

<table>
<thead>
<tr>
<th>If you...</th>
<th>You get...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Let ten seconds go by</td>
<td>-1 point</td>
</tr>
<tr>
<td>Move a card to one of the four upper stacks</td>
<td>+10</td>
</tr>
<tr>
<td>Flip a card in one of the lower seven stacks</td>
<td>+5</td>
</tr>
<tr>
<td>Pull a card out of the discard deck</td>
<td>+5</td>
</tr>
<tr>
<td>Start through discard deck again (one-card draw)</td>
<td>-10 for the first four times, and -20, -30, etc., each time thereafter</td>
</tr>
<tr>
<td>Start through discard deck again (three-card draw)</td>
<td>-30 first two times, -60, -90, etc., each time thereafter</td>
</tr>
</tbody>
</table>

VEGAS SCORING

<table>
<thead>
<tr>
<th>If you...</th>
<th>You get...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Re-deal</td>
<td>-52 points</td>
</tr>
<tr>
<td>Move card to an upper stack</td>
<td>+5</td>
</tr>
</tbody>
</table>
SETTING OTHER OPTIONS

You have four other options in Solitaire. You can change any of these by choosing them from the Options menu:

**Change Card Backs** Gives you a dialog box from which you choose the artwork on the backs of the cards.

**Outline Dragging** When on, you see only see a card’s outline as you drag it.

**Full Card Dragging** Shows the full card as you drag it. The game moves a little slower with this option on. Use Outline Dragging to speed things up. Also, with Full Card Dragging on, you don’t get any destination help when playing at the beginner level.

**Fade on Deal** When on, cards fade in as they are dealt. With this setting off, cards appear immediately. This option also slows things down (not good if you’re playing a timed game).

**Timed Game** Standard setting that times your game and deducts a point when you take more than ten seconds to act. Time is displayed in the lower left of the screen. With this setting turned off, no points are deducted.
As games go, Tetris is easy to learn, hard to master, and unfailingly addictive. To play, simply rotate shapes as they fall down a well, trying to make them land in neatly filled rows. *Simple!* Completely filled rows disappear, giving you room to work—and room is what you need, for when the pieces stack up to the top of the well, it’s Game Over!
PLAYING THE GAME

The basic playing area is called the *well*. Differently-shaped blocks fall down the well, slowly at first, then faster as you advance to higher skill levels. As the pieces fall, you can rotate them counterclockwise and move them left or right. The idea is to fit them neatly into rows at the bottom. When you complete a row—that is, fit the last piece so there aren’t any gaps in the row—it disappears, and the rows above shift down to fill the space. Once you’ve lined the falling piece up correctly, you can make it drop immediately onto the pile, which speeds the pace of the game and earns you extra points.

The longer you play, the more points you make. Your goal, of course, is to accumulate as many points as you can.

**To start a game of Tetris...**

Choose Start New Game from the Game menu. The first piece will immediately start falling from the top of the well.

**MOVING THE PIECES IN TETRIS** Tetris is easy to operate, since you only need to learn to use a few keys. The chart at the bottom of this page shows the keys that maneuver the pieces in both the one- and two-player games.

**PAUSING THE GAME** If you’re in the middle of a game and you need to stop for a second (say, to answer the phone), simply choose Pause Game from the Game menu. While Tetris is paused none of the pieces move. When you’re ready to go back to playing, choose Continue Game from the Game menu. The game will pick up again as though you’d never left. The Pause Game feature is also a great way to stop and calm your panic when the pile of pieces gets large and the pace really picks up. (Of course, you can’t see anything in the well while the game is paused, since that would certainly give you an unfair advantage!)

In Tetris, pieces fall down the “well” and land on the pile below. When you completely fill a row, it disappears and the pile shrinks by one row. Easy, right?
**SCORING**

Scoring in Tetris is pretty simple: the more challenging the play, the more points you get. But for those of you who just have to know, here are some of the scoring rules.

- Every time a piece lands on the pile you get a certain number of points (which goes up as the game level increases).
- When you drop a piece by pressing [Spacebar], you get extra points. The farther it drops, the more points you get.
- You get 1,000 points when you clear four rows at once.
- However, you score fewer points when you're playing with the Preview Pieces option on.

---

**TWO-PLAYER TETRIS**

In two-player Tetris, like in the single-player version, you try to rack up as many points as you can—it's just that your opponent is simultaneously doing the same thing. Each of you has your own well and your own (different) series of falling blocks—it's like playing two single-player games side-by-side.

Here's the tricky part: There are actually two ways for the two-player game to end:

- Both players' piles reach the top of their respective wells.
- One player's pile reaches the top and the other player has more points. (The one with more points wins, of course.)

If you like, you can have the left- and right-player games interact. For example, if you set the Penalize Opponent option, then every time you clear a row, a new row gets added to the bottom of your opponent's well.

**To start a game of two-player Tetris...**

1. Select Two Players from the Options menu. You should also set any of the other options while you're at it (see the next section for a complete list).
2. Choose Start New Game from the Game menu.

---

**MANEUVERING THE TETRIS PIECES**

<table>
<thead>
<tr>
<th>One Player</th>
<th>USE ANY OF THE THREE KEY COMBINATIONS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Two Player</td>
<td>LEFT PLAYER</td>
</tr>
<tr>
<td>Move left</td>
<td>D</td>
</tr>
<tr>
<td>Move right</td>
<td>F</td>
</tr>
<tr>
<td>Rotate counter-clockwise</td>
<td>G</td>
</tr>
<tr>
<td>Drop piece</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Increase difficulty</td>
<td>I ((&quot;)</td>
</tr>
</tbody>
</table>
SETTING THE TETRIS OPTIONS

Tetris comes with many options—found in the Options menu—to test your mastery of the game.

**Two Players** Pits you against a “friend,” as each of you try to get the most points while playing with side-by-side wells.

**Preview Pieces** Your crystal ball. With this option turned on you see the next piece that will drop before it actually appears in the well. As you might expect, this option takes some of the challenge out of the game, and you get less points.

**Players Get Identical Pieces** In two-player Tetris, this option is one way to keep everything fair. (Sort of.) When it’s turned on, both players get the same falling pieces in the same order.

**Set Left Player’s Game Level/Set Right Player’s Game Level** You can set different starting game levels for each player. If you and your opponent aren’t evenly matched, this is a great way to set a handicap.

**Set Starting Lines** Tetris starts your game with some lines partially filled at the bottom. This makes the game exciting from the moment it starts.

**Penalize Opponent** This option makes two-player Tetris just plain nasty. There even are several ways to penalize an opponent:

- Never: Each player plays a normal, friendly Tetris game.
- Every Other Line Filled: Here things become a little less friendly. Every other time you clear a row, an extra, partially filled row is added on your opponent’s side. (And vice versa, of course.)
- Every Line Filled: Each row you clear adds another row to your opponent’s side.
- Multiple Lines Filled Only: For advanced players. You need to clear two lines to penalize your opponent one line; clear three lines to add two; and four lines to add three.

**Show High Scores** Choose this to see a list of the top ten scores.

**Reset Games Won** In the two-player version, Tetris keeps a running total of the games each player has won. Choose this option to set the tally to zero.

**Save Options** If you’re satisfied with the options you’ve set and would like Tetris to keep them in effect, select Save Options. The next time you start Tetris, the current options will be in effect.

*Rotate the pieces as they fall so that they fit snugly into the pile below.*
In the early days of personal computing, you didn’t have much choice. Your PC was made by IBM and you used MS-DOS, which ran only one program at a time. But today, there are hundreds of choices. More brands of dot-matrix printers than you can count. (And laser printers, too.) MS-DOS is still around, but there are challengers like DR-DOS. And you can run many DOS programs at once and switch among them. You can even exchange files with others over a Local Area Network.

With GeoWorks Pro and MS-DOS 5.0 or DR DOS 6.0, you can easily run a lot of DOS programs at the same time.
GeoWorks has kept up with the changes, letting you take full advantage of the software and hardware choices that now exist. For example:

• GeoWorks Pro supports Novell, LANTastic, LANManager, and PC-NFS 3.5 Local Area Networks. This means you can use network drives in the same way you use your local hard disk. You can even print to a network printer by redirecting your printer port. (See the manuals that came with your network for more about setting up network printers.)

• You can print on PostScript printers—including Apple Laserwriters, QMS, and HP printers with PostScript cartridges. You can also print to a PostScript file (which you can then import into programs that accept such files, like PageMaker).

• GeoWorks Pro works with the task switchers (software that lets you switch between several active DOS programs) that come with MS-DOS 5.0 and DR-DOS 6.0. GeoWorks Pro also works within Microsoft Windows.

SWITCHING WITH THE MS-DOS 5.0 DOSSHELL UTILITY

GeoWorks Pro is compatible with the DOSSHELL utility, Microsoft's task switcher for MS-DOS 5.0. Before you use it, though, there are a couple of things you should know:

• The task switcher, DOSSHELL.COM, takes all of extended memory for itself, leaving none for GeoWorks Pro. It also takes up about 40K of regular memory, but it doesn't affect your expanded memory at all.

• When you switch from GeoWorks Pro into another DOS program (such as a spreadsheet or word processor), everything that you were doing in GeoWorks Pro is put on hold. If you're in the middle of printing a document, it will stop printing. If you then try to print something from a DOS program, it will probably come out in the middle of the GeoWorks document. Because of this, you should completely finish printing (and saving) your documents before switching out of GeoWorks Pro.

• GeoWorks Pro generally keeps a lot of files open. Normally this isn't a problem, but if you run other DOS programs that also open lots of files, you might get an error that says you've opened too many. Fortunately, this is easy to fix (see "Preparing Your Computer for DOS Program Switching," discussed a little later).

To switch from GeoWorks Pro to another DOS program...

Make sure that you run DOSSHELL before you start GeoWorks Pro. Then, to switch to the DOSSHELL screen from GeoWorks Pro—from which you can transfer to any currently running DOS program or start a new one—press q + `. Note that while DOSSHELL gives you several keystrokes that you can use to switch applications, only q + ` works from within GeoWorks Pro.

PREPARING YOUR COMPUTER FOR DOS PROGRAM SWITCHING

Before you try to run GeoWorks Pro along with other DOS programs, you need to alter your CONFIG.SYS file (found in the root directory of drive C) to make sure that your computer can handle the large number of files that will be open at the same time.

Warning! Changing your CONFIG.SYS file is a very delicate business. If at any time you feel that you have made an incorrect change, don't hesitate to use the Revert command on the File menu.
To change your CONFIG.SYS file...

1. Start GeoWorks Pro.
2. Start the Notepad desk tool. A blank notebook page appears.
3. Open your CONFIG.SYS file by choosing Open from the File menu. The CONFIG.SYS file should be in the root directory of drive C.
4. Look for the line that begins
   Files=
Edit the line to read
   Files=100
If there is no line like this in the file already, add one (as shown above) at the end of the file.
5. You should also add a line that automatically installs SHARE.EXE:
   Install=c:\dos\share.exe
   /F:4096
(If course, if SHARE.EXE isn't found in the C:\DOS directory, you need to change the directory name accordingly.)
6. Save the changes you've made and exit GeoWorks Pro.

7. Restart your computer by pressing Ctrl + Alt + Del. This puts the new CONFIG.SYS file into effect.

SWITCHING WITH DR-DOS AND TASKMAX

TaskMAX, the DR-DOS 6.0 program switcher, integrates smoothly into GeoWorks Pro, making it almost effortless to switch between GeoWorks Pro and other DOS programs.

But you'll need to watch out for a couple of things to make sure TaskMAX works properly with GeoWorks Pro—specifically, you need to make sure that your CONFIG.SYS file has the line
   Files=120
and that your computer automatically starts SHARE.EXE when you turn it on. (Follow the procedure described in the previous section for changing your CONFIG.SYS file.)

SWITCHING BETWEEN APPLICATIONS Because TaskMAX is integrated with GeoWorks Pro, it's very simple to start DOS programs and switch between them.

To start a DOS application from GeoManager...

You start DOS applications the same way you would if you weren't running TaskMAX—that is, by double-clicking their icons. The only difference is that, with TaskMAX, GeoWorks Pro doesn't have to shut down before running the program. Instead, both GeoWorks Pro
and the DOS program run simultaneously.

Change to the proper directory and double-click the icon of the DOS program to start it. The screen will go black almost immediately, indicating that the program is starting.

If, after double-clicking the icon a dialog box appears that says “shutting down PC/GEOS,” you know that TaskMAX wasn’t started correctly. (Without TaskMAX, GeoWorks Pro must shut down before running a DOS program.) Exit GeoWorks Pro and follow the instructions in the DR-DOS User’s Guide for starting TaskMAX.

To switch to an active DOS program via the Express menu...

The names of all active (i.e., running) DOS programs appear near the top of the Express menu. You can generally tell DOS program names from GeoWorks application names, since the DOS names are normally shown in all capital letters.

1. Click the Express button to bring down the Express menu.

2. Click to select the name of the desired DOS program. The screen immediately goes black while TaskMAX switches to the program. In a few moments, the screen of the DOS program will appear, exactly the way you left it.

To return to GeoWorks Pro...

You can use the TaskMAX dialog box to switch between different active DOS programs.

1. Press \[Ctrl\] + \[Esc\]. This brings up the TaskMAX dialog box.
2. Use the up and down arrow keys to move the cursor to the line that says “GeoWorks Pro.”

Note: If the dialog box doesn’t respond as you press the arrow keys, try this trick: press and release the left \[Ctrl\] key, and then do the same with the right \[Ctrl\] key. The control box should then function correctly.

3. Press \[Return\]. In the now familiar pattern, the screen goes blank for a moment while GeoWorks Pro is restored.

Of course, you could use almost this exact procedure to switch to any active DOS program. All you need to do is choose the name of the program from the TaskMAX dialog box and press \[Return\].

To shut down DOS programs...

The best way to shut down an active DOS program is to switch to the program (via the Express menu, as described earlier) and shut it down in the normal way—the same way you would if you had run it from DOS instead of from GeoWorks Pro. Probably the worst way to shut one down is to delete it using the TaskMAX dialog box (more on that later).
TASK SWITCHING FROM THE DOS PROGRAMS SCREEN
GeoWorks' DOS Programs screen functions almost the same way whether or not you're running TaskMAX. The regular DOS Programs screen (without TaskMAX, that is) is covered elsewhere in this book.

To start a DOS program...
Click the program's button, the way you normally would. Instead of GeoWorks Pro shutting down in the normal way, however, the screen goes blank and the DOS program loads. GeoWorks Pro is still running, in fact, and can easily be recalled with a couple of keystrokes (see below).

To switch to an already running program...
1. Click the "Running Programs" button at the bottom of the DOS Programs screen. A dialog box appears, showing a list of all active DOS programs.
2. Double-click the name of the desired program. The screen goes black while the DOS program is activated.

To return to GeoWorks Pro from another DOS program...
Use the TaskMAX dialog box to switch back to GeoWorks Pro.
1. Press Ctrl + Esc. This brings up the TaskMAX dialog box.
2. Use the up and down arrow keys to move the cursor to the line for GeoWorks Pro.
3. Press Return. The screen goes blank for a moment while GeoWorks Pro is restored.

To shut down DOS applications...
1. Switch to the program (via the "Running Programs" button, described earlier).
2. Shut the program down in the normal way—the same way you would if you had run it from DOS instead of from GeoWorks Pro.
3. After the program shuts down, you may be returned to GeoWorks Pro—or you may be switched to another active DOS program. Use the procedure shown earlier to switch back to GeoWorks Pro.

THE TASKMAX DIALOG BOX
You can control TaskMAX directly using a special dialog box available from the Express menu. While you can start DOS programs or switch to them using this dialog box, this isn't the easiest way to do this—double-clicking the files in GeoManager or choosing their names from the Express menu is actually much simpler. The TaskMAX dialog box, however, is the only way to forcibly shut down a DOS program without switching over to it.

To bring up the TaskMAX dialog box...
Choose TaskMAX Control from the Express menu. The TaskMAX dialog box appears.

The TaskMAX dialog box. The Active Tasks list (1) shows all the DOS programs (other than GeoWorks Pro) that are currently running.
Active Tasks  This list shows all the active DOS programs. The name shown is the name of the program's executable file (that is, the " .EXE " or " .COM " file). If you start the DOS shell, COMMAND.COM, then the name "COMMAND" appears in this list. However, if you switch over to the shell and run a program, the name of this program replaces the name "COMMAND" in the Active Tasks list.

Add  Click this to automatically start another COMMAND.COM DOS shell, which you can then use to start another DOS program.

Run  Click here to switch to the selected program in the list.

Delete  This terminates the selected DOS program. This button is dangerous—see the steps for shutting down DOS programs later in this section.

Per-Task EMS Limit  This shows the maximum amount of EMS memory available to each active DOS program. You can adjust the number.

Free Swap Space  The figure shown is the amount of disk space available for temporarily storing active DOS programs. If this figure is too low, you may be unable to start additional programs.

Clipboard Support  Turn this option on if you want text that you've cut or copied from a DOS program to replace the GeoWorks clipboard, thus making it available for you to paste into GeoWorks applications. Turn the option off if you want to ensure that GeoWorks Pro's clipboard is left unchanged while you're using other DOS programs. (If the option is dimmed and unavailable, it means that your version of TaskMAX doesn't handle DOS cut and paste in a way that works with GeoWorks Pro.)

To start a DOS program...

1. Click Add. This starts the DOS shell, COMMAND.COM, and switches you into it.
2. Run your DOS program from this DOS prompt the way you normally would. Later, when you return to GeoWorks Pro, the TaskMAX dialog box will show you the name of this program, not COMMAND.COM, in the Active Tasks list.

To switch to an active DOS program...

There are two ways to switch to an active program using the TaskMAX dialog box:

- Click to select the name of the program from the list of active DOS programs. Then click Run.
- Double-click the name of the program in the list of active tasks.

In either case, the screen immediately goes black while you switch. After a few moments, you'll be back in the DOS program at exactly the same place you were before.

To shut down an active DOS program...

The best way to shut down a DOS program is to first switch over to it, and then shut it down in the normal way. (You shut down WordPerfect, for example, by pressing $, although every DOS program is different.) The worst way, or at least the most potentially dangerous way, is to use the Delete button in the TaskMAX dialog box.

The problem with this latter method is that the DOS program is abruptly
shut down, without being given the opportunity to release any of its extended memory or flush out its file buffers. You run the risk, then, of corrupting your data files, or at least tying up some of your RAM until you turn your computer off. Not good.

There are times, however, when the Delete button is the only way to shut down a job. Specifically, you must click Delete if you started the program using the i key in the regular TaskMAX dialog box (the one you get when you press q + ` from the DOS prompt, not the one described here that’s part of the Express menu). You can shut down the DOS program in the normal manner, but you can’t get rid of the DOS shell except by clicking Delete.

1 Select the name of the DOS program from the list of active programs.
2 Click Delete.
3 If a warning appears, asking if you do, in fact, wish to forcibly shut down this program, you should probably click No. This warning only appears when you try to delete the kind of program described earlier (it probably has allocated either extended memory or temporary files). No warning, no problem.

CUTTING AND PASTING FROM DOS APPLICATIONS
DR-DOS comes with a way to cut, copy, and paste text from the screen into DOS applications, thus letting you copy some figures from, say, a Lotus 123 screen into your WordPerfect document. You can use this same feature to copy from a DOS program to a GeoWrite document, and vice versa.

When you switch out of GeoWorks Pro, the contents of the GeoWorks clipboard are given to TaskMAX so that they can be pasted into a DOS program later. And vice versa: When you switch back to GeoWorks Pro, TaskMAX takes any text that has been cut or copied and places it into the GeoWorks clipboard.

While this process is automatic, you can turn it on or off. You might choose to turn it off if you had something important in the clipboard and you didn’t want to risk accidentally overwriting it.

To turn the TaskMAX clipboard support on and off...
1 Choose TaskMAX Control from the Express menu. The TaskMAX dialog box appears.
The Clipboard Support option shows whether this feature is on or off. (If the option is dimmed and unavailable, it means that your version of TaskMAX doesn’t handle DOS cut and paste in a way that works with GeoWorks Pro.) Change the setting by clicking the check box.

Click Close to close the dialog box.

RUNNING GEOWORKS PRO UNDER WINDOWS 3.0

It is possible to run GeoWorks Pro from Windows in the 386 enhanced mode, but you must first set up a .PIF file and add GeoWorks Pro to the Non-Windows application group.

To set up the .PIF file...
1. Run Windows.
2. In the Program Manager window double-click the Main Group icon.
3. Open the .PIF Editor.
4. In the .PIF Editor, you need to change only the options shown in the “Windows PIF Options” table below. (Leave all the other PIF options alone).
5. Select Save from the File menu and click the OK button to accept Kernel.pif as the filename.
6. Close the .PIF Editor.

To add GeoWorks Pro to the non-Windows applications group...
1. In the Program Manager window, choose New from the File menu.
2. Click OK to accept “Program Item” as your selection.

Note: If there is no Non-Windows Applications group icon, you need to create one. Consult your Windows manual to see how.
3. In the Program Item Properties window, type GeoWorks Pro in the Description box. This caption will appear under the icon in the Non-Windows Applications window.

4. Press the Tab key to move to the Command Line box and type in “kernel.pif”.
5. Click the Change Icon button to display the Select Icon window and type in W3ICONS.DLL.

6. Move through the icons by clicking the View Next button until you see the World icon.
7. Click OK.
8. Click OK again to save and exit the Program Item Properties window. The newly created icon should be displayed in the Non-Windows Applications window. Double-click on the GeoWorks Pro icon to launch it.

To switch out of GeoWorks Pro and into another DOS program...
All the task switching hotkeys, (Ctrl + Esc, Alt + Esc), and (Alt + Tab) are active. Press any one of these keys to cycle to the next program.

WINDOWS PIF OPTIONS

Main .PIF Editor window Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program Filename</td>
<td>KERNEL.EXE</td>
</tr>
<tr>
<td>Window Title</td>
<td>GeoWorks Pro</td>
</tr>
<tr>
<td>Start-up directory</td>
<td>C:\GEOWORKS</td>
</tr>
<tr>
<td>Execution</td>
<td>Exclusive</td>
</tr>
</tbody>
</table>

Advanced Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Options</td>
<td>Video Memory High</td>
</tr>
<tr>
<td></td>
<td>Graphics (All other display options should be deselected)</td>
</tr>
<tr>
<td>Other Options</td>
<td>Reserve Shortcut Keys</td>
</tr>
<tr>
<td></td>
<td>(Alt + Spacebar, Alt + Enter)</td>
</tr>
</tbody>
</table>

G E O W O R K S P R O I N T H E R E A L W O R L D 21.8
Hot Destinations: South of the Border

**Aero Tours**

Top Vacation Destinations for the Year

<table>
<thead>
<tr>
<th>Location</th>
<th>Bookings</th>
<th>Gross Revenue</th>
<th>Net Income</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mexico</td>
<td>242</td>
<td>$401,120</td>
<td>$43,101</td>
</tr>
<tr>
<td>Europe</td>
<td>630</td>
<td>$802,100</td>
<td>$96,257</td>
</tr>
<tr>
<td>Hawaii</td>
<td>529</td>
<td>$432,994</td>
<td>$29,568</td>
</tr>
</tbody>
</table>

THE APPENDIX AND INDEX
SPECIAL CHARACTERS

There are many special characters that you can use in GeoWorks Pro that you don’t find on your average typewriter—or on your keyboard, for that matter. Foreign language accent marks, foreign currency symbols, and mathematical symbols, for example, that can make your documents more professional looking.
To type a character shown on this list, simply press the key combination shown in the Keys column. (A plus sign (+) means hold down the first set of keys while pressing the second; the word “then” means just the opposite—release the first set before typing the second.) These special characters print normally (that is, the way they look here), providing you don’t use the Text Only option when printing.

## ACCENTED LANGUAGE CHARACTERS

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Â</td>
<td>uppercase A acute accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>e</code> then <code>Shift</code> + <code>a</code></td>
</tr>
<tr>
<td>Æ</td>
<td>uppercase A dieresis accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>u</code> then <code>Shift</code> + <code>a</code></td>
</tr>
<tr>
<td>Â</td>
<td>uppercase A grave accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>\</code> then <code>Shift</code> + <code>a</code></td>
</tr>
<tr>
<td>À</td>
<td>uppercase A circumflex accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>i</code> then <code>Shift</code> + <code>a</code></td>
</tr>
<tr>
<td>Â̈</td>
<td>uppercase A tilde accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>n</code> then <code>Shift</code> + <code>a</code></td>
</tr>
<tr>
<td>À̈</td>
<td>uppercase A ring accent</td>
<td><code>Shift</code> <code>Ctrl</code> <code>Alt</code> + <code>a</code></td>
</tr>
<tr>
<td>á</td>
<td>lowercase a acute accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>e</code> then <code>a</code></td>
</tr>
<tr>
<td>ã</td>
<td>lowercase a dieresis accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>u</code> then <code>a</code></td>
</tr>
<tr>
<td>à</td>
<td>lowercase a grave accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>\</code> then <code>a</code></td>
</tr>
<tr>
<td>ã̈</td>
<td>lowercase a circumflex accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>i</code> then <code>a</code></td>
</tr>
<tr>
<td>à̈</td>
<td>lowercase a tilde accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>n</code> then <code>a</code></td>
</tr>
<tr>
<td>à̈</td>
<td>lowercase a ring accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>a</code></td>
</tr>
<tr>
<td>Ĉ</td>
<td>uppercase C cedilla accent</td>
<td><code>Shift</code> <code>Ctrl</code> <code>Alt</code> + <code>c</code></td>
</tr>
<tr>
<td>ç</td>
<td>lowercase c cedilla accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>c</code></td>
</tr>
<tr>
<td>É</td>
<td>uppercase E acute accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>e</code> then <code>Shift</code> + <code>e</code></td>
</tr>
<tr>
<td>È</td>
<td>uppercase E dieresis accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>u</code> then <code>Shift</code> + <code>e</code></td>
</tr>
<tr>
<td>Ê</td>
<td>uppercase E grave accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>\</code> then <code>Shift</code> + <code>e</code></td>
</tr>
<tr>
<td>Ê̈</td>
<td>uppercase E circumflex accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>i</code> then <code>Shift</code> + <code>e</code></td>
</tr>
<tr>
<td>é</td>
<td>lowercase e acute accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>e</code> then <code>e</code></td>
</tr>
<tr>
<td>ì</td>
<td>lowercase e dieresis accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>u</code> then <code>e</code></td>
</tr>
<tr>
<td>è</td>
<td>lowercase e grave accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>\</code> then <code>e</code></td>
</tr>
<tr>
<td>ì</td>
<td>lowercase e circumflex accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>i</code> then <code>e</code></td>
</tr>
<tr>
<td>Í</td>
<td>uppercase I acute accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>e</code> then <code>Shift</code> + <code>i</code></td>
</tr>
<tr>
<td>Í</td>
<td>uppercase I dieresis accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>u</code> then <code>Shift</code> + <code>i</code></td>
</tr>
<tr>
<td>Í̈</td>
<td>uppercase I grave accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>\</code> then <code>Shift</code> + <code>i</code></td>
</tr>
<tr>
<td>Í̈</td>
<td>uppercase I circumflex accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>i</code> then <code>Shift</code> + <code>i</code></td>
</tr>
<tr>
<td>í</td>
<td>lowercase i acute accent</td>
<td><code>Ctrl</code> <code>Alt</code> + <code>e</code> then <code>i</code></td>
</tr>
</tbody>
</table>

**APPENDIX—SPECIAL CHARACTERS** A2
<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>i</td>
<td>lowercase i dieresis accent</td>
<td>Ctrl Alt + u then i</td>
</tr>
<tr>
<td>i</td>
<td>lowercase i grave accent</td>
<td>Ctrl Alt + ` then i</td>
</tr>
<tr>
<td>i</td>
<td>lowercase i circumflex accent</td>
<td>Ctrl Alt + i then i</td>
</tr>
<tr>
<td>Ń</td>
<td>uppercase N tilde accent</td>
<td>Ctrl Alt + n then Shift + n</td>
</tr>
<tr>
<td>ŋ</td>
<td>lowercase n tilde accent</td>
<td>Ctrl Alt + n then n</td>
</tr>
<tr>
<td>Õ</td>
<td>uppercase O acute accent</td>
<td>Ctrl Alt + e then Shift + o</td>
</tr>
<tr>
<td>Ŗ</td>
<td>uppercase O dieresis accent</td>
<td>Ctrl Alt + u then Shift + o</td>
</tr>
<tr>
<td>Ŗ</td>
<td>uppercase O grave accent</td>
<td>Ctrl Alt + ` then Shift + o</td>
</tr>
<tr>
<td>Ŗ</td>
<td>uppercase O circumflex accent</td>
<td>Ctrl Alt + i then Shift + o</td>
</tr>
<tr>
<td>Õ</td>
<td>uppercase O tilde accent</td>
<td>Ctrl Alt + n then Shift + o</td>
</tr>
<tr>
<td>Õ</td>
<td>uppercase O slash</td>
<td>Shift Ctrl Alt + Shift + o</td>
</tr>
<tr>
<td>õ</td>
<td>lowercase o acute accent</td>
<td>Ctrl Alt + e then Shift + o</td>
</tr>
<tr>
<td>õ</td>
<td>lowercase o dieresis accent</td>
<td>Ctrl Alt + u then Shift + o</td>
</tr>
<tr>
<td>õ</td>
<td>lowercase o grave accent</td>
<td>Ctrl Alt + ` then Shift + o</td>
</tr>
<tr>
<td>õ</td>
<td>lowercase o circumflex accent</td>
<td>Ctrl Alt + i then Shift + o</td>
</tr>
<tr>
<td>ò</td>
<td>lowercase o tilde accent</td>
<td>Ctrl Alt + n then Shift + o</td>
</tr>
<tr>
<td>ø</td>
<td>lowercase o slash</td>
<td>Ctrl Alt + o</td>
</tr>
<tr>
<td>Ú</td>
<td>uppercase U acute accent</td>
<td>Ctrl Alt + e then Shift + u</td>
</tr>
<tr>
<td>Ù</td>
<td>uppercase U dieresis accent</td>
<td>Ctrl Alt + u then Shift + u</td>
</tr>
<tr>
<td>Ù</td>
<td>uppercase U grave accent</td>
<td>Ctrl Alt + ` then Shift + u</td>
</tr>
<tr>
<td>Ù</td>
<td>uppercase U circumflex accent</td>
<td>Ctrl Alt + i then Shift + u</td>
</tr>
<tr>
<td>û</td>
<td>lowercase u acute accent</td>
<td>Ctrl Alt + e then Shift + u</td>
</tr>
<tr>
<td>û</td>
<td>lowercase u dieresis accent</td>
<td>Ctrl Alt + u then Shift + u</td>
</tr>
<tr>
<td>û</td>
<td>lowercase u grave accent</td>
<td>Ctrl Alt + ` then Shift + u</td>
</tr>
<tr>
<td>û</td>
<td>lowercase u circumflex accent</td>
<td>Ctrl Alt + i then Shift + u</td>
</tr>
<tr>
<td>ý</td>
<td>uppercase Y dieresis accent</td>
<td>Ctrl Alt + u then Shift + y</td>
</tr>
<tr>
<td>ý</td>
<td>lowercase y dieresis accent</td>
<td>Ctrl Alt + u then Shift + y</td>
</tr>
<tr>
<td>Æ</td>
<td>uppercase AE diphthong</td>
<td>Shift Ctrl Alt + ' (apostrophe)</td>
</tr>
<tr>
<td>æ</td>
<td>lowercase ae diphthong</td>
<td>Ctrl Alt + ' (apostrophe)</td>
</tr>
<tr>
<td>ÓE</td>
<td>uppercase OE diphthong</td>
<td>Shift Ctrl Alt + q</td>
</tr>
<tr>
<td>òe</td>
<td>lowercase oe diphthong</td>
<td>Ctrl Alt + q</td>
</tr>
<tr>
<td>ò</td>
<td>dotless i</td>
<td>Shift Ctrl Alt + i</td>
</tr>
<tr>
<td>ſ</td>
<td>German double s</td>
<td>Ctrl Alt + s</td>
</tr>
<tr>
<td>ø</td>
<td>ordmasculine</td>
<td>Ctrl Alt + 0 (zero)</td>
</tr>
<tr>
<td>a</td>
<td>ordfeminine</td>
<td>Ctrl Alt + 9</td>
</tr>
</tbody>
</table>

A.3 APPENDIX—SPECIAL CHARACTERS
### Typographical

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>†</td>
<td>dagger</td>
<td>Ctrl + t</td>
</tr>
<tr>
<td>‡</td>
<td>double dagger</td>
<td>Shift + t</td>
</tr>
<tr>
<td>§</td>
<td>section</td>
<td>Ctrl + 6</td>
</tr>
<tr>
<td>¶</td>
<td>paragraph</td>
<td>Ctrl + 7</td>
</tr>
<tr>
<td>®</td>
<td>registered trademark</td>
<td>Ctrl + r</td>
</tr>
<tr>
<td>©</td>
<td>copyright</td>
<td>Ctrl + g</td>
</tr>
<tr>
<td>™</td>
<td>trademark</td>
<td>Ctrl + 2</td>
</tr>
<tr>
<td>•</td>
<td>bullet</td>
<td>Ctrl + 8</td>
</tr>
<tr>
<td>.</td>
<td>centered period</td>
<td>Shift + 0</td>
</tr>
<tr>
<td>◊</td>
<td>lozenge</td>
<td>Shift + v</td>
</tr>
</tbody>
</table>

### Punctuation

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>question down</td>
<td>Shift + /</td>
</tr>
<tr>
<td>!</td>
<td>exclamation down</td>
<td>Ctrl + 1</td>
</tr>
<tr>
<td>...</td>
<td>ellipsis</td>
<td>Ctrl + ;</td>
</tr>
<tr>
<td></td>
<td>non-breaking space</td>
<td>Alt + Spacebar</td>
</tr>
<tr>
<td>-</td>
<td>soft hyphen</td>
<td>Ctrl + - (hyphen)</td>
</tr>
<tr>
<td>–</td>
<td>en dash</td>
<td>Ctrl + - (hyphen)</td>
</tr>
<tr>
<td>—</td>
<td>em dash</td>
<td>Shift + Ctrl + - (hyphen)</td>
</tr>
<tr>
<td>“</td>
<td>typographer’s open quotes</td>
<td>Ctrl + [</td>
</tr>
<tr>
<td>”</td>
<td>typographer’s close quotes</td>
<td>Shift + Ctrl + ]</td>
</tr>
<tr>
<td>’</td>
<td>open single quote</td>
<td>Ctrl + ]</td>
</tr>
<tr>
<td>’</td>
<td>close single quote</td>
<td>Shift + Ctrl + ]</td>
</tr>
<tr>
<td>“</td>
<td>double quote low</td>
<td>Shift + Ctrl + ;</td>
</tr>
<tr>
<td>’</td>
<td>single quote low</td>
<td>Shift + Ctrl + ]</td>
</tr>
<tr>
<td>«</td>
<td>opening guillemot</td>
<td>Ctrl + \</td>
</tr>
<tr>
<td>»</td>
<td>closing guillemot</td>
<td>Shift + Ctrl + \</td>
</tr>
<tr>
<td>‘</td>
<td>opening single guillemot</td>
<td>Shift + Ctrl + &lt;</td>
</tr>
<tr>
<td>’</td>
<td>closing single guillemot</td>
<td>Shift + Ctrl + &gt;</td>
</tr>
</tbody>
</table>
## CURRENCY AND NUMERIC

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>¢</td>
<td>cent</td>
<td>Ctrl Alt + 4</td>
</tr>
<tr>
<td>£</td>
<td>pound sterling</td>
<td>Ctrl Alt + 3</td>
</tr>
<tr>
<td>¥</td>
<td>yen</td>
<td>Ctrl Alt + y</td>
</tr>
<tr>
<td>₤</td>
<td>general currency</td>
<td>Shift Ctrl Alt + 4</td>
</tr>
<tr>
<td>$f$</td>
<td>florin</td>
<td>Ctrl Alt + f</td>
</tr>
<tr>
<td>/</td>
<td>fraction</td>
<td>Shift Ctrl Alt + 3</td>
</tr>
<tr>
<td>°</td>
<td>degree</td>
<td>Shift Ctrl Alt + 8</td>
</tr>
<tr>
<td>%0</td>
<td>per thousand</td>
<td>Shift Ctrl Alt + 5</td>
</tr>
</tbody>
</table>

## MATHEMATICAL

Not all the characters appear in every font. If your font doesn’t have a character you need, use the URW SymbolPS font instead for that one character.

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>≠</td>
<td>not equal</td>
<td>Ctrl Alt + =</td>
</tr>
<tr>
<td>≈</td>
<td>approximately equal</td>
<td>Ctrl Alt + x</td>
</tr>
<tr>
<td>≤</td>
<td>less than or equal</td>
<td>Ctrl Alt + , (comma)</td>
</tr>
<tr>
<td>≥</td>
<td>greater than or equal</td>
<td>Ctrl Alt + . (period)</td>
</tr>
<tr>
<td>±</td>
<td>plus/minus</td>
<td>Shift Ctrl Alt + =</td>
</tr>
<tr>
<td>÷</td>
<td>division</td>
<td>Ctrl Alt + /</td>
</tr>
<tr>
<td>∞</td>
<td>infinity</td>
<td>Ctrl Alt + 5</td>
</tr>
<tr>
<td>∫</td>
<td>integral</td>
<td>Ctrl Alt + b</td>
</tr>
<tr>
<td>¬</td>
<td>logical not</td>
<td>Ctrl Alt + l</td>
</tr>
<tr>
<td>√</td>
<td>radical</td>
<td>Ctrl Alt + v</td>
</tr>
<tr>
<td>Π</td>
<td>Pi</td>
<td>Shift Ctrl Alt + p</td>
</tr>
<tr>
<td>π</td>
<td>pi</td>
<td>Ctrl Alt + p</td>
</tr>
<tr>
<td>Δ</td>
<td>Delta</td>
<td>Ctrl Alt + j</td>
</tr>
<tr>
<td>μ</td>
<td>mu</td>
<td>Ctrl Alt + m</td>
</tr>
<tr>
<td>∂</td>
<td>partial differential</td>
<td>Ctrl Alt + d</td>
</tr>
<tr>
<td>Ω</td>
<td>Omega</td>
<td>Ctrl Alt + z</td>
</tr>
<tr>
<td>Σ</td>
<td>Sigma</td>
<td>Ctrl Alt + w</td>
</tr>
</tbody>
</table>
## ACCENTS

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>`</td>
<td>acute</td>
<td>Ctrl + e then Spacebar</td>
</tr>
<tr>
<td>^</td>
<td>circumflex</td>
<td>Ctrl + i then Spacebar</td>
</tr>
<tr>
<td>\</td>
<td>grave</td>
<td>Ctrl + ` then Spacebar</td>
</tr>
<tr>
<td>&quot;</td>
<td>dieresis</td>
<td>Ctrl + u then Spacebar</td>
</tr>
<tr>
<td>~</td>
<td>tildes</td>
<td>Ctrl + n then Spacebar</td>
</tr>
<tr>
<td>`</td>
<td>macron</td>
<td>Shift + Ctrl + Alt + w</td>
</tr>
<tr>
<td>~</td>
<td>breve</td>
<td>Shift + Ctrl + Alt + z</td>
</tr>
<tr>
<td>.</td>
<td>dot accent</td>
<td>Shift + Ctrl + Alt + d</td>
</tr>
<tr>
<td>v</td>
<td>caron</td>
<td>Shift + Ctrl + Alt + s</td>
</tr>
<tr>
<td>.</td>
<td>ring accent</td>
<td>Shift + Ctrl + Alt + r</td>
</tr>
<tr>
<td>&quot;</td>
<td>Hungarian umlaut</td>
<td>Shift + Ctrl + Alt + u</td>
</tr>
<tr>
<td>.</td>
<td>ogonek</td>
<td>Shift + Ctrl + Alt + y</td>
</tr>
<tr>
<td>.</td>
<td>cedilla</td>
<td>Shift + Ctrl + Alt + e</td>
</tr>
</tbody>
</table>
A

abbreviations, for units of measure, 3.19
accelerators (keyboard), 2.29
accented characters, 3.27, A.2 to A.3, A.6
access codes, entering in GeoDex card files, 10.3
activating windows, 3.8
active area, 3.2
active window, 3.8
Address Book appliance, 4.3
address card file, 4.3, See also GeoDex
Advanced Workspace
  described, 1.6
  entering, 2.4
alarm function. See GeoPlanner
Aldus Pagemaker, capturing images for export to, 7.2
Alt-key combinations, 2.27, 3.15, 3.20, 16.12
appliances, 2.4, 4.1 to 4.5
  in Beginner Workspace, 1.4
  exiting, 4.2
  opening, 4.2
applications, 3.6
  exiting, 2.28, 2.29, 3.31, 3.36
  starting, 3.16, 3.29 to 3.30
  starting automatically, 2.9
  switching between, 2.18, 3.8, 3.16, 3.30
  See also extras
Apply (dialog box option), 3.18
appointment calendar. See GeoPlanner
archive files, 12.8 to 12.9
area codes, using as indexes in card file, 10.2
arithmetic operations. See Calculator
arrow keys
  menu selections with, 3.15
  text cursor repositioning with, 3.24
arrows, on box options, 3.18 to 3.19
arrow-style pointer, 2.15, 3.2, 11.3
ASCII (DOS) files
  importing into GeoWrite, 14.22 to 14.23
  opening/editing with Notepad, 15.1, 15.3
aspect ratio adjustments, 3.42

B

backgrounds, customizing, 16.4 to 16.5
Backspace key, 1.3, 2.11, 3.24
Banner appliance, 4.4
BANNERS folder, 8.3
batch files
  creating/editing for DOS Program screen, 6.4 to 6.5
  starting from GeoManager, 12.3
Batch File Text dialog box, 6.5
.BAT filename extensions, 6.5
baud rate, 9.3
Beginner Workspace
  described, 1.4
  entering, 2.4
  blinking line cursor, 3.27
  body area, 2.10
  boldface type, 2.13, 3.41, 14.3
  borders, 14.11 to 14.12
    in spreadsheets, 17.6, 17.7, 17.8
  boxes. See check boxes; dialog boxes
  Browse View, of GeoDex, 10.2
  bullets, 3.27, 14.3, A.4
  buttons
    Close, 3.10
    Control, 2.29, 3.7
    creating for DOS Programs screen, 6.3 to 6.4
    default, 3.18
    in dialog boxes, 3.17 to 3.18
    "dimmed" versus lit up, 2.9, 3.12
    Express, 2.18, 3.7
    for floppy disks, 8.3
    how they work, 3.4 to 3.5
    Maximize/Restore, 3.7
    on the mouse, 2.6, 3.3
    radio, 2.18, 3.18
  Calculator, 4.3, 5.1 to 5.2
    changing options, 5.3 to 5.4
    cutting and pasting, 5.3
    error indicator, 5.3
    operating, 5.2
    Reverse Polish Notation (RPN), 5.4
    using the memory, 5.3
  calendar
    with Planner appliance, 4.4
    See also GeoPlanner
  Cancel (dialog box option), 3.18
  canceling
    printing, 3.39
    Quick Copy/Quick Move, 3.29
    See also exiting
  Cap Lock key, 16.12
  capturing
    "pictures" of screens, 7.1 to 7.5
    screens within GeoComm, 9.7 to 9.8
  card games, Solitaire, 4.5, 19.1 to 19.4
  cards
    adding to GeoDex card file, 10.2 to 10.3
    with Address Book appliance, 4.3
    editing, 10.4
    flipping through, 10.3
  CARDS folder, 8.3
  carriage returns
    adding/deleting for telecommunications, 9.4
    unnecessary at end of lines, 2.11, 14.2
    cascade menus, 3.13, 3.15
case sensitivity, of searches, 10.8, 13.9, 13.11
centering of text, 14.3, 14.8 to 14.9
See also justifying text
centimeters (cm), 3.19, 14.9
correcting character spacing, 14.5 to 14.6
centers, 17.3 to 17.5, 17.8 to 17.10
check boxes, 3.18
Checksum, 9.9
choosing. See selecting; starting
Ci (Ciceros), 3.19, 14.9
circles, drawing in GeoDraw, 11.5
circle/slash-style pointer, 3.2, 3.17
clicking the mouse buttons, 2.6, 2.13, 2.14, 3.2, 3.4, 3.5
Clipart
browsing in, 2.20
opening, 2.19
clipboard, 2.20
copying charts to, 17.9
copying to, 2.25
copying to/from Calculator, 5.3
retention/erasure of images in, 2.25
saving GeoComm communications to, 9.6
text handling with, 3.28 to 3.29
Close button, 3.10
Close (dialog box option), 3.18
Close (File menu option), 3.36
closing
dialog boxes, 3.18
directories, 3.21, 12.14
documents, 2.28, 3.32, 3.36
windows, 3.11, 3.34
Centimeters, 3.19, 14.9
collapsing directories, 12.11
Collate (Print dialog box option), 3.36 to 3.37
color
for background images, 16.4 to 16.5
filling GeoDraw objects with, 11.12 to 11.13
in GeoWrite documents, 14.12 to 14.14
column breaks, 14.17
columns
in GeoWrite documents, 14.17 to 14.18
in spreadsheets, 17.7
COM1/COM2 ports, 16.6
command line options, from DOS Programs screen, 6.3
to 6.4
commas, for pausing modems, 9.5, 10.3
computer, turning off, 2.30
CONFIG.SYS file, and task switching, 21.3
confirmation messages, 12.15
Control button, 2.29, 3.7, 3.9
Control menu, 3.9 to 3.10
close (dialog box option), 3.18
close (File menu option), 3.36
closing
directories, 3.21, 12.14
documents, 2.28, 3.32, 3.36
windows, 3.11, 3.34
COM1/COM2 ports, 16.6
command line options, from DOS Programs screen, 6.3
to 6.4
commas, for pausing modems, 9.5, 10.3
computer, turning off, 2.30
CONFIG.SYS file, and task switching, 21.3
confirmation messages, 12.15
control button, 2.29, 3.7, 3.9
Control menu, 3.9 to 3.10
Control mode (of Screen Dumper), 7.4
Copy (Edit menu option), 3.28
Copying
enlarged/reduced images, 2.20
files and directories, 7, 8.5 to 8.7, 12.6 to 12.8
floppy disks, 12.13
and pasting objects in GeoDraw, 11.11
spreadsheets, 17.6
tabs, 14.6
to/from clipboard, 2.20, 2.25
See also cut and paste operations
copyright symbol, 3.27, A.4
Correct for Aspect Ratio (View menu option), 3.42
CRC (Cyclic Redundancy Check), 9.9
crosshair-style pointer, 11.4
Ctrl key
combinations with other keys, 3.14, 16.12
this manual's depictions of, 1.3
currency formats, 16.9 to 16.10
currency symbols, A.4
current paragraph, 2.15
cursor
blinking line, 3.27
disabling for screen dumps, 7.2
in GeoComm, 9.2
text-style, 2.10
See also pointers
curved arrow-style pointer, 2.23, 11.4
customizing
borders, 14.11 to 14.12
GeoManager, 12.14 to 12.15
GeoWorks Pro (Preferences), 16.1 to 16.5, 16.9 to 16.12
GeoWrite, 14.18 to 14.19
keyboards, 16.12 to 16.13
modem, 16.14 to 16.15
mouse, 16.13 to 16.14
printers, 16.6 to 16.7
spelling checker, 14.22
video adapters, 16.8 to 16.9
Viewer, 17.11 to 17.12
cut and paste operations
with Calculator, 5.3
from clipboard, 3.28 to 3.29
from GeoPlanner, 13.3
from Scrapbook, 2.19 to 2.26, 18.2, 18.3, 18.5
See also copying
Cut (Edit menu option), 3.28

daily diary
in Planner appliance, 4.4
See also GeoPlanner
dashes (-), in phone numbers, 10.3
data bits, 9.3
date
setting on your computer, 16.3 to 16.4
date book
with Planner appliance, 4.4
See also GeoPlanner
decimals
setting in Calculator, 5.3 to 5.4
setting in GeoWrite, 14.6, 14.12
decimal tabs, 14.6, 14.12
default buttons, 3.18
defusing objects in GeoDraw, 11.6, 11.14 to 11.15
Delete (Del) key, 2.11, 3.24
deleting
column breaks, 14.18
files or directories, 8.7 to 8.8, 12.8
GeoDex file cards, 10.4
GeoDraw objects, 11.11
GeoPlanner repeating events, 13.7
headers and footers, 14.16
page breaks, 14.17
printers, 16.7
Scrapbook pages, 18.3
text, 1.3, 2.11, 3.24, 3.26
title pages, 14.16
words from user dictionary, 14.21 to 14.22
destination directory, 8.6, 12.6
dialing phone numbers. See GeoComm; GeoDex
dialog boxes, 2.9, 3.17 to 3.19
file selector, 2.16
responding to, 3.19 to 3.20
diamonds (radio buttons), 2.18, 3.18
dictionaries, for spell checking, 14.19
“dimmed” versus lit up buttons, 2.9, 3.12
direct manipulation, 3.3
directories
changing, 12.5
closing, 3.21, 12.14
creating, 8.5, 12.5
deleting, 8.7 to 8.8
displaying as tree, 12.11 to 12.12
displaying in compressed mode, 12.5
displaying number of, 8.2, 12.2
as file folders, 2.8, 8.3, 12.3
for GeoWorks Pro, 2.3
getting information about, 8.8, 12.9
moving and copying, 8.5 to 8.7, 12.6 to 12.7
naming or renaming, 3.6, 12.6
opening, 3.21, 8.4, 12.3 to 12.4
opening on other disks, 8.4
parent, 2.8, 12.4
selecting for file saves, 2.17
viewing as list, 12.10
Disable Blinking Cursor option, 7.3
disk drives. See drives
disks, managing in GeoManager, 12.12 to 12.14
disk space, display of, 8.2, 12.2
DOCUMENT directory, 8.4, 12.3 to 12.4
documents, 3.6
closing, 2.28, 3.32, 3.36
icons for, 2.7, 2.9, 8.3
naming, 2.16, 3.6, 3.35
opening, 3.31 to 3.32, 3.36, 8.3
opening in GeoWrite, 2.10, 3.30
opening in Scrapbook, 2.19
opening multiple, 3.33
pagination of, 14.16
pasting images into, 2.26
printing, 2.27, 3.36 to 3.39
safeguard feature for, 16.3
saving, 2.16, 2.28, 3.34 to 3.35, 3.36
sizing in GeoDraw, 11.3
templates for, 1.7
See also text
DOS
exiting to, 3.16
exiting to GeoWorks Pro, 1.7, 6.2 to 6.3
naming files in, 3.6
running from DOS Programs screen, 1.7, 6.2 to 6.3
running from GeoManager, 12.3
and task switching, 21.1 to 21.8
DOS files
changing attributes of, 12.8 to 12.9
opening/editing with Notepad, 15.1, 15.3
saving GeoComm communications as, 9.7, 9.8
telecommunicating via GeoComm, 9.6 to 9.7
DOS Programs screen, 1.7, 6.1 to 6.2
creating/deleting buttons for, 6.3 to 6.4
creating/editing batch files, 6.4 to 6.5
entering, 1.4, 2.4
running DOS programs from, 6.2 to 6.3
DOSSHELL utility, switching GeoWorks Pro with, 21.2
dotted margin area, 11.2
double-clicking the mouse, 2.13, 3.5
dragging the mouse, 2.12, 3.6, 3.12 to 3.13, 3.23
drawing area, 2.21, 11.2
drawing. See GeoDraw
drawing space, 2.23
DR-DOS and TaskMAX environment, 21.3 to 21.8
drives
buttons for, 12.3
rescanning in GeoManager, 12.14
switching, 3.21
DUMP00 files, 7.2
duplex, 9.4

E
editing
batch files, 6.5
GeoDex file cards, 10.4
GeoDraw text, 11.13 to 11.14
GeoPlanner calendar events, 13.4
GeoWrite text, 2.12
with keyboard, 3.26 to 3.27
spreadsheets, 17.5
Edit menu, 3.28 to 3.29
electronic date book. See GeoPlanner
ellipsis (…)
in dialog boxes, 3.17
key combination for, A.4
F

F2, return to Welcome screen, 1.4, 3.16
F3, Exit, 2.29

F5, Spell Checking, 14.19
file attributes, 12.8 to 12.9, 12.10
File Cabinet, 1.5, 8.1 to 8.2
creating documents from, 3.31
entering, 2.7
exiting, 8.9
recalling, 2.18
file icons, 3.4
File menus, in all GeoWorks applications, 3.11, 3.36
filename extensions, 3.6
.BAT, 6.5
.EPS, 17.3
.MAC, 9.10
specifying for Viewer lookups, 17.12
.WK1, 17.3
.WQ1, 17.3
files
deleting, 8.7 to 8.8
display of number of, 8.2, 12.2
getting information about, 8.8, 12.9
as icons in GeoManager, 12.1
importing into GeoDraw, 11.16
importing to/from GeoWrite, 14.22 to 14.23
moving and copying, 8.5 to 8.7, 12.6 to 12.7
renaming, 2.16, 3.6
read-only, archive, system and hidden, 12.8 to 12.9, 12.12
renaming, 8.5
telecommunicating. See GeoComm
viewing as list, 12.10
See also documents
file selector dialog box, 2.16 to 2.17
file selectors, 3.20 to 3.21
how to use, 3.21 to 3.22
filled objects, 11.12
flipping GeoDraw objects, 11.10
floppy disks
buttons for, 8.3, 12.3
copying, 12.13
formatting, 8.8 to 8.9, 12.12 to 12.13
renaming, 12.13 to 12.14
folder icons, 3.4
folders
as icons for directories, 2.7, 8.3, 12.3
opening, 2.8
fonts, 3.40
changing, 2.13
choosing and changing, 3.40 to 3.41
converting with Nimbus Font Converter, 7.6 to 7.7
for GeoComm displays, 9.3
monospaced and proportional, 14.2
in spreadsheets, 17.7 to 17.8
Fonts menus, 3.40 to 3.41
footers and headers, 14.4, 14.15 to 14.16
foreign language accent marks, 3.27, A.2 to A.3, A.6
formatting
floppy disks, 8.8 to 8.9, 12.12 to 12.13
text in GeoWrite, 14.5 to 14.6, 14.8 to 14.9
FORMS folder, 8.3
full-size windows, 3.32, 3.34, 12.4 to 12.5
fusing and defusing objects in GeoDraw, 11.6, 11.14 to 11.15

G

games
  Solitaire, 4.5, 19.1 to 19.4
  Tetris, 20.1 to 20.4
GeoComm, 9.1
  communicating, 9.5 to 9.7, 9.8 to 9.9
  main window, 9.2 to 9.3
  protocol, terminal and modem settings, 9.3 to 9.5
  saving while communicating, 9.7 to 9.8
  showing status, 9.10
  using scripts, 9.10 to 9.12
GeoDex, 10.1 to 10.2
  adding cards to, 10.2 to 10.3
  browsing/searching through, 10.6 to 10.7
  dialing phone numbers from, 10.4 to 10.6
  editing/deleting cards, 10.4
  flipping through cards, 10.3
  linking to GeoPlanner calendar, 10.8, 13.11 to 13.12
  printing from, 10.8
  Quick Dial feature, 10.4 to 10.5
GeoDraw, 11.1 to 11.2
  colors/patterns/styles of objects, 11.11 to 11.13
  copying and pasting objects, 11.11
  copying spreadsheets into, 11.6
  creating objects, 11.3 to 11.7
  deleting objects, 11.11
  editing text, 11.13 to 11.14
  fusing and defusing objects, 11.14 to 11.15
  importing images from other applications, 11.16
  main window, 11.2 to 11.3
  moving and rotating objects, 11.8 to 11.9
  pasting images into documents, 2.21
  selecting objects, 11.7 to 11.8
  setting document size, 11.3
  speeding up, 11.10
  stacking objects, 11.14
GeoManager, 1.6, 12.1 to 12.2
  customizing, 12.14 to 12.15
  directory and file handling, 12 to 3 to 12.12
  disk handling, 12.12 to 12.14
  exiting, 12.15
  launching DOS programs or batch files, 12.3
  main window, 12.2 to 12.3
  viewing charts or spreadsheets from, 17.4
GeoPlanner, 13.1 to 13.2
  alarm function, 13.5, 13.11, 16.2, 16.5
  customizing, 13.10 to 13.11
  linking to GeoDex card file, 10.8, 13.11 to 13.12
  printing calendars/event schedules, 13.9
  scheduling/deleting events, 13.3 to 13.4
  scheduling repeating events, 13.5 to 13.8
  searching for events, 13.9
  viewing calendar, 13.2 to 13.3
  View menu, 13.10
GEOWORKS directory, 2.3
GeoWorks Pro
  customizing, 16.1 to 16.5, 16.9 to 16.12
  in the DOS environment, 21.1 to 21.3
  in the DR-DOS and TaskMAX environment, 21.3 to 21.8
  exiting, 2.30
  installing, 2.2
  overview of, 1.1 to 1.7
  returning to after DOS operations, 6.2 to 6.3
  starting, 2.3
  in the Windows 3.0 environment, 21.8
GeoWrite, 14.1 to 14.3
  borders, 14.11 to 14.12
  color, 14.12 to 14.14
  columns, 14.17 to 14.18
  compared to Notepad, 15.2
  copying spreadsheets into, 17.6
  creating documents in, 2.10
  customizing, 14.18 to 14.19
  file exchanges, 14.22 to 14.23
  formatting text, 14.5 to 14.6, 14.8 to 14.9
  graphics, 14.14 to 14.15
  headers and footers, 14.15 to 14.16
  main window, 14.4 to 14.5
  margins, 14.8
  page breaks, 14.17
  paragraph spacing, 14.9 to 14.10
  spell checking, 14.19 to 14.22
  styles, 14.10 to 14.11
  tables, 14.12
  tabs, 14.6 to 14.7
  title pages, 14.16
  graphics
    in GeoWrite documents, 14.14 to 14.15
    handling with clipboard, 3.28 to 3.29
    placement of, 16.4

H

halftones, 11.13, 14.13, 14.14
handles, for handling objects, 2.21, 11.4
handshake, 9.3
hanging indents, 14.8
Hayes-compatible modems, 9.4, 10.4
headers and footers, 14.4, 14.15 to 14.16
help
  accessing, 3.43
  for installing GeoWorks Pro, 2.2
hidden files, 12.8 to 12.9, 12.12
highlighting
  button options, 2.9, 3.12
items on screen, 3.22
HIMEM.SYS file, 16.8
hourglass-style pointer, 2.5, 3.2

I
I-beam style pointer, 2.5, 2.10, 3.2, 11.4
icons, 3.4
  converting windows to, 3.8
  for directories (folders), 2.7, 2.8, 12.3
  for documents, 2.7, 2.9, 8.3
  files as, 1.6, 12.1
  for paragraph styles, 2.15
  push-pin, 3.14
  for templates, 8.3
  for Text Tool, 2.22
  used in File Cabinet, 8.2 to 8.3
images. See clip art; GeoDraw; Scrapbook
importing
  files into GeoDraw, 11.16
  files into GeoWrite, 14.22 to 14.23
inches (in), 3.19, 14.9
indenting paragraphs, 2.15, 14.3
inserting text, 2.12, 3.27
Insert (Ins) key, 3.27
insertion point (text cursor), 2.10, 3.24
insert mode, 3.27
installing
  GeoWorks Pro, 2.2
  mouse for Quattro Pro SE, 17.3
  printers, 16.6 to 16.7
Quattro Pro SE, 17.2 to 17.3
Intermediate Workspace
  described, 1.5
  entering, 2.4, 8.1
interrupt levels, 16.8, 16.14
invisible windows, 3.32
italics, 2.13, 3.41, 14.3

J
justifying text
  in GeoDraw, 11.13 to 11.14
  in GeoWrite, 14.8 to 14.9
  with ruler, 2.15

K
kerning, 14.5
keyboard
  of Calculator, 5.2
  customizing, 16.12 to 16.13
  responding to dialog boxes with, 3.19 to 3.20
  this manual's depictions of, 1.3
  using instead of the mouse, 3.15
keyboard accelerators, 2.29, 3.14

L
labels, printing from GeoDex, 10.8
language accent marks, 3.27, A.2 to A.3, A.6
LANs (local area networks), 21.2
leaders, 14.7
leading, 14.9 to 14.10
line properties, 11.12
lines
  drawing in GeoDraw, 11.4 to 11.5
  vertical, 14.7, 14.18
lines of text, highlighting, 2.14
list windows, 3.32
Lotus 1-2-3
  starting, 17.12
  viewing files from, 17.2
LPT1/LPT2 ports, 16.6

M
.MAC filename extensions, 9.10
magnifying images or text, 2.20, 3.41 to 3.42
  in GeoDraw, 11.3
mailing labels, printing from GeoDex, 10.8
margins
  with headers and footers, 14.15
  using ruler for, 2.15, 14.8
mathematical operations. See Calculator
mathematical symbols, A.4
Maximize/Restore button, 3.7, 3.9, 3.10
measurements, abbreviations and units of, 3.19, 14.9
meeting calendar
  with Planner appliance, 4.4
  See also GeoPlanner
memory
  expanded, 16.8
  freeing by closing applications, 3.29
  using in Calculator, 5.3
  viewing use of (Perf utility), 7.7 to 7.8
menu bars, 2.13, 3.7
menu names, 3.7
menus, 2.13, 3.11
cascading, 3.13, 3.15
exiting, 3.15
how to use, 3.12 to 3.15
items “dimmed” versus lit up, 2.9, 3.12
navigating with keyboard, 3.15
pinning, 3.13 to 3.14

See also individual menus by name

millimeters (mm), 3.19, 14.9
Minimize button, 3.8, 3.9, 3.10
minus sign (-), as expanded directory display indicator, 12.11
mm (millimeters), 3.19, 14.9
mnemonics
for dialog box options, 3.20
for menu items, 3.15
modem
customizing, 16.14 to 16.15
Hayes compatible, 10.4
required for phone dialing, 10.2
setting up for GeoComm, 9.3, 9.4 to 9.5
signaling pauses for, 9.5, 10.3
monitors, customizing, 16.8 to 16.9
monospaced fonts, 14.2
mouse
clicking, 2.6, 3.2, 3.5
customizing, 16.13 to 16.14
double-clicking, 2.13, 3.5
dragging, 2.12, 3.6
how to use, 2.5, 3.3
installing for Quattro Pro SE, 17.3
multiple-clicking, 2.14, 3.5
pressing the, 3.5
selecting paragraphs with, 2.14
using keyboard instead of, 3.15
move handle, 11.4
moving
files and directories, 8.5 to 8.7, 12.6 to 12.7
objects, 2.24
and rotating GeoDraw objects, 11.8 to 11.9
windows, 3.8
multitasking, demonstration of (3D Font Demo), 7.8

N
naming
batch files, 6.5
directories, 3.6
documents, 2.16, 3.6, 3.35
files in Notepad, 15.3
New (File menu option), 3.36
newsletter templates, 8.3
Nimbus Font Converter, 7.6 to 7.7
No (dialog box option), 3.18
Notepad, 4.2, 15.1 to 15.2
compared to GeoWrite, 15.2
NOTES.TXT file, 15.2
nudging GeoDraw objects, 11.9
number formats, 16.10
Number of Copies (Print dialog box option), 3.36 to 3.37
numeric keypad, using with Calculator, 5.2

O
objects
GeoDraw, 2.21, 11.3 to 11.4
moving, 2.24
rotating, 2.23
OK (dialog box option), 3.18
on-line communications with GeoComm, 9.5
Open (File menu option), 3.36
opening
appliances, 4.2
CLIPART folder, 2.19
directories, 3.21, 8.4, 12.3 to 12.4
directories on other disks, 8.4, 12.4
documents, 3.31 to 3.32, 3.36, 8.3
documents in GeoWrite, 2.10
documents in Scrapbook, 2.19
folders, 2.8
templates, 2.9, 8.3 to 8.4
windows, 3.8
order of operations, for Calculator calculations, 5.2
overlapping objects, 11.4
overlapping windows, 3.11, 3.33, 3.34, 12.4
overtype mode (overstrike), 3.27, 16.3

P
page breaks, 14.17
page size, in spreadsheets, 17.7
pages of text, highlighting, 2.14
pagination of documents, 14.16
paging areas, 3.10
paper, changing options for, 3.38 to 3.39
paragraphs
current, 2.15
highlighting, 2.14
indenting, 2.15, 14.3, 14.8 to 14.9
spacing, 14.9 to 14.10
symbol for, A.4
paragraph spacing, in GeoWrite documents, 14.9 to 14.10
parallel printers, 16.6
parent directories, 2.8, 12.4
parentheses (()), changing order of calculations with, 5.2
in phone numbers, 10.3
parity, 9.3
Paste (Edit menu option), 3.28
paste operations, 2.20
into GeoWrite documents, 2.26
to/from GeoDraw, 2.21, 11.11
See also cut and paste operations
path, 2.8
  displayed, 8.2
  selecting for file saves, 2.17
pattern, filling GeoDraw objects with, 11.12 to 11.13
pausing
  keyboard response, 16.12
  modem dialing, 9.5, 10.3
PCX files
  importing into GeoDraw, 11.16
  importing into Scrapbook, 18.5 to 18.6
percent sign (%), with Screen Dumper filenames, 7.2
Perf, 7.7 to 7.8
personal serial numbers, 2.4
phone numbers. See GeoComm; GeoDex
pictures. See clip art; GeoDraw; Scrapbook
PIF files, and Windows 3.0, 21.8
pinning menus, 3.13 to 3.14
pi (piacas), 3.19, 14.9
pixels, 3.42
Planner appliance, 4.4
plus sign (+), as collapsed directory display indicator, 12.11
pointers
  arrow-style, 2.15, 3.2, 11.3
  blinking line, 3.27
  circle/slash-style, 3.2, 3.17
  crosshair-style, 11.4
  hourglass-style, 2.5, 3.2
  how to use, 3.3
  I-beam style, 2.5, 2.10, 3.2, 11.4
  Quick Copy, 3.29
  Rotate, 11.3
  rotation (curved arrow-style), 2.23, 11.4
  and text cursor, 2.10
  triangle-style, 2.15
See also cursor
points
  as font size measurement, 2.13, 3.40
  "pt" abbreviation for, 3.19
polygons, drawing in GeoDraw, 11.6
ports
  interrupt levels of, 16.8, 16.14
  for mouse, 16.13 to 16.14
  for printers, 16.6
posters, with Banner appliance, 4.4
PostScript-compatible printers, 14.12
PostScript format files, 7.2, 7.3
Preference Desk Tool, for modem setup, 10.4
preferences
  choosing for GeoPlanner, 13.10 to 13.11
  choosing with Systems Preferences (Express menu option), 3.16
  setting for modems, 10.4
Prefix box, of GeoDex Dialing Options window, 10.3
pressing the mouse, 3.5
Print dialog box, 2.27, 3.36 to 3.39
Printer Control Panel (Express menu option), 3.16, 3.39
Printer Options (Print dialog box option), 3.36 to 3.37
printers
  changing options for, 3.38 to 3.39
  customizing, 16.6 to 16.7
  installing, 16.6 to 16.7
  PostScript-compatible, 14.12
Print (File menu option), 3.36 to 3.39
printing
  calendars/event schedules from GeoPlanner, 13.9
  data from GeoDex card file, 10.8
  documents, 2.27, 3.36 to 3.39
Print Pages (Print dialog box option), 3.36 to 3.37
print quality, 3.37
Print Quality (Print dialog box option), 3.36 to 3.37
properties boxes, 11.11
proportional fonts, 14.2
protocols for telecommunications, 9.3
pt (points), 3.19
pull-down menus, 3.11
punctuation characters, A.4
push-pin icon, 3.14

Q
QEMM.SYS file, 16.8
quadruple-clicking the mouse, 2.14, 3.5
Quattro Pro SE
  file imports into GeoDraw, 11.16
  installing, 17.2 to 17.3
  starting, 17.5
  Quick Copy feature, 3.29
  Quick Dial (GeoComm Dial menu option), 9.5
  Quick Dial (GeoDex Dial menu option), 10.4 to 10.5
  Quick Move feature, 3.29
quintuple-clicking the mouse, 2.14, 3.5
quotation marks formats, 16.10 to 16.11, A.4

R
radio buttons, 2.18, 3.18
read-only files, 12.8 to 12.9, 12.15
rectangles, drawing in GeoDraw, 11.5 to 11.6
rectangular aspect ratio, 3.42
reducing images, 2.20
registration card, 2.2
renaming
  files and directories, 8.5, 12.6
  floppy disks, 12.13 to 12.14
  Scrapbook pages, 18.4
Repeat 3. rate (keyboard), 16.12
rescanning drives in GeoManager, 12.14
Reset (dialog box option), 3.18
Restore button, 3.7, 3.9
Return (Enter) key
for default option, 3.19, 3.20
unnecessary at end of lines, 2.11, 14.2
Reverse Polish Notation (RPN), 5.3 to 5.4
Revert command, 3.36
Revert (File menu option), 3.36
Rotate pointer, 11.3, 11.4
rotating
GeoDraw objects, 11.8 to 11.9
text, 2.23
RPN (Reverse Polish Notation), 5.3 to 5.4
ruler, 2.15, 14.4, 14.9
"snap-to" feature, 14.18
rules, drawing for tables and columns, 14.7

Save As (File menu option), 3.36
Save (File menu option), 3.36
versus Save As command, 2.28, 3.35
saving
documents, 2.16, 2.28, 3.34 to 3.35, 3.36
to other directories or disk drives, 3.21 to 3.22
scaling Scrapbook images, 18.4
scheduling events
with Planner appliance, 4.4
See also GeoPlanner
Scrapbook, 18.1
adding and deleting scraps, 18.2 to 18.4
browsing in, 2.20
cutting and pasting images to/from, 2.21 to 2.26
importing images to, 18.5 to 18.6
main window, 18.2
and multiple scrapbooks, 18.5
opening documents in, 2.19
scaling images from, 18.4
screen blanking, 16.8 to 16.9
Screen Dumper, 7.1 to 7.5
screens
capturing "pictures" of, 7.1 to 7.5
capturing within GeoComm, 9.7 to 9.8
scripting language commands, 9.11 to 9.12
scripts, using with GeoComm, 9.10 to 9.12
scroll arrows, 3.10
scroll-back buffer, 9.7
scroll bars, 2.20, 3.8, 3.10
hiding, 14.18 to 14.19
scrolling, windows, 3.10 to 3.11
scrolling list, 3.19
searching
for card file data, 10.6 to 10.7

INDEX
T

tabl ead e rs, 14.7
t a b la st es , c r e at in g in GeoW ri t e, 14.12
t a b s , 14.3, 14.6 to 14.7
tab we l l, 14.6
TaskMAX and DR-DOS environment, 21.3 to 21.8
task switchers, and GeoWorks Pro, 21.1 to 21.2
telecommunications application. See GeoComm
telephone numbers. See GeoComm; GeoDex
templates, 1.5, 1.7, 8.3
tex t a d d in g t o d o c u m e n t s, 2.10 to 2.11
tex t a d d in g t o pi c tu r e s, 2.22
tex t c u r so r, 2.10, 3.24
tex t f i e l d s, 3.19
tex t f i l e s (A SCII f i l e s), 14.22 to 14.23
tex t M o d e O nl y (P r i n t d i a log b o x o pti o n), 3.37
tex t s i z e c h a n g in g in No t e p a d, 15.2 to 15.3
Un.do o p e r a ti o n s
in GeoDex, 10.4
in GeoPlanner, 13.4
with Revert command, 3.36
units of measure, 3.19
URW fonts, converting with Nimbus Font Converter, 7.6
to 7.7
user dictionary, 14.19, 14.21
utiliti es. See applications; extras

V

vertical l i n es o r r u l e s, 14.7, 14.18
video a d a p t e rs, c u sto m i z i n g, 16.8 to 16.9
Viewer, 17.1 to 17.2
and charts, 17.8 to 17.10
copying s prea d s h ee t s, 17.6
creating s prea d s h ee t s, 17.5 to 17.6
customizing, 17.11 to 17.12
dealing w i t h l ar ge s prea d s h ee t s, 17.7 to 17.8
tool b ox, 17.10
viewing s prea d s h ee t s, 17.2 to 17.5
View m e nu, e nl a r g i n g i m ages from, 2.20

W

Wastebasket, for file d e le ti o n, 3.4
Welcome s cre en, 1.3, 2.4
bypassing, 16.3
returning to, 3.16, 6.2
well, of Tetris, 20.2
white-on-black t ex t, 14.13
Window m e nu, 3.34
windows, 2.7, 3.7
activating, 2.20, 3.8
capturing w i t h Sc reen D ump e r, 7.4 to 7.5
closing, 3.11, 3.34
converting to icons, 3.8
enlarging/reducing, 3.7, 3.8, 3.9
full-sized (invisible), 3.32, 3.34, 12.4
moving, 3.8
overlapping, 3.11, 3.33, 3.34, 12.4
scrolling, 3.10 to 3.11
switching between, 2.18
.WK1 f i l e n a m e e xt e n s i o n s, 17.3
word p r o c e s s o r s, 14.2 to 14.3
workspa ce, 2.6
background of, 16.4 to 16.5
WORLD directory, 12.3 to 12.4

I N D E X
X
XMODEM protocol, 9.8 to 9.9

Y
Yes (dialog box option), 3.18

Z
zip codes, using as indexes in card file, 10.2
zooming in and out, 3.41 to 3.42
    in GeoDraw, 11.3
GeoWorks Pro™ delivers two great products for the price of one—GeoWorks Ensemble™ and Borland’s Quattro™ Pro Special Edition. Together, these two award winning products give you the easiest and most complete integrated solution for your business computer.

**Everything You Need in One Package**
- Quattro Pro Special Edition spreadsheet with Database and Charting
- GeoWrite™ word processor
- GeoDraw™ drawing program
- GeoManager™ file and disk manager
- GeoDex® address book and label maker
- GeoPlanner™ schedule planner
- GeoComm® communications program
- Six software “Appliances” designed for the beginner, including Banner Maker
- Two games: Solitaire and Tetris™
- America Online® electronic information service.

**Making it Work**
Whether you’ve never touched a computer before or already have some computer experience under your belt, GeoWorks Pro is a breeze to use. All GeoWorks applications are based on PC/GEOS®, the incredibly easy, windowing, graphical environment, so they work the same easy “point-and-click” way. Quattro Pro Special Edition features intuitive pull down menus and dialog boxes which make it the easiest to use full featured spreadsheet for the PC.