COPYRIGHT
&
TRADEMARK

All application software and GEOS® operating system software Copyright © 1990 - 1993 GeoWorks. All rights reserved. Patent pending. Images Copyright © 1991 - 1993 GeoWorks. All rights reserved.


Electronic Thesaurus licensed from Houghton Mifflin Company. Copyright © 1985 by Houghton Mifflin Company. All rights reserved. Thesaurus U.S. Pat. No. 4,724,523. Reproduction or disassembly of embodied programs or database prohibited. Based upon Roget's II: The New Thesaurus.

Hardware and software floating point math library Copyright © 1984-91 Dimensions Research, Inc.

Word for Word text conversion software Copyright © 1986-1993, Mastersoft, Inc. All rights reserved.

This software contains Nimbus Q from Digital Typeface Corp. and typefaces from URW, GmbH.

Tetris is a registered trademark of Electronorgtechnica. Tetris Copyright © v/o Electronorgtechnia 1987. All rights reserved. Tetris copyright and trademark licensed to Spectrum HoloByte, Inc. and sublicensed to GeoWorks. Original concept by Alexey Pajitnov. GeoWorks version Copyright © 1990-1993.

GeoWorks®, GEOS®, PC/GEOS®, GeoDraw®, GeoFile®, GeoDex®GeoComm®, and GeoPlanner® are Registered Trademarks of GeoWorks. GeoWrite™, GeoBanner™, GeoCalc™, and Lights Out™ are Trademarks of GeoWorks in the United States of America and other countries.

Mastersoft® is a registered trademark of Mastersoft, Inc. in the U.S.A.

All other brand and product names are trademarks or registered trademarks of their respective holders.
1 Getting Started

WHAT ARE GEOWRITE, GEODRAW, GEOCALC, AND GEOFILE? ................................................................. 1.2
Desktop Publishing With Every Application .................................................................................. 1.3
Using GeoWrite, GeoDraw, GeoCalc, and GeoFile ........................................................................ 1.4
With the Ensemble Accessories ................................................................................................. 1.4
Saving Time With Templates .................................................................................................... 1.4
Learning With User Levels ........................................................................................................ 1.4

STARTING AND EXITING GEOWRITE, GEODRAW, GEOCALC, AND GEOFILE ......................................... 1.5
Where to Find GeoWrite, GeoDraw, GeoCalc, and GeoFile ......................................................... 1.5
Starting an Application Directly .................................................................................................. 1.5
Starting an Application by Opening a Document ....................................................................... 1.6
The First Thing You See .............................................................................................................. 1.6
Exiting an Application .................................................................................................................. 1.7

CREATING AND OPENING DOCUMENTS ............................................................................................ 1.8
The New/Open Dialog Box ........................................................................................................... 1.9
Using a Template to Create a Document ....................................................................................... 1.10
Creating a New, Empty Document ............................................................................................... 1.11
Opening an Existing Document .................................................................................................. 1.11

APPLICATION AND DOCUMENT WINDOWS .................................................................................... 1.14
Application Windows .................................................................................................................. 1.14
Document Windows .................................................................................................................... 1.16

SAVING DOCUMENTS ..................................................................................................................... 1.18
Naming a Document ..................................................................................................................... 1.19
Using Save .................................................................................................................................... 1.20
Using Save As ................................................................................................................................ 1.21
2 Tools and Techniques

CONTROLLING YOUR VIEW OF A WINDOW .............................................. 2.2
Zoom Out, Zoom In, and Normal Size ................................................. 2.3
View at %......................................................................................... 2.3
Scale to Fit..................................................................................... 2.4
Changing View Options ................................................................. 2.4
Redrawing the Screen ..................................................................... 2.5

SHOWING RULERS AND SETTING MEASUREMENT UNITS .................. 2.6

USING THE TOOL BARS ................................................................ 2.8
The Style Tool Bar .......................................................................... 2.9
The Function Tool Bar ...................................................................... 2.9
Tool Bars for Drawing and Graphics ................................................ 2.10
Displaying Tool Bars ...................................................................... 2.12
Working With Tools ....................................................................... 2.13

CUSTOMIZING THE TOOL BARS ..................................................... 2.14

SETTING OPTIONS AND SAVING YOUR CONFIGURATION ............ 2.17

SELECTING AND EDITING .............................................................. 2.18
Selecting Text ................................................................................. 2.19
3 Working With Documents

BACKING UP AND RESTORING DOCUMENTS...........................................3.2

MANAGING DOCUMENTS.......................................................................3.3
Using Copy To...................................................................................3.4
Discarding Changes...........................................................................3.6
Renaming a Document.......................................................................3.6
Editing Document Notes..................................................................3.7
Setting and Removing a Document Password.................................3.8
Default Settings for Empty Documents.............................................3.9
Setting the Document Type.............................................................3.10

MANAGING TEMPLATES.................................................................3.13
Using Templates..............................................................................3.13
Creating Your Own Template.........................................................3.15
Modifying a Template.......................................................................3.16
Removing a Template.......................................................................3.17

IMPORTING AND EXPORTING DOCUMENTS................................3.17

WORKING WITH MULTIPLE DOCUMENTS.................................3.18
4 GeoWrite Basics

WHAT IS GEOWRITE? ................................................................. 4.2
STARTING GEOWRITE ............................................................ 4.3
USER LEVELS IN GEOWRITE ................................................... 4.5
TYPING TEXT ............................................................................ 4.5
  Positioning the Insertion Point .............................................. 4.6
  Inserting Text ........................................................................ 4.6
  Typing Numbers ................................................................... 4.7
SELECTING TEXT ....................................................................... 4.7
  Using a Mouse ...................................................................... 4.7
  Canceling a Selection .......................................................... 4.9
USING THE STYLE BAR ............................................................ 4.9
EDITING TEXT ......................................................................... 4.10
  Replacing Text ..................................................................... 4.10
  Deleting Text ....................................................................... 4.10
  Using Cut, Copy, and Paste .................................................. 4.10
  Undo .................................................................................... 4.11
CHANGING HOW TEXT LOOKS ............................................... 4.11
  Changing Character Attributes ............................................ 4.12
  Using the Ruler .................................................................... 4.16
  Aligning Text ...................................................................... 4.19
  Changing Line Spacing ....................................................... 4.20
CHECKING YOUR SPELLING .................................................... 4.21
ZOOMING ............................................................................... 4.23
MOVING AROUND IN YOUR DOCUMENT ............................... 4.23
USING TEMPLATES ............................................................... 4.25
TIPS FOR USING A WORD PROCESSOR ................................. 4.27

KEYBOARD SHORTCUTS .......................................................... 4.27
  Moving the Text Insertion Point ........................................... 4.28
  Selecting Text .................................................................... 4.28

5 Formatting Documents With GeoWrite

CHANGING THE TEXT FORMAT .................................................. 5.2
  Setting a Custom Text Size .................................................. 5.2
  Changing Character Width and Weight ................................ 5.3
  Formatting Paragraphs ....................................................... 5.4
6 Designing GeoWrite Documents

MANAGING TEMPLATES .......................................................... 6.2
Creating and Changing Templates ............................................. 6.2
Managing the Empty Document Template .................................. 6.4

USING SECTIONS ................................................................. 6.6
Planning a Document with Sections .......................................... 6.7
Managing Sections .................................................................... 6.8
Using Page Setup ..................................................................... 6.14
Using Master Pages .................................................................. 6.16

USING GRAPHICS IN A DOCUMENT ..................................... 6.21
Using a Graphic Frame ............................................................ 6.22
Pasting Graphics Into a Document ............................................. 6.26
Wrapping Text ......................................................................... 6.27

USING PAGE LAYOUT ......................................................... 6.28
Working with Documents in Page Layout Mode ......................... 6.28
7 Additional GeoWrite Features

**VIEWING YOUR DOCUMENT** ..................................................................7.2
Changing Display Modes .....................................................................7.2
Displaying Invisible Characters.........................................................7.7

**DISPLAYING COUNTS** ........................................................................7.8

**INSERTING SPECIAL CHARACTERS** ...............................................7.8
Inserting the Current Date ..................................................................7.9
Inserting the Current Time ..................................................................7.9
Inserting a Number (Counter) ...........................................................7.10
Inserting Special Dates ......................................................................7.11
Inserting Special Times ......................................................................7.12

**CONTROLLING PAGINATION** .............................................................7.14
Inserting a Hard Page Break .............................................................7.14
Deleting a Hard Page Break ..............................................................7.15

**MANAGING COLUMNS** .....................................................................7.15
Setting Multiple Columns ...................................................................7.15
Changing Columns ............................................................................7.17
Using Column Breaks .........................................................................7.17

**USING MAIL MERGE** .......................................................................7.17
Creating and Copying Merge Information ...........................................7.18
Setting up the GeoWrite Merge Document ...........................................7.22
Printing the Merge Document .............................................................7.25

**FINISHING YOUR DOCUMENT** .........................................................7.25
Using Footnotes ..................................................................................7.26
Creating a Table of Contents ...............................................................7.28
Creating a Bibliography ......................................................................7.29

**FINE TUNING YOUR USER LEVEL** ...................................................7.29

8 GeoDraw Basics

**STARTING GEODRAW** ......................................................................8.3

**USER LEVELS IN GEODRAW** ...........................................................8.4

**DRAWING TOOLS AT LEVEL I** .........................................................8.5
What Are Drawing Tools? ................................................................8.6
Using Drawing Tools .........................................................................8.6

**CREATING BASIC OBJECTS** .............................................................8.7
Drawing Objects with the Drawing Tools ...........................................8.7
Adding Objects with the Create Submenu ...........................................8.9
9 Starting to Draw With GeoDraw

ADVANCING TO LEVEL 2 ................................................................. 9.2
Additional Menus ........................................................................... 9.2
Expanded Menus ........................................................................... 9.3

DRAWING TOOLS AT LEVEL 2 .................................................. 9.4
The Rotate Tool ........................................................................... 9.4
The Zoom Tool ............................................................................. 9.4
The Shape Tools ........................................................................... 9.5
The Polyline Tools ......................................................................... 9.5

CREATING COMPLEX OBJECTS ............................................. 9.5
Drawing Polylines ......................................................................... 9.6
Drawing Polygons .......................................................................... 9.11
Drawing Stars ................................................................................ 9.11
Drawing Arcs .................................................................................. 9.12

MANIPULATING OBJECTS .................................................. 9.13
Nudging Objects ........................................................................... 9.13
Grouping and Ungrouping Objects ........................................... 9.14
Rotating Objects ........................................................................... 9.15
Flipping Objects ............................................................................ 9.16
Changing the Stacking Order of Objects .................................... 9.16

WORKING WITH TEXT ..................................................... 9.18
Changing Fonts, Styles, Sizes .................................................... 9.19
Aligning Text ................................................................................ 9.20
Coloring Text ............................................................................... 9.21

IMPORTING AND EXPORTING GRAPHICS ......................... 9.22

10 Intermediate GeoDraw Drawing

What You Get at Level 3 ............................................................... 10.3

CONTROLLING YOUR VIEW OF A DRAWING ......................... 10.3
Zooming by Percentage ................................................................ 10.4
Applying View Changes to Other Windows .............................. 10.5
11 Advanced GeoDraw Drawing

What You Get at Level 4

USING THE FLOATING TOOL BOX

ADVANCED VIEW FEATURES

Hiding and Showing Objects
Changing the Size of Selection Handles

ADVANCED DUPLICATING

PASTING AN OBJECT INSIDE ANOTHER
### 12 GeoCalc Basics

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>STARTING GEOCALC</td>
<td>12.3</td>
</tr>
<tr>
<td>USER LEVELS IN GEOCALC</td>
<td>12.5</td>
</tr>
<tr>
<td>MOVING AROUND IN A SPREADSHEET</td>
<td>12.6</td>
</tr>
<tr>
<td>SELECTING CELLS AND RANGES</td>
<td>12.7</td>
</tr>
<tr>
<td>WORKING WITH VALUES AND LABELS</td>
<td>12.10</td>
</tr>
<tr>
<td>Entering Values and Labels</td>
<td>12.10</td>
</tr>
<tr>
<td>Entering Dates</td>
<td>12.14</td>
</tr>
<tr>
<td>Entering Information in a Selected Range</td>
<td>12.17</td>
</tr>
<tr>
<td>WORKING WITH FORMULAS</td>
<td>12.18</td>
</tr>
<tr>
<td>Entering Formulas</td>
<td>12.18</td>
</tr>
<tr>
<td>Using References in Formulas</td>
<td>12.20</td>
</tr>
<tr>
<td>Using Operators in Formulas</td>
<td>12.21</td>
</tr>
<tr>
<td>Using Built-in Functions in Formulas</td>
<td>12.22</td>
</tr>
<tr>
<td>EDITING THE SPREADSHEET</td>
<td>12.26</td>
</tr>
<tr>
<td>Editing the Contents of a Cell</td>
<td>12.26</td>
</tr>
<tr>
<td>Deleting Information</td>
<td>12.27</td>
</tr>
<tr>
<td>Copying and Moving Information</td>
<td>12.27</td>
</tr>
</tbody>
</table>
Inserting and Deleting Rows and Columns ............................................... 12.31
Filling a Range of Cells with Incremental Values ................................... 12.32

CHANGING THE APPEARANCE OF A SPREADSHEET .......................... 12.34
Adjusting Column Width ......................................................................... 12.34
Changing Justification ............................................................................ 12.35
Using Different Text Styles .................................................................... 12.36

13 Formatting GeoCalc Spreadsheets

SHOWING GRID LINES ........................................................................... 13.2
SHOWING CELL BORDERS ..................................................................... 13.3

ADJUSTING ROWS AND COLUMNS ........................................................... 13.4
Columns.................................................................................................. 13.4
Rows........................................................................................................ 13.4

USING HEADERS AND FOOTERS ............................................................. 13.5

USING COLOR .......................................................................................... 13.6

USING NOTES .......................................................................................... 13.8

14 Advanced GeoCalc Formulas

SHOWING AND HIDING FORMULAS ......................................................... 14.2
NAMING CELLS AND RANGES ................................................................ 14.3

CONTROLLING AUTOMATIC RECALCULATION ...................................... 14.7

USING ITERATION AND CIRCULAR REFERENCES ..................................... 14.8

ADVANCED FUNCTIONS ........................................................................... 14.10
Working with Strings ................................................................................ 14.10
Working with Times and Dates ................................................................. 14.11
Working with Numbers ........................................................................... 14.11
Using Logical Functions ......................................................................... 14.12
Using Lookup Functions ......................................................................... 14.13
Using Other Functions ............................................................................ 14.14

15 Charting in GeoCalc

WHAT IS A CHART? .................................................................................. 15.2

TYPES OF CHARTS .................................................................................. 15.2
Column Chart .......................................................................................... 15.3
Bar Chart ................................................................................................ 15.4
Line Chart ................................................................................................ 15.4
Area Chart .......................................................................................................................... 15.5
X-Y Plot Chart ...................................................................................................................... 15.5
Pie Chart .............................................................................................................................. 15.7
High/Low Chart .................................................................................................................. 15.8

CREATING CHARTS ............................................................................................................. 15.8

CHANGING THE TYPE OF CHART ......................................................................................... 15.10

MANIPULATING CHARTS ....................................................................................................... 15.11
Moving a Chart .................................................................................................................... 15.11
Resizing a Chart ................................................................................................................... 15.12
Changing Chart Properties and Attributes ......................................................................... 15.12
Deleting a Chart .................................................................................................................. 15.13
Using a Chart in Another Application ................................................................................ 15.13

ADDING TITLES AND A LEGEND ......................................................................................... 15.14

CHANGING MARKINGS ......................................................................................................... 15.16
Setting Axis and Grid Markings ............................................................................................ 15.16
Changing Marker Shapes ...................................................................................................... 15.17

16 Additional GeoCalc Features

TOOL BARS IN GEOCALC ..................................................................................................... 16.2
Using the Style Bar ................................................................................................................ 16.2
Using the Function Bar .......................................................................................................... 16.4

PRINTING ................................................................................................................................. 16.6
Printing Spreadsheets ......................................................................................................... 16.6
Setting Page Setup Options ................................................................................................. 16.6

SORTING .................................................................................................................................... 16.8

CREATING NUMBER AND DATE FORMATS ........................................................................ 16.10

USING RULERS ......................................................................................................................... 16.12

ADDING GRAPHICS ............................................................................................................. 16.12

USING GEOCALC WITH OTHER GEOS APPLICATIONS .................................................. 16.13

IMPORTING AND EXPORTING GEOCALC INFORMATION ............................................. 16.14
Exporting ............................................................................................................................... 16.14
Importing ............................................................................................................................... 16.17

FINE TUNING YOUR USER LEVEL ........................................................................................ 16.20
A Math and Database Functions

ARGUMENT RULES ................................................................. A.2

FUNCTIONS AVAILABLE IN GEOCALC ONLY .................................. A.3

FUNCTION QUICK REFERENCE .................................................. A.3
Financial Functions ......................................................................... A.3
Information Functions ...................................................................... A.4
Logical Functions ........................................................................... A.5
Mathematical Functions .................................................................. A.5
Print Functions ................................................................................ A.6
Statistical Functions ......................................................................... A.6
String Functions ............................................................................... A.6
Time and Date Functions .................................................................. A.7
Trigonometric Functions ................................................................... A.8

FUNCTION DESCRIPTIONS ....................................................... A.10
ABS(value) ..................................................................................... A.10
ACOS(value) ................................................................................... A.10
ACOSH(value) ................................................................................ A.10
AND(logical1,logical2,...) ............................................................... A.10
ASIN(value) .................................................................................... A.11
ASINH(value) ................................................................................ A.11
ATAN(value) ................................................................................... A.11
ATAN2(x,y) .................................................................................... A.11
ATANH(value) ................................................................................ A.12
AVG(value1,value2,...) .................................................................. A.12
CHAR(value) ................................................................................... A.13
CHOOSE(index,value1,value2,...) .................................................. A.13
CLEAN(string) ................................................................................ A.13
CODE(string) ................................................................................ A.13
COLS(range) .................................................................................. A.14
COS(angle) ..................................................................................... A.14
COSH(value) ................................................................................... A.14
COUNT(value1,value2,...) ............................................................. A.14
CTERM(interest,future_value,present_value) ..................................... A.15
DATE(year,month,day) .................................................................. A.15
DATEVALUE(string) ......................................................................... A.15
DAY(date_value) ............................................................................. A.15
DDB(cost,salvage,life,period) .......................................................... A.16
ERR() ......................................................................................... A.16
EXACT(string1,string2) .......................................................... A.17
EXP(value) ............................................................................... A.17
FACT(value) ............................................................................. A.17
FALSE() .................................................................................. A.18
FILENAME() ............................................................................ A.18
FIND(substring,string,start) .................................................. A.18
FV(payments,interest,term) .................................................. A.18
HLOOKUP(value,range,offset) ............................................ A.19
HOUR(time_value) ................................................................. A.20
IF(logical, true_value, false_value) ........................................ A.20
INDEX(range,column_offset, row_offset) .......................... A.20
INT(value) .............................................................................. A.21
IRR(guess,range) .................................................................... A.21
ISERR(value) ............................................................................ A.22
ISNUMBER(value) ..................................................................... A.22
ISSTRING(value) ......................................................................... A.23
LEFT(string,num) .................................................................... A.23
LENGTH(string) ........................................................................ A.23
LN(value) .................................................................................. A.23
LOG(value) .............................................................................. A.24
LOWER(string) ......................................................................... A.24
MAX(value1,value2,...) ........................................................ A.24
MID(string,start,num) .......................................................... A.24
MIN(value1,value2,...) ........................................................ A.25
MINUTE(time_value) ............................................................... A.25
MOD(value,divisor) ................................................................. A.25
MONTH(date_value) ................................................................. A.25
N(range) .................................................................................. A.26
NA() ........................................................................................ A.26
NOW() .................................................................................... A.26
NPV(interest,range) ................................................................. A.26
OR(logical1,logical2,...) ....................................................... A.27
PAGE() .................................................................................... A.28
PAGES() .................................................................................. A.28
PI() .......................................................................................... A.28
PMT(principal,interest,term) ................................................ A.28
PRODUCT(value1,value2,...) ............................................... A.29
PROPER(string) ......................................................................... A.29
PV(payment,interest,term) .................................................... A.29
RANDOM() .............................................................................. A.30
RANDOMN(value) ..................................................................... A.30
RATE(future_value,present_value,term) ................................. A.30
REPEAT(string,num) ............................................................... A.30
REPLACE(original,start,num,replace) .................................... A.30
RIGHT(string,num) ................................................................. A.31
ROUND(value,places) ............................................................. A.31
ROWS(range) ........................................................................ A.31
SECOND(time_value) ............................................................. A.32
SIN(angle) .............................................................................. A.32
SINH(angle) ............................................................................ A.32
SLN(cost,salvage,lifetime) .................................................... A.32
SQRT(value) ............................................................................. A.33
STD(value1,value2,..) .............................................................. A.33
STDP(value1,value2,..) ............................................................ A.33
STRING(value,N) ................................................................. A.33
SUM(value1,value2,..) ............................................................ A.34
SYD(cost,salvage,lifetime,period) ....................................... A.34
TAN(angle) .............................................................................. A.34
TANH(angle) ............................................................................ A.34
TERM(payments,interest,future_value) ............................... A.35
TIME(hour,minute,second) .................................................. A.35
TIMEVALUE(string) ............................................................. A.35
TODAY() ................................................................................ A.35
TRIM(string) ........................................................................... A.35
TRUE() .................................................................................... A.36
TRUNC(value) ........................................................................... A.36
UPPER(string) ......................................................................... A.36
VALUE(string) ......................................................................... A.36
VAR(value1,value2,..) ............................................................. A.36
VARP(value1,value2,..) ............................................................ A.37
VLOOKUP(value,range,offset) .............................................. A.37
WEEKDAY(date_value) ........................................................ A.38
YEAR(date_value) ............................................................... A.38

B Special Characters ............................................. 1

FOREIGN LANGUAGE CHARACTERS ......................................... B.2
FOREIGN-LANGUAGE ACCENTS ................................................ B.4
TYPOGRAPHICAL SYMBOLS .................................................. B.5
PUNCTUATION MARKS ........................................................ B.5
CURRENCY AND NUMERIC SYMBOLS .................................... B.6
MATHEMATICAL SYMBOLS ..................................................... B.7
C Character Codes

D Tool Bar Reference

THE STYLE TOOL BAR .................................................. D.3
THE FUNCTION TOOL BAR .............................................. D.5
Welcome to Ensemble 2.0! GeoWorks Ensemble 2.0 includes both a state-of-the-art system software called GEOS® and a family of applications that take full use of its power. In Ensemble, you will find writing, drawing, scheduling, database, and calculating tools that are both powerful and easy to use.
Ensemble is easy to use because all of its tools are based on GEOS. With GEOS, all of your options are represented pictorially on the screen. You spend less time trying to remember how to do things and more time actually doing them. Simply use your mouse to move a pointer around on the screen until it points at a picture of what you want, then click the mouse button.

Whether it's a business letter you're writing or some artwork you're creating, GEOS is always WYSIWYG (What You See Is What You Get). WYSIWYG means that your printed pages look just like they do on the screen, freeing you from printer guesswork, and saving you time.

ABOUT THIS BOOK

Along with the applications described in The GEOS Environment & Accessories, Ensemble includes four applications that are designed to help you create professional looking documents, drawings, spreadsheets, and databases.

The first three chapters of this book cover topics that apply to all of the applications in this book. If you have never used an Ensemble application before, you should look in these chapters for information that will serve you well in any Ensemble application.

The rest of the book is dedicated to the following applications:

- **GeoDraw.** An easy-to-use drawing and painting utility.
- **GeoCalc.** A powerful spreadsheet with built-in charting.
- **GeoFile.** A flat-file database that lets you present your data in many different ways.

Typographical Conventions Used in This Book

The following printing conventions are used throughout this book:

- *Italic* type is used to introduce a new term. *Italic* type is also used for book titles and for software titles other than GEOS applications.
- **ALL CAPITALS** type indicates file names.
• **Boldface** is used for the names of keys on the keyboard, such as **Enter** or **Insert**.

• When you see two key names with a + symbol between them, press both keys at the same time. For example, when you see **Ctrl+Esc**, you should hold down the **Ctrl** key while you press the **Esc** key.

**Conventions for Procedures**

*Procedures* are step-by-step instructions that tell you how to perform tasks in Ensemble. Procedures in this book always have a boldface heading beginning with the word “to.” Each step in a procedure first has you perform an action, which is followed by an explanation of Ensemble’s response. When you can do a task in more than one way, you will see the word “or” on its own line, and then an alternate method of completing the step. Some procedures consist of one step, while others have multiple steps.

**SINGLE-STEP PROCEEDURES**

Single-step procedures have a square, black bullet (■) beside the instruction telling you what to do. The following example shows a single-step procedure with two alternative ways to do the task.

*To start GeoPlanner (All Levels)*

■ Locate the GeoPlanner icon and double-click it.

*or*

Choose GeoPlanner from the Express menu in any GEOS application.

**MULTI-STEP PROCEEDURES**

Multi-step procedures have sequentially numbered steps that you should follow in a specific order. The following example shows three steps from a multi-step procedure.

*To select a day and view its events (All Levels)*

1. If the Calendar window isn’t showing, choose Calendar from the View menu. The Calendar window appears.

2. Click to select a day in the Calendar window. The day highlights.

3. The events for the selected day appear in the Events window. If the Events window isn’t showing, choose Events from the View menu. The Events window appears.
**User Level Notation**

Every procedure in this manual is followed by a parenthetical note specifying at which user levels the task can normally be accomplished. The following are two examples of procedures found in this book:

*To start GeoPlanner (All Levels)*

*To show empty days (Level 3)*

In addition, sections are marked with text similar to the one shown in the margin at left. This text, because it says “All Levels,” indicates that the section applies to *all levels* in the application. If it had said “Level 2,” it would indicate that the section only applied to Level 2 of the application.

“All levels” does not necessarily mean that *every* procedure in that section can be used at all levels. Individual procedures within a section may apply to fewer levels than the section itself. For instance, a section labeled “All levels” may contain procedures that apply only to Level 1, along with other procedures that apply to all levels.

For more information about user levels in applications, see “About User Levels” in Chapter 1.
CHAPTER I

Getting Started  This chapter lays the foundation for all the work you will do with GeoWrite, GeoDraw, GeoCalc, and GeoFile. As a general rule, this chapter builds from simplest concepts to more advanced topics. You do not, however, need to read it from beginning to end. Feel free to jump from section to section, like a reference book.
This chapter covers the following topics:

- Starting and exiting an application
- Creating a new document
- Opening an existing document
- Saving and closing a document
- Printing a document
- Changing a document size and orientation
- Changing and saving user levels

Before you begin this chapter, you should be familiar with the following basic skills for using any application:

- Using a Mouse
- Working with windows
- Working with menus
- Working with dialog boxes
- Entering and editing text

For more information about these topics, refer to the book *The GEOS Environment & Accessories*. It helps if you have worked with at least one of the Ensemble accessories and are familiar with the information covered in the first two chapters of *The GEOS Environment & Accessories*.

**WHAT ARE GEOWRITE, GEODRAW, GEOCALC, AND GEOFILE?**

GeoWrite, GeoDraw, GeoCalc, and GeoFile are powerful applications that work together to make your job easier and help you produce professional-looking documents.

Each of these four applications serves a particular purpose. Which ones you use, and when, depends on your needs. In general, you will use the tools in the following ways:

- GeoWrite, for word processing and desktop publishing.
- GeoDraw, for drawing and painting.
- GeoCalc, for numerical spreadsheet analysis and charting.
- GeoFile, for storing and filing information.

You will find these applications both sophisticated and versatile. For instance, you can use GeoWrite to compose letters or write reports, even publish a school paper. You can use GeoDraw to
produce artwork and diagrams, detailed drawings and wall-sized posters. You can use GeoCalc to track and analyze numbers, charting a committee's budget or lab results from an experiment. Finally, you can use GeoFile as a computerized filing system, to store and organize information on people, events, or things. You can use any of these applications individually, or you can use them together and you can share information between them.

These applications appear as icons, like the ones shown at the left. You can find them in the WORLD directory of GeoManager.

**Desktop Publishing With Every Application**

GeoWrite, GeoDraw, GeoCalc, and GeoFile make it easy to produce professional looking documents with text, graphics, and color.

With the Ensemble productivity tools, you can format text in different styles, such as **bold**, *italic*, and *underline*, and you can choose from different fonts, such as Cooperstown, Cranbrook, and Sather Gothic. You can also change the size of text from 4 to 792 points (a point is 1/72 of an inch), and you can select from a palette of 16-million colors and a variety of shades and patterns for both text and graphics.

To help you make your documents more visually appealing, each of the applications has a graphics layer for drawing directly on the page without leaving the application. If you want to add a picture to your GeoWrite document, you need never leave GeoWrite; simply click one of the drawing tools and begin drawing directly on the page. The graphic will appear on the page, overlaying the text. The same technique applies to the GeoCalc spreadsheet. If there is a number or an equation you want to highlight or point out, you can use the drawing tools to draw an arrow and add a note directly on the page. In GeoFile, all of the drawing tools are available for designing forms and, of course, in GeoDraw, all of the drawing tools are brought to the forefront.

The Ensemble productivity tools provide a **WYSIWYG** — What You See is What You Get — display of your document. The image you see on your screen represents, almost exactly, what will print on your printer. And you can print to over 300 of the most popular printers, both color and black and white, with the highest-quality results. Even dot matrix printers produce near-laser-quality documents when used with the Ensemble productivity tools.
Using GeoWrite, GeoDraw, GeoCalc, and GeoFile With the Ensemble Accessories

You can use GeoWrite, GeoDraw, GeoCalc, and GeoFile in conjunction with the Ensemble accessories. Here are some ideas:

- Use GeoDex to store addresses and then copy them into letters you compose in GeoWrite. You can also use a GeoDex document as the source of data for a mail merge in GeoWrite.
- Use the Calculator to perform ad-hoc calculations and copy them into your GeoWrite documents.
- Store commonly used drawings or text as pages in the Scrapbook. As you write or draw, you can recall these scraps and copy them into your document.
- Use GeoComm to dial up bulletin board services and download word processing and graphic files. Use the import feature of GeoWrite and GeoDraw (or Scrapbook) to then incorporate these files into your own documents.

As you become more proficient with all the applications and accessories, you will discover additional ways of using them together. For more information on using the Ensemble accessory applications, see The GEOS Environment & Accessories.

Saving Time With Templates

Each of the applications comes with built-in templates. Templates are documents which serve as a starting point for your own work. Instead of beginning with a blank page, a template lets you start with a document that already has formatting and place holders for your own text and graphics. For instance, to create a greeting card using GeoDraw, or a newsletter using GeoWrite, you can save time by beginning with a template.

As you become proficient with an application, you can create your own templates and share templates with other users.

Learning With User Levels

All the applications explained in this book have four user levels, so you can learn gradually and discover new features as you gain experience rather than encountering all the features at once.
STARTING AND EXITING GEOWRITE, GEODRAW, GEOCALC, AND GEOFILE

ALL LEVELS

You can start an application by opening it directly, or by opening one of its documents. For more information on starting and exiting GEOS applications, see “Starting and Exiting Applications” in Chapter 1 of The GEOS Environment & Accessories.

Where to Find GeoWrite, GeoDraw, GeoCalc, and GeoFile

The icons for GeoWrite, GeoDraw, GeoCalc, and GeoFile appear in the WORLD directory of GeoManager. For more information about GeoManager see The GEOS Environment & Accessories.

Starting an Application Directly

You can start an application directly with the following techniques:

- Double-click the icon of the application you want to start.
- Select the icon of the application you want to start, then choose Open from the File menu.
- Choose Start an Application from the Express menu, then choose the application’s name from a submenu.

To start an application directly (All Levels)

1. Locate the icon representing the application you want to open. You’ll find application icons in the WORLD directory of GeoManager.
2. Double-click the icon.

or

Select the icon; then choose Open from the file menu.

or

Choose Start an Application from the Express menu. A submenu appears. Choose the application’s name from a submenu.

With whichever method you use, the application opens and appears with a window and a New\Open dialog box ready for use.

For more information about using the Express menu, see “Using the Express Menu” in this Chapter.
**Starting an Application by Opening a Document**

If you know the document you want to work with before you start the application, you can start that application by opening one of its document icons instead of the application icon.

*To start an application by opening a document (All Levels)*

1. Locate the icon representing the document you want to open.
2. Double-click the icon.

![Double-click here to start Geowrite, and open this document.](image)

*or*

Select the icon; then choose Open from the file menu.

With whichever method you use, the application starts and automatically opens the selected document.

**The First Thing You See**

When you start GeoWrite, GeoDraw, GeoCalc, or GeoFile, the first thing you see is the application window. Inside the application window is the *New/Open dialog box* (unless you start the application by opening one of its documents, in which case you see the document instead of the New Open dialog Box).
The New/Open dialog box is your starting place with an application. From here you can create and open documents, as well as change the application's user level. For more information on the New/Open dialog box, see “Creating and Opening Documents” in this chapter.

Exiting an Application

You can exit an application at any time, but it's a good idea to first save any open documents before you do. If you exit without first saving, the application gives you a second chance to save your document. If you've just started the application and have not yet started working on a document, or have just closed the last document, you can exit the application directly from the New/Open dialog box.

To exit an application from the New/Open dialog box (All Levels)

1. In the New/Open dialog box, click Exit. The application closes.

To exit an application using the File menu (All Levels)

1. Click the word File on the menu bar. The File menu appears.
2. Click Exit on the menu. The application closes.

To exit an application using the Window Control menu (All Levels)

1. Double-click the Window Control button in the upper left corner of the application window. The application closes.
or

1. Click the Window Control button. The Window Control menu appears.
2. Click Close on the menu. The application closes.

CREATING AND OPENING DOCUMENTS

Each of the Ensemble applications stores information in documents, and each application uses a different kind of document. GeoWrite, for instance, uses word processing documents, whereas GeoFile uses database documents. Each type of document has a unique icon in Ensemble, so you can easily identify the application that was used to create it.


When you create a new document, it normally appears in your DOCUMENT folder. The techniques in this section assume you are working with documents in your DOCUMENT folder.

This section describes how to work with one document at a time. For information on working with more than one document at once, see “Working with Multiple Documents” in Chapter 3.
The New/Open Dialog Box

A typical New/Open dialog box looks like the following:

The particular buttons that appear in the New/Open dialog box depend on the application you are using and its current user level.

The New/Open dialog box appears whenever there are no documents open in the application, such as when you first start the application or when you close the last document. It also appears when you choose New/Open from the File menu.

You may see any of the following buttons in the New/Open dialog box:

- **Template.** Click this button to create a new document, choosing from a list of templates. Templates save time because they provide a starting point for your work. For more information, see “Using a Template to Create a Document” in this chapter.

- **New.** Click this button to create a new, empty document. For more information, see “Creating a New, Empty Document” in this chapter.

- **Open.** Click this button to locate and open a document which already exists. For more information, see “Opening an Existing Document” later in this chapter.

- **Import.** Click this button (not shown in the previous picture) to create a new document by translating information from another application, such as a DOS word processor. For more information, see “Importing and Exporting Documents” in Chapter 3.

- **Change User Level.** Click this button to change the application user level directly from the New/Open dialog box. This is the
same as choosing Change User Level from the Options menu. By changing user levels you specify how simple or complex you want the application to be. For more information, see “User Levels” in this chapter.

- **Exit** or **Cancel**. If there are no documents open in the application, you can click the Exit button to exit the application directly from the dialog box. If there is a document open, then this button becomes Cancel. Click Cancel to close the New/Open dialog box and return to the open document.

**Using a Template to Create a Document**

A *template* provides you with an easy way to create a new document without starting from scratch. Templates include setup information such as margins, tab stops, and spacing, as well as fonts, font size, paper size, and columns. Templates can contain actual text or data that you may use in every document of this type, such as an address and phone number. They can also contain placeholders that reserve space for items such as headlines or graphic images.

You can also design your own templates. For more information about designing and changing templates, see Chapter 3.

*To create a new document by using a template (All Levels)*

1. If the New/Open dialog box is not on the screen, choose New/Open from the File menu. The New/Open dialog box appears.

2. Click the Template button. A dialog box appears with a list of templates you can use in the application you’ve started:

   ![List of templates]

   ![Use Template button]
3. If you want to browse through the templates, click the name of a template you are interested in and then read the notes that appear in the Notes field. Repeat this step as many times as you want.

4. Select the name of the template you want to use, then click Use Template.

or

Double-click the name of the template you want to use.

The dialog box closes and a new, Untitled document appears with information from the template. The original template is left untouched so that you can use it again to create similar documents.

NOTE

When using the Template feature in Level 4 of an application, the dialog box from which you select templates has a For Editing option below the list of templates. You should leave this option unchecked unless you want to edit the original template. For more information on this option, see “Modifying a Template” in Chapter 3.

Creating a New, Empty Document

Creating a new, empty document is like starting with a blank piece of paper. In GeoWrite, GeoDraw, and GeoCalc you can create a new, empty document at any user level. In GeoFile, you cannot create a new, empty document in Levels 1 and 2 because a new, empty document required designing a new database which can only be accomplished at Levels 3 and 4. If you are using GeoFile in Level 1 or 2, you can only create a new databases using a template.

To create a new document (All levels)

1. If the New/Open dialog box is not showing, choose New/Open from the File menu. The New/Open dialog box appears.

2. When the New/Open dialog box appears, click the New button. The dialog box closes and a blank, Untitled document appears in the document window.

Opening an Existing Document

An existing document is one that you have previously created and saved.
To open an existing document, you use a standard file selector. The following procedure explains the easiest way to use the file selector controls to find an existing document in your DOCUMENT folder. If you need to change folders or disks to locate the document you want to use, see “Working With Standard File Selectors” in this Chapter.

To open an existing document (All Levels)

1. If the New/Open dialog box is not showing, choose New/Open from the File menu. The New/Open dialog box appears.

2. When the New/Open dialog box appears, click the Open button. A standard file selector appears:

3. Make sure the name of your DOCUMENT folder is highlighted. If it isn’t, click the Go to Document button. This displays a list of existing documents and folders in your DOCUMENT folder that can be opened by this application.

4. Select the name of the document you want to open.

5. Click the Open button.

The dialog box closes and the existing document appears.

If you have previously set a password for the document, you will be asked to enter the password. For more information on setting a password, see “Setting and Removing a Document Password” in Chapter 3.
THE NOTES FIELD
When opening a document in Level 3 or 4 of an application, a Notes field appears at the bottom of the file selector. When you select a document in the list, its notes appear in the Notes field. Not all documents have document notes. For information on setting and changing document notes, see “Editing Document Notes” in Chapter 3.

THE TYPE INDICATOR AND THE FOR EDITING OPTION
When opening a document in Level 4 of an application, a type indicator and a For Editing option appear below the list of files. When you select a document in the list, the type indicator shows the type of document selected. The status of the For Editing option updates, depending on the type of document selected:

- **Normal.** If you select a normal document, the For Editing option becomes checked, anticipating that you want to make changes to the document.
- **Public.** If you select a Public document, the For Editing option becomes unchecked, anticipating you won’t be making changes to the document.
- **Read-Only.** If you select a read-only document, the For Editing option becomes dimmed. You cannot open a read only document for editing.
- **Template.** If you select a template document, the For Editing option becomes unchecked, anticipating that you do not want to edit the original template but would like to create a new document based on the template.
- **Read-Only Template.** A read-only template behaves exactly as a regular template, except that the For Editing option is always dimmed, which means you cannot edit the original template.

For more information on document types, see “Setting the Document Type” in Chapter 3.

To change the For Editing option in the Open dialog box (Level 4)

1. In the Open file selector, select a document in the list. The For Editing option updates, depending on the document type.
2. Click to change the For Editing option. When checked, you can edit the document. When unchecked, any changes you make must be saved to a document with a different name.
3. Click Open. The document opens.
APPLICATION AND DOCUMENT WINDOWS

When you work an application, you often see two windows — the application window and the document window — one inside the other.

**Application Windows**

The application window appears when you start the application. The following is a typical application window:
The following elements are common to many application windows:

- **Window Control button.** Click to open the Window Control menu. Double-click to close the application window and exit the application.

- **Express button.** Click to open the Express menu. The Express menu lists applications that are currently running, and lets you open other applications.

- **Title bar.** Use to move the window. Also indicates the name of the application and the name of the current document.

- **Help button.** Click to get online help.

- **Minimize button.** Click to shrink the window to the size of an icon. Double-click the icon to restore the window to its normal size.

- **Maximize-Restore button.** Click to maximize a window so that it fills the screen; click again to restore the window to its size before maximizing.

- **Menu bar.** Click a name to open its menu.

- **Tool Bar.** Click a name to open its menu.

- **Window borders.** Drag to resize the window.
The following table explains where to go for more information on application windows.

<table>
<thead>
<tr>
<th>FOR MORE INFORMATION ON</th>
<th>SEE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Window Control menu</td>
<td>“The Window Control Menu” in Chapter 1 of <em>The GEOS Environment &amp; Accessories</em>.</td>
</tr>
<tr>
<td>Using the Express menu</td>
<td>“Using The Express Menu” in this chapter.</td>
</tr>
<tr>
<td>Working with windows</td>
<td>“Working With Windows” in Chapter 1 of <em>The GEOS Environment &amp; Accessories</em>.</td>
</tr>
<tr>
<td>(moving, resizing,</td>
<td></td>
</tr>
<tr>
<td>minimizing, maximize-</td>
<td></td>
</tr>
<tr>
<td>restore)</td>
<td></td>
</tr>
<tr>
<td>Working with menus</td>
<td>“Working With Menus” in Chapter 1 of <em>The GEOS Environment &amp; Accessories</em>.</td>
</tr>
<tr>
<td>(opening, closing, selecting from)</td>
<td></td>
</tr>
<tr>
<td>Using Tool Bars</td>
<td>“Using the Tool Bars” in Chapter 2 of this book.</td>
</tr>
</tbody>
</table>

**Document Windows**

The document window appears within the application window when you create or open a document. If you open multiple documents, each will appear in its own window, though you normally see only one at a time.
The following elements are common to many document windows:

- **Window Control button**. Click to open the Window Control menu. Double-click to close the document window.

- **Title bar**. Indicates the name of the document in the window.

- **Maximize-Restore button**. Click to switch between full-sized and overlapping document windows. Overlapping document windows let you work with multiple documents side by side.

- **Ruler**. Indicates dimensions on the document. Not all document windows have rulers.

- **Scroll bars**. Use to scroll the contents of the window.
The following table explains where to go for more information on application windows.

<table>
<thead>
<tr>
<th>For more information on</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Window Control menu</td>
<td>“The Window Control Menu” in Chapter 1 of <em>The GEOS Environment &amp; Accessories</em>.</td>
</tr>
<tr>
<td>Working with overlapping or full-sized document windows</td>
<td>“Working With Multiple Documents” in Chapter 3 of this book.</td>
</tr>
<tr>
<td>Working with rulers</td>
<td>“Showing Rulers and Setting Measurement Units” in Chapter 2 of this book.</td>
</tr>
<tr>
<td>Scrolling the contents of a window</td>
<td>“Scrolling Through a Window” in Chapter 1 of <em>The GEOS Environment &amp; Accessories</em>.</td>
</tr>
</tbody>
</table>

**SAVING DOCUMENTS**

*Saving* a computer document is different from saving a piece of paper on which you have written something. Anything written on a piece of paper is automatically saved unless you throw the paper away. However, a computer document is not saved until you take an action to save it. Saving a computer document means recording the document on a permanent storage medium such as a fixed disk. Your DOCUMENT folder is such a place; ordinarily, you will want to save documents in your DOCUMENT folder.

You should save a document periodically as you work on it; for instance, whenever you come to a good stopping point. It's also good practice to save a document before you print it, before you make a significant change to it, and as soon as you've finished any work you wouldn't want to redo. However, should you forget to save your document, GEOS applications have a safeguarding feature which protects you from losing changes before you've had a chance to save them. For more information, see “Safeguarding A Document” in this chapter.

Typically, when you're finished working on a document, you save it, and then you close the document. If you want to work
on another document using that application, you can open a different document. Otherwise, you close the application. For more information on closing documents and applications, see “Closing Documents” and “Exiting an Application” in this chapter.

The first time you save a document, you have to name it. The best way to name a document is to describe its contents so that you can recognize the document by its name. For example, a letter you write to your friend Karen might be named “Karen 1/11/92”. A Birthday card you designed might be named “Birthday Card 1991.”

**Naming a Document**

The first time you save a document, you must name it. Most documents you name will probably be GEOS documents, such as those you create with GeoWrite and GeoDraw. In some instances, you may need to create DOS file, such as when you export information from GeoWrite to another word processor; these documents must have a DOS file name. If you need to use a DOS name, the application you’re using will specify this. However, most documents use GEOS document names, which are more flexible.

**NAMING A GEOS DOCUMENT**

There are some rules to follow when you name a GEOS document. The name can be up to 32 characters long, and may contain both upper- and lower-case characters. For example, you could name a document “Seva’s Birthday Card” or “Newsletter 12/4/93”. Each space you type (by pressing the **Spacebar**) counts as one character.

**NAMING A DOS FILE**

There are also rules to follow when you name a DOS file. DOS files can be up to eight characters long, optionally followed by a period and three more characters. The optional three characters following a DOS file name are called the *extension*. The extension usually indicates the type of data the file contains. For instance, the extension .WK1 normally indicates a Lotus 1-2-3 file. DOS file names can only contain the letters A through Z, the numbers 0 through 9, and the following special characters:

- underscore `_`
- caret `^`
- dollar sign `$`
- tildes `~`
- number sign `#`
percentage sign  %
hyphen         -
parentheses    ( )
apostrophe     '

ampersand &
braces        {} 
at sign        @
grave accent   

No other special characters are permitted.

DOS names cannot contain spaces, commas, backslashes, or periods (except the period following the first eight characters). The letters are always converted to upper case.

The following are examples of valid DOS names:
• TO_DO
• RACHEL1.TXT
• ASSIGNMT.DOC

On the other hand, the following names are not acceptable for DOS documents:
• TO DO (Includes a space)
• MEMOTOPEDRO (Too many letters)
• MEMO.EARVIN (More than three letters following the period)

Using Save

If the document already has a name, Save will save any changes to that document. The simplest way to save a document is to choose Save from the File menu. If the document does not yet have a name, Save will ask you to name the document.

To save an Untitled document for the first time (All Levels)

When you create a new document it is temporarily called "Untitled." To save it, you must give it a name.

The Save As file selector appears when you try to save the document. The following procedure explains the easiest way to use standard file selector controls to name the document and save it in your DOCUMENT folder. If you want to save the document somewhere else, see “Working with Standard File Selectors” in Chapter 1.
1. Choose Save from the File menu. A standard file selector appears with a New Name text entry box:

![Image of File Selector](image)

2. Make sure the name of your DOCUMENT folder is highlighted. If it isn't, click the Go to Document. This saves the document in your DOCUMENT folder.

   or

   Use the standard file selector controls to select a different folder or drive for the destination of the save.

3. Type a document name in the New Name text entry box.

4. Click Save to save the document using its new name. You return to the open document, and its name appears in the title bar.

   To save changes to a document that already has a name (All Levels)

   After you have saved a document for the first time, you no longer need to provide a name when you save it. To save any changes to one of these documents, you simply choose Save from the File menu.

   Choose Save from the File menu. Any changes you've made are saved, and you are immediately returned to the open document. If the Save choice is dimmed it means there are no changes to save.

   **Using Save As**

   You can save a document under a different name using the Save As choice on the File menu. When you choose Save As, you create a new version of the document and give it a new name. Save As serves many useful purposes. For example, suppose you wrote sales plan last quarter and named it "Q1 Sales Plan". This
quarter you want to revise the plan, but you also want to keep the original intact so you can refer to it. You could open “Q1 Sales Plan” and immediately save it as “Q2 Sales Plan”. The original document, “Q1 Sales Plan”, is preserved on disk and “Q2 Sales Plan” appears in the document window so that you can change it appropriately to emphasize your new ideas for the quarter.

When you choose Save As, a standard file selector appears. The following procedure explains the easiest way to use standard file selector controls to save the document in your DOCUMENT folder. If you want to save the document somewhere else, see “Working with Standard File Selectors” in Chapter 1.

To save a document under a different name using Save As (Level 3)

1. Choose Save As from the File menu. A standard file selector appears with the current name of the document in the New Name text entry box:

2. Make sure the name of your DOCUMENT folder is highlighted. If it isn’t, click the Go to Document button. This saves the document in your DOCUMENT folder.
   
   or

   Use the standard file selector controls to select a different folder or drive for the destination of the save.

3. Type the new name, which replaces the current name of the document. The new name appears in the text entry box.

4. Click Save to save the document using its new name. The original document is closed and remains as you last saved it. Any recent, unsaved changes are saved to the new version only, which appears in the window ready for editing. If you continue
editing the version on the screen, you are editing the new document.

**Safeguarding a Document**

GEOS periodically takes a “snapshot” of documents you have open so that you are protected in the event of a mishap, such as a power outage. This is called *document safeguarding* and it happens automatically in GEOS.

If something happens and you are afraid you’ve lost work (the power goes out before you saved your work), document safeguarding may have protected your unsaved changes.

To get your work back, you don’t need to do anything special. Simply open the document you were working on. If there are unsaved changes in the document, and document safeguarding was able to protect them, a dialog box will appear letting you know the document has unsaved changes. Respond to the dialog box and then choose Save from the File menu to make the changes permanent.

If you want to change how often your documents are safeguarded, or if you want to turn off document safeguarding altogether, you can do so with settings in Preferences. For more information, see Chapter 12 in *The GEOS Environment & Accessories*.

**NOTE**

Document safeguarding is different from the “auto save” feature found in many DOS applications. Document safeguarding takes a temporary “snapshot” of your changes, but does not permanently save them to your document. Only the Save command will make changes permanent. This means that you control when the document is permanently updated.

**CLOSING DOCUMENTS**

When you close a document, you remove it from the screen; though, the application remains open. You may want to close a document but not its application so that you can create or edit another document in that application.

It is safest and best to save a document before closing it. This way you are guaranteed that all your changes have been saved.
Fortunately, if you forget to save your document before closing it, you will get one last chance to save your changes before the document closes. For more information about saving a document, see “Saving Documents” in this chapter.

To close a document (All Levels)

- Choose Close from the File menu. If there are unsaved changes in the document, you will be asked if you want to save the changes.

The document is closed. If there are no more open documents, then the New/Open dialog box appears.

WORKING WITH STANDARD FILE SELECTORS

A standard file selector is a special type of dialog box that appears whenever an application needs to know where to store a file you want to save, copy, or move, or where to find a file with which you want to work. Although different file selectors contain slightly different text, depending on what you are doing, they generally look and operate the same way. Common standard file selectors appear when you want to select an existing document to open, when you want to save a new document (or save an existing document under a new name), or when you want to create a copy of a document.

Simple Procedure

It’s easiest to store documents in your DOCUMENT folder. By doing so, you avoid the trouble of changing folders and drives in the standard file selector. You simply go straight to your DOCUMENT folder, which is where GEOS applications assume you are storing and retrieving documents.

The procedures for the easy way to use standard file selectors are documented in “Creating and Opening Documents” and “Saving Documents” in this chapter.

Complex Procedure

If you need to store or retrieve documents on another drive or in a folder other than your DOCUMENT folder, you can use a standard file selector to open and close folders and select files on any drive or directory to which you have access. The following
illustration shows the Open file selector in Level 2 of GeoWrite, which is an example of the standard file selector.

The buttons in a standard file selector are as follows:

- **Path drop-down list.** Click this button to display the Path drop-down list. Use this list to open, close, and change to other folders.

- **Go to Document button.** Use this button to move immediately to your DOCUMENT folder.

- **Folder and File list.** This list shows the open folder and its contents. Use this list to select a folder or a file.

- **Open folder.** The open folder is the one at the top of Folder and File list. The contents of the open folder are shown below it in the list.

THE PATH DROP-DOWN LIST

When you click the Path button, the Path drop-down list appears. This list shows the folders you moved through to get to the current folder. For example, if the current folder is the DOCUMENT folder, the Path drop-down list might look like the following:

```
Path
\C:Unamed1\ \GeoWorks
\ DOCUMENT
```
The folder at the bottom of the drop-down list is the current folder. If you had a folder named “Newsletter” inside your DOCUMENT folder and you selected that folder, the Path drop-down list might look like the following, with “LETTERS” as the current folder:

You can open the Path drop-down list to see the current folder in relation to other folders. You can also click a folder in the Path drop-down list to move directly to that folder.

MOVING THROUGH FOLDERS
You can move through folders in the following ways when you use a file selector:
- Open a folder.
- Close a folder.
- Move to the DOCUMENT folder.
- Move to another folder.
- Change to another drive and display its contents.

To open a folder (All Levels)
1. In the Folder and File list, locate the name of the folder you want to open. If necessary, use the scroll bar to see more of the list.
2. Double-click the name of the folder.
   or
Select the name of the folder and then click the Path button. The Path drop-down list appears and the selected folder appears as the last item in the Path: Click it.
The folder opens and its name appears at the top of the Folder and File list. The available contents of the open folder appear beneath its name.

To close a folder (All Levels)
1. At the very top of Folder and File list, locate the open folder. If necessary, use the scroll bar to see the top of the list.
2. Double-click the name of the open folder.
   or
Click the Path button to display its drop-down list. From this list, click the name of the folder above the folder you want to close. The open folder closes and the folder above it becomes the current folder. Its name appears at the top of the File and Folder list.

To move directly to your DOCUMENT folder (All Levels)

1. Click the Go to Document button. The DOCUMENT folder appears at the top of the Folder and File list. Its available contents appear beneath its name in this list.

To change to another drive (All Levels)

1. Click the Drives button. A list of available drives appears. Drives are labeled with letters, such as Drive A or Drive C. The letters A and B typically represent floppy disk drives. Hard disks, hard disk partitions, and other disk devices appear with other letters, usually starting with the letter C and proceeding through the alphabet.

2. Click the letter for the drive you want. The contents of the drive appear in the Folder and File list.

To move to another folder in the path (All Levels)

1. Click the Path button to display its drop-down list. A list of folders appears.

2. Click the name of the folder you want to access. The path list closes and the name of the selected folder appears at the top of the Folder and File list; its contents appear beneath it.

PRINTING DOCUMENTS

Typically, you print documents from within an application by choosing Print from the File menu. This section explains many common printing features and functions. However, the specific printing options you see will depend on the application and printer you’re using.
When you choose Print from the File menu, the Print dialog box appears which allows you to set various printing options before you print a document. The available settings vary by application and by printer. The following illustration shows a typical Print dialog box with some common options:

![Print Dialog Box Illustration](image)

In most applications, the Print dialog box is divided into two sections: Printer Options and Document Options. Depending on your application and printer, your Print dialog box may also have other sections.

- **Printer Options.** Includes items such as the selected printer, paper width and height, paper source, and advanced printer options.
- **Document Options.** Includes items such as print quality and number of copies.

**Printing With Standard Settings**

The Print dialog box comes with standard settings that work well to print most documents. The standard settings assume you want to print one copy of an entire document on 8.5" by 11" paper. If the standard settings do not meet your needs, see “Changing Document Options” in this chapter. If you are using a color printer, you may also want to review “Tips for Using Color” in this section.

*To print a document with standard settings (All Levels)*

1. Choose Print from the File menu. The Print dialog box appears.
2. Click the Print button at the bottom of the dialog box. A message appears informing you that your document is printing. The document prints with the standard settings.
Changing Document Options

The following procedure explains how to change the most common Document Options. The printer and application you’re using determine which of these options are available to you.

To change Document Options (All Levels)

1. Choose Print from the File menu. The Print dialog box appears:

   ![Print dialog box]

2. Fill in the dialog box, selecting from the Document Options section as follows:

   **Print Quality.** Click the radio button that represents the print quality you want to use. High quality produces the most professional looking documents, but it takes longer to print than if you use low quality. Low quality prints much more quickly but produces draft quality documents. Typically, you would want to print at low quality when you are working on drafts and printing speed is important. Select high quality to print final documents.

   **Text Only.** Text Only is the fastest way to print a draft because it uses an approximation of the fonts you see on screen and does not print any graphic images. Select the Text Only option if you want to get a printout of a document quickly.

   **Print Pages.** If you want to print the entire document, click All. If you want to print a range of pages, click From. A black dot appears in the From radio button. Click the arrow buttons or type numbers in the From and To boxes to reflect the range of pages you want printed. If your document has only one page, the To and From option is dimmed.

   **Number of Copies.** If you want to print more than one copy, change the number of copies by clicking the arrow buttons or typing a number in the Number of Copies box.
**Collate.** If you are printing multiple copies and you want them collated, check collate. When you collate copies of a document, one copy of the entire document is printed before the second copy is printed. Collating a document may require more time than not collating it. If you do not collate multiple copies, all copies of page 1 print before all copies of page 2, and so on.

3. Click Print if you’re ready to print the document with the new settings. If you want to change Printer Options before you print, see “Changing Printer Options” in this chapter. If your Print dialog box includes other options, see the chapters for the application you’re using.

**Changing Printer Options**

You are not likely to need to change Printer Options very often. Typically, you only change Printer Options, including size, type, and layout, if you change the paper in your printer.

Printer options must always reflect the actual physical setup of your printer. For example, if you’re printing a GeoDraw document that is 12" by 20" on a printer with 8.5" by 11" paper, the paper size in Printer Options must be 8.5" by 11". You use Page Size from the File menu to specify the size of your GeoDraw document. For more information, see “Changing Document Size and Orientation” in this chapter.

The four following procedures explain how to print to a different printer, change paper options, change the paper source, and print to a file.

**To print to a different printer (All Levels)**

1. Choose Print from the File menu The Print dialog box appears.
2. In the Printer Options section of the dialog box, locate the Printer option. Make sure the printer you want to use is selected. If it is not, use the drop-down list to select it.

![Print dialog box with printers listed](image)

You need to have previously added this printer to your list using Preferences. For more information on Preferences, see Chapter 12 in The GEOS Environment & Accessories.

3. Click Print if you’re ready to print the document to the current printer. If you want to change paper options, change the paper
source, or print to a file, see the following procedures. If your
Print dialog box includes other options, see the chapters that
describe the particular application you’re using.

*To change paper options (All Levels)*

1. Choose Print from the File menu The Print dialog box appears.
2. Make sure the printer you want to use is selected. If it is not, use
the drop-down list to select it.

3. Click the Options button that is below and to the right of the
printer selection. The Options dialog box appears. It will look
similar to the following, though it will vary depending on the
printer you selected:

![Options dialog box](image)

Width and height
4. Fill in the dialog box, changing the options you want, as follows:
   - **Type.** Change the paper type if it is incorrect.
   - **Size.** If the selected paper size is not the size of the paper in your printer, select the correct size from the paper size list.
   - **Width** and **Height.** If you want to use a custom paper size that is not included in the paper size list, use the Width and Height value selectors to enter the width and height of the paper you want to use.
   - **Paper Feed.** Select either portrait or landscape paper layout, depending on the direction of the paper in the paper tray. Portrait layout is a page printed so that, as you read it, the width of the page is less than its height. A horizontal layout is called landscape.

5. Click OK if you want the changes you’ve made to remain in effect for the current session.
   or
   Click Save Options and then click OK if you want the changes to remain in effect every time you print on this printer from now on. You can, of course, return to the Options dialog box whenever you want and change any of these options again.

You return to the Print dialog box.

6. Click Print if you’re ready to print the document with the new settings. If you want to print to a file or change the paper source, see the following procedure. If your Print dialog box includes other options, see the chapters that describe the particular application you’re using.

**NOTE**
You can change the size and orientation of your document without changing any printer settings. You should only change the printer settings in the Options dialog box when they do not match the physical settings on your printer. For information on changing the size and orientation of your document, independent of the paper in your printer, see “Changing Document Size and Orientation” in this chapter.

To change the paper source (All Levels)
You can also use Printer Options to change more advanced options, such as printing to a file and changing the paper source.

1. Choose Print from the File menu. The Print dialog box appears.
2. Make sure the printer you want to use is selected. If it is not, use the drop-down list to select it.

![Printer Options](image)

3. Click the Options button that is below and to the right of the Printer selection. The Options dialog box appears. It will look similar to the following, though it will vary depending on the printer you selected:

![Options Dialog Box](image)

With some printers, the Paper Source options appear as radio buttons.

4. Use the Paper Source drop-down list to select the location of the paper you want to use. The available options depend on the printer you’re using.

5. Click OK if you want the change you’ve made to remain in effect for the current session.

   or

   Click Save Options and then click OK if you want the change to remain in effect every time you print on this printer from now on. You can, of course, return to the Options dialog box whenever you want and change the paper source again.

   You return to the Print dialog box.

5. Click Print if you’re ready to print the document with the new settings. If you want to print to a file, see the following procedure. If your Print dialog box includes other options, see the chapters that describe the particular application you’re using.
To print to a file (All Levels)

Printing a document to a file creates a DOS file with all of the information that would have been sent to the printer, including all printer and graphic codes. This is especially useful when you wish to have a document printed by a service bureau, such as when you want to create a PostScript file for a high-resolution phototypesetter. Printing to a file usually creates an extremely large file unless you’re printing a PostScript file or are printing with the Text Only setting. One page of a complicated document can require over one megabyte of disk space. Make sure you have sufficient space before you print a document to a file.

1. Choose Print from the File menu. The Print dialog box appears.
2. Make sure the printer for which you want to create a file is selected. If it is not, use the drop-down list to select it. You need to have previously added this printer to your list using Preferences. For instance, if you want to create a file for a PostScript printer, you will need to first install a PostScript printer selection using Preferences even if you don’t have that printer physically attached to your computer. For more information on Preferences, see Chapter 12 in The GEOS Environment & Accessories.
3. Click the Options button that is below and to the right of the Printer selection. The Options dialog box appears.
4. Click the Print to: File radio button. A black dot appears in the middle of the File radio button.

   ![Print To: Printer File](image)

   Select to print to a printer or file.

5. Click OK if you want the change you've made to remain in effect for the current session.
   or

   Click Save Options and then Click OK if you want the change to remain in effect every time you print on this printer from now on. You can, of course, return to the Options dialog box whenever you want and change printing to a printer again.

   You return to the Print dialog box.
6. Click the Print to File button at the bottom of the Print dialog box. The Print to File dialog box appears:

![Print to File dialog box](image)

7. Use the file selector to select the folder where you want to store your file. For more information, see “Working with Standard File Selectors” in this chapter.

8. Type the name of the file in the text entry box. You must use a DOS file name. For more information, see “Naming a DOS File” in this chapter.

9. Click Print to File. A message appears informing you that your document is being printed to a file. You then return to your document.

**TIPS FOR COLOR PRINTING**

You can specify any of 16-million colors for text and graphics. When you print your document on a color printer, you get full color printouts. If you have a color display, but don’t have a color printer, you can still specify colors in your document. When you print a color document on a black and white printer, the colors print in shades of gray.

If you are using a color printer with Ensemble, you may wish to install both the color and black and white printer selections for that printer using Preferences. This way you can specify to print in color or black and white by simply choosing between the two printer selections when you print the document. When the Print dialog box appears, simply choose the desired option from the Printer drop-down list in the Printer Options section. Black and white printing is faster than color printing. When the document contains only black and white text and graphics, it is much faster to use the black and white printer selection.

You can tell if a printer is configured to print in color by looking at the name that appears on the Printer drop-down list in the Printer Options section of the Print dialog box. If the name of the
printer has the word “color” in parentheses at the end of its name, then it is configured to print in color. If it has “b/w” in parentheses at the end of its name, then it is a color printer, but it is configured to print in black and white. If it has neither, then it is not recognized as a color printer and will always print in black and white.

For more information on selecting and installing printers, see Chapter 12 in The GEOS Environment & Accessories.

Checking and Canceling Printing Documents

If you want to check the list of your print jobs or cancel a print job, choose Printer Control Panel from the Express menu. For more information about the Printer Control Panel, see Chapter 2 in The GEOS Environment & Accessories.

**CHANGING DOCUMENT SIZE AND ORIENTATION**

LEVELS 2-4

When designing a document, you may want to use the Page Size or Page Setup dialog boxes.

Page Size refers to the size and layout of your document on the screen, including paper type, size, layout, and margins. This does not have to correspond to the actual paper in your printer. For example, you may create a poster that measures 20" by 40". However, the paper in your printer may be 8.5" by 11". In the Page Size dialog box, you specify the size of your document, which is 20" by 40". In the Print dialog box, you specify 8.5" by 11". Your application calculates the number of 8.5" by 11" pages required to print your document and prints it over several pages which you can assemble into a poster. For more information about the Print dialog box, see “Printing Documents” in this chapter.

Different applications have slightly different Page Size dialog boxes, depending on the application you’re using. For features that are unique to the application you are using, see the chapter that describes the application. The Page Size dialog box is documented in this section.

The Page Setup choice varies from application to application. See the documentation for each application for more information on Page Setup.
The Page Size and Page Setup options are saved with the current document. If you use the same settings often, you can create a template with these settings or change the default settings for empty documents. For information on these topics, see “Managing Templates” and “Default Settings for Empty Documents” in Chapter 3.

*To change Page Size options (Levels 2–4)*

1. Choose Page Size from the File menu. The Page Size dialog box appears:

![Page Size dialog box]

Click here to select paper type.
Select page size from list.

Select portrait or landscape layout.

Displays width of selected page.
Displays height of selected page.
Set left, top, right, and bottom margins.

2. Fill in the dialog box, changing the options you want.

**Type.** Choose paper or envelope.

**Size.** Select a page size from the scrolling list. The scrolling list contains all common paper or envelope sizes.

**Width.** Displays the width of the page size you have selected. Can also be used to set a custom page width.

**Height.** Displays the height of the page size you have selected. Can also be used to set a custom page height.

**Paper Layout.** Select portrait or landscape layout.

**Margins.** Set left, right, top, and bottom margins.

3. Click Apply to apply the settings to the current document.
4. Click Close to close the dialog box.

**NOTE**
GeoWrite does not have margin settings in its Page Size dialog box. Instead, you use the Page Setup dialog box to change margins on a section by section basis.

**USER LEVELS**

You can make the GEOS productivity tools as simple or sophisticated as you want. Typically, the more functions an application has, the more intimidating it can be to learn. With the Ensemble productivity tools you can start using an application at a simple, basic level. As you gain experience and become comfortable with it, you can add more functions by changing the user level.

The introduction to each procedure in this manual is followed by the levels at which the particular task is available. For instance: “All Levels” or “Levels 3-4.”

All of the Ensemble productivity tools have four user levels. The following is a general description of each user level:

- **Level 1, Introductory Level.** Level 1 is for first-time users. It includes the application’s simplest features. Use Level 1 to learn the basic operation of the application.

- **Level 2, Beginner Level.** Level 2 is for users who are comfortable with Level 1 and want to use more of the application’s capabilities. Level 2 is also designed for infrequent users or those with simple requirements. If these are your needs, you may not need to move beyond Level 2.

- **Level 3, Intermediate Level.** Level 3 is for users familiar with basic operations who want to learn a few complex functions and procedures. Level 3 includes as much functionality as possible without seeming overwhelming.

- **Level 4, Advanced Level.** Level 4 is for people who use an application every day. It includes all the application’s functions and features as well as advanced shortcuts to complete common tasks. Level 4 is the most powerful and sophisticated level.
The first time you start an application, it will start at Level 1. For information about changing your user level, see “Verifying, Changing, and Saving Your User Level” in this chapter.

**Differences From Level to Level**

Within an application, the user levels build on one another. For example, Level 2 has all the features of Level 1 plus new features available at Level 2. Sometimes, when moving from a lower level to a higher level, the menu bar is rearranged to accommodate all the additional features of the new level. In this case, all the features from the previous level are still available, but they are organized differently across the menu bar.

**Verifying, Changing, and Saving Your User Level**

You can change or verify your user level both while doing work in the application or while the New/Open dialog box is on screen.

To verify or change your user level (All Levels)

1. If the New/Open dialog box is on screen, click the User Level button. Otherwise, choose Change User Level from the Options menu.

   The Change User Level dialog box appears. The highlighted button indicates the level at which you are currently working.

2. Click a button for a different user level if you want to change levels; then, click OK. Your user level is changed for the current session unless you change it again.

   or
Click Cancel if the current level is the one you want to work at. Your user level is unchanged.

To save your user level (All Levels)

If you always want the application to start at the user level you have just selected, you can use the following procedure.

- Choose Save Configuration from the Options menu.
  (If the New/Open dialog box is on screen, you will need to close the dialog box first, by opening or creating a document, before you choose can Save Configuration from the Options menu.)
When you save the configuration of an application, your user level and other options are remembered after you exit the application. For more information about saving your configuration, see “Setting Options and Saving your Configuration” in Chapter 2.

To reset your user level to Level 1 (All Levels)

- Choose Reset Configuration from the Options menu.

Fine Tuning Your User Level

Besides using the preset user levels, you can create your own customized user level. Each application has a set of fine tune features that you can turn on and off. Typically, Level 1 has the fewest fine tune features turned on; Level 4 has the most features turned on.

The features you can fine tune vary from application to application. For more information about which features you can fine tune in each one, see the chapters in this manual that explain that application.

To fine tune a user level (All Levels)

1. If the New/Open dialog box is on screen, click the User Level button. Otherwise, choose Change Level from the Options menu. The Change User Level dialog box appears.
2. To see which features comprise a user level, click that user level and then click Fine Tune. The Fine Tune dialog box appears. The set of fine tune features that are turned on and off defines the user level you selected.

3. To change the available fine tune features, click the features in the Fine Tune dialog box to turn them on or off. Selected features have a darkened check box.

4. When you finish selecting and deselecting features, click OK. The Change User Level dialog box reappears. If the fine tune changes you made coincide with a pre-defined user level, that button is highlighted. If the changes you make do not coincide with a pre-defined user level, none of the user level buttons is highlighted.

5. Click OK to return to the document at the user level you have defined.

6. If you always want the application to start at the user level you have just fine-tuned, choose Save Configuration from the Options menu. (If the New/Open dialog box is on screen, you will need to close the dialog box by opening or creating a document before you can choose from the Options menu.)

When you save the configuration of an application, your user level and other options are remembered after you exit the application. For more information about saving your configuration, see “Setting Options and Saving your Configuration” in Chapter 3.

WORKING WITH MULTIPLE APPLICATIONS

ALL LEVELS

As you become more familiar with GEOS applications, you may want to use more than one application at a time. For example,
you might be calculating a budget in GeoCalc and writing a letter to a friend in GeoWrite. By running more than one application, you could work on both documents at the same time.

Applications “stack” up with the active one on top. The title bar of the active window is highlighted. You can resize the application windows so that you can see edges of each open application. Then, you can move between documents and applications by clicking the window. You can also move between applications using the Express menu. For more information about the Express menu, see “Using the Express Menu” in this chapter.

To open multiple applications (All Levels)

1. Open the first application. The application opens, partially filling the screen. You can open a document if you want.
2. Open the second application. The application opens on top of the first application window. At this point, you can resize or move the windows so that you can see corners of the window. In that way, you can simply click the window and that application comes to the top of the stack.

NOTE
You can open as many applications as you want, though you aren’t likely to need very many applications open at one time. Since every open application uses some of the computer’s memory, you should open only those applications that you want to use. If you have several applications open and your computer seems to be running slower than it normally does, try exiting from a few of them and see if that improves system performance.

To work with multiple applications using the Express menu (All Levels)
Once you have an application open, you can open or switch to any other application in the WORLD folder.

1. Click the Express button, which is located next to the Window Control button on the left side of the title bar of the current application. The Express menu appears.

2. Choose Start an Application to see a list of applications you can start. Click the application you want to start. The application starts.

You can switch between an application and any other application you can see on the screen by clicking the desired window. You
can also switch to an application by selecting its name from the Express menu.

To make an application always remain in front of others

1. Place the application in the Desk Accessories folder (in the WORLD folder).
2. Start the application either by double-clicking its icon or by using the Express menu. The application starts.

The application's window remains in front of other applications even if you click in another application's window — provided the other application is not also in the Desk Accessories folder. If you click in the window of another desk accessory, its window comes to the front.

USING THE EXPRESS MENU

The *Express menu* is a special menu that lets you quickly start an application, switch between running applications, check your printing, or exit directly to DOS. The Express menu works just like any other menu in Ensemble 2.0. But to see it, instead of clicking a menu name, you click the Express button. The Express button appears only in the active window (there's always one active window, so the Express menu is always available). Here are the items you have to choose from in the Express menu:

- **Running Applications** Any applications that are currently running appear in the Express menu. Choose one to bring the application's window to the front.
- **Start an Application** brings up a submenu from which you can start any Ensemble 2.0 application in the WORLD folder or one of its subfolders.
- **Desk Accessories** Any applications that you have put in the Desk Accessories folder appear here. For more about using the Desk Accessories folder, see "Working With Multiple Applications" in this chapter.
- **Printer Control Panel** opens the Printer Control Panel dialog box where you can see what documents you have currently printing or waiting to print. You can also cancel the printing of any document.
- **Go to GeoManager** Brings the GeoManager window to the front, making it the active window.
• **Exit to DOS** shuts down Ensemble 2.0 and returns you to the DOS prompt.

*To switch between running applications*

1. Click the Express button. The Express menu appears.
2. Choose the application's name from the Express menu. The application's window immediately comes to the front, making it the active window.

*To start an application*

1. Choose Start an Application from the Express menu. A submenu appears with a list of folders and applications in the WORLD directory.
2. Choose the application from the submenu.
   
   or
   
   Choose one of the folder names. A submenu appears with a list of applications in that folder. Click one of the application names. The menu disappears and the application starts.

*To monitor your printing*

- Choose Printer Control Panel from the Express menu. The Printer Control Panel appears. Use it to monitor your printing and cancel documents that are waiting to print. See “Checking and Canceling Printing Documents” in Chapter 2 for more information about the Printer Control Panel.

*To return to GeoManager*

- Choose Go to GeoManager from the Express menu. The GeoManager window comes to the front, making it the active window.

*To exit directly to DOS*

- Choose Exit to DOS from the Express menu. Ensemble 2.0 shuts down.
Tools and Techniques  This chapter presents additional concepts and tasks that are common to two or more of the Ensemble applications.
At the end of this chapter you will know how to do the following:

- Set options.
- Save your application configuration.
- Control your view of a window.
- Show rulers and set measurement units.
- Display and use the Tool Bars.
- Customize the Tool Bars.
- Select text and other items for editing and formatting.
- Use Cut, Copy, and Paste.
- Drag and drop items.
- Delete items.
- Use undo.
- Format text with fonts, sizes, styles, and justification.
- Type special characters.

Even though these basic tasks are common across different applications, a specific application may have additional features that enhance the common functionality. The chapters for each application explain all tasks and functions that are unique to that application. Other applications may have fewer common features.

**CONTROLLING YOUR VIEW OF A WINDOW**

The View menu provides choices for changing the way you view a document in a window. You can use the View menu to do the following:

- Zoom in and out on a document, enlarging or reducing its display in a window.
- Enlarge or reduce your view to a custom percent.
- Scale your view of a document so that the whole page fits in the window.
- Set view options, such as whether the horizontal and vertical scroll bars are shown.
- Redraw your screen to see a more accurate rendition of the page.

If you change the view of your window and then choose Save Configuration from the Options menu, your settings will be
saved. For more information on saving your configuration, see “Setting Options and Saving Your Configuration” in this chapter.

**Zoom Out, Zoom In, and Normal Size**

When you open a document, it appears at normal size — the size of the document when it is printed. Sometimes, however, you’ll want to make the document smaller on screen, so that you can see more of it at once. This is called *zooming out*. Zooming out is much like a birds eye view of the document. Sometimes you’ll want to make your document look larger, so that you can see details more clearly. This is called *zooming in*. Zooming in is like putting a magnifying glass over a small portion of the document.

**To use Zoom Out, Zoom In, and Normal Size (All Levels)**

1. To reduce the size of a page so that you can see more of it, choose Zoom Out from the View menu. Each time you zoom out, you reduce the size by 25%. You can reduce the page to 25% of its normal size.

2. To enlarge the size of a page so that you can see more details, choose Zoom In from the View menu. Each time you zoom in, you enlarge the size by 25%. You can enlarge the page up to 200% of its normal size.

3. To quickly return to normal size, choose Normal Size from the View menu. Normal size is 100% of the view.

**View at %**

View at % allows you to choose the percentage of magnification of a page. You can choose from any of the pre-set Zoom Out and Zoom In options, or you can set your own percentage.

**To use View at % (Levels 3–4)**

1. Choose View at % from the View menu. A submenu lists the standard size reductions and enlargements:
2. To choose any standard size, click the choice you want. The menu closes and the page appears at the selected size.

or

To specify any number between 25 and 200%, choose Custom %. The Custom % dialog box appears:

![Custom % dialog box](image)

Type a number or use the arrow buttons to change the value in the Scale (%) box. Click Apply. The percentage you specify is applied to the document, and the Custom % dialog box remains open so that you can experiment with other values. When you've selected the value you want, click Close to close the dialog box.

**Scale to Fit**

Use scale to fit when you want to see an entire page of your document in the window without scrolling. If you choose Scale to Fit, the application automatically sizes the document so that as much of it as possible shows in the window.

*To enable Scale to Fit (Levels 2–4)*

- Choose Scale to Fit from the View menu. The view percentage changes, shrinking the document so that an entire page fits in the window at once, if it can.

As long as the Scale to Fit option is on, the document will automatically change size to fit in the window, even if you change the size of the window.

*To disable Scale to Fit (Levels 2–4)*

- Choose Normal Size from the View Menu.

  or

- Choose a percentage from the View at % submenu on the View menu.

**Changing View Options**

When you choose View Options, a submenu with three options appears:
The options on the View Options menu are as follows:

- **Change All Views Together.** Normally, when you have more than one document open in the same application, any changes you make to the view settings apply to all of the document windows at once. That is, if you change the view percentage in one window, it changes in all windows in that application. However, if you deselect the Change All Views Together option, then any changes you make to view settings apply only to the current document window and not to all of the open windows. For more information on document windows, see “Working With Multiple Documents” in Chapter 3.

- **Show Horizontal Scroll Bar.** When unchecked, the document window will not display a horizontal scroll bar. Since the scroll bar takes up space in your document window, you can hide it to increase the available vertical space in which to display the document.

- **Show Vertical Scroll Bar.** When unchecked, the document window will not display its vertical scroll bar. Deselect to increase the available horizontal space in which to display the document.

**To set View Options (Levels 3–4)**

1. Choose View Options from the View menu. The View Options submenu appears.
2. Select or deselect any of the options.
   The View Options submenu closes and you return to the document.
3. Repeat this procedure to turn other view options on or off.

**Redrawing the Screen**

Sometimes, when you work with a complicated document, you may notice that GEOS does not redraw everything on the screen after you make a change. This is because it can take a while to redraw every component on a complicated page. Often, GEOS applications redraw only some of the components to save time. If you need complete accuracy, however, use the Redraw choice to force the application to take the time to redraw every component of your page.
To redraw the screen (Levels 2–4)

- Choose Redraw from the View menu. The document redraws, updating the accuracy of any complicated text and graphics on the page.

SHOWING RULERS AND SETTING MEASUREMENT UNITS

Some applications use rulers to provide visual measurements. In GeoWrite, you can also use the ruler to set margins and tabs, and in GeoCalc you can use the ruler to work with rows and columns. For more information about using GeoWrite rulers for paragraph formatting, see “Using the Ruler” in Chapter 4. For more information about using GeoCalc rulers, see Chapter 12, “GeoCalc Basics.”

Different Ensemble productivity tools have different rulers. For example, GeoWrite shows a ruler at the top of the writing area to display the width of the page. GeoDraw has both vertical and horizontal rules. You can display the measuring rulers in various units: inches, centimeters, points, picas, and the system default setting specified in Preferences. GeoCalc has a special ruler that does not normally show measurements. Instead it shows the numbers and letters that correspond to the rows and columns.

If you change your ruler settings and then choose Save Configuration from the Options menu, your settings will be saved. For more information on saving your configuration, see “Setting Options and Saving Your Configuration” in this chapter.

NOTE

When you change any of the ruler settings, the change normally applies to all document windows in the current application. If you only want the change to apply to the current document window, deselect the Change All Views Together option on the View Options submenu. For more information, see “Changing View Options” in this chapter.

To turn rulers on or off (GeoDraw Levels 3–4; GeoWrite Level 4)

GeoWrite and GeoDraw have both vertical and horizontal rulers that you can turn on or off independently.

1. Choose Rulers from the Options menu. The Rulers submenu appears.
GeoCalc has both vertical and horizontal rulers, but you always turn them on or off together.

2. Choose Show Vertical Rulers or Show Horizontal Rulers to turn the corresponding ruler on or off. These two choices work independently.

To turn rulers on or off (GeoCalc Level 2)

• Choose Show Rulers from the Options menu.

To turn rulers on or off (GeoCalc Levels 3-4)

1. Choose Rulers from the Options menu. The Rulers submenu appears.

2. Choose Show Rulers.

To change the ruler type or measuring units (GeoCalc Levels 2-4; GeoDraw Levels 3-4; GeoWrite Level 4)

1. Choose Rulers from the Options menu. A submenu appears, listing the following types of measurement units:
   • Spreadsheet (GeoCalc only, shows rows and columns)
   • Inches
   • Centimeters
   • Points
   • Picas
   • System Default (as set in Preferences)

2. Choose the type of measuring unit you want. The rulers change to represent the new measurement unit.
USING THE TOOL BARS

Tool Bars provide buttons that give you quick access to menu choices and features. The Tool Bars appear either under the menu bar or to the left of the application window. Clicking a tool is similar to opening a menu and selecting a choice. The following illustration shows an example of Tool Bars in an application:

These are the Tool Bars you can see in GeoWrite Level 4.

Ensemble applications can have as many as six Tool Bars available at different levels. For example, Level 1 of GeoCalc has no Tool Bars and Level 1 of GeoWrite has only the Style Tool Bar.

Some Tool Bars contain tools that are unique to an application; for example, the Insert Row tool appears only in GeoCalc. Application-specific tools are defined in the documentation for that application.

The following are the standard Tool Bars:

- **Style Tool Bar.** For changing the format of text.
- **Function Tool Bar.** For working with documents (opening, closing, saving), using the clipboard (cutting, copying, and pasting), and other functions.
- **Drawing Tool Bar.** Contains the drawing tools from GeoDraw for drawing objects on the page.
- **Bitmap Tool Bar.** Contains the bitmap drawing tools from GeoDraw for working with bitmap objects.
• **Attributes Tool Bar.** For changing the color, shading, and thickness of graphic objects and text.

• **Floating Tool Box.** Contains tools for manipulating graphic objects, including tools for duplicating, flipping, shuffling, grouping, and ungrouping objects.

• **Graphic Tool Bar.** Combines the best of the Attributes Tool Bar and the Floating Tool Box into one, for GeoWrite and GeoCalc.

The remainder of this provides a broad overview of the Tool Bars. For an explanation of individual tools on the Tool Bars, see Appendix D and the chapters for the application you are using.

**The Style Tool Bar**

The most complete Style Tool Bar is in GeoWrite, though GeoCalc and GeoFile have their own variations.

You can use the Style Tool Bar to change the text characteristics: font, text size, and style. In addition, you can use the tools on the Style Tool Bar as shortcuts to perform common word processing functions.

The Style Tool Bar appears at all Levels in GeoWrite and at Levels 2 through 4 in GeoCalc. Text formatting tools from the Style Bar appear in Levels 3 and 4 of GeoFile when using Design Mode.

For more information on tools from the Style Tool Bar, see Appendix D.

**The Function Tool Bar**

The Function Tool Bar contains tools to perform file functions, such as opening, closing, and saving files. It also contains editing tools (cut, copy, paste, and undo) and zooming tools. The tools available on the Function Tool Bar vary depending on the application.

The Function Tool Bar is available in Levels 2 through 4 of GeoWrite and GeoCalc, though it is not normally shown.
Portions of the Function Tool Bar appear in Levels 3 and 4 of GeoDraw and GeoFile. For more information on tools from the Function Tool Bar, see Appendix D.

**Tool Bars for Drawing and Graphics**

GeoDraw is the drawing application, but since GeoWrite, GeoCalc, and GeoFile also support drawing, you will find many of the GeoDraw tools in each of these applications.

The following illustration shows GeoDraw at Level 4 with its Tool Bars labeled:

**THE DRAWING TOOL BAR**

The Drawing Tool Bar contains the GeoDraw tools for creating graphic objects:
There are tools for drawing different objects, including lines, circles, and rectangles. All of the tools on the Drawing Tool Bar work the same as they do in GeoDraw.

The Drawing Tool Bar is available in GeoWrite Levels 2 through 4, though at Level 2 there are only two tools. In GeoCalc and GeoFile the Drawing Tool Bar is available at Levels 3 and 4. At Level 4, there are more tools than at Level 3.

For information on using the tools on the Drawing Tool Bar, see the appropriate sections in Chapters 8 through 11, which cover GeoDraw.

THE BITMAP TOOL BAR

The Bitmap Tool Bar contains the GeoDraw tools for creating bitmap objects:

![Bitmap Tool Bar]

The Bitmap Tool Bar is available in GeoWrite and GeoCalc at Levels 3 and 4. It is not available in GeoFile. For more information on using the tools on the Bitmap Tool Bar, see “Working With Bitmaps” in Chapter 10.

THE FLOATING TOOL BOX

The Floating Tool Box stands on its own in GeoDraw but is part of the Graphic Tool Bar in GeoWrite and GeoCalc. It provides tools for manipulating graphic objects, including tools for duplicating, flipping, shuffling, grouping, and ungrouping objects.

![Floating Tool Box]
For more information on using the tools on the Floating Tool Box, see “Using the Floating Tool Box” in Chapter 11.

THE ATTRIBUTES TOOL BAR
The Attributes Tool Bar stands on its own in GeoDraw but is part of the Graphic Tool Bar in GeoWrite and GeoCalc. The Attributes Tool Bar contains tools for setting the color and other attributes (such as line thickness and shading) for graphics and text.

For more information on using the tools on the Attributes Tool Bar, see “Setting Attributes” in Chapter 10.

THE GRAPHIC TOOL BAR
The Graphic Tool Bar is only available in GeoWrite and GeoCalc. It contains tools for working with graphics and is a combination of the tools from the previously-described Attributes Tool Bar and Floating Tool Box in GeoDraw.

The Graphic Tool Bar is available in GeoWrite and GeoCalc in Levels 3 and 4, but is not normally shown. The Graphic Tool Bar has additional tools in Level 4 that it doesn’t have in Level 3. For information on using the Attributes tools on the Graphic Tool Bar, see “Setting Attributes” in Chapter 10. For information on using the Floating Tool Box tools, see “Using the Floating Tool Box” in Chapter 11.

Displaying Tool Bars
Different Tool Bars are available at different user levels; however, the availability of a Tool Bar does not mean that it is displayed. You can use the Options menu to turn on and off the display of available Tool Bars. For example, at Level 2 of GeoCalc, the Style
and Function Tool Bars are available, but only the Style Tool Bar is shown. If you want to set the display of Tool Bars for every work session, choose Save Configuration from the Options menu. In GeoFile and GeoDraw, Tool Bars are always on.

To display a Tool Bar (All Levels)

1. Choose Show Tools from the Options menu. The submenu lists the available tools. The check boxes are darkened for visible Tool Bars.
2. Click the button for the Tool Bar you want to change. If the Tool Bar was showing, it is now hidden. If it was hidden, it is now showing.

Working With Tools

Some tools on the Tool Bar are buttons that you click. Others are in the form of a drop-down list.

To use a tool (All levels)

1. Select the item you want to work on.
2. Click the tool you want to use.

To use a drop-down list on the Tool Bar (All Levels)

1. Select the item you want to change.
2. Click the button for the drop-down list. Drop-down list buttons have a bar on the right side of the button, like the example at the left. The list drops down so you can make a selection. Notice the current setting in the drop-down has a darkened radio button.
3. Click the choice you want. The new item is selected, while the old item is unselected.
CUSTOMIZING THE TOOL BARS

LEVEL 4

You can change the Tool Bars to fit your needs, choosing to hide or display certain tools and to move the Tool Bars to new locations. Tools are organized into groups. The following illustration shows the Style Sheet tool group on the Style Tool Bar in GeoWrite:

![Style sheet tool group]

You can show or hide individual tools within a group and you can move a group of tools as a unit into any position on any Tool Bar. For instance, you can move the document control tools (which include Open and Close, for instance) from the Function Bar to the Style Bar in an application.

You can customize the following tool groups, available on most application Tool Bars:

- Text style
- Font
- Point size
- Justification
- Object tools
- Bitmap tools
- Find and replace
- Spell check
- Document control
- Edit/clipboard
- View options
- Print control
- Area attributes
- Line attributes
- Line width/style
- Character foreground color
- Object grouping
- Object edit special
- Object depth
• Object flip

To hide or display individual tools in a group (Level 4)

1. Display any tool bars with which you want to work.
2. Choose Customize Tool Bars from the Options menu. The following dialog box appears:

![Customize Tool Bars](image)

On the Tool Bars themselves, each individual tool group is highlighted with a thick border.

3. From the list of tool groups, select the name of a tool group. or
   Click a tool on the Tool Bar. The name of that tool group becomes selected in the list.
4. Click Show/Hide Tools in Group. The following dialog box appears, showing all the tools in the group:

![Show/Hide Tools in Group](image)

Any items which are not highlighted are currently hidden.

5. Click to toggle the selections on or off. If you want to return to the last display of tools, click Reset before clicking Apply.
6. Click Apply. The Tool Bars redraw according to the selections you made.
7. If you want to show and hide additional tools, you can repeat steps 3 through 6 as many times as you like. The dialog boxes stay open and you can freely click between them.
8. When done, click Close to close the dialog boxes.
9. If you want to save your customization, choose Save Configuration from the Options menu.

To move a tool group (Level 4)

1. Display any tool bars with which you want to work.
2. Choose Customize Tool Bars from the Options menu. The following dialog box appears:

3. In the list of tool groups, click to select the name of a tool group.
   or
   Click any visible tool on the Tool Bar to select that group.
4. Click Move Tool Group. The following dialog box appears:

5. If you want to move the tool group to a different Tool Bar, select the name of the destination Tool Bar from the list in the dialog box, then click Apply.
6. If you want to move the tool group within the Tool Bar, click one of the Nudge buttons to move the group in the direction you want. Each time you click one of the Nudge buttons, the tool group moves in the direction specified.
7. If you want to move additional tools, you can repeat steps 3 through 6 as many times as you like. The dialog boxes stay open and you can freely click between Tool Bars on the window, the Customize Tool Bars dialog box, and the Move Tool Group box.

*If you want to return to the last display of tools, click Reset before clicking Apply.*
8. When done, click Close to close the dialog boxes.
9. If you want to save your customization, choose Save Configuration from the Options menu.

SETTING OPTIONS AND SAVING YOUR CONFIGURATION

You can change an application so that it works the way you want, with the tools you like to use and the options set the way you like. When you choose these settings, you are configuring the application to suit your particular needs. You can change the following settings and save them so that they are in effect the next time you start the application:

- Set or fine-tune the user level. (See “User Levels” in Chapter 1.)
- Adjust the view percentage and view options on the View. (See “Controlling Your View of a Window” in this chapter.)
- Display and set the rulers. (See “Showing Rulers and Setting Measurement Units” in this chapter.)
- Display and customize the Tool Bars. (See “Using the Tool Bars” and “Customizing the Tool Bars” in this chapter.)
- Change other options on the Options menu. (Consult chapters for specific applications.)

To save the application configuration (All Levels)
If you want to keep the configuration you’ve set so that it is in effect each time you start the application, you can save the configuration.

1. Set the options you want.
2. Choose Save Configuration from the Options menu. The current options are saved, so the next time you start the application, those options will take effect immediately.

To reset the configuration (All Levels)

Choose Reset Configuration from the Options menu. The application resets all of its options, tool bars, and user levels to the original, default settings.
SELECTING AND EDITING

ALL LEVELS

Whether you have drawn an illustration, developed a cash flow spreadsheet, or created a list of addresses, you may need to make changes to your documents. It is easy to change things with Ensemble applications by selecting and editing, which is a two-step process:

1. First, select the item you want to change. This sets it apart from the items around it.
2. Then select the type of change you want to make to the item.

When you select an item, it is highlighted by a border, by reversing its colors, or by giving it "handles," as shown in the following illustration. Selected items are ready for you to change.

When you want to make changes, for example, rewording a sentence in GeoWrite or changing an address in GeoDex, first you must select the text you want to change. Selected text appears.

The text is selected.

The range of cells is selected.

The circle is selected.

Once you have selected items you can edit them. Whether you are working with text, graphics, or cells in a spreadsheet, you can edit your document by, moving or copying items from one location to another. For example, you can copy an image from one part of a document and insert at another location. Or you can delete a section of a document entirely. Or you can move it to another location.

You first select an item before perform an editing operation on it. For instance, to copy an item you would first select it, then perform the copy operation.
**Selecting Text**

When you want to make changes to text, for example rewording a sentence in GeoWrite or changing an address in GeoDex, you must first select the text you want to change. Selected text appears highlighted.

You can use a mouse or a keyboard to select text.

*To select text with a mouse (All Levels)*

1. Move the mouse pointer to the word, line, or paragraph you want to select.

2. Press and hold the mouse button and drag the mouse across the text until what you want to select is highlighted. Then release the mouse button.

   *or*

   Click at the beginning of the text, hold down the **Shift** key, and click at the end of the text.

   *or*

   Position the pointer over the text you want to select and quickly click the appropriate number of times:

   - 2 Clicks Selects a word, but not the space after the word
   - 3 Clicks Selects a line
   - 4 Clicks Selects a paragraph
   - 5 Clicks Selects the entire document

   The text you want to delete, replace, or change is selected.

*To extend or reduce the selection (All Levels)*

You may want to change the amount of text you have selected.

1. While a selection is already highlighted, press and hold down the **Shift** key.
If you are using the arrow keys on the numeric keypad to select, be sure Num Lock is off (the Num Lock light on the keyboard is not lit).

2. Click where you want to extend or reduce the selection.

Shift-click to extend the selection to this location.

While a selection is already highlighted, position the pointer and hold down the Shift key. Then click where you want to extend or reduce the selection.

To use the keyboard to select text (All Levels)

If you are a fast typist, you may not want to take your hands off the keyboard to select text. The list below shows how to select text by using two or more keys at the same time. You can use these keys in any combination to extend or reduce a selection you have already made.

- **Shift+Home.** Selects from the insertion point to the beginning of the line.
- **Ctrl+Shift+Home.** Selects from the insertion point to the beginning of the document.
- **Shift+End.** Selects from the insertion point to the end of the line.
- **Ctrl+Shift+End.** Selects from the insertion point to the end of the document.
- **Shift+Right or Left Arrow.** Selects one character in the direction of the arrow.
- **Ctrl+Shift+Right or Left Arrow.** Selects from the insertion point to the nearest beginning or ending of a word in direction of the arrow.
- **Shift+Up or Down Arrow.** Selects from insertion point one line in the direction of the arrow.
- **Ctrl+Shift+Up or Down Arrow.** Selects to beginning or end of the current paragraph.

To cancel a text selection (All Levels)

- If you change your mind after making a selection, you can cancel the selection by clicking anywhere in the text area or by pressing one of the arrow keys.

**Selecting Spreadsheet Cells**

A spreadsheet always has at least one cell selected. That cell has a dark border but is not otherwise highlighted. You can also
select a range of cells. The selected range appears as a highlighted block of cells.

To deselect the selection, simply select something else.

To select a single cell (All Levels)

- Click the cell you want to select.

  or

  Use the arrow keys on the keyboard to move the highlighting to the cell you want to select.

To select a range of cells (All Levels)

- Drag from the first cell to the last cell of the range you want to select.

  or

  Select the first cell in the range, and then hold down the Shift key while pressing the arrow keys to extend the selection.
Selecting Graphics

When you select a graphic, handles appear around the object:

You can select a single graphic object or a group of graphic objects.

SELECTING AND DESELECTING A SINGLE OBJECT

Most of the time you’ll probably want to select a single object to work with.

To select a single object (All Levels)
- Click the object you want to work with. The object selects and its handles appear.

To deselect a single object (All Levels)
- Click a different object. The new object is selected and the original object is deselected.
  or
- Click in an area of the window where no objects appear. The original object is deselected.

SELECTING AND DESELECTING A GROUP OF OBJECTS

You can select a group of objects, such as several shapes in a drawing or multiple cells in GeoCalc. By selecting a group of objects, you can change many objects at the same time. For example, if you want to change the color of several objects in a drawing to blue, you can select all of them and then select blue.

There are many ways to select a group of objects. You can select one object at a time, or you can specify a range. Once you have selected a group, you can extend the selection to include other objects that weren’t included in the original group. Or you can deselect certain objects to remove them from the group.

To select a group of objects one at a time (All Levels)

1. Click one object in the group. The object is highlighted or has handles to indicate its selection.
2. Hold down the Ctrl key and click the other objects you want to add to the group, one at a time. If you add an object by mistake, hold down the Ctrl key and click it again to deselect it.

To select a group of objects by dragging (All Levels)

When you drag to select a group, you group the objects by enclosing them in a dotted rectangle.

1. Move the mouse pointer to the upper-left corner of an imaginary rectangular area that will eventually expand to enclose all the objects you want to select.

2. Press and hold the mouse button while dragging the mouse. The outline of a box follows the pointer, changing size as you drag the mouse.

3. Drag the outline until it surrounds all the objects you want to select.

4. Release the mouse button. Everything within the box is selected.

5. If you made a mistake and released the mouse button in the wrong place, you can adjust the corner of the rectangle by holding down the Shift key and clicking where you would like to place the corner. The outline adjusts and everything within the new box is selected.

To select a group of objects between two points (All Levels)

1. Move the mouse pointer to the corner of an imaginary rectangular area that will eventually enclose all the objects you want to select. Click the mouse button. This is the first point.

2. Move the pointer to the opposite corner of the imaginary box; make sure the corners are far enough apart so that the box surrounds the most distant object you want to include in your selection. Hold down the Shift key and click. This is the second point. Everything between the first point and the second point is selected. If you make a mistake selecting the second point, hold down the Shift key and click in another location. This changes
the range of selected objects by moving the second point. To begin over again, release the Shift key and repeat the process.

To add objects to a group of selected objects (All Levels)

1. Hold down the Ctrl key and click another object to add it to the current selection.
   or
   Hold down the Ctrl key and drag to select additional objects by surrounding them with a dotted box.
   Repeat this step as often as you want to add more objects to the group.

2. When you are finished adding all the objects you want, release the Ctrl key.

To select all objects (All Levels)

Choose Select All from the Edit menu. Everything in the document is selected.

To subtract objects from a group (All Levels)

1. Hold down the Ctrl key and click a selected object to remove it from the group.
   or
   Hold down the Ctrl key and drag the dotted box to enclose a group of objects you want to remove from the selected group.
   Repeat this step as often as you want to subtract additional objects from the group.

2. When you are finished subtracting all the objects you want, release the Ctrl key.

To deselect a group of objects (All Levels)

Click in any area of the window where no object appears. The entire group of selected objects is deselected.

or

Click to select a single object. The single object is selected and all other previously selected objects are deselected.

Replacing Text

The fastest way to replace text is to select it and then type the new entry.
To replace text (All Levels)

1. Select the word or words you want to replace.
2. Type the replacement text. The new text replaces the original text.

Cutting, Copying, and Pasting

You can move text and graphic images around your documents, as if you were cutting and pasting with scissors and glue.

When you select text or a graphic image, you can cut it to move it elsewhere or copy it to paste a replica of it in another place. The selection you copy or cut is placed on the clipboard, an electronic holding space. When you choose Paste from the Edit menu, the contents of the clipboard are pasted into the active document. The active document can be the document that contains the original selection, another document in the same application, or another document in another application. For more information, see “Working With Multiple Documents” Chapter 3 and “Working with Multiple Applications” in Chapter 1.

When you copy or cut a selection to the clipboard, it replaces whatever is currently on the clipboard.

To move a selection (All Levels)

When you move a selection, you remove or cut it from its original location and paste it into another location.

1. Select the item or text you want to move.
2. Choose Cut from the Edit menu. The item is removed from your document and placed on the clipboard, replacing any item already there.
3. Move the insertion point to the location where you want the item to appear. In the case of graphic images, you cannot specify the location.
4. Choose Paste from the Edit menu. The contents of the clipboard are inserted into the document. For text, the pasted text appears at the insertion point. For graphic images, the pasted image appears in its original location if this location is still visible in the window. If the original location is not visible, the pasted image appears in the center of the window.

To copy a selection (All Levels)

If you want to leave an item in its original location and also insert it somewhere else, use Copy instead of Cut.
1. Select the item or text you want to copy.
2. Choose Copy from the Edit menu. The item remains in your document and also goes to the clipboard, replacing any other item on it.
3. Move the insertion point to the location where you want the item to appear.
4. Choose Paste from the Edit menu. The contents of the clipboard are inserted into the document.

**NOTE**
When you paste an item into a document from the clipboard, the item also remains on the clipboard unless you replace it. Therefore you can continue to paste the same item from the clipboard to multiple locations in your document.

*To replace one block of text with another (All Levels)*

1. Select the block of text you want to replace the existing text.
2. Choose Copy or Cut from the Edit menu. The text is placed on the clipboard.
3. Select the block of text you want to replace.
4. Choose Paste from the Edit menu. The selection is replaced by the contents of the clipboard.

**Dragging and Dropping**

The drag and drop feature provides a quick way to move or copy text or graphic images without using the clipboard. You can drag and drop text and graphics from one location to another in a document, or from one document to another, even between applications.

*To drag and drop information from one location to another (All Levels)*

1. Select the information you want to move or copy.
2. Move the mouse pointer over the selected range; and then press and hold down the right mouse button. The drag and drop pointer appears.
3. Drag the pointer so that it is over the location where you want to move or copy the information.
4. Release the mouse button. The information is moved or copied, depending on whether you dragged within the same document or from one document to another.

**NOTE**
As you perform the drag and drop, the small square at the end of the pointer changes to indicate whether this will be a move or a copy.
When the pointer is over the same document, the default operation is a move (indicated by the hollow square at the end of the drag and drop pointer). If the pointer is over another document, the default operation is a copy (indicated by a filled square).
You can override this behavior by holding down the Alt key (to move) or the Ctrl key (to copy) while performing the drag and drop. The small square at the end of the pointer becomes hollow or filled as appropriate.

**Deleting**
You can delete text or graphic images from any document:

*To delete items (All Levels)*

1. Select the text or graphic image you want to delete.
2. Press the **Backspace** or **Delete** key.
   
   or

   Choose Cut from the Edit menu.
   
   or

   Hold down **Shift** and press **Delete**, which is the shortcut key for Cut.

   The selection is deleted.

**NOTE**
Those methods that delete items by cutting (the Cut choice on the Edit menu and the keyboard shortcut **Shift+Delete**) place the selection on the clipboard. You can paste the selection from the clipboard to another location as long as you haven’t cut or copied another item to the clipboard.

*To delete text by using the keyboard (All Levels)*

As long as no text is selected, you can use the following keystrokes to delete text:

- **Backspace**. Character to the left
• **Delete.** Character to the right
• **Ctrl+Backspace.** From insertion point to beginning of word
• **Ctrl+Delete.** From insertion point to end of word
• **Shift+Ctrl+Backspace.** From insertion point to beginning of line
• **Shift+Ctrl+Delete.** From insertion point to end of line

**Using Undo**

Sometimes you may delete or change some text or graphic image and immediately decide you have made a mistake. If you haven't done anything else, you can choose Undo from the Edit menu to restore the text or graphic image to its previous condition.

Once you choose Undo, its name on the Edit menu changes to Redo so that you can undo what was undone.

Not all applications include Undo.

**NOTE**

The undo feature has a couple of limitations you should know about:

• Only basic editing actions can be undone. Complex operations, such as style sheet changes in GeoWrite, cannot be undone. You can use the Backup function on the File menu to save a backup copy of your document before you make a major change.

• If you cut something to the clipboard and then choose Undo, the original item is placed back in the document, but the previous contents of the clipboard are not restored. This is because the undo function only affects text and graphics in the current document; it does not affect the contents of the clipboard. If you want to preserve the contents of the clipboard, you can paste them into the Scrapbook. For more information on using the Scrapbook, see Chapter 7 in *The GEOS Environment & Accessories*.

**Using Shortcut Keys for Editing**

As your proficiency increases, you may find you want to use edit functions without lifting your hands from the keyboard. You can use the following shortcut keys to edit:

<table>
<thead>
<tr>
<th>EDIT FEATURE</th>
<th>KEY SEQUENCE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Shift+Delete</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+Insert</td>
</tr>
</tbody>
</table>
You can use the same techniques to enter text and change its characteristics in every Ensemble application. Depending on the user level you are in, you can set the text characteristics from the menus or by clicking tools on the Tool Bars.

Text formatting is available in different applications at different user levels.

**NOTE**
In the following descriptions of formatting text, some options are not available at the same user levels in every application.

**Using Fonts**

A *font* is a typeface, the design of the individual alphabetic and numeric characters. Some fonts, like URW Sans are very plain, while others are ornate, like Sather Gothic. The fonts available in the Ensemble applications are as follows:

- Cooperstown
- Cranbrook
- Sather Gothic
- Shattuck Avenue
- Superb
- URW Mono
- URW Roman
- URW Sans
- URW SymbolPS

The URW Mono font is most like a typewriter font. It’s *monospaced*; every character uses the same amount of space. The other fonts are *proportionally spaced*; the space taken by a character is relative to the character’s width. In other words, an “i” uses less space than a “w.”
To change the font using the Style Tool Bar (Various Levels)

1. Select the text you want to change.
2. Click the fonts drop-down list button on the Style Tool Bar. (The fonts drop-down list button has the name of the currently selected font on it.) A drop-down list appears:

```
URW Roman
   □ Cooperstoun
   □ Cranbrook
   □ Sather Gothic
   □ Shattuck Avenue
   □ Superb
   □ URW Mono
   □ URW Roman
   □ URW Sans
   □ URW SymbolPS
```

3. Choose the font you want. The highlighted text appears in the font you selected.

To change the font using a menu (Various Levels)

1. Select the text you want to change.
2. Depending on the application you are using, do the following:
   - In GeoWrite, choose Fonts from the Character menu.
   - In GeoDraw, choose Fonts from the Text menu.
   - In GeoCalc, choose Fonts from the Properties menu.
   - In GeoFile, choose Fonts from the Properties menu.

   The Fonts submenu appears:

```
Character
   □ Fonts
   □ Sizes
   □ Styles
   □ Text Color...
   □ Text Background Color...
   □ Character Attributes...
```

3. Choose the font you want.
4. Click Apply. The selected text appears in the font you specify.
To view a font (Various Levels)

If you want to see how a font looks, you can use the Font View option. If you like the design of the font, you can apply it to the selected text.

1. Select the text you want to change.
2. Depending on the application you are using, do the following:
   • In GeoWrite, choose Fonts from the Character menu.
   • In GeoDraw, choose Fonts from the Text menu.
   • In GeoCalc, choose Fonts from the Properties menu.
   • In GeoFile, choose Fonts from the Properties menu.
   The Fonts submenu appears.
3. Choose Font Viewer from the Fonts submenu. The following dialog box appears:

   ![Font Viewer dialog box]

4. Select the font you want to see. The font is displayed at the bottom of the font viewer dialog box.
5. If you want to change the selection to the font you specified, click Apply. The font is applied and the dialog box remains on the screen.
6. Click Close to close the dialog box.

Changing the Text Size

Text size is usually measured in points, a measurement used in the printing industry. A point is approximately 1/72 of an inch. Therefore, 72 point text is one inch tall, and 10 point text is 1/7 of an inch tall. Most books and magazines are written with 10 or 12 point text.
SETTING THE TEXT SIZE
You can choose the size of the characters in your document from any of the following point sizes: 9, 10, 12, 14, 18, 24, 36, 54, 72, larger, smaller, and custom size.

To change the text size from the Style Tool Bar (Various Levels)
1. Select the text you want to change.
2. Click the Text Size drop-down list button. (The text size button has the current text size on it.) A drop-down list appears:

![Text Size Drop-Down List]

3. Choose the text size you want. The highlighted text appears in the size you select.

To change the text size (Various Levels)
1. Select the text you want to change.
2. Depending on the application you are using, do the following:
   • In GeoWrite, choose Sizes from the Character menu.
   • In GeoDraw, choose Sizes from the Text menu.
   • In GeoCalc, choose Sizes from the Properties menu.
   • In GeoFile, choose Sizes from the Properties menu.
The Sizes submenu appears:

![Sizes Submenu](image)

3. Choose the size you want from the list. All highlighted text appears in the size you selected.

**SETTING A CUSTOM SIZE**

If you want a text size that is not one of those listed, you can create a custom size.

To change the text to a custom size (Various Levels)

1. Select the text you want to change.
2. Depending on the application you are using, do the following:
   - In GeoWrite, choose Sizes from the Character menu.
   - In GeoDraw, choose Sizes from the Text menu.
   - In GeoCalc, choose Sizes from the Properties menu.
   - In GeoFile, choose Sizes from the Properties menu.
   The Sizes submenu appears.
3. Choose Custom from the Sizes menu. A dialog box appears:

![Custom Size Dialog Box](image)

4. Change the custom point size by typing a different size or by clicking the arrows to adjust the selected point size. If you don’t want to use points as units, you can type different units, as follows:
   - **Inches**. Type the inches mark (") or type “in”.

• **Picas.** Type “pi”.
• **Points.** Type “pt”.
• **Centimeters.** Type “cm”.
• **Millimeters.** Type “mm”.
• **Ciceros.** Type “ci”.
• **European points.** Type “ep”.

5. Click **Apply** to apply your changes to the selected text.
6. Click **Close** to close the dialog box.

**USING THE SMALLER OR LARGER CHOICES**
You can quickly make text the next larger or smaller pre-defined size.

*To make the text larger or smaller (Various Levels)*

1. Select the text you want to resize.
2. Click the Larger or Smaller button on the Style Tool Bar.
   
   Depending on the application you are using, do the following:
   • In GeoWrite, choose Sizes from the Character menu.
   • In GeoDraw, choose Sizes from the Text menu.
   • In GeoCalc, choose Sizes from the Properties menu.
   • In GeoFile, choose Sizes from the Properties menu.
   
   The Sizes submenu appears.
3. Choose either Larger or Smaller from the Sizes submenu. The text appears in the next smaller or next larger pre-defined size.

**Changing the Text Style**
Text can appear plain, as the text in this sentence, or you can change text to any of the following styles:

• Plain
• **Bold**
• **Italic**
• **Underline**
• **Strike-Thru**
• **Superscript**
• **Subscript**
To change the text style from the Style Tool Bar (Various Levels)

1. Select the text you want to change.
2. Click the Text Style you want to use. The highlighted text appears in the style you select.

To change the text style (Level 1 for GeoWrite and GeoCalc)

1. Select the text that you want to change.
2. Depending on the application you are using, do the following:
   • In GeoWrite, choose the style you want from the Styles menu.
   • In GeoCalc, choose the style you want from the Properties menu.

The highlighted text appears in the new style.

To change the text style (Levels 2–4)

1. Select the text you want to change.
2. Depending on the application you are using, do the following:
   • In GeoWrite, choose Styles from the Character menu.
   • In GeoDraw, choose Styles from the Text menu.
   • In GeoCalc, choose Styles from the Properties menu.
   • In GeoFile, in Design Mode, choose Styles from the Properties menu.

The Styles submenu appears:

3. Choose one of the styles from the list. All highlighted text appears in the style you selected.
To make a selection plain text (Various Levels)

If you have used a variety of text styles in a block of text, you can convert it all to plain text easily.

1. Select the block of text you want to change.

2. Click the Plain Text Tool on the Style Tool Bar.

or

Depending on the application you are using, do the following

- In GeoWrite, choose Styles from the Character menu.
- In GeoDraw, choose Styles from the Text menu.
- In GeoCalc, choose Styles from the Properties menu.
- In GeoFile, in Design Mode, choose Styles from the Properties menu.

The Styles submenu appears.

3. Choose Plain Text from the Styles submenu. The selection reverts to plain text.

Changing the Text Justification

The alignment or \textit{justification} of text determines where the text lines up along a margin. For example, when text is left-aligned, the rows of text line up along the left margin (excluding specified indentation) and the right ends of the lines are ragged. When text is full-aligned, both the right and left sides of the text line up evenly along the left and right margins. See the illustration below for examples of the available alignments.
To specify text justification from the Style Tool Bar (Various Levels)

1. Select the text or move the insertion point into the paragraph, GeoCalc cell, or GeoFile field you want to align.
2. Click the justification button you want on the Style Tool Bar. The selected paragraph aligns as indicated.

<table>
<thead>
<tr>
<th>Left alignment</th>
<th>Centered alignment</th>
<th>Right alignment</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To specify text justification from a menu (Level 1 in GeoWrite, GeoCalc)

1. Select the text or move the insertion point into the paragraph you want to align.
2. Depending on the application you are using, do the following:
   • In GeoWrite, choose the type of justification from the Paragraph menu.
   • In GeoCalc, choose the type of justification from the Properties menu.

The selection aligns as indicated.

To specify text justification from a menu (Levels 2–4)

1. Select the text or move the insertion point into the paragraph you want to align.
2. Depending on the application you are using, do the following:
   • In GeoWrite, choose Justification from the Paragraph menu.
   • In GeoDraw, choose Paragraph from the Text menu, then choose Justification from the Paragraph submenu.
   • In GeoCalc, choose Justification from the Properties menu. In GeoCalc, Full Justification applies to text on the drawing layer, and General justification applies to a spreadsheet cell. You don’t have to worry about which you are in. GeoCalc can tell what you want from the selection you make.
   • In GeoFile, choose Justification from the Properties menu.

The justification menu appears.

3. Choose the type of justification you want. The selected text aligns accordingly.
USING COLOR AND GRAPHICS

GeoDraw is the primary graphics application. However, you can create and edit graphics in any of the productivity tools because they all have most of GeoDraw's tools and features built-in. For instance, in Level 3 and Level 4 of GeoWrite, GeoCalc, and GeoFile you will find a Graphics menu where all of the applicable graphics functions appear for that application. The various submenus on the Graphics menu correspond directly to menus of the same name on the GeoDraw menu bar.
Since all of the graphics functions are based upon those in GeoDraw, these topics are covered in the documentation for GeoDraw. Chapters 8 through 11, which describe the GeoDraw application, provide the information you need for using the color palettes, graphics tools, and menu choices in your documents.

USING STYLE SHEETS

Style sheets are common to both GeoWrite and GeoDraw. In GeoWrite, the styles define different paragraph types, including the font, point size, text style, margins, and indentations. See “Using Text Style Sheets” in Chapter 5 for more information about using paragraph styles in GeoWrite.
In GeoDraw, the styles describe attributes of drawing objects, such as line color, pattern and width, and fill color and pattern. See “Using Graphic Style Sheets” in Chapter 11 for more information about using graphic styles in GeoDraw.
Annotations are special text and graphic objects, such as instructions that appear in a template, which appear on your screen but normally do not print. For example, an envelope template might show the outline of an envelope so that you can see the placement of the addresses. By using annotations, the envelope diagram can be shown on screen without affecting the printout. You can turn these annotations on and off, as you wish.

Normally, annotations are set to appear on screen, but not to print. By choosing from the Annotations submenu on the Options menu, you can change how annotations behave, such as whether they appear on screen and whether or not they print. You can even delete them altogether.

Any changes you make to the annotations settings are saved as part of the document so that you can make your preferred settings part of a template.

To use annotations (Levels 3–4)

1. Open a document that has annotations, such as a template you want to use.
2. Select a drawing tool, such as the rectangle tool. The graphics layer of the document becomes active.
3. Choose Annotation from the Options menu. A submenu appears.
4. Choose the option you want from the Annotations submenu:

   - Draw Annotations. When this option is checked, all annotation objects can be seen on screen. This option is normally checked. Deselect this option to turn off the display of annotations.
   - Print Annotations. When this is checked, all annotation objects will appear on your document when you print it. Normally this option is unchecked so that annotations do not print.
   - Delete Annotations. Choose this to delete all of the annotations from the document.
   - Make Annotations Selectable/Editable. Makes the annotations selectable so that you can edit them.
Make Annotations Unselectable/Uneditable. Makes the annotations unselectable so that they cannot be edited.

4. Use the document as you need.

**TYPING SPECIAL CHARACTERS**

There are many special characters and typographical symbols you can type which don't appear on your keyboard. This section discusses the most common of these.

**Smart Quotes**

*Typographical quotes* are “curly” single and double quotation marks, apostrophes, and commas. You may want to use these in your writing to make your documents look more professional. You can type these characters using the *smart quotes* feature of Ensemble to automatically convert quote marks you type into curly quotes. When smart quotes are on, as they normally are, every time you press the quote key, the application looks at the surrounding characters and tries to determine whether an open quote (" ) or a close quote (") is appropriate and it enters the special character for you. Smart quotes apply when you type single or double quotation marks, or apostrophes. You can, however, turn smart quotes off and on. If you turn them off, quotation marks always appear straight, like those used to indicate inches (3") or feet (3').

*To turn off smart quotes (All Levels)*

If you are working with an application that supports smart quotes and you want to type a straight quote (to indicate measurements, for instance), you can disable the smart quotes feature.

- To turn off smart quotes, hold down the Ctrl key and press the quote key (" ). Now when you type single or double quotation marks, or apostrophes, they will appear as straight quotes.

When smart quotes are off, you can still type typographical curly quotes by pressing Ctrl+Alt+[ for an open quote and Shift+Ctrl+Alt+] for a close quote.
NOTE

It is possible to turn off the smart quotes feature entirely using Preferences. For more information see Chapter 12 in *The GEOS Environment & Accessories*.

*To turn smart quotes on again (All Levels)*

- To turn smart quotes on again, hold down the Ctrl key and press the quote (" ) key. The next time you type any of these quote marks, they will appear as curly quotes.

**Using Other Special Characters**

You can use special characters such as a bullet (•) and em dash (—) by typing special key sequences. You can also type foreign accents such as à or é.

*To type an em dash (—) (All Levels)*

- Hold down the Shift, Ctrl, and Alt keys and type a hyphen. (-)

*To type a bullet (• ) (All Levels)*

- Hold down the Ctrl and Alt keys and type an 8.

*To type an à (All Levels)*

- Hold down the Ctrl and Alt keys and type a.

*To type an é (All Levels)*

- Hold down the Ctrl and Alt keys and type e twice.

For a complete list of the key sequences you can use to type special characters, see Appendix B.
Working With Documents  This chapter describes additional features on the File menu of applications that help you work with documents.
This chapter discusses the following common functions:

- Backing up and restoring documents
- Managing documents
- Managing templates
- Importing and exporting documents
- Opening multiple documents

This chapter assumes you are familiar with the information covered in Chapter 1, which provides an overview of the basic skills you need for working with documents, such as creating and opening documents and using standard file selectors.

BACKING UP AND RESTORING DOCUMENTS

LEVELS 2-4

To back up a document means to make a quick copy of the document in its current state. When you restore a document, you replace the current document with its most recent backup.

You can make backup copies of documents by hand, using the copy function in GeoManager, for instance, but it is much easier to use the backup features found on the Backup submenu of the File menu.

Backing up is like freezing a copy of a document in time. When you save a document, any changes you've made are saved to disk, but the changes are only saved to the current version, not to the backup copy. This way, if you restore from a backup copy, the document reverts to exactly as it was when you backed it up, even if you have saved your document many times between now and when you last backed it up.

BACKING UP A DOCUMENT

Backing up is particularly useful if you are about to make a significant change to a document. It lets you keep a copy of the current version to protect you if you regret the change. The backup feature makes a copy of the current version of a document and keeps it in a special location on the network server. Each backup you save replaces your most recent backup.
To back up a document (Levels 2–4)

Each time you select Make Backup, you create a backup of the current version of the document, which overwrites the previous backup.

1. Choose Backup from the File menu. The Backup submenu appears.
2. Choose Make Backup. A message appears, indicating a copy is being made. This message disappears as soon as the backup is completed.

RESTORING FROM A BACKUP

Restore from Backup recovers the most recent backup copy of a document created by using Backup. This choice is only available if you have created a backup by choosing Backup from the File menu. When you restore from a backup, the previously backed up version of the document overwrites the current version of the document. Use Restore from Backup if you want to revert to the previously backed up version.

When you restore a backup, it replaces your current document, so be sure this is what you want to do.

To restore from a backup (Levels 2–4)

1. If it's not already open, open the document you want to restore to its most recently backed up version.
2. Choose Backup from the File menu. The Backup submenu appears.
3. Choose Restore From Backup. A confirmation message appears.
4. Click Yes. The most recent backup appears in the document window.

NOTE

You can may still be able to recover a backup even if all original copies of the document have been destroyed. Backup copies of your documents are stored in the GEOWORKS\USERDATA\BACKUP folder.

MANAGING DOCUMENTS

LEVELS 2–4

Once you begin accumulating documents, you may find that you need to do a little housekeeping. You may want to change the
name of a document, or you may want to set your own specifications for a document. This section describes how to manage your documents using various choices found on the Other submenu of the File menu. The Other submenu lets you do the following:

- Copy a document
- Export a document
- Discard changes in a document
- Rename a document
- Edit document notes
- Set the document password
- Set the document type
- Change settings in the empty document

Export is briefly described in "Importing and Exporting Documents" in this chapter and in detail in the chapters of applications with exporting capabilities.

**Using Copy To**

When you use Copy To, you create a copy of the current version of a document and give it a new name. The document with the new name is saved to disk and you are left editing the original. This is in contrast to Save As, which saves all of your changes to the document with a new name and closes the original document without saving any changes to it. The following table summarizes the difference between Copy To and Save As:

<table>
<thead>
<tr>
<th>FEATURE</th>
<th>COPY TO</th>
<th>SAVE AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Saves changes to a document using a new name.</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Reverts the original document to its last saved version.</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Leaves you editing the copy.</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Leaves you editing the original.</td>
<td>yes</td>
<td>no</td>
</tr>
</tbody>
</table>
Copy To can be used for several purposes:

- If you are writing a report and want to keep progressive copies so that you can revert to an earlier one if you need to, use Copy To. You could save the report at 8 am and name it REPORT 8 AM. Then you could use Copy To to save a copy of the report every two hours, naming the first copy REPORT 10 AM, the second one REPORT 12 PM, and so on. Using the Copy To function, you continue editing the original version whenever you make a copy. But you also have the option of reverting to an earlier version if you want to.

- If you are drawing a greeting card that you want to personalize, use Copy To. For example, you could make one standard card, personalize it for Ellen, and then save it. A copy of Ellen’s card is saved and you continue to work on it. Personalize the original card for Ann and then use Copy To. This saves Ann’s card. You can continue this process indefinitely, until you have personalized all your cards without fear of losing any of them.

To copy a document using Copy To (Levels 2-4)

When you copy a document, the standard file selector appears. The following procedure explains the easiest way to use the standard file selector controls to save a copy of a document in your DOCUMENT folder. If you want to copy the document somewhere else, see Chapter 1.

1. Choose Other from the File menu. The Other submenu appears.
2. Choose Copy To. The copy file selector appears with the name of the document in the New Name text entry box.

The illustration below shows a typical example of a Copy To file selector:
3. Make sure the DOCUMENT folder is highlighted. If it isn’t, click the Go to Document button. This copies the document to your DOCUMENT folder.

4. Type the name you want to use for the copy. You can use **Backspace** or **Delete** to edit the name. The new name appears in the text entry box.

5. Click Copy To to make a copy of the document using its new name. The document with the new name is saved and closed, and the document with the original name remains in the document window.

**Discarding Changes**

Occasionally, you may make changes to your document that you do not like. Use Discard Changes on the File menu to undo changes you wish you hadn’t made. Discard changes restores a document to its last saved version, eliminating any changes you’ve made since you last saved it.

You can put this feature to good work when you want to experiment. For example, if you want to rearrange your address book, you can save it before you begin the experiment, then if you don’t like what you’ve done to the information, you can use Discard Changes to go back to the original.

**To discard changes (Levels 2-4)**

1. Choose Other from the File menu. The Other submenu appears.

2. Choose Discard Changes. A dialog box appears asking you if you’re sure you want to discard all the changes you have made to the document since you last saved it.

3. Click Yes, and the last saved version appears in the window. All changes since then are erased permanently.

**Renaming a Document**

When you rename a document, you change its name. You may want to rename a document so that its name more closely identifies its contents or purpose. You may also want to rename a document if you want to use its original name for another document.

If the Rename choice is dimmed, either you have not yet saved the document or it is a read-only document. For more information about read-only documents, see “Setting the Document Type” in this chapter.
To rename a document (Levels 2-4)

1. Choose Other from the File menu. The Other submenu appears.

2. Choose Rename Document. The Rename Document dialog box appears with the document's current name in the New Name text entry box.

3. Type the new document name. You can use Backspace or Delete to edit the name. The new name appears in the New Name text entry box.

4. Click the Rename button. The dialog box closes and the new name appears in the title bar.

Editing Document Notes

You can add document notes to any GEOS document. Document notes consist of information you might want to record about your document that you think is important to remember. For example, you can use document notes to keep a revision history of a document. If someone else modifies the document, they can read your notes and add their own.

Notes accompany a document, but they are not an integral part of the body of the document. You can see a document's notes in the file selector box whenever you open an existing document. You cannot add document notes to DOS data files, including DOS text files edited with Text File Editor.

To create, view, or edit document notes (Levels 2-4)

1. Choose Other from the File menu. The Other submenu appears.
2. Choose Edit Document Notes. A dialog box appears:

You can enter up to 100 characters in a note.

3. Type your new document notes or edit the existing ones; and then click Set Document Notes.

or

If you are just viewing the document notes, click Cancel when you are done.

The dialog box closes and you return to the document.

Setting and Removing a Document Password

A document may contain personal information that you want to prevent others from viewing by giving it a password. For example, you can keep your GeoDex address book private by setting a password. If you give a document a password, anyone who tries to open the document must first enter its password. A document password can contain up to 32 characters.

To add or change a document password (Levels 3-4)

1. Choose Other from the File menu. The Other submenu appears.
2. Choose Set Document Password. A dialog box appears:

Make sure you remember the document's password. You cannot open the document without it.

3. Type the password you want to use for the document. The password you type is case-sensitive and space characters and punctuation count. For example, the password “Legion Pier” would be different from the password “legion pier”, as would the password “Legion-Pier!”
4. Click Change Password. A confirmation message appears.
5. Click Yes to confirm that you want to add a password to protect the document. Once the password is added, the document cannot be opened without entering its password. The dialog box closes and you return to the document.

The next time you open the document, you will be asked to enter the password. If you do not enter the password correctly, you cannot open the document.

To remove a password (Levels 3-4)

1. Open a password-protected document. You must use the correct password to open the document.
2. Choose Other from the File menu. The Other submenu appears.
3. Choose Set Document Password. A dialog box appears, with no password shown.
4. Without making any change to the blank Password box, click Change Password. The password is removed from the document. The dialog box closes and you return to the document. From now on, you do not have to enter a password to open this document.

Default Settings for Empty Documents

When you open a new document in any application, an empty document appears. This “empty” document contains Ensemble-defined settings, such as the margin width in GeoWrite or the font in GeoCalc. These settings are called the default settings. The following list includes some of the more common default document settings:

- Page size
- Margin size
- Font
- Text style
- Text size
- Tab settings
- Number format (GeoCalc)
- Column Width (GeoCalc)
- Field size (GeoFile)

If you commonly use different settings in your document, such as a different type size, you may want to customize the settings so
that every time you open the document, you don’t have to change them.

To change the default settings in an empty document (Level 4)

1. Create a new document and set the document characteristics as you want.
2. Choose Other from the File menu. A submenu appears.
3. Choose Empty Document from the Other submenu. A submenu appears.
5. Click Set Empty Document. Subsequent new documents will have the settings you saved, as well as any information in the document when you saved it.

NOTE
Changing and saving the empty document does not change existing documents. If you want to change the settings of existing documents, you must do so individually.

To revert to the original default settings (Level 4)

1. In any open document, choose Other from the File menu. A submenu appears.
2. Choose Empty Document from the Other submenu. A submenu appears.
4. Click Set Empty Document. Subsequent new documents will have the original default document settings.

Setting the Document Type

Document type refers to the type of access that you give a document. For example, you can specify whether a document can be edited or is read-only. A read-only document is a one that can be viewed but not edited. Document types include the following:

Normal. The document can be viewed and edited. The For Editing option in the Open file selector is checked by default. Normal documents are, therefore, routinely opened for editing. You can open a Normal document read-only by deselecting the For Editing choice in the Open file selector.
Read-Only. The document can be viewed but not edited. The For Editing option in the Open file selector is dimmed and cannot be selected. You can set a document read-only when you don’t want yourself or others to accidentally edit it. For more information on file attributes, see Chapter 3 of *The GEOS Environment & Accessories.*

Template. The document will be used as a template. When you open a template document, you don’t normally edit the original template. Instead, you are editing an untitled copy of the template which gets created automatically when you open the template. The For Editing option in the file selector is unchecked by default, which indicates you do not want to edit the original. If you select the For editing option, you can edit the original.

Read-Only Template. A read-only template behaves exactly as a regular template, except that the For Editing option always dimmed, which means you cannot edit the original template. For more information on file attributes, see Chapter 3 of *The GEOS Environment & Accessories.*

Public. This option is useful for documents that are shared over a network. The document can be viewed and edited. However, a public document is not normally opened for editing because the For Editing option in the Open file selector is unchecked by default. If you want to edit a public document, you must open the document from within the application by choosing New/Open from the File menu and then clicking the Open button. After selecting the document in the Open file selector, you must select the For Editing option if you want to edit the document. Setting the type of a document to Public is useful, for instance, if you want to place a copy of a document on a network disk for others to view, but you want to minimize the chances of anybody editing it accidentally. A public document also has the advantage of allowing one person to open it for editing while others are viewing it.

To change a document type (Level 4)

1. Choose Other from the File menu. The Other submenu appears.
2. Choose Set Document Type. A dialog box appears:

![Set Document Type dialog box]

3. Select the radio button that describes the document type you want to use for this document.
4. Click Change Type.

If you select Normal, Read-Only, or Public, the document is immediately changed to the document type you selected.

or

If you select Template or Read-Only Template, you are asked if you want to move this template to the template folder. Click Move Template since it's a good idea to keep all of your templates for an application in the same folder. After you answer this question, the document is changed to the document type you selected.

The dialog box closes and you return to the document.

To use the For Editing option in the Open or Template dialog box (Level 4)

In Level 4 of an application, when you select a document or template to open, a For Editing option appears below the file list in the file selector dialog box. The status of the For Editing option changes depending on the type of document selected.

1. In the folders and files list, select the name of a document. The For Editing option becomes checked or unchecked depending on the type of document you selected.
2. Click to change the For Editing option if you want. When checked, you can edit the original document. When unchecked, any changes you make will not be saved to the original document, but must be saved to a document with a different name. In the case of a template, if the For Editing option is checked, you will be editing the original template. If the for
editing option is unchecked, you will be editing a new Untitled
document that is created from the template.

For more information using the For Editing option with the Open
feature, see “Opening an Existing Document” in Chapter 1. For
more information on using the For Editing option with the
Template feature, see “Modifying a Template” in this chapter.

MANAGING TEMPLATES

All four of the productivity tools include templates, ready-made
documents that can save you time because all the layout work is
done for you. Templates help you create new documents faster
and easier and also help maintain a consistent look among
documents. In addition to the templates provided with Ensemble
applications, you can also create a library of templates of your
own design.

Application templates are saved in a folder named Templates:
GeoWrite Templates, GeoCalc Templates, and so on. A template
contains the text, graphics, formatting, and special layouts
common to documents of a particular type. For example, if you
plan to write a letter, you can open a letter template in the
GeoWrite Templates folder.

The Ensemble productivity tools have a standard set of templates
for the most common kinds of documents for the particular
application. You can use these built-in templates to create your
own documents and you can use them as the basis for your own
templates, but you cannot modify them.

Using Templates

When you open a template, you can use it as is, or you can
change it to suit your needs. When you choose a template from
the New/Open dialog box, the application creates a new
document containing the information in the template you
selected. All you do is fill in the information that's missing or
change the information of the place holder text. Place holders are
text that define the type of entry in a location, such as “ZIP
CODE” that you later replace with the actual information you
want.

Changes you make to the new document don't affect the original
template.
To use a template (All Levels)

1. Start the application you want to use.
   or
   Choose New/Open from the File menu. The New/Open dialog box appears:

![New/Open dialog box]

2. Click Template. A dialog box appears listing the available templates and folders, though not necessarily with the templates shown here:

![Select Template Document to Use]

3. Select the template you want to use, scrolling the list if necessary. A description of the template, if available, appears in the Notes box.

4. Click Use Template. The application creates a copy of the template as a new, untitled document.

**NOTE**
The original template document is unchanged. Changes you make to the new document don’t affect the template.
Creating Your Own Template

You can create and maintain Ensemble templates or you can design your own. To create your own template, you can begin with an empty document or you can use an existing document and save it as a template.

To create a template (Level 4)

1. Open a new or existing document in the application you want to use.

2. Specify the settings you want to use. For example, in GeoWrite, you might want to define the following:
   - Page size
   - Margins
   - Text specifications, such as font, size and style

3. Add the text and text place holders (such as “City”, “State”, and “Zip Code”).

4. Add any graphics you want to include (such as a logo).

5. Choose Other from the File menu. A submenu appears.

6. Choose Save As Template from the Other submenu. The following dialog box appears:

   ![Save Document As a Template dialog box]

7. If necessary, select the folder where you want to save the template.

8. Type the name of the template and then click Save.

9. Close the document. If you want to add document notes to the template, you should do so before closing it. See “Editing Document Notes” in this chapter for more information.
Modifying a Template

You can change any template you’ve created so that it meets your particular needs. Sometimes you can modify the same template in different ways to be appropriate for different situations (such as documents for different clients or organizations).

To change a template you’ve created (Level 4)

1. If the New/Open dialog box is not showing, choose New/Open from the File menu.
2. Click Template. A dialog box lists the available template folders or templates.
3. Select the template you want to modify, scrolling the list if necessary. A description of the template, if available, appears in the Notes box. If the For Editing check box is disabled, you cannot change the template because it is either set to Read Only or you don’t have the network permission to modify it.
4. Select the For Editing option in the dialog box and then click Use Template. The template appears in the application window.
5. Edit the template until it appears the way you want.
6. Choose Save from the File menu.
7. Close the document.

To create a new template based on one of the built-in templates (Level 4)

1. If the New/Open dialog box is not showing, choose New/Open from the File menu.
2. Click Template. A dialog box lists the available template folders or templates.
3. Select the template you want to use, scrolling the list if necessary. A description of the template, if available, appears in the Notes box.
4. Click Use Template. The template appears in the document window.
5. Choose Other from the File menu. A submenu appears.
6. Choose Save As Template from the Other submenu. The following dialog box appears:

![Save Document As a Template dialog box]

7. If necessary, select the folder to which you want to save the template.
8. Type the name of the template.
9. Make the changes you want for the new template.
10. Choose Save from the File menu. The new template is saved with the name you specified in Step #7.
11. Close the document.

**Removing a Template**

Template documents are normally stored in GEOWORKS\USERDATA\TEMPLATE. You can delete templates from this folder in the same manner as you delete any other Ensemble document.

**NOTE**

You cannot remove the built-in templates. You can only remove the templates you have created.

**IMPORTING AND EXPORTING DOCUMENTS**

**Levels 2-4**

*Exporting a document does not save it as an Ensemble document.*

You can import and export many Ensemble documents to and from other applications. For example, you can create a database document in GeoFile and export it to use in another database application. You can import another type of word processing file into GeoWrite.

The chapters for each application describe the specific information on exporting documents.
WORKING WITH MULTIPLE DOCUMENTS

ALL LEVELS

The Ensemble productivity tools allow you to have many documents open at once. The names of all open documents are in the Window menu. By opening multiple documents, you can check references in different documents and copy and paste information between them. You can use choices on the Window menu to switch between open full-sized documents and to set the display of the documents to Full-Sized or Overlapped.

You normally display documents full-size. When you have more than one full-sized document open, you can only see the one on top, like seeing only the top page on a stack of reports sitting on your desk. You can switch between documents by choose the name of the document you want to be on top from the Window menu.

You can also display multiple documents in overlap mode. Overlapped documents are stacked so that you can see the upper left corner of the document. You can also choose to display the documents tiled, where the documents are side-by-side. You can resize and move overlapping documents in the application window. Two overlapping document windows might look like the following:
To open multiple documents (All Levels)

1. Open the first document in the usual way.
2. Choose New/Open from the File menu. The New/Open dialog box appears.
3. Open a second document. The second document displays on top of the first.

To switch documents using the Window menu (All Levels)

1. Open the number of documents you want to use. The documents can be displayed as full-sized windows.
2. Choose the document's name from the list of open documents names in the Windows menu. The document you specified appears on the top of the stack (or is highlighted in a tiled display).

To switch documents using Next on the window control menu in overlapping mode (All Levels)

1. Click the window control button on the document window. The window control menu appears.
2. Choose Next from the window control menu. The next document appears on the top of the stack (or is highlighted in a tiled display).

Repeat this step, selecting the next document, until the document you want to work with is on top.

To change the window display mode using the Window menu (All Levels)

1. Open the number of documents you want to use.
2. Choose a display option from the Window menu.

   Overlapping. The documents stack up, showing the upper left corner of each document. Click any part of a document to make it the active document.

   Full-Sized. Each document is displayed at full-size in the document window. Use the Window menu to switch between documents.

The document windows redisplay in the new mode.

To tile documents (All Levels)

1. Open the number of documents you want to use.
2. Choose Tile from the Window menu.
The document windows automatically switch to overlapping and resize so that they all fit into the application window.

*To change from Overlapping to full-sized using the document's maximize button (All Levels)*

- Click the maximize button in the upper-right corner of a document window. All the document windows change to full-sized.

*To change from Overlapping to full-sized using the document's Window Control menu (All Levels)*

1. Click the window control button on the document window. The window control menu appears.
2. Click Maximize. All the document windows change to full-sized.

*To switch between documents by clicking their windows (All Levels)*

To switch between documents by clicking their windows, the documents must be visible; therefore, they must be overlapping or tiled.

- Click somewhere in the document you want. The document you clicked appears on the top of the overlapped stack or is highlighted in a tiled display.
GeoWrite Basics  This chapter describes the Level 1 functions of GeoWrite. You can use every feature of this basic set at all levels of GeoWrite. When you know these basic skills, you can compose memos, letters, and reports with ease using the power of GeoWrite.
Once you’ve mastered the general concepts for word processing described in this chapter, you may want to learn more. To have more control over how your documents look, set the user level to Level 2 and read Chapter 5.

This chapter and the next three are devoted to GeoWrite. This chapter describes the basic features of GeoWrite at Level 1. Chapter 5 describes ways to format text and documents using styles, headers and footers, title pages, and color. Chapter 6 describes how to use templates, sections, graphics, and page layout in a document. Chapter 7 describes different ways to view a document, insert special characters (such as page breaks), use multiple columns, merge data with other applications, and put the finishing touches on a document.

This chapter describes how to do the following:
- Type text into your document.
- Select text using a mouse or the keys on the keyboard.
- Insert, delete, copy, and move text.
- Change the way text looks by indenting paragraphs various ways.
- Create, change, and delete tab stops.
- Change the characteristics, alignment, and spacing of text.
- Use the Style bar.
- Use the Zoom feature.
- Move around in your document.
- Use the tools on the Style Bar.
- Use templates.
- Check the spelling in your document.

In addition, this chapter provides tips for using GeoWrite most effectively.

This chapter assumes you are familiar with Chapter 1 which gives an overview of the skills you need to use any Ensemble application.

**WHAT IS GEOWRITE?**

GeoWrite is a word processor program — it’s much more than a smart typewriter. It lets you put words on a page — and it lets you change them easily and quickly!
When you type, GeoWrite moves the text to accommodate your adding and deleting words (or paragraphs or whole chapters). You can make every document perfect without tedious retyping. With the Find and Replace feature, you can make global changes (changes throughout an entire document) with a few simple keystrokes. For example, you can change every occurrence of the word “problem” to the word “opportunity.”

To accommodate your level of experience, GeoWrite has four user levels. At Level 1, you can use templates for creating documents with a consistent design. At higher levels, you can add illustrations to your writing and include information from other GEOS applications, such as spreadsheet data or specialized lists from GeoFile.

**STARTING GEOWRITE**

**ALL LEVELS**

The GeoWrite icon appears in the WORLD directory and looks like the example at the left.

*To start GeoWrite (All Levels)*

1. Locate the GeoWrite icon and double-click it. The GeoWrite window appears, along with the New/Open dialog box.

2. Click one of the first three buttons to open a template, create a new empty document, or open an existing document. Click the last button to set the user level. For more information about
using the New/Open dialog box, see “Creating and Opening Documents” in Chapter 1. For more information about setting your user level, see “User Levels” in Chapter 1.

If you click Template, New, or Open, a GeoWrite document appears, as shown in the following illustration:

![Illustration of GeoWrite document with text area and indentation markers]

The *ruler* shows you the size of the page and the locations of *margins* and tab settings. You can change these settings by clicking and dragging the symbols on the ruler. When you start a new document, these settings are automatically set for 1-inch margins, giving you a 6-1/2 inch wide text area on an 8-1/2 inch page.

- **Left Indent Marker.** The two-part Left Indent marker enables you to set the *indentation* of the first line and all succeeding lines.

- **Right Indent Marker.** The Right Indent marker allows you to set the right indentation.

- **Tab.** Tab stops appear automatically every 1/2 inch as shown by the tiny T symbols below the inch and 1/2 inch marks on the ruler. You can also add tab stops wherever you need them.

The *text area* is the area inside the margins of GeoWrite. Characters you type appear in this area.
The *insertion point*, the blinking vertical line, indicates where the characters you type appear in the document.

**USER LEVELS IN GEOWRITE**

*ALL LEVELS*

You can make many of the GEOS applications as simple or sophisticated as you want. Typically, the more functions an application has, the more difficult it is to learn. In GEOS, you can start using an application at a simple, basic level. As you gain experience and are comfortable with it, you can add more functions by changing the user level. For more information about changing and saving user levels, see Chapter 1.

When you use GeoWrite for the first time, it opens to Level 1—the simplest of GeoWrite’s four user levels.

The following are descriptions of GeoWrite’s user levels:

- **Level 1** shows you the basics of manipulating text, using the Style Bar, moving around in a document, using templates, and checking your spelling. This chapter describes the features available at Level 1.

- **Level 2** introduces various ways to enhance a document by adding headers, footers, and a title page. You can format text and use color to change the way text looks. This level makes it easy to use styles to give your documents a consistent look. Chapter 5 describes the features available at Level 2.

- **Level 3 and Level 4** introduce advanced techniques for creating documents using graphics, sections, and page layout features. At these levels, you can create your own templates, insert special characters (such as page breaks), and create documents with multiple columns. Other features include merging data from other applications into your GeoWrite document and adding document enhancements such as footnotes, a table of contents, and a bibliography. Chapter 6 and Chapter 7 describe the features available at Levels 3 and 4.

**TYPING TEXT**

*ALL LEVELS*

When you type on the computer keyboard, the words appear in the text area in GeoWrite. As the words reach the end of a line, they automatically wrap down and continue on the next line.
This feature is called word wrap. Word wrap means that you don’t have to press the Enter key (the Return key on a typewriter) to start a new line of text. This keeps the lines and sentences together in the same paragraph. When you are ready to begin a new paragraph, you press the Enter key.

Positioning the Insertion Point

The insertion point is the blinking vertical line that indicates where the characters you type appear on the screen. On a blank page, the insertion point appears at the upper-left corner. While you are typing, the insertion point moves to the right, appearing after the last word. When you need to make changes to something you have already typed, you can move the insertion point anywhere in the text.

You can quickly, and easily move the insertion point using the mouse, though if you prefer, you can use your keyboard keys. For a list of ways to move the text insertion point using your keyboard, see “Keyboard Shortcuts” at the end of this chapter.

To move the insertion point with the mouse (All Levels)

1. Move the mouse pointer to the location in the text where you want to start the insertion.
2. Click the mouse button. The insertion point moves to the new location.

Inserting Text

Once you place the insertion point, anything you type is inserted into the document at that location. If there is text to the right of the insertion point, it is moved over to accommodate the inserted text.

CORRECTING AS YOU TYPE

If you mistype a word and notice it as you are typing, you can press the Backspace key to erase characters to the left of the insertion point. The Delete key erases characters to the right of the insertion point.

STARTING A NEW PARAGRAPH

When you want to start a new paragraph, press the Enter key. The insertion point moves to the left margin of the next line. If you want to split an existing paragraph into two paragraphs,
position the insertion point where you want to split the paragraphs and press the **Enter** key.

**Typing Numbers**

Numbers you type appear in the text area. You can type numbers using the alphanumeric section of the keyboard or using the numeric keypad.

If you are using the numeric keypad, be sure that **Num Lock** is on (the light on the keyboard is lit) so that you can enter numbers rather than move the insertion point.

---

**SELECTING TEXT**

When you want to make changes, for example rewording a sentence or moving a paragraph, first you must select the text you want to change. Selected text appears highlighted. Once the text is selected, you can manipulate it in many ways, including the following kinds of operations:

- Delete the selection.
- Replace the selection.
- Copy, cut, and paste text using the clipboard.
- Change the font (the kind of characters).
- Change the text size (the size of the characters).
- Change the text style (plain, bold, italic, and underline).
- Change the space between lines.
- Change the paragraph alignment.

You can use either the mouse or the keyboard to select text.

**Using a Mouse**

This section provides an overview of using a mouse to select text. For information about about using your keyboard to select text, see “Keyboard Shortcuts” at the end of this chapter. Also see Chapter 2 for more information about selecting text.
To select text with the mouse (All Levels)

1. Move the mouse pointer to the beginning of the word, line, or paragraph you want to select.

2. Press and hold the left mouse button and drag the mouse across the text until what you want is highlighted, then release the mouse button.

or

Click at the beginning of the text, hold down the **Shift** key, and click at the end of the text.

or

Position the pointer and quickly click the appropriate number of times:

<table>
<thead>
<tr>
<th>ACTION</th>
<th>RESULT</th>
</tr>
</thead>
<tbody>
<tr>
<td>2 Clicks</td>
<td>Selects a word, but not the space after the word.</td>
</tr>
<tr>
<td>3 Clicks</td>
<td>Selects a line.</td>
</tr>
<tr>
<td>4 Clicks</td>
<td>Selects a paragraph.</td>
</tr>
<tr>
<td>5 Clicks</td>
<td>Selects the entire document (the same as choosing Select All from the Edit menu).</td>
</tr>
</tbody>
</table>

HINT

You can choose from two selection methods—clicking and dragging. For example, if you want to select several words, you can use either of the following methods:

- Drag from the beginning to the end of the words you want to select. This method requires a little more effort to hit the end of the selection—in this case, the end of the word—accurately.

- The most effective method is to double-click the first word and drag to the end of the words you want to select. This method selects the text word-by-word, making it easier for you to end your selection at the right location. This is a fast way to select word-by-word, line-by-line, and paragraph-by-paragraph.

To extend or reduce the selection (All Levels)

You may want to include more text in a selection after you have already made the selection.

1. While a selection is highlighted, press and hold down the **Shift** key.
2. Click where you want the new selection to end (or begin). You can make a selection larger or smaller, depending on where you click.

**Canceling a Selection**

If you change your mind after making a selection, you can cancel the selection by clicking anywhere in the text area or by pressing one of the arrow keys.

**USING THE STYLE BAR**

The Style bar appears when you open GeoWrite. Its tools allow you to move from page to page of your document and change text characteristics of selections: font, text size, and text style.

![Style bar diagram](image)

Click to see a list of fonts.

Click to see a list of font sizes.

Font size: increase and decrease

Text styles: plain, bold, italic, and underlined

See Appendix D for complete information about the buttons on the Style bar.

*To use a tool on the style bar (All Levels)*

1. If necessary, select the text whose characteristics you want to change.
2. Click the tool button. If the button is a pull-down menu, press the button and drag to select the choice you want. The characteristics change.
EDITING TEXT

ALL LEVELS

Once you have selected text, you can edit it. You can replace it with different text, delete it, move it somewhere else, or make a copy of it.

Replacing Text

The fastest way to replace text is to select it and then type the new entry. For example, you can change the word “vanilla” to “chocolate” with the following method:

To replace text (All Levels)

1. Select the word (vanilla) or words you want to replace.
2. Type the replacement text (chocolate). The original text (vanilla) is erased and the new text (chocolate) takes its place.

Deleting Text

You can delete (or erase) text using one of the following methods:

• Select the text and choose Cut from the Edit menu. Text you cut is placed on the clipboard. Text removed with the other methods does not go on the clipboard.
• Select the text and press the Backspace or Delete key.
• Select the text and choose Delete from the Edit menu.

NOTE

When you double-click a word that you want to delete, the space after the word is not selected. You must press the Backspace key twice (once to delete the word, and again to delete the space) to maintain the proper spacing between the words.

Using Cut, Copy, and Paste

You can easily move text around, as though you cut it out with scissors and pasted it in a new place. You may have done a similar activity to organize typewritten documents. Chapter 2 provides complete information about the Cut, Copy, and Paste choices on the Edit menu and how they use the clipboard.
To move a selection (All Levels)

1. Select the text you want to move.
2. Choose Cut from the Edit menu. The text is removed from your document and placed on the clipboard.
3. Move the insertion point to where you want the text to appear.
4. Choose Paste from the Edit menu. The contents of the clipboard are inserted into the document.

To copy a selection (Level 1)

If you want to leave the text in the original location and also insert it in another place, you can use Copy rather than Cut.

1. Select the text you want to copy.
2. Choose Copy from the Edit menu. The text gets copied to the clipboard, and it remains in your document.
3. Move the insertion point to where you want the text to appear. If you want to copy to a different document, you must close the original document and open the destination document. If you want to paste into a different application, you must close GeoWrite and then open the new application.
4. Choose Paste from the Edit menu. The contents of the clipboard are inserted into the document.

Undo

Sometimes you may delete some text or change the way it looks and immediately decide that it wasn’t what you wanted. If you haven’t done anything else, you can choose Undo from the Edit menu to restore the text to its last condition. Undo undoes the last editing you did.

Once you choose Undo, its name on the Edit menu changes to Redo so that you can abandon changes you’ve made from choosing Undo.

CHANGING HOW TEXT LOOKS

You have many options for creating attractive, easy-to-read text that conveys your ideas visually. You can change the appearance of the characters you use, as well as the alignment and spacing of lines in a paragraph. Indentations and hanging indents allow you to offset text and numbered lists.
Changing Character Attributes

How a character looks on screen and when printed is determined by its font, size, style, and other attributes. You can change the appearance of your document by changing the way text appears. You can apply character attributes in two ways. You can select the text that you want to change, then choose the attribute you want; for more information, see “Selecting Text” in this chapter. Alternatively, you can choose the attributes you want, then type new text; GeoWrite applies the current attribute settings to any text you type.

Fonts

Fonts are different typefaces that define how each character appears on screen and when printed. Each character has a unique design that varies from font to font.

GeoWrite provides the following fonts (you might also have additional fonts installed):

- URW Mono
- URW Roman
- URW Sans
- URW SymbolPS

The URW Mono font is most like a typewriter font. It’s monospaced; every character uses the same amount of space. The other fonts are proportionally spaced; the space taken by a character is relative to the character’s width. In other words, an “i” uses less space than a “w.” The following illustration shows examples of different fonts:

The font you use in a document depends on many factors, including your personal style and the purpose of the text you’re formatting.

To change the font (All Levels)

1. Select the text you want to change.
2. Choose Fonts from the Character menu. A menu of fonts appears:

![Font Menu](image)

3. Optionally, to see more available fonts, choose Font Viewer from the submenu. A dialog box appears:

![Font Viewer](image)

4. Find the font you want, scrolling the list if necessary, and then select it. GeoWrite applies the font you selected to the highlighted text automatically.

*To change the font more quickly (All Levels)*

1. Select the text you want to change.

2. Click the Fonts arrow button on the Style Bar. A drop-down menu of fonts appears:

![Font Menu](image)

3. Select the font you want. The highlighted text appears in the font you selected.
TEXT SIZES

Text size determines how tall and wide a character is. Text size is usually measured in points, a measurement used in the printing industry. A point is approximately 1/72 of an inch. Therefore, 72 point text is one inch tall, and ten point text is one seventh of an inch tall. Most books and magazines are written with 10 or 12 point text.

You can choose the size of the characters in your document from a list of standard point sizes (9 points through 72 points). At Level 2 and above, you can use a custom text size; for more information, see “Setting a Custom Text Size” in Chapter 5.

To change the text size (All Levels)

1. Select the text you want to change.
2. Choose Sizes from the Character menu. A submenu appears:

   ![Character menu screenshot]

   If all the highlighted text is the same size, the current size is identified by a check mark in the Sizes menu. If the highlighted text contains different sizes, none of the point sizes is marked.

3. Select one of the sizes from the list. GeoWrite applies the size you selected to the highlighted text.

To change the text size more quickly (Levels 2-4)

1. Select the text you want to change.
2. Click the Text Size arrow button on the Style Bar. The menu of text sizes (pictured at left) appears.

3. Select the text size you want. The highlighted text appears in the size you selected.

To change the text size incrementally (All Levels)

1. Select the text you want to resize.

2. If you want to use the menu, choose Sizes from the Character menu. A submenu appears.

3. Make the text larger or smaller using one of the following methods:

<table>
<thead>
<tr>
<th>SIZES MENU</th>
<th>KEYBOARD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smaller</td>
<td>Ctrl + 9</td>
</tr>
<tr>
<td>Larger</td>
<td>Ctrl + 0</td>
</tr>
</tbody>
</table>

Alternatively, click the Increase or Decrease Font Size buttons on the Style Bar.

The text appears in the next smaller or next larger predefined size.

TEXT STYLES

You can use text styles to add emphasis to words and phrases in your document. The following styles are available.

- Plain
- **Bold**
- *Italic*
- Underline

To change the style of text (All Levels)

1. Select the text that you want to change.

2. Choose the style you want from the Style menu on the Style bar.

   or

   Choose the style you want from the Style menu. The selected text appears in the new style.

   or
Click one of the text style buttons on the Style Bar.

The selected text appears in the style you selected.

**Using the Ruler**

When you open a new document, the margins are set for a 6-1/2 inch text area and the tab stops are 1/2 inch apart. You can use the ruler to change right and left indentations and to insert different tab stops.

The indentations and tab stops you see on the ruler affect the paragraph containing the insertion point. If you want to change the setting for the whole document, you must first select the document either by choosing Select All from the Edit menu or by clicking quickly five times.

**NOTE**

At Level 2 and above, you have additional options for changing paragraph indentation and setting tab stops. For more information, see "Formatting Paragraphs" in Chapter 5.

At Level 2 and above, you can change headers and footers. However, ruler changes do not affect header and footer text. For more information, see "Using Headers and Footers" in Chapter 5.

**INDENTATIONS**

The text of each paragraph wraps within the indentation setting, which you can change using the Indentation markers on the ruler. At Level 2 and above, you can set indentations with more
precision; for more information, see “Formatting Paragraphs” in Chapter 5.

The Right Indent marker is a single triangle that you can drag to a new location to specify the right edge of the text.

The Left Indent marker includes two triangular markers.
• The upper triangle sets the indentation of the first line of the paragraph.
• The lower triangle sets the indentation for the remaining lines of the paragraph (the hanging indent).

If both of the Left Indent triangles are together, all lines in the paragraph align beneath the markers. If the top triangle is to the right of the bottom triangle, the paragraph indents in the standard way with the first line indented, as shown in the illustration below.

If you want to specify a hanging indent, such as you see below, to create a special indentation for a list with numbers or bullets, move the lower triangle to the right. The upper triangle shows the indentation of the first line in a paragraph, and the lower triangle shows the indentation of all subsequent lines of the paragraph.

To indent the first line of a paragraph (All Levels)

1. Select all of the paragraphs you want to indent. If you want to indent only a single paragraph, simply move the insertion point into that paragraph.

2. Drag the First Indent marker (the upper triangle) the distance you want for the indentation. The existing text or text you type will be indented as specified.
To create a hanging indent (All Levels)

Hanging indents allow you to align the text when you use bullets or numbered lists.

1. Select the paragraphs for which you want a hanging indent, or move the insertion point to where your hanging indent will begin.

2. Drag the Hanging Indent marker (the lower triangle) to where you want the second and subsequent lines to align.

Tab Stops

Tab stops are the locations where the insertion point stops when you press the Tab key. Automatic tab stops are placed every 1/2 inch, and you can add your own by clicking on the ruler.

At Level 2 and above, you can set tab stops with more precision and additional options, such as right aligned tabs, decimal tabs, custom positions, and tab leaders; for more information, see “Formatting Paragraphs” in Chapter 5.

To create tab stops (All Levels)

1. Select the paragraphs for which you want to create tab stops, or if you want to add a tab stop to a single paragraph, move the insertion point into the paragraph.

2. Click on the ruler. The tab marker appears where you clicked. The automatic tab markers disappear to the left of the new tab marker.

3. If the tab marker isn’t exactly where you want it on the ruler, drag the marker to the location you want.

4. Continue clicking and dragging until you have placed all the tab markers you need.

When you press the Tab key while entering text in the specified paragraphs, the text aligns under the tab marker(s).

To clear a tab stop (All Levels)

Drag the tab marker off the ruler to remove it.
Aligning Text

You can decide how text lines up along a margin: left aligned, centered, right aligned, and full left and right aligned. Alignment is also called justification.

For example, when text is left-aligned, the rows of text line up along the left margin (excluding specified indentation) and the right ends of the lines are ragged.

To change text alignment (All Levels)

1. Select the text or move the insertion point into the paragraph you want to align.
2. Choose Justification from the Paragraph menu. A submenu appears.
3. Select the alignment you want (Left, Center, Right, or Full).

To change text alignment more quickly (All Levels)

1. Select the text or move the insertion point into the paragraph you want to align.
2. Select an alignment using one of the following methods:

<table>
<thead>
<tr>
<th>ALIGNMENT</th>
<th>KEYBOARD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Ctrl L</td>
</tr>
<tr>
<td>Center</td>
<td>Ctrl E</td>
</tr>
<tr>
<td>Right</td>
<td>Ctrl R</td>
</tr>
<tr>
<td>Full</td>
<td>Ctrl J</td>
</tr>
</tbody>
</table>
Alternatively, click one of these buttons on the Style Bar:

- Left
- Center
- Right
- Full

The selected text appears in the alignment you selected.

**Changing Line Spacing**

Line spacing is the spacing between lines in a paragraph, or *leading*.

Line spacing, or leading, is the space between lines in a paragraph.

You may want to add more space between the lines of text in a paragraph. You can choose from the following line spacing:

- **Single.** This is considered normal spacing. There is no extra line space between each row of text.

- **One and a Half.** There is a half line space between each row of text.

- **Double.** There is a whole line space between each row of text.

At Levels 3 and 4, you can specify custom line spacing. For more information, see “Setting Custom Line Spacing” in Chapter 5.
**To specify line spacing (All Levels)**

1. Select the text or move the insertion point into the paragraph you want to change.
2. Choose Line Spacing from the Paragraph menu. A submenu appears.
3. Select one of the following options from the submenu: Single (1), One and a Half, or Double (2). At Levels 3 and 4, you can select Triple (3) line spacing.

**CHECKING YOUR SPELLING**

**Level 1**

Checking your spelling is a good way to find misspelled words and to look for typographical errors. GeoWrite has an electronic dictionary of 100,000 words it checks to look for mistakes. When the spell checker finds a word in your document that is not in the dictionary, it displays it in the Check Spelling dialog box and lets you decide what to do with it.

At Level 2 and above, you can add special words to a User dictionary. For more information, see “Adding Words to the Spelling Dictionary” in Chapter 5.

To check the spelling of a word or block of text (Level 1)

You can check the spelling of a single word, a block of text, or the text in the entire document. To check the entire document, start with step 2.
1. Select the word or block of text you want to check.

2. Click the Check Spelling tool on the Style bar.
   or
   Press F7.
   or
   Choose Check Spelling from the Edit menu.

A dialog box appears. The first misspelled word (or word that is not in the Ensemble dictionary) appears in the Change to: entry box.

3. Type the word correctly and click the Replace button. Use this method if you think the word is misspelled and you don’t think the spell checker will know the word. The spell checker replaces the word with the new spelling and proceeds with its checking.
   or
   Click the Skip button. Use this for special words that appear in your document that do not appear in your user dictionary. The spell checker skips the current word and proceeds with its checking.
   or
   Click the Suggest button. Use this method to have the spell checker look in the dictionary for words that are similar. When the suggestions appear, click the spelling you want to use and then click the Use This Suggestion button. If no suggestion is appropriate, click the Cancel button, then type the word correctly in the Change to: box. The spell checker replaces the word with the new spelling and proceeds with its checking.
   or
   Click the Quit Spell Checking button to stop checking the spelling.
4. When you are finished checking the spelling of the selection or of the entire document, a message window appears. Click OK to return to GeoWrite.

ZOOMING

ALL LEVELS

The Zoom In and Zoom Out choices on the View menu don’t change how your document is printed. They change how the document appears on the screen. Zooming is useful if you are using a small type size and have trouble reading it at normal size. Zooming out is good for seeing how the whole page looks.

To zoom a document (Level 1)

- Choose Zoom In from the View menu to make the document appear larger.
- or
- Choose Zoom Out from the View menu to make the document appear smaller.

NOTE

At Levels 3 and 4, the Function bar contains tools for zooming.

MOVING AROUND IN YOUR DOCUMENT

ALL LEVELS

As your document gets large enough that you cannot see all of it on the screen, you will have to move through it in various ways to make changes. Here are some methods you can use to display other parts of the document:

- **Scrolling.** If you want to look at different areas of your document, use the scroll bars. Scrolling does not move the insertion point. See “Application and Document Windows” in Chapter 2 for more information about scrolling.

- **Leafing Through Pages.** The Next Page and Previous Page choices on the View menu move the document forward and back one page at a time.

- **Go to Page.** You can go directly to a different page in a long document.
To go to the next page in a document (All Levels)

- Choose Next Page from the View menu.
  
or
  Click the Next Page button on the Style Bar.

To go to the previous page (All Levels)

- Choose Previous Page from the View menu.
  
or
  Click the Previous Page button on the Style Bar.

To go to a specific page (All Levels)

1. Choose Go to Page from the View menu. A dialog box appears:

2. Enter the page number you want.

3. Click the Go To button.
A template is a special document that you use as a model to create similar documents. It contains the text, graphics, formatting, and special layouts common to all documents of a particular type. For example, a letter template might contain the following elements:

GeoWrite provides a default template, the “empty” document, that contains standard settings for a basic document. To create a document, you use either a specific template or the empty document. For more information about the empty document, see “Managing Templates” in Chapter 3.

Templates make it faster and easier to create new documents, retaining the text, formatting, and layout you use most often. Templates also help you keep a consistent look among documents.

You can use these templates as is, or you can change them to fit your needs. You can also create your own library of templates for all sorts of uses! For more information about creating and changing templates, see “Managing Templates” in Chapter 3.

When you use a template to create a new document, GeoWrite copies all the information in the template to the new document. Thereafter, all you do is fill in the information that’s missing or
different. Changes you make to the new document don’t affect the source template.

To use a template

1. Start GeoWrite, or choose New/Open from the File menu. The following dialog box appears:

   ![Template button]

2. Choose the Template button. A dialog box appears that lists the available templates.

3. Select the template you want to use, scrolling the list if necessary. A description of the template, if available, appears in the Notes box.

4. Click Use Template to use the highlighted template.

   or

   Point to the name of the template in the list and double-click.

GeoWrite makes a copy of the template and creates a new document called “Write Untitled” followed by a number. This copy contains everything from the template: text, graphics, formatting, styles, special layouts, and so on. When you save the document, you need to give it a name.

You can also use the styles from a template without using its text. For more information, see “Using Style Sheets from Other Documents” in Chapter 5.
TIPS FOR USING A WORD PROCESSOR

ALL LEVELS

Since a word processor is not exactly like a typewriter, if you are a typewriter user, you may have to unlearn some old habits. For example, you shouldn’t use the spacebar to line up text when you are using a word processor. Here are some other word processing tricks that can save you hours of work:

• In order for word wrap to work properly, press the Enter key only at end of paragraph, never at the end of every line. If you press the Enter key at the end of every line, and later change something, the words will not wrap smoothly.

• Use the Tab key rather than Spacebar to align text. If you use the Tab key to set the spacing between text, then you can simply change the measurement of the tab space to change the location of a column.

• Use only one space after a period or colon. When you use a typewriter, you usually use two spaces after a period or colon because of the spacing of the typewriter characters. Since GeoWrite uses proportionally spaced fonts (except URW Mono), you don’t need the extra space after a period.

• Use italic style text rather than underline for book titles. Typewriters don’t have italic font style available so your only option for setting off book titles was to use the underline key. The computer gives you many of the typographical features of typeset printing.

• Since an en dash and em dash are available, use them rather than two hyphens. (See “Typing Special Characters” in Chapter 2.)

• Use bullets for denoting lists such as this list of tips. (See “Typing Special Characters” in Chapter 2.)

KEYBOARD SHORTCUTS

If you are a fast typist, you may not want to take your hands off the keyboard to move the insertion point, or to select text. This section contains tables that show you keystrokes you can use instead of the mouse.
NOTE
If you are using the keys on the numeric keypad to move the insertion point or select text, be sure the Num Lock key is off.

Moving the Text Insertion Point
The table below shows the key combinations for moving the insertion point:

- **Home.** To the beginning of the current line.
- **Ctrl+Home.** To the beginning of the document.
- **End.** To the end of the current line.
- **Ctrl+End.** To the end of document.
- **Arrow Keys (→,←, ↑, and ↓).** One character or line in direction of arrow.
- **Ctrl+←.** To the beginning of the current word, or if it is already there, to the end of the previous word.
- **Ctrl+→.** To the end of the current word, or if it is already there, to the beginning of the next word.
- **Page Up.** Up one screen.
- **Page Down.** Down one screen.
- **Ctrl+Page Up.** Right one screen.
- **Ctrl+Page Down.** Left one screen.

Selecting Text
The table below shows how to select text by using your keyboard:

- **Shift+→ or ←.** Selects one character in the direction of the arrow; reduces or extends the selection a character at a time in the same way.
- **Ctrl+Spacebar.** Selects the current word; the insertion point must be within the word.
- **Ctrl+Shift+→.** Selects to the end of the current word. If already at the end of a word, selects to the beginning of the next word; extends or reduces the selection in the same way.
- **Ctrl+Shift+←.** Selects to the beginning of the current word. If already at the beginning of a word, selects to the end of the
previous word; extends or reduces the selection in the same way.

- **Shift+↑** or ↓. Selects from the insertion point one line in the direction of the arrow; extends or reduces the selection in the same way.

- **Shift+Home**. Selects from the insertion point to the beginning of the line; extends or reduces the selection a line at a time toward the beginning of the document.

- **Shift+End**. Selects from the insertion point to the end of the line; extends or reduces the selection a line at a time toward the end of the document.

- **Ctrl+Shift+↑** or ↓. Selects to the beginning or ending of a paragraph in the direction of the arrow; extends or reduces the selection in the same way.

- **Ctrl+Shift+Home**. Selects from the insertion point to the beginning of the document.

- **Ctrl+Shift+End**. Selects from the insertion point to the end of the document.

- **Ctrl+/**. Selects the entire document (the same as choosing Select All from the Edit menu).
CHAPTER 5

Formatting Documents With GeoWrite

This chapter describes the features that make it quick and easy to create formatted documents. All features described in this chapter are available at Level 2 and above. For an introduction to formatting text, see "Formatting Text" in Chapter 2 and "Changing How Text Looks" in Chapter 4.
This chapter describes how to do the following:

- Format text by changing fonts, text sizes, and character attributes.
- Format paragraphs by changing alignment, spacing, margins, tab stops, borders, and other attributes.
- Use color to emphasize text.
- Find text quickly and, optionally, replacing it with different text.
- Add headers and footers to your document.
- Add a title page to your document.
- Proof your document using advanced spell checking features and an online thesaurus.
- Use and manage styles to save formatting time and to give your documents a consistent look.

CHANGING THE TEXT FORMAT

LEVELS 2-4

This section shows you how to use many of GeoWrite's advanced text and paragraph formatting features. For an introduction of how to format text and paragraphs, see "Changing How Text Looks" in Chapter 4.

Setting a Custom Text Size

At Level 2 and above, you can set a custom size for selected text. You might want to do this if you wanted to use a text size that is not one of the standard sizes GeoWrite provides (such as 6 points). For an introduction to text sizes, see “Changing How Text Looks” in Chapter 4.

To change the text to a custom size (Levels 2-4)

1. Select the text you want to change.
2. Choose Sizes from the Character menu. A submenu appears.
3. Choose Custom Size from the submenu. A dialog box appears:
4. Select the custom point size you want (between 4 and 792, inclusive).

5. Click Apply to apply your changes to the selected text.

6. Click Close to close the dialog box.

**Changing Character Width and Weight**

At Levels 3 and 4, you can fine-tune the appearance of a character by changing its *weight* (thinner or thicker), its *width* (expanded or condensed), and even the distance between characters.

The following example shows what happens when you increase the character width:

![Character Width Example](image)

*To change character attributes (Levels 3-4)*

1. Select the text you want to change.

2. Choose Character Attributes from the Character menu. A dialog box appears:

![Character Attributes Dialog](image)

3. Fill in the dialog box, selecting the attributes you want.

   **Character Weight (%).** Select the weight of the characters. You can choose any weight from 75 to 125.

   **Character Width (%).** Select the width of the characters. You can choose any width from 25 to 200.

   **Character Spacing.** Select the spacing between characters. You can choose any spacing from -150 to 500.

4. Click Apply to apply your changes to the highlighted text.

5. Click Close to close the dialog box.
**Formatting Paragraphs**

You can control paragraph formatting such as alignment, custom line spacing, paragraph spacing, line and column breaks, borders, and hyphenation.

For information about using the ruler to change paragraph alignment, line spacing, margins, indents, and tab stops, see “Using the Ruler” in Chapter 4.

To format a paragraph, you must first select it by highlighting or putting the insertion point in the paragraph you want to format. You do not need to highlight all the text in the paragraph. For more information, see “Selecting Text” in Chapter 4.

**SETTING CUSTOM LINE SPACING**

At Level 2 and above, you can set a custom line spacing for selected text. You might want to do this if you wanted to use a line spacing that is not one of the standard sizes GeoWrite provides. For an introduction, see “Changing Line Spacing” in Chapter 4.

*To change custom line spacing (Levels 3-4)*

1. Select one or more paragraphs you want to change.
2. Choose Line Spacing from the Paragraph menu. A submenu appears.
3. Choose Custom Spacing from the submenu. A dialog box appears:

![Custom Spacing](image)

4. Select Automatic for automatic line spacing or Manual for more precise control.
5. Set the line spacing option you want.
   - **Line Spacing**. If Automatic is selected, select the line spacing you want.
   - **Manual Leading**. If Manual is selected, select the manual line spacing you want.
6. Click Apply to apply your changes to selected paragraphs.
7. Click Close to close the dialog box.
SETTING PARAGRAPH SPACING

*Paragraph spacing* is the space between paragraphs.

*To change paragraph spacing (Levels 3-4)*

1. Select one or more paragraphs you want to change.
2. Choose Paragraph Spacing from the Paragraph menu. A dialog box appears:

![Paragraph Spacing dialog box](image)

3. Fill in the dialog box, selecting the options you want.

   **Space On Top.** Select the space you want to appear before a paragraph.

   **Space On Bottom.** Select the space you want to appear after a paragraph.

4. Click Apply to apply your changes to selected paragraphs.
5. Click Close to close the dialog box.

SETTING INDENTATION

*Indentation* is the distance between the text and the edge of the page margin. The page margin affects every paragraph in a document, while indentation affects individual paragraphs.

You can change the left and right margins of a paragraph, as well as the first line indentation. When you open a document, paragraph margins are initially set to zero (0), which means that they are the same as the page margins.

You can also use the ruler to change paragraph indents. For more information, see “Using the Ruler” in Chapter 4.

You indent a paragraph to set it off from other paragraphs:

   This is an example of a paragraph with indented margins and no indent in the first line. This format makes the paragraph stand out in the flow of text.

A *first line indent* is when the first line starts farther from the left edge of the page than the rest of the paragraph:

   This is an example of a paragraph with an indented first line. Notice that the first line is farther away from the edge of the page than the
rest of the paragraph. This format saves you from typing the Tab key at the start of every new paragraph.

A hanging indent is when the first line starts closer to the left edge of the page than the rest of the paragraph:

This is an example of a paragraph with a hanging indent in the first line. Notice that the first line is farther away from the edge of the page than the rest of the paragraph.

- This format is useful for numbered or bulleted paragraphs.
- This layout makes it easier for the reader to scan paragraphs.

You can also use the ruler to change paragraph margins. For more information, see “Using the Ruler” in Chapter 4.

To set paragraph indents (Levels 2-4)

1. Select one or more paragraphs you want to change.
2. Choose Indents from the Paragraph menu. A dialog box appears:

   ![Indents dialog box]

3. Fill in the dialog box, selecting the options you want.

   **Left Indent of First Line.** Select the distance of the first line from the left margin of the page.

   **Hanging Left Indent.** Select the distance of the text from the left margin of the page.

   **Right Indent.** Select the distance of the text from the page right margin.

4. Click Apply to apply your changes to selected paragraphs.
5. Click Close to close the dialog box.

**SETTING TAB STOPS**

A tab stop is where the insertion point advances to and stops when you press the Tab key. You use tab stops to create aligned columns, such as a table of contents or columns of numbers.
A document initially has automatic tab stops that occur at regular intervals (usually every half inch). You can both redefine this regular distance and you can add tab stops anywhere in between.

You can also set tab stops using the ruler. For more information, see “Using the Ruler” in Chapter 4.

_To create a new tab stop (Levels 2-4)_

1. Select one or more paragraphs you want to change.
2. Choose Tabs from the Paragraph menu. A dialog box appears:

![List of defined tab stops](image)

3. Fill in the dialog box, selecting the options you want.
   - **Tabs List.** Select <<Create New Tab>> in the Tabs list.
   - **Tab Position.** Select the distance of the tab stop from the page margin.
   - **Tab Type.** Select the alignment of the text at the tab stop (Left, Center, Right, or Decimal). For example, you would use a decimal tab to align columns of numbers along the decimal point.
   - **Tab Leader.** Select the character that precedes the tab stop (None, Dot, Line, or Bullet). For example, in a table of contents, each page number might have a tab with a dot leader, as shown here:

     ```
     Chapter 4: Creating Formatted Documents ........................................ 1
     ```

   - **Vertical Line.** This option, when selected, puts a vertical line at the tab position that spans the height of the paragraph. You can set the shading, line width, and line spacing.
For example, if you changed a paragraph in a new draft of a document, you could use a vertical tab line to represent a change bar, as shown here:

```
Sample paragraph with a vertical tab line set to zero (0), along the left margin of the paragraph.
```

4. Click Apply to create the tab stop using the current settings. The tab stop is applied to selected paragraphs.

5. Click Close to close the dialog box.

To change a tab stop (Levels 2-4)

1. Select one or more paragraphs you want to change.
2. Choose Tabs from the Paragraph menu. The Tabs dialog box appears.
3. Select the tab you want to change in the Tabs list.
4. Fill in the rest of the dialog box, selecting the options you want.
5. Click Apply to save your changes to the selected tab stop and to apply them to selected paragraphs.
6. Click Close to close the dialog box.

To delete a tab stop (Levels 2-4)

1. Choose Tabs from the Paragraph menu. The Tabs dialog box appears.
2. Select the tab stop you want to delete in the Tabs list.
3. Click Delete Tab. GeoWrite deletes the tab stop and shifts the text to the next tab stop.

To delete all tab stops (Levels 2-4)

1. Choose Tabs from the Paragraph menu. The Tabs dialog box appears.
2. Click Delete All Tabs. GeoWrite deletes all tab stops, restores the default tab stops for selected paragraphs, and adjusts the text if necessary.

To set the default tab stops (Levels 3-4)

1. Select one or more paragraphs you want to change.
2. Choose Default Tabs from the Paragraph menu. A dialog box appears:

![Default Tabs dialog box]

3. Select a default tab (None, Centimeter, Half Inch, or One Inch).
   
   or
   
   Set a custom default tab.

4. Click Apply to apply your changes to selected paragraphs.

5. Click Close to close the dialog box.

CONTROLLING LINE AND PARAGRAPH BREAKS
You can control whether GeoWrite allows automatic line breaks within words and automatic column breaks within paragraphs. In documents with only one column, column breaks have the same effect as page breaks.

For example, you might want to make sure that a headline appears in the same column as the article to which it belongs. Similarly, you might want to keep an entire paragraph together on the same page rather than have GeoWrite split it in the middle, possibly leaving widows and orphans. A widow occurs when a single line of text is separated from the paragraph it belongs to and is left stranded at the bottom of a page. An orphan occurs when a single line of text is separated from the paragraph it belongs to and is left stranded at the top of a page. Word wrap, column breaks, and keeping paragraphs together are paragraph attributes.

To change paragraph attributes (Levels 3-4)

1. Select one or more paragraphs you want to work with.
2. Choose Paragraph Attributes from the Paragraph menu. A dialog box appears:

![Paragraph Attributes dialog box]

3. Fill in the dialog box, selecting the attributes you want.

**Disable Word Wrap.** Select this option to disable automatic word wrap and permits line breaks in the middle of words.

**Page/Column Break Before.** Select this option to put a column break ahead of the paragraph so that the paragraph appears at the top of the next column.

**Keep with Next Paragraph.** Select this option to keep the current paragraph together with the next paragraph on the same page, preventing GeoWrite from inserting a column or page break between them.

**Keep Paragraph Together.** Select this option to keep the entire paragraph together on the same page, preventing GeoWrite from separating the lines of the paragraph with a page or column break.

**Widow and Orphan Control.** Select the On button to permit column breaks within a paragraph and to specify how many lines to keep together in a column.

**At Paragraph Top.** If Window and Orphan Control is selected, select the number of lines allowed for widows.

**At Paragraph Bottom.** If Window and Orphan Control is selected, select the number of lines allowed for orphans.

4. Click Apply to apply your changes to selected paragraphs.

5. Click Close to close the dialog box.

**SETTING BORDERS**

You can put a border (lines or a box) around a paragraph to add emphasis and make it stand out in the flow of text, as in the following example:

```
This is an example of a paragraph with a single-line border around it.
```
The border width extends to the edge of the left and right indentation marker. You can also set the border color to set it apart from other text.

To make a simple border (Levels 3-4)

1. Select one or more paragraphs you want to have a border.
2. Choose Borders from the Paragraph menu. A submenu appears.
3. Select the border option you want (None, Thin, Thick, Double-Line, or Shadowed). The following example shows a paragraph with a shadow top left border:

   This is an example of a paragraph with a shadow top left border around it.

To make a custom border (Levels 3-4)

1. Select one or more paragraphs you want to have a custom border.
2. Choose Borders from the Paragraph menu. A submenu appears.
3. Choose Custom Border. A dialog box appears:

![Custom Border Dialog Box]

4. Fill in the dialog box, selecting the options you want.
   **Sides to Border.** Select this option to set the sides of the border (Left, Top, Right, and Bottom). Select all to put a box around the text. Select Draw Inner Lines to draw inner lines.

   The following example shows a paragraph with a top and bottom border only:

   This is an example of a paragraph with a top and bottom border.

   **Border Width (points).** Select the width of the border in points.

   **Border Spacing (points).** Select the border spacing in points.
Border Type. Select the type of border (Normal, Shadow, or Double Line).

Shadow Anchor. If a shadow border type is selected, select the anchor for the “light source” that creates the shadow (Top Left, Top Right, Bottom Left, or Bottom Right).

Shadow Width. If a shadow border type is selected, select the width of the shadow in points.

Width Between Double Lines (Points). If a double line border type is selected, select the space between the double lines in points.

5. Click Apply to apply your changes to selected paragraphs.

6. Click Close to close the dialog box.

To change the border color (Levels 3-4)

1. Select one or more paragraphs you want to have a custom border.

2. Choose Borders from the Paragraph menu. A submenu appears.

3. Choose Border Color. A dialog box appears:

4. Fill in the dialog box, selecting the options you want.

  % Shaded. Select the percent shading for the border color. The lower the number, the more faded the color. A setting of zero (0) causes the border to disappear. By default, this setting is 100.

  Color Tools. Select the border color from the color palette. You can also fine tune the color blend by setting the amount of red, green, and blue in the border color; the default values depend on the selected color.

  Pattern. Select the pattern for the border color. By default, this setting is solid. A transparent pattern is also available on this palette.

5. Click Apply to apply your changes to the selected text. Continue to make changes as desired until you’re satisfied with how the border looks.

6. Click Close to close the dialog box.
HYPHENATION

You can determine whether GeoWrite hyphenates words in a paragraph. If hyphenation is active, when a word extends past the right margin, GeoWrite splits the word between syllables, inserts a hyphen (-) and line break, and wraps the rest of the word to the next line.

GeoWrite provides default hyphenation settings that you can change as desired. Note that some hyphenation can make a document easier to read, while too much hyphenation can make it more difficult by breaking continuity and looking cluttered.

NOTE

GeoWrite hyphenates only those words that appear in its dictionary.

To change hyphenation (Levels 3-4)

1. Select one or more paragraphs with the hyphenation you want to change.
2. Choose Hyphenation from the Paragraph menu. A dialog box appears:

3. Fill in the dialog box, selecting the options you want.

On or Off. Select On to allow automatic hyphenation and to set other options on the dialog box.

Maximum consecutive lines to hyphenate. Too many hyphenated lines in a row can clutter a document. Use this setting to restrict the total number of lines that can be hyphenated.

Shortest word to hyphenate. Too many hyphenated words, particularly if they're short, can clutter a document. Use this setting to limit the hyphenation to words of a certain length.

Shortest prefix. Use this setting to establish the length of the shortest prefix to hyphenate, such as “pre” in “prefix”.

**Shortest suffix.** Use this setting to set the length of the shortest suffix to hyphenate, such as “ing” in “hyphenating”.

5. Click Apply to apply your changes to the selected text.

6. Click Close to close the dialog box.

---

**USING COLOR**

Color can add emphasis and appeal to text. You can define colors for selected text or entire paragraphs. If you have a color monitor, the colors you define appear on screen. Similarly, if you have a color printer, the colors you define appear on the printed copy of your document.

*Text color* is the color of the text. *Background color* is the color of the background on which the text appears. When using colors, it’s best to use contrasting colors for each so that the text is easy to read. If the colors are identical, then the text “disappears” into the background. By default, text color is black and background color is white.

Although GEOS has a standard palette of colors, you can create your own variations by adjusting the amount of primary color (red, green, blue) in the color selected from the palette. You can also increase or decrease the percentage of shading to fade or sharpen the color intensity.

You can also choose different patterns to create a different texture in the background.

You can still select colors without a color monitor or printer — you just can’t see them on screen or in a printed report. Instead, colors appear in different shades of gray, which provides contrast to a lesser degree.

For more information on using colors, see “Using Color and Graphics” in Chapter 2.

**Using Text Color**

*Text color* is the color of the characters in the text.

*To change the text color (Levels 2-4)*

1. Select the text you want to change.
2. Choose Text Color from the Character menu. A dialog box appears:

![Text Color dialog box]

3. Fill in the dialog box, selecting the attributes you want.

  **% Shaded.** Select the percent shading for the text color. The lower the number, the more faded the color. A setting of zero (0) causes the text to disappear. By default, this setting is 100.

  **Color Tools.** Select the text color from the color palette. You can also fine tune the color blend by setting the amount of red, green, and blue in the text color; the default values depend on the selected color.

4. Click Apply to apply your changes to the selected text. Continue to make changes as desired until you're satisfied with how the text looks.

5. Click Close to close the dialog box.

*To change the text background color (Levels 2-4)*

1. Select the text you want to change.

2. Choose Text Background Color from the Character menu. A dialog box appears:

![Text Background Color dialog box]

3. Fill in the dialog box, selecting the attributes you want.

  **Filled or Unfilled.** Select Filled to set other options in this dialog box. By default, the text background color is unfilled.

  **% Shaded.** Select the percent shading for the text background color. The lower the number, the more faded the color. A setting of zero (0) causes the text to disappear. By default, this setting is 100.
**Color Tools.** Select the text background color from the color palette. You can also fine tune the color blend by setting the amount of red, green, and blue in the text background color; the default values depend on the selected color.

**Pattern.** Select the pattern for the text background. By default, this setting is solid. A transparent pattern is also available on this palette.

4. Click Apply to apply your changes to the selected text. You can continue to make changes as desired until you're satisfied with how the text looks.

5. Click Close to close the dialog box.

**Using Paragraph Color**

Paragraph color is the background color for an entire paragraph.

*To change the paragraph color (Levels 2-4)*

1. Select one or more paragraphs you want to change.

2. Choose Paragraph Color from the Paragraph menu. A dialog box appears:

3. Fill in the dialog box, selecting the attributes you want.

**Filled or Unfilled.** Select Filled to set other options in this dialog box. By default, the paragraph color is unfilled.

**% Shaded.** Select the percent shading for the paragraph color. The lower the number, the more faded the color. A setting of zero (0) causes the paragraph text to disappear. By default, this setting is 100.

**Color Tools.** Select the paragraph color from the color palette. You can also fine tune the color blend by setting the amount of red, green, and blue in the paragraph color; the default values depend on the selected color.

**Pattern.** Select the pattern for the paragraph color. By default, this setting is solid. A transparent pattern is also available on this palette.
4. Click Apply to apply your changes to the selected text. Continue to make changes as desired until you're satisfied with how the text looks.

5. Click Close to close the dialog box.

**FINDING AND REPLACING TEXT**

**LEVELS 2-4**

You can use find and replace to quickly find a word or phrase in your document and, optionally, to replace it with a different word or phrase. You can also replace all occurrences of a word or phrase in a document.

**Searching for Text**

You can search for any sequence of numbers, letters, spaces, and other printable characters (such as punctuation marks).

*To search for text (Levels 2-4)*

1. Choose Find and Replace from the Edit menu.
   
   or

   Press F6

   or

   At Levels 3-4, click the Find and Replace tool on the Function Bar.

   A dialog box appears:

   ![Find and Replace dialog box]

2. Type the text you want to search for.

3. Click either Find Next or Find Previous. GeoWrite starts the search from the insertion point forward or backward.

   • If GeoWrite finds a match, it highlights the text in the document. You can stop the search here, or you can click Find Next or Find Previous to resume the search for another match.
For forward searches, if GeoWrite reaches the end of the document, it starts searching from the beginning. For backward searches, if GeoWrite reaches the beginning of the document, it starts searching from the end. If GeoWrite cannot find the search text in the document, a message appears to that effect. Click OK to close the message dialog box.

4. Click Close to close the dialog box.

Replacing Text
You can replace any search text with different text.

To replace text (Levels 2-4)

1. Choose Find and Replace from the Edit menu.
   or
   Press F6
   or
   At Levels 3-4, click the Find and Replace tool on the Function Bar.

2. Type the text you want to search for. You can search for any combination of numbers, letters, spaces, and other printable characters (such as punctuation marks).

3. Enter the text that will replace the search text.

4. Click Find Next or Find Previous. GeoWrite starts the search from the insertion point forward or backward. If GeoWrite finds a match, it highlights the text in the document. You have the following choices:
   - You can replace one occurrence of the selected text. To do this, click Replace. You can stop the search here, or you can click Find Next to resume the search for another match.
   - You can replace all occurrences of the search text with the replacement text. To do this, click Replace All. A dialog box appears asking if you want to replace all occurrences. Click Yes to continue, or click No to abandon the operation.
   - Replace in Selection is the same as Replace All, except that it replaces all occurrences only within selected text.

For forward searches, if GeoWrite reaches the end of the document, it starts searching from the beginning. For backward searches, if GeoWrite reaches the beginning of the document, it starts searching from the end. If GeoWrite cannot find the search text in the document, a message appears to that effect. Click OK to close the message dialog box.
text in the document, a message appears to that effect. Click OK to close the message dialog box.

5. Click Close to close the dialog box.

**Using Wildcards and Special Characters**

At Levels 3 and 4, you can use wildcards and special characters when you search and replace text.

A *wildcard* is a symbol that substitutes for a single character (?) or a series of characters (*). You can use wildcards to search for words or phrases that are similar or have slightly different spellings.

For example, if you want to find any word that begins with “math” (such as math, mathematics, mathematical, and so on), you can use the Multiple Characters wildcard in your search text (“math*”). Similarly, if you want to find any occurrence of the words “affect” and “effect”, you can use the Any Character wildcard in your search text (“?fect”).

You can also search and replace *special characters* in your document: graphics, special text, tabs, carriage returns, and page breaks.

*To use wildcards and special characters (Levels 3-4)*

1. Choose Find and Replace from the Edit menu, or press **F6**. The Find and Replace dialog box appears.

2. Click Special Characters. A popup list appears:

   ![Special Characters Popup](image)

3. Select the wildcard(s) and special character(s) you want to search for.

   **Match Multiple Characters.** Select to add the Multiple Character wildcard to the Find text. It allows you to match text where the beginning or end of the text might vary (such as “professor” and “professional”).

   **Match Any Character.** Select to add an Any Character wildcard to the Find text. It allows you to match text where one or more characters might vary (such as “arise” and “arose”).
**Graphic or Special Text.** Select to add a character to search for any graphic object or any special text character (dates, times, numbers, and so on) to the Find text.

**Tab.** Select to add a tab character to the Find or Replace With text.

**Carriage Return.** Select to add a carriage return character to the Find or Replace With text.

**Page Break.** Select to add a page break character to the Find or Replace With text.

For special characters, you can set the following options:

**Ignore Case/Accents.** This is a special character option that instructs GeoWrite to find every occurrence of the search text, ignoring uppercase, lowercase, and accent marks. For example, if the search string is “Dog”, GeoWrite could find matches for “Dog” and “dog”.

**Match Partial Words.** This is a special character option that instructs GeoWrite to search for a portion of a word. For example, if the search string is “print”, GeoWrite could find matches on “print”, “sprinter”, “reprint”, and so on.

4. Click Find Next or Find Previous to search the document for the search text, and click Replace or Replace all to replace the search text with the replacement text.

5. Click Close to close the dialog box.

**USING HEADERS AND FOOTERS**

**LEVELS 2-4**

A header contains anything (text, graphics, or both) that you want to appear at the top of every page. Likewise, a footer contains anything you want to appear at the bottom of each page. Here are some of the things you can put in headers and footers:

- Date the document was created or printed.
- Title or file name of the document.
- Your name or the name of your department, business, or school.
- Chapter or section title.
- Graphics, such as a logo or design.
Header information appears at the top of the page just above the top margin. Footer information appears at the bottom of the page just below the bottom margin.

Headers and footers are not required in your document. Normally, you use them in documents with multiple pages. They can contain text formatting (such as bold or italicized text) and multiple lines of text.

You can be quite creative with headers. For example, you can use a different header or footer on the first page; for more information, see “Using Sections” in Chapter 6. Similarly, you can use different headers and footers on odd and even pages, thereby putting the page number near the outside edge of each page. For more information, see “Setting Document Size and Orientation” in Chapter 1.

By default, every document has a Header and Footer style that you can format as desired. For more information, see “Changing How Text Looks” in Chapter 4 and “Changing the Text Format” in this chapter.

When you import a document into GeoWrite, the headers and footers from the source document do not appear in the target document. For more information about importing, see “Importing and Exporting Documents” in Chapter 3.

NOTE
If you set tabs and margins for the Header or Footer style, the settings are relative to the left edge of the page, not the left edge of the ruler.
Setting Up a Header

The steps for setting up a header at Level 4 vary slightly from the steps at Level 2 and Level 3.

To set up a header (Levels 2-4)

1. At Levels 2 and 3, choose Edit Header from the Layout menu.  
or  
At Level 4, choose Header/Footer from the Layout menu. A submenu appears. Choose Edit Header from the submenu.
A page appears with the insertion point in the upper-left corner of the header area, as shown in the following illustration:

![Header area](image)

This is a special type of page that you use for organizing the layout of documents, not for entering the body of text. For more information, see “Using Master Pages” in Chapter 6.

2. Enter the header information. You can also use the following buttons located at the top of the header window to insert standard information that gets updated automatically:

**Page Number Button.** Click to put the page number at the insertion point.

**Date of Printing Button.** Click to put the date of printing at the insertion point.

4. Click Close to close the special page. The document page reappears.
**Setting Up a Footer**

The steps for setting up a footer at Level 4 vary slightly from the steps at Levels 2 and 3.

*To set up a footer (Levels 2-4)*

1. At Levels 2 and 3, choose Edit Footer from the Layout menu. *or*
   
   At Level 4, choose Header/Footer from the Layout menu. A submenu appears. Choose Edit Footer from the submenu. A page appears with the insertion point in the upper-left corner of the footer area, as shown in the following illustration:

   ![Footer area](image)

   This is a special type of page that you use for laying out documents, not for entering the body of text. For more information, see “Using Master Pages” in Chapter 6.

2. Enter the footer information. You can also use the following buttons located at the top of the footer window to insert standard information that gets updated automatically:

   **Page Number Button.** Click to put the page number at the insertion point.

   **Date of Printing Button.** Click to put the date of printing at the insertion point.

3. Click Close to close the special page. The document page reappears.
The title page is typically the first page of a document. It can be the cover of a report, test, essay, or book. The title page usually contains descriptive information such as the title of the document, the author's name, the date of printing, and so on.

Page numbering remains the same when you add a title page to the front of your document. The first numbered page occurs after the title page.

The steps for adding, moving to, and deleting a title page at Level 4 vary slightly from the steps at Levels 2 and 3.

**To add a title page to a document (Levels 2-4)**

1. At Levels 2 and 3, choose Create Title Page from the Layout menu.

   or

   At Level 4, choose Title Page from the Layout menu. A submenu appears. Choose Create Title Page from the submenu.

   A dialog box appears asking if you want to continue.

2. Click Yes to create the title page. GeoWrite creates a new section called Title Page at the beginning of the document. An empty title page appears, with the insertion point in the upper-left corner of the text area. If your document has headers or footers, they will not appear on the title page.

3. Fill in your title page as desired.

4. Return to the body of your document by scrolling downward or clicking the Next Page tool. You can resume editing anywhere in the document.

**To go to the title page (Levels 2-4)**

1. At Levels 2 and 3, choose Go to Title Page from the Layout menu.

   or

   At Level 4, choose Title Page from the Layout menu. A submenu appears. Choose Go to Title Page from the submenu.

   The title page appears.

**To delete the title page (Levels 2-4)**

1. At Levels 2 and 3, choose Delete Title Page from the Layout menu.
At Level 4, choose Title Page from the Layout menu. A submenu appears. Choose Delete Title Page from the submenu.

A dialog box appears asking if you’re sure you want to delete the title page.

2. Click Yes to delete the title page. GeoWrite deletes the entire Title Page section. If the insertion point was on the title page, GeoWrite moves it to the first page of the next section; otherwise, the insertion point remains in the same location.

PROOFING YOUR DOCUMENT

At Level 2 and above, GeoWrite provides tools you can use to proof read your document before printing it. The spell checker finds misspelled words and typographical errors. The thesaurus finds words with similar meanings. This section describes how to use these tools to help you produce a more well-written document.

Adding Words to the Spelling Dictionary

At Level 1, you can check the spelling in a document. For an introduction to using the spell checker, see “Checking Your Spelling” in Chapter 4.

At Level 2 and above, you can add special words to a user dictionary. You can use this feature when your document contains correctly spelled words not found in the dictionary, such as proper names or special terminology.

To check the spelling of a word or block of text (Levels 2–4)

You can check the spelling of a single word, a block of text, or the text in the entire document. To check the entire document, start with step 2.
1. Select the word or block of text you want to check.

2. Click the Check Spelling tool on the Style Bar.
   
   or

   Press F7.

   or

   Choose Check Spelling from the Edit menu.

   A dialog box appears:

   ![Image of Check Spelling dialog box]

   The mating pattern of the native "flugenheld" bird is one of obscure ritual and many loud noises, particularly by the male when he finds a suitable fe...

3. Select the scope of the text you want to spell check.

   **Check All.** Click this button to check all the text in the document.

   **Check to End.** Click this button to check the text from the position of the insertion bar to the end of document.

   **Check Selection.** Click this button to check only selected text.

   The first misspelled word (or word that is not in the Ensemble dictionary) appears in the Change to: entry box.

4. Select the action you want to take on this word.

   **Skip.** Click this button to ignore this occurrence of the spelling.

   **Skip All.** Click this button to ignore all occurrences of the spelling.

   **Replace.** Type the word correctly, then click this button to replace the misspelled word with the new spelling.

   **Replace All.** Type the word correctly, then click this button to replace all occurrences of the misspelled word with the new spelling.

   **Suggest.** Click this button to display a menu of alternative spellings for the misspelled word. When the suggestions appear, click the spelling you want to use and then click the Use This Suggestion button. If no suggestion is appropriate, click the Cancel button, then type the word correctly in the Change to:
box. The spell checker replaces the word with the new spelling and proceeds with its checking.

**Add to User Dictionary.** Click this button to add the word to the user dictionary. From this point forward, the spell checker will accept this spelling in this and other documents.

**Edit User Dictionary.** Click this button to edit the user dictionary. For instructions, see the next procedure.

5. When you are finished checking the spelling, a message window appears. Click OK to return to GeoWrite.

*To edit the user dictionary (Levels 2-4)*
You can add and delete words in the user dictionary.

1. Click the Check Spelling tool on the Style Bar.
   *or*
   Press **F7**.
   *or*
   Choose Check Spelling from the Edit menu.
   A dialog box appears.

2. Click Edit User Dictionary. A dialog box appears:

3. Fill in the dialog box, selecting the options you want:
   **Words in User Dictionary.** This lists the words in the user dictionary.
   **Delete Selected Word.** To delete a word, select it from the list, then click this button.
   **New Word.** To add a new word, type it here, then click Add New Word. If you attempt to add a word that already exists, a message dialog appears; click OK and resume.

4. Click Close to close the Edit User Dictionary dialog box.
5. Click Close to close the Check Spelling dialog box.
Using the Thesaurus

While writing or editing a document, you might sometimes ask yourself “What’s a better word for ______?” What you want is a synonym: another word with a similar meaning.

How do you find a synonym? You can use a thesaurus, a book of synonyms. GeoWrite gives you an online thesaurus of over 41,000 words so you can look up synonyms quickly and easily.

A word may have different meanings: for example, the word “succeeded” could mean to reach a goal (“She succeeded at her efforts.”) or to replace someone in office (“The newly elected president succeeded the former president.”). Each meaning has a different set of synonyms, so you need to be aware of the meaning you want.

To use the thesaurus (Levels 2-4)

1. Select the word you want to look up. GeoWrite uses the word nearest the insertion point.

2. Choose Thesaurus from the Edit menu. A dialog box appears:

   Click to select a previous synonym.

   Click to replace the selected word in the text with the current word in the dialog box.

   Click to look up a different word.

   Select one of the possible definitions in the list.

   The full text of the selected definition appears here.

   The current word or synonym appears in the current word box.

   Select a synonym for the selected definition.
3. If more than one definition for the current word appears in the Definitions For box, select the definition you want. This list contains possible definitions for the current word, including the part of speech (noun, verb, adjective, and so on) and first part of the definition text.

When you select a different definition, the list of synonyms in the Synonyms for This Definition box changes. The text in the Full Text of Definition box changes as well.

4. Select the synonym you want in the Synonyms for This Definition box. The synonym you selected becomes the current word and appears in the current word box.

   or

Type a different word in the current word box.

5. To look up definition(s) and synonym(s) for the current word, click Lookup.

6. You can go back to a previous word by clicking the Back pull-down list and selecting the previous word you want. It appears in the current word box.

7. Click Replace to replace the selected word in the text with the current word in the dialog box. GeoWrite replaces the text.

8. Click Close to close the dialog box.

**USING TEXT STYLE SHEETS**

A *style* is a collection of text and paragraph formats under a common name. A *text style sheet* is the set of all the named text styles used in a document.

You can use a style to apply all the text and paragraph attributes to an object at the same time. You can record the following attributes in a text style:

- Text attributes, including character font, text size, text style, text color, and character width and height.

- Paragraph attributes, including alignment, spacing, line spacing, indentations, tab stops, paragraph color, and paragraph spacing.

For more information about setting these attributes, see “Changing How Text Looks” in Chapter 4 and “Changing the Text Format” in this chapter.

Styles make it easy for you to apply a group of attributes to text all at once. This saves you the effort of setting the same attributes
for different sections of text. For example, you might want a Title style to automatically center and display title text in a large, bold font. You could define the character and paragraph formatting for each Title paragraph individually, which might be time-consuming, or you could simply apply the Title style to each paragraph and save time.

When you create a style, you give it a name. Styles help ensure a consistent look to your text. They also make it easier to reformat a document because changing a style automatically updates paragraphs in that style as well as any styles that depend on that style.

You can save styles in a template so that you can use them over and over. For more information, see "Creating and Changing Templates" in Chapter 6.

For more information about styles, see "Using Style Sheets" in Chapter 2.

Using Default Styles

GeoWrite provides a set of three commonly-used styles. You can use them as is, or as a starting point for creating your own custom styles:

• **Normal.** This is the base style that comes with GeoWrite.
• **Header.** This is a standard style for the header of a document.
• **Footer.** This is a standard style for the footer of a document.

Applying a Style

You can change the format of a paragraph simply by applying a style from the style sheet.

*To apply a style to a paragraph (Levels 2-4)*

1. Select one or more paragraphs you want to change.
2. Choose Text Style Sheets from the Paragraph menu. A submenu appears.
3. Click Apply Style from the submenu. A dialog box appears:
4. Select the style you want, scrolling the list if necessary. GeoWrite applies the style formatting to selected paragraphs.

5. Double-click the window control button if you want to close the dialog box.

To apply a style more quickly (Levels 2-4)

1. Select one or more paragraphs you want to change.
2. Click the Styles drop-down list button on the Style Bar. A list of styles appears.
3. Select the style you want. GeoWrite applies the style formatting to selected paragraphs.

Storing and Recalling Text Attributes Temporarily

You can temporarily store the text and paragraph attributes from one paragraph and then apply them to another without first creating a named style. To do so, you use the Store Style choice. While named styles are saved with your document, graphic styles that you record with the Store Style choice are not saved when you exit GeoWrite.

To store the text attributes (Levels 2-4)

1. Select a paragraph with the attributes you want to store.
2. Choose Text Style Sheets from the Paragraph menu. A submenu appears.
3. Choose Store Style from the submenu. GeoWrite remembers the attributes of the selected paragraph.

To recall the text attributes (Levels 2-4)

1. Select one or more paragraphs to which you want to apply the stored attributes.
2. Choose Text Style Sheets from the Paragraph menu. A submenu appears.
3. Choose Recall Style from the submenu. GeoWrite applies the saved attributes to the selected text.

Defining a New Style

You can add a new style to the style sheet by giving it a name and defining its attributes. A base style is a style on which other styles depend; these styles are variations on the base style. If you
change an attribute in the base style, all dependent styles will change except those that define the attribute uniquely.

For example, suppose you define a style called “Head Level 2” using another style, “Head Level 1,” as its base style. If you add bold to “Head Level 2”, the text in “Head Level 2” becomes bold. GeoWrite updates all text in either style with the new attributes. Alternatively, you can define a style so that its unique attributes change relative to changes in the base style. For example, if you set margins in “Indent Level 2” relative to “Indent Level 1,” its base style, and you increase the left margin in “Indent Level 1” by .25 inches, GeoWrite increases the left margin in “Indent Level 2” by .25 inches as well.

You can also define a new style without using a base style. GeoWrite uses the default attributes or the attributes of selected text as the starting point instead.

**To define a new style (Levels 3-4)**

1. Select a paragraph with identical or similar attributes to the style you want to create. GeoWrite uses the attributes in the selected (or base) style to define the initial attributes of the new style. You can also start from scratch, with no text selected, using the default text and paragraph attributes.

2. Choose Text Style Sheets from the Paragraph menu. A submenu appears.

3. Choose Define New Style from the submenu. A dialog box appears:

![Define New Style](image)

**Description.** Displays a description of the selected style, which changes when you define text and character attributes. The base
style appears first, then any changes you’ve made to character and paragraph formatting.

**Display in Tool Bar Pop-Down List.** Select whether the style appears in the Styles drop-down list. By default, this option is selected.

**Apply to Selection Only (Character Style).** Select whether you want to apply the style attributes to selected text only or to the entire paragraph.

**Point Size Relative.** Select to make the point size relative to the point size of the base style. Changing the point size in the base style changes the point size in the current style by the same amount.

**Margins Relative.** Select to make the margins relative to the margins of the base style. Changing the margins in the base style changes the margins in the current style by the same amount.

**Leading Relative.** Select to make the leading (or line spacing) relative to the leading of the base style. Changing the leading in the base style changes the leading in the current style by the same amount.

**Name.** Type a new style name. You can use letters, numbers, and spaces. Choose a name that indicates what the style does. For example, you could call a style that contains the name of a chapter “Chapter Name.”

4. Click Define New Style to define the style. GeoWrite applies the new style to the selected text or paragraph.

5. Click Close to close the dialog box.

**Changing Styles**

You can change a style in two ways. You can change its visual attributes (text size, paragraph spacing, and so on) or its style attributes (point size relative, margins relative, and so on). If the style serves as the base style for other styles, changes can affect those dependent styles as well.

**CHANGING VISUAL ATTRIBUTES**

You can change the visual attributes (text and paragraph attributes) of an existing style. Doing so updates all text in the changed style with the attributes you selected.

*To change the format (Levels 3-4)*

1. Select a paragraph in the style you want to change.
2. Set any character and paragraph attributes you want for this style. For instructions on how to do this, see “Changing the Text Format” and “Using Color” in this chapter.

3. Choose Text Style Sheets from the Paragraph menu. A submenu appears.

4. Choose Redefine Style from the submenu. GeoWrite updates the style with the formatting in the selected paragraph.

CHANGING STYLE ATTRIBUTES
You can change the style attributes an existing style. If the style serves as the base style for other styles, changes can affect those styles as well.

To modify an existing style (Levels 3-4)

1. Choose Text Style Sheets from the Paragraph menu. A submenu appears.

2. Choose Manage Styles from the submenu. A dialog box appears:

The current style is highlighted.
Any new styles you create will appear in the styles list.

3. Find the style you want to change, scrolling the list if necessary, and then select it. The text in the Description box changes to show the style you've selected.
4. Click Modify. A dialog box appears:

![Modify Style dialog box]

- **Style attributes**
- **The current style**
- **Base Styles list**

5. Fill in the dialog box, selecting the options you want. For a description of these options, see “Defining a New Style” in this section.

6. You can change the base style if you want by selecting it in the list. If you do not want a base style, choose <<No Base Style>>.

7. Click Modify to change the style definition. The Modify Styles dialog box disappears.

8. Click Apply. GeoWrite applies your changes to the selected text.

9. Click Close to close the dialog box.

**Deleting a Style**

You can delete a style you no longer need. This eliminates clutter in the style sheet. Once you delete a style, you cannot recover it.

**NOTE**

You cannot delete the Normal, Header, or Footer style.

*To delete a style (Levels 3-4)*

1. Choose Text Style Sheets from the Paragraph menu. A submenu appears.
2. Choose Manage Styles from the submenu. A dialog box appears:

![Manage Styles dialog box]

The current style is highlighted.

3. Select the style you want to delete from the list. If the selected style has a base style, the name of the base style appears in the style description box.

4. Click Delete. GeoWrite deletes the selected style. GeoWrite attaches the base style to any paragraphs in the style you just deleted. However, GeoWrite does not apply the attributes of those paragraphs with the attributes in the base style.

   or

   Click Delete and Revert. GeoWrite deletes the selected style, attaches the base style to any paragraphs in the style you just deleted, and overrides the current attributes of those paragraphs with the attributes in the base style.

5. Click Close to close the dialog box.

**Reverting to a Base Style**

If you select a paragraph, you can change its attributes from the current style to the attributes of the base style of the current style.

*To revert to the base style (Levels 3-4)*

1. Select the text you want to change.

2. Choose Text Style Sheets from the Paragraph menu. A submenu appears.
3. Choose Revert to Base Style from the submenu. GeoWrite applies the base style to selected graphic objects, overriding the current attributes of selected graphic objects with the attributes in the base style.

**Using Style Sheets from Other Documents**

You can copy style sheets from another document or template into a document you’re working on. That way, you do not need to define the same styles all over again.

*To get styles from another document (Levels 2-4)*

1. Choose Text Style Sheets from the Paragraph menu. A submenu appears.
2. Choose Bring In Style Sheet from the submenu. A dialog box appears:

   ![Bring in Style Sheet](image)

   *Choose from the list of available documents.*

3. Select a document or template from the list.
4. Click Load Style Sheet. GeoWrite imports the styles from the template you selected. If a style with the same name appears in the template and the document, GeoWrite uses the template style instead.
5. Click Close to close the dialog box.
Designing GeoWrite Documents

This chapter describes the advanced features that make it quick and easy to create documents using templates, sections, graphics, and page layout. Some features described in this chapter are available at Level 2, but most are available at Levels 3 and 4, or at Level 4 only.
This chapter describes how to do the following:
• Create and customize templates to save typing, formatting, and layout time and to give your documents a consistent look.
• Create and format sections in a document.
• Combine graphics and text together in a document.
• Use GeoWrite's page layout mode for desktop publishing.

MANAGING TEMPLATES

LEVEL 4

A template is a special document that you use as a model to create similar documents. It contains the text, graphics, formatting, and special layouts common to all documents of a particular type.

This section shows you how to modify existing templates as well as how to create your own. For an introduction to templates, see “Using a Template to Create a Document” in Chapter 3.

A template is a special file that usually resides in the GeoWrite Templates folder. There are three kinds of templates:
• GeoWrite templates that come with GeoWrite.
• Custom templates that you create for your special needs.
• Empty Document template that replaces the GeoWrite internal default settings for a new empty document.

Creating and Changing Templates

At Level 4, you can create, modify, and delete any template, including GeoWrite templates.

CREATING A NEW TEMPLATE

When you create a new template, you can start with an empty document and build the template from scratch. Alternatively, you can get a head start by using another template or an existing document and saving it under a new name.

To create a new template (Level 4)

2. Click New to start with an empty document.
Click Template to use a template and choose the template from the Select Template Document to Open dialog box.

3. Lay out your template, making it appear the way you want it to when you first open a new document using this template:
   - Add, change, or delete any text and graphics.
   - Define any styles you want to use in the style sheet. You can bring in style sheets from other templates, if you want. For more information, see “Using Text Style Sheets” in Chapter 5.
   - Set up any text, paragraph, section, and document formatting.

4. Choose Other from the File menu. A submenu appears.
5. Choose Save as Template from the submenu. A dialog box appears:

![Save Document As a Template dialog box]

6. Type a name for the template.
7. Click Save. A dialog box appears informing you that GeoWrite has saved the template and that the template is open for editing.
8. Click OK. The template remains on your screen so that you can continue editing, if you want.

MODIFYING A TEMPLATE
You can improve on any existing template, including GeoWrite templates or the Empty Document template (if it exists).

To modify an existing template (Level 4)

2. Click the icon to use a template. A dialog box appears.
3. Select the template you want to change from the template list.
4. Select For Editing.
5. Click Use Template. The template appears, open for editing.
6. Change your template, making it appear the way you want it to when you first open a new document using this template:
   • Add, change, or delete any text and graphics.
   • Define any styles you want to use in the style sheet. You can bring in style sheets from other templates if you want. For more information, see “Using Text Style Sheets” in Chapter 5.
   • Set up any text, paragraph, section, and document formatting.

7. When you're finished, choose Save from the File menu. GeoWrite saves your changes to the template.

DELETING A TEMPLATE
You delete a template the way you would delete any other file in GEOS. Templates usually reside in the GeoWrite Templates folder. For more information about deleting files, see Chapter 3 in The GEOS Environment & Accessories.

WORKING WITH READ-ONLY TEMPLATES
Some templates cannot be changed or edited. A template that is not available for editing is read-only. You can change this designation by setting the document type. For more information, see “Setting the Document Type” in Chapter 3.

To set the document type for a template (Level 4)

1. Open the template.
2. Choose Other from the File menu. A submenu appears.
3. Choose Set Document Type from the submenu. A dialog box appears.
4. Select Template to make it a template you can modify.
   or
   Select Read-Only Template to make it a read-only template.
5. Click Change Type to change the document type.
6. Click Cancel to close the dialog box.

Managing the Empty Document Template
When you create a new document, GeoWrite offers the option to create the document starting from an empty document. This empty document normally consists of internal GeoWrite default settings for the page setup, margins, styles, and other factors that affect the contents and appearance of a new document.
If you want to use different settings for an empty document, however, you can use a default template called Empty Document instead. The Empty Document settings override the GeoWrite internal default settings.

You can assign an existing template or document to be the Empty Document template. You can also remove the Empty Document template and return to the GeoWrite internal defaults.

**SETTING THE EMPTY DOCUMENT**

You can use an existing template or document for the Empty Document template, or you can create a new one and change it as desired. You can set the empty document as often as you like.

*To set the empty document (Level 4)*

1. Create a new document or open an existing document and lay it out as desired.
   - Add, change, or delete any text and graphics.
   - Define any styles you want to use in the style sheet. You can bring in style sheets from other templates, if you want. For more information, see “Using Text Style Sheets” in Chapter 5.
   - Set up any text, paragraph, section, and document formatting.
2. When you’re finished, choose Other from the File menu. A submenu appears.
4. Choose Set Empty Document. A dialog box appears asking you if you want to use the current file as the default empty document; it also tells you if the Empty Document template already exists.
5. Click Set Empty Document. GeoWrite saves the settings from the open file to the Empty Document template.

**CHANGING THE EMPTY DOCUMENT**

Once you’ve set the empty document, you can go back and change it as often as you’d like, or you can assign a different document to the empty document.

*To change the empty document (Level 4)*

2. Click the icon to use a template. A dialog box appears.
3. Select the Empty Document template from the template list.
4. Select For Editing.
5. Click the Use Template button. The template appears, open for editing.
6. Change the Empty Document template as desired.
   • Add, change, or delete any text and graphics.
   • Define any styles you want to use in the style sheet. You can bring in style sheets from other templates if you want. For more information, see “Using Text Style Sheets” in Chapter 5.
   • Set up any text, paragraph, section, and document formatting. Make the document appear the way you want it to when you first open a new document.
7. When you're finished, choose Save from the File menu. GeoWrite saves your changes to the Empty Document template.

To replace the empty document with a different one (Level 4)

Follow the instructions for “Setting the Empty Document” in this chapter, using the file with which you want to replace the empty document.

RESETTING THE EMPTY DOCUMENT

You can remove the Empty Document template if you decide that you want to use the GeoWrite internal defaults for creating empty documents instead.

To reset the empty document (Level 4)

1. Choose Other from the File menu. A submenu appears.
2. Choose Empty Document from the submenu. A submenu appears.
3. Choose Reset Empty Document. A dialog box appears asking if you want to clear the default empty document.
4. Click Clear Empty Document. GeoWrite saves the current settings as the default empty document.
A section is a portion of a document with custom formatting for any of the following characteristics:

- Headers and footers.
- Page margins (top, bottom, left, and right).
- Multiple columns with spaces and rulers.
- Left and right pages.
- Starting page number.
- Text and graphics that appear on every page.

Variations in these characteristics can distinguish one section from the next.

Each document has at least one section. When you create a new document, GeoWrite creates a section called Main Section. Thereafter, you can add as many sections as you want for all kinds of uses.

For example, when you create a title page, GeoWrite automatically creates a section called Title Page; for more information, see “Using a Title Page” in Chapter 5. Similarly, for a document with several chapters, you can create a separate section for each chapter; that way, you can put a different chapter title in the header of each section.

At Level 2 and above, you can use format the section using the page setup and master pages. At Level 4, you can add, rename, and delete sections in a document.

Planning a Document with Sections

Sections typically apply to more complex documents such as books or reports rather than simple ones, such as short memos or letters. Before creating a complex document, think about how to divide it into distinct sections and what kind of page formatting and layout will be similar among all sections.

For example, a lab report for a science experiment might have four separate sections: the introduction, a description of the experiment, the results of the experiment, and conclusions about the results. All sections in the report might have the report title in the header, the page number in the footer, and a very wide margin. The header might also contain the section name, which varies from section to section.
When you have a general idea of how to organize and format the document, create it, then make any formatting and layout changes to the Main Section (such as modifying the page setup and the Master Page). Next, create all the other sections in the document. GeoWrite copies the section formatting automatically to each new section you create, saving you formatting and layout time.

In the lab report example, you'd create the new document, then change the headers, footers, and margins in the Main Section. Next, you'd create the other three sections. Finally, you'd add the section name to the header of each section.

**Managing Sections**
You can add, rename, and delete sections in a document.

**ADDING A SECTION**
You add a new section to a document by either inserting or appending it.

- *Inserting* puts the new section in front of an existing section. This is useful for adding the first section to a document.

- *Appending* puts the new section after an existing section. This is useful for adding the last section to a document.

To put a new section between existing sections, you can use either method.
When you add a section, GeoWrite adds a blank page with a section break. In the Page display mode, you can see how a section break separates sections in a document:

First section

A solid line separates sections in a document

Experiment

The experiment is performed upon all the students in the Biology 101 class. The students are asked how many hours a week they regularly exercise, and what kind of exercise is performed (running, walking, swimming). The heart rate is measured while the student is sitting. Students are asked to climb stairs for one minute. The heart rate is measured again.

Conclusion

You also add a section when you create a new title page. For more information, see “Using a Title Page” in Chapter 5.

To insert a new section (Level 4)

1. Choose Section from the Layout menu. A submenu appears.
2. Choose Insert Section from the submenu. A dialog box appears:

   ![Insert Section dialog box]

3. In the Section to Insert Before list, select the section ahead of which you want to insert the new section.
4. Type a name in the New Section Name box. You can use letters, numbers, and spaces. The name should indicate what the section contains. For example, a logical name for a section that contains introductory text would be "Introduction".

5. Click Insert Section. GeoWrite adds the new section in front of the existing section you selected.

To append a new section (Level 4)

1. Choose Section from the Layout menu. A submenu appears.
2. Choose Append Section from the Section menu. A dialog box appears:

   ![Append Section dialog box]

3. In the Section to Insert After list, select the section after which you want to insert the new section.
4. Type a name in the New Section Name box. You can use letters, numbers, and spaces. The name should indicate what the section contains. For example, a logical name for a section that contains the concluding remarks in a report would be "Conclusion".
5. Click Insert Section. GeoWrite adds the new section behind the existing section you selected.

RENAMING A SECTION

You can change the name of any section in a document, including the Main Section and Title Page section, to make the section name more descriptive or consistent with other section names.

To rename a section (Level 4)

1. Choose Section from the Layout menu. A submenu appears.
2. Choose Rename Section from the submenu. A dialog box appears:

![Rename Section dialog box]

3. In the Section to Rename list, select the section you want to rename.

4. Type a new section name. You can use letters, numbers, and spaces. The name should indicate what the section contains. For example, a logical name for a section that contains the lab results in a report would be “Lab Results”.

5. Click Rename. GeoWrite replaces the old name with the new name you entered.

**DELETING A SECTION**

You can delete a section you no longer need. Deleting a section deletes all the information it contains.

**NOTE**

You cannot delete a section if it is the only section in a document.

*To delete a section (Level 4)*

1. Choose Section from the Layout menu. A submenu appears.

2. Choose Delete Section from the submenu. A dialog box appears:

![Delete Section dialog box]

3. In the sections list, select the section you want to delete.

4. Click Delete. GeoWrite deletes the section you selected.
SELECTING A SECTION
To format a section, you must first select it.

To select a section (Level 4)

Position the insertion point anywhere in the section.

For example, if you are looking at the title page and want to select the Main Section, move the insertion point to a page in the Main Section.

DISPLAYING THE SECTION NAME
The section name can appear in the upper-left corner of the document to remind you where you are. This is for display purposes only; it does not appear on the printed page when you print a document.

To display the section name (Level 4)

1. Choose Other Settings from the Options menu.
2. Select Display Section Name. When selected, a check mark appears next to the menu choice and the section name appears in the upper-left corner of the document, as shown in the following example:

The section name appears here.

SETTING THE STARTING SECTION NUMBER
Sections are numbered sequentially starting with the first section in a document. You can use this internal numbering feature to display the section number for such things as parts of a document or page numbering that includes the section number. By setting the starting section number, you can control the
number that appears for a section. By default, the starting section number is 1.

Suppose, for example, that a report has three separate chapters (chapter 1, 2, and 3) that are individual sections. By setting the starting section number to one (1) and inserting the special character called Section Number in the chapter title and footer, you can display the section number automatically, as shown in the following example:

It also appears in the footer.

If this document has two other sections ahead of the first chapter, such as a title page and a table of contents, you could still achieve the same result. Simply set the starting section number to -2.

*To set the starting section number (Levels 3-4)*

1. Choose Section from the Layout menu. A submenu appears.
2. Choose Set Starting Section # from the submenu. A dialog box appears:

3. Select the starting section number.
4. Click Apply to apply your changes.
5. Click Close to close the dialog box.
Using Page Setup

You can use the Page Setup option on the File menu to set the page margins, columns, left and right pages, and the starting page number in one section only. For example, the following sample document shows the result of setting the column characteristics:

Page Setup is not to be confused with the Page Size option on the File menu, which applies page formatting (type, size, layout, width, and height) to the entire document, including all sections. Page Setup applies to each section; if a document has only one section, it applies to the whole document.

To change the page setup for a section (Levels 2-4)

1. Select the section for which you want to change the page setup. Position the insertion point anywhere in that section.
2. Choose Page Setup from the File menu. A dialog box appears:

![Page Setup Dialog Box]

3. Fill in the dialog box, changing the options you want.

**Section to Change Page Setup For.** Select the section to which the settings apply.

**Starting Page Number.** Select the starting page number for a section. Use it instead of the Follow Last Section option to set the page number regardless of any numbering in previous sections. For example, if a document has a Title Page section and a Main Section, you might want to set the starting page number in the Main Section to 1.

**Follow Last Section.** Select to continue page numbering from the previous section. Use it instead of the Starting Page Number option.

**Columns.** Select the number of columns in the section.

**Spacing.** If you have more than one column in the section, select the distance between columns (as well as the relative column width). Spacing is the same between all columns. By default, this setting is 0.125 inches.

**Rule Width.** If you have more than one column in the section, select the width of a vertical rule. By default, this setting is zero (0) points, or no vertical rule.

**Master Pages.** Select whether you want a single page or left (even) and right (odd) pages that look like mirror images of each other. You would select two if, for example, you wanted the page number or section name to always appear on the outside margin of a page: the left margin on a left page and the right margin on a right page. By default, this setting is one Master Page.

**Margins.** Select the left, right, top, and bottom margins. By default, these settings are at one inch each.

4. Click OK to apply your changes to the selected section.

5. Click Close to close the dialog box.
Using Master Pages

You can specify the kind of information that repeats on each page of a section. For example, you might want a logo to appear on every page, or you might want to make the header bigger on every page.

WHAT IS A MASTER PAGE?
The Master Page is a prototype of how text and graphics appear on every page in a section. The Master Page defines the section's header and footer, the area where the body text appears on a page, and graphics (such as a logo) that repeat on every page.

When you add a page to a section, GeoWrite uses the layout and information in the Master Page to create the new page. Once created, you can modify the document to suit your needs without affecting the Master Page.

Each section has either one or two Master pages, depending on the Master pages setting in Page Setup. By default, each section has just one Master Page.

The following illustration shows a typical Master Page designed with three columns:

CHANGING THE MASTER PAGE
There are several ways to change the Master Page:

• You can change the header and footer. For more information, see “Using Headers and Footers” in Chapter 5.
- You can change the column settings, Master Page settings or margins in Page Setup. For more information, see “Using Page Setup” in this chapter.

- You can edit the Master Page directly, which gives you more precise control over its contents.

When you edit the Master Page, GeoWrite updates the pages in the document with any changes you’ve made. For example, if you change the footer, GeoWrite applies that change to the footer on every page in the section.

To edit the Master Page for a section (Level 4)

1. Select the section for which you want to change the Master Page. Position the insertion point anywhere in that section.

2. Choose Edit Master Page from the Layout menu. The Master Page appears:

![Master Page for Main Section](image)

**Page Number Button.** Click this button to put the page number at the insertion point.

**Date of Printing Button.** Click this button to put the date of printing at the insertion point.

**Redraw Document Button.** Click this button to refresh the screen and implement any changes you’ve made. This option is useful if the Master Page and the document appear on screen at the same time.

4. Make your changes to the Master Page. The changes you can make include:
• Adding any text or graphics you want to the header, the footer.
• Resizing or moving the text region for the header, footer, or body text (including columns). For more information, see the next topic, “Changing Text Regions on the Master Page.”

5. When you’re finished, click Close. GeoWrite updates all affected pages in the section with any changes you’ve made.

CHANGING TEXT REGIONS ON THE MASTER PAGE

The text region defines where text flows on the page. You can move and resize the text region for the header, footer, and body text on a Master Page.

You might want to do this, for example, if you wanted to set a custom width for columns on a page. When you set the number of columns in Page Setup, GeoWrite calculates the column width for you. You can adjust the width or position of these columns by editing the Master Page.

To select a text region (Levels 2-4)

1. Select the Pointer tool from the Drawing Tool Bar. The mouse pointer becomes an arrow.
2. Point the tip of the arrow to a border of the text region (header, footer, or body text) and click the left mouse button. Handles appear along the border of the text region to indicate that it is selected.

Handles show that the text region is selected. Selecting a text region allows you to move it or resize it.

To deselect a text region (Levels 2-4)
- Point anywhere outside or inside the border of the text region and click. The handles disappear.

To change the size of a text region (Levels 2-4)
1. Select the text region you want to resize.
2. Point to any handle, press and hold down the left mouse button, and drag the handle until the text region becomes the size you want.
3. Release the left mouse button.

To move a text region (Levels 2-4)
1. Select the text region you want to move.
2. Point to the move handle, press and hold down the left mouse button, and drag the text region to where you want it to appear.
3. Release the left mouse button.
To copy a text region (Levels 2-4)

1. Select the text region you want to copy.
2. Press Ctrl+Ins.
   or
   Choose Copy from the Edit menu.
   or
   At Levels 3 and 4, click the Copy tool on the Function Bar.
   GeoWrite copies the text region to the clipboard.
3. Position the insertion point to where you want to paste the text region.
4. Press Shift+Ins.
   or
   Choose Paste from the Edit menu.
   or
   At Levels 3 and 4, click the Paste tool on the Function Bar.
   GeoWrite pastes the text region to the document.

To delete a text region (Levels 2-4)

1. Select the text region you want to delete.
2. Press Del.
   or
   Choose Delete from the Edit menu.

REAPPLYING THE MASTER PAGE TO A SECTION

You can make custom changes to individual pages in a document. For example, you can move a column on one page without affecting the column position on other pages in a section.

When you edit the Master Page, you can decide whether or not GeoWrite applies your edits on the Master Page to all pages in the section, overwriting any custom formatting on individual pages. If you select Automatic Layout Recalc from Other Settings in the Options menu, GeoWrite automatically updates all pages in the section with changes to the Master Page. If you deselect this option, GeoWrite does not override individual page formatting automatically.

You can also abandon any changes you've made to the Master Page before applying them to the pages in the section. For example, suppose you change the column widths on the Master
Page but later decide that you want to undo those changes because it will reverse formatting you’ve done on specific pages. You can undo them before GeoWrite updated pages in the section.

To apply the Master Page to all pages in a section (Level 4)

1. Select the section for which you want to change the Master Page. Position the insertion point anywhere in that section.
2. Choose Section from the Layout menu. A submenu appears.
3. Choose Reapply Master Page from the submenu. A dialog box appears:

   ![Reapply Master Page dialog box](image)

   Do you wish to reset the master page before reapplying it to all the page layouts in this section, or do you wish to reapply the existing master page without resetting it?

4. Select from the choices in the dialog box.

   **Reset, Then Reapply.** Click this button to reset the Master Page before reapplying your changes to all pages in this section.

   **Reapply Existing.** Click this button to reapply the Master Page without resetting it.

### USING GRAPHICS IN A DOCUMENT

**LEVELS 2–4**

This section shows you how you can use graphics in a GeoWrite document. It discusses some, but not all, of the graphics features available in GeoWrite. For more information about drawing and graphics, see the discussion of the GeoDraw application in Chapter 8 through 11.

A picture is worth a thousand words. Adding graphics to your document can enhance what you’re trying to say by illustrating a point, clarifying a discussion, or providing more information about a topic.

You can use any graphic image that you can paste from the clipboard. For example, you could draw a logo in GeoDraw, copy it to the clipboard, and paste it directly into your letterhead in GeoWrite. Similarly, you could create a graph in GeoCalc, copy it to the clipboard, and paste it directly in a GeoWrite science report that discusses the graph.
At Levels 3, and 4, you can even create a graphic image within GeoWrite using the tools on the Drawing Tool Bar. That way, you can create a drawing without leaving your document. Level 3 offers many basic drawing tools, and Level 4 offers some of the advanced features found in GeoDraw.

At Level 2 and above, you can add a graphic frame — a rectangle with a simple border around it — anywhere on a page. You can paste graphics directly onto a graphic frame, change its appearance, and control how it fits in the text in a document. You can also paste graphics directly into a document without using a graphic frame.

**Using a Graphic Frame**

A graphic frame is a rectangle that you can use to put a frame around text or graphics in a document. You can fill a graphic frame with color and patterns, change the color and thickness of its border, and make text wrap around it, wrap inside it, or even flow right through it.

**ADDING A GRAPHIC FRAME**

To use a graphic frame, you must first add it to your GeoWrite document.

*To add a graphic frame (Level 2-4)*

1. Choose Create Graphic Frame from the Layout menu.
   
   At Level 2, if this is the first graphic frame you've added during your GeoWrite session, a dialog box appears explaining that graphics tools are available. Click OK.

2. Point to where you want to anchor the upper-left corner of the graphic frame.

3. Press the left mouse button and drag down and to the right until the graphic frame becomes the size you want. An outline shows the borders of the graphic frame as you drag it.
4. Release the left mouse button. The graphic frame appears with handles along its borders, as shown in the following illustration:

![Graphic frame with handles](image)

**The handles along the borders of the graphics frame indicate that it's selected. To resize the graphics frame, drag a handle.**

**CHANGING A GRAPHIC FRAME**

You can resize, move, and delete a graphic frame. To change a graphic frame, you must first select it. When you add a new graphic frame, it is selected automatically. The border of a graphic frame has handles when it's selected.

*To select a graphic frame (Levels 2-4)*

1. Select the Pointer tool from the Drawing Tool Bar.
2. Point the tip of the Arrow pointer to a border of the graphic frame and click the left mouse button. Handles appear along its border to indicate that it is selected.

![The handles along the borders of the graphics frame indicate that it is selected.]

Selecting a graphic frame makes it the target for subsequent operations.

*To deselect a graphic frame (Levels 2-4)*

- Point anywhere outside or inside the border of the graphic frame and click. The handles do not appear whenever a graphic frame is not selected.

*To change the size of a graphic frame (Levels 2-4)*

1. Select the graphic frame you want to resize.
2. Point to any handle, press and hold down the left mouse button, and drag the handle until the graphic frame becomes the size you want.
3. Release the left mouse button.

*To move a graphic frame (Levels 2-4)*

1. Select the graphic frame you want to move.
2. Point to the move handle, press and hold down the left mouse button, and drag the graphic frame to where you want it to appear.
3. Release the left mouse button.

*To copy and paste a graphic frame (Levels 2-4)*

1. Select the graphic frame you want to copy.
2. Press Ctrl+Ins.

or
Choose Copy from the Edit menu.

or

At Levels 3 and 4, click the Copy tool on the Function Bar.
GeoWrite copies the graphic frame to the clipboard.

3. Position the insertion point to the page on which you want the graphic frame to appear.

4. Press **Shift+Ins**.

or

Choose Paste from the Edit menu.

or

At Levels 3 and 4, click the Paste tool on the Function Bar.
GeoWrite pastes the graphic frame from the clipboard.

5. Move and resize the graphic frame as desired.

*To delete a graphic frame (Levels 2-4)*

1. Select the graphic frame you want to delete.

2. Press **Delete**.

or

Press **Shift+Delete** to cut the graphic frame and copy it to the clipboard. That way, you can paste the graphic frame in another location.

or

At Levels 3 and 4, click the Cut tool on the Function Bar to cut the graphic frame and copy it to the clipboard. That way, you can paste the graphic frame in another location.

**SETTING ATTRIBUTES**

Color and patterns can add emphasis and appeal to a graphic frame. You can define colors and patterns for the inside fill (*area attributes*) and border (*line attributes*) of a graphic frame. You can fill the space inside with color or patterns, or you can leave it empty (unfilled).

When using color and patterns in a graphic frame, consider the impact on text, background, and graphics. Do they also have colors and patterns? In combination, do the colors and patterns help communicate what you are trying to convey? You might need to adjust the colors and patterns for any of these objects to clarify any point or message you may be making.
For more information about setting area and line attributes for a graphic frame, see “Setting Attributes” in Chapter 10.

**Pasting Graphics Into a Document**

You can paste any graphic from the clipboard into a GeoWrite document. You can paste it into a graphic frame, if you want, or directly into the text.

To copy and paste a graphic object (Levels 2-4)

1. In the application you’re using to draw the graphic (GeoDraw, GeoCalc, or even GeoWrite itself), select the graphic object you want to copy. You can select and copy more than one graphic object at a time, if you want.

2. Press **Ctrl+Ins.**
   
   or
   
   Choose Copy from the Edit menu.
   
   or
   
   At Levels 3 and 4, click the Copy tool on the Function Bar.

   GeoWrite copies selected graphic objects to the clipboard.

3. Open the GeoWrite document into which you want to paste the graphic object or objects.

4. Position the insertion point on the page on which you want the graphic object or objects to appear.

5. Press **Shift+Ins.**
   
   or
   
   Choose Paste from the Edit menu.
   
   or
   
   At Levels 3 and 4, click the Paste tool on the Function Bar.

   GeoWrite pastes the graphic object or objects from the clipboard.

6. Resize or move the graphic objects as desired.

To change the size of a graphic object (Levels 2-4)

1. Select one or more graphic objects you want to resize.

2. Point to any handle, press and hold down the left mouse button, and drag the handle until the graphic object or objects become the size you want.

3. Release the left mouse button.
To move a graphic object (Levels 2-4)

1. Select one or more graphic objects you want to move.
2. Point to the move handle, press and hold down the left mouse button, and drag the selected graphic objects to where you want it to appear.
3. Release the left mouse button.

Wrapping Text

Wrapping text determines how a graphic fits in with the text. Text can go outside or inside the borders of a graphic object or it can flow right through the graphic object. The following illustration shows examples of each option:

To set text wrapping (Level 4)

1. Select the graphic frame you want to use.
2. Choose Wrap Type from the Graphics menu. A submenu appears.
3. Select one of the following options:
   - Wrap Tightly. This option wraps text tightly around the borders of selected graphic objects.
**Wrap Around Rectangle.** This option wraps text around a rectangular area that completely encloses the selected graphic objects.

**Wrap Inside Object.** This option wraps text inside the border of selected graphic objects.

**Don’t Wrap.** This option suppresses text wrapping. The text goes right through the object.

GeoWrite applies the wrap type you specified and wraps text accordingly.

---

**USING PAGE LAYOUT**

GeoWrite has a page layout mode that you can use for page layout tasks. This section describes when and how to use page layout to create a GeoWrite document.

In general, you use page layout for shorter documents that have a mixture of graphics and text, lots of layout work on each page, and a finite page length. For example, page layout would be ideal if you wanted to create a four-page brochure with graphs and drawings. For short memos, long reports, or books (documents with just pages of text), using page layout may not even be necessary.

When using GeoWrite as a page layout tool, GeoWrite gives you more direct control over pagination in a document. Page layout focuses more on the design of individual pages than on the flow of text through a document. If adding text causes the text to spill past the end of a page, GeoWrite automatically creates an additional page. On the other hand, if deleting text removes all the text on a page, GeoWrite doesn’t automatically delete the page. This is where page layout makes things easy for you.

For example, suppose you lay out a six-page newsletter with graphics on every page and want to insert two pages between the fourth and fifth pages without disturbing the other pages. In page layout mode, you simply insert the pages; GeoWrite moves the fifth and sixth pages down, including graphics.

**Working with Documents in Page Layout Mode**

When you activate page layout mode, you can insert, append, and delete individual pages in a document.
ACTIVATING PAGE LAYOUT MODE

You can activate page layout mode so that GeoWrite doesn’t delete pages automatically and unexpectedly alter your page count. You can do this whenever you want, even after you’ve started editing a document.

To activate page layout mode (Level 4)

1. Choose Page Layout Mode from the Options menu.

ADDING PAGES

You can add a page section to a section or document by either inserting or appending it. Inserting puts the new page ahead of the current page (the page where the insertion point is). Appending puts the new page after the current page. When you add a page, the text flows up into the new page.

In page layout, you can create the number of pages you need first, before filling them with information.

To insert a new page (Level 4)

1. Position the insertion point on the page ahead of which you want to insert the new page.
2. Choose Page Layout from the Layout menu. A submenu appears.
3. Choose Insert Page (Before This One) from the submenu. A confirmation message appears.
4. Click Yes. GeoWrite adds the new page ahead of the current page.

To append a new page (Level 4)

1. Position the insertion point on the page behind which you want to append the new page.
2. Choose Page Layout from the Layout menu. A submenu appears.
3. Choose Append Page (After This One) from the submenu. A confirmation message appears.
4. Click Yes. GeoWrite adds the new page after the current page.

DELETING PAGES

You can delete a page you no longer need. Deleting a page deletes all the information on the page. However, you can prevent GEOS from deleting a page that contains graphics.
NOTE

You cannot delete a page if it is the only page in a document.

*To keep pages with graphics from being deleted (Level 4)*

1. Choose Other Settings from the Options menu.
2. Select Do Not Delete Pages With Graphics.

*To delete an existing page (Level 4)*

1. Position the insertion point on the page you want to delete.
2. Choose Page Layout from the Layout menu. A submenu appears.
3. Choose Delete Page from the submenu. A dialog box appears asking you to confirm that you want to delete the current page.
4. Click Yes. GeoWrite deletes the current page.
Additional GeoWrite Features

This chapter describes the additional features that make it quick and easy to view documents in different ways, insert special characters, work with multiple columns, footnotes, and the thesaurus, and merge data with other GEOS applications.
Some features described in this chapter are available at Level 2, but most are available at Levels 3 and 4, or at Level 4 only.

This chapter describes how to:

• Change the way you view a document.
• Display hidden characters in a document.
• Insert special characters for displaying dates, times, numbers.
• Control pagination with page breaks.
• Format documents with multiple columns.
• Merge data from GeoDex, GeoCalc, and GeoFile into GeoWrite documents
• Add footnotes, a table of contents, and a bibliography to a document.

VIEWING YOUR DOCUMENT

This section shows you how to change the way GeoWrite displays a document so that you can see what you’ve created from different perspectives. It also describes how to show invisible characters (such as tabs, paragraph marks, and page breaks) in a document when you need to know where they are.

You can also change how a document appears on screen by zooming, scaling, viewing percentages, and using other view options. Zooming and scaling are described in The GEOS Environment & Accessories.

Changing Display Modes

A display mode determines the amount of information in a document that appears on screen. Depending on the display mode you’ve set, GeoWrite either displays or hides such elements as graphics, text formatting, page layout (multiple columns and margins), headers, footers, and so on.

GeoWrite has five display modes from which to choose:

• Page. This mode displays all the information on the screen. The document appears the way it would look if printed.
• Condensed. This mode displays text and text formatting in a single continuous column. Graphics do not appear, but the space they occupy appears as white space.
• **Galley.** This mode is the same as Condensed except that it removes any white space that results from page breaks.

• **Draft With Styles.** This mode displays text and text formatting in a single wide column. Graphics are completely hidden.

• **Draft Without Styles.** This mode displays text in a single font and in a single wide column. Graphics are completely hidden.

You can switch display modes depending on what you want to look at and work with in a document. For example, if you want to edit text without being concerned about special formatting, page layout, graphics, and so on, you can choose the simplest display mode (Draft Without Styles). On the other hand, to fine-tune the way everything looks in a document before printing it, you can choose the most complex display mode (Page).

The simpler display modes are generally faster to work in than the more complex ones because GeoWrite doesn’t need to perform as many calculations to display a document. Also, the simpler the display mode, the less “busy” the screen appears.

The display mode applies to how the entire document appears, not just to individual sections or pages. Changing the display mode doesn’t change the information in a document, nor does it change the way the document prints; it merely changes the way the document appears on screen.

*To change the display mode (Levels 3-4)*

1. Choose Display Modes from the View menu. A submenu appears.

2. Select the display mode you want. GeoWrite refreshes the screen and displays the document in the display mode you selected.

**NOTE**

*Refreshing the screen can take time when changing display modes, particularly for complex documents that have both text and graphics.*

**PAGE DISPLAY MODE**

The Page display mode, the default mode when you start GeoWrite, shows you most completely what a document would look like when printed on paper. It shows you everything in the document, including text formatting, page layout (side-by-side columns and margins), graphics, headers, and footers. GeoWrite also displays the section name if you’ve selected Display Section Name in Other Settings under the Options menu.
If you've switched to another display mode, you may want to switch back to Page display mode to fine tune document formatting before printing. Page display mode is the only mode where you can see your page exactly as it will print. It is also the only mode where you can manipulate graphic images, adding, deleting, drawing, moving, and resizing them as desired.

With summer quickly approaching, many people are planning how to spend their vacations. Maybe you are overwhelmed by the number of possibilities of where you and your family could visit. Or perhaps the most exciting place you can think of taking your kids is to the playground in the park down the block. Murtnick Travel is happy to offer special vacation packages to help you out of your dilemma. These special packages are available from the months of the chill by skiing. Murtnick offers special skiing vacations for families and groups.

Whether downhill or cross-country skiing is your preference, you can take a trip to any of five major skiing resorts located throughout the United States. The packages include passes, accommodations, and meals. Equipment rental is extra.

Package Booking
Are you overwhelmed by the packages that are available? Come to Murtnick and our agents will be glad to help you examine the possibilities. Murtnick Travel

GALLEY AND CONDENSED DISPLAY MODES
The Galley display mode shows all text formatting but displays only one continuous column of text. It hides headers and footers, page layout (side-by-side columns and margins), and the section name. It simplifies the display by putting white space where a graphic would appear; however, you cannot manipulate the graphic.
Use the Galley display mode when you want to see and work with text and text formatting but not graphics and page layout. You might need to know where graphics appear in the text but not the details of what they look like.

The Condensed display mode is the same as Galley mode except that it displays any white space resulting from column or page breaks.

**DRAFT WITH STYLES AND DRAFT WITHOUT STYLES DISPLAY MODES**

The Draft With Styles display mode shows you text formatting but displays only one column of text across the entire screen. It differs from Galley and Condensed in that it hides the page layout, graphics, headers, footers, and the section name.
Use the Draft With Styles display mode to work with text and text formatting but not graphics and page layout. Because it fills an entire screen, it's especially useful for editing text in sections with multiple columns. You can focus on what you're writing, not on how it looks on the page.

With summer quickly approaching, many people are planning how to spend their vacations. Maybe you are overwhelmed by the number of possibilities of where you and your family could visit. Or perhaps the most exciting place you can think of taking your kids is to the playground in the park down the street. Murtnick Travel is happy to offer special vacation packages to help you out of your dilemma. These specials are available from the months of June through August, so come and take advantage of these great deals now!

**Vacation Packages**

**WonderWorld**

- Escape from the cold weather and snow by taking a week-long trip to the WonderWorld in Texas. Our family package includes a five-day pass to the WonderWorld park. You can stay at your choice of WonderWorld Resort. We also include a coupon book with discounts at various local attractions you can visit while you are there. Is a week too short? We can customize the package to meet your needs. Accommodations and meals are included along with the round trip air fare. This is a special that you and your family won't want to miss!

- **Skiing**
  - Maybe you don't want to escape the cold weather and snow. You would rather be enjoying yourself in the midst of the chill by skiing. Murtnick offers special skiing vacations for families and groups. Whether downhill or cross-country skiing is your preference, you can take a trip to any of five major skiing resorts located throughout the United States. The package includes passes, accommodations, and meals. Equipment rental is extra.

- **American History Tour**
  - Take your kids on vacation and give them the opportunity to further their education by signing up for the American History Tour. You'll travel to New England and stop at all the major historical sites. Visit the site of Paul Revere's famous midnight ride. See where people still spin wool and churn their own butter as they did in colonial days. Relive the Boston Tea Party and many other historical moments that made our country.

- **Blue Sails Cruise**
  - For sea-going types, join the Blue Sails Cruise for a trip around the Bahamas. Enjoy the warm sea breezes on deck or the entertainment below. Relax and pamper yourself with the many amenities that blue Sails offers.

- **Washington D.C.**
  - If you've never had an opportunity to visit our nation's capital, then a trip to Washington D.C. is a must. See the White House, Capitol, and other government buildings, as well as go to locations that display our nation's historical artifacts. You have the choice of joining a tour group or renting it out on your own. We'll provide you with the information and the car.

You might have an initial delay when switching to or from this display mode because GeoWrite needs to recalculate before it can display the information properly on screen.

Draft Without Styles is the same as Draft With Styles except that it makes text formatting homogenous, displaying all text in a plain font instead of the underlying text formatting. This is the fastest way to edit text because GeoWrite doesn't need to perform as many calculations to display text on screen as you scroll the document. To ensure fast performance, you cannot zoom the document or choose other view options in this display mode.
Displaying Invisible Characters

_Invisible characters_ are non-printing characters that you type but don't normally see on-screen, such as spaces, tabs, paragraph marks (carriage returns), page and column break marks, and section break marks:

You can display invisible characters to see what you've typed and to edit them. For example, you might want to know if you've typed unwanted extra spaces in your document. The following table shows the on-screen symbols that represent invisible characters:

<table>
<thead>
<tr>
<th>SYMBOL</th>
<th>CHARACTER REPRESENTED</th>
</tr>
</thead>
<tbody>
<tr>
<td>¶</td>
<td>Paragraph Mark (carriage return)</td>
</tr>
<tr>
<td>–</td>
<td>Tab</td>
</tr>
<tr>
<td>·</td>
<td>Space</td>
</tr>
<tr>
<td>§</td>
<td>Section Break</td>
</tr>
<tr>
<td>‡</td>
<td>Page Break</td>
</tr>
</tbody>
</table>

_To display invisible characters (Levels 3-4)_

1. Choose Other Settings from the Options menu. A submenu appears.
2. Select Show Invisibles. GeoWrite displays the invisible characters.
DISPLAYING COUNTS

GeoWrite counts the number of characters, words, lines, and paragraphs in a document. You can use this information when your document needs to be a minimum or maximum size, such as a report that must be 250 to 300 words long, or an article that cannot exceed 30 lines.

To view document counts (Levels 2-4)

1. Choose Counts from the Edit menu. A dialog box appears:

![Counts dialog box]

Click to recalculate the counts.

2. Click Close to close the dialog box.

NOTE

You can make changes to the text while the dialog box is visible, then recalculate the counts if you want to see the impact of a change to the document.

To recalculate document counts (Levels 2-4)

1. Choose Counts from the Edit menu. A dialog box appears.
2. Position the insertion point in the text and make the changes that affect the number of characters, words, lines, or paragraphs in the document.
3. Click Count Again.
4. Click Close to close the dialog box.

INSERTING SPECIAL CHARACTERS

You can insert special characters in a document that display dates, times, and numbers. Special characters are useful because they save you from typing and calculating information. For example, if you want the current date in a letter template to be
updated each day, use a special character instead of retyping the date. Some special characters that are available at Levels 3 and 4 are not available at Level 2.

A page break is another kind of special character. For more information, see “Controlling Pagination” in this chapter.

You can search a document for these special characters. For more information, see “Finding and Replacing Text” in Chapter 5.

**Inserting the Current Date**

You can insert the current date in a document. You might do this to put a date at the top of a letter or in a memo. You can specify either of two formats: longhand or numeric. Alternatively, you can insert special date characters to add the current date in a different format. For more information, see “Inserting Special Dates” in this section.

*To insert the current date (Levels 2-4)*

1. Position the insertion point where you want to insert the current date.
2. Choose Insert Special from the Edit menu. A submenu appears.
3. Select the date format you want from the submenu.
   - **Longhand Date.** This option inserts the current date in a longhand format (such as “Friday, December 31, 1993”).
   - **Numeric Date.** This option inserts the current date in a numeric format (such as “12/15/93”).

GeoWrite inserts the current date in the format you selected. The date is entered just as if you’d typed it yourself so that you can change it later.

**Inserting the Current Time**

You can insert the current time in a document. You might do this to “time stamp” a fax or journal entry. The time appears in the HH:MM:SS format (hours: minutes: seconds). Alternatively, you can insert special time characters to add the current time in a different format. For more information, see “Inserting Special Times” in this section.

*To insert the current time (Levels 2-4)*

1. Position the insertion point where you want to insert the current time.
2. Choose Insert Special from the Edit menu. A submenu appears.
3. Choose Current Time from the submenu. GeoWrite inserts the current time in the HH:MM:SS format (such as “12:45:59 PM”). The time is entered just as if you’d typed it yourself so that you can change it later.

**Inserting a Number (Counter)**

GeoWrite keeps track of certain information in a document automatically, such as the current page number in the current section or document, the number of pages in the current section or document, and the current section number or total number of sections. To display any of these numbers, you insert the appropriate special number character in your document in the format you want.

For example, you might use special numbers in a footer to display page numbers that restart in every section: page numbers in the first section might be 1-1, 1-2, 1-3, and so on, while page numbers in the second section might be 2-1, 2-2, 2-3, and so on.

**NOTE**

Once you insert special numbers, you cannot change their value; their value depends on internal GeoWrite calculations.

*To insert a special number (Levels 3-4)*

1. Position the insertion point where you want to insert the number.
2. Choose Insert Special from the Edit menu. A submenu appears.
3. Choose Number from the submenu. A dialog box appears:

![Number Insert dialogue box](image-url)

Select a number type from this list.

Select a number format from this list.
4. Select the number type from the Type list.

**Page Number.** This special character displays the current page number in the document. You can set the starting page number for a document.

**Page Number in Section.** This special character displays the current page number in the current section. You can set the starting page number for a section.

**Number of Pages.** This special character displays the total number of pages in the document.

**Number of Pages in Section.** This special character displays the total number of pages in the current section.

**Section Number.** This special character displays the current section number. The value of this number depends on the starting section number. For more information, see “Managing Sections” in Chapter 6.

**Number of Sections.** This special character displays the total number of sections in the document.

5. Select the format from the Format list: Number, Uppercase Letter, Lowercase Letter, Uppercase Roman, and Lowercase Roman.

6. Click Insert. GeoWrite inserts the number from the list in the format you specified.

**Inserting Special Dates**

GeoWrite keeps track of certain date information automatically, such as the current date as well as the date a document was created, revised, or printed. To display any of these dates, you insert the appropriate special date character in your document, in the format you want.

For example, you might use special dates in a footer, for example, to display the date on which you printed or last revised a document.

**NOTE**

Once you insert special dates, you cannot change their value; their value depends on internal GeoWrite calculations. However, you can change the value when you insert the current date. For more information, see “Inserting the Current Date” in this section.

*To insert a special date (Levels 3-4)*

1. Position the insertion point where you want to insert the date.

2. Choose Insert Special from the Edit menu. A submenu appears.
3. Choose Special Date from the submenu. A dialog box appears:

4. Select the date type from the Type list. The choices include the following:

* **Today's Date (Won't Change).** This date shows the system date (the date that your computer maintains automatically) when you inserted the character. It doesn't change if the system date changes.

* **Date Document Created.** This date shows when the document was created.

* **Date of Last Revision.** This date shows when the document was last saved.

* **Date of Printing.** This date shows when the document was last printed. GeoWrite inserts the date even if you have not yet printed the document.

5. Select the date format from the Format list: Longhand, Abbreviated, Numeric, and so on. A sample of the selected date format appears.

6. Click Insert. GeoWrite inserts the special date from the list in the format you specified.

**Inserting Special Times**

GeoWrite keeps track of certain time information automatically, such as the current time as well as the time a document was created, revised, or printed. To display any of these times, you insert the appropriate special time character in your document, in the format you want.

For example, you might use special times in a footer to display when you printed or last saved a document.
NOTE
Once you insert edit special times, you cannot change their value; their value depends on internal GeoWrite calculations. However, you can change the value when you insert the current time. For more information, see “Inserting the Current Time” in this section.

To insert a special time (Levels 3-4)

1. Position the insertion point where you want to insert the time.
2. Choose Insert Special from the Edit menu. A submenu appears.
3. Choose Special Time from the Insert Special menu. A dialog box appears:

   ![Special Time dialog box]

   - Select a time type from this list.
   - Sample of the selected format.
   - Select a time format from this list.

4. Select the time type from the Type list. The choices include the following:
   - **Now (Won't Change).** This time shows the system time (the time that your computer maintains automatically) when you inserted the character. It doesn't change if the system time changes.
   - **Time Document Created.** This time shows when the document was created.
   - **Time of Last Revision.** This time shows when the document was last saved.
   - **Time of Printing.** This time shows when the document was last printed.
5. Select the time format from the Format list. A sample of the selected time format appears.
6. Click Insert. GeoWrite inserts the time from the list in the format you specified.
CONTROLLING PAGINATION

GeoWrite treats the text in a document as one continuous flow of information. Whenever you insert or delete text or graphics in a document, GeoWrite automatically calculates the location of page breaks and column breaks and inserts them accordingly. This process is called automatic pagination and the calculated page breaks are called soft page breaks because their location changes depending on the amount of information in a document.

You can force a page break manually by inserting a hard page break. You do this whenever you want to start a new page in a specific location, such as a bibliography page in a report or an index.

If you have multiple columns in your document, a page break is the same as a column break. A page break in the last (right-most) column on a page starts subsequent text on the next page. A page break in other columns moves text to the next column on the same page.

GeoWrite inserts a hard page break whenever you add a new section. The hard page break occurs at the section break. For more information, see “Adding a Section” in Chapter 6.

Inserting a Hard Page Break

You can insert a hard page break by using a menu command or by pressing a key combination on the keyboard.

To insert a page break using a menu (Levels 2-4)

1. Position the insertion point where you want to insert the page break.
2. Choose Insert Special from the Edit menu. A submenu appears.
3. Choose Insert Page Break from the submenu. GeoWrite inserts the page break.

If Show Invisibles is selected, the page break marker appears as a double-dagger (†) on screen. For more information, see “Displaying Invisible Characters” in this chapter.

To insert a page break using the keyboard (All Levels)

1. Position the insertion point where you want to insert the page break.
2. Press Ctrl+Enter. The hard page break appears.
Deleting a Hard Page Break

You can delete a hard page break you no longer need. You delete it as you would any other character.

To delete a page break (All Levels)

1. Double-click the page break marker you want to delete.
2. Press Delete. The insertion point moves to the bottom of the page in front of the page break marker. GeoWrite removes the page break, recalculates pagination, and refreshes the screen.

MANAGING COLUMNS

You can have multiple columns of text in a document, just like those you see in a newspaper or a magazine. Multiple columns can add visual appeal to a document and make the text easier to read.

By default, a document has just one column of text. When you specify multiple columns, text flows from the bottom of one column to the top of the next in a snake-like fashion. In Page display mode, multiple columns appear side-by-side on screen.

Setting Multiple Columns

To set up multiple columns, you specify column options in the Page Setup dialog box. These settings apply to the current section only or, if a document has only one section, to the entire document. For information about Page Setup, see “Using Page Setup” in Chapter 6.

If your document will have multiple columns throughout (as in a newsletter), you can save time by setting up columns in the first section before adding other sections to the document. That way, GeoWrite will carry your column settings over to subsequent sections.

When you set multiple columns, you specify the number of columns, the gutter (or spacing) between columns, and the width of any vertical rule(s) (the lines in between the columns). GeoWrite initially calculates a uniform column width for all columns based on the number of columns, the spacing between columns, the size of the page, the page orientation, and the page margins. Later, you can go back and change column widths if
you want. For more information, see "Changing Columns" in this section.

The following sample document shows the result of setting the column characteristics:

The column setting is three (3).

The distance between columns is 0.25 inches.

The vertical rule is 2 points wide.

To change the columns for a section (Levels 2-4)

1. Select the section for which you want to change the page setup. Move the insertion point to anywhere in that section.

2. Choose Page Setup from the File menu. A dialog box appears:
3. Fill in the dialog box, selecting the column options you want:
   **Columns.** Select the number of columns in the section.
   
   **Spacing.** If you have more than one column in the section, select the distance between columns (as well as the relative column width). Spacing is the same between all columns. By default, this setting is 0.125 inches; you can increase this up to 1.0 inch.
   
   **Rule Width.** If you have more than one column in the section and you want a vertical rule, select the width of a vertical rule. By default, this setting is zero (0) points, or no vertical rule; you can increase this up to 9 points.
   
4. Click Apply to apply your changes to the selected section.

5. Click Close to close the dialog box.

**Changing Columns**

Even if you have established columns in your document, you can go back and change the number of columns, the distance between columns, and the width of the vertical rule(s) in the Page Setup dialog box. GeoWrite simply recalculates the column width and redisplay the document with your changes.

In most cases, you won't need to do anything additional. However, you can set a custom size and position for each column by editing the Master Page. You can also customize columns on a page-by-page basis. For more information, see “Using Master Pages” in Chapter 6.

**Using Column Breaks**

You can insert a column break to force GeoWrite to move subsequent text to the top of the next column. A column break is the same as a page break. For more information, see “Inserting a Hard Page Break” in this chapter.

**USING MAIL MERGE**

**LEVELS 2-4**

When you print a GeoWrite document, you have the option to **merge** (combine) information from other GEOS applications. Merging allows you to print form letters, envelopes, mailing labels, reports, and other types of documents using data you've already entered; you don't need to type it again in GeoWrite.
Merging involves two documents: the data document and the merge document. The data document is a GeoDex, GeoFile, or GeoCalc document that contains data stored in a consistent format. For example, a GeoDex data document might contain the names and addresses of your friends, a GeoFile data document might contain a list of all the books you own, and a GeoCalc data document might contain monthly budget figures.

The information in the data document gets inserted into various places in the merge document. This is a GeoWrite document that contains the text, graphics, layout, and formatting that will appear in each printed copy of the document. It also contains merge fields that mark where GeoWrite puts the data from the data document when you print the document.

The easiest way to use GeoWrite’s merge feature is follow this general sequence of tasks:

1. Create the merge data in the format you want (in GeoDex, GeoCalc, or GeoFile).
2. Create the GeoWrite merge document and position the merge fields where you want them.
3. Copy the information you want to merge from the GeoDex, GeoCalc, or GeoFile data document to the clipboard.
4. Merge the information from the clipboard into the GeoWrite document.

This section describes these steps in detail.

NOTE
This section assumes you’re familiar with using at least one of the following: GeoDex, GeoCalc, or GeoFile.

Creating and Copying Merge Information
You can create and store merge data in GeoDex, GeoFile, and GeoCalc.

USING GEODEX
You can use GeoDex to store the information you’ll merge into your GeoWrite document. You can maintain the names, addresses, and phone numbers for just about anyone — friends, associates, colleagues, customers, vendors, and so on.

You can copy one name or all names in the GeoDex document to the clipboard. For this reason, you might want to store the information for different groups of people in different
documents. For example, you might want to keep friends in one file and business associates in another. That way, you can merge and print a personal letter to all your friends without involving business associates.

The following instructions assume that you know how to use GeoDex. For more information, see The GEOS Environment & Accessories.

**NOTE**
GeoDex uses standardized field names. The merge fields in your GeoWrite merge document must match these field names exactly. For more information, see “Setting Up the GeoWrite Merge Document” in this section.

To copy a single record to the clipboard (All Levels)
1. Display the record you want to copy.
2. Choose Copy Record from the Edit Menu. GeoDex copies the current record to the clipboard.

To copy all records to the clipboard (All Levels)
1. Choose Other from the File menu. A submenu appears.
2. Choose Export Document from the submenu. A dialog box appears:

![Export Document Dialog Box]

Click to copy addresses to clipboard.

3. Click Export to Clipboard. GeoDex exports all the records to the clipboard and prepares the data for merging.
USING GEOCALC

You can use GeoCalc to store the information you'll merge into your GeoWrite document. To do so, you must arrange the information in the GeoCalc document in a single table:

Field names appear in the first row. Each column is a different field. Field names are consecutive.

Field Name

Entries appear in the rows below. Each row is a different

This enables GeoCalc to copy the information to the clipboard in a standard format that GeoWrite can understand.

You can design a GeoCalc document like this from scratch or you can simply rearrange the information in an existing document.

The following instructions assume that you know how to use GeoCalc. For more information, see Chapter 12 through 16.

To design a GeoCalc data document (All Levels)

1. Add field names to the first row in the merge table, starting with the first cell (such as A1) and proceeding to the right (such as cell B1, cell C1, and so on) until you've defined a name for each field.

   - A field name can be any combination of letters, numbers, spaces, and punctuation. You can use any field name you want, as long as it matches the name of the merge field in the GeoWrite document. A field name usually describes the information it contains, such as Customer ID or Fax Number.
• Fields names must be contiguous. You cannot have an empty cell between field names.

2. Fill in the rows beneath the field names. Each row will be used one at a time to create individual documents when merging.

   To copy the merge data to the clipboard (All Levels)

1. If you want, change the order of the rows so that the rows at the top are the ones you want to merge. For example, at Level 4 of GeoCalc, you can sort rows so that the entries appear in alphabetical order.

2. Select the first row (with field names) and any subsequent rows you want to merge.

3. Choose Copy from the Edit menu. GeoCalc copies the field names and entries to the clipboard and prepares them for merging.

**USING GEOFILE**

You can use GeoFile to store the information you’ll merge into your GeoWrite document. You can copy one record, marked records, or all records in the GeoFile data document to the clipboard. You can take advantage of the data management features in GeoFile to store and maintain your data.

The following instructions assume that you know how to use GeoFile. For more information, see Chapter 17, 18, and 19.

   To copy records to the clipboard (Levels 2–4)

1. If you want to copy only marked records to the clipboard, mark the records you want to copy.

2. Choose Other from the File menu. A submenu appears.
3. Choose Export Document. A dialog box appears:

4. Fill in the dialog box, selecting the options you want:

   **Export All.** Select this option to export all records in the database.

   **Export Records From/To.** Select this option to export a range of consecutive records; specify the starting and ending record number.

   **NOTE**

   Do not use Map Export Fields when merging data. The field names in the source database must be identical to the names of the merge fields.

5. Click Export to Clipboard. GeoFile copies the records you specified to the clipboard and prepares the data for merging.

**Setting up the GeoWrite Merge Document**

The GeoWrite merge document contains the text, graphics, formatting, and page layout of the information you want to print. It also contains merge fields that correspond to the data in the clipboard.

The field names used in the merge fields must match exactly the field names used in the source data document. These fields are case-sensitive; that is, they must match uppercase and lowercase exactly. For example, a merge field with the name “HomeAddress” will not match “Home Address”, “Home_Address”, or “homeAddress”.
GeoDex requires that you use the following field names *exactly* as they appear in the merge field (including underscores):

<table>
<thead>
<tr>
<th>FIELD NAME</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Index_Field</td>
<td>Name of person, company, or other sorted information.</td>
</tr>
<tr>
<td>Addr_Field</td>
<td>Address information.</td>
</tr>
<tr>
<td>Note_Field</td>
<td>Notes box.</td>
</tr>
<tr>
<td>Home</td>
<td>Home phone number.</td>
</tr>
<tr>
<td>Office</td>
<td>Office phone number.</td>
</tr>
<tr>
<td>Car</td>
<td>Car phone number.</td>
</tr>
<tr>
<td>Fax</td>
<td>Fax phone number.</td>
</tr>
<tr>
<td>Phone_5</td>
<td>Additional phone number.</td>
</tr>
<tr>
<td>Phone_6</td>
<td>Additional phone number.</td>
</tr>
<tr>
<td>Phone_7</td>
<td>Additional phone number.</td>
</tr>
</tbody>
</table>

If appropriate, consider using these field names in GeoCalc and GeoFile as well. That way, you can copy merge data easily among all three applications.

*To add merge fields in a GeoWrite document (Levels 2-4)*

1. Position the pointer to where you want the merge field to appear. It can appear on a line by itself or embedded in other text.
2. Press Ctrl+Alt+\. A double-left bracket appears (<<). This identifies the start of the merge field.
3. Type the field name. Remember that the field name you type must be identical to the field name in the source GeoDex, GeoCalc, or GeoFile document.
4. Press Ctrl+Alt+Shift+\. A double-right bracket appears (>>). This identifies the end of the merge field.
5. If you want, specify the character formatting (such as style, size, color, and so on) for the field.
Repeat this procedure for each merge field in the merge document. When you're finished, your merge document can have any number of merge fields, as shown in the following example:

These fields correspond to the following fields in GeoDex:
Printing the Merge Document

Once you have set up your GeoWrite merge document, you can merge and print it.

To print a merge document (Levels 2-4)

1. Copy the merge information from the source GeoDex, GeoCalc, or GeoFile document. For instructions, see the appropriate procedure in this section.

2. In GeoWrite, choose Print from the File menu. A dialog box appears.

3. Select a merge option.
   **No Merge.** Select this option to prevent merging. If you print a merge document without merging, GeoWrite prints the merge fields instead.
   **Merge One.** Select this option to merge the first entry in the clipboard. Use it to test the merge document to make sure it works properly before printing all entries.
   **Merge All.** Select this option to merge all merge entries in the clipboard.

4. Click Print. GeoWrite merges one or all of the entries in the clipboard with the GeoWrite merge document.

   For each merge entry, GeoWrite merges the fields and prints a copy of the document.

   If a field appears in the clipboard but not in the merge document, GeoWrite skips it. If a field appears in the document but not in the clipboard, GeoWrite prints the merge field instead: the \texttt{<<field>>} text will appear in your document.

**NOTE**

If you see the \texttt{<<field>>} on a printed document, check to see that you selected either Merge One or Merge All. Next, make sure that the name of the field in the data document matches the name of the merge field in the merge document.

FINISHING YOUR DOCUMENT

This section shows you how to put the finishing touches on your document: footnotes, a table of contents, and a bibliography.
Using Footnotes

A *footnote* is a reference, comment, or explanation that appears at the bottom of the page on which the footnote appears or in a footnote section. A footnote typically cites an author or publication, clarifies a point, or offers an aside or digression from the main discussion.

A footnote has two parts: a reference mark in the body and the accompanying footnote itself, which usually appears at the foot on the same page.

Typically, footnotes are numbered sequentially as they occur in the document. If you use numbers for your reference mark, you must update the numbering sequence manually. A footnote remains on the page on which you added it. If the text with the reference mark moves to a different page, you must manually move the footnote to the new page. For these reasons, it's best to add footnotes (starting from the front of the document) when your document is nearly finished.

**CREATING THE REFERENCE MARK**

A *reference mark* is a symbol that appears in two places: in the body text, it indicates the presence of a footnote; in the footnote, it matches the text of the footnote with the reference mark in the body text. A reference mark is typically an asterisk, a number, or some other conventional symbol that is formatted in a superscript style to make it stand out in the text.
To create a reference mark (Levels 3-4)

1. Change to the Page display mode, if necessary.
2. Position the insertion point where you want to put the footnote number.
3. Type the symbol or number of the footnote reference.
4. Select the symbol or number of the footnote reference.
5. Choose Styles from the Character menu. A submenu appears.
6. Choose Superscript. GeoWrite displays the footnote reference in a superscript format.

CREATING THE FOOTNOTE
You can insert the footnote on the page where the reference mark appears or on a separate page of footnotes. You can create a footnote at the bottom of a page by creating a text frame between the body text and the footer.

To create a footnote at the bottom of a page (Levels 3-4)

1. Select the Text tool from the Graphics Tool Bar.
2. Point to where you want to anchor the upper-left corner of the text frame, usually near the bottom of the page, along the left margin and above the footer.
3. Press and hold down the left mouse button, then drag down and to the right until the text frame becomes the size you want (usually along the right margin and as tall as needed for any footnote(s)). An outline shows the borders of the text frame as you drag it.
4. Release the left mouse button. The text frame appears with the insertion point in the upper-left corner of the frame.

5. Type and format the reference marker.

---

works. People who exercise regularly have slower hearts, exercise very little or not at all. The experiment is performed in the Biology 101 class. The students are asked how regularly they exercise, and what kind of exercise is performed.
or

Copy the reference marker from the body text to the clipboard, then paste it here.

6. Type the footnote text.

7. Click the GeoWrite Text tool to resume editing your text.

To wrap text around the footnote (Level 4)

1. Select the text frame containing the footnote you want to wrap text around.

2. Choose Wrap Type from the Graphics menu. A submenu appears.

3. Choose Wrap Around Rectangle from the submenu. GeoWrite wraps text around the text box.

Creating a Table of Contents

You can create a table of contents for a document. A typical table of contents looks like this:

You can use GeoWrite styles to create a table of contents easily. For each heading level in your document, create a style with the following characteristics:

- A right tab type with a dot leader. For more information, see “Setting Tab Stops” in Chapter 5.
• Indented paragraphs for each heading level. For more information, see “Setting Indentation” in Chapter 5.

Once you have created the styles, you can simply enter the heading text, press Tab, enter the page number, then apply the style appropriate to the heading level.

Creating a Bibliography
You can create a bibliography for a document. A typical bibliography looks like this:

|---|

Hanging indentations Bibliography entry

You can use GeoWrite styles to create a bibliography easily. Simply create a style (such as “Biblio”) that is an indented paragraph. For more information, see “Setting Indentation” in Chapter 5.

Once you create the style, you can simply type the bibliography entry and apply the style to it.

FINE TUNING YOUR USER LEVEL

ALL LEVELS

Chapter 1 describes how to change and fine tune your user level. When you choose Set User Level from the Options menu, and click the Fine Tune button, you can toggle the following options on or off:

• Edit Features
• Simple Text Attributes
• Simple Page Layout
• Simple Graphics Layer
• Character Menu
• Color
• Graphics Layer
• Miscellaneous Options
• Complex Text Attributes
• Ruler Control
• Complex Page Layout
• Complex Graphics

If you are working at a lower user level and want to use a feature that is available at a higher level, you can use Fine Tune to activate the feature. To save the fine tuning settings from session to session, use the Save Configurations choice on the Options menu.
GeoDraw Basics  GeoDraw allows you to use your workstation to create many types of designs, pictures, and illustrations. If you have a color monitor, you can see your drawings in color; and if you have a color printer, you can print them in color, too. After you create a drawing, you can copy it into other types of documents. For instance, you can copy a picture you have created in GeoDraw to a report you created in GeoWrite; or you could copy it to a spreadsheet you have created in GeoCalc. You can also import files from other graphics applications into GeoDraw.
This chapter and the next three are devoted to GeoDraw. This chapter describes the basic features of GeoDraw at Level 1. Chapter 9 covers the features available at Level 2. Chapter 10 covers the Level 3 features. Chapter 11 covers the advanced features available at Level 4.

This chapter assumes you are using a mouse, although keyboard shortcuts are provided for some menu choices. A table of the available keyboard shortcuts appears at the end of Chapter 11.

This chapter describes how to do the following:

- Use the Drawing Tools on the Level 1 Tool Bar.
- Create graphic objects using the object tools or the Create submenu.
- Select, move, resize, duplicate, delete, and color graphic objects.
- Add text to drawings by creating text objects.
- Import and export graphics.

This chapter assumes you are familiar with the information covered in both Chapter 1 and Chapter 2, which provide an overview of the skills you need to use any GEOS application.
**STARTING GEODRAW**

**ALL LEVELS**

The GeoDraw icon appears in the WORLD directory and looks like the example at the left.

*To start GeoDraw (All Levels)*

1. Locate the GeoDraw icon and double-click it. The GeoDraw window appears along with the New/Open dialog box:

   The GeoWrite Window at User Level 1, and the New/Open dialog box.

2. Click one of the first three buttons to open a template, create a new empty document, or open an existing document. Click the last button to set the user level. For more information about using the New/Open dialog box, setting your user level, or starting GEOS applications, see Chapter 1.
If you open a document by clicking Template, New, or Open, the GeoDraw document appears:

USER LEVELS IN GEODRAW

You can make many of the GEOS applications as simple or sophisticated as you want. Typically, the more functions an application has, the more difficult it is to learn. In GEOS, you can start using an application at a simple, basic level. As you gain experience and are comfortable with it, you can add more functions by changing the user level. For more information about changing and saving user levels, see Chapter 1.

When you use GeoDraw for the first time, it opens to Level 1—the simplest of GeoDraw's four user levels.

The following are descriptions of GeoDraw's four user levels:

- **Level 1** allows you to create and manipulate basic objects such as lines, rectangles, and circles, and add text to your drawings. This chapter describes the features available at Level 1.

- **Level 2** gives you a set of drawing tools that provide greater flexibility as you create your drawings, allowing you to create editable polylines; to rotate, flip, and shuffle objects; and to
change the text font, style and size. Chapter 9 describes the features available at Level 2.

- Level 3 introduces grids, more extensive control of attributes such as pattern, line thickness and other characteristics, simple custom duplicate, object scaling and skewing, and bitmapped objects. Chapter 10 describes the features available at Level 3.

- Level 4 provides splines (advanced polylines), full custom duplicate, style sheets for both graphics and text, full text options including search, replace, and spell features, and the most complex attribute control. Chapter 11 describes the features available at Level 4.

Anytime you change your user level, you can use the following procedure to reset GeoDraw back to Level 1.

_To reset your user level to Level 1 (All Levels)_

Choose Reset Configuration from the Options menu.

**DRAWING TOOLS AT LEVEL 1**

Each user level in GeoDraw provides a set of drawing tools on the Tool Bar. At Level 1 the Tool Bar looks like this:

Using the Printer button and the Color Palette is like making a choice from a menu: each initiates a process (printing), or changes the document (color). These functions are explained later in this chapter. The other buttons on the Tool Bar are the drawing tools.
What Are Drawing Tools?

When you choose a drawing tool from the Tool Bar, it's a little like picking up a pencil or pen. Drawing tools help you create and manipulate objects in GeoDraw. The following are descriptions of GeoDraw's Level 1 drawing tools:

**Pointer Tool.** The pointer is automatically selected when you start GeoDraw. You use it to select, move, and resize objects.

**Text Tool.** Use the Text tool when you want to add text to your drawing. At Level 1, text always appears in a standard font. When you advance to a higher user level, you have complete control over the font, style, and size of the text in your drawing.

**Line Tool.** Use the Line Tool to draw straight lines. You can change the color, and at higher levels, the thickness of the line.

**Rectangle Tool.** Use the Rectangle Tool to draw both rectangles and squares.

**Ellipse Tool.** Use the Ellipse Tool to draw ellipses and circles.

Using Drawing Tools

Select a drawing tool by clicking it. Then, when you move the pointer into the drawing area, the pointer changes to indicate the type of tool you are using. Here are descriptions of the different types of pointers you will see in Level 1 GeoDraw:

**Arrow.** If you select the pointer tool, the pointer does not change as you move it around the screen — it is always the arrow pointer.

**Crosshairs.** If you select the Line, Rectangle, or Ellipse drawing tool, the pointer changes to crosshairs when you move it over the drawing area. The center of the crosshairs shows where the shape will begin as you draw.

**I-Beam.** If you select the pointer tool, and move the pointer over a text object, the pointer changes to an I-beam pointer. Use the I-beam pointer to select text and move the insertion point. Text objects are discussed later in this chapter.

**Crossed I-Beams.** If you select the Text tool, and move the pointer into the drawing area, the pointer changes to crossed I-beams. (If you move the pointer over a text object, the pointer becomes a regular I-beam pointer.) The intersection of the I-beams shows where text will begin if you click in the drawing area and then type. Using text is described later in this chapter.
The pointer always becomes an arrow pointer when you move it outside the drawing area and onto the Tool Bar or the menu area.

CREATING BASIC OBJECTS

ALL LEVELS

GeoDraw allows you to create images (drawings) composed of one or more objects. An object can be a shape, a line, or a block of text. One of the big advantages of GeoDraw over pencil and pen drawing is that you can easily select, edit, and manipulate individual objects separately from the other objects in the image.

GeoDraw offers you two ways to create objects. You can use the Create choice on the Edit menu to quickly create a shape, or you can use the drawing tools.

Drawing Objects with the Drawing Tools

When you select the Line, Rectangle, or Ellipse tool, the pointer changes to crosshairs when you move it over the drawing area. The center of the crosshairs indicates where your object will start drawing. You can create a shape in virtually any size by clicking where you want the shape to start, dragging the mouse to enlarge the object, and then releasing the mouse button when the object is the size you want.

To draw a rectangle or an ellipse (All Levels)

1. Move the pointer to the tool bar and click either the rectangle or ellipse. These tools function similarly. The tool button is selected.
2. Move the pointer to the drawing area. The pointer changes to crosshairs.
3. Move the crosshairs to where you want your shape to start. (You do not have to move it exactly to the right place now; you can rearrange it later.) Press the left mouse button, and while holding down it down, drag the mouse diagonally until the shape is the size you want, as indicated by the outlines that appear in the drawing area.
4. Release the mouse button. The object appears as a solid shape.
After you create an object, *resize handles* appear around the object, and a *move handle* appears in the center of the object. You can use these handles to move and resize the object. Handles also indicate that an object is selected.

![Move handle (the handle in the center of the object)](image)

![Resize handles (the handles around the edges of the object)](image)

To remove the handles from an object (deselect it), either create another object, or click somewhere else in drawing area that is not occupied by an object. For more information about selecting objects, see “Selecting Objects” in this chapter.

*To create a perfect square or circle (All Levels)*
- Hold down the **Shift** key while drawing either a rectangle or an ellipse. This causes GeoDraw to constrain rectangles to squares and ellipses to circles.

*To create an unfilled object (All Levels)*
- Press the **Ctrl** key while you click and drag to create a shape. When you release the mouse button the unfilled object appears:

![Unfilled object](image)

*To draw a line (All Levels)*

1. Select the Line tool from the Tool Bar. The pointer changes to crosshairs when you move it onto the drawing area.
2. Move the crosshairs to where you want to start your line. (You do not have to move it exactly to the right place now; you can change it later.) Press the left mouse button, and while holding down it down, drag the mouse until the line is as long and in the direction you want.
Hold down the Shift key while drawing a line to constrain the line to horizontal, vertical, or 45 degrees off of either.

3. Release the mouse button. A straight line appears, with a handle at each end and a move handle in the center:

---

The Line tool only makes individual straight lines. At Level 2 you can make connected straight lines and curved lines using the Polyline Tools, described in the next chapter.

To add an arrowhead to the end of a line (All Levels)

- Press the Ctrl key while drawing a line. When you release the mouse button, an arrowhead appears at the point where you ended the line:

---

Adding Objects with the Create Submenu

The Create submenu, located on the Edit menu, lists shapes you can use in your drawings. When you add an object using the Create submenu, the object appears at a standard size in the center of the drawing area. Objects you add with the Create submenu behave just like objects you create using drawing tools, and you can manipulate them as described in this chapter.

Using the Create submenu, you can add the following types of objects to your drawing:

- Rectangles
- Ellipses
- Lines
- Triangles
- Octagons
- 5-Pointed Stars
- 8-Pointed Stars

Each time you create an object using the Create submenu, GeoDraw places it in the center of the drawing area. Unless you want to create a stack of objects, you will want to move each object away from the center point before you add another object with the Create submenu. You move objects by selecting and dragging them, as described in the next section.
MANIPULATING OBJECTS

All drawings are composed of combinations of shapes and lines. You can modify and combine these objects in a variety of ways. This section describes how you can manipulate objects at Level 1, though the procedures given here work at all user levels. Additional techniques become available as you advance to Levels 2, 3, and 4.

Selecting Objects

You can select objects by clicking them with any of the drawing tools. When you have selected an object or objects, any changes you make affect that object. You can tell which object is selected because handles appear around it.

To select an object (All Levels)

Using one of the drawing tools, click the object you want to select. Handles appear around the object.

To deselect an object (All Levels)

- Click in any part of the drawing area where there is no object. Handles in the drawing disappear.
- Select another object.

To select multiple adjacent objects (All Levels)

This technique is useful when you want to move or change the color of several objects that are next to each other. You must use the mouse to accomplish this procedure.

1. Click the Pointer tool.
2. Move the arrow pointer above and to one side of the objects you want to select. Press and hold down the left mouse button, and drag the mouse across the area you want to select. As you move the pointer, a box with a dotted outline appears. Continue to drag and stretch this box over the objects you want to select. As you enclose objects, their handles appear, indicating that they are selected.

2. When all the objects you want to select fall completely within the selection box, release the mouse button. The box disappears, and the object or objects within the area remain selected.

To select multiple non-adjacent objects (All Levels)

This technique is useful when you want to select several objects that aren’t right next to each other.

1. Using any of the drawing tools, place the pointer or crosshairs on the first object you want to select. Hold down the Ctrl key and click. Handles appear around the object.

2. Continue to hold down the Ctrl key, while you click each of the other objects you want to select, one by one. Handles appear around each object.

You can deselect individual objects in the group by holding down the Ctrl key and clicking on them again.

To select all objects in a drawing (All Levels)

Choose Select All from the Edit menu. Handles appear around all the objects in the drawing.

HINT

To select all but a couple objects in your drawing, choose Select All from the Edit menu, then press the Ctrl key and click only those objects you want to deselect.
Moving Objects

When you create objects, they are not attached to the spot where you create them. You can move them around your drawing as you like. This section describes how to move objects in a drawing.

Use the rulers along the top and left side of the drawing area to help you gauge the position of your objects relative to the total drawing area. The default page size is 8.5" by 11", including the area outside the print border. For more information about setting the page size and printing documents, see Chapter 1.

NOTE

Objects that you place outside the print border (the dotted line near the perimeter of the drawing area) will not appear when you print.

To move an object (All Levels)

1. Select the object you want to move. Handles appear around the object:

2. Move the pointer over the diamond shaped move handle in the center of the object. When the pointer changes to a pair of crossed arrows, click and hold the left mouse button to grab the object.

3. Drag the object to the position you want. As you move the mouse, an outline of the object follows your motion, indicating where the object will be placed when you release the mouse button:
4. Release the mouse button. The object appears in its new position:

![Image of object moved to a new position]

To move multiple objects (All Levels)

1. Select the objects you want to move. Handles appear around the objects.
2. Move the pointer over the move handle for one of the objects, press the left mouse button and hold it down.
3. Drag the object to the position you want. Moving one object moves all the selected objects. As you move the mouse, an outline of the objects follows your motion, indicating where the object will be placed when you release the mouse button.
4. When the objects are positioned as you like, release the mouse button.

HINT

Sometimes it is easier to move an object by selecting it, and then dragging it with the right mouse button. This technique is the drag and drop mechanism discussed in The GEOS Environment & Accessories. The pointer changes to show an open rectangle at its base.

To nudge objects (All Levels)

Nudging means moving an object just a tiny bit. Sometimes using a move handle to reposition an object or group does not give you the fine degree of control you need. When you nudge objects, you move them up, down, left, or right one pixel at a time or ten pixels at a time. Pixels are the small dots that make up the images you see on the screen.

1. Select the object or objects you want to nudge.
2. To nudge the selected object(s) ten pixels at a time, press one of the arrow keys.

or
To nudge the selected object(s) one pixel at a time, hold down the **Shift** key while pressing one of the arrow keys.

**Resizing Objects**

Just as objects are not fixed to their original positions, they are not fixed at their original size. You can enlarge and reduce objects by dragging any of an object’s resize handles.

*To resize an object (All Levels)*

1. Select the object you want to resize. Resize handles appear around the object.

2. Drag one of the resize handles (but not the move handle in the center of the object). Dragging toward the center of the object reduces it, while dragging away from the center enlarges it. As you drag, an outline shows the changing size of the object.

To resize the object around its center point, hold down the **C** key or the comma (,) key while dragging. To proportionally resize an object, hold down the **Shift** key while you drag one of the corner handles. If you hold down both the **C** key (or comma) and the **Shift** key while you drag a corner handle, the object proportionally sizes around its center point.

3. When the object is the size you want, release the mouse. The object appears in place.

**NOTE**

Resizing line objects is a little different: you can only extend the length of the line as you drag one of the handles. You cannot resize a line to make it thicker. You can change line thickness only at Levels 3 and 4.

**Duplicating Objects**

It is often useful to duplicate an object instead of recreating it. For example, if you are drawing a floor plan that shows the layout of six desks, you can save time by drawing the first desk and then duplicating it five times.

*To duplicate an object (All Levels)*

1. Select the object you want to duplicate. Handles appear around the object.

2. Choose Duplicate from the Edit menu. The duplicate appears with handles around it in the center of the screen. You can use
the move handle on the duplicate to move the object to the position you want.

**HINT**
Press d to duplicate the selected object(s); press p to duplicate the selected object(s) in place.

**Deleting Objects**
You can delete objects from your drawing at any time.

*To delete an object (All Levels)*

1. Select the object(s) you want to delete. Handles appear around the object(s).
2. Choose Delete from the Edit menu.
   or
   Press the Delete key.
   or
   Press the Backspace (→) key. The object disappears.

**Coloring Objects**
If you have a color monitor, you can change the colors of objects in your drawings. If you have a color printer, the colors will appear on your printed drawings. Otherwise, colors will be printed as varying shades of gray.

*To change the color of an object (Levels 1–2)*

1. Select the object or objects you want to color. Handles appear around the objects.
2. From the color palette on the Tool Bar, select the color you want to use. The selected objects change to that color.

*To change an object's color using the Attributes menu (Levels 1–2)*

1. Select the object(s) you want to color. Handles appear around the object(s).
2. Choose Color from the Attributes menu. The following dialog box appears:

![Color dialog box](image)

3. From the color palette in the dialog box, select the color you want to use.

4. Click Apply. The selected object changes to that color.

5. Click Close. The dialog box disappears.

**ADDING TEXT TO DRAWINGS**

**ALL LEVELS**

In GeoDraw, you enter text in *text objects*. Each text object can contain as little or as much text as you like — from a single letter to multiple paragraphs. To create text objects, you use the Text tool. You can move, delete, and resize text objects just as you would any other object (a line, rectangle, or ellipse).

While the procedures in this section describe the text features available at Level 1, the principles and techniques also apply to the other levels. More advanced text capabilities become available as you advance to higher user levels.

*To create a text object (All Levels)*

1. Select the Text tool from the Tool Bar. The pointer changes to crossed I-beams when you move it over the drawing area.

2. Position the I-beams where you want your text to begin; click and drag diagonally to outline the area in which you want the text to appear. A dotted line shows the borders of the text object.

3. Release the mouse button. The border of the text object appears with a blinking vertical line, the *insertion point*, showing where you can begin typing. The default font is 12 point Roman. You can change the font at higher user levels.

4. Begin typing. As you type, text wraps within the text object, and the object automatically grows vertically to accommodate new
lines of text. Do not use the **Enter** key unless you want to begin a new paragraph. If you later resize your text object, word wrap will automatically adjust the line endings for you — unless you press **Enter** at the end of each line.

**HINT**

To quickly create a standard-size text object, select the Text Tool, and then click where you want to begin entering text. GeoDraw automatically creates a text object six inches across and one line deep. As you type, the text object automatically grows vertically to accommodate new lines of text. You can resize the object later if you like.

*To enter and edit text in a text object (All Levels)*

- Use the basic text editing techniques available in all GEOS applications, including the **Backspace** and **Delete** keys, and the Undo, Cut, Copy, and Paste choices on the Edit menu. For more information about editing text, see Chapter 2.

*To create text in different sizes (All Levels)*

At Levels 2 through 4, there is a Text menu from which you can choose fonts, styles and sizes for your text. At Level 1, the Text menu is not available; however, you can change the size of the default font when you create a text object as described in the following procedure.

1. Select the Text tool from the Tool Bar.
2. Position the crossed I-beam pointer where you want to begin typing.
3. Press and hold the **Ctrl** key, then press the left mouse button and drag the mouse diagonally to create your text object. The size of your type will be the depth of the object you create.
4. Release the mouse button. The blinking vertical line cursor shows the size of capital letters.

**Default Text**

```
Text
```

5. Begin typing. If your characters are too large for the words to fit in the object you defined, GeoDraw extends the object depth, but not its width. To resize a text object, see the procedure below.
To move, resize, or delete a text object (All Levels)

- Use the arrow pointer to move, resize, or delete a text object just as you would any rectangular object. If you make a text object too small, you may not be able to read the text.

**NOTE**
At Level 1, you cannot apply color to a text object. However, coloring text objects is possible when you advance to higher user levels.

To delete empty text objects (All Levels)

If you create a text object but don’t enter any text, you may leave an empty text object in your drawing. When a text object does not contain text and is not selected, the object becomes invisible. If you leave many empty text objects in your drawing, they can obscure portions of other objects. However, you can easily locate and delete these empty text objects.

1. Move the text pointer over the empty text object. The pointer changes to a single vertical I-beam.
2. Click the text object to select it. Handles appear around the text object.
3. Choose Delete from the Edit menu.
   - Or
   Press the **Delete** key.
   - Or
   Press the **Backspace** key. The object disappears.
Starting to Draw With GeoDraw

When you advance to Level 2, additional tools and menu choices give you more extensive drawing capability. For example, at Level 2, you can create complex objects comprising many individual line segments, you can rotate and flip objects, and you can control the appearance of text more extensively than at Level 1.
This chapter explains how to use the tools and menu choices that become available at Level 2. The features described in this chapter are also available at Levels 3 and 4.

ADVANCING TO LEVEL 2

You can advance from Level 1 to Level 2 at any time. For more information about changing your user level, see Chapter 1. At Level 2, the GeoDraw window looks somewhat different than at Level 1. The following illustration shows the GeoDraw window at Level 2:

Additional Menus

Three new menus are available at Level 2:

Transform. This menu provides choices for rotating and flipping objects, and for modifying polylines.

Arrange. This menu provides choices for nudging objects and changing the order of stacked objects. It also has choices for grouping and ungrouping objects.

Text. This menu provides extensive type style and size control, and allows you to color and justify text objects.
Expanded Menus

In addition, at Level 2, the File, View, and Edit menus contain additional choices.

ADDITIONAL CHOICES ON THE VIEW MENU

At Level 2, the View menu offers two additional choices:

**Scale to Fit.** Use this choice to fit all of your drawing in the window.

**Redraw (F5).** Use this choice to redraw all the objects in the current drawing. This is particularly useful when, after you have created and deleted a number of objects, some object fragments are either missing or remaining in the drawing area. Redraw replaces missing fragments and erases leftover bits of deleted objects.

ADDITIONAL CHOICES ON THE EDIT MENU

At Level 2, the Create choice on the Edit menu also offers different options than at Level 1.

<table>
<thead>
<tr>
<th>Create</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create Rectangle</td>
</tr>
<tr>
<td>Create Ellipse</td>
</tr>
<tr>
<td>Create Line</td>
</tr>
<tr>
<td>Create RoundedRectangle</td>
</tr>
<tr>
<td>Create Arc</td>
</tr>
<tr>
<td>Create Triangle</td>
</tr>
<tr>
<td>Create Octagon</td>
</tr>
<tr>
<td>Create 5-Pointed Star</td>
</tr>
<tr>
<td>Create 8-Pointed Star</td>
</tr>
<tr>
<td>Polygons...</td>
</tr>
<tr>
<td>Stars...</td>
</tr>
</tbody>
</table>

There are two new objects you can create from this menu: the rounded rectangle and the arc. Also, two new choices — Polygons and Stars — give more options for the polygons and stars you can create. These features are explained under “Creating Complex Objects” in this chapter.
Six new drawing tools are available on the Level 2 Tool Bar. These tools are illustrated below and described in this section.

**The Rotate Tool**

The Rotate tool lets you grab handles and rotate objects around their center point. You can also use this tool to select and move objects, just as you would with the arrow pointer.

**The Zoom Tool**

The Zoom tool lets you zero-in on a portion of your drawing. Use it to enlarge a portion of your drawing so that you can focus on the fine details. When you select the Zoom tool, the pointer changes to a magnifying glass. You can also use this tool to select and move objects, just as you would with the arrow pointer.

To zoom in on a particular point in a drawing (Levels 2–4)

1. Select the Zoom tool from the Tool Bar. The pointer changes to a magnifying glass when you move it onto the drawing area.
2. Position the Zoom pointer on the area you want to examine, and then click. You can click several times to move closer.

To zoom out (Levels 2–4)

Hold down the Shift key and click with the Zoom tool to zoom out.

You can also use the View menu to change your view. For more information about the View menu, see *The GEOS Environment & Accessories*. 
The Shape Tools

There are five Shape tools at Level 2. The first three (the Line, Rectangle, and Ellipse tools) work just as they do at Level 1. The other two (the rounded rectangle and arc) become available at Level 2:

- **Rounded Rectangle tool.** A rounded rectangle is a rectangle with rounded corners. You can use this tool just as you use the Rectangle tool.

- **Arc tool.** An arc is a portion of a circle or ellipse. For more information about arcs, see “Creating Complex Objects” in this chapter.

You can use the Shape tools to create shapes of almost any size. For more information about how to use Shape tools, see Chapter 8.

The Polyline Tools

*Polylines* are objects made up of line segments that are connected end-to-end. There are two Polyline tools:

- **Polyline tool.** Use this tool to create an object composed of straight line segments.

- **Rounded Polyline tool.** Use this tool to create an object composed of curved line segments.

The Polyline tools give you great flexibility in drawing objects that are composed of many line segments. For more information, see “Creating Complex Objects” in this chapter.

CREATING COMPLEX OBJECTS

**LEVELS 2–4**

At Level 2, you can create objects that are more complex than those you work with at Level 1. This section describes how to create and modify the following complex objects in your drawings:

- Polylines
- Polygons
- Stars
- Arcs

Complex objects are actually similar to the rectangles, lines, and ellipses described in Chapter 8. You can select, move, resize,
duplicate, delete, and color complex objects just as you would a rectangle, line or ellipse.

**Drawing Polylines**

GeoDraw provides two Polyline tools. A *polyline* is an object made up of line segments that are connected end-to-end. You use the Polyline tool to create objects with straight lines joined by angled corners. You use the Rounded Polyline tool to create curves.

You can also create polyline objects with both straight and curved segments. To do so, first create a straight line object, and then modify some of the segments so they are curved. Or, you can go the other way: Create a curved polyline object, and then modify some line segments so they are straight.

A polyline object can be open or closed. An *open polyline* is one in which the last line segment does *not* end at the polyline's starting point. A *closed polyline* is one in which the last line segment ends at the first segment's starting point. Closed objects can be colored at Level 2. At Levels 3 and 4, you can also add fill patterns and other area attributes. For more information about area attributes, see “Setting Attributes” in Chapter 10.
CREATING A POLYLINE AND A ROUNDED POLYLINE

To create a polyline object (Levels 2–4)

1. Select one of the Polyline tools from the Tool Bar. The pointer changes to crosshairs when you move it over the drawing area.

2. Position the crosshairs where you want the polyline object to begin, and then click. A small unfilled circle appears representing the first anchor point. Anchor points are the points where angles or curves connect the individual polyline segments you draw. A dotted box appears around the anchor point indicating that the object is only one anchor point big, so far.

3. Move the crosshairs to the position where you want to end the first line segment. GeoDraw displays the first line segment as you move around.

4. Click again. Another anchor point appears, and the completed line segment remains in place. The dotted box also enlarges to encompass the enlarged object.

5. Move the crosshairs to the endpoint of the next line segment and click. The surrounding dotted line changes size along with your object.

6. Continue adding line segments until the object is complete.
7. Double-click to finish the object. All the anchor points appear in the polyline object, and a dotted line surrounds it indicating the object is selected.

TRANSFORMING A POLYLINE

Once you have created a polyline object, you can grab any of its anchor points like a handle and move it to change the shape of the object. You can also change one, some, or all of the points in the polyline object from corners to curves or from curves to corners.

To change the shape of a polyline object (Levels 2–4)

1. Select one of the Polyline tools, and then click the polyline object whose shape you want to change. GeoDraw displays the object’s anchor points as unfilled circles and places a dotted outline around the object.

2. Select the point you want to move by clicking and holding it with the left mouse button. The selected point is filled, then disappears as you hold the mouse button.

3. Continuing to hold the mouse button, drag the point to change the shape of the object as you like. The affected segments change to show the result of your motion.

4. Release the mouse. The object is redrawn in the new position.

To change polyline points from corners to curves (Levels 2–4)

This procedure is useful if you want to create a polyline object in which some of the lines are straight and some are curved.

1. Select a Polyline tool, and then click the polyline object you want to change. The anchor points appear, and a dotted line surrounds the object.
2. Click the anchor point you want to change. You can select multiple points by holding the **Ctrl** key as you click the points. Each point you select is filled to distinguish it from unselected points.

![Selected anchor points](image1)

3. Choose Polyline from the Transform menu. A submenu appears.
4. Choose either Make Curved Point(s) or Make Corner Point(s) from the submenu. The selected points change accordingly.

![Corner points changed to curves](image2)

**HINT**

You can change a single point from a corner to a curve (or vice versa) by double-clicking it. Double-clicking again changes it back.

**INSERTING AND DELETING ANCHOR POINTS**

You can change the shape of a polyline object by inserting or deleting anchor points. Each point anchors one end of a line segment. You can increase the number of segments in the object by adding anchor points, or reduce the number by deleting anchor points. By making the lines shorter (inserting points) or longer (deleting points) you can control the curves and angles that shape the object.

*To insert anchor points (Levels 2–4)*

1. Select a Polyline tool, and then click the polyline object to which you want to add points. The anchor points appear, and a dotted line surrounds the object.

2. Click a line segment at the position where you want to insert an anchor point. The new anchor point appears.
To delete anchor points (Levels 2–4)

1. Select a Polyline tool, and then click the polyline object from which you want to delete anchor points. The anchor points appear, and a dotted line surrounds the object.

2. Select the point you want to delete by clicking it. You can select multiple points by holding down the Ctrl key as you click each point. Selected points appear filled.

3. Choose Polyline from the Transform menu. A submenu appears.

4. Choose Delete Point(s). The submenu disappears and the selected point or points are deleted.

HINT
You can also delete anchor points by first selecting them and then pressing the Delete key.

OPENING AND CLOSING POLYLINES
You can change a polyline object from open to closed, or from closed to open. Closed polyline objects are filled and can be colored; open polyline objects are unfilled.

To open or close a polyline object (Levels 2–4)

1. Select a Polyline tool, and then click the polyline object you want to open or close. The anchor points appear, and a dotted line surrounds the object.

2. Choose Polyline from the Transform menu. A submenu appears, with an indicator showing whether the polyline is open or closed.

3. Choose Close or Open from the submenu. The submenu disappears and GeoDraw changes the object accordingly, opening or closing the object at the last anchor point that you created or selected.
Drawing Polygons

Using the Create Choice on the Edit menu, you can quickly create polygons with up to 100 sides. Polygons are polyline objects. Therefore, after creating a polygon, you can modify it like any polyline object. For more information about working with polyline objects, see “Drawing Polylines” in this chapter. These are some examples of polygons:

At Levels 3 and 4, there are additional options for creating polygons. For more information, see “Designing Polygons and Stars” in Chapter 10.

To create a polygon (Levels 2–4)

1. Choose Create from the Edit menu. A submenu appears.
2. Choose Polygons from the Create submenu. The following dialog box appears:

   ![Polygon Dialog Box]

3. Click the up and down arrow buttons to select the number of polygon sides you want.
   
   or
   
   Type the number.
4. Click Create Polygon. The polygon appears in your drawing.
5. Click Close to close the Polygon dialog box. The polygon is selected, so you can reposition it in your drawing using any of the drawing tools.

Drawing Stars

Using the Create choice on the Edit menu, you can quickly create stars with up to 100 points. Stars are polyline objects. Therefore, after creating a star, you can modify it like any polyline object. For more information about working with polyline objects, see
"Drawing Polylines" in this chapter. These are some examples of the stars you can create:

At Levels 3 and 4, there are additional options for creating stars. For more information, see “Designing Polygons and Stars” in Chapter 10.

To create a star (Levels 2–4)

1. Choose Create from the Edit menu. A submenu appears.
2. Choose Stars from the Create submenu. The following dialog box appears:
3. Click the up and down arrow buttons to select the number of star points you want.
   or
   Type the number.
4. Click Create Star. The star appears in your drawing.
5. Click Close to close the Stars dialog box. The star is selected, so you can reposition it in your drawing using any of the drawing tools.

Drawing Arcs

An arc is a portion of a circle or an ellipse. You create arcs using the Arc tool. When you create an arc at Level 2, it appears as one quarter of a circle or ellipse:
At Levels 3 and 4, you can change this so that, for example, an arc appears as one eighth or one sixteenth of a circle or ellipse. For more information, see “Changing Arc Attributes” in Chapter 10.

You use the Arc tool in the same way you use the other Shape tools. For information about how to use Shape tools, see “Drawing Objects with the Drawing Tools” in Chapter 8.

**MANIPULATING OBJECTS**

**LEVELS 2–4**

At Level 2, the Rotate pointer, the Arrange menu, and the Transform menu give you new ways to manipulate objects. This section explains how to do the following:

- Nudge objects.
- Group and ungroup objects.
- Rotate objects.
- Flip objects.
- Change the stacking order of objects.

There are keyboard shortcuts for many of these object manipulation techniques. A table of all the available keyboard shortcuts appears at the end of Chapter 11.

**Nudging Objects**

*Nudging* means moving selected objects one pixel at a time. At Levels 2 through 4, you can nudge objects using choices on the Arrange menu.

*To nudge an object (Levels 2–4)*

1. Select the object you want to nudge. Handles appear around the object.
2. From the Arrange menu, choose Nudge Left, Nudge Right, Nudge Up or Nudge Down. The object moves one pixel in the direction you chose. Repeat this step until the object is positioned as you like.

**HINT**

At all user levels, you can nudge objects with the arrow keys and the *Shift* key, as described under “Moving Objects” in Chapter 8.
**Grouping and Ungrouping Objects**

You can group distinct objects together so that you can work with them as if they were a single object. For example, after grouping three rectangles, you could do any of the following:

- Change the fill color for all three rectangles all at once.
- Rotate them around a common center.
- Move them as a group without changing their positions relative to one another.
- Resize them as a group while maintaining their relative scale.

For more information about selecting, moving, and resizing objects, see Chapter 8.

After you've made the changes you want to the group, you can ungroup it to make each component a separate object again. A group can contain any object, including another group.

To group objects (Levels 2–4)

1. Select the graphic object(s) you want to group. A set of handles appears around each object:

![Handles around objects](image1)

2. Choose Group from the Arrange menu. GeoDraw groups the selected objects together as a single graphic object. A single set of handles appears around the group:

![Single set of handles](image2)
To ungroup objects (Levels 2–4)

1. Select the group you want to ungroup.
2. Choose Ungroup from the Arrange menu. GeoDraw separates the components of the group into individual graphic objects. Handles appear around the individual objects.

Rotating Objects

In Level 2, you can rotate a selected object using the Rotate tool or by choosing Rotate from the Transform menu. Using the Transform menu, you can rotate an object 90 degrees clockwise or counter-clockwise, or 180 degrees. (Additional rotation options are available on this menu at Levels 3 and 4.)

The selected object rotates around its center point. You can also select multiple objects, and they will also rotate around their respective center points. If you want multiple objects to rotate around a common center point, you must first group them; for more information, see “Grouping and Ungrouping Objects” in this chapter.

To rotate an object 90 or 180 degrees (Levels 2–4)

1. Select the object(s) you want to rotate. Handles appear around the object(s).
2. From the Transform menu, choose Rotate 90° Clockwise, Rotate 90° Counter-Clockwise, or Rotate 180°. The selected object rotates around its center point as specified. If you selected multiple objects, each object rotates around its own center point.

To rotate an object with the Rotate tool (Levels 2–4)

Using the Rotate tool, you drag an object around its center point until it appears in the position you want. To rotate the selected object in 45° increments, hold the Shift key down while dragging the object.

1. Select the Rotate tool on the Tool Bar. The pointer changes to a curved arrow when you move it over the drawing area.
2. Select the object you want to rotate. Handles appear around the object.
3. Place the tip of the arrow on one of the handles surrounding the selected object. The pointer changes to crossed arrows.
4. Grab the handle by clicking and holding down the left mouse button. The handles disappear.
5. Continuing to hold down the mouse button, move the Rotate tool clockwise or counter-clockwise until the object is in the position you want. A dotted outline shows the position of the object as you rotate it.

6. Release the mouse button. The object appears in its new position with handles around it.

**HINT**
You can also use keyboard shortcuts to rotate objects. To rotate the selected object counter-clockwise 15°, press [, or for 1° press **Shift+**[. To rotate it clockwise 15°, press ], or for 1°, press **Shift+**].

**Flipping Objects**
You can also use the Transform menu to turn objects over, or “flip” them left-to-right or top-to-bottom. This is useful for creating interesting effects with text objects and for building complex designs out of component objects. The following illustration shows some text that has been flipped:

```
<table>
<thead>
<tr>
<th>Test Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Original</td>
</tr>
<tr>
<td>Flipped</td>
</tr>
<tr>
<td>Original</td>
</tr>
</tbody>
</table>
```

Additional Transform menu options are available at Levels 3 and 4. For more information, see “Transforming Objects” in Chapter 10.

*To flip an object (Levels 2–4)*

1. Select the object(s) you want to flip. Handles appear around the object(s).

2. From the Transform menu, choose Flip Left to Right or Flip Top to Bottom. The objects flip in the direction you chose.

**HINT**
You can use keyboard shortcuts to flip objects. Press l (as in “left-to-right”) to flip the selected object left-to-right. Press t (as in “top-to-bottom”) to flip it top-to-bottom.

**Changing the Stacking Order of Objects**
When two objects in a drawing overlap each other, one appears to be in front of the other. In fact, all objects in your drawing are “stacked” one in front of the other, like a deck of cards. Each
time you create an object, you are adding a layer to the stack. The layers are only apparent, though, when objects overlap. The object in front is on top of the stack; that is, it is not covered by any other object. The object at the back of a stack can be covered by one or more objects. It is often useful to change the order in which objects are stacked — for example, to move an object to the front when another objects is stacked on top of it.

**BRINGING AN OBJECT TO THE FRONT OR SENDING IT TO THE BACK**

The Bring to Front and Send to Back choices on the Arrange menu move the selected object directly to the front or back of a stack, regardless of the object's original position.

![Object brought to front](image)

To move an object to the front or back of a stack (Levels 2–4)

1. Select the object you want to move to the front or back of the stack. Handles appear around the object.
2. From the Arrange menu, choose either Bring to Front or Send to Back. The stack is rearranged accordingly.

**HINT**

You can use keyboard shortcuts to move objects to the front or back. Press **f** (as in “front”) to bring the selected object to the front; press **b** (as in “back”) to move the selected object to the back.
PULLING AN OBJECT FORWARD OR PUSHING IT BACK

The Pull Forward and Push Back choices in the Arrange menu move the selected object one level forward or back in the stack, relative to the object's original position.

To push or pull an object back or forward in a stack (Levels 2–4)

This technique is useful when you cannot see objects in the layers of a stack. You can select an object that is visible and move it back one layer at a time, each time revealing the object that was immediately behind it.

1. Select the object you want to pull forward or push back in the stack. Handles appear around the object.
2. From the Arrange menu, choose either Pull Forward or Push Back. The stack is rearranged accordingly.

HINT

You can use keyboard shortcuts to pull objects forward or push them back. Press **Shift+F** to move the selected object forward one layer; press **Shift+B** to move the selected object back one layer.

WORKING WITH TEXT

You use the Text tool to place text in your drawing, and you use the Text menu to change the way text appears. You can edit and change the attributes of text at any time, even after you have rotated or flipped a text object.

At Level 2, you can change the following text attributes:

- Font
- Size
• Style
• Color
• Alignment

This section explains how to change these text attributes.

**Changing Fonts, Styles, Sizes**

Use the Text menu to choose different fonts, styles, and sizes for the text inside text objects in your drawing. Choices you make from the menu apply only to text you have selected — a text object, several text objects, or some text within a text object. While text fonts, styles, and sizes, are described Chapter 2, a brief explanation is given here to emphasize the concepts as they apply to GeoDraw.

*Fonts* are the different type designs that you can see on the screen and print. GeoDraw provides the standard selection of GEOS fonts shown in the illustration below. The default font is URW Roman. You can preview fonts from the Text menu before you apply font changes to your drawing.

*Style* refers to the way the type in each font appears:

- Plain Type
- **Bold**
- *Italic*
- Underlined
- Strike Thru
- Superscript, or Subscript

You can combine styles to create Plain Type Underlined, **Bold Underlined**, *Italic Underlined*, **Bold Italic**, and **Bold Italic Underlined**, and you can apply Strike Thru, Superscript or Subscript to any of those styles. You can choose to have one word in a text object appear in a different style, or you can choose to change the style of all the text in an object. The default style is Plain Type.

*Size* refers to the height of the type measured in points. There are 72 points to an inch, so 72 point text has capital letters that are one inch high, 36 point text has capital letters that are one-half inch high, and 18 point text is one-quarter inch high. The default type size is 12 point.

You can use the Size menu to change the size of selected text, or text in selected objects. The point sizes available from the menu are: 9, 10, 12, 14, 18, 24, 36, 54, and 72. You can create text in
many other sizes using the Ctrl-drag technique described in Chapter 8 or by using techniques that become available at higher levels.

To change the font, style, or size of text in a drawing (Levels 2–4)

1. To change text within a text object, use the Text tool to select the text you want to change.
   
   or

   To change all the text in a text object, use the pointer to select the text object you want to change.

2. From the Text Menu, choose the font, style, or size you want to apply to the selected text or text object. The selected text is changed accordingly.

Aligning Text

Text alignment refers to how the text lines up with the left and right edges of a text object. You can align text at the left, center, or right of a text object. You can also set text in full alignment (flush left and right as in a newspaper column). When you create a text object, GeoDraw sets the alignment to left, but you can change it to suit your needs.

To change text alignment (Levels 2–4)

1. Select the text object whose alignment you want to change.

2. From the Text menu, choose the alignment you want. The text in the selected object changes alignment.
**Coloring Text**

If you have a color monitor, at Level 2 you can add color to some or all of the text in a text object by choosing Text Color from the Text menu. If you have a color printer, you can print your text in color, too. The Text Color palette consists of the same 16 colors that appear on the Tool Bar.

*To change text color using the color palette (Level 2)*

1. To change text within a text object, use the Text tool to select the text you want to change.

   *or*

   To change all the text in a text object, use the pointer tool to select the text object you want to change.

2. Select the color you want from the color palette on the Tool Bar. The text color changes.

*To change text color using the Text Color choice in the Text menu (Level 2)*

1. To change text within a text object, use the Text tool to select the text you want to change.

   *or*

   To change all the text in a text object, use the pointer tool to select the text object you want to change.

2. Choose Text Color from the Text menu. The following dialog box appears:

   ![Text Color Palette](image)

3. Select the color you want to use by clicking it.

4. Click Apply. The color you selected is applied to the selected text. The dialog box remains open so you can change the color again, or change additional text.

5. When you have finished changing text color, click Close.
You can import graphics into GeoDraw that were created with other drawing applications or are stored in other file formats. You can also export drawings you've created in GeoDraw for use in other applications.

Graphics files are stored as bitmaps. Bitmaps consist of a series of dots that together make up a graphic image. With GeoDraw, you can import and export graphics in the following bitmap formats:

**Bitmap (BMP).** This is the standard "device independent bitmap" format that many Windows, and OS/2 applications can create.

**Clipboard (CLP).** This is the Windows clipboard format for bitmaps.

**Graphics Interchange Format (GIF).** This is a popular file format for bitmap graphics files available through online services like America Online and CompuServe.

**PC Paintbrush (PCX).** This is a popular format for exchanging bitmap graphics between applications.

**Tag Image File Format (TIF).** This is a standard format for storing bitmap graphic images. TIFF files can be used by applications on many different kinds of computers.

*To import a graphics file (All Levels)*

1. Open the GeoDraw document into which you want to import a graphics file.

2. Choose Import Graphic from the File menu. A dialog box appears:

![Import Graphic dialog box](image)

3. Fill in the dialog box, selecting the options you want:

**Select File and Format for Import.** Use the standard file selector controls to select the file you want to import. For more information about file selectors, see Chapter 1.
**Formats.** If you know the format of the file you want to import, you can select it from the Formats list. Then, only files with that extension will be displayed. If you don’t know the format of the file, select No Idea (Auto-Detect) in the Formats box.

**File Mask.** Instead of selecting a format from the Formats list, you can type the file mask directly into this field. For more information about file masks, see Chapter 3.

4. Click Import. The dialog box disappears, and a status box appears while the bitmap is being imported.

GeoDraw places the bitmap file you imported into the center of the window. The colors and resolution of imported bitmaps will depend on the display capabilities of your computer. All the data is imported, even if your computer cannot display it; for example, if the file you imported is a 256-color bitmap, even if your display device (monitor) cannot display 256 colors, the color information is still stored in the file.

You can move and resize an imported image, though when you resize it the image will not respond like a graphic object, but rather like a bitmap object. With bitmap objects, the pixels enlarge and shrink as you resize, and you must edit them with the Bitmap Tools. For more information about working with bitmaps, see Chapter 10.

**To export graphics (All Levels)**

When you export from GeoDraw, you can either export the entire drawing or only selected objects.

1. Open the GeoDraw document from which you want to export.

2. If you want to export only certain objects, select only those objects you want to export. If you want to export the whole drawing, you need not select anything. Handles appear around any selected objects.
3. Choose Export Graphic from the File menu. A dialog box appears:

![Export Graphic dialog box]

4. Fill in the dialog box, changing the options you want:

**Select Folder and Format for Export.** Using the standard file selector controls, open the folder where you want to save the exported file. For more information about file selectors, see Chapter 1.

**Formats.** Choose the format for the exported file in the Formats box.

**New File Name.** Enter a name for the exported file. The correct extension already appears in this box, so you do not need to enter it. Be sure to enter a standard DOS file name no more than eight characters long with an optional three letter extension. For more information about DOS file names, see “Saving Documents” in Chapter 1.

**Bitcount.** This field signifies whether the export file is color or black and white. You can choose from the following options:

- *Monochrome* is for black-and-white images.
- *Four Bit* is for color images with a maximum of 16 colors.
- *Eight Bit* is for color images with a maximum of 256 colors.

The availability of the Bitcount options depends on the capabilities of your workstation. If you do not have a color monitor, you can only choose Monochrome. Even if you do have a color monitor, some of the color options may appear dimmed.

**Export BMP Format.** These options appear only when you select BMP from the Formats list. If you are exporting a bitmap format file, you must indicate the type of application you are
exporting to so that the export file is prepared in a way that the application will be able to read it. You can choose from the following options:

- Choose *OS/2 Device Independent Bitmap* if you plan to use the exported file in an OS/2 application.
- Choose *Windows 2.x Device Dependent Bitmap* if you plan to use the exported file in a Windows application with a version of Microsoft Windows earlier than 3.0.
- Choose *Windows 3.x DIB* if you plan to use the exported file in an application running with Microsoft Windows 3.0 or higher.
- Choose *Windows 3.x DIB RLE Compressed* if you plan to use the exported file with Microsoft Windows 3.0 or higher and you want the file to be Run-Length-Encoded (RLE) compressed.

**Compression.** These options appear only when you select TIFF from the Formats list. You can choose from the following options:

- Choose *Uncompressed* to export without compression.
- Choose *Auto-Compress* to export with compression.

**Export Entire Document.** Select this option to export the entire file.

**Export Selected Objects.** Select this option to export only the objects you have selected in the drawing.

5. Click Export. An export progress box appears as GeoDraw converts the image to a bitmap and saves the file with the name you specified and in the folder you specified.
Intermediate GeoDraw Drawing

This chapter covers GeoDraw features that appear in Level 3. All the features described in Chapters 8 and 9 are still available to you at Level 3.
This chapter describes how to do the following:

• Change the way GeoDraw displays your drawing.
• Create bitmaps that have special graphic properties and tools.
• Change object attributes such as the area fill, gradient fill, line color, background color, and text attributes.
• Convert, transform, duplicate, and move objects.
• Align objects using the rulers, grid, and guidelines.
• Align and distribute objects.
• Work with polygons and stars.

This chapter describes objects in a drawing using the following terms:

• A text object is an object you create using the Text tool on the Graphics Tool Bar.
• A graphic object is any line, rectangle, ellipse, arc, star, or polyline object you create using any of the other tools on the Graphics Tool Bar or the Create option on the Edit menu.
• A bitmap is any object you create using any of the tools on the Bitmap Tool Bar.
• An object is any text object, graphic object, or bitmap in a drawing.

For more information about changing your user level, see Chapter 1.

NOTE

The procedures in this chapter describe how to use the drawing features in GeoDraw. If you’re reading these procedures using another GEOS application, such as GeoWrite, GeoCalc, or GeoFile, the actual steps may vary. Consult the chapters about your application for more information.
What You Get at Level 3

At Level 3, GeoDraw provides additional tools you can use. The following illustration shows the GeoDraw window at Level 3:

You can use the bitmap tools to create and manipulate pixels (dots on the screen) in bitmaps. For more information, see "Working with Bitmaps" in this chapter.

You can use the attribute tools on the Tool Bar to set the area fill, shading percentage, line color, background color, and text attributes of a graphic object (a line, rectangle, rounded rectangle, ellipse, arc, star, or polyline). For more information, see "Setting Attributes" in this chapter.

Level 3 provides features that you can use to change the way your drawing appears on screen, give special visual effects to objects, and align objects to give your drawing balance and proportion.

CONTROLLING YOUR VIEW OF A DRAWING

This section describes advanced methods for changing the visual display of your drawing. It explains how to do the following:

- Reduce or enlarge a drawing.
- Show and hide scroll bars.
• Hide objects or draw their outlines only.
• Change the size of selection handles.
• Apply view changes to all open drawings.

**Zooming by Percentage**

Zooming a drawing changes its display size. Reducing a drawing lets you step back to get a broader perspective of your work. Enlarging a drawing lets you get closer to inspect minute details. At all levels, you can use the Zoom tool and the Zoom Out and Zoom In commands to change the drawing’s display size. For more information about Zoom In and Zoom Out, see Chapter 9. At Levels 3 and 4, you can also zoom using a standard or a custom percentage. This is like using the Zoom tool, but with greater precision.

**USING A STANDARD PERCENTAGE**

You can zoom using a standard percentage. Reducing a drawing by 50%, for example, makes the drawing half its original display size.

*To zoom a drawing by a standard percentage (Levels 3-4)*

1. Choose View at % from the View menu. A submenu appears.
2. Reduce the display size by selecting the percentage you want (25, 50, or 75).
   
   *or*
   
   Enlarge the display size by selecting the percentage you want (125, 150, 175, 200, 300, or 400).
   
   The display changes to show the selected size.

**USING A CUSTOM PERCENTAGE**

In addition to using a standard percentage to reduce or enlarge the display size of your drawing, you can set a custom percentage to scale the drawing to a non-standard size such as 67%.

*To change the display using a custom percentage (Levels 3-4)*

1. Choose View at % from the View menu. A submenu appears.
2. Choose Custom % from the submenu. The following dialog box appears:

![Custom % dialog box]

3. Set the Scale % you want. To reduce a drawing, use a percentage from 12 to 99. To enlarge a drawing, use a percentage from 101 to 400.
4. Click Apply. The display changes using the scale percentage you selected.
5. Click Close to close the dialog box.

**Applying View Changes to Other Windows**

If you are working with multiple drawings at the same time, you can decide whether changing a view option in one drawing will result in the same change in all other open windows. For example, if you have selected Change All Views Together and you then reduce the view percentage in one drawing to 75%, GeoDraw reduces the view percentage in all open GeoDraw windows to 75%.

*To control how views changes are updated (Levels 3-4)*

1. Choose View Options from the View menu. A submenu appears.
2. Select Change All Views Together from the submenu. GeoDraw applies view changes in all open drawing windows.
   or
   Deselect Change All Views Together from the submenu. GeoDraw applies view changes to the current drawing window only.

**Showing and Hiding Scroll Bars**

The drawing area has scroll bars that you can use to scroll the drawing area vertically and horizontally. You can hide the vertical and horizontal scroll bars to increase the size of the drawing area when you do not need to scroll. This might happen when, for example, you zoom out (using the Zoom tool) or change view percentage and can see the entire drawing.
To show or hide the horizontal scroll bar (Levels 3-4)

1. Choose View Options from the View menu. A submenu appears.
2. Select Show Horizontal Scroll Bar from the submenu. GeoDraw displays the horizontal scroll bar.

or

Deselect Show Horizontal Scroll Bar from the submenu. GeoDraw hides the horizontal scroll bar.

To show or hide the vertical scroll bar (Levels 3-4)

1. Choose View Options from the View menu. A submenu appears.
2. Select Show Vertical Scroll Bar from the submenu. GeoDraw displays the vertical scroll bar.

or

Deselect Show Vertical Scroll Bar from the submenu. GeoDraw hides the vertical scroll bar.

Changing How Objects Appear

You can hide an object entirely or display only the rectangular outlines of an object. This makes it possible for GeoDraw to redraw the screen more quickly. It can also make your drawing less cluttered with visual details you do not need to see.

DRAWING OUTLINES ONLY

By drawing only the outlines of objects, you can see and change their size and position without the distraction of graphic details (such as color, shape, patterns, and so on).

To show or hide only the outlines of objects (Levels 3-4)

- Select Draw Outlines Only from the Options menu. GeoDraw displays object outlines.

or

Deselect Draw Outlines Only from the Options menu. GeoDraw shows all the graphic or text details of an object.

WORKING WITH BITMAPS

In GeoDraw, you can use three types of objects to compose a drawing: text objects, draw objects, and bitmap objects. Text
objects contain text and are discussed in Chapter 8. Draw objects are shapes that you create by using the tools discussed in chapters 8 and 9. Bitmap objects are special shapes that you create using the bitmap tools discussed in this section.

A *bitmap* is an object made up of *pixels*, which are individual dots that make up an image, like the dots on a television screen. Bitmaps give you the ability to create freehand images. Because bitmaps have special properties, GeoDraw provides a set of tools you can use to manipulate pixels in a bitmap. The Bitmap tools appear on the right side of the Tool Bar:

Like their counterparts on the Tool Bar, the bitmap Line, Rectangle, and Ellipse tools draw geometric shapes. However, the bitmap tools paint pixels in a bitmap, while the Draw tools create distinct graphic objects. You can change the pixels of a bitmap object, not of a draw object, though you can convert draw objects to bitmap objects. For more information about converting objects, see “Converting Draw and Text Objects to Bitmap” later in this chapter.

This section describes how to use the bitmap tools to manipulate pixels in a bitmap. Once created, you can move, resize, and transform a bitmap as you would any other object in a drawing.

**Creating a Bitmap Frame**

A *bitmap frame* defines the outer bounds of a bitmap. You can create a bitmap frame by using the Frame tool or by drawing a bitmap shape using other bitmap tools. You can use the bitmap
tools to change pixels in the object, and you can manipulate the bitmap like other objects, moving, resizing, or transforming it as desired.

**USING THE FRAME TOOL**

If you know the size of the bitmap you want to create, or if you just want to block out an area of the drawing for the bitmap, you can use the Frame tool to create a rectangular bitmap frame.

Any bitmap operations you perform in the frame are bounded by the frame and become part of it. The frame acts much like a draw object—you can stretch, move, and rotate it. You cannot, however, move or resize individual bitmap items you place in the bitmap frame. Once you place a bitmap item into a frame, it permanently becomes part of that frame, unless you choose Undo from the Edit menu.

*To draw a bitmap frame (Levels 3-4)*

1. Select the Frame tool from the Tool Bar. The pointer changes to crosshairs when you move it over the drawing area.

2. Move the pointer to where you want to anchor the first point of the frame, then click and drag the frame until it becomes the size you want.

3. Release the left mouse button. A frame with a white fill and line color appears, with selection handles:

Drawing a bitmap frame creates the bitmap. You can now change pixels inside the bitmap frame. You can also draw other GeoDraw objects on top of the bitmap; however, they remain separate objects, distinct from the bitmap.

**USING A BITMAP SHAPE TOOL**

You can also create a bitmap frame simply by drawing a bitmap shape (straight line, freehand symbol, rectangle, or ellipse) in a blank part of the drawing area. When you do this, GeoDraw creates a rectangular bitmap frame around the image along its
outermost points; the boundaries of the frame become the boundaries of the bitmap:

![Bitmap Freehand line and Bitmap frame]

**Drawing Bitmap Shapes**

You can use the bitmap tools on to draw the following bitmap shapes:

- Straight lines.
- Rectangles.
- Ellipses.
- Freehand shapes.

When you draw a bitmap shape, you change the pixels that the shape touches. Once you draw a bitmap shape, it becomes part of the bitmap frame. You cannot change a bitmap shape as you would a draw object. For example, you cannot move, resize a bitmap ellipse directly; you can only draw another ellipse in the new location or size you want. For this reason, it’s helpful to choose Undo from the Edit menu to correct any mistakes you make.

You normally select the attributes of a bitmap shape before you draw it, including the color, shading, line weight, and so on. You can also change these attributes after you’ve drawn the shape.

The default background color for a bitmap is white. You can change the background color by drawing a bitmap shape in a different color using one of the bitmap tools. The Attribute tools do not apply to bitmaps.

**NOTE**

Unlike other GeoDraw objects, a bitmap is always opaque and never transparent (unfilled). As a result, if you place a bitmap on top of other objects, you cannot see the underlying objects.
**To draw a straight line (Levels 3-4)**
You can draw a straight line in a bitmap using the Bitmap Line tool.

1. Select the line color, shading, and width you want. To do this, you can use the Line Attributes tools or choose Line Attributes from the Attributes menu. For more information, see "Setting Attributes" in this chapter.

2. Select the Bitmap Line tool from the Tool Bar. The pointer changes to crosshairs when you move it over the drawing area.

3. Move the pointer to where you want to anchor the first point of the line, then click and drag the line to where you want it to end.

4. Release the left mouse button. A straight line appears with the attributes you selected:

    ![Straight line](image)

**Pressing Shift while drawing a line constrains the line to horizontal, vertical, or 45 degrees off of horizontal or vertical.**

---

**To draw a rectangle (Levels 3-4)**
You can draw a rectangle in a bitmap using the Bitmap Rectangle tool.

1. Select the area fill color, shading, and pattern you want. To do this, you can use the Area Attributes tools or choose Area Attributes from the Attributes menu. For more information, see "Setting Attributes" in this chapter.

2. Select the Bitmap Rectangle tool. The pointer changes to crosshairs when you move it over the drawing area.

3. Move the pointer to where you want to anchor one corner of the rectangle, and then click and drag until the rectangle is the size you want.

4. Release the left mouse button. A rectangle appears with the attributes you selected:

    ![Rectangle](image)

**Pressing Shift while drawing a rectangle creates a square.**

---

**To draw an ellipse (Levels 3-4)**
You can draw an ellipse in a bitmap using the Bitmap Ellipse tool.
1. Select the area fill color, shading, and pattern. You can use the Area Attributes tools or choose Area Attributes from the Attributes menu. For more information, see “Setting Attributes” in this chapter.

2. Select the Bitmap Ellipse tool from the Tool Bar. The pointer changes to crosshairs when you move it over the drawing area.

3. Move the pointer to where you want to start the ellipse, and then click and drag until the ellipse is the shape and size you want.

4. Release the left mouse button. An ellipse appears with the attributes you selected:

![Ellipse](image)

To draw a freehand shape (Levels 3-4)

You can draw a freehand shape in a bitmap using the Brush tool on the Tool Bar. It's similar to using a paintbrush to draw strokes over a canvas.

1. Select the line color, shading, and width you want. You can use the Line Attributes tools or choose Line Attributes from the Attributes menu. For more information, see “Setting Attributes” in this chapter.

2. Select the Brush tool from the Bitmap Tool Bar. The pointer changes to crosshairs when you move it over the drawing area.

3. Click once to change one pixel.

or

Move the pointer to where you want to start the freehand shape, press and drag the pointer to draw the shape you want, and then release the left mouse button.

If you draw a shape, it appears with the attributes you selected:

![Freehand Shape](image)
Editing Bitmap Pixels

Once you have created a bitmap, you can use the Bitmap tools to change pixels in the object, erase portions of the image you don't want, and to select all or part of the image for cut, copy, and paste operations.

SELECTING A BITMAP

Whenever you use a bitmap tool in a bitmap, the bitmap becomes the selected object. The frame appears around the bitmap to show you that it's the selected object, as shown in the following illustration:

![Frame around bitmap]

USING THE SELECTION TOOL

You can use the Selection tool to select a rectangular region within a bitmap so that you can perform copy, cut, and paste operations using the pixels in the region. You can select all or part of the object. For more information about clipboard operations, see "Selecting and Editing" in Chapter 2.

To select a region within a bitmap (Levels 3-4)

1. Click the Bitmap Selection tool on the Tool Bar. The pointer changes to crosshairs when you move it over the drawing area.
2. Move the pointer to where you want to anchor one corner of the selection, and then click and drag the mouse until the selection region is the size you want.
3. Release the left mouse button. A rectangular selection region appears, as shown in the following illustration:

![Rectangular selection region]

At this point, you can cut or copy the selected region to the clipboard and, optionally, paste it in a different location in the
bitmap. For more information about copy, cut, and paste operations, see “Selecting and Editing” in Chapter 2.

To select all the pixels in a bitmap (Levels 3-4)

1. Choose the Bitmap Selection Tool from the Tool Bar. Click inside the bitmap. A dotted outline appears indicating that the bitmap is selected.
2. Choose Select All from the Edit menu.
   or
   Press Ctrl + /.
Either way, GeoDraw selects all the pixels in the bitmap.

CHANGING THE FILL COLOR OR FILL PATTERN

You can change the color of a contiguous group of pixels using the Bitmap Fill tool. Unlike the Fill tool for graphic objects, which fills the entire interior of a graphic object, the Bitmap Fill tool fills an enclosed area with the current area fill color. The enclosed area is bounded by pixels of a different color.

To change the pixels in an enclosed area (Levels 3-4)

1. Select the Bitmap Fill tool from the Tool Bar. The pointer changes to a paint can when you move it over the drawing area.
2. Select the fill color and the pattern you want. You can use the Area Fill Color tool or choose Area Attributes from the Attributes menu. For more information, see “Setting Attributes” in this chapter.
3. Click anywhere in the enclosed area. GeoDraw changes all pixels in the enclosed area with the current area fill color.

ERASING IN THE BITMAP FRAME

You can use the Eraser tool to erase all or part of a bitmap. When you use the Eraser tool, GeoDraw changes the color of affected pixels to white. It has the same effect of painting pixels white using a different bitmap tool (such as the Rectangle tool).

HINT

To erase a rectangular region, you can use the Selection tool and the Cut or Delete choices on the Edit menu. For more information, see “Using the Selection Tool” in this section. However, to erase a non-rectangular region, including freehand erasing, use the Eraser tool instead.
To erase pixels in a bitmap frame (Levels 3-4)

1. Select the Eraser tool from the Tool Bar. The pointer changes to a square when you move it over the drawing area.

2. Move the pointer to where you want to start erasing, and then click or drag the pointer over the parts of the image you want to erase.

USING THE PIXEL VIEW TOOL

You can use the Pixel View tool on the Tool Bar to change individual pixels in the Pixel View. The Pixel View tool enlarges your drawing and displays a grid of pixels that you can change individually.

Once an image appears in the Pixel View, you can use any of the bitmap tools to make subtle changes to it, such as "smoothing out" a rough edge or corner. For example, to change the color of individual pixels, you can select a line color, select the Brush tool, and then click the pixels you want to change. Similarly, to change a rectangular region of pixels, you can select a fill color, select the Rectangle tool, and then draw a rectangle over the region of pixels you want to change.

To display the Pixel View (Levels 3-4)

1. Select the Pixel View tool from the Tool Bar. The pointer changes to a magnifying glass when you move it over the drawing area. The Pixel View tool is selected.

2. Move the pointer to where you want to change pixels, and then click. The Pixel View appears:

Each square is a single pixel.

3. Select the bitmap tool you want to use to change pixels.
4. In the Pixel View window, use any of the Bitmap tools to change pixels individually or in groups.

To change the Pixel View area (Levels 3-4)

- Click a pixel in the Pixel View window.

or

Click in the bitmap image outside the Pixel View window.

Either way, the pixel you click becomes the center pixel in the Pixel View window.

Changing the Bitmap Color and Resolution

You can change the color format (monochrome or color) and resolution (the number of dots, or pixels, per inch) of a bitmap.

For example, you might want to change a 16-color image to a monochrome image if your hardware doesn't support color or if you want to reduce the storage and memory size of the image. Similarly, you might want to change a monochrome image to a 16-color image so that you can add colors.

You can also change the resolution of a bitmap. For example, you might want to reduce the resolution from 300 dpi to 72 dpi if your hardware doesn't support 300 dpi or you want to reduce the storage and memory size of the image. Similarly, you might want to increase the resolution from 72 dpi to 300 dpi for greater granularity so that you can edit the pixels at a finer level of detail.

To change the format of a bitmap (Levels 3-4)

1. Select the bitmap you want to format.
2. Choose Bitmap Format from the Attributes menu. A dialog box appears:

![Bitmap Format dialog box](image)

3. Fill in the dialog box, changing the options you want.

**Monochrome or 16-Color.** Select the bitmap format you want.
Resolution. Select the resolution you want (72 dpi, 300 dpi, or Custom).

4. Click Apply to apply your changes.
5. Click Close to close the dialog box.

Converting Draw and Text Objects to a Bitmap

You can convert graphic and text objects to a bitmap so that you can edit individual pixels within the object. Doing so can make it easier to fine tune visual details in your drawing.

When you convert an object or a group of objects to a bitmap, GeoDraw converts the image to a grid of pixels and makes transformations (rotation, skewing, and so on) part of the object.

NOTE
Once you convert to a bitmap, the identity of individual objects is lost. You cannot convert the bitmap back to a graphic or text objects and edit them using the graphics or Text tool. As a bitmap, you can edit individual pixels only. For example, if you converted four rectangles to a bitmap, you could not convert the bitmap back to its four component rectangles and then edit them individually.

To convert objects to a bitmap (Levels 3-4):
1. Select one or more objects that you want to convert. If you select multiple objects, GeoDraw will convert them to a single bitmap.
2. Choose Convert from the Transform menu. A submenu appears.
3. Choose Convert to Bitmap. GeoDraw converts selected objects to a bitmap. You can edit the new bitmap as you would any other bitmap.

SETTING ATTRIBUTES

This section describes how to set the attributes for a graphic object—a line, rectangle, rounded rectangle, ellipse, arc, star, or polyline). At Level 2, you can set the area fill color of an object. At Levels 3 and 4, you can set any of the following graphic attributes:

• Area attributes, such as the fill color, shading, fill pattern, and drawing mode
- Line attributes, such as the border color, line pattern, thickness, style, and arrowheads
- Text attributes, such as the font, size, color, line spacing, paragraph spacing, indents, tabs and borders
- Background color
- Gradient fill
- Arc attributes (for arcs only)
- Default attributes

Color and patterns can add emphasis and appeal to a graphic image. You can define colors and patterns for an object’s area attributes (the fill area inside an object) and its line attributes (the border of an object, or a line object). You can fill the space inside with color or patterns, with a gradient that fades from one color to another, or you can leave it empty (unfilled).

If you have a color monitor, you can see color in objects. If you have a color printer, you can also print in color. If your printer doesn’t support color, you see colors printed as varying shades of gray.

At Level 4, you can use style sheets to make it easier to set attributes for objects and to give your drawings a consistent appearance. For more information, see “Using Graphic Style Sheets” in Chapter 11.

**Using the Attribute Tool Bar**

The attribute bar is located vertically along the left-hand side of your draw window. You can use tools on the Attribute Tool Bar to set the attributes for a graphic object. The following illustration shows the elements of the Attribute Tool Bar:

- Area Fill Color
- Area Shading
- Area Pattern
- Line Color
- Line Shading
- Line Width
- Text Color
- Text Shading
Using these tools, you can change the attributes of selected objects and, if no object is selected, you can set the attributes of future objects you draw.

**Setting Area Attributes**

Area attributes apply to the area inside ellipses, rectangles, rounded rectangles, arcs, and closed polylines. You can set any of the following area attributes:

- Fill color
- Color shading
- Pattern
- Drawing mode

You can set all of these attributes using the Area Attributes choice on the Attributes menu. As a shortcut, you can set many attributes more quickly using the tools on the Attribute Tool Bar.

**USING THE AREA ATTRIBUTES DIALOG BOX**

You can set the area attributes of an object using the options in the Area Attributes dialog box. This section describes each attribute in detail. Once you're familiar with the attributes, you may prefer to use the Attribute Tool Bar.

*To set area attributes for a graphic object (Levels 3-4)*

1. Select one or more graphic objects you want to change.
2. Choose Area Attributes from the Attributes menu. A dialog box appears:

   ![Area Attributes Dialog Box](image)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filled or Unfilled</td>
<td>Sets the Filled or Unfilled state</td>
</tr>
<tr>
<td>Shaded</td>
<td>Sets the Shading state</td>
</tr>
<tr>
<td>Fill Color</td>
<td>Sets the Fill Color</td>
</tr>
<tr>
<td>Color Shading</td>
<td>Sets the Color Shading</td>
</tr>
<tr>
<td>Pattern</td>
<td>Sets the Pattern</td>
</tr>
<tr>
<td>Drawing Mode</td>
<td>Sets the Drawing Mode</td>
</tr>
</tbody>
</table>

3. Fill in the dialog box, changing the attributes you want:

   **Filled or Unfilled.** Select Filled to fill the enclosed area of the graphic object and, optionally, to set other options in this dialog box. By default, the area of the graphic object is unfilled.

   **% Shaded.** Select the percent shading for the fill color. The lower the number, the more faded the color. By default, this
setting is 100. If Unfilled is selected, this attribute is set to zero (0).

**Color Tools.** Select the area fill color from the color palette. You can also fine tune the color blend by setting the amount of red, green, and blue in the area fill color; the default values depend on the selected color.

**Pattern.** Select the fill pattern. By default, this setting is solid. A transparent fill pattern is also available on this palette.

**Draw Mode.** Select the draw mode (Normal, Inverse, AND, XOR, or OR) to set the prevailing display color for overlapping objects. For more information, see “Using Draw Modes” in this section.

4. Click Apply to apply your changes to selected graphic objects. Continue to make changes as desired until you’re satisfied with how the graphic object looks.

5. Click Close to close the dialog box.

**USING THE AREA ATTRIBUTES TOOLS**

You can also use the tools on the Attribute Tool Bar to change the fill color, shading, and fill pattern of an object. For more information about each attribute, see the previous section, “Using the Area Attributes Dialog Box.”

---

**To use the Area Fill Color tool (Levels 3-4)**

1. Select one or more graphic objects you want to fill.
2. Click the Area Fill Color tool. A horizontal pop-up menu appears.
3. Select the color you want. GeoDraw applies the area fill color you selected to the selected graphic objects automatically.

**To use the Area Shading tool (Levels 3-4)**

1. Select one or more graphic objects you want to shade.
2. Click the Area Shading tool. A horizontal pop-up menu appears. The option furthest to the left is 100% shading, while the option furthest to the right is 0%, the same as an unfilled object.
3. Select the shading you want. GeoDraw applies the area shading you selected to the selected graphic objects automatically.

**To use the Area Pattern tool (Levels 3-4)**

1. Select one or more graphic objects you want to fill with a pattern.
2. Click the Area Pattern tool. A horizontal pop-up menu appears.
3. Select the pattern you want. GeoDraw applies the area pattern you selected to the selected graphic objects automatically.

**USING DRAW MODES**

The *draw mode* controls the prevailing display color for overlapping objects. This is an advanced feature that you can experiment with for special graphic effects. You can set the draw mode in the Area Attributes Dialog Box.

For example, suppose you wanted to put the Object A (left) on top of Object B. By setting the draw mode, you could control the colors of the overlapping objects.

*To use the draw modes control (Level 3-4)*

1. Select the objects you want to be affected by a draw mode change.
2. Choose Area Attributes from the Attributes menu.
3. Choose a Draw Mode from the drop down list.
   - Normal displays the top object (including the overlap area) in its original color.
   - Inverse displays the top object in the inverse of the background color and, where they overlap, combines the colors of the bottom object to form a third color.
   - AND displays the top object in its original color and, where they overlap, combines the color of the underlying object to create a third color.
   - XOR combines the original color of the top object with the color of the underlying object or background to create other colors.
   - OR displays the top object only where it overlaps. It displays the overlap area in a different color.

GeoDraw uses the draw mode to calculate, on a pixel-by-pixel basis, the color that appears.

**Setting Line Attributes**

Line attributes apply to line objects, to the lines that make up polyline objects, and to the border lines around ellipses, rectangles, rounded rectangles, and arcs.

Line attributes include:
- Color
- Line width
• Line style
• Arrowhead style and direction

You can set these attributes using the Line Attributes choice on the Attributes menu. You can also set many of them more quickly using the tools on the Attribute Tool Bar.

USING THE LINE ATTRIBUTES DIALOG BOX

You can set the line attributes of an object using the options in the Line Attributes dialog box. This section describes each attribute in detail. Once you’re familiar with the attributes, you may prefer to use the Attribute Tool Bar; for more information, see “Using the Line Attributes Tools” in this section.

To set the line attributes (Levels 3-4)

1. Select one or more graphic objects that you want to change.
2. Choose Line Attributes from the Graphics menu. A dialog box appears:

![Line Attributes dialog box]

3. Fill in the dialog box, changing the attributes you want:

   **Filled or Unfilled.** Select Filled to fill the line or border of the graphic object (which makes it visible) and, optionally, to set other options in this dialog box. Select Unfilled if you want the line or border to be invisible. By default, the line is Filled.

   **% Shaded.** Select the percent shading for the line color. The lower the number, the more faded the color. By default, this setting is 100. A zero (0) setting is the same as an unfilled line or border.

   **Color Tools.** Select the line color from the color palette. You can also fine tune the color blend by setting the amount of red, green, and blue in the line color; default values depend on the selected color.
**Width.** Select the thickness of the border line using a set of standard widths. By default, this setting is one point. You can also fine tune the width by selecting a custom thickness; a setting of zero (0) is the same as a hairline width, which makes it the thinnest line that can appear on your display or that your printer can print.

**Style.** Select the style of the border line. By default, this setting is a solid line.

**Arrowhead.** For lines and unclosed objects such as open polylines and open splines, you can select an arrowhead style. By default, no arrowhead style is selected. You can also select an arrowhead location (at the start or the end of the line).

4. Click Apply to apply your changes to selected graphic objects.
5. Click Close to close the dialog box.

**USING THE LINE ATTRIBUTES TOOLS**

You can use the tools on the Attribute Tool Bar to set or change the line color, shading, and thickness of a line or border.

**To use the Line Color tool (Levels 3-4)**

1. Select one or more graphic objects that you want to change.
2. Click the Line Color tool. A horizontal pop-up menu appears.
3. Select the color you want. GeoDraw applies the line color to the selected graphic objects.

**To use the Line Shading tool (Levels 3-4)**

1. Select one or more graphic objects that you want to shade.
2. Click the Line Shading tool. A horizontal pop-up menu appears. The option furthest to the left is 100% shading, while the option furthest to the right is 0%.
3. Select the shading you want. GeoDraw applies the line shading to the selected graphic objects.

**To use the Line Width tool (Levels 3-4)**

1. Select one or more graphic objects that you want to change.
2. Click the Line Width tool. A horizontal pop-up menu appears.
3. Select the width you want. GeoDraw applies the line width to the selected graphic objects.
Setting Text Attributes

You can format text in a drawing to give it more emphasis, to increase its similarity with other objects, to contrast it with other text objects, and so on. GeoDraw offers many of the same text formatting features available in GeoWrite.

At Level 3, you can set the following text options:

- Fonts
- Sizes
- Styles (plain text, bold, italics, underline, strike through, superscript, and subscript)
- Text color
- Justification

In GeoDraw, these features appear on the Text menu. For more information about each of these features, see Chapter 8 and 9.

NOTE
Although GeoDraw and GeoWrite have similar text attributes, you access them in different ways.

To use the Text Color tool (Levels 3-4)

1. To change text within a text object, use the Text tool to select the text you want to change.

   or

2. Click the Text Color tool. A horizontal pop-up menu appears.

3. Select the color you want. GeoDraw applies the color to the selected text or text objects.

To use the Text Shading tool (Levels 3-4)

1. To change text within a text object, use the Text tool to select the text you want to change.

   or

2. To change all the text in a text object, use the pointer to select one or more text objects you want to change.

3. Click the Text Shading tool. A horizontal pop-up menu appears. The option furthest to the left is 100% shading, while the option furthest to the right is 0%.
3. Select the shading you want. GeoDraw applies the shading to the selected text or text objects.

**Setting the Background Color**

When you apply a pattern or shading to a graphic object, it appears transparent — allowing you to see any graphic objects or text behind it. You can, however, make the object appear completely opaque by turning on the object's background color. The following illustration shows what an object looks like with its background color turned off and turned on:

![No shading](image1)

![No pattern](image2)

![Background color off](image3)

![Pattern fill](image4)

![Background color off](image5)

![Pattern fill](image6)

![Background color on and set to white](image7)

To set the background color (Levels 3-4)

1. Select one or more graphic objects for which you want to change the background color.

2. Choose Background Color from the Attributes menu. A dialog box appears.

3. Fill in the dialog box, changing the attributes you want:

![Dialog box](image8)

- **Color Tools.** Select the background color from the color palette. You can also fine tune the color blend by setting the amount of red, green, and blue in the background color; default values depend on the selected color.

- **Draw Background or Don’t Draw Background.** Select Draw Background if you want GeoDraw to draw the background color. By default, GeoDraw does not, and objects are transparent.
Setting the background color has no effect unless Draw Background is selected.

4. Click Apply to apply your changes to selected objects.
5. Click Close to close the dialog box.

Setting the Gradient Fill

A gradient fill is a type of area fill that gradually fades from one color to another. A gradient fill can give graphic objects a more three-dimensional appearance and can be a visually appealing background for other objects.

You specify a starting color, an ending color, and the number of times (intervals) the color changes between the starting and ending points. You also select one of the following types of gradient fill:

- A horizontal gradient goes from left to right, beginning with the start color on the left edge of the graphic object and ending with the end color on the right edge.
- A vertical gradient goes from top to bottom, beginning with the start color on the top edge of the graphic object and ending with the end color on the bottom edge.
- A rectangular gradient goes in an angular pattern from the outside edge of the graphic object to its center, beginning with the start color on the outside edge and ending with the end color at the center.
- A radial gradient goes in an elliptical pattern from the outside edge of the graphic object to its center, beginning with the start color on the outside edge and ending with the end color at the center.

To set the gradient fill for an object (Levels 3-4)

1. Select one or more graphic objects that you want to fill.
2. Choose Gradient Fill from the Attributes menu. A dialog box appears:

![Gradient Fill dialog box]

3. Fill in the dialog box, changing the attributes you want:

   **Color Tools.** Select the start and end colors for the gradient fill from the color palette. You can also fine-tune the color blend by setting the amount of red, green, and blue in the start and end colors; default values depend on the selected color.

   **Gradient Fill Type.** Select the type of gradient fill (vertical, horizontal, rectangular, and radial).

   **Number of Intervals.** Select the number of changes in color (gradations) from start to end. Some video hardware and printers may be unable to reproduce finer gradations (a higher number of intervals).

4. Click Apply to apply your changes.
5. Click Close to close the dialog box.

*To remove a gradient fill from an object (Levels 3-4)*

1. Select one or more graphic objects that you want to change.
2. Choose Gradient Fill from the Attributes menu. A dialog box appears.
3. Click the selected gradient type to deselect it.
4. Click Apply to apply your changes. GeoDraw removes the gradient fill.
5. Click Close to close the dialog box.
**Changing Arc Attributes**

An arc is a portion of an ellipse. Since a full ellipse is 360 degrees around, a 90 degree arc is exactly one quarter of an ellipse; a 180 degree arc is half of an ellipse.

You can set the precise size (in degrees) of the starting angle and ending angle of any arc. You can also specify whether you would like your arc’s end points connected by radii or by a chord. The following illustration shows angle conventions used in GeoDraw and what radii and a chord connected arcs look like.

*To change the arc attributes (Levels 3-4)*

1. Select one or more arcs that you want to change.
2. Choose Arcs from the Attributes menu. A dialog box appears:

   ![Arcs Dialog Box]

3. Fill in the dialog box, changing the options you want.
   
   **Starting Angle.** Select the ending angle. You can specify from zero (0) to 360 degrees, inclusive.
   
   **Ending Angle.** Select the ending angle. You can specify from zero (0) to 360 degrees, inclusive.
   
   **End Points Connected.** Select whether you want the end points connected by a chord or two radii.

4. Click Apply to apply your changes.
5. Click Close to close the dialog box.

**Setting Default Attributes**

The *default attributes* are the area, line, and other attributes that GeoDraw automatically uses when you create a new graphic object.

When you draw multiple objects with similar attributes, you can save time by formatting the first object, then saving its attributes as the default attributes. GeoDraw applies the default attributes to any new objects you create.
For example, if you want to draw four red squares with blue borders, you can simply draw the first square, give it a red fill color and blue line color, set default attributes, then draw the other three squares (which will automatically have the same formatting).

You can use the tools on the Attribute Tool Bar to specify default attributes even if no object is selected. For example, you could select a line color from the Line Color tool and GeoDraw will apply it to any new objects you create.

Default attributes apply regardless of the shape you draw. For example, after drawing the four squares in the previous example, you could continue drawing squares, ellipses, arcs, and polylines with a red fill color and blue border.

*To change the default attributes (Levels 3-4)*

1. Select an object that has the attributes you want to use for the default attributes.
2. Choose Set Default Attributes from the Attributes menu. GeoDraw saves the new attributes of the selected object as the default.

You can change the default attributes as often as you like.

**MANIPULATING OBJECTS**

*Levels 3-4*

This section describes GeoDraw’s advanced features for manipulating objects. You can do the following:

- Convert objects to and from a graphic.
- Scale objects to stretch or shrink their dimensions.
- Rotate objects at an angle.
- Skew objects to make them slant vertically or horizontally.
- Duplicate objects to make copies.
- Move objects in a precise manner.

These operations apply to any of the following objects:

- Draw objects—lines, rectangles, rounded rectangles, ellipses, arcs, and polylines
- Text objects
- Bitmaps
Converting to a Graphic

At Level 2, you can group objects together so that you can manipulate them as you would a single object. At Levels 3 and 4, you can convert an object to a graphic, which has the same effect as grouping a single object. Like ungrouping, you can convert the single object back to its component objects.

This feature is helpful when you want to manipulate a text object like a graphic object to create special visual effects. For example, you could convert a text object with your name to a graphic, then resize and skew the text, as shown in the following illustration:

**Jane Smith** — Before

**Jane Smith** — After

You can also use this feature to save any transformations (skewing, rotating, scaling, and so on) for a single object. That way, you can protect against losing these transformations should you later untransform the object. For more information, see “Untransforming Objects” in this chapter.

*To convert objects to a graphic object (Levels 3-4)*

1. Select one or more objects that you want to convert.
2. Choose Convert from the Transform menu. A submenu appears.
3. Choose Convert to Graphic. GeoDraw converts selected objects to a single object.

*To convert from a graphic (Levels 3-4)*

You can reverse this conversion process to break a single graphic object down to its component parts so that you can edit them individually.

1. Select one or more graphic objects which you want to convert from graphic.
2. Choose Convert from the Transform menu. A submenu appears.
3. Choose Convert from Graphic. GeoDraw converts the selected graphic to its component objects.
Transforming Objects

You can transform an object to give it special visual effects such as scaling, skewing (slanting), and rotating. You can also undo any transformation you make.

SCALING OBJECTS

You can scale an object to resize an object in a precise manner, shrinking or stretching its dimensions as desired. You can scale its vertical and horizontal dimensions independently or together.

For example, suppose you had a rectangle that is two inches long and one inch wide. You could make the rectangle half as long by changing its width to a 50% scale. You could make it twice as tall by changing its height to a 200% scale.

You can use scaling to elongate or shorten a text object without first converting it to a graphic.

To change the scale using standard scale sizes (Levels 3-4)

1. Select one or more objects that you want to scale.
2. Choose Scale from the Transform menu. A submenu appears.
3. Select Half Width, Half Height, Double-Width, or Double-Height from the submenu. GeoDraw redraws selected objects using the scale setting you chose.

To change the scale using a custom scale size (Levels 3-4)

1. Select one or more objects that you want to scale.
2. Choose Scale from the Transform menu. A submenu appears.
3. Choose Custom Scale. A dialog box appears:

4. Fill in the dialog box, changing the options you want.

**Width.** Select the custom scale percentage to increase or decrease the width. You can change the width of an object from 1 to 1000 percent.

**Height.** Select the custom scale percentage to increase or decrease the height. You can change the height of an object from 1 to 1000 percent.
5. Click Scale to apply your changes. GeoDraw redraws selected objects using the custom scale settings you specified.

You can click Scale repeatedly, if you want, to apply different scaling percentages until you achieve the desired effect. For example, if you are trying to scale a rectangle between two other objects, you might need to apply scaling several times to get the exact size and shape you want.

6. Click Close to close the dialog box.

**ROTATING OBJECTS**

*Rotating* an object involves turning it in a clockwise or counterclockwise direction around its center. You can rotate objects at Level 2 using the Rotate tool, as described in Chapter 9. At Levels 3 and 4, however, you can also choose a standard or a custom rotation angle for an object.

*To rotate objects using standard rotation (Levels 3-4)*

1. Select one or more objects that you want to rotate.
2. Choose Rotate from the Transform menu. A submenu appears.
3. Choose the rotation you want from the submenu. GeoDraw rotates the object around its center point; if you selected multiple objects, GeoDraw rotates each around its center point.

*To rotate objects using custom rotation (Levels 3-4)*

1. Select one or more objects that you want to rotate.
2. Choose Rotate from the Transform menu. A submenu appears.
3. Choose Custom Rotate from the submenu. The following dialog box appears:

4. Select the rotation angle you want. You can set rotation from minus 359 to 359 degrees.
5. Click Rotate. GeoDraw rotates the object around its center point; if you selected multiple objects, GeoDraw rotates each object around its center point. You can continue to click Rotate to rotate the object repeatedly until you achieve the visual effect you want.
6. Click Close to close the dialog box.
SKewing objects

You can skew an object to make it slant horizontally or vertically at a precise angle.

- Not skewed
- Skewed 45 degrees left
- Skewed 45 degrees right
- Skewed 45 degrees upward
- Skewed 45 degrees downward

You can choose a standard skew angle of 45 degrees or you can specify a custom angle.

To skew objects using standard settings (Levels 3-4)
1. Select one or more objects that you want to skew.
2. Choose Skew from the Transform menu. A submenu appears.
3. Select the skew angle you want. GeoDraw skews selected objects using the skew angle you chose.

To skew graphic objects using custom settings (Levels 3-4)
1. Select one or more objects that you want to skew.
2. Choose Skew from the Transform menu. A submenu appears.
3. Choose Custom Skew from the submenu. A dialog box appears.
4. Fill in the dialog box, changing the options you want:
**Horizontal.** Select the degrees to skew the selected objects horizontally. A positive value skews the object to the left, and a negative value skews it to the right. You can set skew angles from minus 89 to 89 degrees.

**Vertical.** Select the skew degrees to skew the selected objects vertically. A positive value skews the object upwards, and a negative value skews it downwards. You can set skew angles from minus 89 to 89 degrees.

5. Click Skew. GeoDraw redraws the selected objects using the skew settings you specified. You can continue to click Skew to apply the skewing repeatedly until you achieve the result you want.

6. Click Close to close the dialog box.

**UNTRANSFORMING OBJECTS**

You can remove any skewing, scaling, or rotations you've made to an object and revert to its original drawn state. You might want to do this, for example, if you were experimenting with different transformations and wanted to reverse everything you've done, return to the object's original state, and start over.

**NOTE**

Untransforming removes all transformations you have applied to an object. To abandon individual transformations, choose Undo from the Edit menu or transform the object in reverse.

*To untransform an object (Levels 3-4)*

1. Select one or more objects that you want to untransform.

2. Choose Untransform from the Transform menu. GeoDraw redraws selected objects removing all transformations.

**Duplicating Objects**

Duplicating an object makes a copy of it. At Levels 1 and 2, you can make a single duplicate of one or more objects; for information about this basic duplication technique, see Chapter 8. At Levels 3 and 4, you can also duplicate objects in place and perform multiple and custom duplicating operations.

**Duplicating In Place**

Unlike the regular duplicate operation, duplicating an object in place creates a copy of any selected objects and places the copy directly on top of the original(s). You can use this feature to
create special graphic effects, moving, rotating, or flipping the duplicate while retaining its size or relative position.
For example, suppose you wanted to rotate a series of ellipses around the same center point:

To create this illustration, you would draw the first ellipse, duplicate it in place, then rotate the duplicate by 60 degrees. Next, you'd repeat the process with the second ellipse.

*To duplicate a selected object in place (Levels 3-4)*

1. Select one or more objects you want to duplicate.
2. Choose Duplicate from the Edit menu. A submenu appears.
3. Choose Duplicate in Place from the submenu. GeoDraw duplicates selected objects, placing any duplicates immediately above the original.

**MULTIPLE DUPLICATING**

With multiple duplicating, you can duplicate an object with more options. You can specify the number of duplicates, move the duplicates vertically and horizontally, and rotate the duplicates automatically.
To multiple duplicate an object (Levels 3-4)

1. Select one or more objects that you want to duplicate.
2. Choose Duplicate from the Edit menu. A submenu appears.
3. Choose Multi-Duplicate. A dialog box appears:

4. Fill in the dialog box, changing the options you want:
   - **# of Duplicates**. Select the number of duplicates you want to make of the original.
   - **Rotate**. Select the number of degrees by which you want to incrementally rotate each duplicate.
   - **Move**. Select the vertical and horizontal distance by which you want to incrementally move each duplicate.
5. Click Duplicate. GeoDraw duplicates selected objects using the options you specified.
6. Click Close to close the dialog box.

Custom Moving Objects

At Levels 1 and 2, you can move objects using the mouse. At Levels 3 and 4, you can move objects vertically and horizontally using precise distances. For more information about moving objects, see Chapter 7.

To custom move objects (Levels 3-4)

1. Select one or more objects that you want to move.
2. Choose Move from the Arrange menu. A submenu appears.
3. Choose Custom Move from the submenu. A dialog box appears.
4. Fill in the dialog box, changing the options you want:

![Custom Move dialog box]

**Horizontal.** Select the horizontal distance you want to move. A negative number moves selected objects to the left, while a positive number moves selected objects to the right.

**Vertical.** Select the vertical distance you want to move. A negative number moves selected objects upward, while a positive number moves selected objects downward.

**Units.** Select the measurement units you want to use (Inches, Centimeters, Points, or Picas).

5. Click Move to apply your changes.
6. Click Close to close the dialog box.

**USING RULERS, GRIDS, AND GUIDES**

**Levels 3-4**

This section describes how to use rulers, grids, and guides to align objects in a drawing.

You can align objects so that their top, bottom, right, or left edges fall along the same line.

- ![Aligned vertically]
- ![Aligned horizontally]
- ![Not aligned]

**Using Rulers**

The **rulers** helps you precisely measure the vertical or horizontal distance between objects or between an object and the boundaries of the drawing area. Rulers help you position, align,
and resize objects. You can display rulers along the left and top borders of the drawing area.

SHOWING AND HIDING RULERS
You can display rulers to help you draw objects, or you can hide them to give you more drawing space. By default, GeoDraw displays rulers. At Levels 3 and 4, you can hide the vertical ruler, the horizontal ruler, or both.

To show or hide rulers (Levels 3-4)
1. Choose Rulers from the Options menu. A submenu appears.
2. Select the ruler you want to display (vertical or horizontal).
   or
   Deselect the ruler you want to hide.

CHANGING MEASUREMENT UNITS
You can change the units of measure (or increments) that the ruler displays. The ruler can appear using any of the following measurement systems:
- Inches
- Centimeters
- Points (each point is approximately 1/72 of an inch)
- Picas (twelve points or 1/6 of an inch) or the
- System default (inches or centimeters)
You can change the system default by changing the Measurement System in the International options of Preferences; for more information, see Chapter 3 in The GEOS Environment & Accessories.
To change the units of measure (Levels 3-4)

1. Choose Rulers from the Options menu. A submenu appears.
2. Select Inches, Centimeters, Points, Picas, or System Default from the submenu. GeoDraw changes the ruler to the measurement units you selected.

**Using Grids and Guidelines**

At Levels 1 and 2, you use the mouse to lay out and align objects in a drawing. At Levels 3 and 4, it's easier and more precise to let GeoDraw help you. GeoDraw can position objects using the grid and guidelines, snapping objects into place for you automatically.

**USING A GRID**

The *grid* is a pattern of evenly-spaced vertical and horizontal lines that help you align and size objects in a drawing:

The grid helps you set objects in the basic positions where you want them, relative to each other. Guidelines give you more precise control; for more information, see “Using Guidelines” in this section.
GeoDraw can align objects to the grid even if the grid is hidden.

To show or hide the grid (Levels 3-4)

You can control whether the grid appears on screen or is hidden from view. Displaying the grid can make it easier to see where you want to put objects.

1. Choose Grids from the Options menu. The following dialog box appears:

![Grids dialog box](image)

If the Snap to Grid and Guidelines option is selected, GeoDraw aligns objects to the grid and guidelines automatically. For more information, see “Snapping Objects to the Grid or Guidelines,” in this section.

2. Select Show Grid to display the grid.
   or
   Deselect Show Grid to hide the grid.

3. Click Apply. GeoDraw applies your changes.

4. Click Close to close the dialog box.

To set the grid spacing (Levels 3-4)

You can also set the distance between grid lines. Decreasing the size increments gives you finer control when you snap objects to the grid.

1. Choose Grids from the Options menu. The following dialog box appears:

![Grids dialog box](image)
You can set the grid spacing from zero to 455 inches.

2. Select the units of measure (Inches, Centimeters, Points, or Picas) if you want. By default, the units of measure is the same as the ruler setting.

3. Select the distance between grid lines.

4. Click Apply to apply your changes. GeoDraw changes the grid spacing to the setting you specified.

5. Click Close to close the dialog box.

**USING GUIDELINES**

A **guideline** is a single vertical or horizontal line that you can use to align objects in a drawing. You can have multiple vertical or horizontal guidelines. You can align objects to guidelines like you can for grid lines.

Guidelines help you manually align objects along single vertical or horizontal lines.

Unlike the grid, which automatically covers the drawing area, guidelines appear only where you place them. Use guidelines instead of grids when you want to align objects along a precise vertical or horizontal position. You can use guidelines in combination with grid lines or with grid lines hidden. For more information about grids, see “Using a Grid” in this section.

You can combine vertical and horizontal guideline lines to create corners to which GeoDraw can snap objects.

If Snap to Grid and Guides is selected, GeoDraw “snaps” and aligns objects to guidelines just as it does to grid lines. For more information, see “Snapping Objects to the Grid and Guidelines” in this section.
To create or change a guideline (Levels 3-4)

1. Choose Guides from the Options menu. A dialog box appears:

![Guides dialog box]

2. Fill in the dialog box, changing the options you want:

   **Vertical Guidelines or Horizontal Guidelines.** Select the type of guideline you want to create.

   **Guidelines.** Select <<Create New Guideline>> in the Guidelines list to create a new guideline, or select the guideline you want to change from the Guidelines list.

   **Guide Position.** Select the position you want. For a vertical guide, this sets the distance from the left edge of the drawing area. For a horizontal guide, this sets the distance from the top edge of the drawing area.

3. Click Apply to apply your changes. GeoDraw creates the new guideline in the position you specified, or changes the position of the guideline you selected.

4. Click Close to close the dialog box.

To delete a guideline (Levels 3-4)

1. Choose Guides from the Options menu. A dialog box appears:
2. Fill in the dialog box, changing the options you want:

**Vertical Guidelines or Horizontal Guidelines.** Select the type of guideline you want to delete.

**Guidelines.** Select the guideline you want to delete in the Guidelines list.

3. Click Delete Guide. GeoDraw deletes the guideline you selected.

4. Click Close to close the dialog box.

**SNAPPING OBJECTS TO THE GRID AND GUIDELINES**

GeoDraw includes a feature that automatically snaps (or positions) objects along grid lines and guidelines when you create them. If you activate this feature, when you draw or resize a graphic object, GeoDraw automatically snaps the corners of the object to the closest intersection of the grid lines.

Snapping objects to the grid and guidelines is often faster and more accurate than positioning them manually with the mouse. If you create an object while the snapping feature is inactive, you can still align it to the grid or guidelines; for more information, see “Aligning Objects to the Grid and Guidelines” in this section.

When you move an object, GeoDraw keeps its former distance from grid lines or guidelines. For example, if an ellipse starts 1/4 inch from a vertical grid line and you move it horizontally, GeoDraw puts it 1/4 inch from the closest vertical grid line in its new location, as shown in the following illustration:

```
Grid lines

New position, also 1/4" from grid lines

Previous position, 1/4" from grid lines
```

*To snap objects to the grid or guidelines (Levels 3-4)*

1. Choose Grids from the Options menu. A dialog box appears.
2. Select Snap to Grids and Guides.
3. Click Apply to apply your changes. While Snap to Grids and Guides is selected, GeoDraw will snap corners to grids and guidelines when you draw, move, or resize an object.

4. Click Close to close the dialog box.

ALIGNING OBJECTS TO THE GRID AND GUIDELINES
You can arrange objects so that they line up along grid lines, grid corners, and guidelines. You might want to do this, for example, to align objects created while snapping was turned off. Aligning works whether snapping is turned on or off. You can do this manually by moving objects in the drawing area, but it is easier and more accurate to let GeoDraw do it for you.

To align objects to the grid and guidelines (Levels 3-4)
1. Select one or more objects that you want to align to the grid.
2. Choose Align to Grid from the Arrange menu. A dialog box appears:

3. Click the alignment arrow you want:
GeoDraw moves selected objects to the nearest grid line in the direction of the arrow you click. For example, if you click the upper-left arrow, GeoDraw moves the upper-left corner of selected objects to the nearest grid corner.

4. You can change the alignment again by clicking another arrow.
   or
   Click Close to close the dialog box.

ALIGNING AND DISTRIBUTING OBJECTS

In GeoDraw, sometimes you want objects to line with respect to each other. Say you want a circle and a square centered on each
other, or you want three circles to line up with their left sides on the same vertical line. This is called **aligning** objects. The following illustration shows some objects before they are aligned, and after they are aligned in different ways:

Objects not aligned  |  Left aligned  |  Center aligned  |  Right aligned

You can also **distribute** objects so that they are equally spaced from each other. There are as many ways to distribute objects as there are to align them. The following illustration shows some objects before they are distributed, and after they are distributed along their top edges:

**To align objects to each other (Levels 3-4)**

1. Select two or more objects you want to align.
2. Choose Align/Distribute from the Arrange menu. A dialog box appears:

3. Click the alignment button you want:

Vertical alignment buttons

Horizontal alignment buttons

4. Click Apply to apply your changes.
5. Click Close to close the dialog box.

To distribute objects (Levels 3-4)

1. Select three or more objects you want to distribute.
2. Choose Align/Distribute from the Arrange menu. A dialog box appears.
3. Click the distribution button you want:

Horizontal distribute buttons

- Distribute Left
- Distribute Center
- Distribute Right
- Distribute Distance Between

Vertical distribute buttons

- Distribute Spaces Between
- Distribute Bottom
- Distribute Center
- Distribute Top

4. Click Apply to apply your changes.

5. Click Close to close the dialog box.

DESIGNING POLYGONS AND STARS

At Levels 3 and 4, the Polygons and Stars choices on the Create submenu present some additional features in their respective dialog boxes. You can create polygons or stars with up to 100 sides or points each, as described in Chapter 9, and at the higher user levels you can create these objects in a variety of sizes as well. This section explains how to use these dialog boxes at Levels 3 and 4.

Designing Polygons

When you create a polygon, you can specify the number of sides and the object's horizontal radius and vertical radius in points. The radii for a polygon represent the horizontal and vertical radii of an ellipse in which the polygon can be inscribed.
To create a polygon (Levels 3–4)

1. Choose Polygons from the Create submenu on the Edit menu. A dialog box appears:

![Polygon dialog box](image)

2. Fill in the dialog box, changing the options you want.

**Number of Polygon Sides.** Select the number of sides you want your polygon to have. The default is 5 sides.

**Polygon Radius.** Select the polygon’s horizontal radius and vertical radius. The default is 100 (about 1.4 inches); the minimum size is 1 point (1/72 of an inch), and the maximum size is 576 points (8 inches).

3. Click Create Polygon. GeoDraw places the polygon in the drawing area.

4. Click Close. The dialog box disappears.

**Designing Stars**

When creating stars, you can specify the number of star points, and the width and height of the object in points.

To create a star (Levels 3–4)

1. Choose Stars from the Create submenu on the Edit menu. A dialog box appears:

![Star dialog box](image)
2. Fill in the dialog box, changing the options you want.

**Number of Star Points.** Select the number of points you want your star to have. The default is 5 points; the maximum number is 100. Star points are the points of the star, not the point increments of measure that you use to specify width and height.

**Star’s Outer Radius.** The outer radii of the star represent the radii of an ellipse that touches each of the star’s points. The star’s horizontal radius (left box) and vertical radius (right box) are measured in point increments. The default is 100 (about 1.4 inches); the minimum size is 1 point (1/72 of an inch), and the maximum size is 288 points (4 inches).

**Star’s Inner Radius.** The inner radii of the star represent the radii of an ellipse that touches each of the star’s inverted angles. The left box specifies the horizontal measure, and the right box specifies the vertical measure, in point increments. The default is 40 points (about 0.56 inches); the minimum size is 1 point (about 1/72 of an inch), and the maximum size is 288 points (4 inches).

3. Click Create Star. GeoDraw places the star in the drawing area.
4. Click Close. The dialog box disappears.
Advanced GeoDraw Drawing  Level 4 is the most advanced Level of GeoDraw with Features that allow you to do professional-level drawing. Try paste one object inside another for professional masking effects. You can use advanced viewing options to hide objects and change the size of selection handles.
This chapter explains Level 4 features and describes how to do the following:

- Use the Floating Tool Box to manipulate objects.
- Use the Spline tool to create and edit polylines.
- Use graphic and text styles to save formatting time and to give your drawings a consistent look.
- Use extended attributes to keep some objects from printing or lock them against changes.
- Fine tune your user level.
- Keyboard Shortcuts you can use at all levels

For more information about changing your user level, see Chapter 1.

**What You Get at Level 4**

The following illustration shows the GeoDraw window at Level 4:

![GeoDraw window at Level 4](image)

At Level 4, you get the Clipboard Tool Bar and the Spline tool on the Graphics Tool Bar. The Clipboard Tool Bar provides buttons that have the same functions as choices on the Edit menu. You can use the clipboard tools for editing operations. For more information about standard choices on the Edit menu, see "Selecting and Editing" in Chapter 2.
The following illustration shows the Clipboard Tool Bar:

You use the Spline tool (pictured at left) to edit curved polyline objects with precise detail. For more information, see “Using the Spline Tool to Create and Edit Polylines” in this chapter.

In addition, you can use graphic and text style sheets to format graphic and text objects, respectively. For more information, see “Using Graphic Style Sheets” in this chapter and Chapter 5.
USING THE FLOATING TOOL BOX

The Floating Tool Box contains tools for manipulating objects. These tools are all mouse shortcuts for menu commands.

- Flip Left to Right
- Flip Top to Bottom
- Bring to Front
- Send to Back
- Push Forward
- Push Back
- Group
- Ungroup
- Duplicate
- Duplicate in Place
- Paste Inside
- Break Out Paste Inside

For more information about duplicating, flipping, shuffling, grouping, and ungrouping objects, see Chapter 9.
For more information about pasting inside, see “Pasting an Object Inside Another” in this chapter.

To display the Floating Tool Box (Level 4)
- Choose Floating Tool Box from the Options menu.

To move the Floating Tool Box (Level 4)
- Drag the title bar until the Floating Tool Box appears where you want it.

To close the Floating Tool Box (Level 4)
- Double-click the window control button on the Floating Tool Box.
Level 4 offers you two additional ways to change the view of your drawing: hiding objects and changing the size of selection handles. Both can make it easier for you to see objects on your screen that otherwise might be obscured by other objects.

**Hiding and Showing Objects**

You can select the objects you want to work with and then hide all other objects in the drawing. This feature is helpful if you are working on subtle details in a complex drawing and you want to focus on the area you're changing while ignoring everything else. Hiding an object merely conceals it from view; it does not change its size, position, or other attributes in any way.

*To hide unselected objects (Level 4)*

1. Select one or more objects that you want to remain visible.
2. Choose Hide from the Edit menu. A submenu appears.
3. Choose Hide Unselected Objects from the submenu. GeoDraw hides all objects that are not selected.

*To show hidden objects (Level 4)*

1. Choose Hide from the Edit menu. A submenu appears.
2. Choose Show Hidden Objects. GeoDraw displays all hidden objects.
Changing the Size of Selection Handles

You can increase the size of selection handles to make them easier to see and grab with your mouse. You can reduce their size so that they cover less of the drawing area, or you can make them disappear if you don’t want to see them.

- Small handles
- Medium handles
- Large handles
- Invisible handles

To change the display size of selection handles (Level 4)

1. Choose Handles from the Options menu. A submenu appears.
2. Choose Small, Medium, Large, or Invisible Handles from the submenu. GeoDraw changes selection handles to the size you selected.

ADVANCED DUPLICATING

At Level 4, you can automatically scale and skew objects when you duplicate them.

To custom duplicate an object (Level 4)

1. Select one or more objects that you want to custom duplicate.
2. Choose Duplicate from the Edit menu. A submenu appears.
3. Choose Custom Duplicate. A dialog box appears:

4. Fill in the dialog box, changing the options you want:

   **# of Duplicates.** Select the number of duplicates you want to make of the original.

   **Rotate.** Select the number of degrees by which you want to incrementally rotate each duplicate.

   **Scale.** Select the scale percentage by which you want to incrementally resize each duplicate.

   **Move.** Select the vertical and horizontal distance by which you want to incrementally move each duplicate.

   **Skew.** Select the number of left/right and upward/downward degrees by which you want to skew each duplicate.

5. Click Duplicate. GeoDraw duplicates the selected objects using the options you specified.

6. Click Close to close the dialog box.

**PASTING AN OBJECT INSIDE ANOTHER**

**LEVEL 4**

At Level 4, you can paste one object inside another to produce creative visual effects:
**Pasting Inside**

When you paste an object inside another object, GeoDraw combines them into a single object that you can manipulate as you would any other GeoDraw object. You can use this feature just as an airbrush artist would use a stencil overlay on an image.

The outside object is called the *container object* and the inside object is called the *interior object*. The boundaries of the container object become the boundaries of the interior object. The following procedure will use a progressive example that shows how you can paste one object inside another.

![Diagram](image)

**To paste inside (Level 4)**

1. Place the interior object over the container object. Position the interior object in relation to where you want it inside the container object, as shown in the following example:

![Diagram](image)

If the two objects do not overlap, you cannot paste inside.

**NOTE**

Be sure to position the interior object as close as possible to where you want it. You can fine tune it later, nudging it one pixel at a time, but you can save time by setting the precise position in this step.

2. Select the interior object.

3. Click the Cut icon.
   
   *or*
   
   Choose Cut from the Edit menu.
Either way, GeoDraw places the object on the clipboard.

4. Select the container object.

6. Choose Paste Inside. GeoDraw pastes the interior object inside the container object:

Nudging Inside
Once you have pasted an object inside another, you can fine tune the position of the interior object by moving it one pixel at a time.

To nudge inside (Level 4)

1. Select the object that contains the object or objects you want to nudge inside.
2. Choose Paste Inside from the Edit menu. A submenu appears.
4. Select Left, Right, Up, or Down. GeoDraw nudges the interior object one pixel in the direction you selected.

Breaking Out Paste Inside
Once you have pasted one object inside another, you can break the object into its component objects using the Break Out Paste Inside command. That way, you can manipulate the individual objects rather than as a group.

To break out paste inside (Level 4)

1. Select the object you want to break out.
2. Choose Paste Inside from the Edit menu. A submenu appears.

**USING THE SPLINE TOOL TO CREATE AND EDIT POLYLINES**

At Level 4, the Spline tool appears on the Tool Bar. The Spline Tool lets you create edit polylines with much more precision and control than the Polyline and Rounded Polyline tools. You should be familiar with basic polyline techniques before you attempt to master the Spline tool. For more information about polylines, see Chapter 9.

In lower user levels, polylines are comprised of segments and endpoints, called anchor points. Actually, the curves are more complicated than that—you just see the simplified version at lower user levels. At Level 4, you can see all the elements of a polyline. The following illustration shows the elements of a polyline that you can see at Level 4:

**Segments.** A *segment* is one of the lines or curves that make up a polyline.

**Anchor points.** An *anchor point* defines the end of a segment. An anchor point can fall between two straight segments; two curved segments; or a straight and a curved segment.

**End Points.** End points are simply the first and last anchor points for an open polyline. Closed polylines do not have end points.

**Control points.** *Control points* are handles that you use to change the curvature of a curved segments. To see the control...
points for a segment, select the Spline tool and click on a curved segment. The control points you see govern the shape of the selected segment and the segments next to it.

**Tangent lines.** A *tangent line* is the line that connects an anchor point and its control points. It runs tangent to the curve at the anchor point.

When working with polylines at Levels 2 and 3, you don't see the control points or their tangents. When you use the Spline tool at Level 4, however, you can see and separately manipulate the control points and tangents.

**Creating a Polyline With the Spline Tool**

Drawing a polyline with the Spline tool can seem unfamiliar at first. It takes practice to learn to handle the Spline tool effectively. The following procedures give you the basic steps, but you might want to experiment on your own to perfect your technique. If you prefer, you can use the Rounded Polyline tool to create a polyline, and then use the Spline tool to edit it.

*To draw a polyline with the Spline tool (Level 4)*

1. Select the Spline tool. The pointer becomes crosshairs when you move it over the drawing area.
2. Click where you want to start the first segment of the polyline. A circle surrounds this first anchor point, which is one of the end points of the object.
3. Position the pointer where you want to end the segment. A dotted rectangular outline surrounds the object.
4. Click to create a corner anchor point.

*or*
If you do not hold down the mouse button, you will draw a straight line segment instead of a curve.

Press the left mouse button and drag to create a curved anchor point. As you drag, a tangent line appears in the direction you're dragging, as shown in the following illustration and the first segment appears:

5. If you dragged in Step 4, release the left mouse button when you are satisfied with the curve of the segment. An anchor point appears, as shown in the following illustration:

The object outline expands, if necessary, to include the new anchor point.

6. Repeat Steps 3, 4, and 5 for each segment you want to create. As you add segments, remember the following:

- The shape of the current segment is affected by the shape of the previous segment.
- If you move the mouse without pressing the mouse button, you will see the segment move.
- The first and last anchor points remain on screen, but all other previous anchor points disappear while you are drawing.

7. For the last segment in the polyline, click the first anchor point to create a closed polyline.

or

Double-click the last anchor point to create an open polyline.
(You can later connect the endpoints, if you want, by choosing Polyline from the Transform menu and then choosing Close from the submenu.)
**Manipulating Polylines With the Spline Tool**

At Level 4, you can use the Spline tool to add anchor points to the polyline, precisely edit the curves in the polyline, and change the attributes of control points.

**ADDING AND DELETING ANCHOR POINTS**

You can add and delete anchor points using the Polyline and the Curved Polyline tools.

*To insert anchor points using the Spline tool (Level 4)*

1. Select the Spline tool. When you move the pointer into the drawing area, it changes to crosshairs.
2. If it is not already selected, select the polyline that you want to edit.
3. Click on the polyline segment at the spot where you want to add an anchor point.
5. Choose Insert Point(s) from the submenu. The new point appears where you indicated.

*To delete anchor points using the Spline tool (Level 4)*

1. Select the Spline tool. When you move the pointer into the drawing area, it changes to crosshairs.
2. If it is not already selected, select the polyline that you want to edit.
3. Click to select the anchor point or points you want to delete. Selected anchor points are filled.
4. Press Delete on the keyboard. The selected anchor points disappear.

**CHANGING CURVED SEGMENTS**

You can fine tune the shape of a segment using the Spline tool.

*To reshape a segment using the Spline tool (Level 4)*

1. Select the Spline tool from the Tool Bar. The pointer becomes crosshairs when you move it over the drawing area.

---

For more information about polylines and the polyline tools, see Chapter 9.
2. Point to a segment, press the left mouse button and drag the segment to change its shape.
   
   or
   
   Click a control point to select it, and drag the control points that appear.
   
   or
   
   Click a segment to select it, and drag the control points that appear.

   Regardless of which method you use, GeoDraw displays the former curve as well as the outline of the new curve, as shown in the following illustration:

4. Release the left mouse button when finished. GeoDraw displays the new curve. The control points remain visible.

   To make a curved point a corner point or make a corner point a curved point (Level 4)

   1. Select the Spline tool. When you move the pointer into the drawing area, it changes to crosshairs.
   2. If it is not already selected, select the polyline that you want to edit.
   3. Select the point you want to change.
   5. Choose Make Corner Point(s) or Make Curve Point(s) from the submenu. The anchor point changes to a corner or curve point.

**Changing Control Point Attributes**

You can set the attributes for control points to change how they behave when you change the smoothness of a curve.

If you select Automatic, GeoDraw automatically calculates the positions of the control points to maintain a high degree of
smoothness and to ensure an even curve through the anchor point. The two control points and the anchor point must be on the same tangent and they must be the same distance from the anchor point.

You can specify three additional levels, allowing you to manipulate control points, and thus fine tune the shape of the segment, with increasing levels of precision:

- **Symmetric.** This option ensures that the two control points and the anchor point appear on the same tangent, and that the control points are an equal distance from the anchor point.

- **Collinear.** This option ensures that the two control points and the anchor point appear on the same tangent, but allows the control points to be different distances from the anchor point.

- **Independent.** This option allows two control points to be entirely independent.

Experiment by changing the settings, then manipulating the control points. If you do not like the results of a move, choose Undo Move from the Edit menu.

To change control point attributes (Level 4):

1. Select the Spline tool from the Tool Bar. The pointer becomes crosshairs when you move it over the drawing area.

2. If it is not already selected, select the polyline that you want to edit.

3. Click to select the anchor point with the control points you want to change.


5. Choose Control Points from the submenu. Another submenu appears.

6. Select the control point attribute you want (Automatic, Symmetrical, Collinear, or Independent). GeoDraw applies the attribute to the selected anchor point as soon as you move the anchor point or either of its control points.
LIKE TEXT STY LES, GRAPHIC STY LES ALLOW YOU TO RECORD A SET OF GRAPHIC
ATTRIBUTES AND GIVE THEM A COMMON NAME. THEN, YOU CAN USE THE
STYLE TO APPLY ALL THE ATTRIBUTES TO AN OBJECT AT THE SAME TIME. YOU
CAN RECORD THE FOLLOWING GRAPHIC ATTRIBUTES IN A GRAPHIC STYLE:

- Area attributes, including area fill color, shading, pattern, and
draw mode.
- Line attributes, including line color, shading, line width, line
style, and arrowheads.
- Background color.
- Gradient fill.
- Arc angles for arcs.
- Bitmap format for bitmaps.
- Extended attributes (annotations and locks).

Graphic styles make it easy for you to apply a group of attributes
to one or more objects all at once. This saves you the effort of
setting the same attributes for each object individually. For more
information about changing the attributes of a graphic object, see
"Setting Attributes" in Chapter 10.

When you create a style, you give it a name. Styles help ensure a
consistent look to your drawing. They also make it easier to
reformat a drawing because changing a style automatically
updates graphic objects in that style as well as in styles that
depend on that style. A **graphic style sheet** is the set of all the
named graphic styles used in a drawing.

All GeoDraw documents include one style, Normal. If you create
a drawing based on a template, you might find that other styles
have been defined in the template.

Graphic style sheets are similar to text style sheets. For more
information, see “Using Text Style Sheets” in Chapter 5.

### Defining a New Graphic Style

You can add a new graphic style by giving it a name and
defining its attributes.

You can use the formatting defined in another style with similar
attributes as the base style for a new style. A **base style** is a style
on which other styles depend. If you change an attribute in the
base style, all dependent styles will change except those that
define the attribute uniquely.
For example, suppose you define a style called “Red Fill” using another style, “Filled Objects,” as its base style. If you changed the line width in “Filled Objects” to 3 points, the line width in “Red Fill” would increase to 3 points. GeoDraw also updates all objects drawn in either style with the new attributes.

Alternatively, you can define a style so that its unique attributes change relative to changes in the base style. For example, if the line width in “Red Fill” is 4 points and you increase the line width in “Filled Objects” by 2 points, the line width in “Red Fill” would increase by a corresponding amount to 6 points.

You can also define a new style without using a base style. GeoDraw uses the default attributes or the attributes of a selected object as the starting point instead.

To define a new graphic style (Level 4)

1. Select a graphic object with identical or similar graphic attributes to the style you want to create. GeoDraw uses the attributes in the selected (or base) style to define the initial attributes of the new style. You can also start from scratch, with no objects selected.

2. Choose Graphic Style Sheets from the Attributes menu. A submenu appears.

3. Choose Define New Style from the submenu. A dialog box appears:

   ![Define New Style Dialog Box](image)

4. Fill in the dialog box, changing the options you want.

   **Display in Tool Bar Drop-Down List.** Select whether the style appears in the graphic styles list, if the styles list is available. The styles list appears only if you customize Tool Bars to show style
sheets using the Customize Tool Bars choice on the Options menu. For more information about customizing Tool Bars, see Chapter 2.

**Area Color Relative.** Select to make the area color blend relative to the area color blend of the base style. Changing the area color blend in the base style changes the area color blend in the current style by the same amount.

**Area Mask Relative.** Select to make the area shading (mask) percentage relative to the area shading percentage of the base style. Changing the area shading percentage in the base style changes the area shading percentage in the current style by the same amount.

**Line Color Relative.** Select to make the line color blend relative to the line color blend of the base style. Changing the line color blend in the base style changes the line color blend in the current style by the same amount.

**Line Mask Relative.** Select to make the area shading (mask) percentage relative to the area shading percentage of the base style. Changing the line shading percentage in the base style changes the line shading percentage in the current style by the same amount.

**Line Width Relative.** Select to make the line width relative to the line width of the base style. Changing the line width setting in the base style changes the line width setting in the current style by the same amount.

**Name.** Type a new style name. You can use letters, numbers, and spaces. Choose a name that indicates what the style does. For example, you could call a style that fills the area of the graphic object with the color red “Red Area Fill.”

5. Click Define New Style to define the style.
6. Click Close to close the dialog box.

**Applying a Graphic Style**

You can change the appearance of a graphic object simply by applying a style from the graphic style sheet.

*To apply a graphic style (Level 4)*

1. Select one or more graphic objects to which you want to apply the style.
2. Choose Graphic Style Sheets from the Attributes menu. A submenu appears.
3. Choose Apply Style from the submenu. A dialog box appears listing styles from the style sheet, though not necessarily with all the styles listed here:

4. Select the style you want from the list. GeoDraw applies the style to selected graphic objects.

5. Double-click the window control button if you want to close the dialog box.

**Changing a Graphic Style**

You can change a style in two ways. You can change its visual attributes (area attributes, line attributes, gradient fill, and so on), or you can change its style attributes (area color relative, mask color relative, and so on). If the style serves as the base style for other styles, changes can affect those dependent styles as well.

**CHANGING VISUAL ATTRIBUTES**

You can redefine a style based on the attributes of a selected object. You can change an attribute for one graphic object, then redefine its style to add the attribute to all other graphic objects in the same style.

*To change the visual attributes of a graphic style (Level 4)*

1. Select an object in the style you want to redefine. For example, if you want to redefine a style called "RedFill", select an object in the RedFill style.

2. Change any attributes you want for the style you are redefining.

3. Choose Graphic Style Sheets from the Attributes menu. A submenu appears.

4. Choose Redefine Style from the submenu. GeoDraw updates the style with the attributes of the selected graphic object. GeoDraw also updates any other graphic objects in that style.

**CHANGING STYLE ATTRIBUTES**

You can modify the definition of any style in the styles list to change its style attributes (area color relative, mask color relative, and so on).
To change the style attributes of a graphic style (Level 4)

1. Choose Graphic Style Sheets from the Attributes menu. A submenu appears.

2. Choose Manage Styles from the submenu. The following dialog box appears, though not necessarily with all the styles shown here:

   ![Manage Styles dialog box](image)

   The current style is highlighted.

   Styles List

   Style description

3. Select the style you want to modify from the list.

4. Click Modify. A dialog box appears:

   ![Modify Style dialog box](image)

5. Fill in the dialog box, changing the options you want:

   For a description of these options, see “Defining a New Graphic Style” in this section.
6. Change the base style if you want by selecting it in the list. If you do not want a base style, choose <<No Base Style>>.

7. Click Modify to apply the changes to the selected style. The dialog box disappears.

8. Click Close to close the Manage Styles dialog box.

**Deleting a Graphic Style**

You can delete a style you no longer need. This eliminates clutter in the graphic style sheet. Once you delete a style, you cannot recover it. You cannot delete the Normal style.

*To delete a graphic style (Level 4)*

1. Choose Graphic Style Sheets from the Attributes menu. A submenu appears.

2. Choose Manage Styles from the submenu. The Manage Styles dialog box appears:

3. Select the graphic style you want to delete from the list. If the selected style has a base style, the name of the base style appears in the style description box.

4. Click Delete. GeoDraw deletes the selected graphic style. GeoDraw attaches the base style to any graphic objects in the style you just deleted. However, GeoDraw does not actually change the current graphic attributes of those objects.

   or

   Click Delete and Revert. GeoDraw deletes the selected graphic style, attaches the base style to any graphic objects in the style you just deleted, and overrides the current graphic attributes of those objects with the attributes in the base style.

**Reverting to a Base Graphic Style**

If, after you apply a style to an object, you change the attributes of the object, you can remove all your changes by reverting to the object's original style attributes.

*To revert to the graphic style (Level 4)*

1. Select one or more graphic objects to which you want to reapply the style.

2. Choose Graphic Style Sheets from the Attributes menu. A submenu appears.
3. Choose Revert to Base Style from the submenu. GeoDraw applies the base style to selected graphic objects, overriding the current attributes of selected graphic objects with the attributes in the object's base style.

**Using Style Sheets from Other Drawings**

You can copy style sheets (text and graphic styles) from another drawing into a drawing you're working on. That way, you don't need to define the same styles all over again.

*To get the graphic style sheet from another drawing (Level 4)*

1. Choose Graphic Style Sheets from the Attributes menu. A submenu appears.
2. Choose Bring In Style Sheet from the submenu. A standard file selector appears.
3. Use the file selector to find and select the drawing containing the styles you want to bring in.
4. Click Load Style Sheet. GeoDraw imports the styles from the drawing you selected. If a style with the same name appears in both drawings, GeoDraw uses the style attributes in the source drawing instead.
5. Click Close to close the dialog box.

**Storing and Recalling Graphic Attributes Temporarily**

You can temporarily store the graphic attributes for one object and then apply them to other objects without first creating a named graphic style. To do so, you use the Store Style choice. While named styles are saved with your document, graphic styles you record with the Store Style choice are not saved when you exit GeoDraw.

*To store graphic attributes (Level 4)*

1. Select a graphic object that has the formatting attributes you want to store.
2. Choose Graphic Style Sheets from the Attributes menu. A submenu appears.
3. Choose Store Style from the submenu. GeoDraw remembers the attributes of the selected graphic object.
To recall graphic attributes (Level 4)

1. Select one or more graphic objects to which you want to apply the stored style.

2. Choose Graphic Style Sheets from the Attributes menu. A submenu appears.

3. Choose Recall Style from the submenu. GeoDraw applies the graphic attributes you stored to selected graphic objects.

SETTING EXTENDED ATTRIBUTES

There are two extended attributes you can set for an object:

- Object annotation
- Object locks

Object annotation allows you to mark objects in your drawing that you do not want printed, or that you want hidden. You can also make annotated objects unselectable and uneditable, locking them against any inadvertent changes.

Annotated objects are useful for when you want to place reference objects in your drawing, but you do not want them printed. For example, say you needed a diagonal guide line, but you do not want the line to print along with the other objects in your drawing. Draw the line and annotate it. Then, set the annotation options (in the Options menu) so that the diagonal guide does not print, but it still appears on the screen.

You can also lock an object against specific changes. For example, you can lock the delete operation so that you don't inadvertently delete an object you want to keep. Similarly, you can lock the move operation so that the object remains in a fixed position and is unaffected by subsequent move, align, or distribute operations.

To set extended attributes for an object (Level 4)

1. Select one or more objects for which you want to set extended attributes.
2. Choose Extended Attributes from the Attributes menu. A dialog box appears:

![Extended Attributes dialog box]

3. Select the attributes you want.

**Annotation.** Select this attribute to mark the object as an annotation. By default, this attribute is not selected. For information about annotating documents, see “Using Annotations” in Chapter 2.

**Locks.** Select any of these attributes to prevent the applicable operation (Move, Resize, Rotate, Skew, Edit, Delete, Attribute, Group, Ungroup, Draw, or Print). By default, these attributes are not selected.

4. Click Apply to apply your changes.

5. Click Close to close the dialog box.

---

### To annotate an object

1. Select the object or objects you want to annotate.
2. Choose Extended Attributes from the Attributes menu. A dialog box appears.
3. Click to select Annotation. All annotated objects are affected by choices you make on the Annotation submenu in the Options menu.

### To print annotated objects

The default setting for annotated objects is that they do not print.

1. Choose Annotations from the Options menu. The Annotations submenu appears.
2. Select Print. To turn off the printing for annotated objects, deselect the print option.
To make all annotated objects unselectable and uneditable

1. Choose Annotations from the Options menu. The Annotations submenu appears.
2. Click Make Annotations Unselectable/Uneditable. All your annotated objects are now unselectable and uneditable.

To make all annotated objects selectable and editable

1. Choose Annotations from the Options menu. The Annotations submenu appears.
2. Click Make Annotations Selectable/Editable. All your annotated objects are now selectable.

To hide all annotated objects

Annotated objects, by default, appear on the screen. You can hide them using this procedure.

1. Choose Annotations from the Options menu. The Annotations submenu appears.
2. Deselect Draw Annotations. The annotated objects in your drawing disappear. To see the annotated objects in your drawing, reselect Draw Annotations.

To delete all annotated objects

1. Choose Annotations from the Options menu. The Annotations submenu appears.
2. Click Delete Annotations. All annotated objects in your drawing are deleted.

ADVANCED TEXT FORMATTING

Level 4

You can format text in a drawing to give it more emphasis, to increase its similarity with other objects, to contrast it with other text objects, and so on. GeoDraw offers many of the same text formatting features available in GeoWrite.

At Level 4 in GeoDraw, in addition to the options you can set at Level 3, you can set the following options:

- Text background color
- Character weight, width, and spacing
- Line spacing
At Level 4, you can also use text style sheets, check spelling, and find and replace text. For more information about these options, see Chapter 5.

**FINE TUNING YOUR USER LEVEL**

Chapter 1 describes how to change and fine tune your user level. When you choose Set User Level from the Options menu, and click the Fine Tune button, you can toggle the following options on or off:

- Interactive Create
- Basic Options
- Extended Options
- Basic Geometry
- Extended Geometry
- Basic Attributes
- Extended Attributes
- Basic Text Editing
- Extended Text Editing
- Basic Polyline Editing
- Extended Polyline Editing
- Rulers
- Bitmap Editing

If you are working at a lower user level and want to use a feature that is available at a higher level, you can use Fine Tune to activate the feature. To save the fine tuning settings from session to session, use the Save Configurations choice on the Options menu.
KEYBOARD SHORTCUTS FOR EDITING A DRAWING

The following table lists the special keyboard shortcuts available when an object is selected in the drawing area. Press a key or key combination to trigger its associated command.

<table>
<thead>
<tr>
<th>KEY</th>
<th>COMMAND</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>Zoom out</td>
</tr>
<tr>
<td>+</td>
<td>Zoom in</td>
</tr>
<tr>
<td>b</td>
<td>Send to back</td>
</tr>
<tr>
<td>Shift + B</td>
<td>Shuffle down one layer</td>
</tr>
<tr>
<td>d</td>
<td>Duplicate</td>
</tr>
<tr>
<td>f</td>
<td>Bring to font</td>
</tr>
<tr>
<td>Shift + F</td>
<td>Shuffle up one layer</td>
</tr>
<tr>
<td>g</td>
<td>Group</td>
</tr>
<tr>
<td>u</td>
<td>Ungroup</td>
</tr>
<tr>
<td>h</td>
<td>Center horizontally</td>
</tr>
<tr>
<td>v</td>
<td>Center vertically</td>
</tr>
<tr>
<td>l</td>
<td>Flip left to right</td>
</tr>
<tr>
<td>t</td>
<td>Flip top to bottom</td>
</tr>
<tr>
<td>p</td>
<td>Duplicate in place</td>
</tr>
<tr>
<td>[</td>
<td>Rotate counterclockwise by 15 degrees</td>
</tr>
<tr>
<td>]</td>
<td>Rotate clockwise by 15 degrees</td>
</tr>
<tr>
<td>Shift + [</td>
<td>Rotate counterclockwise by 1 degree</td>
</tr>
<tr>
<td>Shift + ]</td>
<td>Rotate clockwise by 1 degree</td>
</tr>
<tr>
<td>→</td>
<td>Move 10 pixels right</td>
</tr>
<tr>
<td>←</td>
<td>Move 10 pixels left</td>
</tr>
<tr>
<td>Shift + →</td>
<td>Move 1 pixel right (Nudge)</td>
</tr>
<tr>
<td>Shift + ←</td>
<td>Move 1 pixel left (Nudge)</td>
</tr>
<tr>
<td>Ctrl + →</td>
<td>Align to right</td>
</tr>
<tr>
<td>Ctrl + ←</td>
<td>Align to left</td>
</tr>
<tr>
<td>Ctrl + ↑</td>
<td>Align to top</td>
</tr>
<tr>
<td>Ctrl + ↓</td>
<td>Align to bottom</td>
</tr>
</tbody>
</table>
**Constraint Keys**

When you draw, move, resize, or rotate an object, there are certain keys you can use to constrain the operation.

If you hold down the C or comma (,) key while you draw or resize an object, the object expands or contracts around its center point. For example, if you’re dragging the bottom edge of a rectangle downward, the top edge moves upward by an equal amount. You can also hold down the C key to rotate an object around the opposite corner.

If you hold down the Shift key while drawing, moving, resizing, or rotating an object, GeoDraw constrains the operation in the following ways:

<table>
<thead>
<tr>
<th>ACTION</th>
<th>WHEN YOU HOLD DOWN SHIFT KEY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawing an ellipse</td>
<td>You get a perfect circle.</td>
</tr>
<tr>
<td>Drawing a rectangle</td>
<td>You get a perfect square.</td>
</tr>
<tr>
<td>Drawing a straight line</td>
<td>The line is constrained to horizontal, vertical, or the directions 45 degrees off of these axes.</td>
</tr>
<tr>
<td>Drawing a freehand line</td>
<td>Constrains the line to horizontal or vertical.</td>
</tr>
<tr>
<td>Resizing an object</td>
<td>The object’s horizontal and vertical measurements maintain proportion.</td>
</tr>
<tr>
<td>Moving any object</td>
<td>You can only move the object horizontally or vertically.</td>
</tr>
<tr>
<td>Rotating an object</td>
<td>It rotates in 45 degree increments relative to the original angle.</td>
</tr>
</tbody>
</table>
GeoCalc Basics

GeoCalc is a spreadsheet application. A spreadsheet is like a fast calculator that uses a computer to make calculations quickly and efficiently. You can use spreadsheets for keeping track of a budget, creating presentations, and playing "what if" — what if you buy a new stereo before your Aunt Susie sends her usual generous birthday check? What if she doesn't send it this year and you've already bought the stereo?
This chapter describes the basic features of GeoCalc at Level 1, though you can use most of the same techniques at Levels 2 through 4. Once you’ve mastered the general concepts for spreadsheets described in this chapter, you may want to learn more. To have more control over your spreadsheets, set the user level to Level 2 and read Chapter 13.

This chapter describes how to do the following:
- Identify the screen elements in GeoCalc.
- Move around in a spreadsheet.
- Select cells and ranges.
- Enter numbers (known as values) and text (known as labels).
- Create formulas.
- Use built-in functions.
- Edit cell contents and formulas.
- Insert and remove rows and columns.
- Change text characteristics.
- Change the width of a column.

This chapter and the next four chapters are devoted to GeoCalc. This chapter describes the basic features of GeoCalc at Level 1. Chapter 13 describes the options you can use to change the appearance of your spreadsheet. Chapter 14 describes how to create formulas and use functions to make complex formulas easy. Chapter 15 describes creating and editing GeoCalc charts — including bar and column charts, line charts, and pie charts. Chapter 16 describes the GeoCalc Tool Bars and explains how to print spreadsheets, sort information, use GeoCalc with other applications, and fine-tune your user level.

This chapter assumes you are familiar with both Chapter 1 and Chapter 2, which give an overview of the skills you need to use any Ensemble application.
STARTING GEOCALC

ALL LEVELS

The GeoCalc icon appears in the WORLD directory and looks like the example at the left.

To start GeoCalc (All Levels)

1. Locate the GeoCalc icon and double-click it. GeoCalc opens and displays the New/Open dialog box:

   ![New/Open dialog box](image)

   - **Template:** Use a pre-designed template to create a new document.
   - **New:** Create a blank, empty document.
   - **Open:** Open an existing document.
   - **Change User Level:** Change how simple or complex you would like GeoCalc to be.

2. Click one of the first three buttons to open a template, create a new empty document, or open an existing document. Click the last button to set the user level. For more information about using the New/Open dialog box, see “Creating and Opening Documents” in Chapter 1. For more information about setting your user level see “User Levels” in Chapter 1.
If you click Template, New, or Open, a GeoCalc document appears:

**The Spreadsheet Grid.** The grid you see in the illustration above is like a giant piece of accounting paper comprising cells in a table of numbered rows and lettered columns. The grid is your spreadsheet. You enter numbers, text, and formulas into the individual cells in the grid.

**Row and Column Headers.** The numbers down the left side that label each row are called row headers. The letters across the top that label each column are called column headers. Click on these headers to select an entire row or column.

**Cells.** Each cell can hold a discrete piece of information, such as text, numeric values, or formulas for calculations. The text and numeric values you enter appear in the cells of your spreadsheet. If you enter a formula, though, the result of the formula appears in the cell (not the formula itself). At Level 2, you have the option of displaying the formulas instead of the results.

**Cell Addresses.** Each cell has an address, like a map coordinate, denoting its position in a given row and column. The address consists of a row header and a column header. For example, B3 means the cell in row 3 of column B.

**The Active Cell.** Your entries in a spreadsheet go into in the active cell. When you click a cell to select it, it becomes the active cell. The active cell always appears highlighted with a border.
around it. The cell address for the active cell always appears in the Edit Bar.

**The Edit Bar.** The Edit Bar displays information about the active cell. The Edit Bar is where you enter and edit the text, numeric value, or formula you want to enter in the active cell. The Edit Bar includes a number of separate elements, as shown in the illustration to the left.

- **Active Cell Address.** This is the cell address of the active cell. For example, C10 means the cell in the tenth row of column C.
- **Restore Button.** Click this button to cancel the changes you are currently entering in the Edit Area. The value in the cell reverts to the original entry.
- **Enter Button.** Click this button when you want to enter the contents of the Edit Area into the active cell.
- **Edit Area.** This area shows the contents of the active cell. You can make changes here, and then click the Enter button to enter the changes into the active cell. This is also the area where you create formulas or specify functions from the Formula menu (as described later in this chapter).

For more information about starting GEOS applications, see Chapter 1.

**USER LEVELS IN GEOCALC**

GeoCalc has four user levels, as follows:

- **Level 1** provides the basic features you need to work with a spreadsheet. You can enter text, numbers, and formulas. This chapter describes all of the Level 1 features.
- **Level 2** adds the Style Bar and Function Bar so that you can quickly choose actions and set characteristics. In addition, you can copy formulas by “filling,” show formulas in cells, and add charts.
• Level 3 adds the Drawing Tool Bar, Graphics Tool Bar, and Bitmap Tool Bar. At Level 3, you can set printing options, display different rulers, add headers and footers, define names, add notes, and add text color. Level 3 also gives you more options for working with charts.

• Level 4 allows you to specify calculation criteria, sort information, set the row height, and add bitmap graphics and splines.

The first time you use GeoCalc, it starts up at Level 1. You can change your user level at any time. For more information about changing your user level, see Chapter 1.

MOVING AROUND IN A SPREADSHEET

A spreadsheet can contain as many as two million cells. You can scroll through a spreadsheet in much the same way that you scroll through any Ensemble document using the scroll bars or the keyboard. The following procedure describes how to scroll with the keyboard. For more information about using the scroll bars, see The GEOS Environment & Accessories.

To scroll using the keyboard (All Levels)

Use any of the following keystrokes to scroll through a spreadsheet:

• Page Up. One screen up.
• Page Down. One screen down.
• Ctrl+Page Up. One screen right.
• Ctrl+Page Down. One screen left.
SELECTING CELLS AND RANGES

When you want to enter information in a cell or make changes to it, you must first select it to make it the active cell. For example, if you want to type Expenses for 1992 in cell A4, you must first make A4 the active cell. The active cell appears highlighted with a heavy black border around it, as shown in this illustration:

<table>
<thead>
<tr>
<th>January</th>
<th>February</th>
</tr>
</thead>
<tbody>
<tr>
<td>$35.98</td>
<td>$38.24</td>
</tr>
<tr>
<td>$22.47</td>
<td>$26.40</td>
</tr>
<tr>
<td>$129.82</td>
<td>$168.93</td>
</tr>
<tr>
<td>$9.36</td>
<td>$20.45</td>
</tr>
</tbody>
</table>

Highlighted cell

When you want to work with a group of cells, you must first select the entire group. A group of cells is called a range. For example, if you want to copy a group of cells from one part of a spreadsheet to another, you must first select the range that includes all the cells you want to copy, as shown in the following illustration.

When you select a range of cells, all selected cells appear highlighted. One cell within the range is the active cell, and it appears with a border around it.

Like individual cells, ranges have addresses. A range address consists of the address of the first cell, followed by a colon (:) followed by the address of the last cell. In the illustration above, the address for selected range is B3:D10.
To deselect the selection, simply select something else.

To select a single cell (All Levels)
- Click the cell you want to select.
  
or
  Use the arrow keys on the keyboard to move the highlighting to the cell you want to select.
  
or
  Double-click the cell address that appears in the Edit Bar, type the address of the cell you want to select, and then press Enter.
  
or
  Choose Go to Cell from the View menu, type the address of the cell you want to select, and then press Enter.

To select a range of cells (All Levels)
- Drag from the first cell to the last cell of the range you want to select.
  
or
  Click the first cell in the range, and then hold down the Shift key while pressing the arrow keys to extend the selection.

To select an entire row or column (All Levels)
- Click the row or column header.

To select multiple rows or columns (All Levels)
- Drag from the first row or column header to the last row or column header. GeoCalc highlights the rows or columns as you drag.
  
or
  Click the first row or column header, hold down the Shift key, then click the last row or column header. GeoCalc highlights the first and last row or column you selected, as well as all rows or columns in between.

To select a range including every cell that has an entry (All Levels)
- Press Ctrl + Shift + /.
  
or
  Click the Smart Select button in the upper-left corner of the spreadsheet.
GeoCalc selects a range that includes all cells that have entries (and all the empty cells in between).

The following illustration demonstrates the effect of the Smart Select button:

![Smart Select button](image)

To select every cell in the spreadsheet (All Levels)

If you want to perform some action that would affect every cell, such as changing the font for all current and future entries, you can select all cells in the spreadsheet.

- Choose Select All from the Edit menu.

To select a cell using the keyboard (All Levels)

- Use any of the following keystrokes to move the highlighting to the cell you want to select:
  - **Arrow keys.** Selects next cell in the direction of arrow.
  - **Home.** Selects first cell in the current row.
  - **Ctrl+Home.** Selects first cell in the spreadsheet (A1).
  - **End.** Selects last filled cell in the current row.
  - **Ctrl+End.** Selects last cell in the spreadsheet.
  - **Ctrl+Right Arrow.** Selects next filled cell to the right in current row or, if no more filled cells to the right, the last unfilled cell in the row.
  - **Ctrl+Left Arrow.** Selects next filled cell to the left in current row or, if no more filled cells to the left, the first unfilled cell in the row.
  - **Ctrl+Up Arrow.** The next filled cell above the active cell in the current column or, if there are no more filled cells above the active cell, the first unfilled cell in the column.
• Ctrl+Down Arrow. The next filled cell below the active cell in the current column or, if no filled cells appear below the active cell, the last unfilled cell in the column.

To select a range of cells using the keyboard (All Levels)

■ Hold down the Shift key while using one of the keystrokes shown in the table above. This selects the range from the active cell to the destination for the keystroke you use. For example, if C23 is the active cell, you can press Shift+Ctrl+Home to select the entire range A1:C23.

WORKING WITH VALUES AND LABELS

ALL LEVELS

You build a spreadsheet by entering values, labels, and formulas.

• Values. Values are numbers — for example, sales figures for the past four quarters.

• Labels. Labels are the titles or descriptive text you enter to describe the contents of rows and columns — for example, "First Quarter," "Second Quarter," "Third Quarter," and "Fourth Quarter."

• Formulas. Formulas describe the calculations you want to perform — for example, to total the sales for all four quarters. This section explains how to enter values and labels in a spreadsheet. For more information about formulas, see “Working with Formulas” in this chapter.

Entering Values and Labels

The procedure for entering values and labels is the same. However, some special considerations apply to each; for more information, see the notes following the procedure. If you want to enter dates in a spreadsheet, see “Entering Dates” in this chapter.

To enter values or labels (All Levels)

1. Select the cell in which you want the entry to appear.

If you are using the numeric keypad to enter numbers, be sure the Num Lock key is on. If the highlighting moves rather than a
number appearing, turn Num Lock on by pressing the Num Lock key at the top left of the keypad.

2. Type the entry (numbers or words) that you want to appear in the cell. If you make a typing mistake, press the **Backspace** key to erase characters to the left of the insertion pointer in the Edit Area.

3. Press one of the following keys to complete the entry:
   - **Enter**. Moves the highlighting down one cell.
   - **Shift+Enter**. Moves the highlighting up one cell.
   - **Tab**. Moves the highlighting to the right one cell.
   - **Shift+Tab**. Moves the highlighting to the left one cell.
   - **Left** and **Right Arrow**. If the insertion point is at the beginning (for left arrow) or the end (for right arrow) of the Edit Bar, moves the highlighting one cell in the direction of the arrow.
   - **Up** and **Down Arrow**. Moves the highlighting one cell in the direction of the arrow.
   - **Ctrl+Enter**. Keeps the highlighting in the current cell; the active cell does not change.

You can also complete your entry by clicking the Enter button in the Edit Bar. In this case, the highlighting does not move.

**ENTERING LABELS**

If you enter a label wider than the cell in which you enter it, the label spills over into the next cell to the right as long as that cell is empty. If the cell to the right is full, the text appears cut off. The complete text of the label is stored in the cell, but you cannot see it unless you make the column wider. For more information about changing the column width, see “Changing the Appearance of a Spreadsheet” in this chapter.

If you want to enter a number as a label or if you need to enter a label that begins with an equal sign (=), start by typing an apostrophe (') or a double quotation mark ("). When you start an entry with a double quotation mark, the entry appears left-justified and the double quotation mark does not appear. For example, to enter **1993** as a label, you type ***1993. To enter **=National Average** as a label, you type ***=National Average.***

**ENTERING VALUES**

If a cell is not wide enough for a value you enter (or for the result of a formula), you see the symbol ### in the cell, as shown in the illustration to the left. The value is stored in the
cell, but you won't be able to see it unless you make the column wider. For more information about changing the column width, see “Changing the Appearance of a Spreadsheet” in this chapter.

You can enter values between $10^{-4932}$ and $10^{+4932}$. All numbers and calculations are accurate to 15 decimal places. Even when GeoCalc rounds off a number to fewer than 15 decimal places, it uses all 15 decimal places in calculations.

Do not enter commas when you enter values, although you can specify a format that adds commas automatically. (See “Changing the Number Format for Values” below).

You can use any of the following characters in the values you enter:

$1234567890+-Ee$.

Use $E$ or $e$ to specify scientific notation. For example, to enter $3.75 \times 10^{15}$, you can type either of the following: $3.75e15$ or $3.75E15$.

### CHANGING THE NUMBER FORMAT FOR VALUES

Each value in a spreadsheet is displayed in a particular format. When you enter a value, GeoCalc automatically displays it in a standard format; however, you can change the format to suit your needs. The following table shows the available number formats.
<table>
<thead>
<tr>
<th>FORMAT</th>
<th>YOU ENTER...</th>
<th>GEOCALC DISPLAYS</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>1234567</td>
<td>1234567</td>
</tr>
<tr>
<td>Fixed (2 decimal places)</td>
<td>123.4567</td>
<td>123.46</td>
</tr>
<tr>
<td>Fixed with Commas</td>
<td>1234.567</td>
<td>1,234.57</td>
</tr>
<tr>
<td>Fixed Integer (rounded to a whole number)</td>
<td>1234.567</td>
<td>1234</td>
</tr>
<tr>
<td>Currency</td>
<td>1234.567</td>
<td>$1234.57</td>
</tr>
<tr>
<td>Currency with Commas</td>
<td>1234.56</td>
<td>$1,234.57</td>
</tr>
<tr>
<td>Currency Integer (rounded to nearest dollar)</td>
<td>1234.567</td>
<td>$1234</td>
</tr>
<tr>
<td>Percentage (times 100)</td>
<td>.085</td>
<td>8.5%</td>
</tr>
<tr>
<td>Percentage Integer (times 100, rounded to whole percent)</td>
<td>.4275</td>
<td>43%</td>
</tr>
<tr>
<td>Thousands (divided by 1000 and rounded)</td>
<td>1234567</td>
<td>1234.57</td>
</tr>
<tr>
<td>Millions (divided by one million and rounded)</td>
<td>123456789</td>
<td>123.46</td>
</tr>
<tr>
<td>Scientific</td>
<td>1234.5678</td>
<td>1.23E+03</td>
</tr>
</tbody>
</table>

To change the format of values (All Levels)

1. Select the cell(s) containing the value(s) whose format you want to change.

2. Choose Number Format from the Properties menu. The following dialog box appears:

3. Select the format you want from the Formats list. An example of the format appears in the dialog box.
4. Click Apply. GeoCalc changes the format of the selected cell(s).
5. Click Close. The dialog box disappears.

**Entering Dates**

There are two ways to enter dates in your spreadsheet. You can enter them as labels, or you can enter them as formulas.

**ENTERING DATES AS LABELS**

When you enter a date as a label, GeoCalc stores it just as you typed it. If you want to change the format, you must retype the date in the format you want.

*To enter a date as a label (All Levels)*

- Enter the date just as you would any other label. Type the date exactly as you want it to appear.
  
  For example, you could type any of the following:
  
  - Jan 15, 1993
  - January 15, 1993
  - 1/15/93
  - 93-01-15

**ENTERING DATES AS FORMULAS**

You can also enter a date as a formula, using a special date function. When you do this, GeoCalc stores the date as a serial number representing the number of days since January 1, 1900. For example, GeoCalc would store January 1, 1993 as the number 33969.

When a date is stored as a serial number, you can use GeoCalc to change its format automatically, and you can use the date in formulas. For example, you can change *Jan 15, 1993* to *1/15/93* without retyping. And you can “subtract” May 3, 1990 from June 15, 1991 to determine the number of days between the two dates (408). To take advantage of these features, you first enter your date as a formula using the built-in DATE function.

*To enter a date as a formula (All Levels)*

1. Select the cell in which you want to enter a date.
3. Type an open parentheses, followed by numbers representing the year, month, and day of the date you want to enter. Then,
type a close parentheses. Be sure to type the year, month, and day in that order. For example, the entire entry for February 17, 1993 is as follows:

=DATE(1993,2,17)

4. Click the Enter button or press the **Enter** key. The serial number for the date appears in the cell. For example, if you specify February 17, 1993, GeoCalc displays 34016.

Unless you want the date to appear in your spreadsheet as a serial number, you will probably want to change the date format. The next section explains how to do this.

**NOTE**

You can also enter time values (hours, minutes, and seconds) using a similar technique. Instead of the DATE function, you use the TIME function; instead of entering the year, month and day, you enter the hours, minutes, and seconds.

**CHANGING THE DATE FORMAT**

When you enter a date or time value as a formula, GeoCalc initially displays a number; however, you can change the format to suit your needs. The following table shows the available date and time formats.
<table>
<thead>
<tr>
<th>FORMAT</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date - Long</td>
<td>23456 = Saturday, March 21st, 1964</td>
</tr>
<tr>
<td>Date - Long, Condensed</td>
<td>23456 = Sat, Mar 21, 1964</td>
</tr>
<tr>
<td>Date - Long, No Weekday</td>
<td>23456 = March 21, 1964</td>
</tr>
<tr>
<td>Date - Long, Condensed, No Weekday</td>
<td>23456 = Mar 21, 1964</td>
</tr>
<tr>
<td>Date - Short</td>
<td>23456 = 3/21/64</td>
</tr>
<tr>
<td>Date - Short, Zero Padded</td>
<td>23456 = 03/21/64</td>
</tr>
<tr>
<td>Date - Long, Month &amp; Day</td>
<td>23456 = Saturday, March 21st</td>
</tr>
<tr>
<td>Date - Long, Month &amp; Day, No Weekday</td>
<td>23456 = March 21st</td>
</tr>
<tr>
<td>Date - Short, Month &amp; Day</td>
<td>23456 = 3/21</td>
</tr>
<tr>
<td>Date - Short, Month &amp; Year</td>
<td>23456 = March, 1964</td>
</tr>
<tr>
<td>Date - Year</td>
<td>23456 = 1964</td>
</tr>
<tr>
<td>Date - Month</td>
<td>23456 = March</td>
</tr>
<tr>
<td>Date - Day</td>
<td>23456 = 21st</td>
</tr>
<tr>
<td>Date - Weekday</td>
<td>23456 = Saturday</td>
</tr>
<tr>
<td>Time - Hour Min Sec</td>
<td>1234.567 = 1:36:29PM</td>
</tr>
<tr>
<td>Time - Hour Min</td>
<td>1234.567 = 1:36 PM</td>
</tr>
<tr>
<td>Time - Hour</td>
<td>1234.567 = 1 PM</td>
</tr>
<tr>
<td>Time - Min Sec</td>
<td>1234.567 = 36:29</td>
</tr>
</tbody>
</table>

*To change the format for dates (All Levels)*

You use the same procedure to change date formats that you use to change number formats.

1. Select the cell(s) containing the value(s) whose format you want to change.
2. Choose Number Format from the Properties menu. The following dialog box appears:

![Number Format Dialog Box]

- Choose a format here.
- GeoCalc displays an example of the selected format here.

3. Choose the format you want from the Formats list. An example of the format appears in the dialog box.

4. Click Apply. GeoCalc changes the format of the selected cell(s).

5. Click Close. The dialog box disappears.

**Entering Information in a Selected Range**

You can save time by selecting the range of cells in which you want to enter data before you start. Then, if you press **Enter** in the bottom row of the selection, the active cell automatically moves to the top of the next column in the selection. If you press **Tab** in the rightmost column of the selection, the active cell automatically moves to the beginning of the next row in the selection.

![Select Range with Enter]

Moving through the selected range using the **Enter** key.

![Select Range with Tab]

Moving through the selected range using the **Tab** key.
WORKING WITH FORMULAS

Formulas describe calculations you want GeoCalc to perform. When you start to use formulas, you see the power of a spreadsheet. Each time you change the contents of a cell anywhere in your spreadsheet, GeoCalc automatically recalculates every formula in the spreadsheet.

Formulas are made up of the following elements:
- *References* to particular cells or ranges like A1 or B12:C18.
- *Operators* like + and - for addition and subtraction.
- *Values* like 5, 100, and .25.
- *Built-in functions* like DATE, SUM, and AVG.

This section explains how to combine these elements in a formula that performs a specific calculation.

**CAUTION**
GeoCalc uses floating point math. While floating point calculations have benefits such as speed, they are inherently inaccurate. All spreadsheets based on floating point math produce errors in the 17th or 18th significant digit. While this is often not detectable, the errors become apparent in some calculations, especially when you use financial functions like IRR and NPV. GeoCalc adheres to the IEEE 754 standards for floating point calculations. However, you should consult a financial specialist before you invest significant sums of money based on floating point calculations from any source.

**Entering Formulas**
You begin a formula by typing = (an equal sign). Next, you use references, values, operators, and built-in functions to describe the calculation you want to perform. The following illustration shows how you might use a formula to add the expenses for an evening on the town:
Cell B4 contains the following formula:

\[ =B1+B2+B3 \]

This formula tells GeoCalc to add the values in cells B1, B2, and B3 and to display the result in cell B4. Here are the elements of this formula:

- The equal sign (=) tells GeoCalc it's a formula. All formulas must start with an equal sign.
- B1, B2, and B3 are references.
- The plus signs (+) are operators.

The example above does not include a built-in function. For more information about built-in functions, see “Using Built-in Functions in Formulas” in this chapter.

To enter a formula using the keyboard alone (All Levels)

1. Select the cell in which you want to enter the formula.
2. Type = to begin the formula. The equal sign appears in the Edit Area.
3. Type the reference for the first cell you want to use in the calculation.
4. Type the operator you want to use. For example, type + for addition.
5. Type the reference for the next cell you want to use.
6. Continue typing operators and cell addresses until the formula in the Edit Bar appears as you want it.
7. Press the Enter key. The result of the formula appears in the cell.

To enter a formula using the keyboard and the mouse (All Levels)

1. Select the cell in which you want to enter the formula.
2. Type = to begin the formula. The equal sign appears in the Edit Area.
3. Click the first cell you want to use in the calculation. The cell address appears in the Edit Area.
4. Type the mathematical operator you want to use. For example, type * for multiplication.
5. Click the second cell you want to use. The cell address appears in the Edit Area.
6. Continue clicking and typing operators until the formula in the Edit Bar appears as you want it.
7. Click the Enter button or press the **Enter** key. The result of the formula appears in the cell.

**Using References in Formulas**

A *reference* identifies a cell or range of cells. The reference tells GeoCalc where to look to find the values you want to use in a formula. Most formulas include at least one reference.

You can use two types of references in the formulas you create: *relative references* and *absolute references*. Your choice depends on how you want GeoCalc to treat the references when you copy or move the formula from one cell to another.

**RELATIVE REFERENCES**

A relative reference tells GeoCalc how to find a particular cell starting from the cell containing the formula — go two rows up and one column to the right. It is like telling someone how get to your house from theirs — go three blocks east and then four blocks south.

When you copy a formula that contains relative references from one location to another, GeoCalc adjusts the references in the formula relative to the new position of the formula. For example, in an annual budget spreadsheet, you could use a formula with relative references to add the numbers in the January column; then, when you copy the formula to the columns for February through December, GeoCalc adjusts the relative references so that each formula totals the numbers for the column in which it appears.

Relative references look just like cell addresses. The following are examples of relative references: B4, D8, A1, B2:F8.

**ABSOLUTE REFERENCES**

An absolute reference tells GeoCalc the specific address of a cell. An absolute reference is like telling someone your exact address — 3628 Sixteenth Avenue. When you copy a formula from one location to another, GeoCalc does not adjust absolute references. Use an absolute reference when you want to refer to the same cell, regardless of where you may copy the formula in the spreadsheet.

For example, if you are calculating loan payments, you might want to refer to a cell containing the interest rate used in the PMT function. In the example below, when you want to copy the formula, the reference to B3 must not change. Otherwise each calculation would be based on a different interest rate. To ensure
that all copies of the formula use the value in B3, you enter the absolute reference $B$3.

To enter an absolute reference, enter the address with a dollar sign before the column and/or row indicators. B3 is a relative reference. $B$3 is an absolute reference. You can create hybrid references making either the column or row absolute and the other relative, as shown in the following table.

<table>
<thead>
<tr>
<th>REFERENCE</th>
<th>TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>B3</td>
<td>Relative reference</td>
</tr>
<tr>
<td>$B$3</td>
<td>Absolute reference</td>
</tr>
<tr>
<td>B$3</td>
<td>Relative column, absolute row</td>
</tr>
<tr>
<td>$B$3</td>
<td>Absolute column, relative row</td>
</tr>
</tbody>
</table>

Using Operators in Formulas

Operators describe the type of calculation you want to perform — for example, addition or subtraction. The following table shows the operators you can use in formulas.

<table>
<thead>
<tr>
<th>OPERATOR</th>
<th>DESCRIPTION</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>%</td>
<td>Percentage</td>
<td>A14*22%</td>
</tr>
<tr>
<td>^</td>
<td>Exponentiation</td>
<td>13^3</td>
</tr>
<tr>
<td>* and /</td>
<td>Multiplication and division</td>
<td>A14*B12</td>
</tr>
<tr>
<td>+ and -</td>
<td>Addition and subtraction</td>
<td>A14+B12</td>
</tr>
<tr>
<td>&amp;</td>
<td>Concatenation</td>
<td>“Rate &amp;A1&amp;”%</td>
</tr>
</tbody>
</table>
When you use more than one operator in a formula, GeoCalc performs the calculations in the order shown in the table — % first, \(^\) second, and so forth. If you use more than one operator with the same priority (like + and -), GeoCalc performs those calculations from left to right.

You can alter the order of calculations by enclosing within parentheses those expressions you want calculated first. GeoCalc evaluates expressions enclosed in parentheses first, and then uses those results to calculate the rest of the formula. The following table shows some examples.

<table>
<thead>
<tr>
<th>FORMULA</th>
<th>RESULT</th>
</tr>
</thead>
<tbody>
<tr>
<td>50+100/2</td>
<td>100</td>
</tr>
<tr>
<td>(50+100)/2</td>
<td>75</td>
</tr>
</tbody>
</table>

Using Built-in Functions in Formulas

*Built-in functions* perform common calculations automatically. You use them in formulas to simplify your work. For example, the SUM function totals a group of numbers; the AVG function computes the average of a group of numbers; and the NPV function computes the net present value of an investment.

GeoCalc provides functions you can use to perform the following types of calculations:

- Financial
- Information
- Logical
- Mathematical
- Print
- Statistical
- String
- Time and Date
- Trigonometric

This section gives the general procedures for using built-in functions. Detailed descriptions of each of the built-in functions are included in Appendix A.

**KEYWORDS AND ARGUMENTS**

Each built-in function includes a keyword like SUM or AVG. Most functions also require that you specify *arguments*. Arguments are
the data that functions use in a calculation — for example, the numbers you want to total. An argument can be a value, text string, reference, function, or formula. The arguments determine the result of the function.

For example, the financial function PMT calculates the payment required for a loan. The arguments for the PMT function are the principal amount, interest rate, and term of the loan. The following illustration shows how you might use the PMT function to compute a loan payment:

Cell A1 contains the following formula:

\[
=\text{PMT}(10000, 8.75\%/12, 48)
\]

This formula uses the PMT function to tell GeoCalc to compute the monthly loan payment for a 48-month loan of $10,000 at an interest rate of 8.75% per year.

**PLACEHOLDER ARGUMENTS**

When you insert a function in a cell, you can automatically insert placeholders for the arguments. For example, when you insert the PMT function, the placeholders remind you to enter the principal amount, interest rate, and term of the loan, as shown in the following illustration.

Since each function has different arguments, the placeholders can help you remember what arguments to enter for a particular function.

After inserting the function, you replace the placeholders with the actual arguments you want to use, as shown in the following illustration.

If you are pasting a function into the Edit Area, you must replace the placeholder arguments with the values or cell addresses you
want to use in the calculation. If you want to use a fixed value — for example term, the length of the loan in months — you replace **TERM** with the value for the term of the loan, for example 48 (the number of monthly payments in 4 years).

It is important to enter the arguments in a specific order — the order shown in the dialog box and in Appendix A of this manual. Inserting placeholders will help you to remember the order in which to enter arguments.

**ENTERING BUILT-IN FUNCTIONS**

To include a built-in function in a formula, you can either type the function and all of its arguments, or you can insert the function using the Insert Function choice on the Formula menu. When you use the Insert Function choice, you have the additional option of inserting placeholder arguments.

*To insert a function using the Formula menu (All Levels)*

1. Select the cell where you want the result of the calculation to appear.
2. Type `=` to begin the formula. The equal sign appears in the Edit Area.
3. Choose Insert Function from the Formula menu. The following dialog box appears:

```
List of function types

<table>
<thead>
<tr>
<th>Functions</th>
<th>List of available functions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Financial</td>
<td>ABS</td>
</tr>
<tr>
<td>Information</td>
<td>ACOS</td>
</tr>
<tr>
<td>Logical</td>
<td>ACOSH</td>
</tr>
<tr>
<td>Math</td>
<td>AND</td>
</tr>
</tbody>
</table>

**Paste Arguments**

Click here to paste the arguments on placeholder in the formula.
```

4. Select the function you want to use from the Functions list on the right. Optionally, you can select a function type from the list on the left so that the Functions list shows only functions of the type you select.
5. Select the Paste Arguments option (the default) if you want to insert placeholder arguments with the Function.

6. Click Paste. The function appears in the Edit Area. If you specified “Paste Arguments” the arguments also appear in the Edit Area.

7. Click Close to close the dialog box.

8. In the Edit Area, double-click the first argument to select it.

9. Type the text, value, formula or cell reference you want to use for the argument. Make sure you type it correctly. Your entry replaces the placeholder argument.

10. Continue replacing arguments as needed. For specific information about each argument, see Appendix A.

11. Click the Enter button or press the Enter key.

   When the calculation is complete, the result appears in the spreadsheet. If the calculated result is not what you expect, be sure that you typed the formula correctly.

12. Click Close to close the dialog box.

   

   To insert a function by typing (All Levels)
   
   1. Select the cell where you want the result of the calculation to appear.
   
   2. Type = to begin the formula. The equal sign appears in the Edit Area.
   
   3. Type the function name.
   
   4. Type the arguments, enclosed in parentheses. Be sure to include commas between arguments.
   
   5. Click the Enter button or press the Enter key.

   When the calculation is complete, the result appears in the spreadsheet.

   

   To use a function within a function (All Levels)
   
   You can embed one function within another. For example, to sum a range of values and get its integer value, you could type

   \[ =\text{INT}(\text{SUM}(A3:A9)) \]

   1. Insert the first function.

   2. In the Edit Area, select the argument you want to replace with a function.

   3. Insert the second function.

   4. Continue in this manner until the formula is complete.
5. Click the Enter button or press the Enter key.

**NOTE**
When you embed one function within another, it is easy to lose track of where the parentheses belong. If you insert the function with placeholder arguments, GeoCalc inserts the parentheses accurately.

**EDITING THE SPREADSHEET**

After you’ve created a spreadsheet, you may want to make some changes. You may want to delete some obsolete information or to insert rows or columns to make room for new information. You may want to copy or move some information to a new location. Or you may simply need to correct an error you made.

This section describes how to do the following:
- Edit the contents of a cell.
- Delete information from a cell or range of cells.
- Insert and remove rows and columns.
- Copy and move information in a spreadsheet.
- Fill a range with a series of incremental values.

**Editing the Contents of a Cell**

Typically, you will need to modify entries you make in a spreadsheet — whether to correct an error you’ve made or to update the spreadsheet to reflect new information. If it’s a simple change, you can select the cell to make it active and then type the new entry. If you want to make a change in a complex entry, you may want to work in the Edit Bar.

To edit the contents of a cell (All Levels)

1. Select the cell you want to change.
2. In the Edit Area, select the information you want to change, or click where you want to insert new information.
3. Make the corrections you want.

Additional instruction:

You can also press Ctrl+Spacebar to begin editing the selected cell.
4. To confirm your changes, click the Enter button or press the Enter key.

   or

To cancel the changes, click the Restore button or press the Esc key.

**Deleting Information**

Occasionally, you may want to delete the contents of one or more cells. You can delete information permanently, or you can transfer it to the clipboard so you can then move it another location.

*To delete the contents of cells (All Levels)*

1. Select the cell or range of cells whose contents you want to delete.

2. Press the Delete key. The contents of the cell or range are permanently deleted.

   or

Choose Delete from the Edit menu. The contents of the cell or range are permanently deleted.

   or

Choose Cut from the Edit menu. The contents of the cell or range are transferred to the clipboard; you can use the Paste choice on the Edit menu to copy the cell or range to another location.

**HINT**

If you accidentally delete the wrong information using the Delete key or the Delete choice on the Edit menu, you cannot restore the deleted information. You may want to delete information using the Cut choice on the Edit menu; that way, if you accidentally delete the wrong information, you can paste it back in place.

**Copying and Moving Information**

As you work with GeoCalc, you may find it convenient to copy and move information in a spreadsheet. There are two ways to copy and move information in GeoCalc.

- You can use the Fill choices on the Cell menu to copy the contents of the active cell across a row or down a column.

- You can use the Cut, Copy, and Paste choices on the Edit menu to copy or move information to any other location in a
spreadsheet. Alternatively, at Level 2 and above, you can click the clipboard tools on the Function Bar, if displayed.

In either case, the result depends on what kind of information you are copying or moving. When you copy or move values and labels from one location to another, they appear the same in both locations. When you copy or move formulas, however, GeoCalc automatically adjusts relative references for the new position of the formula. You can override this automatic adjustment by using absolute references. For more information about relative and absolute references, see “Using References in Formulas” in this chapter.

COPYING TO ADJACENT CELLS

The Fill Right and Fill Down choices provide a handy shortcut when you want to copy the contents of the active cell across a row or down a column. This is particularly useful when you copy formulas. In a budget spreadsheet, for example, you can enter a formula to calculate the total for the January column, and then copy the formula to the columns for February through December, as shown in the following illustration.

![Screenshot of a spreadsheet showing a table with columns labeled January to June, and numbers filled in for each column. The total for January is calculated and then copied to the other months.](image)

You enter the formula in this cell.

Then, you copy the formula to these cells.

When you copy the formula, GeoCalc automatically adjusts the relative references so that the total is correct for each month.
To copy a formula to adjacent cells (All Levels)

1. Select a range of cells starting with the cell containing the formula you want to copy and ending with the last cell to which you want to copy the formula, as shown in the following example:

   Formula

   You can copy the formula into the range to the right.

2. Choose Fill Down from the Cell menu to copy the formula to the selected cells beneath it.

   or

   Choose Fill Right from Cell menu to copy the formula to the selected cells to its right.

   The formula appears in the new locations.
USING CUT, COPY, AND PASTE

Using these menu choices, you can copy or move a single cell or a range of cells to any other location in a spreadsheet. Cut, Copy, and Paste work the same way in GeoCalc that they do in other Ensemble applications. Cut and Copy place the selected cells on the clipboard; Paste retrieves any previously cut or copied information from the clipboard. For more information about the clipboard or using these menu choices, see “Selecting and Editing” in Chapter 2.

To copy or move information (All Levels)

1. Select the cell, range, row(s), or column(s) you want to copy or move.
2. To copy the selection, choose Copy from the Edit menu; to move it, choose Cut from the Edit menu.
3. Select the first cell where you want to copy or move the information.
4. Choose Paste from the Edit menu. The values and formulas appear in the new location with the first cell of the copied selection appearing in the destination cell.

USING DRAG AND DROP

You can use drag and drop to move or copy cells in your spreadsheet. Drag and drop works the same way in GeoCalc as it does in other Ensemble applications. If you drag and drop within the same document, the default behavior is to move the information. If you drag and drop from one document to another, the default behavior is to copy. You can override this behavior by holding down the Ctrl key if you want to copy or the Alt key if you want to move while performing the drag and drop.

To drag and drop information from one location to another (All Levels)

1. Select the cell, range, row(s), or column(s) you want to move or copy.
2. Move the mouse pointer over the selected range; and then press and hold down the right mouse button. The drag and drop pointer appears.
3. Drag the pointer so that it is over the first cell where you want to move or copy the information.
4. Release the mouse button. The information is moved or copied, depending on whether you dragged within the same document or from one document to another.

**NOTE**

As you position the drag and drop pointer, the small square at the end of the pointer changes to indicate whether this will be a move or a copy.

When the pointer is over the same document, the default operation is a move (indicated by the hollow square at the end of the drag and drop pointer). If the pointer is over another document, the default operation is a copy (indicated by a filled square).

You can override this behavior by holding down the Alt key (to move) or the Ctrl key (to copy) while performing the drag and drop. The small square at the end of the pointer becomes hollow or filled as appropriate.

**Inserting and Deleting Rows and Columns**

After you have created a spreadsheet, you may need to add a row or column to accommodate additional information. When information becomes obsolete, you will want to delete a row or column.

*To insert a row or column (All Levels)*

For multiple additions or deletions, repeat this procedure as needed. At Level 2 and above, you can add and delete multiple rows and columns.

1. Select a cell where you want the insertion to occur. Rows are inserted above the active cell, columns to the left of the active cell.
2. Choose Insert Row/Column from the Edit menu. A dialog box appears.
3. Select either Row or Column in the dialog box.
4. Click Insert.

*To insert a row or column quickly (Levels 2-4)*

At Level 2 and above, if the Function Bar is displayed, you can use tools to insert a row or column more quickly.

1. Select a cell where you want the insertion to occur.
2. Click the Insert Row tool on the Function Bar.

*or*
Click the Insert Column tool on the Function Bar.

To delete a row or column (All Levels)

1. Select a cell in the row or column you want to delete.
2. Choose Delete Row/Column from the Edit menu. A dialog box appears.
3. Select either Row or Column in the dialog box.
4. Click Delete.

To delete a row or column quickly (Levels 2-4)

At Level 2 and above, if the Function Bar is displayed, you can use tools to delete a row or column more quickly.

1. Select a cell in the row or column you want to delete.
2. Click the Delete Row tool on the Function Bar.
   or
   Click the Delete Column tool on the Function Bar.

Filling a Range of Cells with Incremental Values

Using the Fill Series choice on the Cell menu, you can automatically fill a range of cells with a series of incremental values. You select the range of cells and specify the starting value and the increment. GeoCalc does the rest.

If the first cell in a series contains a 1, the next cell will be 2, the following 3, and so on. If the first cell contains a date, Fill Series increments the date; Monday increments to Tuesday, Wednesday, Thursday, and so on. Time increments from 1:00 to 2:00, 3:00, and so on.

To fill a range with incremental values (All Levels)

1. Enter the value or date you want to increment.
2. Select the range of cells you want to fill, starting with the cell you filled in containing the value or date you want to increment.
3. Choose Fill Series from the Cell menu. A dialog box appears:

![Fill Series Dialog Box]

4. Fill in the dialog box, specifying the fill options you want:
   - **Fill By.** Select whether to fill rows or columns.
   - **Units.** Select the type of units for the fill: number, day, weekday, month, or year.
   - **Progression.** Select the progression you want GeoCalc to use: Linear or Geometric. A linear series progresses one step at a time—for example, 1, 2, 3, 4, 5. A geometric series progresses by a specific multiplier at each step—for example, 1, 3, 9, 27, 81, 243.
   - **Step Value.** For a linear progression of numbers, enter the increment you want between each value. For a geometric progression of numbers, enter the multiplier you want to use between each value. For a progression of dates, enter the number of units (days, weekdays, months, or years) you want between each value.

4. Click OK. The range is filled as you specified.

**NOTE**

If you select Day, Weekday, Month, or Year in the Fill Series dialog box, GeoCalc creates the series differently depending on how you originally entered the date. If you entered the date as a label, GeoCalc creates additional dates as labels.

If you entered the date as a series number, GeoCalc creates additional dates as serial numbers; however, the cell must have a date format. To fill date information as text (such as “Sunday” or “January”), fill in the first value as text. For numbers such as a year value, to fill in a progressive series of years, enter the year as a text value (“1990”), not a number. For more information, see “Entering Dates” in this chapter.
CHANGING THE APPEARANCE OF A SPREADSHEET

ALL LEVELS

You may want to change the appearance of a spreadsheet to improve its presentation. For example, you might want to emphasize certain aspects with a different text style or alignment. This section explains how to do the following:

• Change the width of columns.
• Change the justification of information in cells.
• Change the text style of information in cells.

At Levels 2 through 4, you have many additional options for controlling the appearance of your spreadsheet. For more information, see Chapter 13.

Adjusting Column Width

Sometimes when you enter information, it appears truncated or appears as ### because the column is not wide enough. You can change the column width using the mouse or the choices on the Cell menu.

To change the column width by dragging (All Levels)

1. Move the pointer to the header area at the top of the spreadsheet. When the pointer is over the divider that separates the column letters, it changes to a double arrow, as shown in the following illustration.

2. Drag the column divider on the right side of the column until the column is the width you want.

or

Double-click the column divider on the right side of the column to adjust to set the column width just wider than the longest entry in the column. This is the same effect you get if you choose Best Fit from the Cell menu.
To change the column width using the Cell menu (All Levels)

1. Select a cell anywhere in the column whose width you want to change.

2. Select one of the following from the Cell menu:
   • Narrower makes the column 8 points narrower. The default width is 64 points.
   • Wider makes the column 8 points wider. The default width is 64 points.
   • Best Fit makes the column wide enough to fit the widest entry it contains.

Changing Justification

Usually, you want labels to line up at the left edge of a cell, and you want values to line up at the right edge. In other words, you want labels to be \textit{left-justified}, and you want values \textit{right-justified}.

When you enter something in a cell, GeoCalc automatically aligns it in this way. If you enter a value, it appears right-justified. If you entry a label, it appears left-justified. If you enter a formula, the result of the formula appears right-justified.

You can change the justification of cells using the Properties menu.

To change the justification of cells (Level 1)

1. Select the cells you want to align.

2. Choose one of the following from the Properties menu:
   • Left makes the entry left-justified in the cell.
   • Center centers the entry in the cell.
   • Right makes the entry right-justified in the cell.
   • General makes labels left-justified and values right-justified.

\textit{At Level 2, you can change justification by clicking a button on the Style Bar.}
Using Different Text Styles

Using different text styles can help to highlight important information and improve the overall appearance of a spreadsheet. You can change the text style for any cell or range of cells in your spreadsheet — whether they contain labels, values, or formulas.

*To change the style of text (All Levels)*

1. Select the cell or range of cells you want to change.
2. Choose the style you want from the Properties menu.
   - Plain (the text style without bold, italic, or underline)
   - **Bold**
   - **Italic**
   - **Underline**

You can apply more than one style to your text, such as *bold italic*. 
CHAPTER 13

Formatting GeoCalc Spreadsheets

You can use a number of options to change the appearance of your spreadsheet. These options do not affect calculations; they simply make the spreadsheet more attractive and allow you to highlight information to show its importance. You’ll find these visual enhancements particularly helpful if you want to make presentations.
This chapter describes how to do the following:
• Display and print grid lines.
• Display cell borders.
• Adjust rows and columns.
• Create headers and footers.
• Add color.
• Create notes.

This chapter assumes you are familiar with the information covered in Chapter 12, which describes basic spreadsheet skills.

SHOWING GRID LINES

LEVELS 2–4

A grid is the matrix of horizontal or vertical lines dividing the spreadsheet into rows and columns. Each individual line is a grid line. You can show grid lines on screen and print your spreadsheet with or without the grid lines. The default setting for grid lines is to display them; however, you can create interesting effects by turning off the grid lines and adding cell borders as described in the next section.

To show or hide grid lines (Levels 2–4)

Select Draw Grid Lines from the Options menu to show grid lines.

or

Deselect Draw Grid Lines from the Options menu to hide grid lines.

At Levels 3 and 4, you can print grid lines whether they are visible on screen or not. To do so, however, you must use Page Setup on the File menu to specify printing grid lines. For more information, see “Setting Page Setup Options” in Chapter 16.
SHOWING CELL BORDERS

Levels 3-4

To create interesting visual display of your numeric information you can display borders for cells in various configurations, such as in this example:

**Bus Schedule**

<table>
<thead>
<tr>
<th>Morning Schedule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Street</td>
</tr>
<tr>
<td>12th Street</td>
</tr>
<tr>
<td>23rd Street</td>
</tr>
<tr>
<td>West Avenue</td>
</tr>
<tr>
<td>Washington Square</td>
</tr>
<tr>
<td>Edison Avenue</td>
</tr>
<tr>
<td>Marian Plaza</td>
</tr>
<tr>
<td>Seaside Drive</td>
</tr>
<tr>
<td>Main Street</td>
</tr>
<tr>
<td>103rd Street</td>
</tr>
<tr>
<td>205th Street</td>
</tr>
<tr>
<td>Turner Place</td>
</tr>
<tr>
<td>Willinger Avenue</td>
</tr>
</tbody>
</table>

*To display cell borders (Levels 3–4)*

1. Select the cells for which you want borders.
2. Choose Cell Borders from the Properties menu. A dialog box appears:

   ![Cell Borders Dialog Box](image)

3. Select the borders you want. The Outline option displays a border around the selection and deselects Left, Top, Right, and Bottom.
4. Click Apply to apply your changes.
   The dialog box remains on the screen until you close it, so that you can make changes if you want.
5. Click Close to close the dialog box.
ADJUSTING ROWS AND COLUMNS

GeoCalc sets each column to a standard width when you create a spreadsheet. As you enter data, GeoCalc automatically adjusts the row height to accommodate the text size you use. You can manually change both the row height and column width to suit your needs.

Columns

There are several ways to change the width of a column. You can drag the column marker with the mouse or use the Column choices (Narrower, Wider, and Best Fit) on the Cell menu. Alternatively, you can set an exact column width with the Column Width choice on the Cell menu.

To set a column width exactly (Levels 2–4)

1. Select the column for which you want to set the width. To do so, you can either click the column header or select a cell in the column.

2. Choose Column Width from the Cell menu. The following dialog box appears:

3. Enter the number of points you want to use for the column width.

4. Click Apply to apply your changes. The dialog box remains on the screen until you close it, so that you can keep adjusting the width.

A standard column is 64 points wide. A point is nearly 1/72 of an inch.

Rows

Normally the height of each row adjusts automatically to accommodate the text size you use. However, you can manually change the row height if you want to use a different setting.

To set a row height manually (Level 4)

1. Select the row for which you want to set the height. You can either click the row header or select a cell in the row.
2. Choose Row Height from the Cell menu. The following dialog box appears:

3. Enter the number of points you want to use for the row height.
4. Click Apply to apply your changes.
   The dialog box remains on the screen until you close it, so that you can keep adjusting the height.

**USING HEADERS AND FOOTERS**

*Headers* and *footers* are the text that prints at the top or bottom of each page. Headers appear at the top of the page, and footers appear at the bottom. They can be as simple as the page number, or they can include more descriptive information, such as the following:
- Date the document was created or printed.
- Page number.
- Name of the document.
- Your name or the name of your department, business, or school.
- Graphics such as a logo or drawing.

*To create a header or footer (Levels 3–4)*
You can specify that GeoCalc use text you have entered in a cell as the header or footer of the spreadsheet when it is printed. The text appears in the cell and as the header or footer.

1. Enter the header text or footer in a cell or range of cells.

**NOTE**
It is a good idea to enter the text for headers and footers in cells that are not part of the main information in your spreadsheet. Then, when you print the spreadsheet, select a print range that excludes the cells containing the header and footer text.

2. Select the cell or range.
3. Choose Header/Footer from the Cell menu. A submenu appears.
4. Choose either Set Header or Set Footer from the submenu. The selected information will print at the top or bottom of the page, as you have indicated.

*To number pages consecutively*

- Use the PAGE function in the footer cell.
  For more information about the PAGE function, see Appendix A.

**USING COLOR**

**LEVELS 2-4**

You can use color to add interest to your spreadsheet presentation. You can use color for the following elements in a spreadsheet:

- Text
- Background
- Cell Borders

If you don’t have a color printer, the colors print as gray tones.

*To change the color of text (Levels 2-4)*

1. Select the cells which contain the text you want to color.
2. Choose Text Color from the Properties menu. A dialog box appears:

![Text Color dialog box]

3. Fill in the dialog box, selecting the options you want:
   - **% Shaded.** Select the percent shading for the text color. The lower the number, the more faded the color. By default, this setting is 100. If Unfilled is selected, this attribute is set to zero (0).
   - **Color Tools.** Select the text color from the color palette. You can also fine tune the color blend by setting the amount of red, green, and blue in the text color; the default values depend on the selected color.
4. Click Apply to apply your changes. The dialog box remains on the screen until you close it so that you can change the color of different text selections, as you wish.

To change the color of the background (Levels 2–4)

The background is the cell itself. If you set the background color to blue and the text color to black, the cell entries will appear as black text on a blue background.

1. Select the cells for which you want to change the background color.

2. Choose Background Color from the Properties menu. A dialog box appears:

3. Fill in the dialog box, selecting the options you want:

   **Filled or Unfilled.** Select Filled to set other options in this dialog box. By default, the text background color is unfilled.

   **% Shaded.** Select the percent shading for the text background color. The lower the number, the more faded the color. A setting of zero (0) causes the text to disappear. By default, this setting is 100.

   **Color Tools.** Select the text background color from the color palette. You can also fine tune the color blend by setting the amount of red, green, and blue in the text background color; the default values depend on the selected color.

4. Click Apply to apply your changes. The dialog box remains on the screen until you close it so that you can change the background color of different cell selections, as you wish.

To change the color of cell borders at (Levels 3–4)

If you have added cell borders, you can change the color of those borders.

1. Select the cells for which you want borders.
2. Choose Border Color from the Properties menu. A dialog box appears:

![Border Color dialog box](image)

3. Fill in the dialog box, selecting the options you want:

- **% Shaded.** Select the percent shading for the text color. The lower the number, the more faded the color. By default, this setting is 100. If Unfilled is selected, this attribute is set to zero (0).

- **Color Tools.** Select the text color from the color palette. You can also fine tune the color blend by setting the amount of red, green, and blue in the text color; the default values depend on the selected color.

4. Click Apply to apply your changes. The dialog box remains on the screen until you close it, so that you can change the color of different cell borders, as you wish.

**USING NOTES**

**LEVELS 3-4**

You can add notes that provide additional information about the contents of your spreadsheet. They can be a reminder to check a reference, a note about the logic you used for a formula, or a message to a reviewer of the spreadsheet information.

For example, if you want to check a value that seems too high, you can attach a note to the cell containing the questionable value. The cell displays a special Note Indicator so that you know there is a note attached.
The note does not appear in the document; instead, it appears in a special box that you can print with the spreadsheet, if you want.

<table>
<thead>
<tr>
<th></th>
<th>231.00</th>
<th>Note indicator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vanilla</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Strawberry</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pecan Brickle</td>
<td>154.00</td>
<td></td>
</tr>
</tbody>
</table>

To attach a note (Levels 3–4)

1. Select the cell to which you want to attach a note.
2. Choose Notes from the Cell menu. A dialog box appears so that you can enter the note:

3. Type the note in the dialog box.
4. Click Apply to apply your changes. A Note Indicator, a small square, appears to indicate that a note is attached.

If you want to check notes frequently, you can keep the Annotation dialog box displayed on screen so that you can see the notes easily.

5. Click Close to close the dialog box.

To show or hide the Note Indicators (Levels 3–4)

You can turn on and off the display of the little indicators in the upper right corner of cells with attached notes.

1. Choose Other Settings from the Options menu. A submenu appears.
2. Select Show Notes to display the Note Indicators in cells that have attached notes.

or
Deselect Show Notes to hide them.

**To print notes (Levels 3–4)**

When you print the spreadsheet, you can also print the attached notes.

1. Choose Print from the File menu. A dialog box appears:

![Print dialog box]

2. Select Print Cell Notes.

3. Click Print. GeoCalc prints the spreadsheet with the notes attached.
CHAPTER 14

Advanced GeoCalc Formulas Chapter 12

describes how to create formulas and use functions to make complex formulas easy. This chapter builds on that to explain more advanced formula features.
This chapter explains how to do the following:
• Show and hide formulas.
• Assign names to cells and ranges so you can use the names in formulas.
• Turn automatic recalculation on and off.
• Use circular references and iteration in calculations.
• Use advanced functions.
This chapter assumes you are familiar with the information covered in Chapter 1 and Chapter 2, which provides an overview of the skills you need to use any Ensemble application.

**SHOWING AND HIDING FORMULAS**

**LEVELS 2–4**

In order to see a formula for a single cell, you can select the cell and look at the formula in the Edit Bar. If you want, you can display all of the formulas in the spreadsheet cells. This can be helpful if you’ve entered several formulas and want to see them all at once.

<table>
<thead>
<tr>
<th>销售</th>
<th>3000.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>服务</td>
<td>2500.00</td>
</tr>
<tr>
<td>产品</td>
<td>1800.00</td>
</tr>
<tr>
<td>总计 =SUM(C4:C6)</td>
<td></td>
</tr>
<tr>
<td>税 =C8*0.0725</td>
<td></td>
</tr>
<tr>
<td>总计 =C8 + C9</td>
<td></td>
</tr>
</tbody>
</table>

When you show all formulas, formulas appear in cells as if they were labels. That is, if a formula is too long for a cell, it may spill over into the next cell if that cell is empty. If the adjacent cell is not empty, the formula appears cut off.

*To show or hide all formulas (Level 2)*

- Select Show Formulas from the Options menu to show all formulas.
- or
- Deselect Show Formulas from the Options menu to hide all formulas.
To show or hide all formulas (Levels 3-4)

1. Select Other Settings from the Options menu. A submenu appears.
2. Select Show Formulas from the submenu to show all formulas.
   or
   Deselect Show Formulas from the submenu to hide all formulas.

NAMING CELLS AND RANGES

When you create a formula, you normally include references to the cells and ranges you want to use in the calculation. While you can refer to cells and ranges by their addresses, you can also name a cell or a range and then use the name in formulas. This can make your formulas easier to read. For example, which of the following formulas is easier to understand?

=B4=B2+B3

INCOME=SALARY+TIPS

Cell names can be up to 40 characters long and can include alphanumeric characters and the underscore (_) symbol. Cell names cannot contain numbers, spaces, or other characters. If you type a space, GeoCalc inserts an underscore. Cell names are case insensitive; for example, to GeoCalc, the name “Expenses” is the same as “EXPENSES” and “expenses.”

You define a name that refers to a specific cell or range. For example, you might define RATE as A3; then, when entering formulas, you can type RATE instead of typing A3.

You can use both absolute and relative references when you define a name. For example, if you have name $C1 = Income when defined in row 1, but when Income is pasted into row 6, the reference becomes $C6. The reference to column C remains constant (absolute) regardless of where you paste the named cell.

The names you define are saved with your spreadsheet. You can copy formulas that use named cells from one spreadsheet to another; however, the names are replaced by addresses in the second spreadsheet.
To define a name (Levels 3–4)

To help you remember the location or definition of the cells you want to name, you may want to select it first so that the location appears in the Edit Bar.

1. Choose Define Name from the Formulas menu. A dialog box appears, listing any names you have previously defined:

2. Click New. A dialog box appears:

3. Fill in the dialog box, specifying the name and reference you want to use:

   **Name.** Enter the name for the cell or range of cells. Use absolute cell addresses unless you want the named range to reflect a relative position.

   **Definition.** Enter the reference for the cell or range you want to name. You can use relative and absolute references.

4. Click OK. The name appears in the list in the Define Name dialog box.

5. Click Close. The dialog box disappears.
To insert a name in a formula (Levels 3–4)

Once you have defined a name, you can use it in any formulas you create. To do so, you simply type the name in the formula. If you prefer, you can also select the name from a list in a dialog box, as explained in the following procedure.

1. Select a cell and begin entering a formula.
2. When the insertion point in the Edit Bar is in the position for the name you want to use, choose Insert Name from the Formulas menu. The following dialog box appears:

   ![Insert Name dialog box]

3. Select the name you want to insert.
4. Click Paste. The name appears in the Edit Bar.
5. Click Close. The dialog box disappears.

To rename a named cell or range (Levels 3–4)

If you change the definition of a name, the reference changes in existing formulas that contain that name. For example, if you have a range called Expenses that includes B5:B17 and you extend the range to B5:B24, all formulas using the name “Expenses” will be recalculated automatically to include the seven additional cells in the range.

1. Choose Define Name from the Formulas menu. A dialog box appears.
2. Select the name you want to change.
3. Click Change. The following dialog box appears:

   ![Change Name dialog box]

4. Type the new name in the Name box.
5. Click OK. All formulas referring to the old name are updated to the new name.
6. Click Close. The dialog box disappears.

To change the definition of a name (Levels 3–4)

1. Choose Define Name from the Formulas menu. The following dialog box appears, listing existing names:

   ![Define Name dialog box]

2. Select the name for which you want to change the definition.
3. Click Change.
4. Change the cell or range specification to suit your needs. Use absolute cell addresses except unless you want the named range to reflect a relative position.
5. Click OK. GeoCalc updates all formulas to reflect the change.
6. Click Close. The dialog box disappears.

To delete a name (Levels 3–4)

1. Choose Define Name from the Formulas menu. The following dialog box appears:

   ![Define Name dialog box]

2. Select the name you want to delete.
3. Click Delete. A confirmation message appears asking you to whether you want to delete the name.
4. Click Yes to delete the selected name. GeoCalc deletes the name and, for formulas using the deleted name, replaces the name with the cell or range address it referenced.

**CONTROLLING AUTOMATIC RECALCULATION**

**LEVEL 4**

GeoCalc normally recalculates every formula in your spreadsheet every time you make a change. If your spreadsheet is large or contains many complex formulas, this recalculation can be time-consuming. In that case, you may want to turn automatic calculation off. When automatic recalculation is off, you recalculate the spreadsheet manually whenever you want to.

*To turn automatic recalculation on or off (Level 4)*

1. Choose Calculation from the Options menu. The following dialog box appears:

![Calculation Dialog Box]

2. Select Automatic or Manual to specify the type of calculation you want.
3. Click Apply to apply your changes.
4. Click Close. The dialog box disappears.

*To recalculate manually (Level 4)*

When automatic recalculation is off, you must recalculate the spreadsheet manually in order to see the effect of any changes you make.

- Click the Calculate button on the Function Bar.
- or
- Choose Calculate Now from the Options menu.
Occasionally, you may want to create a formula in which the calculation uses the result of the calculation. This is called a *circular reference*. Consider the example below where to calculate gross profit, you subtract expenses from income. If one of the expenses is based on a percentage of the profit — for example, commission payments — the formula has to rely on the outcome of the calculation.

If you calculate this formula in B5 more than once, each successive calculation results in a smaller value. This is called *iteration*. Iteration is the process of recalculating a circular reference repeatedly, until *convergence* occurs, when the difference in the result of each successive calculation is no longer significant. The table below shows the results of a simple iterative calculation so that you can see when the recalculation converges.
Note in the table above how the value in B3 approaches 200 and the value in B4 approaches 100. GeoCalc stops the iteration when the results of a circular reference converge on a single value. If convergence does not happen within the number of recalculations you specify in the Calculations dialog box, GeoCalc automatically stops the iteration. You can specify the limit for the convergence with Maximum Change in the dialog box. If you specify zero for the maximum change, iteration will not stop until it converges (or reaches the maximum number of iterations).

Before using circular references, you must turn on iteration using the Calculation choice on the Options menu. If you enter a formula with a circular reference but have not specified that you want to use iteration, the result of the formula appears as #CIRC#.

To specify iteration (Level 4)

1. Choose Calculation from the Options menu. A dialog box appears:

2. Fill in the dialog box, specifying the options you want.
   - **Allow Iterations.** Select the Allow Iteration option if you are going to use iteration in your spreadsheet.
   - **Maximum Iterations.** Enter the maximum number of iterations you want.
   - **Maximum Change.** Enter the maximum change you want to allow.

3. Click Apply.
4. Click Close. The dialog box disappears.
5. Create the formula with a circular reference. GeoCalc recalculates the formula the specified number of times or stops when the stated value for maximum change is calculated.
NOTE:
If you enter a circular reference in a formula but have not selected the Allow Iterations option, the result of the formula appears as 
#CIRC#.

ADVANCED FUNCTIONS

Chapter 12 describes how to use basic functions and enter the arguments for functions. This section describes how to use more complex functions that involve the following capabilities:

- Conditional statements
- Text strings
- Arrays
- Lookup

See Appendix A for brief descriptions of the functions organized by function type and an alphabetical listing of functions with a complete description and syntax for each.

GeoCalc includes the following types of functions: strings, time and date, financial, mathematical, statistical, trigonometric, information, logical, and print.

You can use a list of values, separated by commas and enclosed in parentheses as arguments for many functions. If the function uses a list for its arguments, then each item in the list is evaluated. For example, the following two functions are equivalent:

\[
\text{SUM(A1:A4)}
\]
\[
\text{SUM(A1,A2,A3,A4)}
\]

NOTE
Named cells and ranges are particularly useful as arguments for functions. For more information on how to name ranges, see "Naming Cells and Ranges" earlier in this chapter.

Working with Strings
String functions let you perform operations on text. At least one argument in each string function is a text string. A string is simply a series of characters.

String functions extract text (including numbers) or return values based on text. For example, you can use RIGHT to extract the
last four digits of a stock number that might identify the manufacturer of a product.

When you enter a string as an argument to a function, you must enclose it in double quotation marks. If the text string itself contains quotation marks, use single quotation marks — for example, “Enter the word ‘vanilla’ in the second blank.” Strings can be up to 255 characters long (including quotation marks). If you want to specify a string with no characters, enter "" to specify empty text.

**Working with Times and Dates**

The time and date functions enable you to enter times and dates in serial form — the form that GeoCalc can understand. For example, you can use the DATEVALUE function to create the appropriate serialized date such as 33988 for January 20, 1993. These functions are most useful in formulas where the time and date are calculated rather than entered as a constant.

**Working with Numbers**

You can use financial, mathematical, trigonometric, and

**FINANCIAL FUNCTIONS**

Financial functions provide formulas for common financial calculations. For example, the FV (Future Value) function calculates the future value of a stream of regularly invested payments.

The arguments for financial functions are either values or addresses of cells that contain values. When the argument is the interest rate, express it as its actual value (.07 rather than 7 to indicate 7%). Be certain to specify the same units for the term and the interest. If the interest is monthly, the term is also monthly. The result of these calculations is always a value.

**MATHEMATICAL FUNCTIONS**

Mathematical functions provide common mathematical formulas. For example, INT (Integer) truncates a value to the nearest whole number. The arguments for mathematical functions are either values or addresses of cells that contain values. The result of these calculations is always a value.
TRIGONOMETRIC FUNCTIONS
Trigonometric functions provide formulas for common trigonometric calculations. The arguments for trigonometric functions are either values or address of cells that contain values. The result of these calculations always return values.

STATISTICAL FUNCTIONS
Statistical functions provide formulas for common statistical calculations. For example, MAX returns the largest value in a list. The arguments for statistical functions consist of either values or address of cells that contain values. The result of these calculations is always a value.

Using Logical Functions
A logical function says, “If this is true then do that.” For example, “If the value is B12 is larger than 10,000 then display 50 in this cell.” To create conditional statements, you use the IF function. The logical functions evaluate relationships and return “true” or “false” results. For example, the IF function looks at a condition such as whether the contents of B13 = 500 and returns a true or false condition.

USING THE IF FUNCTION
IF statements consist of the following three components:
• The condition you want to test.
• The result you want if the condition is true.
• The result you want if the condition is false.
For example, you might want to calculate escalating bonuses for a sales team based on a percentage of the sale. For sales under $10,000, the bonus is 2%. For sales over $10,000, the bonus is 4%. The formula for such an IF statement is as follows:
BONUS = IF(SALES<10000,.02*SALES,.04*SALES)
In this example, SALES<10000 is the condition you want to test; .02*SALES is the result you want if the condition is true, and .04*SALES is the result you want if the condition is false. Therefore, if the SALES figure is $15,000 then the IF statement returns false, and GeoCalc computes the formula in the following way:
BONUS = .04*SALES
BONUS = $600.00
If, on the other hand, the SALES figure is $7,500, then the IF statement returns true, and GeoCalc computes the formula as follows:

\[ \text{BONUS} = 0.02 \times \text{SALES} \]

\[ \text{BONUS} = \$75.00 \]

**USING LOGICAL OPERATORS**

You can also use conditional operators that result in a value of 0 if false or 1 if true. These operators are used with IF functions.

<table>
<thead>
<tr>
<th>SYMBOL</th>
<th>OPERATION</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>A14&gt;B12</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>A14&lt;B12</td>
</tr>
<tr>
<td>( \geq ) (Ctrl+Alt+&lt;)</td>
<td>Greater than or equal to</td>
<td>100(\geq)A14</td>
</tr>
<tr>
<td>( \leq ) (Ctrl+Alt+&gt;)</td>
<td>Less than or equal to</td>
<td>100(\leq)A14</td>
</tr>
<tr>
<td>( \neq ) (Ctrl+Alt+=)</td>
<td>Not equal</td>
<td>A14_B12</td>
</tr>
</tbody>
</table>

**USING THE AND AND OR FUNCTIONS**

By combining IF with the AND and OR functions, you can create even more complex conditional statements. Consider the following examples:

IF(AND(A1>100,B1>100,C1>100),5,0)

The result of this formula is 5 only if the values in A1, B1, and C1 are all greater than 100. Otherwise the result is 0. You can apply the same principle using the OR function, as shown in the following example:

IF(OR(A1>100,B1>100),50,0)

The result of this formula is 50 if either A1 or B1 is greater than 100; otherwise, the result is 0.

**Using Lookup Functions**

Lookup functions create a table within a spreadsheet that acts like a database. You can enter values in the table and then extract information from the table depending on your specifications.

The index entries must be sorted in ascending order. For HLOOKUP, the index is the first row in the selection. For VLOOKUP, the index is the first column.
Lookup tables are good for discounts, tax rates, commission percentages. The multiplication table shown is an example of a simple lookup table.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td># Sold</td>
<td>1257.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td># Units</td>
<td>0.00</td>
<td>100.00</td>
<td>500.00</td>
<td>1000.00</td>
<td>10000.00</td>
</tr>
<tr>
<td>3</td>
<td>Discount</td>
<td>0%</td>
<td>2%</td>
<td>5%</td>
<td>10%</td>
<td>15%</td>
</tr>
<tr>
<td>4</td>
<td>Discount</td>
<td>10%</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

HLOOKUP(B1, B3:F4, 1) = 10%.

In this example, the HLOOKUP function returns the value in the second row of the fourth column in the range B3:F4.

You can extract values horizontally (from rows) with HLOOKUP and vertically (from columns) with VLOOKUP.

**Using Other Functions**

You can also use information and print functions.

**INFORMATION FUNCTIONS**

The information functions return information about a cell or range of cells. For example, COUNT counts the number of items in a list.

**USING PRINT FUNCTIONS**

The print functions return the name of the current file, the current page, and the number of pages. For example, PAGE returns the current page number and can be used in headers and footers for numbering pages.
CHAPTER 15

Charting in GeoCalc  GeoCalc lets you use your spreadsheet data to create a variety of charts that visually represent numeric trends or results. You can include a chart as a part of your spreadsheet. Or, after creating a chart, you can copy it to the clipboard and use it in other GEOS applications like GeoDraw or GeoWrite.
This chapter describes the basic types of charts you can create and explains how to do the following:

- Create new charts.
- Change the type of a chart.
- Add titles, legends, axis marks and grid marks to your charts.

WHAT IS A CHART?

A chart is a graphic representation of numeric data. For example, you can create a chart to show the value of the consumer price index over a period of years, the total revenue for a company broken down by region, or the average student test grade through the school year.

Charts show the relationships between a series of values broken down into categories. For example, in a chart of monthly expenses, the series would include January, February, March, and so forth; the categories would include items like Rent, Food, and Utilities; and the values would be the actual expenditure incurred.

TYPES OF CHARTS

GeoCalc lets you create the following types of charts:

- Column
- Bar
- Line
- Area
- X-Y Plot
- Pie
- High/Low

All but the High/Low chart offer variations you can choose once you have created the chart. Each of the seven standard charts is illustrated in the following sections.
**Column Chart**

A column chart (or a vertical bar chart) plots each category in a series as a vertical bar. The height of the bar corresponds to the value of that category. The following illustration shows a typical column chart:

![Column Chart Illustration](image)

Variations on the standard column chart include the following:

- **Overlapped.** The columns within each category overlap each other slightly.

- **Stacked.** The columns within each category are stacked vertically on top of each other. The height of the stacked column is the sum of the values in the category.

- **Stacked Percentage.** The columns in each category are stacked so that the total height represents 100%. The height of each value is shown as that value's percentage of the whole category. This is like a vertical pie chart.

- **One Color With Values.** Columns all have the same color and are labeled with their numeric values. This variation is a good choice if you do not have a color monitor or color printer.

- **One Color With No Space Between Categories.** Columns all have the same color, and the last column in category 1 abuts the first column in category 2 with no space between them.
Bar Chart

A bar chart is like a column chart with the bars plotted horizontally rather than vertically.

Line Chart

A line chart plots a point indicator for each value on one axis in relation to the text label on the other axis, and connects the points in each series with straight lines. This type of chart is useful for showing how a value changes over time. The following illustration shows a typical line chart:

Variations on the standard line chart include the following:
• **Lines Only.** Draws only the lines connecting the points in each series; does not draw the markers for each point.

• **Markers Only.** Draws only the markers for each point; does not connect the markers with lines.

• **Drop Lines.** Draws the markers for each point, and then connects the points in each category with a vertical line; does not draw lines connecting the values.

**Area Chart**

An *area chart* is a line chart in which the area below the line is filled with a pattern or solid color. The following illustration shows a typical area chart:

![Area Chart Example](image)

Variations on the standard area chart include the following:

• **Stacked Percentage.** Like the column stacked percentage chart, this area chart shows the areas for each category stacked to a constant height representing 100%, and the values are shown as percentages.

• **Drop Lines.** Draws a vertical line to connect the points in each category.

• **Series Name.** Draws the name of each series in the center of its filled area.

**X-Y Plot Chart**

An *X-Y plot chart*, sometimes called a *scatter plot*, looks similar to a line chart, but there is a significant difference between the two. Line charts plot a value against a label (see the line chart
illustration above), whereas X-Y plot charts plot one value against another. X-Y plot charts are unique in that they take categories two rows at a time and plot them against each other. The following illustration shows a typical X-Y plot chart:

Another difference between X-Y plot charts and line charts is that on an X-Y plot chart, the tick marks along each axis (X is the horizontal axis, Y the vertical) are spaced according to their value, which may not always be at regular intervals because of the potentially random nature of the data. On a line chart, one axis always contains text labels which are usually evenly spaced for visual clarity.

Variations on the standard X-Y plot chart include the following:
• **Lines Only.** Draws only the lines connecting the points in each series; does not draw the markers for each point.
• **Markers Only.** Draws only the markers for each point; does not connect the markers with lines. This choice makes an X-Y plot that looks like a traditional scatter plot.
Pie Chart

A pie chart is a circular chart in which the size of each "slice" — or wedge — is proportional to its percentage of the whole. Pie charts are unique in that they only draw one category of data. The illustration below shows a typical pie chart.

Variations on the standard pie chart are:

- **Category Titles.** Inserts the category titles into the chart.

- **One Color with Category Titles.** Shows all the wedges of the pie in one color, with category titles.

- **First Wedge Exploded.** Pulls the wedge that starts near the 12 o’clock position out slightly from the rest of the pie.

- **All Exploded.** Pulls all the wedges apart slightly.

- **With Percentages.** Shows the percentage of the whole pie that each wedge represents.
High/Low Chart

A high/low chart is useful for tracking pairs of data that mark a high and low or a start and end value — such as the price of stocks or the day's temperature range. Each pair of data points are plotted as a single vertical line. You can also show a third or fourth relative value along with each pair, such as the stock's daily closing price or the average temperature. High/low charts require two categories of data, and may show up to four categories. The third category places tick marks to the left; the fourth category places tick marks to the right.

There are no variations available for high/low charts.

CREATING CHARTS

LEVELS 2–4

To create a chart you must first define the data that is to appear in the chart. You can select a portion of an existing spreadsheet, or use a blank spreadsheet in which you enter just the data you wish to chart. For example, the data in the sample line chart that appears earlier in this chapter is one row of data from a larger budget spreadsheet. The spreadsheet shown in the procedure below was developed specifically to generate a chart.

The following illustration shows the general format for data on which you base a chart:
Chart Title. The title of the chart. This label is optional. If you don’t place any text in this cell, the chart won’t be titled. You can title it later using the Titles and Legends choice on the Chart menu.

Series Name. The series names are the labels of the spreadsheet columns.

Category Name. The category names are the labels of the spreadsheet rows.

Value. The numeric data values GeoCalc charts. Each category you wish to chart should have at least one value for each series. Empty cells in your spreadsheet will be interpreted as zeros in your chart.

NOTE

Do not use numbers for the chart title, series names, or category names. For example, instead of naming categories 1, 2, and 3, use something like Day 1, Day 2 and Day 3. If you must use a number, like 1993 and 1994, place a quote mark (" ) before the number so GeoCalc interprets it as text.

To create a chart (Levels 2–4)

Once your labels and data are in place on the spreadsheet, you create charts using either the Charts menu or the charting buttons on the Style Bar.

1. Open the spreadsheet that contains the data you want to chart.

   or

2. Open a new spreadsheet and enter the data you want to chart.

3. Select the cells that contain the data you want to chart.
When you select cells, GeoCalc activates the Chart Menu and Chart buttons on the Style Bar.

3. Decide which type of chart will best depict the data. Remember that a pie chart can only represent one category, X-Y plots compare two or more categories, high/low charts require from two to four categories of data. Use pie charts for percentages, line charts for trends, bar charts for comparing amounts for fixed time intervals, and X-Y plots to show cause and effect.

4. Select the desired type of chart on the Style Bar.

or

Open the Chart menu and select the basic type of chart from the Create submenu. The chart appears as a graphic object in the lower right corner of the GeoCalc window. For more information about charts as graphic objects, see the section “Manipulating Charts” in this chapter.

CHANGING THE TYPE OF CHART

LEVELS 2-4

You can choose a different type of chart to get a different view of your information. To do so, simply click the appropriate chart button.

Once you’ve created a chart, GeoCalc activates additional commands on the Chart menu. Use the Change Type choice on the Chart menu to change the basic type or change the chart to one of its type variations. Alternatively, if you want to change just the type, not the variations, you can use the Chart buttons on the Style Bar instead.
To change the type of chart (Levels 2–4)

1. Select Change Type from the Chart menu. The following dialog box appears:

   ![Change Type Dialog Box]

   If the dialog box covers all or part of the chart, simply move it out of the way.

2. Select the type of chart or variation you want.

3. Click Apply. GeoCalc changes the chart. If you wish, you can make further changes and click Apply to see the effects. The dialog box remains on the screen until you close it.

MANIPULATING CHARTS

LEVELS 2–4

When you create a chart, it appears in your spreadsheet as a graphic object with small filled boxes around the perimeter, and a diamond shaped spot in the center. These handles indicate the chart is the currently selected object.

You can use the handles to manipulate your chart just as you would manipulate any graphic object. The diamond shaped handle in the center is the move handle. You use move handle to move the chart, and you use the other handles to resize it.

The procedures in this section explain how to perform basic operations with graphic objects. For more information about working with graphic objects, see GeoDraw, starting with Chapter 8.

Moving a Chart

You can move the chart to any location in your spreadsheet.
To move a chart (Levels 2–4)

1. If the chart is not selected, click the edge of the chart to select it. Handles appear around the chart frame and the move handle appears in the center.

2. Place the pointer over the move handle in the center of the chart. When the pointer changes to a pair of crossed arrows, click and hold the left mouse button to grab the chart.

3. Holding the mouse button, drag the mouse to move the chart to the position you want.

4. Release the mouse. The chart appears in the new position.

Resizing a Chart

You can make a chart larger or smaller by using the handles to resize it.

To resize a chart (Levels 2–4)

Place the pointer over one of the handles that surrounds the chart, click, hold, and drag the mouse. Dragging toward the center of the chart reduces it, while dragging away from the center enlarges it.

Changing Chart Properties and Attributes

Attributes are visual elements such as color, line thickness, and fill pattern. If you select a chart and then click one part of it, such as a wedge of a pie chart, you can change the attributes of that part of the chart.

To change text properties in a chart (Levels 2–4)

1. Select the chart by clicking it. Handles appear around the chart.

2. Select the text item within the chart that you want to change by clicking on it. Handles appear on that item to indicate it is
selected. You can select multiple text items by holding the Ctrl key as you click. You cannot move any labels that the chart has generated, though you can edit text labels using the Text tool.

3. Choose the text property you wish to change — font, style, size, or color — from the Properties menu or the Style bar.

4. GeoCalc applies the change to the selected text.

To change an attribute of an element in a chart (Levels 3–4)

1. Select the chart by clicking it. Handles appear around the chart.

2. Select the object within the chart that you want to change by clicking on it. Handles appear on that object to indicate it is selected. You cannot move the component parts of the chart or any labels that the chart has generated, though you can edit text labels using the Text tool.

3. Choose the attribute you wish to change from the Graphics menu.

Many of these choices have dialog boxes. For information specific to the choices on this menu, see Chapter 10.

4. Click Apply to apply your changes.

5. Click Close to close the dialog box.

Deleting a Chart

You can delete a chart you no longer need.

To delete a chart (Levels 2–4)

1. If the chart is not selected, click the edge of the chart to select it. Handles appear around the chart frame and the move handle appears in the center.

2. Press Delete.

or

Choose Delete from the Edit menu.

GeoCalc deletes the selected chart.

Using a Chart in Another Application

You can copy a chart to a document you create with another GEOS application. For example, you may want to use a chart in a report you’ve created in GeoWrite, or in an illustration you’ve created in GeoDraw.
To copy a chart to another application (Levels 2–4)

1. Select the chart you want to copy by clicking it. Handles appear around the chart.
2. Choose Copy from the Edit menu.
3. Go to the other application and choose Paste from the Edit menu. The chart appears.

ADDING TITLES AND A LEGEND

LEVELS 2–4

A picture is worth a thousand words, but sometimes you need to add a few words of explanation — especially for a chart.

To add titles and legend to a chart (Levels 2–4)

1. Select the chart with the pointer tool.
2. Choose Titles & Legend from the Chart menu. A dialog box appears:
3. Fill in the dialog box, selecting the options you want:
   - **Chart Title.** Select this option to add a title to the chart. GeoCalc looks for title text in the upper left of the selected chart range. If it can't find any text, a text object with the words "Chart Title" appears at the top of your chart. You can change the title later.
   - **X-Axis Title.** Select this option, if applicable, to add a title to the chart along the X-Axis.
   - **Y-Axis Title.** Select this option, if applicable, to add a title to the chart along the Y-Axis.
   - **Legend.** Select this option if your chart shows more than one category and you want to define the colors or patterns GeoCalc
uses to differentiate between categories. You can also select its position on the chart: Horizontal (below chart) and Vertical (at right of chart).

4. Click Apply to apply your changes. GeoCalc adds the items you selected to your chart, as shown in the following example:

5. Click Close to close the dialog box.

*To change text in the Chart Title or Axis Titles (Levels 3–4)*

1. Select the Text tool from the Drawing Tool Bar. The pointer becomes a crossed I-beam when you move it over the chart.

2. Click the text object you want to change. The text object is outlined, the pointer becomes a single I-beam, and a vertical bar indicates the insert point for text.

3. Use the Backspace and Delete keys to remove text you don’t want, or highlight the unwanted text and choose Delete from the Edit menu.

4. Enter the new text.

5. When you are finished with the Text tool, select the Arrow pointer from the Drawing Tool Box and click an empty area of the chart to remove the outline around the text (so that further changes aren’t accidentally made to the text).

You can apply a variety of style features to the text. For more information about using text features, see “Selecting and Editing” in Chapter 2. For more information about using text in graphics, see the chapters on GeoDraw, starting with Chapter 8.
There are three different types of chart markings you can change: axis markings, grid markings, and the marker shapes that indicate values on a chart.

**Setting Axis and Grid Markings**

*Axis markings* and *grid markings* are useful visual aids that can help people understand your chart. Axis markings are the tick marks that divide the axis lines. Grid markings are vertical and horizontal lines that can cover the chart area between the axes.

*To add axis markings to a chart (Levels 2–4)*

1. Choose Axis from the Chart menu. The Axis dialog box appears:

2. Select the type of axis markings you want, and click Apply. The markings appear in your chart. The following illustration shows a chart with tick marks along the X-Axis:

3. Click Close to close the dialog box.
To add grid markings to a chart (Levels 2–4)

1. Choose Grid Lines from the Chart menu. The Grid Lines dialog box appears:

   ![Grid Lines Dialog Box]

2. Select the axis from which you wish the grid lines to originate, and click apply. The grid lines appear in your chart.

   ![Chart with Grid Lines]

3. Click Close to close the dialog box.

Changing Marker Shapes

Markers are the points in line and X-Y plot charts. If you can’t use color to differentiate between markers, it is sometimes difficult to interpret the data in a chart. Changing the shape of the markers in one or more categories can help make the chart easier to read.

To change the marker shape (Levels 2–4)

1. Select the markers you want to change by clicking on one of them in your chart. The markers in that category are surrounded by outlines to indicate they are selected.

2. Open the Charts menu and choose Marker Shape. The Marker Shape dialog box appears:

   ![Marker Shape Dialog Box]
3. Click the marker shape you want and click Apply. The selected markers change shape as specified.

The dialog box remains on the screen until you close it.
Additional GeoCalc Features  GeoCalc has many additional features to help you create accurate and attractive spreadsheets. You can sort your spreadsheet, create custom number and date formats, and add graphics. This chapter explains these features, and also describes printing and how to fine tune GeoCalc's user level.
This chapter describes how to do the following:

- Use tools on the Style and Function Bars that are unique to GeoCalc.
- Print spreadsheets.
- Sort rows or columns of information.
- Create custom number and date formats.
- Add graphics to a spreadsheet.
- Use GeoCalc with other applications.
- Fine tune your user level.

This chapter assumes you are familiar with the information covered in Chapter 1 and Chapter 2, which provide an overview of the skills you need to use any GEOS application.

**TOOL BARS IN GEOCALC**

**LEVELS 2–4**

At Level 1 in GeoCalc, no Tool Bars are available. At Level 2 and above, you can use the Style and Function Bars introduced in this section. For general information about using Tool Bars, see Chapter 2.

**Using the Style Bar**

The Style Bar appears when you open GeoCalc at Level 2. It allows you to change the text format of values and labels. In addition, you can use the tools on the Style Bar to add and delete rows and columns and create charts from the spreadsheet data.
The Style Bar also contains charting tools that are unique to GeoCalc, as shown in the following illustration. For more information about working with charts, see Chapter 15.

Text styles: plain, bold, italic, and underlined

Click to see a list of fonts.

Click to see a list of font sizes.

Text alignment: left, centered, right, and full

Chart: column, bar, line, area, point, pie, and high/low

The following tools are unique to GeoCalc. For instructions on how to use these tools to create charts, see “Creating Charts” in Chapter 15.

<table>
<thead>
<tr>
<th>BUTTON</th>
<th>TOOL NAME</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Column" /></td>
<td>Column</td>
<td>A column chart plots each category as a series of vertical bars. The height of the bar corresponds to the value of the category.</td>
</tr>
<tr>
<td><img src="image" alt="Bar" /></td>
<td>Bar</td>
<td>A bar chart is like a column chart except that the bars are horizontal rather than vertical.</td>
</tr>
<tr>
<td><img src="image" alt="Line" /></td>
<td>Line</td>
<td>A line chart is a plot of values connected by straight lines.</td>
</tr>
<tr>
<td><img src="image" alt="Area" /></td>
<td>Area</td>
<td>An area chart is a line chart in which the area below the line is filled with a pattern.</td>
</tr>
<tr>
<td><img src="image" alt="Point" /></td>
<td>Point</td>
<td>A point chart is a plot of points.</td>
</tr>
<tr>
<td><img src="image" alt="Pie" /></td>
<td>Pie</td>
<td>A pie chart is a circular chart where each slice represents a part of the whole.</td>
</tr>
<tr>
<td><img src="image" alt="High/Low" /></td>
<td>High/Low</td>
<td>A chart showing stock market data: high, low, and close.</td>
</tr>
</tbody>
</table>
Using the Function Bar

The Function Bar contains tools for performing file functions like opening, closing, and saving files, as well as tools for editing and for zooming in and out. You must display these tools before you can use them; for more information, see “Using the Tool Bars” in Chapter 2.

The Function Bar also contains tools that are unique to GeoCalc, as shown in the following illustration:

- Document options: new document, template, open, close, save, and quick backup
- Edit control options: cut, copy, paste, select all, and delete
- View options: 100% view, zoom in, zoom out, and redraw screen
- Add/delete buttons: add row, add column, delete row, and delete column
- Sort cells forward and sort cells backward
- Calculate now
The following tools are unique to GeoCalc:

<table>
<thead>
<tr>
<th>BUTTON</th>
<th>TOOL NAME</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Insert Row]</td>
<td>Insert Row</td>
<td>Adds one row above the current row. If you have selected multiple rows, Add Row adds the same number of rows above the selection.</td>
</tr>
<tr>
<td>![Delete Row]</td>
<td>Delete Row</td>
<td>Deletes the current row. If you have selected multiple rows, Delete Row deletes the rows containing the selected cells.</td>
</tr>
<tr>
<td>![Insert Column]</td>
<td>Insert Column</td>
<td>Adds one column above the current column. If you have selected multiple columns, Add Column adds the same number of columns to the right of the selection.</td>
</tr>
<tr>
<td>![Delete Column]</td>
<td>Delete Column</td>
<td>Delete the current column. If you have selected multiple columns, Delete Column deletes the columns containing the selected cells.</td>
</tr>
<tr>
<td>![Sort Forward]</td>
<td>Sort Forward</td>
<td>Sorts the selected cells in alphabetic or numeric order.</td>
</tr>
<tr>
<td>![Sort Backward]</td>
<td>Sort Backward</td>
<td>Sorts the selected cells in reverse alphabetic or numeric order.</td>
</tr>
<tr>
<td>![Calculate]</td>
<td>Calculate</td>
<td>If you have specified manual calculation using Calculate on the Options menu, you can click this button to make GeoCalc calculate all formulas in the spreadsheet.</td>
</tr>
</tbody>
</table>

For more information on manipulating rows and columns, see “Inserting and Deleting Rows and Columns” in Chapter 12.

For more information about sorting cells, see “Sorting“ in this chapter.

For more information on recalculating formulas, see “Controlling Automatic Recalculation” in Chapter 14.
PRINTING

Printing a GeoCalc document is much like printing any other GEOS application document. For general information about printing, see “Printing Documents” in Chapter 1.

At Levels 1 and 2, you can print your spreadsheet but cannot specify any special printing options. This section describes the additional printing features that are available at Levels 3 and 4.

Printing Spreadsheets

At Levels 3 and 4, you can set various printing options using the Page Setup choice on the File menu. For more information, see the next section, “Setting Page Setup Options.” After setting any special printing options, you are ready to print your spreadsheet.

To print from within GeoCalc (All Levels)

- Choose Print from the File menu.
  or
- Click the Print button on the Style Bar.

A dialog box appears so that you can specify printer options. For more information about this dialog box, see “Printing Documents” in Chapter 1.

GeoCalc prints your spreadsheet. If you have created a chart, it is printed as part of the spreadsheet, just as you see it on the screen.

To calculate the spreadsheet (Level 4)

At Level 4, you can specify manual calculation. If you have specified manual calculation, be sure to recalculate your spreadsheet before printing it.

- Choose Calculate Now from the Options menu
  or
- Click the Calculate button on the Function Bar.

Setting Page Setup Options

Before you print, you can set print options with the Page Setup choice on the File menu.
To set print options (Levels 3–4)

1. Choose Page Setup from the File menu. A dialog box appears:

![Page Setup dialog box]

2. Fill in the dialog box, changing the options you want:

**Starting Page Number.** The default starting number is 1, but you can specify a different starting number for your spreadsheet. Either click the up and down arrows or type a new number. The page number appears when you use the PAGEO function in a cell and designate that cell as a header or footer. This option does not affect the number of pages printed.

**Print Sideways.** Normally, the spreadsheet is printed as a standard upright page. Select this option if you want to print it sideways.

**Scale to Fit One Page.** Select this option if you want to enlarge or reduce your spreadsheet to fit on a single page. If your spreadsheet is too large, it may be reduced so much that you cannot read it.

**Continuous Printing.** Use this option if you want your spreadsheet printed as one long continuous page. This is particularly effective for dot matrix printers that use continuous form, fan-folded paper. If you print on single sheets, you can tape the sheets together.

**Center Vertically.** Use this option to center the printed spreadsheet on the page.

**Center Horizontally.** Use this option to center the printed spreadsheet on the page.

**Print Grid Lines.** Select this option if you want grid lines to appear on your printed spreadsheet. (To get an idea of how the spreadsheet looks with and without grid lines, choose Draw Grid lines from the Options menu.)

**Print Row and Column Titles.** Use this option if you want the row and column references to be printed on each page of your spreadsheet.
If you specify a header or footer and don’t check these print options, your printed spreadsheet will not have headers and footers.

**Print Headers.** Click this option if you want to have headers printed on the pages of your spreadsheet. You can specify headers using the Header/Footer choice on the Cell menu.

**Print Footers.** Click this option if you want to have footers printed on the pages of your spreadsheet. You can specify footers using the Header/Footer choice on the Cell menu.

3. Click Apply. GeoCalc records the settings you selected.

4. Click Close to close the dialog box.

**SORTING**

**LEVEL 4**

You can sort information in a row, column, or range of cells in either alphabetical (A-Z) or numeric (1-9) order. In addition, you can sort in either ascending (A-Z and 1-9) or descending (Z-A and 9-1) order. A range is sorted by the row or column containing the active cell.

For example, you may be keeping track of the payments of a group of piano students. As shown in the illustration below, you can alphabetize the list of names and payments. Select the range of cells containing all the names and payment information, being certain that the list you want to alphabetize is the leftmost column in the selection. Then, when you sort the list, the names (and the payments for that student) are shown in alphabetical order.

**Unsorted**

<table>
<thead>
<tr>
<th>Susie Jones</th>
<th>$25.00</th>
<th>No Payment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Izuki Iwamai</td>
<td>No Payment</td>
<td>$25.00</td>
</tr>
<tr>
<td>Sean O’Gara</td>
<td>$25.00</td>
<td>$25.00</td>
</tr>
</tbody>
</table>

**Sorted**

<table>
<thead>
<tr>
<th>Izuki Iwamai</th>
<th>No Payment</th>
<th>$25.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Susie Jones</td>
<td>$25.00</td>
<td>No Payment</td>
</tr>
<tr>
<td>Sean O’Gara</td>
<td>$25.00</td>
<td>$25.00</td>
</tr>
</tbody>
</table>

**NOTE**

Be sure to save your work before you perform a sort. Then, if the results of the sort are not what you expected, you can choose Other from the File menu and then choose Discard Changes from the Other submenu.
To sort information in a spreadsheet (Level 4)

1. Select the cells containing the information you want to sort. Be sure to select all the cells you want to sort.

2. If the active cell is not in the row or column you want to sort, move it with one of the following keystrokes:
   - **Return.** Moves the active cell down one row.
   - **Shift+Return.** Moves the active cell up one row.
   - **Tab.** Moves the active cell right one column.
   - **Shift+Tab.** Moves the active cell left one column.

GeoCalc will sort all selected cells by the row or column containing the active cell.

3. Choose Sort from the Edit menu. A dialog box appears:

![Sort dialog box]

4. Fill in the dialog box, specifying the sort criteria you want to use:
   - **Sort By.** You can sort either rows or columns.
   - **Sort Order.** You can sort in either Ascending or Descending order — for example, A, B, C, D or Z, Y, X, W.
   - **Sort Options.** You can specify the following sort options:
     - **Ignore Case/Accent.** You can have the sort ignore any differences in upper and lower case and ignore accents on letters in alphabetical sorts.
     - **Ignore Spaces/Punctuation.** You can have the sort ignore spaces between words and punctuation marks (such as period in Mr.) in alphabetical sorts, such as in a phone book.

4. Click Sort. GeoCalc sorts the selected cells.

To perform a simple sort more quickly (Level 4)

If you want to sort by the left-most column in a range, you can use the sort tools on the Function Bar if it is displayed.

1. Select the range of cells you want to sort.

2. Click the Sort Forward tool on the Function Bar to sort the rows in ascending order.
Click the Sort Backward tool on the Function Bar to sort the rows in descending order.
GeoCalc sorts the range in the order you selected.

CREATING NUMBER AND DATE FORMATS

LEVELS 3–4

GeoCalc offers a wide variety of standard number and date formats. However, you can create additional number at date formats to suit your needs. For example, if you want to show values with 6 decimal places, you can create a special format.

To create a number or date format (Levels 3–4)

1. Choose Number Format from the Properties menu. The following dialog box appears:

![Number Format dialog box]

2. Select a format on which you can base the new format. For example, if you want to create a format for displaying numbers with six decimal places, you might pick Fixed and specify six decimal places.
3. Click Create. A dialog box appears:

4. Fill in the dialog box, selecting the options you want. Refer to the examples in the dialog box as you set your specifications.

**Name of Format.** Enter a name for the new format.

**Places.** Enter the number of decimal places.

**Offset.** Enter the number of offset places. Negative numbers move the decimal point to the left and positive move it to the right.

**Options.** Select format options from the drop-down list: Commas, Percent sign, leading and trailing zeros, and the position of the sign (+ or -) relative to the header or trailer. For example, if the sign follows the header, then a negative dollar amount would be formatted like this: $-100 rather than -$100.

**Fixed/Scientific.** Select either fixed notation or scientific notation.

**Leading.** Enter the numbers or characters you want to appear in front of each value you enter, like a prefix. You can specify a prefix for Positive, Negative, or All Numbers. For example, if you enter **DM** in the All box, every value using this format will begin with **DM**; if you enter **345**, it will appear as **DM345** in the active cell.

**Trailing.** Enter the numbers or characters you want to appear to at the end of each value you enter, like a suffix. For example, if you enter **DM** in the All box, **DM** will appear at the end of every value using this format; if you enter **345**, it will appear as **345DM** in the active cell.

5. Click OK. The new format is saved with the spreadsheet.
NOTE:
At Level 4, if you want to create number and date formats that you will use in most of your work, you can create them in a new document and save them as the default empty document. For more information about changing the default empty document, see “Default Settings for Empty Documents” in Chapter 3.

USING RULERS

Levels 2-4

The rulers for a spreadsheet are normally the row numbers and columns letters. Optionally, you can turn off the row and column headers or select alternate rulers.

In GeoCalc, you can choose the same types of rulers that are available in other GEOS applications: Inches, Centimeters, Points, Picas, and System Default. After you choose one of these rulers, you will see it instead of the spreadsheet column and row headers. This is especially useful if you want to see where a page breaks or when you are working with graphics.

See Chapter 2 for more information about displaying rulers.

To specify a different ruler (Levels 2-4)
1. Choose Rulers from the Options menu.
2. Choose the type of ruler you want from the submenu.

ADDING GRAPHICS

Levels 3-4

You can include charts and drawings in the spreadsheets you create with GeoCalc. Charting lets you build graphs and pie charts based on data you enter in a spreadsheet. For more information about working with charts, see Chapter 15, “Charting in GeoCalc.”

In addition to charts, at Levels 3 and 4, you can use the Drawing Tool Bar and the Graphics Tool Bar to create drawings right in your spreadsheet. If you prefer, you can also create drawings in GeoDraw and then paste them into a GeoCalc document.

Graphics you add to a GeoCalc document actually appear on a transparent drawing layer “on top of” the spreadsheet. If you fill objects with transparent fill patterns, you can see the spreadsheet.
information through the objects. For more information about working with fill patterns, see Chapter 10.

If you are using GeoCalc information for a report or presentation, you can create the visual effects right in GeoCalc using the drawing tools, charting capabilities, and cell borders.

If you are already familiar with GeoDraw, you already know how to create drawings in your spreadsheet. If not, you may want to read the GeoDraw chapters, beginning with Chapter 8. In those chapters, you'll find complete information about GeoDraw, including the Graphics menu and the Drawing, Bitmap, and Graphics Tool Bars.

**USING GEOCALC WITH OTHER GEOS APPLICATIONS**

*Levels 2–4*

You can use information from your spreadsheet in other GEOS applications. For example, you can copy a range of cells to a GeoWrite document. Once you've pasted your information, you can add borders and other visual enhancements with the graphics tools.

Information you paste into other applications is not automatically updated if you make changes to your original spreadsheet. Therefore, if you change the spreadsheet, you must recopy it into the GeoWrite document if you want to keep the information in both documents the same.

For more information about working with multiple applications, see Chapter 3.

*To use spreadsheet data in another application (Levels 2–4)*

1. Create the spreadsheet data you want to use.
2. Select the range that you want to paste into another application.
3. Choose Copy from the Edit menu to copy the selection. The selection is copied to the Clipboard.
4. Open the application and document into which you want to paste the information.
5. Move the insertion point to the location where you want to paste the spreadsheet information.
6. Choose Paste from the Edit menu. The information is pasted into your document with tabs inserted between the columns and with each row starting a new line.
You can export information from GeoCalc in order to use it with DOS applications like Lotus® 1-2-3® and dBASE.® Similarly, you can also import information from DOS applications into GeoCalc. With GeoCalc, you can import and export spreadsheet information in several formats: Lotus, dBASE, and CSV.

CSV, which stands for *comma-separated values*, is a format that many applications can open or import. In a CSV file, each row of your spreadsheet is stored as line of text, with the values in each column separated by commas. You can use this format to export information from GeoCalc for use in any applications that can open or import a CSV file.

This section explains how to export and import spreadsheet information in GeoCalc.

**Exporting**

When you export a spreadsheet in dBASE or CSV format, you can leave the columns in their original order, or you can change the order to match the requirements of the application with which you plan to use the exported file.

*To export a spreadsheet in Lotus or dBASE format (Levels 2–4)*

1. Choose Other from the File menu.
2. Choose Export Document from the Other submenu. A dialog box appears.:

![Select Folder and Format for Export](image)

3. Fill in the dialog box, changing the export options to suit your needs:

**Select Folder and Format for Export.** Using the standard file selector controls, select the folder where you want to save the
exported file. For more information about file selectors, see Chapter 1.

**Formats.** Choose the application in which you want to use the exported information, or choose Comma Separated Values to export information in CSV format.

**New File Name.** Enter a name for the exported file. The correct extension already appears in this box, so you don’t need to enter it. Be sure to enter a standard DOS file name no more than eight characters long. For more information about DOS file names, see “Naming a Document” in Chapter 1.

4. Click Export. GeoCalc creates a file using the specified format.

*To change the order of columns when exporting (Levels 2–4)*

When you export in dBASE format, GeoCalc creates field names (Field1, Field2, Field3, etc.). You can map the information you are exporting to change the order.

**SHORTCUT**

If you prefer, you can rearrange the columns in your spreadsheet so they appear in the order you want. If there are a small number of columns, this may be faster than mapping the information you are exporting.

1. Create the spreadsheet as usual.
2. Choose Other from the File menu.
4. Fill in the dialog box, selecting either CSV or dBASE from the Formats list. The Map Export Fields button is activated.
5. Click Map Export Fields. A dialog box appears with Column A, Column B, and so on listed in the Source List box; the columns that appear here correspond to the occupied columns in the spreadsheet. The Destination List consists of field names (Field 1, Field 2, Field 3, etc.) equal to the number of occupied columns in the spreadsheet.

![Map Export Fields dialog box]

6. Click Field 1 in the Destination List. If the lists in the dialog box are empty, make sure the spreadsheet contains data.

7. Click the column in the Source List that you want to be Field 1 in the export database. The selected name will be the field name associated with Field 1.

8. Click Map. The field pair appears in the Map List. (To break the link between a mapped pair of fields, you can select the pair in the Map list and then click Unmap.)

9. Continue designating pairs until you have specified all the fields you want to map. If you leave any source field unpaired, that field will not be exported.

10. Click Done. The dialog box disappears.

11. Click Export. GeoCalc exports your spreadsheet information in the format you specified.
**Importing**

You can import information from files in Lotus, dBASE, or CSV format. Many applications can export information in these formats, so you do not necessarily have to be using Lotus or dBASE in order to import information into GeoCalc. When you import dBASE and CSV files, you can change the order of the columns when you import.

**NOTE**

Once you begin importing a file, you cannot interrupt the operation. You might need to wait when importing a very large file. Make sure you select the correct file to import.

*To import spreadsheet, CSV, or database data (Levels 2-4)*

1. Choose New/Open from the File menu. The following dialog box appears:

2. Click Import. The following dialog box appears:
3. Select the application from which you are importing from the Formats list.

4. Select the file name of the imported file.

5. Click Import. The information from the import file appears in a GeoCalc window.

To change the order of columns when importing (Levels 2–4)

When you import a dBASE or CSV file, GeoCalc enters data in the order in which it appears in the database. You can map this information in a different order, if you choose.

SHORTCUT

If you prefer, you can rearrange the columns in your spreadsheet after importing the dBASE or CSV file. If there are a small number of columns, this may be faster than mapping the information you are importing.

1. Choose New/Open from the File menu. The following dialog box appears:
2. Click Import. The following dialog box appears:

3. From the Formats list, select the application from which you are importing.

4. Using the standard file selector controls, select the file you want to import. For more information about file selectors, see Chapter 1.

5. Click Map Import Fields. The following dialog box appears:

The Source List shows the field names of the incoming file. The Destination List shows the names of the fields (Column1, Column2, Column3, and so forth).

If the lists in the dialog box are empty, make sure you selected a file in step 4.

6. Click Field 1 in the Source List.

7. Click the field name you want for Field 1 the Destination List.

8. Click Map. The field pair appears in the Map List. (You can select a field pair in the Map list and click Unmap to break the link between mapped pairs.)

9. Continue designating pairs until you have specified all the fields you want to map. If you leave any source field unpaired, it will not be imported from the database.
10. Click Done. The dialog box disappears.

11. Click Export. The information appears in a GeoCalc window in the order you specified.

FINE TUNING YOUR USER LEVEL

Chapter 1 describes how to change and fine tune your user level. When you choose Set User Level from the Options menu, and click the Fine Tune button, you can toggle the following options on or off:

• Simple Cell Attributes
• Complex Cell Attributes
• Page Setup
• Simple Options
• Clear
• Charting
• Graphics
• Complex Graphics
• Names
• Notes
• Search
• Advanced Spreadsheet

If you are working at a lower user level and want to use a feature that is available at a higher level, you can use Fine Tune to activate the feature. To save the fine tuning settings from session to session, use the Save Configurations choice on the Options menu.
GeoFile Basics  GeoFile provides a flexible set of tools for storing and retrieving data. You can use it to store any kind of information, from personal facts to business data.
For example, you could use GeoFile to store the following:

- Addresses
- A household inventory
- A pet’s veterinary history
- Tax records
- Prospective client data
- Real estate listings

GeoFile comes with standard templates that make it easy to work with many common types of data. GeoFile also provides an array of design tools for organizing your data and customizing data entry forms and reports to meet your individual needs.

GeoFile has four user levels. For more information about changing user levels, see Chapter 2. For more information about the user levels in GeoFile, see “User Levels in GeoFile” in this chapter.

This chapter includes a description of what a database is and describes how to do the following:

- Create a database by copying a standard GeoFile template.
- Enter, modify, and delete data.
- Search for data.
- Perform simple sorts.
- Change data layouts and layout viewing options.

This chapter assumes you are using a mouse, although keyboard shortcuts are provided for some menu choices. A table of the available keyboard shortcuts appears at the end of Chapter 19.

This chapter also assumes you are familiar with the information covered in Chapter 1 and Chapter 2, which provide an overview of the skills you need to use any GEOS application.

**WHAT IS A DATABASE?**

GeoFile stores the information you enter in a structure called a *database*. Each GeoFile database is a table, where a row or *record* represents a set of related data, and each column or *field* contains a particular type of data. For example, if you decided to keep track of the results of your spring flower bulb plantings,
your database could contain the following information:

<table>
<thead>
<tr>
<th>FLOWER</th>
<th>VARIETY</th>
<th>COLOR</th>
<th>PLANTED</th>
<th>RESULTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Freesia</td>
<td>Golden Melody</td>
<td>Yellow</td>
<td>11/24/92</td>
<td>Excellent</td>
</tr>
<tr>
<td>Crocus</td>
<td>Vanguard</td>
<td>Violet</td>
<td>11/24/92</td>
<td>Disastrous</td>
</tr>
</tbody>
</table>

Each set of entries for a particular flower is a record. Each type of information about a flower (for example, its variety) is a field. In order for you to be able to refer to a field, each field has a name; for example, RESULTS.

A GeoFile database can hold up to 16,384 records. To make it easy for you to work with such potentially large quantities of data, GeoFile provides tools for building forms or layouts for entering data and for printing it out again in attractive reports. You can also use GeoFile to sort the information you enter and to find specific data quickly.

**STARTING GEOFILE**

**ALL LEVELS**

The GeoFile icon appears in the WORLD folder in GeoManager and looks like the example at the left.

*To start GeoFile (All Levels)*

1. Locate the GeoFile icon and double-click it.

   or

   Choose Start an Application from the Express menu. A submenu appears. Choose GeoFile from the Submenu.
The GeoFile window appears along with the New/Open dialog box:

2. Click one of the first two buttons to open a template, or open an existing document.
GeoFile defaults to Level 1. If you want to create a new database, you need to work at higher user levels. To change user level, click the Change User Level button.
For more information about using the New/Open dialog box, see “Creating and Opening Documents” in Chapter 1. For more information about setting your user level see “User Levels” in Chapter 1. For more information about the Express menu, see “Using the Express menu” in Chapter 1.

USER LEVELS IN GEOFILE

You can make many of the GEOS applications as simple or sophisticated as you want. Typically, the more functions an application has, the more difficult it is to learn. In GEOS, you can start using an application at a simple, basic level. As you gain experience and are comfortable with it, you can add more functions by changing the user level. For more information about changing and saving user levels, see Chapter 1.
When you use GeoFile for the first time, it opens to Level 1—the simplest of GeoFile’s four user levels.
The following are descriptions of GeoFile's four user levels:

- **Level 1** allows you to use the most basic features of GeoFile. At Level 1, you can enter, modify, and retrieve data using an existing database or one that you create yourself by saving a copy of a GeoFile template. This chapter describes the features available at Level 1.

- **Level 2** allows you to use more advanced data entry features including marking records, multilevel sorts, exporting and importing data. You can also control more aspects of printed reports. These features are described in Chapter 18.

- **Level 3** allows you to use all of GeoFile's data entry features and to customize your database organization and layouts. Level 3 provides basic drawing tools that allow you to manipulate graphic objects and to change the text font, style, and size. At Level 3, you can change patterns, select line thickness, and scale graphic objects. For information about how to use the GeoDraw drawing features available at Levels 3 and 4, see Chapter 10 and Chapter 11. For information about using GeoFile to create new fields and layouts, see Chapter 19.

- **Level 4** allows you the most complete control of your database and layouts. Level 4 provides advanced design features for both single and multi-record layouts, including the use of splines, custom duplicate functions, and style sheets for both graphics and text. These are the same design tools available in GeoDraw. For information about these features, see Chapter 10, Chapter 11, and Chapter 19.

For more information about changing user levels, see Chapter 1. For more information about saving a user level, see Chapter 2.

**OPENING A TEMPLATE OR EXISTING DATABASE**

**ALL LEVELS**

At Level 1, you can only work with data in an existing database. You can create a new database only by copying a GeoFile template. You must advance to Levels 2 through 4 to create a database without using a template. For more information, see Chapter 18 and Chapter 19.

**Using Templates to Create a Database**

GeoFile templates are pre-designed documents that you can use to create your own databases. Templates provide a set of ready-
The Sample Database is only an example; do not use it to calculate real tax amounts.

To-use fields and layouts that are designed to perform particular tasks. GeoFile provides a sample template called the Sample Database. This template is an example of how you can use a database to calculate income tax liability for your employees. The template includes such information as tax rates and take-home pay.

When you open a template, GeoFile makes an untitled copy of the template for your use. This copy is a new database in which you can store and retrieve data. When you save the database, you can give it a name of your choice. The template itself remains unchanged, and you can use it to create another GeoFile database.
To use a template to create a new database (All Levels)

1. Click the Template button in the New/Open dialog box. A file selector appears:

2. Double-click the name of the template that you want to use.

   or

   Select the name of the template and click the Use Template button.

   A copy of the template appears in the GeoFile window, with the Record Control Panel at the bottom of the screen. You use the Record Control Panel to navigate within the database. You also use the Record Control Panel to save your records and perform other record management tasks. For more information, see “Using the Record Control Panel” in this chapter.

Opening Existing Databases

You can also use the New/Open dialog box to open an existing GeoFile database.
To open an existing database (All Levels)

1. Click Open Existing Document in the New/Open dialog box. A file selector appears, though not necessarily with all the documents shown here:

![Select Document to Open](image)

2. Use the file selector to find the database that you want to open, and double-click its name.

   or

Select the name of the database and click the Open button. The database appears with the Record Control Panel at the bottom of the screen. For more information, see “Using the Record Control Panel” in this chapter.

**USING THE RECORD CONTROL PANEL**

**ALL LEVELS**

The Record Control Panel is a dialog box that appears in the GeoFile window when you open a copy of a template or a database that already exists. You use the Record Control Panel to navigate through the records in a database, and to perform special functions, such as saving or deleting a record.
The buttons on the Record Control Panel perform the following operations:

- **First Record.** Use this button to move to the first record in the database.
- **Previous Record.** Use this button to move to the previous record.
- **Next Record.** Use this button to move to the next record.
- **Last Record.** Use this button to move to the last record in the database.
- **Record Number.** Use the arrow buttons to select the number of a new record to jump to. The number of the current record appears in the box to the left.
- **New Record.** Use this button to create a new record.
- **Save Record.** Use this button to save the current record.
- **Cancel Changes.** Use this button to cancel any changes you have made to the current record since it was last saved.
- **Delete Record.** Use this button to delete the current record.
ENTERING DATA

ALL LEVELS

You add records to a database by entering information in fields. A field holds a specific piece of information, like a person’s name. Fields in the sample template for tax information include the employee’s address, Social Security number, and tax rate.

When you enter information into fields, you are creating a record. For example, an employee record in the sample template contains fields for the employee’s address, phone number, and tax status.

To add records to a database (All Levels)

1. Open the database or copy of a template that you want to use. The database appears, along with the Record Control Panel.

2. If this is a new database, you need not do this step for the first record. Click the New Record button on the Record Control Panel. Empty fields appear on the screen. The insertion point is in the first field and there’s a dotted box around the first field.

3. Enter information in the field, and then press Tab or Enter.
   or
   Click in the next field.
   The insertion point appears in the next field, and the dotted box appears around the it.

4. Repeat step 3 as many times as necessary to enter information in all the fields in the record. If you want to change the data in a field, click in the field to place the insertion point. You can then edit the text in the field using standard GEOS editing techniques.

5. Click the New Record button on the Record Control Panel.
   or
   Press Ctrl + Enter.

GeoFile saves the record you just entered and displays empty fields on the screen in preparation for a new record.

GeoFile places each new record that you enter at the end of the database. Use GeoFile’s sort feature if you want to list the records in a different order. For this procedure, see “Sorting Records” in this chapter.
MODIFYING DATA

ALL LEVELS

You can easily change information in GeoFile records. You can select, copy, cut, and delete information using the same edit features that you use in any GEOS document. You can also cancel changes that have not yet been saved in the database.

To modify a record (All Levels)

1. Locate and display the record you want to modify. You can do this by using the Record Control Panel or by using GeoFile's search options.

2. Click in the field that contains the data you want to modify. The text insertion point appears in the field and a dotted box appears around the field.

3. Edit the text in the field using standard GEOS text editing techniques. For more information on modifying text, see "Selecting and Editing" in Chapter 2.

You can use the Cancel Changes button in the Record Control Panel to cancel any current changes you have made to a record. GeoFile restores the record to its condition before you changed any information.

DELETING RECORDS

ALL LEVELS

When you no longer need the information a record contains, you can delete the record from the database.

To delete a record (All Levels)

1. Locate and display the record that you want to delete.

2. Click the Delete Record button in the Record Control Panel. A confirmation message appears.

3. Click Yes. GeoFile deletes the record from the database.

SEARCHING FOR RECORDS

ALL LEVELS

In addition to using the Record Control Panel to move through records in a database, you can for records that contain a bit of text or a particular piece of information. The text you search for
is called a *text string*. A text string can be any series of characters, numbers, or words that you want to locate. For example, if you want to locate all records in a mailing list that includes addresses located in San Francisco, use “San Francisco” as your text string.

*To search for a particular record (All Levels)*

1. Choose Find from the Data menu. A dialog box appears:

2. Fill in the dialog box, using the options you want.
   - **Find.** Use this box to enter your text string. For example, if you want to search on a tax rate of 37%, enter 37.
   - **Special Characters.** Click this button to select a wild card. A wild card is a symbol used to represent any character or number. GeoFile has two wild cards: an asterisk (*) indicates any series of characters or numbers; a question mark (?) indicates one character. For example, if you want to list all records for employees whose last name begins with J, enter “J” and choose the Match Multiple Characters from the Special Character drop down list. All records for employees whose last name begins with “J” are displayed. If you want to search the records for employees with three-letter last names that begin with B, type “B” and choose the Match Any Character option from the Special Character drop down list.
   - **Ignore Case/Accents.** Click this button if you want GeoFile to ignore the difference between upper-case and lower-case letters or foreign accents while making a search.
   - **Match Partial Words.** Click this button if you want GeoFile to match your search string to all occurrences of the text string, even within a word. For example, if you check this option and enter “rate” as your search string, GeoFile will locate such words as “rates” and “berated”.

3. Click Find Next. The first record that matches your search criteria appears.

4. Click Find Next again until you have displayed all records that match your search string or if you want GeoFile to stop searching.
At Level 2 and above, you can also make a search by marking particular records for display. For information about how to mark records, see “Marking Records” in Chapter 18.

SORTING RECORDS

GeoFile automatically stores each new record at the end of the database. Therefore, the records may not be arranged the way you want them. Using GeoFile’s sort feature, you can sort your records by the contents of a certain field. For example, you could sort your database by its “City” field if you wanted to sort records by city name.

To sort records in a document (All Levels)

1. Choose Sort from the Data menu. A dialog box appears:

   ![](image)

2. Fill in the dialog box, selecting the options you want.

   **Select Sort Field.** This option lists all fields in your database. Use the scroll bar to move through the list and click the field that you want to use for your sort.

   **Sort Direction.** This option specifies whether you want to list your records in ascending or descending order. If you choose the up staircase button, GeoFile lists all records in ascending order; if you choose the down staircase button, GeoFile lists all records in descending order. For example, to sort employees by descending zip code, click the down staircase button.

   **Sort Options.** This option further defines how GeoFile sorts a database. You use it to request that GeoFile ignore differences

_for information about sorting on more than one field, see “Advanced Sorting” in Chapter 18._
between upper case and lower case letters, foreign accents, spaces, or punctuation marks when sorting.

3. Click Sort. The dialog box disappears. When GeoFile completes the sort, the records appear on the screen in the order you requested.

GeoFile provides additional sort functions if you are working at Level 2 or above. For information about additional sort functions, see Chapter 18.

**USING LAYOUTS**

**A L L  L E V E L S**

You use layouts to organize and present the information stored in your GeoFile database. A *layout* is the visual presentation of your data. The style and fields you use in a layout depend on the purpose of the layout. The tax template, for example, groups fields together based on personal employee information and tax data. This layout uses various colors and type styles to present the data in a format that is both attractive and easy to follow.

A database can have more than one layout. GeoFile provides pre­designed layouts with each template. When you use a template to create a new database, GeoFile copies the template’s layout into the new database.

*To choose a layout (All Levels)*

1. Select Switch Layout from the Layout menu. A dialog box appears:

![Switch Layout dialog box](image-url)
2. Select the layout that you want to use.

3. Click the Switch To button. The new layout appears in the GeoFile window.

At Levels 3 and 4 you can create your own layouts. In fact, you can create up to 255 layouts to meet the needs of a particular database.

The following standard GEOS view options are also available for use with your GeoFile layouts:

• Zoom in or zoom out to reduce or enlarge the page shown in the window.
• View the page at a specific percentage of reduction or enlargement.
• Show the horizontal or vertical scroll bar.
CHAPTER 18

Using a GeoFile Database  This chapter describes the additional data entry features that are available in GeoFile at Levels 2 through 4. At Levels 3 and 4, you have the choice of working in *data entry mode* or in *design mode*. In data entry mode, you enter, modify, and manipulate the data in a database. This chapter and the preceding chapter describe the functionality available as you work in data entry mode.
This chapter describes the following features:

- Record marking to create subsets of your database
- Advanced sorting capabilities
- Importing and exporting capabilities
- Multi-record data entry (Level 4 only)

In design mode, you can modify the structure and layout of an existing database or design a new database from scratch. Chapter 19, “Creating a GeoFile Database” describes the capabilities available in design mode.

This chapter assumes you are familiar with the information covered in Chapter 1 and Chapter 2, which cover basic skills for working with GEOS applications. You should also be familiar with the information in Chapter 17, “GeoFile Basics.”

ADVANCING TO LEVEL 2

LEVEL 2

When you advance your user level, GeoFile provides additional options for working with your database.

When you advance to Level 2, you have access to all the advanced data entry features described in this chapter with the exception of multi-record capabilities. The advanced data entry features appear on GeoFile menus, so GeoFile looks almost the same at Level 2 as it does at Level 1.
At Level 2, GeoFile looks like this:

![GeoFile Document](image)

**WORKING IN DATA ENTRY MODE**

**Levels 3-4**

At Levels 3 and 4, you use the Data Entry and Design buttons to choose between working in data entry mode and design mode.

*To work in data entry mode (Levels 3-4)*

- Click Data Entry to work with the data in a database. After you click Data Entry, GeoFile is in data entry mode.

This chapter describes advanced features available in data entry mode. For information about working in design mode, see Chapter 19.

**WORKING WITH MARKED RECORDS**

**Levels 2-4**

GeoFile's marking features enable you to define a group of records and work with that group separately from the rest of your database. Once you have marked a group of records, GeoFile can quickly retrieve that group so you can do any of the following:

- View just a portion of a database.
• Update a selected group of records.
• Print records containing specific types of data.
• Export a subset of a database.

GeoFile uses *marks* that look like check marks to indicate each member of the group. These marks appear in the upper-right corner of the Record Control Panel when the current record is marked.

**Showing Marked or All Records**

By default, GeoFile displays all the records in a database. When you have marked records, you can choose to have GeoFile display either marked records only or the entire database.

*To show only marked records (Levels 2-4)*

■ Choose Show Only Marked from the Mark menu. GeoFile displays only marked records.

*To show all records (Levels 2-4)*

■ Choose Show All from the Mark menu. GeoFile displays all records in the database, both marked and unmarked.

**Marking Records**

GeoFile provides several methods for marking records:

• You can mark records individually.
• You can specify a search string for GeoFile to use to select and mark a group. This is the simplest way to mark a group of records.
• You can specify a logical expression that GeoFile evaluates for each record in order to select and mark a group. This enables you to specify more complex criteria for GeoFile to use in selecting and marking records.
• You can mark every record in a database.
• You can change the status of all marked records to unmarked and vice versa.

**MARKING A RECORD**

You use the Record Control Panel to mark a particular record. This method is useful, for example, when you have just added a new record and you want to mark it for later reference.
To mark a record using the Record Control Panel (Levels 2-4)

1. Locate and display the record that you want to mark.
2. Click the check box in the upper-right corner of the Record Control Panel. The check box darkens.

Using the Mark Records

You use the Mark Records option on the Mark menu to mark a group of records that share similar information. For example, you may want to group all records that have “San Francisco” in the City field, or that have “February” in the Month field. Mark Records searches on the text you specify in a field you choose, and it marks the records where it finds a match.

To use Mark Records (Levels 2-4)

1. Choose Mark Records from the Mark menu. A dialog box appears:

2. Select the options you want.

Select Mark Field. Select the field containing the information you want GeoFile to search for.

Ignore Case. Select this option if you want GeoFile to treat upper-case text and lower-case text the same.
**Match Only at Start of Field.** GeoFile marks records only where it matches the string with characters at the beginning of the specified field.

**Text to Match.** Enter the text you want GeoFile to use as the basis for marking records. For example, to mark all records for people whose last name is “Smith”, select Last Name as the mark field and enter **Smith** in the Text to Match box.

3. Click Mark. GeoFile marks the records that match your search criterion. GeoFile also creates a formula based on this search criterion and uses it as the default expression in Mark by Formula.

**MARKING RECORDS BY FORMULA**

GeoFile can also use formulas that reference and combine the information stored in your database as the criterion for marking records. For example, you could enter **income > 30000 and (state=“CA”, city=“Sacramento”)** to select and mark the group of records for employees in Sacramento, California with incomes over $30,000.

*To mark records by formula (Levels 2-4)*

1. Select Mark by Formula from the Mark menu. The following dialog box appears:

   ![Mark Fields by Formula dialog box](image)

2. Fill in the dialog box, selecting the options you want:

   **Field Names.** This option lists all the field names in the GeoFile database. Selecting a field name pastes it at the insertion point in the Expression Box.

   **Functions.** This option lists all the GeoFile functions you can use. Selecting a function pastes it at the insertion point in the Expression Box.

---

*For more information about using this dialog box to enter formulas, see “Using Field Expressions” in Chapter 19.*
Math. This option lists all the GeoFile math operators you can use. Selecting an operator pastes it at the insertion point in the Expression Box.

Logic. This option lists all the GeoFile logical operators you can use. Selecting an operator pastes it at the insertion point in the Expression Box.

For a list of GeoFile functions, math operators, and logical operators, see “Using Field Expressions” in Chapter 19.

3. Click OK to mark the records. GeoFile checks the syntax of the expression you’ve typed. If the syntax passes, GeoFile carries out the search and marks each record which meets the criteria set by the specified formula evaluates as true.

4. If GeoFile detects a syntax error, it displays an error box and highlights a problem in the Expression Box. Click OK and resume editing the formula until the syntax is accepted. The dialog box closes.

MARKING ALL RECORDS
Sometimes it’s easiest to start with every record in the database marked, and then unmark specific records by hand. You can mark all records in a simple one-step procedure.

To mark all records (Levels 2-4)
• Choose Mark All from the Mark menu. All records in the database are marked.

SWITCHING MARKED RECORDS
Sometimes you may want to switch between working with your marked and unmarked records. An easy way to handle this situation is to mark one set of records and then use GeoFile’s Switch All Marks option to switch the marks from one group to the other as needed.

For example, you can mark all records for customers with balances greater than zero, thereby creating a marked group of records for customers with outstanding balances and an unmarked group for clients with accounts paid. When you need to work with the records for clients with accounts paid, you just use Switch All Marks. The next time you want to work with the records for clients with outstanding balances, you use Switch All Marks again.
To switch all marks (Levels 2-4)

Choose Switch All Marks from the Mark menu. GeoFile switches the status of all marked records to unmarked and *vice versa*.

**Unmarking Records**

When you want to remove marks from records, you can either remove the marks individually using the Record Control Panel or you can remove them from the entire database using Unmark All.

To unmark a record using the Record Control Panel (Levels 2-4)

1. Locate and display the record that you want to unmark.
2. Click the check box in the upper-right corner of the Record Control Panel. The check box darkens.

To unmark all records (Levels 2-4)

Choose Unmark All from the Mark menu. GeoFile removes the marks from all records in the database.

**Setting Mark Options**

You can set options to control if and when GeoFile should automatically retain or remove marks from records.

To set mark options (Levels 2-4)

1. Choose Mark Options from the Mark Menu. A dialog box appears:

![Mark Options Dialog Box]

2. Fill in the dialog box, selecting the options you want.

**Automatically Mark and Unmark.** Select this option to have GeoFile mark every record that matches the last specified Mark Record or Mark by Formula search criterion. With this setting selected as you update your database, GeoFile automatically marks any record that you add or change that matches the last marking search criterion, and unmarks any record that you change in a way that no longer matches the search criterion. By default, GeoFile operates with this option off.
Clear All Marks Before Re-Marking. Select this option to have GeoFile unmark all records before performing a Mark Record or Mark by Formula search. Deselect this option if you want to use Mark Records or Mark by Formula to add records matching a new search criterion to an already existing marked group. By default, GeoFile runs with this option on.

3. Click OK to set your options.

ADVANCED SORTING

At Level 1, you can sort records in a database by the contents of a single field, and you can specify the order of the sort. For information about the basic sort feature, see Chapter 17.

At Levels 2 through 4, you can use up to six different fields to sort records in your database and specify the order of the sort for each field. For example, you can sort records first in ascending order by customer name and then in descending order by date.

The following example shows the list sorted in ascending order by customer name and in ascending order by date:

<table>
<thead>
<tr>
<th>Date</th>
<th>Name</th>
<th>Qty</th>
</tr>
</thead>
<tbody>
<tr>
<td>12/15/92</td>
<td>ABC Company</td>
<td>3</td>
</tr>
<tr>
<td>12/16/92</td>
<td>ABC Company</td>
<td>5</td>
</tr>
<tr>
<td>12/17/92</td>
<td>Al's Burgers</td>
<td>35</td>
</tr>
<tr>
<td>12/18/92</td>
<td>CominTech</td>
<td>20</td>
</tr>
<tr>
<td>12/19/92</td>
<td>Records Mania</td>
<td>25</td>
</tr>
<tr>
<td>12/21/92</td>
<td>Records Mania</td>
<td>50</td>
</tr>
<tr>
<td>12/22/92</td>
<td>U.S. Express</td>
<td>11</td>
</tr>
</tbody>
</table>
To use advanced sorting features (Levels 2-4)

1. Choose Advanced Sort from the Data menu. A dialog box appears:

2. Fill in the dialog box, selecting the options you want.

   **Fields in Database.** Select the field you want GeoFile to use as a sort key from this alphabetical list of all the fields in the database. If necessary, use the scroll bar to move quickly through the list.

   **Add Sort Key Arrow.** Use this button to add the selected field in the Fields in Database list to the Sort Keys list. Once a field appears on the Sort Keys list, you can no longer select it from the Fields in Database list.

   **Remove Sort Key Arrow.** Use this button to remove the selected field from the Sort Key list. The field becomes available again for selection from the Fields in Database list.

   **Sort Keys.** This lists all the fields that you have selected as sort keys, in order of priority. Select a field from this list of sort keys in order to remove it from the list or to change its priority. If necessary, use the scroll bar to move through the list.

   **Promote.** Use this button to move the selected field in the Sort Key list up one position in the sort order.

   **Demote.** Use this button to move the selected field in the Sort Key list down one position in the sort order.
Sort Direction. This option specifies whether you want to list your records in ascending or descending order. If you choose the ascending button (arrow pointing up), GeoFile sorts all records in ascending order; if you choose the sort descending button (arrow pointing down), GeoFile sorts all records in descending order. For example, if you want to sort cities alphabetically beginning with “A”, click the up staircase button.

Sort Options. This option further defines how GeoFile sorts a database. You use it to request that GeoFile ignore differences between upper-case and lower-case letters, foreign accents, spaces, or punctuation marks when sorting.

Notes. Displays any information that was entered about the selected field when it was created. For more information about field notes, see Chapter 19.

Clear. Use Clear to remove all sort keys from the Sort Keys list. Clear also resets the default sort options and sort directions, and selects the first field in the Fields in Database list.

3. Click Sort. GeoFile sorts your records based on the sort keys and options you specify.

EXPORTING AND IMPORTING DATA

LEVEL 2-4

You can use GeoFile to exchange data with many other applications. To see a list of applications to which you can import from or export to, follow the following procedures. In each, you will see a dialog box with a scrolling list of all available formats.

Exporting GeoFile Data to Another Application

You can export all or specified portions of a GeoFile database. In either case, GeoFile copies the data into a new document that matches the internal format you specify.

To export to another application (Levels 2-4)

1. Open the GeoFile database that contains the data you want to export.

2. Select Show Only Marked from the Mark menu if you want to export the currently marked group of records only. Select Show All from the Mark menu if you want to export all the records in the database.
3. Choose Other from the File menu. A submenu appears.

4. Choose Export Document from the Other submenu. A dialog box appears:

![Dialog box for exporting GeoFile data](image)

5. Use the file selector to find the file you want to import. Also change any of the following options:

   **Formats.** Choose the application in which you want to use the exported information, or choose Comma Separated Values to export information in CSV format.

   **New File Name.** Enter a name for the exported file. The correct extension already appears in this box, so you don't need to enter it. Be sure to enter a standard DOS file name no more than eight characters long. For more information about DOS file names, see “Naming a Document” in Chapter 1.

   **Export Options.** Click All to export all the records in the database. Click From and use the Arrow keys if you want to specify a numeric range of records to export. For example, if you want to export the first 10 records in your database, click From, then use the first set of arrow keys to select 1 and the second set of arrow keys to select 10. If you have chosen Show Only Marked, GeoFile exports the first 10 marked records.

   **Map Export Fields.** Use this to specify the order and number of exported fields.

6. Click Export to copy the data to a new document,

   or

   Click Export to Clipboard to copy records to the clipboard. GeoFile uses data on the clipboard in Mail Merge. For information about Mail Merge, see Chapter 7.

   A message appears to indicate that exporting is in progress. When GeoFile finishes exporting data, the message disappears.
To change the order of fields when exporting (Levels 2-4)

When you export in dBASE or CSV format, GeoFile creates field names (Field1, Field2, Field3, etc.) for the data it exports. You can map the fields you are exporting to change their order in the exported file.

1. Choose Other from the File menu. A submenu appears.
2. Choose Export document from the Other submenu. A dialog box appears.
3. Fill in the dialog box, selecting CSV, dBASE III, or dBASE IV from the Formats list. The Map Export Fields button activates.
4. Click Map Export Fields. A dialog box appears with the fields in your database listed in the Source list. The Destination List consists of field names for the exported file equal to the number of fields in your database.

5. Select a field in the Source List. The Source List displays all the fields in your database.
6. Select the field name in the Destination List that you want to pair with the selected field in the Source list. The field number indicates the position of the selected field in the export document.

7. Click the Map button. The field pair appears in the Map List box.

8. Repeat steps 5 through 7 for each field you want to export. If you leave any source field unpaired, that field will not be exported. To remove a field from the Map List, select the field and click the UnMap button. To remove all fields from the Map List, press the Cancel button.

9. Click Done. The dialog box closes.

10. Click Export. GeoFile exports your data in the format you specified.

**Importing Data from Another Application**

You can import data from fields in Lotus, dBASE, or CSV format. Many applications can export information in these formats, so you do not necessarily have to be using Lotus or dBASE in order to import information into GeoFile. When you import dBASE and CSV files, you can change the order of the columns when you import.

*To import from another application (Levels 2-4)*

1. Choose New/Open from the File menu. A dialog box appears.
2. Click Import. A dialog box appears:

   ![Select File and Format for import dialog box]

3. Use the file selector to find the file you want to import. Also change any of the following options:

   **Formats.** Select the format of the document that you want to import.

   For information about using the standard file selector options, see Chapter 1.
**File Mask.** This box displays the file extension for the selected format. For example, if you select dBASE, .DBF appears as the extension.

**Map Import Fields.** Use this to specify the order and number of exported fields.

4. Click Import. A message informs you that importing is in progress. When the process is complete, GeoFile opens an untitled document containing the fields and data that you have imported. You can name and save the document for later use.

*To map fields for importing (Levels 2-4)*

When you import data in dBASE or CSV format, GeoFile imports data in the order in which it appears in the source file. You can map the fields you are importing to change their order, if you choose.

1. Choose New/Open from the File menu. A dialog box appears.
2. Click Import in the New/Open dialog box. A dialog box appears.
3. Select CSV, dBASE III, or dBASE IV from the Formats list. The Map Export Fields button activates.
4. Select a file using the file selector.

*Mapping slows down the import procedure considerably, so it may not be convenient to use when importing large files.*
5. Click the Map Import Fields button. A dialog box appears:

- Use to select the field you want to import.
- Use to assign a field number to a selected field.
- Fields selected for importing appear here.
- Use to clear all fields from the Map List box and exit the dialog box.
- Use to remove the selected field from the Map List.
- Use to add the selected field to the Map List.

6. Select a field in the Destination List.

7. Select the field name in the Source List that you want to pair with the selected field in the Source list. The field number indicates the position of the selected field in the new document GeoFile creates.

8. Click the Map button. The field pair appears in the Map List box.

9. Repeat steps 5 through 7 for each field you want to import. If you leave any source field unpaired, that field will not be imported.

   To remove a field from the Map List, select the field and click the UnMap button. To remove all fields from the Map List, press the Cancel button.

10. Click Done. The dialog box closes.

11. Click Import. GeoFile imports all data based on the fields you have mapped and the type of import options you have selected.
Creating a GeoFile Database

This chapter describes how to use the design and layout features at Levels 3 and 4 to create a new GeoFile database. It covers the process and tasks involved in designing rather than entering data into a GeoFile database. For more information about entering and retrieving data using a GeoFile database, see Chapter 17 and Chapter 18.
This chapter describes how to do the following:

- Plan a GeoFile database, defining the data you want to store in the database.
- Create a new GeoFile database, either from scratch or using an existing template.
- Add fields to a layout.
- Set the format for number, date, and time fields.
- Use computed fields.
- Format a layout using text and graphics.
- Create additional layouts.
- Use multiple records on a layout.
- Fine tune your user level.

ADVANCING TO LEVELS 3 AND 4

Advancing to Level 3 and Level 4 gives you the tools you need to create a new GeoFile database and customize it by adding fields, layouts, graphics, and formatting.

What You Get at Level 3

If you choose to create a new empty document, GeoFile automatically puts you into design mode and prompts you to add a new field. For more information about the Field Organizer and the New Field dialog boxes, see “Creating a Field” in this chapter.
At Level 3 in design mode, GeoFile looks like this:

In design mode at Level 3, you can create new layouts to display information in a different form; for more information, see “Creating Additional Layouts” in this chapter. You can use the graphics tools to add text and graphic objects to a layout; for more information, see “Using Graphics” in this chapter. You can use the text attributes tools to change the way text looks on the layout; for more information, see “Formatting Text” in this chapter.

In data entry mode, you have access to all the advanced data entry features described in this chapter with the exception of multi-record capabilities.

At Level 3, GeoFile gives you the tools to add fields and design database layouts, including text, graphics, and clipboard tools.
At Level 3 in data entry mode, GeoFile looks like this:

![GeoFile window at Level 3](image)

Click on this button to store and retrieve data.

Click on this button to use database design tools.

**What You Get at Level 4**

The GeoFile window at Level 4 appears the same as at Level 3, with the addition of the Single-Record and Multi-Record buttons. The Multi-Record button changes GeoFile to multi-record mode so that you can put multiple records on a layout. For more information, see “Using Multiple Records on a Layout” in this chapter.

In addition, you can use graphic styles and text styles to format graphic and text objects, respectively. For more information, see “Using Graphics” and “Formatting Text” in this chapter.
At Level 4, the Create New Field dialog box has additional options:

![Create New Field dialog box]

You can specify the data type for a field. You can also define field and data attributes, including field notes, default values or expressions, the field length for text fields, and minimum or maximum values for number fields.

In data entry mode you have access to all the advanced data entry features described in Chapter 18.

At Level 4 in data entry mode, GeoFile looks like this:

![GeoFile - Document]

Click on this button to display one record at a time.

Click on this button to display multiple records on a screen and on a printed page.
CHOOSING A WORK MODE

LEVELS 3-4

GeoFile has two modes at Levels 3 and 4. In design mode, you can design a GeoFile database. In data entry mode, you can add, modify, and search for records in a GeoFile database. You can switch between modes easily.

If you create a new GeoFile database, GeoFile goes into design mode automatically and prompts you to add a new field. If you open an existing GeoFile database, GeoFile goes into the mode used when you last saved a file.

To switch to design mode (Levels 3-4)

Click the Design Button. GeoFile switches to design mode and displays the Field Organizer, which is the command center for managing fields in a database and on a layout:

If no fields appear in the database, GeoFile automatically prompts you to create new fields. For more information, see "Using the Field Organizer" in this chapter.

To switch to data entry mode (Levels 3-4)

Click the Data Entry button. GeoFile switches to data entry mode and displays the Record Control Panel.

For more information about working in the data entry mode, see Chapter 17 and Chapter 18. For more information about the Record Control Panel, see "Using the Record Control Panel" in Chapter 17.

WORKING IN MULTI-RECORD MODE

LEVEL 4

At Level 4, you have the choice of working in single-record mode or multi-record mode. In single-record mode, GeoFile displays
one record at a time on your computer screen, just as it does at Levels 1 through 3, and prints one record on every page. In multi-record mode, GeoFile displays as many records as can fit on the current layout, and prints as many records as can fit on the current layout on every page.

To work in multi-record mode (Level 4)

- Click Multi-Record to display as many records as possible on the current layout. After you click Multi-Record, GeoFile is in multi-record mode.

When you work in multi-record mode, you can edit data in any of the records appearing on your screen. Select the field that contains the data you want to modify, and use any of the standard GEOS editing techniques to change the data.
When you use the New Record button to add a new record to the database, GeoFile displays a set of blank fields to receive your data in the position of the next record on the current layout.

![GeoFile - Customer Orders](image)

If the current layout is full, a new and empty layout page appears. You enter data in the position of the first record on the empty layout.

![GeoFile - Customer Orders](image)

All of the standard GeoFile data entry features operate normally in both single- and multi-record modes.
For information about designing multi-record layouts, see “Using Multiple Records on a Layout” in this chapter. For information about switching layouts, see “Switching Layouts” in this chapter.

PLANNING A DATABASE

LEVELS 3-4

Before you design a database, you should understand basic database concepts and design principles. For an introduction to database concepts, see Chapter 17, “GeoFile Basics.”

When planning a database, you should think about the nature of the information you want to track. Consider the following questions:

• What is the scope of the information? For example, to keep track of customers, you would include pertinent data about each customer such as address, phone, contact person, and so on.

• Within this scope, what are the entries involved? For example, in a customer database, each customer is a separate entry (or record) in the database.

• What do you need to know about each entity or activity? List the pieces of information (or fields) you want to use. For example, for each customer you could include the following facts: customer identification code, address, main phone number, the names of people you work with in the company, account number, and sales to date.

• Is there an existing GeoFile template or database that you could use instead of starting from scratch? If so, you can save design and layout time.

At Level 4, you should consider the following additional questions:

• Do you need to use the same information for different purposes? Will you need to create additional layouts? For example, in a customer database, you might want to have different layouts for entering data, retrieving a phone list, and printing mailing labels.

• Which field type should you use? For example, a street address is probably a Text field, while the customer identification number is likely an Integer and sales to date a Real Number.
• Will any field contain special default data? For example, if most or all of the customers reside in the same state, you could make that state the default data.

• Will text fields have a maximum length? For example, a state abbreviation field requires no more than two characters.

• Will number fields have a minimum or maximum value? For example, you might rank your customers on a scale from 1 to 10.

• What calculations will you need in computed fields? For example, if you want to calculate the average sales revenue per sale, you divide the sales to date by the number of sales.

When you are finished, you might end up with a schematic like this:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Additional Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer_ID</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Customer_Name</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Address</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>City</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>State</td>
<td>Text</td>
<td>Size is 2; default value is “CA”</td>
</tr>
<tr>
<td>Zip</td>
<td>Text</td>
<td>Size is 10</td>
</tr>
<tr>
<td>Account_Number</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Contact</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Phone</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Sales_to_Date</td>
<td>Real Number</td>
<td></td>
</tr>
<tr>
<td>Number_of_Sales</td>
<td>Integer</td>
<td></td>
</tr>
<tr>
<td>Average_Per_Sale</td>
<td>Computed</td>
<td>Formula is: Sales_to_Date / Number_of_Sales</td>
</tr>
<tr>
<td>Create_Date</td>
<td>Date</td>
<td></td>
</tr>
<tr>
<td>Create_Time</td>
<td>Time</td>
<td></td>
</tr>
<tr>
<td>Customer_Rating</td>
<td>Integer</td>
<td>Min = 1, Max = 10</td>
</tr>
</tbody>
</table>

Once you have planned the database, you can create it in GeoFile.
CREATING A GEOFILE DATABASE

LEVELS 3-4

To create a new GeoFile database, you have three options.

• You can start from scratch using a blank document with no fields; you must create the fields and any additional layouts yourself. To do this, click the Empty Document icon on the File New/Open dialog box. For more information, see “Creating and Opening Documents” in Chapter 1.

• You can use a GeoFile template as a starting point to save time creating, laying out, and formatting the database. To do this, click the Template Document icon on the File New/Open dialog box. For more information about using a template, see Chapter 17.

• You can use an existing document and save it under a different name. This also saves time creating, laying out, and formatting the database, although you might need to delete any existing data in the database. To do this, click the Open Existing Document icon on the File New/Open dialog box. For more information on using an existing document, see Chapter 17.

USING THE FIELD ORGANIZER

LEVELS 3-4

In design mode, GeoFile displays the Field Organizer, which is the central command center for designing fields in a database. You can use it to add fields to and remove fields from the database as well as the current layout.
What the Field Organizer Contains

The Field Organizer contains the following elements:

Fields absent from the current layout.

Adds a field to the current layout.

Removes a field from the current layout.

Fields in the current layout.

Click to delete the selected field.

Click to edit the selected field.

Click to create a new field.

Fields Not in Current Layout. This list contains the fields that do not appear in the current layout. A field can appear on other layouts, however. For more information, see “Arranging Fields” in this chapter.

Fields in Current Layout. This list contains the fields that appear in the current layout. A field can appear only once on a layout, though it can appear in more than one layout. For more information, see “Arranging Fields” in this chapter.

Right Arrow Button. Click this button to add a selected field from the Fields Not in Current Layout list to the current layout.

Left Arrow Button. Click this button to remove a selected field from the Fields in Current Layout list.

Notes. This box displays the notes for the selected field. For more information, see “Changing Field Notes” in this chapter.

Create New Fields Button. Click this to create a new field.

Edit This Field Button. Click this button to edit a field definition in the database.

Delete This Field Button. Click this button to delete a field from the database and remove it from any layouts on which it appears.
NOTE
For more information on the Create New Fields, Edit This Field, and Delete This Field buttons, see “Managing Fields in a Database” in this chapter. For more information about the Add and Remove buttons, see “Arranging Fields” in this chapter.

Moving the Field Organizer
The Field Organizer might cover up fields on the layout page that you want to work with. You can move the field organizer out of the way so that you can see the entire layout page.

To move the Field Organizer (Levels 3-4)
- Press the title bar of the Field Organizer and drag the dialog box to a different location, then release the left mouse button.

Closing the Field Organizer
When in design mode, you cannot close the Field Organizer. GeoFile closes it automatically when you switch to data entry mode. For more information, see “Choosing a Work Mode” in this chapter.

MANAGING FIELDS IN A DATABASE

Creating a Field
You can create new fields in a database. At Level 3, you can define field names. At Level 4, you can also define field types, field attributes, and data attributes.

Once you have added a field, you can change its number formatting; for more information, see “Using Field Number Formats” in this chapter. You can also change its text formatting and location on a layout; for more information, see “Formatting a Layout” in this chapter.
PARTS OF A FIELD

A field has two parts. The data entry area is where, during data entry mode, the user types and sees the contents of the field for a particular record. The field label appears next to the data entry area and describes the field to the user. The following example shows these two parts of a field:

```
Last:  Last Name       Data Entry Area

Field Label
```

The field edges define the boundaries of the data entry area; for more information, see “Showing and Hiding Field Edges” in this chapter.

When you add a field, GeoFile uses the field name for both the field label and the field entry area. The field name does not appear in the field entry area during data entry mode. Instead, the field label identifies the contents of the field to the user during data entry mode.

In the previous example, the designer has changed the field label to make the name more descriptive. The field label is optional descriptive text that you can delete if you want. For more information, see “Changing Field Labels” in this chapter.

CREATING A FIELD AT LEVEL 3

At Level 3, you can create a field to a layout.

To create a new field (Level 3)

1. Click Create New Fields on the Field Organizer dialog box. A dialog box appears. When you create a new blank database with no fields, GeoFile displays this dialog box automatically.

```
Create New Field
Please enter a field name. Every field you define should have a unique name. You can use this name later to refer to this field.

Field Name: Field_1

Create  Stop Creating  ?
```

2. Type a field name. A field name can consist of any combination of letters, numbers, and underscores, up to 40 characters. GeoFile does not permit spaces in field names; if you press Spacebar, GeoFile converts the spaces to underscores automatically.
The name you use must be unique in a database; you cannot have the same name for two different fields. Names are not case sensitive; for example, “Social_Security_Number” and “social_security_number” are the same name to GeoFile. Also, when you type a space, GeoFile inserts an underscore automatically.

The name of a field should describe its contents; for example, you could use “Employee_Salary” to name a field that contains the salary of an employee.

3. Click Create. GeoFile creates the field in the database and adds the field and its field label to the current layout page, as in the following example. The field label is optional; you can change or delete it as necessary.

   Employee_Salary: Employee Salary  Data Entry Area

GeoFile places the new field below the previous field, if any, on the layout page. If the number of fields on the layout exceeds the length of the page, GeoFile increases the page size automatically.

4. Click Stop Creating when you finish adding all the fields on the layout. The Create New Field dialog box closes.

CREATING A FIELD AT LEVEL 4

At Level 4, you can define additional field attributes such as field type, field notes, default values, expressions, field length, and minimum and maximum values.

When defining fields, you can use any of the following GeoFile field types:

- **General/Text.** This field type can contain any combination of keyboard characters: letters, numbers, punctuation, spaces, and so on (such as “123 Main Street”). By default, General/Text values can be as large as 1024 characters.

- **Integer.** This field type can contain numbers but does not display fractional portions (numbers to the right of the decimal point), such as 7, 12, 365, 1024, and so on.

- **Real Number.** This field type can contain numbers with fractional portions (including currency values), such as 98.6, 2.17182, 3.14159, and so on.

- **Date.** This field type can contain date values, ranging from 1/1/1900 through 12/31/2099, inclusive.
• **Time.** This field type can contain time values ranging from 12:00:00 AM to 11:59:59 PM within the valid date range.

• **Computed.** This field type can contain an expression that GeoFile computes during data entry when a user adds or edits a record, such as: Sales_to_Date + Number_of_Sales.

In general, use the Integer or Real Number field type for numbers involving mathematics calculations. For example, a Number_of_Sales field and a Sales_to_Date field would be Integer or Real Number fields so you can use them to calculate the Average_Per_Sale field. Integer and Real Number fields can contain values between $10^{-4932}$ and $10^{+4932}$. All numbers and calculations are accurate to 15 decimal places. Even when GeoFile rounds off a number to less than 15 decimal places, it uses all 15 decimal places in calculations.

You can use General/Text for numbers that are not used in calculations, including numbers that contain other characters. For example, Zip_Code and Phone are General/Text fields because there is never a need to use them in calculations and because they contain dashes.

The following procedure describes the basic steps for creating and defining a field at Level 4.

*To create a new field (Level 4)*

1. Click Create New Fields on the Field Organizer dialog box. A dialog box appears:

![Create New Field Dialog Box]

When you create a new blank database with no fields, GeoFile displays this dialog box automatically.

2. Fill in the dialog box, selecting the options you want:

   **Field Name.** Type a field name. A field name can be any combination of letters, numbers, and underscores, up to 40 characters. GeoFile does not permit spaces in field names; if you
press Spacebar, GeoFile converts the spaces to underscores automatically.

The name you use must be unique in a database; you cannot have the same name for two different fields. Names are not case sensitive; for example, “Social_Security_Number” and “social_security_number” are the same name to GeoFile. Also, when you type a space, GeoFile inserts an underscore automatically.

The name of a field should describe its contents; for example, you could use “Employee_Salary” to name a field that contains the salary of an employee.

**Field Type.** This option sets the field type. Select a field type from the list.

**Set Field Notes.** This field attribute sets the notes associated with the field. You can type up to 256 characters in this field. For example, you might say something like “This field is a Real Number that contains the employee’s salary information and currency formatting.” For instructions on setting Field Notes, see “Changing Field Notes” in this chapter.

**Set Default** (or **Set Expression** for Computed fields). This field attribute sets the default expression for the field. For instructions on setting the default or expression, see “Using Field Expressions” in this chapter.

**Length.** This data attribute sets the length of a General/Text field. By default, the length is 1024 characters, the maximum length for a General/Text field. Reduce this setting if you do not want the text field to exceed a certain length (such as a zip code field or a state abbreviation field). All other field types have no default length.

**Min.** This data attribute sets the minimum allowable value for a Real Number, Integer, Date, or Time field.

**Max.** This data attribute sets the maximum allowable value for a Real Number, Integer, Date, or Time field.

3. Click Create to create the field using the options you have selected. GeoFile creates the field in the database and adds the field and its field label to the current layout page.

GeoFile places the new field below the previous field, if any, on the layout page. If the number of fields on the layout exceeds the length of the page, GeoFile increases the page size automatically.

4. Click Stop Creating when you finish adding all the fields on the form. The Create New Field dialog box closes.
Changing Field Notes

You can add notes to a field to as a reminder of what the field contains when you select it in the Field Organizer. For example, you could describe the purpose of a field by saying “This field calculates the average dollar amount per sale.”

To change field notes (Level 4)

1. Select the field you want to change from the Field Organizer.
2. Click Edit This Field on the Field Organizer. A dialog box appears.
3. Click Set Field Notes. A dialog box appears:

   ![Set Field Notes dialog box]

4. Type or edit the document notes in the Notes box. You can enter up to 256 characters.
5. Click OK. The dialog box closes. GeoFile saves your changes. You will see these notes the next time you select the field in the Field Organizer dialog box:

   ![Field Organizer - Layout 1]

Changing a Field Definition

Once you have added a field, you can go back and change its definition. At Level 3, you can change its field name and, at Level 4, you can change its field type, field length, field attributes, and data attributes.

When you change a field definition, the changes affect the field wherever it appears in the GeoFile database; if the field appears
in multiple layouts, GeoFile updates your changes on every layout on which the field appears.

**CHANGING FIELDS AT LEVEL 3**

You can change the name of a field. You may want to make it more descriptive of the information it will contain, or if you may want to make it more consistent with other field names.

*To change the name of a field (Level 3)*

1. Select a field from the Field Organizer. You can select a field whether it appears in the current layout or not.
2. Click Edit This Field on the Field Organizer. A dialog box appears:

   ![Edit a Field Dialog Box](image.png)

3. Type a new name in the Field Name box.
4. Click Apply. GeoFile assigns the new name you typed to the selected field and to its field label.
5. Click Close to close the dialog box.

**CHANGING FIELDS AT LEVEL 4**

At Level 4, you can change additional field attributes such as the field type, field length, field notes, minimum and maximum values, defaults, and expressions. This procedure describes the basic steps for changing a field at Level 4.

*To change the field definition (Level 4)*

1. Select a field from the Field Organizer. You can select a field whether it appears in the current layout or not.
2. Click Edit This Field on the Field Organizer. A dialog box appears:

3. Fill in the dialog box, selecting the options you want.

   **NOTE**
   If you change the field type in a database that has existing data, a warning message appears indicating that GeoFile will convert the data if possible but, if conversion fails, GeoFile will erase the data. If you click OK, GeoFile attempts to convert the data to the new data type. However, certain kinds of information might not convert. For example, if you change a General/Text field to an Integer field, data with alphabetic characters do not convert; GeoFile erases the data and puts an "error" in the field instead.

4. Click Apply. GeoFile applies the changes you have made to the selected field.

5. Click Close to close the dialog box.

**Deleting a Field**
You can delete a field you no longer need from the database. Deleting a field from the database removes it from the database, including any layout on which it appears, and erases any existing data.

Deleting a field from the database differs from removing a field from the current layout. For more information, see "Formatting a Layout" in this chapter.

**NOTE**
You cannot delete a field while an expression in another field refers to it. For example, if the expression in a Monthly_Salary field depends on the Salary field for data, GeoFile will not let you delete the Salary field until you have removed its reference in the Monthly_Salary field. Similarly, you cannot delete a field if it appears in the current layout. You must first remove it from the current layout. Select the field you
want to delete, then click the left arrow button on the Field Organizer to remove it from the current layout.

To delete a field (Levels 3-4)

1. Select a field from the Fields Not in Current Layout list in the Field Organizer. You cannot select a field that appears in the current layout.
2. Click Delete This Field on the Field Organizer. A confirmation message appears.

WARNING

Once you delete a field, you cannot recover any data that it contains. The only way to regain the data is to revert to the last saved version of the database by choosing Discard Changes from the Other choice under the File menu. For more information, see "Managing Documents" in Chapter 3.
3. Click Yes. GeoFile deletes the selected field from any layout on which it appears. Doing this eliminates any data stored in this field.

USING FIELD NUMBER FORMATS

GeoFile provides many ways to display numbers, dates, and times. For example, you can display a number with commas (98,765), without commas (9876), as currency ($98.77), or as a percent (98.8%). You can also create custom formats for special needs. The format you use depends on the way you want to display information.

You can set date and time formats as well. Dates are actually stored as serial numbers representing the number of days since January 1, 1900. Therefore, January 1, 1993 equals 33969. Time values are the fractional portion of date serial numbers; for example, a date value of 33969.25 is actually January 1, 1993, at 6:00 A.M. (the fractional portion represents a percentage of the 24-hour clock). However, during data entry mode, the user enters dates and times in the usual manner, such as “Jan 12, 1994” or “12:35 PM”.

You can use these formats for any field including (at Level 4) General/Text fields. At Level 4, each format works for all field types, although you might want to use a format that applies to the field type you have defined: number formats for integer and
real number fields, date formats for date fields, and time formats for time fields. For computed fields, use the format that corresponds to the result; for example, if the result of a computed field is an integer, use a number format.

**Available Formats**

GeoFile provides a variety of number, date, and time formats.

**AVAILABLE NUMBER FORMATS**

You can use the following formats for fields containing integer, real number, or computed values:

<table>
<thead>
<tr>
<th>NUMBER FORMAT</th>
<th>VALUE</th>
<th>RESULT</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>1234567</td>
<td>1234567</td>
</tr>
<tr>
<td>Fixed (2 decimal places)</td>
<td>123.4567</td>
<td>123.46</td>
</tr>
<tr>
<td>Fixed with Commas</td>
<td>1234.567</td>
<td>1,234.57</td>
</tr>
<tr>
<td>Fixed Integer (rounded to a whole number)</td>
<td>1234.567</td>
<td>1235</td>
</tr>
<tr>
<td>Currency</td>
<td>1234.567</td>
<td>$1234.57</td>
</tr>
<tr>
<td>Currency with Commas</td>
<td>1234.567</td>
<td>$1,234.57</td>
</tr>
<tr>
<td>Currency Integer (rounded to nearest dollar)</td>
<td>1234.567</td>
<td>$1,234</td>
</tr>
<tr>
<td>Percentage (times 100)</td>
<td>.085</td>
<td>8.5%</td>
</tr>
<tr>
<td>Percentage Integer (times 100, rounded to whole percent)</td>
<td>.4275</td>
<td>43%</td>
</tr>
<tr>
<td>Thousands (divided by 1000)</td>
<td>1234567</td>
<td>1234.567</td>
</tr>
<tr>
<td>Millions (divided by one million)</td>
<td>123456789</td>
<td>123</td>
</tr>
<tr>
<td>Scientific</td>
<td>1234.5678</td>
<td>1.23E+03</td>
</tr>
</tbody>
</table>
AVAILABLE DATE FORMATS
You can use the following formats for fields containing date or computed values:

<table>
<thead>
<tr>
<th>DATE FORMAT</th>
<th>EXAMPLE (VALUE = 23456)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date: Long</td>
<td>Saturday, March 21st, 1964</td>
</tr>
<tr>
<td>Date: Long, Condensed</td>
<td>Sat, Mar 21, 1964</td>
</tr>
<tr>
<td>Date: Long, No Weekday</td>
<td>March 21, 1964</td>
</tr>
<tr>
<td>Date: Long, Condensed, No Weekday</td>
<td>Mar 21, 1964</td>
</tr>
<tr>
<td>Date: Short</td>
<td>3/21/64</td>
</tr>
<tr>
<td>Date: Short, Zero Padded</td>
<td>03/21/64</td>
</tr>
<tr>
<td>Date: Long, Month &amp; Day</td>
<td>Saturday, March 21st</td>
</tr>
<tr>
<td>Date: Long, Month &amp; Day, No Weekday</td>
<td>March 21st</td>
</tr>
<tr>
<td>Date: Short, Month &amp; Day</td>
<td>3/21</td>
</tr>
<tr>
<td>Date: Short, Month &amp; Year</td>
<td>March, 1964</td>
</tr>
<tr>
<td>Date: Year</td>
<td>1964</td>
</tr>
<tr>
<td>Date: Month</td>
<td>March</td>
</tr>
<tr>
<td>Date: Day</td>
<td>21st</td>
</tr>
<tr>
<td>Date: Weekday</td>
<td>Saturday</td>
</tr>
</tbody>
</table>

AVAILABLE TIME FORMATS
You can use the following formats for fields containing time or computed values:

<table>
<thead>
<tr>
<th>TIME FORMAT</th>
<th>EXAMPLE (VALUE = 1234.567)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time: Hour Min Sec</td>
<td>1:36:29PM</td>
</tr>
<tr>
<td>Time: Hour Min</td>
<td>1:36 PM</td>
</tr>
<tr>
<td>Time: Hour</td>
<td>1 PM</td>
</tr>
<tr>
<td>Time: Min Sec</td>
<td>36:29</td>
</tr>
</tbody>
</table>

Changing the Field Number Format
You can change the number format for a field.
To change the field number format (Levels 3-4)

1. Select the field you want to format.
2. Choose Field Number Format from the Properties menu. A dialog box appears:

   ![Field Number Format dialog box]

   Formats list
   Examples
   Custom Format buttons

3. Select the format you want from the list.
4. Click Apply. GeoFile applies the format to the field you selected.

Creating Custom Field Number Formats

You can create your own field number formats for special field formatting. You might do this, for example, if you have a currency field in German marks (Deutsch Marks, or “DM”), and want to display “DM” in that field.

To create a custom field number format (Levels 3-4)

1. Select the field you want to format.
2. Choose Field Number Format from the Properties menu. A dialog box appears.
3. Click Create. A dialog box appears:

![Image of Define Format dialog box]

4. Specify the format options you want. Refer to the examples in the dialog box as you set your specifications:

   **Name of Format.** Enter a name for the new format.

   **Places.** Enter the number of decimal places.

   **Offset.** Enter the number of offset places. Negative numbers move the decimal point to the left and positive numbers move it to the right.

   **Options.** Select format options from the drop-down list: Commas, Percent sign, leading and trailing zeros, and the position of the sign (+ or -) relative to the header or trailer. For example, if the sign follows the header, then a negative dollar amount is formatted like this: $-100 (rather than -$100).

   **Fixed/Scientific.** Select either fixed notation or scientific notation.

   **Leading.** Enter the numbers or characters you want to appear in front of each value you enter, like a prefix. You can specify a prefix for Positive, Negative, or All Numbers. For example, if you enter **DM** in the All box, every value using this format will begin with **DM**; if you enter **345**, it will appear as **DM345** in the active cell.

   **Trailing.** Enter the numbers or characters you want to appear at the end of each value you enter, like a suffix. For example, if you enter **DM** in the All box, **DM** will appear at the end of every value using this format; if you enter **345**, it will appear as **345DM** in the active cell.

5. Click OK. GeoFile saves the format you created.
NOTE
If you want to create number and date formats that you will use in most of your work, you can create them in a new document and save them as the default empty document. For more information about changing the default empty document, see “Default Settings for Empty Documents” in Chapter 3.

USING FIELD EXPRESSIONS

LEVEL 4
You can use field expressions to calculate defaults and current values for fields in a layout.

An expression is a formula that can include field names, functions, math operators, logic operators, numbers and strings. For example, the following expression contains fields, math operators (+ and ÷), and a function (TRUNC):

Field_1 +TRUNC(Field_2 ÷ Field_3)

In general, for computed fields, avoid using date and time fields (stored as serial numbers) in combination with other data types. However, you can still perform basic operations on date or time values, such as subtracting dates from each other or calculating times.

You can add default values and expressions to fields. For more information about expressions, see “Using Field Expressions” in this chapter, and see Appendix A.

GeoFile uses many of the same functions and operators that GeoCalc uses. However, not all GeoCalc functions apply to GeoFile. GeoFile supports all GeoCalc functions except the following: COLS, FILENAME, HLOOKUP, INDEX, IRR, N, NPV, PAGE, PAGES, ROWS, and VLOOKUP. Avoid using unsupported functions in GeoFile. In GeoCalc, you normally precede an expression with an equal sign (=); you do not do this in GeoFile. Because GeoCalc supports all the GeoFile functions, you can use GeoCalc to test your formulas before putting them in a GeoFile database. Doing this can save time as you verify your formulas.

Using Default Values
GeoFile calculates a default value when it creates a new record in the database during data entry mode. For example, you can have GeoFile put a default area code in a Phone_Number field using the following simple expression: “510”. Similarly, you could have
a Date_Created field using the function TODAY to save the record creation date in the record.

For default values, you can even rely on the default value of another field in the new record. For example, you can calculate a Date_Payment_Due field using the following expression:

Date_Ordered + 30

NOTE
GeoFile evaluates field expressions according to the alphabetical order of field names. Therefore, in your expression, you can refer only to field names that precede the current field name alphabetically. The expression in the previous example works because Date_Ordered comes before Date_Payment_Due in alphabetical order. Referring to a field named Date_Shipped, however, will not work; you would need to rename the field to use it in the formula.

Using Computed Values
GeoFile calculates a computed value field whenever it creates a new record in the database or when an element in the expression changes during data entry mode.

For example, you can specify the following formula in a field called Average_Per_Sale:

Sales_to_Date ÷ Number_of_Sales

GeoFile recalculates Avg_Per_Sale whenever the value changes in the Sales_to_Date field or Number_of_Sales field.

Changing Defaults and Field Expressions
Use the following procedure to change a field's default or field expression.

To change defaults and field expressions (Level 4)

1. Select a field from the Field Organizer.
2. Click Edit This Field on the Field Organizer. A dialog box appears.
3. Click Set Default. A dialog box appears:

![Create a default expression dialog box]

4. Fill in the dialog box, selecting the options you want:

   **Field Names.** This option lists all the field names in the GeoFile database. Selecting a field name pastes it at the insertion point in the Expression Box.

   **Functions.** This option lists all the GeoFile functions you can use. Selecting a function pastes it at the insertion point in the Expression Box.

   **Math.** This option lists all the GeoFile math operators you can use. Selecting an operator pastes it at the insertion point in the Expression Box.

   **Logic.** This option lists all the GeoFile logical operators you can use. Selecting an operator pastes it at the insertion point in the Expression Box.

   For a list of GeoFile functions, math operators, and logical operators, see the remainder of this section.

5. Click OK. GeoFile checks the syntax of the expression you have typed. If the syntax passes, the dialog box closes.

6. If GeoFile detects a syntax error, it displays an error box and highlights a problem in the Expression Box. Click OK and resume editing the expression until the syntax passes. The dialog box closes.
Using Functions

This section summarizes the GeoFile functions. For an introduction to using functions, see Chapter 12, "GeoCalc Basics." For a detailed description of each function, see its listing in Appendix A.

USING FINANCIAL FUNCTIONS

The arguments for financial functions are either numbers or field names. When the argument is the interest rate, express it as its actual value (for example, enter \texttt{.07} rather than \texttt{7} to indicate 7%). Be certain to specify the same units for the term and the interest. If the interest is monthly, the term is also monthly. The results of these calculations are always numbers.

- \texttt{CTERM} \hspace{1cm} Number of compounding periods required for an investment to grow to a future value.
- \texttt{DDB} \hspace{1cm} Double-declining balance depreciation of an asset.
- \texttt{FV} \hspace{1cm} Future value of an investment.
- \texttt{PMT} \hspace{1cm} Payment of loan.
- \texttt{PV} \hspace{1cm} Present value.
- \texttt{RATE} \hspace{1cm} Required interest rate to reach a future value.
- \texttt{SLN} \hspace{1cm} Straight-line depreciation.
- \texttt{SYD} \hspace{1cm} Accelerated depreciation of an asset, using the sum of year's digits method.
- \texttt{TERM} \hspace{1cm} Required number of payment periods to reach a future value.

You use these functions to calculate financial statistics.

USING INFORMATION FUNCTIONS

The information functions return information about a field.

- \texttt{CHOOSE} \hspace{1cm} Chooses a value from a list.
- \texttt{COUNT} \hspace{1cm} The number of items in a list, that is, the number of non-blank cells in a range.
- \texttt{ERR} \hspace{1cm} Causes the formula to evaluate to the \#ERROR\# message.
- \texttt{ISERR} \hspace{1cm} Returns 1 if an expression is an error or 0 if it is not.
- \texttt{ISNUMBER} \hspace{1cm} Returns 1 if an expression is a number or 0 if it is not.
ISSTRING

Returns 1 if an expression is a string or 0 if it is not.

NA

Causes the formula to evaluate to the N/A (Not Available) error.

You use these functions to check the values in a field. For example, you might want to make sure that an expression does not divide by zero (0).

USING LOGICAL FUNCTIONS

The logical functions evaluate relationships and evaluate “true” or “false” results. True = 1 (or non-zero values) and false = 0. The main purpose of logical functions is the IF( ) function, which evaluates any of the logical functions in order to take a specified action.

AND

Logical AND
FALSE

Returns 0
IF

Evaluates a condition, returning one specified value if true and another if it is false
OR

Logical OR
TRUE

Returns 1

You use these functions to create conditional expressions.

USING MATHEMATICAL FUNCTIONS

The arguments for mathematical functions are either numbers or field names. The results of these calculations are always numbers.

ABS

Absolute value of a number.
EXP

Value of e (the mathematical constant) raised to the n\textsuperscript{th} power.
FACT

Factorial of a number.
INT

Value rounded to the next lowest integer.
LN

Natural logarithm of a number.
LOG

Logarithm of a number.
MOD

Modulus, the remainder of a division calculation.
PRODUCT

Result of multiplication of a list of numbers.
ROUND

Value rounded to the specified number of decimal places.
SQRT

Square root of a number.
SUM

Total of a list of numbers.
TRUNC The integer portion (without rounding) of a number.

You use these functions to manipulate numbers.

**USING STATISTICAL FUNCTIONS**
The arguments for statistical functions consist of either numbers or field names. The results of these calculations are always numbers.

- **AVG** Average of the values in a list.
- **MAX** Largest number in a list.
- **MIN** Smallest number in a list.
- **RANDOM** Random number between 0 and 1.
- **RANDOMN** Random number between 0 and n-1.
- **STD** Standard deviation of the values in a list.
- **STDP** Standard deviation of a population.
- **VAR** Simple variance of sample population.
- **VARP** Population variance of the values in a list.

You use these functions to calculate statistics.

**USING STRING FUNCTIONS**
*Strings are alphanumeric characters. The string functions extract text (including numbers) or return numbers based on text. For example, you can extract the last four digits of a stock number that might identify the manufacturer of a product.*

GeoFile uses GEOS code numbers internally to express each character. The CHAR and CODE string functions convert GEOS codes to characters and vice versa. For information about GEOS character codes, see Appendix C.

- **CHAR** Converts GEOS code numbers to characters.
- **CLEAN** Strips unprintable characters from a string.
- **CODE** Converts characters to their GEOS code numbers.
- **EXACT** Compares two strings for an exact match.
- **FIND** Searches within a string for a specific string.
- **LEFT** Returns the characters in the leftmost position in a string.
- **LENGTH** Returns the number of characters in a string.
- **LOWER** Converts upper case characters to lower case.
- **MID** Returns the characters in the middle of a string.
PROPER  Converts words in a string to initial caps.
REPEAT   Repeats a string a specified number of times.
REPLACE  Replaces matching characters in a string with a
specified string.
RIGHT    Returns the characters in the rightmost position
in a string.
STRING   Converts numbers to a string.
TRIM     Removes leading, trailing and extra internal
spaces in a string.
UPPER    Converts a string to upper case.
VALUE    Converts a number in string form to a value.

You use these functions to manipulate strings.

USING DATE AND TIME FUNCTIONS
GeoFile uses serial numbers to express times and dates. The
serial numbers begin with 1 = January 1, 1900. You can use the
DATEVALUE function to create a serial number. These functions
are most useful in formulas where the time and date are
calculated rather than entered as a constant.

DATE     Converts a numeric date (day, month, year) to
the GeoCalc and GeoFile serial number format.
DATEVALUE Converts a date (in text form) to the GeoCalc
and GeoFile serial number format.
DAY      Extracts the day from the GeoCalc and GeoFile
serial number format.
HOUR     Extracts the hour from the GeoCalc and GeoFile
serial number format.
MINUTE   Extracts the minute from the GeoCalc and
GeoFile serial number format.
MONTH    Extracts the month from the GeoCalc and
GeoFile serial number format.
NOW      Returns the current date (month, day, and year)
and time (hour, minute, and second). No
arguments are necessary.
SECOND  Extracts the second from the GeoCalc and
GeoFile serial number format.
TIME     Converts a numerical time (hour, minute, and
second) to the GeoCalc and GeoFile serial
number format.
TIMEVALUE  Converts a time (in text format) to the GeoCalc and GeoFile serial number format.

TODAY  Returns the current date (month, day, and year) from the GeoCalc and GeoFile serial number format.

WEEKDAY  Returns the number for the day of the from the GeoCalc and GeoFile serial number format (Sunday = 1, Saturday = 7).

YEAR  Returns the current year from the GeoCalc and GeoFile serial number format.

### Using Mathematical Operators

You can use the following mathematical operators in your formulas:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Operation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
<td>Field_1 + Field_2</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
<td>Field_1 - Field_2</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
<td>Field_1 * Field_2</td>
</tr>
<tr>
<td>÷</td>
<td>Division</td>
<td>Field_1 ÷ Field_2</td>
</tr>
<tr>
<td>%</td>
<td>Percentage</td>
<td>Field_1 * 23%</td>
</tr>
<tr>
<td>^</td>
<td>Exponentiation</td>
<td>Field_1^2</td>
</tr>
</tbody>
</table>

For the division operator, you can either type the forward slash (/) or press Ctrl+Alt+ to get the special division symbol.

When you use more than one operator in a formula, GeoCalc performs the calculations in the order shown in the table—% first, ^ second, and so forth. If you use more than one operator with the same priority (like + and -), GeoCalc performs those calculations from left to right.

You can alter the order of calculations by enclosing within parentheses those expressions you want calculated first. GeoCalc evaluates expressions enclosed in parentheses first, and then uses those results to calculate the rest of the formula. The following example shows what happens when you use parentheses:

\[ 10+100\div2 = 60 \]

\[ (10+100)\div2 = 55 \]
Using Logical Operators

You can use the following logical operators in your formulas:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Operation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;</td>
<td>concatenation</td>
<td>City&amp;, &quot;&amp;State&amp;&quot; &amp; Zip</td>
</tr>
<tr>
<td>=</td>
<td>equivalence</td>
<td>IF(Field_1 = Field_2)</td>
</tr>
<tr>
<td>&lt;&gt; or ≠</td>
<td>non-equivalence</td>
<td>IF(Field_1 &lt;&gt; Field_2)</td>
</tr>
<tr>
<td>&lt;</td>
<td>greater than</td>
<td>IF(Field_1 &lt; Field_2)</td>
</tr>
<tr>
<td>&gt;</td>
<td>less than</td>
<td>IF(Field_1 &gt; Field_2)</td>
</tr>
<tr>
<td>≥ or ≥</td>
<td>greater than or equal to</td>
<td>IF(Field_1 &lt;= Field_2)</td>
</tr>
<tr>
<td>≤ or ≤</td>
<td>less than or equal to</td>
<td>IF(Field_1 &gt;= Field_2)</td>
</tr>
</tbody>
</table>

For the non-equivalence operator, you can either type <> or press Ctrl+Alt+= to get the special symbol (≠).
For the greater than or equal to operator, you can either type >= or press Ctrl+Alt+, to get the special symbol (≥).
For the less than or equal to operator, you can either type <= or press Ctrl+Alt+, to get the special symbol (≤).
You use these logical operators in any kind of expression.
To learn how to set up mailing labels, see “Using Multiple Records on a Layout” in this chapter.
You can use the concatenation operator to create a mailing label. If a label has multiple lines, you can use a carriage return inside a string, as in the following example (the ¶ symbol represents a carriage return, which must have quotation marks in front of it and quotation marks after it on the next line):
First_Name" "&Last_Name"¶
"&Address"¶
"&City", "&State&" "&Zip

FORMATTING A LAYOUT

The way you format a layout can greatly affect how easily you or others can enter, search for, or print information. This section describes general design principles for creating a layout, and then
it explains how to use GeoFile's text and graphics features to make your layout more visually appealing and useful.

**Planning a Layout**

Designing a layout page is an art that relies on how well you understand the nature of the information in the database, how you plan to use the information, and what you think is visually attractive. Basic design principles can help you design a better layout. You might want to start by sketching your ideas on paper.

You can create a layout from scratch or you can start with a template or another document and adapt it as necessary. For more information, see Chapter 17. You can even use the clipboard to copy fields and other objects between layouts in a database. You cannot, however, copy fields between databases; each database is a separate file, and field definitions differ between files.

You can usually organize fields into groups or categories. Consider the nature of the information in a database. Which fields belong together in a group? Which fields or groups should be distinct from each other? For example, in a customer database, you might put address information, contact information, and financial information into separate groups.

Your design should enhance how you plan to use the layout. For example, if you are designing a data entry layout, you might consider ways to make it easier and faster to enter the data: arranging the fields in the order in which they appear on paper, putting the fields most likely to contain data ahead of those most likely to remain empty, and so on. Remember that your eye normally travels across a sheet of paper or a computer screen from left to right and from top to bottom.

How much information do you really need on this layout? Can you eliminate fields that are not necessary? For example, if you are designing a layout for finding customer phone numbers, you might include names and phone numbers but omit address and financial information to reduce clutter.

How can you use graphics and text formatting to enhance the similarities and contrasts among fields and groups of fields? For example, you might put a box around each group of fields, put lines between groups, make groups different colors, use white space, and so on.
Do you want to make a field or a group of fields stand out? You can use colors for highlighting or place the field or group in a prominent position on the layout. You can also increase the font size of the text or even put a line with an arrowhead pointing to a particular field.

Aligning fields can make it much easier to scan the information on a layout. Similarly, distributing fields evenly across the layout, rather than clustering them in a small area, can give the layout a sense of balance and proportion.

Remember that you want to use visual cues to enhance the clarity of the data on the layout but not to overwhelm with too much information. You must use your best judgment to determine what looks best. Incorporating these aesthetic touches may seem subtle on the surface, but their value and importance increase every time you or another person uses a layout you have designed.

### Distinct groups contrast with each other.

The field order makes it easy to enter data.

```
Distinct groups contrast with each other.
```

```
The field order makes it easy to enter data.
```

### Fields are aligned vertically.

```
Fields are aligned vertically.
```

```
Related fields appear visually as a group.
```

### Graphics and text enhance similarity and contrast.

```
Graphics and text enhance similarity and contrast.
```

### Changing Field Labels

A field has two parts: the field label and the data entry area. You can change the text of a field label, and you can delete a field
label altogether. Field labels are text objects that you can manipulate as you would any text object.

**CHANGING THE TEXT**

When you add a field to a database, GeoFile automatically uses the name of the field as its field label. You might want to give it a different field label, however, to make it more descriptive or visually appealing. For example, if a field is named “Work_Phone,” you might want to make the field label say “Work Phone” instead.

To change the formatting of a text label, see “Formatting Text” in this chapter.

To change the text of a field label (Levels 3-4)

1. Select the Text tool from the Tool Bar. The pointer changes to crossbeams when you move it over the drawing area.
2. Move the pointer over the field label you want to change and click. An outline appears around the field label, and the insertion point appears inside the outline.
3. Edit the text of the field label.

**DELETING A FIELD LABEL**

Similarly, you might want to remove the field label altogether if it clutters up your layout. For example, you might not want individual field labels for First_Name, Middle_Initia, and Last_Name fields; you might instead want to have just one label, “Name,” for all three fields.

To delete a field label (Levels 3-4)

1. Select the Arrow tool from the Tool, if it is not already selected. The pointer changes to an arrow when you move it over the drawing area.
2. Click the field label you want to delete. Handles appear around the field.
3. Choose Delete from the Edit menu.
   
   or

   Press **Delete**.

   Either way, GeoFile deletes the field label you selected.
COPYING, CUTTING, AND PASTING USING THE CLIPBOARD
You can also cut, copy, and paste field labels using the clipboard. For more information, see “Selecting and Editing” in Chapter 2.

Arranging Fields
Like a text or graphic object, you can move and resize any field on a layout. You can also align or distribute fields to add proportion and balance to your layout.

SELECTING A FIELD
To move or resize a field, you must first select it.

To select a field (Levels 3-4)

1. If it is not already selected, select the Arrow tool from the Tool Bar. The pointer changes to an arrow when you move it over the drawing area.
2. Click the field you want to select. Handles appear around the field:

   ![Image of field handles]

   Move handle (the handle in the center)

   Corner handles (the handles around the edges)

To select multiple objects at a time (All Levels)

- Hold down the Ctrl key and click the object or objects you want to select. Handles appear around each object you select.

To select multiple adjacent objects (All Levels)

1. Place the pointer outside the area that includes the handles of the objects you want to select. Click, hold, and drag the mouse across the area you want to select. As you move the pointer, an outline encloses the area.
2. When all the objects you want to select appear completely within the outline, release the mouse button. The outline disappears, and the object or objects within the area are selected.

MOVING A FIELD
You can move a field from its current position to a new location on a layout. You often move fields and field labels together.
To move a field to a new location (Levels 3-4)

1. Select the object or objects you want to move.
2. Point to the move handle of an object you have selected, then press and drag the selected object or objects to the location you want.
3. Release the left mouse button. GeoFile puts the object or objects you select in the new location.

HINT
Sometimes it is easier to move an object just by dragging it with the right mouse button. This technique is the drag and drop mechanism described in the book *The GEOS Environment & Accessories*. The pointer changes to show an open rectangle at its base.

RESIZING A FIELD
By resizing a field, you can change the position of field edges so that the field fits better on a layout. Changing the field edges does not change the amount of information that the field can contain; it only changes the way the information appears on the layout.

To resize a field (Levels 3-4)

1. Select the field you want to resize.
2. Point to a corner handle of the selected field, then press and drag the handle until the field is the size you want.
3. Release the left mouse button. GeoFile draws the field in the size you selected.

ALIGNING AND DISTRIBUTING FIELDS
You can arrange fields so that they line up with each other (aligning) or so that they are equidistant from each other. Doing so makes your layout more readable and visually appealing. You can align and distribute fields along their top, bottom, left, or right edges; by width or height; or along their vertical or horizontal axes.

For more information, see "Aligning and Distributing Objects" in Chapter 10. Note that, in GeoFile, Arrange appears as a submenu under the Graphics menu.
Setting the Field Order

For data entry layouts, you can set the sequence by which you can move from field to field (after pressing Tab or Enter). By default, GeoFile uses the order in which you created the fields. You might want to change this if a more natural data entry sequence differs.

*To set the field tab order (Levels 3-4)*

1. Choose Set Field Tab Order from the Layout menu. A dialog box appears:

![Field Tab Order Dialog Box](image)

2. Select the field you want to move from the Fields in Database list.
3. Click the Up button. GeoFile moves the selected field up one field in the sequence.
   
   *or*
   
   Click the Down button. GeoFile moves the selected field down one field in the sequence.
4. Repeat Steps 2 and 3 for each field you want to move in the list.
5. Click OK. GeoFile saves the field tab order you selected.

Showing and Hiding Field Edges

By default, when you add a new field to a layout, GeoFile puts a border around the edges of a field's data entry area, as shown in the following illustration:

![Field Edges](image)
These edges indicate the outer boundaries of the field in which you are typing. However, you can hide any or all of these edges if it enhances your layout design.

*To show or hide field edges (Level 4)*

1. Select the field you want to change.
2. Choose Field Edges from the Properties menu. A submenu appears.
3. Select the field edge or edges you want to appear.
   
   or
   
   Deselect the field edge or edges you want to hide.

**Formatting Text**

You can format text on a layout to give it more emphasis, to increase its similarity with other objects, to provide contrast with other text objects, and so on. You can also format the data entry area of any field so that GeoFile uses the formatting to display any text it contains. GeoFile offers many of the text formatting features available in GeoWrite.

In GeoFile, you can use the text formatting choices on the Properties menu to change the font, size, color, and character attributes of selected text. You can use the Paragraph choice on the Properties menu to change the line spacing, paragraph spacing, color, indents, tabs, borders, and other attributes of text paragraphs. You can even create and use text style sheets.

At Levels 3 and 4, GeoFile also provides tools on the Function Tool Bar that you can click to use some of these features:

- Text alignment: left, centered, right, and full
- Click to see a list of fonts.
- Click to see a list of font sizes.
- Font size: increase and decrease.
- Text styles: plain, bold, italic, and underlined

For more information about each of these features, see GeoWrite Chapter 4 and Chapter 5.
NOTE
When following a procedure in the GeoWrite chapters, remember that GeoFile and GeoWrite have different menu structures. For example, to get to the Paragraph menu options, you choose it from the Properties menu in GeoFile, but you choose it from the main menu in GeoWrite. Similarly, the text formatting features appear on the Properties menu in GeoFile, but in GeoWrite they appear on the Character menu.

Using Graphics
You can add graphics to a layout to help group or contrast fields, to clarify the way the information is organized, to emphasize certain information, and so on. GeoFile offers many of the graphics tools available in GeoDraw.
GeoFile provides tools on the Drawing Tool Bar that you can use to add and manipulate objects on a layout:

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Pointer Tool" /></td>
<td>Pointer Tool</td>
<td>Selects one or more objects.</td>
</tr>
<tr>
<td><img src="image" alt="Rotate Tool" /></td>
<td>Rotate Tool</td>
<td>Rotates selected objects.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom Tool" /></td>
<td>Zoom Tool</td>
<td>Increases or reduces the size of the document on screen.</td>
</tr>
<tr>
<td><img src="image" alt="Text Tool" /></td>
<td>Text Tool</td>
<td>Adds and manipulates text objects.</td>
</tr>
<tr>
<td><img src="image" alt="Line Tool" /></td>
<td>Line Tool</td>
<td>Adds line objects.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangle Tool" /></td>
<td>Rectangle Tool</td>
<td>Adds rectangle objects.</td>
</tr>
<tr>
<td><img src="image" alt="Rounded Rectangle Tool" /></td>
<td>Rounded Rectangle Tool</td>
<td>Adds rounded rectangle objects.</td>
</tr>
<tr>
<td><img src="image" alt="Ellipse Tool" /></td>
<td>Ellipse Tool</td>
<td>Adds ellipse objects.</td>
</tr>
<tr>
<td><img src="image" alt="Arc Tool" /></td>
<td>Arc Tool</td>
<td>Adds arc objects.</td>
</tr>
<tr>
<td><img src="image" alt="Polyline Tool" /></td>
<td>Polyline Tool</td>
<td>Adds and manipulates polyline objects.</td>
</tr>
<tr>
<td><img src="image" alt="Rounded Polyline Tool" /></td>
<td>Rounded Polyline Tool</td>
<td>Adds and manipulates rounded polyline objects.</td>
</tr>
<tr>
<td><img src="image" alt="Spline Tool" /></td>
<td>Spline Tool</td>
<td>Adds and manipulates spline objects.</td>
</tr>
</tbody>
</table>

At Level 3 in GeoFile, you can use the graphic formatting choices on the Graphics menu to create, transform, and arrange graphic objects, to set their line and area attributes, and to create and use graphic style sheets. At Level 4, you get additional editing features and you can set additional graphic attributes.
DEFINING AND MANAGING LAYOUTS

Layouts give you different ways to display and print the information in your GeoFile database. At Levels 3 and 4, you can create additional layouts for specialized ways to work with data in the database: entering data, displaying information, printing a report, and so on.

For example, in a customer database, you might have one layout for entering data from business cards, another for displaying company names, contact names and phone numbers, one for printing mailing labels, and yet another for printing an address book. Each layout displays the data in the database in a different way to suit a particular purpose.

Switching Layouts

To work with a layout you have added, you first need to make it the current layout. For an introduction to layouts, see Chapter 17.

To switch to a layout (Levels 1-4)

1. Choose Switch Layout from the Layout menu. A dialog box appears.
2. Select the layout you want from the Choose Layout list.
3. Click Switch To. GeoFile displays the layout you selected.

Creating Additional Layouts

You can create up to 255 layouts in a GeoFile database.

NOTE

When following a procedure in the GeoDraw chapters, remember that GeoFile and GeoDraw have different menu structures. For example, the Transform, Arrange, and Attributes menus in GeoDraw appear as submenus on the Graphics menu in GeoFile.

For more information about each of these features, see GeoDraw Chapters 8, 9, 10, and 11.
To create a new layout (Levels 3-4)

- Choose Create New Layout from the Layout menu. GeoFile creates the new layout, assigns it a name (such as Layout 2) and makes it the current layout in the Field Organizer.

Adding Layout Notes

You can add notes to a layout as a reminder of what the layout contains when you switch to it. For example, you can describe the purpose of a data entry layout by saying “Use this layout to enter customer data.”

To add layout notes (Levels 3-4)

1. Choose Switch Layout from the Layout menu. A dialog box appears.
2. Select the layout you want from the Choose Layout list.
3. Click Edit Notes. A dialog box appears:

   ![Edit Layout Notes dialog box]

4. Type or edit the document notes in the Notes box. You can enter up to 256 characters.
5. Click OK. The dialog box closes. GeoFile saves your changes. These notes will appear the next time you select the layout in the Switch Layout dialog box, as shown in this example:
Renaming a Layout

You can change the name of a layout to make it more descriptive than the name GeoFile assigns when you create the layout. For example, you might want to rename Layout 1 to something like “Data Entry Form.”

To rename a layout (Levels 3-4)

1. Switch to the layout you want if it is not the current layout. For more information, see Chapter 17.
2. Choose Rename Layout from the Layout menu. A dialog box appears.

![Rename Layout dialog box]

3. Type a new layout name. You can use any combination of letters, numbers, spaces, and punctuation. The name you use should describe the purpose of the layout. For example, if your layout is for printing mailing labels, you might call the layout “Mailing Labels.”
4. Click Rename Layout. GeoFile changes the name of the layout to the name you entered.

Deleting a Layout

You can delete a layout you no longer need.

To delete a layout (Levels 3-4)

1. Switch to the layout you want if it is not the current layout.
2. Choose Delete Layout from the Layout menu. A confirmation message appears.
3. Click Yes. GeoFile deletes the current layout and switches to another layout.
Adding and Removing Fields on a Layout

A layout can contain some or all the fields in a database. The same field can appear on more than one layout. You use the Field Organizer to add and remove fields on a layout.

You cannot delete a field if it appears on the current layout. For more information, see “Deleting a Field” in this chapter.

ADDITION FIELD

You can add a field to a layout so that it appears when you select the layout.

To add a field to a layout (Levels 3-4)

1. Switch to the layout you want if it is not the current layout.
2. Select the field you want to add to the layout from the Fields Not in Current Layout list.
   or
   Press Ctrl and select the fields you want to add to the layout from the Fields Not in Current Layout list.
3. Click the right arrow button. GeoFile adds the fields to the layout.

REMOVING A FIELD

You can remove a field you no longer need from a layout. Removing a field does not delete it from the database; the field remains until you delete it from the database using the Delete This Field button on the Field Organizer.

To remove a field from a layout (Levels 3-4)

1. Switch to the layout you want if it is not the current layout.
2. Select the field you want to remove from the layout from the Fields In Current Layout list.

   or

   Press **Ctrl** and select the fields you want to remove from the layout from the Fields In Current Layout list.

3. Click the left arrow button. GeoFile removes the selected fields from the layout.

**Copying Objects Between Layouts**

You can cut, copy, and paste objects between layouts in a database using the clipboard. Doing this can save design and layout time. For more information, see “Selecting and Editing” in Chapter 2.

**WARNING**

You cannot copy objects between different databases using the clipboard because databases have different field definitions. Attempting to do this can cause unexpected results.

**USING MULTIPLE RECORDS ON A LAYOUT**

**LEVEL 4**

*This feature is available in multi-record mode only.*

GeoFile has two record modes at Level 4. In **single-record mode**, you can put one record on a layout at a time. In **multi-record mode**, you can add multiple records to the same layout. For example, you might do this to display rows of records on screen, like a phone list.

<table>
<thead>
<tr>
<th>Service Express</th>
<th>Judy Rickbaum</th>
<th>(578) 389-2678</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABC Company</td>
<td>John Enders</td>
<td>(415) 589-7863</td>
</tr>
<tr>
<td>CommTech</td>
<td>Bill Moss</td>
<td>(781) 892-8698</td>
</tr>
<tr>
<td>Tests Inc.</td>
<td>Christie Parks</td>
<td>(609) 389-7763</td>
</tr>
<tr>
<td>New Tools Co.</td>
<td>Suzy Graham</td>
<td>(708) 780-0090</td>
</tr>
<tr>
<td>Williams and Sons</td>
<td>Samuel Miller</td>
<td>(510) 874-7890</td>
</tr>
<tr>
<td>AC&amp;O Corporation</td>
<td>Dena Berry</td>
<td>(112) 678-3789</td>
</tr>
<tr>
<td>WBR Inc.</td>
<td>Lilly O'Brien</td>
<td>(509) 654-3897</td>
</tr>
</tbody>
</table>
You might also use this mode to print mailing labels or an address book, as shown in this example:

By default, every layout page contains a single record. To format a layout with multiple records, you must switch to multi-record mode and change the page size options.

**Switching Between Single- and Multi-Record Modes**

You can switch between modes by clicking the appropriate button. The buttons are shown here:

---

To switch record modes (Level 4)

- Click the Single-Record button. GeoFile changes to single-record mode.
  
  or
  
  Click the Multi-Record button. GeoFile changes to multi-record mode.

**Fitting Records on a Page**

Once you have entered multi-record mode, you must change the page size options so that multiple records can fit on the layout. For an introduction to page size options, see Chapter 1.
For the Single Record Size option, the default width is the width of the page minus the combined left and right margins. Similarly, its default height is the height of the page minus the top and bottom margins. By default, a single record fits on a layout page. To fit multiple records on a page, you need to reduce the single record size in proportion to the number of records you want to fit on a layout page.

For example, suppose you want to print mailing labels that fit six on a page in two columns, as shown here:

To calculate the record height, use the following formula:

If the page height is 11 inches and the top and bottom margins are 0.25 inches each, you would want to reduce the single record height to 3.5 inches.

To calculate the record width, use the following formula:

If the page width is 8.5 inches and the right and left margins are 0.25 inches each, you would want to reduce the single record width to 4 inches.
In another example, suppose you want to print on mailing labels that fit 30 on a page in three columns, as shown here:

![Mailing labels example](image)

For these mailing labels, the record height is 0.35 inches and the record width is 2.67 inches.

Alternatively, you can obtain the desired record size interactively by adjusting the record size until GeoFile displays the number of records you want on the layout. If you use this approach, it may be useful to zoom out so that you can see the entire page.

*To set the page size options for multiple records (Level 4)*

1. Choose Page Size from the File menu. A dialog box appears:

![Page Size dialog box](image)

2. Fill in the dialog, selecting the options you want.
3. Reduce the single record size in proportion to the number of records you want to fit on a layout page.

4. Click Apply. GeoFile displays dotted grid lines on the layout page indicating where records appear, as shown in the following example:

![Grid lines](image)

You can zoom out to see how records appear on the entire layout page. If necessary, you can continue to adjust the page size options until you achieve the result you want.

5. Click Close to close the dialog box.

Once you have the page size you want, you might need to change the position of fields on the layout so that they will fit.

**Fitting Fields into the Record Region**

Once you have determined the record size, you might need to adjust the position, size, or formatting of fields on the layout page so that the data in the database will fit in the record region.

For example, suppose you have set the single record width to 2 inches but some of the data, when displayed, is longer than 2 inches. If you do nothing, GeoFile will not display or print any text that extends beyond the right margin of the record region. However, if you reduce the length of the field or reduce the text size, more information can appear.

Alternatively, you can move fields closer together so that there is less space between them, or you can move them closer to the upper-left corner.
To fit fields in the Record Region (Level 4)

1. Click the Single-Record button to switch to single-record mode. The size of the layout screen shrinks to the size of a single record.

2. Move fields, change the field size, or change text formatting as desired.

Changing the Record Order

For layouts with multiple records appearing in multiple rows and columns, you can decide the order in which GeoFile organizes the records on a page.

In the following example, GeoFile organizes addresses by zip code in a vertical manner (the default):

In the following example, GeoFile organizes addresses by zip code in a horizontal manner:
To change the record navigation order (Level 3-4)

1. Choose Set Record Order from the Layout menu. A dialog box appears:

2. Select the record navigation order you want.

3. Click OK. GeoFile changes to the record navigation order your selected.

FINE TUNING YOUR USER LEVEL

Chapter 1 describes how to change and fine tune your user level. When you choose Set User Level from the Options menu, and click the Fine Tune button, you can toggle the following options on or off:

- Design Mode
- Graphics Layer
Field Organizer
Multi-Record Layout
Advanced Field Properties
Field Tab Order
Record Order
Mark Records
Advanced Sort
Mark by Formula
Advanced Graphics and Text

If you are working at a lower user level and want to use a feature that is available at a higher level, you can use Fine Tune to activate the feature. To save the fine tuning settings from session to session, use the Save Configuration choice on the Options menu.

KEYBOARD SHORTCUTS

The following table lists some GeoFile keyboard shortcuts you can use in Data Entry mode.

- Ctrl + ,. Previous record
- Ctrl + .. Next record
- Ctrl + ←. First record
- Ctrl + →. Last record
- Ctrl + ;. Mark/unmark record
- Ctrl + i. Commit (insert) record into database
- Tab/Enter. Next field
- Shift + Tab. Previous field
- Shift + Enter. Previous field
- Ctrl + n. Create a new record
- Ctrl + Enter. Create a new record
- Ctrl + Shift + Tab. Place a tab in a field
- Ctrl + Shift + Enter. Place a carriage return in a field
- Ctrl + d. Enter design mode
- Ctrl + e. Enter data-entry mode
• **Ctrl + r.** Enter single-record mode
• **Ctrl + m.** Enter multi-record mode
Math and Database Functions

Functions are built-in formulas that automatically perform common calculations and insert data in GeoCalc or GeoFile. For example, you can use a built-in function to total a group of numbers, calculate the net present value of an investment, or insert the current date and time.
Functions are represented by a *keyword* followed by *arguments* enclosed in parentheses. The function *returns* a value based on the arguments you enter. For example, in the expression SQRT(144), SQRT is the keyword for the square root function and 144 is the argument. This function returns 12, the square root of 144.

This appendix describes the math and database functions you can use in formulas in the spreadsheet cells in GeoCalc and the computed fields in GeoFile. It includes the following information:

- Rules governing arguments
- A quick reference to all functions, organized by function type
- A full function reference, organized alphabetically

This appendix assumes you are familiar with the information covered in Chapter 1. Chapter 1 provides an overview of the skills you need to use any GEOS application. For information about using functions in GeoCalc, see Chapter 12. For information about using functions in GeoFile, see Chapter 19.

**WARNING**

GeoCalc, GeoFile, and Calculator all use floating point math. While floating point calculations have benefits such as speed, they are inherently inaccurate. All spreadsheets and calculators based on floating point math produce errors in the 17th or 18th significant digit. While this is often not detectable, the errors become apparent in some calculations, especially financial functions such as IRR and NPV. GeoCalc, GeoFile, and Calculator all adhere to the IEEE 754 standards for floating point calculations. However, you should consult a financial specialist before you invest significant sums of money based on floating point calculations from any source.

**ARGUMENT RULES**

The following rules apply to using arguments in functions:

- You can use numbers, addresses, ranges, or cell and range names in GeoCalc; and field names in GeoFile as values.
- You must enclose text string arguments in quotation marks.
- You must specify interest rates as decimal values and they must correspond to the same time unit as the term. For example, payments that are monthly require a monthly interest rate.
You must express trigonometric angle arguments in radians. If you want to convert degrees to radians, use the `RADIAN()` function.

Some trigonometric functions return radians. If you need the returned value expressed in degrees, use the `DEGREES()` function.

For a description of each function and its arguments, see “Function Descriptions” in this appendix.

**FUNCTIONS AVAILABLE IN GEOCALC ONLY**

You can use the following functions only in GeoCalc:
- COLS
- FILENAME
- HLOOKUP
- INDEX
- IRR
- N
- NPV
- PAGE
- PAGES
- ROWS
- VLOOKUP

If you try to use any of these functions in GeoFile, you will see an error message.

**FUNCTION Quick REFERENCE**

This section gives an overview of the built-in functions, grouped by category. For more detailed descriptions of the functions and their arguments, see the next section, “Function Descriptions.”

**Financial Functions**

The arguments for financial functions are either numbers or field names or addresses of cells that contain numbers. When the argument is the interest rate, express it as its actual value (for
example, enter .07 or 7\% rather than 7 to indicate 7\%). Be certain to specify the same units for the term and the interest. If the interest is monthly, the term is also monthly. The results of these calculations are always numbers:

- **CTERM**: Number of compounding periods required for an investment to grow to a future value.
- **DDB**: Double-declining balance depreciation of an asset.
- **FV**: Future value of an investment.
- **IRR\***: Internal rate of return of an investment.
- **NPV\***: Net present value.
- **PMT**: Payment of loan.
- **PV**: Present value.
- **RATE**: Required interest rate to reach a future value.
- **SLN**: Straight-line depreciation.
- **SYD**: Accelerated depreciation of an asset, using the sum of year’s digits method.
- **TERM**: Required number of payment periods to reach a future value.

\* Available for use in GeoCalc only.

**Information Functions**

The information functions return information about a cell, range of cells, or field.

- **CHOOSE\***: Chooses a value from a list.
- **COLS\***: Number of columns in a range.
- **COUNT\***: The number of items in a list, that is, the number of non-blank cells in a range.
- **ERR**: Causes the formula to evaluate to the #ERROR# message.
- **HLOOKUP\***: Returns a value from a horizontal lookup table.
- **INDEX\***: Returns the value of the cell at the intersection of a row and column.
- **ISERR**: Returns 1 if an expression is an error or 0 if it is not.
ISNUMBER Returns 1 if an expression is a number or 0 if it is not
ISSTRING Returns 1 if an expression is a string or 0 if it is not
N* Returns the value from the first cell in a range
NA Causes the formula to evaluate to the N/A (Not Available) error
ROWS* Number of rows in a range
VLOOKUP* Returns a value from a vertical lookup table
* Available for use in GeoCalc only

Logical Functions
The logical functions evaluate relationships and return “true” or “false” results. True = 1 (or non-zero values) and false = 0. The main purpose of logical functions is the IF() function, which evaluates any of the logical functions in order to take a specified action.

AND Logical AND
FALSE Returns 0
IF Evaluates a condition, returning one specified value if true and another if it is false
OR Logical OR
TRUE Returns 1

Mathematical Functions
The arguments for mathematical functions are either numbers or field names or addresses of cells that contain numbers. The results of these calculations are always numbers.

ABS Absolute value of a number
EXP Value of e (the mathematical constant) raised to the n\textsuperscript{th} power
FACT Factorial of a number
INT Value rounded to the next lowest integer
LN Natural logarithm of a number
LOG Logarithm of a number
MOD Modulus, the remainder of a division calculation
PRODUCT  Result of multiplication of a list of numbers
ROUND    Value rounded to the specified number of decimal places
SQRT     Square root of a number
SUM      Total of a list of numbers
TRUNC    The integer portion (without rounding) of a number

Print Functions

The print functions return the name of the file, the current page, and the number of pages for inclusion in headers and footers when printing documents in GeoCalc. The print functions are not available for use in GeoFile.

FILENAME  Returns the filename
PAGE      Returns the current page number
PAGES     Returns the total number of pages

Statistical Functions

The arguments for statistical functions consist of either numbers or field names or addresses of cells that contain numbers. The results of these calculations are always numbers.

AVG       Average of the values in a list
MAX       Largest number in a list*
MIN       Smallest number in a list
RANDOM    Random number between 0 and 1
RANDOMN   Random number between 0 and a number you specify
STD       Standard deviation of the values in a list
STDP      Standard deviation of a population
VAR       Simple variance of sample population
VARP      Population variance of the values in a list

String Functions

A string is a series of characters. The string functions extract text (including numbers) or return numbers based on text. For

String arguments must be enclosed in quotation marks.
example, you can extract the last four digits of a stock number that might identify the manufacturer of a product.

GeoCalc and GeoFile use GEOS code numbers internally to represent each character. The CHAR and CODE string functions convert GEOS codes to characters and *vice versa*. For a complete list of the GEOS character codes, see Appendix C.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHAR</td>
<td>Converts a GEOS code number to characters</td>
</tr>
<tr>
<td>CLEAN</td>
<td>Strips unprintable characters from a string</td>
</tr>
<tr>
<td>CODE</td>
<td>Converts a character to its GEOS code number</td>
</tr>
<tr>
<td>EXACT</td>
<td>Compares two strings for an exact match</td>
</tr>
<tr>
<td>FIND</td>
<td>Searches within a string for a specific string</td>
</tr>
<tr>
<td>LEFT</td>
<td>Returns the characters in the leftmost position in a string</td>
</tr>
<tr>
<td>LENGTH</td>
<td>Returns the number of characters in a string</td>
</tr>
<tr>
<td>LOWER</td>
<td>Converts upper case characters to lower case</td>
</tr>
<tr>
<td>MID</td>
<td>Returns the characters in the middle of a string</td>
</tr>
<tr>
<td>PROPER</td>
<td>Converts words in a string to initial caps</td>
</tr>
<tr>
<td>REPEAT</td>
<td>Repeats a string a specified number of times</td>
</tr>
<tr>
<td>REPLACE</td>
<td>Replaces matching characters in a string with a specified string</td>
</tr>
<tr>
<td>RIGHT</td>
<td>Returns the characters in the rightmost position in a string</td>
</tr>
<tr>
<td>STRING</td>
<td>Converts numbers to a string</td>
</tr>
<tr>
<td>TRIM</td>
<td>Removes leading, trailing and extra internal spaces in a string</td>
</tr>
<tr>
<td>UPPER</td>
<td>Converts a string to upper case</td>
</tr>
<tr>
<td>VALUE</td>
<td>Converts a number in string form to a value</td>
</tr>
</tbody>
</table>

**Time and Date Functions**

GeoCalc and GeoFile use serial numbers to represent times and dates. The serial numbers begin with $1 = \text{January 1, 1900}$. The DATE and DATEVALUE functions return the serial number for a given date.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATE</td>
<td>Converts a numeric date (day, month, year) to the GeoCalc and GeoFile serial number format</td>
</tr>
</tbody>
</table>
DATEVALUE
Converts a date (in text form) to the GeoCalc and GeoFile serial number format

DAY
Extracts the day from the GeoCalc and GeoFile serial number format

HOUR
Extracts the hour from the GeoCalc and GeoFile serial number format

MINUTE
Extracts the minute from the GeoCalc and GeoFile serial number format

MONTH
Extracts the month from the GeoCalc and GeoFile serial number format

NOW
Returns the current date (month, day, and year) and time (hour, minute, and second). No arguments are necessary

SECOND
Extracts the second from the GeoCalc and GeoFile serial number format

TIME
Converts a numerical time (hour, minute, and second) to the GeoCalc and GeoFile serial number format

TIMEVALUE
Converts a time (in text format) to the GeoCalc and GeoFile serial number format

TODAY
Returns the current date (month, day, and year) from the GeoCalc and GeoFile serial number format

WEEKDAY
Returns the number for the day of the from the GeoCalc and GeoFile serial number format (Sunday = 1, Saturday = 7)

YEAR
Returns the current year from the GeoCalc and GeoFile serial number format

**Trigonometric Functions**

The arguments for trigonometric functions are either numbers or field names or addresses of cells that contain numbers. The results of these calculations are always numbers.

ACOS
Returns the angle that is the arccosine of a number

ACOSH
Returns the angle that is the hyperbolic arccosine of a number

ASIN
Returns the angle that is the arcsine of a number
<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASINH</td>
<td>Returns the angle that is the hyperbolic arcsine of a number</td>
</tr>
<tr>
<td>ATAN</td>
<td>Returns the angle that is the arctangent of a number</td>
</tr>
<tr>
<td>ATANH</td>
<td>Returns the angle that is the hyperbolic arctangent of a number</td>
</tr>
<tr>
<td>ATAN2</td>
<td>Returns the arctangent of the angle determined by the coordinates (x,y)</td>
</tr>
<tr>
<td>COS</td>
<td>Returns the cosine of a number</td>
</tr>
<tr>
<td>COSH</td>
<td>Returns the hyperbolic cosine of a number</td>
</tr>
<tr>
<td>DEGREES</td>
<td>Converts radians to degrees</td>
</tr>
<tr>
<td>PI</td>
<td>Value of (\pi).</td>
</tr>
<tr>
<td>RADIANS</td>
<td>Converts degrees to radians</td>
</tr>
<tr>
<td>SIN</td>
<td>Returns the sine of a number</td>
</tr>
<tr>
<td>SINH</td>
<td>Returns the hyperbolic sine of a number</td>
</tr>
<tr>
<td>TAN</td>
<td>Returns the tangent of an angle</td>
</tr>
<tr>
<td>TANH</td>
<td>Returns the hyperbolic tangent of a number</td>
</tr>
</tbody>
</table>
FUNCTION DESCRIPTIONS

This alphabetic list describes each function, including its arguments, and provides one or two simple examples.

**ABS**(value)
This mathematical function returns the absolute value of the number represented by value. Value can be a cell or field reference.

**EXAMPLES**
ABS(12) returns 12.
ABS(-12) returns 12.

**ACOS**(value)
This trigonometric function returns the arccosine, the angle for which the cosine equals value. Value can be a cell or field reference.

*Value* must be from -1 to 1.

**EXAMPLE**
ACOS(.50) returns 1.047198 radians.

**ACOSH**(value)
This trigonometric function returns the hyperbolic arccosine of value. The inverse hyperbolic cosine is the number for which the hyperbolic cosine is value. Value can be a cell or field reference.

*Value* must be equal to or greater than 1.

**EXAMPLE**
ACOSH(5) returns 2.292432.

**AND**(logical1,logical2,...)
This logical function returns 1 if all of the arguments are true or 0 if any of the arguments is false. This function is particularly useful with IF statements.

You can have as many *logical* arguments as you want. Logical can be either logical values or arrays or references to cells or fields that contain logical values. Text is ignored. If the argument
doesn't contain a logical value, AND returns the #TYPE# error. See also OR.

**EXAMPLES**

AND(1+3=4,3+1=3) returns 0.
AND(1+3=4,3+1=4) returns 1.
IF(AND(A1>B1,A1<C1),100,200) returns 100 if A1 is greater than B1 and less than C1. Otherwise, it returns 200.

**ASIN(value)**

This trigonometric function returns the arcsine of a value. The arcsine is the angle which is the sine of *value*. The angle is between $-\pi/2$ and $\pi/2$ radians.

*Value* must be from -1 to 1.

**EXAMPLE**

ASIN(.75) returns 0.848062 radians.

**ASINH(value)**

This trigonometric function returns the hyperbolic sine of *value*. The inverse hyperbolic sine is the number which is the hyperbolic cosine of *value*.

**EXAMPLES**

ASINH(10) returns 2.998223.
ASINH(15) returns 3.402307.

**ATAN(value)**

This trigonometric function returns the arctangent of a number. The arctangent is the angle (in radians) for which the tangent equals *value*.

*Value* is the tangent of the angle you want.

**EXAMPLE**

ATAN(90) returns 1.559686 radians.

**ATAN2(x,y)**

This trigonometric function returns the arctangent of $x,y$ — the argument representing an $x,y$ coordinate. The arctangent is the angle formed by the $x$-axis and a line passing through the origin.
(0,0) and the specified x,y coordinate. The coordinates x,y can be in any quadrant.

The angle is returned in radians from $-\pi/2$ to $\pi/2$. A positive result indicates a counterclockwise angle from the x-axis.

You cannot use the origin for the x,y argument. If you use 0,0 for x,y, the #VALUE# error appears in the cell.

**EXAMPLE**

ATAN2(1.5,2.0) returns 0.643501 radians.

**ATANH(value)**

This trigonometric function returns the hyperbolic arctangent of value. Value must be between (but not including) -1 and 1. The inverse hyperbolic tangent is the number which is the hyperbolic tangent of value.

**EXAMPLE**

ATANH(0.75) returns 0.972955.

**AVG(value1,value2,...)**

This statistical function returns the arithmetic mean of a list of values. You can use as many arguments as you want, including values, addresses, ranges, named cells, named ranges, and field names for arguments. AVG ignores treats empty cells as zero values. You cannot average cells or fields containing text.

**EXAMPLES**

AVG(A15:A24) returns 74.
AVG(Grades) returns 85.
AVG(89,94,91,98) returns 93.
CHAR(value)

This string function returns the GEOS character code corresponding to value. You can use values between 1 and 255. The function of CHAR() is the opposite of CODE(). For information about GEOS character codes, see Appendix C.

If the value is out of the 32–255 range, CHAR returns a #VALUE# error.

EXAMPLES

CHAR(65) returns A.
CHAR(68) returns D.

CHOOSE(index, value1, value2, ...)

This information function returns the n\textsuperscript{th} value in the list of arguments, where the first value is 0 and index indicates the n\textsuperscript{th} value. Value can be from 0 to n-1. You can use as many values as you want. Index and values can be numbers, cell references, defined names, formulas, functions, or text. For example, if the values are the months of the year and the index is 5, then CHOOSE returns May. This function returns an error if your index is less than zero or greater than the number of values.

EXAMPLES

CHOOSE(5, A1, A2, A3, A4, A5, A6) returns the contents of cell A5.
CHOOSE(2, “vanilla”, “chocolate”, “toasted almond”, “peach”) returns toasted almond.

CLEAN(string)

This string function removes control characters from string. This is a useful function for removing non-printable characters from imported text.

EXAMPLE

CLEAN(CHAR(13)&“text”) returns text.

CODE(string)

This string function returns the GEOS code for the first character in string. For information about GEOS codes, see Appendix C.
EXAMPLES
CODE("A") returns 65.
CODE("D") returns 68.
CODE("Now is the time") returns 78.

COLS(range)
This information function returns the number of columns in a range.
COLS is not available for use in GeoFile.

EXAMPLE
COLS(B2:F65) returns 5.

COS(angle)
This trigonometric function returns the cosine of angle. You must express angle in radians. If you know an angle in degrees, you can use the RADIANS function to convert it to radians.

EXAMPLES
COS(1.5) returns 0.070737.
COS(RADIANS(40)) returns 0.766044.

COSH(value)
This trigonometric function returns the hyperbolic cosine of value.

EXAMPLE
COSH(2) returns 3.762196.

COUNT(value1,value2,...)
This information function returns the number of arguments. Values can be numbers, null, logical values, dates. In GeoFile, the arguments can only be a comma-separated list. Values referring to blank cells or fields are not counted.

EXAMPLES
COUNT(23,42,65,23) returns 4.
COUNT(B3:B6) returns the number of non-blank cells in the range.
**CTERM(interest,future_value,present_value)**

This financial function returns the number of compound periods required for an investment to grow to a future value. 
*Interest* is the interest rate for the calculation. 
*Future_value* is the proposed value of the asset. 
*Present_value* is the current value of the asset.

**EXAMPLE**

CTERM(.05,1000,500) returns 14.2 periods.

**DATE(year,month,day)**

This date function returns the serial number for the date year, month, and day. 
*Year* can be from 1900 to 2078. For the years 1900 to 1999, you can enter just the last two digits, for example 96 rather than 1996. 
*Month* can be 1–12. 
*Day* can be a value from 1–31, depending on the number days in month.

If you use year, month, or day values that are out of range, DATE returns #VALUE#.

**EXAMPLES**

DATE(93,01,20) returns 33988. 
DATE(93,01,32) returns #VALUE#, because the day value 32 is out of bounds.

**DATEVALUE(string)**

This date function converts a text date into a serial number.

**EXAMPLES**

DATEVALUE("1/20/93") returns 33988. 
DATEVALUE("Jan 20, 1993") returns 33988.

**DAY(date_value)**

This date function returns the day of the month from the date_value. Date_value must be a serial number. Use DATEVALUE to convert dates entered as labels.
EXAMPLES
DAY(33988) returns 20.
DAY(DATEVALUE("1/20/93")) returns 20.

**DDB(cost,salvage,life,period)**
This financial function calculates the depreciation of an asset, using the double-declining balance method. Depreciation is highest in the first period and decreases in successive periods. Each year's depreciation is a constant percent of the *book value* of the asset and continues until the book value equals the salvage value.

\[ \text{DDB} = \text{cost} - \text{salvage} \times \left( \text{total depreciation from previous periods} \times \frac{2}{\text{life}} \right) \]

*Book Value* is the value of the asset at any given period, taking depreciation into account.

*Cost* is the original cost of the asset.

*Salvage* is the ending value of the asset.

*Life* is the duration of the depreciation, using the same units as *Period*.

*Period* is the time-period for which the depreciation calculation occurs.

**NOTE**
This is not a cumulative calculation.

**EXAMPLES**
DDB(5000,250,60,1) returns $166.67, the depreciation during the first month.
DDB(5000,250,60,2) returns $161.11, the depreciation during the second month.
DDB(5000,250,5,1) returns $2000, the depreciation during the first year.

**ERR()**
This information function causes the formula to evaluate to #ERROR# and stop. This is particularly useful with IF functions to say, "If the condition is false, then return #ERROR#." You must include the empty parentheses.
EXAMPLE
IF(A5>100,ERROR,A5) returns #ERROR# if the value in A5 is less than or equal to 100; otherwise, it returns the value in A5.

EXACT(string1,string2)
This string function compares two strings to determine if they match exactly. EXACT is case sensitive, meaning that “April” and “april” are not considered an exact match. If string1 and string2 match, EXACT returns 1; if they do not match, EXACT returns 0. Its action is similar to the equals sign except the = is not case-sensitive. This is particularly useful with IF statements.

EXAMPLES
EXACT(“iteration”,“iteration”) returns 1.
EXACT(“iteration”,“Iteration”) returns 0.
IF(EXACT(A5,“Hotel”),1000,0) returns 1000 if A5 contains “Hotel”.
IF(EXACT(A5=“Hotel”),1000,0) returns 1000 if A5 contains “Hotel” or “hotel”.

EXP(value)
This mathematical function returns $e$ raised to the power of value, where $e$ is approximately equal to 2.71828182845904, the base of the natural logarithm.

EXAMPLE
EXP(2) returns $e^2$ or 7.389056.

FACT(value)
This mathematical function returns the factorial of value. The factorial is equal to $1 \cdot 2 \cdot 3 \ldots \cdot value$, where value is a positive integer. If value has a fractional portion, FACT calculates the factorial for the integer portion of value.

EXAMPLES
FACT(4) returns 24.
FACT(2.5) returns 2.
FALSE()
This logical function returns a zero. You can use FALSE in a calculation or enter it directly into a cell or field where it is interpreted as a logical value by GeoCalc or GeoFile. You must include the empty parentheses. See also TRUE.

FILENAME()
This print function returns the filename of the current file for inclusion in a GeoCalc header or footer. You must include the empty parentheses.
FILENAME is not available for use in GeoFile.

FIND(substring,string,start)
This string function finds the substring within the entire string and returns the numeric position of the first character of the substring. You can specify the numeric position of the starting character for the search with the start argument. The first character in the string is in position 0.

EXAMPLES
FIND("all","Now is the time for all good men",0) returns 20.
FIND("i","Mississippi",3) returns 4.

FV(payments,interest,term)
This financial function returns the future value of a stream of regularly invested payments. For example, you can use FV to calculate if you save $250 every month, will that pay for your child’s college education of $40,000 in ten years?
Payments is the payment made each period.
Interest is the interest rate for the same time period as payments.
Term is the total number of payments that are made.
The following is the formula used by the FV function:
\[
FV = payment \times \left(\frac{(1 + \text{rate})^{\text{term}} - 1}{\text{rate}}\right)
\]

EXAMPLES
FV(250,.05/12,120) returns $38820.57.
To compare the present value with the future value if you invest $500 every month for 10 years at an interest rate of 5%, you would use the following expressions:

\[
\text{FV}(500, .05/12, 120) \quad \text{returns} \quad 77641.14.
\]

\[
\text{PV}(500, .05/12, 120) \quad \text{returns} \quad 47140.68.
\]

**HLOOKUP(value,range,offset)**

This information function allows you to use a spreadsheet table like a database. You can enter values in the table and then extract information from the rows of the table according to your specifications. HLOOKUP extracts from the horizontal rows in the same way as VLOOKUP extracts information from vertical columns. HLOOKUP and VLOOKUP assume the entries in the first row or column are sorted. They return the entry corresponding to the nearest ascending value that is not greater than `value`.

These functions are useful when you have several alternatives to "lookup," such as tax rates, commissions, or discounts.

HLOOKUP is not available for use in GeoFile.

`Value` is the value to be found in the first row of the table. `Value` can be a number, address, or text string. The first row of the table needs to be sorted.

`Range` is the address of the range that defines the table.

`Offset` defines which row contains the information. The offset of the top row is zero.

**EXAMPLE**

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Claudia</td>
<td>Jane</td>
<td>Kyle</td>
<td>Steve</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>1Q</td>
<td>12</td>
<td>14</td>
<td>16</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>2Q</td>
<td>10</td>
<td>11</td>
<td>8</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>3Q</td>
<td>9</td>
<td>13</td>
<td>8</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>4Q</td>
<td>13</td>
<td>8</td>
<td>17</td>
</tr>
</tbody>
</table>

HLOOKUP("Jane", B1:E5, 2) returns 11.
**HOUR(time_value)**

This time function returns the hour of the day from *time_value* serial number. You can use TIMEVALUE to convert text time. The hour is an integer from 0 to 23. Time serial numbers are decimal fractions and can be part of a date/time combination. If there is no fractional part, the time is midnight.

**EXAMPLES**

HOUR(29453.5) *returns* 12.

HOUR(TIMEVALUE("11:58PM")) *returns* 23.

**IF(logical,true_value,false_value)**

This logical function creates a conditional statement that says, “If this is true, then do A; otherwise, do B.” For example, IF(B12=C12,50,25) means “If the value in B12 equals that in C12, then display 50; otherwise, display 25.” For more detailed information about the IF function, see Chapter 14, “Advanced GeoCalc Formulas.”

*Logical* is any expression or value that can be evaluated as true or false.

*True_value* is the value returned is the logical expression is true.

*False_value* is the value returned is the logical expression is false.

**EXAMPLES**

IF(B13=500,50,-50) *returns* 50 if B13 contains 500. Otherwise, the expression *returns* -50.

IF (D14 = “warm”, “red”, “yellow”) *returns* red if D14 contains “warm”. Otherwise, the expression *returns* yellow.

IF (A1>A2,“Ascending”,“Descending”) *returns* Ascending if A1 is greater than A2. Otherwise the expression *returns* Descending.

**INDEX(range,column_offset,row_offset)**

This information function returns the data in the cell at the intersection of the column and row offsets. The top row is 0,0. INDEX is not available for use in GeoFile.

*Range* is the address defining the range.

*Column_offset* defines the column offset in the specified range.

*Row_offset* defines the row offset in the specified range.
EXAMPLE
INDEX(B1:H2,5,6) returns the contents of G7.

**INT(value)**
This mathematical function returns the integer portion of *value*, rounding down to the nearest integer.
*Value* can be a positive or negative number or a reference to a cell or field that contains a number.

**EXAMPLES**
INT(123.456) *returns* 123.
INT(123.567) *returns* 123.
INT(-123) *returns* -123.
INT(-123.456) *returns* -124.

**IRR(guess,range)**
This financial function calculates the internal rate of return on a series of irregular payments at regular intervals. It returns the interest rate when you know the initial investment and know you will get regular payments of varying amounts. (NPV finds the initial investment when you know the interest rate.)

IRR assumes that the income from the investment is reinvested at the interest rate of internal rate of return and calculates the percentage rate at which the NPV of a series of cash flows is equal to the PV of the initial investment.

IRR is not available for use in GeoFile.

*Guess* is the number you guess is approximately the interest rate.
*Range* is the address defining the range for the cash flow table.
Example

For example, your friend is starting a pizza restaurant and you invest $10,000 initially. He then pays you back varying amounts every month. After 5 months you make an additional investment after 6 months to add more staff to the restaurant for the summer. The spreadsheet below shows the cash flow in the range C1:C12.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>January</td>
</tr>
<tr>
<td>2</td>
<td>February</td>
</tr>
<tr>
<td>3</td>
<td>March</td>
</tr>
<tr>
<td>4</td>
<td>April</td>
</tr>
<tr>
<td>5</td>
<td>May</td>
</tr>
<tr>
<td>6</td>
<td>June</td>
</tr>
<tr>
<td>7</td>
<td>July</td>
</tr>
<tr>
<td>8</td>
<td>August</td>
</tr>
<tr>
<td>9</td>
<td>September</td>
</tr>
<tr>
<td>10</td>
<td>October</td>
</tr>
<tr>
<td>11</td>
<td>November</td>
</tr>
<tr>
<td>12</td>
<td>December</td>
</tr>
<tr>
<td>13</td>
<td>IRR</td>
</tr>
</tbody>
</table>
| 14 | IRR(.05,C1:C13) | returns 2.82% if rounded to two decimal places.

ISERR(value)

This information function tests an expression and returns 1 (TRUE) if the expression is an error. This function is particularly useful in IF statements.

EXAMPLES

ISERR(B2) returns TRUE if the value in B2 is an error.

IF(ISERR(B2),"",B2) returns an empty string if there is an error. Otherwise, the expression returns the contents of B2.

ISNUMBER(value)

This information function tests an expression and returns 1 (TRUE) if the expression is a number. This function is particularly useful in IF statements.

EXAMPLES

ISNUMBER(B2) returns TRUE.

IF(ISNUMBER(B2),"",B2) returns an empty string if B2 contains a number. The expression returns the contents of B2 if B2 doesn’t contain a number.
**ISSTRING(value)**

This information function tests an expression and returns 1 (TRUE) if the expression is a string. This is useful in IF statements.

**EXAMPLES**

ISSTRING(B2) *returns* TRUE

IF(ISSTRING(B2),"",B2) *returns* an empty string if B2 contains a string. Otherwise, the expression *returns* the contents of B2.

**LEFT(string,num)**

This string function returns the character in the leftmost position in *string*. *Num* is the number of characters to return. The first character in the string is in position 0. A reference to cells containing values produces an error.

The RIGHT function extracts characters beginning with the rightmost character, while LEFT extracts beginning with the leftmost character, and MID extracts from an internal position. For more information, see the descriptions of the RIGHT and MID functions.

**EXAMPLES**

LEFT("Hale",1) *returns* “H”.

LEFT("12 items left",2) *returns* “12”.

**LENGTH(string)**

This string function returns the number of characters in *string*. LENGTH counts all characters, punctuation marks, and spaces enclosed in quotation marks.

**EXAMPLE**

LENGTH("Now is the time.") *returns* 16.

**LN(value)**

This mathematical function returns the natural logarithm of *value*, using the mathematical constant *e* as a base. LN is the inverse of EXP. *Value* must be a positive number.

**EXAMPLE**

LN(2) *returns* 0.693147.
**LOG(value)**
This mathematical function returns the base 10 logarithm of value. Value must be a positive number.

**EXAMPLES**
LOG(100) returns 2.

**LOWER(string)**
This string function converts all characters in string to lower case.

**EXAMPLES**

**MAX(value1,value2,...)**
This statistical function returns the largest value in the list. The list can include values or addresses, separated by commas. MAX ignores empty cells and treats text as a zero. See also MIN.

**EXAMPLES**
MAX(2,4,6,8) returns 8.
MAX(-2,-4,-6,-8) returns -2.
MAX(B3:B13) returns the largest number in the range B3:B13.

**MID(string,start,num)**
This string function returns the specified number (num) of characters in string, beginning at the position you indicate (start). The first character in the string is in position 0. A reference to cells containing values produces an error.

The RIGHT function extracts characters beginning with the rightmost character, LEFT extracts beginning with the leftmost character, and MID extracts from an internal position. For more information, see the descriptions of the LEFT and RIGHT functions.

**EXAMPLE**
MID("The United States",4,6) returns “United”.
**MIN(value1,value2,...)**

This statistical function returns the smallest value in the list. The list can include values or addresses, separated by commas. MIN ignores empty cells and treats text as a zero. See also MAX.

**EXAMPLES**

MIN(2,4,6,8) *returns* 2.

MIN(-2,-4,-6,-8) *returns* -8.

MIN(B3:B13) *returns* the smallest number in the range B3:B13.

**MINUTE(time_value)**

This time function returns the minute from the *time_value* serial number. The minute is an integer from 0 to 59. Time serial numbers are decimal fractions and can be part of a date/time combination. If there is no fractional part, the time is midnight. You can use TIMEVALUE to convert text time.

**EXAMPLES**

MINUTE(TIMEVALUE "11:58PM") *returns* 58.

MINUTE(29453.55) *returns* 12.

**MOD(value,divisor)**

This mathematical function returns the modulus, the remainder from the division of *value* by *divisor*. If you attempt to divide by zero, MOD returns an error.

**EXAMPLES**

MOD(147,12) *returns* 3.

**MONTH(date_value)**

This time function returns the month from the *date_value* serial number. *Month* is an integer from 1 to 12. Time serial numbers are decimal fractions and can be part of a date/time combination. If there is no fractional part, the time is midnight. Use DATEVALUE to convert dates entered as labels.

**EXAMPLES**

MONTH(DATEVALUE("May 6, 1968")) *returns* 5.

MONTH(25420) *returns* 8.
**N(range)**
This information function returns the contents of the first cell in range, if that cell contains a number, time, or date. If the cell contains text, the function returns 0 (zero).
N is not available for use in GeoFile.

**EXAMPLES**
N(B1:B13) returns 2365 if B1 contains 2365.

**NA()**
This information function stops the evaluation of a formula and generates #N/A# in the formula cell. NA is the abbreviation for “Not Available.” This function is useful if you are creating a spreadsheet and do not have all the required values. If a formula refers to a cell containing #N/A#, it returns #N/A# so that you don’t inadvertently forget to complete the spreadsheet. You can type #N/A# directly into the cell. You must include the empty parentheses.

**NOW()**
This date time function returns the serial number for the current date and time. You must enter the empty parentheses. The whole number represents the date as a serial number starting January 1, 1900 and the decimal fraction of the number represents the time, beginning at midnight = 0. You must include the empty parentheses.

**EXAMPLES**
NOW() returns 33988.50 January 20, 1993, 12 noon) if it is now 12 noon on January 20, 1993.

**NPV(interest,range)**
This financial function returns the net present value, which is the amount of money (in today’s dollars) to be spent in the future. When you want to discount a future cash flow, calculate its present value. If you want to discount *multiple* future cash flows, use net present value to calculate their present values and adds them together.
Use NPV when you know the interest rate and want to know the initial investment. Use IRR when you know the initial investment
and want to calculate the rate. Both NPV and IRR use irregular payments at regular intervals.

The future cash flows are figured at a constant interest rate, assuming that payments are made at the end of each period. If there is a down payment at the beginning of period 1, add that amount to the result of the NPV calculation.

NPV is not available for use in GeoFile.

*Interest* is the interest rate for the calculation.

*Range* is the cells containing the cash flow information.

The following is the formula used by the NPV function:

\[
NPV = \sum_{i=1}^{n} \frac{values_i}{(1 + rate)^i}
\]

**EXAMPLE**

Suppose you want to send your daughter to design school in the coming year. You know the tuition payments are due in August and November, and she will need living costs every month. If the total expense will be $10,500, how much will you have to set aside now in an interest account paying 6.25 percent to cover the necessary expenses each month?

<table>
<thead>
<tr>
<th>Month</th>
<th>Payment</th>
</tr>
</thead>
<tbody>
<tr>
<td>August</td>
<td>$4,250.00</td>
</tr>
<tr>
<td>September</td>
<td>$250.00</td>
</tr>
<tr>
<td>October</td>
<td>$250.00</td>
</tr>
<tr>
<td>November</td>
<td>$4,250.00</td>
</tr>
<tr>
<td>December</td>
<td>$250.00</td>
</tr>
<tr>
<td>January</td>
<td>$250.00</td>
</tr>
<tr>
<td>February</td>
<td>$250.00</td>
</tr>
<tr>
<td>March</td>
<td>$250.00</td>
</tr>
<tr>
<td>April</td>
<td>$250.00</td>
</tr>
<tr>
<td>May</td>
<td>$250.00</td>
</tr>
<tr>
<td>Sum</td>
<td>$10,500.00</td>
</tr>
<tr>
<td>NPV</td>
<td>$10,326.87</td>
</tr>
</tbody>
</table>

NPV(.0625/12,B2:B11) returns 10326.87.

**OR(logical1,logical2,...)**

This logical function returns 1 if at least one of the arguments is true or 0 if all of the arguments are false. The arguments can be values or cell or field references. You can have as many *logical* arguments as you want. OR ignores text. If an argument doesn't contain a logical value, OR returns the #TYPE# error. OR is particularly useful with IF expressions. See also AND.
EXAMPLES
OR(1+2=3,2+3=5) returns 1.
OR(1+2=3,2+3=4) returns 1.
OR((1+2=2,2+3=3) returns 0.
IF(OR(A1>100,A1=B1),25,50) returns 25 if A1 is 100 or less, or A1 equals B1.

PAGE()
This print function returns the current page number for use in a GeoCalc header or footer. You must include the empty parentheses.
If you use PAGE outside of a GeoCalc header or footer, PAGE is calculated when you print.
PAGE is not available for use in GeoFile.

EXAMPLE
"Page"& PAGE()& "of"& PAGES() returns Page 3 of 15.

PAGES()
This print function returns the total number of pages in the document for use in a GeoCalc header or footer. You must include the empty parentheses.
If you use PAGES outside of a GeoCalc header or footer, PAGES is calculated when you print.
PAGES is not available for use in GeoFile.

EXAMPLE
"Page"& PAGE()& "of"& PAGES() returns Page 3 of 15.

PI()
This trigonometric function returns the value of $\pi$ (3.141592653589793). You must include the empty parentheses.

PMT(principal,interest,term)
This financial function calculates the constant payment required to repay a loan at a specified interest rate over a given period of time.
Principal is the amount of the loan.
Interest is the interest rate for the same time period as the term.
Term is the interval at which the payments are made.

EXAMPLE

Use the PMT function to determine the monthly payment for a 20 year loan of $75,000, at 5% annual interest.

\[
\text{PMT}(75000, .05/12, 240) \quad \text{returns} \quad 494.97.
\]

PRODUCT(value1, value2,...)

This mathematical function returns the product of multiplying the values given. You can have as many arguments as you want. Value can be numbers, references, and logical values.

EXAMPLES

\[
\text{PRODUCT}(B1:B13, 2)
\]

\[
\text{PRODUCT}(250, 3, 2) \quad \text{returns} \quad 1500.
\]

PROPER(string)

This string function capitalizes the first letter of every word and the first letter following any non-letter character. PROPER converts all other characters to lower case.

EXAMPLES

\[
\text{PROPER}("\text{Now is the time") \quad \text{returns} \quad \text{"Now Is The Time"}.
\]

\[
\text{PROPER}("1993 BUDGET") \quad \text{returns} \quad \text{"1993 Budget"}.
\]

PV(payment, interest, term)

This financial function returns the present value of an investment, given constant payment stream and interest rate. When you want to discount a future cash flow, calculate its present value. If you want to discount multiple future cash flows, use net present value which calculates their present values and adds them together.

Payment is the amount of each payment.

Interest is the interest rate for the same time period as the term.

Term is the total number of periods over which the payments are made.

EXAMPLE

If you have car payments of $250 every month for 10 years at an interest rate of 5%, what is the present value of the loan?
PV(500,.05/12,120) returns $23,570.34.

**RANDOM()**
This statistical function returns a random number between 0 and 1. RANDOM returns a new random number every time GeoCalc or GeoFile recalculates.
RANDOM() returns a decimal value.

**RANDOMN(value)**
This statistical function returns a random number between 0 and value-1. RANDOMN returns a new random number every time GeoCalc or GeoFile recalculates.
RANDOMN(100) returns a number between 0 and 99.

**RATE(future_value,present_value,term)**
This financial function calculates the interest rate required to make the present value of an investment into the future value. 
*Future_value* is the value of the annuity at the end of the investment period. 
*Present_value* is the value of the annuity today. 
*Term* is the time periods for the investment.

**EXAMPLE**
If you have $5000, what annual interest rate would you need to have $8000 in 5 years?
RATE(8000,5000,5) returns 9.86%.

**REPEAT(string,num)**
This string function returns the string the specified number of times. If *num* is zero, REPEAT returns an empty string.

**EXAMPLES**
REPEAT(“Ha”,6) returns HaHaHaHaHaHa.
REPEAT(“Ha ”,6) returns Ha Ha Ha Ha Ha Ha.

**REPLACE(original,start,num,replace)**
This string function replaces characters within text. 
*Original* is the text string in which you want to replace characters.
Start is the first character in the original string that you want to replace. The first character in the string is 0.

Num is the number of characters in the original string that you want to replace.

Replace is the replacement string. You can use more or fewer replacement characters than are replaced, in the original string.

**EXAMPLES**

REPLACE("1992",3,1,"3") returns "1993".

REPLACE("Now is the time for all good men",29,3,"people") returns "Now is the time for all good people".

**RIGHT(string,num)**

This string function returns the character in the rightmost position in the string. RIGHT returns that number of leftmost characters. The first character in the string is in position 0. A reference to cells containing values produces an error.

While RIGHT extracts characters beginning with the rightmost character, LEFT extracts beginning with the leftmost character, and MID extracts from an internal position. For more information, see the descriptions of the LEFT and MID functions.

**EXAMPLES**

RIGHT("Section A",1) returns "A".

RIGHT("Number of Items, 25",2) returns 25.

**ROUND(value,places)**

This mathematical function rounds value to the number of decimal places you specify.

**EXAMPLE**

ROUND(12.23761,2) returns 12.24.

**ROWS(range)**

This information function returns the number of rows in a range. ROWS is not available for use in GeoFile.

**EXAMPLES**

ROWS(B2:F65) returns 64.
SECOND(time_value)
This time function returns the second from the time_value serial number. The second is an integer from 0 to 59. Time serial numbers are decimal fractions and can be part of a date/time combination. If there is no fractional part, the time is midnight. You can use TIMEVALUE to convert text time.

EXAMPLES
SECOND(TIMEVALUE("11:58:45PM")) returns 45.
SECOND(29453.49) returns 36.

SIN(angle)
This trigonometric function returns the sine of angle. You must express angle in radians. If you know an angle in degrees, you can use the RADIANS function to convert it to radians.

EXAMPLES
SIN(RADIANS(45)) returns 0.707.

SINH(angle)
This trigonometric function returns the hyperbolic sine of angle. You must express angle in radians. If you know an angle in degrees, you can use the RADIANS function to convert it to radians.

EXAMPLES
SINH(0.5) returns 0.521095.

SLN(cost,salvage,life)
This financial function returns the straight-line depreciation of an asset for a period of time. Cost is the initial cost of the asset. Salvage is the value of the asset at the end of the time period. Life is the useful life of the asset, the number of time periods the asset is being depreciated.

EXAMPLES
SLN(12000,2000,5) returns 2000.
**SQRT(value)**
This mathematical function returns the square root of value. Value must be a positive number.

**EXAMPLES**
SQRT(144) returns 12.

**STD(value1,value2,...)**
This statistical function returns the standard deviation of the sample of values. You can use as many values as you want. 
The following is the formula used by the STD function:
\[
\sqrt{\frac{n \sum x^2 - (\sum x)^2}{n(n-1)}}
\]

**EXAMPLES**
STD(254,255,253,248,257,255,256) returns 2.944.

**STDP(value1,value2,...)**
This statistical function returns the standard deviation of an entire population. You can use as many values as you want. You can use values, addresses, ranges, named cells, and field names for arguments.

The following is the formula used by the STDP function:
\[
\sqrt{\frac{n \sum x^2 - (\sum x)^2}{n^2}}
\]

**EXAMPLES**
STDP(254,255,253,248,257,255,256) returns 2.726.

**STRING(value,N)**
This string function converts value into a string, using N decimal places. N can be a number from 0 through 15.

**EXAMPLES**
STRING(245.356,1) returns “245.4”. 
**SUM(value1,value2,...)**
This mathematical function returns the total of the value list. You can use as many arguments as you want, including values, addresses, ranges, named cells, and field names for arguments.

**EXAMPLES**
SUM(B3:B13)
SUM(23,45,67) **returns** 135.

**SYD(cost, salvage, life, period)**
This financial function returns the depreciation of an asset for the current period, using the sum-of-year’s digits method.
Cost is the initial cost of the asset.
Salvage is the value of the asset at the end of the time period.
Life is the useful life of the asset, the number of time periods the asset is being depreciated.
Period is the period to analyze.

**EXAMPLE**
What is the depreciation in the 4th year for a computer system that initially cost $12000, which after 5 years could be sold for $2000?
SYD(12000,2000,5,4) **returns** $1333.33.

**TAN(angle)**
This trigonometric function returns the tangent of angle. You must express angle in radians. If you know an angle in degrees, you can use the RADIANS function to convert it to radians.

**EXAMPLE**
TAN(RADIANS(45)) **returns** 1.0.

**TANH(angle)**
This trigonometric function returns the hyperbolic tangent of angle. You must express angle in radians. If you know an angle in degrees, you can use the RADIANS function to convert it to radians.

**EXAMPLES**
TANH(0.5) **returns** 0.462117.
**TERM(payments, interest, future_value)**

This financial function returns the number of time periods required for a number of equal investment payments to reach a future value. Payments are made at the end of each term and earn a constant interest rate.

*Payments* is the amount of the periodic payments.
*Interest* is the interest rate for the investment per time period.
*Future_value* is the value of the annuity at the end of the investment period.

**EXAMPLE**

How long will it take to accrue $10,000 if you make monthly payments of $250 at an annual interest rate of 5.5%?

TERM(250,.055/12,10000) returns 36.8.

**TIME(hour, minute, second)**

This time function returns the serial value from the *hour*, *minute*, and *second* arguments.

**EXAMPLES**

TIME(12,34,23) returns 0.523877.

**TIMEVALUE(string)**

This time function returns the serial value for *string*.

**EXAMPLES**

TIMEVALUE("1:10PM") returns 0.54861111.

**TODAY()**

This date function returns the serial number for the current day.

**EXAMPLES**

TODAY() returns 33988.00 if today's date is January 20.

**TRIM(string)**

This string function removes extra spaces before, after, and between words.

**EXAMPLES**

TRIM(" Cleveland, Ohio ") returns "Cleveland, Ohio".
TRUE()
This logical function returns 1. You can use TRUE in a calculation or enter it directly into a cell or field where it is interpreted as a logical value by GeoCalc or GeoFile. You must include the empty parentheses. See also FALSE.

TRUNC(value)
This mathematical function removes the fractional portion of value without rounding off.

EXAMPLES
TRUNC(23.66) returns 23.

UPPER(string)
This string function converts string to upper case.

EXAMPLES
UPPER("usa") returns USA.

VALUE(string)
This string function converts string to a value.

EXAMPLES
VALUE("1.75") returns 1.75.

VAR(value1,value2,...)
This statistical function returns the population variance from a sample of values. You can use as many arguments as you want, including values, addresses, ranges, named cells, and field names for arguments.

The following is the formula used by the VAR function:

\[ \frac{n \sum x^2 - (\sum x)^2}{n(n-1)} \]

EXAMPLES
VAR(254,255,253,248,257,255,256) returns 8.666667.
VARP(value1,value2,...)

This statistical function returns the population variance from an entire population represented by values. You can use as many arguments as you want, including values, addresses, ranges, named cells, and field names for arguments.

EXAMPLES

VARP(254,255,253,248,257,255,256) returns 7.42857.

VLOOKUP(value,range,offset)

This information function allows you to use a spreadsheet table like a database. You can enter values in the table and then extract information from the columns of the table according to your specifications. VLOOKUP extracts information from vertical columns in the same way as HLOOKUP extracts from the horizontal rows. HLOOKUP and VLOOKUP assume the entries in the first row or column are sorted. They return the entry corresponding to the nearest ascending value that is not greater than value.

These functions are useful when you have several alternatives to “lookup,” such as tax rates, commissions, or discounts.

VLOOKUP is not available for use in GeoFile.

Value is the value to be found in the first column of the table. Value can be a number, address, or text string. The first column of the table needs to be sorted.

Range is the address of the range that defines the table.

Offset defines which column contains the information. The first column is 0.

EXAMPLE

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Name</td>
<td>1Q</td>
<td>2Q</td>
<td>3Q</td>
<td>4Q</td>
</tr>
<tr>
<td>2</td>
<td>Claudia</td>
<td>12.00</td>
<td>14.00</td>
<td>16.00</td>
<td>15.00</td>
</tr>
<tr>
<td>3</td>
<td>Jane</td>
<td>10.00</td>
<td>11.00</td>
<td>8.00</td>
<td>6.00</td>
</tr>
<tr>
<td>4</td>
<td>Kyle</td>
<td>9.00</td>
<td>13.00</td>
<td>8.00</td>
<td>19.00</td>
</tr>
<tr>
<td>5</td>
<td>Steve</td>
<td>13.00</td>
<td>18.00</td>
<td>17.00</td>
<td>5.00</td>
</tr>
</tbody>
</table>

VLOOKUP("Jane",A2:E5,2) returns 11.00.
WEEKDAY(date_value)
This date function returns the day of the week for date_value. The WEEKDAY returns a number representing the day of the week: 1 for Sunday, 2 for Monday, etc.
Date_value must be a serial number. Use DATEVALUE to convert dates entered as labels.

EXAMPLES
WEEKDAY(33988) returns 4 (Wednesday).
WEEKDAY(DATEVALUE(“1/20/93”)) returns 4 (Wednesday).

YEAR(date_value)
This date function returns the year from the date_value. Date_value must be a serial number. Use DATEVALUE to convert dates entered as labels.

EXAMPLES
YEAR(33988) returns 93.
YEAR(DATEVALUE(“1/20/93”)) returns 93.
Special Characters  With GEOS applications, you can use many special characters that you won’t find on an average typewriter — or on your keyboard, for that matter.
You can use the following types of special characters:

- Foreign language characters
- Foreign-language accents
- Typographical symbols
- Punctuation marks
- Currency and numeric symbols
- Mathematical symbols

This appendix includes a table for each type of special character. The tables show how to type all the available special characters.

*To type a character shown on this list*

- Find the character you want in one of the tables, and then press the key combination shown in the column labeled “Keys.”

In the “Keys” column, a plus sign (+) means hold down the first set of keys while pressing the second; the word “then” means just the opposite — release the first set before typing the second.

### FOREIGN LANGUAGE CHARACTERS

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Á</td>
<td>uppercase A acute accent</td>
<td>Ctrl+Alt+e then Shift+a</td>
</tr>
<tr>
<td>Â</td>
<td>uppercase A dieresis accent</td>
<td>Ctrl+Alt+u then Shift+a</td>
</tr>
<tr>
<td>Á</td>
<td>uppercase A grave accent</td>
<td>Ctrl+Alt+̌ then Shift+a</td>
</tr>
<tr>
<td>Â</td>
<td>uppercase A circumflex accent</td>
<td>Ctrl+Alt+i then Shift+a</td>
</tr>
<tr>
<td>Â</td>
<td>uppercase A tilde accent</td>
<td>Ctrl+Alt+n then Shift+a</td>
</tr>
<tr>
<td>Â</td>
<td>uppercase A ring accent</td>
<td>Shift+Ctrl+Alt+a</td>
</tr>
<tr>
<td>á</td>
<td>lowercase a acute accent</td>
<td>Ctrl+Alt+e then a</td>
</tr>
<tr>
<td>á</td>
<td>lowercase a dieresis accent</td>
<td>Ctrl+Alt+u then a</td>
</tr>
<tr>
<td>à</td>
<td>lowercase a grave accent</td>
<td>Ctrl+Alt+̌ then a</td>
</tr>
<tr>
<td>â</td>
<td>lowercase a circumflex accent</td>
<td>Ctrl+Alt+i then a</td>
</tr>
<tr>
<td>â</td>
<td>lowercase a tilde accent</td>
<td>Ctrl+Alt+n then a</td>
</tr>
<tr>
<td>â</td>
<td>lowercase a ring accent</td>
<td>Ctrl+Alt+a</td>
</tr>
<tr>
<td>Ć</td>
<td>uppercase C cedilla accent</td>
<td>Shift+Ctrl+Alt+c</td>
</tr>
</tbody>
</table>
Lowercase c cedilla accent: Ctrl+Alt+c

Uppercase E acute accent: Ctrl+Alt+e then Shift+e

Uppercase E dieresis accent: Ctrl+Alt+u then Shift+e

Uppercase E grave accent: Ctrl+Alt+ then Shift+e

Uppercase E circumflex accent: Ctrl+Alt+i then Shift+e

Lowercase e acute accent: Ctrl+Alt+e then e

Lowercase e dieresis accent: Ctrl+Alt+u then e

Lowercase e grave accent: Ctrl+Alt+ then e

Lowercase e circumflex accent: Ctrl+Alt+i then e

Lowercase i acute accent: Ctrl+Alt+e then i

Lowercase i dieresis accent: Ctrl+Alt+u then i

Lowercase i grave accent: Ctrl+Alt+ then i

Lowercase i circumflex accent: Ctrl+Alt+i then i

Uppercase N tilde accent: Ctrl+Alt+n then Shift+n

Lowercase n tilde accent: Ctrl+Alt+n then n

Uppercase O acute accent: Ctrl+Alt+e then Shift+o

Uppercase O dieresis accent: Ctrl+Alt+u then Shift+o

Uppercase O grave accent: Ctrl+Alt+ then Shift+o

Uppercase O circumflex accent: Ctrl+Alt+i then Shift+o

Uppercase O tilde accent: Ctrl+Alt+n then Shift+o

Uppercase O slash: Shift+Ctrl+Alt+o

Lowercase o acute accent: Ctrl+Alt+e then o

Lowercase o dieresis accent: Ctrl+Alt+u then o

Lowercase o grave accent: Ctrl+Alt+ then o

Lowercase o circumflex accent: Ctrl+Alt+i then o
<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>ò</td>
<td>lowercase o tilde accent</td>
<td>Ctrl+Alt+n then o</td>
</tr>
<tr>
<td>ø</td>
<td>lowercase o slash</td>
<td>Ctrl+Alt+o</td>
</tr>
<tr>
<td>Û</td>
<td>uppercase U acute accent</td>
<td>Ctrl+Alt+c then Shift+u</td>
</tr>
<tr>
<td>Ù</td>
<td>uppercase U dieresis accent</td>
<td>Ctrl+Alt+u then Shift+u</td>
</tr>
<tr>
<td>Ü</td>
<td>uppercase U grave accent</td>
<td>Ctrl+Alt+ then Shift+u</td>
</tr>
<tr>
<td>Ù</td>
<td>uppercase U circumflex accent</td>
<td>Ctrl+Alt+i then Shift+u</td>
</tr>
<tr>
<td>ū</td>
<td>lowercase u acute accent</td>
<td>Ctrl+Alt+c then u</td>
</tr>
<tr>
<td>û</td>
<td>lowercase u dieresis accent</td>
<td>Ctrl+Alt+u then u</td>
</tr>
<tr>
<td>Õ</td>
<td>lowercase u grave accent</td>
<td>Ctrl+Alt+ then u</td>
</tr>
<tr>
<td>Ũ</td>
<td>lowercase u circumflex accent</td>
<td>Ctrl+Alt+i then u</td>
</tr>
<tr>
<td>Ý</td>
<td>uppercase Y dieresis accent</td>
<td>Ctrl+Alt+u then Shift+y</td>
</tr>
<tr>
<td>ÿ</td>
<td>lowercase y dieresis accent</td>
<td>Ctrl+Alt+u then y</td>
</tr>
<tr>
<td>Æ</td>
<td>uppercase AE diphthong</td>
<td>Shift+Ctrl+Alt+' (apostrophe)</td>
</tr>
<tr>
<td>æ</td>
<td>lowercase ae diphthong</td>
<td>Ctrl+Alt+' (apostrophe)</td>
</tr>
<tr>
<td>CE</td>
<td>uppercase OE diphthong</td>
<td>Shift+Ctrl+Alt+q</td>
</tr>
<tr>
<td>Òe</td>
<td>lowercase oe diphthong</td>
<td>Ctrl+Alt+q</td>
</tr>
<tr>
<td>I</td>
<td>dotless i</td>
<td>Shift+Ctrl+Alt+i</td>
</tr>
<tr>
<td>ß</td>
<td>German double s</td>
<td>Ctrl+Alt+s</td>
</tr>
<tr>
<td>o</td>
<td>ordmasculine</td>
<td>Ctrl+Alt+0 (zero)</td>
</tr>
<tr>
<td>a</td>
<td>ord feminine</td>
<td>Ctrl+Alt+9</td>
</tr>
</tbody>
</table>

FOREIGN-LANGUAGE ACCENTS

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>'</td>
<td>acute</td>
<td>Ctrl+Alt+e then Spacebar</td>
</tr>
<tr>
<td>^</td>
<td>circumflex</td>
<td>Ctrl+Alt+i then Spacebar</td>
</tr>
<tr>
<td>`</td>
<td>grave</td>
<td>Ctrl+Alt+ then Spacebar</td>
</tr>
<tr>
<td>..</td>
<td>dieresis</td>
<td>Ctrl+Alt+u then Spacebar</td>
</tr>
</tbody>
</table>
... ellipsis non-breaking space
- soft hyphen
— en dash
— em dash
" typographer’s open quotes typographer’s close quotes
‘ open single quote
’ close single quote
“ double quote low
‘ single quote low
« opening guillemot
» closing guillemot
‹ opening single guillemot
› closing single guillemot

CURRENCY AND NUMERIC SYMBOLS

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>¢</td>
<td>cent</td>
<td>Ctrl+Alt+;</td>
</tr>
<tr>
<td>£</td>
<td>pound sterling</td>
<td>Alt+Spacebar</td>
</tr>
<tr>
<td>¥</td>
<td>yen</td>
<td>Ctrl+- (hyphen)</td>
</tr>
<tr>
<td>₤</td>
<td>florin</td>
<td>Ctrl+Alt+- (hyphen)</td>
</tr>
<tr>
<td>/</td>
<td>fraction</td>
<td>Shift+Ctrl+Alt+ (hyphen)</td>
</tr>
<tr>
<td>°</td>
<td>degree</td>
<td>Ctrl+Alt+[</td>
</tr>
<tr>
<td>‰</td>
<td>per thousand</td>
<td>Shift+Ctrl+Alt+[</td>
</tr>
</tbody>
</table>

Keys:
- Ctrl+Alt+4
- Ctrl+Alt+3
- Ctrl+Alt+y
- Shift+Ctrl+Alt+4
- Ctrl+Alt+f
- Shift+Ctrl+Alt+3
- Shift+Ctrl+Alt+8
- Shift+Ctrl+Alt+5
MATHEMATICAL SYMBOLS

Not all the mathematical symbols are available in every font. If your font doesn’t have a character you need, use the URW SymbolPS font instead for that one character.

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>≠</td>
<td>not equal</td>
<td>Ctrl+Alt+=</td>
</tr>
<tr>
<td>≈</td>
<td>approximately equal</td>
<td>Ctrl+Alt+x</td>
</tr>
<tr>
<td>≤</td>
<td>less than or equal</td>
<td>Ctrl+Alt+, (comma)</td>
</tr>
<tr>
<td>≥</td>
<td>greater than or equal</td>
<td>Ctrl+Alt+, (period)</td>
</tr>
<tr>
<td>±</td>
<td>plus/minus</td>
<td>Shift+Ctrl+Alt+=</td>
</tr>
<tr>
<td>÷</td>
<td>division</td>
<td>Ctrl+Alt+/</td>
</tr>
<tr>
<td>∞</td>
<td>infinity</td>
<td>Ctrl+Alt+5</td>
</tr>
<tr>
<td>∫</td>
<td>integral</td>
<td>Ctrl+Alt+b</td>
</tr>
<tr>
<td>¬</td>
<td>logical not</td>
<td>Ctrl+Alt+l</td>
</tr>
<tr>
<td>√</td>
<td>radical</td>
<td>Ctrl+Alt+v</td>
</tr>
<tr>
<td>Π</td>
<td>Pi</td>
<td>Shift+Ctrl+Alt+p</td>
</tr>
<tr>
<td>π</td>
<td>pi</td>
<td>Ctrl+Alt+p</td>
</tr>
<tr>
<td>Δ</td>
<td>Delta</td>
<td>Ctrl+Alt+j</td>
</tr>
<tr>
<td>µ</td>
<td>mu</td>
<td>Ctrl+Alt+m</td>
</tr>
<tr>
<td>∂</td>
<td>partial differential</td>
<td>Ctrl+Alt+d</td>
</tr>
<tr>
<td>Ω</td>
<td>Omega</td>
<td>Ctrl+Alt+z</td>
</tr>
<tr>
<td>Σ</td>
<td>Sigma</td>
<td>Ctrl+Alt+w</td>
</tr>
</tbody>
</table>
Character Codes  The following pages list all the characters  
in the GEOS character set and their corresponding character  
codes. These numbers are useful for certain GeoCalc and GeoFile  
functions. Within each column on the following pages, the  
character code is on the left, and the GEOS character is on the  
right.
<table>
<thead>
<tr>
<th>(000)</th>
<th>NUL</th>
<th>034</th>
<th>&quot;</th>
<th>068</th>
<th>D</th>
<th>102</th>
<th>f</th>
</tr>
</thead>
<tbody>
<tr>
<td>(001)</td>
<td>SOH</td>
<td>035</td>
<td>*</td>
<td>069</td>
<td>E</td>
<td>103</td>
<td>g</td>
</tr>
<tr>
<td>(002)</td>
<td>STX</td>
<td>036</td>
<td>$</td>
<td>070</td>
<td>F</td>
<td>104</td>
<td>h</td>
</tr>
<tr>
<td>(003)</td>
<td>ETX</td>
<td>037</td>
<td>%</td>
<td>071</td>
<td>G</td>
<td>105</td>
<td>i</td>
</tr>
<tr>
<td>(004)</td>
<td>EOT</td>
<td>038</td>
<td>&amp;</td>
<td>072</td>
<td>H</td>
<td>106</td>
<td>j</td>
</tr>
<tr>
<td>(005)</td>
<td>ENQ</td>
<td>039</td>
<td></td>
<td>073</td>
<td>I</td>
<td>107</td>
<td>k</td>
</tr>
<tr>
<td>(006)</td>
<td>ACK</td>
<td>040</td>
<td>(</td>
<td>074</td>
<td>J</td>
<td>108</td>
<td>l</td>
</tr>
<tr>
<td>(007)</td>
<td>BEL</td>
<td>041</td>
<td>)</td>
<td>075</td>
<td>K</td>
<td>109</td>
<td>m</td>
</tr>
<tr>
<td>(008)</td>
<td>BS</td>
<td>042</td>
<td>*</td>
<td>076</td>
<td>L</td>
<td>110</td>
<td>n</td>
</tr>
<tr>
<td>(009)</td>
<td>HT</td>
<td>043</td>
<td>+</td>
<td>077</td>
<td>M</td>
<td>111</td>
<td>o</td>
</tr>
<tr>
<td>(010)</td>
<td>LF</td>
<td>044</td>
<td>,</td>
<td>078</td>
<td>N</td>
<td>112</td>
<td>p</td>
</tr>
<tr>
<td>(011)</td>
<td>VT</td>
<td>045</td>
<td>-</td>
<td>079</td>
<td>O</td>
<td>113</td>
<td>q</td>
</tr>
<tr>
<td>(012)</td>
<td>FF</td>
<td>046</td>
<td>.</td>
<td>080</td>
<td>P</td>
<td>114</td>
<td>r</td>
</tr>
<tr>
<td>(013)</td>
<td>CR</td>
<td>047</td>
<td>/</td>
<td>081</td>
<td>Q</td>
<td>115</td>
<td>s</td>
</tr>
<tr>
<td>(014)</td>
<td>SO</td>
<td>048</td>
<td>0</td>
<td>082</td>
<td>R</td>
<td>116</td>
<td>t</td>
</tr>
<tr>
<td>(015)</td>
<td>SI</td>
<td>049</td>
<td>1</td>
<td>083</td>
<td>S</td>
<td>117</td>
<td>u</td>
</tr>
<tr>
<td>(016)</td>
<td>DLE</td>
<td>050</td>
<td>2</td>
<td>084</td>
<td>T</td>
<td>118</td>
<td>v</td>
</tr>
<tr>
<td>(017)</td>
<td>DC1</td>
<td>051</td>
<td>3</td>
<td>085</td>
<td>U</td>
<td>119</td>
<td>w</td>
</tr>
<tr>
<td>(018)</td>
<td>DC2</td>
<td>052</td>
<td>4</td>
<td>086</td>
<td>V</td>
<td>120</td>
<td>x</td>
</tr>
<tr>
<td>(019)</td>
<td>DC3</td>
<td>053</td>
<td>5</td>
<td>087</td>
<td>W</td>
<td>121</td>
<td>y</td>
</tr>
<tr>
<td>(020)</td>
<td>DC4</td>
<td>054</td>
<td>6</td>
<td>088</td>
<td>X</td>
<td>122</td>
<td>z</td>
</tr>
<tr>
<td>(021)</td>
<td>NAK</td>
<td>055</td>
<td>7</td>
<td>089</td>
<td>Y</td>
<td>123</td>
<td></td>
</tr>
<tr>
<td>(022)</td>
<td>SYN</td>
<td>056</td>
<td>8</td>
<td>090</td>
<td>Z</td>
<td>124</td>
<td></td>
</tr>
<tr>
<td>(023)</td>
<td>ETB</td>
<td>057</td>
<td>9</td>
<td>091</td>
<td>[</td>
<td>125</td>
<td></td>
</tr>
<tr>
<td>(024)</td>
<td>CAN</td>
<td>058</td>
<td>:</td>
<td>092</td>
<td>\</td>
<td>126</td>
<td>~</td>
</tr>
<tr>
<td>(025)</td>
<td>EM</td>
<td>059</td>
<td>;</td>
<td>093</td>
<td>]</td>
<td>127</td>
<td>DEL</td>
</tr>
<tr>
<td>(026)</td>
<td>SUB</td>
<td>060</td>
<td>&lt;</td>
<td>094</td>
<td>^</td>
<td>128</td>
<td>Ä</td>
</tr>
<tr>
<td>(027)</td>
<td>ESC</td>
<td>061</td>
<td>=</td>
<td>095</td>
<td>_</td>
<td>129</td>
<td>Å</td>
</tr>
<tr>
<td>(028)</td>
<td>FS</td>
<td>062</td>
<td>&gt;</td>
<td>096</td>
<td>`</td>
<td>130</td>
<td>Ç</td>
</tr>
<tr>
<td>(029)</td>
<td>GS</td>
<td>063</td>
<td>?</td>
<td>097</td>
<td>a</td>
<td>131</td>
<td>É</td>
</tr>
<tr>
<td>(030)</td>
<td>RS</td>
<td>064</td>
<td>@</td>
<td>098</td>
<td>b</td>
<td>132</td>
<td>Ñ</td>
</tr>
<tr>
<td>(031)</td>
<td>US</td>
<td>065</td>
<td>A</td>
<td>099</td>
<td>c</td>
<td>133</td>
<td>Ö</td>
</tr>
<tr>
<td>(032)</td>
<td>SP</td>
<td>066</td>
<td>B</td>
<td>100</td>
<td>d</td>
<td>134</td>
<td>Ü</td>
</tr>
<tr>
<td>(033)</td>
<td>!</td>
<td>067</td>
<td>C</td>
<td>101</td>
<td>e</td>
<td>135</td>
<td>á</td>
</tr>
<tr>
<td>Unicode</td>
<td>Character</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>---------</td>
<td>-----------</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>136</td>
<td>à</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>137</td>
<td>à</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>138</td>
<td>ä</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>139</td>
<td>à</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>140</td>
<td>å</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>141</td>
<td>ç</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>142</td>
<td>é</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>143</td>
<td>è</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>144</td>
<td>ë</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>145</td>
<td>ì</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>146</td>
<td>í</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>147</td>
<td>ì</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>148</td>
<td>î</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>149</td>
<td>ï</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>150</td>
<td>ñ</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>151</td>
<td>ò</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>152</td>
<td>ô</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>153</td>
<td>õ</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>154</td>
<td>ö</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>155</td>
<td>ë</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>156</td>
<td>ú</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>157</td>
<td>ù</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>158</td>
<td>û</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>159</td>
<td>ü</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>160</td>
<td>†</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>161</td>
<td>è</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>162</td>
<td>ê</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>163</td>
<td>ë</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>164</td>
<td>§</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>165</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>166</td>
<td>¶</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>167</td>
<td>®</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>168</td>
<td>©</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>169</td>
<td>™</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>170</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>171</td>
<td>́</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>172</td>
<td>„</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>173</td>
<td>‰</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>174</td>
<td>Æ</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>175</td>
<td>Ø</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>176</td>
<td>∞</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>177</td>
<td>±</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>178</td>
<td>≤</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>179</td>
<td>≥</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>180</td>
<td>¥</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>181</td>
<td>µ</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>182</td>
<td>ρ</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>183</td>
<td>Σ</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>184</td>
<td>Π</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>185</td>
<td>π</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>186</td>
<td>j</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>187</td>
<td>a</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>188</td>
<td>o</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>189</td>
<td>Ω</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>190</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>191</td>
<td>o</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>192</td>
<td>ι</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>193</td>
<td>ì</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>194</td>
<td>ι</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>195</td>
<td>√</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>196</td>
<td>f</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>197</td>
<td>≈</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>198</td>
<td>Δ</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>199</td>
<td>“</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>200</td>
<td>”</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>201</td>
<td>…</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>202</td>
<td>nbs</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>203</td>
<td>À</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>204</td>
<td>Å</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Tool Bar Reference  Tool Bars provide quick access to menu choices and features in Ensemble applications. Each button, or *tool*, on a tool bar corresponds to a menu choice or an option. Often you’ll find it quicker and easier to click the tool button than to select its corresponding function from a menu. In this way, tools provide shortcuts to many commonly used functions.
The following illustration shows all the tool bars as they appear in GeoWrite:

Style Tool Bar

Function Tool Bar

Graphics Tool Bar

Drawing Tool Bar

Bitmap Tool Bar

Style Tool Bar. For changing text formatting.

Function Tool Bar. For working with documents (opening, closing, saving), using the clipboard (cutting, copying, and pasting), and other functions.

Drawing and Graphics Tool Bars. These are the various Tool Bars that either appear in GeoDraw or appear in other applications but derive from the tools in GeoDraw. They are as follows: the Drawing Tool Bar, the Bitmap Tool Bar, the Attributes Tool Bar, the Floating Tool Box, and the Graphic Tool Bar.

This appendix describes the standard tools you see on the Style Tool Bar and the Function Tool Bar. For information on the tools you see on the Drawing and Graphics Tool Bars, see Chapters 8 through 11, which cover GeoDraw.

For a general overview of Tool Bars, see “Using the Tool Bars” in Chapter 2. For information on Customizing Tool Bars, see “Customizing the Tool Bars” in Chapter 2.
THE STYLE TOOL BAR

The Style Tool Bar allows you to change the text characteristics — font, text size, and style. In addition, you can use the tools on the Style Tool Bar as shortcuts to perform common word processing functions.

The list below shows the tool, describes the action it performs, and includes a cross reference to the chapter where you can find other ways to perform the same action.

Scrolls to the top of the previous page of the document. For more information, see “Moving Around in Your Document” in Chapter 4.

Shows the current page number. If you want to go to a specific page, double-click this number and enter the page number you want. For more information, see “Moving Around in Your Document” in Chapter 4.

Scrolls to the top of the next page of the document. For more information, see “Moving Around in Your Document” in Chapter 4.

Starts the spell checker, displaying the dialog box so that you can specify the options you need. For more information, see “Moving Around in Your Document” in Chapter 4.

Prints the current document. For more information, see “Printing Documents” in Chapter 1.

Stores the style definition of the current paragraph so that you can use it in the future by clicking Recall Style. For more information, see “Using Styles” in Chapter 5.

Recalls the style stored by Store Style. For more information, see “Using Styles” in Chapter 5.

Displays the style for the current paragraph. To change the style, click the arrow button, then select the style you want from the drop-down list. For more information, see “Using Styles” in Chapter 5.

Aligns the left side of the current paragraph text with the Left Indent marker. For more information, see “Changing How Text Looks” in Chapter 4.
Centers the current paragraph text between the Left and Right Indent markers. For more information, see “Changing How Text Looks” in Chapter 4.

Aligns the right side of the current paragraph text with the Right Indent marker. For more information, see “Changing How Text Looks” in Chapter 4.

Aligns both sides of the paragraph text with both the Right and Left Indent markers. For more information, see “Changing How Text Looks” in Chapter 4.

Displays the font of the selected characters. To change the font, click the arrow button, then select the font you want from the drop-down list. For more information, see “Changing How Text Looks” in Chapter 4.

Changes the selected text to plain text style. For more information, see “Changing How Text Looks” in Chapter 4.

Changes the selected text to bold text style. For more information, see “Changing How Text Looks” in Chapter 4.

Changes the selected text to italic text style. For more information, see “Changing How Text Looks” in Chapter 4.

Changes the selected text to underlined text style. For more information, see “Changing How Text Looks” in Chapter 4.

Displays the size of the selected text. To change the text size, click the arrow button, then select the size you want from the drop-down list. For more information, see “Changing How Text Looks” in Chapter 4.

Increases the size of the selected text. For more information, see “Changing How Text Looks” in Chapter 4.

Decreases the size of the selected text. For more information, see “Changing How Text Looks” in Chapter 4.
THE FUNCTION TOOL BAR

The Function Tool Bar contains tools to perform file functions, such as opening, closing, and saving files. It also contains editing tools and zooming tools. The tools available on the Function Tool Bar vary depending on the application. This section describes the tools common to the applications that have the Function Tool Bar.

The list below shows the tool, describes the action it performs, and includes a cross reference to the chapter where you can find other ways to perform the same action.

- Creates a new document. For more information, see “Creating and Opening Documents” in Chapter 1.
- Creates a document by using a template. For more information, see “Creating and Opening Documents” in Chapter 1.
- Opens an existing document. For more information, see “Creating and Opening Documents” in Chapter 1.
- Closes the current document. For more information, see “Creating and Opening Documents” in Chapter 1.
- Saves the current document. For more information, see “Saving Documents” in Chapter 1.
- Makes a copy of the current document. For more information, see “Backing Up and Restoring Documents” in Chapter 3.
- Displays the Find and Replace dialog box to enable you to find and, if you want, change text or formatting. For more information, see “Finding and Replacing Text” in Chapter 5.
- Reverses the last editing action. For more information, see “Selecting and Editing” in Chapter 2.
- Removes the selection from the document and places it on the clipboard. For more information, see “Selecting and Editing” in Chapter 2.
- Places a copy of the selection on the Clipboard without removing it from the document. For more information, see “Selecting and Editing” in Chapter 2.
Pastes the contents of the Clipboard into the current document at the insertion point. For more information, see “Selecting and Editing” in Chapter 2.

Selects all text. For more information, see “Selecting and Editing” in Chapter 2.

Deletes the selection. For more information, see “Selecting and Editing” in Chapter 2.

Displays the document at its normal size. For more information, see “Controlling Your View of a Window” in Chapter 2.

Displays the document at a larger size. For more information, see “Controlling Your View of a Window” in Chapter 2.

Displays the document at a smaller size. For more information, see “Controlling Your View of a Window” in Chapter 2.

Redraws the screen. For more information, see “Controlling Your View of a Window” in Chapter 2.

Turns on hyphenation for the selected paragraph. Click again to turn off hyphenation. For more information, see “Changing the Text Format” in Chapter 5.

Adds no extra line space between each row of text in the paragraph containing the selection. For more information, see “Changing How Text Looks” in Chapter 4.

Adds a half a line space between each row of text in the paragraph containing the selection. For more information, see “Changing How Text Looks” in Chapter 4.

Adds a whole line space between each row of text in the paragraph containing the selection. For more information, see “Changing How Text Looks” in Chapter 4.

Adds two line spaces between each row of text in the paragraph containing the selection. For more information, see “Changing How Text Looks” in Chapter 4.
INDEX

A

ABS(value) mathematical function A.10
absolute references in spreadsheets 12.20, 12.21, 14.3
ACOS(value) trigonometric function A.10
ACOSH(value) trigonometric function A.10
active cell 12.4
active cell address 12.5
Add Sort Key Arrow option, GeoFile 18.10
Add to User Dictionary option 5.27
aligning objects 10.36
    relative 10.43, 10.44
    to grid and guidelines 10.43
aligning text, GeoWrite 4.19 to 4.20, 4.27
Allow Iterations option 14.9
anchor point 11.10
anchor points
    deleting 9.9
    inserting 9.9
AND functions 14.13
AND(logical1,logical2,...) A.10
annotated objects
    creating 11.24
    deleting 11.25
    hiding 11.25
    making all selectable and editable 11.25
    making all unselectable and uneditable 11.25
    printing 11.24
annotation 11.23
Annotation attribute 11.24
annotation options
    delete 2.39
    draw 2.39
    make selectable/editable 2.39
    make unselectable/uneditable 2.40
    print 2.39
annotations, using 2.39 to 2.40
apostrophes in spreadsheets 12.11
applications
    configuring 1.41, 2.1 to 2.3
    exiting 1.7
    multiple 1.41 to 1.43
    stacking 1.42
    starting 1.5 to 1.6
        directly 1.5
        with a document or template 1.6
        with icon 1.5
templates for 3.13
viewing 1.42
window 1.6, 1.14
window elements 1.15
Apply to Selection Only (Character Style) option 5.33
arc attributes, changing 10.27
Arc tool 9.5
arc, creating 9.12
area attribute 6.25, 10.16
area charts 15.5
    see also charts
Area Color Relative style option 11.18
Area Fill Color tool 10.19
Area Mask Relative style option 11.18
Area Pattern tool 10.19
Area Shading tool 10.19
arguments in built-in functions 12.22
arguments in functions A.2
Arrow pointer 8.6
Arrowhead line attribute 10.22
ASIN(value) trigonometric function A.11
ASINH(value) trigonometric function A.11
At Paragraph Bottom attribute 5.10
At Paragraph Top attribute 5.10
ATAN(value) trigonometric function A.11
ATAN2(x,y) trigonometric function A.11
ATANH(value) trigonometric function A.12
Attribute tool 10.3
Attribute tool bar 2.12, 10.17
Attributes tool bar D.2
automatic control point attribute 11.14
automatic pagination 7.14
Automatically Mark and Unmark option, GeoFile 18.8
AVG(value1,value2,...) statistical function A.12
axis markings 15.16
backing up documents 3.1 to 3.3
bar charts 15.4
see also charts
Bezier curves 11.10
bibliography, creating 7.29
Bitcount option 9.24
bitmap 10.2, 10.7
changing format 10.15
changing pixels, enclosed area 10.13
color format 10.15
converting graphic and text objects 10.16
ellipse 10.9
ellipse, drawing 10.10
erasing pixels 10.13
frame, drawing 10.8
freehand 10.9
freehand shape, drawing 10.11
pixel view 10.14 to 10.15
rectangles 10.9
rectangles, drawing 10.10
resolution 10.15
selecting pixels 10.13
selection region 10.12
shape 10.8
straight lines 10.9
straight lines, drawing 10.10
Bitmap (BMP) format 9.22
Bitmap Ellipse tool 10.7
bitmap formats
  Bitmap (BMP) 9.22
  Clipboard (CLP) 9.22
  Graphics Interchange Format (GIF) 9.22
  PC Paintbrush (PCX) 9.22
  Tag Image Format (TIF) 9.22
bitmap frame 10.7 to 10.9, 10.8
bitmap graphics files 9.22
Bitmap Line tool 10.7
Bitmap Rectangle tool 10.7
Bitmap tool 10.3
Bitmap tool bar 2.11, D.2
bold text 2.34, 12.36
Border Color % Shaded option 5.12
Border Spacing option 5.11
Border Type option 5.12
Border Width option 5.11
borders, paragraph 5.10 to 5.13
breaking out pasted objects 11.9
bringing objects to front 9.17
Brush bitmap tool 10.7
built-in functions in formulas 12.18
built-in functions in spreadsheets 12.22
built-in templates 3.16
bullet character 2.41, 4.27
buttons
  Change User Level 1.9
  Exit/Cancel 1.10
  Express 1.15
  Help 1.15
  Import 1.9
  Maximize-Restore 1.15, 1.17
  Minimize 1.15
  Record Control Panel 17.8
  Template 1.9, 3.14
  Window Control 1.15, 1.17

Carriage Return option, GeoWrite 5.20
categories, charting 15.2
cell 12.4
cell address 12.4
cell borders 13.3
Center Horizontally option 16.7
Center Vertically option 16.7
Change All Views Together option 2.4, 2.6
Change User Level button 1.9
Change User Level dialog box 1.39
CHAR(value) string function A.13
character codes C.1
character spacing 5.3
character weight 5.3
character width 5.3
chart 15.2
Chart Title option 15.14
charts
  adding axis markings 15.16
  adding grid markings 15.17
  area 15.5
  area chart variations 15.5
  bar 15.4
  bar chart variations 15.3
categories 15.2
  changing marker shapes 15.17
column 15.3
column chart variations 15.3
copying to another application 15.13
creating 15.8 to 15.10
deleting 15.13
element attributes, changing 15.13
elements in 15.8
graphic objects 15.10
handles 15.11
high/low 15.8
line 15.4
line chart variations 15.4
maintaining aspect ratio 15.12
moving 15.11
numbers in titles and category names 15.9
pie 15.7
pie chart variations 15.7
resizing 15.12
scatter plot 15.5
series 15.2
text properties, changing 15.12
titles and legends 15.14 to 15.15
titles, changing text 15.15
tools for creating charts (table) 16.3
type, changing 15.10
types 15.2
x-y plot 15.5
x-y plot chart variations 15.5
Check All option 5.26
Check Selection option 5.26
Check Spelling tool 4.22
Check to End option 5.26
CHOOSE(index, value1, value2, ...) information function A.13
cicero 2.34
circular reference 14.8
circular references 14.8 to 14.10
iterations 14.9
CLEAN(string) function A.13
Clear All Marks Before Re-Marking option, GeoFile 18.9
Clear option, GeoFile 18.11
clicking 2.19, 4.8
clipboard 2.26, 2.27, 2.28, 7.18
Clipboard (CLP) format 9.22
Clipboard toolbar 11.2
clipboard warning, databases 19.48
closing documents 1.23
CODE(string) function A.13
Collate option 1.30
Collinear control point attribute 11.15
color format 10.15
color printing 1.29
Color Tools 13.8
Color Tools attribute 10.19, 10.21, 10.24, 10.26
Color Tools option 5.12, 5.15, 5.16, 13.6, 13.7
color, GeoCalc 13.6 to 13.8
color, GeoWrite 5.14 to 5.17
background 5.15
paragraph 5.16
text 5.14 to 5.15
COLS(range) function A.14
Column Break Before attribute 5.10
column breaks 5.9, 7.14, 7.17
column charts 15.3
see also charts
column width, spreadsheets 12.34
setting a value 13.4
Columns option, GeoWrite 7.17
Columns option, sections 6.15
columns, GeoWrite 7.15 to 7.17
breaks 5.9
changing 7.17
changing for sections 7.16
inserting breaks 7.17
multiple, changing 7.15
multiple, setting 7.15
comma-separated values 16.14
commas in spreadsheets 12.12
Compression options 9.25
Computed field type, databases 19.16
computed value 19.27
concatenation operator, GeoFile 19.34
Condensed display mode, GeoWrite 7.2, 7.5
configurations
saving 11.26
configuring applications 1.40, 1.41
constraint keys 11.10
container object 11.8
Continuous Printing option 16.7
control point 11.10
Copy To 3.4 to 3.6
copying text 4.11
copying text and graphics 2.25 to 2.26
copying, spreadsheets 12.28
COS(angle) function A.14
COSH(value) function A.14
COUNT(value1, value2, ...) function A.14
Create New Fields button, GeoFile 19.12
Crossed I-Beam pointer 8.6
Crosshairs pointer 8.6
CTERM(interest, future_value, present_value) function A.15
cutting text 4.10
cutting text and graphics 2.25 to 2.26

data document 7.18
data entry area, databases 19.14
data entry mode 18.1, 18.3
data entry mode, GeoFile 19.6
switching to 19.6
window, Level 3 19.4
window, Level 4 19.5
database 17.2
database fields
see also field expressions
adding to layout 19.47
aligning 19.39
as text objects 19.38
deleting rows or columns, spreadsheets 12.32
Demon option, GeoFile 18.10
Description options 5.32
design mode 18.1
design mode, GeoFile 19.6
  switching to 19.6
  window, Level 3 19.3
  window, Level 4 19.4
Desk Accessories folder 1.44
dialog boxes
  Change User Level 1.39
  New/Open 1.6, 1.9
  Print 1.28
  Record Control Panel 17.8
dictionary editing 5.27
dictionary, GeoWrite 4.21
Disable Word Wrap attribute 5.10
discarding document changes 3.6
Display in Tool Bar Pop-Down List option 5.33
Display in Tool Bar Pop-Down List style option 11.17
display modes, GeoWrite 7.2 to 7.6
  changing 7.3
distributing objects equally 10.44, 10.45
document counters, GeoWrite 7.8
  recalculating 7.8
  viewing 7.8
DOCUMENT folder 1.8, 1.18
documents
  annotations 2.39
    see also annotation options
  backing up 3.1 to 3.3
  closing 1.23
  Copy To 3.4 to 3.6
  creating 1.10 to 1.11, 6.4
  creating new, empty 1.11
  creating with a template 1.10
default settings 3.9 to 3.10
default settings, changing 3.10
default settings, reverting to 3.10
discarding changes 3.6
  DOS file names 1.19
  empty 3.9, 6.4
  exporting 3.17 to 3.18
  file names 1.19 to 1.20
  GEOS file name 1.19
  graphics
    see also graphics, in documents
  importing 3.17 to 3.18
  location 1.8
  managing 3.3
  multiple 3.18 to 3.20
  changing display mode 3.19
  opening 3.19
  switching 3.19
tiling windows 3.19
  naming 1.19 to 1.20
  Normal type 3.10
  notes 3.7 to 3.8
  opening existing 1.11 to 1.14
  overlap mode 3.18
  page size and orientation options 1.36 to 1.38
  Page Size options 1.37
  printing 1.27 to 1.36
    choosing printer 1.30
    color 1.29
document options 1.28, 1.29 to 1.36
  paper layout (portrait and landscape) 1.32
  paper options 1.31
  paper size 1.32
  paper source option 1.32 to 1.34
  paper type 1.32
  paper width and height 1.32
  printer options 1.28, 1.30 to 1.36
  standard settings 1.28
  Public type 3.11
  Read-Only Template type 3.11
  Read-Only type 3.11
  renaming 3.6
    see also documents
  restoring 3.2
  restoring from a backup 3.3
  safeguarding 1.23
  Save As 3.4
  saving 1.18 to 1.23
    already named 1.21
    untitled 1.20 to 1.21
    with a different name 1.22
  switching 3.19
  Template type 3.11
  templates 3.13 to 3.17
    see also templates
  type 3.10 to 3.13
  type, changing 3.11
  window elements 1.16
  windows 1.14, 1.16
  Don't Wrap option 6.28
  DOS file name, PostScript files 1.35
  DOS file names 1.19
  DOS file, creating 1.34
  Draft With Styles display mode, GeoWrite 7.3, 7.5
  Draft Without Styles display mode, GeoWrite 7.3, 7.6
drag and drop pointer 12.31
drag and drop pointer override 2.27
dragging 4.8
dragging and dropping 2.26
  spreadsheets 12.30 to 12.31
Draw Annotations option 2.39
Draw Background or Don't Draw Background attribute 10.24
draw mode 10.20
Draw Mode attribute 10.19
Drawing tool bar 2.10
drawing tool bar D.2
drawing tools
  Attribute 10.3
  Bitmap 10.3
  Bitmap Ellipse 10.7
  Bitmap Line 10.7
  Bitmap Rectangle 10.7
  Brush 10.7
  Eraser 10.7
  Fill 10.7
  Frame 10.7
  GeoFile (table) 19.43
  Level 3 10.3
  Level 4 11.2
  Pixel View 10.7
  Selection 10.7
drawing tools, GeoCalc 16.12
drawing tools, GeoDraw
  Arc 9.5
  Ellipse 8.6
  Level 1 8.5 to 8.7
  Level 2 9.4
  Line 8.6
  Pointer 8.6
  Polyline 9.5
  Rectangle 8.6
  Rotate 9.4
  Rounded Polyline 9.5
  Rounded Rectangle 9.5
tool pointers 8.6
  Zoom 9.4
duplicating 10.33
duplicating objects in place 10.33

E

End Points Connected attribute 10.27
Ending Angle attribute 10.27
Eraser bitmap tool 10.7
ERRO() function A.16
EXACT(string1,string2) function A.17
Exit/Cancel button 1.10
exiting applications 1.7
EXP(value) function A.17
Export All option, GeoFile 7.22
Export BMP Format options 9.24
Export Entire Document option 9.25
Export Records From/To option, GeoFile 7.22
Export Selected Objects option 9.25
exporting GeoCalc information 16.14 to 16.16
  changing column order 16.15
  CSV format 16.14
dBASE format 16.14
Lotus format 16.14
exporting GeoFile data 18.11 to 18.14
  changing field order 18.13
  formats 18.11
exporting graphics, GeoDraw 9.23 to 9.25
Express button 1.15
Express menu 1.43, 1.44 to 1.45

F

FACT(value) function A.17
FALSEO() function A.18
field edges, GeoFile 19.40
field expressions
  changing 19.27
  changing default 19.27
  computed value 19.27
date functions (table) 19.32
default value 19.26
elements 19.26
field name references 19.27
financial functions (table) 19.29
information functions (table) 19.29
logical functions (table) 19.30
logical operators (table) 19.34
mathematical functions (table) 19.30
mathematical operators (table) 19.33
mathematical operators, sequence for processing 19.33
statistical functions (table) 19.31
string functions (table) 19.31
time functions (table) 19.32
using 19.26
field expressions, databases 19.26 to 19.34
field label, databases 19.14
Field Name option, databases 19.16, 19.17
Field Names option, databases 19.28
Field Names option, GeoFile 18.6
Field Organizer 19.6, 19.11 to 19.13, 19.47
   elements 19.12
   moving 19.13
field, GeoFile 17.2, 17.10
Fields In Current Layout, GeoFile 19.12
Fields in Database option, GeoFile 18.10
Fields Not in Current Layout, GeoFile 19.12
File Mask option 9.23
file name extension 1.19
file names, DOS 1.19
file names, GEOS 1.19
file selectors 1.24 to 1.27
   changing drives 1.27
   changing folders 1.27
   elements 1.24
FILENAME() function A.18
Fill bitmap tool 10.7
Fill by option 12.33
Fill Color % Shaded attribute 10.18
Filled or Unfilled attribute 10.18
Filled or Unfilled line attribute 10.21
Filled or Unfilled option 5.15, 5.16, 13.7
financial functions 14.11
financial functions (table) 19.29
financial functions, GeoFile (list) A.3
find and replacing text 5.17 to 5.20
Find Next option, GeoWrite 5.17
Find option, GeoFile 17.12
Find Previous option, GeoWrite 5.17
FIND(substring,string,start) function A.18
first line indent 5.5
first-line indenting 4.17
Fixed/Scientific option, databases 19.25
Fixed/Scientific option, spreadsheets 16.11
flipping objects 9.16
floating point math A.2
Floating Tool Box 2.11, 11.4 to 11.5, D.2
   closing 11.4
   displaying 11.4
   moving 11.4
folders 1.26 to 1.27
   changing 1.27
   closing 1.26
   DOCUMENT 1.8, 1.18
   opening 1.26
   PRIVDATA 3.3
Follow Last Section option 6.15
fonts 9.19
   changing 4.12 to 4.14
   GeoCalc 2.30, 2.31
   GeoDraw 2.30, 2.31
   GeoFile 2.30, 2.31
   GeoWrite 2.30, 2.31, 4.12 to 4.14
   monospaced 2.29
   proportionally spaced 2.29, 4.27
   selecting new 2.30
   size, changing 4.14 to 4.15
   style, changing 4.15
   using menus 2.30
   using Style tool bar 2.30
   viewing 2.31, 4.13
fonts, GeoDraw 9.19
   see also text, GeoDraw
Footer style, GeoWrite 5.21, 5.35
footers, GeoWrite 5.20
   set up 5.23 to 5.24
footnotes
   creating 7.27
   creating reference marks 7.26
   description 7.26
   elements 7.26
   text wrapping 7.28
For Editing option 1.11, 1.13, 3.10, 3.12
Format options, spreadsheets 16.11
Formats option, exporting 16.15
formatting paragraphs 5.4 to 5.14
   at paragraph bottom 5.10
   At Paragraph Top 5.10
   borders 5.10 to 5.13
   borders, changing color 5.12
   borders, customizing 5.11
   column breaks 5.9, 5.10
   disabling word wrap 5.10
   first line indent 5.5
   hanging indent 5.6
   hyphenation 5.13 to 5.14
   indenting 5.5 to 5.6
   keep together 5.10
   keep with next 5.10
   line breaks 5.9
   line spacing 5.4
   page breaks 5.10
   spacing between paragraphs 5.5
   tab stops 5.6
   widow and orphan control 5.10
   word wrap 5.10
formatting text 2.29 to 2.38
   see also text
formatting text, GeoFile 19.41
   see also formatting text
formatting text, GeoWrite
   character spacing 5.3
   character weight 5.3
   character width 5.3
   custom size 5.2
formulas
   absolute references 12.20, 12.21
arguments 12.22
built-in functions 12.18, 12.22
changing cell or range name definition 14.6
circular references 14.8 to 14.10
copying to adjacent cells 12.29
deleting cell or range names 14.6
entering 12.18
    with keyboard and mouse 12.19
    with keyboard only 12.19
inserting
    built-in functions by typing 12.25
    built-in functions using the Formula menu
    12.24 to 12.26
names 14.5
moving 12.28
naming cells 14.3 to 14.7
naming ranges 14.3 to 14.7
operators 12.18
placeholder arguments 12.23, 12.26
references 12.18
relative 12.20
relative references 12.28
renaming named cells or ranges 14.5
show/hide 14.2 to 14.3
specifying iterations 14.9
using a function within a function 12.25
values 12.18
formulas, GeoCalc 12.10, 12.18 to 12.26
    elements 12.18
Frame bitmap tool 10.7
Function bar tools (table) 16.4
Function tool bar 2.9, D.2, D.5
Functions option, databases 19.28
Functions option, GeoFile 18.6
functions, GeoCalc
    available functions (list) A.3
functions, GeoFile A.1
    arguments in A.2
date (list) A.7
date (table) 19.32
descriptions (alphabetical list) A.10
financial (list) A.3
financial (table) 19.29
information (list) A.4
information (table) 19.29
keyword in A.2
logical (list) A.5
logical (table) 19.30
mathematical (list) A.5
mathematical (table) 19.30
print (list) A.6
statistical (list) A.6
statistical (table) 19.31
string (list) A.6
string (table) 19.31
time (list) A.7
time (table) 19.32
trigonometric (list) A.8
FV(payments,interest,term) function A.18

G
Galley display mode, GeoWrite 7.3, 7.4
General/Text field type, databases 19.15
GeoCalc
    automatic recalculation 14.7
    charts 15.1
        see also charts
color 13.6 to 13.8
        see also spreadsheets, color
exporting 16.14 to 16.16
        see also exporting GeoCalc information
floating point math 12.18
formulas
        see also formulas, GeoCalc
functions available (list) A.3
graphics 16.12 to 16.13
headers and footers 13.5
importing 16.17 to 16.20
        see also importing information into
    GeoCalc
mail merge 7.20 to 7.21
        see also mail merge, GeoCalc
printing 16.6 to 16.8
        see also spreadsheets, printing
rulers, specifying 16.12
spreadsheets
        see also spreadsheets
starting 12.3
user levels 12.5
using with other GEOS applications 16.13
GeoDex
    mail merge 7.18 to 7.19
        see also mail merge, GeoDex
GeoDraw
    bitmap 10.6
        see also bitmap
creating basic objects 8.7 to 8.9
        see also objects, GeoDraw
creating complex objects 9.5 to 9.13
        see also objects, GeoDraw
default attributes 10.27
drawing tools
        see also drawing tools, GeoDraw
Level 3 10.3
Level 4 11.1
editing, keyboard shortcuts 11.27
exporting 9.23 to 9.25
formatting text  11.25
  see also formatting text  11.1
graphic styles  11.16 to 11.23
  see also graphic styles
grid  10.38
  see also grid
  see also guidelines
importing graphics  9.22 to 9.25
introduction  8.1
rulers  10.36 to 10.38
  see also rulers
Spline tool
  see also polylines, Spline tool
starting  8.3
starting window  8.3
text  8.16 to 8.18, 9.18 to 9.21
  see also text, GeoDraw
viewing  10.5
window, Level  2  9.2
window, Level  3  10.3
zooming  10.4 to 10.5
  see also zooming
GeoFile
data entry mode
  see data entry mode, GeoFile
database layout  19.34 to 19.44
databases  17.5 to 17.7, 19.9 to 19.10
  see also databases
description  17.1
design mode
  see design mode, GeoFile
drawing tools (table)  19.43
exporting data  18.11 to 18.14
  see also exporting GeoFile data
field expressions  19.26 to 19.34
Field Organizer  19.11 to 19.13
  see also Field Organizer
functions  19.29 to 19.33
GeoCalc comparison  19.26
graphics  19.42
importing data  18.14 to 18.16
  see also importing data into GeoFile
key combinations (table)  19.55
layouts  17.14
mail merge  7.21 to 7.22
  see also mail merge, GeoFile
multi-record mode  19.6 to 19.9
number formats  19.21 to 19.26
  see also database fields
record marking  18.1
sorting  17.13 to 17.14, 18.9 to 18.11
starting  17.3
starting window  17.4
templates  17.5 to 17.7

see also templates, GeoFile
terms  17.2
uses  17.1
work modes  19.2 to 19.9
  see also data entry mode, GeoFile
  see also design mode, GeoFile
GEOS file name  1.19
GeoWrite
bibliography  7.29
color  5.14 to 5.17
  see also color, GeoWrite
columns  5.9, 7.15 to 7.17
  see also columns, GeoWrite
counters  7.8
  see also counters, GeoWrite
dictionary editing  5.27
display modes  7.2 to 7.6
  see also display modes
document window  4.4
finding and replacing text  5.17 to 5.20
footers  5.20
  see also footers, GeoWrite
footnotes  7.26
  see also footnotes
formatting documents
  see formatting paragraphs
  see formatting text, GeoWrite
formatting paragraphs  5.4 to 5.14
  see also formatting paragraphs
formatting text  5.2 to 5.3
  see also text
headers  5.20
  see also headers, GeoWrite
introductions  4.1 to 4.3
mail merge  7.17 to 7.25
  see also mail merge
master pages  6.16 to 6.21
  see also master pages, GeoWrite
moving through documents  4.23 to 4.25
page layout mode  6.28 to 6.30
  see also page layout mode, GeoWrite
page setup  1.37, 6.14
  see also sections
pagination  7.14 to 7.15
ruler  4.4
scrolling  4.23
sections  6.7
  see also sections
spell checking  4.21 to 4.23, 5.25 to 5.29
  see also spell checking
starting  4.3
style sheets  5.29 to 5.37
  see also text style sheets, GeoWrite
table of contents  7.28 to 7.29
base style 11.16
changing style attributes 11.19
changing visual attributes 11.19
defining new 11.17
deleting 11.21
importing from other drawings 11.22
naming 11.16
options 11.17
recalling stored attributes 11.23
reverting to base 11.21
style sheets 11.16
temporary storing attributes 11.22
Graphic tool bar 2.12, D.2
Graphics Interchange Format (GIF) format 9.22
graphics, GeoCalc 16.12 to 16.13
graphics, in documents 6.21 to 6.27
see also graphic objects
adding frames 6.21 to 6.27
description 6.22
frames
attributes 6.25
changing size 6.24
copying 6.24
deleting 6.25
deselect 6.24
moving 6.24
selecting 6.23
text wrapping options 6.27
grid 10.38, 13.2
setting spacing 10.39
show/hide 10.39
show/hide lines 13.1
units 10.40
grid lines, GeoFile 19.52
grid markings 15.16
grouping objects 9.14
Guide Position option 10.41
guidelines 10.40
changing 10.41
creating 10.41
deleting 10.41
Guidelines option 10.41
gutter 7.15

deleting 7.15
inserting, using menus 7.14
inserting, using the keyboard 7.14
Header style, GeoWrite 5.21, 5.35
headers and footers, spreadsheets 13.5
headers, GeoWrite 5.20
set up 5.22 to 5.23
Height option 1.37
Help button 1.15
high/low charts 15.8
see also charts
HLOOKUP(value, range, offset) function A.19
horizontal gradient 10.25
Horizontal skew option 10.33
HOUR(time_value) function A.20
hyphenation 5.13 to 5.14

I
I-Beam pointer 8.6
IF function 14.12
IF(logical, true_value, false_value) function A.20
Ignore Case option, GeoFile 18.5
Ignore Case/Accents option, GeoFile 17.12
Ignore Case/Accents option, GeoWrite 5.20
Import button 1.9
importing data into GeoFile 18.14 to 18.16
formats 18.11
mapping fields 18.15
importing documents 3.17 to 3.18
importing graphics 9.22 to 9.25
importing information into GeoCalc 16.17 to 16.20
changing column order 16.18
CSV 16.17
dBASE format 16.17
Lotus 16.17
incremental values in spreadsheets 12.32
indenting paragraphs, GeoWrite 4.4, 5.5 to 5.6
indenting paragraphs, GeoWrite, 4.16
indenting paragraphs, GeoWrite, additional options 4.16
Independent control point attribute 11.15
INDEX(range, column_offset, row_offset) function A.20
information functions 14.14
information functions (table) 19.29
information functions, GeoFile (list) A.4
inserting rows or columns, spreadsheets 12.31
insertion point 4.5, 4.6
moving with mouse 4.6
INT(value) function A.21
Integer field type, databases 19.15
integer format 19.22
interior object 11.8
invisible characters 7.7
displaying 7.7
table of 7.7
IRR(guess,range) function A.21
ISERR(value) function A.22
ISNUMBER(value) function A.22
ISSTRING(value) function A.23
italic text 2.34, 4.27, 12.36

J
justifying spreadsheet cells 12.35
justifying text 2.36 to 2.37

K
Keep Paragraph Together attribute 5.10
Keep with Next attribute 5.10
key combinations
bullet character 2.41
editing drawings (table) 11.27
editing text (table) 2.28
em dash 2.41
for data entry mode, GeoFile (table) 19.55
selecting spreadsheet cells 12.9
selecting text (table) 2.20
keyword in functions A.2

L
labels, GeoCalc 12.10
entering 12.11
layouts, GeoFile 17.3, 17.14
choosing 17.14
Leading option, databases 19.25
Leading option, spreadsheets 16.11
Leading Relative option 5.33
Left 19.12
Left Indent of First Line option 5.6
LEFT(string,num) function A.23
Legend option 15.14
Length data attribute, databases 19.17
LENGTH(string) function A.23
line attribute 6.25, 10.17
line breaks 5.9
line charts 15.4
see also charts
Line Color % Shaded line attribute 10.21
Line Color Relative style option 11.18
Line Color tool 10.22
Line Mask Relative style option 11.18
Line Shading tool 10.22
line spacing 4.20, 5.4
Line Width Relative style option 11.18
Line Width tool 10.22
LN(value) function A.23
Locks attribute 11.24
LOG(value) function A.24
Logic option, databases 19.28
Logic option, GeoFile 18.7
logical functions 14.12 to 14.13
logical functions (table) 19.30
logical functions, GeoFile (list) A.5
logical operators (table) 14.13, 19.34
Longhand Date format 7.9
lookup functions 14.13
LOWER(string) function A.24

M
mail merge, GeoCalc 7.20 to 7.21
designing data document 7.20
preparing data document for merge 7.21
mail merge, GeoDex 7.18
copying records 7.19
mail merge, GeoFile 7.21 to 7.22
copying records 7.21
mail merge, GeoWrite 7.17 to 7.25
adding merge fields 7.23 to 7.24
data document 7.18
merge document 7.18, 7.22
merge field names (table) 7.23
printing merge document 7.25
sequence for creating 7.18
Make Annotations Selectable/Editable option 2.39
Make Annotations Unselectable/Uneditable option 2.40
managing documents 3.3
manual leading 5.4
Map Export Fields 7.22
Margins option 1.37
Margins option, sections 6.15
Margins Relative option 5.33
markers, GeoCalc 15.17
marking records, GeoFile 18.1
master pages
buttons 6.17 to 6.18
changing 6.16
columns 6.18
editing 6.17 to 6.18
headers and footers 6.18
reapplying to a section 6.20 to 6.21
text regions 6.18 to 6.20
changing size 6.19
copying 6.20
deleting 6.20
deselecting 6.19
moving 6.19
selecting 6.18
master pages, GeoWrite 6.16 to 6.21
Match Any Character option, GeoWrite 5.19
Match Multiple Characters option, GeoWrite 5.19
Match Only at Start of Field option, GeoFile 18.6
Match Partial Words option, GeoFile 17.12
Match Partial Words option, GeoWrite 5.20
Math option, databases 19.28
Math option, GeoFile 18.7
mathematical functions 14.11
mathematical functions (table) 19.30
mathematical functions, GeoFile (list) A.5
mathematical operators, GeoFile 19.33
sequence for performing operations 19.33
Max data attribute, databases 19.17
MAX(value1,value2, ... ) function A.24
Maximize-Restore button 1.15, 1.17
Maximum Change option 14.9
Maximum Consecutive Lines to Hyphenate option 5.13
Maximum Iterations option 14.9
measurement units 2.6, 2.7, 10.37
Menu bar 1.15
menus
Express 1.43
Merge All option 7.25
merge document 7.18
merge fields 7.18
Merge One option 7.25
MID(string,start,num) function A.24
Min data attribute, databases 19.17
MIN(value1,value2, ... ) function A.25
Minimize button 1.15
MINUTE(time_value) function A.25
MOD(value,divisor) function A.25
monospaced font 2.29
MONTH(date_value) function A.25
move handle, GeoDraw 8.8
Move option, duplicating 10.35, 11.7
moving objects, custom 10.35
moving text 4.10
moving text and graphics 2.25
multi-record mode, GeoFile 19.6 to 19.9, 19.48, 19.50
in layouts 19.48
multiple documents 3.18 to 3.20
see also documents
multiple duplicating 10.34

N
N(range) function A.26
NAO function A.26
Name of Format option 16.11
Name of Format option, databases 19.25
Name option 5.33
Name style option 11.18
naming documents 1.19 to 1.20
naming fields, databases 19.14, 19.19
New File Name option, exporting 16.15
New Word 5.27
New/Open dialog box 1.6, 1.9
Next Page, GeoWrite 4.23
No Merge option 7.25
Normal style, GeoWrite 5.35
note indicators, GeoCalc 13.9
Notes field option 1.12, 1.13
Notes field, template 1.11
Notes option, GeoFile 18.11
notes, document 3.7 to 3.8
Notes, GeoFile 19.12
notes, spreadsheets 13.8 to 13.10
Now (Won't Change) time type 7.13
NOW() function A.26
NPV(interest,range) function A.26
nudging 8.13, 9.2
nudging inside 11.9
nudging objects 9.13, 11.8
Num Lock key 2.20, 4.7, 4.28
number format, spreadsheets 16.10 to 16.12
Number of Copies option 1.29
Number of Duplicates option 10.35, 11.7
Number of Intervals attribute 10.26
Number of Pages in Section number type, GeoWrite 7.11
Number of Pages number type, GeoWrite 7.11
Number of Polygon Sides option 10.47
Number of Sections number type, GeoWrite 7.11
Number of Star Points option 10.48
Numeric Date format 7.9

O
object lock 11.23
objects, GeoDraw
see also graphic objects
adding 8.9
anchor points, deleting 9.9
anchor points, inserting 9.9
bring to front 9.17
changing polyline points 9.8
changing polyline shape 9.8
closing polylines 9.10
coloring 8.15 to 8.16
changing 8.15
changing with the Attributes menu 8.15
creating 8.7 to 8.9, 9.5 to 9.13
arcs 9.12
arrowhead 8.9
circle 8.8
ellipse 8.7
lines 8.8
polygons 9.11
polylines 9.7
rectangle 8.7
rounded polylines 9.7
square 8.8
stars 9.11
unfilled 8.8

deleting 8.15
deselecting 8.10
duplicating 8.14
flipping 9.16
grouping 9.14
moving 8.12
moving multiple 8.13
nudging 8.13, 9.2, 9.13
opening polylines 9.10
polyline 9.2
polylines 9.2
pulling forward 9.18
pushing back 9.18
resizing 8.14
resizing lines 8.14
rotating 9.15
selecting 8.10
  multiple adjacent 8.10
  multiple non-adjacent 8.11
  select all 8.11
sending to back 9.17
show/hide outlines 10.6
stacked 9.2
stacking 9.16
ungrouping 9.15
Offset option, databases 19.25
Offset option, spreadsheets 16.11
opening
  operators in formulas 12.18
operators in spreadsheets (table) 12.21
Options for formatting, databases 19.25
OR functions 14.13
OR(logical1, logical2, ...) function A.27
overlap mode 3.18

Page Break Before attribute 5.10
Page Break option, find and replace, GeoWrite 5.20
page breaks 7.9, 7.14
Page display mode, GeoWrite 7.2, 7.3
page layout mode, GeoWrite 6.28 to 6.30
activating 6.29
adding pages 6.29
appending a new page 6.29
deleting existing pages 6.30
do not delete pages with graphics 6.30
inserting a new page 6.29
Page Number button
  footers 5.23
  headers 5.22
master pages 6.17
Page Number in Section number type, GeoWrite 7.11
Page Number number type, GeoWrite 7.11
page numbering, spreadsheets 13.6
Page Size options 1.37
PAGEO function A.28
PALESO function A.28
pagigation, GeoWrite 7.14 to 7.15
Paper Layout option 1.37
paragraph borders 5.10 to 5.13
  see also formatting paragraphs
Paragraph Color % Shaded option 5.16
paragraph formatting
  see also formatting paragraphs
paragraph spacing 5.5
parentheses in spreadsheets 12.26
passwords, changing 3.8
passwords, removing 3.9
pasting text and graphics 2.25 to 2.26
Path drop-down list 1.24, 1.25
Pattern attribute 10.19
Pattern option 5.12, 5.16
PC Paintbrush (PCX) format 9.22
PIO function A.28
pica 2.34, 10.37
pie charts 15.7
  see also charts
pixel 10.7
Pixel View bitmap tool 10.7
placeholder arguments in spreadsheets 12.23, 12.26
Places option, databases 19.25
Places option, spreadsheets 16.11
plain text 12.36
PMT(principal, interest, term) function A.28
point 10.37
Point Size Relative option 5.33
points 2.34
Polygon Radius option 10.47
polygons 10.46
  creating 9.11
polyline 9.2, 9.6 to 9.9
    closed 9.6
    open 9.6
Polyline tool 9.5
poly lines 9.6 to 9.9
  closing 9.10
  opening 9.10
  rounded 9.7
Spline tool 11.10 to 11.15
  corner point 11.14
  curved point 11.14
  deleting anchor points 11.13
  drawing 11.11
  inserting anchor points 11.13
  reshaping segments 11.13
PostScript file, saving to 1.34
Previous Page, GeoWrite 4.23
Print Annotations option 2.39
Print dialog box 1.28
Print Footers option 16.8
print functions 14.14
print functions, GeoFile (list) A.6
Print Grid Lines option 16.7
Print Headers option 16.8
Print Pages option 1.29
Print Quality option 1.29
Print Row and Column Titles option 16.7
Print Sideways option 16.7
print
  annotated objects 11.24
  canceling print jobs 1.36
  checking print jobs 1.36
  color 1.35
  mail merge documents 7.25
  notes, spreadsheets 13.10
  PostScript file, saving to 1.34
  spreadsheets 16.6
    see also spreadsheets
printing documents 1.27 to 1.36
PRIVDATA folder 3.3
PRODUCT(value1,value2,...) function A.29
productivity tools
  introduction 1.2
  locating 1.3
  purpose 1.2
  templates 1.4
  uses 1.2
  using with other applications 1.4
WSYIWYG 1.3
Progression option 12.33
Promote option, GeoFile 18.10
PROPER(string) function A.29
proportionally spaced fonts 2.29, 4.27
prototype 6.16
Public document type 3.11
pulling objects forward 9.18
pushing objects back 9.18
PV(payment,interest,term) function A.29

Q
  quotation marks in spreadsheets 12.11

R
  radial gradient 10.25
  RANDOM0 function A.30
  RANDOMN(value) function A.30
  RATE(future_value,present_value,term) function A.30
  Read-Only document type 3.11
  Read-Only Template document type 3.11
  real computed value format, databases 19.22
  Real Number field type, databases 19.15
  real number format, databases 19.22
  Reapply Existing option, master pages 6.21
  recalculation, spreadsheets 14.7
    manual 14.7
      turning on and off 14.7
    Record Control Panel dialog box 17.8
    record marking, GeoFile 17.2, 17.10
    records, GeoFile
      show all 18.4
      show only marked 18.4
  rectangular gradient 10.25
  Redo 2.28
  Redraw (F5), GeoDraw 9.3
    Redraw Document button, master pages 6.17
    reference mark (footnotes) 7.26
    references in formulas 12.18
    references in spreadsheets 12.20
      absolute 12.20
      relative 12.20
    relative references in spreadsheets 12.20, 12.28, 14.3
    Remove Sort Arrow option, GeoFile 18.10
    renaming documents 3.6
      see also documents
    REPEAT(string,num) function A.30
    Replace All option 5.18, 5.26
    Replace option 5.26
    REPLACE(original,start,num,replace) function A.30
    Reset, Then Reapply option, master pages 6.21
    resetting configurations 2.17
    resize handle, GeoDraw 8.8
    resolution, GeoDraw 10.15
restoring documents from a backup 3.2, 3.3
Right Arrow button, GeoFile 19.12
Right Indent option 5.6
RIGHT(string,num) function A.31
Rotate option, duplicating 10.35, 11.7
Rotate tool 9.4
rotating objects 9.15
    custom 10.31
    standard 10.31
ROUND(value,places) function A.31
Rounded Polyline tool 9.5
Rounded Rectangle tool 9.5
ROWS(range) function A.31
Rule Width column option, GeoWrite 7.17
Rule Width option, sections 6.15
Ruler 1.17
ruler, GeoDraw 8.12
rulers 2.6 to 2.8, 4.4, 10.36 to 10.38
    GeoWrite 4.16
    measurement units 10.37
    show/hide 10.37
rulers, GeoCalc 16.12

S
safeguarding documents 1.23
Save 1.20 to 1.21
Save As 1.21 to 1.23, 3.4
saving configurations 1.40, 1.41, 2.17, 11.26
saving documents 1.18 to 1.23, 1.20
Scale option, duplicating 11.7
Scale to Fit One Page option 16.7
Scale to Fit option 2.4
Scale to Fit option, GeoDraw 9.3
scatter plot 15.5
scientific notation in spreadsheets 12.12
scrapbook 2.28
Scroll bars 1.17, 4.23
scroll bars, GeoDraw 10.5
scroll bars, show/hide 10.5
scrolling through spreadsheets 12.6
SECOND(time_value) function A.32
section 6.7
Section Number number type, GeoWrite 7.11
Section to Change Page Setup For option 6.15
sections
    adding a page 6.16
    adding new 6.8
    appending new 6.10
    changing page setup 6.14
    deleting 6.11
description 6.7
displaying name 6.12
inserting new 6.8, 6.9
numbering 6.12
planning documents 6.7 to 6.8
reapplying master pages 6.20
renaming 6.10
selecting 6.12
    setting starting section number 6.13
sections, GeoWrite
    changing columns 7.16
segment 11.10
Select File and Format for Import option 9.22
Select Folder and Format for Export option 9.24, 16.14
Select Mark Field option, GeoFile 18.5
Select Sort Field option, GeoFile 17.13
selecting
    with key combinations (table) 4.28
selecting graphic objects 2.22 to 2.24
    see also graphic objects
selecting items 2.18 to 2.24
    see also graphic objects
selecting items
    see also objects
    see also text
selecting spreadsheet cells 2.20, 12.7 to 12.10
    see also spreadsheets
selecting text 2.19, 4.7 to 4.9
    see also text
    canceling a selection 4.9
    extending a selection 4.8
    mouse 4.7 to 4.9
    reducing a selection 4.8
Selection bitmap tool 10.7
sending objects to back 9.17
series, in charts 15.2
Set Default field attribute, databases 19.17
Set Field Notes field attribute, databases 19.17
Shadow Anchor option 5.12
Shadow Width option 5.12
Shortest Prefix option 5.13
Shortest Suffix option 5.14
Shortest Word to Hyphenate option 5.13
Show Scroll Bars option 2.5
show/hide object outlines 10.6
show/hide scroll bars 10.5
Sides to Border option 5.11
SIN(angle) function A.32
single-record mode, GeoFile 19.6, 19.48, 19.50
    in layouts 19.48
SINH(angle) function A.32
Size option 1.37
Skew option, duplicating 11.7
skewing objects, custom 10.32
skewing objects, standard 10.32
Skip All option 5.26
Skip option 5.26
SLN(cost, salvage, life) function A.32
smart quotes 2.40 to 2.41
snapping objects to grid and guidelines 10.42
soft page breaks 7.14
Sort Direction option, GeoFile 17.13, 18.11
Sort Keys option, GeoFile 18.10
Sort Options, GeoFile 18.11
sort, GeoFile 18.9 to 18.11
Spacing column option, GeoWrite 7.17
Spacing option, sections 6.15
special characters
  bullet 4.27
  currency and numeric symbols B.6 to B.7
  em dash 4.27
  foreign language B.2 to B.4
  foreign-language accents B.4 to B.5
  inserting, GeoWrite 7.8
    current date 7.9
    current time 7.9
    numbers (counters) 7.10 to 7.11
    special dates 7.11
    special times 7.12 to 7.13
  invisible (table) 7.7
  mathematical symbols B.7
  punctuation marks B.5 to B.6
  typographical symbols B.5
Special Characters option, GeoFile 17.12
special characters, searching for 5.19
spell checking 4.21 to 4.23, 5.25 to 5.29
word or block of text 4.21
Spline tool 11.2, 11.10 to 11.15
  see also polylines
spreadsheet cells
  selecting range 2.21
  selecting single 2.21
spreadsheets
  absolute references 14.3
  AND functions 14.13
  apostrophe 12.11
  attaching notes 13.9
  auto recalculation
    turning on and off 14.7
  automatic recalculation 14.7
    manual 14.7
  calculating 16.6
  cell addresses 12.4
  cells 12.4
  changing date format 12.16
  charting
    see charts
text 13.6
  column width
    changing by dragging 12.34
    changing with Cell menu 12.35
    setting a value 13.4 to 13.5
  comma 12.12
  copying
    a formula to adjacent cells 12.29
    cell contents 12.27, 12.30
    to adjacent cells 12.28
date format 16.10
date format (table) 12.15
date functions 14.11
defining cell name 14.4
defining range name 14.4
deleting a row or column 12.32
deleting cell contents 12.27
displaying cell borders 13.3
editing 12.26
editing the contents 12.26
entering
  data in a selected range 12.17
  dates as formulas 12.14
  dates as labels 12.14
  formulas 12.10
  labels 12.10, 12.11
  text 12.11
  values 12.10, 12.11
financial functions 14.11
formatting 12.18
formulas 12.10, 12.18 to 12.26
  see also formulas, GeoCalc 12.1
grid 12.4
headers and footers 13.5 to 13.6
headers and footers, creating 13.5
IF function 14.12
incremental values 12.32 to 12.33
information functions 14.14
inserting a row or column 12.31
introduction 12.1
justifying cells 12.35
lables 12.10
logical functions 14.12 to 14.13
logical operators (table) 14.13
lookup functions 14.13
mathematical functions 14.11
moving cell contents 12.27, 12.30
moving within 12.11
multiple additions and deletions of rows and
  columns 12.31
notes 13.8 to 13.10
number format 16.10 to 16.12
  changing 12.13
for values (table) 12.12
operators (table) 12.21
OR functions 14.13
page numbering 13.6
parentheses 12.26
print functions 14.14
printing 16.6 to 16.8
printing notes 13.10
quotation marks 12.11
relative references 14.3
row and column headers 12.4
row height, setting a value 13.4
scientific notation 12.12
scrolling 12.6
select all 12.9
selecting
a cell using key combinations (table) 12.9
a range of cells 12.8
a range of cells using key combinations
(table) 12.10
cells, Num Lock key 12.10
etire row/column 12.8
multiple rows/columns 12.8
range of cells 12.8
single cells 12.8
setting print options 16.6 to 16.8
show/hide grid 13.1
show/hide note indicators 13.9
sorting 16.8 to 16.10
standard column width 13.4
statistical functions 14.12
string functions 14.10
string functions (table) 12.10
string functions, GeoFile (list) A.6
STRING(value,N) function A.33
strings 19.31
style 5.29
Style line attribute 10.22
style sheets, GeoWrite
see also text style sheets, GeoWrite
Style tool bar 2.9, 4.9, D.2, D.3
fonts 2.30
subscript 2.34
Suggest option 5.26
SUM(value1,value2,...) function A.34
superscript 2.34
Switch All Marks option, GeoFile 18.8
SYD(cost,salvage,life,period) function A.34
Symmetric control point attribute 11.15

T

tab key 4.27
Tab Leader option 5.7
Tab option 5.20
tab order, GeoFile 19.40
Tab Position option 5.7
tab stops 5.6
changing 5.8
creating 5.7
deleting a stop 5.8
deleting all 5.8
setting default stops 5.8
tab stops, GeoWrite 4.4, 4.18 to 4.19
Tab Type option 5.7
table of contents, creating 7.28 to 7.29
Tabs List option 5.7
Tag Image File (TIF) format 9.22, 9.25
TAN(angle) function A.34
tangent line 11.11
TANH(angle) function A.34
template 6.2
Template button 1.9, 3.14
Template document type 3.11
templates 3.13 to 3.17
application 3.13
browsing 1.11
changing 3.16, 6.3
creating 3.15, 6.2
creating documents 1.10
creating from built-in template 3.16
deleting 6.4
document type, setting 6.4
empty document 6.4 to 6.6
changing 6.5
replacing 6.6
resetting 6.6
setting 6.5
For Editing option 1.11
Notes field 1.11
read-only 6.4
removing 3.17
USERDATA folder 3.17
templates, GeoFile 17.5 to 17.7
creating a new database 17.7
naming 17.6
opening 17.6
templates, GeoWrite 4.25 to 4.27
using 4.26
TERM(payments, interest, future_value) function A.35
text
aligning 4.19 to 4.20, 4.27
annotations
see annotations, using
attribute 10.17
background color 5.14
bold 2.34
bullet character 2.41
character spacing 5.3
character weight 5.3
clicking 2.19
color 5.14 to 5.15
copying 2.25 to 2.26, 4.11
correcting as you type 4.6
cutting 2.25 to 2.26, 4.10
deleting 2.27, 4.10
with key combinations (table) 2.27
editing 4.10 to 4.11
with key combinations (table) 2.28
em dash 2.41, 4.27
fonts 2.29 to 2.31, 4.12 to 4.14
see also fonts
formatting 2.29 to 2.38
see also formatting text, GeoWrite
italic 2.34, 4.27
justification 2.36 to 2.37
justifying
from a menu, GeoCalc 2.37
from a menu, GeoDraw 2.37
from a menu, GeoFile 2.37
from a menu, GeoWrite 2.37
from Style tool bar 2.37
line spacing 4.20
monospaced 2.29
moving 4.10
numbers 4.7
paragraphs, new 4.6
pasting 2.25 to 2.26
point size options 2.33
point size units 2.33
proportionally spaced 2.29
Redo 2.28
replacing 2.24, 2.26
replacing text 4.10
selecting 2.19, 4.7 to 4.9
canceling a selection 2.20, 4.9
extending a selection 2.19, 4.8
reducing a selection 2.19, 4.8
with key combinations (table) 2.20
with mouse 2.19, 4.8
size 2.31 to 2.34
customizing 2.33
GeoCalc 2.32, 2.34
GeoDraw 2.32, 2.34
GeoFile 2.32, 2.34
GeoWrite 2.32, 2.34
using Style tool bar to change 2.32
smart quotes 2.40 to 2.41
special characters see special characters
strike-thru 2.34
style 2.34 to 2.36
changing, 2.35
plain 2.36
style sheets, GeoWrite 5.29
see also text style sheets, GeoWrite
subscript 2.34
superscript 2.34
typographical quotes 2.40 to 2.41
underline 2.34
Undo 2.28, 4.11
word processor tips 4.27
word wrap 4.27
text area, GeoWrite 4.4
text attribute 10.17
Text Background % Shaded option 5.15
Text Background Color % Shaded option 13.7
text character attributes 4.12
Text Color % Shaded option 5.15, 13.6, 13.8
Text Color tool 10.23
text object 10.2
text objects
converting to bitmap 10.16
Text Only option 1.29
text region 6.18
Text Shading tool 10.23
text string 17.12
text style sheet 5.29
text style sheets, GeoWrite 5.29 to 5.37
applying 5.30
changing existing 5.34
changing format 5.33
default styles 5.30
defining new 5.31 to 5.33
deleting 5.35 to 5.36
Footer style 5.30
Header style 5.30
new style options 5.32
Normal style 5.30
recalling temporarily stored 5.31
reverting to base 5.36
storing temporarily 5.31
using from other documents 5.37
Text to Match option, GeoFile 18.6
text, GeoDraw 9.2, 9.18 to 9.21
aligning text 9.20
attributes 10.23 to 10.24
changing
  font 9.20
  style 9.20
  text size 9.20
changing attributes 9.19
coloring 10.23
color palette 9.21
  Text Color choice 9.21
combining attributes 9.19
creating 8.17
creating objects 8.16 to 8.18
deleting 8.18
deleting empty objects 8.18
editing 8.17
entering 8.17
moving 8.18
resizing 8.18
shading text 10.23
thesaurus 5.28 to 5.29
Time Document Created time type 7.13
Time field type, databases 19.16
time functions (table) 19.32
time functions, GeoFile (list) A.7
Time of Last Revision time type 7.13
Time of Printing time type 7.13
TIME(hour,minute,second) function A.35
TIMEVALUE(string) function A.35
Title bar 1.15, 1.17
title page, GeoWrite 5.24 to 5.25
  adding to a document 5.24
deleting 5.24
go to title page 5.24
Today's Date (Won't Change) date type, GeoWrite 7.12
TODAY() function A.35
Tool bar 1.15
tool bars 2.8 to 2.13, D.1
  Attribute 10.17
  Attributes 2.12
  Bitmap 2.11
Clipboard 11.2
customizing 2.14 to 2.17
displaying 2.12
Drawing 2.10
drawing and graphics 2.10
Floating Tool Box 2.11
Function 2.9
Graphic 2.12
grouping 2.14 to 2.17
grouping (list) 2.14
moving groups 2.16
show/hide groups 2.15
Style 2.9, 4.9
using 2.13
tools
  Check Spelling 4.22
  Trailing option, databases 19.25
  Trailing option, spreadsheets 16.11
transform 10.30
transforming objects 10.30
trigonometric functions 14.12
trigonometric functions, GeoFile (list) A.8
TRIM(string) function A.35
TRUE() function A.36
TRUNC(value) function A.36
Type Indicator option 1.12, 1.13
Type option 1.37
typographical quotes 2.40 to 2.41
U
underline text 2.34, 12.36
Undo 2.28, 4.11
ungrouping objects 9.15
Units option 12.33
untransforming objects 10.33
UPPER(string) function A.36
user levels 1.38 to 1.41
differences in 1.38
  fine tuning 1.40, 7.29, 11.26, 16.20, 19.54
GeoCalc 12.5, 16.20
GeoDraw 8.4 to 8.5, 11.26
GeoFile 17.4, 19.54
GeoWrite 4.5
saving 1.40
verifying and changing 1.39
V
VALUE(string) function A.36
values in formulas 12.18
values, GeoCalc 12.10
entering 12.11
VAR(value1,value2,...) function A.36
VARP(value1,value2,...) function A.37
vertical gradient 10.25
Vertical Guidelines or Horizontal Guidelines option 10.41
Vertical Line option 5.7
Vertical skew option 10.33
View at % option 2.3
viewing 17.15
viewing options
  windows 2.2 to 2.6
viewing, GeoDraw 10.5
VLOOKUP(value,range,offset) function A.37

W
WEEKDAY(date_value) function A.38
Widow and Orphan Control attribute 5.10
Width Between Double Lines option 5.12
Width line attribute 10.22
Width option 1.37
wild cards, GeoFile 17.12
wild cards, searching for 5.19
window
  application 1.6, 1.14
  Change All Views Together option 2.4
document 3.19 to 3.20
  see also documents, multiple
  resizing 1.43
  Scale to Fit 2.4
  setting view options 2.5
  Show Scroll Bar options 2.5
  View at % 2.3
  viewing options 2.2 to 2.6
  zooming 2.3 to 2.4
window borders 1.15
Window Control button 1.15, 1.17
word processor tips 4.27
word wrap 4.6, 4.27, 5.10, 8.16
Words in User Dictionary option 5.27
Wrap Around Rectangle option 6.28
Wrap Inside Object option 6.28
Wrap Tightly option 6.27
wrapping text 6.27
wrapping text around footnotes 7.28
WYSIWYG 1.3

X
X-Axis Title option 15.14
x-y plot charts 15.5
  see also charts

Y
Y-Title option 15.14
YEAR(date_value) function A.38

Z
Zoom tool 9.4
zooming
  custom percentage 10.4
  GeoDraw 10.4 to 10.5
  standard percentage 10.4
  zooming, GeoFile 17.15, 19.52
  zooming, GeoWrite 4.23
  zooming, windows 2.3 to 2.4
COLOPHON

DESIGN
Jennifer Durrant, Michael Eggers

TEXT
David A. Knopf, Ann W. Merrill,
Barbara Bogard, Karen Bowman,
Andrew Chaikin, Jamison Green,
Jacqueline Hale, Eric Ivory,
Karen Kellerman, Michelle Stafford,
Mike Stokowski, Matthew Trifiro

ARTWORK
Tony Lijphart, Angela Yee

PRODUCTION
GeoWorks Documentation Assault Team