Crosstalk for Windows User's Guide
Digital Communications Associates, Inc. ("DCA") has prepared this
document for use by DCA personnel, licensees, and customers. The
information contained herein is the property of DCA and shall not be
copied, photocopied, translated or reduced to any electronic or machine
readable form, either in whole or in part, without prior written approval
from DCA.

DCA reserves the right to, without notice, modify or revise all or part
of this document and/or change product features or specifications and
shall not be responsible for any loss, cost, or damage, including
consequential damage, caused by reliance on these materials.

In all correspondence with Digital Communications Associates, Inc.
regarding this publication, refer to part number 016589 October 1992.

© 1991, 1992 by Digital Communications Associates, Inc. All rights
reserved.

**Trademarks and registered names**

Crosstalk and DCA are registered trademarks and CASL, DART,
QuickBar, and QuickPad are trademarks of Digital Communications
Associates, Inc. Microsoft is a registered trademark and Windows is a
trademark of Microsoft Corporation. All other brand and product names
are trademarks or registered trademarks of their respective owners.
Contents

Before You Begin ................................................................. xiii

Intended audience .................................................................. xiii
About this guide .................................................................... xiv
Documentation conventions .................................................. xv
Common abbreviations .......................................................... xvi
Related publications ............................................................. xvii

1 Introducing Crosstalk .......................................................... 1-1

What is Crosstalk? .................................................................. 1-2
Hardware and software requirements ...................................... 1-5
How to use this guide ............................................................ 1-5
Using on-line help .................................................................. 1-6
  Accessing Help from a dialog box ......................................... 1-6
  Accessing Help from a menu bar .......................................... 1-6
Finding more information ...................................................... 1-7
Viewing Help and another window at the same time .............. 1-7

2 Getting Started with Crosstalk .............................................. 2-1

Overview ............................................................................... 2-2
Planning the installation ......................................................... 2-2
Installing Crosstalk ............................................................... 2-3
Starting Crosstalk .................................................................. 2-4
  Start-up steps .................................................................... 2-4
  The configuration program ............................................... 2-4
  The Open dialog box ......................................................... 2-5
Getting connected quickly ..................................................... 2-5
  Connecting to an information service ................................. 2-6
  Connecting to the DCA Connection bulletin board .......... 2-7
  Connecting to the Crosstalk Forum on CompuServe .......... 2-9
  Creating custom profiles using NEWCALL ..................... 2-10
3 Running a Communications Session .................................................. 3-1

Basics of a communications session .................................................. 3-2
  Introducing session profiles ............................................................. 3-2
    The default session profile .......................................................... 3-2
    Pre-defined session profiles ......................................................... 3-3
  Understanding the session window .................................................. 3-3
    The menu bar .............................................................................. 3-4
    The QuickBar .............................................................................. 3-5
    The status bar ............................................................................ 3-8
Creating and modifying custom session profiles ................................... 3-10
  Using the Settings pull-down options ................................................. 3-10
    Choosing a connection type ........................................................... 3-10
    Choosing a terminal emulator ......................................................... 3-13
    Choosing a file transfer protocol ................................................. 3-15
  Changing session settings ................................................................. 3-17
    Changing your system settings ...................................................... 3-19
Connecting to the host ........................................................................ 3-21
Reviewing data during a communications session .................................. 3-22
  What is the review buffer? ................................................................. 3-22
  Adjusting the size of the review buffer .............................................. 3-22
Transferring files .............................................................................. 3-23
  Sending a file .................................................................................. 3-24
  Receiving a file ............................................................................... 3-25
  Transferring files using Kermit ........................................................ 3-27
    Using Kermit with KCP ................................................................. 3-27
    Using Kermit without KCP ............................................................ 3-28
  Monitoring a file transfer ................................................................. 3-28
  Stopping a file transfer in progress .................................................. 3-30
Transferring ASCII files without using a protocol ................................ 3-30
Taking a snapshot of ASCII screen data .............................................. 3-31
Capturing ASCII screen data from the host ......................................... 3-32
Disconnecting a communications session ........................................... 3-33
Setting up your PC as a host .............................................................. 3-34
  Using ANSWER.XWP .................................................................. 3-34
Selecting Answer mode ..................................................................... 3-34
4 Using the Text Editor

Introducing the Text Editor ................................................. 4-2
The menu bar ................................................................. 4-3
The QuickBar ................................................................. 4-3
The status bar ................................................................. 4-4
Creating and modifying text .............................................. 4-5
Creating a new file .......................................................... 4-5
Opening an existing file .................................................... 4-5
Using the editor ............................................................... 4-6
Entering text ........................................................................ 4-6
Resizing the edit area .......................................................... 4-6
Displaying files as icons ...................................................... 4-6
Editing text ........................................................................... 4-7
Selecting text ................................................................. 4-7
Using the mouse ................................................................... 4-7
Using the keyboard ............................................................. 4-7
Reversing edit actions .............................................................. 4-8
Cutting text ......................................................................... 4-8
Copying text ......................................................................... 4-8
Pasting text .......................................................................... 4-9
Clearing text ................................................................. 4-9
Selecting all of the text ......................................................... 4-9
Combining edit functions ......................................................... 4-9
Duplicating text ................................................................. 4-9
Moving text within a file ....................................................... 4-10
Moving text to another file .................................................. 4-10
Finding and replacing text ................................................... 4-11
Finding a text string ............................................................ 4-11
Replacing a text string .......................................................... 4-12
Saving your files ............................................................... 4-13
Saving a new file ............................................................... 4-13
Saving an existing file .......................................................... 4-13
Saving an existing file under a new name ................................ 4-13
Printing your files ............................................................. 4-14
Choosing and configuring the printer ..................................... 4-14
Printing a file ................................................................. 4-14
Exiting the Text Editor ....................................................... 4-15
5 Using Scripts ................................................................................. 5-1

What are scripts? ........................................................................... 5-2
Using the Learn facility .................................................................. 5-2
  Recording your keystrokes .................................................. 5-3
  Running your Learn script .............................................. 5-4
Using the Script Editor ............................................................... 5-6
  Opening the Script Editor window .................................. 5-6
    The menu bar .............................................................. 5-7
    The QuickBar ........................................................... 5-8
    The status bar ........................................................... 5-9
  Creating a script ..................................................................... 5-10
  Compiling a script ................................................................... 5-10
    From a session window ........................................... 5-11
    From a Script Editor window .................................. 5-12
Running a script ........................................................................... 5-13
  From a session window ................................................. 5-13
  From the Script Editor .................................................. 5-13
Using a start-up script .............................................................. 5-14
Tracing a script ............................................................................. 5-14
Exiting the Script Editor ............................................................ 5-15

6 Using the QuickPad ........................................................................ 6-1

What is a QuickPad? ...................................................................... 6-2
Introducing QuickPad profiles ..................................................... 6-2
Understanding the QuickPad Editor window ............................. 6-3
  The menu bar .............................................................. 6-4
  The QuickBar ........................................................... 6-5
  The status bar ........................................................... 6-7
Using QuickPads during a session ................................................ 6-8
  Displaying a QuickPad on the screen .................................. 6-8
  Editing the QuickPad during a session .................................. 6-9
  Hiding a QuickPad from view ........................................... 6-9
  Redisplaying a hidden QuickPad ........................................ 6-10
  Removing a QuickPad from the screen ................................. 6-10
Creating a QuickPad .................................................................... 6-11
  Creating a new QuickPad .................................................. 6-11
  Opening an existing QuickPad ........................................... 6-11
Editing QuickPads ....................................................................... 6-12
  Placing an object on a QuickPad ......................................... 6-12
    Example 1: Placing a pushbutton on a QuickPad ............... 6-12
    Selecting QuickPad objects ........................................... 6-14
Copying objects .............................................................. 6-14
  Making multiple copies .............................................. 6-15
Moving objects ............................................................. 6-15
Resizing objects ......................................................... 6-15
Rearranging objects ..................................................... 6-16
  Using the QuickPad grid .............................................. 6-16
Deleting objects .......................................................... 6-17
Other customization features ......................................... 6-17
Assigning functions to objects on a QuickPad .................. 6-18
Assigning keystrokes to an object ................................... 6-18
  Example 2: Assigning keystrokes to a pushbutton on a
  QuickPad ........................................................................ 6-19
Assigning a script to an object ........................................... 6-19
Exiting the QuickPad Editor ............................................ 6-21

7 Remapping Your Keyboard ............................................. 7-1

Overview ........................................................................ 7-2
  Introducing keyboard profiles ....................................... 7-2
Understanding the Keyboard Editor window ..................... 7-2
  The menu bar ............................................................... 7-3
  The QuickBar .............................................................. 7-4
  The status bar ............................................................ 7-5
Displaying a keyboard profile ........................................... 7-6
  Displaying the working profile ....................................... 7-6
  Displaying a new profile ............................................... 7-6
  Displaying an existing profile ........................................ 7-6
  Displaying the default profile ......................................... 7-7
Remapping keyboard functions ........................................ 7-7
  Remapping modifier and combination keys ....................... 7-7
Copying a function ......................................................... 7-8
Deleting a function ......................................................... 7-8
Assigning keystrokes or scripts to keys .............................. 7-9
  Assigning keystrokes to a key ....................................... 7-9
  Assigning a script to a key .......................................... 7-10
Using a keyboard map during a session .............................. 7-12
Exiting the Keyboard Editor ............................................. 7-13
A  Connection Considerations ................................................. A-1
  Connection overview .......................................................... A-2
  Modem cables ..................................................................... A-2
    25-pin connectors .......................................................... A-2
    9-pin connectors ............................................................ A-3
  Connecting two systems directly (without a modem) .......... A-4
    Testing the connection .................................................. A-5
  Customizing your modem settings .................................... A-6
    Specifying custom modem settings ................................ A-7
  Network communications (INT14 and NASI) ..................... A-9
    INT14 support .................................................................. A-9
    NASI support .................................................................. A-10
      Basic mode .................................................................... A-11
        Advanced mode .......................................................... A-12
    Using serial ports .......................................................... A-15
    Using the COM3 or COM4 port ....................................... A-16

B  Terminal Emulation Considerations ................................. B-1
  Overview ............................................................................. B-2
    Changing fonts ............................................................... B-2
  ADDS Viewpoint+ emulator ................................................ B-2
  ANSI PC emulator ............................................................. B-3
    Using the keyboard ........................................................ B-3
    Adjusting other emulator settings .................................. B-3
  DEC emulators ................................................................. B-4
    Changing fonts ............................................................... B-5
    Using the keyboard ........................................................ B-5
    Host-controlled printing ................................................ B-5
    Character translation ..................................................... B-6
    Adjusting other emulator settings .................................. B-7
  FTTERM emulator ............................................................. B-7
  Hazeltine 1500 emulator .................................................... B-8
  Hewlett-Packard 700/94 and 2392A emulators ................ B-8
    Using the keyboard ........................................................ B-8
  IBM 3101 emulator ........................................................... B-9
    Using the keyboard ........................................................ B-9
  PC TERM emulator ........................................................... B-9
    Using the keyboard ........................................................ B-9
  Televideo 910, 920, 925 emulators ................................... B-10
C Conversion Issues .......................................................C-1

Converting files .............................................................C-2
  From Crosstalk XVI ....................................................C-2
  From Crosstalk for Windows 1.x ...................................C-2
  From Crosstalk Mark 4 ................................................C-2
  From PROCOMM PLUS ..............................................C-3

D International Considerations ........................................D-1

Choosing language support ..............................................D-2

E Product Support ..........................................................E-1

Receiving technical support .............................................E-2
  Bulletin boards and other services ................................E-2
  Updating or upgrading your software ..............................E-3

Index .............................................................................Index-1

Figures

3-1. The session window .................................................3-3
3-2. Connection Settings dialog box specifying a direct connection ...........................................3-11
3-3. Connection Settings dialog box specifying a modem connection .........................................3-12
3-4. Terminal Settings dialog box .....................................3-14
3-5. Sample File Transfer Settings dialog box ....................3-17
3-6. Session Settings dialog box with the general settings displayed ............................................3-18
3-7. Workstation Settings dialog box with the general settings displayed ....................................3-20
3-8. The file transfer status window .................................3-29
4-1. The Text Editor window ............................................. 4-2
4-2. Find dialog box ...................................................... 4-11
4-3. Replace dialog box ................................................... 4-12

5-1. Run Script dialog box ............................................... 5-5
5-2. Sample Script Editor window ..................................... 5-7
5-3. Compile Script dialog box ......................................... 5-11
5-4. Script Compiler message box ..................................... 5-12

6-1. The QuickPad Editor window ..................................... 6-4
6-2. The MCI Mail QuickPad displayed during a communications session ................................ 6-8
6-3. Button Properties dialog box ..................................... 6-13
6-4. Example of a pushbutton on a QuickPad ..................... 6-14

7-1. The Keyboard Editor window .................................... 7-3
7-2. Key Properties dialog box .......................................... 7-10

A-1. Custom Modem Settings dialog box .......................... A-8
A-2. Connection Settings dialog box specifying INT14 Redirector support ................................ A-10
A-3. Connection Settings dialog box specifying NASI-Basic support ........................................ A-12
A-4. Connection Settings dialog box specifying NASI-Advanced support ......................................... A-13
A-5. Connection Settings dialog box listing the available services on the network ................... A-14

Tables

1-1. Crosstalk features .................................................. 1-2
1-2. Help menu bar pull-downs ....................................... 1-7

2-1. Pre-defined session profiles ..................................... 2-6

3-1. Session menu bar pull-downs .................................. 3-4
3-2. QuickBar icons in a session window .......................... 3-5
3-3. The status bar parameters in a session window ................ 3-9
3-4. Choosing a file transfer protocol ............................. 3-16
3-5. Determining whether your protocol requires host preparation .................................. 3-23
3-6. Host menu options .................................................. 3-35
3-7. ANSWER variables ........................................... 3-37

4-1. Text Editor menu bar pull-downs ......................... 4-3
4-2. QuickBar icons in a Text Editor window ................. 4-4
4-3. Editing actions you can undo .............................. 4-8

5-1. Script Editor menu bar pull-downs ......................... 5-8
5-2. QuickBar icons in a Script Editor window ............... 5-9

6-1. Pre-defined QuickPad profiles ............................. 6-2
6-2. QuickPad Editor menu bar pull-downs .................... 6-5
6-3. QuickBar icons in a QuickPad Editor window .......... 6-6

7-1. Keyboard Editor menu bar pull-downs .................... 7-4
7-2. QuickBar icons in a Keyboard Editor window ......... 7-5

A-1. 9-pin serial port connector modem signals ............. A-3
A-2. DTE-to-DTE connection using 25-pin to 25-pin serial ports .................................................. A-4
A-4. DTE-to-DTE connection using 9-pin to 9-pin serial ports .............................................................. A-5
A-5. Special characters for customizing your modem settings ... A-6
Before You Begin

This guide contains information you need to install, configure, and use Crosstalk® for Windows. It also provides instructions for running a communications session with a host.

Intended audience

This guide is written for the following readers:

- PC users who want to communicate with a host computer
- Managers who want a basic understanding of Crosstalk and its features

Before reading this guide, you should have a working knowledge of the following operating environments:

- Microsoft® Windows™ 3.1
- DOS 3.3 or newer
This guide contains the following chapters:

Chapter 1, "Introducing Crosstalk," gives an overview of the features of Crosstalk, describes hardware and software requirements, and explains how to use Crosstalk's on-line help.

Chapter 2, "Getting Started with Crosstalk," covers the basics of using Crosstalk. It explains installation and configuration concepts and explains how to start and exit the program. This chapter also describes how to connect to bulletin boards, information services, and other host systems quickly.

Chapter 3, "Running a Communications Session," provides an overview of terminal emulation and explains how to use session profiles. It also includes guidelines for transferring and uploading files, taking screen snapshots and screen captures, and connecting and disconnecting a communications session with a host.

Chapter 4, "Using the Text Editor," describes how to create, modify, and save files using Crosstalk's built-in text editor. It also includes instructions for editing text, finding and replacing text strings, and printing files.

Chapter 5, "Using Scripts," describes how to record the keystrokes you enter for communications activities, such as logging on to the host, and explains how to create scripts using the Script Editor. It also provides information to help you compile, run, and trace scripts.

Chapter 6, "Using the QuickPad," provides an overview of the QuickPad™ Editor and explains how to set up and use a QuickPad during a communications session. It also explains how to assign keystrokes or scripts to objects on a QuickPad.

Chapter 7, "Remapping Your Keyboard," explains how to use keyboard profiles to remap your keyboard. It also explains how to assign keystrokes or scripts to specific keys.

Appendix A, "Connection Considerations," explains how to configure and use a modem. It also explains how to connect your PC to another computer without using a modem.
Appendix B, "Terminal Emulation Considerations," provides information about the DEC®, IBM®, VIDTEX™, Hewlett-Packard®, WYSE®, ADDS® Viewpoint®+, Hazeltine, Televideo, Lear-Siegler, TTY (teletype), and FTTERM terminal emulators.

Appendix C, "Conversion Issues," explains how to use the Convert utility to translate files created with other Crosstalk products and PROCOMM PLUS® to Crosstalk for Windows files.

Appendix D, "International Considerations," describes the international character sets supported by Crosstalk.

Appendix E, "Product Support," explains how to contact DCA® Customer Support and what information you should be prepared to provide. It also includes information about the DCA Connection bulletin board system.

This guide also includes an index.

---

**Documentation conventions**

The following documentation conventions are used in this guide:

- **bold**
  In command lines, bold represents information that you should enter exactly as shown.

- **[]**
  In command lines, square brackets indicate an option. To include an option, type only the information inside the brackets. Do not type the brackets unless they appear in bold.

- **italics**
  Italics represent variable information. In command lines, do not enter the words themselves in the command; enter the information they represent.

- **KEY**
  This typeface represents a specific key on the keyboard. If you have remapped the function originally mapped to the key, substitute the new key or key combination for the original.
KEY1-KEY2  Keys displayed with a hyphen between them are called combination keystrokes. To enter combination keystrokes, press one key and hold it down while you press one or more other keys. Release all the keys at the same time.

**Caution:**  This symbol means that a failure to follow the recommended procedure could result in a loss of data or damage to equipment or related products.

This symbol indicates the end of a note or caution.

**Common abbreviations**

The following abbreviations are used in this guide.

- **ACS**  Asynchronous communications server
- **ANSI**  American National Standards Institute
- **ASCII**  American Standard Code for Information Interchange
- **BBS**  Bulletin board system
- **CASL™**  Crosstalk Application Script Language
- **CD**  Carrier detect
- **CIS**  CompuServe Information Service
- **CTS**  Clear to send
- **DCE**  Data communications equipment
- **DDE**  Dynamic Data Exchange
- **DSR**  Data set ready
- **DTE**  Data terminal equipment
- **DTR**  Data terminal ready
- **INT14**  Interrupt 14
- **IRQ**  Interrupt request
- **KB**  Kilobyte
- **KCP**  Kermit™ Command Processor
- **LAN**  Local area network
- **MB**  Megabyte
- **MDI**  Multiple document interface
- **NASI**  NetWare® Asynchronous Server Interface
- **NACS**  Novell® NetWare Asynchronous Communications Server™
- **NCSI**  NetWare Communications Server Interface
Related publications

For information on the Crosstalk Application Script Language, refer to the *CASL Programmer’s Guide*.

For information on Crosstalk Mark 4, refer to the *Crosstalk Mark 4 User’s Guide*.

For information on Crosstalk XVI, see the *Crosstalk XVI User’s Guide*.

This guide does not attempt to provide a detailed explanation of the products, architectures, or standards developed by other companies or organizations. For information on Microsoft Windows 3.1, refer to the documentation provided by Microsoft. For information on DOS, refer to the documentation provided by your DOS vendor.
What is Crosstalk?

Using on-line help

Hardware and software requirements

How to use this guide

1-6

1-5

1-5

1-2
What is Crosstalk?

Crosstalk is a communications program that allows a PC running Microsoft Windows 3.1 to communicate with a host. The host can be any computer that Crosstalk is connecting to. A PC can connect to the host directly, through a modem attached to the PC, or through a modem shared on a LAN. The host does not have to be running Crosstalk in order for your PC to connect to it.

Crosstalk allows you to share information, computing power, and resources with other PCs, with bulletin boards and other on-line services, and with mainframe and minicomputer systems, such as IBM mainframes and DEC VAX® minicomputers.

Table 1-1 summarizes the features provided by Crosstalk. Each feature is covered in detail in later chapters.

Table 1-1. Crosstalk features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple document</td>
<td>You can view multiple windows concurrently, in either a cascaded or tiled format. You can reduce a window to an icon and close all windows simultaneously.</td>
</tr>
<tr>
<td>interface</td>
<td></td>
</tr>
<tr>
<td>Terminal emulation</td>
<td>You can use Crosstalk to emulate several terminals, including DEC, Hewlett-Packard, IBM, VIDTEX, TTY (teletype), WYSE, FTTERM, PC TERM, Hazeltine, Televideo, Lear-Siegler, and ADDS Viewpoint+ terminals.</td>
</tr>
<tr>
<td>File transfer</td>
<td>You can send and receive files to the host computer using one of the following file transfer protocols: X(Y)MODEM and variants, ZMODEM, Kermit, DART®, Crosstalk, IND$FILE, or CompuServe® B+.</td>
</tr>
</tbody>
</table>

continued
Table 1-1. **Crosstalk features** (cont.)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scripts</td>
<td>You can use the Learn facility to record and save a series of keystrokes to perform a task. You can also create, compile, and run scripts using the Script Editor.</td>
</tr>
<tr>
<td>QuickBar</td>
<td>The QuickBar displays icons that initiate tasks, such as file transfers and screen captures. You can start these tasks quickly by clicking on the icons.</td>
</tr>
<tr>
<td>QuickPad</td>
<td>During a communications session, you can execute commands using a QuickPad instead of your keyboard. A QuickPad is a small window that contains objects you click on to initiate host commands. You can also assign functions to different objects on a QuickPad, such as running scripts and sending keystrokes to the host.</td>
</tr>
<tr>
<td>Keyboard mapping</td>
<td>You can change the location of the characters and functions on your keyboard using the Keyboard Editor. You can also assign scripts and keystrokes to specific keys.</td>
</tr>
<tr>
<td>Screen capture</td>
<td>During a communications session, you can copy the contents of the terminal screen and save it in a file, or you can send it to a printer or to the Text Editor.</td>
</tr>
<tr>
<td>Uploading ASCII</td>
<td>During a communications session, you can send an ASCII text file to the host computer.</td>
</tr>
<tr>
<td>text files</td>
<td></td>
</tr>
<tr>
<td>Snapshot</td>
<td>You can copy the contents of your current screen and save it in a file or you can send it to a printer or to the Text Editor using Snapshot.</td>
</tr>
<tr>
<td>Text files</td>
<td>You can create, edit, save, and print text files using the Text Editor.</td>
</tr>
</tbody>
</table>
What is Crosstalk?

Table 1-1. Crosstalk features (cont.)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Session profiles</td>
<td>A session profile contains the name, telephone number, and description of the host system. The profile also contains the communication speed, terminal emulation settings, and keyboard definitions. The software includes a default session profile (NORMAL.XWP) and several profiles that have already been configured and are ready to use to connect to the host.</td>
</tr>
<tr>
<td>Workspace files</td>
<td>You can specify a workspace file (*.XWW) from the Open dialog box. Workspace files contain references to all open windows and their current positions.</td>
</tr>
<tr>
<td>Screen customization</td>
<td>You can customize your screen display, such as the character fonts and colors and audible signals, by modifying the terminal emulation settings.</td>
</tr>
<tr>
<td>DDE support</td>
<td>You can link Windows applications using a protocol called Dynamic Data Exchange. Using DDE, transfer data on a one-time basis, or establish an ongoing dialog with other applications.</td>
</tr>
</tbody>
</table>
Hardware and software requirements

Crosstalk requires the following hardware and software:

- A COMPAQ® 286/386, IBM PC/AT®, IBM PS/2® (except Model 30), or compatible PC
- 400 KB of free system RAM plus the memory needed to run Microsoft Windows
- 3 MB of free hard disk space
- Microsoft Windows 3.1, running in standard or enhanced mode
- An asynchronous autodial modem (over 70 brands and models are supported). The configuration program lists the types of modems Crosstalk supports.
- A mouse or compatible pointing device supported by Microsoft Windows 3.1
- A video adapter and monitor supported by Microsoft Windows 3.1

How to use this guide

This guide is designed for both novice and expert users and is organized to let you work at your own pace. Everyone should read this chapter and Chapter 2, "Getting Started with Crosstalk." These chapters start with the basics—those tasks you'll need to know to get started as quickly as possible. Once you understand the basics, you can skip around the rest of the guide as needed.

This chapter introduces Crosstalk and explains how to use the on-line help. It also lists the hardware and software requirements. Most of the information in this chapter is not available on line.

Once you have read this chapter, turn to Chapter 2, which covers how to install the software. Review this information before you begin the installation. After you have installed the software, you can start Crosstalk and configure your host connection. Instructions for configuring the software are in Chapter 2 and in the on-line help.
Using on-line help

You can find most of the information you need about Crosstalk right on line. Whatever you are doing, you can ask for help. The on-line help provides detailed descriptions of dialog boxes and the choices you can make when completing them. For example, you can use on-line help when you have a question about specific dialog box items or need assistance in completing a task. Glossary terms are also provided.

You can access on-line help from the Help pull-down on an action bar or by choosing the Help pushbutton in a dialog box.

Accessing Help from a dialog box

Most dialog boxes contain a Help pushbutton. Choose this pushbutton to access specific information and instructions about the dialog box and the items in it.

Accessing Help from the menu bar

To see an overview of Crosstalk, choose the Help pull-down from the menu bar. Table 1-2 describes the Help pull-down options.

<table>
<thead>
<tr>
<th>Table 1-2. Help menu bar pull-downs</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
</tr>
<tr>
<td>Help on Help</td>
</tr>
<tr>
<td>Help for...</td>
</tr>
<tr>
<td>Contents</td>
</tr>
</tbody>
</table>
Using on-line help

<table>
<thead>
<tr>
<th>Option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents (cont.)</td>
<td>You can also use the keyword search feature to find information. Simply choose the Search button and follow the instructions in the dialog box.</td>
</tr>
<tr>
<td>About</td>
<td>Displays the name and release number of the product. It also displays a copyright statement.</td>
</tr>
</tbody>
</table>

Finding more information

Once you are in the Help system, you can display additional information about some topics or go to related topics. Look for the distinctive color and highlighting. To access this information, click on a highlighted item. Additional details or step-by-step instructions are displayed. To return to Crosstalk, close the Help window.

Viewing Help and another window at the same time

You can view a window and its related Help instructions at the same time. This is useful if you want to view Help while you perform a task.

To do so, follow these steps:

1. Access Help by selecting the Help pushbutton in a dialog box or by selecting an option from the Help pull-down.
2. If the Help window is full-screen size, reduce it by choosing the restore button in the upper-right corner of the Window.
3. Resize the Help window, if necessary, by dragging the top, bottom, sides, and corners.
4. Move the Help window to the desired location by dragging the title bar.
5. Activate the other window by clicking on it.
6. Resize and reposition the window so that it does not overlap the Help Window. Do this by repeating steps 2 to 4.

For complete instructions on viewing on-line help, choose Using Windows Help from the Help pull-down.
GETTING STARTED WITH CROSSTALK

Overview 2-2
Planning the installation 2-2
Installing Crosstalk 2-3
Starting Crosstalk 2-4
Getting connected quickly 2-5
Disconnecting a session 2-11
Using workspace files 2-11
Exiting Crosstalk 2-12
Overview

This chapter is designed to help you start using Crosstalk quickly. All the basic information you need is provided here, as well as a quick method for starting a communications session. (For a more detailed discussion of communications sessions, refer to Chapter 3, "Running a Communications Session.")

The following topics are covered:

- Planning the installation
- Installing Crosstalk
- Starting Crosstalk
- Getting connected quickly
- Disconnecting a session
- Using workspace files
- Exiting Crosstalk

Planning the installation

Before you begin the installation, make sure you do the following:

- Install the required hardware and software.

- Determine the type of connections you are using to communicate with a host: a direct connection (no modem required), a modem attached to your PC, or a modem shared on a LAN.

- If you're using a modem to connect to the host, note your communications port assignment. This is usually COM1, COM2, COM3, or COM4. You are prompted for this information during the configuration process. If you're not sure which port to use, choose the default port, COM1.
Installing Crosstalk

Once you have checked your hardware and software, you're ready to run the Setup program to install Crosstalk. Follow these steps:

1 Insert the diskette labeled Crosstalk for Windows Disk 1 in any available disk drive on your PC.

2 Start Windows.

3 Choose Run from the Windows Program Manager File pull-down.

4 In the Command Line edit box, enter the diskette drive and the program name as follows:

   drive:\setup

   The Crosstalk Setup dialog box is displayed.

5 Follow the instructions on the screen to install Crosstalk for the first time or to upgrade your software to the latest version.

   After you finish installing the software, the Setup program asks whether you want to display the README.TXT file after exiting the program. You should read this file for any last-minute changes or instructions.

6 Exit Windows, making sure you save your changes.

7 Restart Windows.

The Setup program performs the following tasks:

- Copies files from the installation diskettes to the specified drive and directory.

- Builds the Crosstalk group icon and application icon.

- Automatically creates the XTALK.INI system file. For more information on the XTALK.INI file and other disk files, refer to the README.TXT file.

- Installs the *.FON and *.FOT font files used by Crosstalk.
Installing Crosstalk

- Updates the WIN.INI system file. The other system files (AUTOEXEC.BAT and CONFIG.SYS) are not modified during installation.

- Establishes file associations in the WIN.INI file for the following file extensions: .XWP, .XWQ, .XWK, .XWS, .XWW, and .XWC. For more information about file associations, see your Windows documentation.

Starting Crosstalk

Once you have installed Crosstalk, you are ready to start the software. This section explains how. It also describes the configuration program, which runs automatically when you start Crosstalk for the first time; the Open dialog box; and workspace files.

Start-up steps

To start Crosstalk from the Windows Program Manager, follow these steps:

1. Double-click on the Crosstalk group icon in the Program Manager window. The Crosstalk application icon appears in the Crosstalk group window.

2. Double-click on the Crosstalk application icon.

   If you are starting Crosstalk for the first time, a simple configuration program runs automatically and prompts you for information about your PC and modem, as explained in the next section.

   If you have started Crosstalk before, the Open dialog box is displayed. This is the starting point for establishing connections, as explained in "The Open Dialog Box," later in this chapter.

The configuration program

When you start Crosstalk for the first time, a simple configuration program (CONFIG.XWS) begins running automatically. The configuration program prompts you for specific information about your PC and modem; just follow the instructions on your screen. The configuration program sets up Crosstalk based on your responses to the prompts.
If you install a different modem later on or if you need to change your configuration information, simply run the configuration program again. You do not need to re-install Crosstalk.

Once the configuration program finishes, the Crosstalk main window is displayed. From here, you can choose New or Open from the File pull-down to open a new or existing file.

The Open dialog box

Typically, the first thing you see after starting Crosstalk is the Open dialog box, which contains dialing directory entries. You can think of the Open dialog box as a type of phone book, or dialing directory. From here, you can initiate a connection to the host computer.

Note the list box called List Files of Type, located at the bottom of the Open dialog box. Use this list box to display a specific type of file in the Files list box. For example, if you want to see all the text files in your current directory, choose Text Files from the List Files of Type list box. A list of text files with the .TXT extension is displayed in the Files list box. Then choose a file from this list box and choose OK. The specified file is displayed.

Getting connected quickly

This section is designed to help you establish a host connection as quickly as possible. You'll learn the fastest way to connect to an information service, bulletin board, or any other host computer. (If you find that you need more detailed information, refer to Chapter 3, "Running a Communications Session.")

Crosstalk comes with several session profiles that are configured and ready to use. These pre-defined profiles help simplify the process of connecting to a host system. They contain the parameters required for a communications session, such as the name, telephone number, and password for accessing the host.

If you need to connect to a host for which there is no pre-defined session profile, you must create your own custom session profile. The fastest and simplest way to do this is to use the NEWCALL utility, which is described in "Creating Custom Profiles Using NEWCALL," later in this chapter.
To learn how to use some of the session profiles that come with Crosstalk to connect to information services, continue with the next section.

Information services include electronic mail systems and news and information retrieval services. Before you can connect to an information service, you must contact the service to register for an account. When you register, you receive a telephone number, password, and user ID.

Crosstalk comes with several session profiles that are already defined and ready to use to connect to the following services. Table 2-1 lists these session profiles and describes their function.

<table>
<thead>
<tr>
<th>This session profile...</th>
<th>Connects your PC to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATT.XWP</td>
<td>AT&amp;T Mail service</td>
</tr>
<tr>
<td>CSERVE.XWP</td>
<td>Crosstalk Forum on CompuServe</td>
</tr>
<tr>
<td>DCABBS.XWP</td>
<td>DCA Connection bulletin board</td>
</tr>
<tr>
<td>DELPHI.XWP</td>
<td>Delphi information service</td>
</tr>
<tr>
<td>DIALOG.XWP</td>
<td>Dialog information service</td>
</tr>
<tr>
<td>DOWJONES.XWP</td>
<td>Dow Jones News/Retrieval service</td>
</tr>
<tr>
<td>GENIE.XWP</td>
<td>General Electric Network for Information Exchange service</td>
</tr>
<tr>
<td>LEXIS.XWP</td>
<td>Mead Data LEXIS or NEXIS service</td>
</tr>
<tr>
<td>MCI.XWP</td>
<td>MCI Mail service</td>
</tr>
<tr>
<td>NEWSNET.XWP</td>
<td>NewsNet service</td>
</tr>
<tr>
<td>OAG.XWP</td>
<td>Official Airlines Guide</td>
</tr>
</tbody>
</table>
Getting connected quickly

To connect to an information service using one of the session profiles listed here, follow these steps:

1. Make sure your modem is connected properly, turned on, and ready to use.

2. Choose Open from the File pull-down. The Open dialog box is displayed.

3. Choose the session profile that corresponds with the service you want to connect to from the Files list box and choose OK. The specified profile is displayed. Then the Calling dialog box is displayed.

   **Note:** If this is your first time accessing the service, a Script Dialog box appears in the session window and prompts you for your user ID and password.

   After you enter this information, the last prompt asks whether you want to connect to the information service now. Choose OK.

4. If you want to see the status of the connection in the Modem Dialog area, select the Display Modem Dialog check box.

   If you receive a busy signal, Crosstalk redials the information service automatically.

   **Note:** If you need to reconnect a session that’s been disconnected, choose Connection and then Connect from the Action pull-down.

To connect to an information service other than the ones listed in this section, you must create a custom session profile for each service you plan to communicate with on a regular basis. The simplest way to do this is to use the NEWCALL utility, as explained in "Creating Custom Profiles Using NEWCALL," later in this chapter.

**Connecting to the DCA Connection bulletin board**

Crosstalk lets your PC connect to bulletin boards such as the DCA Connection bulletin board. With the DCA bulletin board, you can find the latest information about Crosstalk and communicate with other DCA users. You can learn about product announcements, news, and technical specifications; private and public e-mail; technical support, technical tips, and product histories; and a private/public user's file exchange for sending files to and from DCA engineers and other users.
To connect to the DCA Connection, you can use the pre-defined session profile DCABBS.XWP that comes with the software. Follow these steps:

1. Make sure your modem is connected properly, turned on, and ready to use.

2. Choose Open from the File pull-down. The Open dialog box is displayed.

3. Choose DCABBS.XWP from the Files list box and choose OK. The DCABBS.XWP session window is displayed. Then the Calling DCABBS.XWP dialog box is displayed.

   **Note:** If this is your first time connecting to this bulletin board, a Script Dialog box appears in the DCABBS.XWP session window and prompts you for registration information, such as your user ID and password, and whether you're calling long distance. You are also prompted for configuration information, such as your communications port and modem speed. Most systems can safely use the default settings.

   After you enter this information, the last prompt asks whether you want to connect to the bulletin board now. Choose Yes.

4. If you want to see the status of the connection in the Modem Dialog area, select the Display Modem Dialog check box.

   **Note:** If you receive an error message saying "hardware not present," your system is not configured properly. Run the configuration program (CONFIG.XWS) again and choose a different communications port. Then try connecting to the bulletin board again.

   If you receive a busy signal, Crosstalk redials the bulletin board automatically.

   Once the connection is made, you are automatically logged on to the DCA Connection and an introductory screen is displayed. Follow the login instructions on your screen.

   **Note:** If you need to reconnect a session that's been disconnected, choose Connection and then Connect from the Action pull-down.

To connect to bulletin boards other than the DCA Connection, you must create a custom session profile for each bulletin board you plan to communicate with on a regular basis. The simplest way to do this is to
use the NEWCALL utility, which is explained in "Creating Custom Profiles Using NEWCALL," later in this chapter.

The Crosstalk Forum on CompuServe supports all DCA Crosstalk products. This forum serves as a central location for users to exchange information, transfer files, and receive technical assistance from DCA engineers and other users.

To connect to the Crosstalk Forum, use the session profile CSERVE.XWP that comes with the software. The settings in this profile are already defined and ready to use to connect with CompuServe.

Follow these steps to connect to the Crosstalk Forum:

1. Make sure your modem is connected properly, turned on, and ready to use.

2. Choose Open from the File pull-down. The Open dialog box is displayed.

3. Choose the CSERVE.XWP profile from the Files list box and choose OK. The CompuServe session window is displayed. Then the Calling CSERVE.XWP dialog box is displayed.

   Note: If this is your first time connecting to CompuServe, a Script Dialog box appears in the session window and prompts you for the type of network you're on, the CompuServe telephone number, your user ID and password, and other configuration information.

   After you enter this information, the last prompt asks whether you want to connect to CompuServe now. Choose Yes.

4. If you want to see the status of the connection in the Modem Dialog area, select the Display Modem Dialog check box.

   If you receive a busy signal, Crosstalk redials the bulletin board automatically. Once the connection is made, you are logged on to CompuServe.
Getting connected quickly

5 Enter the following command at the CompuServe prompt (!):

   GO XTALK

   Your screen displays instructions on how to join the forum. Data library 10 and message area 10 are reserved for Crosstalk for Windows users.

   Note: If you need to reconnect a session that's been disconnected, choose Connection and then Connect from the Action pull-down.

Creating custom profiles using NEWCALL

You may need to connect to a bulletin board or information service for which there is no session profile already configured and ready to use. If so, you must create your own custom session profile. The easiest way to do this is with the NEWCALL utility that comes with Crosstalk.

NEWCALL prompts you for specific information about your PC and modem, creates a session profile based on your responses, and then allows you to connect to the host immediately—all in a few easy steps.

To use NEWCALL, follow these steps:

1 From the File pull-down, choose Open. The Open dialog box is displayed.

2 Enter NEWCALL.XWP in the File Name edit box. Or you can choose NEWCALL.XWP from the Files list box.

3 Choose OK. NEWCALL prompts you for information, such as the host system's name, description, telephone number, and the terminal emulator and file transfer protocol that the host requires. You're also prompted to assign a name to the custom session profile you're creating.

4 The last prompt asks whether you want to connect to the host now. Choose Yes or No.

In the future, you can connect to the same host system again by using this session profile.

   Note: You may find that you need to change some of the settings in the session profile you just created with NEWCALL. To do this, you need to use the options on the Settings pull-down. See Chapter 3, "Running a Communications Session," for more information.
Disconnecting a session

When you are ready to disconnect your communications session with the host, follow these steps:

1. Log off the host using the appropriate logoff procedure.
2. If this logoff procedure does not disconnect the session automatically, choose Connection and then Disconnect from the Action pull-down.

Using workspace files

Before proceeding with the rest of this guide, take a moment to learn how to use Crosstalk's Save Workspace feature. You can use this feature with any of the windows described in this guide.

The Save Workspace feature allows you to save all open windows in their current position to a single workspace file. When you open a workspace file in the future, all the windows are displayed in the same size and position in which they were saved. Workspace files have the file extension .XWW.

The following paragraphs explain how to save your windows to a workspace file and then open the workspace file.

Saving a workspace file

To save all currently opened windows to a workspace file, follow these steps:

1. Choose Save Workspace from the File pull-down. The Save Workspace dialog box is displayed.
2. Type the name of the workspace file you are saving in the File Name edit box.
3. Choose OK.
Using workspace files

**Opening a workspace file**

To open a workspace file, follow these steps:

1. Choose Open from the File pull-down. The Open dialog box is displayed.

2. Type the name of the workspace file you are opening in the File Name edit box. (You can also choose Workspace File (*.XWW) from the list box called List Files of Type at the bottom of the dialog box. A list of workspace files is displayed in the Files list box. Then choose a file from this list box.)

3. Choose OK. The windows are displayed in the same size and position that they were saved in.

**Exiting Crosstalk**

When you are ready to exit Crosstalk, choose Exit from the File pull-down. You are prompted to save any changes you've made in each window before exiting the application.

⚠️ **Caution:** Before you turn off or reboot your PC, disconnect any active communications sessions and exit Crosstalk and Windows to prevent host connection problems or possible loss or corruption of data.
RUNNING A COMMUNICATIONS SESSION

Basics of a communications session 3-2
Creating and modifying custom session profiles 3-10
Connecting to the host 3-21
Reviewing data during a communications session 3-22
Transferring files 3-23
Transferring ASCII files without using a protocol 3-30
Taking a snapshot of ASCII screen data 3-31
Capturing ASCII screen data from the host 3-32
Disconnecting a communications session 3-33
Setting up your PC as a host 3-34
Basics of a communications session

In Chapter 2, "Getting Started with Crosstalk," you learned a quick way to connect to an information service or a bulletin board using pre-defined session profiles. This chapter describes session profiles in greater detail and covers more advanced communications features, such as file transfers, text uploads, and screen captures. This chapter also explains how to set up your PC to operate as a host computer so other computers can connect to it.

The following sections provide a general overview of a communications session. Read these sections before establishing a communications session with the host. Then start the communications session, as described in "Connecting to the Host," later in this chapter.

Session profiles are files that define how a communications session operates. You can simplify the host connection process by setting up a session profile for each computer you plan to communicate with on a regular basis.

A session profile (*.XWP) contains the parameters required for a communications session, such as the name, telephone number, and description of the host system. The session profile also contains the connection, terminal emulation, and file transfer protocol settings. By adjusting these parameters, you can instruct Crosstalk to operate using methods compatible with the host computer.

The following paragraphs describe the session profiles that come with Crosstalk—the default and the pre-defined.

Your default session profile is created during the configuration process, when you are prompted for information about your modem and PC. The configuration program creates a default session profile, NORMAL.XWP, based on your responses to these questions. When you create a new session profile, the default settings in NORMAL.XWP are automatically loaded and used as a basis for creating new session profiles.
Basics of a communications session

**Note:** If you find yourself making the same changes to every session profile you create, you should modify the settings in the NORMAL.XWP profile. The modified NORMAL.XWP settings will then apply to all new session profiles you create.

**Pre-defined session profiles**

Crosstalk comes with several pre-defined session profiles that are ready to use for a communications session. For instructions on how to use these session profiles to connect to bulletin boards, information services, or any other host computer, refer back to Chapter 2, "Getting Started with Crosstalk."

**Understanding the session window**

When you open a session profile, the window shown in Figure 3-1 is displayed.

![Figure 3-1. The session window](image)

The session window includes a menu bar, QuickBar, and status bar. The following paragraphs explain these items.
**The menu bar**

Use the menu bar pull-downs, shown in Figure 3-1, to create and edit a session profile, access scripts and QuickPads, transfer files, capture and take snapshots of screen, upload text files, and connect and disconnect a communications session. You can also use the menu bar pull-downs to open, close, and rearrange your session windows, and access on-line help. Table 3-1 describes each pull-down.

<table>
<thead>
<tr>
<th>Pull-down</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Lets you create, modify, and save session profiles; control printing; and exit Crosstalk. This pull-down also lists the names of the last four profiles you've opened.</td>
</tr>
<tr>
<td>Edit</td>
<td>Provides options to copy text from the screen to the clipboard, paste text from the clipboard to the host, clear the screen and review buffer, and highlight and copy text to the clipboard in a table format.</td>
</tr>
<tr>
<td>Settings</td>
<td>Lets you change connection and emulation parameters, file transfer and communications session settings, and general system settings.</td>
</tr>
<tr>
<td>Actions</td>
<td>Provides options to establish a connection with the host, disconnect a communications session, clear and reset the terminal screen, and transfer files.</td>
</tr>
<tr>
<td>Script</td>
<td>Provides options to record keystrokes and run scripts.</td>
</tr>
<tr>
<td>QuickPad</td>
<td>Lets you specify the QuickPads you want to use or remove from memory. It also provides options to show or hide QuickPads from view and list all open QuickPads.</td>
</tr>
<tr>
<td>Window</td>
<td>Provides options to open, rearrange, and close windows; and lists all open windows.</td>
</tr>
<tr>
<td>Help</td>
<td>Provides on-line instructions for creating, editing, and printing your files.</td>
</tr>
</tbody>
</table>
The QuickBar displays icons that initiate tasks, such as file transfers and screen captures. You can start these tasks quickly by clicking on the icons. Table 3-2 describes the QuickBar icons displayed when you use a session profile to connect to the host.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="file_icon.png" alt="Icon" /></td>
<td>Displays the New dialog box. Use this dialog box to create a new file.</td>
</tr>
<tr>
<td><img src="open_icon.png" alt="Icon" /></td>
<td>Displays the Open dialog box. Use this dialog box to open an existing file.</td>
</tr>
<tr>
<td><img src="save_icon.png" alt="Icon" /></td>
<td>Saves your changes to the currently displayed session profile. If this is a new session profile, the Save As dialog box is displayed.</td>
</tr>
<tr>
<td><img src="connection_icon_connected.png" alt="Icon" /></td>
<td>Indicates that your PC is connected to the host computer. Click on this icon to disconnect the session. The QuickBar displays either this icon or the following icon, depending on the status of the connection.</td>
</tr>
<tr>
<td><img src="connection_icon_disconnected.png" alt="Icon" /></td>
<td>Indicates that your PC is not connected to the host computer. Click on this icon to establish a connection. The QuickBar displays either this icon or the preceding icon, depending on the status of the connection.</td>
</tr>
</tbody>
</table>

continued
### Table 3-2. QuickBar icons in a session window (cont.)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Send Files Icon" /></td>
<td>Displays the Send Files dialog box. Use this dialog box to send a file to the host using the file transfer protocol specified for the currently displayed session profile. <strong>Note:</strong> This icon is grayed if your PC is not connected to the host.</td>
</tr>
<tr>
<td><img src="image" alt="Receive Files Icon" /></td>
<td>Displays the Receive Files dialog box. Use this dialog box to receive a file from the host using the file transfer protocol specified for the currently displayed session profile. <strong>Note:</strong> This icon is grayed if your PC is not connected to the host.</td>
</tr>
<tr>
<td><img src="image" alt="Upload Text Icon" /></td>
<td>Displays the Upload Text dialog box. Use this dialog box to upload an ASCII file to the host. <strong>Note:</strong> This icon is grayed if your PC is not connected to the host.</td>
</tr>
<tr>
<td><img src="image" alt="Run Script Icon" /></td>
<td>Displays the Run Script dialog box. Use this dialog box to specify the script you want to run. If you press this button while a script is running, the script will stop.</td>
</tr>
</tbody>
</table>

continued
### Table 3-2. QuickBar icons in a session window (cont.)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
</table>
| ![Camera Icon](camera_icon.png) | Captures the text on your terminal screen and sends it to the destination specified in the Session Settings dialog box.  
**Note:** This icon is grayed if your PC is not connected to the host. |
| ![Arrow Icon](arrow_icon.png) ![Snapshot Icon](snapshot_icon.png) | Displays the screen snapshot settings in the Session Settings dialog box. Use this dialog box to specify the destination of the screen you're copying using Snapshot. You can send the screen data to a text file, printer, or the Text Editor. This icon is grayed if your PC is not connected to the host.  
**Note:** The icon to the right of the arrow varies, depending on the destination you have specified. |
| ![Capture Icon](capture_icon.png) | Captures the text on your terminal screen. You can capture multiple screens continuously, including the text that has scrolled off your screen. If Capture is already on, choosing this option again stops the screen capture. All the text received from the host is then sent to the destination specified in the Session Settings dialog box.  
**Note:** The icon to the right of the arrow varies, depending on the destination you have specified. |

---

*continued*
Table 3-2. QuickBar icons in a session window (cont.)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Capture Icon" /></td>
<td>Displays the capture settings in the Session Settings dialog box. Use this dialog box to specify the destination of the screen you're capturing using the Capture tool. You can send the screen capture to a text file, printer, or the Text Editor. This icon is grayed if your PC is not connected to the host.</td>
</tr>
<tr>
<td><img src="image" alt="Hide QuickPads Icon" /></td>
<td>Hides any QuickPads associated with the currently displayed session profile. If the QuickPads are already hidden, choosing this icon displays them.</td>
</tr>
</tbody>
</table>

The status bar

The status bar at the bottom of the screen contains information about the current communications session. You can quickly change many of the parameters on the status bar by double-clicking on the parameter. When you do this, the associated dialog box is displayed, allowing you to make changes to the parameter.

Table 3-3 describes the information in the status bar of a session profile.
### Table 3-3. The status bar parameters in a session window

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Message area</td>
<td>Indicates the current status of a communications session. When you double-click on this area, the Session Settings dialog box appears.</td>
</tr>
<tr>
<td>On-line timer</td>
<td>Shows how long the current connection has been active.</td>
</tr>
<tr>
<td>Connection setting</td>
<td>Displays the type of communications device your PC is using to connect to the host. Your PC can use a serial port, modem, or an async server to connect to the host. When you double-click on this area, the Connection Settings dialog box is displayed, allowing you to make changes to the communications parameters or specify a different connection type.</td>
</tr>
<tr>
<td>Terminal type</td>
<td>Displays the type of terminal you are emulating. When you double-click on this area, the Terminal Settings dialog box is displayed, allowing you to make changes to your terminal emulation screen or specify a different terminal emulator.</td>
</tr>
<tr>
<td>File transfer protocol</td>
<td>Shows the file transfer protocol you are using. When you double-click on this area, the File Transfer dialog box is displayed, allowing you to make changes to the current protocol settings or specify a different file transfer protocol.</td>
</tr>
</tbody>
</table>
Creating and modifying custom session profiles

If you need to connect to a host for which there is no pre-defined session profile, you must create your own custom session profile. Crosstalk provides the following two methods for creating custom profiles:

- Using the NEWCALL utility.
- Using the options under the Settings pull-down.

In Chapter 2, "Getting Started with Crosstalk," you learned how to create a custom session profile quickly using NEWCALL. For more information on NEWCALL, refer back to Chapter 2.

The options on the Settings pull-down give you more flexibility than NEWCALL. This section explains how to set up a custom session profile using the Settings pull-down options.

**Note:** Keep in mind that regardless of which method you use to create your custom profile, you must use the Settings pull-down options to modify it.

**Using the Settings pull-down options**

When you create a custom profile using the options under the Settings pull-down, you have more choices and control over the settings in the profile than the NEWCALL utility allows.

All session profiles contain the following information: a connection type, a terminal emulator, a file transfer protocol, system settings, and session settings.

This section explains how to specify this information when you create or modify a custom session profile.

**Choosing a connection type**

You can connect your PC to the host computer either directly or through a modem. This section explains both connection types.
Creating and modifying custom session profiles

Configuring a direct connection

To configure your PC to connect to the host directly, without using a modem, configure your custom profile for a direct connection. Follow these steps:

1. From the File pull-down, choose New. The New dialog box is displayed.
2. Choose the Session icon and choose OK. An untitled session window is displayed.
3. Choose Connection from the Settings pull-down. The Connection Settings dialog box is displayed.
4. Choose Local COM Port (Direct Connect) from the Connection list box. The default settings for a direct connection are displayed, as shown in Figure 3-2.

![Figure 3-2. Connection Settings dialog box specifying a direct connection](image-url)
Creating and modifying custom session profiles

5 Modify the settings as needed. Most systems can use the default settings safely. Keep in mind that the settings you choose must match the host computer's communications parameters. See the on-line help for more details about these settings.

6 Choose OK.

Configuring a modem connection

To configure your PC to connect to the host using a modem, configure your session profile for a modem connection. Follow these steps:

1 From the File pull-down, choose New. The New dialog box is displayed.

2 Click on the Session icon and choose OK. An untitled session window is displayed.

3 Choose Connection from the Settings pull-down. The Connection Settings dialog box is displayed.

4 Choose Local Modem from the Connection list box. The default dialing settings are displayed, as shown in Figure 3-3.

![Connection Settings dialog box](image)

Figure 3-3. Connection Settings dialog box specifying a modem connection
5 Enter the telephone number of the host computer and modify the other dialing settings as needed.

6 If you need to modify the settings for your modem's connection, choose the Connection icon from the left side of the dialog box.

7 If you need to change the type of modem you are using, choose the Modem icon from the left side of the dialog box. The list box displays the types of modems supported by Crosstalk.

8 If you need to modify general system settings, such as your local and long distance access numbers, choose the Workstation icon.

9 Choose OK.

Choosing a terminal emulator

You also need to specify the type of terminal your PC will emulate during the communications session. During emulation, your PC screen will look and operate like this terminal. Crosstalk emulates the following terminals:

- ADDS Viewpoint+
- ANSI PC
- DEC VT52, VT100, VT102, VT220, VT320
- FTTERM (3270 Async)
- Hazeltine 1500
- Hewlett-Packard 700/94 and 2392A
- IBM 3101 Model 10
- Lear-Siegler ADM3a
- PC TERM
- Teletype (TTY)
- Televideo 910, 920, 925
- VIDTEX (CompuServe)
- WYSE 50, 50+ and 60

The terminal that Crosstalk is emulating must be supported by your host computer. If you are not sure which emulator the host requires, contact the host system administrator for assistance.
Creating and modifying custom session profiles

Specifying an emulator

To select the terminal emulator you want to use, follow these steps:

1. With a session profile open, choose Terminal from the Settings pull-down. The Terminal Settings dialog box, similar to the one shown in Figure 3-4, is displayed.

2. Choose a terminal emulator from the Terminal list box. The current settings for the emulator you just selected are displayed.

3. Modify the settings as needed. Most systems can use the default settings safely. (See the on-line help for more details.)

4. Choose OK.

Figure 3-4. Terminal Settings dialog box
Customizing your screen display

You can change the appearance of your terminal screen by changing the settings in the Terminal Settings dialog box. These settings determine the characteristics of your screen display, such as the shape of the cursor and the color of the characters on the screen.

To access the Terminal Settings dialog box (shown in Figure 3-4), follow the instructions in the previous section, "Specifying an Emulator."

The following instructions describe how to modify your screen display settings. Note that some of the terminal emulators display additional icons, allowing you to customize other features of your screen display. If you need more information about these icons, refer to the on-line help.

Once the Terminal Settings dialog box is displayed, follow these steps:

1. To change the color of the characters on your screen, choose the Colors icon from the left side of the dialog box. The default color settings are displayed. Modify these settings as needed.

2. To change the character font style, choose the Fonts icon. The default character font settings are displayed. Modify these settings as needed.

3. Choose OK.

Choosing a file transfer protocol

You also need to tell Crosstalk which file transfer protocol your PC is using to transmit files to and from the host. A file transfer protocol is a standardized method of exchanging files between computers. The protocol manages the entire file transfer process and error checking. Error checking ensures that the file is not altered during the transmission.

Note: File transfer protocol rules and conventions are compatible in most communications packages. The host does not have to run Crosstalk in order to exchange files with your PC. However, your PC and the host must use the same file transfer protocol to be able to exchange files.

Each protocol is suited to a particular purpose or type of host system. If your host uses more than one file transfer protocol, contact your host
system administrator to see which protocol is best to use with Cross-talk. Table 3-4 lists the available protocols and their corresponding hosts.

Table 3-4. Choosing a file transfer protocol

<table>
<thead>
<tr>
<th>If the host is running...</th>
<th>Use this protocol...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crosstalk XVI</td>
<td>Crosstalk</td>
</tr>
<tr>
<td>Remote2</td>
<td>Crosstalk; XMODEM; YMODEM</td>
</tr>
<tr>
<td>Crosstalk Mark 4</td>
<td>DART; ZMODEM</td>
</tr>
<tr>
<td>Crosstalk Communicator</td>
<td>ZMODEM</td>
</tr>
<tr>
<td>Crosstalk for Windows</td>
<td>DART; ZMODEM</td>
</tr>
<tr>
<td>CompuServe</td>
<td>CompuServe B+</td>
</tr>
<tr>
<td>Bulletin board</td>
<td>XMODEM (including any variants); YMODEM (including any variants); ZMODEM</td>
</tr>
<tr>
<td>VAX minicomputer</td>
<td>Kermit; ZMODEM</td>
</tr>
<tr>
<td>IBM mainframe</td>
<td>IND$FILE</td>
</tr>
<tr>
<td>MCI Mail</td>
<td>ZMODEM</td>
</tr>
<tr>
<td>Any PC communications</td>
<td>XMODEM (including any variants); YMODEM (including any variants); Kermit; ZMODEM</td>
</tr>
<tr>
<td>software other than</td>
<td></td>
</tr>
<tr>
<td>Crosstalk</td>
<td></td>
</tr>
</tbody>
</table>

To choose a file transfer protocol, follow these steps:

1. With a session profile open, choose File Transfer from the Settings pull-down. The File Transfer Settings dialog box, similar to the one shown in Figure 3-5, is displayed.
Creating and modifying custom session profiles

Figure 3-5. Sample File Transfer Settings dialog box

The information in this dialog box varies depending on which file transfer protocol you select.

2 Choose a file transfer protocol from the File Transfer list box.

The bottom portion of the dialog box displays a description and the settings for the file transfer protocol you just selected.

3 If necessary, modify the settings in the bottom portion of the dialog box. Most systems can safely use the default settings. See the on-line help for more details about these settings.

4 Choose OK.

Changing session settings

When you create a session profile, you can change the session settings contained in the profile, including the settings for your mouse and windows and the destination of your screen captures and snapshots. You can also assign an icon to the session profile you've created. This icon is displayed when you minimize the window or select the Show Icons check box in the Open dialog box.

To modify the session settings, follow these steps:
Creating and modifying custom session profiles

1 With a session profile open, choose Session from the Settings pull-down. The Session Settings dialog box, similar to the one shown in Figure 3-6, is displayed.

![Session Settings dialog box](image)

**Figure 3-6. Session Settings dialog box with the general settings displayed**

2 Modify the general settings as needed. See the on-line help for details.

3 Modify the other session settings as follows:
   - To modify window features, such as the QuickBar, status line, or review buffer, choose the Window icon. See the on-line help for details.
   - To modify your mouse features and QuickHit settings, choose the Mouse icon. See the on-line help for details.
   - To specify a keyboard profile to use with this session profile, choose the KeyMap icon. See the on-line help for details.
   - To change the start-up script settings, choose the Script icon. See the on-line help for details.
Creating and modifying custom session profiles

- To modify the settings for a text upload, use the scroll bar to choose the Text Upload icon. See the on-line help for details.

- To change the destination or other settings of a screen capture, choose the Capture icon. See the on-line help for more information about screen captures.

- To change the destination or other settings of a screen snapshot, choose the Snapshot icon. See the on-line help for more information about screen snapshots.

- To change the directory for files downloaded from the host, choose the Directory icon. See the on-line help for details.

4 Choose OK.

Changing your system settings

You can change the general workstation settings that affect all profiles, such as start-up script settings or the directory for storing downloaded files, using the Workstation Settings dialog box. These are global settings that are saved in the XTALK.INI file under Windows. Follow these steps:

1 With a session profile open, choose Workstation from the Settings pull-down. The Workstation Settings dialog box, shown in Figure 3-7, is displayed.
Creating and modifying custom session profiles

Figure 3-7. Workstation Settings dialog box with the general settings displayed

2 Modify the general workstation settings as needed. See the on-line help for more details.

3 If you need to change the directory for files downloaded from the host, choose the Directory icon. See the on-line help for more details.

4 Choose OK.

You are now ready to connect to the host, as explained in the next section.
Connecting to the host

Once you have your session profile set up, you can use it to connect your PC to another PC or mainframe, a bulletin board, or an information service. Before you proceed, make sure you know your host system's logon and logoff procedures. Check with the system administrator for more details.

To connect to the host, follow these steps:

1. With a session profile open, choose Connection and then Connect from the Action pull-down.

   If you are using a direct connection (without a modem), the connection is made using the parameters you set in this session profile.

   If you are using a modem connection, the modem dials the host telephone number specified in the session profile you are using. The Calling dialog box is displayed showing the status of the connection. If you receive a busy signal, Crosstalk automatically redials the host.

   Once a connection is made, the message area in the status line changes from "Opening connection" to "Connected."

2. Log on to the host.
Reviewing data during a communications session

Once your PC is connected to the host, all of the information your computer receives during the communications session is displayed on your screen. Crosstalk uses an area called a review buffer to store the data.

This section describes the review buffer and explains how to adjust its size.

What is the review buffer?

As you receive new information during a session, the current information on the screen scrolls off into an area called a review buffer. If there is information in the review buffer, the scroll bar is activated and a line appears at the top of your screen. This dotted line separates the data on your terminal screen from the data stored in the review buffer.

You can display or print the information in the review buffer or save it to a disk file. Each page of the review buffer requires approximately 2 KB of memory, depending on the type of terminal emulator you are using. The default buffer size is 8 pages.

Note: When the host computer sends the command to clear the contents of the screen, the screen data is stored in the review buffer. If, for some reason, the entire screen doesn't clear, some of the screen data may not appear in the review buffer.

To see the contents of the review buffer, use the vertical and horizontal scroll bars.

Adjusting the size of the review buffer

When the review buffer is full, only the newest information is stored and all the previous information is discarded. However, you can prevent this data loss by increasing the size of the buffer. Follow these steps:

1. With a session window open, choose Session from the Settings pull-down. The Session Settings dialog box is displayed.
2. Click on the Window icon. The Session Window Settings dialog box is displayed.
3. Choose a new buffer size from the Buffer Size list box.
4. Choose OK.
Reviewing data during a communications session

Note: If you change the size of the buffer while your PC is connected to the host, the old information in the buffer is discarded.

Transferring files

Transferring a file involves the following tasks:

- Sending or receiving a file
- Monitoring the status of a file transfer
- Stopping the file transfer, if necessary

The following sections explain how to perform these tasks.

Some file transfer protocols require you to prepare the host for the file transfer before starting the transfer. To do this, you must start the file transfer protocol program on the host. Table 3-5 lists which protocols require host preparation and which ones do not. If you need further assistance, contact the host system administrator.

Table 3-5. Determining whether your protocol requires host preparation

<table>
<thead>
<tr>
<th>If you are using this protocol...</th>
<th>Prepare the host to transfer a file</th>
<th>No host preparation is required</th>
</tr>
</thead>
<tbody>
<tr>
<td>CompuServe B+</td>
<td>√</td>
<td></td>
</tr>
<tr>
<td>Crosstalk</td>
<td></td>
<td>√</td>
</tr>
<tr>
<td>DART</td>
<td></td>
<td>√</td>
</tr>
<tr>
<td>IND$FILE</td>
<td></td>
<td>√</td>
</tr>
</tbody>
</table>

continued
Sending files

Table 3-5. Determining whether your protocol requires host preparation (cont.)

<table>
<thead>
<tr>
<th>If you are using this protocol...</th>
<th>Prepare the host to transfer a file</th>
<th>No host preparation is required</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kermit with KCP</td>
<td>√</td>
<td></td>
</tr>
<tr>
<td>Kermit without KCP</td>
<td>√</td>
<td></td>
</tr>
<tr>
<td>XMODEM</td>
<td>√</td>
<td></td>
</tr>
<tr>
<td>YMODEM</td>
<td>√</td>
<td></td>
</tr>
<tr>
<td>ZMODEM</td>
<td>√</td>
<td></td>
</tr>
</tbody>
</table>

If you want to transfer files using the Kermit protocol, refer to "Transferring Files Using Kermit," later in this chapter for instructions.

Sending a file

To send a file to the host using any of the supported protocols, other than Kermit, follow these steps:

1. Make sure you are connected and logged on to the host computer, as explained in "Connecting to the Host," earlier in this chapter.

2. Prepare the host to receive your files by entering the appropriate host commands or starting the protocol program, if necessary.

3. Do one of the following:
   - If you are using the Crosstalk, DART, IND$FILE, XMODEM, or YMODEM Batch protocols, choose File Transfer and then Send File(s) from the Action pull-down. The Send Files dialog box is displayed. The items on this dialog box vary, depending on the file transfer protocol you are using. See the on-line help for more details about the dialog box items.
   - If you are using CompuServe B+ or ZMODEM, the protocol's Autostart feature is enabled and the file transfer begins. A status box appears with information about the file transfer's progress, as explained in "Monitoring a File Transfer," later in this chapter.
4 Do one of the following:

- If you are using the Crosstalk, ZMODEM, or YMODEM Batch protocols, type the file you want to send in the File Name edit box. You can use wild-card characters, such as *.*, to send multiple files. You can also send multiple files to the host by choosing the Add File pushbutton. When you do this, the file you typed in the File Name edit box is added to the Files to Send list box. Do this for each file you want to send.

- If you are using INDF$FILE, type the file you want to send in the Local File Name edit box. If you want to save the file under a different name on the host, type the new name in the Host File Name edit box.

- If you are using DART, type the file you want to send in the File Name edit box. You can use wild-card characters to send multiple files. If you want to specify where to put the files on the host, enter a directory name in the Remote Destination Directory edit box.

- If you are using CompuServe B+, XMODEM or YMODEM, which only allow single-file transfers, the File Name edit box is displayed. Type the file you want to send in this edit box.

5 Choose the Send pushbutton to start the file transfer. A status box appears with information about the file transfer's progress, as explained in "Monitoring a File Transfer," later in this chapter.

Receiving a file

To receive a file from the host using any of the supported protocols, other than Kermit, follow these steps:

1 Make sure you are connected and logged on to the host computer, as explained in "Connecting to the Host," earlier in this chapter.
Transferring files

2 Do one of the following:

- If you are using XMODEM or YMODEM (including any variants), ZMODEM, or CompuServe B+, prepare the host to send the file by entering the appropriate host commands or starting the protocol program, if necessary.

- If you are using the DART, Crosstalk, or IND$FILE, you do not need to prepare the host for the file transfer.

3 Do one of the following:

- If you are using the Crosstalk, DART, IND$FILE, or XMODEM protocols, choose File Transfer and then Receive File(s) from the Action pull-down. The Receive Files dialog box is displayed. The items on this dialog box vary, depending on the file transfer protocol you are using. See the on-line help for more details about the dialog box items.

- If you are using the YMODEM protocol (including any variants), choose File Transfer and then Receive File(s) from the Action pull-down. The file transfer process begins immediately. You can skip steps 4 and 5.

- If you are using CompuServe B+ or ZMODEM, the host system controls entire file transfer process. All you have to do is tell the host you're ready to receive the files, according to its procedures. Then the host system takes over and controls the file transfer. You can skip steps 4 and 5.

4 Do one of the following:

- If you are using the Crosstalk or DART protocols, type the name of the file you want to receive from the host in the Remote Filename edit box. You can specify a path and use wild card characters, such as *, to receive multiple files.

- If you are using XMODEM, which only allows single-file transfers, the Local File Name edit box is displayed. Type the name you want to assign to the file once it is on your disk.

- If you are using IND$FILE, which only allows single-file transfers, the Host File Name edit box is displayed. Type the name of the file you want to receive from the host in this edit box. If you want to assign a different name to the file once it is received on your PC, type the new name in the Local File Name edit box.
Transferring files

This section explains how to transfer files to and from a Kermit host that is in server mode (using KCP). It also describes how to transfer to files using a Kermit host that does not support server mode (not using KCP).

Using Kermit with KCP

To transfer files to a Kermit host that is in server mode, follow these steps:

1. Make sure you are connected and logged on to the host computer, as explained in "Connecting to the Host," earlier in this chapter.

2. From the Action pull-down, choose File Transfer and then Kermit Command Processor. The Command Processor dialog box is displayed.

3. Click on either the Send or Get button, depending on whether you want to send or receive a file. The Send Files or Receive Files dialog box is displayed.

4. Type the name of the file you want to transfer in the File Name edit box. You can specify a path and use wild-card characters, such as *.*, to transfer multiple files. You can also send multiple files by choosing the Add File pushbutton at the bottom of the dialog box. The file you specified in the File Name edit box is added to the Files to Send list box. Do this for each file you want to send to the server.

5. Choose Send or Receive to start the file transfer. A status box displays information about the file transfer's progress. (For more information about this status box, refer to "Monitoring a File Transfer," later in this chapter.)

6. When you are finished transferring files to the Kermit server, choose the Finish button from the Command Processor dialog box. This switches the Kermit host from server mode to command mode. Then the Command Processor dialog box is removed from the screen and the host Kermit prompt is displayed.
To transfer files to a Kermit host that does not support server mode, follow these steps:

1. Make sure you are connected and logged on to the host computer, as explained in "Connecting to the Host," earlier in this chapter.

2. Prepare the host to send or receive your file by entering the appropriate host commands or starting the protocol program, if necessary.

3. From the Action pull-down, choose File Transfer and then Send File(s) or Receive File(s), depending on the direction of the transfer. Either the Send Files or Receive Files dialog box is displayed.

4. If you are sending a file to the Kermit host, type the name of the file in the File Name edit box. If you are receiving a file from the host, type the name of the file in the Remote Filename edit box. You can specify a path and use wild-card characters, such as *, to transfer multiple files.

5. Choose Send or Receive to start the file transfer. A status box appears with information about the file transfer’s progress, as explained in the next section.

You can monitor the status of a file transfer by viewing the file transfer status window, shown in Figure 3-8. This window contains a graphical bar that illustrates the progress of the file transfer. This indicator also shows the percentage complete for the file transfer.
The following paragraphs describe each item in the file transfer status window.

**Block.** Shows the number of blocks being transferred.

**Bytes transferred.** Shows the number of bytes sent or received so far.

**Size of file.** Displays the size of the file being transferred (not available with XMODEM and Kermit when receiving a file).

**Time remaining.** Shows the amount of time remaining until the file transfer is complete (not available with XMODEM and Kermit when receiving a file).

**Total errors.** Displays the total number of errors that have occurred during the file transfer.

**Consec errors.** Displays the number of outstanding errors. This number is set to zero (0) once the errors are corrected.

**Last error.** Shows the last error type that has occurred. Crosstalk automatically corrects the error and then continues the file transfer.

**Throughput.** Displays an estimate of the number of characters being transferred each second. (This is an accumulated average for each file you are transferring.)
Transferring files

Stopping a file transfer in progress

To stop a file transfer in progress, choose the Cancel pushbutton in the File Transfer Status window. Note that the canceling process may take several seconds to occur. You can then restart the transfer process later. If you have selected a file recovery protocol, such as ZMODEM, the transfer will resume where it left off.

Transferring ASCII files without using a protocol

Crosstalk lets you send text files to another computer without using a file transfer protocol. The process is called text uploading. You should use the upload feature to send ASCII files to the host in the following situations:

- If the host computer does not support a file transfer protocol
- If the host computer is using a protocol that Crosstalk does not support

The text upload feature is commonly used for sending files to a text editor on the host computer. Text uploading can be used with ASCII text files only. The file must reside on your disk before you can upload it to the host.

The following instructions explain how to specify uploading parameters, such as character and line pacing, and then upload a file. Follow these steps:

1. Make sure you are connected and logged on to the host.
2. Choose Session from the Settings pull-down. The Session Settings dialog box is displayed.
3. Choose the Text Upload icon from the left side of the dialog box. The text upload settings are displayed.
4. Modify the settings as needed. (See the on-line help for details.)
5. Choose OK.
6. From the Action pull-down, choose Session and then Upload Text File. The Upload Text File dialog box is displayed.
Transferring ASCII files without using a protocol

**Note:** After you choose Upload Text File from the Action pull-down, this option changes to Cancel Upload.

7 Choose the file you want to upload from the Files list box.

8 Choose OK to start the upload. The message area on the status bar displays the status of the text upload.

9 Once you've uploaded a file, be sure to save it on the host disk.

---

**Taking a snapshot of ASCII screen data**

Once you are connected to a host, you can use the Snapshot feature to copy your current screen and save it to a file or send it to a printer or a Text Editor window. This feature works like a camera; it copies the currently displayed screen text. The following instructions explain how to take a screen snapshot:

1 Make sure you are connected and logged on to the host.

2 Choose Session from the Settings pull-down. The Session Settings dialog box is displayed.

3 Choose the Snapshot icon (a camera) from the left side of the dialog box. The screen snapshot settings are displayed.

4 Choose a destination for the screen snapshot. Your choices are File, Printer, or Text Editor.

5 Modify the other settings as needed.

6 Choose OK.

7 From the Action pull-down, choose Session and then Snapshot. The Snapshot feature copies the currently displayed screen and saves the screen data to the destination you specified. Note that if you specify the Text Editor as the destination, a Text Editor window appears behind the session window.

When the snapshot process is complete, the message area on the status bar reads "Snapshot taken."
Capturing ASCII screen data from the host

While you are communicating with the host, you may want to save the information you are receiving as it is transmitted from the host. Cross-talk lets you capture all this information and save it to a file or send it to a printer or to the Text Editor.

Screen captures and screen snapshots are not the same. Capturing works like a video camera; it continues to copy all of the information your PC receives from the host until you turn Capture off. The capturing process does not stop until you tell it to do so.

The Snapshot feature, on the other hand, works like a camera; it takes "snapshots" of only the currently displayed screen. For more information on screen snapshots, see the previous section, "Taking a Snapshot of ASCII Screen Data."

To specify a destination for the screen capture and start capturing screen data, follow these steps:

1. Make sure you are connected and logged on to the host.
2. Choose Session from the Settings pull-down. The Session Settings dialog box is displayed.
3. Click on the Capture icon (a video camera) from the left side of the dialog box. The screen capture settings are displayed.
4. Choose a destination for the screen capture. Your choices are File, Printer, or Text Editor.
5. Modify the other settings as needed. See the on-line help for details.
6. Choose OK.
7. From the Action pull-down, choose Session and then Start Capture. When the capturing process begins, the message area in the status bar reads "Capture in progress."

Note: After you choose Capture from the Action pull-down, the option changes to Stop Capture.
Capturing ASCII screen data from the host

The Capture feature copies the information on your screen continually and saves the data to the destination you specified in the Session Settings dialog box. Note that if you choose the Text Editor as the destination, a Text Editor window appears behind the session window.

When you are ready to stop the capturing process, choose Session and then Stop Capture from the Action pull-down.

Once the capture is complete, the "Capture completed" message appears on the status bar.

---

Disconnecting a communications session

To disconnect a session, follow these steps:

1. Log off the host.

2. If the logoff process does not disconnect the session automatically, choose Connection and then Disconnect from the Action pull-down.

Note: If you're using a modem connection and, for any reason, the host connection is lost during a communications session, Crosstalk disconnects the session automatically.
Setting up your PC as a host

The operations described so far in this chapter pertain to your PC connecting to a host computer. But Crosstalk also allows you to configure your PC as a host. When your PC is the host, other computers can connect to it to transfer files or list the files in your current directory, even if you are not at your PC.

To operate as a host, your computer must be set up as the answering system. The following instructions explain how.

Using ANSWER.XWP

One way to configure your PC as the answering system is to use the ANSWER.XWP session profile that comes with Crosstalk. The settings in this profile are already defined and ready to use. Follow these steps:

1 Choose Open from the File pull-down. The Open dialog box is displayed.

2 Choose ANSWER.XWP from the Files list box and choose OK. The ANSWER.XWP session window is displayed. Then the Waiting for Calls dialog box appears, indicating that your PC is configured as the answering system.

Note: If this is your first time using the ANSWER.XWP profile, you are prompted for specific information about your PC, such as a password (this is optional), the name of the directory users can access to download files, your modem speed, and your PC communications port. Enter the necessary information as instructed on the screen.

Selecting Answer mode

Another way to set up your PC as an answering system is to select Answer mode in the Connections Settings dialog box. Follow these steps:

1 With a session profile open, choose Connection from the Settings pull-down. The Connection Settings dialog box is displayed.

2 Choose Local Modem from the Connection list box. The default dialing settings are displayed.
3 Choose the Connection icon from the left side of the dialog box. The modem connection parameters are displayed.

4 Choose Answer from the Connection Mode list box.

5 Choose OK.

6 From the Action pull-down, choose Connection and then Connect. Once the Waiting for Calls dialog box is displayed, your PC is configured as the answering system.

Running the ANSWER utility

When you open the ANSWER.XWP session profile, a utility called ANSWER runs and displays the Waiting for Calls dialog box on your screen. This dialog box indicates that your PC is waiting for other computers to connect to it.

In addition to making your PC available for other users to connect to it, ANSWER also controls other users' ability to access your PC. If you configured a password for your PC, ANSWER prompts users for this password before they are allowed to access your PC. Users have three chances to enter the correct password. When they do, they are logged on to your PC; otherwise ANSWER disconnects the communications session.

After users log on to your PC, ANSWER displays a host menu on their screens. Table 3-6 describes the options on the host menu.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(F)ile directory</td>
<td>Displays the names of the files in the current directory.</td>
</tr>
<tr>
<td>(C)hange host drive/directory</td>
<td>Changes the disk drive and directory on the host computer.</td>
</tr>
<tr>
<td>e(X)pert mode</td>
<td>Switches the host menu display off and on.</td>
</tr>
</tbody>
</table>

continued
Table 3-6. **Host menu options** (cont.)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(G)oodbye</td>
<td>Terminates the host connection. However, the host is still the answering system, so it's available for future connections.</td>
</tr>
<tr>
<td>(P)age the host operator</td>
<td>Notifies the host system operator that a caller is trying to contact the host operator. The host system beeps for 30 seconds. If there is no response from the host system operator, the host menu is redisplayed on the caller's screen, allowing them to choose a different menu option.</td>
</tr>
<tr>
<td>(D)ownload to your computer</td>
<td>Allows callers to receive a file from the host.</td>
</tr>
<tr>
<td>(U)pload to Host computer</td>
<td>Allows callers to send a file to the host.</td>
</tr>
<tr>
<td>(S)elect protocol</td>
<td>Allows callers to specify a file transfer protocol to use when transferring a file.</td>
</tr>
<tr>
<td>(R)ead messages</td>
<td>Displays the message file.</td>
</tr>
<tr>
<td>(L)eave a message</td>
<td>Allows callers to type a message and save it to the host's disk. Each message is labeled with the user's name and the date and time.</td>
</tr>
</tbody>
</table>

To choose an option from the host menu, users must type the letter in the parentheses. For example, to choose the Read Messages option, users type R and then press ENTER. If additional information is needed, the ANSWER utility prompts users for it.

ANSWER contains three variables: Permission, Logfile, and DirRestrict. To modify ANSWER or these three variables, you must edit and recompile the ANSWER.XWS file using the Script Editor. See Chapter 5, "Using Scripts," for information on editing and compiling scripts.

Table 3-7 describes the variables in the ANSWER utility.
Table 3-7. ANSWER variables

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Permission</td>
<td>Allows other users to enter only a specified set of commands on the host.</td>
</tr>
</tbody>
</table>
| Logfile | Specifies the file to use for call logging. Call logging is a way to track the number of users connecting to the host. This information is stored in a log file. 

If you do not set the Logfile variable, Crosstalk does not track the number of host connections. |
| DirRestrict | Allows other users to access only a specified directory on the host. To set the DirRestrict variable, use the following values: 

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Other users have full access to all the directories in your system.</td>
</tr>
<tr>
<td>1</td>
<td>The ANSWER.XWS script checks the NETID session variable for the directory that other computers can access.</td>
</tr>
<tr>
<td>blank</td>
<td>If the NetIDx variable is blank, the ANSWER.XWS script allows other users to access only the directory designated for file transfers and screen captures.</td>
</tr>
</tbody>
</table>

To stop using your PC as a host computer, choose the Cancel push-button from the Waiting for Calls dialog box on your screen. This stops ANSWER and removes the Waiting for Calls dialog box from your screen. Once you stop ANSWER, no other callers can connect to your computer.

If you stop ANSWER while a caller is connected to your PC, the caller can still transfer files and perform other communications activities; however, the host menu is no longer displayed on the caller's screen.
Introducing the Text Editor 4-2
Creating and modifying text 4-5
Using the editor 4-6
Editing text 4-7
Finding and replacing text 4-11
Saving your files 4-13
Printing your files 4-14
Exiting the Text Editor 4-15
Introducing the Text Editor

Crosstalk provides a built-in text editor that lets you create, edit, and print text files. Crosstalk's Text Editor provides an alternative to using the host text editor or a word processing program. You can also use the Text Editor to edit scripts, electronic mail messages, and any other ASCII text file.

Figure 4-1 shows the window that appears when you create a text file.

Figure 4-1. The Text Editor window

The Text Editor window includes a menu bar, QuickBar, and status bar, which are explained in the following sections.
The menu bar

Use the Text Editor menu bar pull-downs, shown in Figure 4-1, to manage and edit files, find and replace text, compile and run scripts, and rearrange windows. You can also obtain on-line instructions for creating, editing, and printing files. Table 4-1 describes each pull-down.

Table 4-1. Text Editor menu bar pull-downs

<table>
<thead>
<tr>
<th>Pull-down</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Lets you create new files, modify existing files, save and print files, and exit the Text Editor. This pull-down also lists the names of the last four files you opened.</td>
</tr>
<tr>
<td>Edit</td>
<td>Provides options to copy or cut text from the screen to the clipboard, paste text from the clipboard onto the screen, reverse your last editing action, and highlight the entire contents of the file.</td>
</tr>
<tr>
<td>Search</td>
<td>Lets you find specified text strings, replace existing text with new text, and move your cursor to a specific line number in a file.</td>
</tr>
<tr>
<td>Window</td>
<td>Provides options to rearrange and close windows, and lists all open windows.</td>
</tr>
<tr>
<td>Help</td>
<td>Provides on-line instructions for creating, editing, and printing your files.</td>
</tr>
</tbody>
</table>

The QuickBar

The QuickBar contains icons that initiate tasks, such as creating, saving, and printing files. You can start these tasks quickly by clicking on the icons.

Table 4-2 describes the QuickBar icons displayed when using the Text Editor.
## Table 4-2. QuickBar icons in a Text Editor window

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![File Icon]</td>
<td>Displays the New dialog box, which you can use to create a new file.</td>
</tr>
<tr>
<td>![Folder Icon]</td>
<td>Displays the Open dialog box, which you can use to modify an existing file.</td>
</tr>
<tr>
<td>![Save Icon]</td>
<td>Saves your changes to the currently displayed file. If this is a new file, the Save As dialog box is displayed.</td>
</tr>
<tr>
<td>![Print Icon]</td>
<td>Prints the currently displayed file.</td>
</tr>
<tr>
<td>![Find Icon]</td>
<td>Displays the Find dialog box. Use this dialog box to search for a specified text string in your file.</td>
</tr>
<tr>
<td>![Replace Icon]</td>
<td>Displays the Replace dialog box. Use this dialog box to replace existing text with new text.</td>
</tr>
</tbody>
</table>

### The status bar

The status bar displays the cursor location. The cursor position is represented on the status bar as *rrr* (the row) and *ccc* (the column). As you move the cursor, the row and column numbers change accordingly.
Creating and modifying text

To create or modify a file, use the New or Open option from the File pull-down. The instructions that follow assume you're opening a Text Editor window for the first time.

Creating a new file

To begin entering data, follow these steps:

1. Choose New from the File pull-down. The New dialog box is displayed.

2. Choose the Text File icon.

3. Choose OK. The new file is displayed on your screen.

Opening an existing file

To edit an existing file, follow these steps:

1. Choose Open from the File pull-down. The Open dialog box is displayed.

2. Choose the directory in which the file resides.

3. Choose the file from the Files list box.

4. Choose OK. The specified file is displayed on your screen.
Using the editor

This section explains how to do the following:

- Enter text
- Resize the edit area
- Display the files as icons

Entering text

You enter the text for your file in the same way you would enter text using any text editor. To replace text, use your cursor to highlight the characters you want to change, and then type the replacement text.

Resizing the edit area

To resize the edit window, move the border or corner of the window to the size you want. You can also enlarge your edit area by clicking on the system menu icon (next to the File pull-down on the menu bar), and choosing Maximize.

Displaying files as icons

If you have several open files, you may want to minimize the files you are not currently editing. To reduce a file to an icon, you can either click on the minimize icon in the top right corner of the window, or click on the system menu icon (next to the File pull-down on the menu bar), and choose Minimize.

Your file icons are displayed at the bottom of the Crosstalk window. You can choose Arrange Icons from the Window pull-down to keep their arrangement orderly. You can also use the Window pull-down to maximize file icons.
Editing text

This section explains how to edit your files. You can use the Edit pull-down to copy, cut, or clear text within a file; and to copy or move portions of the file from the clipboard to other files. A special editing tool, Undo, allows you to reverse your last editing action.

To display the Edit pull-down, choose Edit from the menu bar.

After you complete an editing session, you can save your work by using Save or Save As from the File pull-down. These options are described in the section "Saving Files," later in this chapter.

Selecting text

Many editing functions require you to select (highlight) text first. The next section explains how to select text using either the mouse or the keyboard.

Using the mouse

To select a block of text with a mouse, follow these steps:

1. Position the mouse pointer at the beginning of the text you want to select.
2. Hold down the mouse button, and drag the mouse until the desired text is highlighted.
3. Release the mouse button.

Using the keyboard

To select a block of text from the keyboard, follow these steps:

1. Position the cursor at the beginning of the text you want to select.
2. Hold down the SHIFT key, and use the arrow keys to move the cursor to the end of the desired text.
3. Release the SHIFT key.
Reversing edit actions

To reverse your last editing action, choose Undo from the Edit pull-down. Table 4-3 lists the editing actions you can undo.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result after using the Undo option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clearing text</td>
<td>Deleted characters are restored.</td>
</tr>
<tr>
<td>Cutting text</td>
<td>The selection is restored.</td>
</tr>
<tr>
<td>Deleting text</td>
<td>Deleted characters are restored.</td>
</tr>
<tr>
<td>Pasting text</td>
<td>Inserted characters are removed; replaced characters are restored.</td>
</tr>
<tr>
<td>Replacing text</td>
<td>Only the last text replacement is reversed.</td>
</tr>
<tr>
<td>Replacing all text</td>
<td>Only the last of the replacements is reversed.</td>
</tr>
<tr>
<td>Typing</td>
<td>Text entered since the last action is removed.</td>
</tr>
<tr>
<td>Reversing actions</td>
<td>The undo action is reversed.</td>
</tr>
</tbody>
</table>

Cutting text

To cut text from your file and put it in the clipboard, follow these steps:

1. Select the text to be cut.
2. Choose Cut from the Edit pull-down.

Copying text

To copy text to the clipboard, follow these steps:

1. Select the text to be copied.
2. Choose Copy from the Edit pull-down.

Pasting text

To paste (insert) text from the clipboard, follow these steps:

1. Position the cursor where the text is to be pasted.
2. Choose Paste from the Edit pull-down.
Clearing text

When you clear text from your file, it deletes the selected text completely; it does not save the text in the clipboard like the Cut procedure. To clear text from your file, follow these steps:

1. Select the text to be deleted.
2. Choose Clear from the Edit pull-down.

Selecting all of the text

To select all of the text in your file, choose Select All from the Edit pull-down.

You can reverse the select-all action by clicking your mouse once or pressing an arrow key.

Combining edit functions

Some editing operations require you to combine Edit pull-down functions to accomplish the editing task. For example, you must combine edit functions to perform the following tasks:

- Duplicate text
- Move text within a file
- Move text to another file

The following paragraphs explain these tasks.

Duplicating text

To duplicate (copy) text from one area to another in your file, follow these steps:

1. Select the text you want to duplicate.
2. Choose Copy from the Edit pull-down.
Editing text

3 Position the cursor at the desired insertion point.
4 Choose Paste from the Edit pull-down.

**Moving text within a file**

To move text from one area to another in your file, follow these steps:

1 Select the text you want to move.
2 Choose Cut from the Edit pull-down. The selected text is copied to the clipboard.
3 Position the cursor at the desired insertion point.
4 Choose Paste from the Edit pull-down.

**Moving text to another file**

To move text to another file, follow these steps:

1 Select the text you want to move.
2 Choose Cut from the Edit pull-down. The selected text is placed in the clipboard.
3 Make the window in which the other file is displayed the active window.
   If you have not yet opened the other file, you must do so before you can insert the cut text.
4 In the file to which the text is to be moved, position the cursor at the desired insertion point
5 Choose Paste from the Edit pull-down. The paste action copies the text in the clipboard to the insertion point you specify.
Finding and replacing text

You can search your text for a word and replace it. The Text Editor lets you do this automatically. Use the Search pull-down to find or to replace text in your file. The Find operations quickly search for a text string you specify. The Replace functions not only search for the specified text but also replace the text with new text. The Find and Replace operations eliminate the necessity of scrolling or paging your way through the file to find each occurrence of text you may want to edit.

In the following sections you will learn how to perform the Find and Replace operations.

Finding a text string

To search for a text string in your file, follow these steps:

1. Choose Find from the Search pull-down. The Find dialog box, shown in Figure 4-2, is displayed.

   ![Find dialog box](image)

   Figure 4-2. Find dialog box

2. Enter the character string you're searching for in the Find What edit box.

3. Select the Match Case check box if upper- or lowercase characters are important to the search.
4 Do one of the following:

- Choose Up to begin searching from the current cursor position to the beginning of your file.
- Choose Down to begin searching from the current cursor position to the end of your file.

The direction specified when you last used Find is the default direction.

5 Choose Find Next. The specified text string is highlighted when it is found.

Replacing a text string

To replace a text string in your file, follow these steps:

1 Choose Replace from the Search pull-down. The Replace dialog box, shown in Figure 4-3, is displayed.

2 Enter the character string that is to be replaced in the Find What edit box.

3 Enter the new text that is to replace the original string in the Replace With edit box.

4 Select the Match Case check box if upper- or lowercase characters are important to the replace operation.
Finding and replacing text

5  Do one of the following:
   • Choose Find Next to search for the next occurrence of the text string. The specified text is highlighted when it is found.
   • Choose Replace to find the first occurrence of the text and replace it with the new text string.
   • Choose Replace All to replace all occurrences of the specified character string.

Saving your files

Once you have created and edited your file, you can save it. This section explains how. These instructions assume you have a file displayed in the Text Editor window already.

Saving a new file

To save a new file, follow these steps:

1  Choose Save from the File pull-down. The Save As dialog box is displayed.

2  Choose the directory in which the file will reside.

3  Enter the file name and extension (.TXT) in the File Name edit box.
   Note: You can enter the entire path as well as the file name and extension in the File Name edit box.

4  Choose OK to save the file.

Saving an existing file

If you are working with a file you have saved before, choose Save from the File pull-down. Your file is saved under the current path and file name.
Saving an existing file under a new name

You can save an existing file under a new name. When you use Save As, the original file is unchanged. The new file contains the data from the original file plus any changes you may have made.

To save an existing file under a new name, follow these steps:

1. Choose Save As from the File pull-down. The Save As dialog box is displayed.

2. Choose the directory in which the new file is to reside.

3. Enter the file name and extension in the File Name edit box.

4. Choose OK.

Printing your files

You can print the data generated at your PC as well as the data received from the host computer. This section explains how.

Choosing and configuring the printer

To choose and configure a printer, follow these steps:

1. Choose Print Setup from the File pull-down. The Print Setup dialog box is displayed.

2. If you want to specify a printer other than the default printer, choose a printer from the Specific Printer list box.

3. Modify the other printer settings as needed.

4. To configure more options for the printer, choose the Options pushbutton. The Options dialog box is displayed.

5. Make your changes to these settings and choose OK. The Print Setup dialog box is displayed again.

6. Choose OK to confirm your settings.
Printing a file

To print a file, choose Print from the File pull-down. The Text Editor starts printing the currently displayed text file.

Exiting the Text Editor

To exit the Text Editor, choose Close from the File pull-down. You are prompted to save any changes you've made in the Text Editor window before exiting.
5 USING SCRIPTS

What are scripts? 5-2
Using the Learn facility 5-2
Using the Script Editor 5-6
What are scripts?

When you work in a data communications environment, you often have to repeat routine tasks on a daily basis. A Crosstalk script, like a computer program, contains a series of instructions that perform those tasks for you automatically. For example, you can create a script that establishes a host connection and logs you on to a host.

Scripts can be as simple or as complex as you want. With Crosstalk, you can create scripts in two ways:

- You can use the Learn facility to record keystrokes as you enter them. This is the fastest and simplest way to create a script.
- You can also use the Crosstalk Script Editor to create, save, compile, and run scripts. This is a more complex but powerful script process, which takes advantage of the power of CASL.

This chapter explains how to create and run scripts using these two methods.

Using the Learn facility

The easiest way to create a script is to record the keystrokes you enter when performing a task. The Crosstalk Learn facility captures the keystrokes and incorporates them in a script. Once a script is created, you can modify it as needed. Or you can replay the script whenever you need to carry out the task that you recorded.

For example, you can create a script while you are entering your logon ID and password at your terminal. This script becomes your logon script. When you run the logon script in the future, your logon procedure is performed for you. Typically, you would use Learn to create logon scripts for each host you plan to communicate with on a regular basis.

The Learn facility captures your keystrokes in statements that are communicated to the host computer. You do not have to write any programming statements; the session connection and communications directives are incorporated for you as part of the completed script.
To record a script using Learn, you do the following:

- Start Learn and record your keystrokes
- Replay the script whenever necessary

These procedures are explained in the following sections.

Before you begin, however, review the following tips:

- Do not use Learn when logging on to the host for the first time. First-time users often are prompted for different information than established users.
- If you make an error while creating a script with Learn, stop recording and start over. Otherwise, the script will repeat the error each time you run it.
- If the logon procedure for the host computer changes, you must create a new logon script with Learn.
- Scripts created with Learn reply to specific prompts from the host. Therefore, if an unfamiliar prompt appears, the script will not run correctly. If this occurs, choose Stop from the Script pull-down to stop running the script. For more information on running scripts created with Learn, refer to "Running Your Learn Script," later in this chapter.

To start Learn and record your keystrokes, follow these steps:

1. Make sure you have a session profile open.

2. When you are ready to log on to the host or to perform any function you want to automate, choose Script from the menu bar and then choose Learn.

   **Note:** Learn changes to Stop Learn once you've started the Learn facility.

3. Type the keystroke sequences you normally enter to complete the communications task. The keystrokes are captured in a script and sent to the host as usual.

   You can see your keystrokes captured and assimilated as CASL statements in a Script Editor window. The window, which runs in
Using the Learn facility

the background, mirrors your keystroke entries as well as the host prompts and responses.

4 To stop recording, choose Stop Learn from the Script pull-down. The Save As dialog box is displayed.

5 Type the name of your Learn script in the File Name edit box and choose OK. Your script is saved under the specified name.

6 A dialog box appears and asks whether you want to use the Learn script as a logon script. Choose Yes or No. If you choose Yes, this script will run automatically the next time you open this session profile.

Running your Learn script

You can replay your Learn script whenever necessary. The following instructions explain how. If the script you are running is a logon script, start with step 1. If, however, your script automates other communications functions, skip steps 1 through 5 and start with step 6.

Caution: Before you start replaying a Learn script, make sure the host state is exactly what it was when you initially started recording your script. If not, you may encounter errors or slow responses from the host while your script is running.

1 With a session profile open, choose Session from the Settings pull-down. The Session Settings dialog box is displayed.

2 Click on the Script icon (a castle) along the left side of the dialog box. The default settings for the logon script are displayed.

3 Choose the name of the script you want to use for this session from the Files list box. A logon script is run automatically when a connection is established.

4 Modify the other script settings as needed. See the on-line help for details.

5 Choose OK.

6 Choose Run from the Script pull-down. The Run Script dialog box, shown in Figure 5-1, is displayed.
Using the Learn facility

Figure 5-1. Run Script dialog box

7 Choose the script file you want to replay from the Files list box. The selected file appears in the File Name edit box.  

Note: You can enter the entire path as well as the file name and extension in the File Name edit box.  

8 If you want specific arguments passed to the script when it runs, type these arguments in the Script Arguments edit box.  

9 Choose OK. Your Learn script is replayed on your screen.
Using the Script Editor

The previous section explained how to create simple scripts using the Learn facility. You may, however, want your script to perform more complex functions. With the Script Editor, you can create, compile, run, and trace both simple and complex scripts. You can also use the Script Editor to modify scripts created with Learn.

To create scripts with the Script Editor, you must use CASL language elements. CASL makes it easy to automate many of the manual tasks you currently perform because you do not have to concern yourself with the details of communications programming; the software handles the communications interface for you. Refer to the CASL Programmer's Guide for more information about developing scripts using CASL elements.

To create a script using the Script Editor, you must perform the following tasks:

• Open a Script Editor window
• Create the script using CASL elements
• Compile the script
• Run the script
• Trace the script (optional)

These procedures are explained in the following sections.

Opening the Script Editor window

To open a new Script Editor window, follow these steps:

1. Choose New from the File pull-down. The New dialog box is displayed.
2. Choose the Script icon.
3. Choose OK. A Script Editor window, similar to the one shown in Figure 5-2, is displayed.
Figure 5-2. Sample Script Editor window

The Script Editor window includes a menu bar, QuickBar, and status bar. The following paragraphs describe these items.

**The menu bar**

Use the menu bar pull-downs, shown in Figure 5-2, to create and edit a script and find and replace text in a script. You can also obtain on-line help for compiling and running scripts and rearranging windows. Table 5-1 describes the menu bar pull-downs.
Table 5-1. Script Editor menu bar pull-downs

<table>
<thead>
<tr>
<th>Pull-down</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Lets you create, modify, save, and print scripts; and exit the Script Editor. This pull-down also lists the names of the last four files you've opened.</td>
</tr>
<tr>
<td>Edit</td>
<td>Lets you copy or cut text from the screen to the clipboard, paste text from the clipboard on to the screen, and highlight the entire contents of the script.</td>
</tr>
<tr>
<td>Search</td>
<td>Lets you find specified text, replace existing text with new text, and move your cursor to a specific line number in the script.</td>
</tr>
<tr>
<td>Script</td>
<td>Lets you compile the currently displayed script. You can also run the script if a session window is open.</td>
</tr>
<tr>
<td>Window</td>
<td>Provides options to open, close, and arrange windows, and list all open windows.</td>
</tr>
<tr>
<td>Help</td>
<td>Provides on-line instructions for creating, editing, and printing your scripts.</td>
</tr>
</tbody>
</table>

The QuickBar

The QuickBar displays icons that initiate tasks such as creating, saving, compiling, and printing scripts. You can start these tasks quickly by clicking on the icons.

Table 5-2 describes the QuickBar icons displayed when you are editing a script.
Table 5-2. QuickBar icons in a Script Editor window

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displays the New dialog box, which you can use to create a new file.</td>
<td></td>
</tr>
<tr>
<td>Displays the Open dialog box, which you can use to open an existing file.</td>
<td></td>
</tr>
<tr>
<td>Saves your changes to the currently displayed script. If this is a new script, the Save As dialog box is displayed.</td>
<td></td>
</tr>
<tr>
<td>Prints the currently displayed script.</td>
<td></td>
</tr>
<tr>
<td>Displays the Find dialog box. Use this dialog box to search for a specified text string in your script.</td>
<td></td>
</tr>
<tr>
<td>Displays the Replace dialog box. Use this dialog box to replace existing text with new text.</td>
<td></td>
</tr>
<tr>
<td>Displays the Script Compiler dialog box and starts compiling the currently displayed script.</td>
<td></td>
</tr>
</tbody>
</table>

The status bar

The status bar displays the cursor location. The cursor position is represented on the status bar as rrr (the row) and ccc (the column). As you move the cursor, the row and column numbers change accordingly.
Creating a script

Once you have the Script Editor window open, you can start writing your script. (See the CASL Programmer's Guide for information on the CASL language elements.) Follow these steps:

1. Enter your script text using CASL elements.
2. When you are finished, choose Save from the File pull-down to save your new script. The Save As dialog box is displayed.
3. Choose the directory in which the script file will reside.
4. Enter the file name and extension (*.XWS) in the File Name edit box.
5. Choose OK.

Compiling a script

Once you have created and saved your script, compile it to determine possible syntax errors. The script compiler converts your source script into a binary form and reports any errors that it detects. For an explanation of script source and executable files, see the CASL Programmer's Guide; it also describes how scripts are recognized and used by Crosstalk.

When you activate the compiler, you do not have to actively participate in the compilation process other than to note any compilation errors. You can cancel the compilation by choosing the Cancel pushbutton in the Script Compiler dialog box.

The compiler analyzes each statement in your script. If a syntax error is encountered, the compiler stops, informs you of the error, and lets you exit to correct the error. After you correct the error, you can restart the compiler by choosing Compile from the Script pull-down. Once a script compiles without errors, the compiler generates an executable file with an .XWC extension. This is the file Crosstalk uses to run the script.

You can compile a script from either a session window or a Script Editor window. The following sections explain how to compile scripts from each window.
If you have created a script with a text editor other than the Crosstalk for Windows 2.0 Script Editor, you should compile the script from the session window. Follow these steps:

1. With a session window open, choose Script from the menu bar and then choose Compile. The Compile Script dialog box, shown in Figure 5-3, is displayed.

   ![Compile Script dialog box](image)

   Figure 5-3. Compile Script dialog box

2. Specify the script you want to compile by choosing the directory in which the file resides.

3. Choose the file from the Files list box or enter the file name and extension (.xWS) in the File Name edit box.

   Note: You can enter the entire path as well as the file name and extension in the File Name edit box.

4. Choose OK to compile the script.

5. The compiler stops when a syntax error is encountered. Correct the error(s) using the same text editor you used to create the script.

6. Repeat steps 1 through 5 until your script compiles without errors.
From a Script Editor window

This section explains how to compile a script from a Script Editor window. Follow these steps:

1. With a script file open, choose Compile from the Script pull-down. The Script Compiler message box, shown in Figure 5-4, is displayed.

![Figure 5-4. Script Compiler message box](image)

If any compilation errors occur, the compiler stops and highlights the possible error in the Script Editor window so you can correct the error.

**Note:** To cancel the compilation before it has completed, choose Cancel from the message box.

2. Correct any errors highlighted in the Script Editor window.

3. Restart the compiler by choosing Compile from the Script pull-down.

4. Repeat steps 1 through 3 until your script compiles without errors.

Crosstalk automatically compiles any script you run if the script has not already been compiled or if the most recent version of the source script (the file with the .XWS extension) is newer than the compiled version (the file with the .XWC extension). You should compile your scripts before trying to run them to ensure that all syntax errors are corrected.

Once you have corrected all syntax errors, you can start running the script, as explained in the following section.
Running a script

You can start running a script from either a session window or the Script Editor. The following paragraphs explain how.

Note: If you are an experienced script user, you may want to debug your script while it is running. To learn how, you should first read "Tracing a Script," later in this chapter. Then come back and read this section to learn how to run your script.

From a session window

To run a script in a session window, follow these steps:

1. With a session window open, choose Run from the Script pull-down. The Run Script dialog box, shown in Figure 5-1, is displayed.

2. Specify the script you want to run by choosing the directory in which the file resides.

3. Choose the file from the Files list box or enter the file name and extension (.XWC) in the File Name edit box.

   Note: You can enter the entire path as well as the file name and extension in the File Name edit box.

4. If you want specific arguments passed to the script when it runs, type these arguments in the Script Arguments edit box.

5. Choose OK to start running the script.

   Note: If you need to stop your script while it's running, choose Stop from the Script pull-down.

From the Script Editor

You can run a script you are editing with the Script Editor. To do so, you must first open a session window. Note that the script will run from the session window, not the Script Editor window. Follow these steps:

1. Open a session window if one is not already open. The session window is displayed on top of the Script Editor window.

2. Make the Script Editor window active by choosing it from the Window pull-down or by clicking on the window, if it is visible.
Using the Script Editor

3 From the Script pull-down in the Script Editor window, choose the Run On option for the session window you want to run the script in. For example, to run a script in the MCI.XWP session window, choose Run On MCI.XWP.

4 Save and compile your script. The script starts running in the specified session window. At this point, all you need to do is note any run-time errors.

You can also specify a script to run when you first start Crosstalk. This script, called a start-up script, is described in the next paragraph.

Using a start-up script

A start-up script (*.XWS) is a CASL program that runs automatically when you start Crosstalk. Crosstalk comes with several start-up scripts that connect your PC to popular information services. For more information about these start-up scripts, refer to the README.TXT file.

To run a start-up script when starting Crosstalk, follow these steps:

1 With a session profile open, choose Workstation from the Settings pull-down. The default workstation settings are displayed.

2 From the Files list box, choose the script you want to run when starting Crosstalk. The selected file appears in the File Name edit box.

3 Choose OK.

Tracing a script

You can check the flow of your script as it runs by starting the trace program. Once the trace program starts, the Script Trace window is displayed. This window contains the current line number and the name of the most recent label the trace program encountered while the script was running. A label is a script command that is used to mark or define a location in a script file. For more information, see the CASL Programmer's Guide.

Although you can begin tracing at any point while a script is running, we suggest you start the trace program before running the script so you can trace the entire script. Follow these steps:

1 With a session profile open, choose Trace from the Script pull-down. The Script Trace window is displayed. The Script Trace window remains open, even after the trace is complete.
2 Run the script, as explained in the next section, "Running a Script."

Note: If you need to stop tracing a script while it is running, choose Stop Trace from the Script pull-down.

3 When you are ready to close the Script Trace window, choose the Cancel pushbutton.

**Exiting the Script Editor**

To exit the Script Editor, choose Close from the File pull-down. You are prompted to save any changes you've made in the Script Editor windows before exiting.

⚠️ Caution: Exit Crosstalk and Windows before you turn off or reboot your PC to prevent possible host connection problems.
What is a QuickPad? 6-2
Using QuickPads during a session 6-8
Creating a QuickPad 6-11
Editing QuickPads 6-12
Assigning functions to objects on a QuickPad 6-18
Exiting the QuickPad Editor 6-21
What is a QuickPad?

A QuickPad is a small window that contains objects you click on with your mouse to execute host commands or run scripts. The objects on a QuickPad include pushbuttons, group boxes, icons, lines, boxes, text, and graphics. You assign functions to these objects, such as running scripts and sending commands to the host computer.

A QuickPad helps you execute host commands that are otherwise hard to remember or that you have to repeat routinely. The QuickPad is also useful if you prefer using a mouse, rather than the keyboard, to execute commands.

Before you begin working with a QuickPad, read through this chapter. You'll learn about how to create and edit QuickPads, and assign scripts and keystrokes to objects on a QuickPad.

Introducing QuickPad profiles

Crosstalk comes with several QuickPad profiles that are already set up and ready to use during a communications session. These QuickPads are displayed automatically once you connect to the bulletin board or information service associated with that QuickPad.

You can use the pre-defined QuickPads that come with Crosstalk or you can create new ones customized to your needs, as explained in "Creating a QuickPad," later in this chapter. Table 6-1 lists each pre-defined QuickPad and its function.

<table>
<thead>
<tr>
<th>Use this QuickPad profile</th>
<th>To communicate with</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATT.XWQ</td>
<td>AT&amp;T Mail service</td>
</tr>
<tr>
<td>CSERVE.XWQ</td>
<td>CompuServe information service</td>
</tr>
<tr>
<td>DCABBS.XWQ</td>
<td>Bulletin boards using the PCBOARD software</td>
</tr>
<tr>
<td>DELPHI.XWQ</td>
<td>Delphi information service</td>
</tr>
</tbody>
</table>

continued
**Table 6-1. Pre-defined QuickPad profiles (cont.)**

<table>
<thead>
<tr>
<th>Use this QuickPad profile...</th>
<th>To communicate with...</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIALOG.XWQ</td>
<td>Dialog information service</td>
</tr>
<tr>
<td>DOWJONES.XWQ</td>
<td>Dow Jones News/Retrieval service</td>
</tr>
<tr>
<td>GENIE.XWQ</td>
<td>General Electric Network for Information Exchange service</td>
</tr>
<tr>
<td>LEXIS.XWQ</td>
<td>Mead Data LEXIS or NEXIS services</td>
</tr>
<tr>
<td>MCI.XWQ</td>
<td>MCI Mail service</td>
</tr>
<tr>
<td>NEWSNET.XWQ</td>
<td>NewsNet service</td>
</tr>
<tr>
<td>OAG.XWQ</td>
<td>Official Airline Guide service</td>
</tr>
</tbody>
</table>
What is a QuickPad?

Understanding the QuickPad Editor window

When you open a QuickPad profile, the QuickPad Editor window, shown in Figure 6-1, is displayed.

![The QuickPad Editor window](image)

**Figure 6-1. The QuickPad Editor window**

The QuickPad window includes a menu bar, the QuickBar, and the status bar. The following paragraphs explain these items.

The menu bar

Use the menu bar items, shown in Figure 6-1, to perform the following functions:

- Create and edit a QuickPad
- Change the layout of a QuickPad
- Rearrange the objects on a QuickPad

You can also use the menu bar pull-downs to open, close, and rearrange your QuickPad windows, and access on-line help. Table 6-2 describes each pull-down.
What is a QuickPad?

Table 6-2. QuickPad Editor menu bar pull-downs

<table>
<thead>
<tr>
<th>Pull-down</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Lets you create, modify, and save QuickPads and exit Crosstalk. This pull-down also lists the names of the last four windows you've opened.</td>
</tr>
<tr>
<td>Edit</td>
<td>Provides options to copy or remove objects from a QuickPad to the clipboard, paste QuickPad objects from the clipboard onto the QuickPad, define properties for the objects on the QuickPad, and highlight the entire contents of a QuickPad. You can also use this pull-down to change the name and color of your QuickPad.</td>
</tr>
<tr>
<td>Layout</td>
<td>Lets you change the layout of the objects on a QuickPad. The layout operations are explained in the section &quot;Editing QuickPads.&quot; You can also use this pull-down to resize your QuickPad.</td>
</tr>
<tr>
<td>Arrange</td>
<td>Provides options to move objects in front of or behind other objects on a QuickPad.</td>
</tr>
<tr>
<td>Window</td>
<td>Provides options to open, close, and rearrange your windows. This pull-down also lists all opened windows.</td>
</tr>
<tr>
<td>Help</td>
<td>Lets you access on-line help for using the QuickPad or Windows.</td>
</tr>
</tbody>
</table>

The QuickBar

The QuickBar displays icons that allow you to draw lines, boxes, and pushbuttons on a QuickPad. The QuickBar also lets you insert group boxes, text, graphics, and icons in the QuickPad. You can insert objects onto your QuickPad quickly by clicking on the appropriate QuickBar icon.

Table 6-3 describes the QuickBar icons displayed when using the QuickPad Editor.
## What is a QuickPad?

### Table 6-3. QuickBar icons in a QuickPad Editor window

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![File]</td>
<td>Displays the New dialog box. Use this dialog box to create a new file.</td>
</tr>
<tr>
<td>![Open]</td>
<td>Displays the Open dialog box. Use this dialog box to modify an existing file.</td>
</tr>
<tr>
<td>![Save]</td>
<td>Saves your changes to the currently displayed QuickPad. If this is a new QuickPad, the Save As dialog box is displayed.</td>
</tr>
<tr>
<td>![Selector]</td>
<td>Activates the Selector. Use this pointer to select one or more objects for modification. If you choose another object on the QuickBar, the Selector is automatically selected again. However, if you press CTRL while choosing another object on the QuickBar, the Selector is not automatically selected again.</td>
</tr>
<tr>
<td>![SelectButton]</td>
<td>Selects the pushbutton object. Use this icon to place a pushbutton on the QuickPad. To resize the button, drag the corner, or border, of the pushbutton until it is the size you want.</td>
</tr>
<tr>
<td>![SelectRectangle]</td>
<td>Selects the rectangle object. Use this icon to place a rectangle on the QuickPad. You can use this rectangle as a border, or outline, around other objects on the QuickPad. To resize the rectangle, drag one of the corners of the rectangle until it is the size you want.</td>
</tr>
</tbody>
</table>

---

continued
Table 6-3. QuickBar icons in a QuickPad Editor window
(cont.)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Group Box Icon" /></td>
<td>Selects the group box object. Use this icon to place a group box on the QuickPad. A group box is similar to an ordinary box, except the group box displays a title across the top of the box. A group box usually contains a group of related information.</td>
</tr>
<tr>
<td><img src="image" alt="TextBox Icon" /></td>
<td>Selects the text box object. Use this icon to place a box on the QuickPad. You can enter text into this box. To move or resize this text box, drag the corner, or border, of the box until it is the size you want.</td>
</tr>
<tr>
<td><img src="image" alt="Bitmap Icon" /></td>
<td>Selects the bitmap (graphic) object. Use this icon to place a bitmap on a QuickPad. This bitmap must be created with a graphics application. The bitmap cannot be resized, but you can drag it until it is positioned where you want on the QuickPad.</td>
</tr>
<tr>
<td><img src="image" alt="Icon Icon" /></td>
<td>Selects the icon object. Use this to place an icon on a QuickPad. You cannot resize the icon once it's placed on a QuickPad. But you can move the icon by dragging it until it's positioned where you want on the QuickPad.</td>
</tr>
</tbody>
</table>

The status bar

The status bar displays the current position of the mouse pointer. The pointer's position is represented on the status bar as the horizontal and vertical (X, Y) coordinates. As you move your cursor, the horizontal and vertical coordinates change accordingly.
Using QuickPads during a session

Crosstalk comes with several QuickPads that are already set up and ready to use during a communications session. These QuickPads are displayed automatically once you connect to the bulletin board or information service associated with that QuickPad. During a session, the QuickPad is always in full view, ready for you to choose an object.

Figure 6-2 shows the MCI Mail QuickPad displayed on the screen during a communications session.

![Figure 6-2. The MCI Mail QuickPad displayed during a communications session](image-url)
Displaying a QuickPad on the screen

To display a QuickPad for easy access during a communications session, you must load the QuickPad profile (*.XWQ) into your PC memory. Once loaded into memory, Crosstalk can quickly access and display the QuickPad.

You can display a QuickPad at any time—whether you're connected to the host computer or not. Follow these steps:

1. With a session profile open, choose Load from the QuickPad pull-down. The Load QuickPad dialog box is displayed.

2. Choose the QuickPad profile (*.XWQ) you want to use during the communications session from the Files list box.

3. Choose OK. The QuickPad you just selected is displayed on your screen.

4. Connect and log on to the host, as explained in Chapter 3, "Running a Communications Session." The QuickPad is enabled and you can use it to issue host commands, run scripts, and so on.

Editing the QuickPad during a session

If, during a communications session, you realize that you need to add or delete objects on a QuickPad, you can use the QuickPad Editor to make the changes without disconnecting the session. Follow these steps:

1. Choose Open from the File pull-down. The Open dialog box is displayed.

2. Specify the name of the QuickPad profile (*.XWQ) you have displayed on your terminal screen.

3. Choose OK. A copy of the QuickPad is displayed in the QuickPad Editor window.

4. Edit the QuickPad in the QuickPad Editor window as needed.

5. Choose Save from the File pull-down to save your changes.

6. Choose Close from the File pull-down to exit the QuickPad Editor. The session window becomes active again and an updated version of the QuickPad, which contains the edits you just made, is displayed on your screen.
Using QuickPads during a session

Hiding a QuickPad from view

If a QuickPad is blocking your view of the terminal screen, you can hide the QuickPad so it doesn't interfere. Follow these steps:

1. Choose Hide from the QuickPad pull-down. The Hide QuickPad dialog box is displayed.

2. Specify which QuickPad you want to hide from the list of open QuickPads.

3. Choose OK. The QuickPad is no longer visible on the screen.

If you have multiple QuickPads on your terminal screen and want to hide them from view, choose Hide All from the QuickPad pull-down.

Redisplaying a hidden QuickPad

If you have a QuickPad hidden from view, you can redisplay it on your terminal screen. Follow these steps:

1. Choose Show from the QuickPad pull-down. The Show QuickPad dialog box is displayed.

2. Choose the QuickPad you want to show from the list of open QuickPads in the Files list box.

3. Choose OK. The selected QuickPad is displayed on the screen.

If you have more than one QuickPad hidden from view and you want to move them to the front of your terminal screen, choose Show All from the QuickPad pull-down.

Removing a QuickPad from the screen

To remove a QuickPad from the screen, choose Unload from the QuickPad pull-down. When you do this, the QuickPad is not simply hidden from view, it is completely removed from your screen.

At this point, you can display a different QuickPad by choosing Load from the QuickPad pull-down, or you can continue with your other communications activities.
Creating a QuickPad

A QuickPad can include pushbuttons, group boxes, icons, lines, boxes, text, and graphics. You can create a new QuickPad or modify an existing one to meet your needs. This section explains how.

Creating a new QuickPad

To create a new QuickPad, follow these steps:

1. Choose New from the File pull-down. The New dialog box is displayed.
2. Click on the QuickPad icon.
3. Choose OK. A blank QuickPad is displayed in the QuickPad Editor window.

Opening an existing QuickPad

To open an existing QuickPad profile, follow these steps:

1. Choose Open from the File pull-down. The Open dialog box is displayed.
2. Choose the QuickPad profile (*.XWQ) you want to open from the Files list box.
3. Choose OK. The QuickPad you specified is displayed in the QuickPad Editor window.
Editing QuickPads

This section explains how to use the QuickPad Editor to edit your QuickPad and place objects on the QuickPad. You will also learn how to select, copy, move, resize, rearrange, and delete QuickPad objects.

Placing an object on a QuickPad

Once you have a QuickPad displayed in the QuickPad Editor window, you can start placing objects on it. Follow these steps:

1. Choose the object you want to place on your QuickPad from the QuickBar.

2. Move your cursor to the QuickPad. While pressing the mouse button, drag your cursor to enlarge the object to the desired size.

3. Double-click on the object, or choose Object Properties from the Edit pull-down. A properties dialog box, which corresponds with the object you selected, is displayed.

4. Complete the properties dialog box by labeling the object and modifying the other settings as needed.

5. Choose OK.

Example 1: Placing a pushbutton on a QuickPad

You can practice placing an object on a QuickPad using the following example. This example shows how to place a pushbutton on a QuickPad and label it "Enter." Follow these steps:

1. Click on the pushbutton icon from the QuickBar.

2. Move your cursor to the QuickPad and click on the area where you want to place the object.

   Note: The numbers in the status bar change to correspond with the current position of your cursor.

3. While pressing the mouse button, drag your cursor to enlarge the pushbutton.
4 Double-click on the object, or choose Object Properties from the Edit pull-down. The Button Properties dialog box, shown in Figure 6-3, is displayed.

![Button Properties dialog box](image)

**Figure 6-3. Button Properties dialog box**

5 Type the following in the Label edit box:

**Enter**

This places a label on the pushbutton. You can adjust the font style and font size of the label if you want.

6 Choose OK. The label on Button 1 changes to Enter, as shown in Figure 6-4.

7 Save this QuickPad. You will use it in "Example 2: Assigning Keystrokes to a Pushbutton on a QuickPad," later in this chapter.
Editing QuickPads

Selecting QuickPad objects

Many editing functions require you to select (highlight) an object first. To select a QuickPad object, click on the object you want to select. The "handles" (■) that appear at the corners of the object indicate that it is selected.

To select multiple objects at the same time, press SHIFT while clicking on each object.

Copying objects

To make a copy of an object, follow these steps:

1. Select the object you want to copy.
2. Position the mouse pointer anywhere on the object, other than the handles.
3. While pressing CTRL, press the mouse button and drag the duplicate object to the position you want on the QuickPad.
4. Release CTRL and the mouse button.

Figure 6-4. Example of a pushbutton on a QuickPad
Note: You can also choose Copy from the Edit pull-down to copy the selected object into the clipboard. Then choose Paste from the Edit pull-down to paste the duplicate object on to the QuickPad.

Making multiple copies

To make additional copies of an object, you can repeat the steps outlined in the preceding section. However, a faster method is to create what is called a matrix of the object. This allows you to make multiple copies of an object in one step. Follow these steps:

1. Select the object you want to copy.
2. Position the mouse pointer on one of the handles of the object.
3. While pressing CTRL and the mouse button, drag the handle of the object. Notice the handles disappear and a dotted square (called a matrix) surrounds the object.
4. Continue dragging the dotted square until it is the size you want. The square is filled automatically with copies of the selected object.
5. Release CTRL and the mouse button. The dotted square disappears and all the duplicate objects are selected.

Moving objects

To move an object from one area on the QuickPad to another, follow these steps:

1. Select the object you want to move.
2. Position the mouse pointer anywhere on the object, other than the handles. While pressing the mouse button, drag the object until it is positioned where you want on the QuickPad.
3. Release the mouse button.

Resizing objects

To change the size of an object, follow these steps:

1. Select the object you want to resize.
2. Position the mouse pointer on one of the handles.
3 While pressing the mouse button, drag the handle until the object is the size you want.

4 Release the mouse button.

Note: You can resize the QuickPad to be as small as possible (and still contain the objects). To do this, choose Resize to Fit from the Layout pull-down.

Rearranging objects

You can quickly rearrange objects that overlap each other by using the Arrange pull-down. To move an object in front of or behind other objects, follow these steps:

1 Select the object you want to rearrange.

2 Do one of the following:
   - To move the object in front of all the other objects, choose Move to Front from the Arrange pull-down.
   - To move the object behind all the other objects, choose Move to Back from the Arrange pull-down.
   - To move the object one position in front of another object, choose Move Forward from the Arrange pull-down.
   - To move the object one position behind another object, choose Move Backward from the Arrange pull-down.

Using the QuickPad grid

To precisely position the objects on your QuickPad, use the QuickPad grid. This grid aligns the objects to the closest line on the grid and specifies the amount of space between the objects. To use the grid, follow these steps:

1 Choose Show Grid from the Layout pull-down to display the grid. A check mark indicates that the Show Grid option is active.

2 Select the object you want to rearrange.
3. Do one of the following:

- To move the object to the closest line on the grid, choose Snap to Grid from the Layout pull-down.
- To change the amount of spacing between the objects on the QuickPad, choose Grid Settings from the Layout pull-down. The Grid Settings dialog box is displayed. Modify the grid spacing as needed and choose OK.

**Note:** To remove the grid lines from the QuickPad, choose Show Grid again. The check mark and the grid lines disappear.

**Deleting objects**

Follow these steps to remove an object from your QuickPad:

1. Select the object you want to delete.
2. Choose Clear from the Edit pull-down, or press DEL. The selected object is removed from the QuickPad. If you want to delete the object and place it in the clipboard, choose Cut from the Edit pull-down instead.

**Other customization features**

You can customize a QuickPad by giving it a label or changing its background color. The following steps describe how:

1. Double-click on the title bar of the QuickPad. The QuickPad Properties dialog box is displayed.
2. To add a label in the title bar above the objects on the QuickPad, enter a name in the Title edit box.
3. To change the background color of the QuickPad, choose a color from the Background Color list box.
4. Choose OK.
Assigning functions to objects on a QuickPad

You can use QuickPad objects to run scripts or automate keystrokes that you use frequently. For example, after you draw a pushbutton on your QuickPad, you can assign a script to the pushbutton that automates your host logon procedure.

Keystrokes and scripts can be assigned only to pushbuttons or icons; you cannot assign these functions to the other QuickPad objects. The following paragraphs explain how to assign keystrokes and scripts to an object.

To assign keystrokes to an object, follow these steps:

1. Select the object you want to assign the keystrokes to.
2. Double-click on the object, or choose Object Properties from the Edit pull-down. A properties dialog box that corresponds to the object you have just selected is displayed.
3. Choose Send Keystrokes from the Action list box.
4. From the Terminal list box, choose the type of terminal emulation software you are using.
   
   **Note:** Once you choose an emulator from the Terminal list box, a list of keystrokes is displayed in the Terminal Keys list box. These keystrokes correspond with the emulator you selected.
5. In the Keystrokes edit box, enter the keystrokes you want to assign to the object. Or double click on the keystrokes in the Terminal Keys list box. The specified keystrokes are displayed in the Keystrokes edit box.
6. Choose OK to assign the keystrokes to the QuickPad object.

**Note:** Once you've assigned terminal-specific keystrokes to a QuickPad object, this QuickPad can be used only with session profiles that are configured for that same type of terminal. For example, if you've assigned VT320 keystrokes to a pushbutton on your QuickPad, this QuickPad can only be used with session profiles that specify VT320 as the terminal type.
Using the QuickPad you created in Example 1, earlier in this chapter, the following example shows you how to assign the Enter command to the pushbutton on the QuickPad. These instructions assume you already have the QuickPad from Example 1 displayed on your screen. Follow these steps:

1. Select the Enter pushbutton on the QuickPad.
2. Double-click on the object, or choose Object Properties from the Edit pull-down. The Button Properties dialog box is displayed.
3. Choose Send Keystrokes from the Action list box.
4. Choose the terminal emulator you are using from the Terminal list box.
5. Type the following in the Keystrokes edit box:
   \(<CR>\)
6. Choose OK to assign the carriage return keystroke to the pushbutton.

The QuickPad Editor lets you assign two types of scripts to an object on a QuickPad—external or embedded. An external script is a script file (*.XWS or *.XWC) that resides on your disk. An embedded script is one you create while you are in the QuickPad Editor. When you assign an embedded script to a QuickPad object, the script is actually stored in the QuickPad profile.

The following guidelines can help you decide whether to assign an external or embedded script to a QuickPad object: Use the embedded script feature if you want to create a short and simple script quickly, or if you intend to send the QuickPad profile to other users. This way, you need to send only one file—the QuickPad profile—since the script is embedded in the profile. If you use the external script feature, you'll have to send two files: the QuickPad profile and the external script.
Assigning functions to objects on a QuickPad

To assign an embedded or external script to an object, follow these steps:

1 Select the object you want to assign a script to.

2 Double-click on the object, or choose Object Properties from the Edit pull-down. A properties dialog box, which is associated with the object you selected, is displayed.

3 Choose either Run Script or Run Embedded Script from the Action list box.

4 Do one of the following:
   • If you specified Run Script, a Script File Name edit box is displayed. Enter the name of the .XWS file you want to assign to the object.
     
     To see a list of all the script files on your disk, choose the Browse pushbutton. The Run Script dialog box is displayed. Choose a script file from the File list box and then choose OK. The file name is placed in the Script File Name edit box.
     
   • If you specified Run Embedded Script, an editing area is displayed at the bottom of the dialog box. Write your script here.
     
     Choose the Compile pushbutton from the dialog box to start compiling the script you just created.

5 Choose OK to assign the script to the QuickPad object.
Exiting the QuickPad Editor

To exit the QuickPad Editor, choose Close from the File pull-down. You are prompted to save any changes you've made in the QuickPad windows before exiting.

⚠️ Caution: Exit Crosstalk and Windows before you turn off or reboot your PC to prevent possible host connection problems.
REMAPPING YOUR KEYBOARD

Overview 7-2
Displaying a keyboard profile 7-6
Remapping keyboard functions 7-7
Assigning keystrokes or scripts to keys 7-9
Using a keyboard map during a session 7-12
Exiting the Keyboard Editor 7-13
Overview

When you are communicating with a host computer, your keyboard functions somewhat differently than normal. This is because your keyboard is emulating a terminal keyboard. You can remap (that is, assign different functions to) the keys on your keyboard to make it easier to use during a communications session. This chapter explains how.

Introducing keyboard profiles

A keyboard profile contains the layout of a terminal keyboard. Each keyboard profile corresponds to a specific type of terminal.

You may find that you want to change the location of some of your keys. Or, you may want to change your keys to be consistent with other applications you use. You can create a customized keyboard by rearranging the characters and functions on your keyboard. To do this, use the Keyboard Editor to create and edit a keyboard profile (*.XWK).

Understanding the Keyboard Editor window

When you open a new or existing keyboard profile, the Keyboard Editor window, shown in Figure 7-1, is displayed.
Figure 7-1. The Keyboard Editor window

The Keyboard Editor window includes a menu bar, QuickBar, and status bar. The following paragraphs describe these areas and explain how to use them.

The menu bar

Use the menu bar pull-downs, shown in Figure 7-1, to create, edit, and save keyboard profiles, display the default keyboard map, and remap your keyboard. You can also use the menu bar pull-downs to open, close, and rearrange your windows, and access on-line help. Table 7-1 describes each pull-down.
Table 7-1. Keyboard Editor menu bar pull-downs

<table>
<thead>
<tr>
<th>Pull-down</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Lets you create new keyboard profiles and modify existing ones and exit the Keyboard Editor. This pull-down also lists the names of the last four windows you've opened.</td>
</tr>
<tr>
<td>Edit</td>
<td>Lets you display or hide the default keyboard profile, which corresponds to the type of terminal your PC is emulating. This pull-down also lets you reverse your last editing action.</td>
</tr>
<tr>
<td>Window</td>
<td>Lets you rearrange and close windows and lists all open windows.</td>
</tr>
<tr>
<td>Help</td>
<td>Lets you access on-line help.</td>
</tr>
</tbody>
</table>

The QuickBar

The QuickBar displays icons that allow you to create, edit, and save keyboard profiles. You can perform these tasks quickly by clicking on the appropriate QuickBar icon.

You can also use the QuickBar to change the type of terminal your PC is emulating to connect to the host. Each keyboard profile corresponds with a specific type of terminal.

Table 7-2 describes the QuickBar icons displayed when you use the Keyboard Editor.
### Table 7-2. QuickBar icons in a Keyboard Editor window

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Displays the New dialog box, which you can use to create a new file.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Displays the Open dialog box. Use this dialog box to open and modify an existing file.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Saves your changes to the currently displayed keyboard profile. If this is a new keyboard profile, the Save As dialog box is displayed.</td>
</tr>
</tbody>
</table>

### The status bar

The status bar of the keyboard profile window displays the keycap your cursor is currently pointing to. As you move your cursor around the keyboard map, the characters in the status bar change accordingly.
Before you can set up and remap a new keyboard profile, you must first display the profile. You can display two keyboard profiles at the same time:

- A working profile that you can customize
- A default profile, from which you can copy specific key functions

This section explains how to display these profiles.

The working profile is displayed in the top half of the Keyboard Editor window. The keys are color coded: the red keys cannot be mapped, but the black and the blank keys are available and can be mapped.

The procedure you use to display a working profile depends on whether you are displaying a new profile, an existing profile, or the default profile. The following paragraphs explain each procedure.

To display a new keyboard profile, follow these steps:

1. Choose New from the File pull-down. The New dialog box is displayed.
2. Click on the KeyMap icon.
3. Choose OK. An untitled keyboard profile is displayed in the Keyboard Editor window.

To display an existing profile, follow these steps:

1. Choose Open from the File pull-down. The Open dialog box is displayed.
2. Choose the working profile name (*.XWK) from the Files list box.
3. Choose OK to display the specified profile.
Displaying the default profile

The default keyboard profile is displayed in the bottom half of the Keyboard Editor window. This profile uses the same type of terminal emulator as the working profile displayed in the top half of the window. You cannot change the default profile, but you can use it to copy key functions into the working profile.

To view the default keyboard profile for the terminal emulator your PC is using, choose Show Defaults from the Edit pull-down. (A check mark appears next to the option.) The default profile is displayed below the working profile.

To remove the default profile from the bottom half of the window, choose Show Defaults from the Edit pull-down again. This removes the default profile as well as the check mark next to the Show Defaults option.

Remapping keyboard functions

You remap your keyboard layout by modifying your working profile. To remap your keyboard, all you do is copy a key function or character to another key by dragging the function or character from one location to another.

This section defines standard, modifier, and combination keys; and tells how to remap them by copying and deleting a function.

Remapping modifier and combination keys

You can use three types of keys as you remap your keyboard: standard keys, modifier keys, and combination keys. A standard key is any key that is pressed alone, such as the letter d. A modifier key is one that, when pressed in combination with another key, changes the function of that key. For example, if you press CTRL while pressing the left square bracket key (\[), the function of the left square bracket key changes to ESC. Modifier keys include SHIFT, CTRL, NUMLOCK, CAPSLOCK, and ALT. A combination key is a combination of a modifier key and a standard key, such as CTRL-d.

You can remap keys within one modifier state. For example, if a function is currently mapped to CTRL-d, you can remap it to CTRL-F10. You can also remap keys across modifier states, such as changing CTRL-F10 to ALT-F10.
Remapping keyboard functions

The Keyboard Editor also lets you change extended (multiple modifier) key states. For example, if a function is currently mapped to CTRL-d, you can remap it to CTRL-SHIFT-d.

The next two sections provide guidelines for copying and deleting functions.

⚠️ **Caution:** Do not assign functions to the standard or shift positions of alphabetic keys; this erases your alphabetic characters. Also, do not assign functions to the Shift position of a key that has a symbol in that position, such as the asterisk (*) on the number 8 key.

### Copying a function

The following example explains how to copy a function from one key to another. These instructions assume you have a keyboard profile displayed already.

Suppose that on a 101-key keyboard, the PF1 key is mapped to F1. To make the location of the PF1 key easier to remember, you want to move it to CTRL-1. To copy the PF1 key to CTRL-1, follow these steps:

1. Move the pointer to the PF1 key on the keyboard map, and click on this key. Do not release the mouse button. The cursor changes from an arrow to a black key with a plus sign (+).

2. Press CTRL and drag the PF1 key to the 1 key, and then release the mouse button. The PF1 key is now assigned to CTRL-1 and PF1 is displayed on the key cap.

3. Choose Save from the File pull-down to save the changes.

⚠️ **Caution:** When you drag a function or character to a key on the working profile, the new function or key overwrites the current function (if any).
Deleting a function

In the previous example, you copied the PF1 key to CTRL-1. It is now mapped to both F1 and CTRL-1. Since you probably do not want the PF1 key mapped to two keys, follow these steps to remove the PF1 key from F1 on the working profile:

1. Move the pointer to the PF1 key mapped to F1 and choose it. Do not release the mouse button. The cursor changes from an arrow to a black key with a plus sign (+).

2. Drag the PF1 key off F1 and onto a blank area in the working profile, and then release the mouse button. The F1 key position is now empty and the function is deleted from that location.

3. Choose Save from the File pull-down to save the changes.

Note: If you accidentally remove a function, replace it by copying the function from the default keyboard profile to the working profile. Or you can reverse the delete action by choosing Undo from the Edit pull-down. The undo must be the first action you initiate after completing the deletion.

Assigning keystrokes or scripts to keys

Crosstalk provides an easy way to assign keystrokes or scripts to keys on the keyboard map. When you assign keystrokes or a script to a key, you can use it during your communications sessions.

The following instructions describe how to assign keystrokes and a script to a key. These instructions assume you have a working profile displayed in the Keyboard Editor window already.

Assigning keystrokes to a key

To assign keystrokes to a key, follow these steps:

1. Double-click on the key that you want to assign the keystrokes to. The Key Properties dialog box, shown in Figure 7-2, is displayed.
Assigning keystrokes or scripts to keys

The Keyboard Editor lets you assign two types of scripts to a key—external or embedded. An external script is a script file (*.XWS) that resides on your disk. An embedded script is one you create while you are in the Keyboard Editor. When you assign an embedded script to a key, the script is actually stored in the keyboard profile.

The following guidelines can help you decide whether to assign an external or embedded script to a key: Use the embedded script feature if you want to create a short and simple script quickly, or if you intend to send the keyboard profile to other users. This way, you need to send
only one file—the keyboard profile—since the script is embedded in the profile. If you use the external script feature, you'll have to send two files: the keyboard profile and the external script.

To assign an embedded or external script to a key, follow these steps:

1. With the working profile open, double-click on the key to which you want the keystroke assigned. The Key Properties dialog box, shown in Figure 7-2, is displayed.

2. Choose either Run Script or Run Embedded Script from the Action list box.

3. Do one of the following:
   - If you specified Run Script, a Script File Name edit box is displayed. Enter the name of the .XWS file you want to assign to the key.
     To see a list of all the script files on your disk, choose the Browse pushbutton. The Run Script dialog box is displayed. Choose a script file from the File list box and then choose OK. The file name is placed in the Script File Name edit box.
   - If you specified Run Embedded Script, an editing area is displayed at the bottom of the dialog box. Write your script here. Choose the Compile pushbutton from the dialog box to start compiling the script you just created.

4. Choose OK. The script is assigned to the selected key on the keyboard map.
Using a keyboard map during a session

Once you have remapped your keyboard and saved the key assignments to a keyboard profile, you can use this profile during a communications session with the host. To do this, you must first assign the keyboard profile to a specific session profile. The keyboard remapping is in effect only if you use this session profile to communicate with the host. Follow these steps:

1. Make sure you have a session profile open and you are connected and logged on to the host.

2. Choose Session from the Settings pull-down. The Session Settings dialog box is displayed.

3. Choose the Keymap icon from the left side of the dialog box. The Session KeyMap dialog box is displayed.

4. In the Files list box, choose the keyboard profile (*.XWK) that you want to use during the communications session. An Edit pushbutton appears on the dialog box.

5. [Optional]. If you want to edit the selected keyboard profile, choose the Edit pushbutton. The keyboard profile is displayed, allowing you to make changes to the keyboard map. Once you've finished your edits, save the keyboard profile. Your remapping will now take effect and you can skip step 6.

6. Choose OK. The remapping will now take effect.

Note: During a communications session, you may want to remap a key that you haven't already saved to a keyboard profile. To do so, you must create a new keyboard profile, remap the key, and then save the key assignment to the new profile. To start this process, choose New from the File pull-down. For more information on creating new keyboard profiles, see "Displaying a New Profile," earlier in this chapter.
Exiting the Keyboard Editor

To exit the Keyboard Editor, choose Close from the File pull-down. You are prompted to save any changes you've made in the Keyboard Editor window(s) before exiting.

⚠️ Caution: Exit Crosstalk and Windows before you turn off or reboot your PC to prevent possible host connection problems.
Connection overview

This appendix explains how to connect your PC to a modem or to another computer. It also provides information on network communications support, such as NASI and INT14, in Crosstalk.

This appendix provides brief steps for performing tasks. For a more complete description of dialog boxes and their options, use the on-line help.

Modem cables

To connect a modem to your PC, you must use the correct modem cables. The major difference between modem cables is the serial port that the modem cables connect to. The serial ports on most IBM and IBM-compatible PCs have one of the following types of serial port connectors:

- 25-pin male D-shell connectors
- 9-pin male D-shell connectors

Nearly all modems have 25-pin female connectors. To connect your modem properly, you must first determine the type of serial port connector your PC has.

This section describes the connector types and explains how the pins should be connected.

25-pin connectors

If your serial port has a 25-pin connector, the cable used to attach your modem should be connected "straight across" on pins 1 through 8 and pin 20. In other words, connect pin 1 to pin 1, pin 2 to pin 2, and so on. You must have a male connector at the modem-end of the cable and a female connector at the PC-end of the cable.

Note that some ready-made (or pre-wired) modem cables do not have all of these pins connected. If you are not sure about your cable connectors, remove the connector covers, if possible, and check the cable.

If you are using a ribbon cable, it is probably connected properly. However, ribbon cables can cause considerable radio-frequency inter-
ference to televisions, radios, and video tape equipment. If this problem occurs, use a shielded cable instead of the ribbon cable.

**9-pin connectors**

Ready-made modem cables are available in either a 9-pin or a 25-pin connector. Unlike the 25-pin connector, the pins of a 9-pin connector are not connected straight across. As a result, some ready-made cables do not generate all the necessary modem signals.

If your computer has a 9-pin serial port connector, refer to Table A-1 to connect the modem cable properly.

| Table A-1. 9-pin serial port connector modem signals |  |
|---|---|---|---|
| **PC connector** | **Modem connector** | **Signal name** |  |
| 1 | 8 | Carrier Detect (CD) |  |
| 2 | 3 | Receive Data (RD) |  |
| 3 | 2 | Transmit Data (TD) |  |
| 4 | 20 | Data Terminal Ready (DTR) |  |
| 5 | 7 | Signal Ground (SG) |  |
| 6 | 6 | Data Set Ready (DSR) |  |
| 7 | 4 | Request To Send (RTS) |  |
| 8 | 5 | Clear To Send (CTS) |  |
| 9 | 22 | Ring Indicator (RI)—optional |  |
Crosstalk can perform communications tasks, such as file transfers, between two computers whose serial ports are connected by cables, without using a modem. This feature is particularly useful when one computer has a 3.5" drive and the other has a 5.25" drive.

To connect the two systems, the cable between the computers must be configured correctly. The serial port on all computers is either a DCE port or a DTE port, depending on the type of device the computer is supporting. Most PC serial ports are configured as DTE, but check your PC documentation to verify this.

If you are connecting two computers with different types of serial ports, such as a DCE port to a DTE port, you must use a straight, unmodified cable, such as a ribbon cable.

If you are connecting two computers with the same type of serial port, you must use either a null modem (also called a modem eliminator), a breakout box, or a special cable. These devices connect the TD signal on one computer to the RD signal on the other computer.

Tables A-2, A-3, and A-4 provide examples of a DTE-to-DTE connection using various types of serial port connectors.

<table>
<thead>
<tr>
<th>Computer A Modem signal</th>
<th>Pin number</th>
<th>Computer B Modem signal</th>
<th>Pin number</th>
</tr>
</thead>
<tbody>
<tr>
<td>TD</td>
<td>2</td>
<td>RD</td>
<td>3</td>
</tr>
<tr>
<td>RD</td>
<td>3</td>
<td>TD</td>
<td>2</td>
</tr>
<tr>
<td>SG</td>
<td>7</td>
<td>SG</td>
<td>7</td>
</tr>
</tbody>
</table>
Connecting two systems directly (without a modem)

Table A-3. DTE-to-DTE connection using 25-pin and 9-pin serial ports

<table>
<thead>
<tr>
<th>Modem signal</th>
<th>Pin number</th>
<th>Modem signal</th>
<th>Pin number</th>
</tr>
</thead>
<tbody>
<tr>
<td>TD</td>
<td>2</td>
<td>RD</td>
<td>2</td>
</tr>
<tr>
<td>RD</td>
<td>3</td>
<td>TD</td>
<td>3</td>
</tr>
<tr>
<td>SG</td>
<td>7</td>
<td>SG</td>
<td>5</td>
</tr>
</tbody>
</table>

Table A-4. DTE-to-DTE connection using 9-pin to 9-pin serial ports

<table>
<thead>
<tr>
<th>Modem signal</th>
<th>Pin number</th>
<th>Modem signal</th>
<th>Pin number</th>
</tr>
</thead>
<tbody>
<tr>
<td>TD</td>
<td>3</td>
<td>RD</td>
<td>2</td>
</tr>
<tr>
<td>RD</td>
<td>2</td>
<td>TD</td>
<td>3</td>
</tr>
<tr>
<td>SG</td>
<td>5</td>
<td>SG</td>
<td>5</td>
</tr>
</tbody>
</table>

Note: When connecting two computers directly, you need only the three pins shown in Tables A-2, A-3, and A-4.

Testing the connection

After you have connected the two computers with the appropriate cable, test the connection to make sure the systems are communicating. Both systems must be configured for a local connection and must be using the same communications parameters, especially the speed, data bits, parity, and stop bit settings.

To test the connection, set up one computer as the calling system and the other as the answering system, as explained in Chapter 3, "Running a Communications Session."
Connecting two systems directly (without a modem)

Now start typing on the answering system. If what you're typing appears on both screens, the systems are communicating properly. If not, you may have a problem with either your parameter settings or the cable connection. Check the parameter settings and the cable, and try again.

Once the two systems are communicating correctly, you can perform communications tasks, such as file transfers.

Customizing your modem settings

You can customize your modem settings by specifying unique characters that perform specific functions. Table A-5 describes these special characters.

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>^M</td>
<td>This sequence indicates a carriage return (ASCII 13). This is the default command terminator for most modems.</td>
</tr>
<tr>
<td>~</td>
<td>The tilde symbol causes Crosstalk to pause for one second before sending the next character. This is useful when you need to slow the transmission of a long string of modem commands.</td>
</tr>
<tr>
<td>^</td>
<td>The caret symbol means the next character in the string is a control character.</td>
</tr>
</tbody>
</table>

continued
### Table A-5. Special characters for customizing your modem settings (cont.)

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>*</code></td>
<td>The left quotation mark before any one of the characters listed in this section prevents Crosstalk from interpreting the character and allows the character to be transmitted to the host literally.</td>
</tr>
<tr>
<td></td>
<td>The comma is often inserted as part of a phone number. It is sent directly to the modem during a dialing string. It is interpreted by most modems as a command to pause for 2 seconds before continuing. This is useful when the modem has to pause to access a line on a PBX system.</td>
</tr>
<tr>
<td><code>#</code></td>
<td>The asterisk can be used as a wild-card character to represent any text or value. Use this character only in the Connect Reliable edit box of the Custom Modem Settings dialog box.</td>
</tr>
</tbody>
</table>

**Note:** Modems that are not Hayes-compatible may not support the comma character. Check your modem documentation to see if your modem uses this character.

To specify the special modem string characters described in Table A-5, follow these steps:

1. With a session profile open, choose Settings from the menu bar and then choose Connection. The Connection Settings dialog box is displayed.

2. Choose either Local Modem, NASI-Advanced, or INT14 from the connection list box.

3. Click on the Modem icon along the left side of the dialog box. A list of modems supported by Crosstalk is displayed. This dialog box also displays the currently selected modems for the available ports or network services.

4. Choose the Custom pushbutton on the right side of the dialog box. The Custom Modem Settings dialog box, shown in Figure A-1, is displayed.
Customizing your modem settings

<table>
<thead>
<tr>
<th>Custom Modem Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save new settings as:</td>
</tr>
<tr>
<td>Initial modem settings: MultiTech MultiModem V32</td>
</tr>
<tr>
<td>Dial Prefix: ATDT</td>
</tr>
<tr>
<td>Dial Suffix:</td>
</tr>
<tr>
<td>Answer Setup: [&quot;ATS0=1&quot;]</td>
</tr>
<tr>
<td>Initialization: [&quot;AT $BA0 $SB19200 &amp;E1 &amp;E4 &amp;E13 &amp;E1&quot;&quot;]</td>
</tr>
<tr>
<td>Disconnect: [&quot;+++&quot;&quot;ATHI&quot;&quot;]</td>
</tr>
<tr>
<td>Connect Speed: [&quot;CONNECT 21&quot;&quot;]</td>
</tr>
<tr>
<td>Connect Reliable: [&quot;CONNECT 2 RELIA&quot;&quot;]</td>
</tr>
<tr>
<td>No Carrier: [&quot;NO CARRIER&quot;&quot;]</td>
</tr>
<tr>
<td>Busy: [&quot;BUSY&quot;&quot;]</td>
</tr>
<tr>
<td>Connect: [&quot;CONNECT&quot;&quot;]</td>
</tr>
<tr>
<td>Command OK: [&quot;OK&quot;&quot;]</td>
</tr>
<tr>
<td>Command Error: [&quot;ERROR&quot;&quot;]</td>
</tr>
<tr>
<td>Dial Tone: [&quot;DIAL TONE&quot;&quot;]</td>
</tr>
<tr>
<td>No Dial Tone: [&quot;NO DIALTONE&quot;&quot;]</td>
</tr>
<tr>
<td>Ringing: [&quot;RING&quot;&quot;]</td>
</tr>
</tbody>
</table>

Figure A-1. Custom Modem Settings dialog box

**Note:** The settings displayed in Figure A-1 vary depending on the modem you've selected from the Initial Modem Settings list box.

**5** In the Save New Settings As edit box, enter the name of the profile that you want to save the new settings to.

**6** Modify the other settings as necessary. See the on-line help for details.

**7** Choose OK. Your custom settings are saved in the new profile you just specified. This file now appears in the Modem Profiles list box of the Connection Settings dialog box.

Crosstalk maintains a large database of modem profiles that are updated on a regular basis. You can download these profiles to your PC by connecting to the DCA Connection bulletin board or the Crosstalk Forum on CompuServe. (See Chapter 2, "Getting Started with Crosstalk," for details about these services.) Note that your custom modem settings are saved to a file name that you specify; therefore, you
do not have to worry about overwriting this file when downloading modem profiles from the data base.

---

**Network communications (INT14 and NASI)**

This section provides information on network communications support in Crosstalk. If your PC is connected to a LAN and you want to communicate through the network's ACS to a shared modem pool, you need to use either INT14 Redirector or NASI services. The following paragraphs explain how.

**INT14 support**

You can use Crosstalk's INT14 support on networks that require communications through a redirected BIOS interrupt instead of the Windows communications driver. When you select an INT14 port, communications are re-routed to the network device associated with that port.

To use INT14, your INT14 driver must be loaded into memory before starting Windows and after the network software is loaded. Check the Crosstalk README.TXT file for a list of tested INT14 drivers and version numbers.

To use INT14, follow these steps:

1. With a session profile open, choose Settings from the menu bar and then choose Connection. The Connection Settings dialog box is displayed.

2. Choose INT14 Redirector from the Connection list box. The default dialing settings are displayed.
   
   When you choose this option, Crosstalk will access the network's communications resources through the INT14 driver.

3. Modify the dialing settings as needed.

4. Choose the Connection icon from the left side of the dialog box. The default communications parameters are displayed, as shown in Figure A-2.
Choose one of the communications ports from the INT14 Redirector Port list box.

6 Modify the other communications settings as needed:
   • To change the settings of the modem associated with the simulated communications port on the network (referred to as the redirected port), choose the Modem icon from the left side of the dialog box.
   • To change the access numbers for local and long distance calls, choose the Workstation icon from the left side of the dialog box.

7 Choose OK.
NASI support

NASI support allows Crosstalk to communicate through an ACS to a modem pool. You can use NASI support with the following interface programs:

- Network Product Corporation's Network Communications Services Interface (NCSI)
- Telebit Asynchronous Communications Server

To use NASI, NCSI, and ACS, you must run the interface program after loading your network software and before starting Windows. (Crosstalk passes data to the interface program, which then directs the data to the appropriate network device.)

Refer to the README.TXT file for information on the latest NASI software versions tested with Crosstalk. The README.TXT file also includes a list of tested NASI/NCSI drivers and version numbers.

NASI support is available in two modes: basic and advanced. The following paragraphs describe these modes.

Basic mode

Basic mode does not support autodial; therefore, you must either enter server commands from your keyboard or create a script that automates this process for you.

The following instructions describe how to specify NASI support in basic mode. These instructions assume you have loaded the NASI software into your PC's memory before starting Windows.

To choose NASI support in basic mode, follow these steps:

1. With a session profile open, choose Connection from the Settings pull-down. The Connection Settings dialog box is displayed.

2. Choose NASI–Basic from the Connection list box. The default dialing settings are displayed. Choosing NASI–Basic causes Crosstalk to access the network's communications resources and use the communications parameters (speed, data bits, and so on) defined by the communications server.

3. To modify the communications parameters, choose the Connection icon from the left side of the dialog box. The default communications parameters are displayed, as shown in Figure A-3.
To change the access numbers for local and long distance calls, choose the Workstation icon from the left side of the dialog box.

5 Choose OK.

**Advanced mode**

Advanced mode offers autodial support and lets Crosstalk use all the parameters from the logical port table. The logical port table tells the software which set of network circuits to use. NASI communications can target only one network circuit per communications session.

The following instructions describe how to specify NASI support in advanced mode. These instructions assume you've loaded the NASI software into your PC memory before starting Windows.

To use NASI support in advanced mode, follow these steps:

1 With a session profile open, choose Settings from the menu bar and then choose Connection. The Connection Settings dialog box is displayed.

2 Choose NASI–Advanced from the Connection list box. The default dialing settings are displayed.
3 Modify the dialing settings as needed.

4 To modify the communications parameters, choose the Connection icon from the left side of the dialog box. The default communications parameters are displayed, as shown in Figure A-4.

![Connection Settings](image)

**Figure A-4.** Connection Settings dialog box specifying NASI-Advanced support

5 Select the Use Network Settings check box if you want to use the network communications server's settings. When you do this, most of the other communications parameters are grayed.

If you want the software to use the communications settings you've defined instead of the network settings, do not select the Use Network Settings check box. This causes the software to override the network settings and to use the communications parameters you specified.

6 Choose the NASI Services icon from the left side of the dialog box. A list of the available services on the network is displayed, as shown in Figure A-5.
Figure A-5. Connection Settings dialog box listing the available services on the network

7 If you want the software to use the first modem available on the network, or if it doesn't matter which modem the software uses to connect to the host, choose a general category of modems from the General Name list box. When you do this, the specific modems associated with this category appear in the Specific Name list box.

**Note:** Every modem on a network is associated with a specific service. (That specific service name appears in the Specific Name list box.) And different types of modems can be grouped together under one general name. This general name appears in the General Name list box.

8 If you want the software to use a specific modem on the network to connect to the host, choose the modem from the list of modems in the Specific Name list box. The modem you selected appears in the Service Name edit box.

9 Choose OK.
Using serial ports

The serial ports on the PC are treated as resources in Windows; therefore Crosstalk must share them with other applications. Once Crosstalk has gained control of a serial port, it can start sending commands to the modem to connect to the host. When Crosstalk receives the CD signal from the modem, the modem has connected successfully to the host.

Note: Your modem must be configured properly; otherwise, Crosstalk may misinterpret the connection status. If you have trouble, select the Scan for Disconnect check box in the Custom Settings dialog box. For information on how to access this dialog box, see "Customizing Your Modem," earlier in this chapter.

When you disconnect a communications session, Crosstalk returns control of the serial port to Windows. The port can now be used by other applications.

Note: If your modem speed is over 9600 baud, some data may be lost if you do not have a buffered serial port, such as UART NS16550A.
Using the COM3 or COM4 port

To use communications ports 3 and 4, you must configure settings such as the port address and the IRQ number used by the communications ports on your PC. Follow these steps:

1. From the Program Manager window in Windows, activate the Main group window.
2. Double-click on the Control Panel icon. The Control Panel window is displayed.
3. Double-click on the Ports icon. The Ports dialog box is displayed.
4. Choose COM3 or COM4 and then choose the Settings push-button. The Settings for COM3 (or COM4) dialog box is displayed. Modify these settings as needed. See the on-line help for details.
5. To specify advanced settings for the communications port, choose the Advanced pushbutton. The Advanced Settings for COM3 (or COM4) dialog box is displayed. Change the port address and IRQ numbers as needed. See the on-line help for details.
6. Choose OK to return to the Settings for COM3 (or COM4) dialog box.
7. Choose OK again to return to the Ports dialog box.
8. Choose Close to return to the Control Panel window.
Overview
ADD5 Viewpoint+ emulator
ANSI PC emulator
DEC emulators
FTTERM emulator
Hazeltine 1500 emulator
Hewlett-Packard 700/94 and 2392A emulators
IBM 3101 emulator
PC TERM emulator
Televideo 910, 920, and 925 emulators
VIDTEX emulator
WYSE 50+ and 60 emulators
Overview

Crosstalk lets your PC connect to the host and emulate a variety of host terminals. This appendix describes special considerations you should be aware of when using the terminal emulators delivered with Crosstalk.

Changing fonts

You can change your character fonts using the Terminal Settings–Fonts dialog box. When you change fonts, Crosstalk changes the terminal screen characters (including those in the review buffer) to the new font.

The fonts available to Crosstalk depend on your PC configuration. You can use only the fonts that are appropriate for the type of terminal your PC is emulating. Most of the terminal emulators that come with Crosstalk can use any type of font. However, some emulators require specific fonts, as explained in the following sections.

ADDS Viewpoint+ emulator

The ADDS Viewpoint+ emulator can use any type of font available to Crosstalk; no specific font is required.

ADDS Viewpoint+ terminals provide three emulation support levels: A1, A2, and A3. Crosstalk supports A2 level, which includes the A1 support level but not A3.

If you are using a 101-key keyboard that has arrow keys, leave NUMLOCK on. This allows you to use the numeric keypad to send numbers, and the arrow keys to control cursor movement.
ANSI PC emulator

The ANSI PC emulator is used most often to connect to PC-based bulletin boards. There are many types of bulletin boards and each one displays information on the screen differently. Fortunately, most bulletin boards use the ANSI standard for positioning the cursor, controlling character color, and other display attributes.

If you are connecting to a bulletin board that supports ANSI color graphics, use the Terminal Settings dialog box to make any changes to the screen display. To access this dialog box from the session window, follow these steps:

1. Choose Settings from the menu bar and then choose Terminal. The Terminal Settings dialog box is displayed.

2. If you want to change the color of the characters on your terminal screen, choose the Colors icon from the left side of the dialog box.

3. If you want to change the character fonts, choose the Font icon from the left side of the dialog box. The ANSI PC emulator requires the ANSI PC font; you cannot use any other type of font.

4. If you want to change other emulation settings, such as the cursor shape and screen size, choose the Terminal icon from the left side of the dialog box.

5. Choose OK to confirm your changes.

Using the keyboard

The keyboard layout of the ANSI PC terminal is similar to the DEC VT102 terminal. If you are using a 101-key keyboard that has arrow keys, leave NUMLOCK on. This allows you to use the numeric keypad to send numbers, and the arrow keys to control cursor movement.

Adjusting other emulator settings

You can change other settings in the ANSI PC emulator, such as the answerback string and the transmit control sequences settings. The following instructions explain how.

To modify the ANSI PC emulator settings, follow these steps:
1 With a session profile open, choose Settings from the menu bar and then choose Terminal. The Terminal Settings dialog box is displayed.

2 Click on the Misc (miscellaneous) icon from the left side of the dialog box. The default settings are displayed.

3 Modify these settings as needed.

   **Note:** Some bulletin boards require you to select the BBS Client Mode check box. This allows you to press CTRL-L to clear your terminal screen and move the cursor to the home position.

4 Choose OK.

---

**DEC emulators**

Crosstalk allows your PC to function like the following DEC terminals:

- VT52
- VT100
- VT102
- VT220
- VT320

Of all the emulators Crosstalk provides, the VT102 emulator is the most commonly used. The VT102 emulator is based on the older VT100 emulator. Therefore, the VT102 emulator will also work on systems that require VT100 emulation.

Crosstalk's VT102 emulator is also compatible with ANSI programming standards, so it supports most VT102 escape sequences. The VT102 emulator also includes the following features:

- Double-high and double-wide characters
- 80-column or 132-column display
The VT320 and VT220 emulators are based on the VT102 emulator. The VT320 emulator displays a host-activated status line at the bottom of your screen. The VT320 emulator also provides all the features supported by the other DEC terminal emulators, such as host-controlled printing.

Changing fonts

Although you can change the fonts, Crosstalk defaults to the DECVT font. If you change the default font, incorrect characters may be displayed.

The DEC terminal emulators do not support the following features:

- Blinking characters
- Character sets that can be downloaded from the host

Using the keyboard

For the DEC terminal emulators, the keyboards can be in either application mode or numeric mode. If NUMLOCK is off, you can use the keys on the numeric keypad to move your cursor. If NUMLOCK is on, the numeric keypad transmits the numbers or characters on the keycap to the host, with the exception of the plus (+) key, which sends the \^ M control sequence to the host, and the asterisk (*) key, which sends a comma. If you leave NUMLOCK on, you can use the arrow keys to move your cursor.

Host-controlled printing

All of the DEC terminal emulators support remote printing from a host application. When the host receives the remote print sequence, Crosstalk automatically sends the data directly to the Windows printer spooler, which in turn sends the data to the printer.

The following instructions explain how to change your printer settings. These instructions assume you have a session profile open already.

To modify your printer settings, follow these steps:

1. Choose Settings from the menu bar and then choose Terminal. The Terminal Settings dialog box is displayed.
DEC emulators

2 Click on the Printer icon along the left side of the dialog box. The current printer settings are displayed.

3 Modify the printer settings as needed.

Note: If you want to print raw data, including printer escape sequences sent to the host, be sure to choose Bypass Printer Driver; otherwise, printer escape sequences are not printed.

4 Choose OK when you have finished your modifications.

Character translation

The character translation feature provides special filtering of incoming and outgoing characters when using the VT102, VT220, and VT320 terminal emulators. Characters are translated from English to the language (or character set) you select in the Terminal Settings dialog box. To access this dialog box from a session window, complete the following steps:

1 Choose Settings from the menu bar and then choose Terminal. The Terminal Settings dialog box is displayed.

2 Click on the Character Set icon along the left side of the dialog box. A list of supported languages is displayed.

3 Specify the language you want to use.

4 Choose OK.

In addition to English (US), Crosstalk can translate the following languages:

Dutch
English (UK)
Finnish
French/Belgian/Flemish
French Canadian
German
Italian
Norwegian/Danish
Portuguese
Spanish
Swedish
Swiss
You can change other settings in the emulator, such as the answerback string and the transmit control sequences settings. Follow these steps:

1 With a session profile open, choose Settings from the menu bar and then choose Terminal. The Terminal Settings dialog box is displayed.

2 Click on the Misc (miscellaneous) icon along the left side of the dialog box. The current settings are displayed.

3 Modify the settings on your screen as needed.

4 Choose OK.

The FTTERM emulator supports only the IBM 3708, 7171, 9370, and 3174 protocol converters.

If you are using a 101-key keyboard that has arrow keys, leave NUMLOCK on. This allows you to use the numeric keypad to send numbers, and the arrow keys to control cursor movement.
Hazeltine 1500 emulator

If you are using a 101-key keyboard that has arrow keys, leave NUMLOCK on. This allows you to use the numeric keypad to send numbers, and the arrow keys to control cursor movement.

Hewlett-Packard 700/94 and 2392A emulators

With Crosstalk, your PC can emulate the HP 700/94 and 2392A terminals. The Hewlett-Packard emulators must use the DECVT font.

The HP terminal emulators do not support the following features:

- Blinking characters
- Local Format mode

Using the keyboard

If you are using a 101-key keyboard that has arrow keys, leave NUMLOCK on. This allows you to use the numeric keypad to send numbers, and the arrow keys to control cursor movement.
IBM 3101 emulator

The IBM 3101 emulator is most commonly used with larger IBM computers, not PCs. The 3101 emulator works in character mode only.

Using the keyboard

If you are using a 101-key keyboard that has arrow keys, leave NUMLOCK on. This allows you to use the numeric keypad to send numbers, and the arrow keys to control cursor movement.

PC TERM emulator

The PC TERM emulator requires the ANSI PC font; you cannot use any other type of font.

All the keystrokes you enter during a communications session send IBM scan codes to the host. Scan codes are numbers that identify which keys you are pressing. These numbers are sent to the host and the host determines which keys were pressed based on the scan code numbers.

Using the keyboard

If you are using a 101-key keyboard that has arrow keys, leave NUMLOCK on. This allows you to use the numeric keypad to send numbers, and the arrow keys to control cursor movement.
Televideo 910, 920, and 925 emulators

If you are using a 101-key keyboard that has arrow keys, leave NUMLOCK on. This allows you to use the numeric keypad to send numbers, and the arrow keys to control cursor movement.

VIDTEX emulator

VIDTEX is a type of terminal used especially for connecting to CompuServe information service. To use the VIDTEX emulator with CompuServe, you must change your CompuServe settings. Follow these steps:

1. With a session profile open, choose Settings from the menu bar and then choose Terminal. The Terminal Settings dialog box is displayed.
2. Choose VIDTEX from the Terminal list box.
3. Modify the emulation settings as needed by clicking on the appropriate icon along the left side of the dialog box.
4. Choose OK.

Using the keyboard

If you are using a 101-key keyboard that has arrow keys, leave NUMLOCK on. This allows you to use the numeric keypad to send numbers, and the arrow keys to control cursor movement.
WYSE 50+ and 60 emulators

If you are using a 101-key keyboard that has arrow keys, leave NUMLOCK on. This allows you to use the numeric keypad to send numbers, and the arrow keys to control cursor movement.
Converting files

The file conversion program (XTALKCNV.EXE) lets you translate files created with previous versions of Crosstalk for Windows, Crosstalk XVI, Crosstalk Mark 4, or PROCOMM PLUS to a format that is compatible with this version of Crosstalk. The following sections explain how.

From Crosstalk XVI

If you have command files (*.XTK) created with Crosstalk XVI, the conversion program translates these files to Crosstalk for Windows 2.0 session profiles (*.XWP). When you open the old file, the conversion program runs automatically and prompts you to convert the file to the new format. Once you've converted the file, you can use it as if it had been created with this version of Crosstalk.

From Crosstalk for Windows 1.x

The conversion program translates dialing directory entries from previous versions of Crosstalk for Windows to session profiles and uses them with this version of Crosstalk for Windows. When you open the old dialing directory entry using this version of Crosstalk, the conversion program runs automatically and translates the file to the new format. Once you close the file, you are prompted to save the file in the new format. Note that if you choose Yes, the conversion program overwrites the old file.

The conversion program does not translate script files created with previous version of Crosstalk for Windows because these files are compatible with this version of the software.

From Crosstalk Mark 4

If you have a dialing directory entry created with Crosstalk Mark 4, you can convert it to a session profile and use it with this version of Crosstalk. To do this, start Crosstalk Mark 4 and run the X4TOWIN2.XTS script file that comes with Crosstalk for Windows 2.0. For instructions on running scripts in Crosstalk Mark 4, see the Crosstalk Mark 4 User’s Guide.
If you have dialing directory entries created with PROCOMM PLUS (*.DIR), you can convert them to Crosstalk for Windows session profiles (*.XWP). When you open the PROCOMM PLUS dialing directory entry using this version of Crosstalk, the conversion program runs automatically and translates the file to the Crosstalk format. Once you close the file, you are prompted to save the file under the new format.

The conversion program translates the dialing directory entries from only the following versions of PROCOMM: PROCOMM 1.4.x, PROCOMM PLUS 1.x, and PROCOMM PLUS 2.x. This program cannot translate script files created with PROCOMM PLUS to Crosstalk scripts (*.XWS).
Choosing language support

Only the IBM PC and DEC terminal emulators support international character sets. These emulators can translate the following languages:

Dutch
English (UK)
English (US)
Finnish
French/Belgian/Flemish
French Canadian
German
Italian
Norwegian/Danish
Portuguese
Spanish
Swedish
Swiss

The DEC terminal emulators also support the DEC supplemental and ISO Latin-1 character sets. Crosstalk displays these special characters as clearly as possible, based on the character set and the video adapter your system uses.

The following instructions explain how to specify the language support you need. Follow these steps:

1. With a session profile open, choose Settings from the menu bar and then choose Terminal. The Terminal Settings dialog box is displayed.

2. Click on the Character Set icon from the left side of the dialog box. A list of supported languages is displayed.

3. Specify the language you want to use.

4. Choose OK.
Receiving technical support

If you encounter a problem installing or using Crosstalk and cannot find the answer in the documentation, you can call DCA Technical Support for help. Assistance is provided only to registered users. To register for technical support, complete the product registration card, which comes with the software, and mail it to the following address:

DCA, Inc.
1000 Alderman Drive
Alpharetta, GA 30202-4199

Before contacting DCA Technical Support, make sure to you know the following information:

- Your Crosstalk serial number. This number is on the master diskette.
- The version number of Crosstalk that you are using.
- The contents of your systems files (AUTOEXEC.BAT, CONFIG.SYS, WIN.INI, SYSTEM.INI, and XTALK.INI).
- If possible, call the customer support department from a telephone that is near the PC you are using, so you can look at the software while working through the problem with DCA Technical Support.

You can call DCA Technical Support at (404) 442-3210. Representatives are available Monday through Thursday, from 8:30 A.M. to 8 P.M., EST; and Friday from 8 A.M. to 8 P.M, EST. You can also contact DCA Technical Support by FAX at (404) 442-4358.

The telephone system at DCA Technical Support automatically routes calls to the available representatives. Be sure to stay on the line so the next available representative can help you.
In addition to telephone support, DCA maintains the DCA Connection bulletin board and the Crosstalk Forum on CompuServe. These services provide the latest support files for all products as well as sample scripts and technical assistance from DCA engineers and other users.

The DCA Connection and Crosstalk Forum can be accessed 24 hours a day, seven days a week. For instructions on how to connect to these services, see Chapter 2, "Getting Started with Crosstalk."

If you have any questions or concerns about disk updates, software versions, or compatibility issues, contact DCA Technical Support.
Index

A
ACS (asynchronous communications server), A-9
ADDS Viewpoint+ emulator, 3-13, B-2
ANSI PC emulator, 3-13, B-3
answering system, specifying, 3-34
Answer mode, 3-34
Answer utility
description of, 3-34
running, 3-35
stopping, 3-37
variables, 3-36
ANSWER.XWP session profile, 3-34
ANSWER.XWS script file, 3-36
ASCII screen data
capturing, 3-32
taking snapshots, 3-31
ASCII text files, uploading, 3-30
asynchronous communications server (ACS), A-9
AT&T Mail, connecting to, 2-6
ATT.XWP session profile, 2-6
ATT.XWQ QuickPad profile, 6-2
AUTOEXEC.BAT file, 2-4, E-2

B
bulletin boards, 2-7. See also information services
connecting to, 2-7
DCA Connection, 2-7

C
cables, modem, A-2
Capture feature
definition of, 3-32
difference from Snapshot feature, 3-32
capturing screens, 3-32
Carrier Detect, A-3, A-15
CASL, definition of, 5-6
CD modem signal, A-3, A-15
character set, choosing, D-2
character translation, B-6
communications ports (COM3 and COM4), A-16
communications session
basics of, 3-2
connecting, 3-21
disconnecting, 2-11, 3-33
establishing, 3-21
compiling a script, 5-10
description of, 5-10
from a Script Editor window, 5-12
from a session window, 5-11
CompuServe, connecting to, 2-9
CompuServe B+, 3-16, 1-2
COM3, using, A-16
COM4, using, A-16
configuration program, 2-4
CONFIG.SYS file, 2-4, E-2
CONFIG.XWS script file, 2-4
connection settings
changing, 3-10
special considerations, A-2
connection types, 3-10
choosing, 3-10
direct connection, 3-11, A-4
INT14 Redirector, description of, A-9
INT14 Redirector support, specifying, A-9
modem connection, 3-12
NASI, description of, A-11
NASI-Advanced support, specifying, A-12
NASI-Basic support, specifying, A-11
converting files, C-2
from Crosstalk Mark 4, C-2
from Crosstalk for Windows 1.x, C-2
from Crosstalk XVI, C-2
from Procomm Plus, C-3
creating scripts
with Learn, 5-2
with the Script Editor, 5-6
creating custom session profiles using NEWCALL, 2-10
using Settings pull-down options, 3-10
Crosstalk
description of, 1-2
exiting, 2-12
features, 1-2
file transfer protocol, 3-16
Crosstalk Communicator, 3-16
Crosstalk Forum, 2-9, E-2
Crosstalk Mark 4, 3-16, C-2
Crosstalk Remote2, 3-16
Crosstalk for Windows 1.x, C-2
Crosstalk XVI, 3-16, C-2
CSERVE.XWP session profile
description of, 2-6
using, 2-9
CSERVE.XWQ QuickPad profile, 6-2
customer support, E-2
customizing a screen display, 3-15
custom modem settings, specifying, A-7
custom session profiles, creating, 3-10

D
DART, 3-16
Data Communications
Equipment (DCE) port, A-4
Data Terminal Equipment (DTE) port, A-4
DCABBS.XWP session profile
description of, 2-6
using, 2-8
DCABBS.XWQ QuickPad profile, 6-2
DCA Connection bulletin board, 2-7, E-2
DCA Customer Support, E-2
DCA support services (on-line), E-2
DCE (Data Communications Equipment) port, A-4
DEC emulators
VT52, 3-13, B-4
VT100, 3-13, B-4
VT102, 3-13, B-4
VT220, 3-13, B-4
VT320, 3-13, B-4
DECVT font, B-5, B-8
defined profiles
definition of, 2-5, 3-3
QuickPad, 6-2
defined profiles (cont.)
  session, 2-5, 3-3
Delphi, connecting to, 2-6
DELPHI.XWP session profile, 2-6
DELPHI.XWQ QuickPad profile, 6-2
dialing the host, 3-21
direct connection, establishing, 3-11
disconnecting a communications session, 2-11, 3-33
disk updating, E-3
Dow Jones, connecting to, 2-6
DOWJONES.XWP session profile, 2-6
DOWJONES.XWQ QuickPad profile, 6-3
DTE (Data Terminal Equipment) port, A-4

emulators (cont.)
  Lear-Siegler ADM3a, 3-13
  PC TERM, 3-13, B-9
  Televideo 910, 3-13, B-10
  Televideo 920, 3-13, B-10
  Televideo 925, 3-13, B-10
  TTY (Teletype), 3-13
  VIDTEX, 3-13, B-10
  WYSE 50+, 3-13, B-11
  WYSE 60, 3-13, B-11
ending a communications session, 2-11, 3-33
executable file, 5-10
exiting
  Crosstalk, 2-12
  Keyboard Editor, 7-13
  QuickPad Editor, 6-21
  Script Editor, 5-15
  Text Editor, 4-15
external scripts, assigning, 6-19, 7-10

E
embedded scripts, assigning, 6-19, 7-10
emulation. See terminal emulation
emulators
  ADDS Viewpoint+, 3-13, B-2
  ANSI PC, 3-13, B-3
  choosing, 3-13
  DEC VT 52, 3-13, B-4
  DEC VT 100, 3-13, B-4
  DEC VT 102, 3-13, B-4
  DEC VT 220, 3-13, B-4
  DEC VT 320, 3-13, B-4
  FTTERM, 3-13, B-7
  Hazeltine 1500, 3-13, B-8
  Hewlett-Packard 700/94, 3-13, B-8
  Hewlett-Packard 2392A, 3-13, B-8
  IBM 3101, 3-13, B-9

F
file conversion, C-2
file transfers, 3-23
  canceling, 3-30
  description of, 3-23
  monitoring, 3-28
  protocols, 1-2, 3-16
  receiving, 3-25
  sending, 3-24
  settings, changing, 3-16
  status window, 3-29
  without using a protocol, 3-30
file transfer protocols
  choosing, 3-16
  CompuServe B+, 3-16, 3-23
  Crosstalk, 3-16, 3-25, 3-23
  DART, 3-16, 3-23
  IND$FILE, 3-16, 3-23
  Kermit, 3-16, 3-24, 3-27
file transfer protocols (cont.)
- XMODEM, 3-16, 3-24
- YMODEM, 3-16, 3-24
- YMODEM Batch, 3-24
- ZMODEM, 3-16, 3-24

fonts
- ANSI PC emulator, B-3, B-9
- changing, B-2
- DEC emulators, changing, B-5
- DECVT, B-5, B-8
- description of, B-2
- FTTERM emulator, 3-13, B-7

G
- GENie, connecting to, 2-6
- GENIE.XWP session profile, 2-6
- GENIE.XWQ QuickPad profile, 6-3
- grid, using the QuickPad, 6-16

H
- hardware requirements, 1-5
- Hazeltine 1500 emulator, 3-13, B-8
- help, contents, 1-6
- help, on-line, 1-6
- Help pull-down options, 1-6
  - About, 1-7
  - Help contents, 1-6
  - Help for..., 1-6
  - Help on Help, 1-6
- Hewlett-Packard emulators, 3-13, B-8
- host computer
  - configuring your PC as, 3-34
  - connecting to, 3-21
  - definition of, 1-2
  - disconnecting from, 2-11, 3-33
- host computer (cont.)
  - setting up your PC as a, 3-34
- host-controlled printing, B-5
- host menu options (table), 3-35

I
- IBM 3101 emulator, 3-13, B-9
- icons
  - file, 4-6
  - QuickBar, 3-5, 4-4, 5-9, 6-6, 7-5
- IND$FILE, 3-16, 3-23
- information services. See also bulletin boards
  - AT&T Mail, 2-6
  - Delphi, 2-6
  - Dow Jones, 2-6
  - GENie, 2-6
  - LEXIS, 2-6
  - NEXIS, 2-6
  - MCI Mail, 2-6
  - NewsNet, 2-6
  - Official Airline Guide (OAG), 2-6
- installation
  - configuration program, 2-4
  - planning, 2-2
  - Setup program, 2-3
  - steps, 2-3
- international character set,
  - choosing, D-2
- IRQ settings, A-16

K
- Kermit
  - protocol, 3-16, 3-24, 3-27
  - server, 3-27
  - transferring files with, 3-27
- Keyboard Editor
  - description of, 7-2
  - exiting, 7-13
Keyboard Editor window
  menu bar, 7-3
  overview, 7-2
QuickBar, 7-4
status bar, 7-5
keyboard profiles
  default, 7-7
  displaying, 7-6
  introducing, 7-2
  using it during a session, 7-12
  working, 7-6
keyboard remapping, 7-7
  assigning keystrokes to a key, 7-9
  assigning a script to a key, 7-10
  combination keys 7-7
  copying a key, 7-8
  deleting a key, 7-9
  during a session, 7-12
  modifier keys 7-7
  overview, 7-2, 7-7

L
language support, choosing, D-2
Learn facility, 5-2
  recording keystrokes, 5-3
  replaying scripts, 5-4
  saving scripts, 5-4
  starting Learn, 5-3
  stopping Learn, 5-4
  tips for using, 5-3
  using, 5-2
Lear-Siegler ADM3a emulator, 3-13
LEXIS, connecting to, 2-6
LEXIS.XWP session profile, 2-6
LEXIS.XWQ QuickPad profile, 6-3
logon script, using, 5-4

M
Mark 4, 3-16, C-2
matrix
  creating, 6-15
  definition of, 6-15
MCI Mail, connecting to, 2-6
MCI.XWP session profile, 2-6
MCI.XWQ QuickPad profile, 6-3, 6-8
MDI (multiple document interface), 1-2
Mead Data LEXIS, connecting to, 2-6
Mead Data NEXIS, connecting to, 2-6
menu bar
  Help, 1-6
  Keyboard Editor, 7-4
  QuickPad Editor, 6-5
  Script Editor, 5-8
  session, 3-4
  Text Editor, 4-3
modem
  cables, A-2
  configuration, 2-4
  connection, 3-12
  custom settings, A-6
  eliminator, A-4
  null, A-4
  signals, A-3, A-4
  special characters (table), A-6
multiple document interface (MDI), 1-2

N
NCSI (Network Communications Services Interface)
  driver, A-10
network communications
  INT14 Redirector, A-9
  NASI, A-11
  NASI-Advanced mode, A-12
  NASI-Basic mode, A-11
  
  
Network Communications Services Interface (NCSI) driver, A-10
NEWCALL, description of, 2-10
NewsNet, connecting to, 2-6
NEWSNET.XWP session profile, 2-6
NEWSNET.XWQ QuickPad profile, 6-3
NEXIS, connecting to, 2-6
9-pin serial port connector, description of, A-3
NORMAL.XWP session profile, 3-2

profiles (cont.)
keyboard, introducing, 7-2
QuickPad, introducing, 6-2
QuickPad, pre-defined, 6-2
session, overview, 2-5, 3-2
session, pre-defined, 2-5, 3-3
working, 7-6

pull-downs,
Help, 1-6
Keyboard Editor, 7-4
QuickPad Editor, 6-5
Script Editor, 5-8
Session, 3-4
Text Editor, 4-3

Q
QuickBar icons
Keyboard Editor (table), 7-5
QuickPad Editor (table), 6-6
Script Editor (table), 5-9
session (table), 3-5
Text Editor (table), 4-4
QuickHit, 3-18
QuickPad
background color, changing, 6-17
creating a new, 6-11
customizing, 6-17
definition of, 6-2
editing, 6-12
grid, using, 6-16
hiding, 6-10
labeling, 6-17
opening an existing, 6-11
pre-defined profiles, 6-2
profiles, definition of, 6-2
purpose of, 6-2
resizing, 6-15
showing a hidden, 6-10
using during a session, 6-8
window, 6-4

O
OAG.XWP session profile, 2-6
OAG.XWQ QuickPad profile, 6-3
objects. See QuickPad objects
Official Airline Guide service, connecting to, 2-6
on-line DCA services, accessing, E-2
on-line help, 1-6
opening workspace files, 2-12

P
PC TERM emulator, 3-13, B-9
ports
addresses, A-16
communication, using, A-16
serial, using, A-15
printer, configuring, 4-14
printing
host-controlled, B-5
scripts, 5-9
text files, 4-15
profiles
default, keyboard, 7-7
default, session, 3-3
QuickPad Editor
  definition of, 6-2
  exiting, 6-21
QuickPad Editor window, 6-4
  menu bar, 6-4
  QuickBar, 6-5
  status bar, 6-7
QuickPad grid, using, 6-16
QuickPad objects
  aligning, 6-16
  assigning keystrokes to, 6-18
  assigning scripts to, 6-19
  copying, 6-14
  deleting, 6-17
  description of, 6-12
  editing, 6-12
  making multiple copies, 6-15
  matrix, creating, 6-15
  moving, 6-15
  placing on a QuickPad, 6-12
  rearranging, 6-16
  resizing, 6-15
  selecting, 6-14
  spacing, 6-16
replaying a script, 5-4
review buffer, 3-22
  adjusting the size of, 3-22
  definition of, 3-22
  scrolling through, 3-22
  using, 3-22
running scripts
  from the Script Editor, 5-13
  from a session window, 5-13
  using Learn, 5-4
  using Script Editor, 5-13
S
  saving workspace files, 2-11
screen capture. See Capture feature.
screens
  capturing, 3-32
  customizing, 3-15
  snapshots, 3-31
Script Editor
  description of, 5-6
  exiting, 5-15
  using, 5-6
Script Editor window, 5-7
  menu bar, 5-7
  QuickBar, 5-8
  status bar, 5-9
scripts
  CASL, 5-6
  compiling, description of, 5-10
  creating, using Learn, 5-2
  creating, using Script Editor, 5-6, 5-10
  definition of, 5-2
  embedded, assigning, 6-19, 7-10
  executable, 5-10
  external, assigning, 6-19, 7-10
  Learn, using, 5-2
  logon, using, 5-4
Remote², 3-16
R
RD (Receive Data) modem signal, A-3, A-4
README.TXT file, 2-3
Receive Data (RD) modem signal, A-3, A-4
remapping, keyboard, 7-7
  assigning keystrokes to a key, 7-9
  assigning a script to a key, 7-10
  combination keys, 7-7
  copying a key, 7-8
  deleting a key, 7-9
  modifier keys, 7-7
  overview, 7-2, 7-7
Remote², 3-16
Crosstalk for Windows User's Guide Index-7
scripts (cont.)
  purpose of, 5-2
  recording keystrokes, 5-3
  recording with Learn, 5-3
  replaying Learn, 5-4
  running, 5-13
  saving, 5-4
  Script Editor, using, 5-6
  source, 5-10
  start recording, 5-3
  start-up, using, 5-14
  stopping a trace, 5-15
  stop recording, 5-4
  tips for using, 5-3
  tracing, 5-14
scroll buffer. See review buffer
serial port
  addresses, A-15
  connectors, description of,
    A-2
  DCE, definition of, A-4
  DTE, definition of, A-4
  9-pin connector, description
    of, A-3
  25-pin connector, description
    of, A-2
  using, A-15
server, Kermit, 3-27
session
  connecting, 3-21
  disconnecting, 2-11, 3-33
session profiles
  creating with NEWCALL, 
    2-10
  creating using Settings pull-
    down options, 3-10
  default, 3-2
  description of, 2-5, 3-2
  introducing, 2-5, 3-2
  pre-defined, 2-5, 3-3
  session settings, changing, 3-17
  session window, changing, 3-17
  menu bar, 3-3
  QuickBar, 3-5
  session window (cont.)
    status bar, 3-8
Set up program, running, 2-3
SG modem signal, A-4
snapshot feature, 3-31
  description of, 3-31
  difference from capture, 3-32
snapshots, taking, 3-31
software
  requirements, 1-5
  updating, E-3
  upgrading, E-3
  versions, E-3
source file, 5-10
start-up, Crosstalk, 2-4
  configuration program, 2-4
  from the Program Manager, 
    2-4
  using a script, 5-14
status bar
  Keyboard Editor, 7-5
  QuickPad Editor, 6-7
  Script Editor, 5-9
  session, 3-8
  Text Editor, 4-4
system settings, changing, 3-19
T
TD modem signal, A-3, A-4
technical support, E-2
Teletype (TTY) emulator, 3-13
Televideo 910 emulator, 3-13,
  B-10
Televideo 920 emulator, 3-13,
  B-10
Televideo 925 emulator, 3-13,
  B-10
terminal emulation
  overview, B-2
  settings, changing, 3-14
  translating characters, B-6
terminal emulators, 3-13
  ADDS Viewpoint+, 3-13, B-2
  ANSI PC, 3-13, B-3
  choosing, 3-13
  DEC VT 52, 3-13, B-4
  DEC VT 100, 3-13, B-4
  DEC VT 102, 3-13, B-4
  DEC VT 220, 3-13, B-4
  DEC VT 320, 3-13, B-4
  FTTERM, 3-13, B-7
  Hazeltine 1500, 3-13, B-8
  Hewlett-Packard 700/94, 3-13, B-8
  Hewlett-Packard 2392A, 3-13, B-8
  IBM 3101, 3-13, B-9
  Lear-Siegler ADM3a, 3-13
  PC TERM, 3-13, B-9
  TTY (Teletype), 3-13
  Televideo 910, 3-13, B-10
  Televideo 920, 3-13, B-10
  Televideo 925, 3-13, B-10
  VIDTEX, 3-13, B-10
  WYSE 50+, 3-13, B-11
  WYSE 60, 3-13, B-11

  text
    clearing, 4-9
    copying, 4-8
    cutting, 4-8
    duplicating, 4-9
    editing, 4-7
    finding, 4-11
    moving, 4-10
    pasting, 4-8
    replacing, 4-11, 4-12
    selecting, 4-7
  Text Editor
    description of, 4-2
    exiting, 4-15
  Text Editor window, 4-2
    menu bar, 4-3
    QuickBar, 4-3
    status bar, 4-4

  text files
    creating, 4-5
    editing, 4-7
    opening existing, 4-5
    printing, 4-15
    saving, 4-13
    uploading, 3-30

  text uploads, 3-30
  Transmit Data (TD) modem signal, A-3, A-4
  TTY emulator, 3-13
  25-pin serial port connector, description of, A-2

  U
  updating or upgrading software, E-3
  uploading files, 3-30

  V
  VIDTEX emulator, 3-13, B-10

  W
  WIN.INI file, 2-4, E-2
  Windows help, using, 1-7
  workspace files, 2-11
    definition of, 2-11
    opening, 2-12
    saving, 2-11
    using, 2-11
  writing scripts
    with CASL, 5-6
    using Learn, 5-2
    using the Script Editor, 5-6, 5-10
  WYSE 50+ emulator, 3-13, B-11
  WYSE 60 emulator, 3-13, B-11
**X**
X4TOWIN2.XTS script file, C-2
XMODEM, 3-16, 3-24–3-26
XTALKCNV.EXE file, C-2
XTALK.INI file, 2-3

**Y**
YMODEM, 3-16, 3-24
YMODEM Batch, 3-24

**Z**
ZMODEM, 3-16, 3-24